Cisco IOS Service Advertisement Framework コンフィギュレーション ガイド
Cisco IOS Service Advertisement Framework コンフィギュレーション ガイド
Cisco IOS Service Advertisement Framework コンフィギュレーション ガイド
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

Cisco IOS Service Advertisement Framework コンフィギュレーション ガイド

機能情報の検索

この章の構成

Cisco SAF の前提条件

Cisco SAF の制限事項

Cisco SAF のメリット

Cisco SAF に関する情報

Cisco SAF の概要

Cisco SAF Forwarder の概要

Cisco SAF Client の概要

Cisco SAF Client と Cisco SAF Forwarder の相互作用の概要

Cisco SAF サービス ID 番号のフォーマット

Cisco SAF とネットワークにおけるドメインの役割

Cisco SAF 仮想ルータ

Cisco SAF ネイバー関係

Cisco SAF Forwarder の設定

Cisco SAF の有効化

Cisco SAF のインターフェイス固有コマンドの設定

マルチトポロジ ネットワーク用の Cisco SAF の設定

Cisco SAF の静的ネイバー関係の設定

Cisco SAF のスタブ ルーティングの設定

Cisco SAF のルート認証の設定

ネイバー変更と警告のログの設定

Cisco SAF に使用されるリンク帯域幅の割合の設定

Cisco SAF インターフェイスのメトリック ダンプニング インターバルの設定

変更ベースのダンプニング設定

インターバル ベースのダンプニング設定

hello パケット間のインターバルとホールド タイムの調整

スプリット ホライズンの無効化

メトリック最大ホップ数の設定

Cisco SAF Client の設定

前提条件

制約事項

Cisco SAF External Client の設定

Cisco SAF 統計情報の表示

Cisco SAF 設定からの情報の削除

Cisco SAF の設定例

Cisco SAF の有効化:例

Cisco SAF インターフェイスの設定:例

Cisco SAF トポロジの設定:例

Cisco SAF スタブ ルーティングの設定:例

IP-RIP を使用した Cisco SAF の設定:例

OSPF を使用した Cisco SAF の設定:例

EIGRP を使用した Cisco SAF の設定:例

別々の LAN 上に配置された Cisco SAF Forwarder の設定:例

集中型 Cisco SAF Forwarder の設定:例

Cisco SAF Client の設定:例

ネイバー変更と警告のログの設定:例

Cisco Unified Communications Manager の Cisco SAF Client としての設定:例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

Cisco Service Advertisement Framework に関する機能情報


 

Cisco IOS Service Advertisement Framework コンフィギュレーション ガイド

Cisco Service Advertisement Framework(SAF)は、ネットワークに接続されたリソースの存在、位置、および設定をアプリケーションで検出可能にするメカニズムです。Cisco SAF を使用すれば、アプリケーションでネットワーク上のサービスをアドバタイズまたは検出することによって、ネットワーク上のサービスのタイムリーで信頼できる認識が可能になります。

サービスとは、ある Cisco SAF Client アプリケーションでアドバタイズすることによって、他の Cisco SAF Client アプリケーションで使用可能になる情報のことです。

機能情報の検索

ご使用のソフトウェア リリースで、このコンフィギュレーション ガイドに記載されたすべての機能がサポートされているとはかぎりません。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このガイドに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「Cisco Service Advertisement Framework に関する機能情報」を参照してください。

プラットフォーム、Cisco IOS OS ソフトウェア イメージ、および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

Cisco SAF の前提条件

Cisco SAF を設定する前に、このマニュアルに記載された概念を理解しておく必要があります。

別の LAN 上に配置された Cisco SAF Forwarder のネイバー関係を設定する前に、各 Cisco SAF Forwarder 間の IP ルーティングが設定されていることを確認してください。

Cisco SAF は、Cisco EIGRP ルーティングとは無関係に動作します。

Cisco SAF の制限事項

service-family ipv6 コマンドを使用する場合は、現在は存在しない IPv6 対応の SAF クライアントが必要です。

Cisco SAF のメリット

従来、ネットワーク上のサービスを特定するには、ネットワーク アプリケーションに必要なサービスのホスト名とネットワーク アドレスを設定するか、ネットワーク アプリケーションで DNS などのオーバーレイ メカニズムを使用する必要がありました。サービス アドバタイズメントをサポートする既存のプロトコルでは、リソース使用の定期的な通知が提供されます。このようなネットワーク サービスの多くは LAN ベースです。

図 1 に、従来の設定方法が必要な Cisco Unified Communications Manager ネットワークを示します。

図 1 Cisco Unified Communications Manager の従来の設定方法

Cisco SAF は、ネットワークに接続されたサービスの存在、位置、および設定をネットワーク アプリケーションで自動的に検出可能にするフレームワークを提供します。このサービスの自動検出によって、頻繁に設定を変更しなければならないダイヤル プランなどの複雑な設定を手動で入力する必要がなくなります。また、Cisco SAF を使用すれば、アプリケーションでサービスをアドバタイズしたり、検出したりすることができます。さらに、1 つの設定を作成すれば、情報が必要なすべてのデバイスにその設定を伝搬させることができます。

図 2 に、Cisco SAF を使用した Cisco Unified Communications Manager ネットワークを示します。

図 2 Cisco Unified Communications Manager を使用した Cisco SAF ネットワーク サービス検出ネットワーク

Cisco SAF Client は、Cisco SAF Forwarder と同じルータ上に設定することも、外部ルータ上に設定することもできます。

Cisco SAF に関する情報

Cisco SAF をネットワーク上に展開するには、次の概念を理解しておく必要があります。

「Cisco SAF の概要」

「Cisco SAF サービス ID 番号のフォーマット」

「Cisco SAF とネットワークにおけるドメインの役割」

「Cisco SAF 仮想ルータ」

「Cisco SAF ネイバー関係」

Cisco SAF の概要

Cisco SAF は、ネットワークに接続されたリソースの存在、位置、および設定をアプリケーションで検出可能にするフレームワークを提供します。Cisco SAF を使用すれば、アプリケーションでネットワーク上のサービスをアドバタイズまたは検出することによって、ネットワーク上のサービスのタイムリーで信頼できる認識が可能になります。サービス情報は、サービスの内容を効率的に配信してその検出を促進する特定の機能を担う Cisco SAF 共同ノードのネットワークを通して配信されます。

非 SAF ノードとは、SAF を認識しないネットワーク上のノードのことです。非 SAF ノードは、「ダーク ネット」と呼ばれており、ISP を通過するために必要です。Cisco SAF メッセージは IP ベースのため、ダーク ネットの影響を受けません。

これらの Cisco SAF 共同ネットワーク ノードは、次の 2 つの機能的役割に分類されます。

Cisco SAF Forwarder

Cisco SAF Client

Cisco SAF を設定するには、SAF Forwarder と SAF Client の両方を設定する必要があります。

Cisco SAF の柔軟性によって、1 台のエッジ ルータを必要に応じて Cisco SAF Forwarder と Cisco SAF Client のどちらかとして機能させることができます。

ここでは、次の情報を提供します。

「Cisco SAF Forwarder の概要」

「Cisco SAF Client の概要」

「Cisco SAF Client と Cisco SAF Forwarder の相互作用の概要」

Cisco SAF Forwarder の概要

Cisco SAF Forwarder は、Cisco SAF Client がアドバタイズしたサービスを受信して、そのサービスをネットワークを通して安全に配信し、他の Cisco SAF Client がそのサービスを利用できるようにします。Cisco SAF Forwarder の特徴:

サービス アドバタイズメントの信頼できる配信を保証します。

パスの冗長性に関する情報を保持します。

スケーラブルです。

ターゲットを絞ったマルチキャストおよびユニキャスト メッセージを使用することによって、ネットワーク帯域幅の使用を最小限に抑えます。

Cisco SAF Forwarder は、サービス アドバタイズメントを他の Cisco SAF Forwarder に伝搬させたり、LAN、構内ネットワーク、WAN、または ISP を通して伝搬させたりすることができます。

基本 Cisco SAF Forwarder は、Cisco SAF Client 間の関係とフレームワークを提供します。Cisco SAF Forwarder の多くは、ネットワークの端または境界に配置されます。Cisco SAF Forwarder は、サービス アドバタイズメントを受信して、そのコピーを保存してから、ネイバー SAF ノードに転送します。クライアントとフォワーダの関係は、アドバタイズメントを維持することです。クライアントがサービスを削除したり、フォワーダ ノードから切断したりした場合は、そのノードから使用できなくなったサービスに関するフレームワークが通知されます。あるフォワーダ ノードで別のフォワーダ ノードからのアドバタイズメントが受信された場合は、その全体(ヘッダーと不明瞭なデータ)のコピーが保存され、他の SAF ピアに転送されます。

有効なすべてのインターフェイスに対してサービスの動的検出を自動的に許可するように LAN 上の Cisco SAF Forwarder を設定すると同時に、他のインターフェイスがサービスを検出するのをブロックするインターフェイス(静的設定)を指定できます。

サービスの動的検出を自動的に許可するように非 SAF ノード上の Cisco SAF Forwarder を設定できます。たとえば、Cisco SAF Forwarder は共通のピア グループに属しています。Cisco SAF Forwarder のペア間の静的設定(ユニキャスト)を作成することもできます。


) サービスの動的検出を許可するには、マルチキャスト ルーティングが必要です。


Cisco SAF Client の概要

Cisco SAF Client は、サービスの製作者(ネットワークにアドバタイズする)と消費者(ネットワークにサービスを要求する)のどちらかまたはその両方です。Cisco SAF Client から Cisco SAF Forwarder に登録メッセージが送信されると、Cisco SAF Forwarder との関係が確率されます。Cisco SAF Forwarder は、この登録メッセージを使用して、その Cisco SAF Client を接続されている他のクライアントから区別する一意のハンドルを取得します。Cisco SAF Client は、登録しなければ、サービスをアドバタイズ(パブリッシュ)または要求(サブスクライブ)することができません。図 3 に、代表的な Cisco SAF ネットワークを示します。

図 3 Cisco Service Advertisement Framework ネットワーク

サービスをアドバタイズするときに、Cisco SAF Client は、提供するサービスに関する情報を含むアドバタイズメントを Cisco SAF Forwarder にパブリッシュ(送信)します。Cisco SAF Client は、新しいサービスのアドバタイズごとにパブリッシュ要求を送信できます。Cisco SAF Forwarder は、Cisco SAF Client がパブリッシュしたすべてのサービスをアドバタイズします。

サービスを要求するときに、Cisco SAF Client は、サブスクライブ要求を使用してサービスの要求通知を送信します。サブスクライブ要求には、Cisco SAF Client に必要なサービス セットが記述されたフィルタが含まれています。この要求に応答して、Cisco SAF Forwarder は、一連の通知要求で、フィルタと一致する最新のサービス セットを Cisco SAF Client に送信します。フロー制御を実現するために複数の通知要求が送信されます。Cisco SAF Client は、Cisco SAF Forwarder が次の要求を送信する前に各通知要求に応答する必要があります。パブリッシュ要求と同様に、Cisco SAF Client は、新しいフィルタを使用するたびにサブスクライブ要求を生成する必要があります。Cisco SAF Client は、既存のサブスクリプションのいずれかを削除するサブスクライブ解除要求も生成できます。

Cisco SAF Client と Cisco SAF Forwarder の相互作用の概要

ほとんどの場合、Cisco SAF Forwarder への接続に使用される 1 つ以上の IP アドレスとポートを使用して Cisco SAF Client アプリケーションを設定することになります。Cisco SAF Client が Cisco SAF Forwarder への TCP 接続を開始します。TCP 接続が確立されると、Cisco SAF Client が Cisco SAF Forwarder に登録メッセージを送信します。この登録メッセージは、その Cisco SAF Client を Cisco SAF Forwarder に接続された他のすべての Cisco SAF Client から区別します。

Cisco SAF Client は、登録が終わると、Cisco SAF Forwarder にパブリッシュ要求を送信することによって、サービスをアドバタイズします。Cisco SAF Client は、新しいサービスをアドバタイズするたびにパブリッシュ要求を送信できます。サービスは、一意のサービス ID、サブサービス ID、およびインスタンス ID によって識別され、サービス データによって記述されます。サービス ID の詳細については、「Cisco SAF サービス ID 番号のフォーマット」を参照してください。

Cisco SAF Forwarder は、Cisco SAF Client がパブリッシュしたすべてのサービスをアドバタイズします。同様に、Cisco SAF Client は、サブスクライブ要求を使用してサービスの通知を要求できます。サブスクライブ要求には、Cisco SAF Client に必要なサービス セットが記述されたフィルタが含まれています。この要求に応答して、Cisco SAF Forwarder は、一連の通知要求で、フィルタと一致する最新のサービス セットを Cisco SAF Client に送信します。フロー制御を実現するために複数の通知要求が送信されます。Cisco SAF Client は、Cisco SAF Forwarder が次の要求を送信する前に各通知要求に応答する必要があります。

パブリッシュ要求と同様に、Cisco SAF Client は、新しいフィルタを使用するたびにサブスクライブ要求を生成できます。Cisco SAF Client は、既存のサブスクリプションのいずれかを削除するサブスクライブ解除要求も生成できます。

Cisco SAF Client と Cisco SAF Forwarder の両方がセキュリティのために共有秘密鍵を使用します。この共有秘密鍵は、ユーザ名とパスワードで構成されます。ユーザ名は、共有秘密として使用されるパスワードを決定するインデックスです。Cisco SAF Client は、要求を送信するときに、ユーザ名、実際のメッセージの内容、およびランダム パスワードを含む属性を送信します。

Cisco SAF Forwarder が要求を受信すると、ユーザ名属性を特定し、それを使用してパスワードのローカル コピーにアクセスしてから、Cisco SAF Client が実行した計算と同様の計算を実行します。計算結果が一致すると、Cisco SAF Client が認証され、その要求の整合性が維持されていることが認識されます。Cisco SAF Forwarder は、要求を拒否することもできます。

Cisco SAF Forwarder が、サービスを Cisco SAF ネットワークにアドバタイズする Cisco SAF Client の有効性に関する確認を要求します。Cisco SAF Forwarder と Cisco SAF Client は、登録時に有効性タイマーを交換します。Cisco SAF Forwarder は、有効性タイマーと同じ時間内に Cisco SAF Client から要求が届かなかった場合にそのクライアントを故障中と見なします。Cisco SAF Client が、要求間のインターバルがこの値を超えないことを保証します。Cisco SAF Client は、送信するデータがない場合は、サーバ上のタイマーを更新するための登録メッセージを生成します。

Cisco SAF Forwarder が Cisco SAF Client の故障を検出すると、そのクライアントの代わりに、アドバタイズされたサービスをネットワークから削除して、そのクライアントが設定したすべてのサブスクリプションを抹消します。Cisco SAF Client が故障したわけではなく、接続が瞬断しただけの場合は、以前のハンドルを使用して再接続および再登録して、Cisco SAF Forwarder に動作可能であることを通知します。Cisco SAF Client を手動で登録解除して、Cisco SAF Forwarder にすべてのサービスとサブスクリプションを削除させることができます。

Cisco SAF サービス ID 番号のフォーマット

サービスとは、ある Cisco SAF Client アプリケーションでアドバタイズすることによって、他の Cisco SAF Client アプリケーションで使用可能になる情報のことです。サービス アドバタイズメントはサービス データで構成されます。また、サービス アドバタイズメントはヘッダー データを使用してフォワーダ間で伝搬されます。サービスの受信を希望する Cisco SAF Client は、サービス ヘッダーとサービス データを調査することができます。

サービス ID 番号がネットワーク上のサービスを一意に識別します。次の例は、サービス ID 番号のフォーマットを示しています。

service:sub-service:instance.instance.instance.instance
 

サービス ID は、アドバタイズするメジャー サービスの 16 ビットの 10 進識別番号です。メジャー サービスとは、Cisco Unified Communications(UC)などの特定のテクノロジー領域を意味します。サービス ID は、SAF クライアントが必要なさまざまなお客様にシスコから割り当てられます。

次の例は、IP Everywhere と Cisco Unified Communications のサービス ID 値を示しています。

Cisco Defined Numbers
SAF_SERVICE_ID_IPE = 100 ! IP Everywhere
SAF_SERVICE_ID_UC = 101 ! Unified Communications
 

サブサービス ID は、アドバタイズするマイナー サービスの 16 ビットの 10 進識別番号です。サブサービス(マイナー サービスとも呼ばれる)とは、テクノロジー内部のサービス タイプを意味します。たとえば、UC 内部には次のようなサブサービスがあります。

サブサービス 1 は「TDM ゲートウェイ」です。

サブサービス 2 は「ホスト型 DN」です。

インスタンスが、この種のサービスのサービス アドバタイズメントを識別します。たとえば、サービス ID が "101:1:abcd.1234.ef.678" の場合は、特定の場所(インスタンス abcd.1234.ef.678)にある Communications Manager クラスタによって通知された UC(サービス 101) TDM ゲートウェイ(サブサービス 1)のアドバタイズメントを意味します。

インスタンス ID は、アドバタイズされた特定のサービスを識別する一意の 128 ビット値です。

クライアント チームがサブサービスの使用方法とアプリケーションのインスタンス値を定義します。クライアントは、Cisco SAF ドメインにおけるインスタンスの一意性を保証する必要があります。

Cisco SAF とネットワークにおけるドメインの役割

ネットワーク サービスの種類と数が増えるほど、これらのサービスのタイムリーで信頼できる認識の実現が、生産性と効率性の向上に大きく貢献することになります。WAN 上でサービス可用性の認識を伝搬させる場合の最重要課題の 1 つがスケーラビリティです。ネットワークの成長に合わせて、ネットワーク上のデバイスから提供されるサービスも増加します。サービス アドバタイズメントに関与するプロトコルは、この増加した負荷を処理するためにスケールする必要があります。このようなプロトコルは、変化に迅速に対応し、新しい情報をタイムリーに生成する必要もあります。

Cisco SAF は、企業のサービス拠点向けのスケーラブルなソリューションとして設計されており、LAN および WAN のインターネット セグメントをカバーすることができます。企業向けソリューションの Cisco SAF は、ドメインを使用して大規模ネットワークにスケールするように設定できます。Cisco Enhanced Interior Gateway Routing Protocol(EIGRP)では、ルートを階層的に検索可能なオートノマス システムの概念が定義されていますが、Cisco SAF でも、ドメインとサブドメインの同様の概念を採用しています。

Cisco SAF は、IP マルチキャストと呼ばれる動的なピア検出およびサービス アドバタイズメント伝搬技術を提供します。IP マルチキャストでは、IP Cisco SAF Forwarder(IP サブネット同士を接続してイントラネットを形成するデバイス)同士が協力する必要があります。ただし、IP マルチキャストがイントラネット全体に実装されない場合があります。IP マルチキャストが存在しない場合は、Cisco SAF が、設定されたサブネット内または IP マルチキャストがサポートされているサブネット グループ内で動作します。

Cisco SAF Forwarder が、ドメインとサブドメインの 2 つのプライマリ タイプ管理ドメイン(AD)を提供します。ドメインとサブドメインは、1 つの注目すべき例外を除いて、同様に機能します。サブドメインでは、一意のネイバー関係が構築されない代わりに、シングル ピアリングが使用されます。

ネットワーク上には、すべてのサービスをアドバタイズするためのドメインが 1 つだけ存在するのが理想的です。ただし、スケーリングやポリシーの問題を考えると、ネットワークによって複数ドメインが必要な場合があります。単一ドメインの使用をお勧めします。次のような場合は、複数ドメインの使用を検討してください。

30,000 を超えるサービスが 1 つのドメインに登録されている。

サービスの伝搬を制限するためにサービスを論理的にグループ分けする必要がある。

アクセスが許可されていないユーザによるサービスの閲覧を防止するには、閉じたグループが必要です。

サービスの再分配によって、複数のドメイン間でサービス情報を交換することができます。サービスをネットワークの特定の領域に限定したり、特定のネットワーク上のサービス数を制限したりしなければならない場合があります。複数ドメインを使用する必要がある場合は、サービス アドバタイズメントの再分配が解決策になる可能性があります。

ネットワーク上の各ドメインは、1 つずつの管理ドメイン(AD) に分けられています。同じ AD 内のすべての Cisco SAF Forwarder(同じドメインを実行している)は、AS 全体の情報を把握しています。2 つ以上の管理ドメインを接続している
Cisco SAF Forwarder は、境界フォワーダと呼ばれています。境界フォワーダが、AS 間でサービス情報をアドバタイズします。複数の境界フォワーダを使用してループ(ある AD から入手された情報がその AD に戻される)を回避する場合は、設計を慎重に検討する必要があります。

Cisco SAF 仮想ルータ

Cisco EIGRP Service-Family Support は、独立して動作する複数のインスタンスの設定を可能にする名前付き設定を拡張したものです。基本の Cisco EIGRP パケット エンコードに Virtual Router ID(VRID; 仮想ルータ ID)が追加されたことによって、複数インスタンスが可能になります。

仮想ルータが作成されるたびに、VRID が、トップ レベル ルータに割り当てられ、その下に設定されたアドレス ファミリーとサービス ファミリーで共有されます。

Cisco SAF ネイバー関係

Cisco SAF Forwarder は、Cisco SAF Forwarder プロトコルをサポートするルータが存在しないネットワーク上で動作できます。このようなネットワークは、「ダーク ネットワーク」と呼ばれています。Cisco SAF(IP クラウド)をサポートしていない IP ネットワーク上で Cisco SAF Forwarder を設定する方法が 2 つあります。1 つはユニキャスト Cisco SAF ネイバーで、もう 1 つはマルチキャスト Cisco SAF ネイバーです。

ユニキャスト設定を使用すれば、ネイバーとの信頼できるポイントツーポイント隣接関係を構築することができます。Cisco SAF Forwarder の数が増えた場合は、マルチキャストを使用して、複数の Cisco SAF ネイバー間の効率的な転送を実現することができます。1 つの IP マルチキャスト グループ アドレスを使用して、複数の Cisco SAF ネイバーが 1 つのピアグループ内で SAF 情報を交換することができます。

Cisco SAF Forwarder の設定

Cisco SAF Forwarder を設定するには、次のセクションに記載されたタスクを実行します。

「Cisco SAF の有効化」(必須)

「Cisco SAF のインターフェイス固有コマンドの設定」(必須)

「マルチトポロジ ネットワーク用の Cisco SAF の設定」(必須)

「Cisco SAF の静的ネイバー関係の設定」(必須)

「Cisco SAF のスタブ ルーティングの設定」(必須)

「Cisco SAF のルート認証の設定」(必須)

「ネイバー変更と警告のログの設定」(任意)

「Cisco SAF に使用されるリンク帯域幅の割合の設定」(任意)

「Cisco SAF インターフェイスのメトリック ダンプニング インターバルの設定」(任意)

「hello パケット間のインターバルとホールド タイムの調整」(任意)

「スプリット ホライズンの無効化」(任意)

「メトリック最大ホップ数の設定」(任意)

Cisco SAF の有効化

Cisco SAF を有効にして Cisco SAF サービス検出プロセスを作成するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. exit-service-family

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

exit-service-family

 

Router(config-router-sf)# exit-service-family

サービス ファミリー コンフィギュレーション モードを終了します。

Cisco SAF のインターフェイス固有コマンドの設定

Cisco SAF は、インターフェイス固有コマンドの継承優先を提供します。sf-interface コンフィギュレーション モードで実施された設定は、特定の sf-interface 設定や工場出荷時のデフォルト設定よりも優先されます。Cisco SAF のサービス ファミリーの下でインターフェイス固有コマンドを設定するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. sf-interface default

6. sf-interface interface-name interface-number

7. sf-interface ......

8. exit-sf-interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

デフォルトで有効になっている、ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを作成します。

ステップ 5

sf-interface interface-name interface-number

 

Router(config-router-sf)# sf-interface ethernet 0/0

ルータ上で指定されたインターフェイスのサービス ファミリー インターフェイス コンフィギュレーション モードを有効にします。

ステップ 6

sf-interface .....

 

Router(config-router-sf-interface)# sf-interface hello-interval 10

設定に必要な interface コマンドを入力します。

ステップ 7

exit-sf-interface

 

Router(config-router-sf-interface)# exit-sf-interface

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

マルチトポロジ ネットワーク用の Cisco SAF の設定

次の設定を使用して、クライアントを登録し、名前付きトポロジにサービスをパブリッシュまたはサブスクライブします。既存のトポロジ名を使用して 2 つ目のトポロジを別の ID に設定した場合は、同じトポロジの 2 つの ID が作成されるのではなく、既存のトポロジが置き換えられます。

マルチトポロジ ネットワーク用の Cisco SAF を設定するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. topology base

6. exit-sf-topology

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

topology base

 

Router(config-router-sf)# topology base

サービス ファミリー インターフェイス トポロジ コンフィギュレーション モードを有効にして、ルータ上で指定されたインターフェイス用のトポロジ ベースを作成します。

ステップ 6

exit-sf-topology

 

Router(config-router-sf-topology)# exit-sf-topology

サービス ファミリー インターフェイス トポロジ コンフィギュレーション モードを終了します。

Cisco SAF の静的ネイバー関係の設定

次のコマンドを使用して、Cisco SAF Forwarder 間の静的ネイバー隣接関係を設定します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. neighbor { ip-address { interface-type interface-number | description word | maximum-service } maximum-service number [threshold-value] [ dampened | reset-time | restart interval | restart-count | warning-only ] }

6. exit-service-family

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

neighbor { ip-address { interface-type interface-number} | description word | maximum-service} | maximum-service number [threshold-value] [ dampened | reset-time | restart interval | restart-count | warning-only ]}

 

Router(config-router-sf)# neighbor 10.10.10.1 Ethernet 0/0

ルータ上で指定されたインターフェイスの Cisco SAF ネイバー関係を有効にします。

ステップ 6

exit-service-family

 

Router(config-router-sf)# exit-service-family

サービス ファミリー コンフィギュレーション モードを終了します。

Cisco SAF のスタブ ルーティングの設定

Cisco SAF Forwarder をスタブ ルータとして設定できます。Cisco EIGRP スタブ ルーティングの詳細については、『 Cisco IOS IP Routing: EIGRP Configuration Guide 』の「 Configuring EIGRP 」モジュールを参照してください。

Cisco SAF スタブ ルータを作成するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. eigrp stub [ receive-only | connected ]

6. exit-service-family

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

eigrp stub [receive-only | connected ]

 

Router(config-router-sf)# eigrp stub connected

Cisco SAF のスタブ ルータを設定します。

ステップ 6

exit-service-family

 

Router(config-router-sf)# exit-service-family

サービス ファミリー コンフィギュレーション モードを終了します。

Cisco SAF のルート認証の設定

Cisco SAF ルート認証では、ルーティング プロトコルからのルーティング更新の Message Digest 5(MD5; メッセージ ダイジェスト 5)認証が提供されます。各パケット内の MD5 鍵付きダイジェストによって、未承認ソースからの不正なまたは偽のルーティング メッセージの導入が阻止されます。Cisco SAF のルート認証を設定するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. sf-interface interface-name interface-number

6. authentication key-chain name-of-chain

7. authentication mode md5

8. exit-sf-interface

9. exit-service-family

10. exit

11. key chain name-of-chain

12. key key-id

13. key-string text

14. accept-lifetime start-time [ local { duration seconds | end-time | infinite }]

15. send-lifetime start-time [ local { duration seconds | end-time | infinite }]

16. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

sf-interface interface-name interface-number

 

Router(config-router-sf)# sf-interface ethernet 0/0

ルータ上で指定されたインターフェイスの IPv4 サービス ファミリー インターフェイス コンフィギュレーション モードを有効にします。

ステップ 6

authentication key-chain name-of-chain

 

Router(config-router-sf-interface)# authentication key-chain example

EIGRP の認証鍵チェーンを指定します。

ステップ 7

authentication mode md5

 

Router(config-router-sf-interface)# authentication key-chain example

ルータ上で指定されたインターフェイスの IPv4 サービス ファミリー認証モード MD5 を有効にします。

ステップ 8

exit-sf-interface

 

Router(config-router-sf-interface)# exit-sf-interface

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

ステップ 9

exit-service-family

 

Router(config-router-sf)# exit-service-family

サービス ファミリー コンフィギュレーション モードを終了します。

ステップ 10

exit

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了します。

ステップ 11

key-chain name-of-chain

 

Router(config)# key-chain example

ルーティング プロトコルの認証を有効にするために必要な認証鍵チェーンを定義して、鍵チェーン コンフィギュレーション モードを開始します。

ステップ 12

key key-id

 

Router(config-keychain)# key example

鍵の認証文字列を特定します。

ステップ 13

key-string text

 

Router(config-keychain-key)# key-string example

鍵の認証文字列を指定します。

ステップ 14

accept-lifetime start-time [ local { duration seconds | end-time | infinite }]

 

Router(config-router-sf-interface)# accept-lifetime example

鍵チェーン内の認証鍵が有効として受信される期間を設定します。

ステップ 15

send-lifetime start-time [ local { duration seconds | end-time | infinite }]

 

Router(config-router-sf-interface)# send-lifetime example

鍵チェーン上の認証鍵が送信可能な期間を設定します。

ステップ 16

exit

 

Router(config-router-sf-interface)# exit

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

ネイバー変更と警告のログの設定

デフォルトで、ルーティング システムの安定性を監視して問題を特定できるように、ネイバー隣接関係の変更がシステム ログに記録されます。無効にしたこのような変更のロギングを再度有効にする場合は、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. eigrp log-neighbor-changes

6. eigrp log-neighbor-warnings

7. exit-service-family

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

eigrp log-neighbor-changes

 

Router(config-router-sf)# eigrp log-neighbor-changes

EIGRP サービス ファミリー ネイバー隣接関係の変更のロギングを有効にします。

ステップ 6

eigrp log-neighbor-warnings seconds

 

Router(config-router-sf)# eigrp log-neighbor-warnings 60

サービス ファミリー 警告メッセージの変更のロギングを有効にします。

ステップ 7

exit-service-family

 

Router(config-router)# exit-service-family

サービス ファミリー コンフィギュレーション モードを終了します。

Cisco SAF に使用されるリンク帯域幅の割合の設定

デフォルトで、 bandwidth interface 設定コマンドで設定されたように、リンク帯域幅の最大 50% がパケットに消費されます。別のレベルのリンク使用が必要な場合、または、設定された帯域幅が実際のリンク帯域幅に適合しない(ルート メトリックの計算に影響を与えるように設定されている)場合は、この値を変更できます。次のコマンドを使用して、Cisco SAF に使用されるリンク帯域幅の割合を設定します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. sf-interface interface-name interface-number

6. bandwidth-percent maximum-bandwidth-percentage

7. exit-sf-interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

sf-interface interface-name interface-number

 

Router(config-router-sf)# sf-interface ethernet0/0

ルータ上で指定されたインターフェイスのサービス ファミリー インターフェイス コンフィギュレーション モードを有効にします。

ステップ 6

bandwidth-percent maximum-bandwidth-percentage

 

Router(config-router-sf-interface)# bandwidth-percent 75

Cisco SAF のリンクに使用される帯域幅の最大割合を設定します。

ステップ 7

exit-sf-interface

 

Router(config-router-sf-interface)# exit-sf-interface

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

Cisco SAF インターフェイスのメトリック ダンプニング インターバルの設定

メトリック コンポーネントは頻繁に変更される可能性があるため、その変更頻度がネットワークに影響を与える可能性があります。頻繁に変更するためには、SAF インターフェイス経由で取得したプレフィックスを更新して、すべての隣接ルータに送信する必要があります。この更新がさらなる更新を産み、最悪の場合、ネットワーク規模のチャーンを引き起こす可能性があります。このような影響を回避するために、ダンプニングしきい値を下回っている変更は無視できるように、メトリックを下げるか、しきい値を設定することができます。

即時更新を引き起こすネットワーク変更には、新しい nexthop またはダウン インターフェイスかダウン ルータがルータ上で選択されるメトリックの変更が含まれます。

メトリック変更のダンプニングは変更またはタイム インターバルに基づいて設定できます。

ダンプニング方法によって次のように動作が異なります。

変更ベースの場合は、特定のインターフェイス経由で取得されたルートの変更または特定のインターフェイス メトリックの変更が、最後にアドバタイズされた値から 計算された メトリックの変更が非常に重要で更新を送信しなけらばならなくなるまで、隣接ルータにアドバタイズされません。

インターバル ベースの場合は、特定のインターフェイス経由で取得されたルートの変更または特定のインターフェイス メトリックの変更が、 指定された インターバルが経過するまで、または、その変更によって新しいルート パスが選択されなければ、隣接ルータにアドバタイズされません。タイマーが切れると、レポートに対する変更が未処理のルートが送信されます。ルートが変更され、そのルートの最終メトリックが最後に更新されたメトリックと一致する場合は、更新されたルータが送信されません。

変更ベースとインターバル ベースのメトリック ダンプニング設定の詳細については、次のセクションを参照してください。

「変更ベースのダンプニング設定」

「インターバル ベースのダンプニング設定」

変更ベースのダンプニング設定

次のコマンドを使用して、Cisco SAF インターフェイスの変更ベースの最大ダンプニング割合を設定します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. sf-interface interface-name interface-number

6. dampening-change [ change-percentage]

7. exit-sf-interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

sf-interface interface-name interface-number

 

Router(config-router-sf)# sf-interface ethernet0/0

ルータ上で指定されたインターフェイスのサービス ファミリー インターフェイス コンフィギュレーション モードを有効にします。

ステップ 6

dampening-change [ change-percentage]

 

Router(config-router-sf-interface)# dampening-change 50

隣接ピアに更新がアドバタイズされる、EIGRP サービス ファミリー インターフェイス経由で取得されたルート変更の割合を設定します。

ステップ 7

exit-sf-interface

 

Router(config-router-sf-interface)# exit-sf-interface

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

インターバル ベースのダンプニング設定

次のコマンドを使用して、Cisco SAF インターフェイスのインターバル ベースのダンプニングを設定します。設定した値によって、Cisco SAF インターフェイスとピアに影響を与えるトポロジ変更による更新が発生するインターバルが設定されます。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. sf-interface interface-name interface-number

6. dampening-interval [interval]

7. exit-service-family

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

sf-interface interface-name interface-number

 

Router(config-router-sf)# sf-interface ethernet0/0

ルータ上で指定されたインターフェイスのサービス ファミリー インターフェイス コンフィギュレーション モードを有効にします。

ステップ 6

dampening-interval [interval]

 

Router(config-router-sf-interface)# dampening-interval 30

EIGRP インターバル ベースのダンプニング インターバルを設定します。

ステップ 7

exit-sf-interface

 

Router(config-router-sf-interface)# exit-sf-interface

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

hello パケット間のインターバルとホールド タイムの調整

ルーティング デバイスは定期的に hello パケットをやり取りすることによって、直接接続されたネットワーク上の他のルータを動的に調査します。この情報は、ネイバーの検出と、ネイバーが到達不能または動作不能になった時点の認識に使用されます。

デフォルトで、hello パケットは 5 秒間隔で送信されます。例外は、デフォルトの hello インターバルが 60 秒の低速 NonBroadcast MultiAccess(NBMA; 非ブロードキャスト マルチアクセス)メディアの場合です。低速とは、 bandwidth interface 設定コマンドで指定されているように、T1 以下のレートを指します。高速 NBMA ネットワークのデフォルトの hello インターバルは 5 秒です。フレーム リレーや Switched Multimegabit Data Service(SMDS; スイッチド マルチメガビット データ サービス)に使用されるネットワークは、NBMA と見なされる場合と見なされない場合があることに注意してください。このようなネットワークは、インターフェイスが物理マルチキャストを使用するように設定されていない場合は NBMA と見なされ、それ以外の場合は NBMA と見なされません。

ホールド タイムは、hello パケット内でアドバタイズされ、送信元が有効であると見なすべき時間をネイバーに指示します。デフォルトのホールド タイムは、hello インターバルの 3 倍、つまり、15 秒です。低速 NBMA ネットワークのデフォルトのホールド タイムは 180 秒です。混雑したネットワークや大規模なネットワーク上では、デフォルトのホールド タイムでは、すべてのルータがネイバーから hello パケットを受信するのに不十分な場合があります。この場合、ホールド タイムを増やすこともできます。ホールド タイムを調整する場合は、テクニカルサポート担当者に相談してください。オートノマス システム番号で指定された特別なルーティング プロセス用のインターフェイスに関するホールド タイムを変更するには、 hold time コマンドを使用します。

hello パケット間のインターバルとホールド タイムを調整できます。hello パケット間のインターバルとホールド タイムを変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system number

5. sf-interface interface-name interface-number

6. hello-interval seconds

7. hold-time seconds

8. exit-sf-interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

sf-interface interface-name interface-number

 

Router(config-router-sf)# sf-interface ethernet0/0

ルータ上で指定されたインターフェイスのサービス ファミリー インターフェイス コンフィギュレーション モードを有効にします。

ステップ 6

hello-interval seconds

 

Router(config-router-sf-interface)# hello-interval 50

EIGRP サービス ファミリー プロセスの期間を設定します。

ステップ 7

hold-time seconds

 

Router(config-router-sf-interface)# hello-interval 50

オートノマス システム番号で指定された EIGRP サービス ファミリー ルーティング プロセスの期間を設定します。

ステップ 8

exit-sf-interface

 

Router(config-router-sf-interface)# exit-sf-interface

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

スプリット ホライズンの無効化

インターフェイス上でスプリット ホライズンが有効になっている場合は、ルート情報(更新パケットや照会パケットなど)の発信元であるインターフェイス以外のルータによるその情報のアドバタイズがブロックされます。この方法で更新パケットと照会パケットを制御することによって、ルーティング ループの可能性が軽減されます。

多くの場合、この動作によって、特にリンクが切断されているときに、複数のルーティング デバイス間の通信が最適化されます。ただし、非ブロードキャスト ネットワーク(フレーム リレーや SMDS など)を使用している場合は、この動作では不十分な状況が発生する可能性があります。その場合は、Cisco SAF を設定したネットワークを含めて、スプリット ホライズンを無効にすることができます。

デフォルトでは、すべてのインターフェイス上でスプリット ホライズンが有効になっています。スプリット ホライズンを無効にするには、インターフェイス コンフィギュレーション モードで、 no split-horizon コマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. sf-interface interface-name interface-number

6. no split-horizon

7. exit-sf-interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

sf-interface interface-name interface-number

 

Router(config-router-sf)# sf-interface ethernet0/0

ルータ上で指定されたインターフェイスのサービス ファミリー インターフェイス コンフィギュレーション モードを有効にします。

ステップ 6

no split-horizon

 

Router(config-router-sf-interface)# no split-horizon

スプリット ホライズンを無効にします。

ステップ 7

exit-sf-interface

 

Router(config-router-sf-interface)# exit-sf-interface

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

メトリック最大ホップ数の設定

最大ホップ数によって、サービスをアドバタイズする目的で伝搬可能なホップ数が制限されます。デフォルトの最大ホップ数は 100 です。

サービスのアドバタイズに使用されるホップ数を制限するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. sf-interface interface-name interface-number

6. metric maximum-hops hop-count

7. exit-sf-interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

sf-interface interface-name interface-number

 

Router(config-router-sf)# sf-interface ethernet 0/0

ルータ上で指定されたインターフェイスのサービス ファミリー インターフェイス コンフィギュレーション モードを有効にします。

ステップ 6

metric maximum-hops

 

Router(config-router-sf-interface)# metric maximum-hops 5

IP ルーティング ソフトウェアを到達不能ルートとしてアドバタイズするためのホップ カウントを指定します。

ステップ 7

exit-sf-interface

 

Router(config-router-sf-interface)# exit-sf-interface

サービス ファミリー インターフェイス コンフィギュレーション モードを終了します。

Cisco SAF Client の設定

ここでは、Cisco Service Advertisement Framework(Cisco SAF)Client を設定するためのタスクについて説明します。

Cisco SAF Client は、次のいずれかの方法で Cisco SAF ネットワークに接続します。

内部 API を使用して Cisco SAF Forwarder に接続する場合は、Cisco SAF Forwarder と同じルータ上に存在します。

Cisco SAF Forwarder の外部に存在します。この設定では、SAF Client は Cisco SAF External Client と呼ばれ、Cisco SAF Forwarder に接続するためのプロトコル インターフェイスが必要になります。

前提条件

事前に必要な作業:

Cisco SAF Client を設定する前に、「Cisco SAF Client の概要」に記載された概念を理解しておく必要があります。

別々の LAN 上に配置された Cisco SAF External Client のネイバー関係を設定する前に、各 Cisco External Client 間の IP ルーティングが設定されていることを確認してください。

制約事項

Cisco SAF は現在、最大 50 台の Cisco SAF External Client をサポートします。

Cisco SAF External Client の設定

Cisco SAF External Client を設定するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system autonomous-system-number

5. topology base

6. external-client client_label

7. exit-sf-topology

8. exit-service-family

9. exit

10. service-family external-client listen {ipv4 | ipv6} tcp_port_number

11. external-client client-label

12. username user-name

13. password password-name

14. keepalive number

15. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp saf

グローバル コンフィギュレーション モードで EIGRP 仮想インスタンスを有効にします。

ステップ 4

service-family { ipv4 | ipv6 } [vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# service-family ipv4 autonomous-system 4453

ルータ上で指定されたオートノマス システム用の Cisco SAF サービス ファミリーを有効にします。

ステップ 5

topology base

 

Router(config-router-sf)# topology base

ルータ上で指定されたインターフェイスのサービス ファミリー インターフェイス トポロジ コンフィギュレーション モードを有効にします。

ステップ 6

external-client client-label

 

Router(config-router-topology)# external-client example

指定されたクライアント ラベルで Cisco SAF External Client を設定します。

ステップ 7

exit-sf-topology

 

Router(config-router-sf-topology)# exit-sf-topology

サービス ファミリー トポロジ コンフィギュレーション モードを終了します。

ステップ 8

exit-service-family

 

Router(config-router-sf)# exit-service-family

サービス ファミリー コンフィギュレーション モードを終了します。

ステップ 9

exit

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了します。

ステップ 10

service-family external-client listen { ipv4 | ipv6 } tcp_port_number

 

Router(config)# service-family external-client listen ipv4 5050

Cisco SAF Forwarder との通信に使用される Cisco SAF External Client の TCP ポートを設定します。

ステップ 11

external-client client-label

 

Router(config)# external-client example

指定されたクライアント ラベルで Cisco SAF External Client を設定します。

ステップ 12

username user-name

 

Router(config-external-client)# username example

外部クライアント ラベル コンフィギュレーション モードを有効にして、指定されたユーザ名で Cisco SAF External Client を設定します。

ステップ 13

password password-name

 

Router(config-external-client-mode)# password examplepass

Cisco SAF External Client のパスワードを設定します。最小パスワード長は 11 文字です。

ステップ 14

keepalive number

 

Router(config-external-client-mode)# keepalive 360000

Cisco SAF External Client のキープアライブ タイマーを指定します。

ステップ 15

exit

 

Router(config-external-client-mode)# exit

外部クライアント ラベル コンフィギュレーション モードを終了します。

Cisco SAF 統計情報の表示

Cisco SAF 統計情報を表示するには、EXEC モードで次のコマンドを使用します。

コマンド
目的

show eigrp service-family {clients [detail] | external-client [name] | subscriptions [detail] }

 

Router# show eigrp service-family

Cisco SAF 用に設定されたクライアント、外部クライアント、またはサブスクリプションに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number accounting

 

Router# show eigrp service-family ipv4 4453 accounting

Cisco SAF に関するアカウンティング情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number clients [detail]

 

Router# show eigrp service-family ipv4 4453 clients

Cisco SAF Client に関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number events [ starting-event-number ending-event-number]

 

Router# show eigrp service-family ipv4 4453 events

Cisco SAF イベントに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number interfaces [ interface-type interface-number | detail ]

 

Router# show eigrp service-family ipv4 4453 interfaces

Cisco SAF インターフェイスに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number subscriptions [ detail ]

 

Router# show eigrp service-family ipv4 4453 subscriptions

Cisco SAF サブスクリプションに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number timers

 

Router# show eigrp service-family ipv4 4453 timers

Cisco SAF タイマーに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number summary

 

Router# show eigrp service-family ipv4 4453 summary

Cisco SAF サマリーに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number zero-successors

 

Router# show eigrp service-family ipv4 4453 zero-successors

Cisco SAF ゼロ サクセサに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology
[service-instance-number]

 

Router# show eigrp service-family ipv4 4453 topology

Cisco SAF トポロジ テーブルに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology active

 

Router# show eigrp service-family ipv4 4453 topology active

Cisco SAF トポロジ テーブルのアクティブ エントリのみを表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology all-links

 

Router# show eigrp service-family ipv4 4453 topology all-links

Cisco SAF トポロジ テーブルのすべてのアクティブ リンク エントリを表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology base [ service-instance-number | clients [detail] ]

 

Router# show eigrp service-family ipv4 4453 topology base clients

Cisco SAF トポロジ ベースに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology detail-links

 

Router# show eigrp service-family ipv4 4453 topology detail-links

Cisco SAF に関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology events [ starting-event-number ending-event-number]

 

Router# show eigrp service-family ipv4 4453 topology

Cisco SAF に関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology pending

 

Router# show eigrp service-family ipv4 4453 topology pending

Cisco SAF に関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology service-type [connected | external | internal | local | redistributed | summary]

 

Router# show eigrp service-family ipv4 4453 topology service-type connected

Cisco SAF トポロジ テーブルの指定されたサービス タイプに関する情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology sia-events [ starting-event-number ending-event-number]

 

Router# show eigrp service-family ipv4 4453 topology sia-events

Cisco SAF トポロジ テーブル内の Stuck in Active(SIA)イベントを表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology sia-statistics [ ip-address ]

 

Router# show eigrp service-family ipv4 4453 topology sia-statistics 10.10.10.1

Cisco SAF トポロジ テーブルに関する Stuck in Active(SIA)統計情報を表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology summary

 

Router# show eigrp service-family ipv4 4453 topology summary

Cisco SAF トポロジ テーブルのサマリーを表示します。

show eigrp service-family {ipv4 | ipv6}
[vrf
vrf-name ] autonomous-system-number topology zero-successors

 

Router# show eigrp service-family ipv4 4453 topology zero-successors

Cisco SAF トポロジ テーブル内にゼロ サクセサが存在する利用可能なサービスに関する情報を表示します。

Cisco SAF 設定からの情報の削除

Cisco SAF 設定からサービス ファミリー情報を削除するには、ユーザ EXEC モードで次のコマンドを使用します。

コマンド
目的

clear eigrp service-family external-client external-client-name

 

Router# clear eigrp service-family external-client example

指定されたクライアントを削除します。

clear eigrp service-family {ipv4 | ipv6} [vrf vrf-name ] autonomous-system-number

 

Router# clear eigrp service-family ipv4 4453

指定されたオートノマス システムの IPv4 または IPv6 プロトコル ファミリーを使用して構成されたネイバーを削除します。

オプションで、すべての Virtual Routing Forwarding(VRF)インスタンス テーブルまたは IP アドレスに関する特定の VRF テーブルを削除できます。

コマンドを使用する場合は、現在は存在しない IPv6 対応の SAF クライアントが必要です。

clear eigrp service-family neighbors [soft] [ neighbors-address | interface-type interface-number]

 

Router# clear eigrp service-family neighbors Ethernet 0/0

ネイバーテーブルから IPv4 プロトコル ファミリーを使用して構成されたネイバーを削除します。

オプションで、隣接関係リセット(ソフト)を使用せずにピアと再同期化することができます。

オプションで、このインターフェイスを通して取得されたすべてのエントリを含むネイバーテーブルから、インターフェイスのタイプと番号を削除できます。

Cisco SAF の設定例

ここでは、次の例について説明します。

「Cisco SAF の有効化:例」

「Cisco SAF インターフェイスの設定:例」

「Cisco SAF トポロジの設定:例」

「Cisco SAF スタブ ルーティングの設定:例」

「IP-RIP を使用した Cisco SAF の設定:例」

「OSPF を使用した Cisco SAF の設定:例」

「EIGRP を使用した Cisco SAF の設定:例」

「別々の LAN 上に配置された Cisco SAF Forwarder の設定:例」

「集中型 Cisco SAF Forwarder の設定:例」

「Cisco SAF Client の設定:例」

「ネイバー変更と警告のログの設定:例」

「Cisco Unified Communications Manager の Cisco SAF Client としての設定:例」

Cisco SAF の有効化:例

次の例では、ルータ コンフィギュレーション モードを開始して、Cisco SAF Forwarder を設定し、サービス ファミリー フォワーダ プロセスを有効にして、4533 という名前のオートノマス システムを設定します。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533

Cisco SAF インターフェイスの設定:例

次の例では、ルータをサービス ファミリー コンフィギュレーション モードにして、すべてのインターフェイスを有効にします。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface default
Router(config-router-sf-interface)# no shutdown
 

次の例では、ルータをサービス ファミリー コンフィギュレーション モードにして、イーサネット インターフェイス 0/0 を有効にします。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface ethernet0/0
 

次の例では、ルータをサービス ファミリー コンフィギュレーション モードにして、イーサネット 0/0 インターフェイスを除くすべてのインターフェイス上の SAF を有効にします。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 3
Router(config-router-sf)# interface default
Router(config-router-sf)# sf-interface ethernet0/0
Router(config-router-sf-interface)# shutdown
Router(config-router-sf-interface)# end
 

次の例では、ルータをサービス ファミリー コンフィギュレーション モードにして、イーサネット 2/0 インターフェイスとイーサネット 2/1 インターフェイス上の SAF を有効にし、他のすべてのインターフェイスを無効にします。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 2
Router(config-router-sf)# sf-interface default
Router(config-router-sf-interface)# shutdown
Router(config-router-sf-interface)# sf-interface ethernet2/0
Router(config-router-sf-interface)# no shutdown
Router(config-router-sf-interface)# sf-interface ethernet2/1
Router(config-router-sf-interface)# no shutdown
Router(config-router-sf-interface)# end

Cisco SAF トポロジの設定:例

次の例では、Cisco SAF トポロジ ベースを設定します。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface default
Router(config-router-sf-interface)# no shutdown
Router(config-router-sf-interface)# topology base

Cisco SAF スタブ ルーティングの設定:例

次の例では、Cisco SAF Forwarder をスタブ ルータとして設定します。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# eigrp stub connected

IP-RIP を使用した Cisco SAF の設定:例

次の例では、ネットワーク 10.0.0.0 上で IP-RIP ルーティングを使用して Cisco SAF を有効にします。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# topology base
Router(config-router-sf-topology)# exit-sf-topology
Router(config-router-sf)# exit service-family
Router(config-router)# router rip
Router(config-router)# network 10.0.0.0

OSPF を使用した Cisco SAF の設定:例

次の例では、ネットワーク 10.0.0.0、領域 0 上で OSPF ルーティングを使用して Cisco SAF を有効にします。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# topology base
Router(config-router-sf-topology)# exit-sf-topology
Router(config-router-sf)# exit service-family
Router(config-router)# router ospf 787
Router(config-router)# network 10.0.0.0 0.0.0.255 area 0

EIGRP を使用した Cisco SAF の設定:例

次の例では、ネットワーク 10.0.0.0 上で EIGRP ルーティングを使用して Cisco SAF を有効にします。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 6476
Router(config-router-sf)# network 10.0.0.0 0.0.0.255
Router(config-router-sf)# topology base
Router(config-router-sf-topology)# exit-af-topology
Router(config-router-sf)# exit-service-family
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# topology base

) サービスが配信されるインターフェイスまたはネットワーク上でルーティングを実行する場合の要件は特にありませんが、到達可能性が保証されない領域にサービスが配信される可能性があります。


別々の LAN 上に配置された Cisco SAF Forwarder の設定:例

次の例では、別々の LAN 上に配置された 2 台の Cisco SAF Forwarder を設定します。


) ループバック モードを使用して、リモート ネイバーを設定します。


Cisco SAF Forwarder 1:

Router(config)# interface loopback1
Router(config-if)# ip address 10.1.1.1 255.255.255.255
Router(config-if)# exit
Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 1
Router(config-router-sf)# neighbor 10.2.2.2 loopback1 remote 10

Cisco SAF Forwarder 2:

Router(config)# interface loopback1
Router(config-if)# ip address 10.2.2.2 255.255.255.255
Router(config-if)# exit
Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 1
Router(config-router-sf)# neighbor 10.1.1.1 loopback1 remote 10

) 次の例では、2 台のルータ間に IP ルーティングが設定されており、ルータが両方のループバックを ping できるものとします。


集中型 Cisco SAF Forwarder の設定:例

次の例では、すべてのサービス アドバタイズメントを IP アドレスが 10.4.15.5 と 10.4.15.1 のネイバーに送信する集中型 Cisco SAF Forwarder を設定します。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface loopback0
Router(config-router-sf-interface)# no split-horizon
Router(config-router-sf-interface)# exit-sf-interface
Router(config-router-sf)# topology base
Router(config-router-sf-topology)# exit-sf-topology
Router(config-router-sf)# neighbor 10.4.15.5 Loopback0 remote 20
Router(config-router-sf)# neighbor 10.4.15.1 Loopback0 remote 20
Router(config-router-sf)# exit-service-family

Cisco SAF Client の設定:例

次の例では、名前が example 、ユーザ名が username_example 、パスワードが password_example 、キープアライブ設定が 360000 秒の Cisco SAF External Client を設定します。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# topology base
Router(config-router-sf-topology)# external-client example
Router(config-router-sf-topology)# exit-sf-topology
Router(config-router-sf)# exit-service-family
Router(config-router)# exit
Router(config)# service-family external-client listen ipv4 3444
Router(config-external-client)# external-client example
Router(config-external-client-mode)# username username_example
Router(config-external-client-mode)# password password_example
Router(config-external-client-mode)# keepalive 360000
 

次の例では、名前が example1 example5 、ユーザ名が username_example1 username_example5 、パスワードが password_example1 password_example5 、キープアライブ設定が 360000 秒の 5 台の Cisco SAF External Client を設定します。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# topology base
Router(config-router-sf-topology)# external-client example1
Router(config-router-sf-topology)# external-client example2
Router(config-router-sf-topology)# external-client example3
Router(config-router-sf-topology)# external-client example4
Router(config-router-sf-topology)# external-client example5
Router(config-router-sf-topology)# exit-sf-topology
Router(config-router-sf)# exit-service-family
Router(config-router)# exit
Router(config)# service-family external-client listen ipv4 3444
Router(config-external-client)# external-client example1
Router(config-external-client-mode)# username username_example1
Router(config-external-client-mode)# password password_example1
Router(config-external-client-mode)# keepalive 360000
Router(config-external-client-mode)# external-client example2
Router(config-external-client-mode)# username username_example2
Router(config-external-client-mode)# password password_example2
Router(config-external-client-mode)# keepalive 360000
Router(config-external-client-mode)# external-client example3
Router(config-external-client-mode)# username username_example3
Router(config-external-client-mode)# password password_example3
Router(config-external-client-mode)# keepalive 360000
Router(config-external-client-mode)# external-client example4
Router(config-external-client-mode)# username username_example4
Router(config-external-client-mode)# password password_example4
Router(config-external-client-mode)# keepalive 360000
Router(config-external-client-mode)# external-client example5
Router(config-external-client-mode)# username username_example5
Router(config-external-client-mode)# password password_example5
Router(config-external-client-mode)# keepalive 360000
 

ネイバー変更と警告のログの設定:例

デフォルトで、ルーティング システムの安定性を監視して問題を特定できるように、ネイバー隣接関係の変更がシステム ログに記録されます。無効にしていた変更のロギングを再度有効にする場合は、次の例に示すコマンドを使用します。

Router(config)# router eigrp saf
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# eigrp log-neighbor-changes
Router(config-router-sf)# eigrp log-neighbor-warnings 60
Router(config-router-sf)# exit-service-family

Cisco Unified Communications Manager の Cisco SAF Client としての設定:例

次の例では、Cisco Unified Communications Manager を Cisco SAF Client として設定します。

Router(config)# router eigrp virtual-router
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# topology base
Router(config-router-sf-topology)# external-client cucm
Router(config-router-sf-topology)# exit-sf-topology
Router(config-router-sf)# exit service-family
Router(config-router)# exit
Router(config)# service-family external-client listen ipv4 3444
Router(config-router-sf)# topology base
Router(config-router-sf-topology)# external-client cucm basename
Router(config-external-client)# username cucm
Router(config-external-client)# password example
Router(config-external-client)# keepalive 360000

参考資料

次のセクションで、Cisco Service Advertisement Framework 機能の関連資料を示します。

「関連資料」

「規格」

「MIB」

「RFC」

「シスコのテクニカル サポート」

関連資料

関連トピック
参照先

Cisco EIGRP テクノロジーの実装

The Cisco EIGRP Implementation

Cisco SAF コマンド:すべてのコマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

Cisco IOS Service Advertisement Framework Command Reference

規格

標準
タイトル

Cisco EIGRP

--

MIB

MIB
MIB リンク

EIGRP MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

Cisco Service Advertisement Framework に関する機能情報

表 1 に、このマニュアルに記載されている機能と、特定の設定情報へのリンクを示します。この表には、Cisco IOS リリース 15.0(1)M 以降のリリースで導入または変更された機能だけが記載されています。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すれば、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートしている Cisco IOS ソフトウェア イメージと Catalyst OS ソフトウェア イメージを調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース トレインの中で特定の機能のサポートが導入された Cisco IOS ソフトウェア リリースだけを示します。特に断りがなければ、その Cisco IOS ソフトウェア リリース トレイン以降のリリースでもこの機能がサポートされます。


 

表 1 Cisco Service Advertisement Framework に関する機能情報

機能名
リリース
機能情報

Cisco Service Advertisement Framework

15.0M、12.2(33)SRE、12.2(33)XNE、15.1T

この機能を使用すれば、アプリケーションで、ネットワークに接続されたリソースの存在、位置、および設定を検出して、ネットワーク上のアプリケーション アドバタイズおよび検出サービスとして、タイムリーで信頼できるネットワーク上のサービス認識を実現できます。

この機能は Cisco IOS 15.0M で導入されました。

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

このコマンドは、Cisco IOS Release 15.1T に統合されました。

次のコマンドがこの機能で導入されました。

authentication(service-family)

bandwidth-percent

clear eigrp service-family

dampening-change

dampening-interval

default external-client

default(SAF)

debug eigrp service-family

default-metric(EIGRP)

eigrp stub(service-family)

exit-service-family

exit-sf-interface

exit-sf-topology

external-client

keepalive(SAF)

maximum-service(EIGRP)

neighbors(service-family)

password(SAF)

service-family

service-family external-client listen

sf-interface

show eigrp service-family

show eigrp service-family ipv4 topology

show eigrp service-family ipv6 topology

show eigrp tech-support

shutdown

topology

username(SAF)

Cisco Service Advertisement Framework

15.0M、12.2(33)SRE、12.2(33)XNE

次のコマンドがこの機能で変更されました。

accept-lifetime

eigrp log-neighbor-changes

eigrp-log-neighbor-warnings

eigrp router-id

hello-interval

hold-time

key

key chain

key-string(認証)

metric weights(EIGRP)

next-hop-self

send-lifetime

split-horizon

timers