Cisco IOS IP ルーティング:プロトコル非依存コン フィギュレーション ガイド
複数のトラッキング オプションに対する PBR サポート
複数のトラッキング オプションに対する PBR サポート
発行日;2012/01/31 | 英語版ドキュメント(2011/05/24 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

複数のトラッキング オプションに対する PBR サポート

機能情報の確認

この章の構成

複数のトラッキング オプションに対する PBR サポートの概要

オブジェクト トラッキング

複数のトラッキング オプションに対する PBR サポートの機能設計

複数のトラッキング オプションに対する PBR サポートの設定方法

CiscoIOS リリース12.3(11)T、12.2(25)S 以前のリリースでの複数のトラッキング オプションに対する PBR サポートの設定

前提条件

CiscoIOS リリース12.3(14)T、12.2(33)S 以降のリリースでの複数のトラッキング オプションに対する PBR サポートの設定

前提条件

複数のトラッキング オプションに対する PBR サポートの設定例

CiscoIOS リリース12.3(11)T、12.2(25)S 以前のリリースでの複数のトラッキング オプションに対する PBR サポートの設定:例

CiscoIOS リリース12.3(14)T、12.2(33)S 以降のリリースでの複数のトラッキング オプションに対する PBR サポートの設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

複数のトラッキング オプションに対する PBR サポートの機能情報

複数のトラッキング オプションに対する PBR サポート

複数のトラッキング オプションに対する PBR サポート機能は、Cisco Discovery Protocol(CDP)を使ったオブジェクト トラッキングの機能を拡張し、追加の方法を使って、ポリシーベース ルーティング(PBR)処理でオブジェクトが使用可能かどうかを確認できます。確認方法として使用できるのは、Internet Control Message Protocol(ICMP)ping、User Datagram Protocol(UDP)ping、または HTTP GET です。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「複数のトラッキング オプションに対する PBR サポートの機能情報」を参照してください。

プラットフォームのサポートと Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

複数のトラッキング オプションに対する PBR サポートの概要

複数のトラッキング オプションに対する PBR サポート機能を設定するには、次の概念を理解しておく必要があります。

「オブジェクト トラッキング」

「複数のトラッキング オプションに対する PBR サポートの機能設計」

オブジェクト トラッキング

オブジェクト トラッキングは、次のようなオブジェクトをモニタする独立したプロセスです。

インターフェイスの回線プロトコルの状態

ルーティング テーブル内のエントリの存在

ping など、Service Assurance Agent(SAA)動作の結果

Hot Standby Router Protocol(HSRP)、Virtual Router Redundancy Protocol(VRRP)、Gateway Load Balancing Protocol(GLBP)、(この機能を使用した)PBR などのクライアントは、特定のトラッキング対象オブジェクトを登録して、オブジェクトの状態が変化したときに処理を実行できます。

複数のトラッキング オプションに対する PBR サポートの機能設計

複数のトラッキング オプションに対する PBR サポート機能は、トラッキング プロセスを通じて使用できるすべてのオブジェクトへの PBR アクセスを提供します。トラッキング プロセスを使って、ICMP ping 到達可能性、ルーティング隣接関係、リモート デバイス上で実行中のアプリケーション、Routing Information Base(RIB)内のルートなどの個々のオブジェクトや、インターフェイス回線プロトコルの状態をトラッキングできます。

オブジェクト トラッキングは次のように機能します。PBR は、特定のオブジェクトのトラッキングが必要なことをトラッキング プロセスに通知します。一方、トラッキング プロセスはそのオブジェクトの状態が変化した場合に PBR に通知します。

複数のトラッキング オプションに対する PBR サポートの設定方法

Cisco IOS リリース 12.3(14)T で IP サービス レベル契約(SLA)に新しい構文が導入されたため、この項の作業は実行している Cisco IOS リリースによって異なります。この機能を使用するには、Cisco IOS リリース 12.3(4)T、12.2(25)S 以降のリリースを実行している必要があります。ここでは、次の作業について説明します。

「Cisco IOS リリース 12.3(11)T、12.2(25)S 以前のリリースでの複数のトラッキング オプションに対する PBR サポートの設定」

「Cisco IOS リリース 12.3(14)T、12.2(33)S 以降のリリースでの複数のトラッキング オプションに対する PBR サポートの設定」

Cisco IOS リリース 12.3(11)T、12.2(25)S 以前のリリースでの複数のトラッキング オプションに対する PBR サポートの設定

複数のトラッキング オプションに対する PBR サポートを設定するには、次の作業を実行します。この作業では、ルート マップを作成および設定し、トラッキング対象オブジェクトの到達可能性を確認します。

前提条件

この作業では、Cisco IOS リリース 12.3(11)T、12.2(25)S 以前のリリースを実行中のネットワーキング デバイスが必要です。

手順の概要

1. enable

2. configure terminal

3. rtr operation-number

4. type echo protocol protocol-type target [ source-ipaddr ip-address ]

5. exit

6. rtr schedule operation-number [ life { forever | seconds }] [ start-time { hh : mm [ : ss ] [ month day | day month ] | pending | now | after hh : mm : ss }] [ ageout seconds ]

7. track object-number rtr entry-number [ reachability ]

8. delay { up seconds [ down seconds ] | [ up seconds ] down seconds }

9. exit

10. interface type number

11. ip address ip-address mask [ secondary ]

12. ip policy route-map map-tag

13. exit

14. route-map map-tag [ permit | deny ] [ sequence-number ]

15. set ip next-hop verify-availability [ next-hop-address sequence track object ]

16. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

rtr operation-number

 

Router(config)# rtr 1

SAA RTR コンフィギュレーション モードを開始し、SAA 動作を設定します。

ステップ 4

type echo protocol protocol-type target [ source-ipaddr ip-address ]

 

Router(config-rtr)# type echo protocol ipicmpecho 10.1.1.10

SAA エンドツーエンド エコー応答時間プローブ動作を設定します。

ステップ 5

exit

 

Router(config-rtr)# exit

SAA RTR コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 6

rtr schedule operation-number [ life { forever | seconds }] [ start-time { hh : mm [ : ss ] [ month day | day month ] | pending | now | after hh : mm : ss }] [ ageout seconds ]

 

Router(config)# rtr schedule 1 life forever start-time now

SAA 動作の時間パラメータを設定します。

ステップ 7

track object-number rtr entry-number [ reachability ]

 

Router(config)# track 123 rtr 1 reachability

Response Time Reporter(RTR)オブジェクトの到達可能性をトラッキングし、トラッキング コンフィギュレーション モードを終了します。

ステップ 8

delay { up seconds [ down seconds ] | [ up seconds ] down seconds }

 

Router(config-track)# delay up 60 down 30

(任意)トラッキング対象オブジェクトの通信状態変化の遅延時間(秒)を指定します。

ステップ 9

exit

 

Router(config-track)# exit

トラッキング コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 10

interface type number

 

Router(config)# interface ethernet 0

インターフェイス タイプおよびインターフェイス番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 11

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.1.1.11 255.0.0.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを指定します。

IPv4 アドレスの設定手順については、『 Cisco IOS IP Addressing Services Configuration Guide 』の「 Configuring IPv4 Addresses 」の章を参照してください。

ステップ 12

ip policy route-map map-tag

 

Router(config-if)# ip policy route-map alpha

ポリシー ルーティングをイネーブルにし、ポリシー ルーティングに使用するルート マップを指定します。

ステップ 13

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 14

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map alpha

ルート マップを指定し、ルートマップ コンフィギュレーション モードを開始します。

ステップ 15

set ip next-hop verify-availability [ next-hop-address sequence track object ]

 

Router(config-route-map)# set ip next-hop verify-availability 10.1.1.1 10 track 123

ルート マップを設定し、トラッキング対象オブジェクトの到達可能性を確認します。

ステップ 16

end

 

Router(config-route-map)# end

ルートマップ コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

Cisco IOS リリース 12.3(14)T、12.2(33)S 以降のリリースでの複数のトラッキング オプションに対する PBR サポートの設定

複数のトラッキング オプションに対する PBR サポートを設定するには、次の作業を実行します。この作業では、ルート マップを作成および設定し、トラッキング対象オブジェクトの到達可能性を確認します。

前提条件

この作業では、Cisco IOS リリース 12.3(14)T、12.2(33)SXH 以降のリリースを実行中のネットワーキング デバイスが必要です。

手順の概要

1. enable

2. configure terminal

3. ip sla monitor operation-number

4. type echo protocol ipIcmpEcho { destination-ip-address | destination-hostname } [ source-ipaddr { ip-address | hostname } | source-interface interface-name ]

5. exit

6. ip sla monitor schedule operation-number [ life { forever | seconds }] [ start-time { hh : mm [ : ss ] [ month day | day month ] | pending | now | after hh : mm : ss }] [ ageout seconds ] [ recurring ]

7. track object-number rtr entry-number [ reachability | state ]

8. delay { up seconds [ down seconds ] | [ up seconds ] down seconds }

9. exit

10. interface type number

11. ip address ip-address mask [ secondary ]

12. ip policy route-map map-tag

13. exit

14. route-map map-tag [ permit | deny ] [ sequence-number ]

15. set ip next-hop verify-availability [ next-hop-address sequence track object ]

16. end

17. show track object-number

18. show route-map [ map-name | all | dynamic ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip sla monitor operation-number

 

Router(config)# ip sla monitor 1

Cisco IOS IP サービス レベル契約(SLA)動作設定を開始し、IP SLA モニタ コンフィギュレーション モードを開始します。

ステップ 4

type echo protocol ipIcmpEcho { destination-ip-address | destination-hostname } [ source-ipaddr { ip-address | hostname } | source-interface interface-name ]

 

Router(config-sla-monitor)# type echo protocol ipIcmpEcho 10.1.1.1

IP SLA Internet Control Message Protocol(ICMP)エコー プローブ動作を設定します。

ステップ 5

exit

 

Router(config-sla-monitor)# exit

IP SLA モニタ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 6

ip sla monitor schedule operation-number [ life { forever | seconds }] [ start-time { hh : mm [ : ss ] [ month day | day month ] | pending | now | after hh : mm : ss }] [ ageout seconds ] [ recurring ]

 

Router(config)# ip sla monitor schedule 1 life forever start-time now

単一の Cisco IOS IP SLA 動作のスケジューリング パラメータを設定します。

この例では、IP SLA 動作の時間パラメータを設定します。

ステップ 7

track object-number rtr entry-number [ reachability | state ]

 

Router(config)# track 123 rtr 1 reachability

Response Time Reporter(RTR)オブジェクトの到達可能性をトラッキングし、トラッキング コンフィギュレーション モードを終了します。

ステップ 8

delay { up seconds [ down seconds ] | [ up seconds ] down seconds }

 

Router(config-track)# delay up 60 down 30

(任意)トラッキング対象オブジェクトの通信状態変化の遅延時間(秒)を指定します。

ステップ 9

exit

 

Router(config-track)# exit

トラッキング コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 10

interface type number

 

Router(config)# interface serial 2/0

インターフェイス タイプおよびインターフェイス番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 11

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 192.168.1.1 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを指定します。

IPv4 アドレスの設定手順については、『 Cisco IOS IP Addressing Services Configuration Guide 』の「 Configuring IPv4 Addresses 」の章を参照してください。

この例では、着信インターフェイスの IP アドレスを指定します。これは、ポリシー ルーティングがイネーブル化されるインターフェイスです。

ステップ 12

ip policy route-map map-tag

 

Router(config-if)# ip policy route-map alpha

ポリシー ルーティングをイネーブルにし、ポリシー ルーティングに使用するルート マップを指定します。

ステップ 13

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 14

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map alpha

ルート マップを指定し、ルートマップ コンフィギュレーション モードを開始します。

ステップ 15

set ip next-hop verify-availability [ next-hop-address sequence track object ]

 

Router(config-route-map)# set ip next-hop verify-availability 10.1.1.1 10 track 123

ルート マップを設定し、トラッキング対象オブジェクトの到達可能性を確認します。

この例では、デバイスが到達可能である場合、シリアル インターフェイス 2/0 で受信したパケットを 10.1.1.1 へ転送するようにポリシーを設定します。

ステップ 16

end

 

Router(config-route-map)# end

ルートマップ コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

ステップ 17

show track object-number

 

Router# show track 123

(任意)トラッキング情報を表示します。

設定を確認するには、このコマンドを使用します。この作業の「例」の項のディスプレイ出力を参照してください。

ステップ 18

show route-map [ map-name | all | dynamic ]

 

Router# show route-map alpha

(任意)ルート マップ情報を表示します。

この例では、「alpha」という名前のルート マップに関する情報を表示します。この作業の「例」の項のディスプレイ出力を参照してください。

次の show track コマンドからの出力は、トラッキング対象オブジェクト 123 が到達可能であることを示しています。

Router# show track 123
 
Track 123
Response Time Reporter 1 reachability
Reachability is Up
2 changes, last change 00:00:33
Delay up 60 secs, down 30 secs
Latest operation return code: OK
Latest RTT (millisecs) 20
Tracked by:
ROUTE-MAP 0
 

次の show route-map コマンドからの出力は、この作業で設定した「alpha」という名前のルート マップに関する情報を示しています。

Router# show route-map alpha
 
route-map alpha, permit, sequence 10
Match clauses:
Set clauses:
ip next-hop verify-availability 10.1.1.1 10 track 123 [up]
Policy routing matches: 0 packets, 0 bytes

複数のトラッキング オプションに対する PBR サポートの設定例

ここでは、次の設定例について説明します。

「Cisco IOS リリース 12.3(11)T、12.2(25)S 以前のリリースでの複数のトラッキング オプションに対する PBR サポートの設定:例」

「Cisco IOS リリース 12.3(14)T、12.2(33)S 以降のリリースでの複数のトラッキング オプションに対する PBR サポートの設定:例」

Cisco IOS リリース 12.3(11)T、12.2(25)S 以前のリリースでの複数のトラッキング オプションに対する PBR サポートの設定:例

次の例では、Cisco IOS リリース 12.3(11)T、12.2(25)S 以前のリリースを実行しているルータ上で、PBR 用にオブジェクト トラッキングを設定しています。

イーサネット インターフェイス 0 で受信したパケットを、デバイスが到達可能である(ping に応答する)場合に限り、10.1.1.1 へ転送するポリシーを設定します。10.1.1.1 がアップしていない場合は、10.2.2.2 へパケットを転送します。10.2.2.2 も到達不可能な場合ポリシー ルーティングは失敗し、ルーティング テーブルに従ってパケットをルーティングします。

リモート デバイスに対して ping を実行するため、2 つの Response Time Reporter (RTR) を設定して、RTR をトラッキングします。ポリシー ルーティングがトラッキング対象 RTR の状態をモニタし、それらの状態に基づいて転送を決定します。

! Define and start the RTRs.
rtr 1
type echo protocol ipicmpecho 10.1.1.1
rtr schedule 1 start-time now life forever
!
rtr 2
type echo protocol ipicmpecho 10.2.2.2
rtr schedule 2 start-time now life forever
!
! Track the RTRs.
track 123 rtr 1 reachability
track 124 rtr 2 reachability
!
! Enable policy routing on the incoming interface.
interface ethernet 0
ip address 10.4.4.4 255.255.255.0
ip policy route-map beta
!
! 10.1.1.1 is via this interface.
interface ethernet 1
ip address 10.1.1.254 255.255.255.0
!
! 10.2.2.2 is via this interface.
interface ethernet 2
ip address 10.2.2.254 255.255.255.0
!
! Define a route map to set the next-hop depending on the state of the tracked RTRs.
route-map beta
set ip next-hop verify-availability 10.1.1.1 10 track 123
set ip next-hop verify-availability 10.2.2.2 20 track 124

Cisco IOS リリース 12.3(14)T、12.2(33)S 以降のリリースでの複数のトラッキング オプションに対する PBR サポートの設定:例

次の例では、Cisco IOS リリース 12.3(14)T、12.2(33)S 以降のリリースを実行しているルータ上で、PBR 用にオブジェクト トラッキングを設定しています。

イーサネット インターフェイス 0 で受信したパケットを、デバイスが到達可能である(ping に応答する)場合に限り、10.1.1.1 へ転送するポリシーを設定します。10.1.1.1 がアップしていない場合は、10.2.2.2 へパケットを転送します。10.2.2.2 も到達不可能な場合ポリシー ルーティングは失敗し、ルーティング テーブルに従ってパケットをルーティングします。

リモート デバイスに対して ping を実行するため、2 つの RTR を設定して、RTR をトラッキングします。ポリシー ルーティングがトラッキング対象 RTR の状態をモニタし、それらの状態に基づいて転送を決定します。

! Define and start the RTRs.
ip sla monitor 1
type echo protocol ipicmpecho 10.1.1.1
ip sla monitor schedule 1 start-time now life forever
!
ip sla monitor 2
type echo protocol ipicmpecho 10.2.2.2
ip sla monitor schedule 2 start-time now life forever
!
! Track the RTRs.
track 123 rtr 1 reachability
track 124 rtr 2 reachability
!
! Enable policy routing on the incoming interface.
interface ethernet 0
ip address 10.4.4.4 255.255.255.0
ip policy route-map beta
!
! 10.1.1.1 is via this interface.
interface ethernet 1
ip address 10.1.1.254 255.255.255.0
!
! 10.2.2.2 is via this interface.
interface ethernet 2
ip address 10.2.2.254 255.255.255.0
!
! Define a route map to set the next-hop depending on the state of the tracked RTRs.
route-map beta
set ip next-hop verify-availability 10.1.1.1 10 track 123
set ip next-hop verify-availability 10.2.2.2 20 track 124

その他の参考資料

ここでは、複数のトラッキング オプションに対する PBR サポート機能に関する関連資料について説明します。

関連資料

関連項目
参照先

Cisco IOS ソフトウェア内でのオブジェクト トラッキング

Cisco IOS IP Application Services Configuration Guide 』の「 Configuring Enhanced Object Tracking 」の章

IP アドレスの設定

Cisco IOS IP Addressing Services Configuration Guide 』の「 Configuring IPv4 Addresses 」の章

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

Cisco Support Web サイトには、豊富なオンライン リソースが提供されており、それらに含まれる資料やツールを利用して、トラブルシューティングやシスコ製品およびテクノロジーに関する技術上の問題の解決に役立てることができます。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト (http://www.cisco.com/techsupport)の、利用頻度の高いドキュメントを日本語で提供しています。

Japan テクニカル サポート Web サイトには、次の URL からアクセスしてください。http://www.cisco.com/jp/go/tac

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、このモジュールで説明した機能で導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS IP Routing Protocols Command Reference 』( http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_book.html )を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、 http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html にある『 Cisco IOS Master Command List, All Releases 』を参照してください。

set ip next-hop verify-availability

複数のトラッキング オプションに対する PBR サポートの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp からアクセスできます。Cisco.com のアカウントは必要ありません。


表 1には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 複数のトラッキング オプションに対する PBR サポートの機能情報

機能名
リリース
機能情報

複数のトラッキング オプションに対する PBR サポート

12.3(4)T
12.2(25)S
12.2(33)SXH

複数のトラッキング オプションに対する PBR サポート機能は、Cisco Discovery Protocol(CDP)を使ったオブジェクト トラッキングの機能を拡張し、追加の方法を使って、ポリシーベース ルーティング(PBR)処理でオブジェクトが使用可能かどうかを確認できます。確認方法として使用できるのは、Internet Control Message Protocol(ICMP)ping、User Datagram Protocol(UDP)ping、または HTTP GET です。

IP SLA での構文変更により、Cisco IOS リリース 12.2(33)SXH で、新しい作業と設定例が導入されました。

set ip next-hop verify-availability コマンドは、この機能によって導入または変更されました。