Cisco IOS IP ルーティング:プロトコル非依存コン フィギュレーション ガイド
IP ルーティング プロトコルに依存しない機能 の設定
IP ルーティング プロトコルに依存しない機能の設定
発行日;2012/01/31 | 英語版ドキュメント(2011/05/24 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

IP ルーティング プロトコルに依存しない機能の設定

機能情報の確認

プロトコルに依存しない機能のタスク リスト

可変長サブネット マスクの使用

スタティック ルートの設定

デフォルト ルートの指定

デフォルト ネットワークの指定

ラスト リゾート ゲートウェイの概要

最大パス数の変更

マルチインターフェイスの負荷分散設定

ルーティング情報の再配布

サポートされるメトリック変換の概要

ルーティング情報のフィルタリング

インターフェイスからのルーティング アップデートの防止

デフォルトのパッシブ インターフェイスの設定

ルーティング アップデートでのルートのアドバタイズの制御

ルーティング アップデート処理の制御

ルーティング情報発信元のフィルタリング

ポリシーベース ルーティングのイネーブル化

ファースト スイッチド ポリシー ルーティングのイネーブル化

ローカル ポリシー ルーティングのイネーブル化

NetFlow ポリシー ルーティングのイネーブル化

BGP による QoS ポリシー伝搬の設定

コミュニティ リストに基づいた QoS ポリシー伝搬の設定

自律システム パス アトリビュートに基づいた QoS ポリシー伝搬の設定

アクセス リストに基づいた QoS ポリシー伝搬の設定

BGP による QoS ポリシー伝搬のモニタリング

認証キーの管理

IP ネットワークのモニタリングとメンテナンス

IP ルーティング テーブルからのルートの消去

システムとネットワーク統計情報の表示

IP ルーティング プロトコルに依存しない設定の例

可変長サブネットマスク:例

ダイナミック プロトコルによるスタティック ルートの上書き:例

管理ディスタンス:例

スタティック ルーティングの再配布:例

EIGRP の再配布:例

RIP および EIGRP の再配布:例

単純な再配布:例

複雑な再配布:例

OSPF ルーティングとルートの再配布:例

基本的な OSPF 設定:例

内部ルータ、ABR、および ASBR の設定:例

複雑な OSPF 設定:例

デフォルト メトリック値の再配布:例

ルート マップ:例

パッシブ インターフェイス:例

デフォルトのパッシブ インターフェイス:例

ポリシーベース ルーティング:例

CEF によるポリシー ルーティング:例

BGP による QoS ポリシー伝搬の設定:例

キー管理:例

IP ルーティング プロトコルに依存しない機能の設定に関する機能情報

IP ルーティング プロトコルに依存しない機能の設定

この章では、IP ルーティング プロトコルに依存しない機能を設定する手順について説明します。この章に記載された IP ルーティング プロトコルに依存しないコマンドの詳細については、『 Cisco IOS IP Routing Protocols Command Reference 』を参照してください。この章に記載されたその他のコマンドに関するマニュアルを入手するには、コマンド リファレンスのマスター インデックスまたはオンライン検索を使用してください。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「IP ルーティング プロトコルに依存しない機能の設定に関する機能情報」を参照してください。

プラットフォームのサポートと Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

プロトコルに依存しない機能のタスク リスト

前出の章では、特定のルーティング プロトコルの設定について説明しました。オプションのプロトコルに依存しない機能を設定するには、次の項に記載されているタスクを実行します。

「可変長サブネット マスクの使用」

「スタティック ルートの設定」

「デフォルト ルートの指定」

「最大パス数の変更」

「マルチインターフェイスの負荷分散設定」

「ルーティング情報の再配布」

「ルーティング情報のフィルタリング」

「ポリシーベース ルーティングのイネーブル化」

「認証キーの管理」

「IP ネットワークのモニタリングとメンテナンス」

設定例については、「IP ルーティング プロトコルに依存しない設定の例」を参照してください。

可変長サブネット マスクの使用

Enhanced Interior Gateway Routing Protocol(EIGRP)、Intermediate System-to-Intermediate System(IS-IS)、Open Shortest Path First(OSPF)、Routing Information Protocol(RIP)バージョン 2、およびスタティック ルートは、可変長サブネット マスク(VLSM)をサポートします。VLSM により、異なるインターフェイスの同じネットワーク番号に別のマスクを使用できるため、IP アドレスを節約し、使用可能なアドレス レンジをより効率的に使用できます。ただし、VLSM を使用すると、ネットワーク管理者によるアドレスの割り当てや現行の管理も難しくなります。

VLSM および適切なアドレス割り当て方法の詳細については、RFC 1219 を参照してください。


) VLSM の使用決定については、慎重に検討してください。アドレス割り当ては間違えやすく、一般的に VLSM を使用するネットワークのモニタは複雑になります。



) VLSM を実装する最善の方法は、既存のアドレッシング計画を維持し、いくつかのネットワークを段階的に VLSM に移行してアドレス レンジを回復することです。VLSM の使用例については、「可変長サブネットマスク:例」を参照してください。


スタティック ルートの設定

スタティック ルートは、指定のパスを通るように発信元と宛先の間でパケットを移動させるユーザ定義のルートです。スタティック ルートは、ルータが特定の宛先へのルートを確立できない場合に重要になることがあります。また、ルーティングできないすべてのパケットを送るラスト リゾート ゲートウェイを指定する場合にも役立ちます。

スタティック ルートを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance] [name] [ permanent | track number] [ tag tag]

スタティック ルートを確立します。

スタティック ルートの設定例については、「ダイナミック プロトコルによるスタティック ルートの上書き:例」を参照してください。

スタティック ルートは、削除されるまでルータ設定に残ります( ip route グローバル コンフィギュレーション コマンドの no 形式を使用します)。ただし、管理ディスタンス値を慎重に割り当てることにより、ダイナミック ルーティング情報でスタティック ルートを上書きすることができます。それぞれのダイナミック ルーティング プロトコルには、デフォルトの管理ディスタンスがあります。デフォルトの管理ディスタンスは、 表 1 のとおりです。ダイナミック ルーティング プロトコルからの情報でスタティック ルートを上書きする場合は、スタティック ルートの管理ディスタンスがダイナミック プロトコルのものよりも大きいことを確認します。

 

表 1 ダイナミック ルーティング プロトコルのデフォルトの管理ディスタンス

ルート送信元
デフォルト ディスタンス

接続されているインターフェイス

0

スタティック ルート

1

EIGRP サマリー ルート

5

外部 BGP

20

内部 EIGRP

90

IGRP

100

OSPF

110

IS-IS

115

RIP

120

EGP

140

ODR

160

外部 EIGRP

170

内部 BGP

200

不明

255

インターフェイスを指定したスタティック ルートは、 redistribute static ルータ コンフィギュレーション コマンドが RIP、EIGRP、およびその他のダイナミック ルーティング プロトコルに指定されているかどうかに関わらず、それらのルーティング プロトコルを介してアドバタイズされます。インターフェイスを指定したスタティック ルートは、ルーティング テーブルで接続済みと見なされ、スタティックな性質を失うため、これらのスタティック ルートがアドバタイズされます。ただし、 network コマンドで定義されたネットワークではないインターフェイスへのスタティック ルートを定義する場合、 redistribute static コマンドがこれらのプロトコルに指定されない限り、ダイナミック ルーティング プロトコルはルートをアドバタイズしません。

インターフェイスがダウンすると、そのインターフェイスを通るすべてのスタティック ルートが IP ルーティング テーブルから削除されます。また、スタティック ルートの転送先ルータ アドレスに指定されたアドレスに有効なネクスト ホップをソフトウェアが検出できない場合も、IP ルーティング テーブルからスタティック ルートが削除されます。

デフォルト ルートの指定

ルータは、他のすべてのネットワークへのルートを判断できない場合があります。機能が揃ったルーティング機能を実現するには、いくつかのルータをスマート ルータとして使用し、残りのルータにスマート ルータへのデフォルト ルートを指定する方法が一般的です (スマート ルータにはインターネットワーク全体のルーティング テーブル情報があります)。これらのデフォルト ルートは、ダイナミックに渡すか、個々のルータに設定できます。

ほとんどのダイナミック内部ルーティング プロトコルは、スマート ルータにダイナミック デフォルト情報を生成させるメカニズムを備えています。この情報は、他のルータに渡されます。

デフォルト ネットワークの指定

指定されたデフォルト ネットワークに直接接続されているインターフェイスがルータにある場合、そのデバイスで動作しているダイナミック ルーティング プロトコルがデフォルト ルートを生成(発信)します。RIP の場合、ルータが擬似ネットワーク 0.0.0.0. をアドバタイズします。EIGRP の場合、ネットワーク自体がアドバタイズされ、外部ルートというフラグが付けられます。

また、ネットワークのデフォルトを生成しているルータには、そのルータ自体のデフォルトが必要な場合があります。ルータがそれ自体のデフォルトを生成できる方法の 1 つに、適切なデバイスを介してネットワーク 0.0.0.0 へのスタティック ルートを指定する方法があります。

ネットワークへのスタティック ルートをスタティック デフォルト ルートとして定義するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# ip default-network network-number

デフォルト ネットワークを指定します。

ラスト リゾート ゲートウェイの概要

ダイナミック ルーティング プロトコルを介してデフォルト情報が渡されている場合、それ以上の設定は必要ありません。システムは、最適なデフォルト ネットワークをデフォルト ルートとして選択するためにルーティング テーブルを定期的にスキャンします。RIP の場合、選択肢はネットワーク 0.0.0.0 しかありません。EIGRP の場合、システム デフォルトの候補となるネットワークがいくつか存在します。Cisco IOS ソフトウェアは、管理ディスタンスとメトリックの両方の情報を使用して、デフォルト ルート(ラスト リゾート ゲートウェイ)を判断します。選択されたデフォルト ルートは、 show ip route EXEC コマンドのラスト リゾート ゲートウェイ表示に表示されます。

ダイナミック デフォルト情報がソフトウェアに渡されていない場合、デフォルト ルートの候補は ip default-network グローバル コンフィギュレーション コマンドで指定されます。この場合、 ip default-network コマンドは未接続ネットワークを引数として取ります。このネットワークが任意の発信元(ダイナミックまたはスタティック)からルーティング テーブルに示されると、デフォルト ルートの候補としてフラグが付けられ、デフォルト ルートとして選択できます。

ルータにデフォルト ネットワーク上のインターフェイスがないものの、ネットワークへのルートがある場合、このネットワークはデフォルト パスの候補と見なされます。候補のルートは検査され、管理ディスタンスおよびメトリックに基づき、最適なルートが選択されます。最適なデフォルト パスへのゲートウェイが、ラスト リゾート ゲートウェイになります。

最大パス数の変更

デフォルトでは、ほとんどの IP ルーティング プロトコルでルーティング テーブルに最大 4 つのパラレル ルートがインストールされます。スタティック ルートには、常に 6 つのルートがインストールされます。BGP は例外で、デフォルトでは宛先へのパスが 1 つ(最良パス)しか許可されていません。ただし、BGP は、等コストおよび不等コスト マルチパスのロード シェアリングを使用するように設定できます。詳細については、 『BGP Multipath Load Sharing for Both eBGP and iBGP in an MPLS-VPN』 の機能を参照してください。

ルーティング テーブルへのインストールを設定できるパラレル ルートの数は、インストールされている Cisco IOS ソフトウェアのバージョンによって変わります。許可されるパラレル パスの最大数を変更するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# maximum-paths number-paths

ルーティング テーブルで許可されるパラレル パスの最大数を設定します。

マルチインターフェイスの負荷分散設定

マルチインターフェイスの負荷分散により、複数のインターフェイスにわたって同じ宛先に向かうトラフィックを効率的に制御できます。 traffic-share min ルータ コンフィギュレーション コマンドでは、同じ宛先に複数のパスを使用できる場合、最小メトリックのパスだけがルーティング テーブルにインストールされるように指定します。許可されるパスの数が 7 つ以上になることはありません。ダイナミック ルーティング プロトコルの場合、パスの数は maximum-paths ルータ コンフィギュレーション コマンドによって制御します。スタティック ルートの発信元には、常に 6 つのパスをインストールできます。それよりも多くのパスを利用できる場合、余分なパスは廃棄されます。インストールされたいくつかのパスがルーティング テーブルから削除されると、保留中のルートが自動的に追加されます。

キーワード across-interfaces を指定して traffic-share min コマンドを使用すると、可能な限り多くの異なるインターフェイスを使用して同じ宛先にトラフィックを送る試行が行われます。パスの最大数に達していて新しいパスがインストールされた場合、ルータはインストールされたパスを比較します。たとえば、パス X がパス Y と同じインターフェイスを参照し、新しいパスが異なるインターフェイスを使用する場合、パス X は削除され、新しいパスがインストールされます。

複数のインターフェイスにわたる等コスト パスに対して、不等コストの複数のルート間に分散されるトラフィックを設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

コマンド
目的

Router(config-router)# traffic-share min across-interfaces

等コスト パスを持つ複数のインターフェイスに対して、マルチインターフェイスの負荷分散を設定します。

ルーティング情報の再配布

Cisco IOS ソフトウェアは、複数のルーティング プロトコルを同時に実行するだけでなく、あるルーティング プロトコルから別のルーティング プロトコルに情報を再配布できます。たとえば、RIP を使用して EIGRP 派生のルートを再アドバタイズしたり、EIGRP プロトコルを使用してスタティック ルートを再アドバタイズしたりするようにルータを設定できます。あるルーティング プロトコルから別のルーティング プロトコルへの再配布は、すべての IP ベース ルーティング プロトコルで設定できます。

また、2 つのドメイン間でルート マップを設定することにより、ルーティング ドメイン間でルートの再配布を条件に応じて制御することもできます。ルート マップは、permit および deny ステートメント、match および set 句、およびシーケンス番号を使用して設定されるルートまたはパケット フィルタです。

次の 4 つの表は、ルートの再配布に関連するタスクを表します。再配布はプロトコルに依存しない機能ですが、 match および set コマンドのいくつかは特定のプロトコルに固有のものです。

再配布用にルート マップを定義するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# route-map map-tag [ permit | deny ] [ sequence-number ]

あるルーティング プロトコルを別のルーティング プロトコルに再配布するための条件を定義します。

1 つまたは複数の match コマンドおよび 1 つまたは複数の set コマンドを、ルート マップ コンフィギュレーション モードで設定します。 match コマンドがない場合、すべてが一致します。 set コマンドがない場合、設定アクションは実行されません。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布するための条件を定義するには、必要に応じて、ルート マップ コンフィギュレーション モードで次のコマンドを少なくとも 1 つ使用します。

 

コマンド
目的

Router(config-route-map)# match as-path path-list-number

BGP 自律システム パスのアクセス リストに一致します。

Router(config-route-map)# match community {standard-list-number | expanded-list-number | community-list-name [ exact ]}

BGP コミュニティに一致します。

Router(config-route-map)# match ip address {access-list-number [access-list-number... | access-list-name...] | access-list-name [access-list-number...| access-list-name] | prefix-list prefix-list-name [prefix-list-name...]}

標準アクセス リスト、拡張アクセス リスト、またはプレフィクス リストによって許可されている宛先ネットワーク番号アドレスを持つすべてのルートに一致します。または、パケットのポリシー ルーティングを実行します。

Router(config-route-map)# match metric metric-value

指定したメトリックを持つルートに一致します。

Router(config-route-map)# match ip next-hop { access-list-number | access-list-name } [ access-list-number | access-list-name ]

指定したアクセス リストのいずれかによって渡されたネクスト ホップ ルータ アドレスに一致します。

Router(config-route-map)# match tag tag-value [ tag-value ]

指定したタグの値に一致します。

Router(config-route-map)# match interface interface- type interface-number [interface- type interface-number ]

指定したインターフェイスの 1 つを起点とする指定のネクスト ホップ ルートに一致します。

Router(config-route-map)# match ip route-source { access-list-number | access-list-name } [ access-list-number | access-list-name ]

アドバタイズされた指定のアクセスリストによって指定したアドレスに一致します。

Router(config-route-map)# match route-type { local | internal | external [ type-1 | type-2 ] | level-1 | level-2 }

指定したルートのタイプに一致します。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布するための条件を定義するには、必要に応じて、ルート マップ コンフィギュレーション モードで次の set コマンドを少なくとも 1 つ使用します。

 

コマンド
目的

Router(config-route-map)# set community { community-number [ additive ] [ well-known ]| none }

BGP コミュニティ アトリビュートを設定します。

Router(config-route-map)# set dampening halflife reuse suppress max-suppress-time

BGP ルート ダンプニング パラメータを設定します。

Router(config-route-map)# set local-preference number-value

BGP ローカル プリファレンス値をパスに割り当てます。

Router(config-route-map)# set weight weight

ルーティング テーブルの BGP ウェイトを指定します。

Router(config-route-map)# set origin { igp | egp as-number | incomplete }

ルート オリジン コードを設定します。

Router(config-route-map)# set as-path { tag | prepend as-path-string }

BGP の自律システム パスを変更します。

Router(config-route-map)# set next-hop next-hop

ネクスト ホップのアドレスを指定します。

Router(config-route-map)# set automatic-tag

タグ テーブルの自動計算をイネーブルにします。

Router(config-route-map)# set level { level-1 | level-2 | level-1-2 | stub-area | backbone }

ルートをインポートするエリアを指定します。

Router(config-route-map)# set metric metric-value

再配布されるルートのメトリック値を設定します(EIGRP 以外のすべてのプロトコル)。

Router(config-route-map)# set metric bandwidth delay reliability load mtu

再配布されるルートを指定するためのメトリック値を設定します(EIGRP のみ)。

Router(config-route-map)# set metric-type { internal | external | type-1 | type-2 }

再配布されるルートに割り当てられるメトリックのタイプを設定します。

Router(config-route-map)# set metric-type internal

ネクスト ホップの内部ゲートウェイ プロトコル(IGP)メトリックと一致するように、外部 BGP ネイバーにアドバタイズされたプレフィクスの Multi Exit Discriminator(MED)値を設定します。

Router(config-route-map)# set tag tag-value

再配布されるルートに適用するタグの値を設定します。

BGP ルート マップ設定タスクの例と設定例については、「 Connecting to a Service Provider Using External BGP 」の章を参照してください。BGP コミュニティとルート マップの例については、「 Configuring BGP Cost Community 」の機能を参照してください。

あるルーティング ドメインから別のルーティング ドメインにルートを配布する、およびルートの再配布を制御するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-router)# redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ metric metric-value ] [ metric-type type-value ] [ match internal | external type-value ] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布します。

ステップ 2

Router(config-router)# default-metric number

現在のルーティング プロトコルが、再配布されるすべてのルートに同じメトリック値を使用するようにします(BGP、OSPF、RIP)。

ステップ 3

Router(config-router)# default-metric bandwidth delay reliability loading mtu

EIGRP ルーティング プロトコルが、EIGRP 以外の再配布されるすべてのルートに同じメトリック値を使用するようにします。

ステップ 4

Router(config-router)# no default-information { in | out }

デフォルトではイネーブルになっている EIGRP プロセス間のデフォルト情報の再配布をディセーブルにします。

あるルーティング プロトコルのメトリックは、必ずしも別のルーティング プロトコルに変換されるわけではありません。たとえば、RIP メトリックはホップ カウントですが、EIGRP メトリックは 5 つのメトリック値の組み合わせです。このような場合、再配布されるルートにダイナミック メトリックが割り当てられます。この場合の再配布は、ルーティング ループを防ぐために、インバウンド フィルタリングと共に一貫して慎重に適用する必要があります。

redistribute コマンドに設定したオプションを削除するには、期待する結果が得られるように redistribute コマンドの no 形式を慎重に使用する必要があります。

 

コマンド
目的

ステップ 1

Router(config-router)# no redistribute connected metric 1000 subnets

redistribute connected metric 1000 subnets コマンドから connected metric 1000 subnets オプションを削除し、 redistribute connected コマンドを設定に残します。

ステップ 2

Router(config-router)# no redistribute connected metric 1000

redistribute connected metric 1000 subnets コマンドから metric 1000 オプションを削除し、 redistribute connected subnets コマンドを設定に残します。

ステップ 3

Router(config-router)# no redistribute connected subnets

redistribute connected metric 1000 subnets コマンドから subnets オプションを削除し、 redistribute connected metric 1000 コマンドを設定に残します。

ステップ 4

Router(config-router)# no redistribute connected

redistribute connected コマンドと redistribute connected コマンドに設定されたすべてのオプションを設定から削除します。

サポートされるメトリック変換の概要

ここでは、ルーティング プロトコル間でサポートされる自動メトリック変換について説明します。次の説明では、メトリック変換に代わるデフォルト再配布メトリックが定義されていないことを前提とします。

RIP は、自動的にスタティック ルートを再配布し、スタティック ルートに 1 のメトリックを割り当てます(直接接続されます)。

BGP は、通常、ルーティング アップデートでメトリックを送信しません。

スタティック ルートと関連のインターフェイスが EIGRP ネットワーク ステートメントで扱われる限り、EIGRP は他の EIGRP ルートの自律システムから自動的にスタティック ルートを再配布できます。EIGRP は、スタティック ルートに対して、直接接続として指定するメトリックを割り当てます。EIGRP は、他の自律システムの EIGRP アップデートから派生したルートのメトリックを変更しません。

デフォルト メトリックが設定されている限り、すべてのプロトコルが他のルーティング プロトコルからルートを再配布できることに注意してください。

ルーティング情報のフィルタリング

ルーティング プロトコル情報をフィルタリングするには、次の項のタスクを実行します。最初に記載されているタスクは必須です。その他はオプションです。

「インターフェイスからのルーティング アップデートの防止」

「ルーティング アップデートでのルートのアドバタイズの制御」

「ルーティング アップデート処理の制御」

「ルーティング情報発信元のフィルタリング」


) ルートが OSPF プロセス間で再配布される場合、OSPF メトリックは保持されません。


インターフェイスからのルーティング アップデートの防止

ローカル ネットワーク上の他のルータがダイナミックにルートを学習しないようにするには、ルーティング アップデート メッセージがルータ インターフェイスから送信されないようにします。ルーティング アップデート メッセージがルータ インターフェイスから送信されないようにすると、インターフェイスの他のシステムはダイナミックにルートを学習しなくなります。この機能は、BGP を除くすべての IP ベース ルーティング プロトコルに適用されます。

OSPF と IS-IS の動作は少し異なります。OSPF の場合、パッシブに指定したインターフェイス アドレスが OSPF ドメインのスタブ ネットワークとして表示されます。OSPF ルーティング情報は、指定されたルータ インターフェイスから送受信されません。IS-IS の場合、指定した IP アドレスはインターフェイス上で IS-IS を実際に実行することなくアドバタイズされます。

指定したインターフェイスからのルーティング アップデートを防止するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# passive-interface interface-type interface-number

指定されたインターフェイスを通したルーティング アップデートの送信を抑制します。

パッシブ インターフェイスの設定例については、「パッシブ インターフェイス:例」を参照してください。

デフォルトのパッシブ インターフェイスの設定

インターネット サービス プロバイダー(ISP)や大規模な企業ネットワークでは、多くのディストリビューション ルータに 200 を超えるインターフェイスがあります。デフォルトのパッシブ インターフェイス機能の導入前には、これらのインターフェイスからルーティング情報を取得するための方法が 2 つありました。

バックボーン インターフェイスで OSPF などのルーティング プロトコルを設定し、接続されたインターフェイスを再配布する。

すべてのインターフェイスでルーティング プロトコルを設定し、手動でそれらのほとんどをパッシブに設定する。

1 つめの方法の場合、ネットワーク オペレータは、再配布が行われるルータ レベルでタイプ 5 リンクステート アドバタイズメント(LSA)を常に集約できるわけではありません。そのため、多くのタイプ 5 LSA がドメインでフラッディングされる可能性があります。

2 つめの方法では、多くのタイプ 1 LSA がエリアにフラッディングされる可能性があります。エリア境界ルータ(ABR)は、タイプ 1 LSA のそれぞれに対してタイプ 3 LSA を生成し、それらをバックボーンにフラッディングします。ただし、ABR レベルで固有の集約を実行でき、このとき、バックボーンにはサマリー ルートが 1 つだけ挿入されます。これにより、処理のオーバーヘッドが削減されます。

この問題に対する従来の解決策は、すべてのインターフェイスにルーティング プロトコルを設定し、隣接させないインターフェイスに手動で passive-interface ルータ コンフィギュレーション コマンドを設定することでした。しかし、一部のネットワークでは、この解決策では 200 またはそれ以上のパッシブ インターフェイス ステートメントをコーディングするということになります。デフォルト パッシブ インターフェイス機能を使用すると、 passive-interface default コマンドを 1 つ使用するだけでデフォルトですべてのインターフェイスをパッシブに設定でき、その後、 no passive-interface コマンドを使用して隣接させる個々のインターフェイスを設定することで、この問題を解決できます。

デフォルト パッシブ インターフェイス機能により、ディストリビューション ルータの設定が簡素化され、ネットワーク マネージャは大規模な ISP ネットワークおよび企業ネットワークでインターフェイスからルーティング情報を取得できます。

デフォルトですべてのインターフェイスをパッシブに設定してから、隣接させる必要があるインターフェイスだけをアクティブにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router protocol

ネットワークのルーティング プロトコルを設定します。

ステップ 2

Router(config-router)# passive-interface default

デフォルトですべてのインターフェイスをパッシブに設定します。

ステップ 3

Router(config-router)# no passive-interface interface-type

隣接させる必要があるインターフェイスだけをアクティブにします。

ステップ 4

Router(config-router)# network network-address [ options ]

ルーティング プロセスのネットワーク リストを指定します。 network-address 引数は、ドット付き 10 進表記の IP アドレス(172.24.101.14 など)です。

デフォルトのパッシブ インターフェイスの例については、「デフォルトのパッシブ インターフェイス:例」を参照してください。

ネットワーク上のインターフェイスがパッシブに設定されているかどうかを確認するには、 show ip ospf interface コマンドなどのネットワーク モニタリング コマンドを入力するか、 show ip interface コマンドなどのコマンドを使用してアクティブに設定したインターフェイスを確認します。

ルーティング アップデートでのルートのアドバタイズの制御

他のルータが 1 つまたは複数のルートを学習しないように、ルーティング アップデートでのルートのアドバタイズを抑制できます。ルート アップデートでルートを抑制すると、他のルータは 1 つまたは複数のルートの特定デバイスの詳細を学習できません。OSPF では、インターフェイス名を指定できません。OSPF に使用する場合、この機能は外部ルートにのみ適用されます。

ルーティング アップデートでのルートのアドバタイズを抑制するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# distribute-list { access-list-number | access-list-name } out [ interface-name | routing-process | as-number ]

アクセス リストに示された処理に応じて、ルートがルーティング アップデートでアドバタイズされることを許可または拒否します。

ルーティング アップデート処理の制御

着信アップデートに示された特定ルートの処理を回避できます。この機能は、OSPF または IS-IS には適用されません。着信アップデートでのルートを抑制するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# distribute-list { access-list-number | access-list-name } in [interface- type interface-number ]

アップデートに示されたルートの処理を抑制します。

ルーティング情報発信元のフィルタリング

いくつかのルーティング情報が他の情報よりも正確な場合があるため、ルーティング情報発信元のフィルタリングにより、さまざまな発信元からのルーティング情報に優先順位を付けられます。 管理ディスタンス は、個々のルータやルータのグループなど、ルーティング情報発信元の信頼性を表す数値です。大規模なネットワークでは、一部のルーティング プロトコルとルータが、ルーティング情報発信元として他よりも信頼性が高い場合があります。また、複数のルーティング プロセスが同一の IP ルータで実行されている場合、同一ルートを複数のルーティング プロセスによってアドバタイズすることもできます。管理ディスタンス値を指定することにより、ルータでルーティング情報発信元をインテリジェントに区別できます。ルータは、ルーティング プロトコルの管理ディスタンスが最小のルートを常に選択します。

ルーティング情報発信元をフィルタリングするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-router)# distance ip-address wildcard- mask [ ip-standard-acl | ip-extended-acl | access-list-name ]

ルーティング情報発信元をフィルタリングします。

ネットワークごとに独自の要件があるため、管理ディスタンスの割り当てに関する一般的なガイドラインはありません。ネットワーク全体の管理ディスタンスの適切なマトリクスを判断する必要があります。表 1は、さまざまなルーティング情報発信元のデフォルトの管理ディスタンスです。

たとえば、EIGRP と RIP を使用するルータがあるとします。EIGRP から派生するルーティング情報を RIP から派生するルーティング情報よりも信頼すると仮定します。この例では、デフォルトの EIGRP 管理ディスタンスがデフォルトの RIP 管理ディスタンスよりも小さいため、ルータは EIGRP から派生する情報を使用して RIP から派生する情報を無視します。ただし、EIGRP から派生する情報の発信元が失われた場合(発信元ネットワークの停電など)、ルータは EIGRP から派生する情報が再提示されるまで RIP から派生する情報を使用します。

ルーティング情報発信元のフィルタリング例については、「管理ディスタンス:例」を参照してください。


) 管理ディスタンスを使用して、同じルーティング プロトコルを実行しているルータからのルーティング情報を格付けすることもできます。フォワーディング ループなど、整合性のないルーティング情報が生じる可能性があるため、管理ディスタンスのこの特定用途に不慣れな場合、この使用方法は推奨しません。



) ルートの重みは、distance コマンドでは設定できなくなりました。ルートの重みを設定するには、ルート マップを使用します。


ポリシーベース ルーティングのイネーブル化

ポリシーベース ルーティングは、宛先ルーティングよりも柔軟性に富んだパケット ルーティング メカニズムです。このプロセスでは、ルータはパケットをルート マップに照合してからルーティングします。ルート マップにより、どのパケットを次にどのルータにルーティングするのかが決定されます。特定のパケットを明らかに最短のパス以外の方法でルーティングする必要がある場合は、ポリシーベース ルーティングをイネーブルにします。ポリシーベース ルーティングを使用すると、同等アクセス、プロトコル依存ルーティング、発信元依存ルーティング、双方向対バッチ トラフィックに基づくルーティング、および専用リンクに基づくルーティングを実現できます。

ポリシーベース ルーティングをイネーブルにするには、ポリシーベース ルーティングに使用するルート マップを特定し、ルート マップを作成する必要があります。ルート マップ自体は、一致基準とそのすべての match 句が適合した場合の処理を指定します。これらのステップを次の作業手順で説明します。

インターフェイスでポリシーベース ルーティングをイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用することにより、ルータが使用するルート マップを指定します。宛先 IP アドレスがルータのインターフェイスの IP アドレスと同じ場合を除き、指定したインターフェイスに着信するパケットはポリシーベース ルーティングの対象になります。このコマンドにより、このインターフェイスに着信するすべてのパケットのファースト スイッチングはディセーブルになります。

 

コマンド
目的

Router(config-if)# ip policy route-map map-tag

ポリシー ルーティングに使用するルート マップを特定します。

ポリシーベース ルーティングに使用するルート マップを定義するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# route-map map-tag [ permit | deny ] [ sequence-number ]

パケットの出力先を制御するためのルート マップを定義します。

パケットをポリシーベース ルーティングするかどうかを学習するためにパケットを検査する基準を定義するには、ルート マップ コンフィギュレーション モードで次のコマンドのいずれかまたは両方を使用します。ルート マップに match 句がない場合は、すべてのパケットを指します。

 

コマンド
目的

Router(config-route-map)# match length minimum-length maximum-length

レイヤ 3 パケット長に一致します。

Router(config-route-map)# match ip address { access-list-number | access-list- name } [ access-list-number | access-list- name ]

1 つまたは複数の標準または拡張アクセス リストによって許可されている宛先 IP アドレスに一致します。

優先順位を設定し、一致基準に適合するパケットが出力される場所を指定するには、ルート マップ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-route-map)# set ip precedence { number | name }

IP ヘッダーで優先値を設定します。

ステップ 2

Router(config-route-map)# set ip next-hop ip-address [ ip-address ]

パケットをルーティングする先のネクストホップを指定します。

(注) ネクストホップは隣接するルータである必要があります。

ステップ 3

Router(config-route-map)# set interface interface-type interface-number [... interface- type interface-number ]

パケットの出力インターフェイスを指定します。

ステップ 4

Router(config-route-map)# set ip default next-hop ip-address [ ip-address ]

この宛先に明示ルートがない場合、パケットをルーティングする先のネクストホップを指定します。

コマンドでは、隣接するルータを指定する必要があります。

ステップ 5

Router(config-route-map)# set default interface interface-type interface-number [... interface- type interface-number ]

宛先の明示ルートがない場合、パケットの出力インターフェイスを指定します。


set ip next-hop コマンドと set ip default next-hop コマンドは似ていますが、動作順序が異なります。set ip next-hop コマンドを設定すると、システムでは最初にポリシー ルーティングが使用されてからルーティング テーブルが使用されます。set ip default next-hop を設定すると、最初にルーティング テーブルが使用されてから指定したネクストホップがポリシー ルーティングされます。


IP ヘッダーで優先順位を設定することにより、トラフィックが多い間、そのパケットを他のパケットよりも高い優先順位または低い優先順位で処理するかどうかが決定されます。デフォルトでは、Cisco IOS ソフトウェアはこの値を操作しません。ヘッダーは元々の優先値のままです。

ポリシーベース ルーティングがイネーブルの場合、IP ヘッダーの優先ビットをルータで設定できます。キューイング機能がイネーブルの場合、このようなヘッダーを含むパケットは、別のルータに到達すると優先設定に従って送信順に並べられます。キューイング機能がイネーブルでない場合、ルータは優先ビットに従いません。パケットは FIFO の順序で送信されます。

番号または名前を使用して、優先設定を変更できます。名前は RFC 791 に基づいていますが、変化しています。 set ip precedence ルート マップ コンフィギュレーション コマンドで値を使用して優先順位を決定するその他の機能をイネーブルにできます。 表 2 は、使用可能な番号とそれに対応する名前です。重要度の低いものから高いものの順に並んでいます。

 

表 2 IP precedence 値

番号
名称

0

routine

1

priority

2

immediate

3

flash

4

flash-override

5

Critical

6

internet

7

network

set コマンドは、相互に使用できます。前出の作業手順に示された順序で評価されます。使用可能なネクストホップは、インターフェイスを意味します。ローカル ルータは、ネクストホップと使用可能なインターフェイスを検出したら、パケットをルーティングします。

ポリシー ルート キャッシュのキャッシュ エントリを表示するには、 show ip cache policy コマンドを使用します。

ポリシーベース ルーティングをファースト スイッチドにする場合は、 「ファースト スイッチド ポリシー ルーティングのイネーブル化」 を参照してください。

ポリシー ルーティングの例については、「ポリシーベース ルーティング:例」を参照してください。

ファースト スイッチド ポリシー ルーティングのイネーブル化

IP ポリシー ルーティングは、ファースト スイッチドにすることもできます。ファースト スイッチド ポリシー ルーティング以前、ポリシー ルーティングはプロセス スイッチドだけでした。そのため、ほとんどのプラットフォームで、スイッチング レートは 1 秒あたり約 1,000 ~ 10,000 パケットでした。このレートは、多くの用途に対して十分な速度ではありませんでした。より高速でポリシー ルーティングを実行する必要があるユーザは、現在、ルータを減速させることなくポリシー ルーティングを実装できます。

ファースト スイッチド ポリシー ルーティングは、次の制限を除き、すべての match コマンドとほとんどの set コマンドをサポートします。

set ip default コマンドはサポートされない。

set interface コマンドはポイントツーポイント リンクでのみサポートされる(ルート マップに set interface コマンドで指定されたのと同じインターフェイスを使用するルート キャッシュ エントリがない場合)。また、プロセス レベルでは、インターフェイスが宛先への適切なパス上にあるかどうかを判断するために、ルーティング テーブルも参照されます。ファースト スイッチング中、ソフトウェアはこのチェックを実行しません。その代わり、パケットが一致する場合、ソフトウェアは単純にパケットを指定されたインターフェイスに送ります。

ファースト スイッチド ポリシー ルーティングを設定する前に、ポリシー ルーティングを設定する必要があります。ポリシー ルーティングのファースト スイッチングは、デフォルトではディセーブルになっています。ポリシー ルーティングをファースト スイッチドにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip route-cache policy

ポリシー ルーティングのファースト スイッチングをイネーブルにします。

ローカル ポリシー ルーティングのイネーブル化

ルータによって生成されるパケットは、通常、ポリシー ルーティングされません。このようなパケットのローカル ポリシー ルーティングをイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用して、ルータが使用するルート マップを指定します。そのルータを起点とするすべてのパケットが、ローカル ポリシー ルーティングの対象となります。

 

コマンド
目的

Router(config)# ip local policy route-map map-tag

ローカル ポリシー ルーティングに使用するルート マップを特定します。

ローカル ポリシー ルーティングに使用するルート マップがある場合にそれを表示するには、 show ip local policy コマンドを使用します。

NetFlow ポリシー ルーティングのイネーブル化

NetFlow ポリシー ルーティング(NPR)は、ポリシー ルーティングに NetFlow サービスを統合し、トラフィック エンジニアリングとトラフィック分類をイネーブルにします。NetFlow サービス により、課金、キャパシティ プランニング、およびリアルタイムのトラフィック フローでの情報モニタリングが実現されます。IP ポリシー ルーティングは、シスコ エクスプレス フォワーディング(CEF)、分散 CEF(dCEF)、および NetFlow で動作するようになりました。

サービス品質(QoS)とトラフィック エンジニアリング普及に伴って、ポリシー ルーティング機能への関心も高まっています。この機能を使用すると、IP precedence ビットとタイプ オブ サービス(ToS)ビットを(アクセス リストとパケット サイズに基づいて)選択的に設定し、事前に定義されたポリシーに基づいてパケットをルーティングできます。大規模でダイナミックなルーティング環境では、ポリシー ルーティングを適切に機能させることが重要です。分散サポートにより、お客様は分散アーキテクチャへの投資を活用できます。

NetFlow ポリシー ルーティングは、次のテクノロジーを利用します。

CEF。パケットをスイッチするときにルーティング テーブルではなく転送情報ベース(FIB)を参照し、デマンド キャッシング スキームのメンテナンス問題を解決します。

dCEF。デマンド キャッシング スキームのスケーラビリティとメンテナンス問題を解決します。

NetFlow。課金、キャパシティ プランニング、およびトラフィック モニタリング機能を実現します。

NPR の利点は次のとおりです。

NPR は新しいスイッチング サービスを利用する。CEF、dCEF、および NetFlow は、現在、ポリシー ルーティングを使用できます。

ポリシー ルーティングは CEF に統合されているので、広範囲および高速のインターフェイスで展開できる。

NPR の制限事項は次のとおりです。

NPR は CEF をサポートする Cisco IOS プラットフォームでのみ使用できる。

分散 FIB ベースのポリシー ルーティングは、dCEF をサポートするプラットフォームでのみ使用できる。

dCEF はシスコ検出プロトコル(CDP)データベースをサポートしないため、 set ip next-hop verify-availability コマンドは dCEF でサポートされない。

NetFlow ポリシー ルーティングを機能させるには、次の機能がすでに設定されている必要があります。

CEF、dCEF、または NetFlow

ポリシー ルーティング

CEF または dCEF を設定するには、『 Cisco IOS IP Switching Configuration Guide 』の「 Cisco Express Forwarding Overview 」の章を参照してください。NetFlow を設定するには、『 Cisco IOS NetFlow Configuration Guide 』の「 Cisco IOS NetFlow Overview 」の章を参照してください。

NPR は、デフォルトのポリシー ルーティング モードです。CEF、dCEF、または NetFlow でポリシー ルーティングをイネーブルにするために、その他の設定を行う必要はありません。これらの機能のいずれかがオンになるとすぐに、パケットは自動的に適切なスイッチング パスでポリシー ルーティングの対象になります。

新しいオプションのコンフィギュレーション コマンドが 1 つあります( set ip next-hop verify-availability )。このコマンドには、次の制限があります。

パケットごとに CDP データベース ルックアップのオーバーヘッドがあるため、多少パフォーマンスが低下する可能性がある。

CDP がインターフェイス上でイネーブルになっている必要がある。

直接接続されるネクストホップは、CDP がイネーブルにされたシスコ デバイスである必要がある。

CDP ネイバー データベースの依存関係により、コマンドは dCEF 設定とは連動しない。

ポリシー ルーティング自体は設定されているものとします。

ルータがパケットをネクストホップにポリシー ルーティングしていて、ネクストホップがダウンしている場合、ルータがネクストホップ(ダウン中)に対してアドレス解決プロトコル(ARP)を使用しようとして失敗します。この動作はいつまでも続く可能性があります。

このような状況の発生を防止するには、ルート マップを使用してネクストホップがルータの CDP ネイバーであることを確認してから、そのネクストホップにルーティングするようにルータを設定します。

いくつかのメディアまたはカプセル化は CDP をサポートしていない、またはルータ トラフィックを送っているのがシスコ デバイスではない場合があるため、この作業はオプションです。

ネクストホップが CDP ネイバーであることを確認してからネクストホップにポリシー ルーティングを試行するようにルータを設定するには、ルート マップ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-route-map)# set ip next-hop verify-availability

ルート マップのネクストホップがルータの CDP ネイバーであることをルータに確認させます。

上記のコマンドが設定され、ネクストホップが CDP ネイバーではない場合、ルータは次のネクストホップ(存在する場合)を検索します。ネクストホップがない場合、単純にパケットはポリシー ルーティングされません。

上記のコマンドが設定されない場合、パケットはポリシー ルーティングされるかルーティングされないままのいずれかになります。

いくつかのネクストホップだけの可用性を選択的に確認する場合、異なる基準(アクセス リストの照合またはパケット サイズの照合を使用)で異なるルート マップ エントリ(同じルート マップ名)を設定し、選択的に set ip next-hop verify-availability コンフィギュレーション コマンドを使用することもできます。

一般的には、既存のポリシー ルーティングと NetFlow の show コマンドを使用してこれらの機能をモニタリングします。これらの show コマンドの詳細について、ポリシー ルーティング コマンドについては『 Cisco IOS IP Routing Protocols Command Reference 』を、NetFlow コマンドについては『 Cisco IOS IP NetFlow Command Reference 』の該当する章を参照してください。

ルート プロセッサ(RP)またはバーサタイル インターフェイス プロセッサ(VIP)でルート マップのプロセッサ間通信(IPC)メッセージの統計情報を表示するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show route-map ipc

RP または VIP でルート マップの IPC メッセージの統計情報を表示します。

BGP による QoS ポリシー伝搬の設定

BGP による QoS ポリシー伝搬機能を使用すると、BGP コミュニティ リスト、BGP 自律システム パス、およびアクセス リストに基づいて IP precedence によってパケットを分類できます。パケットが分類されたら、専用アクセス レート(CAR)および重み付けランダム早期検出(WRED)など、その他の QoS 機能を使用してビジネス モデルに合うようにポリシーを指定および強化できます。

BGP によるポリシー伝搬を設定するには、次の基本作業を実行します。

BGP およびシスコ エクスプレス フォワーディング(CEF)または分散 CEF(dCEF)を設定する。BGP を設定するには、『 Cisco IOS IP Routing Protocols Configuration Guide 』を参照してください。CEF および dCEF を設定するには、『 Cisco IOS IP Switching Configuration Guide 』を参照してください。

ポリシーを定義する。

BGP 経由でポリシーを適用する。

BGP コミュニティ リスト、BGP 自律システム パス、またはアクセス リストを設定し、インターフェイスでポリシーをイネーブルにする。これらの作業の詳細については、以下の作業を参照してください。

ポリシーを使用するために CAR または WRED をイネーブルにする。CAR をイネーブルにするには、『 Cisco IOS Quality of Service Solutions Configuration Guide 』の「 Configuring Committed Access Rate 」の章を参照してください。WRED をイネーブルにするには、『 Cisco IOS Quality of Service Solutions Configuration Guide 』の「 Configuring Weighted Random Early Detection 」の章を参照してください。

ここでは、BGP コミュニティ リスト、BGP 自律システム パス、またはアクセス リストに基づいた QoS ポリシー伝搬の設定方法について説明します。すでに BGP および CEF または dCEF を設定しているものとします。

BGP による QoS ポリシー伝搬を設定するには、次の項で説明する作業を実行します。最初の 3 つは必須です。残りはオプションです。

「コミュニティ リストに基づいた QoS ポリシー伝搬の設定」

「自律システム パス アトリビュートに基づいた QoS ポリシー伝搬の設定」

「アクセス リストに基づいた QoS ポリシー伝搬の設定」

「BGP による QoS ポリシー伝搬のモニタリング」


) BGP による QoS ポリシー伝搬機能を使用するには、ルータで BGP および CEF または dCEF をイネーブルにする必要があります。bgp-policy コマンドをイネーブルにする ATM インターフェイスのサブインターフェイスでは、dCEF がサポートされないため、CEF モードを使用する必要があります。dCEF は、ルート スイッチ プロセッサ(RSP)ではなくバーサタイル インターフェイス プロセッサ(VIP)を使用してフォワーディング機能を実行します。


設定例については、「BGP による QoS ポリシー伝搬の設定:例」を参照してください。

コミュニティ リストに基づいた QoS ポリシー伝搬の設定

ここでは、コミュニティ リストを使用した BGP によるポリシー伝搬の設定方法について説明します。ここで示される作業は、オプションと表記されない限り必須です。すでにルータで CEF または dCEF および BGP を設定しているものとします。

コミュニティ リストに基づいて IP precedence を伝搬するようにルータを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# route-map route-map-name [ permit | deny [ sequence-number ]]

再配布を制御するためのルート マップを定義し、ルート マップ コンフィギュレーション モードに入ります。

ステップ 2

Router(config-route-map)# match community-list community-list-number [ exact ]

BGP コミュニティ リストを照合します。

ステップ 3

Router(config-route-map)# set ip precedence [ number | name ]

コミュニティ リストが一致するときの IP precedence フィールドを設定します。precedence の番号または名前のいずれかを指定できます。

ステップ 4

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 5

Router(config)# router bgp autonomous-system

ルータ コンフィギュレーション モードに入ります。

ステップ 6

Router(config-router)# table-map route-map-name

BGP で学習したルートで IP ルーティング テーブルが更新される場合の、メトリックとタグの値を修正します。

ステップ 7

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 8

Router(config)# ip community-list community-list-number { permit | deny } community-number

BGP のコミュニティ リストを作成し、そのリストへのアクセスを制御します。

ステップ 9

Router(config)# interface interface - type interface-number

インターフェイス(またはサブインターフェイス)を指定し、インターフェイス コンフィギュレーション モードに入ります。

ステップ 10

Router(config-if)# bgp-policy { source | destination } ip-prec-map

IP precedence を使用してパケットを分類します。

ステップ 11

Router(config-if)# ip bgp-community new-format

(任意)コミュニティ番号が短縮形で表示されるように、新しいコミュニティ形式を設定します。

自律システム パス アトリビュートに基づいた QoS ポリシー伝搬の設定

ここでは、自律システム パスに基づいた BGP による QoS ポリシー伝搬の設定方法について説明します。すでにルータで CEF または dCEF および BGP を設定しているものとします。

自律システム パス アトリビュートに基づいて IP precedence を伝搬するようにルータを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# route-map route-map-name [ permit | deny [ sequence-number ]]

再配布を制御するためのルート マップを定義し、ルート マップ コンフィギュレーション モードに入ります。

ステップ 2

Router(config-route-map)# match as-path path-list-number

BGP 自律システム パスのアクセス リストを照合します。

ステップ 3

Router(config-route-map)# set ip precedence [ number | name ]

自律システム パスが一致するときの IP precedence フィールドを設定します。precedence の番号または名前のいずれかを指定します。

ステップ 4

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 5

Router(config)# router bgp autonomous-system

ルータ コンフィギュレーション モードに入ります。

ステップ 6

Router(config-router)# table-map route-map-name

BGP で学習したルートで IP ルーティング テーブルが更新される場合の、メトリックとタグの値を修正します。

ステップ 7

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 8

Router(config)# ip as-path access-list access-list-number { permit | deny } as-regular-expression

自律システム パスのアクセス リストを定義します。

ステップ 9

Router(config)# interface interface - type interface-number

インターフェイス(またはサブインターフェイス)を指定し、インターフェイス コンフィギュレーション モードに入ります。

ステップ 10

Router(config-if)# bgp-policy { source | destination } ip-prec-map

IP precedence を使用してパケットを分類します。

アクセス リストに基づいた QoS ポリシー伝搬の設定

ここでは、アクセス リストに基づいた BGP による QoS ポリシー伝搬の設定方法について説明します。すでにルータで CEF または dCEF および BGP を設定しているものとします。

アクセス リストに基づいて IP precedence を伝搬するようにルータを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# route-map route-map-name [ permit | deny [ sequence-number ]]

再配布を制御するためのルート マップを定義し、ルート マップ コンフィギュレーション モードに入ります。

ステップ 2

Router(config-route-map)# match ip address access-list-number

アクセス リストを照合します。

ステップ 3

Router(config-route-map)# set ip precedence [ number | name ]

自律システム パスが一致するときの IP precedence フィールドを設定します。

ステップ 4

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 5

Router(config)# router bgp autonomous-system

ルータ コンフィギュレーション モードに入ります。

ステップ 6

Router(config-router)# table-map route-map-name

BGP で学習したルートで IP ルーティング テーブルが更新される場合の、メトリックとタグの値を修正します。

ステップ 7

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 8

Router(config)# access-list access-list-number { permit | deny } source

アクセス リストを定義します。

ステップ 9

Router(config)# interface interface - type interface-number

インターフェイス(またはサブインターフェイス)を指定し、インターフェイス コンフィギュレーション モードに入ります。

ステップ 10

Router(config-if)# bgp-policy { source | destination } ip-prec-map

IP precedence を使用してパケットを分類します。

BGP による QoS ポリシー伝搬のモニタリング

BGP による QoS ポリシー伝搬の設定をモニタリングするには、必要に応じて EXEC モードで次のコマンドを使用します。ここに示されるコマンドはオプションです。

 

コマンド
目的

Router# show ip bgp

適切なコミュニティがプレフィクスで設定されていることを確認するために、BGP ルーティング テーブルのエントリを表示します。

Router# show ip bgp community-list community-list-number

適切なプレフィクスが選択されていることを確認するために、BGP コミュニティ リストにより許可されたルートを表示します。

Router# show ip cef network

CEF でプレフィクスの優先値が適切なことを確認するために、IP アドレスに基づいた転送情報ベース(FIB)テーブルのエントリを表示します。

Router# show ip interface

インターフェイスの情報を表示します。

Router# show ip route prefix

適切な優先値がプレフィクスで設定されていることを確認するために、ルーティング テーブルの現在のステータスを表示します。

認証キーの管理

キー管理は、ルーティング プロトコルによって使用される認証キーの制御方法です。すべてのプロトコルが、キー管理を使用するわけではありません。認証キーは、ディレクタ レスポンス プロトコル(DRP)エージェント、EIGRP、および RIP バージョン 2 で利用できます。

認証キーを管理する前に、認証をイネーブルにする必要があります。プロトコルの認証をイネーブルにする方法については、該当するプロトコルについての章を参照してください。

認証キーを管理するには、キー チェーンを定義し、キー チェーンに属するキーを特定し、キーが有効な期間を指定します。各キーには独自のキー ID があります( key キー チェーン コンフィギュレーション コマンドで指定します)。キー ID はローカルに保存されます。キー ID とメッセージに関連付けられているインターフェイスの組み合わせにより、使用中の認証アルゴリズムとメッセージ ダイジェスト 5(MD5)認証キーが一意に特定されます。

ライフタイムを使用して複数のキーを設定できます。存在する有効キーの数に関わらず、認証パケットは 1 つだけ送信されます。ソフトウェアは昇順でキー番号を検査し、検出した最初の有効キーを使用します。ライフタイムは、キーの変更中に重複可能です。ルータが時間を認識している必要があることに注意してください。『 Cisco IOS Network Management Configuration Guide 』の「Performing Basic System Management」の章にあるネットワーク タイム プロトコル(NTP)とカレンダー コマンドを参照してください。

認証キーを管理するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# key chain name-of-chain

キー チェーンを特定します。

ステップ 2

Router(config-keychain)# key number

キー チェーン コンフィギュレーション モードでキー番号を特定します。

ステップ 3

Router(config-keychain-key)# key-string text

キー チェーン コンフィギュレーション モードでキー ストリングを特定します。

ステップ 4

Router(config-keychain-key)# accept-lifetime start-time { infinite | end-time | duration seconds }

キーを受け入れることができる期間を指定します。

ステップ 5

Router(config-keychain-key)# send-lifetime start-time { infinite | end-time | duration seconds }

キーを送信できる期間を指定します。

キー チェーン情報を表示するには、 show key chain コマンドを使用します。キー管理の例については、「キー管理:例」を参照してください。

IP ネットワークのモニタリングとメンテナンス

特定のキャッシュ、テーブル、またはデータベースのすべての内容を削除できます。特定の統計情報を表示することもできます。次の項で、これらの作業について説明します。

IP ルーティング テーブルからのルートの消去

特定のテーブルのすべての内容を削除できます。特定の構造の内容が無効になっている、または無効であると思われるときに、テーブルの消去が必要になる場合があります。

1 つまたは複数のルートを IP ルーティング テーブルから消去するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# clear ip route { network [ mask ] | * }

1 つまたは複数のルートを IP ルーティング テーブルから消去します。

システムとネットワーク統計情報の表示

IP ルーティング テーブル、キャッシュ、およびデータベースの内容など、特定の統計情報を表示できます。提示された情報を使用して、リソースの利用率を確認し、ネットワークの問題を解決できます。また、ノードの到達可能性に関する情報を表示し、デバイスから送信されたパケットがネットワークを通過するルーティング パスを検出することもできます。

さまざまなルーティング統計情報を表示するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show ip cache policy

ポリシー ルート キャッシュのキャッシュ エントリを表示します。

Router# show ip local policy

ローカル ポリシー ルート マップがある場合はそれを表示します。

Router# show ip policy

ポリシー ルート マップを表示します。

Router# show ip protocols

アクティブ ルーティング プロトコル プロセスのパラメータと現在の状態を表示します。

Router# show ip route [ip-address [mask] [ longer-prefixes ] | protocol [process-id] | list {access-list-number | access-list-name} | static download ]

ルーティング テーブルの現在のステータスを表示します。

Router# show ip route summary

サマリー形式でルーティング テーブルの現在のステータスを表示します。

Router# show ip route supernets-only

スーパーネットを表示します。

Router# show key chain [ name-of-chain ]

認証キーの情報を表示します。

Router# show route-map [ map-name ]

設定されているすべてのルート マップまたは指定した 1 つのルート マップを表示します。

IP ルーティング プロトコルに依存しない設定の例

ルーティング プロトコルに依存しない設定の例については、次の各項を参照してください。

「可変長サブネットマスク:例」

「ダイナミック プロトコルによるスタティック ルートの上書き:例」

「管理ディスタンス:例」

「スタティック ルーティングの再配布:例」

「EIGRP の再配布:例」

「RIP および EIGRP の再配布:例」

「OSPF ルーティングとルートの再配布:例」

「デフォルト メトリック値の再配布:例」

「ルート マップ:例」

「パッシブ インターフェイス:例」

「ポリシーベース ルーティング:例」

「CEF によるポリシー ルーティング:例」

「BGP による QoS ポリシー伝搬の設定:例」

「キー管理:例」

可変サブネットマスク:例

次の例では、クラス B ネットワーク アドレス 172.16.0.0 に 2 つの異なるサブネット マスクを使用します。/24 サブネット マスクは、LAN インターフェイスに使用されます。/24 マスクの場合、1 つのサブネットにつきホスト IP アドレスを 254 個持つサブネットを 265 個使用できます。/24 マスクを使用するサブネット範囲の最後のサブネット(172.16.255.0)は、ポイントツーポイント インターフェイスでの使用に予約されており、さらに長い /30 マスクを割り当てられます。172.16.255.0 で /30 マスクを使用すると、1 つのサブネットにつきホスト アドレスを 2 つ持つサブネットが 64 個(172.16.255.0 ~ 172.16.255.252)作成されます。

警告 一義的なルーティングを確実なものにするために、ネットワーク内の LAN インターフェイスには 172.16.255.0/24 を割り当てないでください。

Router(config)# interface Ethernet 0/0
Router(config-if)# ip address 172.16.1.1 255.255.255.0
Router(config-if)# ! 8 bits of host address space reserved for Ethernet interfaces
Router(config-if)# exit
Router(config)# interface Serial 0/0
Router(config-if)# ip address 172.16.255.5 255.255.255.252
Router(config-if)# ! 2 bits of address space reserved for point-to-point serial interfaces
Router(config-if)# exit
Router(config)# router rip
Router(config-router)# network 172.16.0.0
Router(config-router)# ! Specifies the network directly connected to the router

ダイナミック プロトコルによるスタティック ルートの上書き:例

次の例では、管理ディスタンスが 110 未満のルートを使用できない場合、ルータ B(スタティック ルートをインストール済み)からネットワーク 10.0.0.0 へのパケットは 172.18.3.4 経由でルーティングされます。図 1 は、この例を図示したものです。管理ディスタンスが 110 未満のプロトコルによって学習されたルートにより、ルータ B はネットワーク 10.0.0.0 宛てのトラフィックを代替パスであるルータ D を経由させて送ります。

Router(config)# ip route 10.0.0.0 255.0.0.0 172.18.3.4 110

図 1 スタティック ルートの上書き

 

管理ディスタンス:例

次の例では、 router eigrp グローバル コンフィギュレーション コマンドにより、自律システム 1 で EIGRP ルーティングが設定されます。 network コマンド設定により、ネットワーク 192.168.7.0 と 172.16.0.0 で EIGRP ルーティングが指定されます。1 つめの distance ルータ コンフィギュレーション コマンドでは、デフォルトの管理ディスタンスが 255 に設定されます。これにより、明示的なディスタンスが設定されていないルータからのルーティング アップデートをすべて無視するようにルータに対して指示します。2 つめの distance コマンドでは、内部 EIGRP ルートに 80 の管理ディスタンス、外部 EIGRP ルートに 100 の管理ディスタンスが設定されます。3 つめの distance コマンドでは、アドレス 172.16.1.3 のルータに 120 の管理ディスタンスが設定されます。

Router(config)# router eigrp 1
Router(config-router)# network 192.168.7.0
Router(config-router)# network 172.16.0.0
Router(config-router)# distance 255
Router(config-router)# distance eigrp 80 100
Router(config-router)# distance 120 172.16.1.3 0.0.0.0
 

) EIGRP から派生したルートの管理ディスタンスを設定するには、distance eigrp コマンドを使用する必要があります。


次の例では、アドレス 192.168.7.18 のルータに管理ディスタンス 100 を割り当て、サブネット 192.168.7.0 のその他すべてのルータに管理ディスタンス 200 を割り当てます。

Router(config-router)# distance 100 192.168.7.18 0.0.0.0
Router(config-router)# distance 200 192.168.7.0 0.0.0.255
 

ただし、これら 2 つのコマンドの順序を逆にすると、アドレス 192.168.7.18 のルータを含め、サブネット 192.168.7.0 のすべてのルータに管理ディスタンス 200 が割り当てられます。

Router(config-router)# distance 200 192.168.7.0 0.0.0.255
Router(config-router)# distance 100 192.168.7.18 0.0.0.0
 

) 管理ディスタンスの割り当ては、固有の問題を解決するために使用できます。ただし、管理ディスタンスは、ルーティング ループまたは他のネットワーク障害が発生しないように、慎重に一貫して適用する必要があります。


次の例では、学習される IP ルートのディスタンス値は 90 です。デフォルトの管理ディスタンス値が 110 のルートよりも、これらの IP ルートが優先されます。

Router(config)# router isis
Router(config-router)# distance 90 ip

スタティック ルーティングの再配布:例

次の例では、3 つのスタティック ルートが指定されます。そのうち 2 つはアドバイタイズされます。スタティック ルートは、 redistribute static ルータ コンフィギュレーション コマンドを指定し、これら 2 つのネットワークだけが EIGRP プロセスに渡されることを許可するアクセス リストを指定することによって作成されます。再配布されるスタティック ルートは、ルーティング ループ発生の可能性を最小限に抑えるために、1 つのルータだけから発信される必要があります。

Router(config)# ip route 192.168.2.0 255.255.255.0 192.168.7.65
Router(config)# ip route 192.168.5.0 255.255.255.0 192.168.7.65
Router(config)# ip route 10.10.10.0 255.255.255.0 10.20.1.2
Router(config)# !
Router(config)# access-list 3 permit 192.168.2.0 0.0.255.255
Router(config)# access-list 3 permit 192.168.5.0 0.0.255.255
Router(config)# access-list 3 permit 10.10.10.0 0.0.0.255
Router(config)# !
Router(config)# router eigrp 1
Router(config-router)# network 192.168.0.0
Router(config-router)# network 10.10.10.0
Router(config-router)# redistribute static metric 10000 100 255 1 1500
Router(config-router)# distribute-list 3 out static

EIGRP の再配布:例

各 EIGRP ルーティング プロセスでは、1 つの自律システムだけにルーティング情報が提供されます。Cisco IOS ソフトウェアは、サービスを提供する自律システムごとに個別の EIGRP プロセスを実行し、異なるルーティング データベースを維持する必要があります。ただし、これらのルーティング データベース間でルーティング情報を転送できます。

次の設定では、ネットワーク 10.0.0.0 が EIGRP 自律システム 1 の下で設定され、ネットワーク 192.168.7.0 が EIGRP 自律システム 101 の下で設定されます。

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0
Router(config-router)# exit
Router(config)# router eigrp 101
Router(config-router)# network 192.168.7.0
 

次の例では、ネットワーク 192.168.7.0 からのルートが自律システム 1 に再配布されます(自律システム 101 からのその他のルーティング情報は渡しません)。

Router(config)# access-list 3 permit 192.168.7.0
Router(config)# !
Router(config)# route-map 101-to-1 permit 10
Router(config-route-map)# match ip address 3
Router(config-route-map)# set metric 10000 100 1 255 1500
Router(config-route-map)# exit
Router(config)# router eigrp 1
Router(config-router)# redistribute eigrp 101 route-map 101-to-1
Router(config-router)#!
 

次の例は、ネットワーク 192.168.7.0 から自律システム 1 にルートを再配布するための代替方法です。前の設定とは違い、この方法では再配布されるルートのメトリックを設定できません。

Router(config)# access-list 3 permit 192.168.7.0
Router(config)# !
Router(config)# router eigrp 1
Router(config-router)# redistribute eigrp 101
Router(config-router)# distribute-list 3 out eigrp 101
Router(config-router)# !

RIP および EIGRP の再配布:例

ここでは、単純な RIP の再配布の例と EIGRP と BGP 間の複雑な再配布の例について説明します。

単純な再配布:例

内部ルーティング プロトコルとして RIP を使用する大学の WAN について考察します。その大学は、ルーティング プロトコルとして EIGRP を使用する地域ネットワーク 172.16.0.0 に WAN を接続するものとします。この場合の目的は、大学ネットワーク内のネットワークを地域ネットワークのルータにアドバタイズすることです。

次の例では、EIGRP から RIP への再配布が設定されます。

Router(config)# access-list 10 permit 172.16.0.0
Router(config)# !
Router(config)# router eigrp 1
Router(config-router)# network 172.16.0.0
Router(config-router)# redistribute rip metric 10000 100 255 1 1500
Router(config-router)# distribute-list 10 out rip
Router(config-router)# exit
Router(config)# router rip
Router(config-router)# redistribute eigrp 1
Router(config-router)# !
 

この例では、EIGRP ルーティング プロセスが開始されます。 network ルータ コンフィギュレーション コマンドにより、ネットワーク 172.16.0.0(地域ネットワーク)が EIGRP ルーティング情報を送受信するように設定されます。 redistribute ルータ コンフィギュレーション コマンドにより、RIP から派生したルーティング情報がルーティング アップデートでアドバタイズされるように設定されます。 default-metric ルータ コンフィギュレーション コマンドにより、EIGRP メトリックが RIP から派生したすべてのルートに割り当てられます。 distribute-list ルータ コンフィギュレーション コマンドにより、Cisco IOS ソフトウェアに対して、アクセス リスト 10(この例では定義されません)を使用して、各送信アップデートのエントリを制限するように指示します。アクセス リストにより、地域ネットワークへの大学ルートの不正なアドバタイズが防止されます。

複雑な再配布:例

次の例では、 相互 再配布が EIGRP と BGP の間で設定されます。

BGP 自律システム 50000 からのルートが、EIGRP ルーティング プロセス 101 に挿入されます。適切なルートがアドバタイズされるように、フィルタが設定されます。

Router(config)# ! All networks that should be advertised from R1 are controlled with ACLs:
Router(config)# access-list 1 permit 172.18.0.0 0.0.255.255
Router(config)# access-list 1 permit 172.16.0.0 0.0.255.255
Router(config)# access-list 1 permit 172.25.0.0 0.0.255.255
Router(config)# ! Configuration for router R1:
Router(config)# router bgp 50000
Router(config-router)# network 172.18.0.0
Router(config-router)# network 172.16.0.0
Router(config-router)# neighbor 192.168.10.1 remote-as 2
Router(config-router)# neighbor 192.168.10.15 remote-as 1
Router(config-router)# neighbor 192.168.10.24 remote-as 3
Router(config-router)# redistribute eigrp 101
Router(config-router)# distribute-list 1 out eigrp 101
Router(config-router)# exit
Router(config)# router eigrp 101
Router(config-router)# network 172.25.0.0
Router(config-router)# redistribute bgp 50000
Router(config-router)# distribute-list 1 out bgp 50000
Router(config-router)# !

注意 他の適切なオプションがない場合、BGP は IGP に再配布されます。BGP から IGP への再配布は、配布リスト、IP プレフィクス リスト、およびプレフィクス番号を制限するためのルート マップ ステートメントを使用した適切なフィルタと共に適用されます。BGP ルーティング テーブルは、非常に大きくなる場合があります。すべての BGP プレフィクスを IGP に再配布すると、IGP ネットワークの動作に悪影響を及ぼす可能性があります。

OSPF ルーティングとルートの再配布:例

OSPF は、通常、多数の内部ルータ、エリア境界ルータ(ABR)、および自律システム境界ルータ(ASBR)間での調整が必要です。最低でも、OSPF ベースのルータを、すべてデフォルト パラメータ値、認証なし、およびエリアに割り当てられたインターフェイスで設定します。

3 つのタイプの例は、次のとおりです。

1 つめの例は、基本的な OSPF コマンドを示した単純な設定です。

2 つめの例は、単一の任意に割り当てられた OSPF 自律システム内の内部ルータ、ABR、および ASBR の設定を示したものです。

3 つめの例は、より複雑な設定と、OSPF ベースのルーティング環境の制御に利用できるさまざまなツールの応用例を示したものです。

基本的な OSPF 設定:例

次の例では、OSPF ルーティング プロセス 1 をイネーブルにし、イーサネット インターフェイス 0 をエリア 0.0.0.0 に接続し、RIP を OSPF に再配布し、OSPF を RIP に再配布する単純な OSPF 設定を示します。

Router(config)# interface Ethernet 0
Router(config-if)# ip address 172.16.1.1 255.255.255.0
Router(config-if)# ip ospf cost 1
Router(config-if)# exit
Router(config)# interface Ethernet 1
Router(config-if)# ip address 172.17.1.1 255.255.255.0
Router(config-if)# exit
Router(config)# router ospf 1
Router(config-router)# network 172.18.0.0 0.0.255.255 area 0.0.0.0
Router(config-router)# redistribute rip metric 1 subnets
Router(config-router)# exit
Router(config)# router rip
Router(config-router)# network 172.17.0.0
Router(config-router)# redistribute ospf 1
Router(config-router)# default-metric 1
Router(config-router)# !
 

次の例は、4 つのエリア ID を 4 つの IP アドレス範囲に割り当てる設定を示します。この例では、OSPF ルーティング プロセス 1 が初期化され、4 つの OSPF エリア(10.9.50.0、2、3、および 0)が定義されます。エリア 10.9.50.0、2、および 3 は特定のアドレス範囲をマスクし、エリア 0 は 他のすべて のネットワークで OSPF をイネーブルにします。

Router(config)# router ospf 1
Router(config-router)# network 172.18.20.0 0.0.0.255 area 10.9.50.0
Router(config-router)# network 172.18.0.0 0.0.255.255 area 2
Router(config-router)# network 172.19.10.0 0.0.0.255 area 3
Router(config-router)# network 0.0.0.0 255.255.255.255 area 0
Router(config-router)# exit
Router(config)# ! Ethernet interface 0 is in area 10.9.50.0:
Router(config)# interface Ethernet 0
Router(config-if)# ip address 172.18.20.5 255.255.255.0
Router(config-if)# exit
Router(config)# ! Ethernet interface 1 is in area 2:
Router(config)# interface Ethernet 1
Router(config-if)# ip address 172.18.1.5 255.255.255.0
Router(config-if)# exit
Router(config)# ! Ethernet interface 2 is in area 2:
Router(config)# interface Ethernet 2
Router(config-if)# ip address 172.18.2.5 255.255.255.0
Router(config-if)# exit
Router(config)# ! Ethernet interface 3 is in area 3:
Router(config)# interface Ethernet 3
Router(config-if)# ip address 172.19.10.5 255.255.255.0
Router(config-if)# exit
Router(config)# ! Ethernet interface 4 is in area 0:
Router(config)# interface Ethernet 4
Router(config-if)# ip address 172.19.1.1 255.255.255.0
Router(config-if)# exit
Router(config)# ! Ethernet interface 5 is in area 0:
Router(config)# interface Ethernet 5
Router(config-if)# ip address 10.1.0.1 255.255.0.0
Router(config-if)# !
 

network ルータ コンフィギュレーション コマンドは順番に評価されるため、設定ではこれらのコマンドの特定の順序が重要になります。Cisco IOS ソフトウェアは、各インターフェイスの addres s/ wildcard-mask ペアを順番に評価します。詳細については、『 Cisco IOS IP Routing Protocols Command Reference 』を参照してください。

1 つめの network コマンドについて考察します。エリア ID 10.9.50.0 が、サブネット 172.18.20.0 があるインターフェイスに設定されます。一致は、イーサネット インターフェイス 0 について確認されるものとします。イーサネット インターフェイス 0 は、エリア 10.9.50.0 にのみ接続されます。

2 つめの network コマンドが次に評価されます。エリア 2 について、同じプロセスがすべてのインターフェイス(イーサネット インターフェイス 0 を除く)に適用されます。一致は、イーサネット インターフェイス 1 について確認されるものとします。OSPF がそのインターフェイスに対してイネーブルになり、イーサネット 1 がエリア 2 に接続されます。

インターフェイスを OSPF エリアに接続するこのプロセスは、すべての network コマンドに対して継続します。この例にある最後の network コマンドは特別な場合なので、注意してください。このコマンドを使用すると、すべての利用可能なインターフェイス(明示的に別のエリアに接続されていないもの)が、エリア 0 に接続されます。

内部ルータ、ABR、および ASBR の設定:例

図 2は、単一の OSPF 自律システム内にあるさまざまなルータの設定例を図示した一般的なネットワーク マップです。

図 2 OSPF 自律システムのネットワーク マップ例

 

この設定では、OSPF 自律システム 1 に 5 つのルータが設定されています。

ルータ A とルータ B は、両方ともエリア 1 内の内部ルータです。

ルータ C は OSPF ABR です。ルータ C では、エリア 1 が E3 に割り当てられ、エリア 0 が S0 に割り当てられることに注意してください。

ルータ D は、エリア 0(バックボーン エリア)の内部ルータです。この場合、両方の network ルータ コンフィギュレーション コマンドにより、同じエリア(エリア 0 またはバックボーン エリア)が指定されます。

ルータ E は OSPF ASBR です。BGP ルートが OSPF に再配布され、これらのルートが OSPF によってアドバタイズされることに注意してください。


) 自律システム内のすべてのルータの設定に、OSPF 自律システム内のすべてのエリアの定義を含める必要はありません。直接接続されたエリアだけ、定義する必要があります。次の例では、ABR(ルータ C)がサマリー LSA をエリア 1 に挿入するとき、エリア 1 (ルータ A とルータ B)のルータがエリア 0 のルートを学習します。


自律システム 60000 は、IP アドレス 172.16.1.6 で、外部ピアへの BGP リンクを介して外部に接続されます。

図 2に示した一般的なネットワーク マップの設定例は、次のとおりです。

ルータ A の設定:内部ルータ

Router(config)# interface Ethernet 1
Router(config-if)# ip address 192.168.1.1 255.255.255.0
Router(config-if)# exit
Router(config)# router ospf 1
Router(config-router)# network 192.168.1.0 0.0.0.255 area 1
Router(config-router)# exit

ルータ B の設定:内部ルータ

Router(config)# interface Ethernet 2
Router(config-if)# ip address 192.168.1.2 255.255.255.0
Router(config-if)# exit
Router(config)# router ospf 1
Router(config-router)# network 192.168.1.0 0.0.0.255 area 1
Router(config-router)# exit

ルータ C の設定:ABR

Router(config)# interface Ethernet 3
Router(config-if)# ip address 192.168.1.3 255.255.255.0
Router(config-if)# exit
Router(config)# interface Serial 0
Router(config-if)# ip address 192.168.2.3 255.255.255.0
Router(config-if)# exit
Router(config)# router ospf 1
Router(config-router)# network 192.168.1.0 0.0.0.255 area 1
Router(config-router)# network 192.168.2.0 0.0.0.255 area 0
Router(config-router)# exit

ルータ D の設定:内部ルータ

Router(config)# interface Ethernet 4
Router(config-if)# ip address 10.0.0.4 255.0.0.0
Router(config-if)# exit
Router(config)# interface Serial 1
Router(config-if)# ip address 192.168.2.4 255.255.255.0
Router(config-if)# exit
Router(config)# router ospf 1
Router(config-router)# network 192.168.2.0 0.0.0.255 area 0
Router(config-router)# network 10.0.0.0 0.255.255.255 area 0
Router(config-router)# exit

ルータ E の設定:ASBR

Router(config)# interface Ethernet 5
Router(config-if)# ip address 10.0.0.5 255.0.0.0
Router(config-if)# exit
Router(config)# interface Serial 2
Router(config-if)# ip address 172.16.1.5 255.255.255.0
Router(config-if)# exit
Router(config)# router ospf 1
Router(config-router)# network 10.0.0.0 0.255.255.255 area 0
Router(config-router)# redistribute bgp 50000 metric 1 metric-type 1
Router(config-router)# exit
Router(config)# router bgp 50000
Router(config-router)# network 192.168.0.0
Router(config-router)# network 10.0.0.0
Router(config-router)# neighbor 172.16.1.6 remote-as 60000

複雑な OSPF 設定:例

次の設定例では、ABR を設定するさまざまな作業を行います。これらの作業は、次の 2 つの一般的なカテゴリに分類されます。

基本的な OSPF 設定

ルートの再配布

この設定で概説される特定の作業の詳細について、簡単に説明します。図 3 は、ネットワーク アドレス範囲とインターフェイスのエリア割り当てを図示したものです。

図 3 OSPF のインターフェイスとエリア指定の設定例

 

この例での基本的な設定作業は、次のとおりです。

イーサネット インターフェイス 0 からイーサネット インターフェイス 3 のアドレス範囲を設定する。

各インターフェイスで OSPF をイネーブルにする。

各エリアとネットワークの OSPF 認証パスワードを設定する。

リンクステート メトリックと他の OSPF インターフェイス設定オプションを割り当てる。

エリア ID 10.0.0.0 のスタブ エリアを作成する ( area ルータ コンフィギュレーション コマンドの authentication および stub オプションは、別々の area コマンド エントリで指定されますが、1 つの area コマンドにマージできます)。

バックボーン エリア(エリア 0)を指定する。

再配布に関連する設定作業は、次のとおりです。

さまざまなオプションセット( metric-type metric tag 、および subnet など)と共に EIGRP と RIP を OSPF に再配布する。

EIGRP と OSPF を RIP に再配布する。

OSPF の設定例は、次のとおりです。

Router(config)# interface Ethernet 0
Router(config-if)# ip address 192.168.110.201 255.255.255.0
Router(config-if)# ip ospf authentication-key abcdefgh
Router(config-if)# ip ospf cost 10
Router(config-if)# exit
Router(config)# interface Ethernet 1
Router(config-if)# ip address 172.19.251.201 255.255.255.0
Router(config-if)# ip ospf authentication-key ijklmnop
Router(config-if)# ip ospf cost 20
Router(config-if)# ip ospf retransmit-interval 10
Router(config-if)# ip ospf transmit-delay 2
Router(config-if)# ip ospf priority 4
Router(config-if)# exit
Router(config)# interface Ethernet 2
Router(config-if)# ip address 172.19.254.201 255.255.255.0
Router(config-if)# ip ospf authentication-key abcdefgh
Router(config-if)# ip ospf cost 10
Router(config-if)# exit
Router(config)# interface Ethernet 3
Router(config-if)# ip address 10.56.0.201 255.255.0.0
Router(config-if)# ip ospf authentication-key ijklmnop
Router(config-if)# ip ospf cost 20
Router(config-if)# ip ospf dead-interval 80
Router(config-if)# exit
 

次の設定では、OSPF はネットワーク 172.19.0.0 にあります。

Router(config)# router ospf 1
Router(config-router)# network 10.0.0.0 0.255.255.255 area 10.0.0.0
Router(config-router)# network 192.168.110.0 0.0.0.255 area 192.68.110.0
Router(config-router)# network 172.19.0.0 0.0.255.255 area 0
Router(config-router)# area 0 authentication
Router(config-router)# area 10.0.0.0 stub
Router(config-router)# area 10.0.0.0 authentication
Router(config-router)# area 10.0.0.0 default-cost 20
Router(config-router)# area 192.168.110.0 authentication
Router(config-router)# area 10.0.0.0 range 10.0.0.0 255.0.0.0
Router(config-router)# area 192.168.110.0 range 192.168.110.0 255.255.255.0
Router(config-router)# area 0 range 172.19.251.0 255.255.255.0
Router(config-router)# area 0 range 172.19.254.0 255.255.255.0
Router(config-router)# redistribute eigrp 200 metric-type 2 metric 1 tag 200 subnets
Router(config-router)# redistribute rip metric-type 2 metric 1 tag 200
Router(config-router)# exit
 

次の設定では、EIGRP 自律システム 1 が 172.19.0.0 にあります。

Router(config)# router eigrp 1
Router(config-router)# network 172.19.0.0
Router(config-router)# exit
Router(config)# ! RIP for 192.168.110.0:
Router(config)# router rip
Router(config-router)# network 192.168.110.0
Router(config-router)# redistribute eigrp 1 metric 1
Router(config-router)# redistribute ospf 201 metric 1
Router(config-router)# exit

デフォルト メトリック値の再配布:例

次の例では、RIP と EIGRP の両方を実行するように設定された自律システム 1 のルータを示します。この例では、RIP を使用して EIGRP から派生したルートをアドバタイズし、EIGRP から派生したルートに RIP メトリック 10 を割り当てます。

Router(config)# router rip
Router(config-router)# default-metric 10
Router(config-router)# redistribute eigrp 1
Router(config-router)# exit

ルート マップ:例

この項の例では、ルート マップを使用する場合および使用しない場合の、再配布の使用について説明します。IP とコネクションレス型ネットワーク サービス(CLNS)の両方のルーティング プロトコルによる例を示します。次の例では、すべての OSPF ルートが EIGRP に再配布されます。

Router(config)# router eigrp 1
Router(config-router)# redistribute ospf 101
Router(config-router)# exit
 

次の例では、ホップ カウントが 1 の RIP ルートが OSPF に再配布されます。これらのルートは、メトリック 5、メトリック タイプ 1 、およびタグ 1 の外部 LSA として OSPF に再配布されます。

Router(config)# router ospf 1
Router(config-router)# redistribute rip route-map rip-to-ospf
Router(config-router)# exit
Router(config)# route-map rip-to-ospf permit
Router(config-route-map)# match metric 1
Router(config-route-map)# set metric 5
Router(config-route-map)# set metric-type type 1
Router(config-route-map)# set tag 1
Router(config-route-map)# exit
 

次の例では、タグ 7 の OSPF が学習したルートが RIP メトリック 15 として再配布されます。

Router(config)# router rip
Router(config-router)# redistribute ospf 1 route-map 5
Router(config-router)# exit
Router(config)# route-map 5 permit
Router(config-route-map)# match tag 7
Router(config-route-map)# set metric 15
 

次の例では、シリアル インターフェイス 0 のネクストホップ ルータがある OSPF エリア内およびエリア間のルートが、INTER_AS メトリック 5 の BGP に再配布されます。

Router(config)# router bgp 50000
Router(config-router)# redistribute ospf 1 route-map 10
Router(config-router)# exit
Router(config)# route-map 10 permit
Router(config-route-map)# match route-type internal
Router(config-route-map)# match interface serial 0
Router(config-route-map)# set metric 5
 

次の例では、2 つのタイプのルートが統合 IS-IS ルーティング テーブル(IP と CLNS の両方をサポート)に再配布されます。1 つめのタイプは、タグ 5 の OSPF 外部 IP ルートです。これらのルートは、メトリック 5 のレベル 2 IS-IS リンクステート パケット(LSP)に挿入されます。2 つめのタイプは、ISO-IGRP から派生した CLNS プレフィクス ルートで、CLNS アクセス リスト 2000 を照合します。これらのルートは、メトリック 30 のレベル 2 LSP として IS-IS に再配布されます。

Router(config)# router isis
Router(config-router)# redistribute ospf 1 route-map 2
Router(config-router)# redistribute iso-igrp nsfnet route-map 3
Router(config-router)# exit
Router(config)# route-map 2 permit
Router(config-route-map)# match route-type external
Router(config-route-map)# match tag 5
Router(config-route-map)# set metric 5
Router(config-route-map)# set level level-2
Router(config-route-map)# exit
Router(config)# route-map 3 permit
Router(config-route-map)# match address 2000
Router(config-route-map)# set metric 30
Router(config-route-map)# exit
 

次の設定を使用すると、タグ 1、2、3、および 5 の OSPF 外部ルートが、それぞれメトリック 1、1、5、および 5 の RIP に再配布されます。タグ 4 の OSPF ルートは再配布されません。

Router(config)# router rip
Router(config-router)# redistribute ospf 101 route-map 1
Router(config-router)# exit
Router(config)# route-map 1 permit
Router(config-route-map)# match tag 1 2
Router(config-route-map)# set metric 1
Router(config-route-map)# exit
Router(config)# route-map 1 permit
Router(config-route-map)# match tag 3
Router(config-route-map)# set metric 5
Router(config-route-map)# exit
Router(config)# route-map 1 deny
Router(config-route-map)# match tag 4
Router(config-route-map)# exit
Router(config)# route map 1 permit
Router(config-route-map)# match tag 5
Router(config-route-map)# set metric 5
Router(config-route-map)# exit
 

次の設定の場合、RIP が学習したネットワーク 172.18.0.0 のルートと ISO-IGRP が学習したプレフィクス 49.0001.0002 のルートを、メトリック 5 の IS-IS レベル 2 LSP に再配布します。

Router(config)# router isis
Router(config-router)# redistribute rip route-map 1
Router(config-router)# redistribute iso-igrp remote route-map 1
Router(config-router)# exit
Router(config)# route-map 1 permit
Router(config-route-map)# match ip address 1
Router(config-route-map)# match clns address 2
Router(config-route-map)# set metric 5
Router(config-route-map)# set level level-2
Router(config-route-map)# exit
Router(config)# access-list 1 permit 172.18.0.0 0.0.255.255
Router(config)# clns filter-set 2 permit 49.0001.0002...
 

次の設定例は、 default-information ルータ コンフィギュレーション コマンドによってルート マップを参照する方法を示しています。この参照タイプは、「 条件付きのデフォルト発信元 」と呼ばれます。172.20.0.0 がルーティング テーブルにある場合、OSPF はタイプ 2 メトリック 5 のデフォルト ルート(ネットワーク 0.0.0.0)を発信します。

Router(config)# route-map ospf-default permit
Router(config-route-map)# match ip address 1
Router(config-route-map)# set metric 5
Router(config-route-map)# set metric-type type-2
Router(config-route-map)# exit
Router(config)# access-list 1 172.20.0.0 0.0.255.255
Router(config)# router ospf 101
Router(config-router)# default-information originate route-map ospf-default
 

BGP ルート マップ設定作業の例と設定例については、「 Connecting to a Service Provider Using External BGP 」の章を参照してください。

パッシブ インターフェイス:例

OSPF では、パッシブとして指定されたインターフェイスでは hello パケットは送信されません。そのため、ルータはネイバーを検出できず、どの OSPF ネイバーもネットワーク上のルータを検出できません。実際には、このインターフェイスは OSPF ドメインへのスタブ ネットワークとして表示されます。インターフェイス上で OSPF アクティビティを実行することなく、接続されたネットワークに関連付けられたルートを OSPF ドメインにインポートするときにこの設定が役立ちます。

passive-interface ルータ コンフィギュレーション コマンドは、通常、 network ルータ コンフィギュレーション コマンドでワイルドカードを 指定することによって必要以上のインターフェイスが設定されるときに使用します。次の設定により、OSPF は 172.18.0.0 のすべてのサブネットで実行されます。

Router(config)# interface Ethernet 0
Router(config-if)# ip address 172.18.1.1 255.255.255.0
Router(config-if)# exit
Router(config)# interface Ethernet 1
Router(config-if)# ip address 172.18.2.1 255.255.255.0
Router(config-if)# exit
Router(config)# interface Ethernet 2
Router(config-if)# ip address 172.18.3.1 255.255.255.0
Router(config-if)# exit
Router(config)# router ospf 1
Router(config-router)# network 172.18.0.0 0.0.255.255 area 0
Router(config-router)# exit
 

172.18.3.0 で OSPF を実行しない場合は、次のコマンドを入力します。

Router(config)# router ospf 1
Router(config-router)# network 172.18.0.0 0.0.255.255 area 0
Router(config-router)# passive-interface Ethernet 2
Router(config-router)# exit

デフォルトのパッシブ インターフェイス:例

次の例では、ネットワーク インターフェイスを設定し、OSPF を実行しているすべてのインターフェイスをパッシブとして設定し、シリアル インターフェイス 0 をイネーブルにします。

Router(config)# interface Ethernet 0
Router(config-if)# ip address 172.19.64.38 255.255.255.0 secondary
Router(config-if)# ip address 172.19.232.70 255.255.255.240
Router(config-if)# no ip directed-broadcast
Router(config-if)# exit
Router(config)# interface Serial 0
Router(config-if)# ip address 172.24.101.14 255.255.255.252
Router(config-if)# no ip directed-broadcast
Router(config-if)# no ip mroute-cache
Router(config-if)# exit
Router(config)# interface TokenRing 0
Router(config-if)# ip address 172.20.10.4 255.255.255.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# no ip mroute-cache
Router(config-if)# ring-speed 16
Router(config-if)# exit
Router(config)# router ospf 1
Router(config-router)# passive-interface default
Router(config-router)# no passive-interface Serial 0
Router(config-router)# network 172.16.10.0 0.0.0.255 area 0
Router(config-router)# network 172.19.232.0 0.0.0.255 area 4
Router(config-router)# network 172.24.101.0 0.0.0.255 area 4
Router(config-router)# exit

ポリシーベース ルーティング:例

次の例では、2 つの発信元に対して、2 つの異なるサービス プロバイダーへの同等のアクセスを提供します。パケットの宛先についての明示的なルートがルータにない場合、発信元 10.1.1.1 から非同期インターフェイス 1 に届くパケットは、172.16.6.6 のルータに送られます。パケットの宛先についての明示的なルートがルータにない場合、発信元 172.17.2.2 から届くパケットは、192.168.7.7 のルータに送られます。宛先についての明示的なルートがルータにない他のすべてのパケットは破棄されます。

Router(config)# access-list 1 permit ip 10.1.1.1
Router(config)# access-list 2 permit ip 172.17.2.2
Router(config)# interface async 1
Router(config-if)# ip policy route-map equal-access
Router(config-if)# exit
Router(config)# route-map equal-access permit 10
Router(config-route-map)# match ip address 1
Router(config-route-map)# set ip default next-hop 172.16.6.6
Router(config-route-map)# exit
Router(config)# route-map equal-access permit 20
Router(config-route-map)# match ip address 2
Router(config-route-map)# set ip default next-hop 192.168.7.7
Router(config-route-map)# exit
Router(config)# route-map equal-access permit 30
Router(config-route-map)# set default interface null 0
Router(config-route-map)# exit

CEF によるポリシー ルーティング:例

次の例では、CEF によるポリシー ルーティングが設定されます。ルータがポリシー ルーティングを試行する前に、test1 という名前のルート マップのネクストホップ 10.0.0.8 が CDP ネイバーであることを確認するように、ルートが設定されます。

Router(config)# ip cef
Router(config)# interface Ethernet 0/0/1
Router(config-if)# ip route-cache flow
Router(config-if)# ip policy route-map test
Router(config-if)# exit
Router(config)# route-map test permit 10
Router(config-route-map)# match ip address 1
Router(config-route-map)# set ip precedence priority
Router(config-route-map)# set ip next-hop 10.0.0.8
Router(config-route-map)# set ip next-hop verify-availability
Router(config-route-map)# exit
Router(config)# route-map test permit 20
Router(config-route-map)# match ip address 101
Router(config-route-map)# set interface Ethernet 0/0/3
Router(config-route-map)# set ip tos max-throughput
Router(config-route-map)# exit

BGP による QoS ポリシー伝搬の設定:例

次の例では、アクセス リスト、BGP コミュニティ リスト、および BGP 自律システムパスを照合するためのルート マップを作成し、ネイバーから学習されたルートに IP precedence を適用する方法を示します。

BGP による QoS ポリシー伝搬の設定方法については、このマニュアルの「BGP による QoS ポリシー伝搬の設定」の項を参照してください。

図 4 では、ルータ A(Cisco 10000 シリーズ)が自律システム 10 と自律システム 60 からルートを学習します。QoS ポリシーは、定義済みのルート マップに一致するすべてのパケットに適用されます。ルータ A(Cisco 10000 シリーズ)から自律システム 10 または自律システム 60 へのパケットは、番号付きの手順が示すように、適切な QoS ポリシーで送信されます。

図 4 ルータのルート学習と QoS ポリシーの適用

 

ルータ A(Cisco 10000 シリーズ)の設定

interface serial 5/0/0/1:0
ip address 10.28.38.2 255.255.255.0
bgp-policy destination ip-prec-map
no ip mroute-cache
no cdp enable
frame-relay interface-dlci 20 IETF
 
router bgp 30
table-map precedence-map
neighbor 10.20.20.1 remote-as 10
neighbor 10.20.20.1 send-community
!
ip bgp-community new-format
!
! Match community 1 and set the IP Precedence to priority
route-map precedence-map permit 10
match community 1
set ip precedence priority
!
! Match community 2 and set the IP Precedence to immediate
route-map precedence-map permit 20
match community 2
set ip precedence immediate
!
! Match community 3 and set the IP Precedence to flash
route-map precedence-map permit 30
match community 3
set ip precedence flash
!
! Match community 4 and set the IP Precedence to flash-override
route-map precedence-map permit 40
match community 4
set ip precedence flash-override
!
! Match community 5 and set the IP Precedence to critical
route-map precedence-map permit 50
match community 5
set ip precedence critical
!
! Match community 6 and set the IP Precedence to internet
route-map precedence-map permit 60
match community 6
set ip precedence internet
!
! Match community 7 and set the IP Precedence to network
route-map precedence-map permit 70
match community 7
set ip precedence network
!
! Match ip address access list 69 or match AS path 1
! and set the IP Precedence to critical
route-map precedence-map permit 75
match ip address 69
match as-path 1
set ip precedence critical
!
! For everything else, set the IP Precedence to routine
route-map precedence-map permit 80
set ip precedence routine
!
! Define the community lists
ip community-list 1 permit 60:1
ip community-list 2 permit 60:2
ip community-list 3 permit 60:3
ip community-list 4 permit 60:4
ip community-list 5 permit 60:5
ip community-list 6 permit 60:6
ip community-list 7 permit 60:7
!
! Define the AS path
ip as-path access-list 1 permit ^10_60
!
! Define the access list
access-list 69 permit 10.69.0.0

ルータ B の設定

router bgp 10
neighbor 10.30.30.1 remote-as 30
neighbor 10.30.30.1 send-community
neighbor 10.30.30.1 route-map send_community out
!
ip bgp-community new-format
!
! Match prefix 10 and set community to 60:1
route-map send_community permit 10
match ip address 10
set community 60:1
!
! Match prefix 20 and set community to 60:2
route-map send_community permit 20
match ip address 20
set community 60:2
!
! Match prefix 30 and set community to 60:3
route-map send_community permit 30
match ip address 30
set community 60:3
!
! Match prefix 40 and set community to 60:4
route-map send_community permit 40
match ip address 40
set community 60:4
!
! Match prefix 50 and set community to 60:5
route-map send_community permit 50
match ip address 50
set community 60:5
!
! Match prefix 60 and set community to 60:6
route-map send_community permit 60
match ip address 60
set community 60:6
!
! Match prefix 70 and set community to 60:7
route-map send_community permit 70
match ip address 70
set community 60:7
!
! For all others, set community to 60:8
route-map send_community permit 80
set community 60:8
!
! Define the access lists
access-list 10 permit 10.61.0.0
access-list 20 permit 10.62.0.0
access-list 30 permit 10.63.0.0
access-list 40 permit 10.64.0.0
access-list 50 permit 10.65.0.0
access-list 60 permit 10.66.0.0
access-list 70 permit 10.67.0.0

キー管理:例

次の例では、 trees という名前のキー チェーンを設定します。この例では、ソフトウェアは常に有効キーとして willow を受け入れ、送信します。キー chestnut は、午後 1:30 から 午後 3:30 まで受け入れられ、午後 2:00 から 午後 3:30 まで送信されます。重複により、キーの移行またはルータの設定時間の相違に対処できます。同様に、キー birch chestnut のすぐ後に続き、時刻の相違に対処するための 30 分の余裕がそれぞれの側にあります。

Router(config)# interface Ethernet 0
Router(config-if)# ip rip authentication key-chain trees
Router(config-if)# ip rip authentication mode md5
Router(config-if)# exit
Router(config)# router rip
Router(config-router)# network 172.19.0.0
Router(config-router)# version 2
Router(config-router)# exit
Router(config)# key chain trees
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string willow
Router(config-keychain-key)# key 2
Router(config-keychain-key)# key-string chestnut
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 2005 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 2005 duration 3600
Router(config-keychain-key)# key 3
Router(config-keychain-key)# key-string birch
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 2005 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 2005 duration 3600
Router(config-keychain-key)# exit
 

次の例では、trees という名前のキー チェーンが設定されます。

Router(config)# key chain trees
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string willow
Router(config-keychain-key)# key 2
Router(config-keychain-key)# key-string chestnut
Router(config-keychain-key)# accept-lifetime 00:00:00 Dec 5 2004 23:59:59 Dec 5 2005
Router(config-keychain-key)# send-lifetime 06:00:00 Dec 5 2004 18:00:00 Dec 5 2005
Router(config-keychain-key)# exit
Router(config-keychain)# exit
Router(config)# interface Ethernet 0
Router(config-if)# ip address 172.19.104.75 255.255.255.0 secondary 172.19.232.147 255.255.255.240
Router(config-if)# ip rip authentication key-chain trees
Router(config-if)# media-type 10BaseT
Router(config-if)# exit
Router(config)# interface Ethernet 1
Router(config-if)# no ip address
Router(config-if)# shutdown
Router(config-if)# media-type 10BaseT
Router(config-if)# exit
Router(config)# interface Fddi 0
Router(config-if)# ip address 10.1.1.1 255.255.255.0
Router(config-if)# no keepalive
Router(config-if)# exit
Router(config)# interface Fddi 1
Router(config-if)# ip address 172.16.1.1 255.255.255.0
Router(config-if)# ip rip send version 1
Router(config-if)# ip rip receive version 1
Router(config-if)# no keepalive
Router(config-if)# exit
Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# network 172.19.0.0
Router(config-router)# network 10.0.0.0

Router(config-router)# network 172.16.0.0

IP ルーティング プロトコルに依存しない機能の設定に関する機能情報

表 3 に、このモジュールに記載されている機能の一覧と、特定の設定情報へのリンクを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 3には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 3 IP ルーティング プロトコルに依存しない機能の設定に関する機能情報

機能名
リリース
機能情報

デフォルトのパッシブ インターフェイス

12.0

インターネット サービス プロバイダー(ISP)や大規模な企業ネットワークでは、多くのディストリビューション ルータに 200 を超えるインターフェイスがあります。これらのインターフェイスからルーティング情報を取得するには、すべてのインターフェイスでルーティング プロトコルを設定し、隣接させないインターフェイスで passive-interface コマンドを手動設定する必要がありました。デフォルトのパッシブ インターフェイス機能を使用すると、1 つの passive-interface default コマンドを使用してデフォルトですべてのインターフェイスをパッシブとして設定し、その後、 no passive-interface コマンドを使用して隣接させる個々のインターフェイスを設定できるため、ディストリビューション ルータの設定が簡略化されます。

この機能に関する詳細については、次の各項を参照してください。

「デフォルトのパッシブ インターフェイスの設定」

「デフォルトのパッシブ インターフェイス:例」

ファースト スイッチド ポリシー ルーティング

11.3

IP ポリシー ルーティングは、ファースト スイッチドにすることもできます。ファースト スイッチド ポリシー ルーティング以前、ポリシー ルーティングはプロセス スイッチドだけでした。そのため、ほとんどのプラットフォームで、スイッチング レートは 1 秒あたり約 1,000 ~ 10,000 パケットでした。このレートは、多くの用途に対して十分な速度ではありませんでした。より高速でポリシー ルーティングを実行する必要があるユーザは、現在、ルータを減速させることなくポリシー ルーティングを実装できます。

この機能に関する詳細については、次の各項を参照してください。

「ファースト スイッチド ポリシー ルーティングのイネーブル化」

IP ルーティング

11.0

IP ルーティング機能により、このマニュアルと他の IP ルーティング プロトコルのマニュアルで説明されている基本的な IP ルーティング機能が導入されました。

NetFlow ポリシー ルーティング(NPR)

12.0(3)T

NetFlow ポリシー ルーティング(NPR)は、ポリシー ルーティングに NetFlow サービスを統合し、トラフィック エンジニアリングとトラフィック分類をイネーブルにします。NetFlow サービス により、課金、キャパシティ プランニング、およびリアルタイムのトラフィック フローでの情報モニタリングが実現されます。IP ポリシー ルーティングは、シスコ エクスプレス フォワーディング(CEF)、分散 CEF(dCEF)、および NetFlow と連動します。

この機能に関する詳細については、次の各項を参照してください。

「NetFlow ポリシー ルーティングのイネーブル化」

「CEF によるポリシー ルーティング:例」

ポリシーベース ルーティング

11.0

ポリシーベース ルーティング機能により、宛先ルーティングよりも柔軟性に富んだパケット ルーティング メカニズムが導入されました。ポリシーベース ルーティングは、パケットをルーティングする前にルータがパケットをルート マップに照合するプロセスです。ルート マップにより、どのパケットを次にどのルータにルーティングするのかが決定されます。

この機能に関する詳細については、次の各項を参照してください。

「ポリシーベース ルーティングのイネーブル化」

「ポリシーベース ルーティング:例」

ip policy route-map コマンドは、この機能によって導入されました。

ポリシーベース ルーティング(PBR)のデフォルト ネクストホップ ルート

12.1(11)E

ポリシーベース ルーティング(PBR)のデフォルト ネクストホップ ルート機能により、 set ip default next-hop コマンドの結果として転送されるパケットをハードウェア レベルでスイッチする機能が導入されます。以前のリリースでは、PBR のルート マップから生成される転送ルータ パケットは、ソフトウェア レベルでスイッチされました。

この機能に関する詳細については、次の各項を参照してください。

「ポリシーベース ルーティングのイネーブル化」

「ポリシーベース ルーティング:例」

set ip default next-hop コマンドは、この機能によって変更されました。

ポリシー ルーティングのインフラストラクチャ

12.2(15)T

ポリシー ルーティングのインフラストラクチャ機能により、シスコ エクスプレス フォワーディング(CEF)および NetFlow での IP ポリシーベース ルーティングのフル サポートが実現します。CEF によりファースト スイッチングが徐々に時代遅れになるに伴い、ポリシー ルーティングが CEF と統合され、増大するお客様のパフォーマンス要件に対応します。ポリシー ルーティングと NetFlow の両方がイネーブルの場合、冗長な処理が回避されます。

この機能に関する詳細については、次の各項を参照してください。

「NetFlow ポリシー ルーティングのイネーブル化」

「CEF によるポリシー ルーティング:例」

BGP による QoS ポリシー伝搬

12.0

BGP による QoS ポリシー伝搬機能を使用すると、BGP コミュニティ リスト、BGP 自律システム パス、およびアクセス リストに基づいて IP precedence によってパケットを分類できます。パケットが分類されたら、専用アクセス レート(CAR)および重み付けランダム早期検出(WRED)など、その他の QoS 機能を使用してビジネス モデルに合うようにポリシーを指定および強化できます。

この機能に関する詳細については、次の各項を参照してください。

「BGP による QoS ポリシー伝搬の設定」

「コミュニティ リストに基づいた QoS ポリシー伝搬の設定」

「自律システム パス アトリビュートに基づいた QoS ポリシー伝搬の設定」

「アクセス リストに基づいた QoS ポリシー伝搬の設定」

「BGP による QoS ポリシー伝搬のモニタリング」

「BGP による QoS ポリシー伝搬の設定:例」