インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、 Cisco IOS Release15.2M&T
トンネルのルート選択
トンネルのルート選択
発行日;2012/06/25 | 英語版ドキュメント(2011/08/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

トンネルのルート選択

機能情報の確認

内容

トンネルのルート選択の前提条件

トンネルのルート選択の制約事項

トンネルのルート選択に関する情報

トンネル転送動作

トンネルのルート選択の設定方法

トンネルのルート選択の設定

トラブルシューティングのヒント

次の作業

トンネルのルート選択の設定例

例:トンネルのルート選択の設定

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

トンネルのルート選択の機能情報

トンネルのルート選択

トンネルのルート選択機能により、ルーティング テーブルのサブセットを使用してトンネル転送をルーティングできます。トンネルの宛先へのコストが等しいルートが複数ある場合、通常のトンネル転送動作は、ランダムに選択された使用可能なルートのいずれかを使用することになります。トンネルのルート選択機能により、トンネル転送の発信インターフェイスを明示的に設定できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「トンネルのルート選択の機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

トンネルのルート選択の前提条件

トンネル インターフェイスが選択されていることが前提です。

トンネルのルート選択の制約事項

この機能は、次のトンネル モードのみでサポートされます。

総称ルーティング カプセル化(GRE)

GRE マルチポイント

IP in IP

モバイル ユーザ データグラム プロトコル(UDP)

この機能は、トンネル転送が GRE マルチポイント トンネルの場合はトンネルではサポートされません。

サポートされている設定

interface tunnel 0
tunnel mode gre multipoint
tunnel route-via tunnel 1
interface tunnel 1
tunnel mode gre ip

サポートされない設定

interface tunnel 0
tunnel mode gre multipoint
tunnel route-via tunnel 1
interface tunnel 1
tunnel mode gre multipoint

トンネルのルート選択に関する情報

「トンネル転送動作」

トンネル転送動作

トンネルのルート選択機能により、トンネル転送の発信インターフェイスを指定してルーティング テーブルのサブセットを使用し、トンネル転送をルーティングすることができます。

トンネルのルート選択機能は、トンネル転送に関するポリシー ベース ルーティングの実装と同じではありません。トンネルのルート選択機能では、ルート テーブルのサブセットを 1 つだけ使用してトラフィックを転送できますが、ルーティング ループをネットワークに導入することはできません。

図 1 に、デフォルトのトンネル動作とトンネルのルート選択動作の比較を示します。

図 1 トンネルのルート選択トラフィック

 

トンネルのルート選択の設定方法

トンネルのルート選択の設定(必須)

トンネルのルート選択の設定

次の手順を実行して、トンネル転送の発信インターフェイスを指定し、ルーティング テーブルのサブセットを使用してトンネル転送のルーティングを行います。

手順の概要

1. enable

2. configure terminal

3. interface tunnel interface-number

4. tunnel route-via interface-type interface-number { mandatory | preferred }

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel interface-number

 

Router(config)# interface tunnel 0

トンネル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

tunnel route-via interface-type interface-number { mandatory | preferred }

 

Router(config-if)# tunnel route-via ethernet0 mandatory

トンネル転送が使用する発信インターフェイスを指定します。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

トラブルシューティングのヒント

設定のトラブルシューティングを行うには、特権 EXEC モードで debug tunnel route-via コマンドを使用します。 tunnel route-via コマンドでルーティング テーブルのサブセットを使用してトンネル転送の明示的ルーティングを行った後に実行した、 debug tunnel route-via コマンドからの出力例を次に示します。

Router# debug tunnel route-via
 
Tunnel route-via debugging is on
Router#
*May 23 08:40:53.707: TUN-VIA: Tunnel0 candidate route-via Ethernet0/0, next hop 10.73.2.1
*May 23 08:40:53.707: TUN-VIA: Tunnel0 route-via action is forward
*May 23 08:41:03.719: TUN-VIA: Tunnel0 candidate route-via Ethernet0/0, next hop 10.73.2.1
*May 23 08:41:03.719: TUN-VIA: Tunnel0 route-via action is forward
 
Router# undebug tunnel route-via
 
Tunnel route-via debugging is off

次の作業

トンネルのルート選択の設定を確認できます。設定を確認するには、特権 EXEC モードで show interfaces tunnel コマンドを使用します。トンネル転送の発信インターフェイスを指定することで、ルーティング テーブルのサブセットを使用してトンネル転送をルーティングする例を次に示します。

Router# show running-config interface tunnel 0
 
Building configuration...
 
Current configuration : 147 bytes
!
interface Tunnel0
ip unnumbered Loopback0
tunnel source Loopback0
tunnel destination 10.73.0.102
tunnel route-via Ethernet0 preferred
end
 
Router# show interfaces tunnel 0 | include route-via
 

Tunnel route-via feature is on [Ethernet0, preferred]

トンネルのルート選択の設定例

「例:トンネルのルート選択の設定」

例:トンネルのルート選択の設定

イーサネット インターフェイス 0 を優先的な発信転送インターフェイスとして使用するよう Tunnel 0 を設定する例を次に示します。イーサネット インターフェイス 0 からトンネルの宛先までのルートが存在する場合は、トンネル 0 インターフェイスを使用してルータを終了するトラフィックは、イーサネット インターフェイス 0 から送信されます。イーサネット インターフェイス 0 からのルートが存在しない場合は、トラフィックは、トンネルのルート選択機能が設定されていないかのように転送されます。

tunnel route-via interface-type interface-number mandatory コマンドが設定されており、そのインターフェイスを使用しているトンネルの宛先へのルートが存在しない場合、ポイントツーポイント トンネル インターフェイスはダウン状態になります。

Router> enable
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tunnel 0
Router(config-if)# tunnel route-via ethernet0 preferred
Router(config-if)# end
Router# show running-config interface tunnel 0
Building configuration...
 
Current configuration : 147 bytes
!
interface Tunnel0
ip unnumbered Loopback0
tunnel source Loopback0
tunnel destination 10.73.0.102
tunnel route-via Ethernet0 preferred
end
 

 

その他の参考資料

関連資料

関連項目
参照先

トンネルの実装

『Cisco IOS Interface and Hardware Component Configuration Guide』

インターフェイスおよびハードウェア コンポーネント コマンド:tunnel route-via、show interfaces tunnel

『Cisco IOS Interface and Hardware Component Command Reference』

デバッグ コマンド:debug tunnel route-via

『Cisco IOS Debug Command Reference』

標準

標準
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

トンネルのルート選択の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース トレインの中で特定の機能のサポートが導入された Cisco IOS ソフトウェア リリースだけを示します。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 1 トンネルのルート選択の機能情報

機能名
リリース
機能情報

トンネルのルート選択

12.4(11)T
15.0(1)M

トンネルのルート選択機能により、ルーティング テーブルのサブセットを使用してトンネル転送をルーティングできます。トンネルの宛先へのコストが等しいルートが複数ある場合、通常のトンネル転送動作は、ランダムに選択された使用可能なルートのいずれかを使用することになります。トンネルのルート選択機能により、トンネル転送の発信インターフェイスを明示的に設定できます。

この機能により、 debug tunnel route-via、tunnel route-via、show interfaces tunnel の各コマンドが導入または変更されました。