インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、 Cisco IOS Release15.2M&T
Rate-Based Satellite Control Protocol (RBSCP)
Rate-Based Satellite Control Protocol(RBSCP)
発行日;2012/06/25 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

Rate-Based Satellite Control Protocol(RBSCP)

機能情報の確認

内容

Rate Based Satellite Control Protocol の制約事項

Rate-Based Satellite Control Protocol(RBSCP)について

衛星リンクを介した IP

衛星リンクを介したプロキシを拡張するパフォーマンス

衛星リンクを介した RBSCP

Rate-Based Satellite Control Protocol(RBSCP)の設定方法

RBSCP トンネルの設定

前提条件

次の作業

RBSCP トンネルがアクティブであるかの確認

RBSCP トラフィックの確認

Rate-Based Satellite Control Protocol(RBSCP)の設定例

RBSCP トンネルの設定例

RBSCP トンネルのルーティングの設定例

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

Rate Based Satellite Control Protocol の機能情報

Rate-Based Satellite Control Protocol(RBSCP)

Rate-Based Satellite Control Protocol(RBSCP)は、衛星リンクなどのエラー レートが高い無線または長距離の遅延リンクのために設計されました。RBSCP では、トンネルを使用して、エンドツーエンド モデルを中断することなく衛星リンクを介して TCP および IP Security(IPSec)などの特定の IP プロトコルのパフォーマンスを改善できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

Rate Based Satellite Control Protocol の制約事項

RBSCP は、衛星リンクなどの、エラー レートが高い無線または長距離の遅延リンクのために設計されました。エラー レートが高い長距離遅延リンクがない場合は、この機能を実装しないでください。

RBSCP トンネルによって使用されるインターフェイス上に IP Access List(ACL; アクセス リスト)が設定されている場合、RBSCP IP プロトコル(199)では、動作しないインターフェイスまたはトンネルの開始および終了を行える必要があります。

トンネルを介するトラフィックはプロセスで切り替えられるため、RBSCP には一部パフォーマンス上の制約事項があります。

Rate-Based Satellite Control Protocol(RBSCP)について

「衛星リンクを介した IP」

「衛星リンクを介したプロキシを拡張するパフォーマンス」

「衛星リンクを介した RBSCP」

衛星リンクを介した IP

衛星リンクには、リンクを介する IP プロトコルに影響を及ぼすいくつかの特性があります。図 1 は、衛星リンクに 275 ミリ秒の単方向遅延が発生する可能性があることを示しています。550 ミリ秒の Round-Trip Time(RTT; ラウンドトリップ時間)は、TCP に対する非常に長時間の遅延です。別の問題は、LAN の無線リンクに比較して衛星リンクに通常発生する、エラー レート(パケット損失レート)が高いことです。天候さえ衛星リンクに影響を及ぼし、使用可能な帯域幅の減少、RTT およびパケット損失の増加を招きます。

図 1 通常の衛星リンク

 

RTT が長時間の場合、TCP は低速開始モードのままで、衛星リンク帯域幅全体が使用される前の時間が長くなります。TCP および Stream Control Transmission Protocol(SCTP)では、パケット損失イベントがネットワークの輻輳状態と解釈され、輻輳リカバリ手順の実行が開始されます。これによって、リンクを介して送信されるトラフィックが少なくなります。

使用可能な衛星リンク帯域幅は大きくなりますが、衛星リンクを介した IP プロトコルで発生する長時間の RTT および高いエラー レートによって、高い Bandwidth-Delay Product(BDP; 帯域遅延積)が生成されます。

衛星リンクを介したプロキシを拡張するパフォーマンス

衛星リンクの使用時に、低速開始モードで継続される TCP の問題に対処するために、中断を伴う Performance Enhancing Proxy(PEP)ソリューションがネットワークに導入されます。図 2 は、転送接続が、そのデフォルト ルータを介してインターネットに接続しているリモート側のホストで、3 つのセクションに分かれることを示したものです。ルータによって、すべてのインターネット バインド型トラフィックが TCP PEP に送信されます。これによって、インターネットへの TCP 接続が中断されます。PEP によって、すべてのデータのローカル TCP ACK(TCP スプーフィング)が生成されます。トラフィックはバッファリングされ、衛星リンクを介して 1 つの PEP プロトコルを介して再送信されます。2 つ目の PEP では、衛星リンクからのデータを受信し、別の TCP 接続を介してインターネットにデータが再送信されます。TCP 送信が妨害され、ドロップされたパケットは、TCP の輻輳として解釈されず、バッファリングされたデータから再送信されます。最小限の TCP ACK と抑制された TCP 低速の開始では、より多くの帯域幅を使用できます。

図 2 中断を伴う TCP PEP のソリューション

 

中断を伴う TCP PEP を使用する場合の欠陥の 1 つは、中断を伴う TCP PEP によって、エンドツーエンド モデルが中断されることです。トラフィックのフローが中断されると、一部のアプリケーションは動作できず、PEP では、暗号化トラフィック(IPSec)の処理の準備がありません。SCTP などの新しい転送プロトコルでは、中断を伴う TCP PEP で機能する場合に特別な処理または追加コードが必要です。各衛星ルータでは、追加の管理対象ネットワーク コンポーネントも必要です。

衛星リンクを介した RBSCP

RBSCP は、エンドツーエンド モデルを保持するために設計され、PEP ソリューションを使用して衛星リンクを介してパフォーマンスの改善がもたらされます。衛星リンク中でのクリア テキスト トラフィックの IPSec の暗号化(たとえば VPN サービス設定)はサポートされます。RBSCP を使用すると、2 つのルータで、衛星リンクの送信レートを制御およびモニタリングでき、帯域利用率が高まります。損失パケットは、RBSCP によって衛星リンクを介して再送信され、エンド ホスト TCP の送信側が低速開始モードになることが防止されます。

図 3 に示されているように、RBSCP はトンネル インターフェイスを使用して実装されます。トンネルは、衛星モデムまたは内部衛星モデム ネットワーク モジュールで使用可能な Cisco IOS ソフトウェアによってサポートされる任意のネットワーク インターフェイスを介して設定できます。IP トラフィックは、ルータ設定によって指定された適切な変更および機能拡張が使用される衛星リンクにまたがって送信されます。標準ルーティングまたはポリシーベース ルーティングを使用して、RBSCP トンネルを介して送信されるトラフィックを特定できます。

図 3 中断を伴わない RBSCP ソリューション

 

RBSCP トンネルでは、次のいずれかの機能を設定できます。

時間の遅延

RBSCP ルータの 1 つでは、RBSCP トンネルを介した転送のため、フレームを保持するよう設定できます。遅延時間は、エンド ホストでの RTT が増え、RBSCP 時間によって、損失 TCP フレームまたはその他のプロトコル フレームを再送信できます。再送信が正常に実行されると、損失フレーム イベントが、輻輳手順がイネーブルのエンド ホストに到達することが防止されます。一部の場合、遅延なしで RBSCP によって再送信を完了できます。

ACK の分割

受信した各 TCP ACK で生成された多数の追加の TCP ACK は、Acknowledgement(ACK)分割を使用したクリア テキスト TCP トラフィックでパフォーマンスを改善できます。TCP では、受信した各 TCP ACK の 1 つの Maximum Transmission Unit(MTU; 最大伝送ユニット)によって、輻輳ウィンドウが開きます。輻輳ウィンドウが開くと、より大きな帯域幅が使用可能になります。衛星リンクで使用可能なすべての帯域幅が使用されていないときにのみ、この機能を設定します。暗号化トラフィックでは、ACK 分割は使用できません。

ウィンドウ スタッフィング

クリア テキスト TCP トラフィックと SCTP トラフィックは、RBSCP ウィンドウ スタッフィング機能の利点を活用できます。RBSCP では、アドバタイジングされるウィンドウを、使用可能な衛星リンク帯域幅またはルータで使用可能なメモリまで増やすことができるよう、トラフィックをバッファリングできます。パケットを送信するエンド ホストでは、より大きなウィンドウが受信側のエンド ホストに存在し、より多くのトラフィックが送信されると、誤って見なされます。エンド ホストによって、衛星リンクに処理するトラフィックを多く送りすぎることがあり、発生したパケットの損失および再送信によって、リンクに輻輳状態が発生する可能性があるため、この機能は注意して使用してください。

SCTP ドロップ レポート

SCTP では、ACK 計算方式の代わりに適切なバイト計算方式を使用して送信ウィンドウのサイズが決定されるため、ACK 分割は、SCTP では動作しません。RBSCP トンネルでは、輻輳による損失の結果としてではなく、衛星全体でドロップされたパケットの SCTP パケット ドロップ レポートを生成できます。この SCTP ドロップ レポートはデフォルトでオンに設定されており、輻輳ウィンドウ サイズに影響を及ぼすことなくパケットを再送信する機会が提供されます。実際の輻輳損失は、引き続きレポートされますが、通常のリカバリ メカニズムがアクティブにされます。

Rate-Based Satellite Control Protocol(RBSCP)の設定方法

「RBSCP トンネルの設定」(必須)

「RBSCP トンネルがアクティブであるかの確認」(任意)

「RBSCP トラフィックの確認」(任意)

RBSCP トンネルの設定

RBSCP トンネルを設定するには、この作業を実行します。必ずトンネルの両側にルータを設定するようにしてください。

前提条件

この作業でトンネル ソースとして使用される物理インターフェイスは、すでに設定済みであることを確認してください。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip unnumbered interface-type interface-number

5. tunnel source { ip-address | interface-type interface-number }

6. tunnel destination { hostname | ip-address }

7. tunnel bandwidth { receive | transmit } bandwidth

8. tunnel mode { aurp | cayman | dvmrp | eon | gre | gre multipoint | ipip [ decapsulate-any ] | iptalk | mpls | nos | rbscp }

9. tunnel rbscp ack_split split-size

10. tunnel rbscp delay

11. tunnel rbscp report

12. tunnel rbscp window_stuff step-size

13. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface tunnel 0

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip unnumbered interface-type interface-number

 

Router(config-if)# ip unnumbered Ethernet 1

明示的な IP アドレスを割り当てずに、インターフェイスで IP 処理をイネーブルにします。

番号なしインターフェイスでパケットが生成される(たとえば、ルーティング アップデート)たびに、指定されたインターフェイスのアドレスが IP パケットのソース アドレスとして使用されます。

ステップ 5

tunnel source { ip-address | interface-type interface-number }

 

Router(config-if)# tunnel source Ethernet 1

トンネル送信元を設定します。

サービス プロバイダーの IP アドレスを指定する場合は、 ip-address 引数を使用します。

使用するインターフェイスを指定する場合は、 interface-type 引数および interface-number 引数を使用します。RBSCP では、インターフェイスをトンネル ソースとして指定することを推奨します。

ステップ 6

tunnel destination { hostname | ip-address }

 

Router(config-if)# tunnel destination 172.17.2.1

トンネル宛先を設定します。

サービス プロバイダーの IP アドレスを指定する場合は、 hostname 引数を使用します。

使用するインターフェイスを指定する場合は、 ip-address 引数を使用します。

ステップ 7

tunnel bandwidth { receive | transmit } bandwidth

 

Router(config-if)# tunnel bandwidth transmit 1000

パケットの送信に使用されるトンネル帯域幅を指定します。

帯域幅を指定する場合は、 bandwidth 引数を使用します。

は使用されなくなりました。

ステップ 8

tunnel mode { aurp | cayman | dvmrp | eon | gre | gre multipoint | ipip [ decapsulate-any ] | iptalk | mpls | nos | rbscp }

 

Router(config-if)# tunnel mode rbscp

トンネルで使用されるプロトコルを指定します。

RBSCP がトンネル プロトコルとして使用されるように指定する場合は、 rbscp 引数を使用します。

ステップ 9

tunnel rbscp ack_split split-size

 

Router(config-if)# tunnel rbscp ack_split 6

(任意)RBSCP トンネルで分割される TCP Acknowledgement(ACK)をイネーブルにします。

受信する各 ACK に送信される ACK の数を指定する場合は、 split-size 引数を使用します。

ACK のデフォルト数は 4 です。

ステップ 10

tunnel rbscp delay

 

Router(config-if)# tunnel rbscp delay

(任意)RBSCP トンネル遅延をイネーブルにします。

RTT が 700 ミリ秒よりも長い場合にのみ、このコマンドを使用します。

ステップ 11

tunnel rbscp report

 

Router(config-if)# tunnel rbscp report

(任意)ドロップされた RBSCP パケットを SCTP にレポートします。

ドロップされたパケットを SCTP にレポートすることによって、より優良な帯域幅が使用されます。これは、SCTP がエンド ホストに対してドロップされたパケットを再送信するよう指示し、これによって、エンド ホストでネットワークが輻輳していると見なされなくなるためです。

ステップ 12

tunnel rbscp window_stuff step-size

 

Router(config-if)# tunnel rbscp window_stuff 3

(任意)RBSCP トンネルの TCP ウィンドウ スケールの値を増やすことによって、TCP ウィンドウ スタッフィングをイネーブルにします。

ステップ増分数を指定する場合は、 step-size 引数を使用します。

ステップ 13

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

グローバル コンフィギュレーション モードを終了する場合は、この手順をもう一度繰り返します。

次の作業

この作業は、衛星リンクのもう一方の側にあるルータ上で繰り返す必要があります。2 つ目のルータ上の IP アドレスの例、ホスト名、および他のパラメータを、適切な値に置き換えます。

RBSCP トンネルがアクティブであるかの確認

この作業を実行して、「RBSCP トンネルの設定」の作業で設定された RBSCP トンネルがアクティブであることを確認します。

手順の概要

1. enable

2. show rbscp [ all | state | statistics ] [ tunnel tunnel-number ]

3. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show rbscp [ all | state | statistics ] [ tunnel tunnel-number ]
 
Router# show rbscp state tunnel 1

トンネルの現在の状態に関する情報を表示するには、 state キーワードおよび tunnel キーワードを指定してこのコマンドを使用します。次の出力例では、トンネルがオープン状態で示されています。すべてのカウンタで、最後に clear rbscp コマンドを実行した以降の累積合計が表示されます。

ステップ 3

exit

 

Router># exit

特権 EXEC コンフィギュレーション モードを終了します。

RBSCP トラフィックの確認

トラフィックが、RBSCP トンネルを介して、また、衛星リンク全体に送信されていることを確認するには、この作業を実行します。

手順の概要

1. enable

2. show interfaces tunnel number [ accounting ]

3. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show interfaces tunnel number [ accounting ]
 
Router# show interfaces tunnel 0

トラフィックが RBSCP トンネルを介して送信中であることを示すには、このコマンドを使用します。

ステップ 3

exit

 

Router># exit

特権 EXEC コンフィギュレーション モードを終了します。

Rate-Based Satellite Control Protocol(RBSCP)の設定例

「RBSCP トンネルの設定例」

「RBSCP トンネルのルーティングの設定例」

RBSCP トンネルの設定例

次に、衛星リンク経由の RBSCP トンネルを介してトラフィックが送信されるよう、ルータ 1 およびルータ 2 を設定します。

ルータ 1

interface Tunnel 0
ip unnumbered ethernet1
tunnel source ethernet1
tunnel destination 172.17.2.1
tunnel bandwidth transmit 1000
tunnel mode rbscp
tunnel rbscp ack_split 6
tunnel rbscp report
!
interface ethernet1
description Satellite Link
ip address 172.20.1.2 255.255.255.0

ルータ 2

interface Tunnel 0
ip unnumbered ethernet1
tunnel source ethernet1
tunnel destination 172.20.1.2
tunnel bandwidth transmit 1000
tunnel mode rbscp
tunnel rbscp ack_split 6
tunnel rbscp report
!
interface ethernet1
description Satellite Link
ip address 172.17.2.1 255.255.255.0

RBSCP トンネルのルーティングの設定例

RBSCP トンネルを使用するトラフィックのタイプを制御するには、適切なルーティングを設定する必要があります。すべてのトラフィックをトンネルを介して送信する場合、スタティック ルートを設定できます。


) ダイナミック ルーティング プロトコルが使用されている場合に、ルーティング フラップを防止するには、必ずトンネル インターフェイスをパッシブに設定してください。


次に、一部の特定のプロトコル タイプをトンネルを介して送信するために、ポリシー ベースのルーティングを使用する例を示します。この例では、拡張アクセス リストを使用して、TCP、Stream Control Transmission Protocol(SCTP)、Encapsulating Security Payload(ESP)プロトコル、および Authentication Header(AH; 認証ヘッダー)トラフィックで、トンネルを介した送信が可能です。すべての IP トラフィックは拒否されます。

ルータ 1(ローカル側)

interface Tunnel1
ip unnumbered FastEthernet1/1
tunnel source FastEthernet1/1
tunnel destination 10.12.0.20
tunnel mode rbscp
tunnel ttl 5
tunnel bandwidth transmit 30000
tunnel rbscp window_stuff 1
tunnel rbscp ack_split 4
!
interface FastEthernet0/0
ip address 10.13.0.1 255.255.255.0
ip policy route-map rbscp-pbr
duplex auto
speed auto
!
interface FastEthernet1/1
description Satellite Link
ip address 10.12.0.1 255.255.255.0
duplex auto
speed auto
!
ip route 10.15.0.0 255.255.255.0 FastEthernet1/1
!
ip access-list extended rbscp-acl
permit tcp any 10.15.0.0 0.0.0.255
permit 132 any 10.15.0.0 0.0.0.255
permit esp any 10.15.0.0 0.0.0.255
permit ahp any 10.15.0.0 0.0.0.255
deny ip any any
!
!
route-map rbscp-pbr permit 10
match ip address rbscp-acl
set interface Tunnel1

ルータ 2(リモート側)

ip dhcp pool CLIENT
import all
network 10.15.0.0 255.255.255.0
default-router 10.15.0.1
domain-name engineer.chicago.il.us
dns-server 10.10.0.252
!
interface Tunnel1
ip unnumbered FastEthernet0/1
tunnel source FastEthernet0/1
tunnel destination 10.12.0.1
tunnel mode rbscp
tunnel ttl 5
tunnel bandwidth transmit 30000
tunnel rbscp window_stuff 1
tunnel rbscp ack_split 4
!
interface FastEthernet0/0
description Local LAN
ip address 10.15.0.1 255.255.255.0
ip policy route-map rbscp-pbr
duplex auto
speed auto
!
interface FastEthernet0/1
description Satellite Link
ip address 10.12.0.20 255.255.255.0
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
ip access-list extended rbscp-acl
permit tcp any any
permit 132 any any
permit esp any any
permit ahp any any
deny ip any any
!
route-map rbscp-pbr permit 10
match ip address rbscp-acl
set interface Tunnel1

その他の参考資料

関連資料

関連項目
参照先

トンネル インターフェイス コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、使用に関する注意事項および例

『Cisco IOS Interface and Hardware Component Command Reference』

トンネルの設定

『Cisco IOS Interface and Hardware Component Configuration Guide』

標準

標準
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1323

『TCP Extensions for High Performance』

RFC 2018

『TCP Selective Acknowledgment Options』

シスコのテクニカル サポート

説明
リンク

TAC のホームページには、3 万ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

Rate Based Satellite Control Protocol の機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 AToM NSF Any Transport over MPLS および AToM グレースフル リスタートに関する機能情報

機能名
リリース
機能情報

Rate-Based Satellite Control Protocol(RBSCP)

12.3(7)T

この機能が導入されました。

次のコマンドが導入または変更されました。

clear rbscp、debug tunnel rbscp、show rbscp、tunnel bandwidth、tunnel mode、tunnel rbscp ack_split、tunnel rbscp delay、tunnel rbscp input_drop、tunnel rbscp long_drop、tunnel rbscp report、tunnel rbscp、window_stuff。