IP ルーティング:BGP コンフィギュレーション ガイド、 Cisco IOS Release 15.2M&T
BGP:RT 制約ルート配布の設定
BGP:RT 制約ルート配布の設定
発行日;2012/03/26 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

BGP:RT 制約ルート配布の設定

機能情報の確認

内容

BGP:RT 制約ルート配布の前提条件

BGP:RT 制約ルート配布の制限事項

BGP に関する情報:RT 制約ルート配布

BGP:RT 制約ルート配布により解決できる問題

BGP の利点:RT 制約ルート配布

BGP RT-Constrain SAFI

BGP:RT 制約ルート配布のしくみ

RT 制約 NLRI プレフィクス

RT 制約ルート配布のプロセスの例

デフォルトの RT フィルタ

RT 制約ルート配布の設定方法

PE ルータおよびルート リフレクタでのマルチプロトコル BGP の設定

MPLS VPN カスタマーの接続

カスタマーの接続を可能にするための、PE ルータでの VRF の定義

各 VPN カスタマー用の PE ルータでの VRF インスタンスの設定

BGP を PE ルータと CE ルータ間のルーティング プロトコルに設定

PE での RT 制約の設定

RR での RT 制約の設定

BGP:RT 制約ルート配布の設定例

例:PE と RR の間での BGP:RT 制約ルート配布

その他の参考資料

関連資料

MIB

RFC

シスコのテクニカル サポート

BGP:RT 制約ルート配布の機能情報

BGP:RT 制約ルート配布の設定

BGP: RT 制約ルート配布は、Route Reflector(RR; ルート リフレクタ)が RR および PE に送信する不要なルーティング アップデートを減らすためにサービス プロバイダがマルチプロトコル ラベル スイッチング(MPLS)Layer 3 Virtual Private Networks(L3VPN; レイヤ 3 バーチャル プライベート ネットワーク)で使用する機能です。ルーティング アップデートを減らすことにより、リソースを節約できます。RR、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)、PE が伝送するルートは少なくなります。ルーティング アップデートを制限するためにルート ターゲットが使用されます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「BGP:RT 制約ルート配布の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

BGP:RT 制約ルート配布の前提条件

BGP:RT 制約ルート配布を設定する前に、次の項目を設定する方法を理解している必要があります。

MPLS VPN

Route Distinguisher(RD; ルート識別子)

Route Target(RT; ルート ターゲット)

Multiprotocol BGP(MBGP; マルチプロトコル BGP)

BGP:RT 制約ルート配布の制限事項

BGP:RT 制約ルート配布では VPNv4 と VPNv6 のルート アドバタイズメントのみが制限されます。

BGP に関する情報:RT 制約ルート配布

「BGP:RT 制約ルート配布により解決できる問題」

「BGP の利点:RT 制約ルート配布」

「BGP RT-Constrain SAFI」

「BGP:RT 制約ルート配布のしくみ」

「RT 制約 NLRI プレフィクス」

「RT 制約ルート配布のプロセスの例」

「デフォルトの RT フィルタ」

BGP:RT 制約ルート配布により解決できる問題

一部のサービス プロバイダーでは、RR から PE に大量のルーティング アップデートが送信され、その結果リソースが大量に消費されます。PE では、PE にない VRF のルーティング アップデートは必要ではありません。そのため、PE は受信するルーティング アップデートの大部分を不要であると判断します。PE はこの不要なアップデートを除外します。

図 1 に、2 つの PE に不要なルーティング アップデートが送信される場合の例を示します。

図 1 PE での不要なルーティング アップデート

図 1 に示すとおり、PE は次のように不要なルートを受信しています。

1. PE-3 は VRF Blue および VRF Red ルートを RR-1 にアドバタイズします。PE-4 は VRF Red および VRF Green ルートを RR-1 にアドバタイズします。

2. RR-1 にすべての VRF(Blue、Red、Green)に対するすべてのルートが集まります。

3. ルートの更新または VRF プロビジョニングの実行時に、RR-1 はすべての VRF ルートを PE-3 と PE-4 の両方にアドバタイズします。

4. VRF Green のルートは PE-3 では不要です。VRF Blue のルートは PE-4 では不要です。

次に、2 つの RR と、もう 1 組の PE がある場合を見てみましょう。RR から PE に不要なルーティング アップデートが送信されるだけでなく、RR 間でも不要なルーティング アップデートが送信されています。図 2 に、RR に不要なルートが送信される場合の例を示します。

図 2 RR での不要なルーティング アップデート

図 2 に示すとおり、RR-1 と RR-2 は次のように不要なルーティング アップデートを受信しています。

1. PE-3 と PE-4 は VRF Blue、VRF Red、VRF Green の各 VPN ルートを RR-1 にアドバタイズしています。

2. RR-1 はすべての VPN ルートを RR-2 に送信します。

3. PE-1 と PE-2 には VRF Red がないため、VRF Red ルートは RR-2 では不要です。

4. 同様に、PE-3 と PE-4 には VRF Purple がないため、VRF Purple ルートは RR-1 では不要です。

そのため、RR と PE の間で不要なルートが大量にアドバタイズされる可能性があります。BGP:RT 制約ルート配布機能を使用すると、不要なルーティング アップデートを除外することによりこの問題を解決できます。

BGP:RT 制約ルート配布を使用しない場合、アップデートのフィルタリングは PE が行います。この機能を使用すると、アップデートのフィルタリングは RR が行うようになります。

BGP の利点:RT 制約ルート配布

MPLS L3VPN では、PE ルータが BGP と RT 拡張コミュニティを使用して VRF との間での VPN ルートの配布を制御し、VPN を隔離します。PE と Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)は、受信した VPN ルートをフィルタリングして、不要な VPN ルートを除外します。

ただし、不要な VPN ルートの受信とフィルタリングの処理はリソースの浪費につながります。送信元が VPN ルーティング アップデートを生成および送信すると、受信側で不要なルートが除外されます。これによりリソースが節約され、そのような VPN ルート アップデートが最初から生成されないようになります。

ARTF は VPN Network Layer Reachability Information(NLRI; ネットワーク層到達可能性情報)が RR から VPN を必要としない PE に伝播されないようにするためのメカニズムです。この機能により、CPU サイクルと一時メモリの使用量が大幅に削減されます。RT 制約により、VPN ルートの数が制限され、VPN メンバーシップが規定されます。

BGP RT-Constrain SAFI

BGP:RT 制約ルート配布機能では、新しい Subsequent Address Family Identifier(SAFI)である BGP RT-Constrain SAFI が導入されています。アドレス ファミリを入力するためのコマンドは address-family rtfilter unicast コマンドです。

BGP:RT 制約ルート配布のしくみ

「BGP:RT 制約ルート配布により解決できる問題」 で説明したように不要なルートをフィルタリングにより除外するには、PE と RR に BGP:RT 制約ルート配布機能を設定する必要があります。

この機能により、PE は RT メンバーシップを伝播させ、その RT メンバーシップを使用して PE と RR で維持する VPN ルーティング情報を制限できるようになります。PE は MP-BGP UPDATE メッセージを使用してメンバーシップ情報を伝播させます。RR は受信した RT メンバーシップに基づいて VPN ルートのアドバタイズメントを制限します。

この機能により、次の 2 種類の情報が交換されます。

PE は RT 制約 Network Layer Reachability Information(NLRI; ネットワーク層到着可能性情報)を RR に送信します。

RR はアウトバウンド ルート フィルタをインストールします。

図 3 に、RT Constraint(RTC; RT 制約)NLRI とアウトバウンド ルート フィルタの交換を示します。

図 3 PE と RR の間での RTC NLRI とフィルタの交換

図 3 に示すとおり、PE と RR の間では次の情報交換が行われます。

1. PE-3 が RTC NLRI {RT 1, RT 2} を RR-1 に送信します。

2. PE-4 が RTC NLRI {RT 2, RT 3} を RR-1 に送信します。

3. RR-1 は NLRI をアウトバウンド ルート フィルタに変換し、このフィルタ(Permit RT 1, RT 2)を PE-3 にインストールします。

4. RR-1 は NLRI をアウトバウンド ルート フィルタに変換し、このフィルタ(Permit RT 2, RT 3)を PE-4 にインストールします。

RT 制約 NLRI プレフィクス

RT 制約 NLRI の形式は、長さが 12 バイトのプレフィクスで、次の項目で構成されています。

4 バイトの送信元自律システム

8 バイトの RT 拡張コミュニティ値

次に、RT 制約プレフィクスの例を示します。

65000:2:100:1

送信元自律システム番号:65000

BGP 拡張コミュニティのタイプ コード:2

ルート ターゲット:100:1

65001:256:192.0.0.1:100

送信元 ASN:65001

BGP 拡張コミュニティのタイプ コード:256

ルート ターゲット:192.0.0.1:100

1.10:512:1.10:2

送信元 ASN は 4 バイトで一意の 1.10

BGP 拡張コミュニティのタイプ コード:512

ルート ターゲット:1.10:2

BGP 拡張コミュニティのタイプコードの意味については、RFC 4360『 BGP Extended Communities Attribute 』を参照してください。最初の例では、2 は 16 進数の 0x002 に変換されます。RFC 4360 では、0x002 はタイプ コードの後に続く値が 2 オクテットの AS 固有のルート ターゲットであることを示します。

RT 制約ルート配布のプロセスの例

RT 制約ルート配布のプロセスを示すため、この例では PE1 に接続されている AS 100 に 2 つの CE ルータを設置してあります。PE1 は同様に CE ルータに接続されている PE2 と通信します。PE 間には Route Reflector(RR; ルート リフレクタ)があります。PE1 と PE2 は AS 65000 に属しています。

この機能の一般的なプロセスは次のとおりです。

1. ユーザは address-family rtfilter unicast コマンドを使用して、PE1 が BGP ピアをアクティブにするよう設定します。

2. たとえば、AS 65000 の PE1 に対して route-target import 100:1 を設定します。

3. PE1 はこのコマンドを 65000:2:100:1 という RT プレフィクスに変換します。65000 はサービス プロバイダーの AS 番号、2 は BGP 拡張コミュニティのタイプ コード、100:1 は CE の RT(AS 番号および別の番号)です。

4. PE1 は RT Constrain(RTC; RT 制約)プレフィクス 65000:2:100:1 を iBGP ピア RR にアドバタイズします。

5. RR は RTC 65000:2:100:1 を RTC RIB にインストールします。VRF にはそれぞれ独自の RIB があります。

6. また、RR は RTC 65000:2:100:1 をネイバー PE2 のアウトバウンド フィルタにインストールします。

7. RR には RT を許可または拒否するフィルタがあります(iBGP は 1 つの AS で動作していて、AS 番号を追跡する必要はないため、AS 番号は無視されます)。

8. PE1 はアップデート パケットを RR に送信します。RR はフィルタを参照し、アウトバウンド パケットが許可されることを確認します。

デフォルトの RT フィルタ

デフォルトの RT フィルタは、値が 0、長さが 0 に設定されています。デフォルトの RT フィルタは次の場合に使用されます。

RT 値にかかわらずすべての VPN ルートをピアに送信するようにピアで指定される

PE がすべての VPN ルートを RR にアドバタイズするように RR で要求される

デフォルトの RT フィルタを作成するには、 address-family rtfilter unicast コマンドで neighbor default-originate コマンドを設定します。

RT 制約ルート配布の設定方法

BGP:RT 制約ルート配布を設定するには、次の作業を実行します。最初の 3 つの作業は MPLS 環境で一般的なものです。最後の作業は、指定した BGP ネイバーと自動 RT フィルタ情報を交換するためのものです。

「PE ルータおよびルート リフレクタでのマルチプロトコル BGP の設定」(必須)

「MPLS VPN カスタマーの接続」(必須)

「PE での RT 制約の設定」(必須)

「RR での RT 制約の設定」(必須)

PE ルータおよびルート リフレクタでのマルチプロトコル BGP の設定

PE ルータおよびルート リフレクタで Multiprotocol BGP(MP-BGP; マルチプロトコル BGP)接続を設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. no bgp default ipv4-unicast

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } activate

7. address-family vpnv4 [ unicast ]

8. neighbor { ip-address | peer-group-name } send-community extended

9. neighbor { ip-address | peer-group-name } activate

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用できるプライベート自律システム番号の範囲は、64512 ~ 65535 です。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

(任意)IPv4 ユニキャスト アドレス ファミリをすべてのネイバーでディセーブルにします。

ネイバーを MPLS ルートだけに使用している場合は、 bgp default ipv4-unicast コマンドを no 形式で使用します。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor pp.0.0.1 remote-as 100

BGP ネイバー テーブルまたはマルチプロトコル BGP ネイバー テーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router)# neighbor pp.0.0.1 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

unicast キーワード(任意)では、VPNv4 ユニキャスト アドレス プレフィクスを指定します。

ステップ 8

neighbor { ip-address | peer-group-name } send-community extended

 

Router(config-router-af)# neighbor pp.0.0.1 send-community extended

コミュニティ属性が BGP ネイバーに送信されるように指定します。

ip-address 引数には、BGP 対応ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 9

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor pp.0.0.1 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 10

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show ip bgp neighbor コマンドを入力すると、ネイバーが稼動中であることを確認できます。このコマンドが成功しなかった場合は、 debug ip bgp x.x.x.x events コマンドを入力します。ここで、 x.x.x.x はネイバーの IP アドレスです。

カスタマーの接続を可能にするための、PE ルータでの VRF の定義

Virtual Routing and Forwarding(VPN Routing and Forwarding; VPN ルーティング/転送)インスタンスを定義するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target { import | export | both } route-target-ext-community

6. import map route-map

7. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf vpn1

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てる名前です。

ステップ 4

rd route-distinguisher

 
Router(config-vrf)# rd 100:1

ルーティング テーブルと転送テーブルを作成します。

route-distinguisher 引数によって、8 バイトの値が IPv4 プレフィクスに追加され、VPN IPv4 プレフィクスが作成されます。RD は、次のいずれかの形式で入力できます。

16 ビットの AS 番号:32 ビットの番号。101:3 など。

32 ビットの IP アドレス:16 ビットの番号。192.168.122.15:1 など。

ステップ 5

route-target { import | export | both } route-target-ext-community

 

Router(config-vrf)# route-target import 100:1

VRF 用にルート ターゲット拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ターゲット VPN 拡張コミュニティとの間でルーティング情報がインポートおよびエクスポートされます。

route-target-ext-community 引数により、RT 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の RT 拡張コミュニティの VRF リストに追加されます。

ステップ 6

import map route-map

 

Router(config-vrf)# import map vpn1-route-map

(任意)VRF のインポート ルート マップを設定します。

route-map 引数には、VRF のインポート ルート マップとして使用されるルート マップを指定します。

ステップ 7

exit

 

Router(config-vrf)# exit

(任意)終了して、グローバル コンフィギュレーション モードに戻ります。

各 VPN カスタマー用の PE ルータでの VRF インスタンスの設定

PE ルータ上のインターフェイスまたはサブインターフェイスに VRF を関連付けるには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip vrf forwarding vrf-name

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 5/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数で、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 4

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding vpn1

指定したインターフェイスまたはサブインターフェイスに VRF を関連付けます。

vrf-name 引数は、VRF に割り当てる名前です。

ステップ 5

end

 

Router(config-if)# end

(任意)終了して、特権 EXEC モードに戻ります。

BGP を PE ルータと CE ルータ間のルーティング プロトコルに設定

BGP を使用して PE と CE の間のルーティング セッションを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } activate

7. exit-address-family

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用できるプライベート自律システム番号の範囲は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vpn1

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router-af)# neighbor pp.0.0.1 remote-as 200

BGP ネイバー テーブルまたはマルチプロトコル BGP ネイバー テーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor pp.0.0.1 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 8

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

PE での RT 制約の設定

この作業を PE で行うと、指定したネイバーで BGP:RT 制約ルート配布が設定されます。また、RT フィルタリングが発生しているかどうかを確認することもできます(任意)。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family rtfilter unicast

5. neighbor { ip-address | peer-group-name } activate

6. end

7. show ip bgp rtfilter all

8. show ip bgp rtfilter all summary

9. show ip bgp vpnv4 all

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 1

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family rtfilter unicast

 

Router(config-router)# address-family rtfilter unicast

RT フィルタ アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 5

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.0.0.1 activate

指定した BGP ネイバーとの自動 RT フィルタ情報を交換できるようにします。

ステップ 6

end

 

Router(config-router-af)# end

コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 7

show ip bgp rtfilter all

 

Router# show ip bgp rtfilter all

(任意)すべての BGP RT フィルタ情報を表示します。

ステップ 8

show ip bgp rtfilter all summary

 

Router# show ip bgp rtfilter all summary

(任意)BGP RT フィルタのサマリー情報を表示します。

ステップ 9

show ip bgp vpnv4 all

 

Router# show ip bgp vpnv4 all

(任意)BGP VPNv4 フィルタのサマリー情報を表示します。

RR での RT 制約の設定

この作業を RR で行うと、指定したネイバーで BGP:RT 制約ルート配布が設定されます。また、RT フィルタリングが発生しているか確認することもできます(任意)。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family rtfilter unicast

5. neighbor { ip-address | peer-group-name } send-community extended

6. neighbor { ip-address | peer-group-name } activate

7. neighbor { ip-address | peer-group-name } route-reflector-client

8. end

9. show ip bgp rtfilter all

10. show ip bgp rtfilter all summary

11. show ip bgp vpnv4 all

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 1

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family rtfilter unicast

 

Router(config-router)# address-family rtfilter unicast

RT フィルタ アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 5

neighbor { ip-address | peer-group-name } send-community extended

 

Router(config-router-af)# neighbor pp.0.0.1 send-community extended

コミュニティ属性が BGP ネイバーに送信されるように指定します。

ip-address 引数には、BGP 対応ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.0.0.2 activate

指定した BGP ネイバーでの RT 制約をイネーブルにします。

ステップ 7

neighbor { ip-address | peer-group-name } route-reflector-client

 

Router(config-router-af)# neighbor 10.0.0.2 route-reflector-client

指定した BGP ネイバーでの RT 制約をイネーブルにします。

neighbor route-reflector-client コマンドを設定すると、ルータは自動的にデフォルトの RT フィルタを送信し、PE がすべての VPN ルートを RR に送信するように要求します(「デフォルトの RT フィルタ」 を参照してください)。そのため、 neighbor default-originate コマンドを設定する必要はありません。

ステップ 8

end

 

Router(config-router-af)# end

コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 9

show ip bgp rtfilter all

 

Router# show ip bgp rtfilter all

(任意)すべての BGP RT フィルタ情報を表示します。

ステップ 10

show ip bgp rtfilter all summary

 

Router# show ip bgp rtfilter all summary

(任意)BGP RT フィルタのサマリー情報を表示します。

ステップ 11

show ip bgp vpnv4 all

 

Router# show ip bgp vpnv4 all

(任意)BGP VPNv4 フィルタのサマリー情報を表示します。

BGP:RT 制約ルート配布の設定例

「例:PE と RR の間での BGP:RT 制約ルート配布」

例:PE と RR の間での BGP:RT 制約ルート配布

次の例は、図 4 のルータの設定を示しています。PE1 と PE2 はいずれも RR に接続されていて、AS 65000 に属しています。

図 4 PE と RR の間での BGP:RT 制約ルート配布

PE1 の設定

ip vrf BLUE
rd 3:3
route-target export 1:100
route-target import 1:100
!
router bgp 65000
bgp log-neighbor-changes
neighbor 192.168.2.2 remote-as 1
neighbor 192.168.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 192.168.2.2 activate
neighbor 192.168.2.2 send-community extended
exit-address-family
!
address-family rtfilter unicast
neighbor 192.168.2.2 activate
neighbor 192.168.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf BLUE
redistribute static
exit-address-family
!
ip route vrf BLUE 51.51.51.51 255.255.255.255 Null0
!

RR の設定

!
router bgp 65000
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.6.6 remote-as 1
neighbor 192.168.6.6 update-source Loopback0
neighbor 192.168.7.7 remote-as 1
neighbor 192.168.7.7 update-source Loopback0
!
address-family vpnv4
neighbor 192.168.6.6 activate
neighbor 192.168.6.6 send-community extended
neighbor 192.168.6.6 route-reflector-client
neighbor 192.168.7.7 activate
neighbor 192.168.7.7 send-community extended
neighbor 192.168.7.7 route-reflector-client
exit-address-family
!
address-family rtfilter unicast
neighbor 192.168.6.6 activate
neighbor 192.168.6.6 send-community extended
neighbor 192.168.6.6 route-reflector-client
neighbor 192.168.7.7 activate
neighbor 192.168.7.7 send-community extended
neighbor 192.168.7.7 route-reflector-client
exit-address-family
!

PE2 の設定

!
ip vrf RED
rd 17:17
route-target export 150:15
route-target import 150:1
route-target import 1:100
!
router bgp 65000
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.2.2 remote-as 1
neighbor 192.168.2.2 update-source Loopback0
neighbor 192.168.2.2 weight 333
no auto-summary
!
address-family vpnv4
neighbor 192.168.2.2 activate
neighbor 192.168.2.2 send-community extended
exit-address-family
!
address-family rtfilter unicast
neighbor 192.168.2.2 activate
neighbor 192.168.2.2 send-community extended
exit-address-family
!

その他の参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases

BGP コマンド

Cisco IOS IP Routing: BGP Command Reference

L3VPNs とルート ターゲット

Cisco IOS MPLS Configuration Guide 』の「 Configuring MPLS Layer 3 VPNs

MPLS コマンド

『Cisco IOS Multiprotocol Label Switching Command Reference』

MIB

MIB
MIB リンク

--

選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 4360

『BGP Extended Communities Attribute』

RFC 4684

『Constrained Route Distribution for Border Gateway Protocol/MultiProtocol Label Switching (BGP/MPLS) Internet Protocol (IP) Virtual Private Networks (VPNs)』

RFC 5291

『Outbound Route Filtering Capability for BGP-4』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

BGP:RT 制約ルート配布の機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 BGP:RT 制約ルート配布の機能情報

機能名
リリース
機能情報

BGP:RT 制約ルート配布

15.1(1)S

BGP:ルート ターゲット(RT)制約ルート配布は、RR が PE に送信する不要なルーティング アップデートを減らすことによりリソースを節約するためにサービス プロバイダが MPLS L3VPN で使用する機能です。

次のコマンドが導入されました。

address-family rtfilter unicast

show ip bgp rtfilter

Copyright © 2010-2012, シスコシステムズ合同会社.
All rights reserved.