IP ルーティング:BGP コンフィギュレーション ガイド、 Cisco IOS Release 15.2M&T
BGP ルータ ID の VRF 単位での割り当て
BGP ルータ ID の VRF 単位での割り当て
発行日;2012/03/26 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

BGP ルータ ID の VRF 単位での割り当て

機能情報の確認

内容

BGP ルータ ID の VRF 単位での割り当ての前提条件

BGP ルータ ID の VRF 単位での割り当てに関する情報

BGP ルータ ID

VRF 単位でのルータ ID の割り当て

ルート識別子

BGP ルータ ID の VRF 単位での割り当ての設定方法

VRF インスタンスの設定

前提条件

VRF インスタンスとインターフェイスの関連付け

前提条件

VRF 単位での BGP ルータ ID の手動設定

前提条件

VRF 単位での BGP ルータ ID の自動割り当て

前提条件

BGP ルータ ID の VRF 単位での割り当ての設定例

VRF 単位での BGP ルータ ID の手動設定:例

VRF 単位での BGP ルータ ID の自動割り当て:例

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

BGP ルータ ID の VRF 単位での割り当てに関する機能情報

BGP ルータ ID の VRF 単位での割り当て

BGP ルータ ID の VRF 単位の割り当て機能により、同じルータ上のボーダー ゲートウェイ プロトコル(BGP)内に VRF-to-VRF ピアリングを持つ機能が追加されます。BGP は、ルータ ID チェックのため、BGP 自身でセッションを拒否するように設計されています。VRF 単位の割り当て機能を使用すると、既存の bgp router-id コマンドの新しいキーワードを使用して、VRF 単位で異なるルータ ID を使用できます。ルータ ID は、VRF 単位での手動設定、または、アドレス ファミリ コンフィギュレーション モードでのグローバルな自動割り当てや VRF 単位の自動割り当てが可能です。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「BGP ルータ ID の VRF 単位での割り当てに関する機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

BGP ルータ ID の VRF 単位での割り当ての前提条件

この機能を設定する前に、ネットワーク内で Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)または distributed CEF(dCEF; 分散 CEF)がイネーブルになっている必要があり、また、BGP ピアリングがネットワーク内で実行されていることが前提になっています。

BGP ルータ ID の VRF 単位での割り当てに関する情報

「BGP ルータ ID」

「VRF 単位でのルータ ID の割り当て」

「ルート識別子」

BGP ルータ ID

BGP ルータ ID は、ルータの最大 IP アドレスに設定される 4 バイト フィールドです。ループバック インターフェイス アドレスは物理インターフェイスよりも安定しているため、ループバック インターフェイスのアドレスが物理インターフェイスよりも前に考慮されます。BGP ルータ ID は、最小ルータ ID を持つ BGP ルータにプリファレンスが設定されている宛先への最良パスを決定するために、BGP アルゴリズムで使用されます。 bgp router-id コマンドで BGP ルータ ID を手動で設定して、最良パスのアルゴリズムに影響を与えることが可能です。

VRF 単位でのルータ ID の割り当て

Cisco IOS Release 12.2(31)SB2、12.2(33)SRA、12.2(33)SXH、12.4(20)T、およびこれ以降のリリースでは、各バーチャル プライベート ネットワーク(VPN)routing/forwarding(VRF; VPN ルーティング/転送)インスタンスに対する個別のルータ ID の設定に対するサポートが追加されました。BGP ルータ ID の VRF 単位の割り当て機能により、同じルータ上のボーダー ゲートウェイ プロトコル(BGP)内に VRF-to-VRF ピアリングを持つ機能が追加されます。BGP は、ルータ ID チェックのため、BGP 自身でセッションを拒否するように設計されています。VRF 単位の割り当て機能を使用すると、既存の bgp router-id コマンドの新しいキーワードを使用して、VRF 単位で異なるルータ ID を使用できます。ルータ ID は、VRF 単位での手動設定、または、アドレス ファミリ コンフィギュレーション モードでのグローバルな自動割り当てや VRF 単位の自動割り当てが可能です。

ルート識別子

Route Distinguisher(RD; ルート識別子)はルーティング テーブルとフォワーディング テーブルを作成し、VPN のデフォルトのルート識別子を指定します。IPv4 プレフィクスをグローバルに固有の VPN-IPv4 プレフィクスに変更するために、RD が IPv4 プレフィクスの先頭に追加されます。RD は、自律システム番号と任意番号、または IP アドレスと任意番号のいずれかで構成できます。RD は、次のいずれかの形式で入力できます。

16 ビット自律システム番号、コロン、32 ビット番号を入力します。次に例を示します。

45000:3

32 ビット IP アドレス、コロン、16 ビット番号を入力します。次に例を示します。

192.168.10.15:1

BGP ルータ ID の VRF 単位での割り当ての設定方法

各 VRF に BGP ルータ ID を設定するには、主に 2 つの方法があります。VRF 単位で BGP ルータ ID を手動で設定するには、まず、次に示される最初の 3 つの作業を実行する必要があります。自動的に BGP ルータ ID を各 VRF に割り当てるには、最初の作業と 4 番目の作業を実行する必要があります。

「VRF インスタンスの設定」

「VRF インスタンスとインターフェイスの関連付け」

「VRF 単位での BGP ルータ ID の手動設定」

「VRF 単位での BGP ルータ ID の自動割り当て」

VRF インスタンスの設定

VRF インスタンスを VRF 割り当て作業で使用されるように設定するには、この作業を実行します。この作業では、vrf_trans という名前の VRF インスタンスが作成されます。VRF を機能させるために、Route Distinguisher(RD; ルート識別子)が作成されます。ルート識別子が作成されると、vrf_trans という名前の VRF インスタンスにルーティング テーブルとフォワーディング テーブルが作成されます。

前提条件

この作業は、CEF または dCEF をイネーブルにしていることを前提としています。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target { import | both } route-target-ext-community

6. route-target { export | both } route-target-ext-community

7. exit

8. 定義する VRF 単位で、ステップ 3 ~ステップ 7 を繰り返します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf vrf_trans

VRF インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 45000:2

VRF にルーティング テーブルとフォワーディング テーブルを作成し、VPN にデフォルト RD を指定します。

VPN にデフォルト RD を指定するには、 route-distinguisher 引数を使用します。RD の指定に使用できる形式は 2 つあります。詳細については、「ルート識別子」を参照してください。

この例では、RD は、コロンの後に番号 2 を持つ自律システム番号を使用します。

ステップ 5

route-target { import | both } route-target-ext-community

 

Router(config-vrf)# route-target import 55000:5

VRF 用にルート ターゲット拡張コミュニティを作成します。

ターゲット VPN 拡張コミュニティからルーティング情報をインポートするには、 import キーワードを使用します。

ターゲット VPN 拡張コミュニティとの間でルーティング情報のインポートとエクスポートの両方を実行するには、 both キーワードを使用します。

VPN 拡張コミュニティを指定するには、 route-target-ext-community 引数を使用します。

ステップ 6

route-target { export | both } route-target-ext-community

 

Router(config-vrf)# route-target export 55000:1

VRF 用にルート ターゲット拡張コミュニティを作成します。

ターゲット VPN 拡張コミュニティにルーティング情報をエクスポートするには、 export キーワードを使用します。

ターゲット VPN 拡張コミュニティとの間でルーティング情報のインポートとエクスポートの両方を実行するには、 both キーワードを使用します。

VPN 拡張コミュニティを指定するには、 route-target-ext-community 引数を使用します。

ステップ 7

exit

 

Router(config-vrf)# exit

VRF コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

定義する VRF 単位で、ステップ 3 ~ステップ 7 を繰り返します。

--

VRF インスタンスとインターフェイスの関連付け

VRF 単位での割り当て作業で使用されるインターフェイスに VRF インスタンスを関連付けるには、この作業を実行します。この作業では、vrf_trans という名前の VRF インスタンスがシリアル インターフェイスに関連付けられます。

ip vrf forwarding コマンドにより IP アドレスが削除されるため、VRF インスタンスを関連付けるインターフェイスの IP アドレスをメモしておいてください。ステップ 8 で IP アドレスを再設定できます。

前提条件

この作業は、CEF または dCEF をイネーブルにしていることを前提としています。

この作業は、VRF インスタンスが「VRF インスタンスの設定」で設定されていることを前提としています。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask [ secondary ]

5. exit

6. interface type number

7. ip vrf forwarding vrf-name [ downstream vrf-name2 ]

8. ip address ip-address mask [ secondary ]

9. インターフェイスに関連付ける VRF 単位で、ステップ 5 ~ 8 を繰り返します。

10. end

11. show ip vrf [ brief | detail | interfaces | id ] [ vrf-name ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface loopback0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

この例では、ループバック インターフェイス 0 が設定されます。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 172.16.1.1 255.255.255.255

IP アドレスを設定します。

この例では、ループバック インターフェイスが 172.16.1.1 の IP アドレスで設定されます。

ステップ 5

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

interface type number

 

Router(config)# interface serial2/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

この例では、シリアル インターフェイス 2/0 が設定されます。

ステップ 7

ip vrf forwarding vrf-name [ downstream vrf-name2 ]

 

Router(config-if)# ip vrf forwarding vrf_trans

VRF をインターフェイスまたはサブインターフェイスと関連付けます。

この例では、vrf_trans という名前の VRF がシリアル インターフェイス 2/0 に関連付けられます。

(注) インターフェイスにこのコマンドを実行すると、IP アドレスが削除されます。IP アドレスを再設定する必要があります。

ステップ 8

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 192.168.4.1 255.255.255.0

IP アドレスを設定します。

この例では、シリアル インターフェイス 2/0 が 192.168.4.1 の IP アドレスで設定されます。

ステップ 9

インターフェイスに関連付ける VRF 単位で、ステップ 5 ~ 8 を繰り返します。

--

ステップ 10

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 11

show ip vrf [ brief | detail | interfaces | id ] [ vrf-name ]

 

Router# show ip vrf interfaces

(任意)定義された VRF および関連付けられたインターフェイスのセットを表示します。

この例では、このコマンド出力に、作成された VRF および関連付けられたインターフェイスが表示されます。

次の出力は、vrf_trans と vrf_users という名前の 2 つの VRF インスタンスが 2 つのシリアル インターフェイスに設定されたことを示しています。

Router# show ip vrf interfaces
 
Interface IP-Address VRF Protocol
Serial2 192.168.4.1 vrf_trans up
Serial3 192.168.5.1 vrf_user up

VRF 単位での BGP ルータ ID の手動設定

VRF 単位で BGP ルータ ID を手動で設定するには、この作業を実行します。この作業では、複数のアドレス ファミリ コンフィギュレーションが示され、1 つの VRF インスタンスに対して、IPv4 アドレス ファミリ モードでルータ ID が設定されます。ステップ 22 は、特定のステップを繰り返して、同じルータ上で複数の VRF の設定を許可する方法を示します。

前提条件

この作業は、事前に VRF インスタンスを作成し、そのインスタンスをインターフェイスに関連付けていることを前提とします。詳細については、「VRF インスタンスの設定」および「VRF インスタンスとインターフェイスの関連付け」を参照してください。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. no bgp default ipv4-unicast

5. bgp log-neighbor-changes

6. neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

7. neighbor { ip-address | peer-group-name } update-source interface-type interface-number

8. address-family { ipv4 [ mdt | multicast | unicast [ vrf vrf-name ] | vrf vrf-name ] | vpnv4 [ unicast ]}

9. neighbor { ip-address | peer-group-name } activate

10. neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

11. exit-address-family

12. address-family { ipv4 [ mdt | multicast | unicast [ vrf vrf-name ] | vrf vrf-name ] | vpnv4 [ unicast ]}

13. redistribute connected

14. neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

15. neighbor ip-address local-as autonomous-system-number [ no-prepend [ replace-as [ dual-as ]]]

16. neighbor { ip-address | peer-group-name } ebgp-multihop [ ttl ]

17. neighbor { ip-address | peer-group-name } activate

18. neighbor ip-address allowas-in [ number ]

19. no auto-summary

20. no synchronization

21. bgp router-id { ip-address | auto-assign }

22. 別の VRF インスタンスを設定するには、ステップ 11 ~ 21 を繰り返します。

23. end

24. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 45000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ルーティング プロセスで使用される IPv4 ユニキャスト アドレス ファミリをディセーブルにします。

ルータ コンフィギュレーション コマンドを設定した場合は例外です。既存のネイバー コンフィギュレーションは影響されません。

ステップ 5

bgp log-neighbor-changes

 

Router(config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 6

neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

 

Router(config-router)# neighbor 192.168.1.1 remote-as 45000

指定された自律システム内のネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致する場合、ネイバーは内部ネイバーになります。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致しない場合、ネイバーは外部ネイバーになります。

この例では、ネイバーは内部ネイバーになります。

ステップ 7

neighbor { ip-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 192.168.1.1 update-source loopback0

BGP セッションが、TCP 接続の動作インターフェイスを使用できるようにします。

この例では、指定されたネイバーの BGP TCP 接続が、最良のローカル アドレスではなく、ループバック インターフェイスの IP アドレスで発信されます。

ステップ 8

address-family { ipv4 [ mdt | multicast | unicast [ vrf vrf-name ] | vrf vrf-name ] | vpnv4 [ unicast ]}

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、アドレス ファミリ固有の設定を受け入れるよう BGP ピアを設定します。

この例では、VPNv4 アドレス ファミリ セッションを作成します。

ステップ 9

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 172.16.1.1 activate

VPNv4 アドレス ファミリの下のネイバーをアクティブにします。

この例では、ネイバー 172.16.1.1 がアクティブ化されます。

ステップ 10

neighbor { ip-address | peer-group-name } send-community { both | standard | extended }

 

Router(config-router-af)# neighbor 172.16.1.1 send-community extended

コミュニティ属性が BGP ネイバーに送信されるように指定します。

この例では、拡張コミュニティ属性が 172.16.1.1 のネイバーに送信されます。

ステップ 11

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードに戻ります。

ステップ 12

address-family { ipv4 [ mdt | multicast | unicast [ vrf vrf-name ] | vrf vrf-name ] | vpnv4 [ unicast ]}

 

Router(config-router)# address-family ipv4 vrf vrf_trans

アドレス ファミリ コンフィギュレーション モードを開始して、アドレス ファミリ固有の設定を受け入れるよう BGP ピアを設定します。

この例では、vrf_trans という名前の VRF インスタンスが後続の IPv4 アドレス ファミリ コンフィギュレーション コマンドに関連付けられるように指定します。

ステップ 13

redistribute connected

 

Router(config-router-af)# redistribute connected

あるルーティング ドメインから別のルーティング ドメインに再配布します。

この例では、インターフェイスで IP がイネーブルにされると自動的に確立されるルートを表すために、 connected キーワードが使用されます。

この手順に適用される構文だけが表示されます。詳細については、『 Cisco IOS IP Routing: BGP Command Reference 』を参照してください。

ステップ 14

neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

 

Router(config-router-af)# neighbor 192.168.1.1 remote-as 40000

指定された自律システム内のネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致する場合、ネイバーは内部ネイバーになります。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致しない場合、ネイバーは外部ネイバーになります。

この例では、192.168.1.1 のネイバーは外部ネイバーです。

ステップ 15

neighbor ip-address local-as autonomous-system-number [ no-prepend [ replace-as [ dual-as ]]]

 

Router(config-router-af)# neighbor 192.168.1.1 local-as 50000 no-prepend

eBGP ネイバーから受信したルートの AS_PATH 属性をカスタマイズします。

ローカル BGP ルーティング プロセスからの自律システム番号は、デフォルトで、すべての外部ルートに追加されます。

eBGP ネイバーから受信されたルートにローカル自律システム番号を追加しない場合は、 no-prepend キーワードを使用します。

この例では、192.168.1.1 のネイバーからのルートにローカル自律システム番号が含まれていません。

ステップ 16

neighbor { ip-address | peer-group-name } ebgp-multihop [ ttl ]

 

Router(config-router-af)# neighbor 192.168.1.1 ebgp-multihop 2

直接接続されていないネットワーク上の外部ピアからの BGP 接続を受け入れ、またそのピアへの BGP 接続を試みます。

この例では、直接接続されていないネットワーク上に存在するネイバー 192.168.1.1 との接続ができるように BGP を設定します。

ステップ 17

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーを IPv4 アドレス ファミリの下でアクティブ化します。

この例では、ネイバー 192.168.1.1 がアクティブにされます。

ステップ 18

neighbor ip-address allowas-in [ number ]

 

Router(config-router-af)# neighbor 192.168.1.1 allowas-in 1

複製の自律システム番号が含まれるプレフィクスをすべて再アドバタイズできるように、プロバイダー エッジ(PE)ルータを設定します。

この例では、自律システム番号が 45000 の PE ルータが VRF vrf-trans からのプレフィクスを許可するように設定されます。IP アドレスが 192.168.1.1 のネイバー PE ルータが、同じ自律システム番号の別の PE ルータに 1 回再アドバタイズされるように設定されます。

ステップ 19

no auto-summary

 

Router(config-router-af)# no auto-summary

自動サマライズをディセーブルにし、サブプレフィクス ルーティング情報をクラスフル ネットワーク境界間で送信します。

ステップ 20

no synchronization

 

Router(config-router-af)# no synchronization

Cisco IOS ソフトウェアが内部ゲートウェイ プロトコル(IGP)との同期を待たずにネットワーク ルートをアドバタイズすることをイネーブルにします。

ステップ 21

bgp router-id { ip-address | auto-assign }

 

Router(config-router-af)# bgp router-id 10.99.1.1

ローカル BGP ルーティング プロセスの固定ルータ ID を設定します。

この例では、指定された BGP ルータ ID が、IPv4 アドレス ファミリ コンフィギュレーションに関連付けられた VRF インスタンスに割り当てられます。

ステップ 22

別の VRF インスタンスを設定するには、ステップ 11 ~ 21 を繰り返します。

--

ステップ 23

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 24

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name }

 

Router# show ip bgp vpnv4 all

(任意)BGP テーブルからの VPN アドレス情報を表示します。

この例では、すべての VPNv4 データベースが表示されます。

』を参照してください。

次のサンプル出力は、vrf_trans と vrf_user という名前の 2 つの VRF インスタンスが個別のルータ ID で設定されていることを前提としています。ルータ ID が VRF 名の次に表示されます。

Router# show ip bgp vpnv4 all
 
BGP table version is 5, local router ID is 172.17.1.99
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf vrf_trans) VRF Router ID 10.99.1.2
*> 192.168.4.0 0.0.0.0 0 32768 ?
Route Distinguisher: 42:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
*> 192.168.5.0 0.0.0.0 0 32768 ?

VRF 単位での BGP ルータ ID の自動割り当て

VRF 単位で BGP ルータ ID を自動で設定するには、この作業を実行します。この作業では、ループバック インターフェイスが VRF に関連付けられ、 bgp router-id コマンドがルータ コンフィギュレーション レベルで設定されて、BGP ルータ ID がすべての VRF インスタンスに自動的に割り当てられます。ステップ 9 は、特定のステップを繰り返して、インターフェイスに関連付けられる各 VRF を設定する方法を示します。ステップ 30 は、同じルータ上で複数の VRF を設定する方法を示します。

前提条件

この作業は、事前に VRF インスタンスを作成していることを前提とします。詳細については、「VRF インスタンスの設定」を参照してください。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask [ secondary ]

5. exit

6. interface type number

7. ip vrf forwarding vrf-name [ downstream vrf-name2 ]

8. ip address ip-address mask [ secondary ]

9. インターフェイスに関連付ける VRF 単位で、ステップ 5 ~ 8 を繰り返します。

10. exit

11. router bgp autonomous-system-number

12. bgp router-id { ip-address | vrf auto-assign }

13. no bgp default ipv4-unicast

14. bgp log-neighbor-changes

15. neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

16. neighbor { ip-address | peer-group-name } update-source interface-type interface-number

17. address-family { ipv4 [ mdt | multicast | unicast [ vrf vrf-name ] | vrf vrf-name ] | vpnv4 [ unicast ]}

18. neighbor { ip-address | peer-group-name } activate

19. neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

20. exit-address-family

21. address-family { ipv4 [ mdt | multicast | unicast [ vrf vrf-name ] | vrf vrf-name ] | vpnv4 [ unicast ]}

22. redistribute connected

23. neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

24. neighbor ip-address local-as autonomous-system-number [ no-prepend [ replace-as [ dual-as ]]]

25. neighbor { ip-address | peer-group-name } ebgp-multihop [ ttl ]

26. neighbor { ip-address | peer-group-name } activate

27. neighbor ip-address allowas-in [ number ]

28. no auto-summary

29. no synchronization

30. 別の VRF インスタンスを設定するには、ステップ 20 ~ 29 を繰り返します。

31. end

32. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface loopback0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

この例では、ループバック インターフェイス 0 が設定されます。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 172.16.1.1 255.255.255.255

IP アドレスを設定します。

この例では、ループバック インターフェイスが 172.16.1.1 の IP アドレスで設定されます。

ステップ 5

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

interface type number

 

Router(config)# interface loopback1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

この例では、ループバック インターフェイス 1 が設定されます。

ステップ 7

ip vrf forwarding vrf-name [ downstream vrf-name2 ]

 

Router(config-if)# ip vrf forwarding vrf_trans

VRF をインターフェイスまたはサブインターフェイスと関連付けます。

この例では、vrf_trans という名前の VRF がループバック インターフェイス 1 に関連付けられます。

(注) インターフェイスにこのコマンドを実行すると、IP アドレスが削除されます。IP アドレスを再設定する必要があります。

ステップ 8

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.99.1.1 255.255.255.255

IP アドレスを設定します。

この例では、ループバック インターフェイス 1 が 10.99.1.1 の IP アドレスで設定されます。

ステップ 9

インターフェイスに関連付ける VRF 単位で、ステップ 5 ~ 8 を繰り返します。

--

ステップ 10

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 11

router bgp autonomous-system-number

 

Router(config)# router bgp 45000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 12

bgp router-id { ip-address | vrf auto-assign }

 

Router(config-router)# bgp router-id vrf auto-assign

ローカル BGP ルーティング プロセスの固定ルータ ID を設定します。

この例では、BGP ルータ ID が VRF インスタンス単位で自動的に割り当てられます。

ステップ 13

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ルーティング プロセスで使用される IPv4 ユニキャスト アドレス ファミリをディセーブルにします。

ルータ コンフィギュレーション コマンドを設定した場合は例外です。既存のネイバー コンフィギュレーションは影響されません。

ステップ 14

bgp log-neighbor-changes

 

Router(config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 15

neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

 

Router(config-router)# neighbor 192.168.1.1 remote-as 45000

指定された自律システム内のネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致する場合、ネイバーは内部ネイバーになります。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致しない場合、ネイバーは外部ネイバーになります。

この例では、ネイバーは内部ネイバーになります。

ステップ 16

neighbor { ip-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 192.168.1.1 update-source loopback0

BGP セッションが、TCP 接続の動作インターフェイスを使用できるようにします。

この例では、指定されたネイバーの BGP TCP 接続が、最良のローカル アドレスではなく、ループバック インターフェイスの IP アドレスで発信されます。

ステップ 17

address-family { ipv4 [ mdt | multicast | unicast [ vrf vrf-name ] | vrf vrf-name ] | vpnv4 [ unicast ]}

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、アドレス ファミリ固有の設定を受け入れるよう BGP ピアを設定します。

この例では、VPNv4 アドレス ファミリ セッションを作成します。

ステップ 18

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 172.16.1.1 activate

VPNv4 アドレス ファミリの下のネイバーをアクティブにします。

この例では、ネイバー 172.16.1.1 がアクティブ化されます。

ステップ 19

neighbor { ip-address | peer-group-name } send-community { both | standard | extended }

 

Router(config-router-af)# neighbor 172.16.1.1 send-community extended

コミュニティ属性が BGP ネイバーに送信されるように指定します。

この例では、拡張コミュニティ属性が 172.16.1.1 のネイバーに送信されます。

ステップ 20

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードに戻ります。

ステップ 21

address-family { ipv4 [ mdt | multicast | unicast [ vrf vrf-name ] | vrf vrf-name ] | vpnv4 [ unicast ]}

 

Router(config-router)# address-family ipv4 vrf vrf_trans

アドレス ファミリ コンフィギュレーション モードを開始して、アドレス ファミリ固有の設定を受け入れるよう BGP ピアを設定します。

この例では、vrf_trans という名前の VRF インスタンスが後続の IPv4 アドレス ファミリ コンフィギュレーション モードのコマンドに関連付けられるように指定します。

ステップ 22

redistribute connected

 

Router(config-router-af)# redistribute connected

あるルーティング ドメインから別のルーティング ドメインに再配布します。

この例では、インターフェイスで IP がイネーブルにされると自動的に確立されるルートを表すために、 connected キーワードが使用されます。

この手順に適用される構文だけが表示されます。詳細については、『 Cisco IOS IP Routing: BGP Command Reference 』を参照してください。

ステップ 23

neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

 

Router(config-router-af)# neighbor 192.168.1.1 remote-as 40000

指定された自律システム内のネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致する場合、ネイバーは内部ネイバーになります。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致しない場合、ネイバーは外部ネイバーになります。

この例では、192.168.1.1 のネイバーは外部ネイバーです。

ステップ 24

neighbor ip-address local-as autonomous-system-number [ no-prepend [ replace-as [ dual-as ]]]

 

Router(config-router-af)# neighbor 192.168.1.1 local-as 50000 no-prepend

eBGP ネイバーから受信したルートの AS_PATH 属性をカスタマイズします。

ローカル BGP ルーティング プロセスからの自律システム番号は、デフォルトで、すべての外部ルートに追加されます。

eBGP ネイバーから受信されたルートにローカル自律システム番号を追加しない場合は、 no-prepend キーワードを使用します。

この例では、192.168.1.1 のネイバーからのルートにローカル自律システム番号が含まれていません。

ステップ 25

neighbor { ip-address | peer-group-name } ebgp-multihop [ ttl ]

 

Router(config-router-af)# neighbor 192.168.1.1 ebgp-multihop 2

直接接続されていないネットワーク上の外部ピアからの BGP 接続を受け入れ、またそのピアへの BGP 接続を試みます。

この例では、直接接続されていないネットワーク上に存在するネイバー 192.168.1.1 との接続ができるように BGP を設定します。

ステップ 26

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーを IPv4 アドレス ファミリの下でアクティブ化します。

この例では、ネイバー 192.168.1.1 がアクティブにされます。

ステップ 27

neighbor ip-address allowas-in [ number ]

 

Router(config-router-af)# neighbor 192.168.1.1 allowas-in 1

複製の自律システム番号が含まれるプレフィクスをすべて再アドバタイズできるように、プロバイダー エッジ(PE)ルータを設定します。

この例では、自律システム番号が 45000 の PE ルータが VRF vrf-trans からのプレフィクスを許可するように設定されます。IP アドレスが 192.168.1.1 のネイバー PE ルータが、同じ自律システム番号の別の PE ルータに 1 回再アドバタイズされるように設定されます。

ステップ 28

no auto-summary

 

Router(config-router-af)# no auto-summary

自動サマライズをディセーブルにし、サブプレフィクス ルーティング情報をクラスフル ネットワーク境界間で送信します。

ステップ 29

no synchronization

 

Router(config-router-af)# no synchronization

Cisco IOS ソフトウェアが内部ゲートウェイ プロトコル(IGP)との同期を待たずにネットワーク ルートをアドバタイズすることをイネーブルにします。

ステップ 30

別の VRF インスタンスを設定するには、ステップ 20 ~ 29 を繰り返します。

--

ステップ 31

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 32

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name }

 

Router# show ip bgp vpnv4 all

(任意)BGP テーブルからの VPN アドレス情報を表示します。

この例では、すべての VPNv4 データベースが表示されます。

』を参照してください。

次のサンプル出力は、vrf_trans と vrf_user という名前の 2 つの VRF インスタンスが個別のルータ ID で設定されていることを前提としています。ルータ ID が VRF 名の次に表示されます。

Router# show ip bgp vpnv4 all
 
BGP table version is 43, local router ID is 172.16.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf vrf_trans) VRF Router ID 10.99.1.2
*> 172.22.0.0 0.0.0.0 0 32768 ?
r> 172.23.0.0 172.23.1.1 0 0 3 1 ?
*>i10.21.1.1/32 192.168.3.1 0 100 0 2 i
*> 10.52.1.0/24 172.23.1.1 0 3 1 ?
*> 10.52.2.1/32 172.23.1.1 0 3 1 3 i
*> 10.52.3.1/32 172.23.1.1 0 3 1 3 i
*> 10.99.1.1/32 172.23.1.1 0 0 3 1 ?
*> 10.99.1.2/32 0.0.0.0 0 32768 ?
Route Distinguisher: 10:1
*>i10.21.1.1/32 192.168.3.1 0 100 0 2 i
Route Distinguisher: 42:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0 172.22.1.1 0 0 2 1 ?
*> 172.23.0.0 0.0.0.0 0 32768 ?
*> 10.21.1.1/32 172.22.1.1 0 2 1 2 i
*>i10.52.1.0/24 192.168.3.1 0 100 0 ?
*>i10.52.2.1/32 192.168.3.1 0 100 0 3 i
*>i10.52.3.1/32 192.168.3.1 0 100 0 3 i
*> 10.99.1.1/32 0.0.0.0 0 32768 ?
*> 10.99.1.2/32 172.22.1.1 0 0 2 1 ?

BGP ルータ ID の VRF 単位での割り当ての設定例

「VRF 単位での BGP ルータ ID の手動設定:例」

「VRF 単位での BGP ルータ ID の自動割り当て:例」

VRF 単位での BGP ルータ ID の手動設定:例

次の例は、vrf_trans と vrf_user の 2 つの VRF を、同じルータ上で相互間のセッションで設定する方法を示します。VRF 単位での BGP ルータ ID は、個別の IPv4 アドレス ファミリの下で手動で設定されます。 show ip bgp vpnv4 コマンドを使用すると、ルータ ID が VRF 単位に設定されていることを確認できます。このコンフィギュレーションは、グローバル コンフィギュレーション モードで開始されます。

ip vrf vrf_trans
rd 45000:1
route-target export 50000:50
route-target import 40000:1
!
ip vrf vrf_user
rd 65500:1
route-target export 65500:1
route-target import 65500:1
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding vrf_trans
ip address 172.22.1.1 255.255.0.0
!
interface Ethernet1/0
ip vrf forwarding vrf_user
ip address 172.23.1.1 255.255.0.0
!
router bgp 45000
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.3.1 remote-as 45000
neighbor 192.168.3.1 update-source Loopback0
!
address-family vpnv4
neighbor 192.168.3.1 activate
neighbor 192.168.3.1 send-community extended
exit-address-family
!
address-family ipv4 vrf vrf_user
redistribute connected
neighbor 172.22.1.1 remote-as 40000
neighbor 172.22.1.1 local-as 50000 no-prepend
neighbor 172.22.1.1 ebgp-multihop 2
neighbor 172.22.1.1 activate
neighbor 172.22.1.1 allowas-in 1
no auto-summary
no synchronization
bgp router-id 10.99.1.1
exit-address-family
!
address-family ipv4 vrf vrf_trans
redistribute connected
neighbor 172.23.1.1 remote-as 50000
neighbor 172.23.1.1 local-as 40000 no-prepend
neighbor 172.23.1.1 ebgp-multihop 2
neighbor 172.23.1.1 activate
neighbor 172.23.1.1 allowas-in 1
no auto-summary
no synchronization
bgp router-id 10.99.1.2
exit-address-family
 

コンフィギュレーションの後、 show ip bgp vpnv4 all コマンドの出力には、VRF 名の次に表示されるルータ ID が表示されます。

Router# show ip bgp vpnv4 all
 
BGP table version is 43, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 45000:1 (default for vrf vrf_trans) VRF Router ID 10.99.1.2
*> 172.22.0.0 0.0.0.0 0 32768 ?
r> 172.23.0.0 172.23.1.1 0 0 3 1 ?
*>i10.21.1.1/32 192.168.3.1 0 100 0 2 i
*> 10.52.1.0/24 172.23.1.1 0 3 1 ?
*> 10.52.2.1/32 172.23.1.1 0 3 1 3 i
*> 10.52.3.1/32 172.23.1.1 0 3 1 3 i
*> 10.99.1.1/32 172.23.1.1 0 0 3 1 ?
*> 10.99.2.2/32 0.0.0.0 0 32768 ?
Route Distinguisher: 50000:1
*>i10.21.1.1/32 192.168.3.1 0 100 0 2 i
Route Distinguisher: 65500:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0 172.22.1.1 0 0 2 1 ?
*> 172.23.0.0 0.0.0.0 0 32768 ?
*> 10.21.1.1/32 172.22.1.1 0 2 1 2 i
*>i10.52.1.0/24 192.168.3.1 0 100 0 ?
*>i10.52.2.1/32 192.168.3.1 0 100 0 3 i
*>i10.52.3.1/32 192.168.3.1 0 100 0 3 i
*> 10.99.1.1/32 0.0.0.0 0 32768 ?
*> 10.99.2.2/32 172.22.1.1 0 0 2 1 ?
 

指定された VRF の show ip bgp vpnv4 vrf コマンドの出力には、出力ヘッダーにルータ ID が表示されます。

Router# show ip bgp vpnv4 vrf vrf_user
 
BGP table version is 43, local router ID is 10.99.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 65500:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0 172.22.1.1 0 0 2 1 ?
*> 172.23.0.0 0.0.0.0 0 32768 ?
*> 10.21.1.1/32 172.22.1.1 0 2 1 2 i
*>i10.52.1.0/24 192.168.3.1 0 100 0 ?
*>i10.52.2.1/32 192.168.3.1 0 100 0 3 i
*>i10.52.3.1/32 192.168.3.1 0 100 0 3 i
*> 10.99.1.1/32 0.0.0.0 0 32768 ?
*> 10.99.2.2/32 172.22.1.1 0 0 2 1 ?
 

指定された VRF の show ip bgp vpnv4 vrf summary コマンドの出力には、出力の最初の行にルータ ID が表示されます。

Router# show ip bgp vpnv4 vrf vrf_user summary
 
BGP router identifier 10.99.1.1, local AS number 45000
BGP table version is 43, main routing table version 43
8 network entries using 1128 bytes of memory
8 path entries using 544 bytes of memory
16/10 BGP path/bestpath attribute entries using 1856 bytes of memory
6 BGP AS-PATH entries using 144 bytes of memory
3 BGP extended community entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3744 total bytes of memory
BGP activity 17/0 prefixes, 17/0 paths, scan interval 15 secs
 
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.22.1.1 4 2 20 21 43 0 0 00:12:33 3
 

パスが VRF で送信されると、指定された VRF とネットワーク アドレスの show ip bgp vpnv4 vrf コマンドの出力に、正しいルータ ID が表示されます。

Router# show ip bgp vpnv4 vrf vrf_user 172.23.0.0
 
BGP routing table entry for 65500:1:172.23.0.0/8, version 22
Paths: (1 available, best #1, table vrf_user)
Advertised to update-groups:
2 3
Local
0.0.0.0 from 0.0.0.0 (10.99.1.1)
Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best
Extended Community: RT:65500:1

VRF 単位での BGP ルータ ID の自動割り当て:例

次に、BGP が個別のルータ ID を各 VRF インスタンスに自動的に割り当てるように設定する 3 つの異なる設定例を示します。

「ループバック インターフェイス IP アドレスを使用して、グローバルに自動割り当てされるルータ ID」

「デフォルト ルータ ID がない場合にグローバルに自動割り当てされるルータ ID」

「VRF 単位で自動割り当てされるルータ ID」

ループバック インターフェイス IP アドレスを使用して、グローバルに自動割り当てされるルータ ID

次の例は、vrf_trans と vrf_user の 2 つの VRF を、同じルータ上で相互間のセッションで設定する方法を示します。ルータ コンフィギュレーション モードでは、BGP が、各 VRF に BGP ルータ ID を自動的に割り当てるようにグローバルに設定されます。ループバック インターフェイスは、ルータ ID の IP アドレスを送信するために個別の VRF に関連付けられます。 show ip bgp vpnv4 コマンドを使用すると、ルータ ID が VRF 単位に設定されていることを確認できます。

ip vrf vrf_trans
rd 45000:1
route-target export 50000:50
route-target import 40000:1
!
ip vrf vrf_user
rd 65500:1
route-target export 65500:1
route-target import 65500:1
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding vrf_user
ip address 10.99.1.1 255.255.255.255
!
interface Loopback2
ip vrf forwarding vrf_trans
ip address 10.99.2.2 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding vrf_trans
ip address 172.22.1.1 255.0.0.0
!
interface Ethernet1/0
ip vrf forwarding vrf_user
ip address 172.23.1.1 255.0.0.0
!
router bgp 45000
bgp router-id vrf auto-assign
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.3.1 remote-as 45000
neighbor 192.168.3.1 update-source Loopback0
!
address-family vpnv4
neighbor 192.168.3.1 activate
neighbor 192.168.3.1 send-community extended
exit-address-family
!
address-family ipv4 vrf vrf_user
redistribute connected
neighbor 172.22.1.1 remote-as 40000
neighbor 172.22.1.1 local-as 50000 no-prepend
neighbor 172.22.1.1 ebgp-multihop 2
neighbor 172.22.1.1 activate
neighbor 172.22.1.1 allowas-in 1
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf vrf_trans
redistribute connected
neighbor 172.23.1.1 remote-as 50000
neighbor 172.23.1.1 local-as 2 no-prepend
neighbor 172.23.1.1 ebgp-multihop 2
neighbor 172.23.1.1 activate
neighbor 172.23.1.1 allowas-in 1
no auto-summary
no synchronization
exit-address-family
 

コンフィギュレーションの後、 show ip bgp vpnv4 all コマンドの出力には、VRF 名の次に表示されるルータ ID が表示されます。この例で使用されているルータ ID が、ループバック インターフェイス 1 およびループバック インターフェイス 2 で設定された IP アドレスから送信されていることに注意してください。ルータ ID は、「VRF 単位での BGP ルータ ID の手動設定:例」と同じです。

Router# show ip bgp vpnv4 all
 
BGP table version is 43, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 45000:1 (default for vrf vrf_trans) VRF Router ID 10.99.2.2
*> 172.22.0.0 0.0.0.0 0 32768 ?
r> 172.23.0.0 172.23.1.1 0 0 3 1 ?
*>i10.21.1.1/32 192.168.3.1 0 100 0 2 i
*> 10.52.1.0/24 172.23.1.1 0 3 1 ?
*> 10.52.2.1/32 172.23.1.1 0 3 1 3 i
*> 10.52.3.1/32 172.23.1.1 0 3 1 3 i
*> 10.99.1.1/32 172.23.1.1 0 0 3 1 ?
*> 10.99.1.2/32 0.0.0.0 0 32768 ?
Route Distinguisher: 50000:1
*>i10.21.1.1/32 192.168.3.1 0 100 0 2 i
Route Distinguisher: 65500:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0 172.22.1.1 0 0 2 1 ?
*> 172.23.0.0 0.0.0.0 0 32768 ?
*> 10.21.1.1/32 172.22.1.1 0 2 1 2 i
*>i10.52.1.0/24 192.168.3.1 0 100 0 ?
*>i10.52.2.1/32 192.168.3.1 0 100 0 3 i
*>i10.52.3.1/32 192.168.3.1 0 100 0 3 i
*> 10.99.1.1/32 0.0.0.0 0 32768 ?
*> 10.99.1.2/32 172.22.1.1 0 0 2 1 ?

デフォルト ルータ ID がない場合にグローバルに自動割り当てされるルータ ID

次に、ルータを設定して、デフォルトのルータ ID が割り当てられない場合に自動的に BGP ルータ ID が割り当てられる VRF を関連付ける例を示します。

ip vrf vpn1
rd 45000:1
route-target export 45000:1
route-target import 45000:1
!
interface Loopback0
ip vrf forwarding vpn1
ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding vpn1
ip address 172.22.1.1 255.0.0.0
!
router bgp 45000
bgp router-id vrf auto-assign
no bgp default ipv4-unicast
bgp log-neighbor-changes
!
address-family ipv4 vrf vpn1
neighbor 172.22.1.2 remote-as 40000
neighbor 172.22.1.2 activate
no auto-summary
no synchronization
exit-address-family
 

別のルータが 2 つのルータ間のセッションを確立するように設定されていることを前提として、 show ip interface brief コマンドの出力には、設定済みの VRF インターフェイスだけが表示されます。

Router# show ip interface brief
 
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 172.22.1.1 YES NVRAM up up
Ethernet1/0 unassigned YES NVRAM administratively down down
Serial2/0 unassigned YES NVRAM administratively down down
Serial3/0 unassigned YES NVRAM administratively down down
Loopback0 10.1.1.1 YES NVRAM up up
 

show ip vrf コマンドを使用すると、ルータ ID が VRF に対して割り当てられていることを確認できます。

Router# show ip vrf
 
Name Default RD Interfaces
vpn1 45000:1 Loopback0
Ethernet0/0
VRF session is established:

VRF 単位で自動割り当てされるルータ ID

次の例は、vrf_trans と vrf_user の 2 つの VRF を、同じルータ上で相互間のセッションで設定する方法を示します。個別の VRF に関連付けられた IPv4 アドレス ファミリの下では、BGP が自動的に BGP ルータ ID を割り当てるように設定されます。ループバック インターフェイスは、ルータ ID の IP アドレスを送信するために個別の VRF に関連付けられます。 show ip bgp vpnv4 コマンドの出力を使用すると、ルータ ID が VRF 単位に設定されていることを確認できます。

ip vrf vrf_trans
rd 45000:1
route-target export 50000:50
route-target import 40000:1
!
ip vrf vrf_user
rd 65500:1
route-target export 65500:1
route-target import 65500:1
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding vrf_user
ip address 10.99.1.1 255.255.255.255
!
interface Loopback2
ip vrf forwarding vrf_trans
ip address 10.99.2.2 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding vrf_trans
ip address 172.22.1.1 255.0.0.0
!
interface Ethernet1/0
ip vrf forwarding vrf_user
ip address 172.23.1.1 255.0.0.0
!
router bgp 45000
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.3.1 remote-as 45000
neighbor 192.168.3.1 update-source Loopback0
!
address-family vpnv4
neighbor 192.168.3.1 activate
neighbor 192.168.3.1 send-community extended
exit-address-family
!
address-family ipv4 vrf vrf_user
redistribute connected
neighbor 172.22.1.1 remote-as 40000
neighbor 172.22.1.1 local-as 50000 no-prepend
neighbor 172.22.1.1 ebgp-multihop 2
neighbor 172.22.1.1 activate
neighbor 172.22.1.1 allowas-in 1
no auto-summary
no synchronization
bgp router-id auto-assign
exit-address-family
!
address-family ipv4 vrf vrf_trans
redistribute connected
neighbor 172.23.1.1 remote-as 50000
neighbor 172.23.1.1 local-as 40000 no-prepend
neighbor 172.23.1.1 ebgp-multihop 2
neighbor 172.23.1.1 activate
neighbor 172.23.1.1 allowas-in 1
no auto-summary
no synchronization
bgp router-id auto-assign
exit-address-family
 

コンフィギュレーションの後、 show ip bgp vpnv4 all コマンドの出力には、VRF 名の次に表示されるルータ ID が表示されます。この例で使用されているルータ ID が、ループバック インターフェイス 1 およびループバック インターフェイス 2 で設定された IP アドレスから送信されていることに注意してください。

Router# show ip bgp vpnv4 all
 
BGP table version is 43, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 45000:1 (default for vrf vrf_trans) VRF Router ID 10.99.2.2
*> 172.22.0.0 0.0.0.0 0 32768 ?
r> 172.23.0.0 172.23.1.1 0 0 3 1 ?
*>i10.21.1.1/32 192.168.3.1 0 100 0 2 i
*> 10.52.1.0/24 172.23.1.1 0 3 1 ?
*> 10.52.2.1/32 172.23.1.1 0 3 1 3 i
*> 10.52.3.1/32 172.23.1.1 0 3 1 3 i
*> 10.99.1.1/32 172.23.1.1 0 0 3 1 ?
*> 10.99.1.2/32 0.0.0.0 0 32768 ?
Route Distinguisher: 50000:1
*>i10.21.1.1/32 192.168.3.1 0 100 0 2 i
Route Distinguisher: 65500:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0 172.22.1.1 0 0 2 1 ?
*> 172.23.0.0 0.0.0.0 0 32768 ?
*> 10.21.1.1/32 172.22.1.1 0 2 1 2 i
*>i10.52.1.0/24 192.168.3.1 0 100 0 ?
*>i10.52.2.1/32 192.168.3.1 0 100 0 3 i
*>i10.52.3.1/32 192.168.3.1 0 100 0 3 i
*> 10.99.1.1/32 0.0.0.0 0 32768 ?
*> 10.99.1.2/32 172.22.1.1 0 0 2 1 ?

その他の参考資料

次の項では、BGP ルータ ID の VRF 単位での割り当て機能に関連する参照資料を紹介します。

関連資料

関連項目
参照先

BGP コマンド:コマンド構文の詳細、デフォルト、コマンド モード、コマンド履歴、使用上の注意事項、および例

『Cisco IOS IP Routing: BGP Command Reference

設定作業および設定例を含む BGP モジュールおよび機能のロードマップ

『BGP Features Roadmap』

MPLS コマンド:コマンド構文の詳細、デフォルト、コマンド モード、コマンド履歴、使用上の注意事項、および例

Cisco IOS Multiprotocol Label Switching Command Reference

標準

標準
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

次のコマンドは、このモジュールで説明した機能で導入または修正されたものです。これらのコマンドについては、 http://www.cisco.com/en/US/docs/ios/iproute_bgp/command/reference/irg_book.html の『 Cisco IOS IP Routing: BGP Command Reference 』を参照してください。すべての Cisco IOS コマンドについては、 http://tools.cisco.com/Support/CLILookup で Command Lookup Tool を使用するか、 http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html にある Cisco IOS Master Command List, All Releases を使用してください。

bgp router-id

show ip bgp vpnv4

BGP ルータ ID の VRF 単位での割り当てに関する機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース トレインの中で特定の機能のサポートが導入された Cisco IOS ソフトウェア リリースだけを示します。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 1 BGP ルータ ID の VRF 単位での割り当てに関する機能情報

機能名
リリース
機能情報

BGP ルータ ID の VRF 単位での割り当て

12.2(31)SB2
12.2(33)SRA
12.2(33)SXH
12.4(20)T
15.0(1)S

BGP ルータ ID の VRF 単位の割り当て機能により、同じルータ上のボーダー ゲートウェイ プロトコル(BGP)内に VRF-to-VRF ピアリングを持つ機能が追加されます。BGP は、ルータ ID チェックのため、BGP 自身でセッションを拒否するように設計されています。VRF 単位の割り当て機能を使用すると、既存の bgp router-id コマンドの新しいキーワードを使用して、VRF 単位で異なるルータ ID を使用できます。ルータ ID は、VRF 単位での手動設定、または、アドレス ファミリ コンフィギュレーション モードでのグローバルな自動割り当てや VRF 単位の自動割り当てが可能です。

この機能では、 bgp router-id コマンド、 show ip bgp vpnv4 コマンドが追加または変更されています。