IP ルーティング:BGP コンフィギュレーション ガイド、 Cisco IOS Release 15.2M&T
BGP の AS パスからプライベート AS 番号の 削除
BGP の AS パスからプライベート AS 番号の削除
発行日;2012/03/26 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

BGP の AS パスからプライベート AS 番号の削除

機能情報の確認

内容

AS パスからプライベート ASN の削除および交換の制約事項

AS パスからプライベート ASN の削除および交換に関する情報

パブリックおよびプライベート AS 番号

AS パスからプライベート ASN の削除および交換の利点

AS パスからプライベート ASN の削除に関する過去の制約事項

AS パスからプライベート ASN の削除の拡張機能

AS パスからプライベート ASN を削除および交換する方法

AS パスからプライベート ASN の削除および交換(Cisco IOS Release15.1(2)T 以降)

AS パスからプライベート ASN を削除および交換する設定例

例:プライベート ASN の削除(Cisco IOS Release 15.1(2)T)

例:プライベート ASN の削除および交換(Cisco IOS Release 15.1(2)T)

例:プライベート ASN の削除(Cisco IOS Release 12.2)

その他の参考資料

関連資料

標準

MIB

シスコのテクニカル サポート

AS パスからプライベート ASN の削除および交換の機能情報

BGP の AS パスからプライベート AS 番号の削除

プライベート Autonomous System Number(ASN; 自律システム番号)は、グローバルに一意な AS 番号を保護するために、ISP およびお客様のネットワークで使用されます。プライベート AS 番号は一意でないため、この番号を使用してグローバルなインターネットにアクセスすることはできません。AS 番号はルーティング アップデートの eBGP AS パスに表示されます。プライベート ASN を使用している場合にグローバルなインターネットにアクセスするには、AS パスからプライベート ASN を削除することが必要です。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「AS パスからプライベート ASN の削除および交換の機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

AS パスからプライベート ASN の削除および交換の制約事項

この機能は、eBGP ネイバーのみに適用されます。

この機能は、パブリック AS のみのルータに適用されます。この制約事項を回避するには、ネイバー単位で neighbor local-as コマンドを適用し、ローカル AS 番号をパブリック AS 番号として指定することです。

AS パスからプライベート ASN の削除および交換に関する情報

「パブリックおよびプライベート AS 番号」

「AS パスからプライベート ASN の削除および交換の利点」

「AS パスからプライベート ASN の削除に関する過去の制約事項」

「AS パスからプライベート ASN の削除の拡張機能」

パブリックおよびプライベート AS 番号

プライベート AS 番号は、InterNIC によって割り当てられ、グローバルに一意です。有効な範囲は 1 ~ 64511 です。プライベート AS 番号は、グローバルに一意な AS 番号(有効な範囲は 64512 ~ 65535)を保護するために使用されます。プライベート AS 番号はグローバル BGP ルーティング テーブルにリークできません。なぜならプライベート AS 番号は一意ではなく、BGP 最良パスの計算には一意の AS 番号が必要であるからです。そのため、ルートが BGP ピアに伝播される前に、AS パスからプライベート AS 番号を削除する必要がある可能性があります。

AS パスからプライベート ASN の削除および交換の利点

外部 BGP では、グローバルなインターネットへのルーティングで、グローバルに一意な AS 番号を使用する必要があります。プライベート AS 番号(これは一意でない)を使用すると、グローバルなインターネットにアクセスできません。この機能を使用すると、プライベート AS に属するルータがグローバルなインターネットにアクセスできます。ネットワーク管理者は、発信更新メッセージに含まれる AS パスからプライベート AS を削除するようにルータを設定します。場合によっては、これらの番号をローカル ルータの ASN で置き換えて、AS パス長が変化しないようにします。

AS パスからプライベート ASN の削除に関する過去の制約事項

AS パスからプライベート AS 番号を削除する機能は、以前から利用できました。Cisco IOS Release 15.1(2)T より前は、この機能に次の制約事項がありました。

AS パスがプライベートとパブリックの両方の AS 番号に含まれる場合、 neighbor remove-private-as コマンドでプライベート AS 番号が削除されませんでした。

AS パスにコンフェデレーション セグメントが含まれている場合、自律パスのコンフェデレーション部分の後にプライベート AS 番号が続く場合に限って、 neighbor remove-private-as コマンドでプライベート AS 番号が削除されていました。

AS パスに eBGP ネイバーの AS 番号が含まれている場合、プライベート AS 番号は削除されませんでした。

AS パスからプライベート ASN の削除の拡張機能

AS パスからプライベート ASN の削除および交換機能は、次のように拡張されました。

neighbor remove-private-as コマンドでは、AS パスにパブリックとプライベートの両方の ASN が含まれる場合でも、AS パスからプライベート AS 番号が削除されます。

neighbor remove-private-as コマンドでは、AS パスにプライベート AS 番号のみが含まれる場合でも、AS パスからプライベート AS 番号が削除されます。このコマンドは eBGP ピアのみに適用され、eBGP ピアではローカル ルータの AS 番号が AS パスに付加されるため、長さゼロの AS パスにはなりません。

neighbor remove-private-as コマンドでは、AS パスでコンフェデレーション セグメントの前にプライベート ASN が出現する場合でも、プライベート AS 番号が削除されます。

replace-as キーワードを使用して、パスから削除されるプライベート AS 番号をローカル AS 番号と交換できるため、AS パスの長さは同じままに保つことができます。

この機能は、アドレス ファミリごとにネイバーに適用できます(アドレス ファミリ コンフィギュレーション モード)。そのため、この機能をあるアドレス ファミリのネイバーには適用して、別のアドレス ファミリでは適用しないようにすることで、機能が設定されているアドレス ファミリのみのアウトバウンド側の更新メッセージに影響を与えることができます。

この機能は、ピア グループ テンプレート モードで適用できます。

この機能を設定すると、 show ip bgp update-group および show ip bgp neighbor コマンドの出力で、プライベート AS 番号が削除または交換されたことが示されます。

AS パスからプライベート ASN を削除および交換する方法

「AS パスからプライベート ASN の削除および交換(Cisco IOS Release 15.1(2)T 以降)」(必須)

AS パスからプライベート ASN の削除および交換(Cisco IOS Release 15.1(2)T 以降)

eBGP ネイバーのアウトバウンド側で AS パスからプライベート AS 番号を削除するには、次の作業を実行します。さらにプライベート AS 番号をローカル ルータの AS 番号と交換する場合は、ステップ 17 で all replace-as キーワードを含めてください。

この作業例は、図 1 のシナリオにおけるルータ 2 の設定を反映しています。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask

5. exit

6. interface type number

7. ip address ip-address mask

8. exit

9. interface type number

10. ip address ip-address mask

11. exit

12. router bgp autonomous-system-number

13. network network-number

14. network network-number

15. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number

16. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number

17. neighbor { ip-address | peer-group-name } remove-private-as [ all [ replace-as ]]

18. end

19. show ip bgp update-group

20. show ip bgp neighbors

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface gigabitethernet 0/0

インターフェイスを設定します。

ステップ 4

ip address ip-address mask

 

Router(config-if)# ip address 172.30.1.1 255.255.0.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 5

exit

 

Router(config-if)# exit

次に高次のコンフィギュレーション モードに戻ります。

ステップ 6

interface type number

 

Router(config)# interface serial 0/0

インターフェイスを設定します。

ステップ 7

ip address ip-address mask

 

Router(config-if)# ip address 172.16.0.2 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 8

exit

 

Router(config-if)# exit

次に高次のコンフィギュレーション モードに戻ります。

ステップ 9

interface type number

 

Router(config)# interface serial 1/0

インターフェイスを設定します。

ステップ 10

ip address ip-address mask

 

Router(config-if)# ip address 192.168.0.1 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 11

exit

 

Router(config-if)# exit

次に高次のコンフィギュレーション モードに戻ります。

ステップ 12

router bgp autonomous-system-number

 

Router(config)# router bgp 5

BGP インスタンスを指定します。

ステップ 13

network network-number

 

Router(config-router)# network 172.30.0.0

ネットワークが BGP によってアドバタイズされるように指定します。

ステップ 14

network network-number

 

Router(config-router)# network 192.168.0.0

ネットワークが BGP によってアドバタイズされるように指定します。

ステップ 15

neighbor { ip-address | ipv6-address [ % ]| peer-group-name } remote-as autonomous-system-number

 

Router(config-router)# neighbor 172.16.0.1 remote-as 65000

エントリをルーティング テーブルに追加します。

この例では、ルータ 3 をプライベート AS 65000 の eBGP ネイバーとして設定します。

ステップ 16

neighbor { ip-address | ipv6-address [ % ]| peer-group-name } remote-as autonomous-system-number

 

Router(config-router)# neighbor 192.168.0.2 remote-as 1

エントリをルーティング テーブルに追加します。

この例では、ルータ 1 をパブリック AS 1 の eBGP ネイバーとして設定します。

ステップ 17

neighbor { ip-address | peer-group-name } remove-private-as [ all [ replace-as ]]

 

Router(config-router)# neighbor 192.168.0.2 remove-private-as all replace-as

発信更新の AS パスからプライベート AS 番号を削除します。

この例では、発信 eBGP 更新の AS パスからプライベート AS 番号を削除し、ローカル ルータのパブリック AS 番号である 5 で置き換えます。

ステップ 18

end

 

Router(config-router)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 19

show ip bgp update-group

 

Router# show ip bgp update-group

(任意)BGP 更新グループの情報を表示します。

ステップ 20

show ip bgp neighbors

 

Router# show ip bgp neighbors

(任意)BGP ネイバーに関する情報を表示します。

AS パスからプライベート ASN を削除および交換する設定例

「例:プライベート ASN の削除(Cisco IOS Release 15.1(2)T)」

「例:プライベート ASN の削除および交換(Cisco IOS Release 15.1(2)T)」

「例:プライベート ASN の削除(Cisco IOS Release 12.2)」

例:プライベート ASN の削除(Cisco IOS Release 15.1(2)T)

次の例では、ルータ A が neighbor remove-private-as コマンドで設定されています。このコマンドは、172.30.0.7 のネイバーに送信される更新でプライベート AS 番号が削除されます。その後の show コマンドで、ホスト 1.1.1.1 へのルートに関する情報を要求します。出力には、AS パス 1001 65200 65201 65201 1002 1003 1003 にプライベート AS 番号 65200、65201、65201 が含まれています。

これらのプライベート AS 番号が AS パスから削除されたことを確認するには、ルータ B の show コマンドでもホスト 1.1.1.1 へのルートに関する情報を要求します。短い AS パス 100 1001 1002 1003 1003 が出力されますが、プライベート AS 番号 65200、65201、および 65201 が除外されています。パスに追加された 100 は、ルータ B 自身の AS 番号です。

ルータ A

router bgp 100
bgp log-neighbor-changes
neighbor 19.0.101.1 remote-as 1001
neighbor 172.30.0.7 remote-as 200
neighbor 172.30.0.7 remove-private-as all
no auto-summary
 
RouterA# show ip bgp 1.1.1.1
 
BGP routing table entry for 1.1.1.1/32, version 2
Paths: (1 available, best #1, table default)
Advertised to update-groups:
1 2
1001 65200 65201 65201 1002 1003 1003
19.0.101.1 from 19.0.101.1 (19.0.101.1)
Origin IGP, localpref 100, valid, external, best RouterA#

ルータ B(すべてのプライベート ASN を削除済み)

RouterB# show ip bgp 1.1.1.1
 
BGP routing table entry for 1.1.1.1/32, version 3
Paths: (1 available, best #1, table default)
Not advertised to any peer
100 1001 1002 1003 1003
172.30.0.6 from 172.30.0.6 (19.1.0.1)
Origin IGP, localpref 100, valid, external, best RouterB#

例:プライベート ASN の削除および交換(Cisco IOS Release 15.1(2)T)

次の例では、ルータ A がピア 172.30.0.7 にプレフィクスを送信すると、AS パスのすべてのプライベート ASN がルータ自身の ASN である 100 で置き換えられます。

ルータ A

router bgp 100
bgp log-neighbor-changes
neighbor 172.16.101.1 remote-as 1001
neighbor 172.16.101.1 update-source Loopback0
neighbor 172.30.0.7 remote-as 200
neighbor 172.30.0.7 remove-private-as all replace-as
no auto-summary
 

ルータ A は、ピア 172.16.101.1 から 1.1.1.1 を受信しますが、次の出力に示すように、その AS パス リストにはプライベート ASN(65200、65201、および 65201)があります。

 
RouterA# show ip bgp 1.1.1.1
 
BGP routing table entry for 1.1.1.1/32, version 2
Paths: (1 available, best #1, table default)
Advertised to update-groups:
1 2
1001 65200 65201 65201 1002 1003 1003
172.16.101.1 from 172.16.101.1 (172.16.101.1)
Origin IGP, localpref 100, valid, external, best RouterA#
 

ルータ A は neighbor 172.30.0.7 remove-private-as all replace-as で設定されるため、ルータ A はすべてのプライベート ASN が 100 で置き換えられたプレフィクス 1.1.1.1 を送信します。

ルータ B

RouterB# show ip bgp 1.1.1.1
 
BGP routing table entry for 1.1.1.1/32, version 3
Paths: (1 available, best #1, table default)
Not advertised to any peer
100 1001 100 100 100 1002 1003 1003
172.30.0.6 from 172.30.0.6 (192.168.1.2)
Origin IGP, localpref 100, valid, external, best RouterB#

ルータ B

router bgp 200
bgp log-neighbor-changes
neighbor 172.30.0.6 remote-as 100
no auto-summary

例:プライベート ASN の削除(Cisco IOS Release 12.2)

この例では、ルータ 3 でプライベート ASN 65000 を使用します。ルータ 1 およびルータ 2 は、それぞれパブリック ASN AS 1 および AS 5 を使用します。

図 1 に、サービス プロバイダーに属しているルータ 2、およびそのクライアントであるルータ 1 およびルータ 3 を示します。

図 1 プライベート AS 番号の削除

 

この例では、サービス プロバイダーに属しているルータ 2 で、次のようにプライベート AS 番号を削除します。


ステップ 1 ルータ 3 は、AS パス属性 65000 のネットワーク 10.0.0.0/24 をルータ 2 にアドバタイズします。

ステップ 2 ルータ 2 は、ルータ 3 から更新を受け取り、ルーティング テーブルにネクスト ホップ 172.16.0.1(ルータ 3 のシリアル インターフェイス S0)でネットワーク 10.0.0.0/24 に関するエントリを作成します。

ステップ 3 ルータ 2(サービス プロバイダー デバイス)は、 neighbor 192.168.0.2 remove-private-as コマンドで設定されると、プライベート AS 番号を削除して自身の AS 番号を 10.0.0.0/24 ネットワークの AS パス属性として新しい更新パケットを構成し、パケットをルータ 1 に送信します。

ステップ 4 ルータ 1 は、ネットワーク 10.0.0.0/24 の eBGP 更新を受信し、ルーティング テーブルにネクスト ホップ 192.168.0.1(ルータ 2 のシリアル インターフェイス S1)でエントリを作成します。ルータ 1 で認識されるこのネットワークの AS パス属性は、AS 5(ルータ 2)です。つまりプライベート AS 番号がインターネットの BGP テーブルに入ることはありません。

ルータ 3、ルータ 2、およびルータ 1 の設定は次のとおりです。

ルータ 3

interface gigabitethernet 0/0
ip address 10.0.0.1 255.255.255.0
!
interface Serial 0
ip address 172.16.0.1 255.255.255.0
!
router bgp 65000
network 10.0.0.0 mask 255.255.255.0
neighbor 172.16.0.2 remote-as 5
!---Configures Router 2 as an eBGP neighbor in public AS 5.
!
end

ルータ 2

interface gigabitethernet 0/0
ip address 172.30.1.1 255.255.0.0
!
interface Serial 0
ip address 172.16.0.2 255.255.255.0
!
interface Serial 1
ip address 192.168.0.1 255.255.255.0
!
router bgp 5
network 172.30.0.0
network 192.168.0.0
neighbor 172.16.0.1 remote-as 65000
!---Configures Router 3 as an eBGP neighbor in private AS 65000.
neighbor 192.168.0.2 remote-as 1
!---Configures Router 1 as an eBGP neighbor in public AS 1.
neighbor 192.168.0.2 remove-private-as
!---Removes the private AS numbers from outgoing eBGP updates.
!
end

ルータ 1

version 12.2
!
!
interface Serial 0
ip address 192.168.0.2 255.255.255.0
!
router bgp 1
neighbor 192.168.0.1 remote-as 5
!---Configures Router 2 as an eBGP neighbor in public AS 5.
!
end


 

その他の参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

Cisco IOS Master Commands List, All Releases

BGP コマンド

Cisco IOS IP Routing: BGP Command Reference

ここに記載されていないこのテクノロジーの機能に関する情報

『BGP Features Roadmap』

標準

標準
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

AS パスからプライベート ASN の削除および交換の機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


表 1 BGP - プライベート AS の削除および交換の機能情報

 

機能名
リリース
機能情報

BGP - プライベート AS の削除および交換

15.1(2)T、15.0(1)S

プライベート自律システム(AS)番号は、グローバルに一意な AS 番号を保護するために、ISP およびお客様のネットワークで使用されます。プライベート AS 番号は一意でないため、この番号を使用してグローバルなインターネットにアクセスすることはできません。AS 番号は、ルーティング テーブルで eBGP AS パスに出現します。プライベート AS 番号を使用している場合にグローバルなインターネットにアクセスするには、AS パスからプライベート AS 番号を削除することが必要です。

次のコマンドが変更されました。

neighbor remove-private-as