IP ルーティング:BGP コンフィギュレーション ガイド、 Cisco IOS Release 15.2M&T
BGP ポリシー アカウンティング
BGP ポリシー アカウンティング
発行日;2012/03/26 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

BGP ポリシー アカウンティング

機能情報の確認

内容

前提条件

BGP ポリシー アカウンティングに関する情報

BGP ポリシー アカウンティングの概要

BGP ポリシー アカウンティングの利点

BGP ポリシー アカウンティングの設定方法

BGP ポリシー アカウンティングの一致基準の指定

IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化

BGP ポリシー アカウンティングの確認

BGP ポリシー アカウンティングのモニタリングおよびメンテナンス

設定例

BGP ポリシー アカウンティングの一致基準の指定例

IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化の例

その他の参考資料

関連資料

MIB

シスコのテクニカル サポート

BGP ポリシー アカウンティングの機能情報

BGP ポリシー アカウンティング

ボーダー ゲートウェイ プロトコル(BGP)ポリシー アカウンティングは、異なるピア間で送受信される IP トラフィックを測定および分類します。ポリシー アカウンティングは入力インターフェイスでイネーブル化されます。また、コミュニティ リスト、自律システム番号、または自律システム パスなどのパラメータに基づくカウンタが割り当てられ、IP トラフィックを識別します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「BGP ポリシー アカウンティングの機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

前提条件

BGP ポリシー アカウンティング機能を使用する前に、ルータで BGP および CEF または dCEF をイネーブルにする必要があります。

BGP ポリシー アカウンティングに関する情報

「BGP ポリシー アカウンティングの概要」

「BGP ポリシー アカウンティングの利点」

BGP ポリシー アカウンティングの概要

ボーダー ゲートウェイ プロトコル(BGP)ポリシー アカウンティングは、異なるピア間で送受信される IP トラフィックを測定および分類します。ポリシー アカウンティングは入力インターフェイスでイネーブル化されます。また、コミュニティ リスト、自律システム番号、または自律システム パスなどのパラメータに基づくカウンタが割り当てられ、IP トラフィックを識別します。

BGP の table-map コマンドを使用することで、ルーティング テーブルに追加されるプレフィクスは、BGP 属性、自律システム番号、または自律システム パス別に分類されます。パケットおよびバイト カウンタは、入力インターフェイス単位で増加します。トラフィックは、Cisco IOS ポリシーベースの分類子により、異なるトラフィック クラスを表す 8 つの可能性のあるバケットのうちの 1 つにマッピングされます。

BGP ポリシー アカウンティングを使用して、通過するルートに基づいてトラフィックのアカウンティングを行うことができます。Service Provider(SP; サービス プロバイダー)は、すべてのトラフィックをカスタマー別に識別してアカウンティングを行うことができ、それに応じて課金できます。図 1 では、BGP ポリシー アカウンティングはルータ A で実装され、自律システム バケットにおけるパケットおよびバイト ボリュームを測定します。カスタマーは、国内、海外、または衛星経由の送信元からルーティングされたトラフィックに応じて適切に課金されます。

図 1 BGP ポリシー アカウンティングのトポロジ例

 

自律システム番号を使用した BGP ポリシー アカウンティングは、Internet Service Provider(ISP; インターネット サービス プロバイダー)間でのネットワーク回線のピアリングおよび中継の契約に関する設計を改善するために使用できます。

BGP ポリシー アカウンティングの利点

格差を付けた IP トラフィックのアカウンティング

BGP ポリシー アカウンティングは、自律システム番号、自律システム パス、またはコミュニティ リスト ストリングに基づいて IP トラフィックを分類し、パケットおよびバイト カウンタの値を増加させます。サービス プロバイダーは、ルート固有のトラフィック トラバースに基づいてトラフィックのアカウンティングを行い、請求に適用できます。

ネットワーク回線のピアリングおよび中継の契約に関する効率的な設計

BGP ポリシー アカウンティングをエッジ ルータに実装すると、ピアリングおよび中継の契約に関する設計の潜在的な改善点を明らかにすることができます。

BGP ポリシー アカウンティングの設定方法

「BGP ポリシー アカウンティングの一致基準の指定」(必須)

「IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化」(必須)

「BGP ポリシー アカウンティングの確認」(任意)

「BGP ポリシー アカウンティングのモニタリングおよびメンテナンス」(任意)

BGP ポリシー アカウンティングの一致基準の指定

BGP ポリシー アカウンティングを設定する最初の作業は、一致する必要のある基準を指定することです。コミュニティ リスト、自律システム パス、または自律システム番号は、指定が可能で、後でルート マップを使用してマッチングできる BGP 属性の例です。

BGP ポリシー アカウンティングに使用する BGP 属性を指定し、ルート マップで一致基準を作成するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# ip community-list community-list-number { permit | deny } community-number

BGP のコミュニティ リストを作成し、アクセスを制御します。

このステップは、指定する対象のコミュニティごとに繰り返す必要があります。

ステップ 2

Router(config)# route-map map-name [ permit | deny ] [ sequence-number ]

ルート マップ コンフィギュレーション モードを開始し、ポリシー ルーティングの条件を定義します。

map-name 引数はルート マップを識別します。

オプションの permit および deny の各キーワードは一致基準および設定基準とともに機能し、パケットのアカウンティングを行う方法を制御します。

オプションの sequence-number 引数は、同一の名前ですでに設定されているルート マップのリスト内における新しいルート マップの場所を示します。

ステップ 3

Router(config-route-map)# match community-list community-list-number [ exact ]

BGP コミュニティに一致します。

ステップ 4

Router(config-route-map)# set traffic-index bucket-number

BGP ポリシー アカウンティングのルート マップの match 句を渡すパケットの出力先を示します。

IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化

ルート マップを定義して一致基準を指定した後、BGP ポリシー アカウンティングをイネーブルにする前に、IP トラフィックを分類する方法を設定する必要があります。

ルーティング テーブルに追加される各プレフィクスは、 table-map コマンドで、一致基準に基づいて BGP により分類されます。BGP ポリシー アカウンティングは、インターフェイスで bgp-policy accounting コマンドが設定されたときにイネーブル化されます。

IP トラフィックを分類して BGP ポリシー アカウンティングをイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router bgp as-number

BGP ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-router)# table-map route-map-name

ルーティング テーブルに入力された BGP プレフィクスを分類します。

ステップ 3

Router(config-router)# network network-number [ mask network-mask ]

BGP ルーティング プロセスによってアドバタイズされるネットワークを指定します。

ステップ 4

Router(config-router)# neighbor ip-address remote-as as-number

BGP ルーティング テーブルにエントリを追加して、BGP ピアを指定します。

ステップ 5

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

Router(config)# interface interface-type interface-number

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

Router(config-if)# no ip directed-broadcast

ブロードキャストよりもインターフェイスが添付されたサブネットを宛先とする、誘導されたブロードキャストをドロップするようにインターフェイスを設定します。これはセキュリティの問題です。

ステップ 8

Router(config-if)# ip address ip-address mask

IP アドレスを使用してインターフェイスを設定します。

ステップ 9

Router(config-if)# bgp-policy accounting

インターフェイスに対して、BGP ポリシー アカウンティングをイネーブルにします。

BGP ポリシー アカウンティングの確認

BGP ポリシー アカウンティングが動作しているかを確認するために、次の手順を実行します。


ステップ 1 どのアカウンティング バケットが指定されたプレフィクスに割り当てられているかを学習するために、 detail キーワードを指定して show ip cef EXEC コマンドを入力します。

この例では、プレフィクス 192.168.5.0 についての出力が表示されます。この例では、アカウンティング バケット番号「4」(traffic_index 4)がこのプレフィクスに割り当てられていることが示されています。

Router# show ip cef 192.168.5.0 detail
 
192.168.5.0/24, version 21, cached adjacency to POS7/2
0 packets, 0 bytes, traffic_index 4
via 10.14.1.1, 0 dependencies, recursive
next hop 10.14.1.1, POS7/2 via 10.14.1.0/30
valid cached adjacency
 

ステップ 2 ステップ 1 と同じプレフィクス(192.168.5.0)に対し、どのコミュニティが割り当てられているかを学習するために show ip bgp EXEC コマンドを入力します。

この例では、プレフィクス 192.168.5.0 についての出力が表示されます。この例では、コミュニティ「100:197」がこのプレフィクスに割り当てられていることが示されています。

Router# show ip bgp 192.168.5.0
 
BGP routing table entry for 192.168.5.0/24, version 2
Paths: (1 available, best #1)
Not advertised to any peer
100
10.14.1.1 from 10.14.1.1 (32.32.32.32)
Origin IGP, metric 0, localpref 100, valid, external, best
Community: 100:197
 

ステップ 3 show cef interface policy-statistics EXEC コマンドを入力し、インターフェイス単位のトラフィック統計情報を表示します。

この例では、各アカウンティング バケットに割り当てられているパケットおよびバイトの数が出力に表示されます。

LC-Slot7# show cef interface policy-statistics
 
POS7/0 is up (if_number 8)
Bucket Packets Bytes
 
1 0 0
2 0 0
3 50 5000
4 100 10000
5 100 10000
6 10 1000
7 0 0
8 0 0


 

BGP ポリシー アカウンティングのモニタリングおよびメンテナンス

BGP ポリシー アカウンティング機能をモニタリングおよびメンテナンスするには、必要に応じて次のコマンドを EXEC モードで使用します。

 

コマンド
目的

Router# show cef interface [ type number ] policy-statistics

すべてのインターフェイスに対する CEF ポリシー統計情報の詳細を表示します。

Router# show ip bgp [ network ] [ network mask ] [ longer-prefixes ]

BGP ルーティング テーブル内のエントリを表示します。

Router# show ip cef [ network [ mask ]] [ detail ]

Forwarding Information Base(FIB; 転送情報ベース)のエントリまたは FIB の概要を表示します。

設定例

BGP ポリシー アカウンティングの一致基準の指定例

IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化の例

BGP ポリシー アカウンティングの一致基準の指定例

次の例では、BGP コミュニティがコミュニティ リストに指定され、set_bucket という名前のルート マップが、 set traffic-index コマンドを使用して、各コミュニティ リストが特定のアカウンティング バケットに一致するように設定されます。

ip community-list 30 permit 100:190
ip community-list 40 permit 100:198
ip community-list 50 permit 100:197
ip community-list 60 permit 100:296
!
route-map set_bucket permit 10
match community 30
set traffic-index 2
!
route-map set_bucket permit 20
match community 40
set traffic-index 3
!
route-map set_bucket permit 30
match community 50
set traffic-index 4
!
route-map set_bucket permit 40
match community 60
set traffic-index 5

IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化の例

次に、POS インターフェイス 7/0 で BGP ポリシー アカウンティングがイネーブルにされ、 table-map コマンドにより IP ルーティング テーブルが BGP で学習されたルートによりアップデートされたときに、バケット番号が変更される例を示します。

router bgp 65000
table-map set_bucket
network 10.15.1.0 mask 255.255.255.0
neighbor 10.14.1.1 remote-as 65100
!
ip classless
ip bgp-community new-format
!
interface POS7/0
ip address 10.15.1.2 255.255.255.0
no ip directed-broadcast
bgp-policy accounting
no keepalive
crc 32
clock source internal

その他の参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

Cisco IOS Master Commands List, All Releases

BGP コマンド

Cisco IOS IP Routing: BGP Command Reference

BGP 設定情報

『Cisco IOS IP Routing: BGP Configuration Guide』の『 Cisco BGP Features Roadmap 』モジュールの章

シスコ エクスプレス フォワーディング(CEF)および分散 CEF(dCEF)

Cisco IOS IP Switching Command Reference

シスコ エクスプレス フォワーディング(CEF)および分散 CEF(dCEF)の設定情報

『Cisco IOS Switching Services Configuration Guide』の『 Cisco Express Forwarding Overview 』モジュール

MIB

MIB
MIB リンク

CISCO-BGP-POLICY-ACCOUNTING-MIB


) CISCO-BGP-POLICY-ACCOUNTING-MIB は、Cisco IOS Release 12.0(9)S、12.0(17)ST、およびそれ以降のリリースだけで使用可能です。この Management Information Base(MIB; 管理情報ベース)は、いずれのメインラインおよび T トレイン リリースでも使用できません。


選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

BGP ポリシー アカウンティングの機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 BGP ポリシー アカウンティングの機能情報

機能名
リリース
機能情報

BGP ポリシー アカウンティング

12.0(9)S
12.0(17)ST
12.2(13)T
15.0(1)S
12.2(50)SY

ボーダー ゲートウェイ プロトコル(BGP)ポリシー アカウンティングは、異なるピア間で送受信される IP トラフィックを測定および分類します。ポリシー アカウンティングは入力インターフェイスでイネーブル化されます。また、コミュニティ リスト、自律システム番号、または自律システム パスなどのパラメータに基づくカウンタが割り当てられ、IP トラフィックを識別します。

次のコマンドが導入または変更されました。

bgp-policy

set traffic-index

show cef interface policy-statistics

show ip bgp

show ip cef