IP ルーティング:BGP コンフィギュレーション ガイド、 Cisco IOS Release 15.2M&T
内部 BGP 機能の設定
内部 BGP 機能の設定
発行日;2012/03/26 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

内部 BGP 機能の設定

機能情報の確認

内容

内部 BGP 機能に関する情報

BGP ルーティング ドメイン コンフェデレーション

BGP ルート リフレクタ

ルーティング ループを回避するルート リフレクタのメカニズム

iBGP ピアの IP ネクスト ホップを設定するルート リフレクタの BGP アウトバウンド ルート マップ

ルート リフレクタでの BGP VPLS オートディスカバリのサポート

BGP ルート ダンプニング

ルート ダンプニングによるルート フラッピングの最小化

BGP ルート ダンプニングの用語

内部 BGP 機能の設定法

ルーティング ドメイン コンフェデレーションの設定

ルート リフレクタの設定

iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタの設定

BGP タイマーの調整

削除された MED を最も条件の悪いパスと見なすようにルータを設定

MED が副自律システム パスからパスを選択すると見なすようにルータを設定

コンフェデレーションのパスの選択に MED を使用するようにルータを設定

BGP ルート ダンプニングのイネーブル化

BGP ルート ダンプニングのモニタリングおよびメンテナンス

内部 BGP 機能の設定例

例:ルート マップのある BGP コンフェデレーション設定

例:BGP コンフェデレーション

例:iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタ

例:ルート リフレクタでの BGP VPLS オートディスカバリのサポート

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

内部 BGP 機能設定用の機能情報

内部 BGP 機能の設定

このモジュールでは、内部ボーダー ゲートウェイ プロトコル(BGP)機能を設定する手順について説明します。Internal BGP(iBGP; 内部 BGP)とは、単一の自律システム内部にあるネットワーキング デバイスで実行中のボーダー ゲートウェイ プロトコル(BGP)のことです。BGP は、独自のルーティング ポリシーを持つ異なるルーティング ドメイン(自律システム)間に、ループのないルーティングを行うように設計されたドメイン間ルーティング プロトコルです。現在は大規模な内部ネットワークを持つ会社が多く、ネットワークの効率を維持したまま、トラフィック需要の増加に合わせて既存の内部ルーティング プロトコルをスケーリングするには課題が山積しています。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「内部 BGP 機能設定用の機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

内部 BGP 機能に関する情報

「BGP ルーティング ドメイン コンフェデレーション」

「BGP ルート リフレクタ」

「iBGP ピアの IP ネクスト ホップを設定するルート リフレクタの BGP アウトバウンド ルート マップ」

「ルート リフレクタでの BGP VPLS オートディスカバリのサポート」

「BGP ルート ダンプニング」

BGP ルーティング ドメイン コンフェデレーション

内部 BGP(iBGP)メッシュを削減する方法の 1 つとして、ある自律システムを複数の副自律システムに分割し、単一のコンフェデレーションにグループ化することがあげられます。外部からは、このコンフェデレーションは単一の自律システムであるかのように見えます。それぞれの自律システムはそれ自体内で完全メッシュ化され、同一のコンフェデレーションにある他の自律システムとの接続をいくつか持っています。他の自律システムのピアに external BGP(eBGP; 外部 BGP)セッションがある場合でも、iBGP ピアであるかのようにルーティング情報を交換します。特に、ネクストホップ、Multi_Exit_Discriminator(MED)属性、およびローカル プリファレンス情報は保持されます。この機能により、自律システムすべてに対して単一の Interior Gateway Protocol(IGP)を保持することができます。

BGP コンフェデレーションを設定するには、コンフェデレーション ID を指定する必要があります。自律システムのグループは、外部からはコンフェデレーション ID を自律システム番号として持つ単一の自律システムのように見えます。

BGP ルート リフレクタ

BGP を使用するには、iBGP スピーカーすべてが完全メッシュ化されている必要があります。ただし、iBGP スピーカーの数が多い場合、この要件はうまくスケーリングできません。コンフェデレーションを設定せずに iBGP メッシュを減らす別の方法として、ルート リフレクタの設定があります。

図 1 に、3 つの iBGP スピーカー(ルータ A、B、C)を持つ、単純な iBGP 設定の例を示します。ルート リフレクタがない場合、外部ネイバーからルータ A がルートを受信すると、ルータ B および C にもアドバタイズする必要があります。ルータ B および C は、iBGP が学習したルートを他の iBGP スピーカーに再アドバタイズしません。その理由は、これらのルータは内部のネイバーから学習したルートを他の内部ネイバーに渡さないからです。こうして、ルーティング情報のループを回避します。

図 1 完全メッシュ化された 3 つの iBGP スピーカー

 

ルート リフレクタがある場合、学習したルートをネイバーに渡す方法があるため、すべての iBGP スピーカーが完全メッシュ化されている必要はありません。このモデルでは、iBGP が学習したルートを一連の iBGP ネイバーに渡す役割を持つルート リフレクタとして、1 つの iBGP ピアが設定されます。図 2 では、ルータ B はルート リフレクタとして設定されています。ルータ A からアドバタイズされたルートをルート リフレクタが受信すると、ルータ C にアドバタイズします。逆の場合も同じです。このスキームにより、ルータ A とルータ C 間の iBGP セッションは不要になります。

図 2 ルート リフレクタのある単純な BGP モデル

 

ルート リフレクタの内部ピアは、次の 2 種類のグループに分けられます。クライアントのピア、および自律システム(非クライアント ピア)の他のルータすべてです。ルート リフレクタは、これらの 2 つのグループ間でルートを反映させます。ルート リフレクタおよびそのクライアント ピアは、 クラスタ を形成します。非クライアント ピアは相互に完全メッシュ構造にする必要がありますが、クライアント ピアはその必要はありません。クラスタ内のクライアントは、クラスタ外の iBGP スピーカーとは通信しません。

図 3 に、より複雑なルート リフレクタのスキームを示します。ルータ A は、ルータ B、C、および D を持つクラスタのルート リフレクタです。ルータ E、F、および G は完全メッシュ化された、非クライアント ルータです。

図 3 より複雑な BGP ルート リフレクタのモデル

 

ルート リフレクタがアドバタイズされたルートを受信すると、ネイバーによって次のようなアクションを取ります。

EBGP スピーカーからのルートをすべてのクライアントおよび非クライアント ピアにアドバタイズします。

非クライアント ピアからのルートをすべてのクライアントにアドバタイズします。

クライアントからのルートをすべてのクライアントおよび非クライアント ピアにアドバタイズします。したがって、クライアントを完全メッシュ構造にする必要はありません。

ルート リフレクタ対応の BGP スピーカーとともに、ルート リフレクタの概念を理解しない BGP スピーカーを併用することもできます。これらは、クライアントまたは非クライアント グループのメンバとなることが可能で、旧 BGP モデルからルート リフレクタ モデルへ、簡単に順次移行することができます。最初に、ルート リフレクタおよびいくつかのクライアントを持つ単一のクラスタを作成することができます。他のすべての iBGP スピーカーはルート リフレクタに対して非クライアント ピアとすることができ、クラスタを作成して徐々に追加していくことができます。

自律システムは複数のルート リフレクタを持つことができます。ルート リフレクタは、他のルート リフレクタを他の iBGP スピーカーと同様に扱います。ルート リフレクタは、他のルート リフレクタをクライアント グループまたは非クライアント グループに含むように設定できます。単純な設定では、バックボーンを多数のクラスタに分割することができます。各ルート リフレクタは、非クライアント ピアとして他のルート リフレクタとともに設定されます(このため、すべてのルート リフレクタは完全メッシュ化されます)。クライアントは、所属するクラスタのルート リフレクタとだけ、iBGP セッションを維持するように設定されます。

通常、クライアントのクラスタには、1 つのルート リフレクタがあります。その場合、クラスタはルート リフレクタのルータ ID で識別されます。冗長性を向上させ、シングル ポイント障害を避けるために、クラスタは複数のルート リフレクタを含むことがあります。この場合、クラスタ内のすべてのルート リフレクタに 4 バイトのクラスタ ID を設定し、ルート リフレクタが同一クラスタ内のルート リフレクタからのアップデートを識別できるようにする必要があります。クラスタの役割を果たすルート リフレクタはすべて完全メッシュ化され、同一のクライアントおよび非クライアント ピアのセットを持っている必要があります。

ルーティング ループを回避するルート リフレクタのメカニズム

iBGP が学習したルートが反映されるため、ルーティング情報がループする場合があります。ルート リフレクタ モデルには、ルーティングがループするのを防ぐために次のようなメカニズムがあります。

送信元 ID は、任意で非遷移な BGP 属性です。これは 4 バイトの属性で、ルート リフレクタにより作成されます。この属性は、ローカル自律システムのルートの送信元のルータ ID を保持します。したがって、設定ミスによりルーティング情報が送信元に戻ってくる場合、その情報は無視されます。

クラスタ リストは任意で非遷移な BGP 属性です。これは、ルートが渡したクラスタ ID のシーケンスです。ルート リフレクタがクライアントから非クライアント ピアへのルート、およびその逆を反映するとき、ローカル クラスタ ID をクラスタ リストにアペンドします。クラスタ リストが空の場合は、新規のクラスタ リストが作成されます。この属性を使用して、ルート リフレクタは、設定ミスによりルーティング情報が同じクラスタにループ バックするかを識別することができます。クラスタ リストにローカル クラスタ ID が見つかった場合、そのアドバタイズメントは無視されます。

アウトバウンド ルート マップで set 句を使用し、属性の変更や、場合によってはルーティング ループの作成を行うことができます。この動作を回避する目的で、アウトバウンド ルート マップのほとんどの set 句は、iBGP ピアに反映されるルートとしては無視されます。処理されたアウトバウンド ルート マップの唯一の set 句が set ip next-hop 句です。

iBGP ピアの IP ネクスト ホップを設定するルート リフレクタの BGP アウトバウンド ルート マップ

IP ネクスト ホップを設定するルート リフレクタの BGP アウトバウンド ルート マップ機能は、反映されたルートのネクスト ホップ属性をルート リフレクタが変更できるようにします。

アウトバウンド ルート マップで set 句を使用し、属性の変更や、場合によってはルーティング ループの作成を行うことができます。この動作を回避する目的で、アウトバウンド ルート マップのほとんどの set 句は、iBGP ピアに反映されるルートとしては無視されます。ルート リフレクタ(RR)の処理されるアウトバウンド ルート マップの唯一の set 句が set ip next-hop 句です。 set ip next-hop 句は反映されるルートに適用されます。

アウトバウンド ルート マップを持つ RR を設定すると、ネットワーク管理者が反映されたルートのネクスト ホップ属性を変更できます。 set ip next-hop 句でルート マップを設定すると、管理者は転送パスに RR を配置し、ロード バランシングを実行するために iBGP マルチパス ロード シェアリングを設定できます。つまり、RR は複数の出力ポイント間の発信パケットを配信できます。『Configuring iBGP Multipath Load Sharing』モジュールを参照してください。


注意 反映されたルートの BGP 属性を誤って設定すると、不整合ルーティング、ルーティング ループ、または接続の切断が発生することがあります。反映されるルートの BGP 属性の設定は、設計上の問題を十分理解しているユーザだけが行うようにする必要があります。

ルート リフレクタでの BGP VPLS オートディスカバリのサポート

Cisco IOS Release 12.2(33)SRE で、ルート リフレクタでの BGP VPLS オートディスカバリのサポートが導入されました。Cisco 7600 および Cisco 7200 シリーズのルータで、BGP ルート リフレクタが拡張され、ルート リフレクタで VPLS を明示的に設定しなくても BGP VPLS プレフィクスを反映できるようになりました。ルート リフレクタは VPLS プレフィクスを他のプロバイダー エッジ(PE)ルータに反映し、PE が BGP セッションの完全メッシュを持つ必要がないようにします。ネットワーク管理者はルート リフレクタの BGP VPLS アドレス ファミリだけを設定します。

VPLS プレフィクスを反映できるルート リフレクタの設定については、「例:ルート リフレクタでの BGP VPLS オートディスカバリのサポート」に例が示されています。VPLS オートディスカバリの詳細については、『 Cisco IOS MPLS Configuration Guide 』の「VPLS Autodiscovery:BGP Based」の章を参照してください。

BGP ルート ダンプニング

ルート ダンプニングは、インターネットワーク間でフラッピング ルートの伝搬を最小限に抑えるように設計された BGP 機能です。ルートは、その可用性が繰り返し切り替わる場合にフラッピングすると見なされます。

たとえば、自律システム 1、自律システム 2、および自律システム 3 という 3 つの BGP 自律システムがあるネットワークについて考えてみます。自律システム 1 のネットワーク A へのルートがフラッピングする(利用できなくなる)と仮定します。ルート ダンプニングがない状況では、自律システム 1 から自律システム 2 への eBGP ネイバーは、取り消しメッセージを自律システム 2 に送信します。次に自律システム 2 内の境界ルータは、取り消しメッセージを自律システム 3 に伝搬します。ネットワーク A へのルートが再出現したとき、自律システム 1 は自律システム 2 に、自律システム 2 は自律システム 3 にアドバタイズメント メッセージを送信します。ネットワーク A へのルートが利用可能になったり不可になったりを繰り返す場合、取り消しメッセージおよびアドバタイズメント メッセージが多数、送信されます。これは、インターネットに接続されたインターネットワークで問題となります。インターネットのバックボーンでルートのフラッピングが生じると、通常、多くのルートに影響を与えるからです。


) ルート ダンプニングがイネーブルになっている場合、BGP ピア リセットにペナルティは適用されません。リセットするとそのルートは取り消されますが、ルート フラップ ダンプニングがイネーブルの場合でも、このインスタンスにペナルティは課されません。


ルート ダンプニングによるルート フラッピングの最小化

ルート ダンプニング機能は、次のようにしてフラッピングの問題を最小限に抑えます。再び、ネットワーク A へのルートがフラッピングしたと仮定します。(ルート ダンプニングがイネーブルになっている)自律システム 2 内のルータは、ネットワーク A にペナルティ 1000 を割り当てて、履歴状態に移行させます。自律システム 2 内のルータは、引き続きネイバーにルートのステータスをアドバタイズします。ペナルティは累積します。ルート フラップが非常に頻繁に発生し、ペナルティが設定可能な抑制制限を超える場合は、フラップの発生回数に関係なく、ルータはネットワーク A へのルートのアドバタイズを停止します。そのため、ルート ダンプニングが発生します。

ネットワーク A に課されたペナルティは再使用制限に達するまで減衰し、達すると同時にそのルートは再びアドバタイズされます。再使用制限の半分の時点で、ネットワーク A へのルートのダンプニング情報が削除されます。

BGP ルート ダンプニングの用語

ルート ダンプニングについて説明する際には、次の用語が使用されます。

フラップ:可用性が繰り返し切り替わるルート。

履歴状態:一度ルート フラップが発生した後で、そのルートにはペナルティが割り当てられ、履歴状態になります。これは、ルータに履歴情報に基づいた最良パスがないことを意味します。

ペナルティ:ルート フラップが発生するたびに、別の自律システム内でルート ダンプニングについて設定されているルータは、ルートにペナルティ 1000 を割り当てます。ペナルティは累積します。そのルートのペナルティは、抑制限度を超えるまで BGP ルーティング テーブルに保存されます。抑制限度を超えると、ルート ステートは履歴からダンプに変更されます。

ダンプ ステート:この状態では、ルート フラップが非常に頻繁に発生したため、ルータはこのルートを BGP ネイバーにアドバタイズしなくなります。

抑制限度:ペナルティがこの制限を超えるとルートは抑制されます。デフォルト値は 2000 です。

半減期:ルートにペナルティが割り当てられると、半減期期間(デフォルトでは 15 分)後にペナルティは半減されます。ペナルティを小さくするプロセスは 5 秒ごとに発生します。

再使用制限:フラッピング ルートのペナルティが減少し、この再使用制限を下回ると、ルートの抑制は解除されます。つまり、ルートは再び BGP テーブルに追加され、フォワーディングに再び使用されます。デフォルトの再使用制限は 750 です。ルートの抑制中止プロセスは、10 秒経過ごとに発生します。10 秒ごとに、ルータは、現在抑制が解除されているルートを検索して、アドバタイズします。

最大抑制制限:この値は、ルートを抑制できる最大時間です。デフォルト値は半減期の 4 倍です。

iBGP から取得した、自律システムの外部にあるルートはダンプニングされません。このポリシーによって、iBGP ピアが自律システムの外部にあるルートに高いペナルティを設定できなくなります。

内部 BGP 機能の設定法

ルーティング ドメイン コンフェデレーションの設定(任意)

ルート リフレクタの設定(任意)

「iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタの設定」

BGP タイマーの調整(任意)

削除された MED を最も条件の悪いパスと見なすようにルータを設定(任意)

MED が副自律システム パスからパスを選択すると見なすようにルータを設定(任意)

コンフェデレーションのパスの選択に MED を使用するようにルータを設定(任意)

BGP ルート ダンプニング(任意)

ルーティング ドメイン コンフェデレーションの設定

BGP コンフェデレーションを設定するには、コンフェデレーション ID を指定する必要があります。自律システムのグループは、外部からはコンフェデレーション ID を自律システム番号として持つ単一の自律システムのように見えます。BGP コンフェデレーション ID を設定するには、次のコマンドをルータ コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config-router)# bgp confederation identifier as-number

BGP コンフェデレーションを設定します。

コンフェデレーション内の他の自律システムから特別な eBGP としてネイバーを処理するには、次のコマンドをルータ コンフィギュレーション モードで使用します。

コマンド
目的

Router(config-router)# bgp confederation peers as-number [as-number]

コンフェデレーションに属する自律システムを指定します。

iBGP メッシュを削減する他の方法については ルート リフレクタの設定を参照してください。

ルート リフレクタの設定

ルート リフレクタおよびそのクライアントを設定するには、次のコマンドをルータ コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config-router)# neighbor { ip-address | peer-group-name } route-reflector-client

ローカル ルータを BGP ルート リフレクタとして、指定されたネイバーをクライアントとして、それぞれ設定します。

クラスタが複数のルート リフレクタを持つ場合は、次のコマンドをルータ コンフィギュレーション モードで使用して、クラスタ ID を設定します。

 

コマンド
目的

Router(config-router)# bgp cluster-id cluster-id

クラスタ ID の設定

show ip bgp コマンドを使用して、送信元 ID およびクラスタ リストの属性を表示します。

デフォルトでは、ルート リフレクタのクライアントは完全メッシュ化されている必要はなく、クライアントからのルートは他のクライアントに反映されます。ただし、クライアントが完全メッシュ化されている場合は、ルート リフレクタはルートをクライアントに反映する必要はありません。

クライアントからクライアントへのルートの反映をディセーブルにするには、 no bgp client-to-client reflection コマンドをルータ コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config-router)# no bgp client-to-client reflection

クライアントからクライアントへのルート リフレクションをディセーブルにします。

iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタの設定

iBGP ピアのネクスト ホップを設定する RR で次の手順を実行します。次の手順を実行する理由の 1 つに挙げられるのが、iBGP のロード シェアリングを設定できるように RR をルートのネクスト ホップにする場合です。RR クライアントにアドバタイズされる、RR のアドレスになるネクスト ホップが設定されたルート マップを作成します。ルート マップは、ルート マップが適用されるルータからのアウトバウンド ルートだけに適用されます。


注意 反映されたルートの BGP 属性を誤って設定すると、不整合ルーティング、ルーティング ループ、または接続の切断が発生することがあります。反映されるルートの BGP 属性の設定は、設計上の問題を十分理解しているユーザだけが行うようにする必要があります。


neighbor next-hop-self コマンドを使用して RR のネクスト ホップ属性を変更しないでください。RR で neighbor next-hop-self コマンドを使用すると、RR クライアントから反映されている意図したルートではなく、非反映ルートに対してだけネクスト ホップ属性が変更されます。ルートを反映するときにネクストホップ属性を変更するには、アウトバウンド ルート マップを使用します。


ここでは、図 4 に示すシナリオの RR(ルータ 2)を設定します。この場合、ルータ 1 はルートのネクスト ホップが設定された iBGP ピアです。ルート マップが存在しない場合、ルータ 1 からのアウトバウンド ルートは、ネクスト ホップ ルータ 3 に進みます。代わりに、RR のアドレスにネクスト ホップを設定すると、ルータ 1 からのルートが RR に送られ、RR は、ルータ 3、4、および 5 間のロード バランシングを実行できます。

図 4 iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタ

手順の概要

1. enable

2. configure terminal

3. route-map map-tag

4. set ip next-hop ip-address

5. exit

6. router bgp as-number

7. address-family ipv4

8. maximum-paths ibgp number

9. neighbor ip-address remote-as as-number

10. neighbor ip-address activate

11. neighbor ip-address route-reflector-client

12. neighbor ip-address route-map map-tag out

13. その他の RR クライアントごとにステップ 12 ~ 14 を繰り返します。

14. end

15. show ip bgp neighbors

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

route-map map-tag

 

Router(config)# route-map rr-out

ルート マップ コンフィギュレーション モードを開始して、ルート マップを設定します。

ルート マップはルート リフレクタ クライアントのネクストホップを設定するために作成されます。

ステップ 4

set ip next-hop ip-address

 

Router(config-route-map)# set ip next-hop 10.2.0.1

このルート マップが適用される、アドバタイズされるルートに対して、ネクスト ホップ属性をこの IPv4 アドレスに設定することを指定します。

この作業では、RR のアドレスになるようにネクスト ホップを設定します。

ステップ 5

exit

 

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 6

router bgp as-number

 

Router(config)# router bgp 100

ルータ コンフィギュレーション モードを開始して、BGP ルーティング プロセスを作成します。

ステップ 7

address-family ipv4

 

Router(config-router-af)# address-family ipv4

アドレス ファミリ コンフィギュレーション モードを開始して、アドレス ファミリ固有の設定を受け入れるように BGP ピアを設定します。

ステップ 8

maximum-paths ibgp number

 

Router(config-router)# maximum-paths ibgp 5

ルーティング テーブルにインストールできる並列 iBGP ルートの最大数を制御します。

ステップ 9

neighbor ip-address remote-as as-number

 

Router(config-router-af)# neighbor 10.1.0.1 remote-as 100

エントリを BGP ネイバー テーブルに追加します。

ステップ 10

neighbor ip-address activate

 

Router(config-router-af)# neighbor 10.1.0.1 activate

ピアとの情報交換をイネーブルにします。

ステップ 11

neighbor ip-address route-reflector-client

 

Router(config-router-af)# neighbor 10.1.0.1 route-reflector-client

ローカル ルータを BGP ルート リフレクタに設定し、指定されたネイバーをルート リフレクタ クライアントに設定します。

ステップ 12

neighbor ip-address route-map map-name out

 

Router(config-router-af)# neighbor 10.1.0.1 route-map rr-out out

このネイバーから発信ルートにルート マップを適用します。

ステップ 3 で作成したルート マップを参照してください。

ステップ 13

その他の RR クライアントごとにステップ 12 ~ 14 を繰り返します。

その他の RR クライアントにはルート マップを適用しません。

ステップ 14

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ステップ 15

show ip bgp neighbors

 

Router# show ip bgp neighbors

(任意)RR クライアントとしてのステータスを含む BGP ネイバーに関する情報、および設定されたルート マップに関する情報を表示します。

BGP タイマーの調整

BGP は、ある種のタイマーを使用して、キープアライブ メッセージの送信や、キープアライブ メッセージを受信しなくなってからの間隔(この後 Cisco IOS ソフトウェアがピアのデッドを宣言する)などの周期的なアクティビティを制御しています。デフォルトでは、キープアライブ タイマーは 60 秒で、ホールドタイム タイマーは 180 秒です。これらのタイマーを調整することができます。接続が開始されたとき、BGP はホールドタイムをネイバーとネゴシエーションします。2 つのホールドタイムのうちの小さい方が選択されます。次に、ネゴシエーションされたホールドタイムおよび設定されたキープアライブ時間をもとにキープアライブ タイマーが設定されます。

すべてのネイバーに対して BGP タイマーを調整するには、次のコマンドをルータ コンフィギュレーション モードで使用します。

コマンド
目的

Router(config-router)# timers bgp keepalive holdtime

すべてのネイバーに対して BGP タイマーを調整します。

BGP のキープアライブ タイマーおよびホールドタイム タイマーを特定のネイバー用に調整するには、次のコマンドをルータ コンフィギュレーション モードで使用します。

コマンド
目的

Router(config-router)# neighbor [ ip-address | peer-group-name ] timers keepalive holdtime

指定されたピアまたはピア グループに対し、キープアライブまたはホールドタイム タイマー(秒単位)を設定します。


) 特定のネイバーまたはピア グループに対して設定されたタイマーは、timers bgp ルータ コンフィギュレーション コマンドを使用してすべての BGP ネイバーに対して設定されたタイマーを上書きします。


BGP ネイバーまたはピア グループのタイマーをクリアするには、 neighbor timers コマンドの no 形式を使用します。

削除された MED を最も条件の悪いパスと見なすようにルータを設定

削除された MED 属性を持つパスを最も条件の悪いパスと見なすようにルータを設定するには、次のコマンドをルータ コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config-router)# bgp bestpath med missing-as-worst

削除された MED は無限大の値を持つと見なし、MED 値を持たないそのパスを最も条件の悪いパスとするようにルータを設定します。

MED が副自律システム パスからパスを選択すると見なすようにルータを設定

パスを選択する際に MED 値を考慮するようにルータを設定するには、次のコマンドをルータ コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config-router)# bgp bestpath med confed

コンフェデレーション内の複数の副自律システムによりアドバタイズされた中からパスを選択する際に MED を考慮するようにルータを設定します。

MED 間での比較が行われるのは、パスに外部自律システムがない場合に限ります(外部自律システムとは、コンフェデレーションの内部にない自律システムのことです)。パスに外部自律システムがある場合、外部 MED は透過的にコンフェデレーションを通過し、比較は行われません。

次の例では、ルート A をこれらのパスと比較します。

path= 65000 65004, med=2
path= 65001 65004, med=3
path= 65002 65004, med=4
path= 65003 1, med=1

このケースでは、 bgp bestpath med confed ルータ コンフィギュレーション コマンドがイネーブルの場合、パス 1 が選択されます。4 番目のパスの方が MED の値が低いですが、このパスには外部自律システムがあるため、MED を比較する対象にはなりません。

コンフェデレーションのパスの選択に MED を使用するようにルータを設定

コンフェデレーション内の単一の副自律システムによりアドバタイズされたパスの中から最良のパスを選択するために MED を使用するようルータを設定するには、次のコマンドをルータ コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config-router)# bgp deterministic med

同一自律システムの異なるピアによりアドバタイズされたルートから選択する際、MED 変数を比較するようにルータを設定します。


bgp always-compare-med ルータ コンフィギュレーション コマンドがイネーブルな場合は、すべてのパスは完全に比較可能で、bgp deterministic med コマンドがイネーブルになっている場合でも、コンフェデレーションの他の自律システムからのパスも比較対象です。


BGP ルート ダンプニングのイネーブル化

BGP ルート ダンプニングをイネーブルにするには、次のコマンドをアドレス ファミリまたはルータ コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config-router)# bgp dampening

BGP ルート ダンプニングをイネーブルにします。

さまざまなダンプニング要素のデフォルト値を変更するには、次のコマンドをアドレス ファミリ モードまたはルータ コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config-router)# bgp dampening half-life reuse suppress max-suppress [ route-map map-name ]

ルート ダンプニング要素のデフォルト値を変更します。

BGP ルート ダンプニングのモニタリングおよびメンテナンス

フラッピングしているすべてのパスのフラップをモニタできます。ルートの抑制が解除され、少なくとも 1 半減期の間安定すれば、統計情報は削除されます。フラップの統計情報を表示するには、次のコマンドを必要に応じて使用します。

 

コマンド
目的

Router# show ip bgp flap-statistics

すべてのパスの BGP フラップ統計情報を表示します。

Router# show ip bgp flap-statistics regexp regexp

正規表現に一致するすべてのパスの BGP フラップ統計情報を表示します。

Router# show ip bgp flap-statistics filter-list access- list

フィルタを通過したすべてのパスの BGP フラップ統計情報を表示します。

Router# show ip bgp flap-statistics ip-address mask

単一エントリの BGP フラップ統計情報を表示します。

Router# show ip bgp flap-statistics ip-address mask longer-prefix

さらに限定したエントリの BGP フラップ統計情報を表示します。

BGP フラップ統計情報をクリアする(したがってルートがダンプニングされる可能性を減少させる)には、次のコマンドを必要に応じて使用します。

コマンド
目的

Router# clear ip bgp flap-statistics

すべてのルートの BGP フラップ統計情報をクリアします。

Router# clear ip bgp flap-statistics regexp regexp

正規表現に一致するすべてのパスの BGP フラップ統計情報をクリアします。

Router# clear ip bgp flap-statistics filter-list list

フィルタを通過したすべてのパスの BGP フラップ統計情報をクリアします。

Router# clear ip bgp flap-statistics ip-address mask

単一エントリの BGP フラップ統計情報をクリアします。

Router# clear ip bgp ip-address flap-statistics

ネイバーからのすべてのパスの BGP フラップ統計情報をクリアします。


) BGP ピアがリセットされたときも、ルートのフラップ統計情報はクリアされます。リセットするとそのルートは取り消されますが、ルート フラップ ダンプニングがイネーブルの場合でも、このインスタンスにペナルティは課されません。


ルートがダンプニングされると、ダンプニングされたルートが抑制解除されるまでの時間を含む BGP ルート ダンプニング情報が表示されます。情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

Router# show ip bgp dampened-paths

抑制が解除されるまでの時間を含む、ダンプニングされたルートを表示します。

次のコマンドを使用して、BGP ダンプニング情報をクリアし、抑制されたルートを抑制解除することができます。

 

コマンド
目的

Router# clear ip bgp dampening [ ip-address network-mask ]

ルート ダンプニング情報をクリアし、抑制されたルートを抑制解除します。

内部 BGP 機能の設定例

「例:ルート マップのある BGP コンフェデレーション設定」

「例:BGP コンフェデレーション」

「例:iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタ」

「例:ルート リフレクタでの BGP VPLS オートディスカバリのサポート」

例:ルート マップのある BGP コンフェデレーション設定

ここでは、BGP コミュニティおよびルート マップを含む BGP コンフェデレーション設定の使用例を説明します。BGP コンフェデレーションの他の設定例については、この章の「例:BGP コンフェデレーション」を参照してください。

この例では、BGP コンフェデレーション設定でルートをフィルタするために BGP コミュニティ属性がどのように使用されるかを説明します。

この例では、 set-community という名前のルート マップがネイバー 172.16.232.50 へのアウトバウンドのアップデートに適用され、local-as community 属性がそのルートをフィルタするために使用されます。アクセス リスト 1 を渡すルートは、local-as という特別なコミュニティ属性値を持っています。残りのルートは通常どおりアドバタイズされます。この特別なコミュニティ値は、自律システム 200 外部の BGP スピーカーによるこれらのルートのアドバタイズメントを自動的に防ぎます。

router bgp 65000
network 10.0.1.0 route-map set-community
bgp confederation identifier 200
bgp confederation peers 65001
neighbor 172.16.232.50 remote-as 100
neighbor 172.16.233.2 remote-as 65001
!
route-map set-community permit 10
match ip address 1
set community local-as
!

例:BGP コンフェデレーション

次に、コンフェデレーションのいくつかのピアを表示する設定の例を示します。このコンフェデレーションは、自律システム番号 6001、6002、および 6003 の 3 つの自律システムから構成されています。コンフェデレーション外の BGP スピーカーには、このコンフェデレーションは( bgp confederation identifier ルータ コンフィギュレーション コマンドを通じて指定される)自律システム番号 500 を持つ通常の自律システムのように見えます。

自律システム 6001 の BGP スピーカーで、 bgp confederation peers ルータ コンフィギュレーション コマンドは、自律システム 6002 および 6003 からのピアを特別な eBGP ピアとしてマークします。したがって、ピア 172.16.232.55 および 172.16.232.56 は、ローカル プリファレンス、ネクストホップ、および未変更の MED をこのアップデートで取得します。10.16.69.1 のルータは通常の eBGP スピーカーで、このピアから受け取る更新は、自律システム 6001 のピアからの通常の eBGP 更新とまったく同じです。

router bgp 6001
bgp confederation identifier 500
bgp confederation peers 6002 6003
neighbor 172.16.232.55 remote-as 6002
neighbor 172.16.232.56 remote-as 6003
neighbor 10.16.69.1 remote-as 777
 

自律システム 6002 の BGP スピーカーでは、自律システム 6001 および 6003 からのピアは特別な eBGP ピアとして設定されます。10.70.70.1 は通常の iBGP ピアであり、10.99.99.2 は自律システム 700 からの通常の eBGP ピアです。

router bgp 6002
bgp confederation identifier 500
bgp confederation peers 6001 6003
neighbor 10.70.70.1 remote-as 6002
neighbor 172.16.232.57 remote-as 6001
neighbor 172.16.232.56 remote-as 6003
neighbor 10.99.99.2 remote-as 700
 

自律システム 6003 の BGP スピーカーでは、自律システム 6001 および 6002 からのピアは特別な eBGP ピアとして設定されます。10.200.200.200 は、自律システム 701 からの通常の eBGP ピアです。

router bgp 6003
bgp confederation identifier 500
bgp confederation peers 6001 6002
neighbor 172.16.232.57 remote-as 6001
neighbor 172.16.232.55 remote-as 6002
neighbor 10.200.200.200 remote-as 701
 

次に、同じ例の自律システム 701 からの BGP スピーカー 10.200.200.205 からの設定の一部を示します。ネイバー 172.16.232.56 は、自律システム 500 からの通常の eBGP スピーカーとして設定されます。この自律システムを複数の自律システムに内部分割することは、コンフェデレーション外部のピアには知らされていません。

router bgp 701
neighbor 172.16.232.56 remote-as 500
neighbor 10.200.200.205 remote-as 701

例:iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタ

次の例は図 4 に基づいています。ルータ 2 は、クライアント(ルータ 1、3、4、および 5)のルート リフレクタです ルータ 1 はルータ 3 に接続されますが、ルータ 3 をネクスト ホップとして使用する(つまり、ルータ 3 との直接リンクを使用する)ためにルータ 1 が AS 200 宛てのトラフィックを転送しないようにします。ルータ 3、4、および 5 の間でロード シェアリングを実行できる RR にトラフィックを送信します。

次に、RR(ルータ 2)を設定する例を示します。rr-out という名前のルート マップが、ルータ 1 に適用されます。ルート マップは、ネクスト ホップが 10.2.0.1 の RR になるように設定します。ネクスト ホップが RR アドレスであることをルータ 1 が確認すると、ルータ 1 は RR にルートを転送します。RR はパケットを受信すると、自動的に iBGP パス間でロード シェアリングを実行します。最大 5 個の iBGP パスが許可されます。

ルータ 2

route-map rr-out
set ip next-hop 10.2.0.1
!
interface gigabitethernet 0/0
ip address 10.2.0.1 255.255.0.0
router bgp 100
address-family ipv4 unicast
maximum-paths ibgp 5
neighbor 10.1.0.1 remote-as 100
neighbor 10.1.0.1 activate
neighbor 10.1.0.1 route-reflector-client
neighbor 10.1.0.1 route-map rr-out out
!
neighbor 10.3.0.1 remote-as 100
neighbor 10.3.0.1 activate
neighbor 10.3.0.1 route-reflector-client
!
neighbor 10.4.0.1 remote-as 100
neighbor 10.4.0.1 activate
neighbor 10.4.0.1 route-reflector-client
!
neighbor 10.5.0.1 remote-as 100
neighbor 10.5.0.1 activate
neighbor 10.5.0.1 route-reflector-client
end

例:ルート リフレクタでの BGP VPLS オートディスカバリのサポート

次の例では、PE-RR(プロバイダー エッジ ルート リフレクタであることを示す)という名前のホストが、VPLS プレフィクス可能なルート リフレクタとして設定されます。VPLS アドレス ファミリは、次の address-family l2vpn vpls によって設定されます。

hostname PE-RR
!
router bgp 1
bgp router-id 1.1.1.3
no bgp default route-target filter
bgp log-neighbor-changes
neighbor iBGP_PEERS peer-group
neighbor iBGP_PEERS remote-as 1
neighbor iBGP_PEERS update-source Loopback1
neighbor 1.1.1.1 peer-group iBGP_PEERS
neighbor 1.1.1.2 peer-group iBGP_PEERS
!
address-family l2vpn vpls
neighbor iBGP_PEERS send-community extended
neighbor iBGP_PEERS route-reflector-client
neighbor 1.1.1.1 peer-group iBGP_PEERS
neighbor 1.1.1.2 peer-group iBGP_PEERS
exit-address-family
!

その他の参考資料

ここでは、内部 BGP 機能の設定に関連する参考資料について説明します。

関連資料

関連項目
参照先

BGP コマンド

Cisco IOS IP Routing: BGP Command Reference』

BGP の概要

Cisco BGP Overview モジュール

基本的な BGP 設定作業

Configuring a Basic BGP Network 』モジュール

iBGP のマルチパス ロード シェアリング

iBGP Multipath Load Sharing モジュール

サービス プロバイダーへの接続

Connecting to a Service Provider Using External BGP 』モジュール

複数の IP ルーティング プロトコルに適用する機能の設定

『Configuring IP Routing Protocol-Independent Features』

標準

標準
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1772

『Application of the Border Gateway Protocol in the Internet』

RFC 1773

『Experience with the BGP Protocol』

RFC 1774

『BGP-4 Protocol Analysis』

RFC 1930

『Guidelines for Creation, Selection, and Registration of an Autonomous System (AS)』

RFC 2519

『A Framework for Inter-Domain Route Aggregation』

RFC 2858

『Multiprotocol Extensions for BGP-4』

RFC 2918

『Route Refresh Capability for BGP-4』

RFC 3392

『Capabilities Advertisement with BGP-4』

RFC 4271

『A Border Gateway Protocol 4 (BGP-4)』

RFC 4893

『BGP Support for Four-octet AS Number Space』

RFC 5396

『Textual Representation of Autonomous system (AS) Numbers』

RFC 5398

『Autonomous System (AS) Number Reservation for Documentation Use』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

内部 BGP 機能設定用の機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

このテクノロジーの機能でここに記載されていない情報については、『 Cisco BGP Features Roadmap 』を参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 内部 BGP 機能設定用の機能情報

機能名
リリース
機能の設定情報

内部 BGP 機能の設定

10.3
12.0(32)S12
12.0(7)T
12.2(33)SRA
12.2(33)SXH

このモジュールのすべての機能はレガシー機能と見なされ、すべてのトレインのリリース イメージで動作します。

次のコマンドはこれらの機能により追加または変更されました。

bgp always-compare-med

bgp bestpath med confed

bgp bestpath med missing-as-worst

bgp client-to-client reflection

bgp cluster-id

bgp confederation identifier

bgp confederation peers

bgp dampening

bgp deterministic med

clear ip bgp dampening

clear ip bgp flap-statistics

neighbor route-reflector-client

neighbor timers

show ip bgp

show ip bgp dampened-paths

show ip bgp flap-statistics

timers bgp

IP ネクスト ホップを設定するルート リフレクタの BGP アウトバウンド ルート マップ

12.0(22)S
12.0(16)ST
12.2
12.2(14)S
15.0(1)S

IP ネクスト ホップを設定するルート リフレクタの BGP アウトバウンド ルート マップ機能は、反映されたルートのネクスト ホップ属性をルート リフレクタが変更できるようにします。

この機能は次のセクションに記載されています。

「iBGP ピアの IP ネクスト ホップを設定するルート リフレクタの BGP アウトバウンド ルート マップ」

「iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタの設定」

「例:iBGP ピアのネクスト ホップを設定するルート マップを使用するルート リフレクタ」

ルート リフレクタでの BGP VPLS オートディスカバリのサポート

12.2(33)SRE

この機能は Cisco 7600 および Cisco 7200 シリーズのルータで追加されました。この機能は次のセクションに記載されています。

「ルート リフレクタでの BGP VPLS オートディスカバリのサポート」

「例:ルート リフレクタでの BGP VPLS オートディスカバリのサポート」