Cisco IOS NetFlow コンフィギュレーション ガイド
VRF インターフェイス用 NDE
VRF インターフェイス用 NDE
発行日;2012/02/04 | 英語版ドキュメント(2010/08/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

VRF インターフェイス用 NDE

機能情報の検索

目次

の前提条件

の制約事項

について

MPLS VPN ネットワークの例

MPLS VPN ネットワークを出るトラフィックの分析(NetFlow を使用)

MPLS 集約ラベル

格納された MPLS 集約ラベル

格納された MPLS 集約ラベルが 511 を超えた場合

NetFlow キャッシュ書き込み

VPN CAM 内の MPLS 集約ラベル

VPN CAM 外の MPLS 集約ラベル

MPLS 固有のラベル

MPLS VPN NetFlow のキャプチャおよびエクスポートの設定

NetFlow キャッシュでの送信元インターフェイスとしての VRF 名

MPLS VPN の の設定方法

の設定例

MPLS VPN が 1 つ存在するサンプル ネットワークの設定:例

VRF での 機能の設定:例

関連情報

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

VRF インターフェイス用 NDE

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; VPN ルーティングおよび転送)インターフェイス用 NetFlow Data Export(NDE; NetFlow データ エクスポート)機能では、IPv4 MPLS 仮想プライベート ネットワーク(VPN)の最終マルチプロトコル ラベル スイッチング(MPLS)ホップのルータに入るトラフィックに対し、ハードウェア NetFlow キャッシュ エントリの作成およびエクスポートを実行できます。VRF インターフェイス用 NDE 機能により、サイト単位の転送テーブル(VRF)用に設定された IPv4 インターフェイスで受信したトラフィックについてハードウェア NetFlow キャッシュに収集されたデータには、確実に、VRF 固有のルーティング情報が含まれるようになります。

機能情報の検索

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「VRF インターフェイス用 NDEの機能情報」を参照してください。

プラットフォームのサポートと Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

VRF インターフェイス用 NDEの前提条件

VRF インターフェイス用 NDE 機能を設定するには、ルータで Cisco IOS Release 12.2(33)SRB 以降を実行する必要があります。

VRF インターフェイス用 NDEの制約事項

VRF インターフェイス用 NDE 機能がサポートするのは、IPv4 トラフィックのみです。

VRF インターフェイス用 NDE 機能を MPLS VPN 用に設定すると、ルータは予約された VLAN ID を MPLS VPN に割り当てます。これにより、ルータで設定した、VLAN ID を必要とするその他の機能で使用できる VLAN ID の数が限定されます。

VRF インターフェイス用 NDEについて

VRF インターフェイス用 NDE 機能を設定する前に、次の概念を理解する必要があります。

「MPLS VPN ネットワークの例」

「MPLS VPN ネットワークを出るトラフィックの分析(NetFlow を使用)」

「MPLS 集約ラベル」

「NetFlow キャッシュ書き込み」

「NetFlow キャッシュでの送信元インターフェイスとしての VRF 名」

MPLS VPN ネットワークの例

図 1 は、単純な MPLS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)の例です。ルータ PE1 と PE2 を MPLS VPN をサポートするように設定し、ルータ CE1 と CE2 が配置されているサイト間でユーザのトラフィックを伝送できます。ルータ PE1 と PE2 では、MPLS VPN のルーティング トラフィックにマルチプロトコル iBGP ピアを使用します。この例では、VRF インターフェイス用 NDE 機能をルータ PE1 と PE2 に適用できます。

図 1 単純な MPLS VPN ネットワークの例

 

Cisco 7600 シリーズ ルータで MPLS を設定する方法の詳細については、『 Cisco 7600 Series Cisco IOS Software Configuration Guide 』の「 Configuring PFC3BXL and PFC3B Multiprotocol Label Switching (MPLS) 」の章を参照してください。

MPLS VPN ネットワークを出るトラフィックの分析(NetFlow を使用)

VRF インターフェイス用 NDE 機能は、MPLS VPN VRF インターフェイスでルータが受信したトラフィックをキャプチャします。キャプチャは、MPLS ネットワークを出るときに行われます。たとえば、図 2 に示すように、PE2 の VPN Red に VRF インターフェイス用 NDE 機能を設定した場合、CE2 との間でやり取りするトラフィックが VRF Red に割り当てられると、このトラフィックは NetFlow キャッシュに追加され、VPN Red で受信されたものとして表示されます。

図 2 MPLS VPN VRF インターフェイス上でトラフィックを受信するルータ(PE2)の例

 

MPLS 集約ラベル

VPN MPLS ラベルには次の 2 つのタイプがあります。

ルーティングの判断が行われる必要のあるトラフィックの集約ラベル

非集約(特定の)ラベル。

PE ルータで MPLS VPN を設定すると、ルータは VPN の集約 MPLS ラベルを割り当てます。

集約 MPLS ラベルはパケットが属する VRF に対応するため、パケットを転送するには、ルータは VRF のルーティング テーブルを参照して、VPN ドメイン内の正しいネクストホップ IP アドレスを確認する必要があります。VPN ドメインは複数のネクストホップ ルータをサポートできるため、ルータがパケットを転送するには、ネクストホップ IP アドレスが必要です。たとえば、図 2 には、CE2 と CE3 という 2 つの CE ルータがあります。PE1 の VPN Red に着信する MPLS トラフィックは、CE2 と CE3 のいずれかに接続されたホストを宛先とすることができます。PE2 は別のルックアップを実行し、トラフィックの転送先とする正しい CE ルータを特定する必要があります。PE2 を使用してネクストホップ IP アドレス ルックアップを実行する方法は、ルータが格納した MPLS 集約ラベルの数によって異なります。

格納された MPLS 集約ラベル

最初の 511 個の集約 MPLS ラベルのうちのいずれかを使用するトラフィックは、VPN Content Addressable Memory(CAM)にある MPLS VPN ラベルのエントリに基づいてルータによって転送されます。

最初の 511 個の集約 MPLS ラベルのうちのいずれかを使用する MPLS トラフィックの転送は、PE ルータによって次のように行われます。

1. 集約ラベルを伝送する MPLS パケットが、出力 PE ルータに着信します。

2. この MPLS 集約ラベルについて、VPN CAM でのルックアップが実行されます。

3. MPLS 集約ラベルが削除され、パケットの対応する VPN ID が特定されます。

4. VPN CAM から入手したインデックスを使用して、MPLS VPN ルーティング テーブルを参照します。

5. MPLS VPN テーブルから派生した VPN VRF の宛先 IP プレフィクスについて、ルックアップが実行されます。ルックアップの結果には、パケットを正しい CE ルータに転送するために必要な、ネクストホップ IP アドレスと、その他のすべてのリライト情報が含まれます。

格納された MPLS 集約ラベルが 511 を超えた場合

ネットワークの MPLS 集約ラベルの数が 511 を超えると、ルータは、その VPN CAM にそれ以上 MPLS 集約ラベルを格納できません。この場合、ルータは MPLS FIB を参照し、ラベルを取り除いて内部でカプセル化された IPv4 パケットを明らかにします。VRF FIB によってネクストホップが確認された時点でパケットを再循環させます。


) 最初の 511 個の集約 MPLS ラベルは VPN CAM に残り、「格納された MPLS 集約ラベル」の手順に従って処理されます。


集約 MPLS ラベルが VPN CAM 内に存在しない場合に MPLS トラフィックを転送するには、PE ルータによって次の処理が実行されます。

1. TCAM と FIB でルックアップが実行されます。

2. MPLS ラベルが設定され、MPLS 集約ラベルに関連付けられた予約済みの VLAN がパケットに割り当てられます。


) MPLS 集約ラベルの数が 511 を超えると、新しい MPLS 集約ラベルごとに、予約された VLAN インターフェイスが割り当てられます。


3. 予約された VLAN ID の VPN ID は、VLAN RAM から派生したものです。VPN ID は、IP VRF Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)ルックアップのルックアップ キーの一部として使用されます。

4. IP VRF CEF ルックアップの結果には、パケットを正しい CE ルータに転送するために必要な、ネクストホップ IP アドレスと、その他のすべてのリライト情報が含まれます。

NetFlow キャッシュ書き込み

VRF インターフェイス用 NDE 機能を MPLS VPN 用に設定すると、VLAN インターフェイスが予約され、VLAN インターフェイスで NetFlow がイネーブルになります。MPLS VPN IPv4 トラフィックを処理して NetFlow キャッシュを書き込むためにルータが使用する方法は、ルータが格納した MLS 集約ラベルの数に応じて異なります。

VPN CAM 内の MPLS 集約ラベル

VPN 集約 MPLS ラベルの数が 512 よりも少ないと、ラベルと、関連付けられた VPN は MPLS VPN CAM でプログラムされるため、パケットの再循環は必要ありません。Policy Feature Card(PFC; ポリシー フィーチャ カード)は、パケットを IP パケットとして受け取ります。PFC NetFlow 機能はフローを、トラフィックを受信したインターフェイスから送信されたものとしてではなく、MPLS VPN から送信されたものと見なします。

VPN 集約 MPLS ラベルの数が 512 に満たない(すべての MPLS 集約ラベルが VPN CAM に格納されている)場合、 ip flow ingress コマンドを使用して MPLS インターフェイス上で NetFlow をイネーブルにすることで MPLS 集約ラベルを使用する MPLS トラフィック用に NetFlow キャッシュが設定されます。たとえば、図 2 に示すようにルータ PE2 の VPN CAM にある MPLS 集約ラベルに基づいて転送されるトラフィックの NetFlow をイネーブルにするには、FastEthernet0/0 インターフェイスで ip flow ingress コマンドを設定する必要があります。この操作により、キャッシュを設定できます。ルータで NetFlow データをコレクタにエクスポートするには、グローバル コンフィギュレーション モードで flow hardware mpls-vpn ip vrf-id コマンドを発行する必要があります。

VPN CAM 外の MPLS 集約ラベル

ネットワークの MPLS 集約ラベルの数が 511 を超えると、VPN CAM がいっぱいになります。VPN CAM に格納されている MPLS 集約ラベルを使用しない場合、トラフィックを再循環させる必要があります。パケットは、まず Policy Feature Card(PFC; ポリシー フィーチャ カード)によって処理されて MPLS ラベルが除外され、次に VRF インターフェイス用 NDE 機能をイネーブルにしたときに割り当てた予約 VPN VLAN として指定された VLAN とともに PFC によって処理されます。VLAN RAM は、この VLAN をルーティングに使用する VPN にマップします。PFC NetFlow 機能はフローを、予約された VRF VLAN から送信されたものと見なします。予約された VLAN インターフェイスの Ternary Content Addressable Memory(TCAM)エントリにより、NetFlow へのフロー マスクが提供されます。

VPN CAM にない集約ラベルとともに受信した MPLS VPN トラフィックのフローは、グローバル コンフィギュレーション モードで各 VPN VRF に flow hardware mpls-vpn ip vrf-id コマンドを発行することで、NetFlow キャッシュに書き込まれます。

MPLS 固有のラベル

非集約ラベルの場合、定義上は、ルータは基礎をなす IP パケットを確認してパケットのルーティング先を特定する必要はありません。IP フローにキャッシュ書き込みを実行させるには、 flow hardware mpls-vpn ip vrf-id コンフィギュレーション コマンドを入力する必要があります。これにより、特定のラベル フロー トラフィックでラベルを除外し、終了インターフェイスに転送する前に、予約された VPN VLAN に再循環させることができます。ただし、トラフィックの転送に遅延が生じます。

MPLS VPN NetFlow のキャプチャおよびエクスポートの設定

使用している MPLS 集約ラベルには関係なく、分析対象とするすべてのトラフィックについて NetFlow データのキャプチャおよびエクスポートをイネーブルにするには、MPLS インターフェイスで ip flow ingress コマンドを設定し、グローバル コンフィギュレーション モードで各 VPN VRF に flow hardware mpls-vpn ip vrf-id コマンドを設定します。


) NetFlow キャッシュのデータに NetFlow Data Export(NDE; NetFlow データ エクスポート)を設定する手順については、「MPLS VPN の VRF インターフェイス用 NDE の設定方法」を参照してください。


NetFlow キャッシュでの送信元インターフェイスとしての VRF 名

MPLS インターフェイスの MPLS VPN で受信したトラフィックの場合、NetFlow キャッシュにあるトラフィックの送信元インターフェイスは、トラフィックを受信した物理インターフェイスではなく、VPN 名として一覧表示されます。たとえば、図 2 の PE2 の FastEthernet0/0 で受信されたトラフィックは、FastEthernet0/0 インターフェイスではなく、VPN Red で受信されたものとしてルータの NetFlow キャッシュに表示されます。

MPLS VPN の VRF インターフェイス用 NDE の設定方法

MPLS VPN に VRF インターフェイス用 NDE 機能を設定するには、次のタスクを実行します。この設定は、図 3 の PE1 ルータに適切です。ルータ PE2 にもこの設定を行いますが、インターフェイス参照は、PE2 に適したインターフェイスに変更する必要があります。


) このタスクには、ルータ PE1 と PE2 間の MPLS VPN をアクティブにするために必要な Open Shortest Path First(OSPF)と Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を設定するコマンドは含まれていません。図 3 に示したサンプル ネットワークのすべてのデバイスに関する設定については、「VRF インターフェイス用 NDEの設定例」を参照してください。


図 3 サンプル ネットワーク(MPLS VPN は 1 つ存在)

 

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-id

4. rd route-distinguisher

5. route-target { import | export | both } route-target-ext-community

6. interface type number

7. ip address ip-address mask

8. exit

9. mpls label protocol { ldp | tdp }

10. mpls ldp router-id type number

11. interface type number

12. ip address ip-address mask

13. mpls ip

14. ip flow ingress

15. interface type number

16. ip vrf forwarding vrf-id

17. ip address ip-address mask

18. exit

19. mls nde sender

20. mls flow ip { interface-destination-source | interface-full }

21. ip flow-export version 9

22. ip flow-export destination { ip-address | hostname } udp-port

23. flow hardware mpls-vpn ip vrf-id

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-id

 

Router(config)# ip vrf red

VPN Routing/Forwarding(VRF; VPN ルーティング/転送)インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

ステップ 4

rd route-distinguisher

 

Router(config)# rd 200:2

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)ルーティング/転送(VRF)インスタンスのルーティングおよび転送テーブルを作成します。

ステップ 5

route-target { import | export | both } route-target-ext-community

 

Router(config)# route-target both 200:20

VPN VRF 用にルート ターゲット拡張コミュニティを作成します。

ステップ 6

interface type number

 

Router(config)# interface loopback 0

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始して設定します。

ステップ 7

ip address ip-address mask

 

Router(config-if)# ip address 172.20.1.2 255.255.255.0

インターフェイス上で IP アドレスを設定します。

ステップ 8

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 9

mpls label { ldp | tdp }

 

Router(config)# mpls label protocol ldp

MPLS ラベル配布プロトコルを指定します。

ステップ 10

mpls ldp router-id type number

 

Router(config)# mpls ldp router-id loopback0

Label Distribution Protocol(LDP; ラベル配布プロトコル)ルータ ID を決定する優先インターフェイスを指定します。

ステップ 11

interface type number

 

Router(config-if)# interface fastethernet1/1

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始して設定します。

ステップ 12

ip address ip-address mask

 

Router(config-if)# ip address 172.16.1.2 255.255.255.0

インターフェイスの IP アドレスを設定します。

ステップ 13

mpls ip

 

Router(config-if)# mpls ip

特定のインターフェイス用に通常ルーティングされるパスに沿って IPv4 パケットの MPLS 転送が行われるようにします。

ステップ 14

ip flow ingress

 

Router(config-if)# ip flow ingress

インターフェイスで NetFlow をイネーブルにし、received by the インターフェイスで受信されるトラフィックをキャプチャします。

ステップ 15

interface type number

 

Router(config)# interface GigabitEthernet5/2

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始して設定します。

ステップ 16

ip vrf forwarding vrf-id

 

Router(config-if)# ip vrf forwarding red

VPN VRF をインターフェイスまたはサブインターフェイスに関連付けます。

ステップ 17

ip address ip-address mask

 

Router(config-if)# ip address 10.1.0.1 255.255.255.0

インターフェイス上で IP アドレスを設定します。

ステップ 18

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 19

mls nde sender

 

Router(config)# mls nde sender

PFC で NetFlow をイネーブルにします。

ステップ 20

mls flow ip { interface-destination-source | interface-full }

 

Router(config)# mls flow ip interface-destination-source

IP トラフィックに NetFlow フロー マスクを指定します。

ステップ 21

ip flow-export version 9

 

Router(config)# ip flow-export version 9

バージョン 9 エクスポート フォーマットを使用する NetFlow データ エクスポートの設定

ステップ 22

ip flow-export destination { ip-address | hostname } udp-port

 

Router(config)# ip flow-export destination 172.16.2.6 99

NetFlow 情報を送信するワークステーションの IP アドレスまたはホスト名、およびワークステーションがこの入力を待ち受けている UDP ポートの番号。

ステップ 23

flow hardware mpls-vpn ip vrf-id

 

Router(config)# flow hardware mpls-vpn ip red

VRF の VRF インターフェイス用 NDE 機能をイネーブルにします。

次に示す show mls nde コマンドの出力は、NDE 設定および統計情報を示します。

PE1# show mls nde
Netflow Data Export enabled
Exporting flows to 172.16.2.6 (99)
Exporting flows from 172.16.1.2 (51203)
Version: 9
Layer2 flow creation is disabled
Layer2 flow export is disabled
Include Filter not configured
Exclude Filter not configured
Total Netflow Data Export Packets are:
4 packets, 0 no packets, 19 records
Total Netflow Data Export Send Errors:
IPWRITE_NO_FIB = 0
IPWRITE_ADJ_FAILED = 0
IPWRITE_PROCESS = 0
IPWRITE_ENQUEUE_FAILED = 0
IPWRITE_IPC_FAILED = 0
IPWRITE_OUTPUT_FAILED = 0
IPWRITE_MTU_FAILED = 0
IPWRITE_ENCAPFIX_FAILED = 0
Netflow Aggregation Disabled
 
PE1#
 

次に示す show mls NetFlow ip module コマンドの出力は、PFC の NetFlow エントリを示します。出力の 1 行目は VPN Red のトラフィックを示します。


) Module 5 は、この Cisco 7600 シリーズ ルータのアクティブ スーパーバイザ 720 です。


Router# show mls netflow ip module 5
 
Displaying Netflow entries in module 5
DstIP SrcIP Prot:SrcPort:DstPort Src i/f :AdjPtr
-----------------------------------------------------------------------------
Pkts Bytes Age LastSeen Attributes
---------------------------------------------------
10.1.1.1 10.2.0.2 0 :0 :0 vpn:red :0x0
504 398020 1 23:20:48 L3 - Dynamic
224.0.0.5 172.16.1.1 89 :0 :0 Fa1/1 :0x0
1 84 7 23:20:42 L2 - Dynamic
0.0.0.0 0.0.0.0 0 :0 :0 -- :0x0
2238 1582910 33 23:20:48 L3 - Dynamic
224.0.0.2 172.16.1.1 udp :646 :646 Fa1/1 :0x0
5 310 21 23:20:46 L2 - Dynamic
172.16.2.6 172.16.1.2 0 :0 :0 Fa1/1 :0x0
1 140 22 23:20:27 L2 - Dynamic
 
Router#
 

次に示す show ip cache flow コマンドの出力は、NetFlow キャッシュのデータを示します。出力の最後の行のデータは、このトラフィックの送信元インターフェイスが VPN Red であることを示します。

PE1# show ip cache flow
 
-------------------------------------------------------------------------------
MSFC:
IP packet size distribution (3139 total packets):
1-32 64 96 128 160 192 224 256 288 320 352 384 416 448 480
.000 .685 .309 .000 .000 .000 .000 .003 .000 .000 .000 .000 .000 .000 .000
 
512 544 576 1024 1536 2048 2560 3072 3584 4096 4608
.000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
 
IP Flow Switching Cache, 278544 bytes
2 active, 4094 inactive, 56 added
20904 ager polls, 0 flow alloc failures
Active flows timeout in 30 minutes
Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33992 bytes
0 active, 1024 inactive, 4 added, 4 added to flow
0 alloc failures, 0 force free
1 chunk, 2 chunks added
last clearing of statistics never
Protocol Total Flows Packets Bytes Packets Active(Sec) Idle(Sec)
-------- Flows /Sec /Flow /Pkt /Sec /Flow /Flow
TCP-BGP 10 0.0 1 49 0.0 0.0 15.3
TCP-other 6 0.0 2 49 0.0 4.5 15.5
UDP-other 28 0.0 74 63 0.1 320.5 12.7
IP-other 6 0.0 153 80 0.0 1488.3 1.7
Total: 50 0.0 60 68 0.2 358.6 12.2
 
SrcIf SrcIPaddress DstIf DstIPaddress Pr SrcP DstP Pkts
Fa1/1 172.16.1.1 Null 224.0.0.2 11 0286 0286 74
Fa1/1 172.16.1.1 Null 224.0.0.5 59 0000 0000 33
 
-------------------------------------------------------------------------------
PFC:
 
Displaying Hardware entries in Module 5
SrcIf SrcIPaddress DstIPaddress Pr SrcP Dss
Fa1/1 172.20.1.2 172.20.1.3 0 0 0
Fa1/1 172.20.1.3 172.20.1.2 0 0 0
Fa1/1 172.16.1.2 172.16.2.6 0 0 0
Fa1/1 172.16.1.1 224.0.0.2 udp 646 64
-- 0.0.0.0 0.0.0.0 0 0 0
vpn:red 10.2.0.2 10.1.1.1 0 0 0
.
.
.
PE1#

VRF インターフェイス用 NDEの設定例

次の設定例は、VRF インターフェイス用 NDE 機能を設定した 2 台の PE ルータを使用して単純なネットワーク トポロジを設定する方法を示します。

ここでは、次の設定例について説明します。

「MPLS VPN が 1 つ存在するサンプル ネットワークの設定:例」

「VRF での VRF インターフェイス用 NDE 機能の設定:例」

MPLS VPN が 1 つ存在するサンプル ネットワークの設定:例

ここでは、図 3 のすべてのデバイスを設定します。ルータ PE1 と PE2 には、VRF インターフェイス用 NDE 機能が設定されています。

CE1

!
hostname CE1
!
ip cef
!
interface Loopback0
no shutdown
ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no shutdown
ip address 10.1.0.2 255.255.255.0
!
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.1.0.1
!
end
 

PE1

!
hostname PE1
!
ip cef distributed
!
mls nde sender
mls flow ip interface-destination-source
ip flow-export destination 172.16.2.6 99
ip flow-export version 9
!
ip vrf red
rd 200:2
route-target export 200:20
route-target import 200:20
!
flow hardware mpls-vpn ip red
!
multilink bundle-name authenticated
mpls label protocol ldp
!
interface Loopback0
ip address 172.20.1.2 255.255.255.255
!
interface gigabitEthernet5/2
no shutdown
ip vrf forwarding red
ip address 10.1.0.1 255.255.255.0
!
interface FastEthernet1/1
no shutdown
interface FastEthernet1/1
ip address 172.16.1.2 255.255.255.0
ip flow ingress
mpls ip
!
router ospf 100
router-id 172.20.1.2
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
network 172.20.1.2 0.0.0.0 area 0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 172.0.0.0 mask 255.0.0.0
neighbor as200 peer-group
neighbor as200 remote-as 200
neighbor as200 description as200
neighbor as200 update-source Loopback0
neighbor as200 route-reflector-client
neighbor 172.20.1.4 remote-as 200
neighbor 172.20.1.4 description iBGP with r4
neighbor 172.20.1.4 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 172.20.1.4 activate
neighbor 172.20.1.4 send-community both
exit-address-family
!
address-family ipv4 vrf red
no synchronization
network 10.1.0.0 mask 255.255.255.0
network 10.1.1.1 mask 255.255.255.255
exit-address-family
!
ip route 172.0.0.0 255.0.0.0 Null0
ip route vrf red 10.1.1.1 255.255.255.255 10.1.0.2
!
mpls ldp router-id Loopback0
!
end

P1

!
hostname P1
!
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
no shutdown
ip address 172.20.1.3 255.255.255.255
!
interface FastEthernet0/0
no shutdown
ip address 172.16.2.1 255.255.255.0
mpls ip
!
interface FastEthernet0/1
no shutdown
ip address 172.16.1.1 255.255.255.0
mpls ip
!
router ospf 100
router-id 172.20.1.3
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
network 172.20.1.3 0.0.0.0 area 0
!
mpls ldp router-id Loopback0
!
end

PE2

!
hostname PE2
!
ip cef distributed
!
mls nde sender
mls flow ip interface-destination-source
ip flow-export destination 172.16.2.6 99
ip flow-export version 9
!
ip vrf red
rd 200:2
route-target export 200:20
route-target import 200:20
!
flow hardware mpls-vpn ip red
!
multilink bundle-name authenticated
mpls label protocol ldp
!
interface Loopback0
no shutdown
ip address 172.20.1.4 255.255.255.255
!
interface FastEthernet0/0
no shutdown
ip address 172.16.2.2 255.255.255.0
mpls ip
ip flow ingress
!
interface FastEthernet0/1
no shutdown
ip vrf forwarding red
ip address 10.2.0.1 255.255.255.0
!
router ospf 100
router-id 172.20.1.4
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
network 172.20.1.4 0.0.0.0 area 0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 172.0.0.0 mask 255.0.0.0
neighbor as200 peer-group
neighbor as200 remote-as 200
neighbor as200 description as200
neighbor as200 update-source Loopback0
neighbor as200 route-reflector-client
neighbor 172.20.1.2 remote-as 200
neighbor 172.20.1.2 description iBGP with r2
neighbor 172.20.1.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 172.20.1.2 activate
neighbor 172.20.1.2 send-community both
exit-address-family
!
address-family ipv4 vrf red
no synchronization
network 10.2.0.0 mask 255.255.255.0
network 10.2.2.2 mask 255.255.255.255
exit-address-family
!
ip route 172.0.0.0 255.0.0.0 Null0
ip route vrf red 10.2.2.2 255.255.255.255 10.2.0.2
!
mpls ldp router-id Loopback0
!
end

CE2

!
hostname CE2
!
ip cef
!
interface Loopback0
no shutdown
ip address 10.2.2.2 255.255.255.255
!
interface FastEthernet0/1
no shutdown
ip address 10.2.0.2 255.255.255.0
!
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.2.0.1
!
end

VRF での VRF インターフェイス用 NDE 機能の設定:例

この例では、VRF の VRF インターフェイス用 NDE 機能を設定する方法を示します。 ip flow ingress コマンドを使用して GigabitEthernet2/3 インターフェイスで NetFlow をイネーブルにすると、NetFlow キャッシュには、VPN vpn1 のトラフィックに関する情報が書き込まれます。

PE1

!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
!
mls flow ip interface-full
!
interface GigabitEthernet2/3
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
ip flow ingress
!
interface GigabitEthernet2/7
ip vrf forwarding vpn1
ip address 172.16.20.1 255.255.255.0
!
ip flow-export version 9
ip flow-export destination 192.168.10.2 20000
end
 

関連情報

Cisco 7600 シリーズ ルータの NetFlow 機能を設定する方法の詳細については、『 Cisco 7600 Series Cisco IOS Software Configuration Guide 』の「 Configuring NetFlow and NDE 」の章を参照してください。

Cisco 7600 シリーズ ルータの MPLS 機能を設定する方法の詳細については、『 Cisco 7600 Series Cisco IOS Software Configuration Guide 』の「 Configuring PFC3BXL and PFC3B Mode Multiprotocol Label Switching (MPLS) 」の章を参照してください。

その他の参考資料

ここでは、VRF インターフェイス用 NDE機能に関する関連資料について説明します。

関連資料

関連項目
参照先

NetFlow コマンド、コマンド構文の詳細、コマンド モード、デフォルト、コマンド履歴、使用上の注意事項、および例

『Cisco IOS NetFlow Command Reference』

Cisco 7600 シリーズ ルータでの NetFlow、MPLS、およびその他の機能の設定に関する情報

『Cisco 7600 Series Cisco IOS Software Configuration Guide』

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能がサポートする新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。サービス契約が有効で、ログイン ID またはパスワードを取得していない場合は、Cisco.com でまず登録手続きを行ってください。

http://www.cisco.com/en/US/support/index.html

VRF インターフェイス用 NDEの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 1 VRF インターフェイス用 NDEの機能情報

機能名
リリース
機能情報

VRF インターフェイス用 NDE

12.2(33)SRB
15.0(1)S

VRF インターフェイスをサポートする NDE の機能により、VRF インターフェイスからの NetFlow フロー情報をキャプチャしてエクスポートすることができます。

12.2(33)SRB では、この機能が Cisco 7600 シリーズ ルータに追加されました。

この機能に関する詳細については、次の各項を参照してください。

「VRF インターフェイス用 NDEについて」

「MPLS VPN の VRF インターフェイス用 NDE の設定方法」

この機能により、 flow hardware mpls-vpn ip show ip cache flow show ip cache flow aggregation show mls netflow ip コマンドが導入または変更されました。