インターフェイスおよびハードウェア コンポー ネント コンフィギュレーション ガイド Cisco IOS Release 15.1S
Cisco AS5850 のルート スイッチ コント ローラ(RSC)ハンドオーバー冗長
Cisco AS5850 のルート スイッチ コントローラ(RSC)ハンドオーバー冗長
発行日;2012/01/31 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

Cisco AS5850 のルート スイッチ コントローラ(RSC)ハンドオーバー冗長

機能の概要

利点

制約事項

関連機能およびテクノロジー

関連資料

サポートされているプラットフォーム

サポートされている規格、MIB、および RFC

前提条件

設定作業

クラシック スプリット モードの設定

クラシック スプリット モードの確認

ハンドオーバー スプリット モードの設定

ハンドオーバー スプリット モードの確認

トラブルシューティングのヒント

ハンドオーバー 冗長のモニタリングとメンテナンス

設定例

コマンド リファレンス

用語集

Cisco AS5850 のルート スイッチ コントローラ(RSC)ハンドオーバー冗長

機能の履歴

リリース
変更点

12.2(2)XB1

この機能は、Cisco AS5850 に導入されました。

12.2(11)T

この機能は、Cisco IOS リリース 12.2(11)T に統合され、Cisco AS5850 プラットフォームのサポートが追加されました。

このマニュアルでは、Cisco AS5850 の Route-Switch-Controller(RSC; ルート スイッチ コントローラ)ハンドオーバー冗長機能について説明します。次の項で構成されています。

「機能の概要」

「サポートされているプラットフォーム」

「サポートされている規格、MIB、および RFC」

「前提条件」

「設定作業」

「ハンドオーバー 冗長のモニタリングとメンテナンス」

「設定例」

「コマンド リファレンス」

「用語集」

機能の概要

Cisco AS5850 のルート スイッチ コントローラ ハンドオーバー冗長機能は、ハンドオーバー スプリット モードの提供によって、Cisco AS5850 プラットフォームでハイ アベイラビリティの第一フェーズを実現しています。

ゲートウェイに 2 つの Route-Switch-Controller(RSC; ルート スイッチ コントローラ)カードがある場合、Cisco AS5850 をそれぞれクラシック スプリットとハンドオーバー スプリットの 2 種類のスプリット モードに設定できます。

クラシック スプリット モード

クラシック スプリット(デフォルト)モードは、2 つの RSC の間でスロットをスプリットすることによって、システム スループットを最大化します。RSC は、スロット(スロット 0 ~ 5 はスロット 6 の RSC が所有し、スロット 8 ~ 13 はスロット 7 の SRC に所有されます)のセットを制御し、別の RSC によってカードが制御されているため、制御するカードを含まないスロット以外のスロットのように動作します。各 RSC の設定は、該当する RSC が所有するスロットにだけ影響を与えます。停止した RSC のコールは失われますが、機能している RSC のコールは正常に継続します。クラシック スプリット モードで Cisco AS5850 を機能させることは、別のカードセットを所有する 2 つの Cisco AS5850 を持つことと同じです。

ハンドオーバー スプリット モード

ハンドオーバー スプリット モードは、RSC が自動的にスロット、カード、および他の RSC が停止している場合の他の RSC のコールの制御を獲得できるようにすることで、システムの可能性を最大化します。フルセットのカードに適切であるため、各 RSC は、まったく同一に設定されています。通常動作の間、RSC はアクティブであり、クラシック スプリット モードと同様に、所有するスロット、カード、およびコールを処理します。RSC が停止した場合、停止した RSC のコールは、停止の瞬間には失われますが、他の RSC は停止した RSC のスロットの制御を引き継ぎ、エクストラロード状態になり、停止した RSC カードをリスタートし、それらのカードに新たに到着したコールを処理します。停止した RSC が回復するかリスタートされた場合、ユーザがアクティブ RSC に新しく獲得したスロットを戻すように指示するまで、スタンバイ状態のままです。実質的に、これはハンドオーバー機能によるスプリット ダイヤル シェルフです。

システム リソースを最も効率的に使用するため、2 つの RSC のうちの 1 つをまず動作させ、意図的にエクストラロード状態にできます。この設定では、RSCA は当初シャーシ内のすべてのスロットを制御し、RSCB はスタンバイモードであり、RSCA が停止したときには引き継ぐ準備ができています。これによって、RSC ごとに 6 スロットしか利用できないため、トランクと DSP カードの最適な組み合わせの実現が難しいという、通常のクラシック スプリット モードの制限事項を解消できます。パフォーマンス ロードの詳細については、「制約事項」の項を参照してください。

利点

ハイ アベイラビリティ

ハンドオーバー スプリット モードでイネーブルである Cisco AS5850 の RSC ハンドオーバー冗長はシングル ポイント障害、その後のダウンタイム、および回復不能のハードウェア障害解決のために必要なユーザ介入を回避できます。これによって、サービス アベイラビリティが向上し、サービス低下時間およびサービス中断が低減します。

制約事項

RSC カード要件

Cisco AS5850 システム シャーシに 2 つの RSC カードを設置する必要があります。

パフォーマンス ロード、可能なトランク カードおよびポート密度の制限事項

システムがサポートできる CT3、T1、または E1 トランク カードの数は、動作するように設定されているスプリット モードよって異なります。クラシック スプリット モードでは、RSC カードは所有するトランク カードの半分だけを処理する必要があります。ハンドオーバー スプリット モードでは、RSC カードはシャーシ全体のトランク カードのフル ロードを処理できる必要があります。どちらの場合でも、許容されるトランク カードの数は処理する RSC カードのパフォーマンス ロードを超えてはなりません。

パフォーマンス ロードの詳細については、『 Cisco AS5850 Universal Gateway Operations, Administration, Maintenance, and Provisioning Guide 』 の「Overview」の章の「 Cisco AS5850 universal port capacities 」の表を参照してください。

スループットと可用性

最大スループットと最大可用性の間で選択する必要があります。

クラシック スプリット モードを設定することによってハンドオーバー冗長をディセーブルにすると、可用性を犠牲にして最大スループットが得られます。

ハンドオーバー スプリット モードを設定することによってハンドオーバー冗長をイネーブルにすると、スループットを犠牲にして最大可用性を得られます。

ドロップされるコール

停止した RSC のコールは、モードにかかわらず、停止の瞬間に失われます。

固定されたスロット割り当て

スロット割り当ては固定であり、ハンドオーバー中のハンドオーバー スプリット モードでシステムによる場合を除き変更できません。スロット 0 ~ 5 はスロット 6 の RSC が所有し、スロット 8 ~ 13 はスロット 7 の RSC が所有します。

関連機能およびテクノロジー

ルータ シェルフ冗長

Cisco AS5800 で利用できるルータ シェルフ冗長機能は、Cisco AS5850 の RSC ハンドオーバー冗長と同様です。

関連資料

Cisco AS5850 Product Documentation Web サイトから入手可能な、プロビジョニングに関する「 Cisco AS5850 Operations, Administration, Maintenance, and Provisioning Guide 」の章

サポートされているプラットフォーム

Cisco AS5850 ユニバーサル ゲートウェイ

 

表 1 この機能をサポートする Cisco IOS リリースおよびプラットフォーム

プラットフォーム
12.2(2)XB1
12.2(11)T

Cisco AS5850

X

X

Cisco Feature Navigator を使用したプラットフォーム サポートの特定

Cisco IOS ソフトウェアは、特定のプラットフォームがサポートされている機能セットにパッケージングされています。この機能のプラットフォーム サポートに関連した更新情報を取得するには、Cisco Feature Navigator にアクセスします。新しいプラットフォーム サポートが機能に追加されると、Cisco Feature Navigator によって、サポートされているプラットフォームのリストが自動的に更新されます。

Cisco Feature Navigator は Web ベースのツールであり、特定の機能セットがサポートされている Cisco IOS ソフトウェア イメージ、および特定の Cisco IOS イメージ内でサポートされている機能を特定できます。機能またはリリースごとに検索できます。リリース セクションでは、各リリースを横に並べて比較し、各ソフトウェア リリースに固有の機能と共通機能の両方を表示できます。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator により、どの Cisco IOS および Catalyst OS ソフトウェア イメージが特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/fn からアクセスします。Cisco.com のアカウントは必要ありません。

Cisco IOS ソフトウェア イメージの可用性

特定の Cisco IOS ソフトウェア リリースをサポートしているプラットフォームは、そのプラットフォーム用のソフトウェア イメージがあるかどうかに依存します。一部のプラットフォームのソフトウェア イメージは、事前の通知なしに延期、遅延、または変更される場合があります。各 Cisco IOS ソフトウェア リリースのプラットフォーム サポートおよび利用可能なソフトウェア イメージの更新情報は、オンライン リリース ノートまたは Cisco Feature Navigator(サポートされている場合)を参照してください。

サポートされている規格、MIB、および RFC

規格

なし

MIB

CISCO-RF-MIB

プラットフォームおよび Cisco IOS ソフトウェア リリースによりサポートされている MIB のリストを入手し、MIB モジュールをダウンロードするには、Cisco.com の次のシスコ MIB Web サイトの URL にアクセスしてください。
http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

なし

前提条件

RSC カード

Cisco AS5850 に 2 つの RSC カードが設置され、そのうちの 1 つがスロット 6 に、もう 1 つがスロット 7 に設置されていることを確認してください。

トランク カード

Cisco AS5850 に CT3、T1、または E1 トランク カードがある場合、サポート可能な数であることを確認します。パフォーマンス ロードの詳細については、「制約事項」を参照してください。

Cisco IOS イメージ

クラシック スプリット モードの場合、各 RSC に同じ Cisco IOS イメージを設定することが、必須ではありませんが推奨されます。

ハンドオーバー スプリット モードの場合、各 RSC に同じ Cisco IOS イメージを設定し、出力インターフェイスの IP アドレスを除いて同じ設定にすることが必要です。Cisco IOS イメージは、冗長性をサポートする必要があります(Cisco IOS Release 12.2(2)XB、または Cisco IOS Release 12.2(11)T以降のリリース)。

ハンドオーバー後に正しく動作することを確実にするため、システムのすべてのライン カードのスタートアップ設定を両方の RSC の保存設定に複製する必要があります。

Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)または Telnet 接続を使用して、ソフトウェア設定を Cisco AS5850 にダウンロードする必要があります。Cisco IOS イメージをアップグレードする方法を学習するには、Cisco.com Web サイトの Cisco AS5850 Product Documentation にアクセスして、『 Cisco AS5850 Universal Gateway Operations, Administration, Maintenance, and Provisioning Guide 』を検索し、プロビジョニングに関する章を参照してください。

設定作業

この機能の設定作業については、次の項を参照してください。一覧内の各作業は、必須と任意に分けられています。クラシック スプリット モード(デフォルト)、または、ハンドオーバー スプリット モードを設定して確認する必要があることに注意してください。

「クラシック スプリット モードの設定」 (任意)

「クラシック スプリット モードの確認」 (任意)

または

「ハンドオーバー スプリット モードの設定」 (必須)

「ハンドオーバー スプリット モードの確認」 (必須)

クラシック スプリット モードの設定

 

コマンド
目的

ステップ 1

Router# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# redundancy

コンフィギュレーション冗長モードを開始します。

ステップ 3

Router(config-red)# mode classic-split

クラシック スプリット モード(デフォルト モード)を選択します。

ステップ 4

Router# copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

ステップ 5

Router# reload

RSC をリロードします。

各 RSC に順に接続して、これらのコードを入力します。


) クラシック スプリット モードはデフォルト モードです。これらの手順を実行しない場合は、このモードにデフォルト設定されます。



) これらの手順は、単にシステムをクラシック スプリット モードに設定します。手動で各カードを設定する必要があります。


クラシック スプリット システムは、SNMP 管理アプリケーションに 2 つの別の Cisco AS5850 のように表示されます。スピリットを設定するために、各 RSC のコンソール セッション(2 つのコンソール セッション)を処理する必要があります。システム コントローラは、2 つの別の Cisco AS5850 ユニバーサル ゲートウェイのようにクラシック スプリット設定を管理します。

Cisco Universal Gateway Manager(Cisco UGM)のような Network Management System(NMS; ネットワーク管理システム)が利用できます。NMS は、パフォーマンス、およびログ アカウンティング データをモニタリングするのと同様に、複数の Points of Presence(POP; アクセスポイント)のシングル システム ビューを提供します。NMS は Graphical User Interface(GUI; グラフィカル ユーザ インターフェイス)を備え、UNIX SPARC ステーションで実行され、データベース管理システム、ポーリング エンジン、トラップ管理、マップ統合などを含んでいます。また、ユーザがコンソール ポートまたは Web インターフェイスを通じて複数のシステムにアクセスできるように、NMS はリモートの設備にインストールできます。

クラシック スプリット モードでは、各 RSC および各スロットのセットで一意の ID を使用することが望ましいと言えます(NMS の場合は必須です)。しかし、場合によっては、2 つの RSC に同一の ID を使用することで十分な場合もあります。

クラシック スプリット モードの確認

クラシック スプリット モードでは、多くの show コマンド(次に示す例外を除いて)は RSC が所有するスロットの情報だけを表示します。これらのコマンドは、RSC が所有していないスロットにはカードがないかのように動作します。スロットに対する show コマンドの情報を参照するには、スロットを所有する RSC に接続する必要があります。

次のコマンドを任意の順序で入力します。

所有権にかかわらず、すべてのスロットに関する情報を表示するには、EXEC モードで show context all コマンドを入力します。

所有するスロットに関する情報を表示するには、EXEC モードで show context コマンドを all オプションなしで入力します。

RSC がクラシック スプリット モードで動作しているかどうか、動作している場合どのスロットを所有しているかなど、その他の関連する出力を表示するには、EXEC モードで show chassis コマンドを入力します。

RouterA# show chassis
System is in classic-split mode, RSC in slot 6.
Slots owned: 0 1 2 3 4 5
Slots configured: 0 1 2 3 4 5
Slots owned by other: 8 9 10 11 12 13
Slot Board CPU DRAM I/O Memory State Elapsed
Type Util Total (free) Total (free) Time
1 UP324 0%/0% 60159040( 51%) 67108864( 73%) Up 6d01h
2 UP324 0%/0% 60159040( 56%) 67108864( 73%) Up 6d01h
3 UP324 0%/0% 60159040( 56%) 67108864( 73%) Up 6d01h
4 CT3_UP216 0%/0% 60159040( 50%) 67108864( 72%) Up 6d01h
System set for auto boot
 
 
RouterB# show chassis
System is in classic-split mode, RSC in slot 7.
Slots owned: 8 9 10 11 12 13
Slots configured: 8 9 10 11 12 13
Slots owned by other: 0 1 2 3 4 5
Slot Board CPU DRAM I/O Memory State Elapsed
Type Util Total (free) Total (free) Time
9 CT3_UP216 0%/0% 60159040( 65%) 67108864( 72%) Up 00:21:46
10 UP324 0%/0% 60159040( 62%) 67108864( 73%) Up 00:21:48
11 UP324 0%/0% 60159040( 62%) 67108864( 73%) Up 00:21:49
System set for auto boot
 

非所有のカードからのものであっても、すべての設定されたクロック ソースを表示するには、EXEC モードで show chassis clocks コマンドを入力します。1 つの RSC だけがマスター クロックを提供でき、所有権と関係なく存在するすべてのカードからバックアップ クロック ソースが設定される必要がある場合があります。

RouterA# show chassis clocks
Primary Clock:
--------------
Slot 6:
System primary is Slot: 4 Port: 1 of priority 10
TDM Bus Master Clock Generator State = NORMAL
 
Backup clocks:
Source Slot Port DS3-Port Priority Status State
-------------------------------------------------------------
Trunk 9 1 0 8 Good Configured
Trunk 4 21 0 498 Good Default
Trunk 9 21 0 503 Good Default
 
 
Status of trunk clocks:
-----------------------
Ds3 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1
Slot Port Type 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1
4 0 T3 B B B B B B B G G G G G G G G G G G G G G G G G G G G G
9 0 T3 B B B B B B B G G G G G G G G G G G G G G G G G G G G G

ハンドオーバー スプリット モードの設定

両方の RSC のすべてのカードが設定されるように、両方の RSC で次の手順を実行します。

 

コマンド
目的

ステップ 1

Router# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 3

Router(config-red)# mode handover-split

ハンドオーバー スプリットモードを選択します。

各 RSC に順番に接続し、その RSC に接続するすべてのカードが設定されるように実行コンフィギュレーションを変更し、次の手順を実行します。

 

コマンド
目的

ステップ 1

Router# copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

ステップ 2

Router# dir [ /all ][ filesystem: ][ file-url ]

ファイル システムのファイル リストを表示します。新しいイメージがシステム フラッシュ メモリまたは File Transfer Protocol(FTP; ファイル転送プロトコル)サーバにロードされていることを確認するために使用します。

ステップ 3

Router# reload

RSC をリロードします。

実行後の最終的な結果として、各 RSC のすべてのカードが設定されます。


) これらの手順は、単にシステムをハンドオーバー スプリット モードに設定します。手動で両方の RSC の各カードを設定する必要があります。



) デフォルトでは、1 つの RSC は最大 2 つの CT3 カードを処理できます。no dial-config-guidelines コマンドを使用して、この制約事項をリリースできます。パフォーマンス ロードの詳細については、「制約事項」を参照してください。


ハンドオーバー スプリット モードの確認

次のコマンドを任意の順序で入力します。

ハンドオーバーがイネーブルであるかどうか、およびその RSC がアクティブであるかスタンバイであるかを表示するには、EXEC モードで show redundancy states コマンドを入力します。

RouterA# show redundancy states
my state = 13 -ACTIVE
peer state = 13 -ACTIVE
Mode = Duplex
Unit = Preferred Primary
Unit ID = 6
 
Redundancy Mode = Handover-split: If one RSC fails, the peer RSC will take over the feature boards
Maintenance Mode = Disabled
Manual Swact = Enabled
Communications = Up
 
client count = 3
client_notification_TMR = 30000 milliseconds
keep_alive TMR = 4000 milliseconds
keep_alive count = 0
keep_alive threshold = 7
RF debug mask = 0x0
 

記録されたハンドオーバー イベントを表示するには、EXEC モードで show redundancy history コマンドを入力します。

RouterA# show redundancy history
Redundancy Facility Event Log:
00:00:00 client added: RF_INTERNAL_MSG(0) seq=0
00:00:00 client added: RF_LAST_CLIENT(65000) seq=65000
00:00:09 client added: Rsc split dshelf client(19) seq=800
00:00:09 *my state = INITIALIZATION(2) *peer state = DISABLED(1)
00:00:09 RF_PROG_INITIALIZATION(100) RF_INTERNAL_MSG(0) op=0 rc=11
00:00:09 RF_PROG_INITIALIZATION(100) Rsc split dshelf client(19) op=0 rc=11
00:00:09 RF_PROG_INITIALIZATION(100) RF_LAST_CLIENT(65000) op=0 rc=11
00:00:09 *my state = NEGOTIATION(3) peer state = DISABLED(1)
00:00:11 RF_STATUS_PEER_PRESENCE(400) op=1
00:00:11 RF_STATUS_PEER_PRESENCE(400) Rsc split dshelf client(19) op=1
00:00:11 RF_STATUS_PEER_COMM(401) op=1
00:00:11 RF_STATUS_PEER_COMM(401) Rsc split dshelf client(19) op=1
00:00:11 my state = NEGOTIATION(3) *peer state = UNKNOWN(0)
00:00:15 RF_EVENT_CLIENT_PROGRESSION(503) RF_LAST_CLIENT(65000) op=1
00:00:15 RF_PROG_PLATFORM_SYNC(300) RF_LAST_CLIENT(65000) op=1 rc=0
00:00:15 RF_EVENT_CLIENT_PROGRESSION(503) RF_LAST_CLIENT(65000) op=1 rc=0
00:00:17 RF_STATUS_REDUNDANCY_MODE_CHANGE(405) Rsc split dshelf client(19) op=3
00:00:17 RF_EVENT_GO_STANDBY(512) op=0
00:00:17 *my state = STANDBY COLD(4) peer state = UNKNOWN(0)
00:00:17 RF_PROG_STANDBY_COLD(101) RF_INTERNAL_MSG(0) op=0 rc=11
00:00:17 RF_PROG_STANDBY_COLD(101) Rsc split dshelf client(19) op=0 rc=11
00:00:17 RF_PROG_STANDBY_COLD(101) RF_LAST_CLIENT(65000) op=0 rc=11
00:00:19 my state = STANDBY COLD(4) *peer state = ACTIVE_EXTRALOAD(14)
00:00:51 Configuration parsing complete
00:00:53 System initialization complete
00:01:11 RF_STATUS_PEER_PRESENCE(400) op=0
00:01:11 RF_STATUS_PEER_PRESENCE(400) Rsc split dshelf client(19) op=0
00:01:11 my state = STANDBY COLD(4) *peer state = DISABLED(1)
00:01:11 Reloading peer (peer presence lost)
00:01:11 *my state = ACTIVE-FAST(9) peer state = DISABLED(1)
00:01:11 RF_STATUS_MAINTENANCE_ENABLE(403) Rsc split dshelf client(19) op=0
00:01:11 RF_PROG_ACTIVE_FAST(200) RF_INTERNAL_MSG(0) op=0 rc=11
00:01:11 RF_PROG_ACTIVE_FAST(200) Rsc split dshelf client(19) op=0 rc=11
00:01:11 RF_PROG_ACTIVE_FAST(200) RF_LAST_CLIENT(65000) op=0 rc=11
00:01:11 *my state = ACTIVE-DRAIN(10) peer state = DISABLED(1)
00:01:11 RF_PROG_ACTIVE_DRAIN(201) RF_INTERNAL_MSG(0) op=0 rc=11
00:01:11 RF_PROG_ACTIVE_DRAIN(201) Rsc split dshelf client(19) op=0 rc=11
00:01:11 RF_PROG_ACTIVE_DRAIN(201) RF_LAST_CLIENT(65000) op=0 rc=11
00:01:11 *my state = ACTIVE_PRECONFIG(11) peer state = DISABLED(1)
00:01:11 RF_PROG_ACTIVE_PRECONFIG(202) RF_INTERNAL_MSG(0) op=0 rc=11
00:01:11 RF_PROG_ACTIVE_PRECONFIG(202) Rsc split dshelf client(19) op=0 rc=11
00:01:11 RF_PROG_ACTIVE_PRECONFIG(202) RF_LAST_CLIENT(65000) op=0 rc=11
00:01:11 *my state = ACTIVE_POSTCONFIG(12) peer state = DISABLED(1)
00:01:11 RF_PROG_ACTIVE_POSTCONFIG(203) RF_INTERNAL_MSG(0) op=0 rc=11
00:01:11 RF_PROG_ACTIVE_POSTCONFIG(203) Rsc split dshelf client(19) op=0 rc=11
00:01:11 RF_PROG_ACTIVE_POSTCONFIG(203) RF_LAST_CLIENT(65000) op=0 rc=11
00:01:11 *my state = ACTIVE(13) peer state = DISABLED(1)
00:01:11 RF_PROG_ACTIVE(204) RF_INTERNAL_MSG(0) op=0 rc=11
00:01:11 RF_PROG_ACTIVE(204) Rsc split dshelf client(19) op=0 rc=11
00:01:11 RF_PROG_ACTIVE(204) RF_LAST_CLIENT(65000) op=0 rc=11
00:01:11 RF_STATUS_PEER_COMM(401) op=0
00:01:11 RF_STATUS_PEER_COMM(401) Rsc split dshelf client(19) op=0
00:01:11 Reloading peer (communication down)
00:01:11 RF_EVENT_GO_ACTIVE_EXTRALOAD(513) RF_INTERNAL_MSG(0) op=0
00:01:11 RF_PROG_EXTRALOAD(301) RF_INTERNAL_MSG(0) op=0 rc=11
00:01:11 RF_PROG_EXTRALOAD(301) Rsc split dshelf client(19) op=0 rc=11
00:01:11 RF_PROG_EXTRALOAD(301) RF_LAST_CLIENT(65000) op=0 rc=11
00:01:11 RF_EVENT_GO_ACTIVE_EXTRALOAD(513) RF_INTERNAL_MSG(0) op=0
00:03:02 RF_STATUS_PEER_PRESENCE(400) op=1
00:03:02 RF_STATUS_PEER_PRESENCE(400) Rsc split dshelf client(19) op=1
00:03:02 RF_STATUS_PEER_COMM(401) op=1
00:03:02 RF_STATUS_PEER_COMM(401) Rsc split dshelf client(19) op=1
00:03:02 *my state = ACTIVE_EXTRALOAD(14) *peer state = UNKNOWN(0)
00:03:02 RF_PROG_PLATFORM_SYNC(300) RF_INTERNAL_MSG(0) op=0 rc=11
00:03:02 RF_PROG_PLATFORM_SYNC(300) Rsc split dshelf client(19) op=0 rc=11
00:03:02 RF_PROG_PLATFORM_SYNC(300) RF_LAST_CLIENT(65000) op=0 rc=0
00:03:02 RF_EVENT_CLIENT_PROGRESSION(503) RF_LAST_CLIENT(65000) op=1 rc=0
00:03:02 my state = ACTIVE_EXTRALOAD(14) *peer state = NEGOTIATION(3)
00:03:02 RF_EVENT_PEER_PROG_DONE(506) RF_LAST_CLIENT(65000) op=300
00:03:06 my state = ACTIVE_EXTRALOAD(14) *peer state = STANDBY COLD(4)
6d01h RF_EVENT_GO_ACTIVE_HANDBACK(514) RF_INTERNAL_MSG(0) op=0
6d01h RF_PROG_HANDBACK(302) RF_INTERNAL_MSG(0) op=0 rc=11
6d01h RF_PROG_HANDBACK(302) Rsc split dshelf client(19) op=0 rc=0
6d01h RF_EVENT_CLIENT_PROGRESSION(503) Rsc split dshelf client(19) op=1 rc=0
6d01h RF_EVENT_GO_ACTIVE(511) op=0
6d01h Reloading peer (this unit becoming active)
6d01h *my state = ACTIVE-FAST(9) peer state = STANDBY COLD(4)
6d01h RF_STATUS_MAINTENANCE_ENABLE(403) Rsc split dshelf client(19) op=0
6d01h RF_PROG_ACTIVE_FAST(200) RF_INTERNAL_MSG(0) op=0 rc=11
6d01h RF_PROG_ACTIVE_FAST(200) Rsc split dshelf client(19) op=0 rc=11
6d01h RF_PROG_ACTIVE_FAST(200) RF_LAST_CLIENT(65000) op=0 rc=11
6d01h *my state = ACTIVE-DRAIN(10) peer state = STANDBY COLD(4)
6d01h RF_PROG_ACTIVE_DRAIN(201) RF_INTERNAL_MSG(0) op=0 rc=11
6d01h RF_PROG_ACTIVE_DRAIN(201) Rsc split dshelf client(19) op=0 rc=11
6d01h RF_PROG_ACTIVE_DRAIN(201) RF_LAST_CLIENT(65000) op=0 rc=11
6d01h *my state = ACTIVE_PRECONFIG(11) peer state = STANDBY COLD(4)
6d01h RF_PROG_ACTIVE_PRECONFIG(202) RF_INTERNAL_MSG(0) op=0 rc=11
6d01h RF_PROG_ACTIVE_PRECONFIG(202) Rsc split dshelf client(19) op=0 rc=11
6d01h RF_PROG_ACTIVE_PRECONFIG(202) RF_LAST_CLIENT(65000) op=0 rc=11
6d01h *my state = ACTIVE_POSTCONFIG(12) peer state = STANDBY COLD(4)
6d01h RF_PROG_ACTIVE_POSTCONFIG(203) RF_INTERNAL_MSG(0) op=0 rc=11
6d01h RF_PROG_ACTIVE_POSTCONFIG(203) Rsc split dshelf client(19) op=0 rc=11
6d01h RF_PROG_ACTIVE_POSTCONFIG(203) RF_LAST_CLIENT(65000) op=0 rc=11
6d01h *my state = ACTIVE(13) peer state = STANDBY COLD(4)
6d01h RF_PROG_ACTIVE(204) RF_INTERNAL_MSG(0) op=0 rc=11
6d01h RF_PROG_ACTIVE(204) Rsc split dshelf client(19) op=0 rc=0
6d01h RF_EVENT_CLIENT_PROGRESSION(503) Rsc split dshelf client(19) op=1 rc=0
6d01h my state = ACTIVE(13) *peer state = ACTIVE(13)
6d01h my state = ACTIVE(13) *peer state = UNKNOWN(0)
6d01h Reloading peer (notification timeout)
6d01h my state = ACTIVE(13) *peer state = ACTIVE(13)
6d01h RF_STATUS_REDUNDANCY_MODE_CHANGE(405) Rsc split dshelf client(19) op=1
6d01h RF_EVENT_GO_ACTIVE(511) op=0
6d01h RF_STATUS_REDUNDANCY_MODE_CHANGE(405) Rsc split dshelf client(19) op=3
6d01h RF_EVENT_GO_ACTIVE(511) op=0
 

保留中のハンドオーバーの詳細を表示するには、EXEC モードで show redundancy handover コマンドを入力します。

RouterA# show redundancy handover
No handover pending
 

最大 256 個の関連デバッグ エントリを表示するには、EXEC モードで show redundancy debug-log コマンドを入力します。

追加の関連出力を表示するには、EXEC モードで show chassis コマンドを入力します。ハンドオーバー スプリット モードでは、このコマンドは、RSC がスロットを所有しているかどうかにかかわりなく、シャーシ全体のすべてのスロットに対して設定されている RSC を表示します。ピア RSC によって所有されるスロットは、無視状態で表示され、適切に設定され、すぐに使用できます。

次に、通常ロード状態の 2 つの RSC の出力の例を示します。

RouterA# show chassis
System is in handover-split mode, RSC in slot 6.
Slots owned: 0 1 2 3 4 5
Slots configured: 0 1 2 3 4 5 8 9 10 11 12 13
Slots owned by other: 8 9 10 11 12 13
Slot Board CPU DRAM I/O Memory State Elapsed
Type Util Total (free) Total (free) Time
1 UP324 17%/17% 60159040( 50%) 67108864( 73%) Up 6d01h
2 UP324 1%/0% 60159040( 56%) 67108864( 73%) Up 6d01h
3 UP324 0%/0% 60159040( 56%) 67108864( 73%) Up 6d01h
4 CT3_UP216 1%/0% 60159040( 49%) 67108864( 72%) Up 6d01h
9 CT3_UP216 60159040( 0%) 67108864( 0%) Ignore 00:00:20
10 UP324 60159040( 0%) 67108864( 0%) Ignore 00:00:19
11 UP324 60159040( 0%) 67108864( 0%) Ignore 00:00:18
System set for auto boot
 
 
RouterB# show chassis
System is in handover-split mode, RSC in slot 7.
Slots owned: 8 9 10 11 12 13
Slots configured: 0 1 2 3 4 5 8 9 10 11 12 13
Slots owned by other: 0 1 2 3 4 5
Slot Board CPU DRAM I/O Memory State Elapsed
Type Util Total (free) Total (free) Time
1 UP324 0( 0%) 0( 0%) Ignore 00:00:38
2 UP324 0( 0%) 0( 0%) Ignore 00:00:37
3 UP324 0( 0%) 0( 0%) Ignore 00:00:36
4 CT3_UP216 0( 0%) 0( 0%) Ignore 00:00:35
9 CT3_UP216 0%/0% 60159040( 65%) 67108864( 72%) Up 00:23:14
10 UP324 0%/0% 60159040( 62%) 67108864( 73%) Up 00:23:16
11 UP324 0%/0% 60159040( 62%) 67108864( 73%) Up 00:23:17
System set for auto boot

次に、エクストラ ロード状態の 1 つの RSC の出力例を表示します。

RouterA# show chassis
System is in handover-split mode, RSC in slot 6.
Slots owned: 0 1 2 3 4 5 8 9 10 11 12 13
Slots configured: 0 1 2 3 4 5 8 9 10 11 12 13
Slots owned by other: none
Slot Board CPU DRAM I/O Memory State Elapsed
Type Util Total (free) Total (free) Time
1 UP324 0%/0% 60159040( 50%) 67108864( 73%) Up 6d02h
2 UP324 1%/0% 60159040( 56%) 67108864( 73%) Up 6d02h
3 UP324 0%/0% 60159040( 56%) 67108864( 73%) Up 6d02h
4 CT3_UP216 6%/5% 60159040( 49%) 67108864( 72%) Up 6d02h
9 CT3_UP216 5%/4% 60159040( 56%) 67108864( 72%) Up 00:10:29
10 UP324 20%/20% 60159040( 56%) 67108864( 73%) Up 00:10:30
11 UP324 0%/0% 60159040( 56%) 67108864( 73%) Up 00:10:30
System set for auto boot

トラブルシューティングのヒント

 

コマンド
目的

Router# debug redundancy as5850

冗長性に関係するデバッグ オプション(hardware lines、master RSC、FSM events、mode、RF client)をイネーブル、またはディセーブルにします。特定のデバッグ関連のオプション表示に使用します。ここでオプションをディセーブルにしても、すべてのデバッグ エントリが記録され続けます。また、 show redundancy debug-log コマンドを使用して、常にそれらのオプションを表示できます。

ハンドオーバー 冗長のモニタリングとメンテナンス

 

コマンド
目的

Router# redundancy handover
{ cancel | peer-resources | shelf-resources } [ busyout-period mins
at hh:mm day month year ]

RSC 間のスロットのハンドオーバーを指定する、またはキャンセルします。Cisco IOS イメージのアップグレード中、およびいったん停止したが現在は稼動中であるスロットの制御を RSC に戻すために使用します。ピア RSC( peer-resources )またはコマンドが実行されている RSC( shelf-resources )のいずれかに属するスロットのハンドオーバーを指定します。任意で、ハンドオーバーの前にビジーアウトする正確な時刻および継続する時間の長さのいずれか、または両方を指定します。

オプションは、RSC のリロードの原因となります。


) シャーシ リソース全体を制御する RSC がエクストラロードであれば、該当する RSC のマスター LED がオンであることを観察することで検出できます。この状態は、show redundancy states コマンドを使用することでも検出できます。


次に、ハンドオーバー スケジューリング、確認、キャンセル、およびキャンセルの確認の 2 つのインスタンスの例を示します。

RouterA# redundancy handover shelf-resources busyout-period 10 at 16:15 5 Sept 2001
Newly entered handover schedule:
Busyout period at 16:15:00 PST Wed Sep 5 2001 for a duration of 10 minute(s)
Handover pending at 16:25:00 PST Wed Sep 5 2001
Clear calls, handover and reload as specified above?[confirm]
 
RouterA# show redundancy handover
Busyout period at 16:15:00 PST Wed Sep 5 2001 for a duration of 10 minute(s)
Handover pending at 16:25:00 PST Wed Sep 5 2001
 
RouterA# redundancy handover cancel
Scheduled handover is cancelled
 
RSC-Slot6# show redundancy handover
No handover pending
 
 
 
RouterA# redundancy handover peer-resources busyout-period 10 at 16:37 5 Sep 2001
Newly entered handover schedule:
Busyout period at 16:37:00 PST Wed Sep 5 2001 for a duration of 10 minute(s)
Handover pending at 16:47:00 PST Wed Sep 5 2001
Clear calls and handover as specified above?[confirm]
 
RouterA# show redundancy handover
Busyout period at 16:37:00 PST Wed Sep 5 2001 for a duration of 10 minute(s)
Handover pending at 16:47:00 PST Wed Sep 5 2001
 
RouterA# redundancy handover cancel
Scheduled handover is cancelled
 
RouterA# show redundancy handover
No handover pending

設定例

次に、冗長性をサポートするスタートアップ コンフィギュレーションの例を示します。リソース プール範囲およびコントローラ番号の項では、シャーシの各カードが設定されることに注意してください。

RouterA# show startup-config
 
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname RouterA
!
redundancy
mode handover-split
aaa new-model
!
!
aaa group server tacacs+ redline2
!
aaa group server radius RADIUS-GROUP
server 172.22.51.9 auth-port 1645 acct-port 1646
!
aaa authentication login CONSOLE none
aaa authentication login VTY none
aaa authentication ppp default group RADIUS-GROUP
aaa authentication ppp RADIUS-LIST group RADIUS-GROUP
aaa authorization exec CONSOLE none
aaa authorization exec RADIUS-LIST group RADIUS-GROUP
aaa authorization network default group RADIUS-GROUP if-authenticated
aaa authorization network RADIUS-LIST group RADIUS-GROUP if-authenticated
aaa accounting network default start-stop group RADIUS-GROUP
aaa nas port extended
aaa session-id common
enable password xxx
!
username RouterB password 0 xxx
username 54006
username 54006_1 password 0 xxx
username RouterA password 0 xxx
username 54006_d_119 password 0 xxx
!
resource-pool enable
!
resource-pool group resource group1
range port 1/0 1/323
range port 4/20 4/30
!
resource-pool group resource group2
range port 9/0 9/215
range port 10/0 10/120
!
resource-pool group resource digital_group_6
range limit 207
!
resource-pool group resource digital_group
range limit 116
!
resource-pool group resource vpdn_dig
range limit 92
!
resource-pool profile customer 54006_customer
limit base-size all
limit overflow-size 0
resource group1 speech
dnis group 54006_dnis
!
resource-pool profile customer 54007_customer
limit base-size all
limit overflow-size 0
resource group2 speech
dnis group 54007_dnis
!
resource-pool profile customer 54006_customer_sync
limit base-size all
limit overflow-size 0
resource digital_group_6 digital
dnis group 54006_sync_dnis
!
resource-pool profile customer 54007_sync
limit base-size all
limit overflow-size 0
resource digital_group digital
dnis group 54007_sync_dnis
!
resource-pool profile customer 54007_sync_vpdn
limit base-size all
limit overflow-size 0
resource vpdn_dig digital
dnis group 54007_sync_vpdn_dnis
clock timezone PST -7
dial-tdm-clock priority 8 trunk-slot 9 ds3-port 0 port 1
dial-tdm-clock priority 10 trunk-slot 4 ds3-port 0 port 1
spe country t1-default
!
spe link-info poll voice 5
!
ip subnet-zero
ip cef distributed
ip ftp source-interface FastEthernet6/0
ip ftp username root
ip ftp password xxxxx
no ip domain-lookup
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol l2f
source-ip 30.0.0.1
!
chat-script dial "" "ATZ" OK "ATDT\T" TIMEOUT 60 CONNECT
isdn switch-type primary-5ess
!
controller T3 4/0
framing c-bit
cablelength 224
t1 1-28 controller
!
controller T1 4/0:1
framing esf
pri-group timeslots 1-24
!
controller T1 4/0:2
framing esf
pri-group timeslots 1-24
!
controller T1 4/0:3
framing esf
pri-group timeslots 1-24
!
.
.
.
controller T1 4/0:28
shutdown
framing esf
pri-group timeslots 1-24
!
controller T3 9/0
framing c-bit
cablelength 224
t1 1-28 controller
!
controller T1 9/0:1
framing esf
ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis
!
controller T1 9/0:2
framing esf
ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis
!
controller T1 9/0:3
framing esf
ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis
!
.
.
.
controller T1 9/0:12
framing esf
ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis
!
controller T1 9/0:13
framing esf
pri-group timeslots 1-24
!
.
.
.
controller T1 9/0:21
framing esf
pri-group timeslots 1-24
!
controller T1 9/0:22
shutdown
framing esf
ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis
!
.
.
.
controller T1 9/0:28
shutdown
framing esf
ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis
!
!
!
interface Loopback0
ip address 111.111.111.11 255.255.255.0
no ip mroute-cache
!
interface Serial4/0:1:23
no ip address
encapsulation ppp
ip mroute-cache
isdn switch-type primary-5ess
isdn incoming-voice modem
!
interface Serial4/0:2:23
no ip address
encapsulation ppp
ip mroute-cache
isdn switch-type primary-5ess
isdn incoming-voice modem
!
interface Serial4/0:3:23
no ip address
encapsulation ppp
ip mroute-cache
isdn switch-type primary-5ess
isdn incoming-voice modem
!
.
.
.
interface Serial4/0:10:23
no ip address
encapsulation ppp
ip mroute-cache
isdn switch-type primary-5ess
isdn incoming-voice modem
!
interface Serial4/0:11:23
no ip address
encapsulation ppp
ip mroute-cache
isdn switch-type primary-5ess
isdn incoming-voice modem
!
interface Serial9/0:21:23
ip unnumbered Loopback0
encapsulation ppp
ip mroute-cache
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-5ess
!
interface Group-Async0
ip unnumbered Loopback0
encapsulation ppp
dialer in-band
dialer idle-timeout 36000 either
dialer string 6003
dialer-group 1
async default routing
async mode dedicated
peer default ip address pool KRAMER
ppp max-bad-auth 3
ppp authentication chap pap callin RADIUS_LIST
ppp chap hostname RouterB
ppp chap password 7 xxxxx
group-range 9/00 11/323
!
interface Group-Async1
ip unnumbered Loopback0
encapsulation ppp
dialer in-band
dialer idle-timeout 36000 either
dialer string 6003
dialer-group 1
async default routing
async mode dedicated
peer default ip address pool KRAMER1
ppp max-bad-auth 3
ppp authentication chap pap callin RADIUS_LIST
ppp chap hostname RouterA
ppp chap password 7 xxxxx
group-range 1/00 4/215
!
interface Dialer0
ip unnumbered Loopback0
encapsulation ppp
dialer in-band
dialer idle-timeout 36000 either
dialer string 6003
dialer-group 1
peer default ip address pool KRAMER1_d_m
no fair-queue
no cdp enable
ppp authentication chap pap callin RADIUS_LIST
ppp chap hostname RouterA
ppp chap password 7 xxxxx
ppp multilink
!
interface Dialer1
ip unnumbered Loopback0
encapsulation ppp
dialer in-band
dialer idle-timeout 36000 either
dialer string 6003
dialer-group 1
peer default ip address pool KRAMER_d
no cdp enable
ppp max-bad-auth 3
ppp authentication chap pap callin RADIUS_LIST
ppp chap hostname RouterB
ppp chap password 7 xxxxx
!
interface Dialer2
ip unnumbered Loopback0
encapsulation ppp
dialer in-band
dialer idle-timeout 36000 either
dialer string 6003
dialer-group 1
peer default ip address pool KRAMER1_d
no fair-queue
no cdp enable
ppp authentication chap pap callin RADIUS_LIST
ppp chap hostname RouterA
ppp chap password 7 xxxxx
!
interface Dialer5
no ip address
no cdp enable
!
interface Dialer6
no ip address
no cdp enable
!
interface Dialer7
no ip address
no cdp enable
!
.
.
.
interface Dialer26
no ip address
no cdp enable
!
ip local pool KRAMER1 10.6.1.1 10.6.1.108
ip local pool KRAMER1 10.6.2.1 10.6.2.108
ip local pool KRAMER1 10.6.3.1 10.6.3.60
ip local pool KRAMER 10.7.1.1 10.7.1.108
ip local pool KRAMER 10.7.2.1 10.7.2.108
ip local pool KRAMER 10.7.3.1 10.7.3.60
ip local pool KRAMER1_d 10.6.4.1 10.6.4.115
ip local pool KRAMER_d 10.7.4.1 10.7.4.115
ip local pool KRAMER1_d_m 10.6.4.116 10.6.4.163
ip classless
no ip http server
!
ip radius source-interface FastEthernet6/0
!
dialer dnis group 54006_dnis
number 1002
number 1002100212
!
dialer dnis group 54007_dnis
number 38327
!
dialer dnis group 54006_sync_dnis
number 6666
number 6600
number 6666666666
!
dialer dnis group 54007_sync_dnis
number 7700
number 7700000000
!
dialer dnis group 54007_sync_vpdn_dnis
number 7777
number 7777777777
!
dialer dnis group 54007_vpdn_dnis
number 38777
dialer-list 1 protocol ip permit
no cdp run
!
tacacs-server host 152.22.51.64
tacacs-server timeout 30
tacacs-server key cisco
snmp-server community public RW
snmp-server enable traps rf
!
radius-server configure-nas
radius-server host 172.22.51.9 auth-port 1645 acct-port 1646 non-standard
radius-server retransmit 3
radius-server attribute nas-port format c
radius-server key lab
call rsvp-sync
!
voice-port 4/0:1:D
!
voice-port 4/0:2:D
!
.
.
.
voice-port 4/0:28:D
!
voice-port 9/0:1:0
!
voice-port 9/0:2:0
!
.
.
.
voice-port 9/0:28:0
!
!
line con 0
password xxxxxx
logging synchronous
line aux 0
logging synchronous
modem InOut
transport input all
line vty 0 4
password xxx
transport preferred telnet
transport input telnet
line 1/00 4/215
modem InOut
no modem status-poll
no modem log rs232
transport preferred none
transport input all
autoselect during-login
autoselect ppp
line 9/00 9/215
modem InOut
no modem status-poll
no modem log rs232
transport preferred none
transport input all
autoselect during-login
autoselect ppp
line 10/00 11/323
modem InOut
no modem status-poll
no modem log rs232
transport preferred none
transport input all
autoselect during-login
autoselect ppp
!
end

コマンド リファレンス

次のコマンドは、このモジュールで説明した機能で導入または修正されたものです。これらのコマンドの詳細については、『 Cisco IOS Interface and Hardware Component Command Reference 』( http://www.cisco.com/en/US/docs/ios/interface/command/reference/ir_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、参照先( http://tools.cisco.com/Support/CLILookup )の Command Lookup Tool を使用するか、または『 Cisco IOS Master Commands List 』にアクセスしてください。

debug redundancy as5850

mode (redundancy)

redundancy handover

show redundancy (5850)

show chassis

用語集

RSC :Route Switch Controller(ルート スイッチ コントローラ)。スイッチ機能、ルーティング、管理制御、クロック制御、および出力ポートを提供するカード。

クラシック スプリット モード :スロットが 2 つの RSC 間で分配されるため、システム スループットが最大化されるモード。

サービス低下時間 :システムが新しいコールを獲得できない、またはすべてのコール数を実行できない期間の長さ。

サービス中断 :その間は、処理中のコールはドロップされ、ユーザのコールバックを要求するイベント。

ハンドオーバー :システムの別の部分が停止していたときに管理していたリソースを引き継ぐためのシステムのある部分の機能。

ハンドオーバー スプリット モード :ある RSC が停止したときにその RSC のスロット、カード、およびコールの制御をもう 1 つの RSC が自動的に引き継ぐため、システム可用性が最大化されるモード。