インターフェイスおよびハードウェア コンポー ネント コンフィギュレーション ガイド Cisco IOS Release 15.1S
マルチポイント GRE トンネルを使用したダイ ナミック レイヤ 3 VPN
マルチポイント GRE トンネルを使用したダイナミック レイヤ 3 VPN
発行日;2012/02/01 | 英語版ドキュメント(2010/05/20 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

マルチポイント GRE トンネルを使用したダイナミック レイヤ 3 VPN

機能情報の確認

この章の構成

mGRE トンネル機能付きの Dynamic L3 VPN の前提条件

mGRE トンネル機能付きの Dynamic L3 VPN の制約事項

mGRE トンネル機能付きの Dynamic L3 VPN について

レイヤ 3 mGRE トンネル

IP ネットワーク内でのプロバイダー エッジ ルータの相互接続

IP ネットワークと MPLS ネットワークとの間のパケット転送

BGP ネクスト ホップの確認

L3 VPN mGRE トンネルの設定方法

VRF トンネルと mGRE トンネルの作成

前提条件

BGP VPN の情報交換の設定

MPLS VPN over mGRE をイネーブルにして L3VPN カプセル化プロファイルを設定する

前提条件

mGRE を介する MPLS VPN でのアドレス空間の定義とアドレス解決の指定

次の作業

mGRE トンネルを使用した Dynamic L3 VPN サポートの設定例

レイヤ 3 VPN mGRE トンネルの設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

mGRE トンネル機能付きの Dynamic L3 VPN の機能情報

マルチポイント GRE トンネルを使用したダイナミック レイヤ 3 VPN

マルチポイント GRE トンネルを使用したダイナミック レイヤ 3 VPN では、IP ネットワークで使用される拡張 multipoint Generic Routing Encapsulation(mGRE)トンネリング テクノロジーに基づいて、Layer 3(L3; レイヤ 3)トランスポート メカニズムが提供されます。ダイナミック レイヤ 3 トンネリング トランスポートは、IP ネットワーク内で使用でき、Virtual Private Network(VPN; バーチャル プライベート ネットワーク)トラフィックがサービス プロバイダーおよび企業ネットワークに転送され、IP および Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VPN 間のパケット転送の相互運用性も提供されます。この機能では、企業ネットワーク向けの IP バックボーン サービスのアウトソーシングを定義した RFC 2547 がサポートされます。

機能情報の確認

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「mGRE トンネル機能付きの Dynamic L3 VPN の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

mGRE トンネル機能付きの Dynamic L3 VPN の前提条件

マルチポイント GRE トンネルを使用したダイナミック レイヤ 3 VPN を設定する前に、使用する MPLS VPN が設定され、適切に動作していることを確認します。MPLS VPN の設定については、「 Configuring MPLS Layer 3 VPNs 」を参照してください。

mGRE トンネル機能付きの Dynamic L3 VPN の制約事項

単一ネットワーク内で IP/GRE および MPLS カプセル化の両方を使用した MPLS VPN の展開は、サポートされません。

各 Provider Edge(PE; プロバイダー エッジ)ルータでは、1 つのトンネル設定のみがサポートされます。

mGRE トンネル機能付きの Dynamic L3 VPN について

mGRE トンネルを設定して、IP バックボーンをオーバーレイするマルチポイント トンネル ネットワークを作成できます。このオーバーレイによって、VPN トラフィックを転送するために各 PE ルータ同士が接続されます。

さらに、MPLS VPN を mGRE を介して設定すると、標準ベースの IP コアを使用して、L3 PE ベースの VPN サービスを導入できます。これにより、オーバーレイ方式を使用しないで VPN サービスをプロビジョニングできます。MPLS VPN over mGRE が設定されると、システムでは、PE 間の VPN ラベル IPv4 および IPv6 パケットのカプセル化に IPv4 ベースの mGRE トンネルが使用されます。

ここでは、次のトピックについて説明します。

「レイヤ 3 mGRE トンネル」

レイヤ 3 mGRE トンネル

mGRE トンネルを設定することによって、IP バックボーンに対するオーバーレイとして、マルチポイント トンネル ネットワークを作成します。このオーバーレイによって、PE ルータが相互接続され、バックボーンを介して VPN トラフィックが転送されます。このマルチポイント トンネル ネットワークでは、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を使用して PE ルータ間で VPNv4 ルーティング情報が配信され、サービス プロバイダーまたは企業ネットワークおよびカスタマー サイトとの間のピア関係が維持されます。BGP VPNv4 でアドバタイズされるネクスト ホップにより、トンネル エンドポイントの検出がトリガーされます。この機能によって、1 つのサービス プロバイダーの入力 PE ルータから、異なるサービス プロバイダー サイトの出力 PE ルータへ、直接トンネルされるトラフィックが使用されて、連結 VPN サービスと相互動作する機能が、複数のサービス プロバイダーに提供されます。

VPN 転送機能に加え、mGRE トンネルでは、フル メッシュ トポロジが作成され、複数のカスタマー サイトの相互接続に使用されていたポイントツーポイント トンネルのフル メッシュに関連していた以前の管理と操作の負荷が、軽減されます。設定の要件は飛躍的に軽減され、最小限の追加設定でネットワークを使用できます。

Dynamic L3 トンネルによって、VPN の部分メッシュまたはフル メッシュが作成される場合に、さまざまな規模に対して提供されます。新しいルータのみを設定する必要があるため、新しいリモート VPN ピアを追加する方法が簡素化されます。新しいアドレスは動的に認識され、ネットワークのノードに送信されます。ダイナミック ルーティング機能によって、VPN のすべてのルータで必要な設定のサイズが飛躍的に削減されます。たとえば、マルチポイント トンネルの使用では、1 つのトンネル インターフェイスのみを多数の VPN サービスを提供する PE に設定する必要があります。L3 mGRE トンネルは、PE ルータにのみ設定する必要があります。GRE で使用可能な機能は、mGRE でも使用できます。使用できる機能には、mGRE/Next Hop Routing Protocol(NHRP)トンネル トラフィックのダイナミック IP ルーティング、IP マルチキャストおよび Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)スイッチングが含まれます。

ここでは、mGRE トンネルの使用方法について説明します。

「IP ネットワーク内でのプロバイダー エッジ ルータの相互接続」

「IP ネットワークと MPLS ネットワークとの間のパケット転送」

「BGP ネクスト ホップの確認」

IP ネットワーク内でのプロバイダー エッジ ルータの相互接続

マルチポイント GRE トンネルを使用したダイナミック レイヤ 3 VPN を使用すると、マルチアクセス トンネル ネットワークを作成し、IP ネットワークにサービスを提供する PE ルータを相互接続することができます。このトンネル ネットワークでは、すべての PE ルータに IP VPN トラフィックが転送されます。図 1 に、PE ルータ間で VPN トラフィックを転送する IP ネットワークで使用されるトンネル オーバーレイ ネットワークを示します。

図 1 IP ネットワーク間で PE ルータを接続する mGRE トンネル オーバーレイ

 

マルチアクセス トンネル オーバーレイ ネットワークによって、PE ルータ間のフル接続が提供されます。PE ルータ間では、RFC 2547 で定義されている BGP を使用して VPN ルートの情報交換が行われます。IP トラフィックは、オーバーレイ専用および転送ネットワーク専用の IP アドレス空間を使用したマルチポイント トンネル オーバーレイ ネットワークを介して、アドレスの数値の変更ではなくアドレス空間の変更によって、リダイレクトされます。

IP ネットワークと MPLS ネットワークとの間のパケット転送

レイヤ 3 mGRE トンネルは、IP ネットワークと MPLS ネットワークとの間のパケット転送メカニズムとして使用できます。2 つの転送プロトコル間のパケット転送をイネーブルにするには、2 つのネットワーク間の接続の片側にある 1 台の PE ルータで、MPLS が実行されている必要があります。図 2 に、PE ルータ間で VPN トラフィックの転送に mGRE を使用する方法について示します。

図 2 IP ネットワークと MPLS ネットワークとの間の VPN トラフィックの転送での mGRE の使用

 

IP ネットワークと MPLS ネットワークとの間で発生するパケット転送では、MPLS VPN ラベルが GRE キーにマップされます。マッピングは、mGRE と MPLS の両方が設定されているルータで行われます。図 2 では、キーに対するラベルのマッピングはルータ M で発生します。ルータ M は MPLS ネットワークにあります。

BGP ネクスト ホップの確認

BGP では、PE で、BGP パスの選択またはネクスト ホップの確認が実行されます。パス選択プロセスで検討対象になるネットワークへの BGP パスは、Interior Gateway Protocol(IGP)で到達可能である必要があります。IP プレフィクスを受信し、ネクスト ホップ IP アドレスとしてアドバタイズされる場合、IP トラフィックは、ネクスト ホップのアドレス空間を切り替えることによって、送信元から宛先にトンネリングされます。

L3 VPN mGRE トンネルの設定方法

L3 VPN mGRE トンネルを展開するには、ルート マップを介してアップデートがフィルタリングされ、関連するプレフィクスが VRF テーブルで解決されるよう、VRF インスタンスと mGRE トンネルを作成し、VPN IP トラフィックをトンネルにリダイレクトして、BGP VPNv4 での情報交換を設定します。

mGRE を介して L3 VPN の展開を設定する作業については、次の項で説明します。

「VRF トンネルと mGRE トンネルの作成」(必須)

「BGP VPN の情報交換の設定」(必須)

「MPLS VPN over mGRE をイネーブルにして L3VPN カプセル化プロファイルを設定する」(必須)

「mGRE を介する MPLS VPN でのアドレス空間の定義とアドレス解決の指定」(必須)

VRF トンネルと mGRE トンネルの作成

サービス プロバイダー ネットワーク間で VPN トラフィックが転送されるトンネルは、そのアドレス空間にあります。Resolve in VRF(RiV)と呼ばれる特殊な VRF インスタンスが作成される必要があります。ここでは、VRF トンネルと GRE トンネルを作成する方法について説明します。

前提条件

インターフェイス上の IP アドレスは、設定で指定される送信元インターフェイスと同じである必要があります。指定される送信元インターフェイスは、VPNv4 アップデートで送信元として BGP によって使用されるものに一致する必要があります。


) トンネル モード IPSec は、GRE トンネルを介する MPLS ではサポートされません。


手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd 1:1

5. interface tunnel tunnel name

6. ip address ip-address subnet-id

7. tunnel source loopback n

8. tunnel mode gre multipoint l3vpn

9. tunnel key gre-key

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf customer a riv

IP アドレスのトンネルおよびリダイレクトに使用される特殊な Resolve in VRF(RiV)VRF インスタンスおよびテーブルを作成します。

ステップ 4

rd 1:1

 

Router(config-vrf)# rd 1:1

VRF コンフィギュレーション モードを開始し、VPN VRF インスタンスに Route Distinguisher(RD; ルート識別子)を指定します。

ステップ 5

interface tunnel tunnel-name

 

Router(config-vrf)# interface tunnel 1

インターフェイス コンフィギュレーション モードを開始し、トンネルを作成します。

ステップ 6

ip address ip-address subnet-id

 

Router(config-if)# ipaddress 209.165.200.225 255.255.255.224

トンネルの IP アドレスを指定します。

ステップ 7

tunnel source loopback n

 

Router(config-if)# tunnel source loopback test1

ループバック インターフェイスを作成します。

ステップ 8

tunnel mode gre multipoint l3vpn

 

Router(config-if)# tunnel mode gre multipoint l3vpn

トンネルのモードを「gre multipoint l3vpn」に設定します。

ステップ 9

tunnel key gre-ke y

 

Router(config-if)# tunnel key 18

トンネルの GRE キーを指定します。

ステップ 10

end

 

Router(config-if)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

BGP VPN の情報交換の設定

この項で説明する設定作業では、ルート マップを介してアップデートがフィルタリングされ、関連するプレフィクスが VRF テーブルで解決されるよう、BGP VPNv4 での情報交換が設定されます。

手順の概要

1. enable

2. configure terminal

3. interface tunnel tunnel name

4. ip route vrf riv-vrf-name IP address subnet mask tunnel n

5. router bgp as-number

6. network network id

7. neighbor { ip-address | peer-group-name } remote-as as-number

8. neighbor { ip-address | peer-group-name } update-source interface-type

9. address-family vpnv4 [ unicast ]

10. neighbor { ip-address | peer-group-name } activate

11. neighbor { ip-address | peer-group-name } route-map map-name { in | out }

12. set ip next-hop resolve-in-vrf vrf name

13. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel tunnel-name

 

Router(config)# interface tunnel 1

トンネルのインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip route vrf riv-vrf-name ip-address subnet- mask tunnel n

 

Router(config-if)# ip route vrf vrf1 209.165.200.226 255.255.255.224 tunnel 1

特殊な RiV VRF へのパケット転送を設定します。

ステップ 5

router bgp as-number

 

Router(config)# router bgp 100

ルーティング情報が渡される他の BGP ルータおよびタグへのルータが指定されている自律システムの数を指定します。

ステップ 6

network network-id

 

Router(config)# network 209.165.200.255

BGP およびマルチプロトコル BGP ルーティング プロセスによってアドバタイズされるネットワークのネットワーク ID を指定します。

ステップ 7

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config)# neighbor 209.165.200.227 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ステップ 8

neighbor { ip-address | peer-group-name } update-source interface-type

 

Router(config)# neighbor 209.165.200.228 update-source FastEthernet0/1

BGP セッションによって TCP 接続に使用される特別な動作インターフェイスを設定します。

ステップ 9

address-family vpnv4 [ unicast ]

 

Router(config)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPN4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを指定します。

ステップ 10

neighbor { ip-address | peer-group-name } activate

 

Router(config)# neighbor 209.165.200.229 activate

ネイバー ルータとの情報交換をイネーブルにします。

ステップ 11

neighbor { ip-address | peer-group-name } route-map map-name { in | out }

 

Router(config)# neighbor 209.165.200.230 route-map mpt in

受信または発信ルートにルート マップを適用します。

インバウンド インターフェイスごとに一度ずつ使用します。

ステップ 12

set ip next-hop resolve-in-vrf vrf-name

 

Router(config)# set ip next-hop resolve-in-vrf vrft

指定された VRF の VRF テーブルでネクスト ホップが解決されるよう指定します。

ステップ 13

end

 

Router(config)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

MPLS VPN over mGRE をイネーブルにして L3VPN カプセル化プロファイルを設定する

ここでは、VRF を定義し、MPLS VPN over mGRE をイネーブルにして、L3VPN カプセル化プロファイルを設定する方法について説明します。


) この設定では、IPv6、MPLS、IP、および Layer 2 Tunneling Protocol version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)のような転送プロトコルも使用できます。


前提条件

MPLS VPN over mGRE をイネーブルにし、設定するには、トンネル カプセル化の VRF をまず定義し、システムで L3VPN カプセル化をイネーブルにします。

手順の概要

1. enable

2. configure terminal

3. vrf definition vrf-name

4. rd 1:1

5. exit

6. ip cef

7. ipv6 unicast-routing

8. ipv6 cef

9. l3vpn encapsulation ip profile name

10. transport ipv4 [ source interface n ]

11. protocol gre [ key gre-key ]

12. exit

13. interface type number

14. ip address ip-address mask

15. ip router isis

16. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vrf definition vrf-name

 

Router(config)# vrf definition tunnel encap

VPN VRF ルーティング テーブル インスタンスを設定し、VRF コンフィギュレーション モードを開始します。

ステップ 4

rd 1:1

 

Router(config-vrf)# rd 1:1

VPN VRF インスタンスの RD を指定します。

ステップ 5

exit

 

Router(config-vrf)# exit

VRF コンフィギュレーション モードを終了します。

ステップ 6

ip cef

 

Router(config)# ip cef

ルータ上でシスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 7

ipv6 unicast-routing

 

Router(config)# ipv6 unicast-routing

IPv6 ユニキャスト データグラムの転送をイネーブルにします。

ステップ 8

ipv6 cef

 

Router(config)# ipv6 cef

ルータ上で IPv6 のシスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 9

l3vpn encapsulation ip profile-name

 

Router(config)# l3vpn encapsulation ip tunnel encap

L3 VPN カプセル化コンフィギュレーション モードを開始し、トンネルを作成します。

ステップ 10

transport ipv4 source interface n

 

Router(config-l3vpn-encap-ip)# transport ipv4 source loopback 0

IPv4 送信元モードを指定して、送信元インターフェイスを定義します。

ステップ 11

protocol gre [ key gre-key ]

 

Router(config-l3vpn-encap-ip)# protocol gre key 1234

GRE をトンネル モードとして指定し、GRE キーを設定します。

ステップ 12

exit

 

Router(config-l3vpn-encap-ip)# exit

L3 VPN カプセル化コンフィギュレーション モードを終了します。

ステップ 13

interface type number

 

Router(config)# interface loopback 0

インターフェイス タイプを設定するため、インターフェイス コンフィギュレーション モードを開始します。

ステップ 14

ip address ip-address mask

 

Router(config-if)# ip address 10.10.10.4 255.255.255.255

プライマリ IP アドレスとインターフェイスのマスクを指定します。

ステップ 15

ip router isis

 

Router(config-if)# ip router isis

インターフェイスに IP 用の Intermediate System-to-Intermediate System(IS-IS)ルーティング プロセスを設定し、ルーティング プロセスにヌル エリア指示子を付加します。

ステップ 16

end

 

Router(config-if)#end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

mGRE を介する MPLS VPN でのアドレス空間の定義とアドレス解決の指定

ここでは、mGRE を介する MPLS VPN でのアドレス空間の定義方法とアドレス解決の指定方法について説明します。次の手順では、アップデートがルート マップを介してフィルタリングされるよう、ルート マップをアプリケーション テンプレートにリンクし、BGP VPNv4 および VPNv6 の情報交換を設定します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5. neighbor ip-address remote-as as-number

6. neighbor ip-address update-source interface name

7. address-family ipv4

8. no synchronization

9. redistribute connected

10. neighbor ip-address activate

11. no auto-summary

12. exit

13. address-family vpnv4

14. neighbor ip-address activate

15. neighbor ip-address send-community both

16. neighbor ip-address route-map map-name in

17. exit

18. address-family vpnv6

19. neighbor ip-address activate

20. neighbor ip-address send-community both

21. neighbor ip-address route-map map-name in

22. exit

23. route-map map-tag permit position

24. set ip next-hop encapsulate l3vpn profile name

25. set ipv6 next-hop encapsulate l3vpn profile name

26. exit

27. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router (config)# router bgp 100

ルーティング情報が渡される他の BGP ルータおよびタグへのルータが指定されている自律システムの数を指定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

bgp log-neighbor-changes

 

Router (config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 5

neighbor ip-address remote-as as-number

 

Router (config-router)# neighbor 10.10.10.6 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ステップ 6

neighbor ip-address update-source interface-type interface-name

 

Router (config-router)# neighbor 10.10.10.6 update-source loopback 0

BGP セッションが、TCP 接続の動作インターフェイスを使用できるようにします。

ステップ 7

address-family vpn4

 

Router (config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始し、IPv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

ステップ 8

no synchronization

 

Router (config-router-af)# no synchronization

IGP を待たずにネットワーク ルートをアドバタイズするよう、Cisco IOS ソフトウェアをイネーブルにします。

ステップ 9

redistribute connected

 

Router (config-router-af)# redistribute connected

1 つのルーティング ドメインから別のルーティング ドメインにルートを再配布し、送信元プロトコルによって認識されたルート、および、送信元プロトコルが実行されているインターフェイスを介して接続されているプレフィクスを、ターゲット プロトコルで再配布できるようにします。

ステップ 10

neighbor ip-address activate

 

Router (config-router-af)# neighbor 10.10.10.6 activate

BGP ネイバーとの情報交換をイネーブルにします。

ステップ 11

no auto-summary

 

Router (config-router-af)# no auto-summary

自動サマライズをディセーブルにし、サブプレフィクス ルーティング情報をクラスフル ネットワーク境界間で送信します。

ステップ 12

exit

 

Router (config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 13

address-family vpnv4

 

Router (config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

ステップ 14

neighbor ip-address activate

 

Router (config-router-af)# neighbor 10.10.10.6 activate

BGP ネイバーとの情報交換をイネーブルにします。

ステップ 15

neighbor ip-address send-community both

 

Router (config-router-af)# neighbor 10.10.10.6 send-community both

標準コミュニティと拡張コミュニティの両方のコミュニティ アトリビュートが、BGP ネイバーに送信されるように指定します。

ステップ 16

neighbor ip-address route-map map-name in

 

Router (config-router-af)# neighbor 10.10.10.6 route-map SELECT UPDATE FOR L3VPN in

名前付きルート マップを受信ルートに適用します。

ステップ 17

exit

 

Router (config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 18

address-family vpnv6

 

6Router (config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、VPNv6 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

ステップ 19

neighbor ip-address activate

 

Router (config-router-af)# neighbor 209.165.200.252 activate

BGP ネイバーとの情報交換をイネーブルにします。

ステップ 20

neighbor ip-address send-community both

 

Router (config-router-af)# neighbor 209.165.200.252 send-community both

標準コミュニティと拡張コミュニティの両方のコミュニティ アトリビュートが、BGP ネイバーに送信されるように指定します。

ステップ 21

neighbor ip-address route-map ip-address in

 

Router (config-router-af)# neighbor 209.165.200.252 route-map SELECT UPDATE FOR L3VPN in

名前付きルート マップを受信ルートに適用します。

ステップ 22

exit

 

Router (config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 23

route-map map-tag permit position

 

Router (config-router)# route-map 192.168.10.1 permit 10

ルート マップ コンフィギュレーション モードを開始し、1 つのルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義します。

redistribute ルータ コンフィギュレーション コマンドによって、指定されたマップ タグが使用され、このルート マップが参照されます。複数のルート マップで同じマップ タグ名を共有できます。

このルート マップの一致基準が満たされている場合は、set アクションの制御に従ってルートが再配布されます。

一致基準が満たされていない場合、同じマップ タグが使用されている次のルート マップがテストされます。あるルートが、同じ名前を共有するルート マップ セットの一致基準のいずれも満たさない場合、そのセットによる再配布は行われません。

position 引数は、同じ名前で設定済みのルート マップのリストに新しいルート マップが入る位置を示します。

ステップ 24

set ip next-hop encapsulate l3vpn tunnel encap

 

Router (config-route-map)# set ip next-hop encapsulate l3vpn my profile

ルート マップの match 句を渡す出力 IPv4 パケットは、トンネルのカプセル化のため、VRF に送信されます。

ステップ 25

set ipv6 next-hop encapsulate l3vpn profile name

 

Router (config-route-map)# set ip next-hop encapsulate l3vpn tunnel encap

 

ルート マップの match 句を渡す出力 IPv6 パケットは、トンネルのカプセル化のため、VRF に送信されます。

ステップ 26

end

 

Router (config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 27

end

 

Router (config)# exit

グローバル コンフィギュレーション モードを終了します。

次の作業

設定が適切に動作していることを確認するために、次の操作を実行できます。

VRF プレフィクスのチェック

指定された VRF プレフィクスが BGP で受信されたことを確認します。BGP テーブル エントリに、ルート マップが動作し、RiV にネクスト ホップが示されていることが表示されているはずです。この例で示されているように、 show ip bgp vpnv4 コマンドを使用します。

Router# show ip bgp vpnv4 vrf customer 209.165.200.250
 
BGP routing table entry for 100:1:209.165.200.250/24, version 12
Paths: (1 available, best #1)
Not advertised to any peer
Local
209.165.200.251 in "my riv" from 209.165.200.251 (209.165.200.251)
Origin incomplete, metric 0, localpref 100, valid, internal, best
Extended Community: RT:100:1
 

同じ情報がルーティング テーブルに送信されたことを確認します。

Router# show ip route vrf customer 209.165.200.250
 
Routing entry for 209.165.200.250/24
Known via "bgp 100", distance 200, metric 0, type internal
Last update from 209.165.200.251 00:23:07 ago
Routing Descriptor Blocks:
* 209.165.200.251 (my riv), from 209.165.200.251, 00:23:07 ago
Route metric is 0, traffic share count is 1
AS Hops 0

CEF スイッチング

CEF スイッチングが想定どおりに動作していることも確認できます。

Router# show ip cef vrf customer 209.165.200.250
 
209.165.200.250/24, version 6, epoch 0
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
fast tag rewrite with Tu1, 123.1.1.2, tags imposed: {17}
via 209.165.200.251, 0 dependencies, recursive
next hop 209.165.200.251, Tunnel1 via 209.165.200.251/32 (my riv)
valid adjacency
tag rewrite with Tu1, 209.165.200.251, tags imposed: {17}

エンドポイントの作成

この例では、トンネル エンドポイントが正しく作成されたことが表示されています。

Router# show tunnel endpoint tunnel 1
 
Tunnel1 running in multi-GRE/IP mode
RFC2547/L3VPN Tunnel endpoint discovery is active on Tu1
Transporting l3vpn traffic to all routes recursing through "my riv"
 
Endpoint 209.165.200.251 via destination 209.165.200.251
Endpoint 209.165.200.254 via destination 209.165.200.254

隣接

対応する隣接が作成されたことを確認します。

Router# show adjacency Tunnel 1 interface
Protocol Interface Address
TAG Tunnel1 209.165.200.251(4)
15 packets, 1980 bytes
4500000000000000FF2FC3C77B010103
7B01010200008847
Epoch: 0
Fast adjacency disabled
IP redirect disabled
IP mtu 1472 (0x0)
Fixup enabled (0x2)
GRE tunnel
Adjacency pointer 0x624A1580, refCount 4
Connection Id 0x0
Bucket 121
 

MPLS が mGRE を介して転送中のため、LINK_TAG 隣接が関連する隣接であることに注意してください。隣接にレポートされる MTU は、パケットが受信するペイロードの長さ(MPLS ラベルを含む)です。隣接に示される MAC ストリングは、次のように解釈できます。

45000000 -> Beginning of IP Header (Partially populated, tl & chksum
00000000 are fixed up per packet)
FF2FC3C7
7B010103 -> Source IP Address in transport network 209.165.200.253
7B010102 -> Destination IP address in transport network 209.165.200.252
00008847 -> GRE Header

 

MPLS レイヤ 3 VPN の設定に関する情報については、『 Cisco IOS Multiprotocol Label Switching Configuration Guide 』を参照してください。

show l3vpn encapsulation profile-name コマンドを使用すると、アプリケーションの基本的な状態に関する情報を取得できます。このコマンドの出力によって、トンネルおよび VRF への参照に関する詳細が示されます。

mGRE トンネルを使用した Dynamic L3 VPN サポートの設定例

ここでは、mGRE を介するレイヤ 3 VPN の設定例について説明します。

「レイヤ 3 VPN mGRE トンネルの設定:例」

レイヤ 3 VPN mGRE トンネルの設定:例

この例では、mGRE トンネルを作成する設定シーケンスを示します。特殊な VRF インスタンスの定義が含まれます。

ip vrf my riv
rd 1:1
interface Tunnel1
ip vrf forwarding my_riv
ip address 209.165.200.250 255.255.255.224
tunnel source Loopback0
tunnel mode gre multipoint l3vpn
tunnel key 123
end
ip route vrf my riv ip address subnet mask Tunnel1
 
router bgp 100
network 209.165.200.251
neighbor 209.165.200.250 remote-as 100
neighbor 209.165.200.250 update-source Loopback0
!
address-family vpnv4
neighbor 209.165.200.250 activate
neighbor 209.165.200.250 route-map SELECT_UPDATES_FOR_L3VPN_OVER_MGRE in
!
route-map SELECT UPDATES FOR L3VPN OVER MGRE permit 10
set ip next-hop in-vrf my riv

 

この例では、ルート マップをアプリケーションにリンクする設定を示します。

vrf definition Customer A
rd 100:110
route-target export 100:1000
route-target import 100:1000
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
vrf definition tunnel encap
rd 1:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
l3vpn encapsulation ip profile name
transport source loopback 0
protocol gre key 1234
!
!
interface Loopback0
ip address 209.165.200.252 255.255.255.224
ip router isis
!
interface Serial2/0
vrf forwarding Customer A
ip address 209.165.200.253 255.255.255.224
ipv6 address 3FFE:1001::/64 eui-64
no fair-queue
serial restart-delay 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 209.165.200.254 remote-as 100
neighbor 209.165.200.254 update-source Loopback0
!
address-family ipv4
no synchronization
redistribute connected
neighbor 209.165.200.254 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 209.165.200.254 activate
neighbor 209.165.200.254 send-community both
neighbor 209.165.200.254 route-map SELECT UPDATE FOR L3VPN in
exit-address-family
!
address-family vpnv6
neighbor 209.165.200.254 activate
neighbor 209.165.200.254 send-community both
neighbor 209.165.200.254 route-map SELECT UPDATE FOR L3VPN in
exit-address-family
!
address-family ipv4 vrf Customer A
no synchronization
redistribute connected
exit-address-family
!
address-family ipv6 vrf Customer A
redistribute connected
no synchronization
exit-address-family
!
!
route-map SELECT UPDATE FOR L3VPN permit 10
set ip next-hop encapulate <profile_name>
set ipv6 next-hop encapsulate <profile_name>

その他の参考資料

ダイナミック L3 VPN mGRE トンネルのその他の関連資料については、次の参考資料を参照してください。

関連資料

関連項目
参照先

MPLS Layer 3 VPN の設定

Cisco IOS Multiprotocol Label Switching Configuration Guide

MPLS VPN Over mGRE

Cisco IOS Interface and Hardware Component Configuration Guide

シスコ エクスプレス フォワーディング

Cisco IOS IP Switching Configuration Guide

総称ルーティング カプセル化

Cisco IOS Interface and Hardware Component Configuration Guide

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

IETF-PPVPN-MPLS-VPN-MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

RFC 2784

『Generic Routing Encapsulation (GRE)』

RFC 2890

Key Sequence Number Extensions to GRE

RFC 4023

Encapsulating MPLS in IP or Generic Routing Encapsulation

RFC 4364

『BGP/MPLS IP Virtual Private Networks (VPNs)』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

mGRE トンネル機能付きの Dynamic L3 VPN の機能情報

表 1-1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.0(23)S 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1-1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1-1 mGRE トンネル機能付きの Dynamic L3 VPN の機能情報

機能名
リリース
機能情報

マルチポイント GRE トンネルを使用したダイナミック レイヤ 3 VPN

12.0(23)S

この機能では、IP ネットワークで使用される拡張 mGRE トンネリング テクノロジーに基づいて、L3 トランスポート メカニズムが提供されます。