Cisco IOS ワイドエリア ネットワーキング コンフィ ギュレーション ガイド
PPP over Frame Relay
PPP over Frame Relay
発行日;2012/02/03 | 英語版ドキュメント(2011/07/31 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

PPP over Frame Relay

機能情報の確認

内容

PPP over Frame Relay の前提条件

PPP over Frame Relay の制約事項

PPP over Frame Relay について

PPP over Frame Relay の概要

利点

PPP over Frame Relay の設定方法

PPP over Frame Relay のイネーブル化

前提条件

PPP over Frame Relay の設定例

例:PPP over Frame Relay DTE

例:PPP over Frame Relay DCE

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

PPP over Frame Relay の機能情報

用語集

PPP over Frame Relay

PPP over Frame Relay 機能で、ルータでフレームリレー上にエンドツーエンド Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)セッションを確立できるようにします。

機能情報の確認

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「PPP over Frame Relay の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

PPP over Frame Relay の前提条件

PPP over Frame Relay を設定する前に、フレームリレーが encapsulation frame-relay コマンドを使用してルータでイネーブルになっている必要があります。

PPP over Frame Relay の制約事項

PPP over Frame Relay を使用する場合、次の制約事項が適用されます

フレームリレー Permanent Virtual Circuit(PVC; 相手先固定接続)のみがサポートされます。

Internet Protocol(IP; インターネット プロトコル)のみがサポートされます。

PPP over Frame Relay について

PPP over Frame Relay 機能を設定するには、次の概念を理解しておく必要があります。

「PPP over Frame Relay の概要」

PPP over Frame Relay の概要

PPP over Frame Relay 機能で、ルータでフレームリレー上にエンドツーエンド Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)セッションを確立できるようにします。IP データグラムは、RFC 1973 準拠のフレームリレー フレーム構成を使用して PPP リンクで送信されます。この機能は図 1 のように、リモート ユーザが PPP を実行してフレームリレー企業ネットワークにアクセスする際に利用できます。図 2 で、Cisco 90i D4 チャネル カードを使用した接続シナリオを示しています。このカードは、Integrated Services Digital Network(ISDN)Digital Service Loop(DSL; デジタル サービス ループ)、PPP、またはフレームリレーをサポート可能で、Internet Service Provider(ISP; インターネット サービス プロバイダー)または企業ネットワークに接続します。

図 1 PPP over Frame Relay のシナリオ

 

図 2 PPP over Frame Relay のフレーム形式

 

PPP over Frame Relay は、RFC 1973 で規定された機能およびカプセル化仕様に準拠しています。フレーム形式を図 3 に示します。

PPP 接続はフレームリレー PVC で確立されます。関連するフレームリレー PVC が「アクティブ」状態にならない限り、PPP セッションは発生しません。フレームリレー VC は、RFC 1490 やシスコ独自の異なるフレームリレーカプセル化方法を使用した他の回線と、同じフレームリレー リンク上で共存できます。複数のフレームリレー内 PPP 回線が 1 つのフレームリレー リンクに存在できます。

1 つの PPP 接続が、1 つの仮想アクセス インターフェイスに存在します。この接続は、仮想テンプレート インターフェイスから内部で作成されます。仮想アクセス インターフェイスは仮想テンプレート インターフェイスから複製されます。仮想アクセス インターフェイスは、対応する DLCI が設定された場合、フレームリレー回線の作成と共存します。1 つの仮想テンプレート インターフェイスは、必要なすべての PPP とネットワーク プロトコル情報が含まれており、複数の仮想アクセス インターフェイスで共有されます。ハードウェア圧縮と仮想キューイング アルゴリズム(重み付け均等化キューイング、カスタム キューイング、プライオリティ キューイングなど)は、仮想アクセス インターフェイスに適用されません。フレームリレー回線が PPP over Frame Relay を使用して確立されると、この回線のすべての着信および送信パケットは、この DLCI が設定から削除されるまで RFC 1973 PPP-in-Frame-Relay カプセル化に準拠します。

図 3 PPP over Frame Relay のフレーム形式

 

フレームリレー フレーム形式のコンポーネントの説明を、 表 1 に示します。

 

表 1 PPP フレームリレー形式の説明

フィールド
説明

Flag

フレームの開始または終了を示す 1 バイト。

Address

物理チャネル(DLCI)にマッピングされる論理接続を示す 2 バイト フィールド。

Control

ユーザ データの送信を要求する 1 バイト。PPP over Frame Relay では 0X03 の値を使用します。これは、フレームが Unnumbered Information(UI; アンナンバード インフォメーション)フレームであることを示します。

NLPID

シングル バイトのネットワーク層プロトコル ID で、フレームリレーへの PPP パケットを一意に特定します。

PPP protocol

PPP パケット タイプを識別します。

利点

PPP over Frame Relay には次の利点があります。

フレームリレー上のエンドツーエンド PPP セッションが可能。

ISDN DSL でフレームリレーと PPP の両方をサポートする 90i IDSL チャネル ユニットをサポート。

PPP over Frame Relay の設定方法

PPP over Frame Relay の実装に必要な作業は、ローカルで終了する PVC があるインターフェイスと、関連する PPP および IP の仮想テンプレートを設定するだけです。ここでは、次の作業について説明します。

「PPP over Frame Relay のイネーブル化」

PPP over Frame Relay のイネーブル化

PPP セッションを伝送し、適切な仮想テンプレート インターフェイスにリンクする物理インターフェイスを設定するには、次のタスクを実行します。

前提条件

Cisco ルータの設定後や、フレームリレーをカプセル化するサーバへのアクセス後、物理インターフェイスに PVC を設定し、PPP カプセル化を含む仮想テンプレートを、そのインターフェイスに適用する DLCI に適用する必要があります。

手順の概要

1. enable

2. configure terminal

3. interface type number . subinterface-number { multipoint | point-to-point }

4. frame-relay interface-dlci dlci [ ppp virtual-template-name-string ]

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number . subinterface-number { multipoint | point-to-point }

 

Router(config)# interface serial 2.1 point-to-point

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

frame-relay interface-dlci dlci [ ppp virtual-template-name-string ]

 

Router(config-if)# frame-relay interface-dlci

PVC を定義し、それを仮想テンプレートにマッピングします。

ステップ 5

end

 

Router(config-if)# exit

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

PPP over Frame Relay の設定例

ここでは、次の例について説明します。

例:PPP over Frame Relay DTE

例:PPP over Frame Relay DCE

例:PPP over Frame Relay DTE

次は、ルータを PPP over Frame Relay の Data Terminating Equipment(DTE; データ終端着信側機器)装置として設定します。サブインターフェイス 2.1 には、必要な DLCI と仮想テンプレート情報が含まれています。仮想テンプレート インターフェイス(interface virtual-template 1)には、シリアル サブインターフェイス 2.1 の DLCI 32 に関連付けられた PPP セッションに適用される PPP 情報が含まれています。

interface serial 2
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface serial 2.1 point-to-point
frame-relay interface-dlci 32 ppp virtual-template1
!
interface Virtual-Template1
ip unnumbered ethernet 0
ppp authentication chap pap

) デフォルトで、仮想テンプレート インターフェイスのカプセル化タイプは PPP カプセル化です。そのため、ルータで実行中の設定を表示しても encapsulation ppp コマンドは表示されません。


例:PPP over Frame Relay DCE

次は、ルータが Data Communications Equipment(DCE; データ通信装置)機器として動作するように設定した例です。一般に、ルータを他のルータに直接接続する場合や、電話会社のチャネル バンクの 90i D4 チャネル ユニットに接続する場合に、DCE として設定します。このタイプの設定には、 frame-relay switching frame-relay intf-type dce 、および frame-relay route コマンドの、3 つのコマンドが必要です。

frame-relay switching
!
interface Serial2/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 31 interface Serial1/2 100
frame-relay interface-dlci 32 ppp Virtual-Template1
!
interface Serial2/0:0.2 point-to-point
no ip address
frame-relay interface-dlci 40 ppp Virtual-Template2
!
interface Virtual-Template1
ip unnumbered Ethernet0/0
peer default ip address pool default
ppp authentication chap pap
!
interface Virtual-Template2
ip address 209.165.200.225 255.255.255.224
ppp authentication chap pap

) デフォルトで、仮想テンプレート インターフェイスのカプセル化タイプは PPP カプセル化です。そのため、ルータで実行中の設定を表示しても encapsulation ppp コマンドは表示されません。


参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

WAN コマンド

『Cisco IOS Wide-Area Networking Command Reference』

フレームリレーの設定

『Configuring Frame Relay』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1973

『PPP over Frame Relay』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。
以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する
この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

PPP over Frame Relay の機能情報

表 2 に、この機能のリリース履歴を示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 2 PPP over Frame Relay の機能情報

機能名
リリース
機能情報

PPP over Frame Relay

11.3(4)T
15.0(1)S

PPP over Frame Relay 機能で、ルータでフレームリレー上にエンドツーエンド PPP; セッションを確立できるようにします。

この機能に関する詳細については、次の各項を参照してください。

「PPP over Frame Relay について」

「PPP over Frame Relay の設定方法」

次のコマンドが導入または変更されました。 debug frame-relay ppp frame-relay interface-dlci show frame-relay pvc .

用語集

Data Link Connection Identifier(DLCI; データリンク接続識別子) :フレームリレー ネットワークの PVC または SVC を指定する値。基本的なフレームリレーの仕様では、DLCI はローカルで重要です(接続装置で、異なる値を使用して同じ接続を指定することができます)。LMI 拡張仕様では、DLCI はグローバルで重要です(DLCI はエンド デバイスを個別に指定します)。

Integrated Services Digital Network(ISDN): 電話会社が提供する通信プロトコルで、電話回線でのデータ、音声、その他の送信元トラフィックの伝送が可能。

Link Control Protocol (LCP; リンク コントロール プロトコル):PPP で使用されるデータリンク接続を確立、設定、テストするプロトコル。

Permanent Virtual Circuit(PVC; 相手先固定接続) :永続的に確立される仮想回線。PVC は、回線の確立に関連した帯域幅を節約し、特定の仮想回線が常に存在しなければならない状況をなくします。

Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル) :ポイントツーポイント リンク上のネットワーク層プロトコル情報をカプセル化するプロトコル。PPP 用の RFC は RFC 1661 です。

Virtual Circuit(VC; 仮想回線) 2 つのネットワーク デバイス間で信頼性の高い通信を確保するために作成される論理回線。仮想回線は固定(PVC)とスイッチド(SVC)があります。仮想回線は、フレームリレーおよび X.25 で使用されます。