Cisco IOS ワイドエリア ネットワーキング コンフィ ギュレーション ガイド
レイヤ 2 ローカル スイッチング
レイヤ 2 ローカル スイッチング
発行日;2012/02/06 | 英語版ドキュメント(2011/11/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

レイヤ 2 ローカル スイッチング

機能情報の確認

内容

レイヤ 2 ローカル スイッチングの前提条件

レイヤ 2 ローカル スイッチングの制限事項

Cisco 7200 および 7500 シリーズ ルータの制限事項

Cisco 7600 および 6500 シリーズ ルータの制限事項

Cisco 10000 シリーズ ルータの制限事項

ギガビット スイッチ ルータの制約事項

サポートされていないハードウェア

レイヤ 2 ローカル スイッチングに関する情報

レイヤ 2 ローカル スイッチングの概要

NSF/SSO:ローカル スイッチングの概要

レイヤ 2 ローカル スイッチングの用途

アクセス回線冗長性のローカル スイッチング

ATM-to-ATM ACR のローカル スイッチング

CEM-to-CEM ACR のローカル スイッチング

レイヤ 2 ローカル スイッチングの設定方法

ATM-to-ATM PVC ローカル スイッチングと同一ポート スイッチングの設定

ATM-to-ATM PVP ローカル スイッチングの設定

ATM PVP 同一ポート スイッチングの設定

ATM とイーサネット ポート モードの間のローカル スイッチングの設定

ATM とイーサネット VLAN モードの間のローカル スイッチングの設定

イーサネット VLAN の同一ポート スイッチングの設定

イーサネット ポート モードとイーサネット VLAN の間のローカル スイッチングの設定

ATM とフレームリレーの間のローカル スイッチングの設定

フレームリレーとフレームリレーの間のローカル スイッチングの設定

フレームリレー同一ポート スイッチングの設定

HDLC ローカル スイッチングの設定

制約事項

前提条件

ATM-to-ATM ACR のローカル スイッチングの設定

CEM-to-CEM ACR のローカル スイッチングの設定

レイヤ 2 ローカル スイッチングの確認

レイヤ 2 ローカル スイッチングの設定の確認

NSF/SSO ローカル スイッチングの設定の確認

トラブルシューティングのヒント

レイヤ 2 ローカル スイッチングの設定例

例:ATM-to-ATM ローカル スイッチング

例:ATM PVC 同一ポート スイッチング

例:ATM PVP 同一ポート スイッチング

例:ATM とイーサネット間のローカル スイッチング

例:ATM とイーサネット VLAN 間

例:ATM とイーサネット ポート モード間

例:イーサネット VLAN の同一ポート スイッチング

例:ATM とフレームリレー間のローカル スイッチング

例:フレームリレーとフレームリレー間のローカル スイッチング

例:フレームリレー DLCI 同一ポート スイッチング

例:HDLC ローカル スイッチング

例:NSF/SSO:イーサネット ポート モードとイーサネット VLAN 間のローカル スイッチング

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

レイヤ 2 ローカル スイッチングの機能情報

レイヤ 2 ローカル スイッチング

レイヤ 2 ローカル スイッチング機能を使用すると、次の 2 つの方法でレイヤ 2 データをスイッチングできます。

同じルータ上の 2 つのインターフェイス間

同じインターフェイス ポート上の 2 つの回線間(同一ポート スイッチングと呼びます)

この機能でサポートされるインターフェイス間のスイッチングの組み合わせは、次のとおりです。

ATM と ATM の間

ATM とイーサネットの間

ATM とフレームリレーの間

イーサネットとイーサネット VLAN の間

フレームリレーとフレームリレー(および Cisco IOS Release 12.0(28)S 以降ではマルチリンク フレームリレー)の間

High-Level Data Link Control(HDLC; ハイレベル データリンク コントロール)

次の同一ポート スイッチング機能がサポートされています。

ATM Permanent Virtual Circuit(PVC; 相手先固定接続)および Permanent Virtual Path(PVP; 相手先固定パス)

イーサネット VLAN

フレームリレー

機能情報の確認

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「レイヤ 2 ローカル スイッチングの機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

レイヤ 2 ローカル スイッチングの前提条件

Cisco 7200 シリーズ ルータの場合、Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)をイネーブルにする必要があります。Cisco 7500 シリーズ ルータの場合、シスコ エクスプレス フォワーディングまたは Distributed Cisco Express Forwarding(dCEF; 分散型 CEF)をイネーブルにする必要があります(分散型 CEF は、Gigabit Switch Router(GSR; ギガビット スイッチ ルータ)ではデフォルトでイネーブルになっています)。

フレームリレー ローカル スイッチングの場合、 frame-relay switching コマンドをグローバルに実行する必要があります。

レイヤ 2 ローカル スイッチングの制限事項

以降のセクションでは、レイヤ 2 ローカル スイッチング機能の制限事項について説明します。

「Cisco 7200 および 7500 シリーズ ルータの制限事項」

「Cisco 7600 および 6500 シリーズ ルータの制限事項」

「Cisco 7600 および 6500 シリーズ ルータの制限事項」

「Cisco 10000 シリーズ ルータの制限事項」

「ギガビット スイッチ ルータの制約事項」

「サポートされていないハードウェア」

Cisco 7200 および 7500 シリーズ ルータの制限事項

ATM シングル セル リレー AAL0 では、ATM Virtual Path Identifier/Virtual Channel Identifier(VPI/VCI; 仮想パス識別子/仮想チャネル識別子)の値が、Cisco 7200 シリーズおよび 7500 シリーズ ルータの入力および出力 ATM インターフェイス間で一致している必要があります。値が一致せず、2 つの異なるインターフェイス上にある 2 つの ATM VPI と VCI の間でレイヤ 2 ローカル スイッチングが必要な場合は、ATM AAL5 を選択してください。ただし、ATM AAL5 が Operation, Administration, and Maintenance(OAM; 運用管理および保守)トランスペアレント モードを使用している場合、VPI と VCI の値は一致する必要があります。

NSF/SSO:レイヤ 2 ローカル スイッチングは、Cisco 7500 シリーズ ルータでサポートされています。

レイヤ 2 ローカル スイッチングは、Cisco 7200 シリーズ ルータの次のインターフェイス プロセッサでサポートされています。

C7200-I/O-2FE

C7200-I/O-GE+E(このポート アダプタのギガビット イーサネット ポートだけがサポートされます)

C7200-I/O-FE

レイヤ 2 ローカル スイッチングは、Cisco 7500 シリーズ ルータの次のインターフェイス プロセッサでサポートされます。

GEIP(ギガビット イーサネット インターフェイス プロセッサ)

GEIP+(拡張ギガビット イーサネット インターフェイス プロセッサ)

レイヤ 2 ローカル スイッチングは、Cisco 7200 および 7500 シリーズ ルータの次のポート アダプタでサポートされています。

PA-FE-TX(シングル ポート ファスト イーサネット 100BASE-TX)

PA-FE-FX(シングル ポート ファスト イーサネット 100BASE-FX)

PA-2FE-TX(デュアル ポート ファスト イーサネット 100BASE-TX)

PA-2FE-FX(デュアル ポート ファスト イーサネット 100BASE-FX)

PA-4E(4 ポート イーサネット アダプタ)

PA-8E(8 ポート イーサネット アダプタ)

PA-4T(4 ポート同期シリアル ポート アダプタ)

PA-4T+(拡張 4 ポート同期シリアル ポート アダプタ)

PA-8T(8 ポート同期シリアル ポート アダプタ)

PA-12E/2FE(12 ポート イーサネット/2 ポート ファスト イーサネット アダプタ)(Cisco 7200 のみ)

PA-GE(ギガビット イーサネット ポート アダプタ)(Cisco 7200 のみ)

PA-H(シングル ポート High-Speed Serial Interface(HSSI)アダプタ)

PA-2H(デュアル ポート HSSI アダプタ)

PA-MC-8E1(8 ポート マルチチャネル E1 G.703/G.704 120Ω インターフェイス)

PA-MC-2EI(2 ポート マルチチャネル E1 G.703/G.704 120Ω インターフェイス)

PA-MC-8T1(8 ポート マルチチャネル T1、Data Service Units(DSU; データ サービス ユニット)および Channel Service Units(CSU; チャネル サービス ユニット)内蔵)

PA-MC-4T1(4 ポート マルチチャネル T1、CSU および DSU 内蔵)

PA-MC-2T1(2 ポート マルチチャネル T1、CSU および DSU 内蔵)

PA-MC-8TE1+(8 ポート マルチチャネル T1/E1)

PA-MC-T3(1 ポート マルチチャネル T3 インターフェイス)

PA-MC-E3(1 ポート マルチチャネル E3 インターフェイス)

PA-MC-2T3+(2 ポート拡張マルチチャネル T3 ポート アダプタ)

PA-MC-STM1(1 ポート マルチチャネル STM-1 ポート アダプタ)(Cisco 7500 のみ)

PA-T3(シングル ポート T3 ポート アダプタ)

PA-E3(シングル ポート E3 ポート アダプタ)

PA-2E3(2 ポート E3 ポート アダプタ)

PA-2T3(2 ポート T3 ポート アダプタ)

PA-POS-OC-3SML(シングル ポート Packet over SONET(POS)、シングルモード、ロング リーチ)

PA-POS-OC-3SMI(シングル ポート PoS、シングルモード、中距離)

PA-POS-OC-3MM(シングル ポート PoS、マルチモード)

PA-A3-OC-3(1 ポート ATM OC-3/STM1 ポート アダプタ、拡張)

PA-A3-OC-12(1 ポート ATM OC-12/STM-4 ポート アダプタ、拡張)(Cisco 7500 のみ)

PA-A3-T3(DS3 高速インターフェイス)

PA-A3-E3(E3 中速インターフェイス)

PA-A3-8T1IMA(ATM Inverse Multiplexer over ATM(IMA; ATM の逆多重化)ポート アダプタ、8 T1 ポート)

PA-A3-8E1IMA(ATM Inverse Multiplexer over ATM(IMA; ATM の逆多重化)ポート アダプタ、8 E1 ポート)

PA-A6(Cisco ATM ポート アダプタ)

Cisco 7600 および 6500 シリーズ ルータの制限事項

レイヤ 2 ローカル スイッチングは、Cisco 7600-SUP720/MSFC3 ルータ上で、次のポート アダプタとインターフェイス プロセッサをサポートしています。

拡張 FlexWAN モジュール上のすべてのポート アダプタ

SIP-200 ラインカード上のすべての Shared Port Adapter(SPA; 共有ポート アダプタ)

Cisco 6500 シリーズおよび 7600 シリーズ ルータでは、 like-to-like ローカル スイッチングだけがサポートされています(ATM と ATM の間およびフレームリレーとフレームリレーの間)。

同一ポート スイッチングは、Cisco 6500 シリーズおよび 7600 シリーズ ルータではサポートされていません。

Cisco 10000 シリーズ ルータの制限事項

Cisco 10000 シリーズ ルータでのレイヤ 2 ローカル スイッチングの詳細については、『 Configuring Layer 2 Local Switching 』を参照してください。

ギガビット スイッチ ルータの制約事項

VPI/VCI の書き換えがサポートされています。

すべての GSR ラインカードで、フレームリレーとフレームリレーの間のローカル スイッチングがサポートされています。

8 ポート OC-3 ATM エンジン 2 ラインカードでは、like-to-like のレイヤ 2 ローカル スイッチングだけがサポートされています。

IP Service Engine(ISE; IP サービス エンジン)(エンジン 3)ラインカードでは、like-to-like および any-to-any ローカル スイッチングがサポートされています。ISE 以外のラインカードでは、like-to-like ローカル スイッチングだけがサポートされています。

Cisco IOS Release 12.0(31)S2 から、ISE カスタマー エッジ側インターフェイスで、次の種類の like-to-like および any-to-any ローカル スイッチングがサポートされるようになりました。

ATM と ATM の間

ATM とイーサネットの間

ATM とフレームリレーの間

イーサネットとイーサネット VLAN の間

フレームリレーとフレームリレーの間(マルチリンク フレームリレーを含む)

ATM の同一ポート スイッチング(PVC および PVP)

イーサネット VLAN の同一ポート スイッチング

フレームリレーの同一ポート スイッチング


) カスタマー エッジ側ラインカード上のネイティブ Layer 2 Tunnel Protocol Version 3(L2TPv3; レイヤ 2 トンネリング プロトコル バージョン 3)トンネル セッションは、トンネルサーバ カードを使用するトンネル セッションと共存できます。


Cisco IOS Release 12.0(32)SY から、エンジン 5 SPA および SPA Interface Processor(SIP; SPA インターフェイス プロセッサ)上のカスタマー エッジ側インターフェイスで、次の種類の like-to-like ローカル スイッチングがサポートされるようになりました。

イーサネットとイーサネット VLAN の間

フレームリレーとフレームリレーの間(マルチリンク フレームリレーを含む)

イーサネット VLAN の同一ポート スイッチング

フレームリレーの同一ポート スイッチング

ATM-to-ATM ローカル スイッチングでは、レイヤ 2 ローカル スイッチング機能で次の ATM タイプがサポートされています。

ATM Adaptation Layer 5(AAL5; ATM アダプテーション レイヤ 5)

ATM シングル セル リレー アダプテーション レイヤ 0(AAL0)、VC モード

GSR 上の ATM シングル セル リレー VP モード

GSR 上の ISE ラインカード上の ATM シングル セル リレー VC および VP モード

Cisco IOS Release 12.0(30)S から、GSR の IP Services Engine(ISE/エンジン 3)ラインカード上で、ローカル スイッチングとセル パッキングを ATM VP または VC モードで使用できるようになりました。セル パッキングの設定方法については、『 Any Transport over MPLS 』を参照してください。

サポートされていないハードウェア

次のハードウェアはサポートされていません。

Cisco 7200:非 VXR シャーシ

Cisco 7500:Route Switch Processor(RSP; ルート スイッチ プロセッサ)1 および 2

Cisco 7500:Versatile Interface Processor(VIP)2-40 およびそれ以前

GSR:4 ポート OC-3 ATM エンジン 0 ラインカード

GSR:4 ポート OC-12 ATM エンジン 2 ラインカード

GSR:1 ポート OC-12 ATM エンジン 0 ラインカード

GSR:イーサネット エンジン 1、エンジン 2、およびエンジン 4 ラインカード

レイヤ 2 ローカル スイッチングに関する情報

レイヤ 2 ローカル スイッチング機能を設定するには、次のことを理解する必要があります。

概念

「レイヤ 2 ローカル スイッチングの概要」

「NSF/SSO:ローカル スイッチングの概要」

「レイヤ 2 ローカル スイッチングの用途」

「アクセス回線冗長性のローカル スイッチング」

レイヤ 2 ローカル スイッチングの概要

ローカル スイッチングを使用すると、同じルータ上の種類が同じ 2 つのインターフェイスの間(たとえば、ATM と ATM の間、フレームリレーとフレームリレーの間)か、種類の異なるインターフェイスの間(たとえば、フレームリレーと ATM の間)で、レイヤ 2 データをスイッチングできます。インターフェイスは、同じラインカード上にあっても 2 つの異なるカード上にあってもかまいません。スイッチングの際には、レイヤ 3 アドレスではなくレイヤ 2 アドレスが使用されます。

また、同一ポートのローカル スイッチング機能を使用すると、 同じ インターフェイス上の 2 つの回線の間でレイヤ 2 データをスイッチングできます。

NSF/SSO:ローカル スイッチングの概要

Nonstop Forwarding(NSF; ノンストップ フォワーディング)と Stateful Switchover(SSO; ステートフル スイッチオーバー)を使用すると、冗長な Route Processors(RP; ルート プロセッサ)とデータのチェックポイントを使用し、プライマリ RP が障害になったときのパケット損失が最小となるようにすることで、ネットワークのアベイラビリティが向上します。NSF/SSO のサポートは、次のローカルにスイッチングされる接続回線で使用できます。

イーサネットとイーサネット VLAN の間

フレームリレーとフレームリレーの間

レイヤ 2 ローカル スイッチングの用途

2 つの地域通信事業者間でトラフィックを伝送するために Interexchange Carrier(IXC; 中継キャリア)を利用する Incumbent Local Exchange Carrier(ILEC; 既存地域通信事業者)は、レイヤ 2 ローカル スイッチング機能を使用できます。電気通信規制では、トラフィックを伝送するための IXC の費用を ILEC が支払うことになっています。場合によって、ILEC は異なる Local Access and Transport Area(LATA; ローカル アクセスおよびトランスポート エリア)にあるカスタマー接続を終端できないことがあります。また、カスタマー接続が、同じルータ上にある同じ LATA で終端する場合もあります。

たとえば、企業 A に、国内全体にわたる 50 を超える LATA があり、各 LATA で 3 台のルータを使用しているとします。企業 A は、地域通信事業者間でトラフィックを伝送するために、企業 B と C を利用しています。この場合、同じルータ上でレイヤ 2 フレームのローカル スイッチングが必要になることがあります。

同様に、ルータがたとえばチャネライズド インターフェイスをしている場合、受信および送信トラフィックを、1 つの物理ポートに存在する 2 つの論理インターフェイス上でスイッチングすることが必要になる場合があります。同一ポート ローカル スイッチング機能は、そのような実装に対応しています。

図 1 に、フレームリレーとフレームリレーの間、および ATM とフレームリレーの間のローカル スイッチングを使用するネットワークを示します。

図 1 ローカル スイッチングの例

 

アクセス回線冗長性のローカル スイッチング

Automatic Protection Switching(APS; 自動保護スイッチング)メカニズムによって、50 ミリ秒以下のスイッチオーバーが実現されます。ただし、疑似配線設定では、疑似配線がスイッチオーバー時に起動状態になるまで時間を要するため、スイッチオーバーに時間がかかります。運用インターフェイスと保護インターフェイスでそれぞれ個別に疑似配線が設定されているのではなく、単一の疑似配線が適用されている場合、疑似配線のスイッチオーバーにかかる時間が短縮される可能性があります。疑似配線が単一の場合、スイッチオーバーにおける Label Distribution Protocols(LDP; ラベル配布プロトコル)のネゴシエーションも不要になります。仮想インターフェイスまたはコントローラ モデルによって、Provider Edge(PE; プロバイダー エッジ)ルータ間に単一の疑似配線を設定できます。

Access Circuit Redundancy(ACR; アクセス回線冗長性)を使用すると、スイッチオーバーの時間を短縮してデータ トラフィックのダウンタイムを削減することができます。ACR は、各冗長回線ペアが運用回線と保護回線から成る APS 1+1、非リバーティブ モデルで利用できます。信号障害状態または信号劣化が検出されると、ハードウェアによって運用回線から保護回線にスイッチングされます。

運用インターフェイスと保護インターフェイスは、次のように配置できます。

同一の SPA 上

異なる SPA 上の同じラインカード上

異なる SPA 上の異なるラインカード上

運用インターフェイスと保護インターフェイスに ACR が設定されると、仮想インターフェイスが作成され、インターフェイス間のデータのスイッチングを加速するため、仮想インターフェイス間で接続が確立されます。

ここでは、次の内容について説明します。

「ATM-to-ATM ACR のローカル スイッチング」

「CEM-to-CEM ACR のローカル スイッチング」

ATM-to-ATM ACR のローカル スイッチング

ATM-to-ATM ACR のローカル スイッチングでは、ATM AAL5 および ATM AAL0 カプセル化タイプがサポートされており、L2 トランスポート Virtual Circuit(VC; 仮想回線)間のレイヤ 2 データがスイッチングされます。


) L2 トランスポート VC は双方とも、同じカプセル化タイプが設定されている必要があります。


図 2 に、ATM-to-ATM ACR のローカル スイッチング モデルを示します。

図 2 ATM-to-ATM ACR のローカル スイッチング モデル

 

この図では次のようになっています。

ATM 1/0/0 と ATM 9/0/0 が、ACR 1 グループの運用インターフェイスおよび保護インターフェイスとして設定されています。

ATM 7/1/0 と ATM 9/1/0 が、ACR 2 グループの運用インターフェイスおよび保護インターフェイスとして設定されています。

ACR 間で接続が確立されています。

Add/Drop Multiplexer(ADM; アド/ドロップ マルチプレクサ)によって ACR グループ ACR 1 の一部である両インターフェイスにデータが送信されます。

ACR グループ 1 の APS アクティブ インターフェイス VC(0/32)で受信したセルまたはパケットは ACR 2 インターフェイス VC(1/32)にスイッチングされ、APS 非アクティブ インターフェイスからのセルまたはパケットはドロップされます。

ACR 2 VC(1/32)インターフェイスで受信したパケットは、ACR グループ ACR 2 の一部である両物理インターフェイスに複製されます。

CEM-to-CEM ACR のローカル スイッチング

Circuit Emulation(CEM; 回線エミュレーション)によって、Time Division Multiplexing(TDM; 時分割多重)データが TDM 疑似配線を介して転送されます。これにより、モバイル オペレータは TDM トラフィックを IP または Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークを介して伝送できるようになります。CEM-to-CEM ACR では、仮想コントローラを作成して、この仮想コントローラを物理コントローラに関連付けます。APS と ACR が物理コントローラに設定されると仮想コントローラが作成されます。仮想コントローラで実行されたコマンドはすべて、運用コントローラと保護コントローラに適用されます。仮想コントローラによって設定の一元化が簡素化され、柔軟性が増すため、障害が発生しても保護コントローラでバックアップ疑似配線を実行する必要がなくなります。このように疑似配線間でスイッチオーバーが実施されないので、物理リンクで障害が発生した際の復旧時間が短縮されます。

CEM グループが仮想コントローラに設定されると、仮想 CEM-ACR インターフェイスが作成され、CEM 回線に関連付けられます。ACR によって、同じ ACR グループに属する物理コントローラに対応する物理インターフェイスに CEM インターフェイスと CEM 回線が作成されます。

図 3 に、CEM-to-CEM ACR のローカル スイッチング モデルを示します。

図 3 CEM-to-CEM ACR のローカル スイッチング モデル

 

この図では次のようになっています。

ADM からパケットを受信します。APS 非アクティブ インターフェイスからのパケットはドロップされ、APS アクティブ インターフェイスで受信したパケットはスイッチングされます。

ACR グループ 1 の一部である APS アクティブ インターフェイスの CEM 回線 ID 1 で受信したパケットは、ACR グループ 2 の一部である APS アクティブ インターフェイスの CEM 回線 ID 2 にスイッチングされます。

パケットは複製され、ACR グループ 2 の一部である APS アクティブ物理 CEM インターフェイスおよび非アクティブ物理 CEM インターフェイスで送信されます。

レイヤ 2 ローカル スイッチングの設定方法

以降のセクションでは、それぞれの種類のレイヤ 2 ローカル スイッチングを設定する方法について説明します。

「ATM-to-ATM PVC ローカル スイッチングと同一ポート スイッチングの設定」(任意)

「ATM-to-ATM PVP ローカル スイッチングの設定」(任意)

「ATM PVP 同一ポート スイッチングの設定」(任意)

「ATM とイーサネット ポート モードの間のローカル スイッチングの設定」(任意)

「ATM とイーサネット VLAN モードの間のローカル スイッチングの設定」(任意)

「イーサネット VLAN の同一ポート スイッチングの設定」(任意)

「イーサネット ポート モードとイーサネット VLAN の間のローカル スイッチングの設定」(任意)

「ATM とフレームリレーの間のローカル スイッチングの設定」(任意)

「フレームリレーとフレームリレーの間のローカル スイッチングの設定」(任意)

「フレームリレー同一ポート スイッチングの設定」(任意)

「HDLC ローカル スイッチングの設定」(任意)

「ATM-to-ATM ACR のローカル スイッチングの設定」(任意)

「CEM-to-CEM ACR のローカル スイッチングの設定」(任意)

「レイヤ 2 ローカル スイッチングの確認」(任意)

Cisco 10000 シリーズ ルータでのレイヤ 2 ローカル スイッチングの詳細については、『 Configuring Layer 2 Local Switching 』を参照してください。

ATM-to-ATM PVC ローカル スイッチングと同一ポート スイッチングの設定

カプセル化タイプ ATM AAL5 および ATM AAL0 に対してローカル スイッチングを設定できます。

ATM PVC の作成は必須ではありません。PVC を作成しない場合、自動的に作成されます。ATM-to-ATM ローカル スイッチングでは、自動的にプロビジョニングされた PVC にデフォルトのカプセル化タイプ AAL0 のセル リレーが設定されます。


) Cisco IOS Release 12.0(30)S から、このセクションの手順に従って同一ポート スイッチングを設定できるようになりました。


ATM-to-ATM PVC ローカル スイッチングと同一ポート スイッチングを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface atm slot / port

4. pvc vpi / vci l2transport

5. encapsulation layer-type

6. exit

7. exit

8. connect connection-name interface pvc interface pvc

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm slot / port

 

Router(config)# interface atm1/0

ATM ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

pvc vpi / vci l2transport

 

Router(config-if)# pvc 1/200 l2transport

VPI と VCI を割り当て、ATM PVC l2transport コンフィギュレーション モードを開始します。

l2transport キーワードは、PVC が終端 PVC ではなくスイッチド PVC であることを示します。

ステップ 5

encapsulation layer-type

 

Router(cfg-if-atm-l2trans-pvc)# encapsulation aal5

ATM PVC のカプセル化タイプを指定します。AAL0 と AAL5 がサポートされています。

同じルータ上の別の ATM PVC に対して手順 3 ~ 5 を繰り返します。

ステップ 6

exit

 

Router(cfg-if-atm-l2trans-pvc)# exit

PVC l2transport コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

connect connection-name interface pvc interface pvc

 

Router(config)# connect atm-con atm1/0/0 0/100 atm2/0/0 0/100

指定した 2 つの相手先固定接続の間にローカル接続を作成します。

ATM-to-ATM PVP ローカル スイッチングの設定

ATM-to-ATM PVP ローカル スイッチングを設定するには、次の作業を実行します。

Cisco IOS Release 12.0(30)S から、「ATM PVP 同一ポート スイッチングの設定」で説明する同一ポート スイッチングが使用できるようになりました。

手順の概要

1. enable

2. configure terminal

3. interface atm slot / port

4. atm pvp vpi l2transport

5. exit

6. exit

7. connect connection-name interface pvp interface pvp

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm slot / port

 

Router(config)# interface atm1/0

ATM ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

atm pvp vpi l2transport

 

Router(config-if)# atm pvp 100 l2transport

仮想パスを指定し、PVP l2transport コンフィギュレーション モードを開始します。 l2transport キーワードは、PVP が終端 PVP ではなくスイッチド PVP であることを示します。

同じルータ上の別の ATM 相手先固定パスに対して手順 3 と 4 を繰り返します。

ステップ 5

exit

 

Router(config-if-atm-l2trans-pvp)# exit

PVP l2transport コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 6

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 7

connect connection-name interface pvp interface pvp

 

Router(config)# connect atm-con

atm1/0 100 atm2/0 200

グローバル コンフィギュレーション モードで、指定した 2 つの相手先固定パスの間にローカル接続を作成します。

ATM PVP 同一ポート スイッチングの設定

ATM インターフェイス上で ATM PVP スイッチングを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface atm slot / subslot / port

4. atm pvp vpi l2transport

5. exit

6. exit

7. connect connection-name interface pvp interface pvp

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm slot / subslot / port

 

Router(config)# interface atm1/0/0

ATM ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

atm pvp vpi l2transport

 

Router(config-if)# atm pvp 100 l2transport

1 つの VPI を指定し、PVP l2transport コンフィギュレーション モードを開始します。この同じポート上の他の ATM 相手先固定パスに対し、このステップを繰り返します。

l2transport キーワードは、指定した PVP が終端 PVP ではなくスイッチド PVP であることを示します。

ステップ 5

exit

 

Router(config-if-atm-l2trans-pvp)# exit

PVP l2transport コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 6

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 7

connect connection-name interface pvp interface pvp

 

Router(config)# connect atm-con atm1/0/0 100 atm1/0/0 200

グローバル コンフィギュレーション モードで、指定した 2 つの相手先固定パスの間にローカル接続を作成します。

ATM とイーサネット ポート モードの間のローカル スイッチングの設定

ATM とイーサネット ポート モードの間のローカル スイッチングでは、ATM PVC の作成は必須ではありません。PVC を作成しない場合、自動的に作成されます。ATM とイーサネットの間のローカル スイッチングでは、自動的にプロビジョニングされた PVC にデフォルトのカプセル化タイプ AAL5SNAP が設定されます。

ATM とイーサネットの間のローカル スイッチングでは、IP インターワーキング タイプとイーサネット インターワーキング タイプの両方がサポートされます。イーサネット インターワーキング タイプを使用する場合、インターワーキング デバイス(ルータ)はブリッジド パケットを期待します。そのため、ATM CPE を IRB または RBE 用に設定します。


) イーサネット側で ICMP Router Discovery Protocol(RDP)をイネーブルにすることを推奨します。


ATM とイーサネットの間のローカル スイッチングでは、次のカプセル化タイプがサポートされています。

ATM とイーサネットの間、IP インターワーキング:AAL5SNAP、AAL5MUX

ATM とイーサネットの間、イーサネット インターワーキング:AAL5SNAP

ATM とイーサネット ポート モードの間のローカル スイッチングを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface atm slot / port

4. pvc vpi / vci l2transport

5. encapsulation layer-type

6. exit

7. exit

8. interface fastethernet slot / subslot / port

9. exit

10. connect connection-name interface pvc interface [ interworking ip | ethernet ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm slot / port

 

Router(config)# interface atm1/0

ATM ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

pvc vpi / vci l2transport

 

Router(config-if)# pvc 1/200 l2transport

VPI と VCI を割り当て、PVC l2transport コンフィギュレーション モードを開始します。

l2transport キーワードは、PVC が終端 PVC ではなくスイッチド PVC であることを示します。

ステップ 5

encapsulation layer-type

 

Router(cfg-if-atm-l2trans-pvc)# encapsulation aal5snap

PVC のカプセル化タイプを指定します。

ステップ 6

exit

 

Router(config-if-atm-l2trans-pvc)# exit

PVC l2transport コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface fastethernet slot / subslot / port

 

Router(config)# interface fastethernet6/0/0

ファスト イーサネット ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 10

connect connection-name interface pvc interface [ interworking ip | ethernet ]
 

Router(config)# connect atm-eth-con atm1/0 0/100 fastethernet6/0/0 interworking ethernet

グローバル コンフィギュレーション モードで、2 つのインターフェイス間にローカル接続を作成し、インターワーキング タイプを指定します。

インターワーキング タイプとしては、IP とイーサネットの両方がサポートされています。

ATM とイーサネット VLAN モードの間のローカル スイッチングの設定

ATM とイーサネット VLAN モードの間のローカル スイッチングでは、ATM PVC の作成は必須ではありません。PVC を作成しない場合、自動的に作成されます。ATM とイーサネットの間のローカル スイッチングでは、自動的にプロビジョニングされた PVC にデフォルトのカプセル化タイプ AAL5SNAP が設定されます。

ATM とイーサネットの間のローカル スイッチングでは、IP インターワーキング タイプとイーサネット インターワーキング タイプの両方がサポートされます。イーサネット インターワーキング タイプを使用する場合、インターワーキング デバイス(ルータ)はブリッジド パケットを期待します。そのため、ATM CPE を IRB または RBE 用に設定します。


) イーサネット側で ICMP Router Discovery Protocol(RDP)をイネーブルにすることを推奨します。


ATM とイーサネットの間のローカル スイッチングでは、次のカプセル化タイプがサポートされています。

ATM とイーサネットの間、IP インターワーキング:AAL5SNAP、AAL5MUX

ATM とイーサネットの間、イーサネット インターワーキング:AAL5SNAP

イーサネット サブインターフェイス上で受信したフレームから、VLAN ヘッダーが削除されます。

VLAN モードで ATM とイーサネットの間のローカル スイッチングを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface atm slot / subslot / port

4. pvc vpi / vci l2transport

5. encapsulation layer-type

6. exit

7. interface fastethernet slot / port / subinterface-number

8. encapsulation dot1q vlan-id

9. exit

10. connect connection-name interface pvc interface [ interworking ip | ethernet ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm slot / subslot / port

 

Router(config)# interface atm1/0/0

ATM ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

pvc vpi / vci l2transport

 

Router(config-if)# pvc 1/200 l2transport

VPI と VCI を割り当て、PVC l2transport コンフィギュレーション モードを開始します。

l2transport キーワードは、PVC が終端 PVC ではなくスイッチド PVC であることを示します。

ステップ 5

encapsulation layer-type

 

Router(cfg-if-atm-l2trans-pvc)# encapsulation aal5snap

PVC のカプセル化タイプを指定します。

ステップ 6

exit

 

Router(cfg-if-atm-l2trans-pvc)# exit

PVC l2transport コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 7

interface fastethernet slot / port / subinterface-number

 

Router(config-if)# interface fastethernet6/0/0.1

ファスト イーサネット ラインカード、サブスロット(使用可能な場合)、ポート、およびサブインターフェイスを指定し、サブインターフェイス コンフィギュレーション モードを開始します。

ステップ 8

encapsulation dot1q vlan-id

 

Router(config-subif)# encapsulation dot1q 100

802.1Q VLAN パケットを受け付けるようにインターフェイスをイネーブルにします。

ステップ 9

exit

 

Router(config-subif)# exit

サブインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 10

connect connection-name interface pvc interface [ interworking ip | ethernet ]

 

Router(config)# connect atm-eth-vlan-con atm1/0/0 0/100 fastethernet6/0/0.1 interworking ethernet

グローバル コンフィギュレーション モードで、2 つのインターフェイス間にローカル接続を作成し、インターワーキング タイプを指定します。

インターワーキング タイプとしては、IP とイーサネットの両方がサポートされています。

イーサネット VLAN の同一ポート スイッチングの設定

イーサネット VLAN の同一ポート スイッチングを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface fastethernet slot / port . subinterface-number

4. encapsulation dot1q vlan-id

5. exit

6. interface fastethernet slot / port . subinterface-number

7. encapsulation dot1q vlan-id

8. exit

9. connect connection-name interface interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface fastethernet slot / port.subinterface-number

 

Router(config)# interface fastethernet6/0.1

1 つ目のファスト イーサネット ラインカード、サブスロット(使用可能な場合)、ポート、およびサブインターフェイスを指定し、サブインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation dot1q vlan-id

 

Router(config-subif)# encapsulation dot1q 10

サブインターフェイスで 802.1Q VLAN パケットの受信をイネーブルにし、1 つ目の VLAN を指定します。

ステップ 5

exit

 

Router(config-subif)# exit

サブインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

interface fastethernet slot / port.subinterface-number

 

Router(config)# interface fastethernet6/0.2

グローバル コンフィギュレーション モードで、2 つ目のファスト イーサネット ラインカード、サブスロット(使用可能な場合)、ポート、およびサブインターフェイスを指定し、サブインターフェイス コンフィギュレーション モードを開始します。

ステップ 7

encapsulation dot1q vlan-id

 

Router(config-subif)# encapsulation dot1q 20

サブインターフェイスで 802.1Q VLAN パケットの受信をイネーブルにし、2 つ目の VLAN を指定します。

ステップ 8

exit

 

Router(config-subif)# exit

サブインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 9

connect connection-name interface interface

 

Router(config)# connect conn fastethernet6/0.1 fastethernet6/0.2

グローバル コンフィギュレーション モードで、同じファスト イーサネット ポート上の 2 つのサブインターフェイスの間(つまり、上で指定したその VLAN の間)にローカル接続を作成します。

イーサネット ポート モードとイーサネット VLAN の間のローカル スイッチングの設定

イーサネット(ポート モード)とイーサネット VLAN の間のローカル スイッチングを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface fastethernet slot / subslot / port

4. interface fastethernet slot / port / subinterface-number

5. encapsulation dot1q vlan-id

6. exit

7. connect connection-name interface interface [ interworking ip | ethernet ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface fastethernet slot / subslot / port

 

Router(config)# interface fastethernet3/0/0

ファスト イーサネット ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。これは、PE ルータの一方の側にある、Customer Edge(CE; カスタマー エッジ)ルータとの間でイーサネット パケットをやり取りするインターフェイスです。

ステップ 4

interface fastethernet slot / port / subinterface-number

 

Router(config)# interface fastethernet6/0/0.1

ファスト イーサネット ラインカード、サブスロット(使用可能な場合)、ポート、およびサブインターフェイスを指定し、サブインターフェイス コンフィギュレーション モードを開始します。これは、PE ルータの他方の側にある、CE ルータとの間でイーサネット VLAN パケットをやり取りするインターフェイスです。

ステップ 5

encapsulation dot1q vlan-id

 

Router(config-subif)# encapsulation dot1q 100

802.1Q VLAN パケットを受け付けるようにインターフェイスをイネーブルにします。

ステップ 6

exit

 

Router(config-subif)# exit

サブインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 7

connect connection-name interface interface [ interworking ip | ethernet ]

 

Router(config)# connect eth-ethvlan-con fastethernet3/0/0 fastethernet6/0/0.1 interworking ethernet

2 つのインターフェイス間にローカル接続を作成し、インターワーキング タイプを指定します。

インターワーキング タイプとしては、IP とイーサネットの両方がサポートされています。

ATM とフレームリレーの間のローカル スイッチングの設定

ATM とフレームリレーの間のローカル スイッチングを設定するには、 interworking ip キーワードを使用します。

FRF.8 フレームリレーと ATM の間のサービス インターワーキング機能はサポートされていません。フレームリレーの Discard Eligible(DE; 廃棄適性)ビットは、ATM の Cell Loss Priority(CLP; セル損失率優先度)にマッピングされず、Forward Explicit Congestion Notification(FECN; 順方向明示的輻輳通知)ビットは ATM の Explicit Forward Congestion Indication(EFCI; 明示的順方向輻輳通知)ビットにマッピングされません。

PVC の作成は必須ではありません。PVC を作成しない場合、自動的に作成されます。ATM とイーサネットの間のローカル スイッチングでは、自動的にプロビジョニングされた PVC にデフォルトのカプセル化タイプ AAL5SNAP が設定されます。

ATM とフレームリレーの間のローカル スイッチングでは、次のカプセル化タイプがサポートされています。

AAL5SNAP

AAL5NLPID(GSR は、IP インターワーキングに対し、代わりに AAL5MUX を使用します)

手順の概要

1. enable

2. configure terminal

3. interface atm slot / port

4. pvc vpi / vci l2transport

5. encapsulation layer-type

6. exit

7. interface serial slot / port

8. encapsulation frame-relay [ cisco | ietf ]

9. frame-relay interface-dlci dlci switched

10. exit

11. connect connection-name interface pvc interface dlci [ interworking ip | ethernet ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm slot / port

 

Router(config)# interface atm1/0

ATM ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

pvc vpi / vci l2transport

 

Router(config-if)# pvc 1/200 l2transport

VPI と VCI を割り当て、PVC l2transport コンフィギュレーション モードを開始します。

l2transport キーワードは、PVC が終端 PVC ではなくスイッチド PVC であることを示します。

ステップ 5

encapsulation layer-type

 

Router(cfg-if-atm-l2trans-pvc)# encapsulation aal5snap

PVC のカプセル化タイプを指定します。

ステップ 6

exit

 

Router(cfg-if-atm-l2trans-pvc)# exit

PVC l2transport コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 7

interface serial slot / subslot / port

 

Router(config-if)# interface serial6/0/0

チャネライズド ラインカード、サブスロット(使用可能な場合)、およびシリアル ポートを指定します。

ステップ 8

encapsulation frame-relay [ cisco | ietf ]

 

Router(config-if)# encapsulation frame-relay ietf

インターフェイスのフレームリレー カプセル化を指定します。

カプセル化タイプは、ローカル スイッチングでは重要でありません。カプセル化タイプは終端回線だけに関係します。

ステップ 9

frame-relay interface-dlci dlci switched

 

Router(config-if)# frame-relay interface-dlci 100 switched

(任意)スイッチド フレームリレー DLCI を設定します。

この手順でフレームリレー PVC を作成しない場合、 connect コマンドによって自動的に作成されます。

ステップ 10

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 11

connect connection-name interface pvc interface dlci [ interworking ip | ethernet ]

 

Router(config)# connect atm-fr-con

atm1/0 0/100 serial6/0/0 100 interworking ip

2 つのインターフェイスの間にローカル接続を作成します。

フレームリレーとフレームリレーの間のローカル スイッチングの設定

フレームリレーとフレームリレーの間のローカル スイッチングの設定に関する詳細については、『 Distributed Frame Relay Switching』機能モジュールを参照してください。

Cisco IOS Release 12.0(30)S では、「フレームリレー同一ポート スイッチングの設定」で説明するように、同じポート上の仮想回線の間でスイッチングを行うことができます。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. frame-relay switching

5. interface type number

6. encapsulation frame-relay [ cisco | ietf ]

7. frame-relay interface-dlci dlci switched

8. exit

9. exit

10. connect connection-name interface dlci interface dlci

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distribute d ]

 

Router(config)# ip cef

シスコ エクスプレス フォワーディングをイネーブルにします。

Cisco 7500 シリーズ ルータの場合は、 ip cef distributed コマンドを使用します(GSR では、このコマンドはデフォルトでイネーブルになっています)。

Cisco 7200 シリーズ ルータの場合は、 ip cef コマンドを使用します。

ステップ 4

frame-relay switching

 

Router(config)# frame-relay switching

フレームリレー DCE デバイスまたは Network-to-Network Interface(NNI; ネットワーク間インターフェイス)上で PVC スイッチングをイネーブルにします。

ステップ 5

interface type number

 

Router(config)# interface serial 0

フレームリレー インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

encapsulation frame-relay [ cisco | ietf ]

 

Router(config-if)# encapsulation frame-relay

フレームリレーのカプセル化をイネーブルにします。

デフォルトのカプセル化は cisco です。

カプセル化タイプを指定する必要はありません。

ステップ 7

frame-relay interface-dlci dlci switched

 

Router(config-if)# frame-relay interface-dlci 100 switched

(任意)スイッチド PVC を作成し、フレームリレー DLCI コンフィギュレーション モードを開始します。

スイッチド PVC ごとに、ステップ 5 ~ 7 を繰り返します。

この手順でフレームリレー PVC を作成しない場合、 connect コマンドによって自動的に作成されます。

ステップ 8

exit

 

Router(config-fr-dlci)# exit

フレームリレー DLCI コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 9

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 10

connect connection-name interface dlci interface dlci

 

Router(config)# connect connection1 serial0 100 serial1 101

フレームリレー PVC 間の接続を定義します。

フレームリレー同一ポート スイッチングの設定

同じインターフェイス上のフレームリレー スイッチングを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. frame-relay switching

5. interface type number

6. encapsulation frame-relay [ cisco | ietf ]

7. frame-relay intf-type [ dce | dte | nni ]

8. frame-relay interface-dlci dlci switched

9. exit

10. exit

11. connect connection-name interface dlci interface dlci

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distributed ]

 

Router(config)# ip cef

シスコ エクスプレス フォワーディングをイネーブルにします。

Cisco 7500 シリーズ ルータの場合は、 ip cef distributed コマンドを使用します(GSR では、このコマンドはデフォルトでイネーブルになっています)。

Cisco 7200 シリーズ ルータの場合は、 ip cef コマンドを使用します。

ステップ 4

frame-relay switching

 

Router(config)# frame-relay switching

フレームリレー DCE デバイスまたは NNI 上で PVC スイッチングをイネーブルにします。

ステップ 5

interface type number

 

Router(config)# interface serial 0

フレームリレー インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

encapsulation frame-relay [ cisco | ietf ]

 

Router(config-if)# encapsulation frame-relay

フレームリレーのカプセル化をイネーブルにします。

デフォルトのカプセル化は cisco です。

カプセル化タイプを指定する必要はありません。

ステップ 7

frame-relay intf-type [ dce | dte | nni ]

 

Router(config-if)# frame-relay intf-type nni

(任意)次の特定の接続タイプのサポートをイネーブルにします。

DCE

DTE(デフォルト)

NNI

ステップ 8

frame-relay interface-dlci dlci switched

 

Router(config-if)# frame-relay interface-dlci 100 switched

(任意)スイッチド PVC を作成し、フレームリレー DLCI コンフィギュレーション モードを開始します。

この手順でフレームリレー PVC を作成しない場合、 connect コマンドによって自動的に作成されます。

ステップ 9

exit

 

Router(config-fr-dlci)# exit

フレームリレー DLCI コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 10

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 11

connect connection-name interface dlci interface dlci

 

Router(config)# connect connection1 serial1/0 100 serial1/0 200

2 つのデータ リンクの間に接続を作成します。

HDLC ローカル スイッチングの設定

HDLC のローカル スイッチングを設定するには、次の作業を実行します。PE ルータでは HDLC カプセル化が設定されます。CE ルータでは、HDLC、PPP、およびフレームリレーを含む任意の HDLC ベースのカプセル化が設定されます。

制約事項

HDLC カプセル化が設定されたインターフェイス上では、他の設定を行わないでください。インターフェイスに IP アドレスを割り当てると、 connect コマンドが拒否され、次のエラー メッセージが表示されます。

Incompatible with IP address command on interface - command rejected.
 

HDLC カプセル化がイネーブルになっているインターフェイス上で他の設定を行うと、ローカル スイッチング機能が動作しないおそれがあります。

インターワーキングはサポートされていません。

HDLC に対する同一ポート ローカル スイッチングはサポートされていません。

ダイヤラと ISDN インターフェイスはサポートされていません。シリアル、HSSI、および POS インターフェイスだけで HDLC ローカル スイッチングを設定できます。

前提条件

HDLC カプセル化を設定したインターフェイスが、CE インターフェイスの MTU よりも小さいか、同じサイズか、それよりも大きい ping パケットを処理できることを確認します。

シスコ エクスプレス フォワーディングをイネーブルにします。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. interface type number

5. exit

6. connect connection-name interface interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef

 

Router(config)# ip cef

シスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface serial 2/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

connect connection-name interface interface

 

Router(config)# connect connection1 serial1/0 serial1/0

2 つのインターフェイスの間の接続を定義します。

ATM-to-ATM ACR のローカル スイッチングの設定

ATM-to-ATM ACR のローカル スイッチングを設定するには、次の作業を実行します。


connect コマンドによって、必要な L2 トランスポート VC をデフォルトの AAl0 カプセル化タイプで作成するためのインフラストラクチャが提供されます。VC が存在している必要はありません。


手順の概要

1. enable

2. configure terminal

3. interface atm slot / subslot / port

4. aps group [ acr ] group-number

5. aps working circuit-number

6. aps protect circuit-number ip-address

7. exit

8. interface acr acr-group-number

9. pvc [ name ] vpi/vci l2transport

10. exit

11. exit

12. connect connection-name type number pvc type number pvc

13. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm slot / subslot / port

 

Router(config)# interface atm8/0/0

ATM ラインカード、サブスロット(使用可能な場合)、およびポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

aps group [ acr ] group-number

 

Router(config-if)# aps group acr 1

ACR の運用インターフェイスおよび保護インターフェイスを設定します。

group-number :グループ数。

ステップ 5

aps working circuit-number

 

Router(config-if)# aps working 1

ATM OC-3 インターフェイスを運用インターフェイスとしてイネーブルにします。

circuit-number :運用インターフェイスとしてイネーブルにされる回線数。

ステップ 3 ~ 5 を繰り返して、保護インターフェイスを設定します。

ステップ 6

aps protect circuit-number ip-address

 

Router(config-if)# aps protect 1 10.0.0.1

ATM OC-3 インターフェイスを保護インターフェイスとしてイネーブルにします。

circuit-number :保護インターフェイスとしてイネーブルにされる回線数。

ip-address :ATM OC-3 運用インターフェイスが搭載されたルータの IP アドレス。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface acr acr-group-number

 

Router(config)# interface acr 1

ACR インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

acr-group-number :運用インターフェイスと保護インターフェイスに割り当てるグループ番号。

ステップ 9

pvc [ name ] vpi/vci l2transport

 

Router(config-if)# pvc 0/32 l2transport

ATM PVC を作成し、ATM 仮想回線コンフィギュレーション モードを開始します。

ステップ 10

exit

 

Router(config-if-atm-vc)# exit

ATM 仮想回線コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

他の ACR グループに関して、ステップ 8 ~ 9 を繰り返します。

ステップ 11

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 12

connect connection-name type number pvc type number pvc

 

Router(config)# connect connection1 acr 1 0/32 acr 2 1/32

ATM-ACR インターフェイス間の接続を定義します。

connection-name :ローカル スイッチング接続名。

type :ローカル スイッチング接続の作成に使用するインターフェイス タイプまたは回線タイプ。

number :インターフェイスまたは回線の数を指定する整数。

ステップ 13

exit

 

Router(config)# exit

グローバル コンフィギュレーションを終了して、特権 EXEC モードに戻ります。

CEM-to-CEM ACR のローカル スイッチングの設定

CEM-to-CEM ACR のローカル スイッチングを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. controller sonet slot / subslot / port

4. aps group [ acr ] group-number

5. aps working circuit-number

6. aps protect circuit-number ip-address

7. exit

8. controller sonet-acr acr-group-number

9. framing sonet

10. sts-1 number

11. mode vt-15

12. vtg number t1 number cem-group number timeslots number

13. exit

14. exit

15. interface cem-acr acr-group-number

16. exit

17. cem slot / port / channel

18. xconnect virtual-connect-id

19. exit

20. exit

21. connect connection-name type number circuit-id type number circuit-id

22. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

controller sonet slot / subslot / port

 

Router(config)# controller sonet 8/0/0

仮想コントローラを指定し、SONET コントローラ コンフィギュレーション モードを開始します。

ステップ 4

aps group [ acr ] group-number

 

Router(config-controller)# aps group acr 1

ACR の運用インターフェイスおよび保護インターフェイスを設定します。

group-number :グループ数。

ステップ 5

aps working circuit-number

 

Router(config-controller)# aps working 1

SONET インターフェイスを運用インターフェイスとしてイネーブルにします。

circuit-number :運用インターフェイスとしてイネーブルにされる回線数。

ステップ 3 ~ 5 を繰り返して、保護インターフェイスを設定します。

ステップ 6

aps protect circuit-number ip-address

 

Router(config-controller)# aps protect 1 10.0.0.1

SONET インターフェイスを保護インターフェイスとしてイネーブルにします。

circuit-number :保護インターフェイスとしてイネーブルにされる回線数。

ip-address :SONET 運用インターフェイスが搭載されたルータの IP アドレス。

ステップ 7

exit

 

Router(config-controller)# exit

SONET コントローラ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

controller sonet-acr acr-group-number

 

Router(config)# controller SONET-acr 1

SONET ACR コントローラを指定し、SONET コントローラ コンフィギュレーション モードを開始します。

acr-group-number :運用インターフェイスと保護インターフェイスに割り当てるグループ番号。

ステップ 9

framing sonet

 

Router(config-controller)# framing sonet

SONET フレーム構成のコントローラ フレーム構成を設定します。

ステップ 10

sts-1 number

 

Router(config-controller)# sts-1 2

STS ID を指定し、STS コンフィギュレーション モードを開始します。

ステップ 11

mode vt-15

 

Router(config-ctrlr-sts1)# mode vt-15

STS-1 モードの動作として、VT-15 を指定します。

ステップ 12

vtg number t1 number cem-group number timeslots number

 

Router(config-ctrlr-sts1)# vtg 2 t1 4 cem-group 2 timeslots 1-5,14

単一の T1 Circuit Emulation Service over Packet Switched Networks(CESoPSN)グループを有する仮想トリビュタリ グループを作成します。

ステップ 13

exit

 

Router(config-ctrlr-sts1)# exit

STS コンフィギュレーション モードを終了し、SONET コントローラ コンフィギュレーション モードに戻ります。

ステップ 14

exit

 

Router(config-controller)# exit

SONET コントローラ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 15

interface cem-acr acr-group-number

 

Router(config)# interface cem-acr 1

CEM-ACR インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 16

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 17

cem slot / port / channel

 

Router(config)# cem 1/2/0

CEM を設定し、CEM コンフィギュレーション モードを開始します。

ステップ 18

xconnect virtual-connect-id

 

Router(config-cem)# xconnect 0

CEM 接続を確立して、CEM xconnect コンフィギュレーション モードを開始します。

virtual-connect-id :Virtual connect ID(VCID; 仮想接続 ID)。

ステップ 19

exit

 

Router(config-cem-xconnect)# exit

CEM xconnect コンフィギュレーション モードを終了し、CEM コンフィギュレーション モードに戻ります。

ステップ 20

exit

 

Router(config-cem)# exit

CEM コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

他の CEM グループに関して、ステップ 15 ~ 19 を繰り返します。

ステップ 21

connect connection-name type number circuit-id type number circuit-id

 

Router(config)# connect connect1 cem-acr 1 2 cem-acr 2 3

2 つの CEM-ACR 回線の間に接続を定義します。

connection-name :ローカル スイッチング接続名。

type :ローカル スイッチング接続の作成に使用するインターフェイス タイプまたは回線タイプ。

number :インターフェイスまたは回線の数を指定する整数。

circuit-id :CEM グループ ID。

ステップ 22

exit

 

Router(config)# exit

グローバル コンフィギュレーションを終了して、特権 EXEC モードに戻ります。

レイヤ 2 ローカル スイッチングの確認

ここでは、次の確認作業とトラブルシューティング情報について説明します。

「レイヤ 2 ローカル スイッチングの設定の確認」

「NSF/SSO ローカル スイッチングの設定の確認」

「トラブルシューティングのヒント」

レイヤ 2 ローカル スイッチングの設定の確認

レイヤ 2 ローカル スイッチング機能の設定を確認するには、プロバイダー エッジ(PE)ルータで次のコマンドを使用します。

手順の概要

1. show connection [ all | element | id id | name name | port port ]

2. show atm pvc

3. show frame-relay pvc [ pvc ]

手順の詳細


ステップ 1 show connection [ all | element | id id | name name | port port ]

show connection コマンドは、ATM インターフェイスとファスト イーサネット インターフェイスの間のローカル接続を表示します。

Router# show connection name atm-eth-con
 
ID Name Segment 1 Segment 2 State
==================================================================
1 atm-eth-con ATM0/0/0 AAL5 0/100 FastEthernet6/0/0 UP
 

この例では、ATM インターフェイスとシリアル インターフェイスの間のローカル接続を表示しています。

Router# show connection name atm-fr-con
 
ID Name Segment 1 Segment 2 State
==================================================================
1 atm-fr-con ATM0/0/0 AAL5 0/100 Serial1/0/0 16 UP
 

この例では、シリアル インターフェイス上の同一ポート接続が表示されます。

Router# show connection name same-port
 
ID Name Segment 1 Segment 2 State
==================================================================
1 same-port Serial1/1/1 101 Serial1/1/1 102 UP
 

ステップ 2 show atm pvc

show atm pvc コマンドでは、インターフェイス ATM3/0 がアップ状態であることが表示されています。

Router# show atm pvc
 
VCD/ Peak Avg/Min Burst
Interface Name VPI VCI Type Encaps SC Kbps Kbps Cells Sts
3/0 10 1 32 PVC FRATMSRV UBR 155000 UP
 

ステップ 3 show frame-relay pvc [ pvc ]

show frame-relay pvc コマンドは、スイッチド フレームリレー PVC を表示します。

Router# show frame-relay pvc 16
 
PVC Statistics for interface POS5/0 (Frame Relay NNI)
DLCI = 16, DLCI USAGE = SWITCHED, PVC STATUS = UP, INTERFACE = POS5/0
LOCAL PVC STATUS = UP, NNI PVC STATUS = ACTIVE
input pkts 0 output pkts 0 in bytes 0
out bytes 0 dropped pkts 100 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
switched pkts 0
Detailed packet drop counters:
no out intf 0 out intf down 100 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
pvc create time 00:25:32, last time pvc status changed 00:06:31


 

NSF/SSO ローカル スイッチングの設定の確認

レイヤ 2 ローカル スイッチングでは、同じルータ上の次の接続回線のローカル スイッチングに対し、NSF/SSO がサポートされています。

イーサネット(ポート モード)とイーサネット VLAN の間

フレームリレーとフレームリレーの間

RP 上の NSF/SSO の設定については、『 Stateful Switchover 』機能モジュールを参照してください。NSF/SSO:レイヤ 2 ローカル スイッチング が正しく動作していることを確認するには、このセクションの手順を実行します。

手順の概要

1. ping

2. redundancy force-switchover

3. show connect all

4. ping

手順の詳細


ステップ 1 ping コマンドを実行するか、2 台の CE ルータ間でトラフィックを発生させます。

ステップ 2 redundancy force-switchover コマンドを使用して、アクティブ RP からスタンバイ RP に強制的に切り替えます。この手動の手順により、アクティブな RP の「通常の」制御されたシャットダウンが行われ、スタンバイ RP に切り替えられます。この通常シャットダウンにより、不可欠なクリーンアップが行われます。

ステップ 3 show connect all コマンドを実行し、デュアル RP 上のレイヤ 2 ローカル スイッチング接続が動作していることを確認します。

Router# show connect all
 
ID Name Segment 1 Segment 2 State
2 Eth-Vlan1 Fa1/1/1 Fa6/0/0/0.1 UP
 

ステップ 4 CE ルータから ping コマンドを実行し、切り替えの際の連続的なパケット損失が最小限であることを確認します。


 

トラブルシューティングのヒント

レイヤ 2 ローカル スイッチングをトラブルシューティングするには、PE ルータで次のコマンドを使用します。

debug atm l2transport

debug conn

debug frame-relay pseudowire

show frame-relay pvc

show connection

show atm pvc

レイヤ 2 ローカル スイッチングの設定例

ここでは、次の設定例について説明します。

「例:ATM-to-ATM ローカル スイッチング」

「例:ATM PVC 同一ポート スイッチング」

「例:ATM PVP 同一ポート スイッチング」

「例:ATM とイーサネット間のローカル スイッチング」

「例:イーサネット VLAN の同一ポート スイッチング」

「例:ATM とフレームリレー間のローカル スイッチング」

「例:フレームリレーとフレームリレー間のローカル スイッチング」

「例:フレームリレー DLCI 同一ポート スイッチング」

「例:HDLC ローカル スイッチング」

「例:NSF/SSO:イーサネット ポート モードとイーサネット VLAN 間のローカル スイッチング」

例:ATM-to-ATM ローカル スイッチング

次に、AAL5 が設定された ATM インターフェイス上のローカル スイッチングの例を示します。

interface atm1/0/0
pvc 0/100 l2transport
encapsulation aal5
 
interface atm2/0/0
pvc 0/100 l2transport
encapsulation aal5
 
connect aal5-conn atm1/0/0 0/100 atm2/0/0 0/100

例:ATM PVC 同一ポート スイッチング

次に、1 つの ATM インターフェイス上の 2 つの PVC 間での同一ポート スイッチングの例を示します。

interface atm1/0/0
pvc 0/100 l2transport
encapsulation aal5
pvc 0/200 l2transport
encapsulation aal5
 
connect conn atm1/0/0 0/100 atm1/0/0 0/200

例:ATM PVP 同一ポート スイッチング

次に、1 つの ATM インターフェイス上の 2 つの PVP 間での同一ポート スイッチングの例を示します。

interface atm1/0/0
atm pvp 100 l2transport
atm pvp 200 l2transport
 
connect conn atm1/0/0 100 atm1/0/0 200

例:ATM とイーサネット間のローカル スイッチング

ATM とイーサネットの間のローカル スイッチングは、ATM フレームを、同じ PE ルータ上のイーサネット/VLAN フレームに終端します。イーサネット モードと IP モードの 2 つのインターワーキング モデルが使用されます。

例:ATM とイーサネット VLAN 間

次に、イーサネット VLAN が設定されたイーサネット インターフェイスと、AAL5 カプセル化が設定された ATM PVC インターフェイスの例を示します。 connect コマンドを使用すると、これら 2 つのインターフェイス間でのローカル スイッチングが可能となり、インターワーキング タイプがイーサネット モードに指定されます。

interface fastethernet6/0/0.1
encapsulation dot1q 10
 
interface atm2/0/0
pvc 0/400 l2transport
encapsulation aal5
 
connect atm-ethvlan-con atm2/0/0 0/400 fastethernet6/0/0.1 interworking ethernet

例:ATM とイーサネット ポート モード間

次に、イーサネットが設定されたイーサネット インターフェイスと、AAL5SNAP カプセル化が設定された ATM インターフェイスの例を示します。 connect コマンドを使用すると、これら 2 つのインターフェイス間でのローカル スイッチングが可能となり、インターワーキング タイプが IP モードに指定されます。

interface atm0/0/0
pvc 0/100 l2transport
encapsulation aal5snap
 
interface fastethernet6/0/0
 
connect atm-eth-con atm0/0/0 0/100 fastethernet6/0/0 interworking ip

例:イーサネット VLAN の同一ポート スイッチング

次に、1 つのイーサネット インターフェイス上の 2 つの VLAN 間での同一ポート スイッチングの例を示します。

interface fastethernet0/0.1
encapsulation dot1q 1
interface fastethernet0/0.2
encapsulation dot1q 2
 
connect conn FastEthernet0/0.1 FastEthernet0/0.2

例:ATM とフレームリレー間のローカル スイッチング

次に、フレームリレーが設定されたシリアル インターフェイスと、AAL5SNAP カプセル化が設定された ATM インターフェイスの例を示します。 connect コマンドを使用すると、これら 2 つのインターフェイス間でローカル スイッチングが可能になります。

interface serial1/0
encapsulation frame-relay
 
interface atm1/0
pvc 7/100 l2transport
encapsulation aal5snap
 
connect atm-fr-conn atm1/0 7/100 serial1/0 100 interworking ip

例:フレームリレーとフレームリレー間のローカル スイッチング

次に、フレームリレーが設定されたシリアル インターフェイスの例を示します。 connect コマンドを使用すると、これら 2 つのインターフェイス間でローカル スイッチングが可能になります。

frame-relay switching
ip cef distributed
 
interface serial3/0/0
encapsulation frame-relay
frame-relay interface-dlci 100 switched
frame-relay intf-type dce
 
interface serial3/1/0
encapsulation frame-relay ietf
frame-relay interface-dlci 200 switched
frame-relay intf-type dce
 
connect fr-con serial3/0/0 100 serial3/1/0 200

例:フレームリレー DLCI 同一ポート スイッチング

次に、1 つのフレームリレー インターフェイス上の 2 つのデータ リンク間での同一ポート スイッチングの例を示します。

interface serial1/0
encapsulation frame-relay
frame-relay int-type nni
 
connect conn serial1/0 100 serial1/0 200

例:HDLC ローカル スイッチング

次に、HDLC 用の 2 つのシリアル インターフェイスのローカル スイッチングの例を示します。

interface serial1/0
no ip address
 
interface serial2/0
no ip address
 
connect conn1 serial1/0 serial1/0

例:NSF/SSO:イーサネット ポート モードとイーサネット VLAN 間のローカル スイッチング

次の設定は、図 4に示すネットワーク トポロジを使用しています。

図 4 NSF/SSO:レイヤ 2 ローカル スイッチング:イーサネットとイーサネット VLAN の間

 

次に、PE1 ルータに接続するための CE インターフェイスの設定例を示します。

 

CE1
CE2

ip routing

!

interface fa3/1/0

description: connection to PE fa1/1/1

no shutdown

ip address 10.1.1.1 255.255.255.0

ip routing

!

interface fa4/0

no shutdown

!

interface fa4/0.1

description: connection to PE1 fa6/0/0.1

encapsulation dot1Q 10

ip address 10.1.1.2 255.255.255.0

!

interface fa4/0.2

description - connection to PE1 fa6/0/0.2

encapsulation dot1Q 20

ip address 172.16.1.2 255.255.255.0

次に、CE ルータへの NSF/SSO および PE インターフェイスを持つ PE1 ルータの設定例を示します。

 

PE1

redundancy

no keepalive-enable

mode sso

!

hw-module slot 2 image disk0:rsp-pv-mz.shaft.111004

hw-module slot 3 image disk0:rsp-pv-mz.shaft.111004

!

ip routing

ip cef distributed

!

interface fa1/1/1

description - connection to CE1 fa3/1/0

no shutdown

no ip address

!

interface fa4/0/0

description - connection to CE3 fa6/0

no shutdown

no ip address

!

interface fa6/0/0

no shutdown

no ip address

!

interface fa6/0/0.1

description - connection to CE2 fa4/0.1

encapsulation dot1Q 10

no ip address

!

interface fa6/0/0.2

description - connection to CE2 fa4/0.2

encapsulation dot1Q 20

no ip address

次に、ARP メディエーションのためのインターワーキング IP に対する CE ルータ上の ICMP Router Discovery Protocol(IRDP)の設定例を示します。

 

CE1
CE2

interface FastEthernet3/1/0

ip irdp

ip irdp maxadvertinterval 0

interface FastEthernet4/0.1

ip irdp

ip irdp maxadvertinterval 0

次に、CE ルータ上の OSPF の設定例を示します。

 

CE1
CE2

interface loopback 1

ip address 10.11.11.11 255.255.255.255

!

router ospf 10

network 10.11.11.11 0.0.0.0 area 0

network 192.168.1.1 0.0.0.0 area 0

interface loopback 1

ip address 12.12.12.12 255.255.255.255

!

router ospf 10

network 10.12.12.12 0.0.0.0 area 0

network 192.168.1.2 0.0.0.0 area 0

次に、イーサネット インターワーキング用の、PE1 ルータ上のローカル スイッチングの設定例を示します。

connect eth-vlan1 fa1/1/1 fa6/0/0.1 interworking ethernet

connect eth-vlan2 fa4/0/0 fa6/0/0.2 interworking ethernet

 

次に、IP インターワーキング用の、PE1 ルータ上のローカル スイッチングの設定例を示します。

connect eth-vlan1 fa1/1/1 fa6/0/0.1 interworking ip

connect eth-vlan2 fa4/0/0 fa6/0/0.2 interworking ip

参考資料

関連資料

関連項目
参照先

MPLS

MPLS Product Literature

レイヤ 2 ローカル スイッチングの設定作業

『Configuring Layer 2 Local Switching』

フレームリレー ATM インターワーキングの設定作業

『Configuring Frame Relay-ATM Interworking』

フレームリレーとフレームリレーの間のローカル スイッチングの設定作業

『Distributed Frame Relay Switching』

7600 シリーズ ルータでの CEoP およびチャネライズド ATM SPA の設定作業

『Configuring the CEoP and Channelized ATM SPAs』

規格

規格
タイトル

draft-ietf-l2tpext-l2tp-base-03.txt

『Layer Two Tunneling Protocol (Version 3) 'L2TPv3'』

draft-martini-l2circuit-trans-mpls-09.txt

『Transport of Layer 2 Frames Over MPLS』

draft-martini-l2circuit-encap-mpls-04.txt

『Encapsulation Methods for Transport of Layer 2 Frames Over IP and MPLS Networks』

draft-ietf-ppvpn-l2vpn-00.txt

『An Architecture for L2VPNs』

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。
以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する
この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

レイヤ 2 ローカル スイッチングの機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 レイヤ 2 ローカル スイッチングの機能情報

機能名
リリース
機能情報

レイヤ 2 ローカル スイッチング

12.0(27)S
12.2(25)S
12.0(30)S
12.0(31)S2
12.0(32)SY
12.2(28)SB
12.4(11)T
12.2(33)SRB
12.2(33)SXH
12.2(33)SB
15.0(1)S

レイヤ 2 ローカル スイッチング機能を使用すると、同じルータ上の 2 つのインターフェイス間でレイヤ 2 データをスイッチングできます。また、場合によっては、同じインターフェイス ポート上の 2 つの回線の間でレイヤ 2 データをスイッチングできます。

この機能は、Cisco IOS Release 12.0(27)S で、Cisco 7200 および 7500 シリーズ ルータに実装されました。

この機能は、Cisco IOS Release 12.2(25)S に統合され、Cisco 7500 シリーズ ルータに実装されました。

Cisco IOS Release 12.0(30)S で、同一ポート スイッチングのサポートが追加されました。レイヤ 2 インターフェイス間ローカル スイッチングのサポートが、GSR に追加されました。

Cisco IOS Release 12.0(31)S2 で、GSR 上のカスタマー エッジ側 IP Service Engine(ISE)インターフェイスに対するサポートが追加されました。

Cisco IOS Release 12.0(32)SY で、GSR のエンジン 5 共有ポート アダプタ(SPA)および SPA インターフェイス プロセッサ(SIP)上のカスタマー エッジ側インターフェイスに対するサポートが追加されました。

Cisco IOS Release 12.2(28)SB で、この機能が更新され、Cisco 7500 シリーズ ルータで、Nonstop Forwarding(NSF)/Stateful Switchover(SSO)の次のローカル スイッチング タイプに対する、NSF/SSO のサポートが追加されました。

NSF/SSO:イーサネットとイーサネット VLAN の間のローカル スイッチングのサポート

NSF/SSO:フレームリレーとフレームリレーの間のローカル スイッチングのサポート

Cisco IOS Release 12.4(11)T で、Cisco 7200 シリーズ ルータに対して次のローカル スイッチング タイプのサポートが追加されました。

イーサネットとイーサネット VLAN の間

イーサネット VLAN の同一ポート スイッチング

フレームリレーとフレームリレーの間

フレームリレーの同一ポート スイッチング

Cisco IOS Release 12.2(28)SB で、Cisco 10000 シリーズ ルータ上のローカル スイッチングのサポートが追加されました。

Cisco IOS Release 12.2(33)SXH で、Cisco 6500 シリーズ スイッチと Cisco 7600 シリーズ ルータ上で、like-to-like ローカル スイッチング(ATM 同士と FR 同士のみ)のサポートが追加されました。これらのルータでは同一ポート スイッチングはサポートされません。

Cisco IOS Release 12.2(33)SB で、Cisco 7200 シリーズ ルータおよび Cisco 10000 シリーズ ルータ上で、HDLC ローカル スイッチングのサポートが追加されました。

この機能に関する詳細については、次の各項を参照してください。

「レイヤ 2 ローカル スイッチングに関する情報」

「レイヤ 2 ローカル スイッチングの設定方法」

次のコマンドが導入または変更されました。 connect L2VPN ローカル スイッチング)、 encapsulation レイヤ 2 ローカル スイッチング)、 show connection

ATM ローカル スイッチング用のアクセス回線冗長性

15.1(1)S

Access Circuit Redundancy(ACR; アクセス回線冗長性)を使用すると、スイッチオーバーの時間を短縮してデータ トラフィックのダウンタイムを削減することができます。ACR は、各冗長回線ペアが運用回線と保護回線から成る APS 1+1、非リバーティブ モデルで利用できます。信号障害状態または信号劣化が検出されると、ハードウェアによって運用回線から保護回線にスイッチングされます。

この機能は、Cisco IOS Release 15.1(1)S で導入されました。

この機能に関する詳細については、次の各項を参照してください。

「アクセス回線冗長性のローカル スイッチング」

「ATM-to-ATM ACR のローカル スイッチング」

次のコマンドが導入または変更されました。 aps group connect L2VPN ローカル スイッチング)

ACR での CEM のサポート

15.1(1)S

この機能により、CEM で Access Circuit Redundancy(ACR; アクセス回線冗長性)がサポートされます。

この機能は、Cisco IOS Release 15.1(1)S で導入されました。

この機能に関する詳細については、次の各項を参照してください。

「アクセス回線冗長性のローカル スイッチング」

「CEM-to-CEM ACR のローカル スイッチング」

次のコマンドが導入または変更されました。 aps group connect L2VPN ローカル スイッチング)