Cisco IOS ワイドエリア ネットワーキング コンフィ ギュレーション ガイド
L2VPN インターワーキング
L2VPN インターワーキング
発行日;2012/02/06 | 英語版ドキュメント(2011/11/23 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

L2VPN インターワーキング

機能情報の確認

内容

L2VPN インターワーキングの前提条件

L2VPN インターワーキングの制約事項

一般的な制約事項

Cisco 7600 シリーズ ルータの制約事項

Cisco 12000 シリーズ ルータの制限事項

ATM AAL5 インターワーキングの制約事項

Ethernet/VLAN インターワーキングの制約事項

の制約事項

フレームリレー インターワーキングの制約事項

PPP インターワーキングの制約事項

L2VPN インターワーキングについて

L2VPN インターワーキングの概要

L2VPN インターワーキング モード

イーサネット(ブリッジ型)インターワーキング

IP(ルーテッド)インターワーキング

VLAN インターワーキング

L2VPN インターワーキング:サポート マトリクス

PPP の L2VPN インターワーキング用のスタティック IP アドレス

L2VPN インターワーキングの設定方法

L2VPN インターワーキングの設定

L2VPN インターワーキング設定の確認

の設定

制約事項

前提条件

L2VPN インターワーキングの設定例

Ethernet to VLAN over L2TPV3(ブリッジ型):例

Ethernet to VLAN over AToM(ブリッジ型):例

Frame Relay to VLAN over L2TPV3(ルーテッド):例

Frame Relay to VLAN over AToM(ルーテッド):例

Frame Relay to ATM AAL5 over AToM(ルーテッド):例

VLAN to ATM AAL5 over AToM(ブリッジ型):例

Frame Relay to PPP over L2TPv3(ルーテッド):例

Frame Relay to PPP over AToM(ルーテッド):例

Ethernet/VLAN to PPP over AToM(ルーテッド):例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

L2VPN インターワーキングの機能情報

L2VPN インターワーキング

Layer 2 Virtual Private Network(L2VPN; レイヤ 2 バーチャル プライベート ネットワーク)インターワーキングを使用すると異なる接続回線どうしが接続できます。この機能モジュールでは、次の L2VPN インターワーキング機能の設定方法について説明します。

Ethernet/VLAN to ATM AAL5 インターワーキング

Ethernet/VLAN to Frame Relay インターワーキング

Ethernet/VLAN to PPP インターワーキング

Ethernet to VLAN インターワーキング

Frame Relay to ATM AAL5 インターワーキング

Frame Relay to PPP インターワーキング

Ethernet/VLAN to ATM Virtual Channel Identifier(VPI; 仮想チャネル識別子)および Virtual Channel Identifier((VCI; 仮想チャネル識別子)インターワーキング

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション

機能情報の確認

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「L2VPN インターワーキングの機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、Cisco Catalyst OS ソフトウェア イメージ、および Cisco IOS XE ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

L2VPN インターワーキングの前提条件

ルータに L2VPN インターワーキングを設定する前に次の事項を確認してください。

シスコ エクスプレス フォワーディングをイネーブルにする必要があります。

Cisco 12000 シリーズ インターネット ルータでは、IP Services Engine(ISE; IP サービス エンジン/エンジン 3)またはエンジン 5 インターフェイス上で L2VPN インターワーキング用に Layer 2 Tunnel Protocol version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)を設定する前に、ラインカード上で L2VPN 機能バンドルもイネーブルにする必要があります。

機能バンドルをイネーブルにするには、グローバル コンフィギュレーション モードで次のように hw-module slot np mode feature コマンドを入力します。

Router# configure terminal
Router(config)# hw-module slot slot-number np mode feature

L2VPN インターワーキングの制約事項

次の各項では、L2VPN インターワーキングの制約事項を示します。

「一般的な制約事項」

「Cisco 7600 シリーズ ルータの制約事項」

「Cisco 12000 シリーズ ルータの制限事項」

「ATM AAL5 インターワーキングの制約事項」

「Ethernet/VLAN インターワーキングの制約事項」

「L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション の制約事項」

「フレームリレー インターワーキングの制約事項」

「PPP インターワーキングの制約事項」

一般的な制約事項

ここでは、L2VPN インターワーキングに適用される全般的な制約事項を示します。プラットフォーム固有またはデバイス固有のその他の制約事項は、以降の項で示します。

Provider Edge(PE; プロバイダー エッジ)ルータ上のインターワーキング タイプは、ピア PE ルータ上のインターワーキング タイプと一致する必要があります。

L2VPN インターワーキングでは、次の Quality of Service(QoS; サービス品質)機能がサポートされます。

トンネル ヘッダーのスタティック IP Type of Service(ToS; タイプ オブ サービス)または Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Experimental Bit(EXP; 検出ビット)設定

トンネル ヘッダーの IP ToS リフレクション(Layer 2 Tunnel Protocol Version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)のみ)

フレームリレー ポリシング

フレームリレー Data-Link Connection Identifier(DLCI; データリンク接続識別子)ベースの輻輳管理(Cisco 7500/Versatile Interface Processor(VIP))

VLAN 優先順位ビットから MPLS EXP ビットへの 1 対 1 マッピング

ATM AAL5 VC モードだけがサポートされます。ATM VP およびポート モードはサポートされません。

Cisco 7600 シリーズ ルータの制約事項

Cisco 7600 シリーズ ルータでは、次のラインカードがサポートされます。 表 1 に、インターワーキング リンクの WAN(ATM、フレームリレー、または PPP)側でサポートされるラインカードを示します。 表 2 にインターワーキング リンクのイーサネット側でサポートされているラインカードを示します。Cisco 7600 ルータでサポートされる共有ポート アダプタとラインカードの詳細については、次のマニュアルを参照してください。

『Cisco 7600 Series Routers Documentation Roadmap』

『Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers』

表 1 Cisco 7600 シリーズ ルータ:WAN 側でサポートされるラインカード

インターワーキング タイプ
コア方向ラインカード
カスタマーエッジ ラインカード

イーサネット(ブリッジ型)(ATM とフレームリレーの間)

任意

EflexWAN
SIP-200
SIP-400

IP(ルーテッド)(ATM、フレームリレー、PPP)

任意

EflexWAN
SIP-200

表 2 Cisco 7600 シリーズ ルータ:イーサネット側でサポートされるラインカード

インターワーキング タイプ
Ethernet over MPLS モード
コア方向ラインカード
カスタマーエッジ ラインカード

イーサネット(ブリッジ型)

Policy Feature Card(PFC; ポリシー フィーチャ カード)ベース

任意(Optical Services Module(OSM; オプティカル サービス モジュール)と ES40 を除く)

Catalyst LAN
SIP-600

イーサネット(ブリッジ型)

Switched Virtual Interface(SVI; スイッチ仮想インターフェイス)ベース

EflexWAN
ES20
ES+40
SIP-200
SIP-400
SIP-600

Catalyst LAN
EflexWAN(MPB あり)
ES20
ES+40
SIP-200(MPB あり)
SIP-400(MPB あり)
SIP-600

イーサネット(ブリッジ型)

スケーラブル(E-MPB あり)

任意(OSM を除く)

ES20
SIP-600 および SIP-400(Gigabit Ethernet(GE; ギガビット イーサネット)SPA あり)

IP(ルーテッド)

PFC ベース

Catalyst LAN
SIP-600

注: Cisco IOS Release 12.2(33)SRD では、PFC ベース モードはルーテッド インターワーキングでサポートされません。SVI、スケーラブル、または Ethernet Virtual Connection(EVC; イーサネット仮想接続)ベースの Ethernet over MPLS(EoMPLS)を代わりに使用してください。

Catalyst LAN
SIP-600

注: Cisco IOS Release 12.2(33)SRD では、PFC ベース モードはルーテッド インターワーキングでサポートされません。SVI、スケーラブル、または EVC ベース EoMPLS を代わりに使用してください。

IP(ルーテッド)

SVI ベース

任意(Catalyst LAN と OSM を除く)

Catalyst LAN
EflexWAN(MPB あり)
ES20
SIP-200(MPB あり)
SIP-400(MPB あり)
SIP-600

Cisco 7600 シリーズ ルータと L2VPN インターワーキングには、次の制約事項が適用されます。

OAM エミュレーションは、SIP-200、SIP-400、および Flexwan2 ラインカード上の L2VPN インターワーキングでは不要です。

Cisco 7600 シリーズ ルータでは、Cisco IOS Release 12.2(33)SRE から導入された L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能がサポートされます。この機能には、次の制約事項があります。

PFC ベースの EoMPLS はサポートされません。

スケーラブルおよび SVI ベース EoMPLS は、SIP-400 ラインカードでサポートされます。

Cisco 7600 シリーズ ルータでは、L2VPN Interworking over L2TPv3 はサポートされません。

Cisco 7600 シリーズ ルータでは、次のインターワーキング タイプだけがサポートされます。

Ethernet/VLAN to Frame Relay(IP およびイーサネット モード)

Ethernet/VLAN to ATM AAL5SNAP(IP およびイーサネット モード)

Ethernet/VLAN to PPP(IP のみ)

Ethernet to VLAN インターワーキング

Cisco 7600 シリーズ ルータでは、次のインターワーキング タイプがサポートされません。

Ethernet/VLAN to ATM AAL5MUX

Frame Relay to PPP インターワーキング

Frame Relay to ATM AAL5 インターワーキング

インターワーキング リンクの両側に、同じカプセル化とインターワーキング タイプが設定されている必要があります。

イーサネット カプセル化を使用する場合は、イーサネット(ブリッジ型)インターワーキング タイプを使用する必要があります。イーサネット カプセル化を使用していない場合は、Routed Bridge Encapsulation(RBE; ルーテッド ブリッジ カプセル化)などのブリッジング メカニズムを使用できます。

IP カプセル化(ATM やフレームリレーなど)を使用する場合は、IP(ルーテッド)インターワーキング タイプを使用する必要があります。PE ルータは、アドレスの学習と解決のためにプロセスをネゴシエーションします。

擬似回線の各側の接続回線で同じ MTU サイズを使用する必要があります。

PFC ベース EoMPLS は、ES40 ラインカードでサポートされません。SVI および EVC/スケーラブル EoMPLS が代替オプションです。

Cisco IOS Release 12.2(33)SRD およびそれ以降のリリースでは、PFC ベース EoMPLS はルーテッド/IP インターワーキングでサポートされません。代替のルーテッド/IP インターワーキング オプションは、SVI と EVC、またはスケーラブル EoMPLS です。ただし、PFC ベース EoMPLS は、イーサネット/ブリッジ型インターワーキングと like-to-like over AToM でサポートされます。

Cisco 12000 シリーズ ルータの制限事項

Cisco 12000 シリーズ ルータでのハードウェア要件の詳細については、『 Cross-Platform Release Notes for Cisco IOS Release 12.0S 』を参照してください。

Cisco 12000 シリーズ ルータでの QOS サポートについては、『 Any Transport over MPLS (AToM): Layer 2 QoS (Quality of Service) for the Cisco 12000 Series Router 』を参照してください。

Frame Relay to PPP および High-Level Data Link Control インターワーキングの場合

Cisco 12000 シリーズ インターネット ルータでは、Cisco IOS Release 12.0(32)S よりも前の Cisco IOS リリースで PPP および High-level Data-Links Control(HDLC; 高レベル データ リンク制御)転送タイプを使用した L2VPN インターワーキングはサポートされません。

Cisco IOS Release 12.0(32)S およびそれ以降のリリースでは、Cisco 12000 シリーズ インターネット ルータは、次の Shared Port Adapter(SPA; 共有ポート アダプタ)でだけ Frame Relay over MPLS および PPP と HDLC over MPLS の L2VPN インターワーキングをサポートします。

ISE/エンジン 3 SPA:

SPA-2XCT3/DS0(2 ポート チャネライズド T3 to DS0)

SPA-4XCT3/DS0(4 ポート チャネライズド T3 to DS0)

エンジン 5 SPA:

SPA-1XCHSTM1/OC-3(1 ポート チャネライズド STM-1c/OC-3c to DS0)

SPA-8XCHT1/E1(8 ポート チャネライズド T1/E1)

SPA-2XOC-48-POS/RPR(2 ポート OC-48/STM16 POS/RPR)

SPA-OC-192POS-LR(1 ポート OC-192/STM64 POS/RPR)

SPA-OC-192POS-XFP(1 ポート OC-192/STM64 POS/RPR)

L2VPN Interworking over L2TPv3

Cisco 12000 シリーズ インターネット ルータでは、L2TPv3 に対してイーサネット(ブリッジ型)インターワーキングはサポートされません。IP(ルーテッド)インターワーキングだけがサポートされます。

IP(ルーテッド)インターワーキングは、( sequencing コマンドを使用して)データ シーケンス用に設定された L2TPv3 擬似回線ではサポートされません。

Cisco IOS Release 12.0(32)SY およびそれ以降のリリースでは、Cisco 12000 シリーズ インターネット ルータは、次のように、ISE およびエンジン 5 ラインカード上で IP モードの L2TPv3 トンネルを介した L2VPN インターワーキングをサポートします。

L2TPv3 トンネリング用に設定された ISE インターフェイス上では、次のレイヤ 2 カプセル化がサポートされます。

ATM Adaptation Layer Type-5(AAL5; ATM アダプテーション レイヤ タイプ 5)

イーサネット

802.1q(VLAN)

フレームリレー DLCI

L2TPv3 トンネリング用に設定されたエンジン 5 インターフェイス上では、次のレイヤ 2 カプセル化がサポートされます。

イーサネット

802.1q(VLAN)

フレームリレー DLCI

詳細については、『 Layer 2 Tunnel Protocol Version 3 』を参照してください。

エンジン 5 イーサネット SPA 上の L2TPv3 インターワーキングでサポートされるフレーム形式は、Ether タイプ 0x0800 値がインターネット プロトコル ペイロードおよび(任意で)802.1q VLAN として設定されたイーサネット バージョン 2(イーサネット II とも呼ばれる)だけです。他のイーサネット フレーム形式のイーサネット パケットはドロップされます。

リモート イーサネット ポート シャットダウンのサポート

Cisco リモート イーサネット ポート シャットダウン機能(リモート リンク エラー後のデータ損失の可能性を最小化します)は、次のエンジン 5 イーサネット SPA でだけサポートされます。

SPA-8XFE(8 ポート ファスト イーサネット)

SPA-2X1GE(2 ポート ギガビット イーサネット)

SPA-5X1GE(5 ポート ギガビット イーサネット)

SPA-10X1GE(10 ポート ギガビット イーサネット)

SPA-1X10GE(1 ポート 10 ギガビット イーサネット)

この機能の詳細については、『 Any Transport over MPLS (AToM): Remote Ethernet Port Shutdown 』を参照してください。

エンジン 5 ラインカード上の L2VPN Any-to-Any インターワーキング

表 3 に、MPLS または L2TPv3 で接続回線を介して接続されているエンジン 3 およびエンジン 5 SPA インターフェイス上の L2VPN インターワーキングに対してサポートされる転送タイプの各種組み合せを示します。

 

表 3 L2VPN インターワーキングでサポートされるエンジン 3 およびエンジン 5 ラインカード/SPA

接続回線 1(AC1)
接続回線 2(AC2)
インターワーキング モード
AC1 エンジン タイプとラインカード/SPA
AC2 エンジン タイプとラインカード/SPA

フレームリレー

フレームリレー

IP

エンジン 5
POS とチャネライズド

エンジン 3
ATM ラインカード

フレームリレー

ATM

イーサネット

エンジン 5
POS とチャネライズド

エンジン 3
ATM ラインカード

フレームリレー

ATM

IP

エンジン 5
POS とチャネライズド

エンジン 3
ATM ラインカード

フレームリレー

イーサネット

イーサネット

エンジン 5
POS とチャネライズド

エンジン 5
ギガビット イーサネット

フレームリレー

イーサネット

IP

エンジン 5
POS とチャネライズド

エンジン 5
ギガビット イーサネット

フレームリレー

VLAN

イーサネット

エンジン 5
POS とチャネライズド

エンジン 5
ギガビット イーサネット

フレームリレー

VLAN

IP

エンジン 5
POS とチャネライズド

エンジン 5
ギガビット イーサネット

イーサネット

イーサネット

イーサネット

エンジン 5
ギガビット イーサネット

エンジン 5
ギガビット イーサネット

イーサネット

イーサネット

IP

エンジン 5
ギガビット イーサネット

エンジン 5
ギガビット イーサネット

イーサネット

VLAN

イーサネット

エンジン 5
ギガビット イーサネット

エンジン 5
ギガビット イーサネット

イーサネット

VLAN

IP

エンジン 5
ギガビット イーサネット

エンジン 5
ギガビット イーサネット

ATM

イーサネット

イーサネット

エンジン 3
ATM ラインカード

エンジン 5
ギガビット イーサネット

ATM

イーサネット

IP

エンジン 3
ATM ラインカード

エンジン 5
ギガビット イーサネット

Cisco 12000 シリーズ エンジン 3 ラインカードでは、Network Layer Protocol ID(NLPID; ネットワーク層プロトコル ID)カプセル化はルーテッド モードでサポートされません。また、NLPID と AAL5MUX はどちらもブリッジ モードでサポートされません。

Cisco 12000 シリーズ インターネット ルータでは、L2TPv3 に対してイーサネット(ブリッジ型)インターワーキングはサポートされません。

L2VPN インターワーキング設定では、 encapsulation l2tpv3 コマンドを使用して擬似回線に L2TPv3 トンネル カプセル化を設定したあとは、 interworking ethernet コマンドを入力できません。

Cisco 12000 シリーズ インターネット ルータ上のイーサネット SPA では、L2TPv3 インターワーキングでサポートされるフレーム形式は、Ether タイプ 0x0800 値がインターネット プロトコル ペイロードおよび(任意で)802.1q VLAN として設定されたイーサネット バージョン 2(イーサネット II とも呼ばれる)だけです。

他のイーサネット フレーム形式のイーサネット パケットはドロップされます。

ATM AAL5 インターワーキングの制約事項

ATM AAL5 インターワーキングには、次の制約事項が適用されます。

Switched Virtual Circuit(SVC; 相手先選択接続)はサポートされません。

Inverse Address Resolution Protocol(ARP; アドレス解決プロトコル)は IP インターワーキングでサポートされません。

カスタマー エッジ(CE)ルータでは、ポイントツーポイント サブインターフェイスまたはスタティック マップを使用してください。

AAL5MUX および AAL5SNAP カプセル化はどちらもサポートされます。AAL5MUX の場合、変換は不要です。

Ethernet End-to-End over ATM シナリオでは、次の変換がサポートされます。

LAN Frame Check Sequence(FCS; フレーム チェック シーケンス)のないイーサネット(AAAA030080C200070000)

スパニング ツリー(AAAA030080c2000E)

その他はすべてドロップされます。

IP over ATM シナリオでは、IPv4(AAAA030000000800)変換がサポートされます。その他はすべてドロップされます。

L2VPN インターワーキングの Operation, Administration, and Management(OAM; 操作、管理、メンテナンス)エミュレーションは、like-to-like と同じです。エンドツーエンド F5 ループバック セルは、PE ルータでループバックされます。擬似回線がダウンしている場合は、F5 エンドツーエンド セグメント Alarm Indication Signal(AIS; アラーム表示信号)/Remote Defect Identification(RDI; リモート検出識別)が PE ルータから CE ルータに送信されます。

Interim Local Management Interface(ILMI; 暫定ローカル管理インターフェイス)では、Virtual Circuit(VC; 仮想回線)と Permanent Virtual Circuit(PVC; 相手先固定接続)を管理できます。

ILMI 管理をイネーブルにするには、PE ルータの ATM インターフェイスに ILMI PVC 0/16 を設定します。PVC がプロビジョニングまたは削除されると、CE ルータに ilmiVCCChange トラップが送信されます。

User-Network Interface(UNI; ユーザ ネットワーク インターフェイス)のユーザ側だけがサポートされます。UNI のネットワーク側はサポートされません。

Ethernet/VLAN インターワーキングの制約事項

イーサネット/VLAN インターワーキングには、次の制約事項が適用されます。

VLAN to Ethernet インターワーキング、VLAN to Frame Relay(ルーテッド)、またはイーサネット(ブリッジ型)インターワーキングを使用した ATM を設定すると、CE ルータから VLAN タグ付きフレームを受信するイーサネット側の PE ルータによって VLAN タグが削除されます。逆方向では、PE ルータはフレームを CE ルータに送信する前にフレームに VLAN タグを追加します。

interworking vlan コマンドで L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能をイネーブルにした場合は、VLAN ID がイーサネット フレームの一部として含まれます。詳細については、「VLAN インターワーキング」を参照してください。)

VLAN からフレームリレーへのブリッジ型インターワーキングでは、フレームリレー PE ルータによって、受信したイーサネット トラフィックから VLAN タグが取り除かれます。

Cisco 10720 インターネット ルータでは、L2TPv3 上でだけ Ethernet to VLAN インターワーキング イーサネットがサポートされます。

RAW イーサネット ポートまたは VLAN トランクのイーサネット インターワーキングはサポートされません。異なる転送タイプ間でトラフィックが送信されると、トラフィック ストリームは分離されません。

ルータ モードでは、イーサネット PE ルータに CE ルータを 1 台だけ接続できます。

接続回線と疑似配線は 1 対 1 の関係である必要があります。ポイントツーマルチポイントまたはマルチポイントツーポイント設定はサポートされません。

イーサネットから非イーサネットへの設定では、CE ルータにポイントツーポイント オペレーションのルーティング プロトコルを設定します。

IP インターワーキング モードでは、IPv4(0800)変換がサポートされます。PE ルータは ARP(0806)パケットをキャプチャし、独自の MAC アドレス(プロキシ ARP)で応答します。その他はすべてドロップされます。

イーサネットまたは VLAN には、2 台の IP デバイス(PE ルータと CE ルータ)だけが含まれている必要があります。PE ルータはプロキシ ARP を実行し、受信したすべての ARP 要求に応答します。したがって、イーサネットまたは VLAN セグメントには、CE 1 台と PE ルータ 1 台のみ存在できます。

CE ルータによってスタティック ルーティングが実行されている場合、次のタスクを実行できます。

CE ルータにトラフィックを正しく転送するには、PE ルータが CE ルータの MAC アドレスを認識している必要があります。イーサネット PE ルータは、Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)Router Discovery Protocol(RDP; ルータ ディスカバリ プロトコル)請求メッセージを、送信元 IP アドレスをゼロとして送信します。イーサネット CE ルータは、この請求メッセージに応答します。ICMP RDP 請求メッセージに応答するように Cisco CE ルータのイーサネットまたは VLAN インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで ip irdp コマンドを発行します。CE ルータを設定しないと、CE ルータによって PE ルータにトラフィックが送信されるまで、トラフィックはドロップされます。

CE ルータで Router Discovery Protocol を実行しないようにするには、インターフェイス モードで ip irdp maxadvertinterval 0 コマンドを実行します。

この制限は、CE ルータとして Catalyst スイッチを使用してイーサネットと VLAN の間にインターワーキングを設定した場合に適用されます。スパニング ツリー プロトコルは、イーサネット インターワーキングに対してサポートされます。イーサネット ポートおよび VLAN 間のイーサネット インターワーキングでは、VLAN 1 でのみスパニング ツリー プロトコルがサポートされます。VLAN 1 を非ネイティブ VLAN として設定します。

イーサネット PE ルータ上のインターワーキング設定を変更する場合は、隣接する CE ルータ上の ARP エントリをクリアして、新しい MAC アドレスを学習できるようにします。このように設定しないと、トラフィック ドロップが発生する可能性があります。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション の制約事項

次の制約事項は、VLAN ID をイーサネット フレームの一部として含められるようにする L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能に適用されます。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能は次のリリースでサポートされます。

Cisco Catalyst 3750 Metro スイッチ用 Cisco IOS release 12.2(52)SE

Cisco 7600 シリーズ ルータ用 Cisco IOS Release 12.2(33)SRE

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション は、L2TPv3 ではサポートされません。この機能は、AToM でのみ設定できます。

PE ルータ上のインターフェイスが VLAN インターフェイスの場合は、PE ルータで必ずしも interworking vlan コマンドを指定する必要はありません。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション 機能は次の接続回線の組合せでのみ使用できます。

Ethernet to Ethernet

Ethernet to VLAN

VLAN to VLAN

PE ルータにインターワーキング タイプを指定した場合は、そのインターワーキング タイプが適用される必要があります。両方の PE ルータでインターワーキング タイプが一致している必要があります。一致していないと、VC がダウン状態のままになる非互換状態が発生します。接続回線(AC)が VLAN の場合は、PE ルータは、Label Distribution Protocol(LDP; ラベル配布プロトコル)を使用して VC タイプをネゴシエーション(自動検知)できます。

たとえば、PE1 および PE2 の両方でイーサネット インターフェイスが使用され、VLAN インターワーキングは PE1 のみで指定されます。PE2 にはインターワーキング タイプが設定されず、インターワーキング タイプを自動検出できません。その結果、VC がダウン状態のままになる非互換状態が発生します。

一方、PE1 でイーサネット インターフェイスが使用され、VLAN インターワーキングがイネーブルになっていて(これにより VLAN が VC タイプとして適用されます)、PE2 で VLAN インターフェイスが使用され、インターワーキングがイネーブルになっていない場合(これにより、PE2 ではイーサネットがデフォルトの VC タイプとして使用されます)、PE2 ではインターワーキング タイプを自動検知およびネゴシエーションし、VLAN を VC タイプとして選択できます。

表 4 に、ネゴシエーション後の AC タイプ、インターワーキング オプション、および VC タイプの概要を示します

表 4 ネゴシエート イーサネットおよび VLAN インターワーキング タイプ

PE1 AC Type
インターワーキング オプション
PE2 AC タイプ
インターワーキング オプション
ネゴシエーション後の VC タイプ

イーサネット

none

イーサネット

none

イーサネット

Vlan

none

イーサネット

none

イーサネット

イーサネット

none

Vlan

none

イーサネット

Vlan

none

Vlan

none

イーサネット

イーサネット

Vlan

イーサネット

none

互換性なし

Vlan

Vlan

イーサネット

none

互換性なし

イーサネット

Vlan

Vlan

none

Vlan

Vlan

Vlan

Vlan

none

Vlan

イーサネット

none

イーサネット

Vlan

互換性なし

Vlan

none

イーサネット

Vlan

Vlan

イーサネット

none

Vlan

Vlan

互換性なし

Vlan

none

Vlan

Vlan

Vlan

イーサネット

Vlan

イーサネット

Vlan

Vlan

Vlan

Vlan

イーサネット

Vlan

Vlan

イーサネット

Vlan

Vlan

Vlan

Vlan

Vlan

Vlan

Vlan

Vlan

Vlan

フレームリレー インターワーキングの制約事項

フレームリレー インターワーキングには、次の制約事項が適用されます。

接続回線の Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズは、MPLS を介して接続する場合に一致している必要があります。デフォルトでは、フレームリレー DLCI に関連付けられている MTU サイズはインターフェイス MTU です。これにより、たとえば PoS インターフェイス(デフォルトの MTU は 4470 バイト)上の一部の DLCI をイーサネットまたは VLAN(デフォルトの MTU は 1500 バイト)に接続し、同じ PoS インターフェイス上の他の DLCI を ATM(デフォルトの MTU は 4470 バイト)に接続する場合などに、問題が発生する場合があります。インターフェイス MTU すべてを最小公分母(ここでは 1500 バイト)に戻さないようにするため、 mtu コマンドを使用して DLCI の MTU を指定します。

DLCI モードのみがサポートされます。ポート モードはサポートされません。

DCE または Network-to-Network Interface(NNI; ネットワーク間インターフェイス)を使用するようにフレームリレー スイッチングを設定します。DTE モードでは、Local Management Interface(LMI; ローカル管理インターフェイス)プロセスでステータスはレポートされません。Frame Relay over MPLS 回線で障害が発生し、PE ルータが DTE モードの場合、CE ルータには、回線がディセーブルであることが通知されません。DCE または NNI を設定するには、グローバル コンフィギュレーション モードで frame-relay switching コマンドを設定します。

フレームリレー ポリシングは、Cisco 7500 シリーズ ルータ上で配信されません。フレームリレー ポリシングをイネーブルにした場合は、トラフィックがルート スイッチ プロセッサに送信されて処理されます。

Inverse Address Resolution Protocol(ARP; アドレス解決プロトコル)は IP インターワーキングでサポートされません。CE ルータでは、ポイントツーポイント サブインターフェイスまたはスタティック マップを使用してください。

PE ルータによって、CE から送信されるシスコのカプセル化方式と
Internet Engineering Task Force(IETF)カプセル化方式の変換が自動的にサポートされますが、CE ルータに送信する場合は IETF のみ変換されます。これは、シスコ カプセル化方式で送信するように設定されている場合でも Cisco CE ルータでは IETF カプセル化方式が受信時に処理されるため、Cisco CE ルータでは問題が発生しません。

イーサネット インターワーキングでは、次の変換がサポートされます。

LAN Frame Check Sequence(FCS; フレーム チェック シーケンス)のないイーサネット(0300800080C20007 または 6558)

スパニング ツリー(0300800080C2000E または 4242)

その他すべての変換はドロップされます。

IP インターワーキングでは、IPv4(03CC または 0800)変換がサポートされます。その他すべての変換はドロップされます。

PVC ステータス シグナリングは、like-to-like の場合と同様に動作します。PE ルータでは、擬似回線のアベイラビリティに基づいて PVC ステータスが CE ルータにレポートされます。PE ルータによって検出された PVC ステータスも、擬似回線に反映されます。LMI to OAM インターワーキングは、ATM にフレームリレーを接続するとサポートされます。

PPP インターワーキングの制約事項

PPP インターワーキングには次の制約事項があります。

PPP セッションと疑似配線は 1 対 1 の関係である必要があります。擬似回線上での複数の PPP セッションの多重化はサポートされません。

PPP セッションとフレームリレー DLCI は 1 対 1 の関係である必要があります。フレームリレー PVC にはそれぞれ PPP セッションが 1 つ必要です。

IP(IPv4(0021)インターワーキングのみがサポートされます。Link Control Protocol(LCP; リンク制御プロトコル)パケットおよび Internet Protocol Control Protocol(IPCP; インターネット プロトコル制御プロトコル)パケットは PE ルータで終端されます。その他はすべてドロップされます。

IP インターワーキングが疑似配線に設定されると、プロキシ IPCP は PE ルータで自動的にイネーブルにされます。

デフォルトでは、PE ルータは CE ルータがリモート CE ルータの IP アドレスを認識していると想定します。

Password Authentication Protocol(PAP; パスワード認証プロトコル)および Challenge-Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)認証がサポートされています。

L2VPN インターワーキングについて

次の各項では、L2VPN インターワーキングの概要を説明します。

「L2VPN インターワーキングの概要」

「L2VPN インターワーキング モード」

「L2VPN インターワーキング:サポート マトリクス」

「PPP の L2VPN インターワーキング用のスタティック IP アドレス」

L2VPN インターワーキングの概要

MPLS および IP を介したレイヤ 2 トランスポートは、Ethernet-to-Ethernet や PPP-to-PPP などの like-to-like 接続回線に対してすでに存在します。L2VPN インターワーキングはこの機能に基づいて構築されており、異なる接続回線どうしが接続できる機能を備えています。インターワーキング機能によって、異なるレイヤ 2 カプセル化間の変換が容易になります。図 1 に、ATM およびフレームリレー パケットが MPLS クラウドを介して伝送されるレイヤ 2 インターワーキングの例を示します。

図 1 ATM to Frame Relay インターワーキングの例

L2VPN インターワーキング機能では、MPLS および L2TPv3 を介したイーサネット、802.1Q(VLAN)、フレームリレー、ATM AAL5、および PPP 接続回線がサポートされます。like-to-like 機能の機能と制約は、L2VPN インターワーキングにも適用されます。

L2VPN インターワーキング モード

L2VPN インターワーキングは、イーサネット(「ブリッジ型」)モード、IP(「ルーテッド」)、またはイーサネット VLAN モードで使用できます。擬似回線クラス コンフィギュレーション モードで interworking { ethernet | ip |vlan } コマンドを発行することにより、モードを指定します。

イーサネット(ブリッジ型)インターワーキング

ethernet キーワードを指定すると、接続回線からイーサネット フレームが抽出されて、疑似配線に送信されます。イーサネット エンドツーエンド送信が想定されます。イーサネットでない接続回線フレームはドロップされます。VLAN の場合、VLAN タグが削除され、タグなしイーサネット フレームが残されます。

イーサネット インターワーキングは、ブリッジ型インターワーキングとも呼ばれます。イーサネット フレームは、擬似回線を介してブリッジされます。CE ルータは、ネイティブでイーサネットをブリッジすることも、Bridge Virtual Interface(BVI; ブリッジ仮想インターフェイス)や RBE などのブリッジ型カプセル化を使用してルーティングすることもできます。PE ルータは、イーサネット like-to-like モードで動作します。

このモードは次のサービスを実現するために使用します。

LAN サービス:たとえば、複数のサイトを有する企業が、いくつかのサイトでサービス プロバイダー(SP)ネットワークへのアクセスにイーサネット接続を使用して、その他のサイトでは、ATM 接続を使用する場合などです。企業はすべてのサイトへの LAN 接続を必要とします。この場合、1 つのサイトのイーサネットまたは VLAN からのトラフィックを IP/MPLS ネットワーク経由で送信し、別のサイトの ATM VC 上のブリッジ型トラフィックとしてカプセル化できます。

接続サービス:たとえば、Internal Gateway Protocol(IGP)ルーティング プロトコルを実行する複数のサイトを有する企業で、ブロードキャスト リンクと非ブロードキャスト リンクのプロシージャに互換性がない場合などです。ここでは、いくつかのサイトで Open Shortest Path First(OSPF)または Intermediate System to Intermediate System(IS-IS)などの IGP が実行されています。このような場合、一部のプロシージャ(ルート アドバタイズメントや指定ルータなど)は、基礎となる レイヤ 2 プロトコルに依存し、ポイントツーポイント ATM 接続とブロードキャスト イーサネット接続とでは異なります。したがって、ATM 上でのブリッジ型カプセル化を使用して、IGP を実行している CE ルータ間の同種イーサネット接続を実現できます。

IP(ルーテッド)インターワーキング

ip キーワードを指定すると、接続回線から IP パケットが抽出されて、疑似配線に送信されます。IPv4 パケットを含まない接続回線フレームはドロップされます。

IP インターワーキングは、ルーテッド インターワーキングとも呼ばれます。CE ルータは CE と PE ルータ間のリンクの IP をカプセル化します。MPLS および L2TPv3 の IP 疑似配線に信号を発信するのに新しい VC タイプが使用されます。疑似配線をまたいだレイヤ 2 と IP カプセル化の変換が必要です。異なるレイヤ 2 カプセル化では処理が異なるため、アドレス解決とルーティング プロトコルの処理について、特別な配慮が必要です。

このモードを使用して、サイトへのレイヤ 2 接続にかかわらず、これらのサイト間に IP 接続を提供します。本質的にはポイントツーポイントであり、サービス プロバイダーはカスタマーのルーティング情報を保持しないため、レイヤ 3 VPN とは異なります。

アドレス解決は、次のようにカプセル化に依存します。

イーサネットでは、ARP を使用

フレームリレーおよび ATM では、Inverse ARP を使用

PPP では、IPCP を使用

したがって、アドレス解決を PE ルータで終端する必要があります。エンドツーエンドのアドレス解決はサポートされません。ルーティング プロトコルは、ブロードキャストとポイントツーポイント メディアでは異なる動作をします。イーサネットでは、CE ルータでスタティック ルーティングを使用するか、イーサネット側をポイントツーポイント ネットワークとして扱うルーティング プロトコルを設定する必要があります。

VLAN インターワーキング

vlan キーワードにより、VLAN ID をイーサネット フレームの一部として含めることができます。Cisco IOS Release 12.2(52)SE では、イーサネット(ブリッジ型)インターワーキングにイーサネット VLAN を使用するように Catalyst 3750 Metro スイッチを設定できます。擬似回線クラス コンフィギュレーション モードで interworking vlan コマンドを発行することにより、イーサネット VLAN(タイプ 4)を指定できます。これにより、VLAN ID をイーサネット フレームの一部として含めることができます。Cisco IOS Release 12.2(52)SE よりも前のリリースでは、VLAN カプセル化の実行には、イーサネット VLAN インターフェイス/サブインターフェイスを介して CE ルータを PE ルータに接続する必要がありました。

L2VPN インターワーキング:サポート マトリクス

サポートされる L2VPN インターワーキング 機能を 表 5 に示します。

表 5 L2VPN インターワーキングでサポートされる機能

機能
MPLS または L2TPv3 のサポート
IP またはイーサネットのサポート

Ethernet/VLAN to ATM AAL5

MPLS
L2TPv3(12000 シリーズのみ)

IP
イーサネット

Ethernet/VLAN to Frame Relay

MPLS
L2TPv3

IP
イーサネット

Ethernet/VLAN to PPP

MPLS

IP

Ethernet to VLAN

MPLS
L2TPv3

IP
イーサネット1

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション

MPLS

イーサネット VLAN

Frame Relay to ATM AAL5

MPLS
L2TPv3(12000 シリーズのみ)

IP

Frame Relay to Ethernet または VLAN

MPLS
L2TPv3

IP
イーサネット

Frame Relay to PPP

MPLS
L2TPv3

IP

注: Cisco 12000 シリーズのインターネット ルータ上では、次のようになります。

イーサネット(ブリッジ型)インターワーキングは L2TPv3 に対してサポートされません。

IP(ルーテッド)インターワーキングは、( sequencing コマンドを使用して)データ シーケンス用に設定された L2TPv3 擬似回線ではサポートされません。

1.L2VPN インターワーキングあり:AToM 機能の VLAN イネーブル/ディセーブル オプション、VLAN インターワーキングもサポートされます。詳細については、「VLAN インターワーキング」を参照してください。

PPP の L2VPN インターワーキング用のスタティック IP アドレス

PPP のローカル CE ルータを使用して PE ルータでアドレス解決する場合、PE ルータ上でリモート CE ルータの IP アドレスを設定できます。PE ルータの xconnect PPP インターフェイス上のリモート CE ルータの IP アドレスを指定して ppp ipcp address proxy コマンドを実行します。次の例は、設定サンプルを示しています。

pseudowire-class ip-interworking
encapsulation mpls
interworking ip
 
interface Serial2/0
encapsulation ppp
xconnect 10.0.0.2 200 pw-class ip-interworking
ppp ipcp address proxy 10.65.32.14
 

ローカル CE ルータでアドレス解決を実行する場合は、 peer default ip address コマンドを使用して、ローカル CE ルータ上にリモート CE ルータの IP アドレスを設定することもできます。

L2VPN インターワーキングの設定方法

ここでは、L2VPN インターワーキングを設定するために実行できる作業について説明します。

「L2VPN インターワーキングの設定」(必須)

「L2VPN インターワーキング設定の確認」(任意)

「L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション の設定」(任意)

L2VPN インターワーキングの設定

L2VPN インターワーキングを使用すると異なる接続回線どうしが接続できます。L2VPN インターワーキング機能を設定するには、 interworking コマンドを疑似配線を構成するコマンド リストに追加する必要があります。ここでは、L2VPN インターワーキングの疑似配線を設定する手順を説明します。全体的な AToM または L2TPv3 設定の一部として、 interworking コマンドを使用します。AToM または L2TPv3 の設定に関する詳細については、次のマニュアルを参照してください。

『Layer 2 Tunnel Protocol Version 3』

『Any Transport over MPLS』

手順の概要

1. enable

2. configure terminal

3. hw-module slot slot-number np mode feature

4. pseudowire-class name

5. encapsulation { mpls | l2tpv3 }

6. interworking { ethernet | ip | vlan }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hw-module slot slot-number np mode feature
 

Router(config)# hw-module slot 3 np mode feature

(任意)Cisco 12000 シリーズ ルータの L2VPN インターワーキング機能をイネーブルにします。

コマンドを入力してラインカードの L2VPN 機能バンドルをイネーブルにする必要があります。

ステップ 4

pseudowire-class name

 

Router(config)# pseudowire-class class1

指定した名前の疑似回線クラスを確立して、疑似配線クラスコンフィギュレーション モードに入ります。

ステップ 5

encapsulation { mpls | l2tpv3 }

 

Router(config-pw)# encapsulation mpls

トンネリング カプセル化を指定します。これは mpls または l2tpv3 です。

ステップ 6

interworking { ethernet | ip } | vlan }

 

Router(config-pw)# interworking ip

擬似回線のタイプと、その回線を流れるトラフィックのタイプを指定します。

コマンドを入力できません。

L2VPN インターワーキング設定の確認

L2VPN インターワーキング設定を確認するには、次のコマンドを使用します。

手順の概要

1. enable

2. show l2tun session all

3. show arp

4. ping

5. show l2tun session interworking

6. show mpls l2transport vc detail

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2 show l2tun session all(L2TPv3 のみ)

L2TPv3 では、PE ルータで show l2tun session all コマンドを使用して、L2VPN インターワーキング設定を確認できます。

次の例では、インターワーキング タイプを太字で示します。

PE1
PE2

Router# show l2tun session all

 

Session Information Total tunnels 1 sessions 1

 

Session id 15736 is up, tunnel id 35411

Call serial number is 4035100045

Remote tunnel name is PE2

Internet address is 10.9.9.9

Session is L2TP signalled

Session state is established, time since change 1d22h

16 Packets sent, 16 received

1518 Bytes sent, 1230 received

Receive packets dropped:

out-of-order: 0

total: 0

Send packets dropped:

exceeded session MTU: 0

total: 0

Session vcid is 123

Session Layer 2 circuit, type is Ethernet, name is FastEthernet1/1/0

Circuit state is UP

Remote session id is 26570, remote tunnel id 46882

DF bit off, ToS reflect disabled, ToS value 0, TTL value 255

No session cookie information available

FS cached header information:

encap size = 24 bytes

00000000 00000000 00000000 00000000

00000000 00000000

Sequencing is off

Router# show l2tun session all

 

Session Information Total tunnels 1 sessions 1

 

Session id 26570 is up, tunnel id 46882

Call serial number is 4035100045

Remote tunnel name is PE1

Internet address is 10.8.8.8

Session is L2TP signalled

Session state is established, time since change 1d22h

16 Packets sent, 16 received

1230 Bytes sent, 1230 received

Receive packets dropped:

out-of-order: 0

total: 0

Send packets dropped:

exceeded session MTU: 0

total: 0

Session vcid is 123

Session Layer 2 circuit, type is Ethernet Vlan, name is FastEthernet2/0.1:10

Circuit state is UP, interworking type is Ethernet

Remote session id is 15736, remote tunnel id 35411

DF bit off, ToS reflect disabled, ToS value 0, TTL value 255

No session cookie information available

FS cached header information:

encap size = 24 bytes

00000000 00000000 00000000 00000000

00000000 00000000

Sequencing is off

 

ステップ 3 show arp

CE ルータ間で show arp コマンドを実行して、データが送信されていることを確認できます。

Router# show arp
 
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.1.1.5 134 0005.0032.0854 ARPA FastEthernet0/0
Internet 10.1.1.7 - 0005.0032.0000 ARPA FastEthernet0/0
 

ステップ 4 ping

CE ルータ間で ping コマンドを実行して、データが送信されていることを確認できます。

Router# ping 10.1.1.5
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

ステップ 5 show l2tun session interworking(L2TPv3 のみ)

L2TPv3 の場合、インターワーキング タイプが正しく設定されていることを確認するには、 show l2tun session interworking コマンドを実行します。インターワーキング変換を実行している PE ルータ上でコマンドを入力します。

例 1 では、PE ルータによって RAW イーサネット変換が実行されます。コマンド出力には、インターワーキング タイプがダッシュ(-)付きで表示されます。

例 2 では、PE ルータによってイーサネット VLAN 変換が実行されます。コマンド出力には、インターワーキング タイプが ETH と表示されます。

例 1 Raw イーサネット変換のコマンド出力

Router# show l2tun session interworking
 
Session Information Total tunnels 1 sessions 1
 
LocID TunID Peer-address Type IWrk Username, Intf/Vcid, Circuit
15736 35411 10.9.9.9 ETH - 123, Fa1/1/0

例 2 イーサネット VLAN 変換のコマンド出力

Router# show l2tun session interworking
 
Session Information Total tunnels 1 sessions 1
 
LocID TunID Peer-address Type IWrk Username, Intf/Vcid, Circuit
26570 46882 10.8.8.8 VLAN ETH 123, Fa2/0.1:10
 

ステップ 6 show mpls l2transport vc detail(AToM のみ)

AToM の設定を確認するには、 show mpls l2transport vc detail コマンドを使用します。次の例では、インターワーキング タイプを太字で示します。

PE1
PE2

Router# show mpls l2transport vc detail

 

Local interface: Fa1/1/0 up, line protocol up, Ethernet up

Destination address: 10.9.9.9, VC ID: 123, VC status: up

Preferred path: not configured

Default path: active

Tunnel label: 17, next hop 10.1.1.3

Output interface: Fa4/0/0, imposed label stack {17 20}

Create time: 01:43:50, last status change time: 01:43:33

Signaling protocol: LDP, peer 10.9.9.9:0 up

MPLS VC labels: local 16, remote 20

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 15, send 4184

byte totals: receive 1830, send 309248

packet drops: receive 0, send 0

Router# show mpls l2transport vc detail

 

Local interface: Fa2/0.3 up, line protocol up, Eth VLAN 10 up

MPLS VC type is Ethernet, interworking type is Ethernet

Destination address: 10.8.8.8, VC ID: 123, VC status: up

Preferred path: not configured

Default path: active

Tunnel label: 16, next hop 10.1.1.3

Output interface: Fa6/0, imposed label stack {16 16}

Create time: 00:00:26, last status change time: 00:00:06

Signaling protocol: LDP, peer 10.8.8.8:0 up

MPLS VC labels: local 20, remote 16

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 5, send 0

byte totals: receive 340, send 0

packet drops: receive 0, send 0

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション の設定

擬似回線クラス コンフィギュレーション モードで interworking vlan コマンドを発行することにより、イーサネット VLAN(タイプ 4)を指定できます。これにより、VLAN ID をイーサネット フレームの一部として含めることができます。Cisco IOS Release 12.2(52)SE および Cisco IOS Release 12.2(33)SRE よりも前のリリースでは、VLAN カプセル化の実行には、イーサネット リンクを介して CE ルータを PE ルータに接続する必要がありました。

制約事項

Cisco IOS Release 12.2(52)SE および Cisco IOS Release 12.2(33)SRE では、 encapsulation コマンドで mpls キーワードだけがサポートされます。 l2tpv3 キーワードはサポートされていません。 interworking コマンドでは、 ethernet および vlan キーワードのみサポートされます。 ip キーワードはサポートされていません。

前提条件

AToM の詳細な設定手順については、『 Any Transport over MPLS 』を参照してください。

手順の概要

1. enable

2. configure terminal

3. pseudowire-class name

4. encapsulation { mpls | l2tpv3 }

5. interworking { ethernet | ip | vlan }

6. end

7. show mpls l2transport vc [ vcid vc-id | vcid vc-id-min vc-id-max ] [ interface type number [ local-circuit-id ]] [ destination ip-address | name ] [ detail ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class name

 

Router(config)# pseudowire-class class1

指定した名前の疑似回線クラスを確立して、疑似配線クラスコンフィギュレーション モードに入ります。

ステップ 4

encapsulation { mpls | l2tpv3 }

 

Router(config-pw)# encapsulation mpls

トンネリング カプセル化を指定します。これは mpls または l2tpv3 です。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション 機能では、MPLS カプセル化方式のみサポートされています。

ステップ 5

interworking { ethernet | ip | vlan }

 

Router(config-pw)# interworking vlan

擬似回線のタイプと、その回線を流れるトラフィックのタイプを指定します。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション 機能では、 vlan キーワードを指定します。

ステップ 6

end

 

Router(config-pw)# end

疑似配線クラス コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ステップ 7

show mpls l2transport vc [ vcid vc-id | vcid vc-id-min vc-id-max ] [ interface type number [ local-circuit-id ]] [ destination ip-address | name ] [ detail ]

 

Router# show mpls l2transport vc detail

AToM VC に関する情報を表示します。

インターフェイス上の擬似回線が VC タイプと異なる場合は、インターワーキング タイプが show mpls l2transport vc detail コマンドの出力に表示されます。次の例では、疑似配線はイーサネット ポートに設定され、VLAN インターワーキングは疑似配線クラスに設定されます。出力を太字で示します。

PE1# show mpls l2 vc 34 detail
 
Local interface: Et0/1 up, line protocol up, Ethernet up
MPLS VC type is Ethernet, interworking type is Eth VLAN
Destination address: 10.1.1.2, VC ID: 34, VC status: down
Output interface: if-?(0), imposed label stack {}
Preferred path: not configured
Default path: no route
No adjacency
Create time: 00:00:13, last status change time: 00:00:13
Signaling protocol: LDP, peer unknown
Targeted Hello: 10.1.1.1(LDP Id) -> 10.1.1.2
Status TLV support (local/remote) : enabled/None (no remote binding)
LDP route watch : enabled
Label/status state machine : local standby, AC-ready, LnuRnd
Last local dataplane status rcvd: No fault
Last local SSS circuit status rcvd: No fault
Last local SSS circuit status sent: Not sent
Last local LDP TLV status sent: None
Last remote LDP TLV status rcvd: None (no remote binding)
Last remote LDP ADJ status rcvd: None (no remote binding)
MPLS VC labels: local 2003, remote unassigned
Group ID: local 0, remote unknown
MTU: local 1500, remote unknown
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0

L2VPN インターワーキングの設定例

次の各項では、L2VPN インターワーキングの例を示します。

「Ethernet to VLAN over L2TPV3(ブリッジ型):例」

「Ethernet to VLAN over AToM(ブリッジ型):例」

「Frame Relay to VLAN over L2TPV3(ルーテッド):例」

「Frame Relay to VLAN over AToM(ルーテッド):例」

「Frame Relay to ATM AAL5 over AToM(ルーテッド):例」

「VLAN to ATM AAL5 over AToM(ブリッジ型):例」

「Frame Relay to PPP over L2TPv3(ルーテッド):例」

「Frame Relay to PPP over AToM(ルーテッド):例」

「Ethernet/VLAN to PPP over AToM(ルーテッド):例」

「参考資料」

Ethernet to VLAN over L2TPV3(ブリッジ型):例

次の例は、Ethernet to VLAN over L2TPv3 の設定を示しています。

PE1
PE2

ip cef

!

l2tp-class interworking-class

authentication

hostname PE1

password 0 lab

!

pseudowire-class inter-ether-vlan

encapsulation l2tpv3

interworking ethernet

protocol l2tpv3 interworking-class

ip local interface Loopback0

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface FastEthernet1/0

xconnect 10.9.9.9 1 pw-class inter-ether-vlan

ip cef

!

l2tp-class interworking-class

authentication

hostname PE2

password 0 lab

!

pseudowire-class inter-ether-vlan

encapsulation l2tpv3

interworking ethernet

protocol l2tpv3 interworking-class

ip local interface Loopback0

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

!

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.3

encapsulation dot1Q 10

xconnect 10.8.8.8 1 pw-class inter-ether-vlan

Ethernet to VLAN over AToM(ブリッジ型):例

次の例は、Ethernet to VLAN over AToM の設定を示しています。

PE1
PE2

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom-eth-iw

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface FastEthernet1/0.1

encapsulation dot1q 100

xconnect 10.9.9.9 123 pw-class atom-eth-iw

 

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom

encapsulation mpls

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

!

interface FastEthernet0/0

no ip address

!

interface FastEthernet1/0

xconnect 10.9.9.9 123 pw-class atom

 

Frame Relay to VLAN over L2TPV3(ルーテッド):例

次の例は、Frame Relay to VLAN over L2TPv3 の設定を示しています。

PE1
PE2

configure terminal

ip cef

frame-relay switching

!

!

interface loopback 0

ip address 10.8.8.8 255.255.255.255

no shutdown

!

pseudowire-class ip

encapsulation l2tpv3

interworking ip

ip local interface loopback0

!

interface POS1/0

encapsulation frame-relay

clock source internal

logging event dlci-status-change

no shutdown

no fair-queue

!

connect fr-vlan POS1/0 206 l2transport

xconnect 10.9.9.9 6 pw-class ip

!

router ospf 10

network 10.0.0.2 0.0.0.0 area 0

network 10.8.8.8 0.0.0.0 area 0

configure terminal

ip routing

ip cef

frame-relay switching

!

interface loopback 0

ip address 10.9.9.9 255.255.255.255

no shutdown

!

pseudowire-class ip

encapsulation l2tpv3

interworking ip

ip local interface loopback0

!

interface FastEthernet1/0/1

speed 10

no shutdown

!

interface FastEthernet1/0/1.6

encapsulation dot1Q 6

xconnect 10.8.8.8 6 pw-class ip

no shutdown

!

router ospf 10

network 10.0.0.2 0.0.0.0 area 0

network 10.9.9.9 0.0.0.0 area 0

 

Frame Relay to VLAN over AToM(ルーテッド):例

次の例は、Frame Relay to VLAN over AToM の設定を示しています。

 

PE1
PE2

configure terminal

ip cef

frame-relay switching

!

mpls label protocol ldp

mpls ldp router-id loopback0

mpls ip

!

pseudowire-class atom

encapsulation mpls

interworking ip

!

interface loopback 0

ip address 10.8.8.8 255.255.255.255

no shutdown

!

connect fr-vlan POS1/0 206 l2transport

xconnect 10.9.9.9 6 pw-class atom

configure terminal

ip routing

ip cef

frame-relay switching

!

mpls label protocol ldp

mpls ldp router-id loopback0

mpls ip

!

pseudowire-class atom

encapsulation mpls

interworking ip

!

interface loopback 0

ip address 10.9.9.9 255.255.255.255

no shutdown

!

interface FastEthernet1/0/1.6

encapsulation dot1Q 6

xconnect 10.8.8.8 6 pw-class atom

no shutdown

Frame Relay to ATM AAL5 over AToM(ルーテッド):例


) Frame Relay to ATM AAL5 は、IP モードの AToM でだけ使用可能です。


次の例は、Frame Relay to ATM AAL5 over AToM の設定を示しています。

PE1
PE2

ip cef

frame-relay switching

mpls ip

mpls label protocol ldp

mpls ldp router-id loopback0 force

pseudowire-class fratmip

encapsulation mpls

interworking ip

interface Loopback0

ip address 10.33.33.33 255.255.255.255

interface serial 2/0

encapsulation frame-relay ietf

frame-relay intf-type dce

connect fr-eth serial 2/0 100 l2transport

xconnect 10.22.22.22 333 pw-class fratmip

interface POS1/0

ip address 10.1.7.3 255.255.255.0

crc 32

clock source internal

mpls ip

mpls label protocol ldp

router ospf 10

passive-interface Loopback0

network 10.33.33.33 0.0.0.0 area 10

network 10.1.7.0 0.0.0.255 area 10

ip cef

mpls ip

mpls label protocol ldp

mpls ldp router-id loopback0 force

pseudowire-class fratmip

encapsulation mpls

interworking ip

interface Loopback0

ip address 10.22.22.22 255.255.255.255

interface ATM 2/0

pvc 0/203 l2transport

encapsulation aa5snap

xconnect 10.33.33.33 333 pw-class fratmip

interface POS1/0

ip address 10.1.1.2 255.255.255.0

crc 32

clock source internal

mpls ip

mpls label protocol ldp

router ospf 10

passive-interface Loopback0

network 10.22.22.22 0.0.0.0 area 10

network 10.1.1.0 0.0.0.255 area 10

 

VLAN to ATM AAL5 over AToM(ブリッジ型):例

次の例は、VLAN to ATM AAL5 over AToM の設定を示しています。

PE1
PE2

ip cef

!

mpls ip

mpls label protocol ldp

mpls ldp router-id Loopback0

!

pseudowire-class inter-ether

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface ATM1/0.1 point-to-point

pvc 0/100 l2transport

encapsulation aal5snap

xconnect 10.9.9.9 123 pw-class inter-ether

!

interface FastEthernet1/0

xconnect 10.9.9.9 1 pw-class inter-ether

!

router ospf 10

log-adjacency-changes

network 10.8.8.8 0.0.0.0 area 0

network 10.1.1.1 0.0.0.0 area 0

ip cef

!

mpls ip

mpls label protocol ldp

mpls ldp router-id Loopback0

!

pseudowire-class inter-ether

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

!

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.1

encapsulation dot1Q 10

xconnect 10.8.8.8 123 pw-class inter-ether

!

router ospf 10

log-adjacency-changes

network 10.9.9.9 0.0.0.0 area 0

network 10.1.1.2 0.0.0.0 area 0

Frame Relay to PPP over L2TPv3(ルーテッド):例

次の例は、Frame Relay to PPP over L2TPv3 の設定を示しています。

PE1
PE2

ip cef

ip routing

!

!

!

pseudowire-class ppp-fr

encapsulation l2tpv3

interworking ip

ip local interface Loopback0

!

interface Loopback0

ip address 10.1.1.1 255.255.255.255

!

interface FastEthernet1/0/0

ip address 10.16.1.1 255.255.255.0

!

interface Serial3/0/0

no ip address

encapsulation ppp

ppp authentication chap

!

ip route 10.0.0.0 255.0.0.0 10.16.1.2

!

xconnect 10.2.2.2 1 pw-class ppp-fr

ppp ipcp address proxy 10.65.32.14

 

ip cef

ip routing

!

frame-relay switching

!

pseudowire-class ppp-fr

encapsulation l2tpv3

interworking ip

ip local interface Loopback0

!

interface Loopback0

ip address 10.2.2.2 255.255.255.255

!

interface FastEthernet1/0/0

ip address 10.16.2.1 255.255.255.0

!

interface Serial3/0/0

no ip address

encapsulation frame-relay

frame-relay intf-type dce

!

ip route 10.0.0.0 255.0.0.0 10.16.2.2

!

connect ppp-fr Serial3/0/0 100 l2transport

xconnect 10.1.1.1 100 pw-class ppp-fr

Frame Relay to PPP over AToM(ルーテッド):例

次の例は、Frame Relay to PPP over AToM の設定を示しています。

PE1
PE2

ip cef

ip routing

mpls label protocol ldp

mpls ldp router-id loopback0 force

!

!

!

pseudowire-class ppp-fr

encapsulation mpls

interworking ip

ip local interface Loopback0

!

interface Loopback0

ip address 10.1.1.1 255.255.255.255

!

interface FastEthernet1/0/0

ip address 10.16.1.1 255.255.255.0

mpls ip

label protocol ldp

!

interface Serial3/0/0

no ip address

encapsulation ppp

ppp authentication chap

xconnect 10.2.2.2 1 pw-class ppp-fr

ppp ipcp address proxy 10.65.32.14

!

ip route 10.0.0.0 255.0.0.0 10.16.1.2

 

ip cef

ip routing

mpls label protocol ldp

mpls ldp router-id loopback0 force

!

frame-relay switching

!

pseudowire-class ppp-fr

encapsulation mpls

interworking ip

ip local interface Loopback0

!

interface Loopback0

ip address 10.2.2.2 255.255.255.255

!

interface FastEthernet1/0/0

ip address 10.16.2.1 255.255.255.0

mpls ip

mpls label protocol ldp

!

interface Serial3/0/0

no ip address

encapsulation frame-relay

frame-relay intf-type dce

!

ip route 10.0.0.0 255.0.0.0 10.16.2.2

!

connect ppp-fr Serial3/0/0 100 l2transport

xconnect 10.1.1.1 100 pw-class ppp-fr

Ethernet/VLAN to PPP over AToM(ルーテッド):例

次の例は、Ethernet VLAN to PPP over AToM の設定を示しています。

PE1
PE2

configure terminal

mpls label protocol ldp

mpls ldp router-id Loopback0

mpls ip

!

pseudowire-class ppp-ether

encapsulation mpls

interworking ip

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

no shutdown

!

interface POS2/0/1

no ip address

encapsulation ppp

no peer default ip address

ppp ipcp address proxy 10.10.10.1

xconnect 10.9.9.9 300 pw-class ppp-ether

no shutdown

 

 

configure terminal

mpls label protocol ldp

mpls ldp router-id Loopback0

mpls ip

!

pseudowire-class ppp-ether

encapsulation mpls

interworking ip

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

no shutdown

!

interface vlan300

mtu 4470

no ip address

xconnect 10.8.8.8 300 pw-class ppp-ether

no shutdown

!

interface GigabitEthernet6/2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 300

switchport mode trunk

no shutdown

参考資料

ここでは、L2VPN インターワーキング機能に関する関連資料について説明します。

関連資料

関連項目
参照先

Layer 2 Tunnel Protocol Version 3

『Layer 2 Tunnel Protocol Version 3』

Any Transport over MPLS

『Any Transport over MPLS』

Cisco 12000 シリーズ ルータ ハードウェア サポート

『Cross-Platform Release Notes for Cisco IOS Release 12.0S』

Cisco 7600 シリーズ ルータ ハードウェア サポート

『Cisco 7600 Series Routers Documentation Roadmap』

『Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers』

Cisco 3270 シリーズ ルータ ハードウェア サポート

『Cisco IOS Software Releases 12.2SE Release Notes』

規格

規格
タイトル

draft-ietf-l2tpext-l2tp-base-03.txt

『Layer Two Tunneling Protocol (Version 3) 'L2TPv3'』

draft-martini-l2circuit-trans-mpls-09.txt

『Transport of Layer 2 Frames Over MPLS』

draft-ietf-pwe3-frame-relay-03.txt.

『Encapsulation Methods for Transport of Frame Relay over MPLS Networks』

draft-martini-l2circuit-encap-mpls-04.txt.

『Encapsulation Methods for Transport of Layer 2 Frames Over IP and MPLS Networks』

draft-ietf-pwe3-ethernet-encap-08.txt.

『Encapsulation Methods for Transport of Ethernet over MPLS Networks』

draft-ietf-pwe3-hdlc-ppp-encap-mpls-03.txt.

『Encapsulation Methods for Transport of PPP/HDLC over MPLS Networks』

draft-ietf-ppvpn-l2vpn-00.txt.

『An Architecture for L2VPNs』

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

L2VPN インターワーキングの機能情報

表 6 に、この機能のリリース履歴を示します。

一部のコマンドは、お使いの Cisco IOS ソフトウェア リリースで使用できないことがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 6 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 6 L2VPN インターワーキングの機能情報

機能名
リリース
機能情報

L2VPN インターワーキング

12.0(26)S
12.0(30)S
12.0(32)S
12.0(32)SY
12.2(33)SRA
12.4(11)T
12.2(33)SXH
12.2(33)SRD
12.2(52)SE
12.2(33)SRE

この機能により、異なる接続回線どうしを接続できます。インターワーキング機能によって、異なるレイヤ 2 カプセル化間の変換が容易になります。

この機能は、Cisco IOS Release 12.0(26)S で導入されました。

Cisco IOS Release 12.0(30)S では、Cisco 12000 シリーズ インターネット ルータのサポートが追加されました。

Cisco IOS Release 12.0(32)S では、Cisco 12000 シリーズ ルータで次の 4 つの転送タイプについてエンジン 5 ラインカード(SIP-401、SIP-501、SIP-600、SIP-601)がサポートされるようになりました。

Ethernet/VLAN to Frame Relay インターワーキング

Ethernet/VLAN to ATM AAL5 インターワーキング

Ethernet to VLAN インターワーキング

Frame Relay to ATM AAL5 インターワーキング

Cisco 12000 シリーズ インターネット ルータでは、L2TPv3 トンネリング用に設定されている IP Services Engine(ISE; IP サービス エンジン)とエンジン 5 ラインカードのサポートが追加されました(『 Layer 2 Tunnel Protocol Version 3 』を参照)。

Cisco IOS Release 12.2(33)SRA では、Cisco 7600 シリーズ ルータのサポートが追加されました。

Cisco IOS Release 12.4(11)T では、次の転送タイプがサポートされるようになりました。

Ethernet to VLAN インターワーキング

Ethernet/VLAN to Frame Relay インターワーキング

この機能は、Cisco IOS Release 12.2(33)SXH に統合されました。

Cisco IOS Release 12.2(33)SRD では、Cisco 7600 シリーズ ルータに対して、SIP-400 のルーテッド インターワーキングおよびブリッジ型インターワーキングがサポートされるようになりました。

Cisco IOS Release 12.2(52)SE では、Cisco 3750 Metro スイッチに対して L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション 機能が追加されました。

Cisco IOS Release 12.2(33)SRE では、Cisco 7600 シリーズ ルータに対して L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション 機能が追加されました。

次のコマンドが導入または変更されました。 interworking