Cisco IOS Configuration Fundamentals コンフィギュレーション ガイド
コンフィギュレーションのコンテキスト差分 ユーティリティ
コンフィギュレーションのコンテキスト差分ユーティリティ
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

コンフィギュレーションのコンテキスト差分ユーティリティ

この章の構成

コンフィギュレーションのコンテキスト差分ユーティリティの前提条件

コンフィギュレーションのコンテキスト差分ユーティリティの制約事項

コンフィギュレーションのコンテキスト差分ユーティリティについて

コンフィギュレーションのコンテキスト差分ユーティリティの利点

コンフィギュレーションのコンテキスト差分ユーティリティの出力形式

コンフィギュレーションのコンテキスト差分ユーティリティの使用方法

コンフィギュレーションのコンテキスト差分ユーティリティの使用

コンフィギュレーションのコンテキスト差分ユーティリティの設定例

比較操作:例

差分比較操作:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

の機能情報

コンフィギュレーションのコンテキスト差分ユーティリティ

コンフィギュレーションのコンテキスト差分ユーティリティ機能は、2 つのコンフィギュレーション ファイル(Cisco IOS Integrated File System(IFS)を通じてアクセス可能)を行ごとに比較し、その間の違いの一覧を生成する機能を提供します。生成される出力には、追加、変更、削除された設定行と、変更された設定行が存在するコンフィギュレーション モードに関する情報が含まれています。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「コンフィギュレーションのコンテキスト差分ユーティリティの機能情報」を参照してください。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の入手方法

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

コンフィギュレーションのコンテキスト差分ユーティリティの前提条件

コンフィギュレーションのコンテキスト差分ユーティリティ機能で使用されるコンフィギュレーション ファイルの形式は、次に示す標準的な Cisco IOS コンフィギュレーション ファイルのインデント ルールに準拠している必要があります。

新しい行のすべてのコマンドは、コマンドがコンフィギュレーション サブモードにない限り、インデントなしで開始します。

レベル 1 コンフィギュレーション サブモード内のコマンドは、スペース 1 個分インデントします。

レベル 2 コンフィギュレーション サブモード内のコマンドは、スペース 2 個分インデントします。

以降のサブモードのコマンドも同様にインデントします。

ルータには、比較する 2 つのコンフィギュレーション ファイルを合わせたサイズよりも大きい連続したメモリ ブロックが必要です。

コンフィギュレーションのコンテキスト差分ユーティリティの制約事項

ルータに、比較する 2 つのコンフィギュレーション ファイルを合わせたサイズよりも大きい連続したメモリ ブロックがない場合、比較操作に失敗します。

コンフィギュレーションのコンテキスト差分ユーティリティについて

コンフィギュレーションのコンテキスト差分ユーティリティ機能を使用する前に、次の概念について理解してください。

「コンフィギュレーションのコンテキスト差分ユーティリティの利点」

「コンフィギュレーションのコンテキスト差分ユーティリティの出力形式」

コンフィギュレーションのコンテキスト差分ユーティリティの利点

コンフィギュレーションのコンテキスト差分ユーティリティ機能は、2 つのコンフィギュレーション ファイル(Cisco IOS File System(IFS)を通じてアクセス可能)を行ごとに比較し、その間の違いの一覧を生成する機能を提供します。生成された出力に、次の項目に関する情報が含まれます。

追加、変更、削除された設定行。

変更された設定行が存在するコンフィギュレーション モード。

順序による影響を受ける設定行の場所の変更。たとえば、 ip access-list コマンドと community-lists コマンドは、コンフィギュレーション ファイル内での、同じ種類の他の Cisco IOS コマンドとの相対的な順序による影響を受けます。

コンフィギュレーションのコンテキスト差分ユーティリティの出力形式

比較操作

コンフィギュレーションのコンテキスト差分ユーティリティ機能は、2 つのコンフィギュレーション ファイルのファイル名を入力として使用します。比較操作が指定したファイルに対して実行され、2 つのファイルの間の差分が出力として生成されます。出力の解釈は、2 つのファイルの設定順序に依存します( show archive config differences コマンド)。このため、最初に入力したファイルのファイル名が file1、2 番目に入力したファイルのファイル名を file2 とします。生成される出力リストの各エントリの前には、見つかった差分の種類を示す固有のテキスト記号が付与されます。テキスト記号とその意味は次のとおりです。

マイナス記号(-)は、設定行が file1 に存在し file2 に存在しないことを示します。

プラス記号(+)は、設定行が file2 に存在し file1 に存在しないことを示します。

感嘆符(!)と説明用のコメントは、順序による影響を受ける設定行の場所が、file1 と file2 で異なることを示します。

差分比較操作

一部のアプリケーションでは、比較操作で生成される出力に、変更されていない(つまりマイナス記号もプラス記号もない)設定行が含まれている必要があります。そのようなアプリケーションのために、差分比較操作を実行できます。この操作では、指定されたコンフィギュレーション ファイルを実行コンフィギュレーション ファイルと比較します( show archive config incremental-diffs コマンド)。

差分比較操作を実行すると、実行コンフィギュレーション ファイルにない設定行(つまり、実行コンフィギュレーション ファイルと比較する、指定したファイルだけに現れる設定行)が出力として生成されます。感嘆符(!)と説明用のコメントは、順序による影響を受ける設定行の場所が、指定したコンフィギュレーション ファイルと実行コンフィギュレーション ファイルで異なることを示します。

コンフィギュレーションのコンテキスト差分ユーティリティの使用方法

ここでは、次の手順について説明します。

「コンフィギュレーションのコンテキスト差分ユーティリティの使用」(必須)

コンフィギュレーションのコンテキスト差分ユーティリティの使用

この作業では、コンフィギュレーションのコンテキスト差分ユーティリティ機能を使用する方法について説明します。

手順の概要

1. enable

2. show archive config differenc es [ file1 [ file2 ]]
または
show archive config incremental- diff s [ file ]

3. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show archive config differenc es [ file1 [ file2 ]]

または

show archive config incremental- diff s file

 

Router# show archive config differences running-config startup-config

または

 

Router# show archive config incremental-diffs nvram:startup-config

2 つのコンフィギュレーション ファイル(IFS を通じてアクセス可能)を行ごとに比較し、その間の差分の一覧を生成します。

または

指定したコンフィギュレーション ファイルと実行コンフィギュレーション ファイルを行ごとに比較し、実行コンフィギュレーション ファイルにない設定行の一覧を生成します。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

コンフィギュレーションのコンテキスト差分ユーティリティの設定例

ここでは、次の設定例について説明します。

「比較操作:例」

「差分比較操作:例」

比較操作:例

この例では、実行コンフィギュレーション ファイルとスタートアップ コンフィギュレーションに対して比較操作を行います。 表 1 に、この例で使用するコンフィギュレーション ファイルを示します。

表 1 比較操作の例で使用するコンフィギュレーション ファイル

実行コンフィギュレーション ファイル
スタートアップ コンフィギュレーション ファイル

no ip subnet-zero

ip cef

interface Ethernet1/0

ip address 10.7.7.7 255.0.0.0

no ip route-cache

no ip mroute-cache

duplex half

no ip classless

snmp-server community public RO

ip subnet-zero

ip cef

ip name-server 10.4.4.4

voice dnis-map 1

dnis 111

interface Ethernet1/0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

duplex half

ip default-gateway 10.5.5.5

ip classless

access-list 110 deny ip any host 10.1.1.1

access-list 110 deny ip any host 10.1.1.2

access-list 110 deny ip any host 10.1.1.3

snmp-server community private RW

次に、 show archive config differences コマンドからの出力例を示します。この出力例は、 表 1 のコンフィギュレーション ファイルに対して比較操作を行った結果です。

Router# show archive config differences running-config startup-config
 

+ip subnet-zero

+ip name-server 10.4.4.4

+voice dnis-map 1

+dnis 111

interface Ethernet1/0

+no ip address

+shutdown

+ip default-gateway 10.5.5.5

+ip classless

+access-list 110 deny ip any host 10.1.1.1

+access-list 110 deny ip any host 10.1.1.2

+access-list 110 deny ip any host 10.1.1.3

+snmp-server community private RW

-no ip subnet-zero

interface Ethernet1/0

-ip address 10.7.7.7 255.0.0.0

-no ip classless

-snmp-server community public RO

差分比較操作:例

この例では、スタートアップ コンフィギュレーション ファイルと実行コンフィギュレーション ファイルに対して差分比較操作を行っています。 表 2 に、この例で使用するコンフィギュレーション ファイルを示します。

表 2 差分比較操作の例で使用するコンフィギュレーション ファイル

スタートアップ コンフィギュレーション ファイル
実行コンフィギュレーション ファイル

ip subnet-zero

ip cef

ip name-server 10.4.4.4

voice dnis-map 1

dnis 111

interface Ethernet1/0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

duplex half

ip default-gateway 10.5.5.5

ip classless

access-list 110 deny ip any host 10.1.1.1

access-list 110 deny ip any host 10.1.1.2

access-list 110 deny ip any host 10.1.1.3

snmp-server community private RW

no ip subnet-zero

ip cef

interface Ethernet1/0

ip address 10.7.7.7 255.0.0.0

no ip route-cache

no ip mroute-cache

duplex half

no ip classless

snmp-server community public RO

次に、 show archive config incremental-diffs コマンドからの出力例を示します。この出力例は 表 2 のコンフィギュレーション ファイルに対して差分比較操作を行った結果です。

Router# show archive config incremental-diffs startup-config
 

ip subnet-zero

ip name-server 10.4.4.4

voice dnis-map 1

dnis 111

interface Ethernet1/0

no ip address

shutdown

ip default-gateway 10.5.5.5

ip classless

access-list 110 deny ip any host 10.1.1.1

access-list 110 deny ip any host 10.1.1.2

access-list 110 deny ip any host 10.1.1.3

snmp-server community private RW

その他の関連資料

ここでは、コンフィギュレーションのコンテキスト差分ユーティリティ機能に関する参考資料について説明します。

関連資料

関連項目
参照先

コンフィギュレーション ファイルの管理についての情報

『Managing Configuration Files』

コンフィギュレーション ファイルを管理するためのコマンド

Cisco IOS Configuration Fundamentals Command Reference

規格

規格
タイトル

この機能によりサポートされた新規標準または改訂標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

次に示すコマンドは、このモジュールに記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS Configuration Fundamentals Command Reference 』( http://www.cisco.com/en/US/docs/ios/fundamentals/command/reference/cf_book.html )を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、または『 Cisco IOS Master Commands List 』を参照してください。

show archive config differences

show archive config incremental-diffs

コンフィギュレーションのコンテキスト差分ユーティリティの機能情報

表 3 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージの各サポート情報を検索できます。 http://www.cisco.com/go/cfn にある Cisco Feature Navigator にアクセスしてください。Cisco.com のアカウントは必要ありません。


表 3 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 3 コンフィギュレーションのコンテキスト差分ユーティリティの機能情報

機能名
リリース
機能情報

コンフィギュレーションのコンテキスト差分ユーティリティ

12.3(4)T
12.2(25)S
12.2(27)SBC
12.2(33)SRA
12.2(33)SXH
12.2(33)SB

コンフィギュレーションのコンテキスト差分ユーティリティ機能は、2 つのコンフィギュレーション ファイルを行ごとに比較し、その間の違いの一覧を生成する機能を提供します。生成される出力には、追加、変更、削除された設定行と、変更された設定行が存在するコンフィギュレーション モードに関する情報が含まれています。

この機能は、12.3(4)T で初めて導入されました。

12.2(33)SB では、この機能が Cisco 10000 シリーズに実装されました。

この機能に関する詳細については、次の各項を参照してください。

「コンフィギュレーションのコンテキスト差分ユーティリティの利点」

「コンフィギュレーションのコンテキスト差分ユーティリティの出力形式」

「コンフィギュレーションのコンテキスト差分ユーティリティの使用」

この機能によって変更されたコマンドは、 show archive config differences show archive config incremental-diffs です。