Quality of Service ソリューション ガイド、 Cisco IOS Release 15.1S
Quality of Service:ポリシー集約
Quality of Service:ポリシー集約
発行日;2012/02/02 | 英語版ドキュメント(2011/04/29 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

Quality of Service:ポリシー集約

目次

QoS:ポリシー集約の前提条件

QoS:ポリシー集約の制約事項

QoS:ポリシー集約に関する情報

クラス定義文の中のフラグメントについて

Gigabit Etherchannel バンドル用のフラグメントについて

QoS:ポリシー集約の設定方法

インターフェイスに対する QoS:ポリシー集約の設定方法

ポリシー マップでのフラグメント トラフィック クラスの設定

サービス フラグメント トラフィック クラスの設定

Gigabit Etherchannels に対する QoS:ポリシー集約の設定方法

Gigabit Etherchannel メンバー リンク サブインターフェイス上でのフラグメントの設定

Gigabit Etherchannel バンドルをサポートする物理インターフェイス上でのサービス フラグメントの設定

QoS:ポリシー集約の設定例

QoS:ポリシー集約:例

Gigabit Etherchannel QoS:ポリシー集約:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

QoS:ポリシー集約の機能情報

用語集

Quality of Service:ポリシー集約

Quality of Service:ポリシー集約(QoS:ポリシー集約)機能を使用すると、同じ物理インターフェイス上の異なるポリシー マップのデフォルト トラフィック クラスを、モジュラ QoS CLI 内の 1 つのトラフィック クラスとして設定できます。

この章で紹介する機能情報の入手方法

お使いの Cisco IOS ソフトウェアが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールに記載されている機能に関するドキュメントへのリンク、および各機能がサポートされているリリースに関するリストについては、「QoS:ポリシー集約の機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

QoS:ポリシー集約の前提条件

この機能は、Modular Quality of Service(QoS)Command-Line interface(CLI; コマンド ライン インターフェイス)(MQC; モジュラ QoS コマンドライン インターフェイス)を使用して設定します。これは、同じ物理インターフェイスにアタッチされた複数のポリシー マップで、異なるポリシー マップ内の複数のデフォルト トラフィック クラスを同じように扱う QoS 設定で最も有効です。

QoS:ポリシー集約の制約事項

この機能は、複数のポリシー マップが同じ物理インターフェイスにアタッチされている場合にのみ働きます。この機能は、異なる物理インターフェイス上のポリシー マップのデフォルト トラフィック クラスをまとめて分類するためには使用できません。

QoS:ポリシー集約に関する情報

このセクションには次のトピックがあります。

「クラス定義文の中のフラグメントについて」

「Gigabit Etherchannel バンドル用のフラグメントについて」

クラス定義文の中のフラグメントについて

QoS:ポリシー集約では、クラス定義文にフラグメントという考え方が導入されます。ポリシー マップ中で、デフォルト トラフィック クラス定義文をフラグメントとしてマークできます。同じインターフェイス上の他のポリシー マップでも、必要に応じてそのデフォルト トラフィック クラス文をフラグメントとして定義できます。その後、サービス フラグメント クラス定義文を使用して個別のポリシー マップを作成し、すべてのフラグメントに 1 つのグループとして QoS を割り当てるために使用できます。

図 1 に、フラグメントを使用していない 3 つのポリシー マップがアタッチされた 1 つの物理インターフェイスの例を示します。各ポリシー マップにはデフォルト トラフィック クラスがあり、自身のポリシー マップ中のデフォルト トラフィックに対してのみトラフィックを分類できることに注意してください。

図 1 フラグメントを使用せずに設定された 3 つのポリシー マップ

図 2 に、フラグメントを使用して設定された同じ構成を示します。クラス定義文を使用した第 4 のポリシー マップが追加され、フラグメントがまとめて分類されています。デフォルト トラフィック クラスは、個々のポリシーマップ内の 3 つの個別のデフォルト トラフィック クラスとしてではなく、1 つのサービス フラグメント グループとして分類されます。

図 2 フラグメントを使用して設定された 3 つのポリシー マップ

Gigabit Etherchannel バンドル用のフラグメントについて

Gigabit Etherchannel(GEC)バンドルのすべてのメンバー リンクが同じ物理インターフェイス上にある場合、Gigabit Etherchannel に対してフラグメントを設定できます。特に、同じ物理インターフェイス上の VLAN がまとめられている場合、フラグメントを使用して、VLAN サブインターフェイス メンバー リンクの GEC バンドルのすべてのデフォルト トラフィックをまとめて扱うことを定義できます。

Gigabit Etherchannel バンドルに対してフラグメントが設定されている場合、 fragment キーワードを使用してデフォルト トラフィック クラスが設定されているポリシー マップは、メンバー サブインターフェイス リンクにアタッチされ、フラグメントをまとめて分類するために service-fragment キーワードを使用して設定されているポリシー マップは物理インターフェイスにアタッチされます。

QoS:ポリシー集約の設定方法

ここでは、次の手順について説明します。

「インターフェイスに対する QoS:ポリシー集約の設定方法」

「Gigabit Etherchannels に対する QoS:ポリシー集約の設定方法」

インターフェイスに対する QoS:ポリシー集約の設定方法

ここでは、次の手順について説明します。

「ポリシー マップでのフラグメント トラフィック クラスの設定」

「サービス フラグメント トラフィック クラスの設定」

ポリシー マップでのフラグメント トラフィック クラスの設定

ここでは、ポリシー マップでクラス ステートメントをフラグメントとして設定する方法について説明します。

前提条件

この手順では、デフォルト トラフィック クラスをポリシー マップでフラグメントとして設定する方法のみを示します。ポリシー マップでの他のクラスの設定や、ルータでの他のポリシー マップの設定手順は含まれていません。

すべてのポリシー マップと同様に、設定をインターフェイスにアタッチするまで、ネットワーク トラフィックはそれに従って管理されません。この手順では、ポリシー マップのインターフェイスへのアタッチ手順は扱っていません。

ポリシー マップのアタッチと削除については、次の点に注意してください。

QoS:ポリシー集約を設定するには、 service-fragment キーワードを含んでいるポリシー マップを最初にメイン インターフェイスにアタッチし、次に fragment キーワードを含んでいるポリシー マップをメイン インターフェイスにアタッチする必要があります。

QoS:ポリシー集約をディセーブルにするには、まず fragment キーワードを含んでいるポリシー マップをサブインターフェイスから削除し、次に service-fragment キーワードを含んでいるポリシー マップをサブインターフェイスから削除する必要があります。

制約事項

ポリシー マップ中のデフォルト クラス文だけをフラグメントとして設定できます。

フラグメントは、複数のポリシー マップが同じ物理インターフェイスにアタッチされている場合にのみ機能します。この手順は、異なる物理インターフェイス上のポリシー マップのフラグメントとしてデフォルト トラフィック クラスを分類するためには使用できません。

fragment キーワードが入力されているクラスではキューイング機能だけが許可され、 fragment キーワードが使用されているクラスでは 1 つ以上のキューイング機能を入力する必要があります。

fragment キーワードを使用したクラスがあるポリシー マップは、インターフェイスから出て行くトラフィックのみに適用できます( service-policy output コマンドを使用してインターフェイスにアタッチしたポリシー マップ)。

fragment キーワードは、子のポリシー マップでは入力できません。

手順の概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class class-default fragment fragment-class-name

5. qos-queueing-feature

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

Router(config)# policy-map subscriber1

設定するトラフィック ポリシーの名前を指定し、ポリシーマップ コンフィギュレーション モードを開始します。

ステップ 4

class class-default fragment fragment-class-name

 

Router(config-pmap)# class class-default fragment BestEffort

デフォルト トラフィック クラスをフラグメントとして指定し、フラグメント トラフィック クラスに名前を付けます。

ステップ 5

qos-queueing-feature

QoS コンフィギュレーション コマンドを入力します。フラグメントとして設定したデフォルト トラフィック クラスでは、キューイング機能だけがサポートされています。

現在サポートされているキューイング機能は、 bandwidth shape 、および random-detect exponential-weighting-constant です。

複数の QoS キューイング コマンドを入力できます。

次の例では、BestEffort という名前のフラグメントがポリシー マップ subscriber1 およびポリシー マップ subscriber 2 で作成されます。

policy-map subscriber1
class voice
set cos 5
priority level 1
class video
set cos 4
priority level 2
class class-default fragment BestEffort
shape average 200000000
bandwidth remaining ratio 10

policy-map subscriber 2
class voice
set cos 5
priority level 1
class video
set cos 4
priority level 2
class class-default fragment BestEffort
shape average 200000000
bandwidth remaining ratio 10

 

次の作業

フラグメントとして設定したクラス文に QoS を適用するには、ポリシー マップ中で複数のデフォルト クラス文をフラグメントとして設定した後、 service-fragment キーワードを使用したクラス文のある個別のポリシー マップを設定する必要があります。

この手順については、「サービス フラグメント トラフィック クラスの設定」を参照してください。

サービス フラグメント トラフィック クラスの設定

ここでは、ポリシー マップでサービス フラグメント トラフィック クラス文を設定する方法について説明します。サービス フラグメント トラフィック クラスは、以前他のポリシー マップでフラグメントとして設定されたデフォルト クラス文のコレクションに QoS を適用するために使用します。

前提条件

この手順では、フラグメント デフォルト トラフィック クラスがすでに作成されているものと仮定します。フラグメント デフォルト トラフィック クラスを作成するための手順については、「ポリシー マップでのフラグメント トラフィック クラスの設定」を参照してください。

すべてのポリシー マップと同様に、設定をインターフェイスにアタッチするまで、ネットワーク トラフィックはそれに従って管理されません。この手順では、ポリシー マップのインターフェイスへのアタッチ手順は扱っていません。

制約事項

サービス フラグメントは、同じ物理インターフェイスのフラグメントをまとめて分類するためだけに使用できます。異なるインターフェイスのフラグメントは、同じサービス フラグメントを使用して分類できません。

service-fragment キーワードが入力されているクラスではキューイング機能だけが許可され、 service-fragment キーワードが使用されているクラスでは 1 つ以上のキューイング機能を入力する必要があります。

service-fragment キーワードを使用したクラスがあるポリシー マップは、インターフェイスを出て行くトラフィックのみに適用できます( service-policy output コマンドを使用してインターフェイスにアタッチしたポリシー マップ)。

service-fragment キーワードを使用して設定されたクラスは、インターフェイスにまだ設定されているフラグメントに QoS をまとめて適用するために使用されている場合、削除できません。 service-fragment キーワードを使用して設定されているクラスを削除するには、サービス フラグメントを削除する前にフラグメント トラフィック クラスを削除します。

fragment キーワードは、子のポリシー マップでは入力できません。

手順の概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class class-name service-fragment fragment-class-name

5. qos-queueing-feature

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

Router(config)# policy-map BestEffortFragments

設定するトラフィック ポリシーの名前を指定し、ポリシーマップ コンフィギュレーション モードを開始します。

ステップ 4

class class-name service-fragment fragment-class-name

 

Router(config-pmap)# class data service-fragment BestEffort

fragment-class-name に一致するすべてのフラグメントを合わせたトラフィックのクラスを指定します。他のポリシー マップでフラグメントを定義する場合、サービス フラグメント クラスを正しく設定するには、 fragment-class-name がこのコマンド ラインの fragment-class-name に一致する必要があります。

ステップ 5

qos-queueing-feature

QoS コンフィギュレーション コマンドを入力します。フラグメントとして設定したデフォルト トラフィック クラスでは、キューイング機能だけがサポートされています。

現在サポートされているキューイング機能は、 bandwidth shape 、および random-detect exponential-weighting-constant です。

複数の QoS キューイング コマンドを入力できます。

次の例では、BestEffort という名前のすべてのフラグメントに QoS を適用するために、ポリシー マップが作成されます。

policy-map main-interface
class data service-fragment BestEffort
shape average 400000000
 

次の例では、2 つのフラグメントが作成され、サービス フラグメントを使用してまとめて分類されます。

policy-map subscriber1
class voice
set cos 5
priority level 1
class video
set cos 4
priority level 2
class class-default fragment BestEffort
shape average 200000000
bandwidth remaining ratio 10

policy-map subscriber 2
class voice
set cos 5
priority level 1
class video
set cos 4
priority level 2
class class-default fragment BestEffort
shape average 200000000
bandwidth remaining ratio 10
 
policy-map main-interface
class data service-fragment BestEffort
shape average 200000000
shape average 200000000
bandwidth remaining ratio 10

トラブルシューティングのヒント

同じサービス フラグメントの一部と見なされるすべてのクラス文で fragment-class-name が同じになっていることを確認してください。

次の作業

ポリシー マップをインターフェイスにアタッチする必要があります。

Gigabit Etherchannels に対する QoS:ポリシー集約の設定方法

QoS:ポリシー集約を Gigabit Etherchannel バンドルに対して正しく設定するには、次の手順を実行する必要があります。

フラグメント トラフィック クラスが設定され、メンバー リンク サブインターフェイスにアタッチする必要があります。

サービス フラグメント トラフィック クラスが設定され、メイン物理インターフェイスにアタッチする必要があります。

ここでは、これらの手順について詳しく説明します。次の手順が含まれています。

「Gigabit Etherchannel メンバー リンク サブインターフェイス上でのフラグメントの設定」

「Gigabit Etherchannel バンドルをサポートする物理インターフェイス上でのサービス フラグメントの設定」

Gigabit Etherchannel メンバー リンク サブインターフェイス上でのフラグメントの設定

ここでは、Gigabit Etherchannel バンドルのメンバー リンク サブインターフェイスにアタッチされているポリシー マップのデフォルト トラフィック クラスをフラグメントとして設定する方法について説明します。

前提条件

この手順では、サービス フラグメント トラフィック クラスがすでに作成されている必要があります。フラグメント クラスを設定しないと、サービス フラグメント トラフィック クラスを設定できません。フラグメント クラスを作成するための手順については、「ポリシー マップでのフラグメント トラフィック クラスの設定」を参照してください。サービス フラグメント トラフィック クラスを作成するための手順については、「サービス フラグメント トラフィック クラスの設定」を参照してください。

これらの手順では、Gigabit Etherchannel メンバー リンク サブインターフェイスで設定可能なオプションの詳細は説明していません。これらの手順は、すでにフラグメント トラフィック クラスがあるポリシー マップをメンバー リンク サブインターフェイスにアタッチするための手順のみを示しています。

制約事項

フラグメントは、2 つ以上の物理インターフェイス上のトラフィックに対して使用できません。この設定が正しく機能するためには、GEC がすべて同じ物理インターフェイス上にある必要があります。

手順の概要

1. enable

2. configure terminal

3. interface port-channel port-channel-interface-number . port-channel-subinterface-number

4. service-policy output fragment-class-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface port-channel port-channel-interface-number.port-channel-subinterface-number

 

Router(config)# interface port-channel 1.100

Etherchannel メンバー リンク サブインターフェイスを設定するためにサブインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

service-policy output fragment-class-name

 

Router(config-subif)# service-policy output subscriber

フラグメント デフォルト トラフィック クラスが含まれているサービス ポリシーを、Etherchannel メンバー リンク サブインターフェイスにアタッチします。

次の例では、subscriber という名前のサービス ポリシーにフラグメント デフォルト トラフィック クラスがあり、Gigabit Etherchannel バンドルのメンバー リンク サブインターフェイスにアタッチされます。


) この例は、フラグメント デフォルト トラフィック クラスを Gigabit Etherchannel バンドルのメンバー リンク サブインターフェイスにアタッチする方法のみを示しています。この設定は不完全であり、物理インターフェイスがサービス フラグメント トラフィック クラスをサポートするように設定されるまで、デフォルト トラフィックが適切に分類されません。


policy-map subscriber
class voice
priority level 1
class video
priority level 2
class class-default fragment BE
shape average 100000000
bandwidth remaining ratios 80
policy-map aggregate-member-link
class BestEffort service-fragment BE
shape average 100000000
!
interface Port-channel1
ip address 172.1.2.3 255.255.0.0
!
interface Port-channel1.100
encapsulation dot1Q 100
ip address 173.1.2.100 255.255.255.0
service-policy output subscriber
!

トラブルシューティングのヒント

この設定は、フラグメントとしてマークされたデフォルト トラフィック クラスを分類するために、サービス フラグメント デフォルト トラフィック クラスが作成されるまで、機能しません。この設定がネットワーク トラフィックに何らかの影響を与えるようにするには、このサービス フラグメント トラフィック クラスを設定する必要があります。

次の作業

この設定は、フラグメントとしてマークされたデフォルト トラフィック クラスを分類するために、サービス フラグメント デフォルト トラフィック クラスが作成されるまで、機能しません。

「Gigabit Etherchannel バンドルをサポートする物理インターフェイス上でのサービス フラグメントの設定」の手順に従ってこの設定を完成させます。

Gigabit Etherchannel バンドルをサポートする物理インターフェイス上でのサービス フラグメントの設定

ここでは、Gigabit Etherchannel バンドルの物理インターフェイス上で、サービス フラグメント デフォルト トラフィック クラスがあるポリシー マップを設定する方法について説明します。

前提条件

この手順では、サービス フラグメント トラフィック クラスがすでに作成されている必要があります。フラグメント クラスを設定しないと、サービス フラグメント トラフィック クラスを設定できません。フラグメント クラスを作成するための手順については、「ポリシー マップでのフラグメント トラフィック クラスの設定」を参照してください。サービス フラグメント トラフィック クラスを作成するための手順については、「サービス フラグメント トラフィック クラスの設定」を参照してください。

これらの手順では、Gigabit Etherchannel メンバー リンク サブインターフェイスで設定可能なオプションの詳細は説明していません。これらの手順は、すでにフラグメント トラフィック クラスがあるポリシー マップをメンバー リンク サブインターフェイスにアタッチするための手順のみを示しています。

制約事項

この手順は、GEC バンドルのすべてのリンクが同じ物理インターフェイス上にある場合にのみ機能します。

手順の概要

1. enable

2. configure terminal

3. interface gigabitethernet interface-number

4. service-policy output fragment-class-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface gigabitethernet interface-number

 

Router(config)# interface gigabitethernet 1/1/1

ギガビット イーサネット インターフェイス モードを開始します。

ステップ 4

service-policy output service-fragment-class-name

 

Router(config-subif)# service-policy output aggregate-member-link

サービス フラグメント デフォルト トラフィック クラスが含まれているサービス ポリシーを、物理ギガビット イーサネット インターフェイスに付加します。

次の例では、ポリシー マップ subscriber が BE という名前のフラグメント クラスで設定されます。次に、フラグメントは aggregate-member-link という名前のポリシー マップの一部として設定されます。次に、ポリシー マップ subscriber がバンドル サブインターフェイスにアタッチされ、ポリシー マップ aggregate-member-link が物理インターフェイスにアタッチされます。

port-channel load-balancing vlan-manual
class-map match-all BestEffort
!
class-map match-all video
!
class-map match-all voice
!
policy-map subscriber
class voice
priority level 1
class video
priority level 2
class class-default fragment BE
shape average 100000000
bandwidth remaining ratios 80
 
policy-map aggregate-member-link
class BestEffort service-fragment BE
shape average 100000000
!
interface Port-channel1
ip address 172.1.2.3 255.255.0.0
!
interface Port-channel1.100
encapsulation dot1Q 100
ip address 173.1.2.100 255.255.255.0
service-policy output subscriber
!
interface Port-channel1.200
encapsulation dot1Q 200
ip address 173.1.2.200 255.255.255.0
service-policy output subscriber
!
interface Port-channel1.300
encapsulation dot1Q 300
ip address 173.1.2.300 255.255.255.0
service-policy output subscriber
!
interface GigabitEthernet1/1/1
no ip address
channel-group 1 mode on
service-policy output aggregate-member-link
!
interface GigabitEthernet1/1/2
no ip address
channel-group 1 mode on
service-policy output aggregate-member-link

トラブルシューティングのヒント

fragment-class-name がサービス フラグメントおよびフラグメント クラス定義で一貫していることを確認してください。

次の作業

これは、Gigabit Etherchannel(GEC)バンドル上で QoS:ポリシー集約機能を設定するための最後の設定手順です。

QoS:ポリシー集約の設定例

ここでは、次の例について説明します。

「QoS:ポリシー集約:例」

「Gigabit Etherchannel QoS:ポリシー集約:例」

QoS:ポリシー集約:例

次の例では、QoS:ポリシー集約を使用して、トラフィックのフラグメント クラスを定義し、BestEffort という名前のデフォルト トラフィック クラスを使用してデフォルト トラフィックを分類しています。subscriber1 および subscriber2 という名前のポリシー マップからのすべてのデフォルト トラフィックは、BestEffort という名前のフラグメント デフォルト トラフィック クラスの一部です。このデフォルト トラフィックは、 service-fragment キーワードと shape コマンドを使用する data という名前のクラスを作成することで、まとめてシェーピングされます。

この例では、次の点に注意してください。

各フラグメント デフォルト トラフィック クラスの class-name は「BestEffort」です。

「BestEffort」の class-name は、 service-fragment キーワードを入力したクラスを定義するためにも使用されます。このクラスは、「BestEffort」という名前のフラグメント デフォルト トラフィック クラスを使用して転送されるすべてのトラフィックにシェーピング ポリシーを適用します。

policy-map subscriber1
class voice
set cos 5
priority level 1
class video
set cos 4
priority level 2
class class-default fragment BestEffort
shape average 200000000
bandwidth remaining ratio 10

policy-map subscriber 2
class voice
set cos 5
priority level 1
class video
set cos 4
priority level 2
class class-default fragment BestEffort
shape average 200000000
bandwidth remaining ratio 10
 
policy-map input_policy
class class-default
set dscp default
 
policy-map main-interface
class data service-fragment BestEffort
shape average 400000000
 
interface portchannel1.1001
encapsulation dot1q 1001
service-policy output subscriber1
service-policy input input_policy
 
interface portchannel1.1002
encapsulation dot1q 1002
service-policy output subscriber2
service-policy input input_policy
 
interface gigabitethernet 0/1
description member-link1
port channel 1
service-policy output main-interface
 
interface gigabitethernet 0/2
description member-link2
port channel 1

service-policy output main-interface

Gigabit Etherchannel QoS:ポリシー集約:例

次の例では、ポリシー マップ subscriber が BE という名前のフラグメント クラスで設定されます。次に、フラグメントは aggregate-member-link という名前のポリシー マップの一部として設定されます。次に、ポリシー マップ subscriber がバンドル サブインターフェイスにアタッチされ、ポリシー マップ aggregate-member-link が物理インターフェイスにアタッチされます。

port-channel load-balancing vlan-manual
class-map match-all BestEffort
!
class-map match-all video
!
class-map match-all voice
!
policy-map subscriber
class voice
priority level 1
class video
priority level 2
class class-default fragment BE
shape average 100000000
bandwidth remaining ratios 80
 
policy-map aggregate-member-link
class BestEffort service-fragment BE
shape average 100000000
!
interface Port-channel1
ip address 172.1.2.3 255.255.0.0
!
interface Port-channel1.100
encapsulation dot1Q 100
ip address 173.1.2.100 255.255.255.0
service-policy output subscriber
!
interface Port-channel1.200
encapsulation dot1Q 200
ip address 173.1.2.200 255.255.255.0
service-policy output subscriber
!
interface Port-channel1.300
encapsulation dot1Q 300
ip address 173.1.2.300 255.255.255.0
service-policy output subscriber
!
interface GigabitEthernet1/1/1
no ip address
channel-group 1 mode on
service-policy output aggregate-member-link
!
interface GigabitEthernet1/1/2
no ip address
channel-group 1 mode on
service-policy output aggregate-member-link

その他の参考資料

次の項では、QoS:ポリシー集約機能の関連資料を示します。

関連資料

関連項目
参照先

モジュラ QoS コマンドライン インターフェイス

『Applying QoS Features Using the MQC』

比率を使用した残り帯域幅の分配

『Distribution of Remaining Bandwidth Using Ratio』

クラスベースのシェーピング

『Regulating Packet Flow on a Per-Class Basis -- Using Class-Based Traffic Shaping』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

次のコマンドはこのモジュールに記述された機能で変更されています。これらのコマンドの詳細については、 http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_book.html にある『 Cisco IOS Quality of Service Command Reference 』を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、 http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html にある『 Cisco IOS Master Command List, All Releases 』を参照してください。

class(ポリシー マップ)

QoS:ポリシー集約の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 QoS:ポリシー集約の機能情報

機能名
リリース
機能情報

QoS:ポリシー集約

12.2(33)SRA

Quality of Service:ポリシー集約(QoS:ポリシー集約)機能を使用すると、同じ物理インターフェイス上の異なるポリシー マップのデフォルト トラフィック クラスを、モジュラ QoS CLI 内の 1 つのトラフィック クラスとして設定できます。

用語集

サービス フラグメント :すべてがフラグメントで構成されるトラフィック クラスを指定する、ポリシー マップ内のクラス定義文。

フラグメント :フラグメントは、ポリシー マップ内のデフォルト トラフィック クラスの設定オプションです。フラグメントとして設定されたデフォルト トラフィック クラスは、後でサービス フラグメントの一部になります。フラグメントを使用すると、同じインターフェイス上の複数のポリシー マップの複数のデフォルト トラフィック クラスをまとめて分類できます。フラグメントを使用しない場合、各ポリシー マップには、そのポリシー マップのみに含まれる 1 つのデフォルト トラフィック クラスがあります。