Quality of Service ソリューション ガイド、 Cisco IOS Release 15.1S
重み付け均等化キューイングの設定
重み付け均等化キューイングの設定
発行日;2012/02/02 | 英語版ドキュメント(2011/04/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

重み付け均等化キューイングの設定

フローベース WFQ の設定作業リスト

WFQ の設定

均等化キューイングのモニタリング

分散重み付け均等化キューイングの設定作業リスト

フローベース DWFQ の設定

QoS グループベースの DWFQ の設定

タイプ オブ サービスベースの DWFQ タイプの設定

DWFQ のモニタリング

クラスベース WFQ の設定作業リスト

クラス マップの定義

ポリシー マップでのクラス ポリシーの設定

テール ドロップを使用するクラス ポリシーの設定

WRED パケット ドロップを使用するクラス ポリシーの設定

Class-Default クラス ポリシーの設定

サービス ポリシーの適用と CBWFQ のイネーブル化

既存のポリシー マップ クラスの帯域幅の変更

既存のポリシー マップ クラスのキュー制限の変更

クラスの削除

ポリシー マップの削除

ポリシー マップとそのクラスの設定の確認

DCBWFQ の設定作業リスト

既存のトラフィック クラスの帯域幅の変更

既存のトラフィック クラスのキュー制限の変更

DCBWFQ のモニタリングと保守

IP RTP プライオリティの設定作業リスト

IP RTP プライオリティの設定

IP RTP プライオリティの確認

IP RTP プライオリティのモニタリングと保守

フレームリレー IP RTP プライオリティの設定作業リスト

フレームリレー IP RTP プライオリティの設定

フレームリレー IP RTP プライオリティの確認

フレームリレー IP RTP プライオリティのモニタリングと保守

フレームリレー PVC インターフェイス プライオリティの設定作業リスト

マップ クラスの PVC プライオリティの設定

フレームリレー PIPQ のイネーブル化とキュー制限の設定

PVC へのマップ クラスの割り当て

フレームリレー PIPQ の確認

フレームリレー PIPQ のモニタリングと保守

低遅延キューイングの設定作業リスト

LLQ の設定

LLQ の確認

LLQ のモニタリングと保守

分散型 LLQ の設定作業リスト

使用可能な帯域幅の量に関するプライオリティ キューの設定

使用可能な帯域幅の割合に関するプライオリティ キューの設定

送信リング制限の設定

分散型 LLQ の確認

送信リング制限の確認

分散型 LLQ のモニタリングと保守

フレームリレー向け低遅延キューイングの設定作業リスト

クラス マップの定義

ポリシー マップでのクラス ポリシーの設定

LLQ プライオリティ キューのクラス ポリシーの設定

指定した帯域幅および WRED パケット ドロップを使用したクラス ポリシーの設定

Class-Default クラス ポリシーの設定

サービス ポリシーの割り当てとフレームリレー向け LLQ のイネーブル化

ポリシー マップとそのクラスの設定の確認

フレームリレー向け LLQ のモニタリングと保守

LLQ 設定作業リストのバースト サイズの設定

LLQ 帯域幅の設定

LLQ バースト サイズの設定

LLQ バースト サイズの確認

ATM アダプタの VC 単位ホールド キューのサポートの設定作業リスト

ATM アダプタでの VC 単位ホールド キューの設定

ATM アダプタの VC 単位ホールド キューの設定の確認

フローベース WFQ の設定例

DWFQ の設定例

フローベース DWFQ:例

QoS グループベース DWF:例

ToS ベースの DWFQ:例

CBWFQ の設定例

クラス マップの設定:例

ポリシーの作成:例

インターフェイスへのポリシーの割り当て:例

WRED パケット ドロップを使用した CBWFQ:例

サービス ポリシー マップの内容の表示例

指定したサービス ポリシー マップのすべてのクラス

すべてのサービス ポリシー マップのすべてのクラス

サービス ポリシー マップの指定ししたクラス

指定したインターフェイス上のすべてのサービス ポリシー マップのすべてのクラス

Distributed CBWFQ の設定例

トラフィック クラスの設定:例

トラフィック ポリシーの作成:例

インターフェイスへのトラフィック ポリシーの割り当て:例

IP RTP プライオリティの設定例

CBWFQ の設定:例

仮想テンプレートの設定:例

マルチリンク バンドルの設定:例

デバッグ:例

フレームリレー IP RTP プライオリティの設定例

一致する RTP パケットに対する完全プライオリティ サービス:例

フレームリレー PVC インターフェイス PQ の設定例

LLQ の設定例

ATM PVC の設定:例

仮想テンプレートの設定:例

マルチリンク バンドルの設定:例

分散型 LLQ の設定例

ATM サブインターフェイスの使用可能な帯域幅の量に関する PQ のイネーブル化:例

ATM サブインターフェイスで使用可能な帯域幅に占める割合に関する PQ のイネーブル化:例

ATM インターフェイスの送信リング制限の設定:例

ATM PVC サブインターフェイスの送信リング制限の設定:例

フレームリレー向け LLQ の設定例

LLQ のバースト サイズの設定例

ATM アダプタの VC 単位ホールド キューのサポート:例

重み付け均等化キューイングの設定

機能の履歴

リリース
変更点

Cisco IOS

Cisco IOS ソフトウェアの機能サポートに関する情報については、Cisco Feature Navigator を使用してください。

ここでは、フローベース Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)、Distributed WFQ(DWFQ; 分散型 WFQ)、Class-Based WFQ(CBWFQ; クラスベース WFQ)、Distributed Class-Based WFQ(DCBWFQ; 分散型クラスベース WFQ)、および WFQ または CBWFQ 内で厳格な Priority Queueing(PQ; プライオリティ キューイング)機能を提供する関連機能(後述の項を参照)の設定作業について説明します。

IP RTP プライオリティ キューイング

フレームリレー IP RTP プライオリティ キューイング

フレームリレー PVC インターフェイス プライオリティ キューイング

低遅延キューイング

分散型低遅延キューイング

フレームリレー向け低遅延キューイング(LLQ)

低遅延キューイングのバースト サイズ

ATM アダプタの VC 単位ホールド キューのサポート

詳細な概念情報については、『 Congestion Management Overview 』モジュールを参照してください。

この章の QoS コマンドの詳細については、『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。この章に記載されている他のコマンドのドキュメントについては、コマンド リファレンス マスター インデックスを使用するか、オンライン検索してください。

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

フローベース WFQ の設定作業リスト

WFQ には、あらかじめアクセス リストを定義しなくても、個々のトラフィック ストリームを自動的にソートするトラフィック プライオリティ管理機能があります。また、WFQ では、1 組のアプリケーション間で送信される全二重データ ストリーム、および音声やビデオなどの単方向通信も管理できます。WFQ セッションには、高帯域幅と低帯域幅という 2 つのカテゴリがあります。低帯域幅のトラフィックは、広帯域幅のトラフィックよりも有効な優先順位を持ち、高帯域幅のトラフィックは転送サービスを、割り当てられた重み付けに従って比例的に共有します。

インターフェイスで WFQ をイネーブルにすると、輻輳メッセージに関する設定またはデフォルトのしきい値に達した後、高帯域幅トラフィック ストリームの新しいメッセージは破棄されます。ただし、コントロール メッセージの通信など、低帯域幅の通信ではデータのキューイング処理が続行されます。その結果、均等化キューには、設定したしきい値の数よりも多いメッセージが含まれることがあります。

Standard WFQ では、パケットはフローごとに分類されます。同じ発信元 IP アドレス、宛先 IP アドレス、発信元 TCP または User Datagram Protocol(UDP; ユーザ データグラム プロトコル)ポート、または宛先 TCP または UDP ポートは、同じフローに属します。WFQ は、同じ割合で帯域幅を各フローに割り当てます。また、フローベース WFQ は、すべてのフローが等しく重み付けされるため、均等化キューイングとも呼ばれます。

Cisco IOS ソフトウェアのフローベース WFQ 形式は、次の 2 つです。

Standard WFQ。2 Mbps 以下で動作するすべてのシリアル インターフェイスではデフォルトでイネーブルです。また、すべてのシスコ シリアル インターフェイスで実行できます。

Distributed WFQ。Route Switch Processor(RSP)ベースの TSP7000 インターフェイス プロセッサを搭載した Cisco 7000 シリーズ ルータ、および Versatile Interface Processor(VIP)ベースの VIP2-40 以降のインターフェイス プロセッサを搭載した Cisco 7500 シリーズ ルータでのみ動作します(VIP のポート アダプタの集約ライン レートが DS3 を上回る場合は、VIP2-50 インターフェイス プロセッサを強く推奨します。OC-3 レートには VIP2-50 インターフェイス プロセッサが必要です)。DWFQ の設定については、この章で後述する分散重み付け均等化キューイングの設定作業リストを参照してください。

フローベース WFQ を設定するには、以下の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

WFQ の設定(必須)

均等化キューイングのモニタリング(任意)

フローベース WFQ は、Unavailable Bit Rate(UBR; 使用不能ビット レート)、Variable Bit Rate(VBR; 可変ビット レート)、および Available Bit Rate(ABR; 使用可能ビット レート)ATM 接続でサポートされます。

フローベース WFQ の設定例については、この章の末尾を参照してください。

WFQ の設定

インターフェイスでフローベース WFQ を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# fair-queue [ congestive-discard-threshold [ dynamic-queues [ reservable-queues ]]]

WFQ を使用するインターフェイスを設定します。

フローベース WFQ は、トラフィック データ ストリームの識別登録サービスを使用してトラフィック ストリームが属するメッセージを決定します。トラフィックをデータ ストリームに分類するために使用されるメッセージのアトリビュートについては、『 Cisco IOS Quality of Service Solutions Command Reference 』の fair-queue (WFQ)コマンドの説明に記載されている表を参照してください。

高帯域幅通信のメッセージがドロップされた後の輻輳のしきい値、およびダイナミック キューと予約可能キューの数については、デフォルト値が用意されています。ただし、そのデフォルト値を変更することで、実際のネットワーク運用に合わせて微調整できます。WFQ および CBWFQ をインターフェイスまたは ATM VC でイネーブルにするときに使用するダイナミック キューのデフォルト数については、『 Cisco IOS Quality of Service Solutions Command Reference 』の fair-queue (WFQ)コマンドの説明に記載されている表を参照してください。これらの値は DWFQ には適用されません。


) WFQ は、E1(2.048 Mbps)以下で動作するインターフェイスでは、WFQ がデフォルト キューイング モードです。WFQ は、Link Access Procedure、Balanced(LAPB)、X.25、または Synchronous Data Link Control(SDLC)カプセル化を使用しない物理インターフェイスのデフォルトでイネーブルです。WFQ はこれらのプロトコルのオプションではありません。また、WFQ は、Multilink PPP(MLP; マルチリンク PPP)用に設定されているインターフェイスのデフォルトでもイネーブルです。ただし、適用可能なリンクで custom queueing(CQ; カスタム キューイング)または priority queueing(PQ; プライオリティ キューイング)がイネーブルの場合、均等化キューイングよりも優先され、実質的に均等化キューイングはディセーブルになります。また、自律スイッチングまたはシリコン スイッチングをイネーブルにすると、WFQ は自動的にディセーブルになります。


均等化キューイングのモニタリング

ネットワークでフローベースの均等化キューイングをモニタするには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show interfaces [ interface ]

インターフェイスに固有の統計情報を表示します。

Router# show queue interface-type interface-number

特定のインターフェイスまたは Virtual Circuit(VC; 仮想回線)のキュー内にあるパケット カウントを表示します。

Router# show queueing fair

均等化キューイング設定のステータスを表示します。

分散重み付け均等化キューイングの設定作業リスト

DWFQ を設定するには、以下の項で説明する作業のいずれかを実行します(複数の作業は実行できません)。

「フローベース DWFQ の設定」

「QoS グループベースの DWFQ の設定」

「タイプ オブ サービスベースの DWFQ タイプの設定」

「DWFQ のモニタリング」(任意)

フローベース DWFQ をイネーブルにしてから、クラスベース DWFQ(QoS グループベースまたは ToS ベース)をイネーブルにすると、フローベース DWFQ ではなくクラスベース DWFQ が実行されます。

クラスベース DWFQ をイネーブルにしてからフローベース DWFQ に切り替える場合、 no fair-queue class-based コマンドを使用してクラスベース DWFQ をディセーブルにしてから、フローベース DWFQ をイネーブルにする必要があります。

クラスベース DWFQ のいずれかのタイプをイネーブルにしてから、他のタイプをイネーブルにすると、最初のタイプではなく 2 番めのタイプが実行されます。

DWFQ は、RSP ベースの RSP7000 インターフェイス プロセッサを搭載する Cisco 7000 シリーズ ルータ、または VIP ベースの VIP2-40 以降のインターフェイス プロセッサを搭載する Cisco 7500 シリーズ ルータでのみ動作します(VIP のポート アダプタの集約ライン レートが DS3 を上回る場合は、VIP2-50 インターフェイス プロセッサを強く推奨します。OC-3 レートには VIP2-50 インターフェイス プロセッサが必要です)。

DWFQ はインターフェイスで設定できますが、サブインターフェイスでは設定できません。Fast EtherChannel、トンネル、または他の論理インターフェイスや仮想インターフェイス(MLP など)ではサポートされません。

DWFQ の設定例については、この章の末尾を参照してください。

フローベース DWFQ の設定

フローベース DWFQ を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# fair-queue

フローベース DWFQ をイネーブルにします。

ステップ 2

Router(config-if)# fair-queue aggregate-limit aggregate-packet

(任意)バッファするパケットの上限を設定します。上限を超えるパケットはドロップされます。この制限を下回る場合、パケットはドロップされません。

ステップ 3

Router(config-if)# fair-queue individual-limit individual-packet

(任意)輻輳時のフロー別の各キューについて、最大キュー サイズを設定します。

フローベース DWFQ の場合、パケットはフロー別に分類されます。同じ発信元 IP アドレス、宛先 IP アドレス、発信元 TCP ポートまたは UDP ポート、宛先 TCP ポートまたは UDP ポート、およびプロトコルは、同じフローに属します。

一般的に、集約または個別の制限値をデフォルトから変更する必要があります。状況に応じて異なる値を使用することに利点があると判断した場合にのみ、 fair-queue aggregate-limit コマンドと fair-queue individual-limit コマンドを使用します。

QoS グループベースの DWFQ の設定

QoS ベースの DWFQ を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# fair-queue qos-group

QoS グループベースの DWFQ をイネーブルにします。

ステップ 2

Router(config-if)# fair-queue qos-group number weight weight

QoS グループごとに、各クラスに割り当てる帯域幅の割合を指定します。

ステップ 3

Router(config-if)# fair-queue aggregate-limit aggregate-packet

(任意)バッファするパケットの上限を設定します。上限を超えるパケットはドロップされます。この制限を下回る場合、パケットはドロップされません。

ステップ 4

Router(config-if)# fair-queue individual-limit individual-packet

(任意)輻輳時のフロー別の全キューについて、最大キュー サイズを設定します。

ステップ 5

Router(config-if)# fair-queue qos-group number limit class-packet

(任意)輻輳時の特定の QoS グループ キューについて、最大キュー サイズを設定します。

一般的に、集約、個別、またはクラスの制限値をデフォルトから変更する必要があります。状況に応じて異なる値を使用することに利点があると判断した場合にのみ、 fair-queue aggregate-limit コマンド、 fair-queue individual-limit コマンド、および fair-queue limit コマンドを使用します。

タイプ オブ サービスベースの DWFQ タイプの設定

Type of Service(ToS; タイプ オブ サービス)ベースの DWFQ を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# fair-queue tos

ToS ベースの DWFQ 認証をイネーブルにします。

ステップ 2

Router(config-if)# fair-queue tos number weight weight

(任意)ToS クラスごとに、各クラスに割り当てる帯域幅の割合を指定します。

ステップ 3

Router(config-if)# fair-queue aggregate-limit aggregate-packet

(任意)バッファするパケットの上限を設定します。上限を超えるパケットはドロップされます。この制限を下回る場合、パケットはドロップされません。

ステップ 4

Router(config-if)# fair-queue individual-limit individual-packet

(任意)輻輳時のフロー別の全キューについて、最大キュー サイズを設定します。

ステップ 5

Router(config-if)# fair-queue tos number limit class-packet

(任意)輻輳時の特定の ToS キューについて、最大キュー サイズを設定します。

一般的に、集約、個別、またはクラスの制限値をデフォルトから変更する必要があります。状況に応じて異なる値を使用することに利点があると判断した場合にのみ、 fair-queue aggregate-limit コマンド、 fair-queue individual-limit コマンド、および fair-queue limit コマンドを使用します。

DWFQ のモニタリング

DWFQ をモニタするには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show interfaces [ interface ]

インターフェイスに固有の統計情報を表示します。

Router# show queueing fair-queue

均等化キューイング設定のステータスを表示します。

クラスベース WFQ の設定作業リスト

CBWFQ を設定するには、以下の項で説明する作業を実行します。最初の 3 つの項の作業は必須です。残りの項の作業は任意です。

「クラス マップの定義」(必須)

「ポリシー マップでのクラス ポリシーの設定」(必須)

「サービス ポリシーの適用と CBWFQ のイネーブル化」(必須)

「既存のポリシー マップ クラスの帯域幅の変更」(任意)

「既存のポリシー マップ クラスのキュー制限の変更」(任意)

「クラスの削除」(任意)

「ポリシー マップの削除」(任意)

「ポリシー マップとそのクラスの設定の確認」(任意)

CBWFQ は VBR 接続および ABR ATM 接続でサポートされます。UBR 接続ではサポートされません。

CBWFQ の設定例については、この章の末尾を参照してください。

VC 単位 WFQ と CBWFQ の設定方法については、『 Configuring IP to ATM Class of Service 』モジュールを参照してください。

クラス マップの定義

クラスに属するかどうかを決定するパケットを確認する一致基準を含むクラス マップを作成するには(また、1 つまたは複数のポリシー マップでポリシーを指定できるクラスを効率的に作成するには)、グローバル コンフィギュレーション モードで最初のコマンドを使用してから、必要に応じて、クラスマップ コンフィギュレーション モードで次のコマンドのいずれかを使用します。

 

コマンド
目的

ステップ 1

Router(config)# class-map class-map-name

作成するクラス マップの名前を指定します。

ステップ 2

Router(config-cmap)# match access-group { access-group | name access-group-name }

 

または

 

Router(config-cmap)# match input-interface interface-name

 

 

または

Router(config-cmap)# match protocol protocol

 

 

または

 

Router(config-cmap)# match mpls experimental number

クラスにコンテンツ パケットが属しているかをチェックする access control list(ACL; アクセス コントロール リスト)の名前を指定します。CBWFQ は番号付き ACL または名前付き ACL をサポートします。

クラスにパケットが属しているかをチェックする一致基準として使用する入力インターフェイスの名前を指定します。

クラスにパケットが属しているかをチェックする一致基準として使用するプロトコルの名前を指定します。

クラスにパケットが属しているかをチェックする一致基準として使用する EXP フィールドの値を指定します。

クラス マップを定義する場合、他の一致基準を使用できます。その他の一致基準については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

ポリシー マップでのクラス ポリシーの設定

ポリシー マップを設定し、サービス ポリシーを構成するクラス ポリシーを作成するには、 policy-map コマンドを使用して、ポリシー マップ名を指定してから、次のコマンドの 1 つまたは複数を使用し、標準クラスまたはデフォルト クラスのポリシーを設定します。

class

bandwidth (policy-map クラス)

fair-queue (class-default クラスの場合のみ)

queue-limit または random-detect

定義するクラスごとに、リストされているコマンドを 1 つ以上使い、クラス ポリシーを設定します。たとえば、あるクラスには帯域幅を、別のクラスには帯域幅およびキュー制限を指定します。

ポリシー マップのデフォルト クラス(一般に class-default クラスといいます)は、ポリシー マップでポリシーが定義されているその他のクラスの一致基準を満たさない場合にトラフィックが送られるクラスです。

クラス ポリシーはルータで定義可能な数だけ設定できます(最大 64 個)。ただし、ポリシー マップのすべてのクラスに割り当てられる帯域幅の合計数は、インターフェイスで使用可能な帯域幅の 75% 以下にする必要があります。残りの 25% はコントロールおよびルーティング トラフィックに使用されます(75% の制限を上書きするには、 max-reserved bandwidth コマンドを使用します)。帯域幅のすべてが割り当てられない場合、残りの帯域幅は、設定済み帯域幅に基づいて比例的に各クラスへ割り当てられます。

ポリシー マップのクラス ポリシーを設定するには、以降の項で説明する任意の作業を実行します。以下の手順を実行しない場合、デフォルトの処理が実行されます。

「テール ドロップを使用するクラス ポリシーの設定」(任意)

「WRED パケット ドロップを使用するクラス ポリシーの設定」(任意)

「Class-Default クラス ポリシーの設定」(任意)

テール ドロップを使用するクラス ポリシーの設定

ポリシー マップを設定し、サービス ポリシーを構成するクラス ポリシーを作成するには、グローバル コンフィギュレーション モードで最初のコマンドを使用してポリシー マップ名を指定してから、必要に応じて policy-map クラス コンフィギュレーション モードで次のコマンドを使用し、標準クラスのポリシーを設定します。デフォルト クラスのポリシーを設定するには、この章のClass-Default クラス ポリシーの設定を参照してください。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

作成し、サービス ポリシーで使用するクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# bandwidth { bandwidth-kbps | percent percent }

クラスに割り当てる帯域幅の量(kbps 単位)または使用可能な帯域幅に占める割合を指定します。設定する帯域幅の量は、レイヤ 2 オーバーヘッドにも対応できるサイズにする必要があります。

ステップ 4

Router(config-pmap-c)# queue-limit number-of-packets

そのクラスのキューに投入できるパケットの最大数を指定します。

同じポリシー マップ内で複数のクラスについてポリシーを設定するには、ステップ 2ステップ 4 を繰り返します。この一連のコマンドでは queue-limit コマンドを使用するため、ポリシー マップには Weighted Random Early Detection(WRED)パケット ドロップではなく、テール ドロップが使用されます。

WRED パケット ドロップを使用するクラス ポリシーの設定

ポリシー マップを設定し、サービス ポリシーを構成するクラス ポリシーを作成するには、必要に応じてグローバル コンフィギュレーション モードで最初のコマンドを使用してポリシー マップ名を指定してから、policy-map クラス コンフィギュレーション モードで次のコマンドを使用し、標準クラスのポリシーを設定します。デフォルト クラスのポリシーを設定するには、この章のClass-Default クラス ポリシーの設定を参照してください。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

作成し、サービス ポリシーで使用するクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# bandwidth { bandwidth-kbps | percent percent }

クラスに割り当てる帯域幅の量(kbps 単位)または使用可能な帯域幅に占める割合を指定します。設定する帯域幅の量は、レイヤ 2 オーバーヘッドにも対応できるサイズにする必要があります。

ステップ 4

Router(config-pmap-c)# random-detect

WRED をイネーブルにします。クラス ポリシーは、テール ドロップではなく WRED を使用してパケットをドロップします。

ステップ 5

Router(config-pmap-c)# random-detect exponential-weighting-constant exponent

 

または

 

Router(config-pmap-c)# random-detect precedence precedence min-threshold max-threshold mark-prob-denominator

平均キュー長の計算に使用する指数加重係数を設定します。

特定の IP precedence を持つパケットの WRED パラメータを設定します。precedence ごとにこのコマンドを繰り返します。

同じポリシー マップ内で複数のクラスについてポリシーを設定するには、ステップ 2ステップ 5 を繰り返します。この一連のコマンドは、テール ドロップではなく、WRED パケット ドロップを使用します。


) ポリシー マップで、パケットのドロップにテール ドロップではなく WRED を使用するようクラスを設定する場合、このサービス ポリシーを適用しようとしているインターフェイスで WRED が設定されないようにしてください。


Class-Default クラス ポリシーの設定

class-default クラスは、定義したクラスのいずれにも該当しないトラフィックを分類するために使用されます。パケットが分類されると、クラスのディファレンシエーテッド サービスで使用可能なすべての標準メカニズムを適用します。ポリシー マップを作成したときに class-default クラスは事前定義されますが、設定する必要があります。デフォルトのクラスが設定されていない場合、デフォルトでは設定されているどのクラスにも一致しないトラフィックはフロー分類となり、ベストエフォート扱いとなります。

デフォルトで、class-default クラスは、フローベース WFQ として定義されます。ただし、 bandwidth policy-map クラス コンフィギュレーション コマンドを使用してデフォルト クラスを設定すると、デフォルト クラスはフローベース WFQ に使用できなくなります。

ポリシー マップを設定し、class-default クラスを設定してテール ドロップを使用するには、グローバル コンフィギュレーション モードで最初のコマンドを使用してポリシー マップ名を指定します。次に、デフォルト クラスのポリシーを設定するには、policy-map クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-default default-class-name

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 3

Router(config-pmap-c)# bandwidth { bandwidth-kbps | percent percent }

 

 

または

 

Router(config-pmap-c)# fair-queue [ number-of-dynamic-queues ]

クラスに割り当てる帯域幅の量(kbps 単位)または使用可能な帯域幅に占める割合を指定します。設定する帯域幅の量は、レイヤ 2 オーバーヘッドにも対応できるサイズにする必要があります。

デフォルト クラスで実行するフローベースの WFQ が使用するために予約する、ダイナミック キューの数を指定します。ダイナミック キューの数はインターフェイスの帯域幅から求めます。WFQ および CBWFQ をインターフェイスまたは ATM VC でイネーブルにするときに使用するダイナミック キューのデフォルト数については、『 Cisco IOS Quality of Service Solutions Command Reference 』の fair-queue (WFQ)コマンドの説明に記載されている表を参照してください。

ステップ 4

Router(config-pmap-c)# queue-limit number-of-packets

デフォルト クラスのキューに保存できるパケットの最大数を指定します。

ポリシー マップを設定し、class-default クラスを設定して WRED パケット ドロップを使用するには、グローバル コンフィギュレーション モードで最初のコマンドを使用してポリシー マップ名を指定します。次に、デフォルト クラスのポリシーを設定するには、policy-map クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-default default-class-name

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 3

Router(config-pmap-c)# bandwidth { bandwidth-kbps | percent percent }

 

 

または

 

Router(config-pmap-c)# fair-queue [ number-of-dynamic-queues ]

クラスに割り当てる帯域幅の量(kbps 単位)または使用可能な帯域幅に占める割合を指定します。設定する帯域幅の量は、レイヤ 2 オーバーヘッドにも対応できるサイズにする必要があります。

デフォルト クラスで動作するフローベース WFQ に使用するために、予約するダイナミック キューの数を指定します。ダイナミック キューの数はインターフェイスの帯域幅から求めます。WFQ および CBWFQ をインターフェイスまたは ATM VC でイネーブルにするときに使用するダイナミック キューのデフォルト数については、『 Cisco IOS Quality of Service Solutions Command Reference 』の fair-queue (WFQ)コマンドの説明に記載されている表を参照してください。

ステップ 4

Router(config-pmap-c)# random-detect

WRED をイネーブルにします。クラス ポリシーは、テール ドロップではなく WRED を使用してパケットをドロップします。

ステップ 5

Router(config-pmap-c)# random-detect exponential-weighting-constant exponent

 

または

 

Router(config-pmap-c)# random-detect precedence precedence min-threshold max-threshold mark-prob-denominator

平均キュー長の計算に使用する指数加重係数を設定します。

特定の IP precedence を持つパケットの WRED パラメータを設定します。precedence ごとにこのコマンドを繰り返します。

サービス ポリシーの適用と CBWFQ のイネーブル化

出力インターフェイスにサービス ポリシーを適用し、インターフェイスで CBWFQ をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。CBWFQ をイネーブルにすると、サービス ポリシー マップの一部として設定されているすべてのクラスは、均等化キューイング システムにインストールされます。

 

コマンド
目的

Router(config-if)# service-policy output policy-map

CBWFQ をイネーブルにし、指定したサービス ポリシー マップを出力インターフェイスに適用します。

物理インターフェイスでの CBWFQ は、インターフェイスがデフォルトのキューイング モードにある場合のみ設定可能です。E1(2.048 Mbps)以下でのシリアル インターフェイスでは、デフォルトで WFQ が使用されます。他のインターフェイスでは、デフォルトで FIFO が使用されます。物理インターフェイスで CBWFQ をイネーブルにすると、デフォルトのインターフェイス キューイング方式が上書きされます。ATM Permanent Virtual Circuit(PVC; 相手先固定接続)で CBWFQ をイネーブルにしても、デフォルトのキューイング方式は無効になりません。

既存のポリシー マップ クラスの帯域幅の変更

既存のクラスに割り当てる帯域幅の量を変更するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

変更するクラスを含むポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

帯域幅を変更するクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# bandwidth { bandwidth-kbps | percent percent }

クラスの再設定に使用する使用可能帯域幅の新しいサイズ(kbps 単位)または使用可能な帯域幅に占める割合を指定します。設定する帯域幅の量は、レイヤ 2 オーバーヘッドにも対応できるサイズにする必要があります。

既存のポリシー マップ クラスのキュー制限の変更

既存のクラス用に予約する、キューに保存するパケットの最大数を変更するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

変更するクラスを含むポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

キューの制限を変更するクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# queue-limit number-of-packets

再設定するクラスで、キューに保存できるパケットの新しい最大数を指定します。パケットのデフォルトおよび最大数は 64 です。

クラスの削除

サービス ポリシー マップから 1 つまたは複数のクラス マップを削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

削除するクラスを含むポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# no class class-name

削除するクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# no class class-default

デフォルトのクラスを削除します。

ポリシー マップの削除

ポリシー マップを削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# no policy-map policy-map

削除するポリシー マップの名前を指定します。

ポリシー マップとそのクラスの設定の確認

特定のポリシー マップ、特定のポリシー マップの特定のクラス、またはインターフェイスに設定されているすべてのポリシー マップの内容を表示するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map policy-map

指定したポリシー マップを構成するすべてのクラスの設定を表示します。

Router# show policy-map policy-map class class-name

指定したポリシー マップの指定したクラスの設定を表示します。

Router# show policy-map interface interface-name

指定したインターフェイスのすべてのポリシー マップについて、設定されているすべてのクラスの設定を表示します。

Router# show queue interface-type interface-number

特定のインターフェイスのキューイングの設定と統計情報を表示します。

show policy-map interface コマンドの発行後に表示されるカウンタは、インターフェイスで輻輳が発生した場合にのみ更新されます。

DCBWFQ の設定作業リスト

DCBWFQ を設定するには、以下の項で説明する作業を実行します。すべての作業は任意と記載されていますが、最初または 2 番めの項の作業は完了する必要があります。

「既存のトラフィック クラスの帯域幅の変更」(任意)

「既存のトラフィック クラスのキュー制限の変更」(任意)

「DCBWFQ のモニタリングと保守」(任意)

DCBWFQ はユーザ定義のトラフィック クラスとサービス ポリシーを使用して設定します。トラフィック クラスおよびサービス ポリシーは、Modular Quality of Service Command-Line Interface(CLI; コマンド ライン インターフェイス)機能を使用して設定されます。Modular QoS CLI で QoS を設定する方法については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

ポリシー マップとそのクラスの設定の確認については、この章の末尾を参照してください。

既存のトラフィック クラスの帯域幅の変更

輻輳が発生している環境で既存のトラフィック クラスに割り当てる帯域幅の量を変更するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するトラフィック ポリシーの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

 

帯域幅を変更するトラフィック クラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# bandwidth bandwidth-kbps

輻輳が発生したネットワーク環境でトラフィック クラスに割り当てる帯域幅の量(kbps)を指定します。

policy-map コマンドを使用してトラフィック ポリシーを設定した後は、インターフェイスにトラフィック ポリシーを適用してからイネーブルにする必要があります。トラフィック ポリシーをインターフェイスに適用する方法については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

既存のトラフィック クラスのキュー制限の変更

既存のトラフィック クラス用に予約する、キューに保存するパケットの最大数を変更するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するトラフィック ポリシーの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

キューの制限を変更するトラフィック クラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# queue-limit number-of-packets

再設定するトラフィック クラスで、キューに保存できるパケットの新しい最大数を指定します。パケットのデフォルトおよび最大数は 64 です。

policy-map コマンドを使用してサービス ポリシーを設定した後は、インターフェイスにトラフィック ポリシーを適用してからイネーブルにする必要があります。トラフィック ポリシーをインターフェイスに適用する方法については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

DCBWFQ のモニタリングと保守

トラフィック ポリシーと関連するトラフィック クラスの設定を表示するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map

設定済みトラフィック ポリシーをすべて表示します。

Router# show policy-map policy-map-name

ユーザが指定したトラフィック ポリシーを表示します。

Router# show policy-map interface

インターフェイスに適用されているすべての入力および出力ポリシーの統計情報と設定を表示します。

Router# show policy-map interface interface-spec

特定のインターフェイスに適用されている入力および出力ポリシーの設定と統計情報を表示します。

Router# show policy-map interface interface-spec input

インターフェイスに適用されている入力ポリシーの設定と統計情報を表示します。

Router# show policy-map interface interface-spec output

インターフェイスに適用されている出力ポリシーの設定と統計情報を表示します。

Router# show policy-map [ interface [ interface-spec [ input | output ] [ class class-name ]]]]

ポリシーに設定されているクラス名の設定と統計情報を表示します。

IP RTP プライオリティの設定作業リスト

IP RTP プライオリティを設定するには、以下の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

「IP RTP プライオリティの設定」(必須)

「IP RTP プライオリティの確認」(任意)

「IP RTP プライオリティのモニタリングと保守」(任意)

IP RTP プライオリティの設定例については、この章の末尾を参照してください。

Frame Relay Traffic Shaping(FRTS; フレームリレー トラフィック シェーピング)と Frame Relay Fragmentation(FRF.12 以降)は、IP RTP プライオリティ機能を使用する前に設定しておく必要があります。FRTS と FRF.12 の設定については、それぞれ『 MQC-Based Frame Relay Traffic Shaping 』モジュールと『 FRF.20 Support 』を参照してください。

IP RTP プライオリティの設定

UDP 宛先ポートの範囲に属する RTP パケット フロー セットについて、完全プライオリティ キューを予約するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip rtp priority starting-rtp-port-number port-number-range bandwidth

UDP 宛先ポートの範囲に属する RTP パケット フロー セットについて、完全プライオリティ キューを予約します。


注意 ip rtp priority コマンドは他のトラフィックよりも高い絶対優先度を指定するため、注意して使用してください。輻輳時に、トラフィックが設定した帯域幅を超えた場合、その超過したトラフィックはすべてドロップします。

ip rtp reserve および ip rtp priority コマンドは、同じインターフェイス上に設定できます。

frame-relay ip rtp priority コマンドによって、Frame Relay PVC に完全 PQ が提供されます。このコマンドの詳細については、『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。

IP RTP プライオリティの確認

プライオリティ キューの内容(キューの深さ、キューされる最初のパケットなど)を表示するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show queue interface-type interface-number

特定のインターフェイスのキューイングの設定と統計情報を表示します。

IP RTP プライオリティのモニタリングと保守

プライオリティ キューにドロップが発生している場合に RTP 帯域幅を調整したり、RTP トラフィックを減らしたりするには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# debug priority

プライオリティ キューからパケットがドロップされる場合、プライオリティ キューイングの出力を表示します。

Router# show queue interface-type interface-number

特定のインターフェイスのキューイングの設定と統計情報を表示します。

フレームリレー IP RTP プライオリティの設定作業リスト

フレームリレー IP RTP プライオリティを設定するには、以下の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

「フレームリレー IP RTP プライオリティの設定」(必須)

「フレームリレー IP RTP プライオリティの確認」(任意)

「フレームリレー IP RTP プライオリティのモニタリングと保守」(任意)

フレームリレー IP RTP プライオリティの設定例については、この章の末尾を参照してください。

フレームリレー IP RTP プライオリティの設定

UDP 宛先ポートの範囲に属する RTP パケット フロー セットについて、Frame Relay PVC に完全プライオリティ キューを予約するには、map-class コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-map-class)# frame-relay ip rtp priority starting-rtp-port-number port-number-range bandwidth

UDP 宛先ポートの範囲に属する RTP パケット フロー セットについて、完全プライオリティ キューを予約します。


注意 frame-relay ip rtp priority コマンドによって、他のトラフィックよりも絶対的なプライオリティが付与されるため、使用には注意が必要です。輻輳時に、トラフィックが設定した帯域幅を超えた場合、その超過したトラフィックはすべてドロップします。

フレームリレー IP RTP プライオリティの確認

フレームリレー IP RTP プライオリティ機能を確認するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show frame relay pvc

フレームリレー インターフェイス対応 PVC に関する統計情報を表示します。

Router# show queue interface-type interface-number

特定のインターフェイスの均等化キューイングの設定と統計情報を表示します。

Router# show traffic-shape queue

VC Data-Link Connection Identifier(DLCI; データリンク接続識別子)レベルで、特定の時点でキューイングされた要素に関する情報を表示します。

フレームリレー IP RTP プライオリティのモニタリングと保守

プライオリティ キューにドロップが発生している場合に RTP 帯域幅を調整したり、RTP トラフィックを減らしたりするには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# debug priority

プライオリティ キューからパケットがドロップされる場合、プライオリティ キューイングの出力を表示します。

フレームリレー PVC インターフェイス プライオリティの設定作業リスト

フレームリレー PVC インターフェイス プライオリティ機能を設定するには、以下の項で説明する作業を実行します。最初の 3 つの項の作業は必須です。残りの項の作業は任意です。

「マップ クラスの PVC プライオリティの設定」(必須)

「フレームリレー PIPQ のイネーブル化とキュー制限の設定」(必須)

「PVC へのマップ クラスの割り当て」(必須)

「フレームリレー PIPQ の確認」(任意)

「フレームリレー PIPQ のモニタリングと保守」(任意)

フレームリレー PVC インターフェイス PQ の設定例については、この章の末尾を参照してください。

マップ クラスの PVC プライオリティの設定

マップ クラス内で PVC プライオリティを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# map-class frame-relay map-class-name

フレームリレー マップ クラスを指定します。

ステップ 2

Router(config-map-class)# frame-relay interface-queue priority { high | medium | normal | low }

フレームリレー マップ クラスに PVC プライオリティ レベルを割り当てます。

フレームリレー PIPQ のイネーブル化とキュー制限の設定

Frame Relay(FR; フレームリレー)PIPQ をイネーブルにし、プライオリティ キュー サイズを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# interface type number [ name-tag ]

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# encapsulation frame-relay [ cisco | ietf ]

フレームリレー カプセル化をイネーブルにします。

ステップ 3

Router(config-if)# frame-relay interface-queue priority [ high-limit medium-limit normal-limit low-limit ]

フレームリレー PIPQ をイネーブルにし、プライオリティ キューの制限を設定します。

PVC へのマップ クラスの割り当て

特定の PVC にマップ クラスを割り当てるには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# frame-relay interface-dlci dlci

フレームリレー インターフェイスで単一の PVC を指定します。

ステップ 2

Router(config-fr-dlci)# class map-class-name

マップ クラスを指定した PVC に関連付けます。

フレームリレー PIPQ の確認

Frame Relay(FR)PIPQ の設定を確認するには、必要に応じて特権 EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show frame-relay pvc [ interface interface ][ dlci ]

フレームリレー インターフェイス対応 PVC に関する統計情報を表示します。

Router# show interfaces [ type number ][ first ][ last ]

シリアル インターフェイスに固有の統計情報を表示します。

Router# show queueing [ custom | fair | priority | random-detect [ interface atm_subinterface [ vc [[ vpi /] vci ]]]]

すべてまたは選択した設定済みキューイング戦略を表示します。

フレームリレー PIPQ のモニタリングと保守

Frame Relay(FR)PIPQ の設定をモニタおよび保守するには、必要に応じて特権 EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# debug priority

プライオリティ キューからパケットがドロップされる場合、プライオリティ キューイングの出力を表示します。

Router# show frame-relay pvc [ interface interface ][ dlci ]

フレームリレー インターフェイス対応 PVC に関する統計情報を表示します。

Router# show interfaces [ type number ][ first ][ last ]

シリアル インターフェイスに固有の統計情報を表示します。

Router# show queue i nterface-name interface-number [ vc [ vpi /] vci ][ queue-number ]

特定のインターフェイスまたは VC のキュー内部のパケットのコンテンツを表示します。

Router# show queueing [ custom | fair | priority | random-detect [ interface atm_subinterface [ vc [[ vpi /] vci ]]]]

すべてまたは選択した設定済みキューイング戦略を表示します。

低遅延キューイングの設定作業リスト

LLQ を設定するには、以下の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

「LLQ の設定」(必須)

「LLQ の確認」(任意)

「LLQ のモニタリングと保守」(任意)

LLQ の設定例については、この章の末尾を参照してください。

LLQ の設定

ポリシー マップ内でクラスにプライオリティを付与するには、policy-map クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-pmap-c)# priority bandwidth

このトラフィック クラス用に完全プライオリティ キューを予約します。

LLQ の確認

プライオリティ キューの内容(キューの深さ、キューされる最初のパケットなど)を表示するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show queue interface-type interface-number

特定のインターフェイスのキューイングの設定と統計情報を表示します。

プライオリティ キューは、通話 ID がダイナミック キュー + 8 の数値と同じキューです。プライオリティ キューのパケットの重み付けは 0 です。

LLQ のモニタリングと保守

プライオリティ キューにドロップが発生している場合に RTP 帯域幅を調整したり、RTP トラフィックを減らしたりするには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# debug priority

プライオリティ キューからパケットがドロップされる場合、プライオリティ キューイングの出力を表示します。

Router# show queue interface-type interface-number

特定のインターフェイスのキューイングの設定と統計情報を表示します。

Router# show policy-map interface interface-name

指定したインターフェイスのすべてのトラフィック ポリシーについて、設定されているすべてのクラスの設定を表示します。インターフェイスに適用されているトラフィック ポリシーのプライオリティ クラスについて、パケットおよびバイトが破棄またはドロップされることを表示します。

分散型 LLQ の設定作業リスト

分散型 LLQ を設定するには、以下の項で説明する作業を実行します。最初の 2 つの項の作業は必須です。残りの項の作業は任意です。

「使用可能な帯域幅の量に関するプライオリティ キューの設定」(必須)

「使用可能な帯域幅の割合に関するプライオリティ キューの設定」(必須)

「送信リング制限の設定」(任意)

「分散型 LLQ の確認」(任意)

「送信リング制限の確認」(任意)

「分散型 LLQ のモニタリングと保守」(任意)

分散型 LLQ の設定例については、この章の末尾を参照してください。

使用可能な帯域幅の量に関するプライオリティ キューの設定

トラフィック ポリシー内で使用可能な帯域幅の量に基づいて、トラフィック クラスにプライオリティを付与するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-name

設定するポリシー マップの名前を指定します。ポリシー マップ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-pmap)# class class-name

サービス ポリシーに含まれる定義済みクラスの名前を指定します。ポリシー マップ クラス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-pmap-c)# priority kpbs [ bytes ]

CBWFQ トラフィックに使用可能な帯域幅の指定した量で、プライオリティ キューを予約します。

この項に設定したトラフィック ポリシーは、まだインターフェイスに適用されていません。トラフィック ポリシーをインターフェイスに適用する方法については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

使用可能な帯域幅の割合に関するプライオリティ キューの設定

使用可能な帯域幅の割合に基づいて、クラスにプライオリティを付与するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-name

 

設定するトラフィック ポリシーの名前を指定します。ポリシー マップ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-pmap)# class class-name

 

サービス ポリシーに含まれる定義済みクラスの名前を指定します。ポリシー マップ クラス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-pmap-c)# priority percent percent

 

CBWFQ トラフィックに使用可能な帯域幅の指定した割合で、プライオリティ キューを予約します。

この項に設定したトラフィック ポリシーは、まだインターフェイスに適用されていません。トラフィック ポリシーをインターフェイスに適用する方法については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

送信リング制限の設定

ATM PVC の送信リングに使用可能なパーティクルの数を制限するには、グローバル インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# interface atm interface-name

設定する ATM インターフェイスの名前を指定します。

ステップ 2

Router(config-if)# atm pvc vcd-number vpi-number vci-number Encapsulation-type tx-ring-limit ring-limit

設定する ATM PVC、カプセル化タイプ、および送信リングの制限値を指定します。

ATM サブインターフェイスの送信リングに使用可能なパーティクルの数を制限するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# interface atm subinterface name

設定するサブインターフェイスの名前を指定します。

ステップ 2

Router(config-subif)# pvc pvc-name

設定する PVC の名前を指定します。

ステップ 3

Router(config-if-atm-vc)# tx-ring-limit ring-limit

送信リング制限値を指定します。

分散型 LLQ の確認

プライオリティ キューの内容(キューの深さ、キューされる最初のパケットなど)を表示するには、必要に応じて、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show interfaces [ interface-type interface-number ] fair-queue

VIP ベースのインターフェイスの WFQ について、情報と統計情報を表示します。

Router# show policy-map policy-map-name

特定のポリシー マップのプライオリティ設定など、ポリシー マップの内容を表示します。

プライオリティ キューは、通話 ID がダイナミック キュー + 8 の数値と同じキューです。プライオリティ キューのパケットの重み付けは 0 です。

送信リング制限の確認

インターフェイスまたは PVC の内容を表示するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show atm vc vc-name

VC の内容を表示します。 tx-ring-limit コマンドを適切にイネーブルにすると、 show atm vc コマンドの出力は送信リングの制限値を示します。

分散型 LLQ のモニタリングと保守

プライオリティ キューにドロップが発生している場合に Real-Time Transport Protocol(RTP)帯域幅を調整したり、RTP トラフィックを減らしたりするには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show interfaces [ interface-type interface-number ] fair-queue

VIP ベースのインターフェイスの WFQ について、情報と統計情報を表示します。

Router# show policy-map policy-map-name

特定のポリシー マップのプライオリティ設定など、トラフィック ポリシーの内容を表示します。

Router# show policy interface interface-name

指定したインターフェイスのすべてのサービス ポリシーについて、設定されているすべてのクラスの設定を表示します。インターフェイスに適用されているサービス ポリシーのプライオリティ クラスについて、パケットおよびバイトが破棄またはドロップされることを表示します。

Router# show atm vc vc-name

VC の内容を表示します。 tx-ring-limit コマンドを適切にイネーブルにすると、 show atm vc コマンドの出力は送信リングの制限値を示します。

フレームリレー向け低遅延キューイングの設定作業リスト

フレームリレー向け LLQ を設定するには、以下の項で説明する作業を実行します。最初の 3 つの項の作業は必須です。残りの項の作業は任意です。

「クラス マップの定義」(必須)

「ポリシー マップでのクラス ポリシーの設定」(必須)

「サービス ポリシーの割り当てとフレームリレー向け LLQ のイネーブル化」(必須)

「ポリシー マップとそのクラスの設定の確認」(任意)

「フレームリレー向け LLQ のモニタリングと保守」(任意)

フレームリレー向け LLQ の設定例については、この章の末尾を参照してください。

クラス マップの定義

クラスにパケットが属しているかをチェックする一致基準を含むクラス マップを作成するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# class-map class-map-name

作成するクラス マップの名前を指定します。

ステップ 2

Router(config-cmap)# match access-group { a ccess-group | name access-group-name}

または

 

Router(config-cmap)# match input-interface interface-name

 

または

 

Router(config-cmap)# match protocol protocol

クラスにコンテンツ パケットが属しているかを確認する ACL の名前を指定します。

クラスにパケットが属しているかをチェックする一致基準として使用する入力インターフェイスの名前を指定します。

クラスにパケットが属しているかをチェックする一致基準として使用するプロトコルの名前を指定します。

ポリシー マップでのクラス ポリシーの設定

ポリシー マップを設定し、サービス ポリシーを構成するクラス ポリシーを作成するには、最初に policy-map コマンドを使用してポリシー マップの名前を指定します。次に、次のコマンドを 1 つ以上使い、標準クラスまたはデフォルト クラスのポリシーを設定します。

priority

bandwidth

queue-limit または random-detect

fair-queue (class-default クラスの場合のみ)

定義するクラスごとに、リストされているコマンドを 1 つ以上使い、クラス ポリシーを設定します。たとえば、あるクラスには帯域幅を、別のクラスには帯域幅およびキュー制限を指定します。

ポリシー マップのデフォルト クラス(一般に class-default クラスといいます)は、ポリシー マップで定義されているその他のクラスの一致基準を満たさない場合にトラフィックが送られるクラスです。

クラス ポリシーはルータで定義可能な数だけ設定できます(最大 64 個)。ただし、ポリシー マップのすべてのクラスに割り当てられている帯域幅の合計は、最小 Committed Information Rate(CIR; 認定情報レート)を超えてはいけません。最小 CIR は、VC と、 frame-relay voice bandwidth コマンドおよび frame-relay ip rtp priority コマンドで予約されている帯域幅の差に設定されているレートです。最小 CIR が設定されていない場合は、CIR の半分が帯域幅のデフォルトになります。割り当てられていない帯域幅がある場合は、残っている帯域幅は設定されている帯域幅に応じてクラスに割り当てられます。

ポリシー マップのクラス ポリシーを設定するには、以降の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

「LLQ プライオリティ キューのクラス ポリシーの設定」(必須)

「指定した帯域幅および WRED パケット ドロップを使用したクラス ポリシーの設定」(任意)

「Class-Default クラス ポリシーの設定」(任意)

LLQ プライオリティ キューのクラス ポリシーの設定

ポリシー マップを設定し、ポリシー マップ内のクラスにプライオリティを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

作成し、サービス ポリシーで使用するクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# priority bandwidth-kbps

完全プライオリティ クラスを作成し、そのクラスに割り当てる帯域幅の量(kbps)を指定します。

指定した帯域幅および WRED パケット ドロップを使用したクラス ポリシーの設定

ポリシー マップを設定し、サービス ポリシーを構成するクラス ポリシーを作成するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

作成し、サービス ポリシーで使用するクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# bandwidth bandwidth-kbps

クラスに割り当てる帯域幅の量(kbps)または使用可能な帯域幅のパーセントを指定します。帯域幅は kbps またはパーセントで指定します。単位はクラス内で統一します(プライオリティ キューの帯域幅は kbps で指定)。

ステップ 4

Router(config-pmap-c)# random-detect

WRED をイネーブルにします。

同じポリシー マップ内で複数のクラスについてポリシーを設定するには、ステップ 2ステップ 4 を繰り返します。

Class-Default クラス ポリシーの設定

class-default クラスは、定義したクラスのいずれにも該当しないトラフィックを分類するために使用されます。ポリシー マップの作成時に class-default クラスを事前定義していても、あらためて定義する必要があります。デフォルト クラスを設定していなければ、設定したクラスのいずれにも該当しないトラフィックはベストエフォート扱いになります。ベストエフォート扱いとは、可能な場合はネットワークがそのトラフィックを配信し、信頼性、遅延防止、スループットは保証されないというものです。

ポリシー マップと class-default クラスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-default default-class-name

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 3

Router(config-pmap-c)# bandwidth bandwidth-kbps

 

または

 

Router(config-pmap-c)# fair-queue [ number-of-dynamic-queues ]

クラスに割り当てる帯域幅の量(kbps 単位)を指定します。

デフォルト クラスで実行するフローベースの WFQ が使用するために予約する、ダイナミック キューの数を指定します。ダイナミック キューの数はインターフェイスの帯域幅から求めます。

ステップ 4

Router(config-pmap-c)# queue-limit number-of-packets

デフォルト クラスのキューに保存できるパケットの最大数を指定します。

サービス ポリシーの割り当てとフレームリレー向け LLQ のイネーブル化

サービス ポリシーを出力インターフェイスにアタッチし、フレームリレー向け LLQ をイネーブルにするには、マップ クラス コンフィギュレーション モードで次のコマンドを使用します。LLQ をイネーブルにすると、サービス ポリシー マップの一部として設定されているすべてのクラスは、均等化キューイング システムにインストールされます。

 

コマンド
目的

Router(config-map-class)# service-policy output policy-map

指定したサービス ポリシー マップを出力インターフェイスにアタッチし、フレームリレー向け LLQ をイネーブルにします。

ポリシー マップとそのクラスの設定の確認

インターフェイスに設定されている特定のポリシー マップまたはすべてのポリシー マップの内容を表示するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show frame-relay pvc dlci

PVC および特定の DLCI のポリシー マップのクラスの設定に関する統計情報を表示します。

Router# show policy-map interface interface-name

FRTS が設定されている場合、すべてのフレームリレー VC レベルのポリシー マップに関するクラスの設定を表示します。

FRTS を設定しない場合、インターフェイスレベル ポリシーに関するクラスの設定を表示します。

Router# show policy-map interface interface-name dlci dlci

FRTS が設定されている場合は、特定の DLCI の、ポリシー マップのクラスの設定を表示します。

フレームリレー向け LLQ のモニタリングと保守

フレームリレー向け LLQ のモニタに使用できるコマンドのリストについては、前の項のポリシー マップとそのクラスの設定の確認を参照してください。

LLQ 設定作業リストのバースト サイズの設定

LLQ のバースト サイズを設定するには、以下の項で説明する作業を実行します。最初の 2 つの項は必須です。残りの項は任意です。

「LLQ 帯域幅の設定」(必須)

「LLQ バースト サイズの設定」(必須)

「LLQ バースト サイズの確認」(任意)

LLQ のバースト サイズの設定例については、この章の末尾を参照してください。

LLQ 帯域幅の設定

LLQ 帯域幅を設定するには、policy-map クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# priority bandwidth

プライオリティ トラフィックの最大帯域幅の量(kbps 単位)を指定します。

LLQ バースト サイズの設定

LLQ バースト サイズを設定するには、policy-map クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# priority bandwidth burst

バースト サイズ(バイト単位)を指定します。範囲は 32 ~ 200 万です。

LLQ バースト サイズの確認

LLQ バースト サイズを確認するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map

指定したサービス ポリシー マップを構成する全クラスの設定、またはすべての既存ポリシー マップに関する全クラスの設定を表示します。

Router# show policy-map interface

 

指定したインターフェイスまたは PVC でサービス ポリシーに設定されているクラスの設定を表示します。

ATM アダプタの VC 単位ホールド キューのサポートの設定作業リスト

ATM アダプタの VC 単位ホールド キューのサポートを設定するには、以下の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

「ATM アダプタでの VC 単位ホールド キューの設定」(必須)

「ATM アダプタの VC 単位ホールド キューの設定の確認」(任意)

ATM アダプタの VC 単位ホールド キューのサポート:例については、この章の末尾を参照してください。

VC 単位および ATM 設定に関連する情報については、『 IP to ATM Class of Service Overview 』モジュールおよび『 Configuring IP to ATM Class of Service 』モジュールを参照してください。

ATM アダプタでの VC 単位ホールド キューの設定

ATM アダプタで VC 単位ホールド キューを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# vc-hold-queue number-of-packets

VC 単位ホールド キューに含まれるパケット数を指定します。5 ~ 1024 の範囲の数を指定できます。

ATM アダプタの VC 単位ホールド キューの設定の確認

ATM アダプタの VC 単位ホールド キューの設定を確認するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show queueing interface

インターフェイスまたは VC のキューイングの統計情報を表示します。

フローベース WFQ の設定例

次に、64 メッセージ、512 ダイナミック キュー、および 18 RSVP キューを含む均等化キューを要求する例を示します。

Router(config)# interface Serial 3/0
Router(config-if)# ip unnumbered Ethernet 0/0
Router(config-if)# fair-queue 64 512 18
 

WFQ の設定方法については、この章のフローベース WFQ の設定作業リストを参照してください。

DWFQ の設定例

ここでは、DWFQ の設定例を示します。

「フローベース DWFQ:例」

「QoS グループベース DWF:例」

「ToS ベースの DWFQ:例」

DWFQ の設定方法については、この章の分散重み付け均等化キューイングの設定作業リストを参照してください。

フローベース DWFQ:例

次に、HSSI インターフェイス 0/0/0 で DWFQ をイネーブルにする例を示します。

Router(config)# interface Hssi0/0/0
Router(config-if)# description 45Mbps to R2
Router(config-if)# ip address 200.200.14.250 255.255.255.252
Router(config-if)# fair-queue
 

次に、この設定の show interfaces fair-queue コマンドの出力例を示します。

Router# show interfaces hssi 0/0/0 fair-queue
 
Hssi0/0/0 queue size 0
packets output 35, drops 0
WFQ: global queue limit 401, local queue limit 200
 

QoS グループベース DWF:例

次に、QoS グループベース DWFQ を設定する例を示します。Committed Access Rate(CAR; 専用アクセス レート)ポリシーは、2 の IP precedence 値を持つパケットを QoS グループ 2 に割り当てるために使用されます。6 の IP precedence 値は、QoS グループ 6 に割り当てられます。

Router(config)# interface Hssi0/0/0
Router(config-if)# ip address 188.1.3.70 255.255.255.0
Router(config-if)# rate-limit output access-group rate-limit 6 155000000 2000000 8000000 conform-action set-qos-transmit 6 exceed-action drop
Router(config-if)# rate-limit output access-group rate-limit 2 155000000 2000000 8000000 conform-action set-qos-transmit 2 exceed-action drop
Router(config-if)# fair-queue qos-group
Router(config-if)# fair-queue qos-group 2 weight 10
Router(config-if)# fair-queue qos-group 2 limit 27
Router(config-if)# fair-queue qos-group 6 weight 30
Router(config-if)# fair-queue qos-group 6 limit 27
!
Router(config)# access-list rate-limit 2 2
Router(config)# access-list rate-limit 6 6
 

次の出力例は、 show interfaces fair-queue コマンドを使用して WFQ の統計情報を表示する方法を示します。

Router# show interfaces fair-queue
 
Hssi0/0/0 queue size 0
packets output 806232, drops 1
WFQ: aggregate queue limit 54, individual queue limit 27
max available buffers 54
 
Class 0: weight 60 limit 27 qsize 0 packets output 654 drops 0
Class 2: weight 10 limit 27 qsize 0 packets output 402789 drops 0
Class 6: weight 30 limit 27 qsize 0 packets output 402789 drops 1

ToS ベースの DWFQ:例

次に、デフォルトのパラメータを使用して、タイプ オブ サービス(ToS)ベースの DWFQ のタイプを設定する例を示します。

Router# configure terminal
Router(config)# interface Hssi0/0/0
Router(config-if)# fair-queue tos
Router(config-if)# end
 

次に、HSSI インターフェイス 0/0/0 の show running-config コマンドの出力を示します。ルータによってデフォルトの重み付けが自動的に追加され、ToS クラスの制限が設定に追加されます。

interface Hssi0/0/0
ip address 188.1.3.70 255.255.255.0
fair-queue tos
fair-queue tos 1 weight 20
fair-queue tos 1 limit 27
fair-queue tos 2 weight 30
fair-queue tos 2 limit 27
fair-queue tos 3 weight 40
fair-queue tos 3 limit 27
 

次の出力例は、 show interfaces fair-queue コマンドを使用して DWFQ の統計情報を表示する方法を示します。

Router# show interfaces fair-queue
 
Hssi0/0/0 queue size 0
packets output 1417079, drops 2
WFQ: aggregate queue limit 54, individual queue limit 27
max available buffers 54
 
Class 0: weight 10 limit 27 qsize 0 packets output 1150 drops 0
Class 1: weight 20 limit 27 qsize 0 packets output 0 drops 0
Class 2: weight 30 limit 27 qsize 0 packets output 775482 drops 1
Class 3: weight 40 limit 27 qsize 0 packets output 0 drops 0

CBWFQ の設定例

ここでは、CBWFQ の設定例を示します。

「クラス マップの設定:例」

「ポリシーの作成:例」

「インターフェイスへのポリシーの割り当て:例」

「WRED パケット ドロップを使用した CBWFQ:例」

「サービス ポリシー マップの内容の表示例」

CBWFQ の設定方法については、この章のクラスベース WFQ の設定作業リストを参照してください。

クラス マップの設定:例

次の例では、ACL 101 および 102 が作成されます。次に、2 つのクラス マップが作成され、その一致基準が定義されます。1 つめの class1 という名前のマップクラスでは、一致基準として番号付きの ACL 101 が使用されます。2 つめの class2 という名前のマップクラスでは、一致基準として番号付きの ACL 102 が使用されます。パケットはこれらの ACL の内容と照合され、そのクラスに属するかどうかが判断されます。

Router(config)# access-list 101 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 20000
Router(config# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 56000
 
Router(config)# class-map class1
Router(config-cmap)# match access-group 101
Router(config-cmap)# exit
 
Router(config-cmap)# class-map class2
Router(config-cmap)# match access-group 102
Router(config-cmap)# exit

ポリシーの作成:例

次の例では、class1 と class2 という 2 つのクラス用のポリシー設定を含む、policy1 というポリシー マップが定義されます。これらのクラスの一致基準は、前述のクラス マップの設定:例で定義されました。

class1 では、帯域幅の割り当て要求と、このクラスのキューが保存できるパケットの最大数がポリシーに指定されます。class2 のポリシーでは、帯域幅の割り当て要求に 1000 kbps が指定されているため、デフォルトのキューの制限は 64 パケットであると想定されます。

Router(config)# policy-map policy1
 
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 3000
Router(config-pmap-c)# queue-limit 30
Router(config-pmap-c)# exit
 
Router(config-pmap)# class class2
Router(config-pmap-c)# bandwidth 2000
Router(config-pmap-c)# exit

インターフェイスへのポリシーの割り当て:例

次に、既存のポリシー マップを割り当てる例を示します。ポリシー マップを定義した後は、そのマップを 1 つまたは複数のインターフェイスに割り当て、そのインターフェイスのサービス ポリシーを指定できます。同じポリシー マップを複数のインターフェイスに割り当てることができますが、各インターフェイスは、入力に 1 つのポリシー マップ、出力に 1 つのポリシー マップのみを割り当てることができます。

この例のポリシー マップは、前述のポリシーの作成:例で定義されました。

Router(config)# interface e1/1
Router(config-if)# service output policy1
Router(config-if)# exit
 
Router(config)# interface fa1/0/0
Router(config-if)# service output policy1
Router(config-if)# exit

WRED パケット ドロップを使用した CBWFQ:例

次の例では、class1 というクラス マップが作成され、パケットがそのクラスに属することを確認するために、一致基準として入力 FastEthernet インターフェイス 0/1 を使用するように定義されます。次のポリシー マップ policy1 は、class1 のポリシー設定を含むように定義されます。これは WRED パケット ドロップ用に設定されます。

Router(config)# class-map class1
Router(config-cmap)# match input-interface FastEthernet0/1
!
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 1000
Router(config-pmap-c)# random-detect
!
Router(config)# interface serial0/0
Router(config-if)# service-policy output policy1
!

サービス ポリシー マップの内容の表示例

次に、サービス ポリシー マップの内容を表示する例を示します。内容を表示するには、4 つの方法があります。

指定したサービス ポリシー マップを構成するすべてのクラスを表示します。

すべてのサービス ポリシー マップに設定されたすべてのクラスを表示します。

サービス ポリシー マップの指定したクラスを表示します。

指定したインターフェイスのすべてのサービス ポリシー マップに設定されたすべてのクラスを表示します。

指定したサービス ポリシー マップのすべてのクラス

次に、po1 というサービス ポリシー マップの内容を表示する例を示します。

Router# show policy-map po1
 
Policy Map po1
Weighted Fair Queueing
Class class1
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class2
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class3
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class4
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class5
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class6
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class7
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class8
Bandwidth 937 (kbps) Max thresh 64 (packets)

すべてのサービス ポリシー マップのすべてのクラス

次に、ルータ上のすべてのポリシー マップの内容を表示する例を示します。

Router# show policy-map
 
Policy Map poH1
Weighted Fair Queueing
Class class1
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class2
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class3
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class4
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class5
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class6
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class7
Bandwidth 937 (kbps) Max thresh 64 (packets)
Class class8
Bandwidth 937 (kbps) Max thresh 64 (packets)
Policy Map policy2
Weighted Fair Queueing
Class class1
Bandwidth 300 (kbps) Max thresh 64 (packets)
Class class2
Bandwidth 300 (kbps) Max thresh 64 (packets)
Class class3
Bandwidth 300 (kbps) Max thresh 64 (packets)
Class class4
Bandwidth 300 (kbps) Max thresh 64 (packets)
Class class5
Bandwidth 300 (kbps) Max thresh 64 (packets)
Class class6
Bandwidth 300 (kbps) Max thresh 64 (packets)

サービス ポリシー マップの指定ししたクラス

次に、po1 というポリシー マップに属する class7 というクラスの設定を表示する例を示します。

Router# show policy-map po1 class class7

Class class7
Bandwidth 937 (kbps) Max Thresh 64 (packets)

指定したインターフェイス上のすべてのサービス ポリシー マップのすべてのクラス

次に、出力イーサネット インターフェイス 2/0 上のクラスについて設定を表示する例を示します。かっこ内の数字は、Management Information Base(MIB; 管理情報ベース)で使用されます。

Router# show policy-map interface e2/0
 
Ethernet2/0
 
Service-policy output:p1 (1057)
 
Class-map:c1 (match-all) (1059/2)
19 packets, 1140 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:ip precedence 0 (1063)
Weighted Fair Queueing
Output Queue:Conversation 265
Bandwidth 10 (%) Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
 
Class-map:c2 (match-all) (1067/3)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:ip precedence 1 (1071)
Weighted Fair Queueing
Output Queue:Conversation 266
Bandwidth 10 (%) Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
 
Class-map:class-default (match-any) (1075/0)
8 packets, 2620 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:any (1079)

Distributed CBWFQ の設定例

ここでは、CBWFQ の設定例を示します。

「トラフィック クラスの設定:例」

「トラフィック ポリシーの作成:例」

「インターフェイスへのトラフィック ポリシーの割り当て:例」

DCBWFQ の設定方法については、この章の「DCBWFQ の設定作業リスト」を参照してください。

トラフィック クラスの設定:例

次に、2 つのトラフィック クラスを作成し、その一致条件を定義する例を示します。1 つめの class1 という名前のトラフィック クラスでは、一致基準として番号付きの ACL 101 が使用されます。2 つめの class2 という名前のトラフィック クラスでは、一致基準として番号付きの ACL 102 が使用されます。パケットはこれらの ACL の内容と照合され、そのトラフィック クラスに属するかどうかが判断されます。

Router(config)# class-map class1
Router(config-cmap)# match access-group 101
Router(config-cmap)# exit
 
Router(config)# class-map class2
Router(config-cmap)# match access-group 102
Router(config-cmap)# exit
 

トラフィック クラスの詳細については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

トラフィック ポリシーの作成:例

次の例では、policy1 というトラフィック ポリシーが定義され、QoS 機能と、class1 と class2 という 2 つのトラフィック クラスが関連付けられます。これらのトラフィック クラスの一致基準は、前述のクラス マップの設定:例で定義されました。

class1 に対しては、帯域幅割り当て要求と、そのクラス用に予約されるキューの最大パケット数の制限が QoS ポリシーに含まれています。class2 のポリシーでは、帯域幅の割り当て要求に 1000 kbps が指定されているため、デフォルトのキューの制限は 64 パケットであると想定されます。

Router(config)# policy-map policy1
 
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 3000
Router(config-pmap-c)# queue-limit 30
Router(config-pmap)# exit
 
Router(config-pmap)# class class2
Router(config-pmap-c)# bandwidth 2000
Router(config-pmap)# exit
 

トラフィック ポリシーの設定の詳細については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

インターフェイスへのトラフィック ポリシーの割り当て:例

次に、既存のトラフィック ポリシーをインターフェイスに適用する例を示します。トラフィック ポリシーを定義した後は、そのマップを 1 つまたは複数のインターフェイスに割り当て、そのインターフェイスのトラフィック ポリシーを指定できます。 同じポリシー マップを複数のインターフェイスに割り当てることができますが、各インターフェイスは、入力に 1 つのトラフィック ポリシー、1 回の出力に 1 つのトラフィック ポリシーのみを割り当てることができます

Router(config)# interface fe1/0/0
Router(config-if)# service output policy1
Router(config-if)# exit
 

トラフィック ポリシー設定の割り当ての詳細については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

IP RTP プライオリティの設定例

ここでは、IP RTP プライオリティの設定例を示します。

「CBWFQ の設定:例」

「仮想テンプレートの設定:例」

「マルチリンク バンドルの設定:例」

「デバッグ:例」

IP RTP プライオリティの設定方法については、この章の「IP RTP プライオリティの設定作業リスト」を参照してください。

CBWFQ の設定:例

次の例では、まず CBWFQ の設定を定義してから、完全プライオリティ キューを予約します。

! The following commands define a class map:
Router(config)# class-map class1
Router(config-cmap)# match access-group 101
Router(config-cmap)# exit
 
! The following commands create and attach a policy map:
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 3000
Router(config-pmap-c)# queue-limit 30
Router(config-pmap-c)# random-detect
Router(config-pmap-c)# random-detect precedence 0 32 256 100
Router(config-pmap-c)# exit
Router(config)# interface Serial1
Router(config-if)# service-policy output policy1
 
! The following command reserves a strict priority queue:
Router(config-if)# ip rtp priority 16384 16383 40
 

queue-limit コマンドと random-detect コマンドは、CBWFQ 設定では任意のコマンドです。 queue-limit コマンドは、クラス キューのテール ドロップ制限を設定するために使用されます。 random-detect コマンドは、インターフェイスで使用できる random-detect コマンドと同様に、クラス キューの RED ドロップ制限を設定するために使用されます。

仮想テンプレートの設定:例

次に、CBWFQ による仮想テンプレート設定で完全プライオリティ キューを設定する例を示します。

Router(config)# multilink virtual-template 1
Router(config)# interface virtual-template 1
Router(config-if)# ip address 172.16.1.1 255.255.255.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip rtp priority 16384 16383 25
Router(config-if)# service-policy output policy1
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave
Router(config-if)# end
 
Router(config)# interface Serial0/1
Router(config-if)# bandwidth 64
Router(config-if)# ip address 1.1.1.2 255.255.255.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# ppp multilink
Router(config-if)# end
 

) 仮想アクセス インターフェイス機能を適切に実行するには、bandwidth policy-map クラス コンフィギュレーション コマンドは、仮想テンプレートで設定しないでください。例のように、実際のインターフェイスで設定する必要があります。


マルチリンク バンドルの設定:例

次に、WFQ によるマルチリンク バンドル設定で完全プライオリティ キューを設定する例を示します。マルチリンク バンドルを使用する利点は、異なるインターフェイスで異なる IP RTP プライオリティ パラメータを指定できることです。

次のコマンドでは、マルチリンク バンドル 1 を作成します。これは、200 kbps という最大 IP RTP プライオリティの帯域幅に設定されます。

Router(config)# interface multilink 1
Router(config-if)# ip address 172.17.254.161 255.255.255.248
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip rtp priority 16384 16383 200
Router(config-if)# no ip mroute-cache
Router(config-if)# fair-queue 64 256 0
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave
 

次のコマンドでは、マルチリンク バンドル 2 を作成します。これは、100 kbps という最大 IP RTP プライオリティの帯域幅に設定されます。

Router(config)# interface multilink 2
Router(config-if)# ip address 172.17.254.162 255.255.255.248
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip rtp priority 16384 16383 100
Router(config-if)# no ip mroute-cache
Router(config-if)# fair-queue 64 256 0
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave
 

例の次の部分では、 multilink-group コマンドを使用して、シリアル インターフェイス 2/0 をマルチリンク バンドル 1 の一部になるように設定します。

Router(config)# interface serial 2/0
Router(config-if)# bandwidth 256
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# no ip mroute-cache
Router(config-if)# no fair-queue
Router(config-if)# clockrate 256000
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 1
 

次に、シリアル インターフェイス 2/1 をマルチリンク バンドル 2 の一部になるように設定します。

Router(config)# interface serial 2/1
Router(config-if)# bandwidth 128
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# no ip mroute-cache
Router(config-if)# no fair-queue
Router(config-if)# clockrate 128000
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 2

デバッグ:例

次に、 debug priority コマンドの出力例を示します。この例の 64 は、パケットがドロップされた時点の実際のプライオリティ キューの深さを示します。

Router# debug priority
 
*Feb 28 16:46:05.659:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.671:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.679:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.691:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.699:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.711:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.719:WFQ:dropping a packet from the priority queue 64
 

フレームリレー IP RTP プライオリティの設定例

この「一致する RTP パケットに対する完全プライオリティ サービス:例」では、設定例を示します。

フレームリレー IP RTP プライオリティ キューイングの設定方法については、この章の「フレームリレー IP RTP プライオリティの設定作業リスト」を参照してください。

一致する RTP パケットに対する完全プライオリティ サービス:例

次に、まず voip という フレームリレー マップ クラスを設定し、次にマップ クラスを PVC 100 に割り当て、一致する RTP パケットに完全プライオリティ サービスを提供する例を示します。この例では、16384 ~ 32764 の範囲の UDP ポートを使用する PVC 100 の RTP パケットに一致し、完全プライオリティ サービスが提供されます。

map-class frame-relay voip
frame-relay cir 256000
frame-relay bc 2560
frame-relay be 600
frame-relay mincir 256000
no frame-relay adaptive-shaping
frame-relay fair-queue
frame-relay fragment 250
frame-relay ip rtp priority 16384 16380 210
 
interface Serial5/0
ip address 10.10.10.10 255.0.0.0
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
load-interval 30
clockrate 1007616
frame-relay traffic-shaping
frame-relay interface-dlci 100
class voip
frame-relay ip rtp header-compression
frame-relay intf-type dce

フレームリレー PVC インターフェイス PQ の設定例

ここでは、フレームリレー PIPQ の設定例を示します。

フレームリレー PIPQ の設定方法については、この章の「フレームリレー PVC インターフェイス プライオリティの設定作業リスト」を参照してください。

次に、シリアル インターフェイス 0 で 4 つの PVC を設定する例を示します。DLCI 100 には high プライオリティ、DLCI 200 には medium プライオリティ、DLCI 300 には normal プライオリティ、DLCI 400 には low プライオリティが割り当てられます。

次のコマンドでは、PVC プライオリティ レベルを使用して フレームリレー マップ クラスを設定します。

Router(config)# map-class frame-relay HI
Router(config-map-class)# frame-relay interface-queue priority high
Router(config-map-class)# exit
Router(config)# map-class frame-relay MED
Router(config-map-class)# frame-relay interface-queue priority medium
Router(config-map-class)# exit
Router(config)# map-class frame-relay NORM
Router(config-map-class)# frame-relay interface-queue priority normal
Router(config-map-class)# exit
Router(config)# map-class frame-relay LOW
Router(config-map-class)# frame-relay interface-queue priority low
Router(config-map-class)# exit
 

次のコマンドを使用して、フレームリレー カプセル化および フレームリレー PIPQ をシリアル インターフェイス 0 でイネーブルにします。プライオリティ キューのサイズは、high プライオリティ キューには 20、medium プライオリティ キューには 40、normal プライオリティ キューには 60、low プライオリティ キューには 80 という最大パケット数に設定されます。

Router(config)# interface Serial0
Router(config-if)# encapsulation frame-relay
Router(config-if)# frame-relay interface-queue priority 20 40 60 80
 

次のコマンドは、DLCI を設定済みマップ クラスに割り当てることで、4 つの PVC にプライオリティを割り当てます。

Router(config-if)# frame-relay interface-dlci 100
Router(config-fr-dlci)# class HI
Router(config-fr-dlci)# exit
Router(config-if)# frame-relay interface-dlci 200
Router(config-fr-dlci)# class MED
Router(config-fr-dlci)# exit
Router(config-if)# frame-relay interface-dlci 300
Router(config-fr-dlci)# class NORM
Router(config-fr-dlci)# exit
Router(config-if)# frame-relay interface-dlci 400
Router(config-fr-dlci)# class LOW
Router(config-fr-dlci)# exit

LLQ の設定例

ここでは、LLQ の設定例を示します。

「ATM PVC の設定:例」

「仮想テンプレートの設定:例」

「マルチリンク バンドルの設定:例」

LLQ の設定方法については、この章の低遅延キューイングの設定作業リストを参照してください。

ATM PVC の設定:例

次の例では、保証帯域幅が 50 kbps の完全プライオリティ キューが、ソース アドレス 10.10.10.10 から宛先アドレス 10.10.10.20 に送信される(ポートは 16384 ~ 20000 および 53000 ~ 56000 の範囲)トラフィックに予約されています。

まず、次のコマンドでアクセス リスト 102 を設定して必要な音声トラフィックを一致させます。

Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 20000
Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 56000
 

次に、クラス マップ音声を定義し、policy1 というポリシー マップを作成します。続いて、クラス音声の完全プライオリティ キューを予約し、クラス バーに帯域幅 20 kbps を設定し、WFQ のデフォルト クラスを設定します。次に service-policy コマンドを使用して、サブインターフェイス atm1/0.2 の PVC インターフェイス 0/102 にポリシー マップを割り当てます。

Router(config)# class-map voice
Router(config-cmap)# match access-group 102
 
Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50
Router(config-pmap)# class bar
Router(config-pmap-c)# bandwidth 20
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue
 
Router(config)# interface atm1/0.2
Router(config-subif)# pvc 0/102
Router(config-subif-vc)# service-policy output policy1

仮想テンプレートの設定:例

次に、CBWFQ による仮想テンプレート設定で完全プライオリティ キューを設定する例を示します。アクセス リスト 102 と一致する仮想テンプレート 1 のトラフィックは、完全プライオリティ キューに送信されます。

まず、クラス マップ voice が定義され、policy1 というポリシー マップが作成されます。(50 kbps という使用可能な保証帯域幅がある)完全プライオリティ キューは、voice というクラスのために予約されています。

Router(config)# class-map voice
Router(config-cmap)# match access-group 102
Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50
 

次に、 service-policy コマンドは、policy1 というポリシー マップを仮想テンプレート 1 に適用します。

Router(config)# multilink virtual-template 1
Router(config)# interface virtual-template 1
Router(config-if)# ip address 172.16.1.1 255.255.255.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# service-policy output policy1
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave
Router(config-if)# end
 
Router(config)# interface serial 2/0
Router(config-if)# bandwidth 256
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# no fair-queue
Router(config-if)# clockrate 256000
Router(config-if)# ppp multilink

マルチリンク バンドルの設定:例

次に、CBWFQ によるマルチリンク バンドル設定で完全プライオリティ キューを設定する例を示します。アクセス リスト 102 と一致するシリアル インターフェイス 2/0 のトラフィックは、完全プライオリティ キューに送信されます。マルチリンク バンドルを使用する利点は、異なるインターフェイスで異なる priority パラメータを指定できることです。異なる priority パラメータを指定するには、異なるパラメータを使用して 2 つのマルチリンク バンドルを設定します。

まず、クラス マップ voice が定義され、policy1 というポリシー マップが作成されます。(50 kbps という使用可能な保証帯域幅がある)完全プライオリティ キューは、voice というクラスのために予約されています。

Router(config)# class-map voice
Router(config-cmap)# match access-group 102
Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50
 

次のコマンドで、マルチリンク バンドル 1 を作成します。policy1 というポリシー マップは、 service-policy コマンドによってバンドルに適用されます。

Router(config)# interface multilink 1
Router(config-if)# ip address 172.17.254.161 255.255.255.248
Router(config-if)# no ip directed-broadcast
Router(config-if)# no ip mroute-cache
Router(config-if)# service-policy output policy1
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave
 

例の次の部分では、 multilink-group コマンドでシリアル インターフェイス 2/0 がマルチリンク バンドル 1 の一部になるように設定します。その結果、アクセス リスト 102 に一致するシリアル インターフェイス 2/0 上のトラフィックが、完全プライオリティ キューに効率的に送信されます。

Router(config)# interface serial 2/0
Router(config-if)# bandwidth 256
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# no fair-queue
Router(config-if)# clockrate 256000
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 1

分散型 LLQ の設定例

ここでは、分散型 LLQ の設定例を示します。

「ATM サブインターフェイスの使用可能な帯域幅の量に関する PQ のイネーブル化:例」

「ATM サブインターフェイスで使用可能な帯域幅に占める割合に関する PQ のイネーブル化:例」

「ATM インターフェイスの送信リング制限の設定:例」

「ATM PVC サブインターフェイスの送信リング制限の設定:例」

分散型 LLQ の設定方法については、この章の「分散型 LLQ の設定作業リスト」を参照してください。

ATM サブインターフェイスの使用可能な帯域幅の量に関する PQ のイネーブル化:例

priority コマンドを ATM サブインターフェイスでイネーブルにできます。また、そのサブインターフェイスでは 1 つの ATM PVC のみをイネーブルにする必要があります。この設定によって、十分な量の ATM PVC がサポートされます。

次の例では、使用可能な保証帯域幅が 50 kbps のプライオリティ キューが、ソース アドレス 10.10.10.10 から宛先アドレス 10.10.10.20 に送信される(ポートは 16384 ~ 20000 および 53000 ~ 56000 の範囲)トラフィックに予約されています。

まず、次のコマンドでアクセス リスト 102 を設定して必要な音声トラフィックを一致させます。

Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 20000
Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 56000
 

次に、voice というトラフィック クラスを定義し、policy1 というポリシー マップを作成します。クラス voice のプライオリティ キューには、50 kbps の使用可能な保証帯域幅と 60 バイトの使用可能なバースト サイズが予約されます。20 kbps の帯域幅が bar というクラスに設定されます。また、フローベースの均等化キューイングにデフォルト クラスが設定されます。次に service-policy コマンドを使用して、サブインターフェイス atm1/0 の PVC インターフェイス 0/102 にポリシー マップを割り当てます。

Router(config)# class-map voice
Router(config-cmap)# match access-group 102
 
Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50 60
Router(config-pmap)# class bar
Router(config-pmap-c)# bandwidth 20
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue
 
Router(config)# interface atm1/0
Router(config-subif)# pvc 0/102
 
Router(config-subif)# service-policy output policy1

ATM サブインターフェイスで使用可能な帯域幅に占める割合に関する PQ のイネーブル化:例

priority percent コマンドを ATM サブインターフェイスでイネーブルにできます。また、そのサブインターフェイスでは 1 つの ATM PVC のみをイネーブルにする必要があります。この設定によって、十分な量の ATM PVC がサポートされます。

次の例では、使用可能な保証帯域幅が 15% の割合のプライオリティ キューが、ソース アドレス 10.10.10.10 から宛先アドレス 10.10.10.20 に送信される(ポートは 16384 ~ 20000 および 53000 ~ 56000 の範囲)トラフィックに予約されています。

まず、次のコマンドでアクセス リスト 102 を設定して必要な音声トラフィックを一致させます。

Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 20000
Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 56000
 

次に、voice というトラフィック クラスを定義し、policy1 というポリシー マップを作成します。クラス voice のプライオリティ キューには、15% の割合の使用可能な保証帯域幅が予約されます。20% の割合の帯域幅が bar というクラスに設定されます。また、フローベースの均等化キューイングにデフォルト クラスが設定されます。次に、 service-policy コマンドを使用して、ATM サブインターフェイス 1/0.2 にポリシー マップを適用します。

Router(config)# class-map voice
Router(config-cmap)# match access-group 102
 
Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority percent 15
Router(config-pmap)# class bar
Router(config-pmap-c)# bandwidth percent 20
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue
 
Router(config)# interface atm1/0.2
Router(config-subif)# service-policy output policy1

ATM インターフェイスの送信リング制限の設定:例

次に、ATM インターフェイスの送信リングのパーティクル数を 7 パーティクルに制限する例を示します。

Router(config)# interface atm 1/0/0
Router(config-if)# atm pvc 32 0 32 tx-ring-limit 7

ATM PVC サブインターフェイスの送信リング制限の設定:例

次に、ATM PVC サブインターフェイスの送信リングのパーティクル数を 10 パーティクルに制限する例を示します。

Router(config)# interface ATM1/0/0.1 point-to-point
Router(config-subif)# pvc 2/200
Router(config-if-atm-vc)# tx-ring-limit 10
 

tx-ring-limit コマンドは、単一インターフェイス上の複数の ATM PVC サブインターフェイスに適用できます。個々の PVC で、送信リング制限を設定できます。

フレームリレー向け LLQ の設定例

ここでは、フレームリレー向け LLQ の設定例を示します。

フレームリレー向け LLQ の設定方法については、この章の「フレームリレー向け低遅延キューイングの設定作業リスト」を参照してください。

次に、フラグメンテーションを使用して 64K CIR に合わせて PVC を設定する例を示します。このシェーピング キューは、voice には 1 つのクラス、IP precedence トラフィックには 2 つのデータ クラス、ベストエフォート トラフィックにはデフォルト クラスを使用して設定されます。WRED は、データ クラスのいずれかでドロップ ポリシーとして使用されます。

以下のコマンドでは、クラス マップとそのクラス マップの一致基準を定義します。

!
class-map voice
match access-group 101
!
class-map immediate-data
match access-group 102
!
class-map priority-data
match access-group 103
 
!
access-list 101 permit udp any any range 16384 32767
access-list 102 permit ip any any precedence immediate
access-list 103 permit ip any any precedence priority
 

以下のコマンドでは、mypolicy というポリシー マップを作成および定義します。

!
policy-map mypolicy
class voice
priority 16
class immediate-data
bandwidth 32
random-detect
class priority-data
bandwidth 16
class class-default
fair-queue 64
queue-limit 20
 

以下のコマンドでは、フレームリレー フラグメンテーションをイネーブルにし、ポリシー マップを DLCI 100 に適用します。

!
interface Serial1/0.1 point-to-point
frame-relay interface-dlci 100
class fragment
!
map-class frame-relay fragment
frame-relay cir 64000
frame-relay mincir 64000
frame-relay bc 640
frame-relay fragment 50
service-policy output mypolicy

LLQ のバースト サイズの設定例

LLQ のバースト サイズを設定する方法については、この章のLLQ 設定作業リストのバースト サイズの設定を参照してください。

次に、Voice というクラスのバースト パラメータを 1250 バイトに設定する例を示します。このクラスには 1000 kbps の割り当て帯域幅があります。

policy policy1
class Voice
priority 1000 1250

ATM アダプタの VC 単位ホールド キューのサポート:例

ATM アダプタの VC 単位ホールド キューのサポートを設定する方法については、この章の「ATM アダプタの VC 単位ホールド キューのサポートの設定作業リスト」を参照してください。

次に、VC 単位ホールド キューを 55 に設定する例を示します。

interface atm2/0.1
pvc 1/101
vc-hold-queue 55