Quality of Service ソリューション ガイド、 Cisco IOS Release 15.1S
フレームリレー用 RSVP サポートの設定
フレームリレー用 RSVP サポートの設定
発行日;2012/02/01 | 英語版ドキュメント(2011/05/06 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

フレームリレー用 RSVP サポートの設定

フレームリレー用 RSVP サポートの設定作業リスト

インターフェイスでのフレームリレー カプセル化のイネーブル化

仮想回線の設定

インターフェイスでのフレームリレー トラフィック シェーピングのイネーブル化

拡張ローカル管理インターフェイスのイネーブル化

インターフェイス上での RSVP のイネーブル化

インターフェイスに対するトラフィック シェーピング マップ クラスの指定

WFQ およびトラフィック シェーピング パラメータによるマップ クラスの定義

CIR の指定

最小 CIR の指定

WFQ のイネーブル化

FRF.12 のイネーブル化

パスの設定

予約の設定

フレームリレー用 RSVP サポートの確認

マルチポイント設定

ポイントツーポイント設定

フレームリレー用 RSVP サポートのモニタリングと保守

フレームリレー用 RSVP サポートの設定例

マルチポイントの設定例

ポイントツーポイント設定例

フレームリレー用 RSVP サポートの設定

ここでは、フレームリレー用 RSVP サポート機能の設定作業について説明します。

詳細な概念情報については、『 Signalling Overview 』モジュールを参照してください。

この章のフレームリレー用 RSVP サポート コマンドの詳細については、『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。この章に記載されている他のコマンドのドキュメントについては、コマンド リファレンス マスター インデックスを使用するか、オンライン検索してください。

プラットフォームのサポートと Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

フレームリレー用 RSVP サポートの設定作業リスト

フレームリレー用に Resource Reservation Protocol(RSVP; リソース予約)サポートを設定するには、以下の項で説明する作業を実行します。各作業には、任意または必須と指定しています。

インターフェイスでのフレームリレー カプセル化のイネーブル化(必須)

仮想回線の設定(必須)

インターフェイスでのフレームリレー トラフィック シェーピングのイネーブル化(必須)

拡張ローカル管理インターフェイスのイネーブル化(任意)

インターフェイス上での RSVP のイネーブル化(必須)

インターフェイスに対するトラフィック シェーピング マップ クラスの指定(必須)

WFQ およびトラフィック シェーピング パラメータによるマップ クラスの定義(必須)

CIR の指定(必須)

最小 CIR の指定(任意)

WFQ のイネーブル化(必須)

FRF.12 のイネーブル化(必須)

パスの設定(任意)

予約の設定(任意)

フレームリレー用 RSVP サポートの確認(任意)

フレームリレー用 RSVP サポートのモニタリングと保守(任意)

フレームリレー用 RSVP サポートの設定例については、この章の末尾を参照してください。

インターフェイスでのフレームリレー カプセル化のイネーブル化

インターフェイスでフレームリレー カプセル化をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# interface s3/0

インターフェイス(たとえば、シリアル インターフェイス 3/0)をイネーブルにし、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# encapsulation frame-relay [ cisco | ietf ]

フレームリレーをイネーブルにし、カプセル化方式を指定します。

仮想回線の設定

Virtual Circuit(VC; 仮想回線)を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# frame-relay interface-dlci dlci

Data-Link Connection Identifier(DLCI; データリンク接続識別子)をルータまたはアクセス サーバ上の指定したフレームリレー サブインターフェイスに割り当てます。

インターフェイスでのフレームリレー トラフィック シェーピングのイネーブル化

インターフェイスで Frame Relay Traffic Shaping(FRTS; フレームリレー トラフィック シェーピング)をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# frame-relay traffic-shaping

フレームリレー インターフェイスのすべての Permanent Virtual Circuit(PVC; 相手先固定接続)と Switched Virtual Circuit(SVC; 相手先選択接続)について、トラフィック シェーピングと VC 単位のキューイングをイネーブルにします。

拡張ローカル管理インターフェイスのイネーブル化

拡張 Local Management Interface(LMI; 拡張ローカル管理インターフェイス)をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# frame-relay lmi-type

LMI タイプを選択します。

インターフェイス上での RSVP のイネーブル化

インターフェイス上で RSVP をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip rsvp bandwidth

インターフェイス上で RSVP をイネーブルにします。

インターフェイスに対するトラフィック シェーピング マップ クラスの指定

インターフェイスに対してトラフィック シェーピング マップ クラスを指定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# frame-relay class name

マップ クラスをインターフェイスまたはサブインターフェイスに関連付けます。

WFQ およびトラフィック シェーピング パラメータによるマップ クラスの定義

Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)およびトラフィック シェーピング パラメータを使用してマップ クラスを定義するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# map-class frame-relay map-class-name

指定したクラスのパラメータを定義します。

CIR の指定

Committed Information Rate(CIR; 認定情報レート)を指定するには、マップ クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-map-class)# frame-relay cir { in | out } bps

フレームリレー VC の最大着信および最大発信 CIR を指定します。

最小 CIR の指定

フレームリレー VC に最小許容着信または最小許容発信 CIR(minCIR)を指定するには、マップ クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-map-class)# frame-relay mincir { in | out } bps

フレームリレー VC の最小許容着信および最小許容発信 CIR を指定します。

(注) minCIR を設定しない場合、アドミッション コントロール値は CIR/2 です。

 

WFQ のイネーブル化

WQF をイネーブルにするには、マップ クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-map-class)# frame-relay fair-queue

PVC で WFQ をイネーブルにします。

FRF.12 のイネーブル化

FRF.12 をイネーブルにするには、マップ クラス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-map-class)# frame-relay fragment fragment-size

PVC でフレームリレー フラグメンテーションをイネーブルにします。

パスの設定

ジョブを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# ip rsvp sender

RSVP パス パラメータを指定します。宛先と送信元のアドレス、プロトコル、宛先と送信元のポート、前ホップのアドレス、平均ビット レート、バースト サイズなどです。

予約の設定

予約を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# ip rsvp reservation

RSVP 予約パラメータを指定します。宛先と送信元のアドレス、プロトコル、宛先と送信元のポート、次ホップのアドレス、次ホップのインターフェイス、予約形式、サービス タイプ、平均ビット レート、バースト サイズなどです。

フレームリレー用 RSVP サポートの確認

ここでは、マルチポイント設定またはポイントツーポイント設定で、フレームリレー用の RSVP のサポートを確認する手順について説明します。

マルチポイント設定

マルチポイント設定でフレームリレー用 RSVP サポートを確認するには、次の手順を実行します。


ステップ 1 インターフェイスと許可済み予約に関する情報を表示するには、 show ip rsvp installed コマンドを入力します。次の出力例は、シリアル サブインターフェイス 3/0.1 に 2 つの予約があることを示しています。

Router# show ip rsvp installed
 
RSVP:Serial3/0
BPS To From Protoc DPort Sport Weight Conversation
RSVP:Serial3/0.1
BPS To From Protoc DPort Sport Weight Conversation
40K 145.20.22.212 145.10.10.211 UDP 10 10 0 24
50K 145.20.21.212 145.10.10.211 UDP 10 10 6 25

) 音声のようなフローには重み付け 0 が割り当てられ、プライオリティ キューに進みます。


ステップ 2 インターフェイス、サブインターフェイス、DLCI PVC、および現在の予約に関する追加情報を表示するには、 show ip rsvp installed detail コマンドを入力します。


) 次の出力では、最初のフローは重み付けが 0 より上の予約済みキューを取得し、2 番めのフレームは重み付けが 0 のプライオリティ キューを取得します。


Router# show ip rsvp installed detail
 
RSVP:Serial3/0 has the following installed reservations
RSVP:Serial3/0.1 has the following installed reservations
RSVP Reservation. Destination is 145.20.21.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 10, Source port is 10
Reserved bandwidth:50K bits/sec, Maximum burst:1K bytes, Peak rate:50K bits/sec
QoS provider for this flow:
WFQ on FR PVC dlci 101 on Se3/0: RESERVED queue 25. Weight:6
Data given reserved service:0 packets (0M bytes)
Data given best-effort service:0 packets (0 bytes)
Reserved traffic classified for 68 seconds
Long-term average bitrate (bits/sec):0M reserved, 0M best-effort
RSVP Reservation. Destination is 145.20.22.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 10, Source port is 10
Reserved bandwidth:40K bits/sec, Maximum burst:1K bytes, Peak rate:40K bits/sec
QoS provider for this flow:
WFQ on FR PVC dlci 101 on Se3/0: PRIORITY queue 24. Weight:0
Data given reserved service:0 packets (0M bytes)
Data given best-effort service:0 packets (0 bytes)
Reserved traffic classified for 707 seconds
Long-term average bitrate (bits/sec):0M reserved, 0M best-effort


 

ポイントツーポイント設定

ポイントツーポイント設定でフレームリレー用 RSVP サポートを確認するには、次の手順を実行します。


ステップ 1 インターフェイスと許可済み予約に関する情報を表示するには、 show ip rsvp installed コマンドを入力します。次の出力例では、シリアル サブインターフェイス 3/0.1 に 1 つの予約、シリアル サブインターフェイス 3/0.2 に 1 つの予約があります。

Router# show ip rsvp installed
 
RSVP:Serial3/0
BPS To From Protoc DPort Sport
RSVP:Serial3/0.1
BPS To From Protoc DPort Sport
50K 145.20.20.212 145.10.10.211 UDP 10 10
 
RSVP:Serial3/0.2
BPS To From Protoc DPort Sport
10K 145.20.21.212 145.10.10.211 UDP 11 11

) 音声のようなフローには重み付け 0 が割り当てられ、プライオリティ キューに進みます。


ステップ 2 インターフェイス、サブインターフェイス、DLCI PVC、および現在の予約に関する追加情報を表示するには、 show ip rsvp installed detail コマンドを入力します。


) 次の出力では、重み付けが 0 より上の第 1 フローは予約済みキューを取得し、重み付けが 0 の第 2 フローはプライオリティ キューを取得します。


Router# show ip rsvp installed detail
 
RSVP:Serial3/0 has the following installed reservations
RSVP:Serial3/0.1 has the following installed reservations
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 10, Source port is 10
Reserved bandwidth:50K bits/sec, Maximum burst:1K bytes, Peak rate:50K bits/sec
QoS provider for this flow:
WFQ on FR PVC dlci 101 on Se3/0: RESERVED queue 25. Weight:6
Data given reserved service:415 packets (509620 bytes)
Data given best-effort service:0 packets (0 bytes)
Reserved traffic classified for 862 seconds
Long-term average bitrate (bits/sec):4724 reserved, 0M best-effort
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 11, Source port is 11
Reserved bandwidth:10K bits/sec, Maximum burst:1K bytes, Peak rate:10K bits/sec
QoS provider for this flow:
WFQ on FR PVC dlci 101 on Se3/0: PRIORITY queue 24. Weight:0
Data given reserved service:85 packets (104380 bytes)
Data given best-effort service:0 packets (0 bytes)
Reserved traffic classified for 875 seconds
Long-term average bitrate (bits/sec):954 reserved, 0M best-effort
RSVP:Serial3/0.2 has the following installedreservations
 
RSVP Reservation. Destination is 145.20.21.212, Source is 145.10.10.211,
 
Protocol is UDP, Destination port is 11, Source port is 11
Reserved bandwidth:10K bits/sec, Maximum burst:1K bytes, Peak rate:10Kbits/sec
QoS provider for this flow:
WFQ on FR PVC dlci 101 on Se3/0:PRIORITY queue 24. Weight:0
Data given reserved service:85 packets (104380 bytes)
Data given best-effort service:0 packets (0 bytes)
Reserved traffic classified for 875 seconds
Long-term average bitrate (bits/sec):954 reserved, 0M best-effort


 

フレームリレー用 RSVP サポートのモニタリングと保守

フレームリレー用 RSVP サポートをモニタおよび保守するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show ip rsvp installed

インターフェイスとその許可された予約に関する情報を表示します。

Router# show ip rsvp installed detail

インターフェイス、DLCI、およびその許可された予約に関する追加情報を表示します。

Router# show queueing

すべてまたは選択した設定済みキューイング戦略を表示します。

フレームリレー用 RSVP サポートの設定例

ここでは、フレームリレー用 RSVP サポートの設定例を示します。

マルチポイントの設定例

ポイントツーポイント設定例

フレームリレー用 RSVP サポート機能の設定方法については、この章の「フレームリレー用 RSVP サポートの設定作業リスト」を参照してください。

マルチポイントの設定例

図 1 に、複数の PVC がルータ R1 の同じサブインターフェイスに設定されるフレームリレー環境で、一般的に使用されるマルチポイント インターフェイス設定を示します。

図 1 マルチポイント インターフェイス設定

RSVP は DLCI 101 および DLCI 201 の minCIR に基づいてアドミッション コントロールを実行します。輻輳ポイントは 10.1.1.1/16 サブインターフェイスではなく、DLCI 101 および DLCI 201 の CIR です。

次に、シリアル インターフェイス 3/0 の出力例を示します。

interface Serial3/0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type cisco
ip rsvp bandwidth 350 350
!
interface Serial3/0.1 multipoint
ip address 10.1.1.1 255.255.0.0
frame-relay interface-dlci 101
class fr-voip
frame-relay interface-dlci 201
class fast-vcs
ip rsvp bandwidth 350 350
 
ip rsvp pq-profile 6000 2000 ignore-peak-value
!
!
map-class frame-relay fr-voip
frame-relay cir 800000
frame-relay bc 8000
frame-relay mincir 128000
frame-relay fragment 280
no frame-relay adaptive-shaping
frame-relay fair-queue
!
map-class frame-relay fast-vcs
frame-relay cir 200000
frame-relay bc 2000
frame-relay mincir 60000
frame-relay fragment 280
no frame-relay adaptive-shaping
frame-relay fair-queue
!

) FRTS をイネーブルにする場合、フレームリレーの認定バースト(Bc)値(ビット単位)を最大 1/100th の CIR 値(ビット/秒単位)に設定する必要があります。この設定によって、FRTS トークン バケット間隔(Bc/CIR)は 10 Ms を超えず、音声パケットはすぐにサービスされます。


ポイントツーポイント設定例

図 2 に、1 つのサブインターフェイスにつき 1 つの PVC がルータ R1 で設定されているフレームリレー環境で、一般的に使用されるポイントツーポイント インターフェイス設定を示します。

図 2 ポイントツーポイント インターフェイス設定例

R1 のルータ インターフェイス帯域幅は T1(1.544 Mbps)で、DLCI 201 から R3 に対する CIR 値は 256 kbps です。DLCI 201 上で R1 から R3 へのトラフィック フローの場合、輻輳ポイントは DLCI 201 の CIR です。結果として、RSVP は minCIR に基づいてアドミッション コントロールを実行し、各 DLCI で実行される WFQ システムのキューや帯域幅などのリソースを予約します。

次に、シリアル インターフェイス 3/0 の出力例を示します。

interface Serial3/0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type cisco
ip rsvp bandwidth 500 500
!
interface Serial3/0.1 point-to-point
ip address 10.1.1.1 255.255.0.0
frame-relay interface-dlci 101
class fr-voip
ip rsvp bandwidth 350 350
!
interface Serial3/0.2 point-to-point
ip address 10.3.1.1 255.255.0.0
frame-relay interface-dlci 201
class fast-vcs
ip rsvp bandwidth 150 150
 
ip rsvp pq-profile 6000 2000 ignore-peak-value
!
!
map-class frame-relay fr-voip
frame-relay cir 800000
frame-relay bc 8000
frame-relay mincir 128000
frame-relay fragment 280
no frame-relay adaptive-shaping
frame-relay fair-queue

) FRTS をイネーブルにする場合、フレームリレーの認定バースト(Bc)値(ビット単位)を最大 1/100th の CIR 値(ビット/秒単位)に設定する必要があります。この設定によって、FRTS トークン バケット間隔(Bc/CIR)は 10 Ms を超えず、音声パケットはすぐにサービスされます。