Quality of Service ソリューション ガイド、 Cisco IOS Release 15.1S
RSVP の設定
RSVP の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/05/06 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

RSVP の設定

機能情報の確認

目次

RSVP の設定に関する前提条件

RSVP の設定に関する制約事項

RSVP の設定について

RSVP の予約タイプ

個別予約

共有予約

RSVP 設定の計画

RSVP 実装に関する考慮事項

フレームリレー インターネットワークに関する考慮事項

ATM インターネットワークに関する考慮事項

可変帯域幅に関する考慮事項

RSVP 入力 CAC

中間 RSVP アウェア ノードのアドミッション制御

IP トンネル インターフェイス上のアドミッション制御

RSVP プリエンプション

RSVP over DMVPN

RSVP でのトランスポート メカニズムのサポート

RSVP の設定方法

RSVP のイネーブル化

RSVP 帯域幅の設定

シングルまたはグループ フローの最大帯域幅の設定

RSVP データベースへの送信者または受信者の入力

トランスポート プロトコルとしての RSVP の設定

マルチキャストの宛先の指定

RSVP ネイバー予約の制御

RSVP の NetFlow への適用

IP precedence および ToS 値

トンネル帯域幅オーバーヘッドの設定

トラブルシューティングのヒント

RSVP 通知の送信

RSVP 設定の確認

RSVP の設定例

例:マルチキャスト セッション用の RSVP の設定

例:RSVP 帯域幅の設定

例:トンネル帯域幅オーバーヘッドの設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

RSVP の設定に関する機能情報

RSVP の設定

この章では、Resource Reservation Protocol(RSVP; リソース予約プロトコル)機能の設定作業について説明します。この機能は、ルータ ネットワークの両側に設置されたエンド システムまたはホストで、それらの間の予約済み帯域幅パスを設定し、データ伝送の Quality of Service(QoS)を保証可能にする IP サービスです。

機能情報の確認

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「RSVP の設定に関する機能情報」を参照してください。

プラットフォーム サポートとシスコ ソフトウェア イメージ サポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

RSVP の設定に関する前提条件

RSVP は、デフォルトで、RSVP を実装していないシステムとの下位互換性を維持するためにディセーブルになっています。RSVP がイネーブルになっていなければ、他のどの RSVP 設定も実行できません。

RSVP の設定に関する制約事項

RSVP は、Versatile Interface Processor(VIP)-distributed Cisco Express Forwarding(dCEF; 分散型シスコ エクスプレス フォワーディング)と一緒に設定することができません。

RSVP over DMVPN 機能は、Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)を使用しない RSVP over IPsec トンネルをサポートしません。

入力 Call Admission Control(CAC; コール アドミッション制御)機能は、RSVP 高速ローカル修復をサポートしません。非 RSVP クラウド内でルート変更が実施されると、入力インターフェイスでも対応する変更が実施されます。

RSVP の設定について

RSVP によってエンド システムは、ネットワークからの QoS の保証を要求できます。ネットワーク リソース予約の必要性は、次のようにデータ トラフィックとリアルタイム トラフィックの場合で異なります。

データ トラフィックの場合、インターネットワークがデータ トラフィックにデータグラム サービスを提供するため、予約済みの帯域幅が必要です。この非同期パケット スイッチングは、サービス品質の保証が不要な場合があります。データ トラフィックの送信者と受信者の間にエンドツーエンド コントロールがあると、適切な情報の送信量を確保できます。

データグラム サービスで動作時に、リアルタイム トラフィック(つまり音声またはビデオ情報)には問題が発生します。リアルタイム トラフィックからはほぼ一定の情報フローが送信されるため、ネットワークの「パイプ」も一定である必要があります。リアルタイム ホスト間のサービスが変化しないという何らかの保証を提供する必要があります。First-in, First-out(FIFO; 先入れ先出し)ベースで動作するルータには、送信されたリアルタイム情報が中断され、回復できないリスクがあります。

リソース保証の必要性がほとんどないデータ アプリケーションは、リアルタイム トラフィックよりも比較的低い帯域幅を頻繁に要求します。ほぼ一定のビットレート要件のテレビ会議アプリケーションと、バースト型の低ビットレート要件のインタラクティブ データ アプリケーションは、使用できるネットワーク リソースを共有します。

RSVP は、大規模なファイル転送の要件によって、バースティ データ トラフィックに必要な帯域幅リソースが消費されないように防ぎます。RSVP を使用する場合、スタティックな Time-Division Multiplexer(TDM)が単一のチャネルを共有する複数のソースをソートして優先順位を付けるときと同様に、ルータはパケットをソートして優先順位を付けます。

RSVP メカニズムによって、リアルタイム トラフィックは、一定の遅延のために必要なリソースを予約できるようになります。テレビ会議アプリケーションは、ルータの設定を使用して、必要な帯域幅があるパスに対して要求を伝播し、テレビ会議の宛先について遅延します。RSVP は通常の間隔で予約を確認し、繰り返します。RSVP はこのプロセスによって RSVP エンド システム間のパスを調整および変更し、ルートの変更から回復できます。

(データ トラフィックとは異なり)リアルタイム トラフィックにはネットワークの一貫性が保証されている必要があります。一貫した QoS がなければ、リアルタイム トラフィックには次の問題が発生します。

ジッタ:送信信号に短い時間または位相のずれが生じると、同期外れなどのエラーの原因になります。

帯域幅不足:音声コールはデジタル信号レベル 0(64 kb/s の DS-0)を使用し、ビデオ会議は T1/E1(1.544 Mb/s または 2.048 Mb/s)を使用し、より忠実度の高いビデオはさらに高い帯域幅を使用します。

遅延変動:信号要素の送信時刻と到着時刻の差に変動がある場合は、リアルタイム トラフィックが同期されなくなり、送信が失敗することがあります。

情報損失:信号要素がドロップしたり、かなり遅れて到着したりした場合は、音声の損失によって、ノイズを伴う歪みやパチパチ音が発生します。また、ビデオの損失によって、画像のにじみ、ディストーション、またはブラックアウトが発生します。

RSVP は、Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)または Random Early Detection(RED; ランダム早期検出)と連動します。この予約設定とパケット キューイングの連携では、RSVP を使用したエンドツーエンド フローと、WFQ を使用したルータ間通信という 2 つの主要な概念を使用します。

RSVP フロー:データが一方向(送信元から宛先へ)にしか送信されない「複数宛先単方向通信」を実行するストリームです。フローは、複数の送信者から複数の宛先に送信されます。フローはマージすることもマージしないこともできます。また、マージ方式は、フローを使用するアプリケーションのアトリビュートによって変わります。

WFQ カンバセーション:特定のインターフェイスを通過する単一のトランスポート層セッションまたはネットワーク層フローのトラフィックです。この通信は、関連する通信レイヤの送信者および宛先のアドレス、プロトコル タイプ、ポート番号、または他のアトリビュートから識別されます。

RSVP を使用すると、ホストからホストの一部にパケットを送信(マルチキャスト)できます。RSVP では、リソース予約は主にマルチキャスト アプリケーション(テレビ会議など)に適用されていると仮定します。RSVP の主な対象はマルチメディア トラフィックですが、ユニキャスト トラフィック(Network File System(NFS; ネットワーク ファイル システム)やバーチャル プライベート ネットワーク管理など)の帯域幅予約にも影響します。ユニキャスト送信の場合、単一のホストから単一のホストにパケットが送信されます。

RSVP を設定する前に、次の概念を理解しておく必要があります。

「RSVP の予約タイプ」

「RSVP 設定の計画」

「RSVP 実装に関する考慮事項」

「RSVP 入力 CAC」

「RSVP over DMVPN」

「RSVP でのトランスポート メカニズムのサポート」

RSVP の予約タイプ

マルチキャスト フローには次の 2 つのタイプがあります。

個別予約:1 人の送信者のみから送信されたフロー

共有予約:1 人以上の送信者から送信されたフロー

RSVP では、これらの予約に特定のアルゴリズム アトリビュートを持たせています。

個別予約

個別予約の一例として、キューの許可と管理が必要な個別のデータ ストリームを各送信者が発信するビデオ アプリケーションがあります。このようなフローの場合、通過する各送信設備(イーサネット、High-Level Data Link Control(HDLC; ハイレベル データリンク コントロール)、フレームリレー Data-Link Connection Identifier(DLCI; データリンク接続識別子)、ATM 仮想チャネルなど)の送信者ごとに、個別の予約が必要になります。RSVP は、この個別予約を明示的と見なし、それを固定フィルタ形式の予約を使用して成立させます。

ユニキャスト アプリケーションに RSVP を使用すると、一般的に、個別フローのケースは悪化します。

共有予約

共有予約の例として、キュー内の許可と管理が必要なデータ ストリームを送信者が個別に出力する音声アプリケーションが挙げられます。ただし、アプリケーションの性質から、制限された数の送信者が任意の時間にデータを送信します。そのため、このようなフローは送信者ごとに個別予約は不要です。代わりに、必要に応じて、任意の複数の送信者に単一の予約を適用できます。

RSVP は Wild Card または Shared Explicit 形式の予約を使用して共有予約をインストールします。これらの形式の違いは、アプリケーションの範囲(ワイルドまたは明示)によって決まります。

Wild Card Filter は、すべての送信者の帯域幅と遅延特性を予約しますが、予約メッセージで伝送される送信元アドレスのリストによって制限されます。

Shared Explicit 形式の予約は、特定のネットワーク リソースのフローを識別します。

RSVP 設定の計画

ネットワーク上で RSVP を適切に設定して使用するには、慎重に計画する必要があります。最低でも、RSVP はルータ インターフェイスで帯域幅のニーズの評価を反映する必要があります。RSVP 設定について計画する場合、次の問題を考慮してください。

エンドユーザ アプリケーション フローごとに RSVP で許可すべき帯域幅はどれくらいですか。使用してインストールアプリケーションの「フィードとスピード」を理解する必要があります。デフォルトで、単一のフローで予約可能なサイズの合計は、予約可能な全体の帯域幅になります。ただし、単一フローの帯域幅パラメータを使用して、個々の予約を少ないサイズに制限できます。予約する帯域幅値は、インターフェイスで予約可能なサイズを超過できないため、指定したサイズよりも大きいフローは予約できません。

RSVP に使用できる帯域幅のサイズはどのくらいですか。デフォルトで、インターフェイスで使用できる帯域幅の 75% は予約可能です。トンネル インターフェイスを使用している場合、トンネルの帯域幅がトンネル内の予約される帯域幅の合計であれば、そのトンネルを RSVP で予約できます。

少量のデータ通信に必要な、タイムリーなサービスを適切に提供するために、RSVP から除外する必要がある帯域幅はどのくらいですか。データ トラフィック用のエンドツーエンド コントロールでは、すべてのセッションが輻輳をダイナミックに回避できるように動作すると仮定しています。リアルタイムの要件は、この動作に従いません。RSVP の QoS 設定の副作用として、バースティ データ トラフィックに帯域幅が割り当てられる処理とは別に、確保する帯域幅を決定します。


) RSVP コンフィギュレーション コマンドを入力する前に、慎重に計画する必要があります。


RSVP 実装に関する考慮事項

予約システムの設計時には、RSVP の実装に関する考慮事項を意識する必要があります。RSVP は、すべてのデータ リンクをインターネットワークに提示するモデルではありません。RSVP は、インターフェイス上でのトラフィックの混合を見逃さないキューイング システムを備えるようにインターフェイスをモデル化します。帯域幅または遅延特性が、このモデルに設定された範囲内に限定されます。残念ながら、データ リンクはこの方法で不完全にモデリングされることがよくあります。次のガイドラインを使用してください。

シリアル回線インターフェイス:PPP、HDLC、Link Access Procedure, Balanced(LAPB; 平衡型リンク アクセス手順)、High-Speed Serial Interface(HSSI)、および同様のシリアル回線インターフェイスは、RSVP で適切にモデリングされます。そのため、デバイスはこれらのインターフェイスについて保証できます。Nonbroadcast Multiaccess(NBMA)インターフェイスは、最も予約を必要としています。

マルチアクセス LAN:これらのデータ リンクは、RSVP インターフェイスで適切にモデリングされません。LAN 自体に、保証するデバイスの制御下にないキューイング システムがあるためです。デバイスは提供する負荷については保証しますが、競合する負荷や、隣接する LAN システムが提供する負荷のタイミングは保証できません。ネットワーク管理者は、アドミッション コントロールを使用して、LAN で使用できるトラフィック量を制御できます。ただし、ネットワーク管理者は、RSVP を効率的に使用するために、ネットワーク設計での許可の使用を中心に取り組む必要があります。

Subnetwork Bandwidth Manager(SBM)プロトコルは、LAN 用に RSVP を強化したプロトコルです。各セグメントの 1 つのデバイスは、Designated SBM(DSBM)に選択されます。DSBM がセグメント上のすべての予約を処理することで、複数の RSVP デバイスが予約を受けて、共有 LAN 帯域幅の使用量が多くならないように回避します。また、DSBM は有効な RSVP 予約がなくても、ホストに対して許可されているトラフィック量を通知できます。

パブリック X.25 ネットワーク:レートまたは遅延の予約が、パブリック X.25 ネットワークで役立つかどうかは明確ではありません。

次の項で説明するように、フレームリレーと ATM ネットワークで特殊な設定を使用する必要があります。

フレームリレー インターネットワークに関する考慮事項

次の RSVP 実装に関する考慮事項は、フレームリレー インターネットワーク用に予約システムを設計する場合に適用されます。

予約はインターフェイスまたはサブインターフェイスに対して行われます。サブインターフェイスが複数の Data-Link Control(DLC; データリング制御)を備えている場合は、必要な帯域幅と予約された帯域幅が一致しない可能性があります。そのため、フレームリレー インターフェイスの RSVP サブインターフェイスが適切に動作するには、DLC を 1 つだけ含める必要があります。

さらに、フレームリレー DLC には Committed Information Rate(CIR)およびバースト コントロール(認定バーストおよび超過バースト)があります。これは設定で反映されない可能性があり、インターフェイス速度とはまったく異なる可能性があります(超過するまで追加されたり、極端に小さくなったりします)。そのため、インターフェイスとサブインターフェイスの両方で、 ip rsvp bandwidth コマンドを入力する必要があります。両方の帯域幅は許可基準として使用されます。

たとえば、フレームリレー インターフェイスが T1 レート(1.544 Mb/s)で動作し、128 kb/s と 56 kb/s の回線が設置されたリモート オフィスへの複数の DLC をサポートしているとします。インターフェイス全体の合計(75% は 1.158 Mb/s)と予約対象の受信インターフェイスの合計(75% はそれぞれ 96 kb/s と 42 kb/s)を設定する必要があります。許可が成功するのは、DLC(サブインターフェイス)と集約インターフェイスで十分な帯域幅が使用可能な場合のみです。

ATM インターネットワークに関する考慮事項

次の RSVP 実装に関する考慮事項は、ATM インターネットワーク用に予約システムを設計する場合に適用されます。

ATM を設定する場合、多くの場合、Usable Bit Rate(UBR; 使用可能ビット レート)(Available Bit Rate(ABR; 使用可能ビット レート))の Virtual Channel(VC; 仮想チャネル)が接続する個別ルータを使用します。ATM ネットワークはこのようなサービス クラスを使用して、トラフィックのビット レート要件を満たすようにベストエフォートで処理します。また、ネットワークを通過しない情報については端末の責任と仮定します。

この ATM サービスは、必要な特性を持つ予約済みトラフィックのために、個別のチャネルを開くことができます。RSVP はこれらの VC を開き、キャッシュを調整して、この目的のために VC を効率的に使用する必要があります。

可変帯域幅に関する考慮事項

RSVP は、 ip rsvp bandwidth コマンドを使用して物理インターフェイスまたは論理インターフェイス上でイネーブルにできます。絶対値とインターフェイス帯域幅のパーセンテージのどちらかを RSVP 帯域幅またはフロー帯域幅として設定できます。つまり、RSVP 帯域幅として絶対値を、フロー帯域幅としてインターフェイス帯域幅のパーセンテージを設定することも、その逆を設定することもできます。RSVP 帯域幅またはフロー帯域幅として絶対値を設定するには、 ip rsvp bandwidth コマンドを使用します。RSVP 帯域幅またはフロー帯域幅としてインターフェイス帯域幅のパーセンテージを設定するには、 ip rsvp bandwidth percent コマンドを使用します。RSVP 帯域幅としてインターフェイスのパーセンテージを設定した場合は、インターフェイス帯域幅が変化すると RSVP 帯域幅も変化します。同じことがフロー帯域幅にも当てはまります。

固定インターフェイス上の帯域幅は、固定インターフェイス上で明示的に帯域幅を設定することによって変更できます。同じことが可変帯域幅インターフェイスにも当てはまりますが、このインターフェイス上の帯域幅は、メンバー リンクの追加または削除やメンバー リンクの帯域幅の変化など、さまざまな要因で変化する可能性があります。

RSVP 入力 CAC

RSVP 入力 CAC 機能は、特定のフローの発信インターフェイスだけでなく、着信インターフェイス上の帯域幅リソースを保証するように Cisco IOS RSVP IPv4 実装を拡張します。

図 1 は、入力 CAC 機能が実装された展開シナリオを示しています。本社と支社が、非 RSVP Internet Service Provider(ISP; インターネット サービス プロバイダー)のクラウド上で接続されています。このシナリオでは、ISP クラウドが RSVP の実行に必要な分を除く、必要な帯域幅を保証できます。そのため、Provider Edge(PE; プロバイダー エッジ)ルータではなく、Customer Edge(CE; カスタマー エッジ)ルータのみが RSVP を実行します。

図 1 RSVP 入力 CAC

本社で使用される CE-PE リンクの帯域幅が 10 Gb/s であるのに対して、支社で使用される CE-PE リンクの帯域幅が 1 Gb/s であるシナリオを考えます。本社から支社へのメディア トラフィックの一部に対して、5 Gb/s の帯域幅を保証する必要があります。図 1 に示す RSVP 実装では、本社で使用される CE-PE リンクが RSVP 帯域幅予約に参加できるため、この 5 Gb/s のフローに必要な QoS が保証されます。支社で使用される CE-PE リンクは、1 Gb/s の容量しかないため、ボトルネックになります。ただし、支社では RSVP CAC が出力インターフェイス(CE と支社間)に対してしか実施されないため、このボトルネックは検出されません。したがって、5 Gb/s のトラフィックが許可されます。このトラフィックが許可される前に出力インターフェイスの帯域幅をチェックするように RSVP CAC 機能が拡張されていれば、この状況を回避できます。

RSVP 入力 CAC 機能の利点は次のとおりです。

入力 RSVP 帯域幅プールが着信インターフェイス上で設定されている場合に、それらのインターフェイス上で CAC を実行するように帯域幅予約を拡張します。

入力インターフェイス帯域幅が変化した(リンク帯域幅の変化、入力帯域幅プールの変化、または入力ポリシーの変更によって)場合、または、新しい予約要求を受信した場合にプリエンプション ロジックを拡張します。

入力ポリシー パラメータを含むように RSVP ポリシーを拡張します。

この機能は、すべての RSVP 対応トランスポート層でサポートされます。

入力 CAC 機能はデフォルトでイネーブルになっていません。入力 CAC をイネーブルにして、入力 RSVP 帯域幅プールを定義するには、 ip rsvp bandwidth コマンドを使用します。入力 CAC 機能は、イネーブルにされた以降に設定された予約に対してのみ適用されます。

中間 RSVP アウェア ノードのアドミッション制御

新しいまたは変更された予約要求が中間 RSVP アウェア ノードで受信された場合は、アドミッション制御が、出力インターフェイスに関連付けられた帯域幅プールに対して実行されてから、そのフローの入力インターフェイスに関連付けられた帯域幅プールに対して実行されます。

IP トンネル インターフェイス上のアドミッション制御

フローの入力インターフェイスが IP トンネルの場合は、両方のトンネル インターフェイス上だけでなく、基になる物理インターフェイス上でも必要な入力 RSVP 帯域幅プールを設定する必要があります。入力 CAC 機能は、要求を許可する前に、これらの両方の帯域幅プールをチェックします。

RSVP プリエンプション

RSVP プリエンプションを使用すれば、ルータで 1 つ以上の既存の RSVP 帯域幅予約をプリエンプション処理して、RSVP で設定された帯域幅プールの上限を超えないようにしながら、より優先度の高い予約に対応できます。最新の RSVP 帯域幅に基づいて RSVP セッションをプリエンプション処理または許可する RSVP ポリシーによって、RSVP 帯域幅の動的更新を実現できます。出力インターフェイスと入力インターフェイスの両方で RSVP プリエンプションをイネーブルにするには、 ip rsvp policy preempt コマンドを使用します。

RSVP プリエンプションが必要な理由は次のとおりです。

リンク帯域幅は縮小する可能性があります(可変帯域幅リンクと同様に、カスタマイズされた設定が原因の場合と動的な場合があります)。

ユーザは、設定をカスタマイズすることによって RSVP 帯域幅プールを縮小できます。

新しい予約には一部の既存の予約よりも高い優先度が設定されます。

最大グループ帯域幅と最大シングル帯域幅のどちらか(または両方)を削減する変更が RSVP ローカル ポリシーに加えられるため、このポリシーを満たすすべての予約をプリエンプション処理する必要があります。

RSVP over DMVPN

Dynamic Multipoint Virtual Private Network(DMVPN)を使用すれば、GRE トンネル、IPsec 暗号化、および Next Hop Resolution Protocol(NHRP)を組み合わせることによって、大小の IPsec VPN をスケールすることができます。DMVPN の詳細については、「 DMVPN 」モジュールを参照してください。

RSVP over DMVPN 機能は、次のような設定をサポートします。

手動設定された GRE/multipoint Generic Routing Encapsulation(mGRE; マルチポイント総称ルーティング カプセル化)トンネル経由の RSVP

IPsec 保護モードで手動設定された GRE/mGRE トンネル経由の RSVP

DMVPN 環境内の GRE/mGRE トンネル(IPsec 保護と非 IPsec 保護)経由の RSVP

図 2 に、スポーク/ハブ/スポークまたはフェーズ 1 DMVPN モードを示します。Tunnel0 という名前の 2 つの静的なスポーク/ハブ間トンネルが設定されています。Tunnel0 は、スポーク A とスポーク B 上の GRE インターフェイスとして存在しています。ハブ上では、Tunnel0 が mGRE インターフェイスとしてモデル化されています。

図 2 RSVP over DMVPN フェーズ 1

 

RSVP がトンネル経由で動作する方法と RSVP がサブインターフェイス経由で動作する方法にはいくつかの違いがあります。RSVP がサブインターフェイス上で設定されている場合は、Cisco IOS ソフトウェアが自動的に RSVP 設定をメイン インターフェイスにも適用します。この処理は、サブインターフェイスとメイン インターフェイス間のバインディングが静的なために可能です。ただし、トンネル インターフェイスと物理インターフェイス間の関連付けは動的に行われます。したがって、トンネル経由の RSVP が設定されている場合は、トンネル/物理間の関連付けが変化する可能性があるため、同じ設定を物理インターフェイスに直接適用することができません。そのため、RSVP は、トンネルの出口を設定可能な物理インターフェイス(メイン インターフェイスまたはサブインターフェイス)上に設定する必要があります。

192.168.1.0/24 ネットワークに接続された IP 電話機などのデバイスで 192.168.2.0/24 ネットワークに接続された別の IP 電話機などのデバイスへのコールを予約する必要がある場合は、スポーク A がスポーク B 宛ての PATH メッセージをトンネル インターフェイス 0 経由で直接送信します。RESV メッセージは、ハブを中継してスポーク B に転送されます。スポーク B は、ハブに送信される RESV メッセージで応答します。ハブは、Tunnel0 mGRE インターフェイスとその関連物理インターフェイス上で帯域幅を予約しようとします。ハブが必要な帯域幅を予約できた場合は、予約が成立して RESV メッセージがスポーク A に転送されます。スポーク A は、Tunnel0 上で RESV メッセージを受信し、Tunnel0 GRE インターフェイスとその関連物理インターフェイス上で帯域幅を予約しようとします。スポーク A が必要な帯域幅の予約に成功した場合は、予約が成立します。


) 特定のセッションでトンネル/物理インターフェイス間の関連付けが変化した場合に、新しい物理インターフェイス上で RSVP CAC が実行されます。これにより、一度成立した RSVP 予約が取り消される可能性があります。このような場合は、RSVP が既存の予約のみを削除します。音声トラフィックの場合は、Cisco Unified Communications Manager Express(Cisco UCME)などの他のアプリケーションによってデータ フローが決定されます。


帯域幅アドミッション制御中は、Cisco IOS ソフトウェアが、トンネリングやトンネル経由の暗号化による IP オーバーヘッドの増加を考慮する必要があります。インターネット パケットの平均サイズに基づいて、追加のオーバーヘッドのデフォルト値が入力されます。ただし、 ip rsvp tunnel overhead-percent コマンドを使用してこの値を書き換えることができます。

RSVP でのトランスポート メカニズムのサポート

RSVP Transport for Medianet 機能は、クライアントのトランスポート メカニズムとして機能するように RSVP 機能を拡張します。これは、送信者から受信者へのデータ フロー用パスの予約に使用される 5 タプル フローに 3 つのパラメータを追加することによって実現されます。この 5 タプル フローは、宛先 IP アドレス、送信元 IP アドレス、IP プロトコル、宛先ポート、および送信元ポートで構成されます。

このモデルでは、クライアントからトランスポート サービスが要求されるたびに、RSVP が Transport Protocol(TP; トランスポート プロトコル)セッションを作成します。このようなトランスポート サービス要求は、 表 1 に示すような 8 タプル フローで識別されます。

表 1 RSVP トランスポート プロトコルのサポート(8 タプル フロー)

8 タプル パラメータ
説明

Destination-IP

フローの宛先 IP アドレス

Destination-Port

フローの宛先ポート

IP Protocol

IP ヘッダー内の IP プロトコル番号

Source-IP

フローの送信元 IP アドレス

Source-Port

フローの送信元ポート

Client ID

特定のクライアント アプリケーションを識別します。クライアント ID は、RSVP トランスポートを使用するクライアントを識別するために動的に割り当てられる番号です。この番号は、クライアントを RSVP に登録するときにクライアントから RSVP に提供されます。クライアント ID によって、RSVP は、同じ 5 タプル フローに対してトランスポート サービスを要求しているクライアント アプリケーションを区別できます。

Initiator ID

トランスポート サービス要求を開始しているノードを識別します。イニシエータ ID によって、RSVP は、複数の開始ノードからの同じ 5 タプル フローに対して同じクライアント アプリケーションから生成されたトランスポート サービス要求を区別できます。TP クライアントは、RSVP トランスポート セッションを開始するときに、このイニシエータ ID を 8 タプル フローで渡す必要があります。この ID はネットワーク全体で一意にする必要があります。

Instance ID

特定のクライアント アプリケーションと特定のイニシエータからのトランスポート サービス要求を識別します。インスタンス ID によって、RSVP は、同じ開始ノードからの同じ 5 タプル フローに対して同じクライアント アプリケーションから生成されたトランスポート サービス要求のインスタンスを区別できます。このインスタンス ID は、クライアントが RSVP トランスポート セッションを開始するときに、クライアントから RSVP に渡されます。

8 タプル フローは、RSVP TP セッションを識別して、それらを特定のクライアント トランスポート サービス要求にマップします。

TP クライアントが RSVP に対してトランスポート サービスを要求すると、RSVP はそのトランスポート サービス要求に固有の TP セッションを作成し、それを使用してそのサービス要求に関してクライアントから送信された他のすべてのメッセージを転送します。また、RSVP は、定期的に PATH メッセージを更新することによって、この TP セッションの状態を維持します。

RSVP は、トランスポート サービス要求に関して、次の 2 種類のトランスポート メカニズムをクライアントに提供します。

パスベースのトランスポート メカニズム:このメカニズムでは、イニシエータ ノードが TP クライアントのメッセージ(TP-Client-Data とも呼ばれる)を特定のフローの宛先に転送します。RSVP は、クライアントからのトランスポート サービス要求に固有の TP セッションを作成し、PATH メッセージを使用して TP-Client-Data を送信します。また、RSVP は、TP-Client-Data が対応する 5 タプルのデータ フローと同じパスで転送されることを保証します。さらに、RSVP は、イニシエータから宛先と TP セッションが終了するノードのどちらかへのすべての中間ノード上でこのトランスポート セッションの状態を維持します。

トランスポート通知ベースのトランスポート メカニズム:このメカニズムでは、フロー パス内のノードからの TP-Client-Data が同じパス内の他のノードに転送されます。RSVP は Transport-Notify メッセージを使用して TP-Client-Data を送信します。

パスベースのトランスポート メカニズムでは、送信者から受信者へのパスに沿って TP-Client-Data を伝送するために RSVP PATH メッセージが使用されます。RSVP は、クライアント スタックが動作している各 RSVP 対応ホップ上のクライアント スタックに TP-Client-Data を渡します。これにより、クライアントは次のタスクのいずれかを実行できます。

RSVP に、変更された、または、変更されていない TP-Client-Data をより下流の受信者に送信するように要求する。この場合は、RSVP が、クライアントの発信 TP-Client-Data を PATH メッセージに埋め込んで受信者に転送します。

クライアントが特定のノードでトランスポート セッションを終了させることにした場合に TP-Client-Data を終端させる。この場合は、RSVP が、どの PATH メッセージも下流に送信しません。

トランスポート通知ベースのトランスポート メカニズムでは、RSVP が、Transport-Notify メッセージを使用してクライアントのメッセージを送信します。この場合は、TP クライアントが RSVP に次のいずれかのタスクを実行するように要求できます。

RSVP に、8 タプル フローの TP-Client-Data を対象 IP アドレスに送信するように要求する。この要求は、対応する 8 タプル フロー用の RSVP TP セッションが存在しない場合でも処理されます。

RSVP に、TP-Client-Data を 1 つ上流の RSVP ホップに送信するように要求する。このプロセスは、対応する 8 タプル フロー用の RSVP TP セッションが存在することが前提になります。この場合は、RSVP が、8 タプル フローの Path State Block(PSB)から 1 つ前の RSVP アウェア ホップ IP アドレスを抽出して、Transport-Notify メッセージとそれに埋め込まれた TP-Client-Data をその IP アドレスに送信します。

RSVP は、Transport-Notify メッセージと埋め込まれたトランスポート オブジェクトをルータ上で動作している対応する TP クライアントに渡します。対応する TP クライアントがルータ上に存在せず、RSVP Transport-Notify メッセージ内に 8 タプル フロー用の RSVP TP セッションがすでに存在していた場合は、RSVP が、このメッセージを 1 つ上流の RSVP 対応ルータに送信します。この動作は、RSVP がこのメッセージを TP クライアントに配信できるようになるまで続きます。

対応する TP クライアントがルータ上に存在せず、8 タプル フロー用の RSVP TP セッションも存在しない場合は、RSVP がメッセージをドロップします。

RSVP の設定方法

「RSVP のイネーブル化」(必須)

「RSVP 帯域幅の設定」(必須)

「シングルまたはグループ フローの最大帯域幅の設定」(必須)

「RSVP データベースへの送信者または受信者の入力」(任意)

「トランスポート プロトコルとしての RSVP の設定」(任意)

「マルチキャストの宛先の指定」(任意)

「RSVP ネイバー予約の制御」(任意)

「RSVP の NetFlow への適用」(任意)

「IP precedence および ToS 値」(任意)

「トンネル帯域幅オーバーヘッドの設定」(任意)

「RSVP 通知の送信」(任意)

「RSVP 設定の確認」(任意)

RSVP のイネーブル化

RSVP を実装していないシステムとの下位互換性のために、デフォルトで RSVP はディセーブルです。インターフェイス上で RSVP for IP をイネーブルにするには、次の作業を実行します。この作業では、RSVP を開始して、帯域幅とシングル フローの上限を設定します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip rsvp bandwidth [ interface-bandwidth [ percent percent-bandwidth | [ single-flow-bandwidth ] [ sub-pool bandwidth ]]]

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface fastethernet 0/1

指定したインターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip rsvp bandwidth [ interface-bandwidth [ percent percent-bandwidth | [ single-flow-bandwidth ] [ sub-pool bandwidth ]]]
 

Router(config-if)# ip rsvp bandwidth 23 54

インターフェイスで IP 用 RSVP をイネーブルにします。

ステップ 5

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

RSVP 帯域幅の設定

RSVP 帯域幅を設定するには、次の作業を実行します。デフォルトの最大帯域幅は、インターフェイスで使用可能な帯域幅の 75% が上限です。デフォルトで、単一のフローで予約可能なサイズの合計は、予約可能な全体の帯域幅が上限です。

通常、100 kb/s を超えることがない個別の回線の予約は成功します。ただし、他の回線上での予約が 1.2 Mb/s にまで増加し、帯域幅が十分残っているサブインターフェイス上で予約が実行された場合は、物理インターフェイスのサポート帯域幅が不十分なため、その予約要求は拒否されます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip rsvp bandwidth [ interface-bandwidth [ single-flow-bandwidth ] [ sub-pool bandwidth ]]

または

ip rsvp bandwidth percent interface-bandwidth [ max-flow-bw | percent flow-bandwidth ]

5. ip rsvp bandwidth ingress [ ingress-bandwidth | percent percent-bandwidth [ maximum-ingress-bandwidth | percent percent-bandwidth ]]

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number
 
Router(config)# interface multilink 2

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip rsvp bandwidth [ interface-bandwidth [ percent percent-bandwidth | [ single-flow-bandwidth ] [ sub-pool bandwidth ]]

または

 
ip rsvp bandwidth percent rsvp-bandwidth [ max-flow-bw | percent flow-bandwidth ]
 

Router(config-if)# ip rsvp bandwidth 23 34

または

Router(config-if)# ip rsvp bandwidth percent 50 percent 10

RSVP 帯域幅とフロー帯域幅に対して絶対値を設定します。

(注) サブインターフェイス上では、このコマンドが、物理インターフェイスとサブインターフェイスのより限定的な使用可能帯域幅に適用されます。たとえば、フレーム リレー インターフェイスに、名目上 1.536 Mb/s が可能な T1 コネクタと 128 kb/s 回線上の 64 kb/s サブインターフェイス(64 kb/s CIR)が実装されているとします。RSVP 帯域幅は、メイン インターフェイス上で最大 1,200 kb/s に、各サブインターフェイス上で最大 100 kb/s に設定できます。

または

RSVP 帯域幅とフロー帯域幅としてインターフェイス帯域幅のパーセンテージを設定します。

他の例については、「RSVP の設定例」を参照してください。

ステップ 5

ip rsvp bandwidth ingress ingress-bandwidth

または

ip rsvp bandwidth ingress percent percent-bandwidth [ maximum-ingress-bandwidth | percent percent-bandwidth ]
 

Router(config-if)# ip rsvp bandwidth ingress 40

または

Router(config-if)# ip rsvp bandwidth ingress percent 80

(任意)RSVP 入力予約可能帯域幅を設定します。

または

入力帯域幅としてインターフェイス帯域幅のパーセンテージを設定します。

ステップ 6

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

シングルまたはグループ フローの最大帯域幅の設定

シングルまたはグループ フローの最大帯域幅を設定するには、次の作業を実行します。アプリケーション ID 拡張の一部として、RESV メッセージの最大帯域幅を設定できます。これにより、共有予約と非共有予約の両方に対する RSVP のアドミッション制御プロセスでローカル ポリシー帯域幅制限を使用できます。また、ポリシー帯域幅が不十分で着信 RESV メッセージのニーズを満たせない場合に、ローカル ポリシーでアドミッション制御機能中のプリエンプションをトリガーできます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip rsvp policy local identity alias1 [ alias2 ... alias4 ]

5. maximum bandwidth [ group | single ] bandwidth

または

maximum bandwidth percent { group | single } bandwidth-percentage

6. maximum bandwidth ingress { group | single } bandwidth

または

maximum bandwidth ingress percent { group | single } percent

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number
 
Router(config)# interface multilink 2

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip rsvp policy local identity alias1 [ alias2 ... alias4 ]
 

Router(config-if)# ip rsvp policy local identity video

過去に設定されたアプリケーション ID のアプリケーション ID エイリアスを指定して、ローカル ポリシー コンフィギュレーション モードを開始します。

ステップ 5

maximum bandwidth [ group | single ] bandwidth

または

maximum bandwidth percent { group | single } bandwidth-percentage
 

Router(config-rsvp-local-if-policy)# maximum bandwidth group 500

または

Router(config-rsvp-local-if-policy)# maximum bandwidth percent group 50

ローカル ポリシーでカバーされるシングル予約またはグループ予約で要求可能な最大帯域幅を kb/s 単位で設定します。

または

ローカル ポリシーでカバーされるシングルまたはグループ予約で使用可能な最大帯域幅としてインターフェイスの RSVP 帯域幅のパーセンテージを設定します。

ステップ 6

maximum bandwidth ingress { group | single } bandwidth

または

maximum bandwidth ingress percent { group | single } percent
 

Router(config-rsvp-local-policy)# maximum bandwidth ingress group 200

または

Router(config-rsvp-local-if-policy)# maximum bandwidth ingress percent group 50

グローバルベースの RSVP ポリシー内で、グループ予約またはシングル予約の最大入力帯域幅を設定します。

または

グループ予約またはシングル予約として、インターフェイスの RSVP 入力帯域幅の最大パーセンテージを設定します。

ステップ 7

end

 

Router(config-rsvp-local-if-policy)# end

ローカル ポリシー コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

RSVP データベースへの送信者または受信者の入力

RSVP データベース上で送信者または受信者をイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip rsvp sender session-ip-address sender-ip-address [ tcp | udp | ip-protocol ] session-dport sender-sport previous-hop-ip-address previous-hop-interface bandwidth burst-size

4. ip rsvp reservation session-ip-address sender-ip-address [ tcp | udp | ip-protocol ] session-dport sender-sport next-hop-ip-address next-hop-interface { ff | se | wf } { rate | load } bandwidth burst-size

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip rsvp sender session-ip-address sender-ip-address [ tcp | udp | ip-protocol ] session-dport sender-sport previous-hop-ip-address previous-hop-interface bandwidth burst-size

 

Router(config)# ip rsvp sender 10.10.1.1 10.10.2.2 tcp 2 3 10.10.3.1 fastEthernet 0/1 2 3

RSVP データベースで送信者を入力します。

ルータで、送信者または指定された属性を含む 1 つ前のホップ ルートからの RSVP PATH メッセージを受信して処理しているように見せかけることができるようにします。

関連する ip rsvp sender-host コマンドは、ルータで RSVP PATH メッセージを生成するホストをシミュレートできるようにします。ほとんどの場合、これはデバッグとテストの目的で使用されます。

ステップ 4

ip rsvp reservation session-ip-address sender-ip-address [ tcp | udp | ip-protocol ] session-dport sender-sport next-hop-ip-address next-hop-interface { ff | se | wf } { rate | load } bandwidth burst-size

 

Router(config)# ip rsvp reservation 10.0.0.4 10.0.0.5 tcp 2 3 10.0.0.3 fastEthernet 0/1 ff load 2 4

受信者を RSVP データベースに入力し、ルータで RSVP RESV メッセージを受信して処理しているように見せかけることができるようにします。

関連する ip rsvp reservation-host コマンドは、ルータで RSVP RESV メッセージを生成するホストをシミュレートできるようにします。ほとんどの場合、これはデバッグとテストの目的で使用されます。

ステップ 5

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

トランスポート プロトコルとしての RSVP の設定

RSVP をトランスポート プロトコルとしてイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip rsvp transport client client-id

4. ip rsvp transport sender-host [ tcp | udp ] destination-address source-address ip-protocol dest-port source-port client-id init-id instance-id [ vrf vrf-name ] [ data data-value ]

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip rsvp transport client client-id

 

Router(config)# ip rsvp transport client 2

RSVP トランスポート セッションを作成します。ルータで RSVP PATH メッセージを生成するホストをシミュレートできるようにします。

このコマンドは、デバッグとテストに使用されます。

ステップ 4

ip rsvp transport sender-host [ tcp | udp ] destination-address source-address ip-protocol dest-port source-port client-id init-id instance-id [ vrf vrf-name ] [ data data-value ]
 

Router(config)# ip rsvp transport sender-host tcp 10.1.1.1 10.2..1.1 3 4 5 2 3 4 vrf vr1

RSVP トランスポート クライアント ID を RSVP に登録します。

このコマンドは、デバッグとテストの目的に使用されます。

ステップ 5

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

マルチキャストの宛先の指定

User Datagram Protocol(UDP; ユーザ データグラム プロトコル)カプセル化を使用している RSVP ネイバーが検出された場合、そのネイバーが使用できるように、ルータは UDP カプセル化メッセージを自動的に生成します。

ただし、ホストは、ルータから受信(UDP 経由でのみ)するまで、このようなメッセージを発信しない場合があります。ルータが IP カプセル化マルチキャストを生成するときはいつでも、UDP カプセル化済み RSVP マルチキャストを生成するようにルータに指示する必要があります。

UDP カプセル化メッセージを受信すべきマルチキャスト宛先を指定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip rsvp udp-multicasts [ multicast-address ]

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip rsvp udp-multicasts [ multicast-address ]

 

Router(config)# ip rsvp udp-multicasts 10.3.4.1

UDP カプセル化メッセージを受信するマルチキャストの宛先を指定します。

ステップ 4

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

RSVP ネイバー予約の制御

デフォルトでは、任意の RSVP ネイバーが予約要求を提供できます。予約要求を提供可能な RSVP ネイバーを制御するには、次の作業を実行します。この作業を実行する場合は、アクセス リストに適合しないネイバーは受け入れられません。アクセス リストは IP ヘッダーに適用されます。

手順の概要

1. enable

2. configure terminal

3. ip rsvp neighbor access-list-number

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip rsvp neighbor access-list-number

 

Router(config)# ip rsvp neighbor 12

予約を提供できるルータを制限します。

ステップ 4

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

RSVP の NetFlow への適用

パケットに関する情報を受信して、必要に応じて、トークン バケットを更新したり、IP precedence を設定したりできるように、RSVP でそれ自身を NetFlow に対応付けられるようにするには、次の作業を実行します。 ip rsvp svc-required コマンドを使用して、ATM Switched Virtual Circuits(SVC; 相手先選択接続)を使用するようにインターフェイスを設定した場合は、RSVP がパケット フロー識別を実行するために自動的にそれ自身を NetFlow に対応付けるため、この作業は任意です。ただし、ATM SVC を使用せずに、IP precedence Type of Service(ToS; タイプ オブ サービス)ビット設定を各パケットで実行する場合、 ip rsvp flow-assist コマンドを使用して、RSVP を NetFlow に適用するように RSVP に指示する必要があります。


) WFQ を使用している場合、ToS および IP precedence ビットは、輻輳のために、RSVP から見えるデータ パケットのみが設定されます。


手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip rsvp flow-assist

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface fastethernet 0/1

指定したインターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip rsvp flow-assist

 

Router(config-if)# ip rsvp flow-assist

RSVP の NetFlow への適用を可能にします。

ステップ 5

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

IP precedence および ToS 値


) IP Precedence 値と ToS 値を使用して、RSVP フロー仕様(flowspec)を満たしている、または超えている RSVP 予約パス内のパケットをマーキングするように設定するには、次の作業を実行します。すべてのパケットに IP precedence 値または ToS 値を設定し、ATM SVC を使用しない(つまり、ip rsvp svc-required コマンドを設定していない)場合は、ip rsvp flow-assist コマンドを設定する必要があります。


IP ヘッダーの ToS バイトは、IP precedence ビットとして上位 3 ビット、ToS ビットとして下位 5 ビットを定義します。

ルータ ソフトウェアは、パケットの送信者および宛先のアドレスとポート番号を確認し、パケットが RSVP 予約と一致するかどうかを決定します。一致が存在する場合、RSVP は入力プロセスの一部として、予約のフロー仕様に従ってパケットを確認します。このプロセス中に、RSVP は、パケットがフロー仕様に準拠しているか超過しているかを判断し、それに従って ToS ビットの IP precedence と ToS ビットを設定します。これらの IP precedence および ToS ビット設定は、出力インターフェイスでは VC 単位の Distributed Weighted Random Early Detection(DWRED)に使用されます。また、ダウンストリーム ルータでインターフェイスから使用できます。

拡張 ATM ポート アダプタ(PA-A3)と各 SVC DWRED ドロップ ポリシーによって実行されるスケジューリングの組み合わせによって、予約に一致してもフロー仕様を超過するパケット(つまり、予約のトークン バケットに準拠していないパケット)は、ベストエフォート型パケットのように扱われます。予約のために SVC で送信されますが、準拠するトラフィックを中断しないように IP precedence がマークされます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip rsvp precedence { conform | exceed } precedence-value

5. ip rsvp tos { conform | exceed } tos-value

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface fastethernet 0/1

指定したインターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip rsvp precedence { conform | exceed } precedence-value

 

Router(config-if)# ip rsvp precedence conform 23

IP precedence の準拠値または超過値を設定します。

ステップ 5

ip rsvp tos { conform | exceed } tos-value

 

Router(config-if)# ip rsvp tos conform 45

ToS の準拠値または超過値を設定します。

ステップ 6

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

トンネル帯域幅オーバーヘッドの設定

トンネル帯域幅オーバーヘッドを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface tunnel number

4. ip rsvp tunnel overhead-percent [ overhead-percent ]

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel number

 

Router(config)# interface tunnel 0

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip rsvp tunnel overhead-percent [ overhead-percent ]

 

Router(config-if)# ip rsvp tunnel overhead-percent 20

トンネル インターフェイス上のパーセンテージ帯域幅オーバーヘッドのオーバーライド値を設定します。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show ip rsvp interface detail コマンドを使用すれば、RSVP 設定パラメータを表示できます。

RSVP 通知の送信

リモート管理ステーション上のユーザが RSVP 関連情報をモニタできるようにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. snmp-server enable traps rsvp

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

snmp-server enable traps rsvp

 

Router(config)# snmp-server enable traps rsvp

RSVP 通知を送信します。

ステップ 4

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

RSVP 設定の確認

ネットワーク リソース ポリシーを反映した RSVP 予約を設定した後で RSVP の動作を確認するには、次の作業を実行します。これらの手順は任意の順序で実行できます。

手順の概要

1. enable

2. show ip rsvp interface [ type number ]

3. show ip rsvp installed [ type number ]

4. show ip rsvp neighbor [ type number ]

5. show ip rsvp sender [ type number ]

6. show ip rsvp request [ type number ]

7. show ip rsvp reservation [ type number ]

8. show ip rsvp ingress interface [ detail ] [ type number ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show ip rsvp interface [ type number ]

 

Router# show ip rsvp interface fastethernet 0/1

RSVP 関連のインターフェイス情報を表示します。

ステップ 3

show ip rsvp installed [ type number ]

 

Router# show ip rsvp installed fastethernet 0/1

RSVP 関連のフィルタと帯域幅情報を表示します。

ステップ 4

show ip rsvp neighbor [ type number ]

 

Router# show ip rsvp neighbor fastethernet 0/1

現在の RSVP ネイバーを表示します。

ステップ 5

show ip rsvp sender [ type number ]

 

Router# show ip rsvp sender fastethernet 0/1

RSVP 送信者情報を表示します。

ステップ 6

show ip rsvp request [ type number ]

 

Router# show ip rsvp request fastethernet 0/1

RSVP 要求情報を表示します。

ステップ 7

show ip rsvp reservation [ type number ]

 

Router# show ip rsvp reservation fastethernet 0/1

RSVP 受信者情報を表示します。

ステップ 8

show ip rsvp ingress interface [ detail ] [ type number ]

 

Router# show ip rsvp ingress interface detail

RSVP 入力帯域幅情報を表示します。

RSVP の設定例

ここでは、次の設定例について説明します。

「例:マルチキャスト セッション用の RSVP の設定」

「例:RSVP 帯域幅の設定」

「例:トンネル帯域幅オーバーヘッドの設定」

例:マルチキャスト セッション用の RSVP の設定

ここでは、3 台の Cisco 4500 ルータ上で RSVP をマルチキャスト セッション用に設定する方法について説明します。

RSVP の設定方法については、「RSVP の設定方法」を参照してください。

アップストリーム(端末)ホストで実行されている RSVP 送信者アプリケーションと、ダウンストリーム(端末)ホストで実行されている RSVP 受信アプリケーション(いずれのホストもこの例では表示されません)間に、3 つのルータはルータ ネットワークを構成します。

ルータ ネットワークには、ルータ A、ルータ B、およびルータ C という 3 つのルータが含まれます。この例では、ルータ A のアップストリーム High-Speed Serial Interface(HSSI)のインターフェイス 0 は、アップストリーム ホストにリンクしていると仮定しています。ルータ A およびルータ B は、ルータ A のダウンストリーム イーサネット インターフェイス 1 から接続されています。インターフェイス 1 は、ルータ B のアップストリーム インターフェイスのイーサネット 1 にリンクしています。ルータ B およびルータ C は ルータ C のダウンストリーム HSSI インターフェイス 0 から接続されています。インターフェイス 0 は、ルータ C のアップストリーム HSSI インターフェイス 0 にリンクしています。この例では、ルータ C のダウンストリーム イーサネット インターフェイス 2 はダウンストリーム ホストにリンクしていると仮定します。

通常は、ルータ ネットワークの一方の端にあるエンド システム ホスト上で動作している RSVP 対応アプリケーションが、通信するルータ ネットワークのもう一方の端にある宛先エンド システムまたはホストに、ユニキャストまたはマルチキャスト RSVP PATH(Set Up)メッセージを送信します。開始側アプリケーションは送信者と呼ばれ、ターゲットまたは宛先アプリケーションは受信者と呼ばれます。この例では、送信者がルータ A より上流にあるホスト上で動作し、受信者がルータ C より下流にあるホスト上で動作しています。ルータ ネットワークは、RSVP PATH メッセージを送信者から受信者に配信します。受信者は、受信者と送信者の間に必要な、要求されたリソースをネットワーク全体で予約するために RSVP RESV メッセージで返信します。RSVP RESV メッセージで、システムに接続するルータ ネットワークが提供しようとしている必要な QoS のパラメータを指定します。

この例では、送信側アプリケーションを実行するホストと、受信側アプリケーションを実行するホストは示しません。通常、ルータ ネットワークで送信者からダウンストリームの最初のルータ(この場合はルータ A)は、送信者から RSVP PATH メッセージを受信します。通常、ルータ ネットワークの最後のルータ(つまり、受信側アプリケーションを実行するホストから 1 つアップストリームのホップで、この場合はルータ C)は、受信者から RSVP RESV メッセージを受信します。

この例では、送信者と受信者のアプリケーションが実行しているホストを明示的に含めていないため、送信者から PATH メッセージ、受信者から RESV メッセージを受信しているように、ルータの動作が設定されています。この目的で使用されるコマンドは(この例では RSVP がより詳細にわかります)、 ip rsvp sender コマンドおよび ip rsvp reservation コマンドです。ルータ A では、次のコマンドが発行されました。

ip rsvp sender 225.1.1.1 10.1.2.1 UDP 7001 7000 10.1.2.1 Hs0 20 1
 

このコマンドは、送信元 10.1.2.1 からマルチキャスト アドレス 225.1.1.1 宛ての PATH メッセージを受信したかのようにルータを動作させます。PATH メッセージの 1 つ前のホップが 10.1.2.1 で、メッセージが HSSI インターフェイス 0 上で受信されました。

ルータ C では、次のコマンドが発行されました。

ip rsvp reservation 225.1.1.1 10.1.2.1 UDP 7001 7000 10.1.3.1 Et2 FF LOAD 8 1
 

このコマンドによって、マルチキャストの宛先が 225.1.1.1 のセッションの RESV メッセージを受信したかのように、ルータが動作します。メッセージは、送信元 10.1.2.1 に対する固定フィルタ予約を要求し、アドレスが 10.1.3.1 のイーサネット インターフェイス 2 上の受信者から届いたかのように動作します。

この例では、RSVP PATH メッセージは、送信者からダウンストリーム(この例ではルータ A)への単方向で送信されます(ホストが RSVP PATH メッセージを開始した場合、メッセージはホストからルータ A に送信されます)。ルータ A はメッセージをダウンストリームのルータ B に送信し、ルータ B はダウンストリームのルータ C に送信します(ダウンストリームのホストが実際の受信者である場合、ルータ C は受信ホストへのダウンストリーム方向で RSVP PATH メッセージを送信します)。ルータ ネットワークの各ルータは、RSVP PATH メッセージを処理し、次のダウンストリーム ホップにルーティングする必要があります。

RSVP RESV は 単方向で送信されます。つまり、受信者からアップストリーム(この例ではルータ C)へ、ルータ C からルータ B へのアップストリーム、およびルータ B からルータ A へのアップストリームです。ダウンストリームのホストが受信者の場合、メッセージはそのホストから発信され、ルータ C に送信されます。アップストリーム ホストが送信者の場合、RSVP RESV メッセージの最終的な宛先はアップストリーム ホストです。各ホップでは、RSVP RESV メッセージを受信するルータは、予約要求を受け入れるかどうかを決定する必要があります。

ip rsvp bandwidth コマンドによって、インターフェイス上の RSVP をイネーブルにし、予約可能なインターフェイス上の帯域幅サイズ(および単一フローに割り当て可能な帯域幅サイズ)を指定します。RSVP 予約用に QoS を確保するために、予約用にイネーブルにされたインターフェイスに WFQ が設定されます。

ルータ ネットワークが指定した(QoS)サービス レベルを提供できる場合、エンドツーエンドの予約パス確立されます。提供できない場合、予約の試行は拒否され、RESV ERROR メッセージが受信者に送信されます。RSVP RESV メッセージがルータ ネットワーク全体で送信者に送信されるときに、ネットワークの各ルータが要求されたサービス レベルを受け入れる可能であることがリンクごとに確認されます。ただし、帯域幅を予約するデータ自体は 単方向(確立済みの PATH 経由で送信者から受信者へ)のみで送信されます。そのため、QoS は単方向でのみ有効です。これは、1 対多のマルチキャスト データ フローの場合に一般的です。

この例の 3 つのルータを選択した後は、 show ip rsvp sender コマンドと show ip rsvp reservation コマンドによって、PATH および RESV の状態を確認できるようにします。

ルータ A の設定

ルータ A では、RSVP が、データ送信用として 10 kb/s が予約されたイーサネット インターフェイス 1 上でイネーブルにされます。RSVP の QoS を確保するために、このインターフェイスで重み付け均等化キューが予約されます(ルータ A では、RSVP が、1 kb/s が予約された HSSI インターフェイス 0 上でもイネーブルにされますが、この帯域幅はメッセージを渡すためだけに使用されます)。

!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname routerA
!
ip subnet-zero
no ip domain-lookup
ip multicast-routing
ip dvmrp route-limit 20000
!
!
interface Ethernet0
ip address 172.0.0.193 255.0.0.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
media-type 10BaseT
!
interface Ethernet1
ip address 172.1.1.2 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 10 10
fair-queue 64 256 1000
media-type 10BaseT
!
interface Hssi0
ip address 10.1.1.1 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 1 1
!
interface ATM0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
network 10.0.0.0 0.255.255.255 area 10
network 172.0.0.0 0.255.255.255 area 10
!
ip classless
ip rsvp sender 225.1.1.1 12.1.2.1 UDP 7001 7000 10.1.2.1 Hs0 20 1
!
line con 0
exec-timeout 0 0
length 0
transport input none
line aux 0
line vty 0 4
login
!
end

ルータ B の設定

ルータ B では、RSVP が、データ送信用として 20 kb/s が予約された HSSI インターフェイス 0 上でイネーブルにされます。RSVP の QoS を確保するために、このインターフェイスで重み付け均等化キューが予約されます(ルータ B では、RSVP が、1 kb/s が予約されたイーサネット インターフェイス 1 上でもイネーブルにされますが、この帯域幅はメッセージを渡すためだけに使用されます)。

!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname routerB
!
ip subnet-zero
no ip domain-lookup
ip multicast-routing
ip dvmrp route-limit 20000
clock calendar-valid
!
interface Ethernet0
ip address 172.0.0.194 255.0.0.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
media-type 10BaseT
!
interface Ethernet1
ip address 10.1.1.1 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 1 1
media-type 10BaseT
!
interface Hssi0
ip address 10.1.1.2 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 20 20
fair-queue 64 256 1000
hssi internal-clock
!
interface ATM0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
network 10.0.0.0 0.255.255.255 area 10
network 172.0.0.0 0.255.255.255 area 10
!
ip classless
!
line con 0
exec-timeout 0 0
length 0
transport input none
line aux 0
line vty 0 4
login
!
end

ルータ C の設定

ルータ C では、RSVP が、データ送信用として 20 kb/s が予約されたイーサネット インターフェイス 2 上でイネーブルにされます。RSVP の QoS を確保するために、このインターフェイスで重み付け均等化キューが予約されます(ルータ C では、RSVP が、1 kb/s が予約された HSSI インターフェイス 0 上でもイネーブルにされますが、この帯域幅はメッセージを渡すためだけに使用されます)。

!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname routerC
!
ip subnet-zero
no ip domain-lookup
ip multicast-routing
ip dvmrp route-limit 20000
!
interface Ethernet0
ip address 172.0.0.195 255.0.0.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
media-type 10BaseT
!
interface Ethernet1
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Ethernet2
ip address 10.1.3.2 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 20 20
fair-queue 64 256 1000
media-type 10BaseT
!
interface Ethernet3
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Ethernet4
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Ethernet5
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Hssi0
ip address 10.1.1.1 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 1 1
hssi internal-clock
!
interface ATM0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
network 10.0.0.0 0.255.255.255 area 10
network 172.0.0.0 0.255.255.255 area 10
!
ip classless
ip rsvp reservation 225.1.1.1 10.1.2.1 UDP 7001 7000 10.1.3.1 Et2 FF LOAD 8 1
!
line con 0
exec-timeout 0 0
length 0
transport input none
line aux 0
line vty 0 4
login
!
end

例:RSVP 帯域幅の設定

次に、RSVP 帯域幅として絶対値を、フロー帯域幅としてインターフェイスのパーセンテージを設定する例を示します。

configure terminal
interface multilink 2
ip rsvp bandwidth 1000 percent 50
 

次に、RSVP 帯域幅としてインターフェイスのパーセンテージを、フロー帯域幅として絶対値を設定する例を示します。

configure terminal
interface multilink 2
ip rsvp bandwidth percent 50 1000
 

次に、RSVP 帯域幅およびフロー帯域幅として絶対値を設定する例を示します。

configure terminal
interface multilink 2
ip rsvp bandwidth 23 34
 

次に、インターフェイス レベル RSVP ポリシー内でフロー グループの上限にすべきインターフェイスの RSVP 帯域幅のパーセンテージを設定する例を示します。

configure terminal
interface multilink 2
ip rsvp policy local identity id1
maximum bandwidth percent group 80
maximum bandwidth percent single 5
end
 

次に、フロー グループの上限にすべき RSVP 帯域幅のパーセンテージの設定を確認する例を示します。

Router# show running interface multilink 2
 
Building configuration...
 
Current configuration : 298 bytes
!
interface Multilink2
ip address 30.30.30.1 255.255.255.0
ip ospf cost 100
ppp multilink
ppp multilink group 2
ppp multilink endpoint ip 30.30.30.2
ip rsvp policy local identity id1
maximum bandwidth percent group 80
maximum bandwidth percent single 5
ip rsvp bandwidth percent 50 percent 10
end
 

次に、インターフェイスの RSVP 入力帯域幅を設定する例を示します。

enable
configure terminal
interface tunnel 0
ip rsvp bandwidth ingress 200

 

次に、グローバルベースの RSVP ポリシーで、グループ予約とシングル予約のそれぞれの最大入力帯域幅を設定する例を示します。

enable
configure terminal
ip rsvp local identity rsvp-video
maximum bandwidth ingress group 200
maximum bandwidth ingress single 100
 

次に、グループ予約とシングル予約のそれぞれのインターフェイスの RSVP 入力帯域幅の最大パーセンテージを設定する例を示します。

enable
configure terminal
interface tunnel 0
ip rsvp local identity rsvp-video
maximum bandwidth ingress percent group 50
maximum bandwidth ingress single 50
 

次に、インターフェイス上の入力 CAC パラメータを確認する例を示します。

Router# show ip rsvp ingress interface detail ethernet 1/0
 
interface rsvp in-allocated in-i/f max in-flow max VRF
Et1/0 ena 0 7500K 7500K 0

例:トンネル帯域幅オーバーヘッドの設定

次に、トンネル帯域幅オーバーヘッドを設定する例を示します。

configure terminal
interface tunnel 0
ip rsvp overhead-percent 25

end

show ip rsvp interface show ip rsvp interface detail 、および show ip rsvp reservation コマンドを使用して RSVP 設定パラメータを確認できます。

Router# show ip rsvp interface detail
 
Tu0:
RSVP: Enabled
Interface State: Up
Bandwidth:
Curr allocated: 10K bits/sec
Max. allowed (total): 75K bits/sec
Max. allowed (per flow): 75K bits/sec
Max. allowed for LSP tunnels using sub-pools: 0 bits/sec
Set aside by policy (total): 0 bits/sec
Admission Control:
Header Compression methods supported:
rtp (36 bytes-saved), udp (20 bytes-saved)
Tunnel IP Overhead percent:
4
Tunnel Bandwidth considered:
Yes
Traffic Control:
RSVP Data Packet Classification is ON via CEF callbacks
Signalling:
DSCP value used in RSVP msgs: 0x3F
Number of refresh intervals to enforce blockade state: 4
Authentication: disabled
Key chain: <none>
Type: md5
Window size: 1
Challenge: disabled
Hello Extension:
State: Disabled

 

Router# show ip rsvp interface
 
interface rsvp allocated i/f max flow max sub max VRF
Et0/0 ena 10400 7500K 7500K 0
Et1/0 ena 20K 7500K 7500K 0

Tu0 ena 10400 750K 750K 0

 
Router# show ip rsvp reservation
 
To From Pro DPort Sport Next Hop I/F Fi Serv BPS
192.168.2.2 192.168.1.2 TCP 10 10 192.168.2.2 Tu0 SE RATE 10K

その他の参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

RSVP コマンド:完全なコマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS Quality of Service Solutions Command Reference』

RSVP の概要

Signalling Overview

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、シスコ ソフトウェア、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

新しい RFC または変更された RFC はサポートされていません。また、既存の RFC に対するサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

Cisco Support and Documentation Web サイトでは、ドキュメント、ソフトウェア、およびツールをダウンロードするためのオンライン リソースを提供しています。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。Cisco Support and Documentation Web サイト上のツールにアクセスするには、Cisco.com のユーザ ID とパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

RSVP の設定に関する機能情報

表 2 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 2 RSVP の設定に関する機能情報

機能名
リリース
機能情報

RSVP:Resource Reservation Protocol(リソース予約プロトコル)

11.2(1)
12.2(28)SB

RSVP は、ルータ ネットワークの両端にあるエンド システムまたはホストで、両者間に予約済み帯域幅パスを設定し、データ送信用の QoS を事前に決定して保証可能にする IP サービスです。

この機能に関する詳細については、次の各項を参照してください。

「RSVP の設定について」

「RSVP の設定方法」

コマンドの ip rsvp bandwidth ip rsvp flow-assist ip rsvp neighbor ip rsvp reservation ip rsvp sender が導入または変更されました。

可変 BW インターフェイス用 RSVP

15.1(1)S
15.1(2)T

可変 BW インターフェイス用 RSVP 機能を使用すれば、RSVP 帯域幅としてインターフェイス帯域幅のパーセンテージを設定できます。

Cisco IOS Release 15.1(2)T で、この機能が導入されました。

Cisco IOS Release 15.1(1)S で、この機能が Cisco 7600 シリーズ ルータ上に実装されました。

この機能に関する詳細については、次の各項を参照してください。

「可変帯域幅に関する考慮事項」

「RSVP の設定方法」

コマンドの ip rsvp bandwidth percent maximum bandwidth percent が導入または変更されました。

RSVP Over DMVPN

15.1(1)S
15.1(2)T

RSVP over DMVPN 機能は、手動設定トンネルおよび DMVPN IP トンネル経由の RSVP の実装をサポートします。

Cisco IOS Release 15.1(2)T で、この機能が導入されました。

Cisco IOS Release 15.1(1)S で、この機能が Cisco 7600 シリーズ ルータ上に実装されました。

この機能に関する詳細については、次の各項を参照してください。

「RSVP over DMVPN」

「RSVP の設定方法」

コマンドの ip rsvp bandwidth ignore ip rsvp tunnel overhead-percent 、および show ip rsvp interface detail が導入または変更されました。

RSVP 入力 CAC

15.1(1)S
15.1(3)T

RSVP 入力 CAC 機能は、特定のフローの発信インターフェイスだけでなく、着信インターフェイス上の帯域幅リソースを保証するように Cisco IOS RSVP IPv4 実装を拡張します。

Cisco IOS Release 15.1(3)T で、この機能が導入されました。

Cisco IOS Release 15.1(1)S で、この機能が Cisco 7600 シリーズ ルータ上に実装されました。

この機能に関する詳細については、次の各項を参照してください。

「RSVP 入力 CAC」

「RSVP の設定方法」

コマンドの ip rsvp bandwidth maximum bandwidth ingress 、および show ip rsvp ingress が導入または変更されました。

RSVP Transport for Medianet

15.1(3)T

RSVP Transport for Medianet 機能は、クライアントのトランスポート メカニズムとして機能するように RSVP を拡張します。

この機能については、次の項に説明があります。

「RSVP でのトランスポート メカニズムのサポート」

「RSVP の設定方法」

コマンドの ip rsvp transport ip rsvp transport sender-host show ip rsvp transport show ip rsvp transport sender が導入または変更されました。