マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
L2VPN マルチセグメント擬似回線
L2VPN マルチセグメント擬似回線
発行日;2012/01/30 | 英語版ドキュメント(2011/07/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

L2VPN マルチセグメント擬似回線

機能情報の確認

目次

L2VPN マルチセグメント擬似回線の前提条件

L2VPN マルチセグメント擬似回線の制約事項

L2VPN マルチセグメント擬似回線に関する情報

L2VPN 擬似回線の定義

L2VPN マルチセグメント擬似回線の定義

マルチセグメント擬似回線の MPLS OAM サポート

L2VPN VPLS Inter-AS オプション B の MPLS OAM サポート

L2VPN マルチセグメント擬似回線の設定方法

L2VPN マルチセグメント擬似回線の設定

L2VPN マルチセグメント擬似回線の情報の表示

ping mpls および trace mpls コマンドを使用したマルチセグメント擬似回線の確認

制約事項

ping mpls および trace mpls コマンドを使用した L2VPN VPLS Inter-AS オプション B の確認

制約事項

の設定例

例:L2VPN マルチセグメント擬似回線の設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

L2VPN マルチセグメント擬似回線の機能情報

L2VPN マルチセグメント擬似回線

L2VPN マルチセグメント擬似回線機能を使用すると、複数のレイヤ 2 擬似回線セグメントを 1 つの擬似回線として機能するように設定できます。Layer 2 Virtual Private Network(L2VPN; レイヤ 2 バーチャル プライベート ネットワーク)マルチセグメント擬似回線は、同一または異なるキャリア ネットワークにある複数のコアまたは自律システムにわたります。また、L2VPN マルチセグメント擬似回線は、L2VPN Virtual Private LAN Services(VPLS; バーチャル プライベート LAN サービス)Inter-AS オプション B ネットワークでも使用されます。

このマニュアルでは、L2VPN マルチセグメント擬似回線に対する Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)の Operations, Administration, and Maintenance(OAM; 運用管理および保守)サポートおよび L2VPN VPLS Inter-AS オプション B 機能の MPLS OAM サポートについて説明します。これらの機能では、 ping mpls および trace mpls コマンドを使用して、擬似回線の接続性を確認できます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「L2VPN マルチセグメント擬似回線の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

L2VPN マルチセグメント擬似回線の前提条件

この機能を設定する前に、次のマニュアルを参照してください。

『Any Transport over MPLS』

『L2VPN Pseudowire Switching』

『MPLS LSP Ping/Traceroute for LDP/TE, and LSP Ping for VCCV』

Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP) 』(RFC 4447)

L2VPN マルチセグメント擬似回線の制約事項

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)レイヤ 2 擬似回線のみがサポートされます。

Cisco IOS Release 12.3(33)SRE では、L2VPN マルチセグメント擬似回線機能の、擬似回線のスタティック コンフィギュレーションのみがサポートされます。

Cisco IOS Release 15.1(1)S では、擬似回線のダイナミック コンフィギュレーションがサポートされ、L2VPN VPLS Inter-AS オプション B 機能に必要とされます。

Cisco IOS Release 12.3(33)SRE では、L2VPN マルチセグメント擬似回線機能の、Forwarding Equivalence Class(FEC)128 でアドバタイズされる擬似回線のみがサポートされます。FEC 129 はサポートされません。

Cisco IOS Release 15.1(1)S では、FEC 129 がサポートされ、L2VPN VPLS Inter-AS オプション B 機能の擬似回線に関する情報の交換に使用されます。

S-PE ルータは、1600 個の擬似回線に制限されます。

L2VPN マルチセグメント擬似回線に関する情報

「L2VPN 擬似回線の定義」

「L2VPN マルチセグメント擬似回線の定義」

「マルチセグメント擬似回線の MPLS OAM サポート」

「L2VPN VPLS Inter-AS オプション B の MPLS OAM サポート」

L2VPN 擬似回線の定義

図 1 に示すように、L2VPN Pseudowire(PW; 擬似回線)は、コア全体の 2 つの Provider Edge(PE; プロバイダー エッジ)ルータ間に確立されたトンネルで、MPLS データとしてカプセル化されたレイヤ 2 ペイロードを伝送します。L2VPN 擬似回線は、フレーム リレーや ATM などの従来のレイヤ 2 ネットワークの MPLS コアへのキャリアの移行に役立ちます。2 つの PE ルータ間の PW は、同一の Autonomous System(AS; 自律システム)内に配置されています。ルータ PE1 および PE2 は、Terminating PE Router(T-PE)と呼ばれます。接続回線は、これらの PE ルータの PW にバインドされています。

図 1 L2VPN 擬似回線

 

L2VPN マルチセグメント擬似回線の定義

図 2 に示すように、L2VPN Multisegment Pseudowire(MS-PW)は、1 つの PW として機能する複数の PW セグメントのセットです。スイッチド PW とも呼ばれます。MS-PW は、同一または異なるキャリア ネットワークにある複数のコアまたは自律システムにわたります。L2VPN MS-PW には、最大 254 個の PW セグメントを含めることができます。

図 2 マルチセグメント擬似回線

エンド ルータは Terminating PE Router(T-PE)と呼ばれ、スイッチング ルータは S-PE ルータと呼ばれます。S-PE ルータは、MS-PW 内の前後の PW セグメントのトンネルを終了します。S-PE ルータは、MS-PW 内の前後の PW セグメントの制御とデータ プレーンを切り替えます。MS-PW は、すべての単一セグメントの PW がアップ状態になったときにアップしたと宣言されます。詳細については、『 L2VPN Pseudowire Switching 』のマニュアルを参照してください。

Cisco IOS Release 12.2(33)SRE で導入された L2VPN マルチセグメント擬似回線機能では、擬似回線はスタティックに作成され、FEC 128 情報は、各 AS に関する情報を交換するために使用されます。

マルチセグメント擬似回線の MPLS OAM サポート

ping mpls および trace mpls コマンドを使用して、MPLS マルチセグメント擬似回線のすべてのセグメントが動作していることを確認できます。

ping mpls コマンドを使用して、次の擬似回線ポイントでの接続を確認できます。

擬似回線の一方の終端からもう一方へ

擬似回線の一方の終端から特定のセグメントへ

2 つの隣接する S-PE ルータ間のセグメント

trace mpls コマンドを使用して、次の擬似回線ポイントでの接続を確認できます。

擬似回線の一方の終端からもう一方へ

擬似回線の一方の終端から特定のセグメントへ

2 つの隣接する S-PE ルータ間のセグメント

セグメントの範囲

L2VPN VPLS Inter-AS オプション B の MPLS OAM サポート

Cisco IOS Release 15.1(1)S で導入された L2VPN VPLS Inter-AS オプション B 機能では、マルチセグメント擬似回線を使用して、異なる自律システムの Autonomous System Border Routers(ASBR; 自律システム境界ルータ)に接続します。この機能では、擬似回線はダイナミックに作成され、FEC 129 情報は、各 ASBR に関する情報を交換するために使用されます。

表 1 に、スタティック マルチセグメント擬似回線と、ダイナミック マルチセグメント擬似回線の差異のリストを示します。

表 1 スタティック マルチセグメント擬似回線とダイナミック マルチセグメント擬似回線の比較

スタティック マルチセグメント擬似回線
ダイナミック マルチセグメント擬似回線

スタティックにステッチされ、ダイナミックにシグナリングされます。

ダイナミックにステッチされ、ダイナミックにシグナリングされます。

Label Distribution Protocol(LDP; ラベル配布プロトコル)により Type Length Value(TLV; タイプ、長さ、値)および FEC 128 情報がセグメント間で交換されます。

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)により、TLV および FEC 129 情報が ASBR 間で交換されます。

L2VPN VPLS Inter-AS オプション B 機能の詳細については、『 L2VPN VPLS Inter-AS Option B 』を参照してください。

L2VPN マルチセグメント擬似回線の設定方法

ここでは、L2VPN マルチセグメント擬似回線の設定および確認作業の概要を示します。

「L2VPN マルチセグメント擬似回線の設定」(必須)

「L2VPN マルチセグメント擬似回線の情報の表示」(任意)

「ping mpls および trace mpls コマンドを使用したマルチセグメント擬似回線の確認」(任意)

L2VPN マルチセグメント擬似回線の設定

S-PE ルータで次の手順を実行して、L2VPN マルチセグメント擬似回線を作成します。

Cisco 7600 ルータ特有の手順

Cisco 7600 ルータが、S-PE または T-PE ルータに接続された最後から 2 番めのホップ ルータの場合、S-PE または T-PE ルータで次のコマンドを発行します。

mpls ldp explicit-null

no mls mpls explicit-null propagate-ttl

手順の概要

1. enable

2. configure terminal

3. mpls label protocol ldp

4. mpls ldp router-id interface force

5. pseudowire-class name

6. encapsulation mpls

7. switching tlv

8. exit

9. l2 vfi name point-to-point

10. description string

11. neighbor ip-address vcid { encapsulation mpls | pw-class pw-class-name }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls label protocol ldp

 

Router(config)# mpls label protocol ldp

すべてのインターフェイス上での Label Distribution Protocol(LDP; ラベル配布プロトコル)の使用を設定します。

ステップ 4

mpls ldp router-id interface force

 

Router(config)# mpls ldp router-id loopback0 force

LDP ルータ ID を決定するための優先インターフェイスを指定します。

ステップ 5

pseudowire-class name

 

Router(config)# pseudowire-class atom

指定する名前で擬似回線クラスを確立し、擬似回線クラス コンフィギュレーション モードを開始します。

ステップ 6

encapsulation mpls

 

Router(config-pw-class)# encapsulation mpls

トンネリングのカプセル化を指定します。

MPLS L2VPN の場合、カプセル化タイプは mpls です。

ステップ 7

switching tlv

 

Router(config-pw-class)# switching tlv

(任意)ラベル バインディングの内のスイッチング ポイントの Type-Length Variable(TLV)のアドバタイズメントをイネーブルにします。

このコマンドは、デフォルトでイネーブルにされています。

ステップ 8

exit

 

Router(config-pw-class)# exit

擬似回線クラス コンフィギュレーション モードを終了します。

ステップ 9

l2 vfi name point-to-point

 

Router(config)# l2 vfi atomtunnel point-to-point

ポイントツーポイント レイヤ 2 Virtual Forwarding Interface(VFI)を作成し、VFI コンフィギュレーション モードを開始します。

ステップ 10

description string

 

Router(config-vfi)# description segment1

マルチセグメント擬似回線のプロバイダー エッジ スイッチング ルータの説明を指定します。

ステップ 11

neighbor ip-address vcid { encapsulation mpls | pw-class pw-class-name }

 

Router(config-vfi)# neighbor 10.0.0.1 100 pw-class mpls

エミュレートされた VC を設定します。

IP アドレスおよびピア ルータの VC ID を指定します。また、エミュレートされた VC で使用する擬似回線クラスを指定します。

コマンドは 2 つのみです。

L2VPN マルチセグメント擬似回線の情報の表示

L2VPN マルチセグメント擬似回線のステータスを表示するには、次の作業を実行します。

手順の概要

1. show mpls l2transport binding

2. show mpls l2transport vc detail

手順の詳細


ステップ 1 show mpls l2transport binding

show mpls l2transport binding コマンドを使用して、擬似回線のスイッチング ポイントの情報を表示します。出力の太字で表示されている箇所を参照してください(次の例では、PE1 および PE4 が T-PE ルータです)。

Router# show mpls l2transport binding
 
Destination Address: 10.1.1.1, VC ID: 102
Local Label: 17
Cbit: 1, VC Type: Ethernet, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2], TTL [3]
CV Type: LSPV [2]
Remote Label: 16
Cbit: 1, VC Type: Ethernet, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2], TTL [3]
CV Type: LSPV [2]
PW Switching Point:
Vcid local IP addr remote IP addr Description
101 10.11.11.11 10.20.20.20 PW Switching Point PE3
100 10.20.20.20 10.11.11.11 PW Switching Point PE2

 

ステップ 2 show mpls l2transport vc detail

show mpls l2transport vc detail コマンドを使用して、擬似回線のスイッチング ポイントのステータスを表示します。次の例では、出力(太字で表示された箇所)にマルチセグメント擬似回線の障害の原因のとなったセグメントが表示されています。

Router# show mpls l2transport vc detail
 
Local interface: Se3/0 up, line protocol up, HDLC up
Destination address: 12.1.1.1, VC ID: 100, VC status: down
Output interface: Se2/0, imposed label stack {23}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:03:02, last status change time: 00:01:41
Signaling protocol: LDP, peer 10.1.1.1:0 up
Targeted Hello: 10.1.1.4(LDP Id) -> 10.1.1.1, LDP is UP
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRrd
Last local dataplane status rcvd: No fault
Last local SSS circuit status rcvd: No fault
Last local SSS circuit status sent: DOWN(PW-tx-fault)
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: DOWN(PW-tx-fault)
PW Switching Point:
Fault type Vcid local IP addr remote IP addr Description
PW-tx-fault 101 10.1.1.1 10.1.1.1 S-PE2
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 19, remote 23
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 16, send 27
byte totals: receive 2506, send 3098
packet drops: receive 0, seq error 0, send 0


 

ping mpls および trace mpls コマンドを使用したマルチセグメント擬似回線の確認

ping mpls および trace mpls コマンドを使用して、マルチセグメント擬似回線の接続を確認できます。

制約事項

IPv4 LDP または Traffic Engineering(TE; トラフィック エンジニアリング)で使用できる ping mpls および trace mpls キーワードのうち、一部は擬似回線では使用できません。

次のキーワードは、 ping mpls pseudowire コマンドでは使用できません。

dsmap

flags

force-explicit-null

output

revision

ttl

次のキーワードは、 trace mpls pseudowire コマンドでは使用できません。

flags

force-explicit-null

output

revision

ttl

手順の概要

1. ping mpls pseudowire destination-address vc-id [ segment segment-number ]

2. trace mpls pseudowire destination-address vc-id segment segment-number [ segment-number ]

手順の詳細


ステップ 1 ping mpls pseudowire destination-address vc-id [ segment segment-number ]

ここで、

destination-address は、送信元方向のセグメントの終端である、S-PE ルータのアドレスです。

vc-id は、送信元から次の PE ルータへのセグメントの VC ID です。

segment segment-number は任意で、ping を実行する対象セグメントを指定します。

次の例では、図 2 に示すトポロジを使用します。

T-PE1 から T-PE2 に対してエンドツーエンドの ping 動作を実行するには、次のコマンドを入力します。 destination-address は S-PE1 で、 vc-id は T-PE1 と S-PE1 間の VC です。

ping mpls pseudowire destination-address vc-id

T-PE1 からセグメント 2 に対して ping 動作を実行するには、次のコマンドを入力します。destination -address は S-PE1 で、 vc-id は T-PE1 と S-PE1 間の VC です。

ping mpls pseudowire destination-address vc-id segment 2

 

ステップ 2 trace mpls pseudowire destination-address vc-id segment segment-number [ segment-number ]

ここで、

destination-address はトレースの起点の次の S-PE ルータのアドレスです。

vc-id は、 trace コマンドが発行されたセグメントの VC ID です。

segment-number は、トレース動作が作用するセグメントを示します。2 つのセグメント番号を入力した場合、Traceroute 動作はその 2 つの間の範囲にあるルータに対してトレースを実行します。

次の例では、図 2 に示すトポロジを使用します。

マルチセグメント擬似回線の T-PE1 からセグメント 2 にトレース動作を実行するには、次のコマンドを入力します。 destination-address は S-PE1 で、 vc-id は T-PE1 と S-PE1 間の VC です。

trace mpls pseudowire destination-address vc-id segment 2

この例では、T-PE1 から S-PE2 に対してトレースを実行します。

セグメントの範囲に対してトレース動作を実行するには、次のコマンドを入力します。この例では、S-PE2 から T-PE2 に対してトレースを実行します。 destination-address は S-PE1 で、 vc-id は T-PE1 と S-PE1 間の VC です。

trace mpls pseudowire destination-address vc-id segment 2 4

次のコマンドは、S-PE ルータ 10.10.10.9 で、最初にセグメント 1、次にセグメント 2 に対してトレース動作を実行します。

セグメント 1 のトレース:

 
Router# trace mpls pseudowire 10.10.10.9 220 segment 1
 
Tracing MS-PW segments within range [1-1] peer address 10.10.10.9 and timeout 2 seconds
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
L 1 10.10.9.9 0 ms [Labels: 18 Exp: 0]
local 10.10.10.22 remote 10.10.10.9 vc id 220
 

セグメント 2 のトレース:

 
Router# trace mpls pseudowire 10.10.10.9 220 segment 2
 
Tracing MS-PW segments within range [1-2] peer address 10.10.10.9 and timeout 2 seconds
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
L 1 10.10.9.9 4 ms [Labels: 18 Exp: 0]
local 10.10.10.22 remote 10.10.10.9 vc id 220
 
! 2 10.10.3.3 4 ms [Labels: 16 Exp: 0]
local 10.10.10.9 remote 10.10.10.3 vc id 220


 

ping mpls および trace mpls コマンドを使用した L2VPN VPLS Inter-AS オプション B の確認

ping mpls および trace mpls コマンドを使用して、L2VPN VPLS Inter-AS Option B 機能を使用したコンフィギュレーションでのマルチセグメント擬似回線の接続を確認できます。エンドツーエンドの ping および trace 動作では、擬似回線のもう一方の終端にある T-PE ルータの宛先アドレスを入力します。

制約事項

IPv4 LDP または Traffic Engineering(TE; トラフィック エンジニアリング)で使用できる ping mpls および trace mpls キーワードのうち、一部は擬似回線では使用できません。

次のキーワードは、 ping mpls pseudowire コマンドでは使用できません。

dsmap

flags

force-explicit-null

output

revision

ttl

次のキーワードは、 trace mpls pseudowire コマンドでは使用できません。

flags

force-explicit-null

output

revision

ttl

手順の概要

1. ping mpls pseudowire destination-address vc-id [ segment segment-numbe r ]

2. trace mpls pseudowire destination-address vc-id segment segment-number [ segment-number ]

手順の詳細


ステップ 1 ping mpls pseudowire destination-address vc-id [ segment segment-number ]

ここで、

destination-address は、擬似回線のもう一方の終端にある T-PE2 ルータのアドレスです。

vc-id は、T-PE1 と S-PE1 間の VC ID です。

segment segment-number は任意で、ping を実行する対象セグメントを指定します。

次の例では、図 2 に示すトポロジを使用します。

T-PE1 から T-PE2 に対してエンドツーエンドの ping 動作を実行するには、次のコマンドを入力します。destination -address は T-PE2 で、 vc-id は T-PE1 と S-PE1 間の VC です。

ping mpls pseudowire destination-address vc-id

 

ステップ 2 trace mpls pseudowire destination-address vc-id segment segment-number [ segment-number ]

ここで、

destination-address は、擬似回線のもう一方の終端にある T-PE2 ルータのアドレスです。

vc-id は、T-PE1 と S-PE1 間の VC ID です。

segment-number は、トレース動作が作用するセグメントを示します。2 つのセグメント番号を入力した場合、Traceroute 動作はその 2 つの間の範囲にあるルータに対してトレースを実行します。

次の例では、図 2 に示すトポロジを使用します。

T-PE1 から T-PE2 に対してトレース動作を実行するには、次のコマンドを入力します。 destination-address は T-PE2 で、 vc-id は T-PE1 と S-PE1 間の VC です。

trace mpls pseudowire destination-address vc-id segment 2

この例では、T-PE1 から T-PE2 に対してトレースを実行します。

セグメントの範囲に対してトレース動作を実行するには、次のコマンドを入力します。この例では、S-PE2 から T-PE2 に対してトレースを実行します。 destination-address は S-PE1 で、 vc-id T-PE1 と S-PE1 間の VC です。

trace mpls pseudowire destination-address vc-id segment 2 4


 

L2VPN マルチセグメント擬似回線の設定例

ここでは、図 2 に示したものと類似したネットワークの設定例を示します。

「例:L2VPN マルチセグメント擬似回線の設定」

例:L2VPN マルチセグメント擬似回線の設定

次の例には、すべてのコマンドが含まれているわけではありません。設定されていないインターフェイスは、表示されていません。この例では、L2VPN マルチセグメント擬似回線 に関連する箇所は太字で示しています。

T-PE1 の設定

no ipv6 cef
multilink bundle-name authenticated
frame-relay switching
mpls traffic-eng tunnels
mpls ldp discovery targeted-hello accept
no mpls ip propagate-ttl forwarded
mpls label protocol ldp
!
policy-map exp2
!
interface Loopback0
ip address 10.131.191.252 255.255.255.255
no clns route-cache
!
interface Ethernet0/0
ip address 10.131.191.230 255.255.255.252
mpls label protocol ldp
mpls ip
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/0
ip address 10.131.159.246 255.255.255.252
shutdown
no clns route-cache
!
interface Ethernet2/0
no ip address
no cdp enable
!
interface Ethernet2/0.1
encapsulation dot1Q 1000
xconnect 10.131.191.251 333 encapsulation mpls
!
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 10.131.159.244 0.0.0.3 area 0
network 10.131.191.228 0.0.0.3 area 0
network 10.131.191.232 0.0.0.3 area 0
network 10.131.191.252 0.0.0.0 area 0
network 11.0.0.0 0.0.0.3 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
ip classless
!
no ip http server
!
mpls ldp router-id Loopback0 force
end

S-PE1 の設定

no ipv6 cef
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers
mpls ldp discovery targeted-hello accept
no mpls ip propagate-ttl forwarded
mpls label protocol ldp
!
policy-map exp2
!
l2 vfi sam-sp point-to-point
neighbor 10.131.191.252 333 encapsulation mpls
neighbor 10.131.159.251 222 encapsulation mpls
!
interface Tunnel3
ip unnumbered Loopback0
shutdown
mpls label protocol ldp
mpls accounting experimental input
mpls ip
tunnel mode mpls traffic-eng
tunnel destination 10.131.159.252
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 2 2
tunnel mpls traffic-eng bandwidth 512
tunnel mpls traffic-eng path-option 1 dynamic
no clns route-cache
service-policy output exp2
!
interface Loopback0
ip address 10.131.191.251 255.255.255.255
no clns route-cache
!
interface Ethernet0/0
ip address 10.131.191.229 255.255.255.252
mpls traffic-eng tunnels
mpls label protocol ldp
mpls ip
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/0
ip address 10.131.159.226 255.255.255.252
mpls traffic-eng tunnels
mpls ip
no clns route-cache
service-policy output exp2
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Serial2/0
ip unnumbered Loopback0
mpls ip
no fair-queue
no keepalive
serial restart-delay 0
no clns route-cache
!
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 10.131.159.224 0.0.0.3 area 0
network 10.131.191.228 0.0.0.3 area 0
network 10.131.191.251 0.0.0.0 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
ip classless
!
end

T-PE2 の設定

no ipv6 cef
no l2tp congestion-control
multilink bundle-name authenticated
frame-relay switching
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp discovery targeted-hello accept
no mpls ip propagate-ttl forwarded
mpls label protocol ldp
!
interface Loopback0
ip address 10.131.159.252 255.255.255.255
no clns route-cache
!
interface Ethernet0/0
ip address 10.131.159.230 255.255.255.252
interface Ethernet0/0
ip address 10.131.159.230 255.255.255.252
mpls traffic-eng tunnels
mpls ip
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/0
ip address 10.131.159.245 255.255.255.252
shutdown
mpls ip
no clns route-cache
!
interface Ethernet3/0.1
encapsulation dot1Q 1000
xconnect 10.131.159.251 111 encapsulation mpls
!
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 10.131.122.0 0.0.0.3 area 0
network 10.131.159.228 0.0.0.3 area 0
network 10.131.159.232 0.0.0.3 area 0
network 10.131.159.244 0.0.0.3 area 0
network 10.131.159.252 0.0.0.0 area 0
network 11.0.0.0 0.0.0.3 area 0
network 19.0.0.0 0.0.0.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
end

S-PE2 の設定

no ipv6 cef
no l2tp congestion-control
multilink bundle-name authenticated
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp discovery targeted-hello accept
no mpls ip propagate-ttl forwarded
mpls label protocol ldp
!
l2 vfi sam-sp point-to-point
neighbor 10.131.159.252 111 encapsulation mpls
neighbor 10.131.191.251 222 encapsulation mpls
!
!
interface Loopback0
ip address 10.131.159.251 255.255.255.255
!
interface Ethernet0/0
interface Ethernet0/0
ip address 10.131.159.229 255.255.255.252
mpls traffic-eng tunnels
mpls accounting experimental input
mpls ip
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/0
ip address 10.131.159.225 255.255.255.252
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 10.131.159.224 0.0.0.3 area 0
network 10.131.159.228 0.0.0.3 area 0
network 10.131.159.251 0.0.0.0 area 0
network 19.0.0.0 0.0.0.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
end

その他の参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

Cisco IOS Master Commands List, All Releases

MPLS コマンド

Cisco IOS Multiprotocol Label Switching Command Reference

レイヤ 2 VPNS

Any Transport over MPLS

L2VPN Pseudowire Switching

MPLS LSP Ping/Traceroute for LDP/TE, and LSP Ping for VCCV

L2VPN VPLS Inter-AS オプション B

L2VPN VPLS Inter-AS Option B

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

L2VPN マルチセグメント擬似回線の機能情報

表 2 に、この機能のリリース履歴を示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連のソフトウェア リリースのうち、特定の機能のサポートが初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがないかぎり、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 2 L2VPN マルチセグメント擬似回線の機能情報

機能名
リリース
機能情報

L2VPN マルチセグメント擬似回線

12.2(33)SRE

この機能を使用すると、複数のレイヤ 2 擬似回線セグメントを 1 つの擬似回線として機能するように設定できます。この機能は、同一または異なるキャリア ネットワークにある複数のコアまたは自律システムにわたります。

マルチセグメント擬似回線の MPLS OAM サポート

12.2(33)SRE

この機能では、 ping mpls および trace mpls コマンドを使用して、MPLS マルチセグメント擬似回線のすべてのセグメントが動作していることを確認できます。

L2VPN VPLS Inter-AS オプション B の MPLS OAM サポート

15.1(1)S

この機能は、マルチセグメント擬似回線機能の MPLS OAM サポートに対する拡張です。この機能では、 ping mpls および trace mpls コマンドを使用して、L2VPN VPLS Inter-AS オプション B コンフィギュレーションで使用されている擬似回線を確認できます。