マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
NSF/SSO - MPLS VPN
NSF/SSO - MPLS VPN
発行日;2012/01/31 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

NSF/SSO - MPLS VPN

目次

の前提条件

に関する制約事項

について

の機能に必要な要素

VPN プレフィクス情報のバックアップ ルート プロセッサへのチェックポイント機能

再起動中の BGP グレースフル リスタートによるプレフィクス情報の保存方法

ルータで がイネーブルでない場合の動作

の設定方法

基本的な VPN の NSF サポートの設定

前提条件

BGP をラベル配布プロトコルとして使用する MPLS VPN インターフェイスの NSF サポートの設定

前提条件

設定の確認

の設定例

基本的な MPLS VPN での :例

CE1 ルータ

PE1 ルータ

PE2 ルータ

CE2 ルータ

ISP であるカスタマー キャリアを含む CSC ネットワークの :例

CSC-CE1 の設定

CSC-PE1 の設定

CSC-PE2 の設定

CSC-CE2 の設定

MPLS VPN プロバイダーであるカスタマーを含む CSC ネットワークの :例

CE1 の設定

PE1 の設定

CSC-CE1 の設定

CSC-PE1 の設定

CSC-PE2 の設定

CSC-CE2 の設定

PE2 の設定

CE2 の設定

BGP を使用して MPLS ラベルを配布する CSC ネットワークの:例

CE1 の設定

PE1 の設定

CSC-CE1 の設定

CSC-PE1 の設定

CSC-PE2 の設定

CSC-CE2 の設定

PE2 の設定

CE2 の設定

BGP を使用してルートおよび MPLS ラベルを配布する Inter-AS ネットワークの :例

RR1 の設定

ASBR1 の設定

RR2 の設定

ASBR2 の設定

BGP を使用して非 MPLS VPN サービス プロバイダーを介してルートおよび MPLS ラベルを配布する Inter-AS ネットワークの :例

RR1 の設定

ASBR1 の設定

RR2 の設定

ASBR2 の設定

ASBR3 の設定

RR3 の設定

ASBR4 の設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

の機能情報

NSF/SSO - MPLS VPN

NSF/SSO - MPLS VPN 機能により、プライマリ Route Processor(RP; ルート プロセッサ)の再起動時に、Provider Edge(PE; プロバイダー エッジ)ルータまたは Autonomous System Border Router(ASBR; 自律システム境界ルータ)(冗長ルート プロセッサ)が、データ フォワーディング情報を Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)に保存できるようになります。この章では、次の種類の VPN など、MPLS VPN ネットワークでノンストップ フォワーディングをイネーブルにする方法について説明します。

基本的な MPLS VPN

MPLS VPN:Carrier Supporting Carrier

MPLS VPN:Carrier Supporting Carrier:IPv4 BGP ラベル配布

MPLS VPN:相互自律システム

MPLS VPN:Inter-AS:IPv4 BGP ラベル配布

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。このモジュールに記載されている機能に関するドキュメントへのリンク、および各機能がサポートされているリリースに関するリストについては、「NSF/SSO - MPLS VPNの機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

NSF/SSO - MPLS VPN の前提条件

NSF/SSO - MPLS VPN 機能の前提条件は、次のとおりです。

サポートされているハードウェアの詳細については、ご使用のプラットフォームのリリース ノートを参照してください。

Stateful Switchover(SSO; ステートフル スイッチオーバー)をイネーブルにするには、MPLS VPN Carrier Supporting Carrier 設定のコアまたは MPLS VPN ルーティングおよびフォワーディング インスタンスで LDP を使用している場合、MPLS Label Distribution Protocol(LDP; ラベル配布プロトコル)グレースフル リスタートをイネーブルにする必要があります。詳細については、「 NSF/SSO-MPLS LDP and MPLS LDP Graceful Restart 」の機能の章を参照してください。

Provider(P; プロバイダー)ルータ、PE ルータおよび Customer Edge(CE; カスタマー エッジ)ルータ間で実行するルーティング プロトコルで NSF をイネーブルにする必要があります。ルーティング プロトコルを以下に示します。

Border Gateway Protocol(BGP)

Open Shortest Path First(OSPF)

Intermediate System-to-Intermediate System(IS-IS)

Cisco ノンストップ フォワーディング サポートは、シスコ エクスプレス フォワーディングのルータで設定する必要があります。詳細については、「 Cisco Nonstop Forwarding 」の機能の章を参照してください。

NSF/SSO - MPLS VPN 機能をイネーブルにするには、サポートされている MPLS VPN ネットワーク設定が必要です。設定情報については、「 Configuring MPLS VPNs 」の機能の章を参照してください。

NSF/SSO - MPLS VPNに関する制約事項

NSF/SSO - MPLS VPN 機能には、次の制約事項があります。

Tag Distribution Protocol(TDP; タグ配布プロトコル)セッションはサポートされていません。LDP セッションだけがサポートされています。

NSF/SSO - MPLS VPN 機能では、ネイバー ネットワーキング デバイスが NSF 認識デバイスであることが必要です。ピア ルータは、NSF/SSO - MPLS VPN 対応ルータとの通信で使用されるプロトコルのグレースフル リスタートをサポートする必要があります。

NSF/SSO - MPLS VPN 機能は、Label-Controlled ATM(LC-ATM; ラベル制御 ATM)インターフェイス上では設定できません。

NSF/SSO - MPLS VPNについて

NSF/SSO - MPLS VPN を設定するには、次の概念を理解する必要があります。

「NSF/SSO - MPLS VPN の機能に必要な要素」

「VPN プレフィクス情報のバックアップ ルート プロセッサへのチェックポイント機能」

「再起動中の BGP グレースフル リスタートによるプレフィクス情報の保存方法」

「ルータで NSF/SSO - MPLS VPN がイネーブルでない場合の動作」

NSF/SSO - MPLS VPN の機能に必要な要素

VPN NSF では、いくつかの要素が機能する必要があります。

VPN NSF は、グレースフル リスタート Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)仕様および「 Cisco Nonstop Forwarding 」の機能の章で定義されている BGP グレースフル リスタート メカニズムを使用します。BGP グレースフル リスタートでは、ルータは、NSF モードで VPNv4 プレフィクスの MPLS フォワーディング エントリを作成できます。フォワーディング エントリは、再起動中に保存されます。BGP では、プレフィクスおよび対応するラベル情報を保存して、再起動後にこの情報を復元します。

NSF/SSO - MPLS VPN 機能では、コア ネットワーク(MPLS ラベル配布プロトコル、トラフィック エンジニアリングまたはスタティック ラベリング)でラベル配布プロトコルの NSF を使用します。

NSF/SSO - MPLS VPN 機能は、コア(OSPF または IS-IS)で使用される Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)の NSF を使用します。

NSF/SSO - MPLS VPN 機能は、PE およびカスタマー CE ルータ間のルーティング プロトコルの NSF を使用します。

VPN プレフィクス情報のバックアップ ルート プロセッサへのチェックポイント機能

BGP は、プレフィクスのローカル ラベルを割り当てる場合、バックアップ ルート プロセッサでバインディングするローカル ラベルをチェックポイントします。このチェックポイント機能は、アクティブ ルート プロセッサからバックアップ ルート プロセッサにステート情報をコピーします。これにより、バックアップ ルート プロセッサの情報も最新の情報になります。アクティブ ルート プロセッサで障害が発生した場合、バックアップ ルート プロセッサは、サービスが中断することなく継承できます。チェックポイントは、アクティブ ルート プロセッサが一括同期(すべてのローカル ラベル バインディングをバックアップ ルート プロセッサにコピーします)を実行するときに開始されます。この後、アクティブ ルート プロセッサは、ラベルが割り当てられる、または解放されるときに、個々のプレフィクス ラベル バインディングをダイナミックにチェックポイントします。これにより、BGP が再コンバージェンスする前に、ラベル パケットのフォワーディングを継続できます。

再起動中の BGP グレースフル リスタートによるプレフィクス情報の保存方法

BGP グレースフル リスタートが可能なルータの接続が切断されると、リスタート ルータで次のことが行われます。

1. ルータは、他のルータとの BGP セッションを確立して、グレースフル リスタート可能な他のルータから BGP ルートを再学習します。リスタート ルータは、ネイバー ルータからアップデートを受信するまで待機します。ネイバー ルータはアップデートの送信を完了したことを示す end-of-Routing Information Base(RIB; ルーティング情報ベース)マーカーを送信すると、リスタート ルータは、その独自のアップデートの送信を開始します。

2. リスタート ルータは、チェックポイント データベースにアクセスして、各プレフィクスに割り当てられたラベルを検出します。ラベルを検出すると、そのラベルをネイバー ルータにアドバタイズします。ラベルを検出しない場合、新しいラベルを割り当て、アドバタイズします。

3. リスタート ルータは、使用されなくなったエントリのタイマーの有効期限が切れると、使用されなくなったプレフィクスを削除します。

BGP グレースフル リスタートが可能なピア ルータがリスタート ルータを検出すると、次のことを行います。

1. ピア ルータは、すべてのルーティング アップデートをリスタート ルータに送信します。アップデートの送信を完了すると、ピア ルータは、end-of RIB マーカーをリスタート ルータに送信します。

2. ピア ルータは、リスタート ルータから学習した BGP ルートをすぐにはその BGP ルーティング テーブルから削除しません。リスタート ルータからプレフィクスを学習する場合、ピアは、新しいプレフィクスおよびラベル情報が古い情報と一致する場合、使用されなくなったルートをリフレッシュします。

ルータで NSF/SSO - MPLS VPN がイネーブルでない場合の動作

ルータに NSF/SSO - MPLS VPN 機能が設定されていないときに、NSF/SSO - MPLS VPN 機能が設定されているルータとの BGP セッションを確立しようとすると、これらの 2 つのルータは、通常の BGP セッションを作成しますが、NSF/SSO - MPLS VPN 機能は実行できません。

NSF/SSO - MPLS VPN の設定方法

ここでは、次の手順について説明します。

「基本的な VPN の NSF サポートの設定」(必須)

「BGP をラベル配布プロトコルとして使用する MPLS VPN インターフェイスの NSF サポートの設定」(必須)

「NSF/SSO - MPLS VPN設定の確認」(任意)

基本的な VPN の NSF サポートの設定

基本的な VPN の NSF サポートを設定するには、この作業を実行します。

前提条件

ルート プロセッサは SSO で設定する必要があります。詳細については、「 Stateful Switchover 」の機能の章を参照してください。

MPLS VPN Carrier Supporting Carrier 設定のコアまたは Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)インスタンスで LDP を使用する場合、MPLS LDP: NSF/SSO Support and Graceful Restart 機能をイネーブルにする必要があります。詳細については、「 NSF/SSO-MPLS LDP and MPLS LDP Graceful Restart 」の機能の章を参照してください。

P、PE および CE ルータ間で稼動するルーティング プロトコルでノンストップ フォワーディングをイネーブルにする必要があります。ルーティング プロトコルは、OSPF、IS-IS および BGP です。詳細については、「 Cisco Nonstop Forwarding 」の機能の章を参照してください。

NSF/SSO - MPLS VPN 機能をイネーブルにするには、サポートされている MPLS VPN ネットワーク設定が必要です。設定情報については、「 Configuring MPLS VPNs 」の機能の章を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. router bgp as - number

5. bgp graceful-restart restart-time secs

6. bgp graceful-restart stalepath-time secs

7. bgp graceful-restart

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distributed ]

 

Router(config)# ip cef distributed

シスコ エクスプレス フォワーディングをイネーブルにします。

このコマンドは、ルータのシスコ エクスプレス フォワーディングがデフォルトでイネーブルにされていない場合に使用します。

ステップ 4

router bgp as - number

 

Router(config)# router bgp 1

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。

有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 5

bgp graceful-restart restart-time secs
 
Router(config-router)# bgp graceful-restart restart-time 200

(任意)再起動後にグレースフル リスタート対応のネイバーが稼動するまで待機する最大時間を指定します。デフォルト値は 120 秒です。設定可能な値の範囲は 1 ~ 3600 秒です。

ステップ 6

bgp graceful-restart stalepath-time secs
 
Router(config-router)# bgp graceful-restart stalepath-time 400

(任意)グレースフル リスタートが実行されるピアで使用されなくなったパスを保持する最大時間を指定します。このタイマーが期限切れになると、使用されなくなったすべてのパスが削除されます。デフォルトは 360 秒です。設定可能な値の範囲は 1 ~ 3600 秒です。

ステップ 7

bgp graceful-restart
 
Router(config-router)# bgp graceful-restart

ルータでの BGP グレースフル リスタートをイネーブルにします。 bgp graceful-restart コマンドの詳細については、『 Cisco Nonstop Forwarding 』を参照してください。

ステップ 8

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

BGP をラベル配布プロトコルとして使用する MPLS VPN インターフェイスの NSF サポートの設定

次の VPN 機能では、NSF/SSO - MPLS VPN 機能用の特別な設定が必要です。

MPLS VPN:Carrier Supporting Carrier:IPv4 BGP ラベル配布

MPLS VPN:Inter-AS:IPv4 BGP ラベル配布

追加コマンド mpls forwarding bgp を、BGP を使用して MPLS ラベルおよびルートを配布するインターフェイスで実行する必要があります。次の手順を実行して、これらの MPLS VPN で NSF/SSO - MPLS VPN 機能を設定します。

前提条件

BGP をラベル配布プロトコルとして使用している Carrier Supporting Carrier(CSC)または Inter-AS で、MPLS VPN が設定されている必要があります。

まず NSF/SSO - MPLS VPN を設定します(「基本的な VPN の NSF サポートの設定」を参照してください)。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. interface slot/port

5. mpls forwarding bgp

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distributed ]

 

Router(config)# ip cef distributed

シスコ エクスプレス フォワーディングをイネーブルにします。

このコマンドは、ルータのシスコ エクスプレス フォワーディングがデフォルトでイネーブルにされていない場合に使用します。

ステップ 4

interface slot/port
 
Router(config)# interface POS1/0/0

インターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

mpls forwarding bgp
 
Router(config-if)# mpls forwarding bgp

インターフェイスで BGP ラベルを交換できるようにします。このコマンドは、BGP を使用して MPLS ラベルおよびルートを転送するように設定されている任意のインターフェイスで実行する必要があります。

NSF/SSO - MPLS VPN設定の確認

ここでは、NSF/SSO - MPLS VPN 機能を使用する設定を確認する方法について説明します。

BGP、OSPF、IS-IS の確認手順については、「 Cisco Nonstop Forwarding 」の機能の章を参照してください。

MPLS LDP:NSF/SSO 機能の確認手順については、「 NSF/SSO-MPLS LDP and MPLS LDP Graceful Restart 」の機能の章を参照してください。

Configuring MPLS VPNs 」の機能の章の確認情報を参照してください。

手順の概要

1. show ip bgp vpnv4 all labels

2. show ip bgp vpnv4 all neighbors

3. show ip bgp labels

4. show ip bgp neighbors

手順の詳細


ステップ 1 show ip bgp vpnv4 all labels

このコマンドは、各ルート識別子の着信および発信 BGP ラベルを表示します。コマンドからの出力例を、次に示します。

Router# show ip bgp vpnv4 all labels
 
Network Next Hop In label/Out label
Route Distinguisher: 100:1 (vpn1)
10.3.0.0/16 10.0.0.5 25/20
10.0.0.1 25/23
10.0.0.2 25/imp-null
10.0.0.9/32 10.0.0.1 24/22
10.0.0.2 24/imp-null
 

ステップ 2 show ip bgp vpnv4 all neighbors

このコマンドは、BGP ピアがグレースフル リスタートを実行できるかどうかを表示します。コマンドからの出力例を、次に示します。

Router# show ip bgp vpnv4 all neighbors
 
BGP neighbor is 10.0.0.1, remote AS 100, internal link
BGP version 4, remote router ID 10.0.0.1
BGP state = Established, up for 02:49:47
Last read 00:00:47, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
Address family VPNv4 Unicast: advertised and received
Graceful Restart Capabilty: advertised and received
Remote Restart timer is 120 seconds
Address families preserved by peer:
VPNv4 Unicast
.
.
.

ステップ 3 show ip bgp labels

このコマンドは、Exterior Border Gateway Protocol(EBGP; 外部ボーダー ゲートウェイ プロトコル)ルート テーブルの MPLS ラベルに関する情報を表示します。コマンドからの出力例を、次に示します。

 
Router# show ip bgp labels
 
Network Next Hop In label/Out label
10.3.0.0/16 10.0.0.1 imp-null/imp-null
0.0.0.0 imp-null/nolabel
10.0.0.9/32 10.0.0.1 21/29
10.0.0.11/32 10.0.0.1 24/38
10.0.0.13/32 0.0.0.0 imp-null/nolabel
10.0.0.15/32 10.0.0.1 29/nolabel
10.0.0.1 29/21
 

ステップ 4 show ip bgp neighbors

このコマンドは、BGP ピアがグレースフル リスタートを実行できるかどうかを表示します。コマンドからの出力例を、次に示します。

Router# show ip bgp neighbors
 
BGP neighbor is 10.0.0.1, remote AS 100, external link
BGP version 4, remote router ID 10.0.0.5
BGP state = Established, up for 02:54:19
Last read 00:00:18, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
Address family IPv4 Unicast: advertised and received
ipv4 MPLS Label capability: advertised and received
Graceful Restart Capabilty: advertised and received
Remote Restart timer is 120 seconds
Address families preserved by peer:
IPv4 Unicast
.
.
.

NSF/SSO - MPLS VPN の設定例

ここでは、6 つの設定例を示します。最初の設定例では、一般的な設定である、基本的な VPN 設定を示します。2 番め、3 番め、4 番めの設定例では、異なる CSC VPN 設定を示します。4 番めの設定例では、BGP を MPLS ラベル配布方法として使用し、 mpls forwarding bgp コマンドを必要とする CSC VPN 設定を示します。最後の 2 つの例は、Inter-AS 設定を示します。

「基本的な MPLS VPN での NSF/SSO - MPLS VPN:例」

「ISP であるカスタマー キャリアを含む CSC ネットワークの NSF/SSO - MPLS VPN:例」

「MPLS VPN プロバイダーであるカスタマーを含む CSC ネットワークの NSF/SSO - MPLS VPN:例」

「BGP を使用して MPLS ラベルを配布する CSC ネットワークのNSF/SSO - MPLS VPN:例」

「BGP を使用してルートおよび MPLS ラベルを配布する Inter-AS ネットワークの NSF/SSO - MPLS VPN:例」

「BGP を使用して非 MPLS VPN サービス プロバイダーを介してルートおよび MPLS ラベルを配布する Inter-AS ネットワークの NSF/SSO - MPLS VPN:例」

基本的な MPLS VPN での NSF/SSO - MPLS VPN:例

この例では、NSF/SSO - MPLS VPN 機能は、既存の MPLS VPN 設定でイネーブルにされます。

Cisco 7500 シリーズ ルータでの SSO のイネーブル化

次のコマンドは、Cisco 7500 シリーズ ルータで SSO をイネーブルにするときに使用されます。

hw-module slot

redundancy

mode sso

この設定例は、両方のプラットフォームで同じですが、次のコンフィギュレーション ブート コマンドが、Cisco 7500 シリーズ ルータ設定の最初にある点が例外です(Cisco 10000 シリーズ ルータ設定にはありません)。

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz

Cisco 10000 シリーズ ルータでの SSO のイネーブル化

SSO モードはデフォルトでイネーブルになっています。

Cisco 7500 シリーズおよび Cisco 10000 シリーズの両方のルータでの NSF のイネーブル化

次のコマンドは、BGP や OSPF などのルーティング プロトコルおよび BGP や LDP などのラベル配布プロトコルで NSF をイネーブルにするときに使用されます。

bgp graceful-restart restart-time

bgp graceful-restart stalepath-time

bgp graceful-restart

nsf enforce global


) この設定例では、NSF/SSO コマンドは太字で表示され、任意のプラットフォーム固有のコマンドは矢印で強調表示されています。


図 1 に、PE および CE ルータでの NSF/SSO - MPLS VPN 機能の設定を示します。

図 1 MPLS VPN:NSF/SSO での MPLS VPN 設定


) LDP は、デフォルトの MPLS ラベル プロトコルです。


次に、CE および PE ルータでの NSF/SSO - MPLS VPN 機能の設定例を示します。

CE1 ルータ

ip cef
no ip domain-lookup
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Ethernet4
ip address 10.0.0.1 255.0.0.0
media-type 10BaseT
!
router ospf 100
redistribute bgp 101
nsf enforce global
passive-interface Ethernet4
network 10.0.0.0 0.255.255.255 area 100
!
router bgp 101
no synchronization
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart network 10.0.0.0
network 10.0.0.0
neighbor 10.0.0.2 remote-as 100

PE1 ルータ

redundancy
mode sso
!
ip cef distributed
mpls ldp graceful-restart
mpls label protocol ldp
 
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
no mpls aggregate-statistics
!
interface Loopback0
ip address 10.12.12.12 255.255.255.255
!
interface Ethernet1/4 =====> interface FastEthernet1/1/4 on a Cisco 10000 series router
ip vrf forwarding vpn1
ip address 10.0.0.2 255.0.0.0
!
mpls ip
 
interface ATM3/0 =====> interface ATM3/0/0 on a Cisco 10000 series router
no ip address
!
interface ATM3/0.1 point-to-point ==> interface ATM3/0/0.1 point-to-point on a Cisco 10000
ip unnumbered Loopback0
mpls ip
!
router ospf 100
passive-interface Ethernet1/4 ===> passive-interface FastEthernet1/1/4 on a Cisco 10000
nsf enforce global
network 10.0.0.0 0.255.255.255 area 100
!
router bgp 100
no synchronization
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
 
no bgp default ipv4-unicast
neighbor 10.14.14.14 remote-as 100
neighbor 10.14.14.14 update-source Loopback0
!
address-family ipv4 vrf vpn1
neighbor 10.0.0.1 remote-as 101
neighbor 10.0.0.1 activate
exit-address-family
!
address-family vpnv4
neighbor 10.14.14.14 activate
neighbor 10.14.14.14 send-community extended
exit-address-family
 

PE2 ルータ

redundancy
mode sso
!
ip cef distributed
mpls ldp graceful-restart
mpls label protocol ldp
!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
no mpls aggregate-statistics
!
!
interface Loopback0
ip address 10.14.14.14 255.255.255.255
!
interface ATM1/0 =====> interface ATM1/0/0 on a Cisco 10000 series router
no ip address
!
interface ATM1/0.1 point-to-point ==> interface ATM1/0/0.1 point-to-point on a Cisco 10000
ip unnumbered Loopback0
mpls ip
!
interface FastEthernet3/0/0
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
ip route-cache distributed
mpls ip
!
router ospf 100
nsf enforce global
passive-interface FastEthernet3/0/0
network 10.0.0.0 0.255.255.255 area 100
!
router bgp 100
no synchronization
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no bgp default ipv4-unicast
neighbor 10.12.12.12 remote-as 100
neighbor 10.12.12.12 update-source Loopback0
!
address-family ipv4 vrf vpn1
neighbor 10.0.0.2 remote-as 102
neighbor 10.0.0.2 activate
exit-address-family
!
address-family vpnv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
exit-address-family
 

CE2 ルータ

ip cef
!
interface Loopback0
ip address 10.13.13.13 255.255.255.255
!
interface FastEthernet0
ip address 10.0.0.2 255.0.0.0
no ip mroute-cache
!
router ospf 100
redistribute bgp 102
nsf enforce global
passive-interface FastEthernet0
network 10.0.0.0 0.255.255.255 area 100
!
router bgp 102
no synchronization
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
 
network 10.0.0.0
network 10.0.0.0
neighbor 10.0.0.1 remote-as 100

ISP であるカスタマー キャリアを含む CSC ネットワークの NSF/SSO - MPLS VPN:例

この例では、MPLS VPN SSO および NSF は、既存の MPLS CSC VPN 設定で設定されます。CSC ネットワーク設定では、カスタマー キャリアは、Internet Service Provider(ISP; インターネット サービス プロバイダー)です(図 2 を参照してください)。

Cisco 7500 シリーズ ルータでの SSO のイネーブル化

次のコマンドは、Cisco 7500 シリーズ ルータで SSO をイネーブルにするときに使用されます。

hw-module slot

redundancy

mode sso

この設定例は、両方のプラットフォームで同じですが、次のコンフィギュレーション ブート コマンドが、Cisco 7500 シリーズ ルータ設定の最初にある点が例外です(Cisco 10000 シリーズ ルータ設定にはありません)。

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz

Cisco 10000 シリーズ ルータでの SSO のイネーブル化

SSO モードはデフォルトでイネーブルになっています。

Cisco 7500 シリーズおよび Cisco 10000 シリーズの両方のルータでの NSF のイネーブル化

次のコマンドは、BGP や OSPF などのルーティング プロトコルおよび BGP や LDP などのラベル配布プロトコルで NSF をイネーブルにするときに使用されます。

bgp graceful-restart restart-time

bgp graceful-restart stalepath-time

bgp graceful-restart

nsf enforce global


) この設定例では、NSF/SSO コマンドは太字で表示され、任意のプラットフォーム固有のコマンドは矢印で強調表示されています。


 

図 2 MPLS VPN:NSF および SSO での MPLS VPN CSC 設定

CSC-CE1 の設定

mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address 10.14.14.14 255.255.255.255
!
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
!
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM2/0
no ip address
!
interface ATM2/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
!
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
nsf enforce global
network 10.14.14.14 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
network 10.0.0.0 0.255.255.255 area 200

CSC-PE1 の設定

redundancy
mode sso
ip cef distributed
mpls ldp graceful-restart
mpls label protocol ldp
 
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
no mpls aggregate-statistics
!
interface Loopback0
ip address 10.11.11.11 255.255.255.255
!
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.19.19.19 255.255.255.255
!
interface ATM1/1/0
no ip address
!
interface ATM1/1/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
!
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/0/0
no ip address
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
nsf enforce global
passive-interface ATM3/0/0.1
passive-interface Loopback100
network 10.11.11.11 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
nsf enforce global
redistribute bgp 100 metric-type 1 subnets
network 10.19.19.19 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
 
timers bgp 10 30
neighbor 10.12.12.12 remote-as 100
neighbor 10.12.12.12 update-source Loopback0
!
address-family ipv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-PE2 の設定

redundancy
mode sso
ip cef distributed
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls ldp graceful-restart
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
ip address 10.12.12.12 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.20.20.20 255.255.255.255
!
interface ATM0/1/0
no ip address
!
interface ATM0/1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/0/0
no ip address
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
nsf enforce global
passive-interface ATM3/0/0.1
passive-interface Loopback100
network 10.12.12.12 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
nsf enforce global
redistribute bgp 100 metric-type 1 subnets
network 10.20.20.20 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor 10.11.11.11 remote-as 100
neighbor 10.11.11.11 update-source Loopback0
!
address-family ipv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-CE2 の設定

ip cef
!
mpls label protocol ldp
mpls ldp graceful-restart
!
interface Loopback0
ip address 10.16.16.16 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM5/0
no ip address
!
interface ATM5/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
nsf enforce global
redistribute connected subnets
network 10.16.16.16 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
network 10.0.0.0 0.255.255.255 area 200

MPLS VPN プロバイダーであるカスタマーを含む CSC ネットワークの NSF/SSO - MPLS VPN:例

図 3 に示す CSC ネットワーク設定では、カスタマー キャリアは、MPLS VPN プロバイダーです。カスタマー キャリアには 2 つのサイトがあります。バックボーン キャリアおよびカスタマー キャリアは、MPLS を使用します。internal BGP(iBGP; 内部 BGP)セッションは、ISP の外部ルーティング情報を交換します。

図 3 MPLS VPN:NSF および SSO での MPLS VPN CSC 設定 2

 

次の設定例は、CSC ネットワーク内の各ルータの設定を示しています。OSPF は、カスタマー キャリアをバックボーン キャリアに接続するために使用されるプロトコルです。NSF/SSO - MPLS VPN 機能は、既存の MPLS VPN 設定でイネーブルにされます。

Cisco 7500 シリーズ ルータでの SSO のイネーブル化

次のコマンドは、ルータで SSO をイネーブルにするときに使用されます。

hw-module slot

redundancy

mode sso

この設定例は、両方のプラットフォームで同じですが、次のコンフィギュレーション ブート コマンドが、Cisco 7500 シリーズ ルータ設定の最初にある点が例外です(Cisco 10000 シリーズ ルータ設定にはありません)。

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz

Cisco 10000 シリーズ ルータでの SSO のイネーブル化

SSO モードはデフォルトでイネーブルになっています。

Cisco 7500 シリーズおよび Cisco 10000 シリーズの両方のルータでの NSF のイネーブル化

次のコマンドは、BGP や OSPF などのルーティング プロトコルおよび BGP や LDP などのラベル配布プロトコルで NSF をイネーブルにするときに使用されます。

bgp graceful-restart restart-time

bgp graceful-restart stalepath-time

bgp graceful-restart

nsf enforce global


) この設定例では、NSF/SSO コマンドは太字で表示され、任意のプラットフォーム固有のコマンドは矢印で強調表示されています。


CE1 の設定

ip cef
!
interface Loopback0
ip address 10.17.17.17 255.255.255.255
!
interface Ethernet0/1
ip address 10.0.0.2 255.0.0.0
!
router ospf 300
log-adjacency-changes
nsf enforce global
redistribute bgp 300 subnets
passive-interface Ethernet0/1
network 10.17.17.17 0.0.0.0 area 300
!
router bgp 300
no synchronization
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
redistribute connected
redistribute ospf 300 match internal external 1 external 2
neighbor 10.0.0.1 remote-as 200
neighbor 10.0.0.1 advertisement-interval 5
no auto-summary

PE1 の設定

redundancy
mode sso
ip cef distributed
mpls ldp graceful-restart
mpls label protocol ldp
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
!
interface Loopback0
ip address 10.13.13.13 255.255.255.255
!
interface ATM1/0 =====> interface ATM1/0/0 on a Cisco 10000 series router
no ip address
!
interface ATM1/0.1 point-to-point ===> interface ATM1/0/0 point-to-point on a Cisco 10000
ip address 10.0.0.1 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface Ethernet3/0 =====> interface FastEthernet3/0/0 on a Cisco 10000 series router
ip vrf forwarding vpn2
ip address 10.0.0.1 255.0.0.0
no ip mroute-cache
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
nsf enforce global
passive-interface Ethernet3/0 ===> passive-interface FastEthernet3/0/0 on a Cisco 10000
 
network 10.13.13.13 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor 10.15.15.15 remote-as 200
neighbor 10.15.15.15 update-source Loopback0
!
address-family ipv4
neighbor 10.15.15.15 activate
neighbor 10.15.15.15 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.15.15.15 activate
neighbor 10.15.15.15 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor 10.0.0.2 remote-as 300
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 as-override
neighbor 10.0.0.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family
 

CSC-CE1 の設定

mpls label protocol ldp
mpls ldp graceful-restart
!
interface Loopback0
ip address 10.14.14.14 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM2/0
no ip address
!
interface ATM2/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
nsf enforce global
network 10.14.14.14 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
network 10.0.0.0 0.255.255.255 area 200

CSC-PE1 の設定

redundancy
mode sso
ip cef distributed
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls label protocol ldp
mpls ldp graceful-restart
no mpls aggregate-statistics
!
interface Loopback0
ip address 10.11.11.11 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.19.19.19 255.255.255.255
!
interface ATM1/1/0
no ip address
!
interface ATM1/1/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/0/0
no ip address
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
passive-interface ATM3/0/0.1
nsf enforce global
passive-interface Loopback100
network 10.11.11.11 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
nsf enforce global
redistribute bgp 100 metric-type 1 subnets
network 10.19.19.19 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 10.12.12.12 remote-as 100
neighbor 10.12.12.12 update-source Loopback0
!
address-family ipv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-PE2 の設定

redundancy
mode sso
ip cef distributed
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls label protocol ldp
mpls ldp graceful-restart
no mpls aggregate-statistics
!
interface Loopback0
ip address 10.12.12.12 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.20.20.20 255.255.255.255
!
interface ATM0/1/0
no ip address
!
interface ATM0/1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/0/0
no ip address
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
nsf enforce global
passive-interface ATM3/0/0.1
passive-interface Loopback100
network 10.12.12.12 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
nsf enforce global
redistribute bgp 100 metric-type 1 subnets
network 10.20.20.20 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 10.11.11.11 remote-as 100
neighbor 10.11.11.11 update-source Loopback0
!
address-family ipv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-CE2 の設定

ip cef
!
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address 10.16.16.16 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM5/0
no ip address
!
interface ATM5/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
nsf enforce global
network 10.16.16.16 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
network 10.0.0.0 0.255.255.255 area 200

PE2 の設定

redundancy
mode sso
ip cef distributed
ip cef accounting non-recursive
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address 10.15.15.15 255.255.255.255
!
interface Ethernet3/0 =====> interface FastEthernet3/0/0 on a Cisco 10000 series router
ip vrf forwarding vpn2
ip address 10.0.0.1 255.0.0.0
!
interface ATM5/0 =====> interface ATM5/0/0 on a Cisco 10000 series router
no ip address
!
interface ATM5/0.1 point-to-point ==> interface ATM5/0/0.1 point-to-point on a Cisco 10000
ip address 10.0.0.1 255.0.0.0
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
nsf enforce global
passive-interface Ethernet3/0 ===> passive-interface FastEthernet3/0/0 on a Cisco 10000
network 10.15.15.15 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor 10.13.13.13 remote-as 200
neighbor 10.13.13.13 update-source Loopback0
!
address-family ipv4
neighbor 10.13.13.13 activate
neighbor 10.13.13.13 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.13.13.13 activate
neighbor 10.13.13.13 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor 10.0.0.2 remote-as 300
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 as-override
neighbor 10.0.0.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

CE2 の設定

ip cef
!
interface Loopback0
ip address 10.18.18.18 255.255.255.255
!
interface Ethernet0/1
ip address 10.0.0.2 255.0.0.0
!
router ospf 300
log-adjacency-changes
nsf enforce global
redistribute bgp 300 subnets
passive-interface Ethernet0/1
network 10.18.18.18 0.0.0.0 area 300
!
router bgp 300
no synchronization
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
redistribute connected
redistribute ospf 300 match internal external 1 external 2
neighbor 10.0.0.1 remote-as 200
neighbor 10.0.0.1 advertisement-interval 5
no auto-summary

BGP を使用して MPLS ラベルを配布する CSC ネットワークのNSF/SSO - MPLS VPN:例

次の例および図 4 では、NSF/SSO - MPLS VPN 機能は、既存の MPLS VPN で設定されます。

Cisco 7500 シリーズ ルータでの SSO のイネーブル化

次のコマンドは、ルータで SSO をイネーブルにするときに使用されます。

hw-module slot

redundancy

mode sso

この設定例は、両方のプラットフォームで同じですが、次のコンフィギュレーション ブート コマンドが、Cisco 7500 シリーズ ルータ設定の最初にある点が例外です(Cisco 10000 シリーズ ルータ設定にはありません)。

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz

Cisco 10000 シリーズ ルータでの SSO のイネーブル化

SSO モードはデフォルトでイネーブルになっています。

Cisco 7500 シリーズおよび Cisco 10000 シリーズの両方のルータでの NSF のイネーブル化

次のコマンドは、BGP や OSPF などのルーティング プロトコルおよび BGP や LDP などのラベル配布プロトコルで NSF をイネーブルにするときに使用されます。

bgp graceful-restart restart-time

bgp graceful-restart stalepath-time

bgp graceful-restart

nsf enforce global

mpls forwarding bgp


) この設定例では、NSF/SSO コマンドは太字で表示され、任意のプラットフォーム固有のコマンドは矢印で強調表示されています。


この項および図 4 では、いずれも BGP/MPLS VPN サービス プロバイダーであるバックボーン キャリアおよびカスタマー キャリアの例を示します。次の例は、PE および CE ルータ間でルートおよび MPLS ラベルを配布するために BGP がどのようにイネーブルにされるかを示します。

図 4 MPLS VPN:NSF および SSO での MPLS VPN CSC 設定 3

 

図 4 では、サブネット マスクは 255.255.255.252 です。

これらのルータの特徴を次に示します。

CE1 および CE2 はエンド カスタマーに属します。CE1 ルータと CE2 ルータは、PE ルータから学習したルートを交換します。エンド カスタマーは、カスタマー キャリアから VPN サービスを購入します。

PE1 および PE2 は、MPLS VPN サービスを提供するように設定された、カスタマー キャリア ネットワークの一部です。PE1 および PE2 は、VPNv4 IBGP セッションを使用してピアリングして、MPLS VPN ネットワークを形成します。

CSC-CE1 および CSC-CE2 は、カスタマー キャリア ネットワークの一部です。CSC-CE1 ルータと CSC-CE2 ルータは、MPLS ラベルとともに IPv4 BGP アップデートを交換し、IGP(この例では OSPF)との間で送受信される PE ループバック アドレスを再配布します。カスタマー キャリアは、バックボーン キャリアから Carrier Supporting Carrier VPN サービスを購入します。

CSC-PE1 および CSC-PE2 は、Carrier Supporting Carrier VPN サービスを提供するように設定された、バックボーン キャリアのネットワークの一部です。CSC-PE1 および CSC-PE2 は、VPNv4 IP BGP セッションを使用してピアリングして、MPLS VPN ネットワークを形成します。VRF では、CSC-PE1 と CSC-PE2 は、CSC-CE ルータを使用してピアリングします。CSC-CE ルータは、IPv4 EBGP セッションを使用して、ルートとともに MPLS ラベルを伝送するように設定されています。

CE1 の設定

ip cef
interface Loopback0
ip address aa.aa.aa.aa 255.255.255.255
!
interface Ethernet3/3
ip address mm.0.0.1 255.0.0.0
!
router bgp 300
no synchronization
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
redistribute connected !Exchange routes
neighbor mm.0.0.2 remote-as 200 !learned from PE1.
neighbor mm.0.0.2 advertisement-interval 5
no auto-summary

PE1 の設定

redundancy
mode sso
ip cef distributed
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address bb.bb.bb.bb 255.255.255.255
!
interface Ethernet3/0 =====> interface FastEthernet3/0/0 on a Cisco 10000 series router
ip address nn.0.0.1 255.0.0.0
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
interface Ethernet3/3 =====> interface FastEthernet3/0/3 on a Cisco 10000 series router
ip vrf forwarding vpn2
ip address mm.0.0.2 255.0.0.0
no ip mroute-cache
!
router ospf 200
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
passive-interface Ethernet3/3 ===> passive-interface FastEthernet3/0/3 on a Cisco 10000
network bb.bb.bb.bb 0.0.0.0 area 200
network nn.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor hh.hh.hh.hh remote-as 200
neighbor hh.hh.hh.hh update-source Loopback0
!
address-family vpnv4 !VPNv4 session with PE2.
neighbor hh.hh.hh.hh activate
neighbor hh.hh.hh.hh send-community extended
bgp dampening 30
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor mm.0.0.1 remote-as 300
neighbor mm.0.0.1 activate
neighbor mm.0.0.1 as-override
neighbor mm.0.0.1 advertisement-interval 5
no auto-summary
no synchronization
bgp dampening 30
exit-address-family

CSC-CE1 の設定

ip cef
!
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address cc.cc.cc.cc 255.255.255.255
!
interface Ethernet3/0
ip address pp.0.0.1 255.0.0.0
mpls forwarding bgp
!
interface Ethernet4/0
ip address nn.0.0.2 255.0.0.0
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets !Exchange routes
redistribute bgp 200 metric 3 subnets !learned from PE1.
passive-interface ATM1/0
passive-interface Ethernet3/0
network cc.cc.cc.cc 0.0.0.0 area 200
network nn.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor pp.0.0.2 remote-as 100
neighbor pp.0.0.2 update-source Ethernet3/0
no auto-summary
!
address-family ipv4
redistribute connected
redistribute ospf 200 metric 4 match internal
neighbor pp.0.0.2 activate
neighbor pp.0.0.2 send-label
no auto-summary
no synchronization
bgp dampening 30
exit-address-family

CSC-PE1 の設定

redundancy
mode sso
ip cef distributed
!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address dd.dd.dd.dd 255.255.255.255
!
interface Ethernet3/1 =====> interface FastEthernet3/0/1 on a Cisco 10000 series router
ip vrf forwarding vpn1
ip address pp.0.0.2 255.0.0.0
mpls forwarding bgp
!
interface ATM0/1/0
no ip address
!
interface ATM0/1/0.1 point-to-point
ip unnumbered Loopback0
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
passive-interface Ethernet3/1
network dd.dd.dd.dd 0.0.0.0 area 100
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor ee.ee.ee.ee remote-as 100
neighbor ee.ee.ee.ee update-source Loopback0
!
address-family vpnv4 !VPNv4 session with CSC-PE2.
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee send-community extended
bgp dampening 30
exit-address-family
!
address-family ipv4 vrf vpn1
neighbor pp.0.0.1 remote-as 200
neighbor pp.0.0.1 activate
neighbor pp.0.0.1 as-override
neighbor pp.0.0.1 advertisement-interval 5
neighbor pp.0.0.1 send-label
no auto-summary
no synchronization
bgp dampening 30
exit-address-family

CSC-PE2 の設定

redundancy
mode sso
ip cef distributed
!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address ee.ee.ee.ee 255.255.255.255
!
interface Ethernet5/0 =====> interface FastEthernet5/0/0 on a Cisco 10000 series router
ip vrf forwarding vpn1
ip address ss.0.0.2 255.0.0.0
mpls forwarding bgp
no ip route-cache distributed
clock source internal
!
interface ATM2/1/0
no ip address
!
interface ATM2/1/0.1 point-to-point
ip unnumbered Loopback0
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
passive-interface Ethernet5/0 ====> passive-interface FastEthernet5/0/0 on a Cisco 10000
passive-interface ATM3/0/0
network ee.ee.ee.ee 0.0.0.0 area 100
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor dd.dd.dd.dd remote-as 100
neighbor dd.dd.dd.dd update-source Loopback0
!
address-family vpnv4 !VPNv4 session with CSC-PE1.
neighbor dd.dd.dd.dd activate
neighbor dd.dd.dd.dd send-community extended
bgp dampening 30
exit-address-family
!
address-family ipv4 vrf vpn1
neighbor ss.0.0.1 remote-as 200
neighbor ss.0.0.1 activate
neighbor ss.0.0.1 as-override
neighbor ss.0.0.1 advertisement-interval 5
neighbor ss.0.0.1 send-label
no auto-summary
no synchronization
bgp dampening 30
exit-address-family

CSC-CE2 の設定

ip cef
!
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address gg.gg.gg.gg 255.255.255.255
!
interface Ethernet2/2
ip address ss.0.0.2 255.0.0.0
no ip mroute-cache
mpls forwarding bgp
!
interface ATM3/1/0.1 point-to-point
ip address yy.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets !Exchange routes
redistribute bgp 200 metric 3 subnets !learned from PE2.
passive-interface ATM3/1/0.1
network gg.gg.gg.gg 0.0.0.0 area 200
network ss.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor yy.0.0.2 remote-as 100
neighbor yy.0.0.2 update-source ATM3/1/0.1
no auto-summary
!
address-family ipv4
redistribute connected
redistribute ospf 200 metric 4 match internal
neighbor yy.0.0.2 activate
neighbor yy.0.0.2 send-label
no auto-summary
no synchronization
bgp dampening 30
exit-address-family

PE2 の設定

redundancy
mode sso
ip cef distributed
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
!
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address hh.hh.hh.hh 255.255.255.255
!
interface Ethernet3/6 =====> interface FastEthernet3/0/6 on a Cisco 10000 series router
ip vrf forwarding vpn2
ip address tt.0.0.2 255.0.0.0
!
interface ATM5/0.1 point2point
ip address qq.0.0.1 255.0.0.0
no atm enable-ilmi-trap
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb update-source Loopback0
!
address-family vpnv4 !VPNv4 session with PE1.
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb send-community extended
bgp dampening 30
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor tt.0.0.1 remote-as 300
neighbor tt.0.0.1 activate
neighbor tt.0.0.1 as-override
neighbor tt.0.0.1 advertisement-interval 5
no auto-summary
no synchronization
bgp dampening 30
exit-address-family
 

CE2 の設定

ip cef
!
interface Loopback0
ip address jj.jj.jj.jj 255.255.255.255
!
interface Ethernet3/6
ip address tt.0.0.1 255.0.0.0
!
router bgp 300
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no synchronization
bgp log-neighbor-changes
timers bgp 10 30 !Exchange routes
redistribute connected !learned from PE2.
redistribute ospf 300 match internal external 1 external 2
neighbor tt.0.0.2 remote-as 200
neighbor tt.0.0.2 advertisement-interval 5
no auto-summary

BGP を使用してルートおよび MPLS ラベルを配布する Inter-AS ネットワークの NSF/SSO - MPLS VPN:例

図 5 および次の例では、NSF/SSO - MPLS VPN 機能は、既存の MPLS VPN Inter-AS 設定で設定されます。

Cisco 7500 シリーズ ルータでの SSO のイネーブル化

次のコマンドは、ルータで SSO をイネーブルにするときに使用されます。

hw-module slot

redundancy

mode sso

この設定例は、両方のプラットフォームで同じですが、次のコンフィギュレーション ブート コマンドが、Cisco 7500 シリーズ ルータ設定の最初にある点が例外です(Cisco 10000 シリーズ ルータ設定にはありません)。

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz

Cisco 10000 シリーズ ルータでの SSO のイネーブル化

SSO モードはデフォルトでイネーブルになっています。

Cisco 7500 シリーズおよび Cisco 10000 シリーズの両方のルータでの NSF のイネーブル化

次のコマンドは、BGP や OSPF などのルーティング プロトコルおよび BGP や LDP などのラベル配布プロトコルで NSF をイネーブルにするときに使用されます。

bgp graceful-restart restart-time

bgp graceful-restart stalepath-time

bgp graceful-restart

nsf enforce global

mpls forwarding bgp

IPv4 BGP ラベル配布を使用した Inter-AS では、ASBR が PE ルータの MPLS ラベルとともに IPv4 ルートを交換できるように VPN をセットアップできます。Route Reflector(RR; ルート リフレクタ)は、マルチホップ マルチプロトコル EBGP を使用して VPNv4 ルートを交換します。この設定では、ASBR にすべての VPNv4 ルートを格納する必要がなくなります。RR を使用して VPNv4 ルートを格納し、PE ルータに転送すると、スケーラビリティが改善されます。

図 5 には、2 つの MPLS VPN サービス プロバイダーが示されています。これらは、VPNv4 アドレスを RR と IPv4 ルート間で、MPLS ラベルを ASBR 間で配布します。

図 5 MPLS VPN:NSF/SSO での MPLS VPN Inter-AS 設定

図 5 に、VPNv4 ルートとリモート PE および RR の IPv4 ルートと MPLS ラベルをローカル PE および RR に配布するときに使用できる 2 つの技術を示します。

AS 100 は、ルート リフレクタを使用して、IPv4 ルートと MPLS ラベルおよび VPNv4 ルートを ASBR から PE に配布します。

AS 200 では、ASBR2 が学習した IPv4 ルートは IGP に再配布されます。


) この設定例では、NSF/SSO コマンドは太字で表示され、任意のプラットフォーム固有のコマンドは矢印で強調表示されています。


RR1 の設定

RR1 の設定例では、次のことが指定されています。

RR1 は、マルチホップ マルチプロトコル EBGP を使用して、RR2 と VPNv4 ルートを交換します。

VPNv4 ネクスト ホップ情報および VPN ラベルは、自律システム間で保存されます。

RR1 には、VPNv4 ルートが RR2 から学習した PE1、および ASBR1 から学習した IPv4 ルートおよび MPLS ラベルが反映されます。

redundancy
mode sso
ip subnet-zero
ip cef distributed
 
!
interface Loopback0
ip address aa.aa.aa.aa 255.255.255.255
!
interface Serial1/2 =======> Serial1/0/2 on a Cisco 10000 series router
ip address dd.0.0.2 255.0.0.0
clockrate 124061
!
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
network aa.aa.aa.aa 0.0.0.0 area 100
network dd.0.0.0 0.255.255.255 area 100
!
router bgp 100
bgp cluster-id 1
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor ee.ee.ee.ee remote-as 100
neighbor ee.ee.ee.ee update-source Loopback0
neighbor ww.ww.ww.ww remote-as 100
neighbor ww.ww.ww.ww update-source Loopback0
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb ebgp-multihop 255
neighbor bb.bb.bb.bb update-source Loopback0
no auto-summary
!
address-family ipv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee route-reflector-client !IPv4+labels session to PE1
neighbor ee.ee.ee.ee send-label
neighbor ww.ww.ww.ww activate
neighbor ww.ww.ww.ww route-reflector-client !IPv4+labels session to ASBR1
neighbor ww.ww.ww.ww send-label
no neighbor bb.bb.bb.bb activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee route-reflector-client !VPNv4 session with PE1
neighbor ee.ee.ee.ee send-community extended
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb next-hop-unchanged
!MH-VPNv4 session with RR2 with next hop unchanged
neighbor bb.bb.bb.bb send-community extended
exit-address-family
!
ip default-gateway 10.3.0.1
no ip classless
!
end

ASBR1 の設定

ASBR1 は、ASBR2 と IPv4 ルートおよび MPLS ラベルを交換します。

redundancy
mode sso
ip cef distributed
ip subnet-zero
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address ww.ww.ww.ww 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Ethernet0/2 =====> interface FastEthernet1/0/2 on a Cisco 10000 series router
ip address hh.0.0.2 255.0.0.0
no ip mroute-cache
mpls forwarding bgp
!
interface Ethernet0/3 =====> interface FastEthernet1/0/3 on a Cisco 10000 series router
ip address dd.0.0.1 255.0.0.0
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
passive-interface Ethernet0/2 =====> passive-interface FastEthernet1/0/2 on a Cisco 10000
network ww.ww.ww.ww 0.0.0.0 area 100
network dd.0.0.0 0.255.255.255 area 100
!
router bgp 100
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa update-source Loopback0
neighbor hh.0.0.1 remote-as 200
no auto-summary
! Redistributing IGP into BGP
! so that PE1 & RR1 loopbacks
! get into the BGP table.
address-family ipv4
redistribute ospf 10
neighbor aa.aa.aa.aa activate
neighbor aa.aa.aa.aa send-label
neighbor hh.0.0.1 activate
neighbor hh.0.0.1 advertisement-interval 5
neighbor hh.0.0.1 send-label
no auto-summary
no synchronization
exit-address-family
!
ip default-gateway 10.3.0.1
ip classless
end
 

RR2 の設定

RR2 は、マルチホップ マルチプロトコル EBGP を使用して、VPNv4 ルートと RR1 を交換します。この設定では、ネクスト ホップ情報および VPN ラベルは、自律システム間で保存されます。

ip subnet-zero
ip cef
!
interface Loopback0
ip address bb.bb.bb.bb 255.255.255.255
!
interface Serial1/1
ip address ii.0.0.2 255.0.0.0
no ip mroute-cache
!
router ospf 20
log-adjacency-changes
network bb.bb.bb.bb 0.0.0.0 area 200
network ii.0.0.0 0.255.255.255 area 200
!
router bgp 200
bgp cluster-id 1
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa ebgp-multihop 255
neighbor aa.aa.aa.aa update-source Loopback0
neighbor ff.ff.ff.ff remote-as 200
neighbor ff.ff.ff.ff update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor aa.aa.aa.aa activate
neighbor aa.aa.aa.aa next-hop-unchanged
!Multihop VPNv4 session with RR1 with next-hop unchanged
neighbor aa.aa.aa.aa send-community extended
neighbor ff.ff.ff.ff activate
neighbor ff.ff.ff.ff route-reflector-client !VPNv4 session with PE2
neighbor ff.ff.ff.ff send-community extended
exit-address-family
!
ip default-gateway 10.3.0.1
no ip classless
end

ASBR2 の設定

ASBR2 は、ASBR1 と IPv4 ルートおよび MPLS ラベルを交換します。ただし、ASBR1 とは異なり、ASBR2 は RR を使用して IPv4 ルートおよび MPLS ラベルを PE2 に反映しません。ASBR2 は、ASBR1 から学習した IPv4 ルートおよび MPLS ラベルを IGP に再配布します。PE2 は、これらのプレフィクスに到達できます。

ip subnet-zero
ip cef
!
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address xx.xx.xx.xx 255.255.255.255
!
interface Ethernet1/0
ip address hh.0.0.1 255.0.0.0
no ip mroute-cache
mpls forwarding bgp
!
interface Ethernet1/2
ip address jj.0.0.1 255.0.0.0
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 20
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
redistribute bgp 200 subnets
passive-interface Ethernet1/0
! redistributing the routes learned from ASBR1
!(EBGP+labels session) into IGP so that PE2
! will learn them
network xx.xx.xx.xx 0.0.0.0 area 200
network jj..0.0 0.255.255.255 area 200
!
router bgp 200
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb update-source Loopback0
neighbor hh.0.0.2 remote-as 100
no auto-summary
!
address-family ipv4
redistribute ospf 20
! Redistributing IGP into BGP
! so that PE2 & RR2 loopbacks
! will get into the BGP-4 table
neighbor hh.0.0.2 activate
neighbor hh.0.0.2 advertisement-interval 5
neighbor hh.0.0.2 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb send-community extended
exit-address-family
!
ip default-gateway 10.3.0.1
ip classless
!
end

BGP を使用して非 MPLS VPN サービス プロバイダーを介してルートおよび MPLS ラベルを配布する Inter-AS ネットワークの NSF/SSO - MPLS VPN:例

この例では、NSF/SSO - MPLS VPN 機能は、既存の MPLS VPN でイネーブルにされます。

Cisco 7500 シリーズ ルータでの SSO のイネーブル化

次のコマンドは、ルータで SSO をイネーブルにするときに使用されます。

hw-module slot

redundancy

mode sso

この設定例は、両方のプラットフォームで同じですが、次のコンフィギュレーション ブート コマンドが、Cisco 7500 シリーズ ルータ設定の最初にある点が例外です(Cisco 10000 シリーズ ルータ設定にはありません)。

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz

Cisco 10000 シリーズ ルータでの SSO のイネーブル化

SSO モードはデフォルトでイネーブルになっています。

Cisco 7500 シリーズおよび Cisco 10000 シリーズの両方のルータでの NSF のイネーブル化

次のコマンドは、BGP や OSPF などのルーティング プロトコルおよび BGP や LDP などのラベル配布プロトコルで NSF をイネーブルにするときに使用されます。

bgp graceful-restart restart-time

bgp graceful-restart stalepath-time

bgp graceful-restart

nsf enforce global

mpls forwarding bgp

図 6 に、非 MPLS VPN サービス プロバイダー経由で接続された 2 つの MPLS VPN サービス プロバイダーを示します。ネットワーク中間の自律システムは、LDP を使用して MPLS ラベルを配布するバックボーン自律システムとして設定されます。LDP ではなくトラフィック エンジニアリング トンネルを使用して、非 MPLS VPN サービス プロバイダーで LSP を構築することもできます。

図 6 MPLS VPN:NSF/SSO での MPLS VPN Inter-AS 設定 2


) この設定例では、NSF/SSO コマンドは太字で表示され、任意のプラットフォーム固有のコマンドは矢印で強調表示されています。


RR1 の設定

RR1 の設定例では、次のことが指定されています。

RR1 は、マルチホップ マルチプロトコル EBGP を使用して、RR2 と VPNv4 ルートを交換します。

VPNv4 ネクスト ホップ情報および VPN ラベルは、自律システム間で保存されます。

RR1 には、VPNv4 ルートが RR2 から学習した PE1、および ASBR1 から学習した IPv4 ルートおよび MPLS ラベルが反映されます。

ip subnet-zero
ip cef
!
interface Loopback0
ip address aa.aa.aa.aa 255.255.255.255
!
interface Serial1/2
ip address dd.0.0.2 255.0.0.0
clockrate 124061
!
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
network aa.aa.aa.aa 0.0.0.0 area 100
network dd.dd.0.0.0 0.255.255.255 area 100
!
router bgp 100
bgp cluster-id 1
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor ee.ee.ee.ee remote-as 100
neighbor ee.ee.ee.ee update-source Loopback0
neighbor ww.ww.ww.ww remote-as 100
neighbor ww.ww.ww.ww update-source Loopback0
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb ebgp-multihop 255
neighbor bb.bb.bb.bb update-source Loopback0
no auto-summary
!
address-family ipv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee route-reflector-client !IPv4+labels session to PE1
neighbor ee.ee.ee.ee send-label
neighbor ww.ww.ww.ww activate
neighbor ww.ww.ww.ww route-reflector-client !IPv4+labels session to ASBR1
neighbor ww.ww.ww.ww send-label
no neighbor bb.bb.bb.bb activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee route-reflector-client !VPNv4 session with PE1
neighbor ee.ee.ee.ee send-community extended
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb next-hop-unchanged
!MH-VPNv4 session with RR2 with next-hop-unchanged
neighbor bb.bb.bb.bb send-community extended
exit-address-family
!
ip default-gateway 10.3.0.1
no ip classless
!
snmp-server engineID local 00000009020000D0584B25C0
snmp-server community public RO
snmp-server community write RW
no snmp-server ifindex persist
snmp-server packetsize 2048
!
end

ASBR1 の設定

ASBR1 は、ASBR2 と IPv4 ルートおよび MPLS ラベルを交換します。

redundancy
mode sso
 
ip subnet-zero
ip cef distributed
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address ww.ww.ww.ww 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Serial3/0/0
ip address kk.0.0.2 255.0.0.0
mpls forwarding bgp
ip route-cache distributed
!
interface Ethernet0/3
ip address dd.0.0.1 255.0.0.0
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 10
log-adjacency-changes
nsf enforce global
auto-cost reference-bandwidth 1000
redistribute connected subnets
passive-interface Serial3/0/0
network ww.ww.ww.ww 0.0.0.0 area 100
network dd.0.0.0 0.255.255.255 area 100
!
router bgp 100
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa update-source Loopback0
neighbor kk.0.0.1 remote-as 200
no auto-summary
!
address-family ipv4
redistribute ospf 10 ! Redistributing IGP into BGP
neighbor aa.aa.aa.aa activate ! so that PE1 & RR1 loopbacks
neighbor aa.aa.aa.aa send-label ! get into BGP table
neighbor kk.0.0.1 activate
neighbor kk.0.0.1 advertisement-interval 5
neighbor kk.0.0.1 send-label
no auto-summary
no synchronization
exit-address-family
!
ip default-gateway 10.3.0.1
ip classless
!
end

RR2 の設定

RR2 は、マルチホップ マルチプロトコル EBGP を使用して、RR1 と VPNv4 ルートを交換します。この設定では、自律システム間でネクスト ホップ情報および VPN ラベルが保存されます。

ip subnet-zero
ip cef
!
interface Loopback0
ip address bb.bb.bb.bb 255.255.255.255
!
interface Serial1/1
ip address ii.0.0.2 255.0.0.0
no ip mroute-cache
!
router ospf 20
log-adjacency-changes
network bb.bb.bb.bb 0.0.0.0 area 200
network ii.0.0.0 0.255.255.255 area 200
!
router bgp 200
bgp cluster-id 1
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa ebgp-multihop 255
neighbor aa.aa.aa.aa update-source Loopback0
neighbor ff.ff.ff.ff remote-as 200
neighbor ff.ff.ff.ff update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor aa.aa.aa.aa activate
neighbor aa.aa.aa.aa next-hop-unchanged
!MH Vpnv4 session with RR1 with next-hop-unchanged
neighbor aa.aa.aa.aa send-community extended
neighbor ff.ff.ff.ff activate
neighbor ff.ff.ff.ff route-reflector-client !Vpnv4 session with PE2
neighbor ff.ff.ff.ff send-community extended
exit-address-family
!
ip default-gateway 10.3.0.1
no ip classless
!
end

ASBR2 の設定

ASBR2 は、ASBR1 と IPv4 ルートおよび MPLS ラベルを交換します。ただし、ASBR1 とは異なり、ASBR2 は RR を使用して IPv4 ルートおよび MPLS ラベルを PE2 に反映しません。代わりに、ASBR2 は、ASBR1 から学習した IPv4 ルートおよび MPLS ラベルを IGP に再配布します。これで、PE2 がこれらのプレフィクスに到達できるようになります。

redundancy
mode sso
ip subnet-zero
ip cef distributed
!
mpls ldp graceful-restart
mpls label protocol ldp
!
interface Loopback0
ip address xx.xx.xx.xx 255.255.255.255
!
interface Ethernet0/1 =====> interface FastEthernet1/0/1 on a Cisco 10000 series router
ip address qq.0.0.2 255.0.0.0
mpls forwarding bgp
!
interface Ethernet1/2 =====> interface FastEthernet1/1/2 on a Cisco 10000 series router
ip address jj.0.0.1 255.0.0.0
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 20
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
redistribute bgp 200 subnets
!redistributing the routes learned from ASBR4
!(EBGP+labels session) into IGP so that PE2
!will learn them
passive-interface Ethernet0/1 ====> passive-interface FastEthernet1/0/1 on a Cisco 10000
network xx.xx.xx.xx 0.0.0.0 area 200
network jj.0.0.0 0.255.255.255 area 200
!
router bgp 200
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb update-source Loopback0
neighbor qq.0.0.1 remote-as 100
no auto-summary
!
address-family ipv4
! Redistributing IGP into BGP redistribute ospf 20
! so that PE2 & RR2 loopbacks
! will get into the BGP-4 table
neighbor qq.0.0.1 activate
neighbor qq.0.0.1 advertisement-interval 5
neighbor qq.0.0.1 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb send-community extended
exit-address-family
!
ip default-gateway 10.3.0.1
ip classless
!
end

ASBR3 の設定

ASBR3 は、非 MPLS VPN サービス プロバイダーに属しています。ASBR3 は、ASBR1 との間で IPv4 ルートおよび MPLS ラベルを交換します。また、ASBR3 は、ASBR1 から学習したルートを RR3 経由で ASBR3 に渡します。


) IBGP を使用してルートおよびラベルを配布する場合は、学習した EBGP ルートを BGP に再配布しないでください。このような設定はサポートされていません。


ip subnet-zero
ip cef
!
interface Loopback0
ip address yy.yy.yy.yy 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Hssi4/0 ========> only on a Cisco 7500 series router
ip address mm.0.0.0.1 255.0.0.0 ========> only on a Cisco 7500 series router
no ip mroute-cache ========> only on a Cisco 7500 series router
mpls ip ========> only on a Cisco 7500 series router
hssi internal-clock ========> only on a Cisco 7500 series router
!
interface Serial5/0 ========> Serial5/0/0 on a Cisco 10000 series router
ip address kk.0.0.1 255.0.0.0
no ip mroute-cache
load-interval 30
clockrate 124061
mpls forwarding bgp
!
router ospf 30
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
network yy.yy.yy.yy 0.0.0.0 area 300
network mm.0.0.0 0.255.255.255 area 300 ========> only on a Cisco 7500 series router
!
router bgp 300
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor cc.cc.cc.cc remote-as 300
neighbor cc.cc.cc.cc update-source Loopback0
neighbor kk.0.0.2 remote-as 100
no auto-summary
!
address-family ipv4
neighbor cc.cc.cc.cc activate ! IBGP+labels session with RR3
neighbor cc.cc.cc.cc send-label
neighbor kk.0.0.2 activate ! EBGP+labels session with ASBR1
neighbor kk.0.0.2 advertisement-interval 5
neighbor kk.0.0.2 send-label
no auto-summary
no synchronization
exit-address-family
!
end

RR3 の設定

RR3 は、IPv4 ルートと MPLS ラベルを ASBR3 および ASBR4 に反映する非 MPLS VPN RR です。

ip subnet-zero
!
interface Loopback0
ip address cc.cc.cc.cc 255.255.255.255
!
interface POS0/2 =========> interface POS1/0/2 on a Cisco 10000 series router
ip address pp.0.0.1 255.0.0.0
no ip route-cache cef
no ip route-cache
no ip mroute-cache
crc 16
clock source internal
!
router ospf 30
log-adjacency-changes
network cc.cc.cc.cc 0.0.0.0 area 300
network pp.0.0.0 0.255.255.255 area 300
!
router bgp 300
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor zz.zz.zz.zz remote-as 300
neighbor zz.zz.zz.zz update-source Loopback0
neighbor yy.yy.yy.yy remote-as 300
neighbor yy.yy.yy.yy update-source Loopback0
no auto-summary
!
address-family ipv4
neighbor zz.zz.zz.zz activate
neighbor zz.zz.zz.zz route-reflector-client
neighbor zz.zz.zz.zz send-label ! IBGP+labels session with ASBR3
neighbor yy.yy.yy.yy activate
neighbor yy.yy.yy.yy route-reflector-client
neighbor yy.yy.yy.yy send-label ! IBGP+labels session with ASBR4
no auto-summary
no synchronization
exit-address-family
!
ip default-gateway 10.3.0.1
ip classless
!
end

ASBR4 の設定

ASBR4 は、非 MPLS VPN サービス プロバイダーに属しています。ASBR4 と ASBR3 は、RR3 経由で IPv4 ルートと MPLS ラベルを交換します。


) IBGP を使用して、ルートおよびラベルを配布する場合、学習した EBGP ルートを IBGP に再配布しないでください。このような設定はサポートされていません。


redundancy
mode sso
mpls ldp graceful-restart
ip subnet-zero
ip cef distributed
!
interface Loopback0
ip address zz.zz.zz.zz 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Ethernet0/2 =====> interface FastEthernet1/0/2 on a Cisco 10000 series router
ip address qq.0.0.1 255.0.0.0
no ip mroute-cache
mpls forwarding bgp
!
interface POS1/1/0
ip address pp.0.0.2 255.0.0.0
ip route-cache distributed
!
interface Hssi2/1/1 ========> only on a Cisco 7500 series router
ip address mm.0.0.2 255.0.0.0 ========> only on a Cisco 7500 series router
ip route-cache distributed ========> only on a Cisco 7500 series router
no ip mroute-cache ========> only on a Cisco 7500 series router
mpls label protocol ldp ========> only on a Cisco 7500 series router
mpls ip ========> only on a Cisco 7500 series router
hssi internal-clock ========> only on a Cisco 7500 series router
!
router ospf 30
log-adjacency-changes
nsf enforce global
auto-cost reference-bandwidth 1000
redistribute connected subnets
passive-interface Ethernet0/2 ====> passive-interface FastEthernet1/0/2 on a Cisco 10000
network zz.zz.zz.zz 0.0.0.0 area 300
network pp.0.0.0 0.255.255.255 area 300
network mm.0.0.0 0.255.255.255 area 300
!
router bgp 300
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 10 30
neighbor cc.cc.cc.cc remote-as 300
neighbor cc.cc.cc.cc update-source Loopback0
neighbor qq.0.0.2 remote-as 200
no auto-summary
!
address-family ipv4
neighbor cc.cc.cc.cc activate
neighbor cc.cc.cc.cc send-label
neighbor qq.0.0.2 activate
neighbor qq.0.0.2 advertisement-interval 5
neighbor qq.0.0.2 send-label
no auto-summary
no synchronization
exit-address-family
!
ip classless
end
 

その他の参考資料

ここでは、NSF/SSO - MPLS VPN 機能に関する追加情報について説明します。

関連資料

関連項目
参照先

ノンストップ フォワーディングおよび BGP グレースフル リスタート

『Cisco Nonstop Forwarding』

MPLS LDP のノンストップ フォワーディング

NSF/SSO-MPLS LDP and MPLS LDP Graceful Restart

ステートフル スイッチオーバー

『Stateful Switchover』

基本的な VPN、MPLS VPN 相互自律システム、MPLS VPN Carrier Supporting Carrier

Configuring MPLS VPNs

規格

規格
タイトル

draft-ietf-mpls-bgp-mpls-restart.txt

『Graceful Restart Mechanism for BGP with MPLS』

draft-ietf-mpls-idr-restart.txt

『Graceful Restart Mechanism for BGP』

MIB

MIB
MIB リンク

MPLS VPN MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1163

『A Border Gateway Protocol』

RFC 1164

『Application of the Border Gateway Protocol in the Internet』

RFC 2283

『Multiprotocol Extensions for BGP-4』

RFC 2547

『BGP/MPLS VPNs』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。サービス契約が有効で、ログイン ID またはパスワードを取得していない場合は、Cisco.com でまず登録手続きを行ってください。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にあるコマンド検索ツールを使用するか、または『 Cisco IOS Master Command List 』を参照してください。

mpls forwarding bgp

show ip bgp labels

show ip bgp vpnv4

NSF/SSO - MPLS VPNの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージの各サポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 NSF/SSO - MPLS VPN の機能情報

機能名
リリース
機能情報

NSF/SSO - MPLS VPN

12.2(25)S
12.2(28)SB
12.2(33)SRA
12.2(33)SXH

この機能により、プライマリ ルート プロセッサの再起動時に、Provider Edge(PE; プロバイダー エッジ)ルータまたは Autonomous System Border Router(ASBR; 自律システム境界ルータ)(冗長ルート プロセッサ)が、データ フォワーディング情報を Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)に保存できるようになります。

この機能は、12.2(25)S で Cisco 7500 シリーズ ルータに導入されました。

Cisco 10000 シリーズ ルータのサポートは、12.2(28)SB で追加されました。

Cisco 7600 シリーズ ルータのサポートは、12.2(33)SRA で追加されました。

この機能は、12.2(33)SXH でこのリリースに統合されました。