マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI
MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI
発行日;2012/01/31 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI

機能情報の確認

この章の構成

の前提条件

の制約事項

に関する情報

IPv4 と IPv6 の MPLS VPN で共通の VRF に関する概念

単一プロトコル VRF からマルチプロトコル VRF への移行

マルチプロトコル VRF 設定の特性と例

マルチプロトコル VRF 設定:単一プロトコルと非共通ポリシーを使用する例

マルチプロトコル VRF 設定:マルチプロトコルと非共通ポリシーを使用する例

マルチプロトコル VRF 設定:マルチプロトコルと共通ポリシーを使用する例

マルチプロトコル VRF 設定:マルチプロトコルと共通ポリシーおよび非共通ポリシーを使用する例

の設定方法

IPv4 および IPv6 MPLS VPN 用の VRF の設定

マルチプロトコル VRF とインターフェイスの関連付け

設定の確認

IPv4 だけの単一プロトコル VRF からマルチプロトコル VRF 設定への移行

の設定例

IPv4 および IPv6 VPN 用の VRF の設定:例

マルチプロトコル VRF とインターフェイスの関連付け:例

IPv4 だけの単一プロトコル VRF 設定からマルチプロトコル VRF 設定への移行:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

の機能情報

用語集

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI

このマニュアルでは、IPv4 および IPv6 VPN 用の Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスの設定方法、および既存の IPv4 だけの単一プロトコル VRF をマルチプロトコル VRF 設定にアップグレードする方法について説明します。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能によって、同じ VRF インスタンスで IPv4 および IPv6 VPN をイネーブルにし、単一プロトコル VRF 設定からマルチプロトコル VRF 設定への移行を簡単に実行できる Cisco IOS Command-Line Interface(CLI; コマンドライン インターフェイス)コマンドが導入されます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLIの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI の前提条件

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能の前提条件は、次のとおりです。

移行する場合は、IPv4 Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VPN VRF が存在している必要があります。

新たに VRF を設定する場合は、Provider Edge(PE; プロバイダー エッジ)ルータを含むコア内のすべてのルータで、シスコ エクスプレス フォワーディング、および Label Distribution Protocol(LDP; ラベル配布プロトコル)または MPLS Traffic Engineering(TE; トラフィック エンジニアリング)の MPLS ラベル配布方式がイネーブルになっている必要があります。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI の制約事項

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能には、次の制約事項があります。

マルチプロトコル VRF に変換したあとは、VRF を IPv4 だけの単一プロトコル VRF に再変換することができません。

1 つのインターフェイスは 1 つの VRF にだけ関連付けることができます。同じインターフェイスで、IPv4 用の VRF と、別の IPv6 用の VRF を設定することはできません。

マルチプロトコル VRF では、IPv4 および IPv6 アドレス ファミリだけを設定できます。IPX や AppleTalk などの他のプロトコルはサポートされていません。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI に関する情報

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能を使用して単一プロトコル VRF からマルチプロトコル VRF に移行する前に、次の概念を理解しておく必要があります。

「IPv4 と IPv6 の MPLS VPN で共通の VRF に関する概念」

「単一プロトコル VRF からマルチプロトコル VRF への移行」

「マルチプロトコル VRF 設定の特性と例」

IPv4 と IPv6 の MPLS VPN で共通の VRF に関する概念

IPv6 の VPN では、アドレス ファミリ、ルート識別子、ルート ターゲット、VRF 識別子など、IPv4 MPLS VPN で使用されるものと同じ VRF に関する概念が使用されます。IPv4 と IPv6 の両方の VPN を使用するカスタマーは、これらのアドレス ファミリにおいて VRF ポリシーを共有できます。IPv4 だけの単一プロトコル VRF で行うように、アドレス ファミリごとに個別に VRF ポリシーを定義するのではなく、すべてのアドレス ファミリに適用可能な VRF ポリシーを定義できます。

Cisco IOS Release 12.2(33)SRB よりも前は、VRF は IPv4 アドレス ファミリにだけ適用されました。VRF 名とルーティングおよび転送テーブルの識別子との間、VRF 名と Route Distinguisher(RD; ルート識別子)との間、VRF 名と VPN ID との間には、1 対 1 の関係がありました。この設定は、単一プロトコル VRF と呼ばれています。

Cisco IOS Release 12.2(33)SRB では、multiple Address-Family(multi-AF; 複数アドレス ファミリ)VRF 構造のサポートが導入されました。multi-AF VRF では、同じ VRF に複数のアドレス ファミリを定義できます。名前、およびポリシーのセットによって識別される特定の VRF を、IPv4 VPN と IPv6 VPN の両方に同時に適用できます。ルーティングおよび転送テーブルは IPv4 プロトコルと IPv6 プロトコルで異なりますが、特定のインターフェイスでこの VRF をアクティブにできます。この設定は、マルチプロトコル VRF と呼ばれています。

単一プロトコル VRF からマルチプロトコル VRF への移行

Cisco IOS Release 12.2(33)SRB よりも前は、IPv4 だけの単一プロトコル VRF を作成できました。単一プロトコル VRF は、 ip vrf コマンドを入力して作成していました。インターフェイスで単一プロトコル VRF をアクティブにするには、 ip vrf forwarding (インターフェイス コンフィギュレーション)コマンドを入力していました。

Cisco IOS Release 12.2(33)SRB で MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能が導入されたあとは、 vrf definition コマンドを入力してマルチプロトコル VRF を作成します。インターフェイスでマルチプロトコル VRF をアクティブにするには、 vrf forwarding コマンドを入力します。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能では、VRF 設定を単一プロトコル VRF モデルからマルチプロトコル VRF モデルに強制的に移行する vrf upgrade-cli multi-af-mode { common-policies | non-common-policies } [ vrf vrf-name ] コマンドが導入されました。

route-target ポリシーが、multi-AF VRF に設定されたすべてのアドレス ファミリに適用される場合は、 common-policies キーワードを選択します。

route-target ポリシーが、移行元である IPv4 アドレス ファミリにだけ適用される場合は、 non-common-policies キーワードを選択します。

vrf upgrade-cli コマンドを入力して設定を NVRAM に保存すると、単一プロトコル VRF 設定がマルチプロトコル VRF 設定として保存されます。アップグレード プロセスにおいて、 ip vrf コマンドが vrf definition コマンド(グローバル コンフィギュレーション コマンド)に変換され、 ip vrf forwarding コマンドが vrf forwarding コマンド(インターフェイス コンフィギュレーション コマンド)に変換されます。 vrf upgrade-cli コマンドは一度だけ実行でき、即時に処理が実行されます。

ルータには、IPv4 だけの VRF とマルチプロトコル VRF の両方を設定することができます。VRF を作成したあとは、その VRF を作成したモードのコマンドだけを使用して VRF を編集できます。たとえば、次のマルチプロトコル VRF 用のコマンドを使用して、vrf2 という名前の VRF を作成したとします。

Router# configure terminal
Enter configuration command, one per line. End with CNTL/Z
Router(config)# vrf definition vrf2
Router(config-vrf)# rd 2:2
Router(config-vrf)# route-target import 2:2
Router(config-vrf)# route-target export 2:2
Router(config-vrf)# end
 

IPv4 だけの VRF コマンドを使用して VRF vrf2 の編集を試みると、次のメッセージが表示されます。

Router# configure terminal
Enter configuration command, one per line. End with CNTL/Z
Router(config)# ip vrf vrf2
 
% Use ‘vrf definition vrf2’ command
 

また、マルチプロトコル VRF 用のコマンドを使用して IPv4 だけの VRF の編集を試みると、次のメッセージが表示されます。<vrf-name> は、IPv4 だけの VRF の名前です。

% Use ‘ip vrf <vrf-name>’ command
 

ip vrf name コマンドおよび ip vrf forwarding (インターフェイス コンフィギュレーション) name コマンドは、一定の使用猶予期間後に削除されます。古い IPv4 だけの VRF を新しいマルチプロトコル VRF 設定に移行するには、 vrf upgrade コマンドを使用します。VRF が IPv4 VPN 用であるか、IPv6 VPN 用であるか、またはその両方であるかにかかわらず、新しい VRF を作成する必要がある場合には、multi-AF 設定をサポートするマルチプロトコル VRF 用の vrf definition コマンドおよび vrf forwarding コマンドを使用します。

マルチプロトコル VRF 設定の特性と例

マルチプロトコル VRF では、同じアドレス ファミリに IPv4 VRF と IPv6 VRF の両方を設定することも、IPv4 または IPv6 アドレス ファミリのそれぞれに別々の VRF を設定することもできます。マルチプロトコル VRF 設定には、次の特性があります。

VRF 名によって VRF が識別されますが、この VRF には IPv4 と IPv6 の両方のアドレス ファミリを設定できます。同じインターフェイスで、異なる VRF 名を使用して IPv4 および IPv6 アドレス ファミリを設定することはできません。

RD、VPN ID、および Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)コンテキストは、特定の VRF の IPv4 と IPv6 の両方のアドレス ファミリによって共有されます。

address-family 設定の外部で multi-AF VRF モードに指定されたポリシー(ルート ターゲットなど)は、各アドレス ファミリに適用されるデフォルトとなります。ルート ターゲットは、アドレス ファミリの内部および外部で定義できる唯一の VRF 特性です。

マルチプロトコル VRF をインターフェイスに関連付けた場合は、次の特性も適用されます。

インターフェイスを VRF にバインドすると( vrf forwarding vrf-name コマンド)、そのインターフェイス上のすべての IPv4 および IPv6 アドレスが削除されます。

VRF を特定のインターフェイスに関連付けると、すべてのアクティブなアドレス ファミリがその VRF に属するようになります。address-family タイプのアドレスが設定されていない場合は、例外的にそのプロトコルはディセーブルになります。

VRF にバインドされたインターフェイスにアドレスを設定する場合、そのアドレス タイプに対応するアドレス ファミリが当該 VRF でアクティブである必要があります。アクティブでない場合は、まず VRF でアドレス ファミリをアクティブにする必要があるという内容のエラー メッセージが表示されます。

Cisco IOS Release 12.2(33)SRB では、単一プロトコル VRF CLI との下位互換性がサポートされています。このことは、同じルータで単一プロトコル CLI とマルチプロトコル CLI を使用できることを意味しています。ただし、同じ VRF 設定内でこれら両方を使用することはできません。

単一プロトコル CLI を使用すると、引き続き VRF 内で IPv4 アドレスを定義し、同じインターフェイスのグローバル ルーティング テーブルに IPv6 アドレスを定義できます。

次の各項では、マルチプロトコル VRF 設定の例を示します。

「マルチプロトコル VRF 設定:単一プロトコルと非共通ポリシーを使用する例」

「マルチプロトコル VRF 設定:マルチプロトコルと非共通ポリシーを使用する例」

「マルチプロトコル VRF 設定:マルチプロトコルと共通ポリシーを使用する例」

「マルチプロトコル VRF 設定:マルチプロトコルと共通ポリシーおよび非共通ポリシーを使用する例」

マルチプロトコル VRF 設定:単一プロトコルと非共通ポリシーを使用する例

次に、address-family 設定に route-target ポリシーを持つ単一プロトコル(IPv4)用のマルチプロトコル VRF 設定の例を示します。

vrf definition vrf2
rd 2:2
!
address-family ipv4
route-target export 2:2
route-target import 2:2
exit-address-family
 

RD(2:2)は、VRF vrf2 に定義されたすべてのアドレス ファミリに適用されます。

マルチプロトコル VRF 設定:マルチプロトコルと非共通ポリシーを使用する例

次に、route-target ポリシーが別々の address-family 設定に定義された、IPv4 および IPv6 VPN 用のマルチプロトコル VRF 設定の例を示します。

vrf definition vrf2
rd 2:2
!
address-family ipv4
route-target export 2:2
route-target import 2:2
exit-address-family
!
address-family ipv6
route-target export 3:3
route-target import 3:3
exit-address-family

マルチプロトコル VRF 設定:マルチプロトコルと共通ポリシーを使用する例

次に、VRF のグローバル部分に route-target ポリシーが定義された、IPv4 および IPv6 VPN 用のマルチプロトコル VRF 設定の例を示します。

vrf definition vrf2
rd 2:2
route-target export 2:2
route-target import 2:2
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
 

route-target ポリシーは、address-family 設定の外部に定義されています。したがって、ポリシーは、VRF vrf2 に定義されたすべてのアドレス ファミリに適用されます。

マルチプロトコル VRF 設定:マルチプロトコルと共通ポリシーおよび非共通ポリシーを使用する例

次に、グローバル領域と address-family 領域の両方に route-target ポリシーが定義されたマルチプロトコル VRF の例を示します。

IPv6 では、アドレス ファミリの下に route-target 定義が定義されています。これらの定義が使用され、グローバル領域の route-target 定義は無視されます。したがって、IPv6 VPN では、インポート 100:2 は無視されます。

IPv4 では、アドレス ファミリの下に route-target ポリシーは定義されていないため、グローバル定義が使用されます。

vrf definition vfr1
route-target export 100:1
route-target import 100:1
route-target import 100:2
!
address-family ipv4
exit-address-family
!
address-family ipv6
route-target export 100:1
route-target import 100:1
route-target import 100:3
exit-address-family

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI の設定方法

この機能には、マルチプロトコル VRF(同一 VRF 内における IPv4 および IPv6 VPN)の設定、および単一プロトコル VRF 設定(IPv4 だけの VRF)からマルチプロトコル VRF 設定への移行が可能な Cisco IOS CLI コマンドが備えられています。

マルチプロトコル VRF を使用すると、IPv4 と IPv6 との間でルート ターゲット ポリシー(インポートとエクスポート)を共有したり、IPv4 および IPv6 VPN に異なる route-target ポリシーを設定したりできます。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI の設定またはこの機能への移行を行うには、次の作業を実行します。

「IPv4 および IPv6 MPLS VPN 用の VRF の設定」(必須)

「マルチプロトコル VRF とインターフェイスの関連付け」(必須)

「MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 設定の確認」(任意)

単一プロトコル VRF からマルチプロトコル VRF 設定に移行するには、次の作業を実行します。

「IPv4 だけの単一プロトコル VRF からマルチプロトコル VRF 設定への移行」(任意)

IPv4 および IPv6 MPLS VPN 用の VRF の設定

IPv4 および IPv6 MPLS VPN 用の VRF を設定するには、次の作業を実行します。IPv4 VPN と IPv6 VPN の両方に対して VRF を設定する場合(マルチプロトコル VRF)、VRF 内のすべてのアドレス ファミリに適用される route-target ポリシーを設定することも、VRF 内の個別のアドレス ファミリに適用される route-target ポリシーを設定することもできます。

次に、別々の VRF アドレス ファミリに IPv4 および IPv6 VPN の route-target ポリシーが定義された VRF の設定方法を示します。

手順の概要

1. enable

2. configure termina l

3. vrf definition vrf-name

4. rd route-distinguisher

5. address-family { ipv4 | ipv6 }

6. route-target { import | export | both } route-target-ext-community

7. exit-address-family

8. address-family { ipv4 | ipv6 }

9. route-target { import | export | both } route-target-ext-community

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vrf definition vrf-name

 

Router(config)# vrf definition vrf1

VRF ルーティング テーブルを設定し、VRF コンフィギュレーション モードを開始します。

vrf-name 引数は、VRF の名前です。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 100:1

VRF のルーティング テーブルと転送テーブルを作成します。

route-distinguisher 引数では、8 バイトの値を IPv4 プレフィクスに追加して VPN IPv4 プレフィクスを作成することを指定します。ルート識別子は、次のいずれかの形式で入力できます。

16 ビット ASN:32 ビット数値
(101:3 など)

32 ビット IP アドレス:16 ビット数値
(192.168.122.15:1 など)

ステップ 5

address-family { ipv4 | ipv6 }

 

Router(config-vrf) address-family ipv4

VRF アドレス ファミリ コンフィギュレーション モードを開始して、VRF のアドレス ファミリを指定します。

ipv4 キーワードは、VRF の IPv4 アドレス ファミリを指定します。

ipv6 キーワードは、VRF の IPv6 アドレス ファミリを指定します。

ステップ 6

route-target { import | export | both } route-target-ext-community

 

Router(config-vrf-af)# route-target both 100:2

VRF 用の route-target 拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ルーティング情報のターゲット VPN 拡張コミュニティからのインポート、およびターゲット VPN 拡張コミュニティへのエクスポートの両方が行われます。

route-target-ext-community 引数により、route-target 拡張コミュニティ アトリビュートが、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 7

exit-address-family

 

Router(config-vrf-af)# exit-address-family

VRF アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 8

address-family { ipv4 | ipv6 }

 

Router(config-vrf) address-family ipv6

VRF アドレス ファミリ コンフィギュレーション モードを開始して、VRF のアドレス ファミリを指定します。

ipv4 キーワードは、VRF の IPv4 アドレス ファミリを指定します。

ipv6 キーワードは、VRF の IPv6 アドレス ファミリを指定します。

ステップ 9

route-target { import | export | both } route-target-ext-community

 

Router(config-vrf-af)# route-target both 100:3

VRF 用の route-target 拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ルーティング情報のターゲット VPN 拡張コミュニティからのインポート、およびターゲット VPN 拡張コミュニティへのエクスポートの両方が行われます。

route-target-ext-community 引数により、route-target 拡張コミュニティ アトリビュートが、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

route-target コマンドは、各ターゲット コミュニティにつき一度ずつ入力します。

ステップ 10

end

 

Router(config-vrf-af)# end

終了して、特権 EXEC モードに戻ります。

マルチプロトコル VRF とインターフェイスの関連付け

マルチプロトコル VRF をインターフェイスに関連付けるには、次の作業を実行します。VRF をインターフェイスに関連付けると、VRF がアクティブになります。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. vrf forwarding vrf-name

5. ip address ip-address mask [ secondary ]

6. ipv6 address { ipv6-address / prefix-length | prefix-name sub-bits / prefix-length }

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 0/1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 4

vrf forwarding vrf-name

 

Router(config-if)# vrf forwarding vrf1

VRF をインターフェイスまたはサブインターフェイスに関連付けます。

vrf-name 引数は、VRF の名前です。

ステップ 5

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.24.24.24 255.255.255.255

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ip-address 引数は、IP アドレスです。

mask 引数は、関連付けられた IP サブネットのマスクです。

secondary キーワードは、設定されるアドレスがセカンダリ IP アドレスであることを指定する場合に使用します。このキーワードを省略すると、設定されるアドレスはプライマリ IP アドレスになります。

ステップ 6

ipv6 address { ipv6-address / prefix-length | prefix-name sub-bits / prefix-length }

 

Router(config-if)# ipv6 address 2001:0DB8:0300:0201::/64

IPv6 の一般的なプレフィクスに基づいて IPv6 アドレスを設定し、インターフェイスにおける IPv6 処理をイネーブルにします。

ipv6-address 引数は、使用する IPv6 アドレスです。

prefix-length 引数は、IPv6 プレフィクスの長さです。これは、アドレスのうち連続する上位何ビットがプレフィクス(アドレスのネットワーク部)を構成するかを示す 10 進数値です。10 進数値の前にスラッシュ記号が必要です。

prefix-name 引数は、インターフェイスに設定するネットワークを表す上位ビットを指定する一般的なプレフィクスです。

sub-bits 引数は、 prefix-name 引数 で指定された一般的なプレフィクスによって提供されるプレフィクスに連結する、アドレスのサブプレフィクス ビットおよびホスト ビットです。

sub-bits 引数は、RFC 2373 に記載された形式で指定する必要があります。この形式では、アドレスは、16 進数値を 16 ビット単位でコロンで区切って指定します。

ステップ 7

end

 

Router(config-if) end

終了して、特権 EXEC モードに戻ります。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 設定の確認

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能の設定を確認する、つまり VRF 設定が multi-AF マルチプロトコル VRF にアップグレードされたことを表示するには、次の作業を実行します。

手順の概要

1. enable

2. show running-config vrf [ vrf-name ]

3. show vrf

4. show vrf detail [ vrf-name ]

5. exit

手順の詳細


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。プロンプトが表示されたらパスワードを入力します。例を示します。

Router> enable
Router#
 

ステップ 2 show running-config vrf [ vrf-name ]

このコマンドを使用して、multi-AF マルチプロトコル VRF 設定へのアップグレードに成功したことを確認します。次に、multi-AF マルチプロトコル VRF にアップグレードする前のコマンド出力例を示します。

Router# show running-config vrf vpn2
 
Building configuration...
 
Current configuration : 604 bytes
ip vrf vpn2
rd 1:1
route-target both 1:1
!
!
interface Loopback1
ip vrf forwarding vpn2
ip address 10.43.43.43 255.255.255.255
!
 

次に、すべてのアドレス ファミリに対して共通のポリシーを持つ multi-AF マルチプロトコル VRF へのアップグレード後のコマンド出力例を示します。

Router# show running-config vrf vpn1
 
Building configuration...
 
Current configuration : 604 bytes
vrf definition vpn1
rd 1:1
route-target both 1:1
!
address-family 1pv4
exit-address-family
!
!
interface Loopback1
ip vrf forwarding vpn1
ip address 10.43.43.43 255.255.255.255
!
 

この設定には、 vrf definition コマンドが含まれています。 ip vrf コマンドは、multi-AF マルチプロトコル VRF 設定では vrf definition コマンドに置き換えられます。

ステップ 3 show vrf

このコマンドを使用して、multi-AF マルチプロトコル VRF 設定へのアップグレードに成功したことを確認します。VRF 設定が multi-AF マルチプロトコル VRF 設定に更新されると、 show ip vrf コマンドが show vrf コマンドに置き換えられます。 show vrf コマンドによって、VRF に定義されているプロトコルが表示されます。次に、単一プロトコル VRF 設定を multi-AF マルチプロトコル VRF 設定にアップグレードしたあとのコマンド出力例を示します。

Router# show vrf vpn1
 
Name Default RD Protocols Interfaces
vpn1 1:1 ipv4 Lo1/0
 

次に、 show ip vrf vp1 コマンドの出力例を示します。この出力を show vrf vpn1 コマンドの出力と比較してください。VRF で使用されているプロトコルは表示されていません。

Router# show ip vrf vrf1
 
Name Default RD Interface
vpn1 1:1 Loopback1
 

次に、いくつかのマルチプロトコル VRF に対する show vrf コマンドの出力例を示します。これらの VRF の 1 つには、IPv4 プロトコルと IPv6 プロトコルの両方が含まれています。

Router# show vrf
 
Name Default RD Protocols Interfaces
vpn1 1:1 ipv4 Lo1/0
vpn2 100:3 ipv4 Lo23 AT3/0/0.1
vpn4 100:2 ipv4,ipv6
 

ステップ 4 show vrf detail [ vrf-name ]

このコマンドを使用して、定義されている VRF のすべての特性を表示し、設定が想定どおりであることを確認します。たとえば、VRF vpn1 の VRF 設定が次のようであるとします。

vrf definition vpn1
route-target both 100:1
route-target import 100:2
!
address-family ipv4
exit-address-family
!
address-family ipv6
route-target both 100:1
route-target import 100:3
exit-address-family
 

この場合、このコマンドによって次のように表示されます。

Router# show vrf detail vpn1
 
VRF vpn1 (VRF Id = 3); default RD <not set>; default VPNID <not set>
No interfaces
Address family ipv4 (Table ID = 3 (0x3)):
Connected addresses are not in global routing table
Export VPN route-target communities
RT:100:1
 
Import VPN route-target communities
RT:100:1 RT:100:2
 
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix
Address family ipv6 (Table ID = 503316483 (0x1E000003)):
Connected addresses are not in global routing table
Export VPN route-target communities
RT:100:1
 
Import VPN route-target communities
RT:100:1 RT:100:3
 
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix
 

ステップ 5 exit

このコマンドを使用して、ユーザ EXEC モードに戻ります。例を示します。

Router# exit
Router>
 


 

IPv4 だけの単一プロトコル VRF からマルチプロトコル VRF 設定への移行

IPv4 だけの単一プロトコル VRF からマルチプロトコル VRF 設定への移行を強制するには、次の作業を実行します。

マルチプロトコル VRF 設定では、同じ VRF に複数のアドレス ファミリを定義できます。名前、およびポリシーのセットによって識別される特定の VRF を、IPv4 VPN と IPv6 VPN の両方に同時に適用できます。ルーティングおよび転送テーブルは IPv4 プロトコルと IPv6 プロトコルで異なりますが、特定のインターフェイスでこの VRF をアクティブにできます。

手順の概要

1. enable

2. configure terminal

3. vrf upgrade-cli multi-af-mode { common-policies | non-common-policies } [ vrf vrf-name ]

4. exit

5. show running-config vrf vrf-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vrf upgrade-cli multi-af-mode { common-policies | non-common-policies } [ vrf vrf-name ]

 

Router(config)# vrf upgrade-cli multi-af-mode common-policies vrf vpn4

ルータに設定されている 1 つの VRF インスタンスまたはすべての VRF をアップグレードして、同じ VRF で複数のアドレス ファミリをサポートします。

multi-af-mode キーワードは、1 つの単一プロトコル VRF またはすべての VRF の、multi-AF 設定をサポートするマルチプロトコル VRF へのアップグレードを指定します。

common-policies キーワードは、multi-AF VRF に設定されたすべてのアドレス ファミリにポリシーが適用されるように、route-target ポリシーを VRF 設定の共通部分にコピーすることを指定します。

non-common-policies キーワードは、IPv4 だけにポリシーが適用されるように、route-target ポリシーを VRF 設定の IPv4 アドレス ファミリ部分にコピーすることを指定します。

vrf キーワードは、multi-AF VRF 設定にアップグレードする VRF を指定します。

vrf-name 引数は、multi-AF VRF 設定にアップグレードする単一プロトコル VRF の名前です。

ステップ 4

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

ステップ 5

show running-config vrf [ vrf-name ]

 

Router# show running-config vrf vpn4

特定の VRF インスタンスまたはルータに設定されているすべての VRF にリンクされている、ルータの実行コンフィギュレーションのサブセットを表示します。

vrf-name 引数は、設定を表示する VRF の名前です。

コマンドを使用できます。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI の設定例

次に、MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能に備えられている VRF CLI を使用して、単一プロトコル VRF をマルチプロトコル VRF 設定に移行する例を示します。

「IPv4 および IPv6 VPN 用の VRF の設定:例」

「マルチプロトコル VRF とインターフェイスの関連付け:例」

「IPv4 だけの単一プロトコル VRF 設定からマルチプロトコル VRF 設定への移行:例」

IPv4 および IPv6 VPN 用の VRF の設定:例

次に、IPv4 および IPv6 VPN 用の VRF を設定する例を示します。

configure terminal
!
vrf definition vrf1
rd 100:1
!
address-family ipv4
route-target both 100:2
exit-address-family
!
address-family ipv6
route-target both 100:3
exit-address-family
 

この例では、非共通ポリシーが address-family 設定に定義されています。

次に、VRF 設定のグローバル部分に共通ポリシーが定義された、IPv4 および IPv6 用の VRF の例を示します。

configure terminal
!
vrf definition vrf2
rd 200:1
route-target both 200:2
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
end

マルチプロトコル VRF とインターフェイスの関連付け:例

次に、マルチプロトコル VRF をインターフェイスに関連付ける例を示します。

configure terminal
!
interface Ethernet 0/1
vrf forwarding vrf1
ip address 10.24.24.24 255.255.255.255
ipv6 address 2001:0DB8:0300:0201::/64
end

IPv4 だけの単一プロトコル VRF 設定からマルチプロトコル VRF 設定への移行:例

ここでは、IPv4 だけの単一プロトコル VRF からマルチプロトコル VRF 設定に移行する例を示します。

次の例は、IPv4 および IPv6 用の Cisco IOS VRF CLI をルータに入力する前の IPv4 だけの単一プロトコル VRF を示しています。

ip vrf vrf1
rd 1:1
route-target both 1:1
 
interface Loopback1
ip vrf forwarding V1
ip address 10.3.3.3 255.255.255.255
 

次に、単一プロトコル VRF vrf1 のマルチプロトコル VRF 設定への移行を強制する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
!
Router(config)# vrf upgrade-cli multi-af-mode common-policies vrf vrf1
 
You are about to upgrade to the multi-AF VRF syntax commands.
You will loose any IPv6 address configured on interfaces
belonging to upgraded VRFs.
Are you sure ? [yes]: yes
 
Number of VRFs upgraded: 1
 
Router(config)# exit
 

次に、強制的に移行したあとのマルチプロトコル VRF 設定を示します。

vrf definition vrf1
rd 1:1
route-target both 1:1
!
address-family ipv4
exit-address-family
!
 
interface Loopback1
vrf forwarding V1
ip address 10.3.3.3 255.255.255.255
 
 

次に、別の multi-AF マルチプロトコル VRF 設定の例を示します。

vrf definition vrf2
rd 100:1
address family ipv6
route-target both 200:1
exit-address-family
!
ip vrf vrf1
rd 200:1
route-target both 200:1
!
interface Ethernet0/0
vrf forwarding vrf2
ip address 10.50.1.2 255.255.255.0
ipv6 address 2001:0DB8:0:1::/64
!
interface Ethernet0/1
ip vrf forwarding vrf1
ip address 10.60.1.2 255.255.255.0
ipv6 address 2001:0DB8:1 :1::/64
 

この例では、インターフェイス Ethernet0/0 に定義されているすべてのアドレス(IPv4 と IPv6)は VRF vrf2 に属しています。インターフェイス Ethernet0/1 では、IPv4 アドレスは VRF vrf1 に定義されていますが、IPv6 アドレスはグローバル IPv6 ルーティング テーブルに定義されています。

その他の参考資料

ここでは、MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI機能に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS

『MPLS Product Literature』

MPLS および MPLS VPN を設定するためのコマンド

『Cisco IOS Multiprotocol Label Switching Command Reference』

MPLS および MPLS VPN の設定作業

『Cisco IOS Multiprotocol Label Switching Configuration Guide』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1771

『A Border Gateway Protocol 4 (BGP-4)』

RFC 4364

『BGP MPLS/IP Virtual Private Networks (VPNs)』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『 Cisco IOS Master Command List, All Releases 』( http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html )にアクセスしてください。

show vrf

vrf definition

vrf forwarding

vrf upgrade-cli

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLIの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI の機能情報

機能名
リリース
機能情報

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI

12.2(33)SRB
12.2(33)SXI

このマニュアルでは、IPv4 および IPv6 VPN 用のマルチプロトコル Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスの設定方法、および既存の IPv4 だけの単一プロトコル VRF をマルチプロトコル VRF 設定にアップグレードする方法について説明します。

MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 機能によって、同じ Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VRF インスタンスで IPv4 および IPv6 VPN をイネーブルにし、単一プロトコル VRF 設定からマルチプロトコル VRF 設定への移行を簡単に実行できる Cisco IOS Command-Line Interface(CLI; コマンドライン インターフェイス)コマンドが導入されます。

12.2(33)SRB では、Cisco 7600 ルータにこの機能が導入されました。

12.2(33)SXI では、この機能が Cisco IOS Release 12.2SXI に統合されました。

この機能に関する詳細については、次の各項を参照してください。

「IPv4 と IPv6 の MPLS VPN で共通の VRF に関する概念」

「単一プロトコル VRF からマルチプロトコル VRF への移行」

「マルチプロトコル VRF 設定の特性と例」

「IPv4 および IPv6 MPLS VPN 用の VRF の設定」

「マルチプロトコル VRF とインターフェイスの関連付け」

「MPLS VPN - IPv4 および IPv6 VPN 用 VRF CLI 設定の確認」

「IPv4 だけの単一プロトコル VRF からマルチプロトコル VRF 設定への移行」

次のコマンドが導入または変更されました。 show vrf vrf definition vrf forwarding vrf upgrade-cli

用語集

6PE :IPv6 Provider Edge(プロバイダー エッジ)ルータ、または IPv6 を使用する Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Label Switching Router(LSR; ラベル スイッチング ルータ)エッジ ルータ。

6VPE :IPv6 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Provider Edge(プロバイダー エッジ)ルータ。

AF :Address Family(アドレス ファミリ)。すべてのメンバが共通のアドレッシング メカニズムを使用してエンドポイントを識別する、関連通信プロトコルのセット。プロトコル ファミリとも呼ばれます。

AFI :Address Family Identifier(アドレス ファミリ識別子)。ネットワーク アドレスに関連付けられたネットワーク レイヤ プロトコルの ID を示します。

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。自律システム間で使用されるルーティング プロトコル。このルーティング プロトコルによってインターネットが実現されています。BGP はディスタンスベクトル ルーティング プロトコルであり、接続性情報および追加の BGP アトリビュートのセットを伝送します。これらのアトリビュートによって、特定の宛先に到達するために使用する最適なルートを決定するためのポリシーのセットが機能します。BGP は RFC 1771 で定義されています。

CE :Customer Edge(カスタマー エッジ)ルータ。Virtual Private Network(VPN; バーチャル プライベート ネットワーク)カスタマー サイトに接続するサービス プロバイダー ルータ。

FIB :Forwarding Information Base(転送情報ベース)。データ パケットのスイッチングに関する情報を格納するデータベースです。FIB は、Routing Information Base(RIB; ルーティング情報ベース)の情報に基づいています。転送用にライン カードにインストールされている、選択されたルートの最適なセットです。

HA :High Availability(ハイ アベイラビリティ)。ハイ アベイラビリティは、システムが継続的に動作することとして定義されます。システムが使用可能であるためには、アプリケーション サーバ、データベース サーバ、記憶装置、エンドツーエンド ネットワークを含むすべてのコンポーネントが継続的にサービスを提供する必要があります。

IP :Internet Protocol(インターネット プロトコル)。TCP/IP スタックにおいてコネクションレス型のネットワーク間サービスを提供するネットワーク レイヤ プロトコル。IP では、アドレッシング、タイプ オブ サービス指定、フラグメンテーションと再編成、セキュリティなどの機能が提供されます。

IPv4 :IP バージョン 4。TCP/IP プロトコル スイートのネットワーク レイヤ。IPv4 はコネクションレス型のベスト エフォート パケット スイッチング プロトコルです。

IPv6 :IP バージョン 6。IPv4 の代替バージョン。IPv6 は、次世代の IP プロトコルです。IPv6 は IPv4 と下位互換性があり、データ セキュリティや最大ユーザ アドレス数などの IPv4 の弱点を克服できるように設計されています。IPv6 によってアドレス空間が 32 ビットから 128 ビットに広がるため、利用可能なネットワークやシステムの数に実質的に制限がなくなります。また、リアルタイムの音声やビデオのために、Quality of Service(QoS; サービス品質)パラメータもサポートされています。

MFI :MPLS Forwarding Infrastructure(MPLS。シスコの MPLS サブシステムでは、着信ラベルと発信ラベル、およびそれらのラベルに関連する対応パケットに関する情報を保存するための、ラベル付けに適したデータ構造を指します。

MPLS :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)。MPLS は、ネットワークを通してパケット(フレーム)を転送するための方式です。ネットワークのエッジにあるルータがラベルをパケット(フレーム)に適用できるようにします。ネットワーク コア内の ATM スイッチまたは既存のルータは、最小限のルックアップ オーバーヘッドでラベルに従ってパケットを切り替えることができます。

PE :Provider Edge(プロバイダー エッジ)ルータ。サービス プロバイダーのネットワークの一部であり、Customer Edge(CE; カスタマー エッジ)ルータに接続されたルータです。PE ルータ機能は、MLS エッジ Label Switching Router(LSR; ラベル スイッチング ルータ)の機能と、Virtual Private Network(VPN; バーチャル プライベート ネットワーク)をサポートするためのいくつかの追加機能を組み合せたものです。

RD (IPv4):Route Distinguisher(ルート識別子)。IPv4 プレフィクスに連結される 8 バイトの値で、一意の VPN IPv4(VPNv4)プレフィクスを形成します。

RD (IPv6):Route Distinguisher(ルート識別子)。IPv6 プレフィクスの先頭に付加される 64 ビットの値で、グローバルに一意な VPN-IPv6 アドレスを形成します。

RIB :Routing Information Base(ルーティング情報ベース)。Forwarding Information Base(FIB; 転送情報ベース)の選択元である、すべての使用可能なルートのセット。基本的に、RIB には、選択できる使用可能なすべてのルートが含まれています。これは、ダイナミック ルーティング プロトコルによって学習されたすべてのルート、すべての直接接続されているネットワーク(つまり、特定のルータのインターフェイスが接続されているネットワーク)、およびスタティック ルートなどのその他の設定されているすべてのルートを合せたものです。

RT :Route Target(ルート ターゲット)。プレフィクスがインポートされる Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; VPN ルーティングおよび転送)ルーティング テーブルを識別するために使用される拡張コミュニティ アトリビュート。

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。ネットワーク間のトラフィックをすべて暗号化することにより、パブリック TCP/IP ネットワーク経由でも IP トラフィックをセキュアに転送できます。VPN では、「トンネリング」が使用され、すべての情報が IP レベルで暗号化されます。

VRF :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VPN ルーティングおよび転送)インスタンス。VRF は、IP ルーティング テーブル、取得された転送テーブル、その転送テーブルを使用する一連のインターフェイス、転送テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。一般に、VRF には、PE ルータに付加されるカスタマー VPN サイトが定義されたルーティング情報が格納されています。

VRF テーブル :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスに関連付けられたルーティングおよび転送テーブル。これはカスタマー固有のテーブルであり、これにより Provider Edge(PE; プロバイダー エッジ)ルータは各カスタマーに対して独立したルーティング状態を維持できます。

 

Copyright © 2006-2011, シスコシステムズ合同会社.
All rights reserved.