マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS VPN 半二重 VRF
MPLS VPN 半二重 VRF
発行日;2012/01/31 | 英語版ドキュメント(2011/07/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS VPN 半二重 VRF

この章の構成

MPLS VPN 半二重 VRF を設定するための前提条件

MPLS VPN 半二重 VRF の制約事項

MPLS VPN 半二重 VRF の設定に関する情報

MPLS VPN 半二重 VRF 概要

アップストリーム VRF とダウンストリーム VRF

Reverse Path Forwarding チェック

MPLS VPN 半二重 VRF の設定方法

スポーク PE ルータでのアップストリーム VRF とダウンストリーム VRF の設定

VRF とインターフェイスの関連付け

AAA サーバ用のダウンストリーム VRF の設定

MPLS VPN 半二重 VRF 設定の確認

MPLS VPN 半二重 VRF の設定例

スポーク PE ルータでのアップストリーム VRF とダウンストリーム VRF の設定:例

VRF とインターフェイスの関連付け:例

MPLS VPN 半二重 VRF の設定:スタティック CE-PE ルーティングを使用した例

MPLS VPN 半二重 VRF の設定:RADIUS サーバとスタティック CE-PE ルーティングを使用した例

MPLS VPN 半二重 VRF の設定:ダイナミック CE-PE ルーティングを使用した例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS VPN 半二重 VRF の機能情報

MPLS VPN 半二重 VRF

MPLS VPN 半二重 VRF 機能では、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)サービスの加入者に対してスケーラブルなハブアンドスポーク接続が提供されます。この機能では、スポークごとに 1 つの Virtual Routing and Forwarding(VRF)は必要ないため、従来ハブアンドスポーク テクノロジーで課せられていた制約が解消されます。また、この機能では、加入者トラフィックがアップストリーム ISP 経由でリモート ネットワークにルーティングされるのか、または他のローカルやリモートの接続加入者にルーティングされるのかにかかわらず、加入者トラフィックが常にホールセール サービス プロバイダーと Internet Service Provider(ISP; インターネット サービス プロバイダー)間の中央リンクを通過することが保証されます。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「MPLS VPN 半二重 VRF の機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

MPLS VPN 半二重 VRF を設定するための前提条件

MPLS コア ネットワークが機能している必要があります。

MPLS VPN 半二重 VRF の制約事項

次の機能は、MPLS VPN 半二重 VRF 機能が設定されたインターフェイスではサポートされていません。

マルチキャスト

MPLS VPN Carrier Supporting Carrier

MPLS VPN 相互自律システム

MPLS VPN 半二重 VRF の設定に関する情報

この機能を設定するには、次の概念を理解しておく必要があります。

「MPLS VPN 半二重 VRF 概要」

「アップストリーム VRF とダウンストリーム VRF」

「Reverse Path Forwarding チェック」

Cisco 10000 シリーズ ルータにおけるこの機能の情報については、『 Cisco 10000 Series Router Broadband Aggregation, Leased-Line, and MPLS Configuration Guide 』の「Configuring Multiprotocol Label Switching」の章の「Half-Duplex VRF」の項を参照してください。

MPLS VPN 半二重 VRF 概要

MPLS VPN 半二重 VRF 機能には、次の利点があります。

MPLS VPN 半二重 VRF 機能は、スポーク Provider Edge(PE; プロバイダー エッジ)ルータでの加入者間のローカル接続を禁止し、加入者がハブ サイトに常に接続されるようにします。同じ PE ルータに接続しているすべてのサイトは、ハブ サイトを使用して、サイト間のトラフィックを転送する必要があります。これにより、スポーク サイトでのルーティングは、常にアクセス側インターフェイスからネットワーク側インターフェイスに対して、またはネットワーク側インターフェイスからアクセス側インターフェイスに対して実行されます。アクセス側インターフェイスからアクセス側インターフェイスへのルーティングは発生しません。

MPLS VPN 半二重 VRF 機能は、PE ルータにおいて、トラフィックをアップストリーム ISP に渡さずにスポーク間のスイッチングをローカルで行うことを禁止します。これにより、加入者は直接相互に接続できなくなり、ホールセール サービス プロバイダーの収益が損なわれることがなくなります。

MPLS VPN 半二重 VRF 機能では、スポークごとに 1 つの VRF という要件がなくなるため、スケーラビリティが向上します。この機能が設定されていない場合、スポークが同じ PE ルータに接続されると、スポーク間のトラフィックがホールセール サービス プロバイダーと ISP 間の中央リンクを通過するように、各スポークは異なる VRF に設定されます。ただし、この設定には拡張性がありません。多数のスポークが同じ PE ルータに接続されている場合、スポークごとに 1 つの VRF を設定すると、作業が非常に複雑になったり、メモリ使用量が大幅に増加したりします。この状況は、特に、レイヤ 3 VPN への高密度リモート アクセスをサポートする大規模ホールセール サービス プロバイダー環境で発生します。

図 1 に、サンプル ハブアンドスポーク トポロジを示します。

図 1 ハブアンドスポーク トポロジ

 

アップストリーム VRF とダウンストリーム VRF

MPLS VPN 半二重 VRF 機能では、スポークとハブ PE ルータとの間で IP トラフィックを転送するために、2 つの単一方向 VRF が使用されます。

アップストリーム VRF は、スポークからハブ PE ルータに IP トラフィックを転送します。この VRF には、通常、1 つのデフォルト ルートだけが含まれていますが、サマリー ルートや複数のデフォルト ルートが含まれる場合もあります。デフォルト ルートは、アップストリーム ISP に接続しているハブ PE ルータのインターフェイスをポイントします。ルータは、ハブ PE ルータまたはホーム ゲートウェイが送信するルーティング アップデートからデフォルト ルートの情報をダイナミックに学習します。


) 通常、アップストリーム VRF はハブに接続されますが、ローカル Domain Name System(DNS; ドメイン ネーム システム)やゲーム サーバ サービスなどの、ハブを経由する必要がない別のローカル サービス用の異なるローカル アップストリーム インターフェイスをスポーク PE に用意することもできます。


ダウンストリーム VRF は、ハブ PE ルータからのトラフィックをスポークに転送して戻します。この VRF には、次のものが含まれます。

Authentication, Authorization, and Accounting(AAA; 認証、認可、アカウンティング)サーバまたは Dynamic Host Control Protocol(DHCP)から受信した、スポークの PPP ルートおよびユーザ単位のスタティック ルート

ハブ PE ルータからインポートされたルート

スポークの Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)、Open Shortest Path First(OSPF)、Routing Information Protocol(RIP)、または Enhanced Interior Gateway Routing Protocol(EIGRP)ダイナミック ルート

スポーク PE ルータは、ダウンストリーム VRF から Multiprotocol Border Gateway Protocol(MP-BGP; マルチプロトコル ボーダー ゲートウェイ プロトコル)にルートを再配布します。このルータは、通常、接続されたスポークの MPLS コアを介してサマリー ルートをアドバタイズします。ハブ PE ルータに設定された VRF は、アドバタイズされたサマリー ルートをインポートします。

Reverse Path Forwarding チェック

Reverse Path Forwarding(RPF)チェックを行うと、IP パケットがルータに入るときに、正しいインバウンド インターフェイスを使用するようになります。MPLS VPN 半二重 VRF 機能では、スポーク側インターフェイスでのユニキャスト RPF チェックがサポートされています。ダウンストリームおよびアップストリーム転送にはそれぞれ異なる VRF が使用されるため、RPF メカニズムにより、ダウンストリーム VRF で送信元アドレス チェックが確実に行われます。

ユニキャスト RPF は、デフォルトではオンになっていません。『 Configuring Unicast Reverse Path Forwarding 』の手順に従ってイネーブルにする必要があります。

MPLS VPN 半二重 VRF の設定方法

ここでは、次の各手順について説明します。

「スポーク PE ルータでのアップストリーム VRF とダウンストリーム VRF の設定」(必須)

「VRF とインターフェイスの関連付け」(必須)

「AAA サーバ用のダウンストリーム VRF の設定」(任意)

「MPLS VPN 半二重 VRF 設定の確認」(任意)

Cisco 10000 シリーズ ルータでこの機能を設定するには、『 Cisco 10000 Series Router Broadband Aggregation, Leased-Line, and MPLS Configuration Guide 』の「Configuring Multiprotocol Label Switching」の章の「Half-Duplex VRF」の項を参照してください。

スポーク PE ルータでのアップストリーム VRF とダウンストリーム VRF の設定

PE ルータまたはスポーク PE ルータでアップストリーム VRF とダウンストリーム VRF を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure termina l

3. vrf definition vrf-name

4. rd route-distinguisher

5. address-family { ipv4 | ipv6 }

6. route-target { import | export | both } route-target-ext-community

7. exit-address-family

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vrf definition vrf-name

 

Router(config)# vrf definition vrf1

VRF ルーティング テーブルを設定し、VRF コンフィギュレーション モードを開始します。

vrf-name 引数は、VRF の名前です。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 100:1

VRF のルーティング テーブルと転送テーブルを作成します。

route-distinguisher 引数では、8 バイトの値を IPv4 プレフィクスに追加して VPN IPv4 プレフィクスを作成することを指定します。ルート識別子は、次のいずれかの形式で入力できます。

16 ビットの Autonomous System Number(ASN; 自律システム番号):32 ビットの番号
101:3 など。

32 ビットの IP アドレス:16 ビットの番号
192.168.122.15:1 など。

ステップ 5

address-family { ipv4 | ipv6 }

 

Router(config-vrf) address-family ipv4

VRF アドレス ファミリ コンフィギュレーション モードを開始して、VRF のアドレス ファミリを指定します。

ipv4 キーワードは、VRF の IPv4 アドレス ファミリを指定します。

ipv6 キーワードは、VRF の IPv6 アドレス ファミリを指定します。

(注) MPLS VPN 半二重 VRF 機能では、IPv4 アドレス ファミリだけがサポートされています。

ステップ 6

route-target { import | export | both } route-target-ext-community

 

Router(config-vrf-af)# route-target both 100:2

VRF 用の route-target 拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ルーティング情報のターゲット VPN 拡張コミュニティからのインポート、およびターゲット VPN 拡張コミュニティへのエクスポートの両方が行われます。

route-target-ext-community 引数により、route-target 拡張コミュニティ アトリビュートが、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 7

exit-address-family

 

Router(config-vrf-af)# exit-address-family

VRF アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 8

end

 

Router(config-vrf-af)# end

終了して、特権 EXEC モードに戻ります。

VRF とインターフェイスの関連付け

VRF をインターフェイスに関連付けて、VRF をアクティブにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. vrf forwarding vrf-name

5. ip address ip-address mask [ secondary ]

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 0/1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 4

vrf forwarding vrf-name [ downstream vrf2 ]

 

Router(config-if)# vrf forwarding vrf1

VRF をインターフェイスまたはサブインターフェイスに関連付けます。

vrf-name 引数は、VRF の名前です。

downstream vrf2 は、ピア ルートおよびユーザ単位ルートがインストールされるダウンストリーム VRF の名前です。

ステップ 5

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.24.24.24 255.255.255.255

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ip-address 引数は、IP アドレスです。

mask 引数は、関連付けられた IP サブネットのマスクです。

secondary キーワードは、設定されるアドレスがセカンダリ IP アドレスであることを指定する場合に使用します。このキーワードを省略すると、設定されるアドレスはプライマリ IP アドレスになります。

ステップ 6

end

 

Router(config-if) end

終了して、特権 EXEC モードに戻ります。

AAA サーバ用のダウンストリーム VRF の設定

ブロードバンドまたはリモート アクセス環境において AAA(RADIUS)サーバ用のダウンストリーム VRF を設定するには、次のシスコ アトリビュート値を入力します。

lcp:interface-config=ip vrf forwarding U downstream D

標準 VPN 環境においては、代わりに次のシスコ アトリビュート値を入力します。

ip:vrf-id=U downstream D

MPLS VPN 半二重 VRF 設定の確認

AAA サーバ用のダウンストリーム VRF 設定を確認するには、次の手順を実行します。

手順の概要

1. show vrf [ brief | detail | id | interfaces | lock | select ] [ vrf-name ]

2. show ip route vrf vrf-name

3. show running-config [ interface type number ]

手順の詳細


ステップ 1 show vrf [ brief | detail | id | interfaces | lock | select ] [ vrf-name ]

このコマンドを使用して、関連付けられている各インターフェイスまたは VAI のダウンストリーム VRF を含む、ルータで設定されているすべての VRF に関する情報を表示します。

Router# show vrf
 
Name Default RD Interfaces
Down 100:1 POS3/0/3 [D]
POS3/0/1 [D]
100:3 Loopback2
Virtual-Access3 [D]
Virtual-Access4 [D]
Up 100:2 POS3/0/3
POS3/0/1
100:4 Virtual-Access3
 

show vrf detail vrf-name

このコマンドを使用して、VRF に関連付けられているすべてのインターフェイス、サブインターフェイス、および VAI を含む、指定した VRF に関する詳細情報を表示します。

vrf-name 引数の値を指定しなかった場合は、ルータに設定されているすべての VRF に関する詳細情報が表示されます。

次に、ブロードバンドまたはリモート アクセス環境において、vrf1 と呼ばれる VRF の詳細情報を表示する例を示します。

Router# show vrf detail vrf1
 
VRF D; default RD 2:0; default VPNID <not set>
Interfaces:
Loopback2 Virtual-Access3 [D] Virtual-Access4 [D]
Connected addresses are not in global routing table
Export VPN route-target communities
RT:2:0
Import VPN route-target communities
RT:2:1
No import route-map
No export route-map
VRF U; default RD 2:1; default VPNID <not set>
Interfaces:
Virtual-Access3 Virtual-Access4
Connected addresses are not in global routing table
No Export VPN route-target communities
Import VPN route-target communities
RT:2:1
No import route-map
No export route-map
 

次に、標準 VPN 環境において VRF 詳細を表示する例を示します。

Router# show vrf detail
 
VRF Down; default RD 100:1; default VPNID <not set> VRF Table ID = 1
Description: import only from hub-pe
Interfaces:
Pos3/0/3 [D] Pos3/0/1:0.1 [D]
Connected addresses are not in global routing table
Export VPN route-target communities
RT:100:0
Import VPN route-target communities
RT:100:1
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF Up; default RD 100:2; default VPNID <not set> VRF Table ID = 2
Interfaces:
Pos3/0/1 Pos3/0/3
Connected addresses are not in global routing table
No Export VPN route-target communities
Import VPN route-target communities
RT:100:1
No import route-map
No export route-map
VRF label distribution protocol: not configured
 

ステップ 2 show ip route vrf vrf-name

このコマンドを使用して、指定した VRF の IP ルーティング テーブル、およびダウンストリーム VRF にインストールされているユーザ単位ルートに関する情報を表示します。

次に、ブロードバンドまたはリモート アクセス環境において、D と呼ばれるダウンストリーム VRF のルーティング テーブルを表示する例を示します。

Router# show ip route vrf D
 
Routing Table: D
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS interarea
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
U 10.0.0.2/32 [1/0] via 10.0.0.1
S 10.0.0.0/8 is directly connected, Null0
U 10.0.0.5/32 [1/0] via 10.0.0.2
C 10.8.1.2/32 is directly connected, Virtual-Access4
C 10.8.1.1/32 is directly connected, Virtual-Access3
 

次に、標準 VPN 環境において、Down と呼ばれるダウンストリーム VRF のルーティング テーブルを表示する例を示します。

Router# show ip route vrf Down
 
Routing Table: Down
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is 10.13.13.13 to network 0.0.0.0
 
C 10.2.0.0/8 is directly connected, Pos3/0/3
10.3.0.0/32 is subnetted, 1 subnets
B 10.4.16.16 [200/0] via 10.13.13.13, 1w3d
B 10.6.0.0/8 [200/0] via 10.13.13.13, 1w3d
C 10.0.0.0/8 is directly connected, Pos3/0/1
10.7.0.0/16 is subnetted, 1 subnets
B 10.7.0.0 [20/0] via 10.0.0.2, 1w3d
10.0.6.0/32 is subnetted, 1 subnets
B 10.0.6.14 [20/0] via 10.0.0.2, 1w3d
10.8.0.0/32 is subnetted, 1 subnets
B 10.8.15.15 [20/0] via 10.0.0.2, 1w3d
B* 0.0.0.0/0 [200/0] via 10.0.0.13, 1w3d

 

次に、ブロードバンドまたはリモート アクセス環境において、U と呼ばれるアップストリーム VRF のルーティング テーブルを表示する例を示します。

Router# show ip route vrf U
 
Routing Table: U
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS interarea
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is 192.168.0.20 to network 0.0.0.0
 
10.0.0.0/32 is subnetted, 1 subnets
C 10.0.0.8 is directly connected, Loopback2
B* 0.0.0.0/0 [200/0] via 192.168.0.20, 1w5d
 

次に、標準 VPN 環境において、Up と呼ばれるアップストリーム VRF のルーティング テーブルを表示する例を示します。

Router# show ip route vrf Up
 
Routing Table: Up
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is 10.13.13.13 to network 0.0.0.0
 
10.2.0.0/32 is subnetted, 1 subnets
C 10.2.0.1 is directly connected, Pos3/0/3
10.3.0.0/32 is subnetted, 1 subnets
B 10.3.16.16 [200/0] via 10.13.13.13, 1w3d
B 10.6.0.0/8 [200/0] via 10.13.13.13, 1w3d
10.0.0.0/32 is subnetted, 1 subnets
C 10.0.0.1 is directly connected, Pos3/0/1
B* 0.0.0.0/0 [200/0] via 10.13.13.13, 1w3d
 

ステップ 3 show running-config [ interface type number ]

このコマンドを使用して、関連するアップストリーム VRF とダウンストリーム VRF に関する情報を含む、指定したインターフェイスに関する情報を表示します。

次に、POS3/0/1 という名前のサブインターフェイスに関する情報を表示する例を示します。

Router# show running-config interface POS3/0/1
 
Building configuration...
 
Current configuration : 4261 bytes
!
interface POS3/0/1
ip vrf forwarding Up downstream Down
ip address 10.0.0.1 255.0.0.0
end
 


 

MPLS VPN 半二重 VRF の設定例

ここでは、次の設定例について説明します。

「スポーク PE ルータでのアップストリーム VRF とダウンストリーム VRF の設定:例」

「VRF とインターフェイスの関連付け:例」

「MPLS VPN 半二重 VRF の設定:スタティック CE-PE ルーティングを使用した例」

「MPLS VPN 半二重 VRF の設定:RADIUS サーバとスタティック CE-PE ルーティングを使用した例」

「MPLS VPN 半二重 VRF の設定:ダイナミック CE-PE ルーティングを使用した例」

スポーク PE ルータでのアップストリーム VRF とダウンストリーム VRF の設定:例

次に、Up と呼ばれるアップストリーム VRF を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# vrf definition Up
Router(config-vrf)# rd 1:0
Router(config-vrf)# address-family ipv4
Router(config-vrf-af)# route-target import 1:0
Router(config-vrf-af)# exit-address-family
 

次に、Down と呼ばれるダウンストリーム VRF を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# vrf definition Down
Router(config-vrf)# rd 1:8
Router(config-vrf)# address-family ipv4
Router(config-vrf-af)# route-target import 1:8
Router(config-vrf-af)# exit-address-family

VRF とインターフェイスの関連付け:例

次に、Up と呼ばれる VRF を POS3/0/1 サブインターフェイスに関連付け、Down と呼ばれるダウンストリーム VRF を指定する例を示します。

Router> enable
Router# configure terminal
Router(config)# interface POS 3/0/1
Router(config-if)# vrf forwarding Up downstream Down
Router(config-if)# ip address 10.0.0.1 255.0.0.0
 

MPLS VPN 半二重 VRF の設定: スタティック CE-PE ルーティングを使用した例

この例では、図 2 に示すハブアンドスポーク トポロジを使用し、ローカルで認証を行っています(つまり、RADIUS サーバは使用しません)。

図 2 トポロジ例

 

vrf definition D
rd 1:8
address-family ipv4
route-target export 1:100
exit-address-family
!
vrf definition U
rd 1:0
address-family ipv4
route-target import 1:0
exit-address-family
!
ip cef
vpdn enable
!
vpdn-group U
accept-dialin
protocol pppoe
virtual-template 1
!
interface Loopback2
vrf forwarding U
ip address 10.0.0.8 255.255.255.255
!
interface ATM2/0
description Mze ATM3/1/2
no ip address
no atm ilmi-keepalive
pvc 0/16 ilmi
!
pvc 3/100
protocol pppoe
!
pvc 3/101
protocol pppoe
!

MPLS VPN 半二重 VRF の設定:RADIUS サーバとスタティック CE-PE ルーティングを使用した例

次に、2 つの Point-to-Point Protocol over Ethernet(PPPoE)クライアントを、ルータ C と呼ばれるスポーク PE ルータ上の単一 VRF ペアに接続する例を示します。両方の PPPoE クライアントは、同じ VRF で設定されていますが、すべての通信は、ハブ PE ルータを使用して発生します。半二重 VRF がスポーク PE で設定されています。クライアントの設定は、RADIUS サーバからスポーク PE にダウンロードされます。

この例では、図 2 に示しているように、ハブアンドスポーク トポロジが使用されます。


) ホールセール プロバイダーは、ユーザ認証要求を対応する ISP に転送できます。ISP によってユーザが認証される場合、ホールセール プロバイダーは、PE ルータに戻される要求に VRF 情報を付加します。


aaa new-model
!
aaa group server radius R
server 10.0.20.26 auth-port 1812 acct-port 1813
!
aaa authentication ppp default group radius
aaa authorization network default group radius
!
vrf defintion D
description Downstream VRF - to spokes
rd 1:8
address-family ipv4
route-target export 1:100
exit-address-family
!
vrf definition U
description Upstream VRF - to hub
rd 1:0
address-family ipv4
route-target import 1:0
exit-address-family
!
ip cef
vpdn enable
!
vpdn-group U
accept-dialin
protocol pppoe
virtual-template 1
!
interface Loopback2
vrf forwarding U
ip address 10.0.0.8 255.255.255.255
!
interface ATM2/0
pvc 3/100
protocol pppoe
!
pvc 3/101
protocol pppoe
!
interface virtual-template 1
no ip address
ppp authentication chap
!
router bgp 1
no synchronization
neighbor 172.16.0.34 remote-as 1
neighbor 172.16.0.34 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 172.16.0.34 activate
neighbor 172.16.0.34 send-community extended
auto-summary
exit-address-family
!
address-family ipv4 vrf U
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf D
redistribute static
no auto-summary
no synchronization
exit-address-family
!
ip local pool U-pool 10.8.1.1 2.8.1.100
ip route vrf D 10.0.0.0 255.0.0.0 Null0
!
radius-server host 10.0.20.26 auth-port 1812 acct-port 1813
radius-server key cisco

MPLS VPN 半二重 VRF の設定:ダイナミック CE-PE ルーティングを使用した例

次に、OSPF を使用して、スポーク サイトにルートをダイナミックにアドバタイズする例を示します。

この例では、図 2 に示しているように、ハブアンドスポーク トポロジが使用されます。

VRF の作成

vrf definition Down
rd 100:1
address-family ipv4
route-target export 100:0
exit-address-family
!
vrf definition Up
rd 100:2
address-family ipv4
route-target import 100:1
exit-address-family

MPLS のイネーブル化

mpls ldp graceful-restart
mpls ldp router-id Loopback0 force
mpls label protocol ldp

コアへの BGP の設定

router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 10.13.13.13 remote-as 100
neighbor 10.13.13.13 update-source Loopback0
!
address-family vpnv4
neighbor 10.13.13.13 activate
neighbor 10.13.13.13 send-community extended
bgp scan-time import 5
exit-address-family

エッジへの BGP の設定

address-family ipv4 vrf Up
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf Down
redistribute ospf 1000 vrf Down
no auto-summary
no synchronization
exit-address-family

スポーク PE のコアに向けたインターフェイスおよびプロセス

interface Loopback0
ip address 10.11.11.11 255.255.255.255
!
interface POS3/0/2
ip address 10.0.1.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
network 10.11.11.11 0.0.0.0 area 100
network 10.0.1.0 0.255.255.255 area 100

スポーク PE のエッジに向けたインターフェイスおよびプロセス

interface Loopback100
vrf forwarding Down
ip address 10.22.22.22 255.255.255.255
!
interface POS3/0/1
vrf forwarding Up downstream Down
ip address 10.0.0.1 255.0.0.0
!
interface POS3/0/3
vrf forwarding Up downstream Down
ip address 10.2.0.1 255.0.0.0
!
router ospf 1000 vrf Down
router-id 10.22.22.22
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
redistribute bgp 100 metric-type 1 subnets
network 10.22.22.22 0.0.0.0 area 300
network 10.0.0.0 0.255.255.255 area 300
network 10.2.0.0 0.255.255.255 area 300
default-information originate

その他の関連資料

ここでは、MPLS VPN 半二重 VRF 機能の関連資料について説明します。

関連資料

関連項目
参照先

MPLS VPN

『Configuring MPLS Layer 3 VPNs』

MPLS コマンド

『Cisco IOS Multiprotocol Label Switching Command Reference』

IPv4 および IPv6 の VRF の設定

MPLS VPN--VRF CLI for IPv4 and IPv6 VPNs

ユニキャスト Reverse Path Forwarding

『Configuring Unicast Reverse Path Forwarding』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

MPLS VPN 半二重 VRF の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS VPN 半二重 VRF の機能情報

機能名
リリース
機能情報

MPLS VPN:スタティック ルーティングによる Half Duplex VRF(HDVRF; 半二重 VRF)のサポート

12.3(6)
12.3(11)T
12.2(28)SB

この機能を使用すると、MPLS VPN のエッジにある同じ PE ルータに接続する VPN クライアントが、常にハブ サイトを通信に使用するようになります。

この機能は、12.3(6) で導入されました。

この機能は、12.4(20)T で統合されました。

この機能は、12.2(28)SB で統合されました。

MPLS VPN 半二重 VRF

12.2(28)SB2
12.4(20)T
12.2(33)SRC

12.2(28)SB2 では、ダイナミック ルーティング プロトコルのサポートが追加されました。

Cisco 10000 シリーズ ルータにおける情報については、次の URL にある『 Cisco 10000 Series Router Broadband Aggregation, Leased-Line, and MPLS Configuration Guide 』の「Configuring Multiprotocol Label Switching」の章の「Half-Duplex VRF」の項を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/aggr/10000/swconfig/cfggdes/bba/dffsrv.htm#wp1065648

12.4(20)T では、ダイナミック ルーティング プロトコルのサポートが追加されたこの機能が統合されました。

Cisco IOS Release 12.2(33)SRC では、ダイナミック ルーティング プロトコルのサポートが追加されたこの機能が SR トレインに統合されました。

次のコマンドが導入または変更されました。 show ip interface、show vrf