マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS VPN - L3VPN over GRE
MPLS VPN - L3VPN over GRE
発行日;2012/01/31 | 英語版ドキュメント(2011/08/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS VPN - L3VPN over GRE

機能情報の確認

目次

MPLS VPN - L3VPN over GRE の前提条件

MPLS VPN - L3VPN over GRE の制約事項

MPLS VPN - L3VPN over GRE に関する情報

PE-to-PE トンネリング

P-to-PE トンネリング

P-to-P トンネリング

MPLS VPN - L3VPN over GRE の設定方法

MPLS VPN - L3VPN over GRE トンネル インターフェイスの設定

前提条件

MPLS VPN - L3VPN over GRE の設定例

MPLS VPN - L3VPN over GRE を使用した MPLS 設定:例

ユニキャスト ルートの表示:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS VPN - L3VPN over GRE の機能情報

MPLS VPN - L3VPN over GRE

MPLS VPN - L3VPN over GRE 機能は、非 MPLS ネットワーク経由で Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)パケットのトンネリングを行うためのメカニズムを提供します。

MPLS VPN - L3VPN over GRE 機能は、MPLS over Generic Routing Encapsulation(MPLSoGRE)を使用して、MPLS パケットを IP トンネル内にカプセル化します。このアクションによって、非 MPLS ネットワーク間にバーチャル ポイントツーポイント リンクが作成されます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「MPLS VPN - L3VPN over GRE の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

MPLS VPN - L3VPN over GRE の前提条件

MPLS VPN - L3VPN over GRE 機能を設定する前に、MPLS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)が正しく設定され、動作していることを確認します。MPLS VPN の設定に関する詳細については、『 Configuring MPLS Layer 3 VPNs 』モジュールを参照してください。

次のルーティング プロトコルが正しく設定され、動作していることを確認します。

Label Distribution Protocol(LDP; ラベル配布プロトコル):MPLS ラベル配布の場合。『 MPLS Label Distribution Protocol Overview 』を参照してください

Multiprotocol Border Gateway Protocol(MP-BGP; マルチプロトコル ボーダー ゲートウェイ プロトコル):VPN ルートとラベル配布の場合。『 Configuring MPLS Layer 3 VPNs 』を参照してください

MPLS VPN - L3VPN over GRE の制約事項

MPLS VPN - L3VPN over GRE 機能では、次のものはサポートされません。

トンネル インターフェイスで設定された Quality of service(QoS; サービス品質)サービス ポリシー。物理またはサブフェイスではサポートされます。

GRE オプション:シーケンス、チェックサム、およびソースルート

IPv6 GRE

Carrier Supporting Carrier(CSC)や InterAutonomous System(Inter-AS; 相互自律システム)などの拡張機能

MPLS VPN - L3VPN over GRE に関する情報

MPLS VPN - L3VPN over GRE 機能は、非 MPLS ネットワーク経由で MPLS パケットのトンネリングを行うためのメカニズムを提供します。

MPLS VPN - L3VPN over GRE を使用すると、非 MPLS ネットワーク間の GRE トンネルを作成できます。MPLS パケットは、GRE トンネル パケット内でカプセル化され、カプセル化されたパケットは、GRE トンネルを経由して非 MPLS ネットワークを通ります。非 MPLS ネットワークのもう一方の側で GRE トンネル パケットを受信すると、GRE トンネル パケット ヘッダーは削除され、内部 MPLS パケットは最終的な宛先に転送されます。

MPLS VPN - L3VPN over GRE 機能では、次の 3 つの GRE トンネル設定がサポートされます。

「PE-to-PE トンネリング」

「P-to-PE トンネリング」

「P-to-P トンネリング」

PE-to-PE トンネリング

Provider Edge-to-Provider Edge(PE-to-PE; プロバイダー エッジ間)トンネリング設定によって、非 MPLS ネットワーク間の複数のカスタマー ネットワークをスケーラブルな方法で接続できます。この設定を使用して、複数のカスタマー ネットワーク宛のトラフィックは、単一の GRE トンネルから多重化されます。


) 類似したスケーラブルではない代替方法は、別個の GRE トンネルから各カスタマー ネットワークに接続することです(たとえば、GRE トンネルごとに 1 つのカスタマー ネットワークを接続します)。


図 1 に示すように、PE ルータは、VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)番号を非 MPLS ネットワークの各側にある Customer Edge(CE; カスタマー エッジ)ルータに割り当てます。

PE ルータは、BGP、OSPF、または Routing Information Protocol(RIP; ルーティング情報プロトコル)などのルーティング プロトコルを使用して、CE ルータの背後にある IP ネットワークについて学習します。CE ルータの背後にある IP ネットワークへのルートは、関連する CE ルータの VRF ルーティング テーブルに格納されます。

非 MPLS ネットワークのいずれかの側にある PE ルータは、(非 MPLS ネットワーク内で動作している)ルーティング プロトコルを使用して、非 MPLS ネットワークのもう一方の側にある PE ルータについて学習します。PE ルータ間に確立された学習ルートは、メインまたはデフォルトのルーティング テーブルに格納されます。

反対方向の PE ルータは、BGP を使用して、PE ルータの背後にあるカスタマー ネットワークに関連付けられたルートについて学習します。これらの学習ルートは、非 MPLS ネットワークには認識されません。

この例では、BGP は、非 MPLS ネットワークにまたがる GRE トンネル経由で BGP ネイバー(反対方向の PE ルータ)へのスタティック ルートを定義します。BGP ネイバーによって学習されたルートには GRE トンネルのネクストホップが含まれているため、すべてのカスタマー ネットワーク トラフィックが GRE トンネルを使用して送信されます。

図 1 PE-to-PE トンネリング

 

P-to-PE トンネリング

図 2 に示すように、Provider-to-Provider Edge(P-to-PE)トンネリング設定によって、非 MPLS ネットワークで PE ルータ(P1)を MPLS セグメント(PE-2)に接続できます。この設定では、非 MPLS ネットワークの一方の側宛の MPLS トラフィックは、単一の GRE トンネル経由で送信されます。

図 2 P-to-PE トンネリング

 

P-to-P トンネリング

図 3 に示すように、Provider-to-Provider(P-to-P)設定によって、非 MPLS ネットワークで 2 つの MPLS セグメント(P1 から P2)を接続できます。この設定では、非 MPLS ネットワークの一方の側宛の MPLS トラフィックは、単一の GRE トンネル経由で送信されます。

図 3 P-to-P トンネリング

 

MPLS VPN - L3VPN over GRE の設定方法

ここでは、次の手順について説明します。

「MPLS VPN - L3VPN over GRE トンネル インターフェイスの設定」(必須)

MPLS VPN - L3VPN over GRE トンネル インターフェイスの設定

MPLS VPN - L3VPN over GRE 機能を設定するには、非 MPLS ネットワークにまたがる GRE トンネルを作成する必要があります。この手順は、GRE トンネルの両方の終端にあるデバイスで実行する必要があります。

前提条件

MPLS VPN - L3VPN over GRE 機能を設定する前に、MPLS VPN と適切なルーティング プロトコルが正しく設定され、動作していることを確認します。「MPLS VPN - L3VPN over GRE の前提条件」を参照してください。

手順の概要

1. enable

2. configure terminal

3. interface tunnel tunnel-number

4. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ dhcp ] [ distance ] [ name next-hop-name ] [ permanent | track number ] [ tag tag ]

5. tunnel source source-address

6. tunnel destination destination-address

7. mpls ip

8. exit

9. show ip route

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel tunnel-number

 

Router(config)# interface tunnel 1

指定されたインターフェイスでトンネルを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [dhcp] [distance] [name next-hop-name] [permanent | track number] [tag tag]

 

Router(config-if)# ip route 209.165.200.253 255.255.255.224 FastEthernet 0/0

SIP 2 インターフェイスまたはトンネル インターフェイスで BGP ネイバーへのスタティック ルートを設定します。

ステップ 5

tunnel source source-address

 

Router(config-if)# tunnel source 209.165.200.254

トンネルのソース IP アドレスを指定します。

ステップ 6

tunnel destination destination-address

 

Router(config-if)# tunnel destination 209.165.200.255

トンネルの宛先 IP アドレスを指定します。

ステップ 7

mpls ip

 

Router(config-if)# mpls ip

トンネルの物理インターフェイスで MPLS をイネーブルにします。

ステップ 8

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 9

show ip route

 

Router(config)# show ip route

ユニキャスト ルートを表示して、スタティック ルートをグローバルに設定するか、トンネルで設定します。

次に、非 MPLS ネットワークにまたがる GRE トンネル設定の例を示します。この例は、トンネルの両方の終端にある PE デバイス(PE1 と PE2)でのトンネル設定を示しています。

PE1 の設定

Router# configure terminal
Router(config)# interface Tunnel 1
Router(config-if)# ip address 209.165.200.253 255.255.255.224
Router(config-if)# tunnel source 209.165.200.254
Router(config-if)# tunnel destination 209.165.200.255
Router(config-if)# mpls ip

PE2 の設定

Router# configure terminal
Router(config)# interface Tunnel 1
Router(config-if)# ip address 209.165.200.235 255.255.255.224
Router(config-if)# tunnel source 209.165.200.240
Router(config-if)# tunnel destination 209.165.200.245
Router(config-if)# mpls ip

MPLS VPN - L3VPN over GRE の設定例

ここでは、MPLS VPN - L3VPN over GRE 機能の次の設定例を示します。

「MPLS VPN - L3VPN over GRE を使用した MPLS 設定:例」

「ユニキャスト ルートの表示:例」

MPLS VPN - L3VPN over GRE を使用した MPLS 設定:例

次の基本的な MPLS 設定例では、非 MPLS ネットワークにまたがる GRE トンネルを使用します。この例は、図 1 の設定と似ています。

PE1 の設定

!
mpls ip
!
ip vrf vpn1
rd 100:1
route-target import 100:1
route-target export 100:1
!
interface loopback 0
ip address 209.165.200.225 255.255.255.224
!
interface GigabitEthernet 0/1/2
ip address 209.165.200.226 255.255.255.224
!
interface Tunnel 1
ip address 209.165.200.227 255.255.255.224
tunnel source 209.165.200.228
tunnel destination 209.165.200.229
mpls ip
!
interface GigabitEthernet 0/1/3
ip vrf forwarding vpn1
ip address 209.165.200.230 255.255.255.224
!
router bgp 100
neighbor 209.165.200.231 remote-as 100
neighbor 209.165.200.231 update-source loopback0
!
address-family vpnv4
neighbor 209.165.200.232 activate
neighbor 209.165.200.232 send community-extended
!
address-family ipv4 vrf vpn1
neighbor 209.165.200.240 remote-as 20
neighbor 209.165.200.240 activate
!

PE2 の設定

!
mpls ip
!
ip vrf vpn1
rd 100:1
route-target import 100:1
route-target export 100:1
!
interface loopback 0
ip address 209.165.200.240 255.255.255.224
!
interface GigabitEthernet 0/1/1
ip address 209.165.200.241 255.255.255.224
!
interface Tunnel 1
ip address 209.165.200.244 255.255.255.224
tunnel source 209.165.200.245
tunnel destination 209.165.200.247
mpls ip
!
interface GigabitEthernet 0/0/5
ip vrf forwarding vpn1
ip address 209.165.200.249 255.255.255.224
!
router bgp 100
neighbor 209.165.200.250 remote-as 100
neighbor 209.165.200.252 update-source loopback0
!
address-family vpnv4
neighbor 209.165.200.253 activate
neighbor 209.165.200.254 send community-extended
!
address-family ipv4 vrf vpn1
neighbor 209.165.200.254 remote-as 30
neighbor 209.165.200.255 activate
 

ユニキャスト ルートの表示:例

次に、ユニキャスト ルートの表示例を示します。この表示は、選択したインターフェイスに依存している BGP ネイバーのネクストホップを示しています。

Router# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
209.165.200.225/32 is subnetted, 1 subnets
O 209.165.200.226 [110/3] via 209.165.200.250, 00:09:55, POS2/0/0
209.165.200.227/32 is subnetted, 1 subnets
C 209.165.200.229 is directly connected, Loopback0
209.165.200.230/32 is subnetted, 1 subnets
O 209.165.200.231 [110/2] via 209.165.200.232, 00:09:55, POS2/0/0
S 209.165.200.240/8 [1/0] via 209.165.200.252
209.165.200.245/32 is subnetted, 2 subnets
S 209.165.200.247 is directly connected, POS2/0/0
O 209.165.200.248 [110/3] via 209.165.200.249, 00:09:55, POS2/0/0
C 209.165.200.254/8 is directly connected, POS2/0/0

その他の参考資料

ここでは、MPLS VPN - L3VPN over GRE 機能の関連資料について説明します。

関連資料

関連項目
参照先

MPLS VPN ネットワークの設定
Multiprotocol Border Gateway Protocol(MP-BGP; マルチプロトコル ボーダー ゲートウェイ プロトコル)

『Configuring MPLS Layer 3 VPNs』

ラベル配布プロトコル

『MPLS Label Distribution Protocol Overview』

L3 VPN over mGRE トンネルの設定

『Dynamic Layer-3 VPNs with Multipoint GRE Tunnels』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

MPLS VPN - L3VPN over GRE の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 MPLS VPN - L3VPN over GRE の機能情報

機能名
リリース
機能情報

MPLS VPN - L3VPN over GRE 機能

12.0(22)S
12.2(13)T
12.0(26)S
12.2(33)SRE

MPLS VPN - L3VPN over GRE 機能は、非 MPLS ネットワーク経由で Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)パケットのトンネリングを行うためのメカニズムを提供します。

この機能で使用される新しいコマンドまたは変更されたコマンドはありません。

Copyright © 2008-2011, シスコシステムズ合同会社.
All rights reserved.