マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS
ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS
発行日;2012/02/01 | 英語版ドキュメント(2011/07/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS

機能情報の確認

この章の構成

の前提条件

の制約事項

に関する情報

MPLS VPN Inter-AS の概要

MPLS VPN Inter-AS の利点

ASBR で VPN-IPv4 アドレスを交換する Inter-AS の使用

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における情報交換

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における情報の伝送

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における VPN ルーティング情報の交換

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS システム間のパケット転送

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における連合の使用

の設定方法

VPN-IPv4 アドレスを交換するように ASBR を設定する

連合内のサブ自律システム間で VPN ルートを交換する EBGP ルーティングの設定

ASBR で VPN-IPv4 アドレスを交換する Inter-AS の確認

の設定例

の設定:例

自律システム 1、CE1 の設定:例

自律システム 1、PE1 の設定:例

自律システム 1、P1 の設定:例

自律システム 1、EBGP1 の設定:例

自律システム 2、EBGP2 の設定:例

自律システム 2、P2 の設定:例

自律システム 2、PE2 の設定:例

自律システム 2、CE2 の設定:例

連合における の設定:例

自律システム 1、CE1 の設定:例

自律システム 1、PE1 の設定:例

自律システム 1、P1 の設定:例

自律システム 1、ASBR1 の設定:例

自律システム 2、ASBR2 の設定:例

自律システム 2、P2 の設定:例

自律システム 2、PE2 の設定:例

自律システム 2、CE2 の設定:例

コマンド リファレンス

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS 機能を使用すると、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)がサービス プロバイダーおよび自律システムにまたがることができます。この章では、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)を有効にし、Exterior Border Gateway Protocol(EBGP; 外部ボーダー ゲートウェイ プロトコル)を使用して VPN-IPv4 アドレスの形式で IPv4 Network Layer Reachability Information(NLRI; ネットワーク レイヤ到達可能性情報)を交換する方法について説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-ASの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-ASの前提条件

MPLS VPN 内の自律システムまたはサブ自律システム間に EBGP ルーティングを設定する前に、すべての MPLS VPN ルーティング インスタンスおよびセッションを適切に設定しておく必要があります。ここで説明する設定作業は、これらの設定作業に基づいて行われます。『 Configuring MPLS Layer 3 VPNs 』の手順に従って、次の作業を実行します。

VPN ルーティング インスタンスの定義

MPLS コアにおける BGP ルーティング セッションの設定

MPLS コアにおける PE から PE へのルーティング セッションの設定

BGP の PE から CE へのルーティング セッションの設定

直接接続された ASBR 間の VPN-IPv4 EBGP セッションの設定

この機能は、 表 1 に記載されている Cisco 12000 シリーズ ルータ ラインカードでサポートされています。

 

表 1 Cisco IOS リリースに追加された Cisco 12000 シリーズ ラインカード サポート

タイプ
ラインカード
追加された Cisco IOS リリース

Packet over SONET(POS)

4-Port OC-3 POS
1-Port OC-12 POS
8-Port OC-3 POS
16-Port OC-3 POS
4-Port OC-12 POS
1-Port OC-48 POS
4-Port OC-3 POS ISE
8-Port OC-3 POS ISE
16 x OC-3 POS ISE
4-Port OC-12 POS ISE
1-Port OC-48 POS ISE

12.0(16)ST

12.0(17)ST



12.0(22)S

電気インターフェイス

6-Port DS3
12-Port DS3
6-Port E3
12-Port E3

12.0(21)ST

12.0(22)S

イーサネット

3-Port GbE
1-Port 10-GbE
Modular GbE/FE

12.0(23)S
12.0(24)S

ATM

4-Port OC-3 ATM
1-Port OC-12 ATM
4-Port OC-12 ATM
8-Port OC-3 ATM

12.0(16)ST

12.0(17)ST
12.0(23)S

チャネライズド インターフェイス

2-Port CHOC-3
6-Port Ch T3 (DS1)
1-Port CHOC-12 (DS3)
1-Port CHOC-12 (OC-3)
4-Port CHOC-12 ISE
1-Port CHOC-48 ISE

12.0(22)S

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-ASの制約事項

マルチホップ VPN-IPv4 EBGP はサポートされていません。

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS に関する情報

この機能を設定する前に、次の概念を理解する必要があります。

「MPLS VPN Inter-AS の概要」

「MPLS VPN Inter-AS の利点」

「ASBR で VPN-IPv4 アドレスを交換する Inter-AS の使用」

「ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における情報交換」

MPLS VPN Inter-AS の概要

自律システムとは、共通のシステム管理グループによって管理され、単一の明確に定義されたルーティング プロトコルを使用する、単一のネットワークまたはネットワークのグループのことです。

VPN が大規模になるにつれて、その要件も多くなります。異なる地理的エリアにある異なる自律システムに VPN を設定する必要がある場合もあります。また、一部の VPN は、複数のサービス プロバイダーにまたがって設定する必要があります(オーバーラッピング VPN)。VPN がどのように複雑で、どのような場所にあっても、自律システム間の接続はカスタマーに対してシームレスである必要があります。

MPLS VPN Inter-AS の利点

MPLS VPN Inter-AS には次の利点があります。

VPN が複数のサービス プロバイダー バックボーンをまたがることが可能

異なる自律システムを実行する複数のサービス プロバイダーが、共同で同じカスタマーに MPLS VPN サービスを提供できます。あるカスタマー サイトから開始し、さまざまな VPN サービス プロバイダー バックボーンを通過して、同じカスタマーの別のサイトに到達するように VPN を設定できます。以前は、MPLS VPN は、単一の BGP 自律システム サービス プロバイダー バックボーンだけを通過できました。この機能により、複数の自律システムが、サービス プロバイダーのカスタマー サイト間に連続性がありシームレスなネットワークを形成できます。

VPN が異なるエリアに存在可能

サービス プロバイダーは、異なる地理的エリアに VPN を作成できます。すべての VPN トラフィック フローが(エリア間で)1 箇所のポイントを通過するようにすると、エリア間のネットワーク トラフィックのレートをより適切に制御できます。

IBGP メッシングを最適化するための連合が可能

自律システム内の Internal Border Gateway Protocol(IBGP; 内部ボーダー ゲートウェイ プロトコル)メッシングがより整理され、管理しやすくなります。自律システムを複数の異なるサブ自律システムに分割して、それらを単一の連合に分類できます(ただし、VPN バックボーン全体は単一の自律システムと見なされます)。連合を形成するサブ自律システム間でのラベル付き VPN-IPv4 NLRI の交換がサポートされているため、サービス プロバイダーはこの機能を使用して、連合全体で MPLS VPN を提供できます。

ASBR で VPN-IPv4 アドレスを交換する Inter-AS の使用

異なるサービス プロバイダーの異なる自律システムは、VPN-IPv4 アドレスの形式で IPv4 NLRI を交換することによって通信できます。ASBR は、EBGP を使用してその情報を交換します。その後、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)によって、各 VPN および各自律システム全体に、VPN-IPv4 プレフィクスのネットワーク レイヤ情報が配布されます。ルーティング情報では、次のプロトコルが使用されます。

自律システム内では、ルーティング情報は IGP を使用して共有されます。

自律システム間では、ルーティング情報は EBGP を使用して共有されます。サービス プロバイダーは、EBGP を使用することによって、異なる自律システム間でループせずにルーティング情報を交換できることが保証されるドメイン間ルーティング システムを設定できます。

EBGP の主な機能は、自律システムのルートのリストに関する情報を含む、自律システム間のネットワーク到達可能性情報を交換することです。自律システムは、EBGP ボーダー エッジ ルータを使用して、ラベル スイッチング情報を含むルートを配布します。各ボーダー エッジ ルータでは、ネクストホップおよびラベルが書き換えられます。詳細については、「ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における情報交換」を参照してください。

MPLS VPN でサポートされている相互自律システム設定は次のとおりです。

プロバイダー間 VPN: 異なるボーダー エッジ ルータによって接続された、2 つ以上の自律システムを含む MPLS VPN。各自律システムは、EBGP を使用してルートを交換します。自律システム間では、IGP 情報(ルーティング情報)は交換されません。

BGP 連合: 単一の自律システムを複数のサブ自律システムに分割し、それらを指定された単一の連合として分類した MPLS VPN。ネットワークでは、連合は単一の自律システムとして認識されます。異なる自律システム内のピアは、EBGP セッションを介して通信しますが、これらのピアは IBGP ピアである場合と同様にルート情報を交換できます。

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における情報の伝送

図 1 に、2 つの異なる自律システムから構成された 1 つの MPLS VPN を示します。各自律システムは異なる管理制御下で運用され、異なる IGP が実行されています。サービス プロバイダーは、EBGP ボーダー エッジ ルータ(ASBR1、ASBR2)を経由してルーティング情報を交換します。

図 1 ASBR で VPN-IPv4 アドレスを交換する 2 つの MPLS VPN Inter-AS システム間の EBGP 接続

 

 

この設定では、次のプロセスによって情報が送信されます。


ステップ 1 プロバイダー エッジ ルータ(PE-1)では、ルートを配布する前に、そのルートに対してラベルが割り当てられます。PE ルータは、BGP のマルチプロトコル拡張を使用して、ラベル マッピング情報を送信します。PE ルータは、VPN-IPv4 アドレスとしてルートを配布します。アドレス ラベルおよび VPN 識別子は、NLRI の一部として符号化されます。

ステップ 2 2 つのルート リフレクタ(RR-1 と RR-2)には、自律システム内の VPN-IPv4 内部ルートが反映されます。自律システムのボーダー エッジ ルータ(ASBR1 と ASBR2)は、VPN-IPv4 外部ルートをアドバタイズします。

ステップ 3 EBGP ボーダー エッジ ルータ(ASBR1)によって、次の自律システム(ASBR2)にルートが再配布されます。ASBR1 は、EBGP のネクストホップ アトリビュートの値として自身のアドレスを指定し、新しいラベルを割り当てます。このアドレスでは、次のことが保証されます。

ネクストホップ ルータは、サービス プロバイダー(P)バックボーン ネットワーク内で常に到達可能であること。

配布元ルータによって割り当てられたラベルが適切に解釈されること(ルータに関連付けられるラベルは、対応するネクストホップ ルータによって割り当てられる必要があります)。

ステップ 4 EBGP ボーダー エッジ ルータ(ASBR2)では、設定に応じて、次のいずれかの方法でルートが再配布されます。

IBGP ネイバーが neighbor next-hop-self コマンドを使用して設定されている場合、ASBR2 は、EBGP ピアから受信したアップデートのネクストホップ アドレスを変更して転送します。

IBGP ネイバーが neighbor next-hop-self コマンドを使用して設定されていない場合、ネクストホップ アドレスは変更されません。ASBR2 は、EBGP ピアのホスト ルートを IGP 経由で伝播する必要があります。EBGP VPN-IPv4 ネイバー ホスト ルートを伝播するには、 redistribute connected subnets コマンドを使用します。EBGP VPN-IPv4 ネイバー ホスト ルートは、ネイバーがアップ状態になったときにルーティング テーブルに自動的にインストールされます。このことは、異なる自律システム内の PE ルータ間でラベル スイッチド パスを確立するために重要です。


 

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における VPN ルーティング情報の交換

自律システムは、接続を確立するために VPN ルーティング情報(ルートとラベル)を交換します。自律システム間の接続を制御するために、PE ルータおよび EBGP ボーダー エッジ ルータは Label Forwarding Information Base(LFIB; ラベル転送情報ベース)を保持します。LFIB では、VPN 情報の交換中に PE ルータおよび EBGP ボーダー エッジ ルータが受信するラベルとルートが管理されます。

図 2 に、自律システム間における VPN のルートおよびラベル情報の交換について示します。自律システムでは、VPN ルーティング情報を交換する場合に次の条件が使用されます。

ルーティング情報に次の内容が含まれています。

宛先ネットワーク(N)

配布元ルータに関連付けられたネクストホップ フィールド

ローカル MPLS ラベル(L)

RD1: ルート識別子が宛先ネットワーク アドレスの一部として含まれています。ルート識別子によって、VPN-IPv4 ルートが VPN サービス プロバイダー環境内でグローバルに一意となります。

ASBR は、IBGP ネイバーに VPN-IPv4 NLRI を送信する場合に、ネクストホップを変更するように設定されています(next-hop-self)。したがって、ASBR では、IBGP ネイバーに NLRI を転送する場合に新しいラベルを割り当てる必要があります。

図 2 ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS システム間でのルートとラベルの交換

 

図 3 に、自律システム間における VPN のルートおよびラベル情報の交換について示します。唯一の違いは、ASBR2 が redistribute connected コマンドを使用して設定されていることです。これにより、ホスト ルートがすべての PE に伝播されます。ASBR2 はネクストホップ アドレスを変更するように設定されていないため、 redistribute connected コマンドが必要となります。

図 3 ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における、redistribute connected コマンドを使用したルートとラベルの交換

 

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS システム間のパケット転送

図 4 に、プロバイダー間ネットワークにおいて、次のパケット転送方法を使用して自律システム間でパケットが転送されるようすを示します。

パケットは、MPLS によって宛先に転送されます。パケットでは、各 PE ルータおよび EBGP ボーダー エッジ ルータの LFIB に格納されているルーティング情報が使用されます。

サービス プロバイダーの VPN バックボーンでは、ダイナミック ラベル スイッチングを使用してラベルが転送されます。

自律システムでは、標準的なマルチレベル ラベリングを使用して、自律システム ルータのエッジ間(CE-5 から PE-3 など)でパケットが転送されます。自律システム間では、アドバタイズされたルートに対応する単一レベルのラベリングだけが使用されます。

データ パケットが VPN バックボーンを通過する場合、2 つのレベルのラベルが伝送されます。

最初のラベル(IGP ルート ラベル)によって、パケットが正しい PE ルータまたは EBGP ボーダー エッジルータに転送されます(たとえば、ASBR2 の IGP ラベルは、ASBR2 ボーダー エッジ ルータを指します)。

2 つめのラベル(VPN ルート ラベル)によって、パケットが適切な PE ルータまたは EBGP ボーダー エッジルータに転送されます。

図 4 ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS システム間のパケット転送

 

図 5 に、図 4 と同じパケット転送方法を示します。ただし、今回は、EBGP ルータ(ASBR1)で新しいラベルが再割り当てされずにパケットが転送されます。

図 5 ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS システム間での新しいラベルを割り当てないパケット転送

 

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS における連合の使用

連合とは、複数のサブ自律システムをグループ化したものです。連合を使用することによって、自律システム内のピア デバイスの合計数を減らすことができます。連合では、自律システムが複数のサブ自律システムに分割され、自律システムに連合識別子が割り当てられます。VPN は、異なる自律システムまたは連合を形成する複数のサブ自律システムで実行される、複数のサービス プロバイダーにまたがることができます。

連合において、各サブ自律システムと他のサブ自律システムとの関係は、完全なメッシュになっています。サブ自律システム間の通信は、Open Shortest Path First(OSPF)や Intermediate System-to-Intermediate System(IS-IS)などの IGP を使用して行われます。また、各サブ自律システムは、他のサブ自律システムへの EBGP 接続も持っています。Confederation EBGP(CEBGP; 連合 EBGP)ボーダー エッジ ルータは、指定されたサブ自律システム間で next-hop-self アドレスを転送します。next-hop-self アドレスによって、BGP では、プロトコルでネクストホップを選択するのではなく、ネクストホップとして指定されたアドレスを使用することが強制されます。

次の 2 つの方法のいずれかを使用して、異なるサブ自律システムに連合を設定できます。

next-hop-self アドレスが CEBGP ボーダー エッジ ルータ間でだけ転送されるようにルータを設定できます(双方向)。サブ自律システム ボーダーのサブ自律システム(IBGP ピア)では、next-hop-self アドレスは転送されません。各サブ自律システムは、単一の IGP ドメインとして実行されます。ただし、CEBGP ボーダー エッジ ルータ アドレスは、IGP ドメイン内で認識されます。

next-hop-self アドレスが CEBGP ボーダー エッジ ルータ間(双方向)、およびサブ自律システム ボーダーの IBGP ピア内で転送されるようにルータを設定できます。各サブ自律システムは、単一の IGP ドメインとして実行されますが、ドメイン内の PE ルータ間でも next-hop-self アドレスを転送します。CEBGP ボーダー エッジ ルータ アドレスは、IGP ドメイン内で認識されます。


図 2 および図 3 は、2 つの自律システムでルートが交換され、パケットが転送されるしくみを示しています。連合内のサブ自律システムでは、ルートの交換およびパケットの転送に同様の方法が使用されます。


図 6 に、一般的な MPLS VPN 連合設定を示します。この連合設定の特徴は次のとおりです。

2 つの CEBGP ボーダー エッジ ルータは、2 つのサブ自律システム間で VPN-IPv4 アドレスおよびラベルを交換します。

配布元ルータはネクストホップ アドレスおよびラ xルを変更して、next-hop-self アドレスを使用します。

IGP-1 および IGP-2 では、CEBGP-1 と CEBGP-2 のアドレスが認識されます。

図 6 連合内の 2 つのサブ自律システム間の EBGP 接続

 

この連合設定の特徴は次のとおりです。

CEBGP ボーダー エッジ ルータは、サブ自律システム間の隣接ピアとして機能します。サブ自律システムは、EBGP を使用してルート情報を交換します。

CEBGP ボーダー エッジ ルータ(CEBGP-1、CEBGP-2)は、ルートを次のサブ自律システムに配布する前に、ルートのラベルを割り当てます。CEBGP ボーダー エッジ ルータは、BGP のマルチプロトコル拡張を使用して、VPN-IPv4 アドレスとしてルートを配布します。ラベルおよび VPN 識別子は、NLRI の一部として符号化されます。

各 PE および CEBGP ボーダー エッジ ルータは、ルートを再配布する前に、各 VPN-IPv4 アドレス プレフィクスに独自のラベルを割り当てます。CEBGP ボーダー エッジ ルータは、ラベル付きの VPN-IPv4 アドレスを交換します。ラベルには、(EBGP ネクストホップ アトリビュートの値として)next-hop-self アドレスが含まれています。サブ自律システム内では、CEBGP ボーダー エッジ ルータ アドレスが IBGP ネイバー全体に配布され、2 つの CEBGP ボーダー エッジ ルータが両方の連合で認識されます。

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS の設定方法

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS を設定するには、次の各項で説明する作業を実行します。

「VPN-IPv4 アドレスを交換するように ASBR を設定する」(必須)

「連合内のサブ自律システム間で VPN ルートを交換する EBGP ルーティングの設定」(必須)

「ASBR で VPN-IPv4 アドレスを交換する Inter-AS の確認」(任意)

VPN-IPv4 アドレスを交換するように ASBR を設定する

他の自律システムと VPN-IPv4 ルートを交換するように EBGP ASBR を設定するには、次の作業を実行します。


) VPN-IPv4 EBGP ネイバーのホスト ルートを他のルータおよびプロバイダー エッジ ルータに伝播するには、ルータの IGP 設定部分で redistribute connected subnets コマンドを発行します。IBGP ネイバーを設定するときに next-hop-self アドレスを指定することもできます。


手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. no bgp default route-target filter

5. address-family vpnv4 [ unicast ]

6. neighbor peer-group-name remote-as as-number

7. neighbor peer-group-name activate

8. exit-address-family

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 1

EBGP ルーティング プロセスを作成して、それに自律システム番号を割り当てます。

自律システム番号は、他の自律システムの EBGP ルータでルータを識別できるようにするために渡されます。

ステップ 4

no bgp default route-target filter

 

Router(config)# no bgp default route-target filter

BGP の route-target フィルタリングをディセーブルにし、ルータをコンフィギュレーション モードに設定します。

受信したすべての BGP VPN-IPv4 ルートがルータによって受け入れられます。

ステップ 5

address-family vpnv4 [unicast]

 

Router(config-router)# address-family vpnv4

VPN バックボーン全体で VPNv4 アドレスを伝送するルーティング セッションを設定し、ルータをアドレス ファミリ コンフィギュレーション モードに設定します。

8 バイトの Route Distinguisher(RD; ルート識別子)を追加することによって、各アドレスはグローバルに一意になります。

unicast キーワードによって、ユニキャスト プレフィクスが指定されます。

ステップ 6

neighbor peer-group-name remote-as as-number

 

Router(config-router-af)# neighbor 1 remote-as 2

アドレス ファミリ コンフィギュレーション モードを開始して、隣接 EBGP ピア グループを指定します。

この EBGP ピア グループは、指定した自律システムに属すると見なされます。

ステップ 7

neighbor peer-group-name activate

 

Router(config-router-af)# neighbor 1 activate

ネイバー EBGP ルータへの VPNv4 アドレス ファミリのアドバタイズメントをアクティブにします。

ステップ 8

exit-address-family

 

Router(config-router-af)# exit-address-family

ルータ コンフィギュレーション モードのアドレス ファミリ サブモードを終了します。

ステップ 9

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

連合内のサブ自律システム間で VPN ルートを交換する EBGP ルーティングの設定

連合内のサブ自律システム間で VPN ルートを交換する EBGP ルーティングを設定するには、次の作業を実行します。


) VPN-IPv4 EBGP ネイバーのホスト ルートが(IGP によって)他のルータおよびプロバイダー エッジ ルータに伝播されるようにするには、CEBGP ルータの IGP 設定部分で redistribute connected コマンドを指定します。OSPF を使用している場合は、「redistribute connected」サブネットが存在する CEBGP インターフェイスで OSPF プロセスがイネーブルにならないようにする必要があります。



) この連合では、サブ自律システムの IGP ドメインで CEBGP-1 および CEBGP-2 のアドレスが認識されている必要があります。ルータ設定の一部として next-hop-self アドレスを指定しない場合は、CEBGP-1 および CEBGP-2 のアドレスだけでなく、サブ自律システム内のすべての PE ルータのアドレスがネットワーク全体に配布されるようにする必要があります。


手順の概要

1. enable

2. configure terminal

3. router bgp sub-autonomous-system

4. bgp confederation identifier as-number

5. bgp confederation peers sub-autonomous-system

6. no bgp default route-target filter

7. address-family vpnv4 [ unicast ]

8. neighbor peer-group-name remote-as as-number

9. neighbor peer-group-name next-hop-self

10. neighbor peer-group-name activate

11. exit-address-family

12. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp sub-autonomous-system

 

Router(config)# router bgp 2

EBGP ルーティング プロセスを作成し、それに自律システム番号を割り当てて、ルータでコンフィギュレーション モードを開始します。

サブ自律システム番号は、他のサブ自律システムの EBGP ルータでルータを識別できるようにするために渡されます。

ステップ 4

bgp confederation identifier as-number

 

Router(config-router)# bgp confederation identifier 100

各サブ自律システムに関連付けられる連合識別子を指定することによって、EBGP 連合を定義します。

サブ自律システムは、単一の自律システムと見なされます。

ステップ 5

bgp confederation peers sub-autonomous-system

 

Router(config-router)# bgp confederation peers 1

連合に属するサブ自律システムを指定します(連合内の他のサブ自律システムのネイバーを特殊な EBGP ピアとして指定します)。

ステップ 6

no bgp default route-target filter

 

Router(config-router)# no bgp default route-target filter

BGP の route-target コミュニティ フィルタリングをディセーブルにします。受信したすべての BGP VPN-IPv4 ルートがルータによって受け入れられます。

ステップ 7

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

VPN バックボーン全体で VPNv4 アドレスを伝送するルーティング セッションを設定します。8 バイトの RD を追加することによって、各アドレスはグローバルに一意になります。アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードによって、ユニキャスト プレフィクスが指定されます。

ステップ 8

neighbor peer-group-name remote-as as-number

 

Router(config-router-af)# neighbor 1 remote-as 1

アドレス ファミリ コンフィギュレーション モードを開始して、隣接 EBGP ピア グループを指定します。

この EBGP ピア グループは、指定したサブ自律システムに属すると見なされます。

ステップ 9

neighbor peer-group-name next-hop-self

 

Router(config-router-af)# neighbor 1 next-hop-self

ルータを指定したネイバーのネクストホップとしてアドバタイズします。

next-hop-self アドレスがルータ設定の一部として指定されている場合は、 redistribute connected コマンドを使用する必要はありません。

ステップ 10

neighbor peer-group-name activate

 

Router(config-router-af)# neighbor R activate

指定したサブ自律システムのネイバー PE ルータへの VPNv4 アドレス ファミリのアドバタイズメントをアクティブにします。

ステップ 11

exit-address-family

 

Router(config-router-af)# exit-address-family

ルータ コンフィギュレーション モードのアドレス ファミリ サブモードを終了します。

ステップ 12

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

ASBR で VPN-IPv4 アドレスを交換する Inter-AS の確認

VPN-IPv4 LFIB エントリを表示するには、次の作業を実行します。

手順の概要

1. enable

2. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

3. show mpls forwarding - table [ network { mask | length } | labels label [ -label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

4. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

 

Router# show ip bgp vpnv4 all labels

BGP テーブルの VPN アドレス情報を表示します。

すべての VPNv4 ラベルについての情報を表示するには、 all キーワードおよび labels キーワードを使用します。

ステップ 3

show mpls forwarding-table [ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

 

Router# show mpls forwarding-table

MPLS LFIB の内容(ルートの VPNv4 プレフィクスや長さ、BGP ネクストホップ宛先など)を表示します。

ステップ 4

disable

 

Router# disable

終了して、ユーザ EXEC モードに戻ります。

show mpls forwarding-table コマンドのサンプル出力で、VPN-IPv4 LFIB がどのように表示されるかを示します。

Router# show mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
33 33 10.120.4.0/24 0 Hs0/0 point2point
35 27 100:12:10.200.0.1/32 \
0 Hs0/0 point2point
 

この例では、Prefix フィールドは VPN-IPv4 RD およびプレフィクスとして表示されています。(例の最後の行のように)値が Prefix カラムの幅よりも長い場合は、転送テーブルの出力が自動的に次の行に折り返されて、カラムの位置合せが維持されます。

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS の設定例

ここでは、MPLS VPN Inter-AS の次の設定例について説明します。

「ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-ASの設定:例」

「連合における ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS の設定:例」

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-ASの設定:例

図 7 のネットワーク トポロジは、次のように設定された 2 つの自律システムを示しています。

自律システム 1(AS1)には、PE1、P1、および EBGP1 が含まれています。IGP は OSPF です。

自律システム 2(AS2)には、PE2、P2、および EBGP2 が含まれています。IGP は IS-IS です。

CE1 および CE2 は、VPN1 という同じ VPN に属しています。

P ルータはルート リフレクタです。

EBGP1 は、 redistribute connected subnets コマンドを使用して設定されています。

EBGP2 は、 neighbor next-hop-self コマンドを使用して設定されています。

図 7 2 つの自律システムの設定

 

自律システム 1、CE1 の設定:例

次の例は、2 つの自律システムがあるトポロジにおける VPN1 の CE1 の設定方法を示しています(図 7 を参照)。

CE1: Burlington
!
interface Loopback1
ip address aa.0.0.6 255.255.255.255
!
interface Serial1/3
description wychmere
no ip address
encapsulation frame-relay
frame-relay intf-type dce
!
interface Serial1/3.1 point-to-point
description wychmere
ip address aa.6.2.1 255.255.255.252
frame-relay interface-dlci 22
!
router ospf 1
network aa.0.0.0 0.255.255.255 area 0

自律システム 1、PE1 の設定:例

次の例は、2 つの自律システムがあるトポロジにおける AS1 の PE1 の設定方法を示しています(図 7 を参照)。

PE1: wychmere
!
ip cef
!
ip vrf V1
rd 1:105
route-target export 1:100
route-target import 1:100
!
interface Serial0/0
description Burlington
no ip address
encapsulation frame-relay
no fair-queue
clockrate 2000000
!
interface Serial0/0.3 point-to-point
description Burlington
ip vrf forwarding V1
ip address aa.6.2.2 255.255.255.252
frame-relay interface-dlci 22
!
interface Ethernet0/1
description Vermont
ip address aa.2.2.5 255.255.255.0
tag-switching ip
!
router ospf 1
log-adjacency-changes
network aa.0.0.0 0.255.255.255 area 0
!
router ospf 10 vrf V1
log-adjacency-changes
redistribute bgp 1 metric 100 subnets
network aa.0.0.0 0.255.255.255 area 0
!
router bgp 1
no synchronization
neighbor 1 peer-group
neighbor 1 remote-as 1
neighbor 1 update-source Loopback0
neighbor aa.0.0.2 peer-group R
no auto-summary
!
address-family ipv4 vrf V1
redistribute ospf 10
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor R activate
neighbor R send-community extended
neighbor aa.0.0.2 peer-group R
no auto-summary
exit-address-family

自律システム 1、P1 の設定:例

次の例は、2 つの自律システムがあるトポロジにおける AS1 の P1 の設定方法を示しています(図 7 を参照)。

P1: Vermont
!
ip cef
!
interface Loopback0
ip address aa.0.0.2 255.255.255.255
!
interface Ethernet0/1
description Ogunquit
ip address aa.2.1.1 255.255.255.0
tag-switching ip
!
interface FastEthernet2/0
description wychmere
ip address aa.2.2.1 255.255.255.0
duplex auto
speed auto
tag-switching ip
!
router ospf 1
log-adjacency-changes
network aa.0.0.0 0.255.255.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor R peer-group
neighbor R remote-as 1
neighbor R update-source Loopback0
neighbor R route-reflector-client
neighbor aa.0.0.4 peer-group R
neighbor aa.0.0.5 peer-group R
!
address-family vpnv4
neighbor R activate
neighbor R route-reflector-client
neighbor R send-community extended
neighbor aa.0.0.4 peer-group R
neighbor aa.0.0.5 peer-group R
exit-address-family

自律システム 1、EBGP1 の設定:例

次の例は、2 つの自律システムがあるトポロジにおける AS1 の EBGP1 の設定方法を示しています(図 7 を参照)。

EBGP1: Ogunquit
!
ip cef
!
interface Loopback0
ip address aa.0.0.4 255.255.255.255
!
EBGP1: Ogunquit
!
ip cef
!
interface Loopback0
ip address aa.0.0.4 255.255.255.255
!
interface Ethernet0/1
description Vermont
ip address aa.2.1.40 255.255.255.0
tag-switching ip
!
interface ATM1/0
description Lowell
no ip address
no atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
description Lowell
ip address aa.0.0.1 255.255.255.252
pvc 1/100
!
router ospf 1
log-adjacency-changes
redistribute connected subnets
network aa.0.0.0 0.255.255.255 area 0
!
router bgp 1
no synchronization
no bgp default route-target filter
bgp log-neighbor-changes
neighbor R peer-group
neighbor R remote-as 1
neighbor R update-source Loopback0
neighbor aa.0.0.2 remote-as 2
neighbor aa.0.0.2 peer-group R
no auto-summary
!
address-family vpnv4
neighbor R activate
neighbor R send-community extended
neighbor aa.0.0.2 activate
neighbor aa.0.0.2 send-community extended
neighbor aa.0.0.2 peer-group R
no auto-summary
exit-address-family

自律システム 2、EBGP2 の設定:例

次の例は、2 つの自律システムがあるトポロジにおける AS2 の EBGP2 の設定方法を示しています(図 7 を参照)。

EBGP2: Lowell
!
ip cef
!
ip vrf V1
rd 2:103
route-target export 1:100
route-target import 1:100
!
interface Loopback0
ip address aa.0.0.3 255.255.255.255
ip router isis
!
interface Loopback1
ip vrf forwarding V1
ip address aa.0.0.3 255.255.255.255
!
interface Serial0/0
description Littleton
no ip address
encapsulation frame-relay
load-interval 30
no fair-queue
clockrate 2000000
!
interface Serial0/0.2 point-to-point
description Littleton
ip unnumbered Loopback0
ip router isis
tag-switching ip
frame-relay interface-dlci 23
!
interface ATM1/0
description Ogunquit
no ip address
atm clock INTERNAL
no atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
description Ogunquit
ip address aa.0.0.2 255.255.255.252
pvc 1/100
!
router isis
net 49.0002.0000.0000.0003.00
!
router bgp 2
no synchronization
no bgp default route-target filter
bgp log-neighbor-changes
neighbor aa.0.0.1 remote-as 1
neighbor aa.0.0.8 remote-as 2
neighbor aa.0.0.8 update-source Loopback0
neighbor aa.0.0.8 next-hop-self
!
address-family ipv4 vrf V1
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor aa.0.0.1 activate
neighbor aa.0.0.1 send-community extended
neighbor aa.0.0.8 activate
neighbor aa.0.0.8 next-hop-self
neighbor aa.0.0.8 send-community extended
exit-address-family

自律システム 2、P2 の設定:例

次の例は、2 つの自律システムがあるトポロジにおける AS2 の P2 の設定方法を示しています(図 7 を参照)。

P2: Littleton
!
ip cef
!
ip vrf V1
rd 2:108
route-target export 1:100
route-target import 1:100
!
interface Loopback0
ip address aa.0.0.8 255.255.255.255
ip router isis
!
interface Loopback1
ip vrf forwarding V1
ip address aa.0.0.8 255.255.255.255
!
interface FastEthernet0/0
description Pax
ip address aa.9.1.2 255.255.255.0
ip router isis
tag-switching ip
!
interface Serial5/0
description Lowell
no ip address
encapsulation frame-relay
frame-relay intf-type dce
!
interface Serial5/0.1 point-to-point
description Lowell
ip unnumbered Loopback0
ip router isis
tag-switching ip
frame-relay interface-dlci 23
!
router isis
net aa.0002.0000.0000.0008.00
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor R peer-group
neighbor R remote-as 2
neighbor R update-source Loopback0
neighbor R route-reflector-client
neighbor aa.0.0.3 peer-group R
neighbor aa.0.0.9 peer-group R
!
address-family ipv4 vrf V1
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor R activate
neighbor R route-reflector-client
neighbor R send-community extended
neighbor aa.0.0.3 peer-group R
neighbor aa.0.0.9 peer-group R
exit-address-family

自律システム 2、PE2 の設定:例

次の例は、2 つの自律システムがあるトポロジにおける AS2 の PE2 の設定方法を示しています(図 7 を参照)。

PE2: Pax
!
ip cef
!
ip vrf V1
rd 2:109
route-target export 1:100
route-target import 1:100
!
interface Loopback0
ip address aa.0.0.9 255.255.255.255
ip router isis
!
interface Loopback1
ip vrf forwarding V1
ip address aa.0.0.9 255.255.255.255
!
interface Serial0/0
description Bethel
no ip address
encapsulation frame-relay
frame-relay intf-type dce
no fair-queue
clockrate 2000000
!
interface Serial0/0.1 point-to-point
description Bethel
ip vrf forwarding V1
ip unnumbered Loopback1
frame-relay interface-dlci 24
!
interface FastEthernet0/1
description Littleton
ip address aa.9.1.1 255.255.255.0
ip router isis
tag-switching ip
!
router ospf 10 vrf V1
log-adjacency-changes
redistribute bgp 2 subnets
network aa.0.0.0 0.255.255.255 area 0
!
router isis
net 49.0002.0000.0000.0009.00
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor aa.0.0.8 remote-as 2
neighbor aa.0.0.8 update-source Loopback0
!
address-family ipv4 vrf V1
redistribute connected
redistribute ospf 10
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor aa.0.0.8 activate
neighbor aa.0.0.8 send-community extended
exit-address-family v

自律システム 2、CE2 の設定:例

次の例は、2 つの自律システムがあるトポロジにおける VPN1 の CE2 の設定方法を示しています(図 7 を参照)。

CE2: Bethel
!
interface Loopback0
ip address 1.0.0.11 255.255.255.255
!
interface Serial0
description Pax
no ip address
encapsulation frame-relay
no fair-queue
clockrate 2000000
!
interface Serial0.1 point-to-point
description Pax
ip unnumbered Loopback0
frame-relay interface-dlci 24
!
router ospf 1
network aa.0.0.0 0.255.255.255 area 0

連合における ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS の設定:例

図 8 のネットワーク トポロジは、バックボーンを連合でパーティション化した、単一のインターネット サービス プロバイダーを示しています。プロバイダーの自律システム番号は 100 です。2 つの自律システムでは独自の IGP が実行されており、次のように設定されています。

自律システム 1(AS1)には、PE1、P1、ASBR1 が含まれています。IGP は OSPF です。

自律システム 2(AS2)には、PE2、P2、ASBR2 が含まれています。IGP は IS-IS です。

CE1 および CE2 は、VPN1 という同じ VPN に属しています。

P ルータはルート リフレクタです。

ASBR1 は、 redistribute connected subnets コマンドを使用して設定されています。

ASBR2 は、 neighbor next-hop-self コマンドを使用して設定されています。

図 8 連合内の 2 つの自律システムの設定

 

自律システム 1、CE1 の設定:例

次の例は、連合トポロジにおける VPN1 の CE1 の設定方法を示しています(図 8 を参照)。

CE1: Burlington
!
interface Loopback1
ip address aa.0.0.6 255.255.255.255
!
interface Serial1/3
description wychmere
no ip address
encapsulation frame-relay
frame-relay intf-type dce
!
interface Serial1/3.1 point-to-point
description wychmere
ip address aa.6.2.1 255.255.255.252
frame-relay interface-dlci 22
!
router ospf 1
network aa.0.0.0 0.255.255.255 area 0

自律システム 1、PE1 の設定:例

次の例は、連合トポロジにおける AS1 の PE1 の設定方法を示しています(図 8 を参照)。

 
PE1: wychmere
!
ip cef
!
ip vrf V1
rd 1:105
route-target export 1:100
route-target import 1:100
!
interface Serial0/0
description Burlington
no ip address
encapsulation frame-relay
no fair-queue
clockrate 2000000
!
interface Serial0/0.3 point-to-point
description Burlington
ip vrf forwarding V1
ip address aa.6.2.2 255.255.255.252
frame-relay interface-dlci 22
!
interface Ethernet0/1
description Vermont
ip address aa.2.2.5 255.255.255.0
tag-switching ip
!
router ospf 1
log-adjacency-changes
network aa.0.0.0 0.255.255.255 area 0
!
router ospf 10 vrf V1
log-adjacency-changes
redistribute bgp 1 metric 100 subnets
network aa.0.0.0 0.255.255.255 area 0
!
router bgp 1
no synchronization
bgp confederation identifier 100
bgp confederation identifier 100
neighbor 1 peer-group
neighbor 1 remote-as 1
neighbor 1 update-source Loopback0
neighbor aa.0.0.2 peer-group R
no auto-summary
!
address-family ipv4 vrf V1
redistribute ospf 10
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor R activate
neighbor R send-community extended
neighbor aa.0.0.2 peer-group R
no auto-summary
exit-address-family

自律システム 1、P1 の設定:例

次の例は、連合トポロジにおける AS1 の P1 の設定方法を示しています(図 8 を参照)。

 
P1: Vermont
!
ip cef
!
interface Loopback0
ip address aa.0.0.2 255.255.255.255
!
interface Ethernet0/1
description Ogunquit
ip address 100.2.1.1 255.255.255.0
tag-switching ip
!
interface FastEthernet2/0
description wychmere
ip address aa.2.2.1 255.255.255.0
duplex auto
speed auto
tag-switching ip
!
router ospf 1
log-adjacency-changes
network aa.0.0.0 0.255.255.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 100
neighbor R peer-group
neighbor R remote-as 1
neighbor R update-source Loopback0
neighbor R route-reflector-client
neighbor 100.0.0.4 peer-group R
neighbor 100.0.0.5 peer-group R
!
address-family vpnv4
neighbor R activate
neighbor R route-reflector-client
neighbor R send-community extended
neighbor aa.0.0.4 peer-group R
neighbor aa.0.0.5 peer-group R
exit-address-family

自律システム 1、ASBR1 の設定:例

次の例は、連合トポロジにおける AS1 の ASBR1 の設定方法を示しています(図 8 を参照)。

 
EBGP1: Ogunquit
!
ip cef
!
interface Loopback0
ip address aa.0.0.4 255.255.255.255
!
interface Ethernet0/1
description Vermont
ip address aa.2.1.40 255.255.255.0
tag-switching ip
!
interface ATM1/0
description Lowell
no ip address
no atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
description Lowell
ip address aa.0.0.1 255.255.255.252
pvc 1/100
!
router ospf 1
log-adjacency-changes
redistribute connected subnets
network aa.0.0.0 0.255.255.255 area 0
!
router bgp 1
no synchronization
no bgp default route-target filter
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation peers 1
neighbor R peer-group
neighbor R remote-as 1
neighbor R update-source Loopback0
neighbor aa.0.0.2 remote-as 2
neighbor aa.0.0.2 next-hop-self
neighbor aa.0.0.2 peer-group R
no auto-summary
!
address-family vpnv4
neighbor R activate
neighbor R send-community extended
neighbor aa.0.0.2 activate
neighbor aa.0.0.2 next-hop-self
neighbor aa.0.0.2 send-community extended
neighbor aa.0.0.2 peer-group R
no auto-summary
exit-address-family

自律システム 2、ASBR2 の設定:例

次の例は、連合トポロジにおける AS2 の ASBR2 の設定方法を示しています(図 8 を参照)。

 
EBGP2: Lowell
!
ip cef
!
ip vrf V1
rd 2:103
route-target export 1:100
route-target import 1:100
!
interface Loopback0
ip address aa.0.0.3 255.255.255.255
ip router isis
!
interface Loopback1
ip vrf forwarding V1
ip address aa.0.0.3 255.255.255.255
!
interface Serial0/0
description Littleton
no ip address
encapsulation frame-relay
load-interval 30
no fair-queue
clockrate 2000000
!
interface Serial0/0.2 point-to-point
description Littleton
ip unnumbered Loopback0
ip router isis
tag-switching ip
frame-relay interface-dlci 23
!
interface ATM1/0
description Ogunquit
no ip address
atm clock INTERNAL
no atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
description Ogunquit
ip address aa.0.0.2 255.255.255.252
pvc 1/100
!
router isis
net aa.0002.0000.0000.0003.00
!
router bgp 2
no synchronization
no bgp default route-target filter
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation peers 1
neighbor aa.0.0.1 remote-as 1
neighbor aa.0.0.1 next-hop-self
neighbor aa.0.0.8 remote-as 2
neighbor aa.0.0.8 update-source Loopback0
neighbor aa.0.0.8 next-hop-self
!
address-family ipv4 vrf V1
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor aa.0.0.1 activate
neighbor aa.0.0.1 next-hop-self
neighbor aa.0.0.1 send-community extended
neighbor aa.0.0.8 activate
neighbor aa.0.0.8 next-hop-self
neighbor aa.0.0.8 send-community extended
exit-address-family

自律システム 2、P2 の設定:例

次の例は、連合トポロジにおける AS2 の P2 の設定方法を示しています(図 8 を参照)。

 
P2: Littleton
!
ip cef
!
ip vrf V1
rd 2:108
route-target export 1:100
route-target import 1:100
!
interface Loopback0
ip address aa.0.0.8 255.255.255.255
ip router isis
!
interface Loopback1
ip vrf forwarding V1
ip address aa.0.0.8 255.255.255.255
!
interface FastEthernet0/0
description Pax
ip address aa.9.1.2 255.255.255.0
ip router isis
tag-switching ip
!
interface Serial5/0
description Lowell
no ip address
encapsulation frame-relay
frame-relay intf-type dce
!
interface Serial5/0.1 point-to-point
description Lowell
ip unnumbered Loopback0
ip router isis
tag-switching ip
frame-relay interface-dlci 23
!
router isis
net aa.0002.0000.0000.0008.00
!
router bgp 2
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 100
neighbor R peer-group
neighbor R remote-as 2
neighbor R update-source Loopback0
neighbor R route-reflector-client
neighbor aa.0.0.3 peer-group R
neighbor aa.0.0.9 peer-group R
!
address-family ipv4 vrf V1
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor R activate
neighbor R route-reflector-client
neighbor R send-community extended
neighbor aa.0.0.3 peer-group R
neighbor aa.0.0.9 peer-group R
exit-address-family

自律システム 2、PE2 の設定:例

次の例は、連合トポロジにおける AS2 の PE2 の設定方法を示しています(図 8 を参照)。

 
PE2: Pax
!
ip cef
!
ip vrf V1
rd 2:109
route-target export 1:100
route-target import 1:100
!
interface Loopback0
ip address aa.0.0.9 255.255.255.255
ip router isis
!
interface Loopback1
ip vrf forwarding V1
ip address 1.0.0.9 255.255.255.255
!
interface Serial0/0
description Bethel
no ip address
encapsulation frame-relay
frame-relay intf-type dce
no fair-queue
clockrate 2000000
!
interface Serial0/0.1 point-to-point
description Bethel
ip vrf forwarding V1
ip unnumbered Loopback1
frame-relay interface-dlci 24
!
interface FastEthernet0/1
description Littleton
ip address 200.9.1.1 255.255.255.0
ip router isis
tag-switching ip
!
router ospf 10 vrf V1
log-adjacency-changes
redistribute bgp 2 subnets
network aa.0.0.0 0.255.255.255 area 0
!
router isis
net aa.0002.0000.0000.0009.00
!
router bgp 2
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 100
neighbor aa.0.0.8 remote-as 2
neighbor aa.0.0.8 update-source Loopback0
!
address-family ipv4 vrf V1
redistribute connected
redistribute ospf 10
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor aa.0.0.8 activate
neighbor aa.0.0.8 send-community extended
exit-address-family

自律システム 2、CE2 の設定:例

次の例は、連合トポロジにおける VPN1 の CE2 の設定方法を示しています(図 8 を参照)。

 
CE2: Bethel
!
interface Loopback0
ip address aa.0.0.11 255.255.255.255
!
interface Serial0
description Pax
no ip address
encapsulation frame-relay
no fair-queue
clockrate 2000000
!
interface Serial0.1 point-to-point
description Pax
ip unnumbered Loopback0
frame-relay interface-dlci 24
!
router ospf 1
network aa.0.0.0 0.255.255.255 area 0

コマンド リファレンス

この機能では、新しいコマンドや変更されたコマンドは使用されません。

その他の関連資料

ここでは、MPLS VPN に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS

『MPLS Product Literature』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1700

『Assigned Numbers』

RFC 1966

BGP Route Reflection: An Alternative to Full Mesh IBGP

RFC 2842

Capabilities Advertisement with BGP-4

RFC 2858

『Multiprotocol Extensions for BGP-4』

RFC 3107

『Carrying Label Information in BGP-4』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-ASの機能情報

表 2 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 2 ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-ASの機能情報

機能名
リリース
機能情報

MPLS VPN:相互自律システム サポート

12.1(5)T
12.0(16)ST
12.0(17)ST
12.0(22)S

この機能を使用すると、MPLS VPN が複数のサービス プロバイダーと自律システムにまたがることができます。この機能では、VPN-IPv4 アドレスを交換する ASBR を使用して Inter-AS を設定する方法について説明します。

この機能では、新しいコマンドや変更されたコマンドは使用されません。