マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
VPLS Autodiscovery:BGP Based
VPLS Autodiscovery:BGP Based
発行日;2012/01/30 | 英語版ドキュメント(2011/07/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

VPLS Autodiscovery:BGP Based

機能情報の確認

目次

VPLS Autodiscovery:BGP Based の前提条件

VPLS Autodiscovery:BGP Based の制約事項

VPLS Autodiscovery:BGP Based に関する情報

VPLS 機能の動作

VPLS Autodiscovery:BGP Based 機能の動作

VPLS Autodiscovery のイネーブル化と VPLS の手動設定の違い

VPLS Autodiscovery:BGP Based による影響を受ける show コマンド

ルート リフレクタの BGP VPLS Autodiscovery サポート

VPLS Autodiscovery:BGP Based の設定方法

VPLS Autodiscovery:BGP Based のイネーブル化

前提条件

VPLS Autodiscovery をイネーブル化する BGP の設定

VPLS Autodiscovery 設定のカスタマイズ

VPLS Autodiscovery:BGP Based の設定例

VPLS Autodiscovery:BGP Based:基本設定例

ルート リフレクタでの BGP VPLS Autodiscovery サポート:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

VPLS Autodiscovery:BGP Based の機能情報

VPLS Autodiscovery:BGP Based

VPLS Autodiscovery を使用すると、各 Virtual Private LAN Service(VPLS; バーチャル プライベート LAN サービス)Provider Edge(PE; プロバイダー エッジ)ルータで、同じ VPLS ドメインの一部である他の PE ルータを検出できます。また、VPLS Autodiscovery を使用すると、VPLS ドメインに対して PE ルータが追加または削除されるときを自動的に検出できます。そのため、VPLS を手動で設定して、PE ルータが追加または削除されるときに設定を保守する必要がなくなります。VPLS Autodiscovery は、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を使用して、VPLS メンバを検出して、VPLS の擬似回線をセットアップおよび解除します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「VPLS Autodiscovery:BGP Based の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

VPLS Autodiscovery:BGP Based の前提条件

Cisco 7600 シリーズ ルータを使用している場合、VPLS Autodiscovery を設定する前に、『 Cisco 7600 Series Router IOS Software Configuration Guide, 12.2SR 』の「Virtual Private LAN Services on the Optical Service Modules」という項にある Cisco 7600 ルータ固有の作業を実行します。

VPLS Autodiscovery:BGP Based の制約事項

VPLS Autodiscovery は、IPV4 アドレスだけをサポートします。

VPLS Autodiscovery は、Forwarding Equivalence Class(FEC)129 を使用してエンドポイント情報を伝達します。手動で設定された擬似回線は、FEC 128 を使用します。

VPLS Autodiscovery は、Layer 2 Tunnel Protocol Version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)ではサポートされません。

VPLS Autodisocovery は、相互自律システム設定ではサポートされません。

単一の Virtual Forwarding Instance(VFI)で、自動検出および手動設定された擬似回線の両方を設定できます。ただし、これらの擬似回線が同じピア PE ルータを使用することはできません。

VPLS Autodiscovery をイネーブルにして、両方のピアが自動検出モードになったあとで、 neighbor (VPLS) コマンドを使用してネイバーを手動設定する場合、各ピアでその VPLS の検出データを受け取らないように、Route Target(RT; ルート ターゲット)値を手動設定します。

複数の擬似回線を手動設定し、各擬似回線で同じ PE ルータの異なる IP アドレスをターゲットにする場合、同じ Virtual Circuit Identifier(VC ID; 仮想回線識別子)を使用して同じ PE ルータで終端する擬似回線を識別しないでください。

擬似回線を設定する場合、PE ルータでネイバーを手動設定し、他の PE ルータで自動検出を使用し他方向の同じ擬似回線を設定することはできません。

トンネル選択は、自動検出されたネイバーではサポートされません。

VFI あたり最大 16 のルート ターゲットを使用できます。

同じ PE ルータの複数の VFI で、同じ RT を使用することはできません。

BGP 自動検出プロセスは、ダイナミック階層 VPLS をサポートしません。User-facing PE(U-PE)ルータは、Network-facing PE(N-PE)ルータを検出できません。また、N-PE ルータは、U-PE ルータを検出できません。

自動検出されたネイバーの擬似回線では、スプリット ホライズンがイネーブルにされます。そのため、階層 VPLS の擬似回線を手動設定します。U-PE ルータは、これらの擬似回線の BGP 自動検出には参加しないことを確認してください。

自動検出されたネイバーでスプリット ホライズンをディセーブルにしないでください。スピリット ホライズンは、VPLS Autodiscovery で必須です。

プロビジョニングされるピア アドレスは、ピアの Label Distribution Protocol(LDP; ラベル配布プロトコル)ルータ ID にバインドした /32 アドレスでなければなりません。

ピア PE ルータは、ローカル LDP ルータ ID として使用される IP アドレスにアクセスできなければなりません。IP アドレスピア PE ルータの xconnect コマンドで使用する必要はありませんが、その IP アドレスは到達可能でなければなりません。

VPLS Autodiscovery は、Cisco 7600 ルータ ハードウェアでサポートされます。サポートされている共有ポート アダプタおよびラインカードの詳細については、次のマニュアルを参照してください。

『Cisco 7600 Series Router Cisco IOS Software Configuration Guide』

『Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers』

VPLS Autodiscovery:BGP Based に関する情報

VPLS Autodiscovery を理解するには、次の概念を理解しておく必要があります。

「VPLS 機能の動作」

「VPLS Autodiscovery:BGP Based 機能の動作」

「VPLS Autodiscovery のイネーブル化と VPLS の手動設定の違い」

「VPLS Autodiscovery:BGP Based による影響を受ける show コマンド」

「ルート リフレクタの BGP VPLS Autodiscovery サポート」

VPLS 機能の動作

VPLS では、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークで、Transparent LAN Services(TLS; 透過型 LAN サービス)としても知られる、マルチポイント イーサネット LAN サービスを提供できます。VPLS のすべてのカスタマー サイトは、地理的な場所が異なる可能性がある場合でも、同じ LAN 上にあります。

VPLS Autodiscovery:BGP Based 機能の動作

VPLS Autodiscovery では、各 VPLS PE ルータは、同じ VPLS ドメインの一部である他の PE ルータを検出できます。また、VPLS Autodiscovery は、VPLS ドメインに対して PE ルータがいつ追加または削除されたかを追跡できます。自動検出およびシグナリング機能は、BGP を使用して、PE ルータを検出および追跡します。

BGP では、エンドポイント プロビジョニング情報を保存するときに L2VPN Routing Information Base(RIB; ルーティング情報ベース)が使用されます。これは、レイヤ 2 VFI が設定されたときに毎回アップデートされます。プレフィクスおよびパス情報は L2VPN データベースに保存され、最適パスが BGP により決定されるようになります。BGP により、アップデート メッセージですべての BGP ネイバーにエンドポイント プロビジョニング情報が配布されるとき、L2VPN ベースのサービスをサポートするために、エンドポイント情報を使用して擬似回線メッシュが設定されます。

BGP オートディスカバリ メカニズムにより、Cisco IOS Virtual Private LAN Service(VPLS; バーチャル プライベート LAN サービス)機能に必要不可欠な L2VPN サービスの設定が簡易化されます。VPLS は、高速イーサネット使用した堅牢でスケーラブルな IP MPLS ネットワークによる大規模な LAN として、地理的に分散した拠点間を接続することで柔軟なサービスの展開を実現します。VPLS Autodiscovery に関連する BGP および L2VPN アドレス ファミリの詳細については、次のマニュアルを参照してください。

Cisco BGP Overview 』の「L2VPN Address Family」の項

BGP Support for the L2VPN Address Family 』マニュアル

VPLS Autodiscovery のイネーブル化と VPLS の手動設定の違い

VPLS Autodiscovery では、VPLS を手動セットアップする必要はありません。VPLS Autodiscovery のセットアップに使用するコマンドは、 表 1 に示すように、VPLS の手動設定に使用するコマンドと似ています。VPLS Autodiscovery は、 neighbor コマンドを L2VPN アドレス ファミリ モードで使用して、エンドポイント情報を配布し、擬似回線を設定します。

表 1 VPLS Autodiscovery 設定と VPLS の手動設定

VPLS の手動設定
VPLS Autodiscovery:BGP Based
 
l2 vfi vpls1 manual
vpn id 100
neighbor 10.10.10.1 encapsulation mpls
neighbor 10.10.10.0 encapsulation mpls
exit
 
l2 vfi vpls1 autodiscovery
vpn id 100
exit
 
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback1
.
.
.
address-family l2vpn vpls
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
exit-address-family

VPLS Autodiscovery を設定する場合、 l2vfi autodiscovery コマンドを入力します。このコマンドを使用すると、VFI は、擬似回線エンドポイントを学習およびアドバタイズできます。その結果、 neighbor (VPLS) コマンドを L2 VFI コンフィギュレーション モードで入力する必要はありません。

ただし、 neighbor (VPLS) コマンドは、L2 VFI コマンド モードの VPLS Autodiscovery で引き続きサポートされます。 neighbor (VPLS) コマンドを使用すると、自動検出プロセスに参加しない PE ルータが VPLS に参加できます。また、 neighbor (VPLS) コマンドは、トンネル選択機能を使用して設定された PE ルータで使用できます。さらに、 neighbor (VPLS) コマンドは、自動検出プロセスに参加せず、スピリット ホライズン フォワーディングがディセーブルにされている U-PE ルータがある階層 VPLS 設定で使用できます。

VPLS Autodiscovery:BGP Based による影響を受ける show コマンド

VPLS Autodiscovery では、次の show コマンドが変更されました。

detail キーワードを指定した show mpls l2transport vc コマンドは、自動検出された VPLS 擬似回線の FEC 129 シグナリング情報を含むようにアップデートされました。

show vfi コマンドは、自動検出された VFI に関する情報を表示するようになりました。新しい情報には、VPLS ID、Route Distinguisher(RD; ルート識別子)、RT および検出されたピアのルータ ID が含まれます。

show xconnect コマンドがアップデートされ、 rib キーワードを使用すると、擬似回線に関する RIB 情報を提供するようになりました。

ルート リフレクタの BGP VPLS Autodiscovery サポート

VPLS Autodiscovery は、通常、PE ルータで実行され、エンドポイント検出および PE(通常は完全メッシュ)間での擬似回線のセットアップをサポートします。VPLS は、通常、BGP ルート リフレクタでは実行されません。Cisco IOS Release 12.2(33)SRE では、ルート リフレクタの VPLS Autodiscovery サポートが導入されました。BGP ルート リフレクタは、ルート リフレクタで VPLS を明示的に設定せずに、BGP VPLS プレフィクスを反映するときに使用できます。

ルート リフレクタは、自動検出に参加しません。つまり、ルート リフレクタおよび PE 間で擬似回線はセットアップされません。ルート リフレクタは VPLS プレフィクスを他の PE に反映し、PE が BGP セッションの完全メッシュを持つ必要がないようにします。ネットワーク管理者はルート リフレクタの BGP VPLS アドレス ファミリだけを設定します。ルート リフレクタでの VPLS 自動検出サポートの設定例については、「ルート リフレクタでの BGP VPLS Autodiscovery サポート:例」を参照してください。

VPLS Autodiscovery:BGP Based の設定方法

VPLS Autodiscovery を設定するには、次の作業を実行します。

「VPLS Autodiscovery:BGP Based のイネーブル化」(必須)

「VPLS Autodiscovery をイネーブル化する BGP の設定」(必須)

「VPLS Autodiscovery 設定のカスタマイズ」(任意)

VPLS Autodiscovery:BGP Based のイネーブル化

次の作業を実行すると、各 VPLS PE ルータで、同じ VPLS ドメインの一部である他の PE ルータを検出できます。

前提条件

VPLS Autodiscovery を設定する前に、『 Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SR 』の「Virtual Private LAN Services on the Optical Services Modules」の章にある Cisco 7600 ルータ固有の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. l2 vfi vfi-name autodiscovery

4. vpn id vpn-id

5. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

l2 vfi vfi-name autodiscovery

 

Router(config)# l2 vfi vpls1 autodiscovery

VPLS Autodiscovery を PE ルータをイネーブルにして、L2 VFI コンフィギュレーション モードを開始します。

ステップ 4

vpn id vpn-id

 

Router(config-vfi)# vpn id 10

VPLS ドメインの VPN ID を設定します。

ステップ 5

exit

 

Router(config-vfi)# exit

L2 VFI コンフィギュレーション モードを終了します。このコマンドは、ルータが L2 VFI コンフィギュレーション モードを終了するまで機能しません。

VPLS Autodiscovery をイネーブル化する BGP の設定

Cisco IOS Release 12.2(33)SRB では、BGP L2VPN アドレス ファミリが、VPLS Autodiscovery のエンドポイント プロビジョニング情報を含む個別の L2VPN RIB で導入されました。BGP は、レイヤ 2 Virtual Forwarding Instance(VFI)が設定されたときに毎回アップデートされる L2VPN データベースからのエンドポイント プロビジョニング情報を学習します。BGP により、アップデート メッセージですべての BGP ネイバーにエンドポイント プロビジョニング情報が配布されるとき、L2VPN ベースのサービスをサポートするために、エンドポイント情報を使用して擬似回線メッシュが設定されます。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. no bgp default ipv4-unicast

5. bgp log-neighbor-changes

6. neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

7. neighbor { ip-address | peer-group-name } update-source interface

8. 他の BGP ネイバーを設定する場合、ステップ 6 および 7 の操作を繰り返します。

9. address-family l2vpn [ vpls ]

10. neighbor { ip-address | peer-group-name } activate

11. neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

12. L2VPN アドレス ファミリで他の BGP ネイバーをアクティブにする場合、ステップ 10 および 11 の操作を繰り返します。

13. exit-address-family

14. exit

15. exit

16. show vfi

17. show ip bgp l2vpn vpls { all | rd vpn-rd }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 65000

指定されたルーティング プロセスでルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ルーティング プロセスで使用される IPv4 ユニキャスト アドレス ファミリをディセーブルにします。

ルータ コンフィギュレーション コマンドを設定した場合は例外です。既存のネイバー コンフィギュレーションは影響されません。

ステップ 5

bgp log-neighbor-changes

 

Router(config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 6

neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

 

Router(config-router)# neighbor 10.10.10.1 remote-as 65000

指定された自律システム内のネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致する場合、ネイバーは内部ネイバーになります。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致しない場合、ネイバーは外部ネイバーになります。

この例では、10.10.10.1 のネイバーは内部 BGP ネイバーです。

ステップ 7

neighbor { ip-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 10.10.10.1 update-source loopback1

(任意)ルーティング テーブル アップデートを受信するための特定のソース、またはインターフェイスを選択するようにルータを設定します。

この例では、ループバック インターフェイスを使用します。この設定の利点は、ループバック インターフェイスはフラッピング インターフェイスの効果の影響を受けないところにあります。

ステップ 8

他の BGP ネイバーを設定する場合、ステップ 6 および 7 の操作を繰り返します。

--

ステップ 9

address-family l2vpn [ vpls ]

 

Router(config-router)# address-family l2vpn vpls

L2VPN アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

オプションの vpls キーワードは、 VPLS エンドポイント プロビジョニング情報が BGP ピアに配布されるように指定します。

この例では、L2VPN VPLS アドレス ファミリ セッションが作成されます。

ステップ 10

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.10.10.1 activate

ネイバーが L2VPN VPLS アドレス ファミリの情報をローカル ルータと交換できるようにします。

ステップ 11

neighbor { ip-address | peer-group-name } send-community { both | standard | extended }

 

Router(config-router-af)# neighbor 10.10.10.1 send-community extended

コミュニティ アトリビュートを BGP ネイバーに送信する必要があることを指定します。

この例では、拡張コミュニティ アトリビュートが 10.10.10.1 のネイバーに送信されます。

ステップ 12

L2VPN アドレス ファミリで他の BGP ネイバーをアクティブにする場合、ステップ 10 および 11 の操作を繰り返します。

--

ステップ 13

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードに戻ります。

ステップ 14

exit

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了します。

ステップ 15

exit

 

Router(config)# exit

特権 EXEC モードを終了します。

ステップ 16

show vfi

 

Router# show vfi

(任意)設定した VFI インスタンスに関する情報を表示します。

ステップ 17

show ip bgp l2vpn vpls { all | rd vpn-rd }

 

Router# show ip bgp l2vpn vpls all

(任意)Layer2 VPN VPLS アドレス ファミリに関する情報を表示します。

VPLS Autodiscovery 設定のカスタマイズ

VPLS 環境をカスタマイズできるコマンドはいくつかあります。VPLS ドメインの識別子、ルート識別子、ルート ターゲットおよび PE ルータを指定できます。これらの設定をカスタマイズするには、次のステップを実行します。

手順の概要

1. enable

2. configure terminal

3. l2 vfi vfi-name autodiscovery

4. vpn id vpn-id

5. vpls-id { autonomous-system-number : nn | ip-address : nn }

6. rd { autonomous-system-number : nn | ip-address : nn }

7. route-target [ import | export | both ] { autonomous-system-number : nn | ip-address : nn }

8. l2 router-id ip-address

9. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

l2 vfi vfi-name autodiscovery

 

Router(config)# l2 vfi vpls1 autodiscovery

VPLS Autodiscovery を PE ルータをイネーブルにして、L2 VFI コンフィギュレーション モードを開始します。

ステップ 4

vpn id vpn-id

 

Router(config-vfi)# vpn id 10

VPLS ドメインの VPN ID を設定します。

ステップ 5

vpls-id { autonomous-system-number : nn | ip-address : nn }

 

Router(config-vfi)# vpls-id 5:300

(任意)VPLS ドメインを指定します。VPLS Autodiscovery は、BGP 自律システム番号および設定された VFI VPN ID を使用して VPLS ID を自動的に生成するため、このコマンドはオプションです。このコマンドを使用すると、自動的に生成された VPLS ID を変更できます。

VPLS ID 引数の設定形式には 2 種類あります。例で示されているような autonomous-system-number:network number ASN:nn )の形式、または IP-address:network number IP-address:nn )の形式で設定できます。

ステップ 6

rd { autonomous-system-number : nn | ip-address : nn }

 

Router(config-vfi)# rd 2:3

(任意)RD を指定してエンドポイント情報を配布します。VPLS Autodiscovery は、BGP 自律システム番号および設定された VFI VPN ID を使用して RD を自動的に生成するため、このコマンドはオプションです。このコマンドを使用すると、自動的に生成されたルート識別子を変更できます。

ルート識別子の引数を設定するには、2 つの形式があります。例で示されているような autonomous-system-number:network number ASN:nn )の形式、または IP-address:network number IP-address:nn )の形式で設定できます。

ステップ 7

route-target [ import | export | both ] { autonomous-system-number : nn | ip-address : nn }

 

Router(config-vfi)# route-target 600:2222

(任意)Route Target(RT; ルート ターゲット)を指定します。VPLS Autodiscovery は、RD および VPLS ID の下位 6 バイトを使用してルート ターゲットを自動的に生成するため、このコマンドはオプションです。このコマンドを使用すると、自動的に生成されたルート ターゲットを変更できます。

ルート ターゲット引数の設定形式には 2 種類あります。例で示されているような autonomous-system-number:network number ASN:nn )の形式、または IP-address:network number IP-address:nn )の形式で設定できます。

ステップ 8

l2 router-id ip-address

 

Router(config-vfi)# l2 router-id 10.10.10.10

(任意)PE ルータの固有の識別子を指定します。VPLS Autodiscovery は、MPLS グローバル ルータ ID を使用してレイヤ 2 ルータ ID を自動的に生成するため、このコマンドはオプションです。このコマンドを使用すると、自動的に生成された ID を変更できます。

ステップ 9

exit

 

Router(config-vfi)# exit

L2 VFI コンフィギュレーション モードを終了します。このコマンドは、ルータが L2 VFI コンフィギュレーション モードを終了するまで機能しません。

VPLS Autodiscovery:BGP Based の設定例

次に、ルータ リフレクタでサポートされる VPLS Autodiscovery および VPLS Autodiscovery を使用するネットワークの設定例を示します。

「VPLS Autodiscovery:BGP Based:基本設定例」

「ルート リフレクタでの BGP VPLS Autodiscovery サポート:例」

VPLS Autodiscovery:BGP Based:基本設定例

図 1 に、VPLS Autodiscovery の基本設定を示します。

図 1 VPLS Autodiscovery の基本設定

 

PE1

 
l2 router-id 10.1.1.1
l2 vfi auto autodiscovery
vpn id 100
!
pseudowire-class mpls
encapsulation mpls
!
interface Loopback1
ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
description Backbone interface
ip address 192.168.0.1 255.255.255.0
mpls ip
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.255 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback1
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback1
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family l2vpn vpls
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family

PE2

 
l2 router-id 10.1.1.2
l2 vfi auto autodiscovery
vpn id 100
!
pseudowire-class mpls
encapsulation mpls
!
interface Loopback1
ip address 10.1.1.2 255.255.255.255
!
interface Ethernet0/0
description Backbone interface
ip address 192.168.0.2 255.255.255.0
mpls ip
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.255 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback1
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback1
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family l2vpn vpls
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family

PE3

 
l2 router-id 10.1.1.3
l2 vfi auto autodiscovery
vpn id 100
!
pseudowire-class mpls
encapsulation mpls
!
interface Loopback1
ip address 10.1.1.3 255.255.255.255
!
interface Ethernet0/0
description Backbone interface
ip address 192.168.0.3 255.255.255.0
mpls ip
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.255 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback1
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback1
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family l2vpn vpls
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
exit-address-family

ルート リフレクタでの BGP VPLS Autodiscovery サポート:例

次の例では、PE-RR(プロバイダー エッジ ルート リフレクタであることを示す)という名前のホストが、VPLS プレフィクス可能なルート リフレクタとして設定されます。VPLS アドレス ファミリは、次の address-family l2vpn vpls によって設定されます。

hostname PE-RR
!
router bgp 1
bgp router-id 1.1.1.3
no bgp default route-target filter
bgp log-neighbor-changes
neighbor iBGP_PEERS peer-group
neighbor iBGP_PEERS remote-as 1
neighbor iBGP_PEERS update-source Loopback1
neighbor 1.1.1.1 peer-group iBGP_PEERS
neighbor 1.1.1.2 peer-group iBGP_PEERS
!
address-family l2vpn vpls
neighbor iBGP_PEERS send-community extended
neighbor iBGP_PEERS route-reflector-client
neighbor 1.1.1.1 peer-group iBGP_PEERS
neighbor 1.1.1.2 peer-group iBGP_PEERS
exit-address-family

その他の参考資料

ここでは、VPLS Autodiscovery:BGP Based 機能の参考資料について説明します。

関連資料

関連項目
参照先

Cisco 7600 シリーズ ルータでの Virtual Private LAN Services

Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SR 』の「Virtual Private LAN Services on the Optical Services Modules」の章

L2 VPN(Cisco 7600 ルータ)

Cisco 7600 ルータのレイヤ 2 VPN の設定情報については、次のマニュアルを参照してください。

Cisco 7600 Series Cisco IOS Software Configuration Guide , Release 12.2SR』の「Configuring PFC3BXL and PFC3B Mode Multiprotocol Label Switching」の章

OSM Configuration Note , Release 12.2SR』の「Configuring Multiprotocol Label Switching on the Optical Services Modules」の章

FlexWAN and Enhanced FlexWAN Modules Configuration Guide 』の「Configuring Multiprotocol Label Switching on FlexWAN and Enhanced FlexWAN Modules」の章

Cisco 7600 Series Router SIP, SSC, and SPA Software Configuration Guide 』の「Configuring Any Transport over MPLS on a SIP」の項

Cisco 7600 Series Router SIP, SSC, and SPA Software Configuration Guide 』の「Configuring AToM VP Cell Mode Relay Support」の項

Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers

MPLS コマンド

Cisco IOS Multiprotocol Label Switching Command Reference http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html

規格

規格
タイトル

draft-ietf-l2vpn-signaling-08.txt

『Provisioning, Autodiscovery, and Signaling in L2VPNs』

draft-ietf-l2vpn-vpls-bgp-08.8

『Virtual Private LAN Service (VPLS) Using BGP for Autodiscovery and Signaling』

draft-ietf-mpls-lsp-ping-03.txt

『Detecting MPLS Data Plane Failures』

draft-ietf-pwe3-vccv-01.txt

『Pseudo-Wire (PW) Virtual Circuit Connection Verification (VCCV)』

MIB

MIB
MIB リンク

CISCO-IETF-PW-MIB(PW-MIB)

CISCO-IETF-PW-MPLS-MIB(PW-MPLS-MIB)

CISCO-IETF-PW-ENET-MIB(PW-ENET-MIB)

CISCO-IETF-PW-FR-MIB(PW-FR-MIB)

CISCO-IETF-PW-ATM-MIB(PW-ATM-MIB)

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3916

『Requirements for Pseudo-wire Emulation Edge-to-Edge (PWE3)』

RFC 3981

『Pseudo Wire Emulation Edge-to-Edge Architecture』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。サービス契約が有効で、ログイン ID またはパスワードを取得していない場合は、Cisco.com でまず登録手続きを行ってください。

http://www.cisco.com/en/US/support/index.html

VPLS Autodiscovery:BGP Based の機能情報

表 2 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージの各サポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 2 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 2 VPLS Autodiscovery:BGP Based の機能情報

機能名
リリース
機能情報

VPLS Autodiscovery:BGP Based

12.2(33)SRB

VPLS Autodiscovery を使用すると、各 Virtual Private LAN Service(VPLS; バーチャル プライベート LAN サービス)Provider Edge(PE; プロバイダー エッジ)ルータで、同じ VPLS ドメインの一部である他の PE ルータを検出できます。

12.2(33)SRB では、Cisco 7600 ルータにこの機能が導入されました。

次のコマンドが、この機能によって導入または変更されました。

auto-route-target

l2 router-id

l2 vfi autodiscovery

neighbor(VPLS)

rd(VPLS)

route-target(VPLS)

show mpls l2transport vc

show vfi

show xconnect

vpls-id

xconnect

ルート リフレクタの BGP VPLS Autodiscovery サポート

12.2(33)SRE

この機能が Cisco 7600 シリーズ ルータに追加されました。この機能は次のセクションに記載されています。

「ルート リフレクタの BGP VPLS Autodiscovery サポート」

「ルート リフレクタでの BGP VPLS Autodiscovery サポート:例」