マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
VPLS に対する NSF/SSO/ISSU サポート
VPLS に対する NSF/SSO/ISSU サポート
発行日;2012/01/31 | 英語版ドキュメント(2011/07/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

VPLS に対する NSF/SSO/ISSU サポート

目次

VPLS に対する NSF/SSO/ISSU サポートの前提条件

VPLS に対する NSF/SSO/ISSU サポートに関する制約事項

VPLS に対する NSF/SSO/ISSU サポートに関する情報

NSF/SSO と VPLS の連動方法

ISSU と VPLS の連動方法

VPLS に対する NSF/SSO/ISSU サポートの設定方法

VPLS の設定

NSF/SSO:Any Transport over MPLS の設定

NSF/SSO ルータ サポートの設定

ISSU ルータ サポートの設定

VPLS に対する NSF/SSO/ISSU サポートの確認とトラブルシューティング

VPLS に対する NSF/SSO/ISSU サポートの設定例

NSF/SSO/ISSU VPLS:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

VPLS に対する NSF/SSO/ISSU サポートに関する機能情報

VPLS に対する NSF/SSO/ISSU サポート

Nonstop Forwarding(NSF; ノンストップ フォワーディング)、Stateful Switchover(SSO; ステートフル スイッチオーバー)、および In Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)がサポートされる Virtual Private LAN Service(VPLS; バーチャル プライベート LAN サービス)によって、マルチポイント レイヤ 2 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)サービスに VPLS を使用するサービス プロバイダー ネットワークのアベイラビリティが向上します。Cisco NSF with SSO は、ネットワーク サービスのアベイラビリティを向上させるのに有効です。Cisco NSF with SSO を使用すると、ネットワーク プロセッサのハードウェアまたはソフトウェアに障害が発生した場合でも、継続してパケットを転送できます。冗長システムでは、セカンダリ プロセッサは、プライマリ プロセッサでの深刻な障害の発生時にコントロール プレーン サービスを回復するのに対して、SSO は、プライマリとセカンダリ プロセッサ間でネットワーク ステート情報を同期化します。

VPLS High Availability(HA; ハイ アベイラビリティ)機能には、VPLS NSF/SSO とともに ISSU 機能が組み込まれています。ISSU と NSF/SSO は連携して、コントロール プレーンとデータプレーンを停止することなく、Cisco IOS イメージのアップグレードまたはダウングレードを可能にします。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。 最新の機能情報と注意事項については、ご使用の Cisco IOS ソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「VPLS に対する NSF/SSO/ISSU サポートに関する機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

VPLS に対する NSF/SSO/ISSU サポートの前提条件

ここでは、VPLS に対する NSF/SSO/ISSU サポート機能を使用するために必要な次の前提条件をリストします。

ネットワークで次の機能を設定する必要があります。

VPLS (『Cisco 7600 Series Router Cisco IOS Software Configuration Guide 』Release 12.2SR の章「Virtual Private LAN Services on the Optical Services Modules」を参照)

VPLS Autodiscovery(『 VPLS Autodiscovery: BGP Based 』と『 BGP Support for the L2VPN Address Family 』を参照)

NSF/SSO:Any Transport over MPLS(『 NSF/SSO--Any Transport over MPLS and AToM Graceful Restart 』を参照)

7600 ルータでの NSF/SSO ルータ サポート(『 Cisco 7600 Series Cisco IOS Software Configuration Guide 』Release 12.2SR の章「Configuring NSF with SSO Supervisor Engine Redundancy」を参照)

7600 ルータでの ISSU ルータ サポート(『 Cisco 7600 Series Cisco IOS Software Configuration Guide 』Release 12.2SR の章「ISSU and eFSU on Cisco 7600 Series Routers」を参照)

VPLS に対する NSF/SSO/ISSU サポートに関する制約事項

VPLS に対する NSF/SSO/ISSU サポート機能には、次の制約事項があります。

VPLS に対する NSF/SSO/ISSU サポートでは、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)による自動検出されたネイバーへの PWs はサポートされていません。スタティックに設定されたネイバーはサポートされます。

サポートされるハードウェアについては、『Cisco Release 12.2SR Release Notes』を参照してください。

VPLS に対する NSF/SSO/ISSU サポートでは、Minimal Disruptive Restart(MDR)あるいはファームウェアまたはドライバ コードの事前ダウンロードをサポートしないラインカードはサポートされません。

VPLS に対する NSF/SSO/ISSU サポートに関する情報

VPLS に対する NSF/SSO/ISSU サポート機能を設定するには、次の概念について理解する必要があります。

「NSF/SSO と VPLS の連動方法」

「ISSU と VPLS の連動方法」

NSF/SSO と VPLS の連動方法

NSF/SSO がサポートされる VPLS によって、マルチポイント レイヤ 2 VPN サービスに VPLS を使用するサービス プロバイダー ネットワークのアベイラビリティが向上します。HA は、システムの障害時に発生する可能性があるサービスの停止を最小限に抑えます。障害に対処するために、VPLS HA には、スタンバイ Route Processor(RP; ルート プロセッサ)を使用してコントロール プレーンの冗長性を提供する SSO および NSF メカニズムが組み込まれています。VPLS NSF は、SSO および NSF メカニズムによって実現されます。

スタンバイ RP がアクティブ RP に移行している間、パケットの転送は、ラインカードでの転送を続行するか、新たにアクティブになった RP に関連付けられた他のハードウェア デバイスに切り替えられます(スイッチオーバー)。

ISSU と VPLS の連動方法

VPLS HA には、VPLS NSF/SSO とともに ISSU が組み込まれています。これは、IP/MPLS エッジの包括的なインサービス アップグレード ソリューションです。ISSU は、ソフトウェア アップグレードとメンテナンス アクティビティが原因のネットワークのダウンタイムを最小限に抑えます。ISSU では、コントロール プレーンに影響を与えることなく、システム パケットの転送への影響を最小限に抑えて、Cisco IOS ソフトウェア イメージにアップグレードまたはダウングレードできます。ISSU を使用すると、チェックポインティングに使用されるすべてのメッセージ データ構造、およびアクティブ RP とスタンバイ RP 間の交換がバージョン管理されます。

インサービス アップグレードを実行するには、デュアル RP ベースのプラットフォーム(Cisco 7600 ルータなど)のスタンバイ RP が、必要な Cisco IOS ソフトウェア リリースで最初にロードされます。その後、スタンバイ RP は、アップグレードされたバージョンのソフトウェアがインストールされたホットスタンバイ RP として起動し、制御をスタンバイ RP に移動して、アップグレードされたイメージを実行するためにスイッチオーバーが実行されます。

ISSU の手順中に、サポートされる SSO プロトコルと機能によって、レイヤ 2 プロトコル セッションが中断されることなくセッション状態が維持されます。ソフトウェアのアップグレード手順中にパケット転送を続行するために Cisco NSF テクノロジーが使用され、一方新たにアクティブになった RP ではルーティング情報が再作成されます。結果として、レイヤ 2 プロトコル セッションは中断されることなく、パケット転送に対する影響を最小限に抑えて、IP/MPLS プロバイダー エッジ ルータのシームレスなソフトウェア アップグレードが行われます。

利点

ISSU の主な利点は次のとおりです。

高速で中断のない機能の展開:ソフトウェアのアップグレード中にユーザ セッションを維持してパケット損失を最小限に抑えることによって、ISSU は、IP/MPLS プロバイダー エッジで新しい機能とサービスの高速で中断のない展開を可能にします。

予定されているダウンタイムの包括的なソリューション:ISSU は、警告の修正の適用から、新しい機能とサービスの展開に至る、全体的な一連のソフトウェア アップグレードのニーズに対処し、予定されているネットワーク ダウンタイムに対処するための包括的なソリューションを提供します。

動作効率の向上:ISSU は、予定されているダウンタイムを最小限に抑えて合理化し、ソフトウェアの展開に関する動作プロセスの変更を可能にして、予定されているダウンタイムの作業と費用を大幅に削減して動作効率を向上させます。

VPLS に対する NSF/SSO/ISSU サポートの設定方法

ここでは、次の手順について説明します。

「VPLS の設定」(必須)

「NSF/SSO:Any Transport over MPLS の設定」(必須)

「NSF/SSO ルータ サポートの設定」(必須)

「ISSU ルータ サポートの設定」(必須)

VPLS の設定

ルータで VPLS が設定されている必要があります。VPLS の設定に関する詳細については、『 Cisco 7600 Series Router Cisco IOS Software Configuration Guide 』Release 12.2SR の章「Virtual Private LAN Services on the Optical Services Modules」を参照してください。

NSF/SSO:Any Transport over MPLS の設定

ルータで NSF/SSO:Any Transport over MPLS 機能を設定する必要があります。NSF/SSO:Any Transport over MPLS 機能の設定に関する詳細については、『 NSF/SSO--Any Transport over MPLS and AToM Graceful Restart 』の機能の章を参照してください。

NSF/SSO ルータ サポートの設定

Cisco 7600 ルータで NSF/SSO ルータ サポートを設定する必要があります。NSF/SSO スーパーバイザ エンジンの冗長機能の設定に関する詳細については、『 Cisco 7600 Series Cisco IOS Software Configuration Guide 』Release 12.2SR の章「Configuring NSF with SSO Supervisor Engine Redundancy」を参照してください。

ISSU ルータ サポートの設定

Cisco 7600 ルータで ISSU ルータ サポートを設定する必要があります。

Cisco 7600 シリーズ ルータでの ISSU および Enhanced Fast Software Upgrade(eFSU)の設定に関する詳細については、『 Cisco 7600 Series Cisco IOS Software Configuration Guide 』Release 12.2SR の章「ISSU and eFSU on Cisco 7600 Series Routers」を参照してください。

VPLS に対する NSF/SSO/ISSU サポートの確認とトラブルシューティング

VPLS に対する NSF/SSO/ISSU サポートの設定を確認するには、次の show コマンドと debug コマンドを使用します。

手順の詳細

1. show checkpoint clients

2. show vfi [name vfi-name ] checkpoint [summary]

3. debug cwan atom

4. debug cwan ltl

5. debug issu client negotiation

6. debug issu client registration

7. debug issu client transform

8. debug vfi checkpoint

手順の詳細


ステップ 1 show checkpoint clients

このコマンドを使用して、チェックポイント クライアントに関する情報を表示します。

Router# show checkpoint clients
 
Check Point List of Clients
 
CHKPT on ACTIVE server.
 
--------------------------------------------------------------------------------
Client Name Client Entity Bundle
ID ID Mode
--------------------------------------------------------------------------------
CHKPT Test client 1 -- On
 
Total API Messages Sent: 0
Total IPC Sent: 0
Total Message Len: 0
Total Bytes Allocated: 0
Buffers Held: 0
IPC Frag Count: 0
IPC HW mark: 0
IPC Sends w/Flow Off: 0
Send Errs: 0
Send Peer Errs: 0
Rcv Xform Errs: 0
Xmit Xform Errs: 0
Incompatible Messages: 0
--------------------------------------------------------------------------------
Client Name Client Entity Bundle
ID ID Mode
--------------------------------------------------------------------------------
Network RF Client 3 -- Off
 
Total API Messages Sent: 10
Total IPC Sent: 10
Total Message Len: 2144
Total Bytes Allocated: 2904
Buffers Held: 0
IPC Frag Count: 0
IPC HW mark: 0
IPC Sends w/Flow Off: 0
Send Errs: 0
Send Peer Errs: 0
Rcv Xform Errs: 0
Xmit Xform Errs: 0
Incompatible Messages: 0
--------------------------------------------------------------------------------
Client Name Client Entity Bundle
ID ID Mode
--More--
.
.
.
 

ステップ 2 show vfi [name vfi-name ] checkpoint [summary]

このコマンドを使用して、H-VPLS-A-VFI という名前の特定の Virtual Forwarding Instance(VFI)に関するチェックポイント情報を表示します。

Router# show vfi name H-VPLS-A-VFI checkpoint
 
VFI Active RP
Checkpointing: Allowed
ISSU Client id: 2092, Session id: 65543, Compatible with peer
 
VFI VFI AC VFI PW
Bulk-sync 1 1 3
Checkpoint failures: 0 3 21
Recovered at switchover: 0 0 0
Recovery failures: 0 0 0
 
Legend: C=Checkpointed
 
VFI name: H-VPLS-A-VFI, state: up, type: multipoint
VPN ID: 12, Internal ID 1 C
Local attachment circuits:
Vlan200 16387 / 8195 C
Neighbors connected via pseudowires:
Peer ID VC ID SSM IDs
10.0.0.12 12 4096 / 12292 C
10.0.0.15 12 8193 / 16389 C
10.0.0.14 12 12290 / 20486 C
 

ステップ 3 debug cwan atom

このコマンドを使用して、Any Transport over MPLS(AToM)プラットフォーム イベントのデバッグをイネーブルにします。

次に、デバッグがイネーブルにされ、PW ポートが設定されてから設定解除された場合に表示されるデバッグ メッセージの出力例を示します。

Router# debug cwan atom
 
ConstWan Generic AToM debugging is on
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router#(config)# l2 vfi VPLS-2000 manual
Router#(config-vfi)# vpn id 2000
Router#(config-vfi)# neighbor 10.1.1.1 encapsulation mpls
Router#(config-vfi)#
01:16:36: cwan_rp_vfi_atom_provision_vlan PROV[VFI-ATOM]: plat_index(0xC7D00084) vlanid(2000) pseudo_port(0x84) vfi_plat_index(0xC7D00084) seginfo(0x53D38220) segtype(25) seghandle(0x53AEE074) split-horizon(On) cwan_atom_intfs(3) vfi_vcs(3) spoke_vcs(0)
Router#(config-vfi)# end
 
Router# debug cwan atom
 
ConstWan Generic AToM debugging is on
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# l2 vfi VPLS-2000
Router(config-vfi)# no neighbor 10.1.1.1 encapsulation mpls
Router(config-vfi)#
01:27:18: cwan_rp_vfi_atom_unprovision_vlan: UNPROV[VFI-ATOM]: circ_index(0xC7D00084) is_vfi(1) vlan(2000) vfi_vcs(3) spoke_vcs(0) split_horizon(On)
01:27:18: cwan_atom_vlan_remove_rp: Vlan2000 ip_iw(0) ip_enabled(0)
Router#(config-vfi)# end
 

ステップ 4 debug cwan ltl

このコマンドを使用して、Local Target Manager(LTL)デバッグ イベントとエラーのデバッグを可能にします。

次に、デバッグがイネーブルにされ、PW ポートが設定されてから設定解除された場合に表示されるデバッグ メッセージの出力例を示します。

 
Router# debug cwan ltl
 
ConstWan LTL manager debugging is on
Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
Router#(config)# l2 vfi VPLS-2000 manual
Router#(config-vfi)# vpn id 2000
Router#(config-vfi)# neighbor 10.1.1.1 encapsulation mpls
Router#(config-vfi)#
 
01:17:35: CWAN LTL MGR: Port 133 is free to use for VPLS with vlan 2000 - tx_tvc(0x9F404)
Router#(config-vfi)# end
Router# debug cwan ltl
 
ConstWan LTL manager debugging is on
Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# l2 vfi VPLS-2000 manual
Router(config-vfi)# no neighbor 10.1.1.1 encapsulation mpls
Router(config-vfi)#
 
01:29:05: CWAN LTL MGR: DELETE VPLS PW vlan(2000) pseudo_slotunit(133)
Router(config-vfi)# end
 

ステップ 5 debug issu client negotiation

このコマンドを使用して、ISSU クライアントのネゴシエーション イベントとエラーのデバッグを可能にします。

Router# debug issu client negotiation
 
*Jun 5 22:41:47.332: VFI ISSU: Negotiation rc ISSU_RC_NEGO_DONE, compatible
*Jun 5 22:41:47.332: AToM HA: CID 84 Seq 230 Event RF_PROG_STANDBY_CONFIG Op 0 State ACTIVE Peer STANDBY COLD-CONFIG
*Jun 5 22:41:47.432: ATOM ISSU: Propose L2HW cap 0xFFF rc 0
*Jun 5 22:41:47.532: ATOM ISSU: Active negotiator, accept compatible L2HW cap 0xFFF
*Jun 5 22:41:48.232: ATOM ISSU: Negotiation rc ISSU_RC_NEGO_DONE, compatible
*Jun 5 22:41:50.836: cwan_atom_issu_start_nego_session: Start session negotiation
*Jun 5 22:41:50.836: cwan_atom_issu_start_nego_session: Started nego successfully, rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:41:50.836: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:41:50.840: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:41:50.940: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:41:50.940: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:41:51.040: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:41:51.040: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:41:51.140: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:41:51.140: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:41:51.240: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:41:51.240: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:41:51.340: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:50:40.156: VFI ISSU: Negotiation rc ISSU_RC_NEGO_DONE, compatible
*Jun 5 22:50:40.156: AToM HA: CID 84 Seq 230 Event RF_PROG_STANDBY_CONFIG Op 0 State ACTIVE Peer STANDBY COLD-CONFIG
*Jun 5 22:50:40.256: ATOM ISSU: Passive negotiator, accept compatible L2HW cap 0xFFF
*Jun 5 22:50:40.964: ATOM ISSU: Negotiation rc ISSU_RC_NEGO_DONE, compatible
*Jun 5 22:50:43.516: cwan_atom_issu_start_nego_session: Start session negotiation
*Jun 5 22:50:43.516: cwan_atom_issu_start_nego_session: Started nego successfully, rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:50:43.520: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:50:43.520: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:50:43.620: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:50:43.620: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:50:43.720: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:50:43.720: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:50:43.820: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:50:43.820: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:50:43.920: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
*Jun 5 22:50:43.920: cwan_atom_issu_receive_nego_msg: issu_receive_nego_msg rc=ISSU_RC_NEGO_NOT_DONE
*Jun 5 22:50:44.020: cwan_atom_issu_receive_nego_msg: Start, cwan_atom_issu_nego_done=0
 

ステップ 6 debug issu client registration

このコマンドを使用して、ISSU クライアントの登録イベントとエラーのデバッグを可能にします。

ピア ルータのリロード後に、次のデバッグ メッセージが表示されます。

Router# debug issu client registration
 
Router#
 
00:42:21: VFI ISSU: Unregistered ISSU session 0, ISSU_RC_OK
00:42:21: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to down
00:42:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet6/2, changed state to down
00:42:21: %LINK-3-UPDOWN: Interface Vlan2000, changed state to down
00:42:21: %LINK-3-UPDOWN: Interface Vlan2001, changed state to down
00:42:21: %LINK-3-UPDOWN: Interface Vlan2002, changed state to down
Router#
00:42:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2000, changed state to down
00:42:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2001, changed state to down
00:42:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2002, changed state to down
Router#
00:49:01: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to down
00:49:02: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to up
PE-3#
00:49:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet6/2, changed state to up
Router#
00:49:35: %LINK-3-UPDOWN: Interface Vlan2000, changed state to up
00:49:35: %LINK-3-UPDOWN: Interface Vlan2001, changed state to up
00:49:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2000, changed state to up
00:49:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2001, changed state to up
00:49:35: %LINK-3-UPDOWN: Interface Vlan2002, changed state to up
Router#
00:49:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2002, changed state to up
Router#
00:49:48: VFI ISSU: Registered session 131171, ISSU_RC_OK
Router#
00:50:08: %HA_CONFIG_SYNC-6-BULK_CFGSYNC_SUCCEED: Bulk Sync succeeded
Router#
 

ステップ 7 debug issu client transform [ clientID client-id ]

このコマンドを使用して、ISSU クライアントのトランスフォーム イベントとエラーのデバッグを可能にします。

次のコマンドの例を使用すると、特定の ISSU クライアント(clientID 2092)のデバッグ出力が可能になります。ピア ルータのリロード後に、次のデバッグ メッセージが表示されます。

Router# debug issu client transform clientID 2092
 
Router#
 
05:35:15: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to down
05:35:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet6/2, changed state to down
05:35:15: %LINK-3-UPDOWN: Interface Vlan2000, changed state to down
05:35:15: %LINK-3-UPDOWN: Interface Vlan2001, changed state to down
05:35:15: %LINK-3-UPDOWN: Interface Vlan2002, changed state to down
Router#
05:35:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2000, changed state to down
05:35:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2001, changed state to down
05:35:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2002, changed state to down
Router#
05:41:55: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to down
05:41:56: %LINK-3-UPDOWN: Interface GigabitEthernet6/2, changed state to up
.
.
.
05:43:02: VFI ISSU: Xmit transform message 5, rc ISSU_RC_OK
05:43:02: ISSU Buffer dump @ 0x0817EC7C
05:43:02: 00 00 00 00
05:43:02: VFI ISSU: Xmit transform message 1, rc ISSU_RC_OK
05:43:02: %HA_CONFIG_SYNC-6-BULK_CFGSYNC_SUCCEED succeeded
Router#
 

ステップ 8 debug vfi checkpoint

このコマンドを使用して、VFI チェックポインティング イベントとエラーのデバッグを可能にします。

Router# debug vfi checkpoint
 
Router# $may24_v1 6 slavedisk0:s72033-adventerprisek9_wan-mz.cflow_may24_v1
 
Router#
 
*Jun 5 22:37:17.268: AToM HA: CF status 3 not processed
*Jun 5 22:37:17.268: VFI HA: CF status 3 not processed
*Jun 5 22:37:17.296: AC HA RF: CId:83, Seq:228, Sta:RF_STATUS_PEER_COMM, Opr:0, St:ACTIVE, PSt:STANDBY HOT
*Jun 5 22:37:17.296: VFI HA: CID 145, Seq 229, Status RF_STATUS_PEER_COMM, Op 0, State ACTIVE, Peer STANDBY HOT
*Jun 5 22:37:17.296: AToM HA: CID 84, Seq 230, Status RF_STATUS_PEER_COMM, Op 0, State ACTIVE, Peer STANDBY HOT
*Jun 5 22:37:17.444: AToM HA: CF status 3 not processed
*Jun 5 22:37:17.444: VFI HA: CF status 3 not processed
*Jun 5 22:37:17.268: %OIR-SP-3-PWRCYCLE: Card in module 6, is being power-cycled (RF request)
*Jun 5 22:37:17.792: AC HA RF: CId:83, Seq:228, Sta:RF_STATUS_PEER_PRESENCE, Opr:0, St:ACTIVE, PSt:DISABLED
*Jun 5 22:37:17.792: VFI HA: CID 145, Seq 229, Status RF_STATUS_PEER_PRESENCE, Op 0, State ACTIVE, Peer DISABLED
*Jun 5 22:40:40.244: SP-STDBY: SP: Currently running ROMMON from S (Gold) region
*Jun 5 22:40:45.028: %DIAG-SP-STDBY-6-RUN_MINIMUM: Module 6: Running Minimal Diagnostics...
*Jun 5 22:40:56.492: %DIAG-SP-STDBY-6-DIAG_OK: Module 6: Passed Online Diagnostics
*Jun 5 22:41:53.436: %SYS-SP-STDBY-5-RESTART: System restarted --
*Jun 5 22:42:12.760: VFI HA: CID 145 Seq 229 Event RF_PROG_STANDBY_BULK Op 0 State ACTIVE Peer STANDBY COLD-BULK
*Jun 5 22:42:12.764: VFI HA: Ignore RF progression event, VFI Mgr process is not running, skipped bulk sync
.
.
.
*Jun 5 22:42:16.948: %ISSU_PROCESS-SP-7-DEBUG: Peer state is [ STANDBY HOT ]; Please issue the runversion command
*Jun 5 22:42:15.928: %PFREDUN-SP-STDBY-6-STANDBY: Ready for SSO mode
*Jun 5 22:42:16.956: %RF-SP-5-RF_TERMINAL_STATE: Terminal state reached for (SSO)
*Jun 5 22:42:16.112: %SYS-SP-STDBY-3-LOGGER_FLUSHED: System was paused for 00:00:00 to ensure console debugging output.
Router#

VPLS に対する NSF/SSO/ISSU サポートの設定例

次に、VPLS に対する NSF/SSO/ISSU サポート機能を使用したネットワークの設定例を示します。

「NSF/SSO/ISSU VPLS:例」

NSF/SSO/ISSU VPLS:例

図 1 に、NSF/SSO/ISSU VPLS の基本的な設定を示します。

図 1 基本的な NSF/SSO/ISSU の設定

CE1

 
CE1_7206#
!
hostname CE1_7206
!
ip cef
!
interface Loopback0
description - FULL MESH VPN
ip address 10.0.0.0 10.255.255.255
!
interface FastEthernet0/0
ip address 10.0.57.100 255.255.255.0
no ip mroute-cache
duplex half
no cdp enable
!
interface FastEthernet1/0
description - H-VPLS VPN to uPE1
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet1/0.1
description - H-VPLS VPN to uPE1
encapsulation dot1Q 121
ip address 10.1.1.120 255.255.255.0
!
interface FastEthernet4/1
description - FULL MESH VPN to PE1
no ip address
duplex auto
speed auto
!
interface FastEthernet4/1.1
description - FULL MESH VPN to PE1
encapsulation dot1Q 120
ip address 10.1.1.120 255.255.255.0
!
interface FastEthernet6/1
description - VPWS VPN to PE1
no ip address
duplex auto
speed auto
!
interface FastEthernet6/1.1
description - VPWS VPN to PE1
encapsulation dot1Q 122
ip address 10.1.1.120 255.255.255.0
!
router ospf 10
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 10.120.120.120 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
!
ip default-gateway 10.0.57.1
!
end
 

uPE1

 
uPE1_7609#
!
upgrade fpd auto
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service internal
!
hostname uPE1_7609
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xx
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
ip host lab24 172.16.0.0
ip host dirt 172.16.0.19
!
vtp mode transparent
!
multilink bundle-name authenticated
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
redundancy
mode sso
main-cpu
auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
!
vlan 100
!
interface Loopback0
description - H-VPLS
ip address 10.0.0.0 255.255.255.255
!
interface GigabitEthernet1/1
description - H-VPLS to CE1
switchport
switchport trunk allowed vlan 10-1000
switchport mode trunk
!
interface GigabitEthernet5/2
ip address 10.0.0.0 255.255.255.0
media-type rj45
no cdp enable
!
interface GigabitEthernet9/0/0
description - H-VPLS to PE1
ip address 10.0.0.1 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface Vlan1
no ip address
shutdown
!
router ospf 10
log-adjacency-changes
passive-interface Loopback0
network 10.0.5.0 0.0.0.255 area 0
network 10.0.0.8 0.0.0.0 area 0
!
ip route 172.16.17.19 255.255.255.255 10.0.57.1
ip route 172.16.0.0 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
control-plane
!
end

PE1

 
PE1_7613#
!
upgrade fpd auto
service internal
!
hostname PE1_7613
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xxx
boot-end-marker
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
ip host dirt 172.16.0.0
ip host lab24 172.16.0.01
!
ipv6 mfib hardware-switching replication-mode ingress
!
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
no mls acl tcam share-global
mls cef error action freeze
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
redundancy
mode sso
main-cpu
auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
l2 vfi vpls_auto autodiscovery
vpn id 1
!
l2 vfi vpls_man manual
vpn id 10
neighbor 10.0.0.12 encapsulation mpls
neighbor 10.0.0.11 encapsulation mpls
!
interface Loopback0
description - FULL MESH
ip address 10.0.0.9 255.255.255.255
!
interface Loopback1
description - VPWS
ip address 172.16.0.0 255.255.255.255
!
interface Loopback2
description - H-VPLS
ip address 10.0.0.0 255.255.255.255
!
interface GigabitEthernet7/2
ip address 10.0.0.01 255.255.255.0
media-type rj45
no cdp enable
!
interface GigabitEthernet10/1
description - FULL MESH to CE1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10-1000
switchport mode trunk
!
interface GigabitEthernet10/2
description - VPWS to CE1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10-1000
switchport mode trunk
!
interface GigabitEthernet12/0/0
description - H-VPLS to uPE1
ip address 10.0.0.3 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet12/0/1
description - H-VPLS to nPE2
ip address 10.0.0.1 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet12/1/0
description - VPWS to P
ip address 10.0.0.3 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet12/1/1
description - FULL MESH to P
ip address 10.0.2.0 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet12/2/0
description - FULL MESH to PE3
ip address 10.1.0.3 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
no ip address
xconnect vfi vpls_auto
!
router ospf 10
! for FULL MESH
log-adjacency-changes
passive-interface Loopback0
network 10.1.1.0 0.0.0.255 area 0
network 10.2.2.0 0.0.0.255 area 0
network 10.5.5.0 0.0.0.255 area 0
network 10.9.9.9 0.0.0.0 area 0
network 10.0.0.02 0.0.0.255 area 0
network 10.0.0.04 0.0.0.0 area 0
network 10.0.0.5 0.0.0.0 area 0
!
router ospf 20
! for VPWS
log-adjacency-changes
passive-interface Loopback1
network 10.0.20.0 0.0.0.255 area 0
network 10.0.0.9 0.0.0.0 area 0
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.0.11.0 remote-as 1
neighbor 10.0.10.0 update-source Loopback0
neighbor 10.0.12.0 remote-as 1
neighbor 10.0.0.12 update-source Loopback0
neighbor 10.0.0.32 remote-as 1
neighbor 10.0.0.31 update-source Loopback2
!
address-family ipv4
no synchronization
neighbor 10.0.11.0 activate
neighbor 10.12.0.0 activate
neighbor 10.0.32.0 activate
no auto-summary
exit-address-family
!
address-family l2vpn vpls
neighbor 10.0.0.11 activate
neighbor 10.0.11.0 send-community both
neighbor 10.12.0.0 activate
neighbor 10.0.0.12 send-community both
neighbor 10.0.0.32 activate
neighbor 10.0.32.0 send-community both
exit-address-family
!
ip default-gateway 10.0.57.1
ip route 172.16.0.0 255.255.255.255 10.0.57.1
ip route 172.16.0.2 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
end

P

 
P_7206_g1#
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P_7206_g1
!
ip cef
ip host lab24 172.16.0.254
ip host dirt 172.16.0.129
!
mpls label protocol ldp
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
!
interface Loopback0
description - FULL MESH
ip address 10.0.0.10 255.255.255.255
!
interface Loopback1
description - VPWS
ip address 10.0.0.1 255.255.255.255
!
!
interface GigabitEthernet1/0
description - VPWS to PE1
ip address 10.0.20.6 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet2/0
description - FULL MESH to PE1
ip address 10.0.2.6 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet3/0
description - VPWS to PE2
ip address 10.0.0.6 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet4/0
description - FULL MESH to PE2
ip address 10.0.3.6 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
router ospf 10
! for FULL MESH
log-adjacency-changes
passive-interface Loopback0
network 10.0.2.6 0.0.0.0 area 0
network 10.0.2.0 0.0.0.255 area 0
network 10.0.3.6 0.0.0.0 area 0
network 10.0.3.0 0.0.0.255 area 0
network 10.0.0.0 0.0.0.255 area 0
!
router ospf 20
! for VPWS
log-adjacency-changes
passive-interface Loopback1
network 10.0.20.0 0.0.0.255 area 0
network 10.21.0.0 0.0.0.255 area 0
network 10.0.10.0 0.0.0.0 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.0.9.9 remote-as 1
neighbor 10.9.0.9 update-source Loopback0
neighbor 10.11.0.11 remote-as 1
neighbor 10.0.11.0 update-source Loopback0
no auto-summary
!
ip default-gateway 10.0.0.0
!
mpls ldp router-id Loopback0 force
!
 

PE2

 
PE2_7606#
!
upgrade fpd auto
!
service internal
service counters max age 10
!
hostname PE2_7606
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xx
boot-end-marker
!
no aaa new-model
!
ipv6 mfib hardware-switching replication-mode ingress
!
mls ip multicast flow-stat-timer 9
!
multilink bundle-name authenticated
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
redundancy
mode sso
main-cpu
auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
!
l2 vfi vpls_auto autodiscovery
vpn id 1
!
l2 vfi vpls_manual manual
vpn id 10
neighbor 10.0.0.9 encapsulation mpls
neighbor 10.0.0.11 encapsulation mpls
!
interface Loopback0
description - FULL MESH
ip address 10.0.0.12 255.255.255.255
!
interface Loopback1
description - VPWS
ip address 10.0.0.112 255.255.255.255
!
interface Loopback2
description - H-VPLS
ip address 10.0.32.0 255.255.255.255
!
interface GigabitEthernet2/1
description - FULL MESH to CE2
switchport
switchport trunk allowed vlan 10-1000
switchport mode trunk
!
interface GigabitEthernet4/0/0
description - FULL MESH to PE3
ip address 10.0.4.0 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet4/1/0
description - VPWS to P
ip address 10.0.21.0 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet4/1/1
description - FULL MESH to P
ip address 10.0.3.4 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet4/3/0
description - VPWS to CE2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4/3/1
description - H-VPLS to nPE1
ip address 10.0.0.3 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet5/2
ip address 10.0.5.0 255.255.255.0
media-type rj45
no cdp enable
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
no ip address
shutdown
xconnect vfi vpls_auto
!
router ospf 10
log-adjacency-changes
passive-interface Loopback0
network 10.0.3.4 0.0.0.0 area 0
network 10.0.4.0 0.0.0.255 area 0
network 10.0.6.4 0.0.0.0 area 0
network 10.0.0.5 0.0.0.255 area 0
network 10.0.0.12 0.0.0.0 area 0
network 10.0.32.0 0.0.0.0 area 0
network 10.0.1.0 0.0.0.0 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.0.0.9 remote-as 1
neighbor 10.0.9.0 update-source Loopback0
neighbor 10.0.11.0 remote-as 1
neighbor 10.0.0.11 update-source Loopback0
neighbor 10.0.29.0 remote-as 1
neighbor 10.0.0.29 update-source Loopback2
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family l2vpn vpls
neighbor 10.0.0.9 activate
neighbor 10.0.9.0 send-community both
neighbor 10.0.11.0 activate
neighbor 10.0.0.11 send-community both
neighbor 10.0.0.2 activate
neighbor 10.0.0.3 send-community both
exit-address-family
!
ip default-gateway 10.0.0.1
ip route 172.16.0.0 255.255.255.255 10.0.57.1
ip route 172.16.0.254 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
end

uPE2

 
uPE2_7606#
!
upgrade fpd auto
version 12.2
service timestamps debug uptime
service timestamps log uptime
service internal
!
hostname uPE2_7606
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xx
boot-end-marker
!
ipv6 mfib hardware-switching replication-mode ingress
!
multilink bundle-name authenticated
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
power redundancy-mode combined
!
redundancy
mode sso
main-cpu
auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
!
interface Loopback0
description - H-VPLS
ip address 10.0.0.13 255.255.255.255
!
interface FastEthernet3/1
description - H-VPLS to CE2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10-1000
switchport mode trunk
!
interface GigabitEthernet4/0/0
description - H-VPLS to uPE2
ip address 10.0.0.2 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet5/2
ip address 10.0.0.11 255.255.255.0
media-type rj45
no cdp enable
!
interface Vlan1
no ip address
shutdown
!
router ospf 10
log-adjacency-changes
passive-interface Loopback0
network 10.0.6.0 0.0.0.255 area 0
network 10.0.0.13 0.0.0.0 area 0
!
ip default-gateway 10.0.0.1
ip route 172.16.1.129 255.255.255.255 10.0.57.1
ip route 172.16.192.254 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
control-plane
!
end

CE2

 
CE2_7206#
!
hostname CE2_7206
!
ip cef
!
interface Loopback0
ip address 10.0.0.123 255.255.255.255
!
interface FastEthernet1/0
description - H-VPLS VPN to uPE2
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet1/0.1
description - H-VPLS VPN to uPE2
encapsulation dot1Q 10
ip address 10.0.0.121 255.255.255.0
!
interface Ethernet2/0
ip address 10.0.0.97 255.255.255.0
no ip mroute-cache
duplex half
no cdp enable
!
interface FastEthernet4/0
description - FULL MESH VPN to PE2
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet4/0.1
description - FULL MESH VPN to PE2
encapsulation dot1Q 10
ip address 10.0.0.121 255.255.255.0
!
interface GigabitEthernet5/0
description - VPWS VPN to PE2
no ip address
no ip mroute-cache
no negotiation auto
!
interface GigabitEthernet5/0.1
description - VPWS VPN to PE2
encapsulation dot1Q 10
ip address 10.0.0.121 255.255.255.0
!
router ospf 10
log-adjacency-changes
network 10.0.1.0 0.0.0.255 area 0
network 10.0.0.1 0.0.0.255 area 0
network 10.0.0.123 0.0.0.0 area 0
!
ip default-gateway 10.0.0.4
!
end

PE3

 
PE3_7606#
!
upgrade fpd auto
version 12.2
service timestamps debug uptime
service timestamps log uptime
service internal
!
hostname PE3_7606
!
boot-start-marker
boot system flash disk0:s72033-adventerprisek9_wan_dbg-mz.xx
boot-end-marker
!
ipv6 mfib hardware-switching replication-mode ingress
!
multilink bundle-name authenticated
mpls ldp graceful-restart
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
redundancy
mode sso
main-cpu
auto-sync running-config
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
l2 vfi vpls_auto autodiscovery
vpn id 1
!
l2 vfi vpls_manual manual
vpn id 10
neighbor 10.0.9.9 encapsulation mpls
neighbor 10.0.0.12 encapsulation mpls
!
interface Loopback0
description - FULL MESH
ip address 10.0.0.11 255.255.255.255
!
interface Loopback1
description - H-VPLS
ip address 10.0.0.31 255.255.255.255
!
interface GigabitEthernet3/2/1
description - FULL MESH to PE1
ip address 10.0.0.5 255.255.255.0
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet5/2
ip address 10.0.0.115 255.255.255.0
media-type rj45
no cdp enable
!
interface GigabitEthernet6/2
description - FULL MESH to CE3
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10-1000
switchport mode trunk
no cdp enable
!
interface Vlan1
no ip address
shutdown
!
router ospf 10
log-adjacency-changes
passive-interface Loopback0
network 10.0.4.0 0.0.0.255 area 0
network 10.0.0.11 0.0.0.0 area 0
network 10.0.31.0 0.0.0.0 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.0.0.9 remote-as 1
neighbor 10.0.9.0 update-source Loopback0
neighbor 10.0.12.0 remote-as 1
neighbor 10.0.0.12 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family l2vpn vpls
neighbor 10.0.9.0 activate
neighbor 10.0.0.9 send-community both
neighbor 10.0.0.12 activate
neighbor 10.0.12.0 send-community both
exit-address-family
!
ip default-gateway 10.0.57.1
ip route 172.16.0.129 255.255.255.255 10.0.57.1
ip route 172.16.0.254 255.255.255.255 10.0.57.1
!
mpls ldp router-id Loopback0 force
!
end

その他の参考資料

ここでは、VPLS に対する NSF/SSO/ISSU サポート機能に関する参考資料を紹介します。

関連資料

関連項目
参照先

ステートフル スイッチオーバー

『Stateful Switchover』

MPLS ラベル配布プロトコル

MPLS Label Distribution Protocol (LDP)

Cisco ノンストップ フォワーディング

『Cisco Nonstop Forwarding』

Any Transport over MPLS

Any Transport over MPLS

NSF/SSO:Any Transport over MPLS

『NSF/SSO - Any Transport over MPLS and AToM Graceful Restart』

L2VPN インターワーキング設定

L2VPN Interworking

VPLS

Cisco 7600 Series Router Cisco IOS Software Configuration Guide 』Release 12.2SR の章「Virtual Private LAN Services on the Optical Services Modules」を参照してください。

VPLS Autodiscovery

VPLS Autodiscovery: BGP Based 』と『 BGP Support for the L2VPN Address Family 』を参照してください。

7600 ルータでの NSF/SSO ルータ サポート

Cisco 7600 Series Cisco IOS Software Configuration Guide 』Release 12.2SR の章「Configuring NSF with SSO Supervisor Engine Redundancy」を参照してください。

7600 ルータでの ISSU ルータ サポート

Cisco 7600 Series Cisco IOS Software Configuration Guide 』Release 12.2SR の章「ISSU and eFSU on Cisco 7600 Series Routers」を参照してください。

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 3478

『Graceful Restart Mechanism for Label Distribution』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『 Cisco IOS Master Commands List 』にアクセスしてください。

debug cwan atom

debug cwan ltl

debug issu client negotiation

debug issu client registration

debug issu client transform

debug vfi checkpoint

show checkpoint clients

show vfi checkpoint

VPLS に対する NSF/SSO/ISSU サポートに関する機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 VPLS に対する NSF/SSO/ISSU サポートに関する機能情報

機能名
リリース
機能情報

VPLS に対する NSF/SSO/ISSU サポート

12.2(33)SRC

NSF/SSO/ISSU がサポートされる Virtual Private LAN Services(VPLS; バーチャル プライベート LAN サービス)によって、マルチポイント レイヤ 2 VPN サービスに VPLS を使用するサービス プロバイダー ネットワークのアベイラビリティが向上します。Cisco Nonstop Forwarding(NSF; ノンストップ フォワーディング)with Stateful Switchover(SSO; ステートフル スイッチオーバー)は、ネットワーク サービスのアベイラビリティを向上させるのに有効です。

12.2(33)SRC では、この機能は Cisco 7600 ルータで導入されました。