マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート
NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート
発行日;2012/01/31 | 英語版ドキュメント(2011/07/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート

機能情報の確認

目次

の前提条件

サポートされるハードウェア

MPLS HA 環境でのネイバー ルータ

ステートフル スイッチオーバー

ルーティング プロトコルのノンストップ フォワーディング

に関する制約事項

について

の機能

AToM 情報チェックポインティング

チェックポイティングに関するトラブルシューティングのヒント

ISSU のサポート

MPLS LDP グレースフル リスタートの設定

の設定例

AToM NSF の VLAN インターワーキングのイーサネット:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

の機能情報

NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート

NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート機能を使用すると、Any Transport over MPLS(AToM)により、Cisco Nonstop Forwarding(NSF; ノンストップ フォワーディング)、Stateful Switchover(SSO; ステートフル スイッチオーバー)、Graceful Restart(GR; グレースフル リスタート)を使用して、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)フォワーディング ステートを失うことなく、Route Processor(RP; ルート プロセッサ)で、コントロール プレーン サービスの中断から回復できます。

NSF with SSO を使用すると、ネットワーク サービスのアベイラビリティを効果的に改善できます。Cisco NSF with SSO を使用すると、ネットワーク プロセッサのハードウェアまたはソフトウェアに障害が発生した場合でも、継続してパケットを転送できます。冗長システムでは、プライマリ プロセッサで重大な障害が発生している間、セカンダリ プロセッサにより、コントロール プレーン サービスが回復されます。SSO は、プライマリ プロセッサとセカンダリ プロセッサの間でネットワーク ステート情報を同期します。


) このマニュアルでは、NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート機能は、簡潔に AToM NSF と呼ばれます。


機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「AToM NSFの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

AToM NSF の前提条件

AToM NSF を設定する前に、次の作業を完了していることを確認してください。

AToM Virtual Circuit(VC; 仮想回線)がルータで設定されている。AToM の設定については、「 Any Transport over MPLS 」の機能の章を参照してください。L2VPN インターワーキングの設定については、「 L2VPN Interworking 」の機能の章を参照してください。

SSO がルート プロセッサで設定されている。設定情報については、「 Stateful Switchover 」の機能の章を参照してください。

ノンストップ フォワーディングがルータで設定されている。P ルータ、PE プロバイダー エッジ ルータ、CE カスタマー エッジ ルータ間で稼動するルーティング プロトコルでノンストップ フォワーディングをイネーブルにする必要があります。ルーティング プロトコルは、Open Shortest Path First(OSPF)、Intermediate System-to-Intermediate System(IS-IS)、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)です。設定情報については、「 Cisco Nonstop Forwarding 」の機能の章を参照してください。

ここでは、次の前提条件について説明します。

「サポートされるハードウェア」

「MPLS HA 環境でのネイバー ルータ」

「ステートフル スイッチオーバー」

「ルーティング プロトコルのノンストップ フォワーディング」

サポートされるハードウェア

この機能のハードウェア要件については、次のマニュアルを参照してください。

Cisco IOS Release 12.2(25)S の場合、『 Cross-Platform Release Notes for Cisco IOS Release 12.2S 』の「Supported Hardware」の項を参照してください。

URL:
http://www.cisco.com/en/US/docs/ios/12_2s/release/notes/122Srn.html

Cisco IOS Release 12.2(28)SB の場合、『 Cross-Platform Release Notes for Cisco IOS Release 12.2SB 』の「Supported Hardware」の項を参照してください。

URL:
http://www.cisco.com/en/US/docs/ios/12_2sb/release/notes/122SB.html

Cisco IOS Release 12.2(33)SRC の場合、『 Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers 』の「Supported Hardware」の項を参照してください。

URL:
http://www.cisco.com/en/US/docs/ios/12_2sr/release/notes/122SRrn.html

MPLS HA 環境でのネイバー ルータ

AToM NSF では、ネイバー ネットワーキング デバイスが AToM GR を実行できる必要があります。Cisco IOS Release 12.2(25)S および 12.2(28)SB では、Cisco 7200 および Cisco 7500 ルータは、AToM GR をサポートし、ネイバー ネットワーキング デバイスとして使用できます。

Cisco IOS Release 12.2(33)SRC では、Cisco 7600 ルータは、AToM High Availability(HA; ハイ アベイラビリティ)および MPLS Label Distribution Protocol(LDP; ラベル配布プロトコル)GR をサポートできます。

ステートフル スイッチオーバー

AToM NSF を実行するには、ルート プロセッサを SSO および GR に設定する必要があります。詳細については、「 Stateful Switchover 」の機能の章を参照してください。

ルーティング プロトコルのノンストップ フォワーディング

Provider(P; プロバイダー)ルータ、Provider Edge(PE; プロバイダー エッジ)ルータ、Customer Edge(CE; カスタマー エッジ)ルータ間で稼動するルーティング プロトコルで NSF をイネーブルにする必要があります。次に、ルーティング プロトコルを示します。

Border Gateway Protocol(BGP)

Open Shortest Path First(OSPF)

Intermediate System-to-Intermediate System(IS-IS)

詳細については、「 Cisco Nonstop Forwarding 」の機能の章を参照してください。

AToM NSFに関する制約事項

AToM NSF には次の制約事項があります。

Tag Distribution Protocol(TDP; タグ配布プロトコル)セッションはサポートされていません。LDP セッションだけがサポートされています。

AToM NSF は、Label-Controlled ATM(LC-ATM; ラベル制御 ATM)インターフェイス上では設定できません。

AToM NSF は、AToM Layer 2 Virtual Private Network(L2VPN; レイヤ 2 バーチャル プライベート ネットワーク)インターワーキングをサポートします。ただし、Layer 2 Tunnel Protocol Version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)インターワーキングはサポートされません。

AToM NSF は、レイヤ 2 ローカル スイッチングと相互運用します。ただし、AToM NSF は、ローカル スイッチングに設定されたインターフェイスには効果はありません。

分散型シスコ エクスプレス フォワーディングをインターフェイス上で使用するには、シリアル インターフェイスで均等化キューイングをディセーブルにします。

Cisco 7500 シリーズ ルータでは、分散型シスコ エクスプレス フォワーディングは AToM NSF をサポートするために必要です。

Cisco 7500 ルータは、AToM Ethernet-VLAN インターワーキング IP をサポートしません。ただし、AToM Ethernet-VLAN インターワーキング イーサネットはサポートされます。

AToM NSFについて

AToM NSF を設定するには、次の概念を理解する必要があります。

「AToM NSF の機能」

「AToM 情報チェックポインティング」

「ISSU のサポート」

AToM NSF の機能

AToM NSF は、AToM を使用してレイヤ 2 VPN サービスをカスタマーに提供するサービス プロバイダーのネットワークのアベイラビリティを改善します。HA は、障害を検出し、提供されるサービスの中断を最小限に抑える機能を提供します。AToM NSF は、SSO および NSF メカニズムに実現されます。スタンバイ RP は、コントロール プレーン冗長性を提供します。Attachment Circuit(AC; アタッチメント回線)および AToM Pseudowires(PW; 擬似回線)のコントロール プレーン ステートおよびデータ プレーン プロビジョニング情報は、スタンバイ RP にチェックポイントされ、AToM L2VPN の NSF が提供されます。

AToM 情報チェックポインティング

チェックポインティングは、ステート情報をアクティブ RP からバックアップ RP にコピーし、バックアップ RP の情報を最新の情報にする機能です。アクティブ RP で障害が発生すると、バックアップ RP は継承できます。

AToM NSF 機能では、チェックポインティング機能は、アクティブ RP の情報バインディングをバックアップ RP にコピーします。アクティブ RP は、情報が変更されたときにアップデートをバックアップ RP に送信します。

チェックポイティング データを表示するには、アクティブおよびバックアップ RP で show acircuit checkpoint コマンドを入力します。アクティブおよびバックアップ RP は、同じ情報のコピーを保持します。

チェックポイティングに関するトラブルシューティングのヒント

チェックポインティング エラーに関するトラブルシューティングを簡単に行うため、次のコマンドを使用します。

debug acircuit checkpoint コマンドを使用すると、AC のチェックポインティング デバッグ メッセージをイネーブルにできます。

debug mpls l2transport checkpoint コマンドを使用すると、AToM のチェックポインティング デバッグ メッセージをイネーブルにできます。

show acircuit checkpoint コマンドを使用すると、AC チェックポイント情報を表示できます。

show mpls l2transport checkpoint コマンドを使用すると、チェックポインティングが許可されているかどうか、一括同期された AToM VC の数(アクティブ RP)、チェックポイント データを持つ AToM VC の数(スタンバイ RP)を表示できます。

show mpls l2transport vc detail コマンドを使用すると、VC チェックポイント情報の詳細を表示できます。

ISSU のサポート

Cisco IOS Release 12.2(33)SRC から、AToM NSF は、In Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)機能をサポートします。Virtual Private LAN Service(VPLS; バーチャル プライベート LAN サービス)NSF/SSO および HA with ISSU を使用すると、コントロールおよびデータ プレーンを停止することなく、Cisco IOS イメージをアップグレードまたはダウングレードできます。ISSU を使用すると、アクティブ RP およびスタンバイ RP 間のチェックポインティングおよび交換に使用されるすべてのメッセージ データ構造がバージョン化されます。

MPLS LDP グレースフル リスタートの設定

AToM NSF を設定するには、MPLS LDP グレースフル リスタートを設定する必要があります。

MPLS LDP GR はグローバルでイネーブルにされます。LDP GR をイネーブルにしても、既存の LDP セッションには影響しません。LDP GR は、機能がグローバルにイネーブルにされたあとに確立される新しいセッションに対してイネーブルです。

MPLS LDP GR を設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. mpls ldp graceful-restart

5. interface type slot / port

6. mpls ip

7. mpls label protocol { ldp | tdp | both }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [distributed]

 

Router(config)# ip cef distributed

シスコ エクスプレス フォワーディングをイネーブルにします。


) Cisco ASR 1000 シリーズ アグリゲーション サービス ルータでは、distributed キーワードは必須です。


ステップ 4

mpls ldp graceful-restart

 
Router (config)# mpls ldp graceful-restart

サービスの中断時に LDP バインディングおよび MPLS フォワーディング ステートを保護するように、ルータをイネーブルにします。

ステップ 5

interface type slot / port

 
Router(config)# interface pos 3/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

mpls ip

 

Router(config-if)# mpls ip

インターフェイスに対して MPLS ホップバイホップ転送を設定します。

ステップ 7

mpls label protocol { ldp | tdp | both }

 

Router(config-if)# mpls label protocol ldp

インターフェイスに対して LDP の使用を設定します。

TDP セッションはサポートされないため、LDP を使用する必要があります。

グローバル コンフィギュレーション モードで mpls label protocol ldp コマンドを発行することもできます。これにより、MPLS 用に設定されたすべてのインターフェイスで LDP がイネーブルになります。

AToM NSF の設定例

ここでは、次の設定例について説明します。

「AToM NSF の VLAN インターワーキングのイーサネット:例」

AToM NSF の VLAN インターワーキングのイーサネット:例

次の例に、AToM NSF を 2 つの PE ルータで設定する方法を示します。

PE1
PE2
ip cef distributed
!
redundancy
mode sso
!
boot system flash disk2:rsp-pv-mz
!
mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-labels
!
pseudowire-class atom-eth
encapsulation mpls
interworking ethernet
!
interface Loopback0
ip address 10.8.8.8 255.255.255.255
!
interface FastEthernet1/1/0
xconnect 10.9.9.9 123 encap mpls pw-class atom-eth
 
interface POS6/1/0
ip address 10.1.1.1 255.255.255.0
mpls ip
mpls label protocol ldp
clock source internal
crc 32
!
interface Loopback0
ip address 10.8.8.8 255.255.255.255
no shutdown
!
router ospf 10
nsf
network 10.8.8.8 0.0.0.0 area 0
network 19.1.1.1 0.0.0.0 area 0
 
ip cef distributed
!
redundancy
mode sso
!
boot system flash disk2:rsp-pv-mz
 
mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-labels
!
pseudowire-class atom-eth
encapsulation mpls
interworking eth
!
interface Loopback0
ip address 10.9.9.9 255.255.255.255
!
interface FastEthernet3/0/0
ip route-cache cef
!
interface FastEthernet3/0/0.3
encapsulation dot1Q 10
xconnect 10.8.8.8 123 encap mpls pw-class atom-eth
 
interface POS1/0/0
ip address 10.1.1.2 255.255.255.0
mpls ip
mpls label protocol ldp
clock source internal
crc 32
!
interface Loopback0
ip address 10.9.9.9 255.255.255.255
!
router ospf 10
nsf
network 10.9.9.9 0.0.0.0 area 0
network 10.1.1.2 0.0.0.0 area 0

その他の参考資料

ここでは、AToM NSF に関する関連資料について説明します。

関連資料

関連項目
参照先

ステートフル スイッチオーバー

『Stateful Switchover』

MPLS ラベル配布プロトコル

MPLS Label Distribution Protocol (LDP)

Cisco ノンストップ フォワーディング

『Cisco Nonstop Forwarding』

Any Transport over MPLS

Any Transport over MPLS

L2VPN インターワーキング設定

L2VPN Interworking

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 3478

『Graceful Restart Mechanism for Label Distribution』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にあるコマンド検索ツールを使用するか、または『 Cisco IOS Master Command List 』を参照してください。

debug acircuit checkpoint

debug mpls l2transport checkpoint

show acircuit checkpoint

show mpls l2transport checkpoint

show mpls l2transport vc

AToM NSFの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 AToM NSF Any Transport over MPLS および AToM グレースフル リスタートの機能情報

機能名
リリース
機能情報

AToM NSF

12.2(25)S
12.2(28)SB
12.2(33)SRC

この機能は、NSF、SSO、グレースフル リスタートを使用して、ルート プロセッサで、MPLS フォワーディング ステートを失うことなく、コントロール プレーン サービスの中断から回復できるようにします。

この機能は、12.2(25)S で Cisco 7500 シリーズ ルータに導入されました。

この機能は、12.2(28)SB でこのリリースに統合されました。

この機能は、12.2(33)SRC で Cisco 7600 ルータのこのリリースに統合されました。ISSU のサポートが追加されました。