マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS ポイントツーマルチポイント トラ フィック エンジニアリング:静的な疑似回線 のサポート
MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート
発行日;2012/01/30 | 英語版ドキュメント(2011/07/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート

機能情報の確認

目次

の前提条件

に関する制約事項

について

の概要

VC ラベル コリジョン

ラベル スプーフィングについて

の設定方法

ヘッドエンド ルータの設定

制約事項

テールエンド ルータの設定

スタティック PW 設定の確認

の設定例

例:ヘッドエンド ルータ(PE5)の設定

例:テールエンド ルータ(PE1)の設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート 機能を使用すると、ポイントツーマルチポイント Pseudowire(PW; 擬似回線)を設定して、レイヤ 2 トラフィックを 1 つの送信元から 1 つ以上の宛先に転送できます。この機能は、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Point-to-Multipoint Traffic Engineering(P2MP TE; ポイントツーマルチポイント トラフィック エンジニアリング)トンネルに対してトラフィック セグメンテーションを提供します。

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート 機能は、Layer 2 Virtual Private Network(L2VPN; レイヤ 2 バーチャル プライベート ネットワーク)スタティック PW を使用して MPLS ネットワークでポイントツーマルチポイント レイヤ 2 接続を提供することで、レイヤ 2 トラフィックを転送します。スタティック PW には、Label Distribution Protocol(LDP; ラベル配布プロトコル)は必要ありません。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

目次

「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの前提条件」

「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートに関する制約事項」

「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートについて」

「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの設定方法」

「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの設定例」

「その他の参考資料」

「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの機能情報」

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの前提条件

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート 機能を設定する前に、次の前提条件が満たされていることを確認します。

すべてのルータ(ヘッドエンド、ミッドポイント、およびテールエンド)に Cisco IOS Release 15.0(1)S 以降がインストールされていること。

すべてのルータ(ヘッドエンド、ミッドポイント、およびテールエンド)に Cisco 7600 シリーズ ルータがインストールされていること。

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート 機能は、出力レプリケーションがサポートされているあらゆるスーパーバイザ エンジン上でサポートされます。

詳細については、次のマニュアルを参照してください。

『AToM Static Pseudowire Provisioning』

『MPLS Point-to-Multipoint Traffic Engineering』

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートに関する制約事項

この機能は、Cisco 7600 シリーズ ルータのみでサポートされています。

この機能は、次の接続回線のみでサポートされます。

ATM over MPLS

スケーラブルな Ethernet over MPLS

PPP over MPLS

Frame Relay over MPLS

High-Level Data Link Control over MPLS

レイヤ 2 トラフィックの P2MP TE トンネルへのマッピングは、 xconnect preferred コマンドを使用して手動で設定されます。スタティック ルートおよび xconnect フォールバック設定を使用したトラフィックはサポートされません。

この機能では、出力レプリケーションはサポートされません。

この機能は、Label Switched Path(LSP; ラベル スイッチド パス)の ping および trace ではサポートされません。

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートについて

「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの概要」

「VC ラベル コリジョン」

「ラベル スプーフィングについて」

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの概要

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート 機能は、1 つの送信元から 1 つ以上の宛先にレイヤ 2 トラフィックを転送します。この機能には、次の特性があります。

この機能は、L2VPN スタティック PW を使用して MPLS ネットワークでポイントツーマルチポイント レイヤ 2 接続を提供し、レイヤ 2 トラフィックを転送します。

この機能によって提供された MPLS P2MP TE トンネルを使用すると、ビデオ配布およびクロック配布(モバイル バックホール)などのアプリケーションが可能になります。

この機能は、Cisco Nonstop Forwarding(NSF; ノンストップ フォワーディング)、Stateful Switchover(SSO; ステートフル スイッチオーバー)と互換性があります。この機能に NSF/SSO を設定する方法につては、『 NSF/SSO--MPLS TE and RSVP Graceful Restart 』および『 MPLS Point-to-Multipoint Traffic Engineering 』を参照してください。

この実装では、『 Framework and Requirements for Virtual Private Multicast Service 』に従って、PW は双方向です。

VC ラベル コリジョン

この機能では、コンテキスト固有ラベル スペースはサポートされません。MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート 機能を設定する場合、ローカル バインディングが一意であることを確認する必要があります。ローカル バインディングが一意でない場合、トラフィックが意図せずにマージされてしまう場合があります。図 1 では、両方の PW がルータ PE 3 をエンドポイントとして共有します。各 PW のローカル ラベルは 16 であり、これがコリジョンを引き起こします。

図 1 VC ラベル コリジョンの回避

ラベル スプーフィングについて

P2MP スタティック PW では、ラベルが両端で正しく設定されたことを確認するシグナリング プロトコルはありません。ラベルが正しく設定されていない場合、トラフィックが間違った宛先に送られる場合があります。これはマルチキャスト設定であるため、スケーラビリティが影響を受けるおそれがあります。

P2MP スタティック PW は、アップストリーム方向にはコンテキスト固有ラベルを持たず、シグナリング プロトコルは使用しません。したがって、PW ラベルをスプーフしてトラフィックを間違った宛先にルーティングする可能性があります。PW ラベルがヘッドエンドでスプーフされた場合、テールエンドでの MPLS ルックアップはグローバル テーブルで実行されるため、テールエンドでは検証できません。このため、スプーフされたラベルがグローバル テーブルに存在する場合、トラフィックは間違った宛先(Customer Equipment(CE; カスタマー装置))にルーティングされます。

オペレータが正しくないスタティック PW ラベルを設定した場合も、同じ状況が起こり得ます。間違った PW ラベルが設定された場合、トラフィックは間違った宛先(CE)に送られます。

図 2に、コンテキスト固有ラベル スペースなしの PW ラベル割り当てを示します。

図 2 コンテキスト固有ラベル スペースなしの PW ラベル割り当て

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの設定方法

ここでは、次の手順について説明します。

「ヘッドエンド ルータの設定」(必須)

「テールエンド ルータの設定」(必須)

「スタティック PW 設定の確認」(任意)

ヘッドエンド ルータの設定

ヘッドエンド ルータを設定するには、次の作業を実行します。この作業には、次の処理が含まれます。

xconnect コマンドの一部として、フェイク ピア IP アドレスを設定すること。この IP アドレスがネットワーク内の他のルータによって使用されないように、ネットワーク ドメイン管理者がこの IP アドレスを予約することが非常に重要です。

優先パス設定を使用して P2MP スタティック PW を設定すること。PW クラスでは、トンネル インターフェイスは優先パスとして指定され、フォールバック パスはディセーブルになります。

詳細については、次のマニュアルを参照してください。

『AToM Static Pseudowire Provisioning』

『MPLS Point-to-Multipoint Traffic Engineering』

制約事項

フォールバック パス設定は、P2MP スタティック PW はサポートされません。

手順の概要

1. enable

2. configure terminal

3. pseudowire-class class-name

4. encapsulation mpls

5. protocol none

6. preferred-path [ interface tunnel tunnel-number ] [ disable-fallback ]

7. exit

8. interface tunnel number

9. ip unnumbered loopback number

10. tunnel mode mpls traffic-eng point-to-multipoint

11. tunnel destination list mpls traffic-eng { identifier dest-list-id | name dest-list-name }

12. exit

13. interface loopback number

14. ip address [ ip-address mask [ secondary ]]

15. exit

16. interface ethernet number

17. no ip address [ ip-address mask [ secondary ]]

18. no keepalive [ period [ retries ]]

19. xconnect peer-ip-address vcid encapsulation mpls manual pw-class class-name

20. mpls label local-pseudowire-label remote-pseudowire-label

21. [ no ] mpls control-word

22. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class class-name

 

Router(config)# pseudowire-class static-pw

スタティック AToM PW クラスを 指定 し、PW クラス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation mpls
 

Router(config-pw)# encapsulation mpls

PW を介したレイヤ 2 トラフィックのトンネリング用データ カプセル化方式として、MPLS を指定します。

ステップ 5

protocol none

 

Router(config-pw)# protocol none

スタティック PW から作成される L2TPv3 セッションではシグナリングが使用されないように 指定 します。

ステップ 6

preferred-path interface tunnel tunnel-number disable-fallback

 

Router(config-pw)# preferred-path interface tunnel 1 disable-fallback

P2MP トンネルをトラフィック パスとして指定し、優先パスが到達不能の場合に、デフォルト パスを使用することでルータをディセーブルにします。

ステップ 7

exit

 

Router(config-pw)# exit

PW クラス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻して、トンネル選択をイネーブルにします。

ステップ 8

interface tunnel number

 

Router(config)# interface tunnel 1

トンネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

ip unnumbered loopback number

 

Router(config-if)# ip unnumbered loopback0

明示的な IP アドレスをインターフェイスに割り当てずにループバック インターフェイス上で IP 処理をイネーブルにします。

loopback0 を指定することで、トンネル インターフェイスにループバック インターフェイス 0 の IP アドレスと同じ IP アドレスが割り当てられます。

このコマンドは、ループバック インターフェイス 0 が IP アドレスとともに設定されるまでは有効になりません。ステップ 14 を参照してください。

ステップ 10

tunnel mode mpls traffic-eng point-to-multipoint

 

Router(config-if)# tunnel mode mpls traffic-eng point-to-multipoint

トンネル上で MPLS P2MP TE をイネーブルにします。

ステップ 11

tunnel destination list mpls traffic-eng { identifier dest-list-id | name dest-list-name }

 

Router(config-if)# tunnel destination list mpls traffic-eng name in-list-01

宛先リストを指定して、ポイントツーマルチポイント宛先の IP アドレスを指定します。

ステップ 12

exit

 

Router (config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 13

interface loopback number

 

Router (config)# interface loopback0

ループバック インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 14

ip address [ ip-address mask [ secondary ]]

 

Router (config-if)# ip address 172.16.255.5 255.255.255.255

ループバック インターフェイスにプライマリ IP アドレスを指定します。

ステップ 15

exit

 

Router (config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 16

interface ethernet number

 

Router (config)# interface ethernet0/0

イーサネット インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 17

no ip address [ ip-address mask [ secondary ]]

 

Router (config-if)# no ip address

インターフェイス上で IP 処理をディセーブルにします。

ステップ 18

no keepalive [ period [ retries ]]

 

Router (config-if)# no keepalive

インターフェイス上でキープアライブ パケットがディセーブルになるように指定します。

インターフェイスが停止しても、キープアライブ パケットがディセーブルになっていれば、セッションはシャットダウンしないで継続します。

ステップ 19

xconnect peer-ip-address vcid encapsulation mpls manual pw-class class-name
 

Router(config-if)# xconnect 172.16.255.255 100 encapsulation mpls manual pw-class static-pw

スタティック AToM PW を設定して、xconnect コンフィギュレーション モードを開始します。ここでスタティック PW ラベルが設定されます。

ステップ 20

mpls label local-pseudowire-label remote-pseudowire-label
 

Router(config-if-xconn)# mpls label 16 17

ローカルおよびリモート回線ラベルを定義して、AToM スタティック PW 接続を設定します。

ラベルは、 mpls label range コマンドを使用して設定されたスタティック ラベル範囲内にある未使用のスタティック ラベルである必要があります。

mpls label コマンドを使用すると、入力したラベルの有効性がチェックされ、有効でない場合はエラー メッセージが表示されます。 remote-pseudowire-label 引数に指定されたラベルは、ピア PE のローカル PW ラベルの値である必要があります。

ステップ 21

[ no ] mpls control-word
 

Router(config-if-xconn)# no mpls control-word

MPLS 制御ワードが送信されるかどうかを設定します。

このコマンドは、フレーム リレー Data-Link Connection Identifier(DLCI; データリンク接続識別子)接続回線および ATM Adaptation Layer 5(AAL5; ATM アダプテーション レイヤ 5)接続回線に対して設定する必要があります。その他の接続回線では、制御ワードはデフォルトで含まれています。

制御ワードの包含をイネーブルにする場合、回線が正しく動作するように、接続の両端でイネーブルにする必要があります。

制御ワードの包含は、 no mpls control-word コマンドを使用して明示的にディセーブルにできます。

ステップ 22

exit
 

Router(config-if-xconn)# exit

コンフィギュレーション モードを終了します。

目的のコンフィギュレーション モードに到達するまで、ルータ プロンプトで exit コマンドを入力し続けます。

テールエンド ルータの設定

テールエンド ルータを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. pseudowire-class class-name

4. encapsulation mpls

5. protocol none

6. exit

7. interface loopback number

8. ip address [ ip-address mask [ secondary ]]

9. exit

10. interface ethernet number

11. no ip address [ ip-address mask [ secondary ]]

12. no keepalive [ period [ retries ]]

13. xconnect peer-ip-address vcid encapsulation mpls manual pw-class class-name

14. mpls label local-pseudowire-label remote-pseudowire-label

15. [ no ] mpls control-word

16. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class class-name

 

Router(config)# pseudowire-class static-pw

スタティック AToM PW クラスを指定し、PW クラス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation mpls
 

Router(config-pw)# encapsulation mpls

PW を介したレイヤ 2 トラフィックのトンネリング用データ カプセル化方式として、MPLS を指定します。

ステップ 5

protocol none

 

Router(config-pw)# protocol none

スタティック PW から作成される L2TPv3 セッションではシグナリングが使用されないように指定します。

ステップ 6

exit

 

Router(config-pw)# exit

PW クラス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 7

interface loopback number

 

Router(config)# interface loopback0

ループバック インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip address [ ip-address mask [ secondary ]]

 

Router(config-if)# ip address 172.16.255.1 255.255.255.255

ループバック インターフェイスにプライマリ IP アドレスを指定します。

ステップ 9

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 10

interface ethernet number

 

Router(config)# interface ethernet0/0

イーサネット インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 11

no ip address [ ip-address mask [ secondary ]]

 

Router(config-if)# no ip address

インターフェイス上で IP 処理をディセーブルにします。

ステップ 12

no keepalive [ period [ retries ]]

 

Router(config-if)# no ip address

インターフェイス上でキープアライブ パケットがディセーブルになるように指定します。

インターフェイスが停止しても、キープアライブ パケットがディセーブルになっていれば、セッションはシャットダウンしないで継続します。

ステップ 13

xconnect peer-ip-address vcid encapsulation mpls manual pw-class class-name
 

Router(config-if)# xconnect 172.16.255.5 100 encapsulation mpls manual pw-class static-pw

スタティック AToM PW を設定して、xconnect コンフィギュレーション モードを開始します。ここでスタティック PW ラベルが設定されます。

ステップ 14

mpls label local-pseudowire-label remote-pseudowire-label
 

Router(config-if-xconn)# mpls label 17 16

ローカルおよびリモート回線ラベルを定義して、AToM スタティック PW 接続を設定します。

ラベルは、 mpls label range コマンドを使用して設定されたスタティック ラベル範囲内にある未使用のスタティック ラベルである必要があります。

mpls label コマンドを使用すると、入力したラベルの有効性がチェックされ、有効でない場合はエラー メッセージが表示されます。 remote-pseudowire-label 引数に指定されたラベルは、ピア PE のローカル PW ラベルの値である必要があります。

ステップ 15

[ no ] mpls control-word
 

Router(config-if-xconn)# no mpls control-word

MPLS 制御ワードが送信されるかどうかを設定します。

このコマンドは、フレーム リレー Data-Link Connection Identifier(DLCI; データリンク接続識別子)接続回線および ATM Adaptation Layer 5(AAL5; ATM アダプテーション レイヤ 5)接続回線に対して設定する必要があります。その他の接続回線では、制御ワードはデフォルトで含まれています。

制御ワードの包含をイネーブルにする場合、回線が正しく動作するように、接続の両端でイネーブルにする必要があります。

制御ワードの包含は、 no mpls control-word コマンドを使用して明示的にディセーブルにできます。

ステップ 16

exit
 

Router(config-if-xconn)# exit

コンフィギュレーション モードを終了します。

目的のコンフィギュレーション モードに到達するまで、ルータ プロンプトで exit コマンドを入力し続けます。

スタティック PW 設定の確認

L2VPN スタティック PW コンフィギュレーションを確認するには、 show running-config EXEC コマンドを使用します。L2VPN スタティック PW が正しくプロビジョニングされたことを確認するには、次の手順で説明するように、 show mpls l2transport vc detail および ping mpls pseudowire EXEC コマンドを使用します。

手順の概要

1. show mpls l2transport vc detail

2. ping mpls pseudowire ipv4-address vc-id vc-id

手順の詳細


ステップ 1 show mpls l2transport vc detail

スタティック PW 以外のコンフィギュレーションでは、このコマンドにより、MPLS ラベル(LDP など)を送信するために使用されるプロトコル タイプのリストが表示されます。スタティック PW コンフィギュレーションでは、シグナリング プロトコル フィールドの値は、Manual である必要があります。

次の例では、出力例が表示されます。

Router# show mpls l2transport vc detail
 
Local interface: Et1/0 up, line protocol up, Ethernet up
Destination address: 10.0.1.1, VC ID: 200, VC status: up
Output interface: Et3/0, imposed label stack {17}
Preferred path: not configured
Default path:
Next hop: 10.0.0.2
Create time: 00:27:27, last status change time: 00:27:24
Signaling protocol: Manual
MPLS VC labels: local 17, remote 17
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 193, send 193
byte totals: receive 19728, send 23554
packet drops: receive 0, send 0
 

ステップ 2 ping mpls pseudowire ipv4-address vc-id vc-id

スタティック PW 上ではパラメータの指示制御プロトコル交換は実行されないため、接続の両端が正しく設定されている必要があります。ラベルまたは制御ワード オプションの不一致を検出する 1 つの方法は、設定作業の一環として、MPLS PW LSP ping コマンドを送信し、問題が検出された場合は接続を再設定します。 ping コマンドが宛先に正常に送信されると、感嘆符(!)が表示されます。

次の例では、出力例が表示されます。

Router# ping mpls pseudowire 10.7.1.2 vc-id 1001
 
Sending 5, 100-byte MPLS Echos to 10.7.1.2,
timeout is 2 seconds, send interval is 0 msec:

 

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms


 

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの設定例

ここでは、ヘッドエンド ルータ(PE5)およびテールエンド ルータ(PE1)の PW 設定を表示する例を示します。

例:ヘッドエンド ルータ(PE5)の設定

次のヘッドエンド ルータの設定例では、次の点に注意します。

preferred-path interface tunnel1 コマンドにより、P2MP トンネルが優先パスとして指定されます。

tunnel mode mpls traffic-eng point-to-multipoint コマンドにより、P2MP トンネルがイネーブルにされます。

mpls label コマンドにより、スタティック バインディングが定義されます。

xconnect コマンドにより、ダミー ピアが作成されます。

Router(config)# pseudowire-class STATIC-PW
Router(config-pw-class)# encapsulation mpls
Router(config-pw-class)# protocol none
Router(config-pw-class)# preferred-path interface Tunnel1
!
Router(config)# interface Tunnel1
Router(config-if)# description PE5->PE1,PE2,PE3,PE4-EXCIT
Router(config-if)# ip unnumbered loopback0
Router(config-if)# tunnel mode mpls traffic-eng point-to-multipoint
Router(config-if)# tunnel destination list mpls traffic-eng name P2MP-EXCIT-DST-LIST
Router(config-if)# tunnel mpls traffic-eng priority 7 7
Router(config-if)# tunnel mpls traffic-eng bandwidth 10000
!
Router(config)# interface loopback0
Router(config-if)# ip address 172.16.255.5 255.255.255.255
!
Router(config)# interface ethernet0/0
Router(config-if)# description CONNECTS to CE5
Router(config-if)# no ip address
Router(config-if)# no keepalive
Router(config-if)# xconnect 172.16.255.255 100 encapsulation mpls manual pw-class static-pw
Router(config-if-xconn)# mpls label 16 17
Router(config-if-xconn)# mpls control-word
!

例:テールエンド ルータ(PE1)の設定

次のテールエンド ルータの設定例では、次の点に注意します。

すべてのテールエンド ルータは、同一のバインディング設定を使用します。

xconnect コマンドは、必ずテールエンド ルータ上で設定される必要があります。

Router(config)# pseudowire-class static-pw
Router(config-pw-class)# encapsulation mpls
Router(config-pw-class)# protocol none
!
Router(config)# interface loopback0
Router(config-if)# ip address 172.16.255.1 255.255.255.255
!
Router(config)# interface ethernet0/0
description CONNECTS TO CE1
Router(config-if)# no ip address
Router(config-if)# no keepalive
Router(config-if)# xconnect 172.16.255.5 100 encapsulation mpls manual pw-class static-pw
Router(config-if-xconn)# mpls label 17 16
Router(config-if-xconn)# mpls control-word
!

その他の参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

Cisco IOS Master Commands List, All Releases

MPLS コマンド

Cisco IOS Multiprotocol Label Switching Command Reference

MPLS P2MP TE

MPLS Point-to-Multipoint Traffic Engineering

AToM スタティック PW プロビジョニング

AToM Static Pseudowire Provisioning

NSF/SSO

NSF/SSO--MPLS TE and RSVP Graceful Restart

規格

規格
タイトル

draft-ietf-l2vpn-vpms-frmwk-requirements-02.txt

Framework and Requirements for Virtual Private Multicast Service

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

-

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポートの機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能のサポートが初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがないかぎり、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート の機能情報

機能名
リリース
機能情報

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:静的な疑似回線のサポート

15.0(1)S

この機能を使用すると、ポイントツーマルチポイント PW を設定して、レイヤ 2 トラフィックを 1 つの送信元から 1 つ以上の宛先に転送できます。