マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS ポイントツーマルチポイント トラ フィック エンジニアリング
MPLS ポイントツーマルチポイント トラフィック エンジニアリング
発行日;2012/01/30 | 英語版ドキュメント(2011/07/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS ポイントツーマルチポイント トラフィック エンジニアリング

機能情報の確認

目次

MPLS ポイントツーマルチポイント トラフィック エンジニアリング条件

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの制約事項

MPLS ポイントツーマルチポイント トラフィック エンジニアリングに関する情報

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの概要

P2MP TE Sub-LSP のシグナリング方法

P2MP TE トラフィックの転送方法

ダイナミック パスまたは明示パスを使用した IGP パスの計算

再マージ イベント

クロスオーバー イベント

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの利点

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:トラフィックの再最適化

P2MP TE トンネルと P2P TE トンネルとの共存

FRR を使用した P2MP TE リンクの保護

FRR 障害検出メカニズム

P2MP TE の帯域幅プリエンプション

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの設定方法

ヘッドエンド ルータの設定

制約事項

ミッドポイント ルータの設定

テールエンド ルータの設定

P2MP TE トンネルでの FRR の設定

MPLS トラフィック エンジニアリング システムのイベント ロギングのイネーブル

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの設定の確認

ヘッドエンド ルータの設定の確認

ミッドポイント ルータの設定の確認

テールエンド ルータの設定の確認

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの設定例

例:ヘッドエンド ルータ(PE5)の設定

例:ミッドポイント ルータ(P1)の設定

例:テールエンド ルータ(PE1)の設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの機能情報

用語集

MPLS ポイントツーマルチポイント トラフィック エンジニアリング

MPLS ポイントツーマルチポイント トラフィック エンジニアリング機能を使用すると、1 つの送信元から複数の宛先に Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)トラフィックを転送できます。Cisco Nonstop Forwarding(NSF; ノンストップ フォワーディング)および Stateful Switchover(SSO; ステートフル スイッチオーバー)(NSF/SSO)は、ルート プロセッサに致命的な障害が発生した場合に、Point-to-Multipoint(P2MP; ポイントツーマルチポイント)Traffic Engineering(TE; トラフィック エンジニアリング)トンネル トラフィックの中断を最小限に抑えます。トラフィック損失はプラットフォームによって異なります。

この機能を使用した NSF/SSO の設定の詳細については、『 NSF/SSO--MPLS TE and RSVP Graceful Restart 』を参照してください。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「MPLS ポイントツーマルチポイント トラフィック エンジニアリングの機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

MPLS ポイントツーマルチポイント トラフィック エンジニアリング条件

MPLS Point-to-Multipoint Traffic Engineering(P2MP TE; ポイントツーマルチポイント トラフィック エンジニアリング)機能を設定する前に、次の点に注意します。

MPLS ネットワークで、ヘッドエンド、ミッドポイント、テールエンドの各ルータに Resource Reservation Protocol(RSVP; リソース予約プロトコル)およびトラフィック エンジニアリング機能を設定します。

Cisco ノンストップ NSF/SSO は、NSF/SSO が設定されたデュアル ルート プロセッサを搭載したプラットフォームのみでサポートされています。

NSF/SSO をサポートするには、すべてのルータ(ヘッドエンド、ミッドポイント、テールエンド)を Cisco 7600 シリーズ ルータにする必要があります。

すべてのルータに RSVP グレースフル リスタートが設定されている必要があります。詳細については、『 NSF/SSO--MPLS TE and RSVP Graceful Restart 』を参照してください。

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの制約事項

次の機能はサポートされません。

P2MP TE 機能は、エリア間ネットワークおよび自律システム ネットワークではサポートされません。すべてのP2MP TE Sub-Label Switched Path(LSP; ラベル スイッチド パス)の起点および終端は、同一の IGP および自律システム ドメインにする必要があります。

P2MP Sub-LSP のリンク保護(ノードおよびパス保護ではない)のみがサポートされます。

P2MP TE 機能では、Protocol Independent Multicast(PIM)スパース モードはサポートされません。PIM Source Specific Multicast(SSM)のみがサポートされます。

ヘッドエンド ルータでは、手動で宛先を追加および削除する必要があります。宛先を動的に追加したり、削除したりすることはサポートされていません。

RFC 4090 には、2 つの FRR 手法(ファシリティ バックアップおよび迂回バックアアップ)が説明されています。Point-to-Point(P2P; ポイントツーポイント)TE および P2MP TE では、いずれもファシリティ FRR 手法のみがサポートされます。

draft-ietf-mpls-p2mp-te-mib-09.txt で説明されているように、P2MP TE では、P2MP トンネルの MIB はサポートされません。P2MP TE ヘッドエンド インターフェイスは、MPLS-TE-STD-MIB の mplsTunnelTable として表現されます。ただし、MPLS-TE-STD-MIB では Sub-LSP の関連情報はサポートされません。

MPLS LSP ping および MPLS Operations, Administration, and Maintenance(OAM; 運用管理および保守)機能はサポートされません。

MPLS P2MP TE トンネルおよび IP マルチキャスト(MFIB)では、フラグメンテーションはサポートされません。ヘッドエンド ルータの入力インターフェイスで MTU 値を設定します。

ポートチャネルに MPLS TE Fast Reroute(FRR; 高速リルート)が統合されている場合は、次の制限事項が適用されます。

アクティブ ポートおよびバックアップ ポートは、ポートチャネル インターフェイスである必要があります。

プライマリ ポートチャネル インターフェイスのすべてのメンバは、同一のスロット上にある必要があります。

Cisco 7600 シリーズ ルータでは、Sub-LSP に対して FRR 保護がイネーブルになっている場合、バックアップ ポートチャネルのすべてのメンバは同一のスロット上にある必要がありますが、このスロットはプライマリ ポートチャネルとは異なるものである必要があります。

S 以外のシャーシを使用した Cisco 7600 シリーズ ルータでは、トラフィック損失は最大 2 秒です。

MPLS ポイントツーマルチポイント トラフィック エンジニアリングに関する情報

「MPLS ポイントツーマルチポイント トラフィック エンジニアリングの概要」

「P2MP TE Sub-LSP のシグナリング方法」

「P2MP TE トラフィックの転送方法」

「ダイナミック パスまたは明示パスを使用した IGP パスの計算」

「MPLS ポイントツーマルチポイント トラフィック エンジニアリングの利点」

「MPLS ポイントツーマルチポイント トラフィック エンジニアリング:トラフィックの再最適化」

「P2MP TE トンネルと P2P TE トンネルとの共存」

「FRR を使用した P2MP TE リンクの保護」

「P2MP TE の帯域幅プリエンプション」

「MPLS ポイントツーマルチポイント トラフィック エンジニアリングの設定方法」

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの概要

図 1に示されているように、P2MP TE ネットワークには、次の要素が含まれています。

ヘッドエンド ルータ(送信元ルータまたは入力ルータとも呼ばれます)では、Label Switched Path(LSP; ラベル スイッチド パス)が開始されます。ヘッドエンド ルータは、分岐点にもなります。つまり、ルータによりパケット レプリケーションが実行され、Sub-LSP は異なる宛先に分割されます。

ミッドポイント ルータでは、Sub-LSP シグナリングが処理されます。ミッドポイント ルータは、分岐点にもなります。

テールエンド ルータ(宛先ルータ、出力ルータ、リーフノード ルータとも呼ばれます)では、Sub-LSP シグナリングが終了します。

バド ルータはミッドポイント ルータであり、同時にテールエンド ルータでもあります。

P2MP トンネルは、1 つ以上の Sub-LSP で構成されています。同一の P2MP トンネルに属するすべての Sub-LSP には、ヘッドエンド ルータで設定されている同一の制約、保護ポリシーなどが使用されます。

図 1 基本 P2MP TE トンネル

 

P2MP TE トンネルは、基本的なポイントツーポイント TE トンネルに存在する機能に基づいて構築されます。P2MP TE トンネルには、次の特性があります。

送信元(ヘッドエンド)はありませんが、複数の宛先(テールエンド)があります。

単一方向です。

明示的にルーティングされます。

複数の Sub-LSP によりヘッドエンド ルータがさまざまなテールエンド ルータに接続されます。

図 2 に、3 つの宛先を持つ P2MP TE トンネルを示します。

PE1 はヘッドエンド ルータです。

P01 は分岐点ルータで、パケット レプリケーションが発生します。

PE2、PE3、PE4 はテールエンド ルータで、Sub-LSP はここで終了します。

PE ルータと CE ルータ間では、PIM がイネーブルになり、直接接続された Customer Edge(CE; カスタマー エッジ)ルータとマルチキャスト ルーティング情報が交換されます。PIM は、P2MP TE トンネル間ではイネーブルではありません。

Sub-LSP 障害エラーのデータベース

(P2MP、P2P のいずれの場合でも)Sub-LSP が SSO スイッチオーバー後に回復できなかった場合は、障害がエラー データベースに記録され、トラブルシューティングに使用されます。 show ip rsvp high database lsp コマンドを使用すれば、エラー データベースのエントリを表示されます。

図 2 P2MP TE トンネルを使用したネットワーク トポロジ

 

P2MP TE Sub-LSP のシグナリング方法

RFC 4875 で定義されている RSVP TE 拡張を使用すると、複数の Sub-LSP をヘッドエンド ルータからシグナリングできます。P2MP TE トンネルは、ヘッドエンド ルータをさまざまなテールエンド ルータに接続する複数の Sub-LSP で構成されています。

ヘッドエンド ルータにより、1 つの RSVP パス メッセージが各宛先に送信されます。テールエンド ルータは、RESV メッセージで応答します。Label Forwarding Information Base(LFIB; ラベル転送情報ベース)は、RESV メッセージによって割り当てられた RSVP ラベルを使用して入力されます。

P2MP TE 機能では、同一の Path/Resv メッセージ内に存在する複数の Sub-LSP のシグナリングはサポートされません。複数の Sub-LSP が同一のメッセージ内に発生している場合、ルータは PathErr Unknown Objects メッセージを送信し、複数の Sub-LSP を持つ Path/Resv メッセージは転送されません。

テールエンド ルータにより非予約ラベルが割り当てられます。この非予約ラベルは 15 より多く、暗黙的または明示的ヌル ラベルは含まれません。非予約ラベルを使用すると、IP マルチキャストはテールエンド ルータ上で Reverse Path Forwarding(RPF; リバース パス転送)チェックを実行できるようになります。Sub-LSP テールエンド ルータは通常のインターフェイスとしては表現できないため、特殊な LSP Virtual Interface(VIF; 仮想インターフェイス)が自動的に作成されます。LSP VIF は、P2MP TE テールエンド ルータから発信されるすべての IP マルチキャスト トラフィックの発信側インターフェイスを表します。

図 3 に、LSP シグナリング プロセスを示します。

図 3 LSP のシグナリング方法

 

P2MP TE トラフィックの転送方法

トラフィック エンジニアリング トンネルのヘッドエンドでは、スタティック Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)グループからトンネルへのマッピングを使用して、IP マルチキャスト トラフィックが P2MP TE トンネルに関連付けられた一意の MPLS ラベルにカプセル化されます。マルチキャスト トラフィックは、P2MP ツリーでラベル スイッチされ、分岐で複製されて、P2MP ツリー上にバド ノードが発信されます。ラベル付きパケットがテールエンド(PE ルータ)に到達すると、MPLS ラベルは削除され、IP マルチキャスト ツリーに転送されて、エンドポイント方向に向けられます。図 4に、このプロセスを示します。


) P2MP TE 機能では、最後から 2 番めのホップでのポッピングはサポートされません。したがって、出力ルータは明示的ヌル ラベルまたは非ヌル ラベルを割り当てる必要があります。


図 4 パケットの P2MP ツリー通過方法

 

Sub-LSP が共通ルータ(分岐点)を共有し、そのルータの同一の入力インターフェイスを使用する場合、転送には同一の MPLS ラベルが使用されます。図 5 に示すとおり、マルチキャスト ステートは、分岐点で MPLS ラベルを再使用して構築されます。この例では、ルータ C を使用する 2 つの Sub-LSP により、MPLS ラベル 17 が共有されています。

図 5 分岐点での MPLS ラベルの再使用

 

ダイナミック パスまたは明示パスを使用した IGP パスの計算

明示パスを指定するか、またはパスがダイナミックに作成されるようにできます。また、帯域幅パラメータを指定できます。帯域幅パラメータは、Open Shortest Path First(OSPF)および統合 Intermediate System-to-Intermediate System(IS-IS)に対する既存の RSVP-TE 拡張を使用して、MPLS ネットワーク全体でフラッディングされます。

MPLS コア ネットワークでは、RSVP を使用してエンドツーエンドの IP マルチキャスト接続をイネーブルにします。テールエンド ルータおよびエンドポイント ルータでは、PIM を使用して直接接続された CE ルータとマルチキャスト ルーティング情報が交換されます。PIM は、MPLS コアでは設定されていません。

P2MP TE トンネルと通常の P2P TE トンネルは共存できます。この場合、既存のパス計算と帯域幅プリエンプション ルールが適用されます。

ご使用の P2MP TE ネットワークでダイナミック パス計算をイネーブルにするか、CLI コマンドを使用して明示パスを設定するか、または両方の方法を使用して IGP パスを作成します。

ダイナミック パスは、Constrained Shortest Path First(CSPF)を使用して作成され、宛先への最良のパスが決定されます。CSPF では、計算の一環として、帯域幅、アフィニティ、プライオリティなどのパス制約が使用されます。

明示パスには、Sub-LSP で使用するヘッドエンド ルータからテールエンド ルータへのパスを手動で指定できます。ヘッドエンド ルータの静的パスを設定します。

再マージ イベント

明示パスに設定された等コスト リンクまたは等コスト パスの数が限られている場合、ミッドポイント ルータでは 2 つの Sub-LSP が異なる入力インターフェイスを使用して接続されていても、出力インターフェイスは同じものが使用される場合があります。これは再マージ イベントと呼ばれ、MPLS パケットの重複を引き起こします。ルータにより再マージ イベントが検出されると、ルータから「PathErr Routing Problem: Remerge Detected」メッセージがヘッドエンド ルータに送信されます。Sub-LSP は確立しません。ダイナミック パスでは、ルータから再マージ状況を回避するパスがシグナリングされます。

クロスオーバー イベント

P2MP トンネルでは、兄弟関係にある 2 つの Sub-LSP(同一のリンクおよびラベルを共有する Sub-LSP)が、同一の交差ノード上で、異なる着信インターフェイスおよび異なる発信インターフェイスを持つ場合、「クロスオーバー」と呼ばれます。兄弟関係にある Sub-LSP は、入力ラベルを共有することも、出力帯域幅を共有することもありません。帯域幅が無駄になるため、クロスオーバー LSP の設定は避けます。ただし、Sub-LSP の重複によりエラーが発生することはありません。

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの利点

P2MP TE機能には、次の利点があります。

P2MP TE Sub-LSP を設定する際、アフィニティ、管理メトリック、FRR 保護、帯域幅制約などのシグナリング アトリビュートを設定できます。

P2MP TE は、単一のトラフィック コントロール ポイントを提供します。すべてのシグナリングおよびパス パラメータは、ヘッドエンド ルータで指定します。

明示パスを設定して、トラフィックの配布を最適化できます。

P2MP TE Sub-LSP に対して、FRR リンク保護および帯域幅保護をイネーブルにできます。

MPLS コアでは Protocol Independent Multicast(PIM; プロトコル独立マルチキャスト)は必要ありません。テールエンド ルータ上の非 MPLS インターフェイスだけは、PIM を設定する必要があります。

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:トラフィックの再最適化

最初の Sub-LSP が正常にシグナリングされると、P2MP TE トンネルは動作(アップ)状態になります。すべての Sub-LSP が停止すると、P2MP TE トンネルは動作していない(ダウン)状態になります。トンネルの再最適化は特定のイベントによりトリガーできます。

Sub-LSP のいずれかがバックアップ トンネルに高速リルートされている(ダイナミック LSP の場合)。

リンクが動作状態(コマンド mpls traffic-eng reoptimize events link-up が設定されている場合)。

mpls traffic-eng reoptimize timers frequency コマンドにより、定期的にスケジュール最適化が実行される。

ネットワーク管理者が mpls traffic-eng reoptimize コマンドを使用してトンネル最適化を強制的に実行する。

FRR 保護されたインターフェイスが動作中になった。

非 FRR LSP により、再マージ状態が検出された。

P2MP トンネルが再最適化されると、新しい LSP がシグナリングされ、トラフィックは新しい LSP に移動されます。

トンネルの再最適化が必要かどうかを決定するために、ルータでは次の条件が考慮されます。

ルータは、新しいツリーと現在のツリーのアクセス可能な宛先の数を比較します。新しいツリーに含まれているアクセス可能な宛先の数の方が現在のツリーよりも多い場合、ルータは再最適化を実行します。新しいツリーに含まれているアクセス可能な宛先の数の方が現在のツリーよりも少ない場合、ルータは現在のツリーを保持します。

ルータは、現在のツリー内のアクセス可能な宛先のセットと同じセットが新しいツリーにあることを確認します。新しいツリーに同一の宛先が含まれていない場合は、ルータは現在のツリーを保持します。

ルータは、新しいツリー内の宛先の数と古いツリー内の宛先の数を比較します。新しいツリー内の宛先の数の方が現在のツリー内の宛先の数よりも多い場合、ルータは新しいツリーに切り替えます。これにより、新しいツリーには既存の宛先すべてと、追加の宛先が含まれることが保証されます。

ルータは、現在のツリーと新しいツリーのメトリックを比較して、新しいツリーと現在のツリーに同一のアクセス可能な宛先のセットが含まれていことを確実にします。

ルータは、古いツリーと新しいツリーのアドミニストレイティブ ウェイトを比較します。累積アドミニストレイティブ ウェイトが小さい場合には、ルータは新しいツリーに切り替えます。この手順は、その他すべての条件が同じであった場合のタイブレーカとして適用されます。

P2MP TE では、メークビフォアブレーク再最適化が使用されます。これには、次の再最適化プロセスが使用されます。

新しい LSP がシグナリングされます。

確実に十分な時間が経過してからトラフィックが現在の LSP から新しい LSP に移動されるように、ヘッドエンド ルータでタイマーが開始されます。

現在の LSP から新しい LSP にトラフィックがリダイレクトされます。

古い Sub-LSP を切断する目的で、タイマーが開始されます。

P2MP TE トンネルと P2P TE トンネルとの共存

P2P と P2MP TE トンネルは、両方とも次の特性を共有します。

P2P トンネルおよび P2MP トンネルのトンネル帯域幅は、同じ方法で設定されます。P2MP TE トンネルでは、設定したあらゆる帯域幅パラメータが、すべての宛先ルータに適用されます。つまり、帯域幅パラメータは、すべての Sub-LSP に適用されます。P2P トンネルおよび P2MP TE トンネルは、いずれも同一の IGP 拡張を使用して、リンク帯域幅情報をネットワーク全体にフラッディングします。

P2P トンネルおよび P2MP トンネルのトンネル設定と保持優先順位、アトリビュート フラグ、アフィニティとマスク、アドミニストレイティブ ウェイトの各パラメータは、同じ方法で設定されます。P2MP TE トンネルのパラメータは、すべての Sub-LSP に適用されます。

FRR-enabled P2MP Sub-LSP は、ネットワーク内で FRR-enabled P2P LSP ネットワークと共存できます。P2P TE では、ノード、リンク、帯域幅の保護がサポートされます。P2MP TE では、リンクと帯域幅の保護のみがサポートされます。

CSPF を使用してパスをダイナミックに計算する方法は、P2P と P2MP TE で同様です。

自動トンネル バックアップの動作は、P2P トンネルと P2MP トンネルで若干異なります。P2P トンネルでは、自動トンネル バックアップにより 2 つのバックアップ トンネルが作成されます。1 つはノード保護、もう 1 つはリンク保護に使用されます。P2P LSP の保護には、ノード保護バックアップが優先されます。P2MP トンネルでは、自動トンネル バックアップにより 1 つのバックアップ トンネル(リンク保護)が作成されます。P2MP Sub-LSP に対しては、リンク保護バックアップのみ使用できます。P2P トンネルおよび P2MP トンネルは共存でき、いずれも保護することが可能です。


) P2MP Sub-LSP が R1 → R2 → R3 の順番でシグナリングされ、P2P トンネルは R3 → R2 → R1 の順番でシグナリングされた場合、R3 上でルータ OSPF または IS-IS の IGP コンフィギュレーション モードで mpls traffic-eng multicast-intact コマンドを発行して、R3 の Sub-LSP のマルチキャスト トラフィックに確実に対応できるようにします。


FRR を使用した P2MP TE リンクの保護

FRR は、P2P LSP および P2MP Sub-LSP に対して同様の方法で適用されます。P2MP をサポートするための新しいプロトコル拡張は必要ありません。


) P2MP TE を FRR 保護するには、すべての最後から 2 番めのホップ ルータで ip routing protocol purge interface コマンドを発行します。このコマンドを発行しない場合、ルータは FRR カットオーバー イベント中に最大 6 秒分に相当するトラフィックを失います。


FRR により、リンクまたはノード障害の結果として生じるトラフィック配信の中断が最小限に抑えられます。FRR は、ヘッドエンド ルータにより新しいエンドツーエンド LSP がシグナリングされるまで、一時的に LSP トラフィックをネットワーク障害周囲のパックアップ パスに高速スイッチングします。

FRR-enabled P2MP Sub-LSP は、ネットワーク内で FRR-enabled P2P LSP ネットワークと共存できます。P2MP TE では、リンクと帯域幅の保護のみがサポートされます。P2P TE に対しては、ノード、リンク、帯域幅の保護がサポートされます。

P2P TE トンネルの LSP と同様に、P2MP Sub-LSP のリンク保護に対して Point of Local Repair(PLR; ローカル修復ポイント)ノード上で P2P 明示バックアップ トンネルを設定できます。また、P2P TE トンネルの自動トンネル バックアップ機能を使用して、バックアップ トンネルの自動作成をイネーブルにすることもできます。同一の発信リンクを共有する、兄弟関係にあるすべての Sub-LSP は、同一のバックアップ トンネルにより保護されます。同一の発信リンクを共有する、いとこ関係にあるすべての Sub-LSP は、複数の P2P バックアップ トンネルにより保護されます。

図 6 に、P2MP TE トンネルのリンク保護を示します。この例では、PE1 がトンネル ヘッドエンド ルータ、PE2、PE3、PE4 がトンネル テールエンド ルータを示しています。次の Sub-LSP がネットワーク内の PE1 からシグナリングされます。

PE1 から PE2 への Sub-LSP の移動パスは PE1 → P01 → P02 → PE2 です。

PE1 から PE3 への Sub-LSP の移動パスは PE1 → P01 → P03 → PE3 です。

PE1 から PE4 への Sub-LSP の移動パスは PE1 → P01 → P04 → PE4 です。

ノード P01 は MPLS フォワーディング プレーンでパケット レプリケーションを実行する分岐ノードです。PE1 から発信される入力トラフィックは、ルータ P02、P03、P04 に向かってレプリケーションされます。

図 6 P2MP TE リンク保護の例

 

3 つの Sub-LSP を保護するために、別々のポイントツーポイント バックアップ トンネルがシグナリングされます。バックアップ トンネルは、代替ネットワーク パスを持つリンクに対してのみ作成されることに注意します。この例では、ルータ P01 が Point of Local Repair(PLR; ローカル修復ポイント)で、ルータ P02、P03、P04 が Merge Point(MP; マージ ポイント)です。

ルータ P01 と P04 の間でリンク障害が発生した場合、次のイベントがトリガーされます。

1. ルータ P01 は、PE4 宛てのトラフィックを P04 に関連付けられたバックアップ トンネルに切り替えます。

2. ルータ P01 は、P2MP TE ヘッドエンド ルータ PE1 のアップストリームに RSVP パス エラーメッセージを送信します。これと同時に、P01 と P04 は IGP アップデート(Link State Advertisement(LSA; リンクステート アドバタイズメント))をすべての隣接 IGP ネイバーに送信します。これにより、P01 ~ P04 のリンクに関連付けられたインターフェイスが停止したことが示されます。

3. RSVP パスのエラー メッセージおよび IGP LSA アップデートを受信すると、ヘッドエンド ルータは P2MP TE トンネルの再最適化をトリガーし、新しい Sub-LSP をシグナリングします。(これは、ダイナミック パスの作成を指定した場合に発生します)。


) 1 つの Sub-LSP のみがアクティブになっても、すべての Sub-LSP がアクティブになるまで、この Sub-LSP は停止したままになります。


FRR 障害検出メカニズム

P2MP TE ネットワークのリンク障害を検出するには、ネイティブ リンクおよびインターフェイス障害検出メカニズム(Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)、Loss Of Signal(LOS; 信号消失)障害イベント、RSVP Hello など)を使用できます。

『Bidirectional Forwarding Detection』

MPLS トラフィック エンジニアリング:BFD でトリガーされた FRR 機能では、Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)プロトコルを使用してあらゆるメディア タイプ、カプセル化、トポロジ、およびルーティング プロトコルの高速転送パス障害検出回数を提供し、リンクおよびノードを保護できます。高速転送パス障害検出に加えて、BFD はネットワーク管理者に整合性のある障害検出方法を提供します。詳細については、『 MPLS Traffic Engineering: BFD-triggered Fast Reroute (FRR) 』を参照してください。

信号消失障害イベント

FRR は、信号消失イベントでトリガーされる場合があります。信号消失イベントによる FRR トリガーは、アラームをベースにしており、プラットフォームおよびラインカード サポートに依存します。詳細については、『 MPLS TE: Link and Node Protection, with RSVP Hellos Support (with Fast Tunnel Interface Down Detection) 』を参照してください。

RSVP Hello

リンク障害中に FRR カットオーバー通知を提供しないインターフェイスでは、RSVP Hello を設定できます。RSVP Hello の動作は、P2MP TE と P2P TE で類似しています。バックアップ トンネルを持ち、出力インターフェイスで RSVP Hello をイネーブルにしているすべての Sub-LSP では、RSVP Hello インスタンスがネイバーに対して作成され、Sub-LSP は Hello データベース内のネイバーの FRR ツリーに追加されます。

出力インターフェイスとネイバー アドレス間の Hello インスタンスは、高速リルート可能な P2MP Sub-LSP および P2P LSP で共有されます。ネイバーへの Hello セッションが停止していると宣言された場合、バックアップ LSP または Sub-LSP で保護されているすべての P2P LSP および P2MP Sub-LSP は、制御とデータ プレーン内のそれぞれのバックアップに切り替えられます。

また、RSVP Hello セッションにより、Sub-LSP に対する RSVP ステートがタイムアウトする前に、P2MP ヘッドエンド ルータに Sub-LSP のパス上の障害をヘッドエンド ルータに通知できます。これにより、迅速な再最適化が可能になります。Sub-LSP の出力インターフェイスで RSVP Hello がイネーブルであっても、Sub-LSP ではバックアップ トンネルを選択できない場合、Sub-LSP によりネイバーへの Hello インスタンスが検索されます。Hello インスタンスが存在しない場合は、Hello State Time(HST)Hello インスタンスが作成されます。ネイバーが停止した場合、その Sub-LSP も切断されます。詳細については、『 MPLS Traffic Engineering (TE) - Fast Reroute (FRR) Link and Node Protection 』を参照してください。

P2MP TE の帯域幅プリエンプション

P2MP TE Sub-LSP の帯域幅アドミッション制御およびプリエンプション メカニズムは、P2P TE トンネルに関連付けられた LSP に対するものと同様です。P2MP TE トンネルに対して定義されたあらゆるリンクのアフィニティまたは制御が考慮されます。Sub-LSP にシグナリングされた帯域幅は、適切なプライオリティで適切なプールから削除されます。また、必要に応じてプライオリティの低い Sub-LSP はプライオリティの高い Sub-LSP にプリエンプションされます。

P2MP トンネルは、サブプールまたはグローバルプールの帯域幅を使用するように設定できます。帯域幅を設定した場合、P2MP トンネルのすべての Sub-LSP が、同一の帯域幅の大きさおよびタイプでシグナリングされます。P2MP トンネルの帯域幅の大きさまたはタイプが変更されると、P2MP トンネル入力は、常に新しい Sub-LSP セット(新しい P2MP LSP)に、新しい帯域幅の大きさおよびタイプをシグナリングします。

プリエンプション プロシージャでは、トンネルのタイプは考慮されません。P2P LSP および P2MP Sub-LSP に対して、同一のプライオリティ ルールが適用されます。セットアップ プライオリティの高い Sub-LSP は、トンネルのタイプにかかわらず、保持優先順位の低い LSP(Sub-LSP)にプリエンプトされます。したがって、P2MP Sub-LSP は P2P LSP をプリエンプトする場合があります。この逆の場合もあります。いずれの LSP がプリエンプトされるかは、保持プライオリティに基づいて決定されます。

P2MP TE トンネルは、サブプールまたはグローバルプール帯域幅を使用するように設定できます。P2MP TE トンネルに関連付けられたすべての Sub-LSP は、同一の帯域幅の大きさおよびタイプでシグナリングされます。帯域幅の大きさおよびタイプが変更された場合、P2MP トンネルのヘッドエンド ルータは、新しいセットの Sub-LSP に、新しい帯域幅パラメータをシグナリングします。

帯域幅の共有は、P2MP TE Sub-LSP と P2P TE LSP で類似しています。新しい Sub-LSP を追加する場合、P2MP-TE ヘッドエンド ルータにより、その他の Sub-LSP と帯域幅を共有するかどうかが決定されます。2 つの Sub-LSP は、「中継ペア」であれば帯域幅を共有できます。「中継ペア」である場合、Sub-LSP は出力インターフェイス、ネクストホップ、および出力ラベルが共有されています。

LSP および Sub-LSP は、異なる帯域幅プールを使用している場合、帯域幅を共有できません。帯域幅の変更には、P2P または P2MP TE トンネルの再最適化が必要です。これにより、共通リンク上で帯域幅が二重にカウントされる場合があります。

FRR で帯域幅保護を使用するには、次の要件があります。

バックアップ トンネルは、新しい Sub-LSP が作成される間、サービス レベル契約を維持する必要があります。

PLR ルータは、バックアップ トンネルに十分な帯域幅容量がある場合にかぎり、バックアップ トンネルを選択します。

バックアップ トンネルは、帯域幅をシグナリングしない場合があります。

最良のバックアップ パスは、PLR ルータによって決定され、バックアップ帯域幅およびクラス タイプに基づいてプライマリ パスが保護されます。

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの設定方法

P2MP TE 機能を設定するには、次の手順を実行します。

「ヘッドエンド ルータの設定」(必須)

「ミッドポイント ルータの設定」(必須)

「テールエンド ルータの設定」(必須)

「P2MP TE トンネルでの FRR の設定」(任意)

「MPLS トラフィック エンジニアリング システムのイベント ロギングのイネーブル」(任意)

「MPLS ポイントツーマルチポイント トラフィック エンジニアリングの設定の確認」(任意)

ヘッドエンド ルータの設定

次の手順では、マルチキャストおよび MPLS ポイントツーマルチポイント トラフィック エンジニアリング用にヘッドエンド ルータを設定する方法について説明します。設定の一部として、テールエンド ルータを指定します。また、トンネルが使用する必要のある明示パスを指定するか、あるいはパスがダイナミックに作成されるかまたはダイナミック パスおよび明示パスを組み合わせて持つように要求することもできます。

P2MP TE トンネルの設定はヘッドエンド ルータで実行されるため、この機能は宛先が頻繁に変わることがない状況では最良の動作を実現します。P2MP 機能は、Sub-LSP のダイナミックな接合およびプルーニングはサポートされません。

制約事項

宛先ごとの複数パス オプションはサポートされません。P2MP TE 機能では、各宛先に 1 つのパス オプションのみを許可します。

ポイントツーマルチポイント トラフィック エンジニアリング トンネルでは、 tunnel destination コマンドは、サポートされません。代わりに、 mpls traffic-eng destination list コマンドを使用します。

Sub-LSP(宛先)ごとの複数パス オプションはサポートされません。P2MP TE 機能では、各 Sub-LSP に 1 つのパス オプションのみを許可します。

この機能では、 tunnel mpls traffic-eng autoroute announce コマンドはサポートされません。このコマンドは、IP ユニキャスト トラフィックのみでサポートされます。

P2MP Sub-LSP が R1 → R2 → R3 の順番でシグナリングされ、P2P トンネルは R3 → R2 → R1 の順番でシグナリングされた場合、R3 上でルータ OSPF または IS-IS の IGP コンフィギュレーション モードで mpls traffic-eng multicast-intact コマンドを発行して、R3 の Sub-LSP のマルチキャスト トラフィックに確実に対応できるようにします。

P2MP TE 機能では、ポリシーベース ルーティングはサポートされません。

P2MP TE 機能は、スタティック IP ルートでは設定できません。

手順の概要

1. enable

2. configure terminal

3. mpls traffic-eng tunnels

4. ip multicast-routing [ vrf vrf-name ] [ distributed ]

5. interface tunnel number

6. tunnel mode mpls traffic-eng point-to-multipoint

7. tunnel destination list mpls traffic-eng { identifier dest-list-id | name dest-list-name }

8. ip igmp static-group { * | group-address [ source { source-address | ssm-map }] | class-map class-map-name }

9. ip pim { dense-mode [ proxy-register { list access-list | route-map map-name }] | passive | sparse-mod e | sparse-dense-mode }

10. exit

11. mpls traffic-eng destination list { name dest-list-name | identifier dest-list-id }

12. ip ip-address path-option id { dynamic | explicit { name name | identifier id } [ verbatim ]}

13. exit

14. ip explicit-path { name word | identifier number } [ enable | disable ]

15. next-address [ loose | strict ] ip-address

16. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls traffic-eng tunnels

 

Router(config)# mpls traffic-eng tunnels

MPLS トラフィック エンジニアリングをグローバルにイネーブルにします。

トラフィック エンジニアリング トンネルをサポートする各ネットワーク インターフェイスでも、このコマンドを発行します。

ステップ 4

ip multicast-routing [ vrf vrf-name ] [distributed]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをグローバルにイネーブルにします。

ステップ 5

interface tunnel number

 

Router(config)# interface tunnel 100

トンネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

tunnel mode mpls traffic-eng point-to-multipoint

 

Router(config-if)# tunnel mode mpls traffic-eng point-to-multipoint

トンネル上で MPLS ポイントツーマルチポイント トラフィック エンジニアリングをイネーブルにします。

ステップ 7

tunnel destination list mpls traffic-eng { identifier dest-list-id | name dest-list-name }

 

Router(config-if)# tunnel destination list mpls traffic-eng name in-list-01

宛先リストを指定して、ポイントツーマルチポイント宛先の IP アドレスを指定します。

ステップ 8

ip igmp static-group { * | group-address [ source { source-address | ssm-map }] | class-map class-map-name }

 

Router(config-if)# ip igmp static-group 239.100.100.101 source 10.11.11.11

インターフェイス上でスタティック グループのメンバシップ エントリを設定します。

送信元アドレス(S、G)が解決できない場合は、TE トンネル インターフェイス上でこれを設定します。

ステップ 9

ip pim { dense-mode [ proxy-register { list access-list | route-map map-name }] | passive | sparse-mode | sparse-dense-mode }

 

Router(config-if)# ip pim passive

インターフェイスで Protocol Independent Multicast(PIM; プロトコル独立マルチキャスト)をイネーブルにします。

パッシブ モードで設定されたインターフェイスにより、PIM 制御プレーン トラフィックが渡されたり、転送されたりすることはなく、IGMP トラフィックのみが渡されるか、転送されます。

ステップ 10

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 11

mpls traffic-eng destination list { name dest-list-name | identifier dest-list-id }

 

Router(config)# mpls traffic-eng destination list name in-list-01

宛先リストを作成し、トラフィック エンジニアリング宛先リストコンフィギュレーション モードを開始します。

ステップ 12

ip ip-address path-option id { dynamic | explicit { name name | identifier id }

[ verbatim ]}

 

Router(cfg-te-dest-list)# ip 10.10.10.10 path-option 1 dynamic

MPLS ポイントツーマルチポイント トラフィック エンジニアリング トンネル宛先の IP アドレスを指定します。

explicit キーワードを使用する場合、ip explicit-path コマンドを使用して明示パスを設定する必要があります。

各宛先に対して、この手順を繰り返します。

ステップ 13

exit

 

Router(cfg-te-dest-list)# exit

トラフィック エンジニアリング宛先リスト コンフィギュレーション モードを終了します。

ステップ 14

ip explicit-path { name word | identifier number } [ enable | disable ]

 

Router(config)# ip explicit-path name path1 enable

IP 明示パスの名前を指定して、IP 明示パス コンフィギュレーション モードを開始します。

ステップ 15

next-address [ loose | strict ] ip-address

 

Router(cfg-ip-expl-path)# next-address 10.0.0.2

指定したアドレスのみを含む明示パスまたはルーズな明示パスを指定します。

ステップ 16

end

 

Router(cfg-ip-expl-path)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ミッドポイント ルータの設定

ミッドポイント ルータで P2MP TE 機能をサポートするために、特別な設定を行う必要はありません。ミッドポイント ルータには、Cisco IOS Release 12.2(33)SRE 以降のリリースがインストールされている必要があります。ミッドポイント ルータは、P2MP シグナリング拡張をサポートしており、実装可能である必要があります。ミッドポイント ルータの MPLS TE 設定は、P2P と P2MP TE の両方をサポートします。すべてのマルチキャスト トラフィックは、ラベル スイッチされます。ミッドポイント ルータには、IPv4 マルチキャスト ルーティングまたは PIM は必要ありません。MPLS TE の設定に関する詳細については、『 MPLS Traffic Engineering and Enhancements 』を参照してください。

テールエンド ルータの設定

テールエンド ルータは、IP マルチキャスト パケットから MPLS ラベルを削除して、通常のマルチキャスト転送プロセス用にこのパケットを MFIB に送信します。 ip mroute コマンドを発行してヘッドエンド ルータに戻るスタティック ルートを設定することで、RPF チェックをイネーブルにする必要があります。

次の作業では、PE ルータの出力インターフェイスで PIM を設定する方法を説明します。PIM は、1 つ以上のマルチキャスト受信者が接続している LAN に接続された CE ルータに接続された PE ルータで必要です。

出力 PE ルータがデコーダ デバイスまたはシステム(DCM など)に直接接続されている場合、PE ルータの出力インターフェイス上で Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)を設定する必要があります。IGMP の設定に関する詳細については、『 Customizing IGMP 』を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ vrf vrf-name] [ distributed ]

4. ip multicast mpls traffic-eng [ range access-list-number | access-list-name ]

5. interface type slot / port

または

interface type slot / port-adapter/port

6. ip pim { dense-mode [ proxy-register { list access-list | route-map map-name }] | passive | sparse-mode | sparse-dense-mode }

7. exit

8. ip mroute [ vrf vrf-name ] source-address mask { fallback-lookup { global | vrf vrf-name } | rpf-address | interface-type interface-number } [ distance ]

9. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ vrf vrf-name ] [distributed]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをグローバルにイネーブルにします。

ステップ 4

ip multicast mpls traffic-eng [ range access-list-number | access-list-name ]

 

Router(config)# ip multicast mpls traffic-eng

MPLS トラフィック エンジニアリング ポイントツーマルチポイント トンネルの IP マルチキャスト ルーティングをイネーブルにします。

ステップ 5

interface type slot / port

または

interface type slot / port-adapter / port

 

Router(config)# interface ethernet 1/1

または

 

Router(config)# interface fastethernet 1/0/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

slot 引数で、スロット番号を指定します。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

port 引数で、ポート番号を指定します。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

port-adapter 引数で、ポート アダプタ番号を指定します。ポート アダプタの互換性の詳細については、該当するハードウェア マニュアルを参照してください。

ステップ 6

ip pim { dense-mode [ proxy-register { list access-list | route-map map-name }] | passive | sparse-mode | sparse-dense-mode }

 

Router(config-if)# ip pim sparse-dense-mode

インターフェイスで Protocol Independent Multicast(PIM; プロトコル独立マルチキャスト)をイネーブルにします。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 8

ip mroute [ vrf vrf-name ] source-address mask { fallback-lookup { global | vrf vrf-name } | rpf-address | interface-type interface-number } [ distance ]

 

Router(config)# ip mroute 10.10.10.10 255.255.255.255 10.11.11.11

ヘッドエンド ルータへのスタティック マルチキャスト ルート(mroute)を設定することで、RPF チェックをイネーブルにします。

ステップ 9

end

 

Router(config)# end

(必須)現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

P2MP TE トンネルでの FRR の設定

P2MP TE トンネルに関連付けられた Sub-LSP に対してリンク保護をイネーブルにするには、次の設定作業を実行します。

各 P2MP TE トンネルのヘッドエンド ルータで FRR をイネーブルにします。

保護を必要とするネットワーク インターフェイスに P2P バックアップ トンネルを設定します。

詳細および設定方法については、『 MPLS Traffic Engineering--Fast Reroute Link and Node Protection 』を参照してください。

MPLS トラフィック エンジニアリング システムのイベント ロギングのイネーブル

MPLS トラフィック エンジニアリング システムのロギングにより、次のイベントが表示できます。

LSP の設定および切断

RSVP パスおよび RESV リクエスト

Sub-LSP のステータス(パス変更メッセージによる)

システム ロギングをイネーブルにするコマンドには、次のようなものがあります。

mpls traffic-eng logging lsp path-errors

mpls traffic-eng logging lsp preemption

mpls traffic-eng logging lsp reservation-errors

mpls traffic-eng logging lsp setups

mpls traffic-eng logging lsp teardowns

mpls traffic-eng logging tunnel path change

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの設定の確認

ここでは、次の作業について説明します。

「ヘッドエンド ルータの設定の確認」

「ミッドポイント ルータの設定の確認」

「テールエンド ルータの設定の確認」

ヘッドエンド ルータの設定の確認

ヘッドエンド ルータで次の手順を実行して、次の内容を確認します。

すべての Sub-LSP がイネーブルになっている。

IP マルチキャスト トラフィックは P2MP TE トンネルに転送されている。

次のコマンドも、ヘッドエンド ルータの確認に役立ちます。

show cef path set および show cef path set detail (ヘッドエンド ルータが分岐点にもなっている場合)

show ip mfib および show ip mfib verbose

show ip rsvp fast-reroute

show mpls traffic-eng destination list

show mpls traffic-eng fast-reroute database

show mpls traffic-eng tunnels(dest-mode p2mp、detail、summary キーワードを指定)

手順の概要

1. enable

2. show mpls traffic-eng tunnels brief

3. show mpls traffic-eng forwarding path-set brief

4. show mpls traffic-eng forwarding path-set detail

5. show ip mroute

手順の詳細


ステップ 1 enable

enable コマンドを発行して特権 EXEC モードを開始します。

ステップ 2 show mpls traffic-eng tunnels brief

show mpls traffic-eng tunnels brief コマンドを使用して、ヘッドエンド ルータから発信される P2MP TE トンネルを表示します。次に例を示します。

Router# show mpls traffic-eng tunnels brief
 
signaling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 60 seconds, next in 5 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: disabled
 
P2P TUNNELS:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
p2p-LSP 10.2.0.1 - Se2/0 up/up
Displayed 2 (of 2) heads, 0 (of 0) midpoints, 0 (of 0) tails
 
P2MP TUNNELS:
DEST CURRENT
INTERFACE STATE/PROT UP/CFG TUNID LSPID
Tunnel2 up/up 3/10 2 1
Tunnel5 up/down 1/10 5 2
Displayed 2 (of 2) P2MP heads
 
P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID ST UP IF DOWN IF
10.1.0.1 2 1 10.2.0.1 1 up head Se2/0
10.1.0.1 2 1 10.3.0.199 2 up head Et2/0
10.1.0.1 2 1 19.4.0.1 2 up head s2/0
10.1.0.1 2 2 1 9.4.0.1 2 up head s2/0
10.1.0.1 5 2 10.5.0.1 7 up head e2/0
100.100.100.100 1 3 200.200.200.200 1 up ge2/0 s2/0
100.100.100.100 1 3 10.1.0.1 1 up e2/0 tail
Displayed 7 P2MP sub-LSPs:
5 (of 5) heads, 1 (of 1) midpoints, 1 (of 1) tails
 

ステップ 3 show mpls traffic-eng forwarding path-set brief

show mpls traffic-eng forwarding path-set brief コマンドを使用して、ヘッドエンド ルータから発信される Sub-LSP を表示します。次に、ヘッドエンド ルータから異なる宛先に発信される 3 つの Sub-LSP の例を示します。すべての Sub-LSP は、同一のパス セット(パスの集合)に属します。パス セットには一意の ID が与えられます。この ID は、例の PSID 列に表示されます。

Router# show mpls traffic-eng forwarding path-set brief
 
Sub-LSP Identifier
src_lspid[subid]->dst_tunid InLabel Next Hop I/F PSID
--------------------------- ------- ------------- ------ ----
10.0.0.1_19[16]->10.0.0.8_1 none 10.0.1.2 Et0/0 C5000002
10.0.0.1_19[27]->10.0.0.6_1 none 10.0.1.2 Et0/0 C5000002
10.0.0.1_19[31]->10.0.0.7_1 none 10.0.1.2 Et0/0 C5000002
 

ステップ 4 show mpls traffic-eng forwarding path-set detail

show mpls traffic-eng forwarding path-set detail コマンドを使用して、ヘッドエンド ルータから発信される Sub-LSP に関する詳細を表示します。次に例を示します。

 
Router# show mpls traffic-eng forwarding path-set detail
 
LSP: Source: 10.1.0.1, TunID: 100, LSPID: 7
Destination: 10.2.0.1, P2MP Subgroup ID: 1
Path Set ID: 0x30000001
OutLabel : Serial2/0, 16
Next Hop : 10.1.3.2
FRR OutLabel : Tunnel666, 16
 
LSP: Source: 10.1.0.1, TunID: 100, LSPID: 7
Destination: 10.3.0.1, P2MP Subgroup ID: 2
Path Set ID: 0x30000001
OutLabel : Serial2/0, 16
Next Hop : 10.1.3.2
FRR OutLabel : Tunnel666, 16
 

ステップ 5 show ip mroute

show ip mroute コマンドを使用して、IP マルチキャスト トラフィックが P2MP TE トンネルに転送されることを確認します。次の例で太字で示された出力は、トンネル 1 が、送信元アドレス 10.10.10.10 のマルチキャスト グループ 232.0.1.4 の発信インターフェイス リストの一部であることを示します。

Router# show ip mroute
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.10.10.10, 232.0.1.4), 1d00h/stopped, flags: sTI
Incoming interface: Ethernet2/0, RPF nbr 10.10.1.1
Outgoing interface list:
Tunnel1, Forward/Sparse-Dense, 1d00h/00:01:17
 
(*, 224.0.1.40), 1d00h/00:02:48, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet2/0, Forward/Sparse, 1d00h/00:02:48

ミッドポイント ルータの設定の確認

ミッドポイント ルータで次のコマンドを使用して、MPLS 転送が発生することを確認します。ミッドポイント ルータが分岐ルータである場合は、 show mpls forwarding-table labels コマンドを使用して、show 固有のラベルを表示することもできます。

手順の概要

1. enable

2. show mpls forwarding-table

手順の詳細


ステップ 1 enable

enable コマンドを発行して特権 EXEC モードを開始します。

ステップ 2 show mpls forwarding-table

show mpls forwarding-table コマンドを使用して、ミッドポイント ルータで MPLS パケットが切り替わることを表示します。次に例を示します。

Router# show mpls forwarding-table
 
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 16 10.0.0.1 1 [19] 0 Et1/0 10.0.1.30
 
Router# show mpls forwarding-table detail
 
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 16 10.0.0.1 1 [19] 0 Et1/0 10.0.1.30
MAC/Encaps=14/18, MRU=1500, Label Stack{16}
AABBCC032800AABBCC0325018847 00010000
No output feature configured
Broadcast

テールエンド ルータの設定の確認

テールエンド ルータで次の手順を実行して、次の内容を確認します。

MPLS 転送が発生すること。

IP マルチキャスト転送が発生すること。

show ip mfib show mpls traffic-eng destination list 、および show mpls traffic-eng tunnels dest-mode p2mp コマンドを使用して確認することもできます。

手順の概要

1. enable

2. show mpls forwarding-table

3. show ip mroute

手順の詳細


ステップ 1 enable

enable コマンドを発行して特権 EXEC モードを開始します。

ステップ 2 show mpls forwarding-table

show mpls forwarding-table コマンドを使用して、MPLS ラベル付きパケットが、テールエンド ルータからラベルなしで転送されることを表示します。

Router# show mpls forwarding-table
 
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
17 [T] No Label 10.0.0.1 1 [19] 342 aggregate
 
[T] Forwarding through a LSP tunnel.
 
Router# show mpls forwarding-table detail
 
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
17 No Label 10.0.0.1 1 [19] 342 aggregate
MAC/Encaps=0/0, MRU=0, Label Stack{}, via Ls0
 

ステップ 3 show ip mroute

show ip mroute コマンドを使用して、IP マルチキャスト トラフィックを表示します。次の例で太字で示された出力は、送信元アドレス 10.10.10.10 のマルチキャスト グループ 232.0.1.4 の着信インターフェイスは Lspvif0、発信インターフェイスは Ethernet1/0 であることを示します。

Router# show ip mroute
 
IP Multicast Routing Table
...
 
(*, 232.0.1.4), 1d02h/stopped, RP 0.0.0.0, flags: SP
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null
 
(10.10.10.10, 232.0.1.4), 00:01:51/00:01:38, flags:
Incoming interface: Lspvif0, RPF nbr 10.0.0.1, Mroute
Outgoing interface list:
Ethernet1/0, Forward/Sparse, 00:01:51/00:02:37
 
(*, 224.0.1.40), 1d02h/00:02:57, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet1/0, Forward/Sparse, 1d02h/00:02:57

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの設定例

次に、ヘッドエンド ルータ(PE5)、ミッドポイント ルータ(P1)、およびテールエンド ルータ(PE1)上でのポイントツーマルチポイント トラフィック エンジニアリングの設定例を示します。

「例:ヘッドエンド ルータ(PE5)の設定」

「例:ミッドポイント ルータ(P1)の設定」

「例:テールエンド ルータ(PE1)の設定」

図 7 MPLS TE P2MP TE サンプル トポロジ

 

例:ヘッドエンド ルータ(PE5)の設定

次のヘッドエンド ルータの設定例では、次の点に注意します。

IPv4 マルチキャスト ルーティングは、 ip multicast-routing コマンドでイネーブルにされています。

2 つの宛先リストが指定されており、1 つはダイナミック パス用、もう 1 つは明示パス用です。宛先リストは、各宛先に 1 つのパス オプションのみを指定しています。

tunnel mode mpls traffic-eng point-to-multipoint コマンドにより、P2MP トンネルがイネーブルにされます。

トンネル インターフェイス上で、 ip pim passive コマンドが使用されています。

非 MPLS インターフェイス上で、 ip pim sparse-mode コマンドが使用されています。

ip igmp static-group コマンドにより、マルチキャスト グループが P2MP トンネルにマップされています。

トンネル 3 をバックアップ パスとして、ルータ上で FRR がイネーブルになっています。PE5->P1-BKUP という明示パスが、代替パスを提供しています。

hostname [PE5]
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone PST -8
ip subnet-zero
ip source-route
ip cef
no ip domain lookup
!
ip multicast-routing
!
no ipv6 cef
mpls traffic-eng tunnels
!
mpls traffic-eng destination list name P2MP-DYN-DST-LIST
ip 172.16.255.1 path-option 10 dynamic
ip 172.16.255.2 path-option 10 dynamic
ip 172.16.255.3 path-option 10 dynamic
ip 172.16.255.4 path-option 10 dynamic
!
mpls traffic-eng destination list name P2MP-EXCIT-DST-LIST
ip 172.16.255.1 path-option 10 explicit identifier 101
ip 172.16.255.2 path-option 10 explicit identifier 102
ip 172.16.255.3 path-option 10 explicit identifier 103
ip 172.16.255.4 path-option 10 explicit identifier 104
!
multilink bundle-name authenticated
!
interface Tunnel1
description PE5->PE1,PE2,PE3,PE4-DYN
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.0.1.4 source 192.168.5.255
ip igmp static-group 232.0.1.3 source 192.168.5.255
ip igmp static-group 232.0.1.2 source 192.168.5.255
ip igmp static-group 232.0.1.1 source 192.168.5.255
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name P2MP-DYN-DST-LIST
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 10000
!
interface Tunnel2
description PE5->PE1,PE2,PE3,PE4-EXCIT
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.0.1.8 source 192.168.5.255
ip igmp static-group 232.0.1.7 source 192.168.5.255
ip igmp static-group 232.0.1.6 source 192.168.5.255
ip igmp static-group 232.0.1.5 source 192.168.5.255
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name P2MP-EXCIT-DST-LIST
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 20000
tunnel mpls traffic-eng fast-reroute
!
interface Tunnel3
description PE5->P1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 172.16.255.201
tunnel mpls traffic-eng path-option 10 explicit name PE5->P1-BKUP
!
interface Loopback0
ip address 172.16.255.5 255.255.255.255
!
interface Ethernet0/0
description CONNECTS to CE5
ip address 192.168.5.1 255.255.255.252
ip pim sparse-mode
!
interface Ethernet1/0
description CONNECTS TO P1
bandwidth 1000000
ip address 172.16.0.13 255.255.255.254
ip router isis
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel3
isis network point-to-point
ip rsvp bandwidth percent 100
!
interface Ethernet2/0
description CONNECTS TO P2
bandwidth 1000000
ip address 172.16.0.14 255.255.255.254
ip router isis
mpls traffic-eng tunnels
isis network point-to-point
ip rsvp bandwidth percent 100
!
router isis
net 49.0001.1720.1625.5005.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
!
ip classless
!
no ip http server
!
ip pim ssm default
!
ip explicit-path identifier 101 enable
next-address 172.16.0.12
next-address 172.16.192.0
next-address 172.16.0.0
!
ip explicit-path identifier 102 enable
next-address 172.16.0.12
next-address 172.16.192.0
next-address 172.16.0.3
!
ip explicit-path identifier 103 enable
next-address 172.16.0.12
next-address 172.16.192.0
next-address 172.16.192.6
next-address 172.16.0.6
!
ip explicit-path identifier 104 enable
next-address 172.16.0.12
next-address 172.16.192.0
next-address 172.16.192.6
next-address 172.16.0.9
!
ip explicit-path name PE5->P1-BKUP enable
next-address 172.16.0.15
next-address 172.16.192.2

例:ミッドポイント ルータ(P1)の設定

次のミッドポイント ルータの設定例では、次の点に注意します。

MPLS トラフィック エンジニアリングは、グローバルおよびその他のコア ルータに接続しているインターフェイス上の両方でイネーブルになっています。

MPLE TE 拡張は、 mpls traffic-eng router-id および mpls traffic-eng level コマンドを使用してイネーブルにされています。

hostname [P1]
!
no aaa new-model
clock timezone PST -8
ip subnet-zero
ip source-route
ip cef
no ip domain lookup
!
no ipv6 cef
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
interface Loopback0
ip address 172.16.255.201 255.255.255.255
!
interface Ethernet0/0
description CONNECTS TO P2
bandwidth 1000000
ip address 172.16.192.2 255.255.255.254
ip router isis
mpls traffic-eng tunnels
isis network point-to-point
ip rsvp bandwidth percent 100
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
description CONNECTS TO P3
bandwidth 1000000
ip address 172.16.192.1 255.255.255.254
ip router isis
mpls traffic-eng tunnels
isis network point-to-point
ip rsvp bandwidth percent 100
!
interface Ethernet2/0
description CONNECTS TO PE5
bandwidth 1000000
ip address 172.16.0.12 255.255.255.254
ip router isis
mpls traffic-eng tunnels
isis network point-to-point
ip rsvp bandwidth percent 100
!
router isis
net 49.0001.1720.1625.5201.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
ip classless
!
no ip http server

例:テールエンド ルータ(PE1)の設定

次のテールエンド ルータの設定例では、次の点に注意します。

IPv4 マルチキャスト ルーティングは、 ip multicast-routing コマンドでイネーブルにされています。

非 MPLS インターフェイス上で、 ip pim sparse-mode コマンドが使用されています。

ip multicast mpls コマンドにより、トラフィックのマルチキャスト ルーティングがイネーブルにされています。

hostname [PE1]
!
no aaa new-model
clock timezone PST -8
ip subnet-zero
ip source-route
ip cef
no ip domain lookup
!
ip multicast-routing
!
no ipv6 cef
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
interface Loopback0
ip address 172.16.255.1 255.255.255.255
!
interface Ethernet0/0
description CONNECTS TO CE1
ip address 192.168.1.1 255.255.255.252
ip pim sparse-mode
!
interface Ethernet0/3
description CONNECTS TO P3
bandwidth 155000
no ip address
shutdown
mpls traffic-eng tunnels
ip rsvp bandwidth 155000
!
interface Ethernet1/0
description CONNECTS TO PE2
bandwidth 1000000
ip address 172.16.0.5 255.255.255.254
ip router isis
mpls traffic-eng tunnels
isis network point-to-point
ip rsvp bandwidth percent 100
!
interface Ethernet2/0
description CONNECTS TO P3
bandwidth 1000000
ip address 172.16.0.0 255.255.255.254
ip router isis
mpls traffic-eng tunnels
isis network point-to-point
ip rsvp bandwidth percent 100
!
router isis
net 49.0001.1720.1625.5001.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
!
ip classless
!
no ip http server
 
!
ip multicast mpls traffic-eng
ip pim ssm default
ip mroute 192.168.5.0 255.255.255.0 172.16.255.5

その他の参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

Cisco IOS Master Commands List, All Releases

MPLS コマンド

Cisco IOS Multiprotocol Label Switching Command Reference

MPLS トラフィック エンジニアリング FRR

MPLS Traffic Engineering--Fast Reroute Link and Node Protection

MPLS トラフィック エンジニアリング LSP アトリビュート

MPLS Traffic Engineering--LSP Attributes

NSF/SSO - MPLS TE および RSVP のグレースフル リスタート

NSF/SSO--MPLS TE and RSVP Graceful Restart

MPLS ポイントツーマルチポイント トラフィック エンジニアリング:L2VPN のスタティックな擬似回線のサポート

MPLS Point-to-Multipoint Traffic Engineering: Support for Static Pseudowires

規格

規格
タイトル

draft-leroux-mpls-p2mp-te-bypass-xx.txt

『P2MP MPLS-TE Fast Reroute with P2MP Bypass Tunnels』

draft-ietf-mpls-p2mp-te-mib-09.txt

『Point-to-Multipoint Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB) module』

draft-ietf-mpls-ldp-p2mp-02.txt

Label Distribution Protocol Extensions for Point-to-Multipoint and Multipoint-to-Multipoint Label Switched Paths

MIB

MIB
MIB リンク

MPLS トラフィック エンジニアリング MIB

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 4875

『Extensions to RSVP-TE for Point-to-Multipoint TE Label Switched Paths』

RFC 4461

『Signaling Requirements for Point-to-Multipoint TE MPLS LSPs』

RFC 5332

『MPLS Multicast Encapsulations』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

MPLS ポイントツーマルチポイント トラフィック エンジニアリングの機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能のサポートが初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがないかぎり、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 MPLS ポイントツーマルチポイント トラフィック エンジニアリングの機能情報

機能名
リリース
機能情報

MPLS ポイントツーマルチポイント トラフィック エンジニアリング
NSF/SSO:MPLS ポイントツーマルチポイント トラフィック エンジニアリング

12.2(33)SRE
15.0(1)S

MPLS ポイントツーマルチポイント トラフィック エンジニアリング機能を使用すると、ルート プロセッサに致命的な障害が発生した場合に、P2MP TE トンネル トラフィックの中断を最小限に抑えながら、1 つの送信元から複数の宛先に MPLS トラフィックを転送できます。

この機能は、Cisco IOS Release 12.2(33)SRE で導入されました。

NSF/SSO のサポートは、Cisco IOS Release 15.0(1)S で追加されました。

次のコマンドが導入または変更されました。

debug ip rsvp p2mp,
debug mpls traffic-eng filter
debug mpls traffic-eng path
ip multicast mpls traffic-eng
ip path-option
ip pim
show cef
show ip multicast mpls vif
show ip rsvp fast-reroute
show ip rsvp fast-reroute bw-protect
show ip rsvp fast-reroute detail
show ip_rsvp high-availability counters
show ip rsvp high-availability database
show ip rsvp request
show ip rsvp reservation
show ip rsvp sender
show mpls traffic-eng destination list
show mpls traffic-eng fast-reroute database
show mpls traffic-eng forwarding path-set
show mpls traffic-eng forwarding statistics
show mpls traffic-eng tunnels
show mpls traffic-eng tunnels summary
tunnel destination list mpls traffic-eng
tunnel mode mpls traffic-eng point-to-multipoint

用語集

MDT :特定の VPN へのトラフィックまたは制御メッセージまたはその両方を伝送する、コア内の Multicast Domain/Distribution Tree(マルチキャスト ドメインおよび配布ツリー)。MDT は、Domain-Model について説明していることを暗黙的に意味しています。また、MDT はコア内に複数のカプセル化タイプを持つことができます。たとえば、GRE、IP-in-IP、MPLS などです。

MFI :MPLS Forwarding Infrastructure。

mLDP :LDP へのマルチキャスト シグナリング拡張。

P2MP ID(P2ID) :P2MP TE LSP の固有識別情報で、ブランチまたはリーフまたはその両方の数にかかわらず、LSP 全体で一定です。

P2MP LSP :リーフ Sub-LSP の 1 つ以上の送信元。5 つのタプル キーで識別されます。

セッション

P2MP ID

トンネル ID

拡張トンネル ID

送信者テンプレート

トンネル送信者アドレス

LSP ID

P2MP Sub-LSP :ヘッドエンド ルータから 1 つの宛先に伸びる P2MP TE LSP のセグメント。Sub-LSP は、次の 7 つのタプル キーで識別されます。

P2MP セッション

P2MP ID

トンネル ID

拡張トンネル ID

送信者テンプレート

トンネル送信者アドレス

LSP ID

サブグループ ID 発信元

サブグループ ID

P2MP-TE :Point to Multipoint Traffic Engineering(ポイントツーマルチポイント トラフィック エンジニアリング)。

P2MP ツリー :入力ルータからすべての出力ルータへの P2MP TE Sub-LSP のパスを構成する、ルータおよび TE リンクの順序セット。

P2MP トンネル :1 つ以上の P2MP LSP のグループ。トンネルには、次の 3 つのタプル キーがあります。

P2MP ID

トンネル ID

拡張トンネル ID

PIM :Protocol Independent Multicast(プロトコル独立マルチキャスト)。

PIM-SM :PIM Sparse Mode。RFC 4601 を参照してください。

PIM-SSM :PIM Source Specific Multicast。PIM-SM のサブセットです。RFC 4601 を参照してください。

兄弟関係にある LSP :同一の P2MP トンネルに属する 2 つの LSP。つまり、両方の LSP に対するセッション オブジェクトは同一です。

兄弟関係にある Sub-LSP :同一の P2MP LSP に属する 2 つの Sub-LSP。つまり、両方の Sub-LSP に対するセッションおよび送信者テンプレート オブジェクトは同一です。

クロスオーバー :複数の着信 Sub-LSP が、同一の LSP に属しながら、異なる入力インターフェイスおよび異なる出力インターフェイスを持つ場合に、交差ノード上で発生する状態です。

再マージ :同一の P2MP LSP に属する 2 つのデータ ストリームが 1 つのデータ ストリームにマージされた場合に、これらのデータ ストリームが交差ノードを終了する際に交差ノードで発生する状態。

受信者 :P2MP Sub-LSP でサポートされた P2MP サービス上で伝送されるトラフィックの受信者。受信者は、必ずしも P2MP LSP の出力ルータである必要はありません。0、1、またはそれ以上の受信者が、特定の出力ルータを使用してデータを受信する場合があります。

出力ルータ :P2MP TE Sub-LSP の宛先(多数の場合がある)の 1 つ。出力ルータは、テールエンド ルータ、リーフ ノード、またはリーフとも呼ばれます。

接合 :新しい Sub-LSP を P2MP TE トンネルに追加するプロセス。

送信元 :P2MP LSP でサポートされている P2MP サービス上で伝送されるトラフィックの送信者。送信者は、必ずしも P2MP LSP の入力ルータである必要はありません。

データ重複 :出力ルータが重複パケットを受信した場合に発生する状態。この状態は、LSP、再マージ、またはクロスオーバーの結果として発生する場合があります。データ重複はネットワーク帯域幅を無駄にするため、最小限に抑える必要があります。

テールエンド ルータ :P2MP トンネルの「テールエンド」にある出力 PE ルータ。

入力ルータ :P2MP TE LSP を設定するシグナリング メッセージを開始するルータ。ヘッドエンド ルータとも呼ばれます。

バド ルータ :1 つ以上のダウンストリーム ルータが直接接続された出力ルータ。バド ノードは、分岐ノードおよび宛先にできます。

プルーニング :P2MP LSP から Sub-LSP を削除するプロセス。

分岐ルータ :複数のダウンストリーム ルータが直接接続されたルータ。パケット レプリケーションが発生するルータです。

ヘッドエンド ルータ :P2MP トンネルの「ヘッドエンド」にある入力 PE ルータ。