マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS トラフィック エンジニアリング - エリ ア間トンネル
MPLS トラフィック エンジニアリング - エリア間トンネル
発行日;2012/01/30 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS トラフィック エンジニアリング - エリア間トンネル

機能情報の確認

この章の構成

MPLS トラフィック エンジニアリング - エリア間トンネルの前提条件

MPLS トラフィック エンジニアリング - エリア間トンネルの制約事項

MPLS トラフィック エンジニアリング - エリア間トンネルの概要

エリア間トンネル機能

自動ルート宛先機能

CBTS と自動ルート宛先との相互作用

手動で設定したスタティック ルートと自動ルート宛先との相互作用

自動ルート アナウンスと自動ルート宛先との相互作用

転送隣接と自動ルート宛先との相互作用

MPLS トラフィック エンジニアリング - エリア間トンネルの利点

MPLS トラフィック エンジニアリング - エリア間トンネルの設定方法

エリア間トンネルの OSPF の設定

ABR ルータの OSPF の設定

非 ABR ルータの OSPF の設定

エリア間トンネルの IS-IS の設定

バックボーン ルータの IS-IS の設定

非バックボーン ルータの IS-IS の設定

インターフェイスの IS-IS の設定

トラフィック エンジニアリングをサポートするための MPLS および RSVP の設定

MPLS トラフィック エンジニアリング エリア間トンネルの設定

明示パスを使用するための MPLS トラフィック エンジニアリング エリア間トンネルの設定

明示パスの設定

自動ルート宛先を使用した MPLS トラフィック エンジニアリングの設定

MPLS トラフィック エンジニアリング - エリア間トンネルの設定例

エリア間トンネルの OSPF の設定:例

エリア間トンネルの IS-IS の設定:例

トラフィック エンジニアリングをサポートするための MPLS および RSVP の設定:例

MPLS トラフィック エンジニアリング エリア間トンネルの設定:例

自動ルート宛先を使用した MPLS トラフィック エンジニアリングの設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS トラフィック エンジニアリング - エリア間トンネルの機能情報

用語集

MPLS トラフィック エンジニアリング - エリア間トンネル

MPLS トラフィック エンジニアリング - エリア間トンネル機能を使用すると、複数の Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)エリアおよびレベルにわたって Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Traffic Engineering(TE; トラフィック エンジニアリング)トンネルを確立できます。これにより、トンネルのヘッドエンドとテールエンド ルータが両方とも同じエリアに存在する必要がなくなりました。IGP は、Intermediate System-to-Intermediate System(IS-IS)または Open Shortest Path First(OSPF)のいずれかです。


) Cisco IOS Release 12.2(33)SRE および以降のリリースでは、自動ルート宛先機能をサポートしています。この機能により、トラフィックは、手動で設定したスタティック ルートではなく TE トンネルを経由して自動的にルーティングされます。


機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「MPLS トラフィック エンジニアリング - エリア間トンネルの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

MPLS トラフィック エンジニアリング - エリア間トンネルの前提条件

ネットワークが、次の Cisco IOS 機能をサポートしている必要があります。

MPLS

IP シスコ エクスプレス フォワーディング

IS-IS または OSPF

TE トンネル

MPLS トラフィック エンジニアリング - エリア間トンネルの制約事項

エリア間トンネルでは、( tunnel mpls traffic-eng path-option number dynamic コマンド内に指定された)TE トンネルのダイナミック パス オプション機能はサポートされない。Area Border Router(ABR; エリア境界ルータ)を識別する明示パスが必要です。使用する ABR の選択肢がある場合、それぞれ別の ABR シーケンスを識別する複数の明示パスを使用することを推奨します。

エリア間トンネルでは、( tunnel mpls traffic-eng autoroute announce コマンド内に指定された)MPLS TE 自動ルート機能はサポートされない。これは、テールエンド ルータの背後にあるネットワーク トポロジを知ることが必要となるためです。

エリア間トンネルでは、( tunnel mpls traffic-eng affinity コマンド内に指定された)トンネル アフィニティはサポートされない。

エリア間トンネルでは、トンネル パスの再最適化はサポートされない。

Cisco IOS Release 12.4(20)T では、ルーズ ホップを含む Label Switched Path(LSP; ラベル スイッチド パス)の Stateful Switchover(SSO; ステートフル スイッチオーバー)はサポートされない。

MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。

MPLS トラフィック エンジニアリング - エリア間トンネルの概要

MPLS トラフィック エンジニアリング - エリア間トンネル機能を使用する前に、次の概念を理解する必要があります。

「エリア間トンネル機能」

「自動ルート宛先機能」

「MPLS トラフィック エンジニアリング - エリア間トンネルの利点」

エリア間トンネル機能

エリア間トンネルを設定するには、 next-address loose コマンドを使用して、ヘッドエンド ルータ上に、LSP が通過する必要のある各 ABR を識別する、トンネル Label Switched Path(LSP; ラベル スイッチド パス)に対して、ルーズにルーティングされた明示パスを指定します。指定した明示パス上のヘッドエンド ルータと ABR は、ルーズ ホップを展開し、それぞれが次の ABR またはトンネル宛先へのパス セグメントを計算します。

たとえば、図 1 に示す単純なマルチエリア ネットワークにおいて、ルータ R1 からルータ R3 への TE トンネルを設定するには、トンネルの明示パス内に、ABR1 および ABR2 をルーズ ホップとして指定します。


) 同様に、Rx もルーズ ホップとして設定できます。この場合、ヘッドエンド ルータ R1 が Rx へのパスを計算し、ルータ Rx が ABR1 へのパスを計算します。


トンネル LSP をシグナリングするために、ヘッドエンド ルータ(R1)は ABR1 へのパスを計算し、それ自身から ABR1 へのパスを一連のストリクト ホップとして指定し、そのあとに、ABR1 からテールエンドへのパスを一連のルーズ ホップ(ABR2、R3)として指定する、Resource Reservation Protocol(RSVP; リソース予約プロトコル)Path メッセージを送信します。ABR1 は、Path メッセージを受信すると、バックボーン エリアの ABR2 までのパスを展開します。このとき、それ自身から ABR2 へのパスを一連のストリクト ホップとして指定し、そのあとに、その ABR2 からトンネル テールエンド(R3)へのパスをルーズ ホップとして指定する、Path メッセージを転送します。ABR2 は、Path メッセージを受信すると、テールエンド エリアの R3 までのパスを展開します。このとき、それ自身から R2 へのパスを指定する Path メッセージを一連のストリクト ホップとして伝播します。

図 1 マルチエリア ネットワーク

 


) Cisco IOS Release 12.2(33)SRB で、ルーズ ホップを含む LSP の SSO 回復がサポートされています。

Cisco IOS Release 12.4(20)T では、ルーズ ホップを含む LSP の SSO 回復はサポートされていません。



) 厳密には、IS-IS では ABR が認識されません。MPLS トラフィック エンジニアリング - エリア間トンネル機能を説明するために、IS-IS レベル 1-2 ルータを ABR と想定します。



) TE エリア間トンネルの明示パスには、非 ABR LSP をいくつでも含めることができます。1 つのエリア内に、次の IP アドレスとしてルーズなアドレスと厳格なアドレスを組み合せて指定できます。明示パス内に次の IP アドレスを指定するには、next-address コマンドを使用します。



) OSPF では、エリアが仮想リンクを介してバックボーンに接続されている場合、パス内に 3 つ以上の ABR が存在する可能性があります。


エリア間トラフィック エンジニアリング LSP では、次の MPLS TE 機能がサポートされています。

自動帯域幅調整

Diff-Serve-aware トラフィック エンジニアリング

高速リルート リンク保護

ポリシーベース ルーティング

スタティック ルーティング

自動ルート宛先機能

自動ルート宛先機能を使用すると、手動で設定したスタティック ルートではなく TE トンネルを経由して、トラフィックを自動的にルーティングできます。

トンネル単位でこの機能をイネーブルにするには、 tunnel mpls traffic-eng autoroute destination コマンドを使用します。

ここでは、自動ルート宛先機能と他の各機能との相互作用について説明します。

「CBTS と自動ルート宛先との相互作用」

「手動で設定したスタティック ルートと自動ルート宛先との相互作用」

「自動ルート アナウンスと自動ルート宛先との相互作用」

「転送隣接と自動ルート宛先との相互作用」

CBTS と自動ルート宛先との相互作用

自動ルート宛先機能がイネーブルになっている TE トンネルは、Class-Based Traffic Shaping(CBTS)トンネル バンドル マスターまたはメンバとして設定することもできます。CBTS バンドル内では、自動ルート宛先がイネーブルになっているマスター トンネルだけが Routing Information Base(RIB; ルーティング情報ベース)にインストールされます。つまり、メンバ トンネルは RIB にインストールされません。

自動ルート宛先がイネーブルになっているメンバ トンネルがバンドルから設定解除されると、通常の TE トンネルとなります。TE は、スタティック プロセスでこれらのトンネルを経由するスタティック ルートを RIB にインストールするように要求します。これに対し、自動ルート宛先がイネーブルになっている通常の TE トンネルがメンバとして CBTS バンドルに追加されると、TE は、スタティック プロセスでこれらのトンネルを経由する自動スタティック ルートを RIB から削除するように要求します。

手動で設定したスタティック ルートと自動ルート宛先との相互作用

tunnel mpls traffic-eng autoroute destination コマンドによって自動ルート宛先がイネーブルになっているトンネルと同じ宛先への、手動で設定されたスタティック ルートがある場合、その宛先に対するトラフィックは、スタティック ルートと、自動ルート宛先がイネーブルになっているトンネルとの間で負荷共有されます。

自動ルート アナウンスと自動ルート宛先との相互作用

エリア内トンネルでは、トンネルが自動ルート アナウンスと自動ルート宛先の両方を使用して設定されている場合、IGP とスタティック プロセスの両方によってそのトンネルが RIB にアナウンスされます。RIB は、IGP ルートよりもスタティック ルートを優先するため、自動ルート アナウンスよりも自動ルート宛先機能が優先されます。

転送隣接と自動ルート宛先との相互作用

トンネルが転送隣接と自動ルート宛先の両方を使用して設定されている場合、IGP とスタティック プロセスの両方によってそのトンネルが RIB にアナウンスされます。RIB は、スタティック ルートを優先します。ただし、IGP は、 forwarding adjacency コマンドを介してトンネルの情報を提供されており、トンネル情報がフラッディングしたため、転送隣接は引き続き機能します。

MPLS トラフィック エンジニアリング - エリア間トンネルの利点

あるルータから別の IGP エリア内の別のルータへのトラフィックを TE LSP 経由にする必要がある場合、MPLS トラフィック エンジニアリング - エリア間トンネル機能を使用すると、送信元ルータから宛先ルータへのトンネルを設定できます。これに代わる方法としては、一連のトンネルを設定し、それぞれが送信元ルータと宛先ルータの間にあるエリアの 1 つを通過するようにします。これにより、トンネルの 1 つに到着したトラフィックは、次の同種のトンネルに転送されます。

自動ルート宛先機能を使用すると、ASBR などの特定のエリア間トンネル経由でトラフィックをルーティングするために、手動でスタティック ルートを設定する必要がなくなります。

MPLS トラフィック エンジニアリング - エリア間トンネルの設定方法

ここでは、次の作業について説明します。

「エリア間トンネルの OSPF の設定」(任意)

「エリア間トンネルの IS-IS の設定」(任意)

「トラフィック エンジニアリングをサポートするための MPLS および RSVP の設定」(必須)

「MPLS トラフィック エンジニアリング エリア間トンネルの設定」(必須)


) OSPF または IS-IS のいずれかを設定する必要があります。


エリア間トンネルの OSPF の設定

ここでは、次の作業について説明します。

「ABR ルータの OSPF の設定」

「非 ABR ルータの OSPF の設定」

ABR ルータの OSPF の設定

OSPF を実行している ABR ごとに、次の手順を実行して、トンネルを配置または経由する各エリア上にトラフィック エンジニアリングを設定します。複数のエリアを設定し、各エリア内または各エリア間でトラフィック エンジニアリングを設定することによって、エリア内のネットワーク内部の変更をルータに含めることができます。


) MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。


手順の概要

1. enable

2. configure terminal

3. router ospf process-id

4. network ip- address wildcard - mask area area-id

5. mpls traffic-eng router-id interface-name

6. mpls traffic-eng area 0

7. mpls traffic-eng area number

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id

 

Router(config)# router ospf 1

OSPF をイネーブルにし、ルータ コンフィギュレーション モードを開始します。

process-id 引数は、OSPF ルーティング プロセスで内部的に使用される識別パラメータです。この引数は論理的に割り当てられ、任意の正の整数を使用できます。OSPF ルーティング プロセスごとに固有の値を割り当てます。

ステップ 4

network ip-address wildcard-mask area area-id

 

Router(config-router)# network 192.168.45.0 0.0.255.255 area 1

OSPF を実行するインターフェイスを指定し、インターフェイスの接続先のエリアを指定します。

ステップ 5

mpls traffic-eng router-id interface-name

 

Router(config-router)# mpls traffic-eng router-id Loopback0

ノードのトラフィック エンジニアリング ルータ識別子が、指定されたインターフェイスに関連付けられている IP アドレスになるように指定します。

ルータ ID は、 show mpls traffic-eng topology path コマンド出力に表示されます。

の値は、Loopback0 にしてください。

ステップ 6

mpls traffic-eng area 0

 

Router(config-router)# mpls traffic-eng area 0

エリア 0 内の OSPF に対して、MPLS トラフィック エンジニアリングをオンにします。

コマンドを使用します。

ステップ 7

mpls traffic-eng area number

 

Router(config-router)# mpls traffic-eng area 2

OSPF MPLS を実行しているルータを、指定された OSPF エリアのトラフィック エンジニアリングをフラッディングするように設定します。

ステップ 8

end

 

Router(config-router)# end

特権 EXEC モードに戻ります。

非 ABR ルータの OSPF の設定

OSPF を実行している非 ABR ごとに、次の手順を実行して OSPF を設定します。


) MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。


手順の概要

1. enable

2. configure terminal

3. router ospf process-id

4. network ip-address wildcard-mask area area-id

5. mpls traffic-eng router-id interface-name

6. mpls traffic-eng area number

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id

 

Router(config)# router ospf 1

OSPF をイネーブルにし、ルータ コンフィギュレーション モードを開始します。

process-id 引数は、OSPF ルーティング プロセスで内部的に使用される識別パラメータです。ローカルで割り当てられ、任意の正の整数を使用できます。OSPF ルーティング プロセスごとに固有の値を割り当てます。

ステップ 4

network ip-address wildcard-mask area area-id

 

Router(config-router)# network 192.168.10.10 255.255.255.0 area 1

OSPF を実行するインターフェイスを指定し、インターフェイスの接続先のエリアを指定します。

ステップ 5

mpls traffic-eng router-id interface-name

 

Router(config-router)# mpls traffic-eng router-id Loopback0

ノードのトラフィック エンジニアリング ルータ識別子が、指定されたインターフェイスに関連付けられている IP アドレスになるように指定します。

ルータ ID は、 show mpls traffic-eng topology path コマンド出力に表示されます。

の値は、Loopback0 にしてください。

ステップ 6

mpls traffic-eng area number

 

Router(config-router)# mpls traffic-eng area 1

ルータが属するエリアを指定します。

コマンドを使用します。

ステップ 7

end

 

Router(config-router)# end

特権 EXEC モードに戻ります。

エリア間トンネルの IS-IS の設定

ここでは、次の作業について説明します。

「バックボーン ルータの IS-IS の設定」

「非バックボーン ルータの IS-IS の設定」

「インターフェイスの IS-IS の設定」

バックボーン ルータの IS-IS の設定

バックグラウンド(レベル 1-2)ルータに IS-IS を設定するには、次の手順を実行します。


) MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。


手順の概要

1. enable

2. configure terminal

3. router isis

4. metric-style wide

5. net nn.nnnn.nnnn.nnnn.nnnn

6. mpls traffic-eng router-id interface-name

7. mpls traffic-eng level-1

8. mpls traffic-eng level-2

9. interface typeslot / port

10. ip router isis

11. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router isis

 

Router(config)# router isis

IS-IS ルーティングをイネーブルにし、IP に IS-IS プロセスを指定して、ルータをルータ コンフィギュレーション モードに設定します。

ステップ 4

metric-style wide

 

Router(config-router)# metric-style wide

新スタイルの Type, Length, Value(TLV; タイプ、長さ、値)オブジェクトだけを生成して受け入れるようにルータを設定します。

ステップ 5

net nn.nnnn.nnnn.nnnn.nnnn

 

Router(config-router)# net 10.0000.0100.0000.0010

エリア ID(エリア アドレス)およびシステム ID を設定します。

ステップ 6

mpls traffic-eng router-id interface-name

 

Router(config-router)# mpls traffic-eng router-id Loopback0

ノードのトラフィック エンジニアリング ルータ識別子が、インターフェイス Loopback0 に関連付けられている IP アドレスになるように指定します。

ステップ 7

mpls traffic-eng level-1

 

Router(config-router)# mpls traffic-eng level-1

IS-IS の MPLS トラフィック エンジニアリングをレベル 1 でオンにします。

コマンドを使用します。

ステップ 8

mpls traffic-eng level-2

 

Router(config-router)# mpls traffic-eng level-2

IS-IS の MPLS トラフィック エンジニアリングをレベル 2 でオンにします。

コマンドを使用します。

ステップ 9

interface typeslot / port

 

Router(config-router)# interface POS1/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 10

ip router isis

 

Router(config-if)# ip router isis

IS-IS ルーティングをイネーブルにします。

IS-IS を実行する各インターフェイスで、このコマンドを指定します。

ステップ 11

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

非バックボーン ルータの IS-IS の設定

非バックボーン ルータに IS-IS を設定するには、次の手順を実行します。


) MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。


手順の概要

1. enable

2. configure terminal

3. router isis

4. metric-style wide

5. net nn.nnnn.nnnn.nnnn.nnnn

6. mpls traffic-eng router-id interface-name

7. mpls traffic-eng { level-1 | level-2 }

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router isis

 

Router(config)# router isis

IS-IS ルーティングをイネーブルにし、IP に IS-IS プロセスを指定して、ルータをルータ コンフィギュレーション モードに設定します。

ステップ 4

metric-style wide

 

Router(config-router)# metric-style wide

新スタイルの TLV だけを生成して受け入れるようにルータを設定します。

ステップ 5

net nn.nnnn.nnnn.nnnn.nnnn

 

Router(config-router)# net 10.0000.2000.0100.0001

エリア ID(エリア アドレス)およびシステム ID を設定します。

ステップ 6

mpls traffic-eng router-id interface-name

 

Router(config-router)# mpls traffic-eng router-id Loopback0

ノードのトラフィック エンジニアリング ルータ識別子が、インターフェイス Loopback0 に関連付けられている IP アドレスになるように指定します。

ステップ 7

mpls traffic-eng { level-1 | level-2 }

 

Router(config-router)# mpls traffic-eng level-1

IS-IS の MPLS トラフィック エンジニアリングをレベル 1 でオンにします。

コマンドを使用します。

ステップ 8

end

 

Router(config-router)# end

特権 EXEC モードに戻ります。

インターフェイスの IS-IS の設定

インターフェイスに IS-IS を設定するには、次の手順を実行します。


) MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。


手順の概要

1. enable

2. configure terminal

3. router isis

4. metric-style wide

5. net nn.nnnn.nnnn.nnnn.nnnn

6. mpls traffic-eng router-id interface-name

7. interface typeslot/port

8. ip router isis

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router isis

 

Router(config)# router isis

IS-IS ルーティング プロトコルをイネーブルにし、IP に IS-IS プロセスを指定します。

このコマンドによって、ルータはルータ コンフィギュレーション モードになります。

ステップ 4

metric-style wide

 

Router(config-router)# metric-style wide

新スタイルの TLV だけを生成して受け入れるようにルータを設定します。

ステップ 5

net nn.nnnn.nnnn.nnnn.nnnn

 

Router(config-router)# net 10.0000.0100.0000.0010

エリア ID(エリア アドレス)およびシステム ID を設定します。

ステップ 6

mpls traffic-eng router-id interface-name

 

Router(config-router)# mpls traffic-eng router-id Loopback0

ノードのトラフィック エンジニアリング ルータ識別子が、インターフェイス Loopback0 に関連付けられている IP アドレスになるように指定します。

ステップ 7

interface typeslot / port

 

Router(config-router)# interface POS1/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip router isis

 

Router(config-if)# ip router isis

IS-IS ルーティングをイネーブルにします。

IS-IS を実行する各インターフェイスで、このコマンドを指定します。

ステップ 9

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

トラフィック エンジニアリングをサポートするための MPLS および RSVP の設定

トラフィック エンジニアリングをサポートするように MPLS および RSVP を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. ip cef

4. mpls traffic-eng tunnels

5. interface typeslot / port

6. ip address ip-address mask [ secondary [ vrf vrf-name ]]

7. ip rsvp bandwidth

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef

 

Router(config)# ip cef

ルート プロセッサ カードでシスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 4

mpls traffic-eng tunnels

 

Router(config)# mpls traffic-eng tunnels

デバイスで MPLS トラフィック エンジニアリング トンネル シグナリングをイネーブルにします。

ステップ 5

interface typeslot / port

 

Router(config)# interface Loopback0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

ip address ip-address mask [ secondary [ vrf vrf-name ]]

 

Router(config-if)# ip address 192.168.10.10 255.255.255.255

IP ネットワーク アドレスおよびネットワーク マスクをインターフェイスに割り当てます。

ステップ 7

ip rsvp bandwidth

 

Router(config-if)# ip rsvp bandwidth

インターフェイスで IP の RSVP をイネーブルにします。

ステップ 8

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

MPLS トラフィック エンジニアリング エリア間トンネルの設定

ここでは、次の作業について説明します。

「明示パスを使用するための MPLS トラフィック エンジニアリング エリア間トンネルの設定」

「明示パスの設定」

明示パスを使用するための MPLS トラフィック エンジニアリング エリア間トンネルの設定

明示パスを使用するように MPLS トラフィック エンジニアリング エリア間トンネルを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. interface tunnel-interface

4. ip unnumbered type number

5. tunnel destination ip-address

6. tunnel mode mpls traffic-eng

7. tunnel mpls traffic-eng bandwidth bandwidth

8. tunnel mpls traffic-eng path-option number explicit { name path-name | identifier path-number } [ lockdown ]

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel-interface

 

Router(config)# interface Tunel1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip unnumbered type number

 

Router(config-if)# ip unnumbered Loopback 0

トンネル インターフェイスに IP アドレスを割り当てます。

MPLS トラフィック エンジニアリング トンネル インターフェイスは単一方向リンクを表すため、番号なしにする必要があります。

ステップ 5

tunnel destination ip-address

 

Router(config-if)# tunnel destination 192.168.20.20

トンネルの宛先を指定します。

宛先デバイスの MPLS トラフィック エンジニアリング ルータ ID を入力する必要があります。

ステップ 6

tunnel mode mpls traffic-eng

 

Router(config-if)# tunnel mode mpls traffic-eng

トンネル カプセル化モードを MPLS トラフィック エンジニアリングに設定します。

ステップ 7

tunnel mpls traffic-eng bandwidth bandwidth

 

Router(config-if)# tunnel mpls traffic-eng bandwidth 300

MPLS トラフィック エンジニアリング トンネルに必要な帯域幅を設定します。

ステップ 8

tunnel mpls traffic-eng path-option number explicit { name path-name | identifier path-number } [ lockdown ]

 

Router(config-if)# tunnel mpls traffic-eng path-option 1 explicit name path-Tunnel1

指定した IP 明示パス、またはトラフィック エンジニアリング トポロジ データベースからダイナミックに計算されたパスを使用するように、トンネルを設定します。

name キーワードでは、 next-address loose コマンドを介して、トンネル LSP が通過する ABR をルーズ ホップとして指定する必要があります。

ステップ 9

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

明示パスの設定

明示パスを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. ip explicit-path name pathname

4. next-address [ loose | strict ] ip-address

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip explicit-path name pathname

 

Router(config)# ip explicit-path name path-tunnel1

IP 明示パス コンフィギュレーション モードを開始し、指定されたパスを作成または変更します。

ステップ 4

next-address [ loose | strict ] ip-address

 

Router(config-ip-expl-path)# next-address loose 192.168.40.40

明示パス内の次の IP アドレスを指定します。

next-address loose コマンド内で、パスが通過する各 ABR を指定する必要があります。

ステップ 5

end

 

Router(config-ip-expl-path)# end

特権 EXEC モードに戻ります。

自動ルート宛先を使用した MPLS トラフィック エンジニアリングの設定

自動ルート宛先を使用して MPLS トラフィック エンジニアリング トンネルを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. interface tunnel-interface

4. ip unnumbered type number

5. tunnel destination ip-address

6. tunnel mode mpls traffic-eng

7. tunnel mpls traffic-eng bandwidth bandwidth

8. tunnel mpls traffic-eng path-option number explicit { name path-name | identifier path-number } [ lockdown ]

9. tunnel mpls traffic-eng autoroute destination

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel-interface

 

Router(config)# interface Tunnel1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip unnumbered type number

 

Router(config-if)# ip unnumbered Loopback 0

トンネル インターフェイスに IP アドレスを割り当てます。

MPLS トラフィック エンジニアリング トンネル インターフェイスは単一方向リンクを表すため、番号なしにする必要があります。

ステップ 5

tunnel destination ip-address

 

Router(config-if)# tunnel destination 192.168.20.20

トンネルの宛先を指定します。

宛先デバイスの MPLS トラフィック エンジニアリング ルータ ID を入力する必要があります。

ステップ 6

tunnel mode mpls traffic-eng

 

Router(config-if)# tunnel mode mpls traffic-eng

トンネル カプセル化モードを MPLS トラフィック エンジニアリングに設定します。

ステップ 7

tunnel mpls traffic-eng bandwidth bandwidth

 

Router(config-if)# tunnel mpls traffic-eng bandwidth 300

MPLS トラフィック エンジニアリング トンネルに必要な帯域幅を設定します。

ステップ 8

tunnel mpls traffic-eng path-option number explicit { name path-name | identifier path-number } [ lockdown ]

 

Router(config-if)# tunnel mpls traffic-eng path-option 1 explicit name path-Tunnel1

指定した IP 明示パス、またはトラフィック エンジニアリング トポロジ データベースからダイナミックに計算されたパスを使用するように、トンネルを設定します。

name キーワードでは、 next-address loose コマンドを介して、トンネル LSP が通過する ABR をルーズ ホップとして指定する必要があります。

ステップ 9

tunnel mpls traffic-eng autoroute destination

 

Router(config-if)# tunnel mpls traffic-eng autoroute destination

トラフィックが、TE トンネルを経由して自動的にルーティングされます。

ステップ 10

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

MPLS トラフィック エンジニアリング - エリア間トンネルの設定例

ここでは、図 2 に示すような単純なルータ トポロジに対して MPLS トラフィック エンジニアリング エリア間トンネルを設定する方法を示します。次の各項で、それぞれの設定を示す設定フラグメントを記載しています。

「エリア間トンネルの OSPF の設定:例」

「エリア間トンネルの IS-IS の設定:例」

「トラフィック エンジニアリングをサポートするための MPLS および RSVP の設定:例」

「MPLS トラフィック エンジニアリング エリア間トンネルの設定:例」

「自動ルート宛先を使用した MPLS トラフィック エンジニアリングの設定:例」

図 2 ルータ トポロジ

 

エリア間トンネルの OSPF の設定:例

以降の設定フラグメントは、エリア間トンネルに OSPF を設定する方法を示しています。次のことが前提となっています。

ルータ R1、Rx、および Ra が OSPF エリア 1 内にある。

ルータ Ra、Ry、および Rb が OSPF エリア 0 内にある。

ルータ Rb、Rz、および R2 が OSPF エリア 2 内にある。

ルータ Ra が、エリア 0 およびエリア 1 の ABR である。

ルータ Rb が、エリア 0 およびエリア 2 の ABR である。

ルータ R1 の OSPF 設定

router ospf 1
network 192.168.10.10 0.0.0.0 area 1
network 192.168.35.0 0.0.0.255 area 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 1

ルータ Rx の OSPF 設定

router ospf 1
network 192.168.30.30 0.0.0.0 area 1
network 192.168.35.0 0.0.0.255 area 1
network 192.168.45.0 0.0.0.255 area 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 1

ルータ Ra の OSPF 設定

Ra は、エリア 0 およびエリア 1 の ABR です。インターフェイス POS2/0 はエリア 1 内にあり、インターフェイス POS3/0 はエリア 0 内にあります。 mpls traffic-eng area コマンドで、両方のエリアで IGP TE アップデートが行われるように Ra を設定しています。

router ospf 1
network 192.168.40.40 0.0.0.0 area 0
network 192.168.45.0 0.0.0.255 area 1
network 192.168.55.0 0.0.0.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng area 1

ルータ Rb の OSPF 設定

Rb は、エリア 0 およびエリア 2 の ABR です。インターフェイス POS4/0 はエリア 0 内にあり、インターフェイス POS5/0 はエリア 2 内にあります。 mpls traffic-eng area コマンドで、両方のエリアで IGP TE アップデートが行われるように Rb を設定しています。

router ospf 1
network 192.168.60.60 0.0.0.0 area 0
network 192.168.65.0 0.0.0.255 area 0
network 192.168.75.0 0.0.0.255 area 2
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng area 2

 

ルータ Rz の OSPF 設定

router ospf 1
network 192.168.70.70 0.0.0.0 area 2
network 192.168.75.0 0.0.0.255 area 2
network 192.168.85.0 0.0.0.255 area 2
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 2

 

ルータ R2 の OSPF 設定

router ospf 1
network 192.168.20.20 0.0.0.0 area 2
network 192.168.85.0 0.0.0.255 area 2
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 2

エリア間トンネルの IS-IS の設定:例

以降の設定フラグメントは、エリア間トンネルに IS-IS を設定する方法を示しています。次のことが前提となっています。

R1 と Rx はレベル 1 のルータである。

Ra、Ry、および Rb はレベル 1-2 のルータである。

Rz と R2 はレベル 1 のルータである。

ルータ R1 の IS-IS 設定

interface POS1/0
ip router isis
router isis
metric-style wide
net 10.0000.0100.0000.0010
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1

ルータ Rx の IS-IS 設定

clns routing
interface POS1/0
ip router isis
interface POS2/0
ip router isis
router isis
metric-style wide
net 10.0000.2000.0100.0001
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1

ルータ Ra の IS-IS 設定

clns routing
interface POS2/0
ip router isis
interface POS3/0
ip router isis
router isis
metric-style wide
net 10.0000.2000.0200.0002
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
mpls traffic-eng level-2

ルータ Ry の IS-IS 設定

clns routing
interface POS3/0
ip router isis
interface POS4/0
ip router isis
router isis
metric-style wide
net 10.0000.2000.0300.0003
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

ルータ Rb の IS-IS 設定

clns routing
interface POS4/0
ip router isis
interface POS5/0
ip router isis
router isis
metric-style wide
net 10.0000.2000.0400.0004
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
mpls traffic-eng level-2

ルータ Rz の IS-IS 設定

clns routing
interface POS5/0
ip router isis
interface POS6/0
ip router isis
router isis
metric-style wide
net 10.0000.2000.0500.0005
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1

ルータ R2 の IS-IS 設定

clns routing
interface POS6/0
ip router isis
router isis
metric-style wide
net 10.0000.0200.0000.0020
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1

トラフィック エンジニアリングをサポートするための MPLS および RSVP の設定:例

次の設定フラグメントは、ルータでトラフィック エンジニアリングをサポートするように MPLS および RSVP を設定する方法を示しています。

ルータ R1 のトラフィック エンジニアリング設定

ip cef
mpls traffic-eng tunnels
interface Loopback0
ip address 192.168.10.10 255.255.255.255
interface POS1/0
!Each interface supporting MPLS TE must include the following:
mpls traffic-eng tunnels
ip rsvp bandwidth
 
The configuration of routers Rx, Ra, Ry, Rb, Rz, and R2 for traffic engineering operation is similar to that for R1.

MPLS トラフィック エンジニアリング エリア間トンネルの設定:例

次の設定フラグメントは、MPLS トラフィック エンジニアリング エリア間トンネルを設定する方法を示しています。トンネル 1 は、Ra および Rb 経由でルーズにルーティングされたパス オプションを使用して設定されています。

R1 エリア間トンネル設定

次のコマンドでは、明示パスを使用するように MPLS TE トンネルを設定しています。

interface Tunnel1
ip unnumbered Loopback0
tunnel destination 192.168.20.20
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng bandwidth 300
tunnel mpls traffic-eng path-option 1 explicit name path-tunnel1
 

次のコマンドでは、明示パスを設定しています。

ip explicit-path name path-tunnel1
next-address loose 192.168.40.40
next-address loose 192.168.60.60
next-address loose 192.168.20.20 !Specifying the tunnel tailend in the loosely routed
!path is optional.

) 一般的に、エリア間トンネルの場合は、トンネルのシグナリングの成功率を高めるために、ルーズにルーティングされたパス オプションを複数設定して、それぞれで ABR(OSPF の場合)またはレベル 1-2 の境界ルータ(IS-IS の場合)の異なる組み合せを指定する必要があります。この単純なトポロジにおいては、他にルーズにルーティングされたパスはありません。


自動ルート宛先を使用した MPLS トラフィック エンジニアリングの設定:例

次の例に、自動ルート宛先を使用して MPLS TE トンネルを設定する方法を示します。

interface Tunnel103
ip unnumbered Loopback0
tunnel destination 10.1.0.3
tunnel mode mpls traffic-eng
tunnel mpls traffic-end path-option 1 explicit name 111-103
tunnel mpls traffic-eng autoroute destination

その他の参考資料

ここでは、MPLS トラフィック エンジニアリング - エリア間トンネル機能の関連資料を示します。

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

MPLS トラフィック エンジニアリング - エリア間トンネルの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。その機能は、特に断りがないかぎり、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 1 MPLS トラフィック エンジニアリング - エリア間トンネルの機能情報

機能名
リリース
機能設定情報

MPLS トラフィック エンジニアリング - エリア間トンネル

12.0(19)ST1
12.0(21)ST
12.2(18)S
12.2(18)SXD
12.2(27)SBC
12.2(28)SB
12.2(33)SRB
12.4(20)T
12.2(33)SRE

MPLS トラフィック エンジニアリング - エリア間トンネル機能を使用すると、複数の IGP エリアおよびレベルにわたって MPLS TE トンネルを確立できます。これにより、トンネルのヘッドエンドとテールエンド ルータが両方とも同じエリアに存在する必要がなくなりました。

この機能は、12.0(19)ST1 で導入されました。

Cisco 10000 シリーズ ルータのサポートは、12.0(21)ST で追加されました。

この機能は、12.2(18)S で統合されました。

この機能は、12.2(18)SXD で統合されました。

この機能は、12.2(27)SBC で統合されました。

この機能は、12.2(28)SB で統合されました。

ルーズ ホップを含む LSP の Stateful Switchover(SSO; ステートフル スイッチオーバー)回復に対するサポートは、12.2(33)SRB で追加されました。

ルーズ ホップを含む LSP の SSO 回復に対するサポートは、12.4(20)T で廃止されました。

自動ルート宛先機能は、12.2(33)SRE で追加されました。次のコマンドが追加または変更されました。 show ip static route show mpls traffic-eng autoroute show mpls traffic-eng tunnels tunnel mpls traffic-eng autoroute destination

用語集

ABR :Area Border Router(エリア境界ルータ)。2 つのエリアを接続するルータ。OSPF では、ABR は両方のエリアに属し、エリアごとに別々のトポロジ データベースを管理する必要があります。OSPF ルータのインターフェイスが複数のエリアに存在する場合、その OSPF ルータはエリア境界ルータとなります。

IGP :Interior Gateway Protocol(内部ゲートウェイ プロトコル)。自律システム内でのルーティング情報の交換に使用されるインターネット プロトコル。一般的な IGP には、OSPF や Routing Information Protocol(RIP)などがあります。

IS-IS :Intermediate System-to-Intermediate System。IS-IS は、DECnet Phase V ルーティングに基づいた OSI リンクステート階層型ルーティング プロトコルです。Intermediate System(IS)ルータが、単一のメトリックに基づいてルーティング情報を交換して、ネットワーク トポロジを決定します。

Label Switched Path(LSP; ラベル スイッチド パス)トンネル :パケットの伝送にラベル スイッチングが使用される、2 台のルータ間に設定された接続。

LSP :Label Switched Path(ラベル スイッチド パス)。一連のホップ(R0...Rn など)。パケットは、ラベル スイッチング メカニズムを使用して R0 から Rn まで伝送されます。ラベル スイッチド パスは通常のルーティング メカニズムに基づいてダイナミックに選択されるか、または設定によって選択されます。

MPLS :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)。ネットワークを介してパケット(フレーム)を転送する方式。ネットワークのエッジにあるルータがパケットにラベルを適用できるようにします。ネットワーク コア内の ATM スイッチまたは既存のルータは、最小限のルックアップ オーバーヘッドでラベルに従ってパケットを切り替えることができます。

OSPF :Open Shortest Path First。インターネット コミュニティの Routing Information Protocol(RIP)の後継アルゴリズムとして提案された、リンクステートの階層型 IGP ルーティング アルゴリズム。OSPF 機能には、最小コストによるルーティング、マルチパスのルーティング、およびロード バランシングが含まれます。

エリア :ネットワーク セグメント(たとえば、OSPF ベースのセグメント)とそれに接続されたデバイスの論理セット。エリアは通常、ルータによって他のエリアに接続されて、1 つの自律システムを構成します。OSPF と IS-IS では、エリアの定義方法が異なります。OSPF エリアの境界は、ルータによってマーキングされます。異なるエリアに、別々のインターフェイスが含まれます。IS-IS では、すべてのルータが完全に 1 つのエリア内にあり、エリア境界はルータ上でなくリンク上にあります。エリア同士を接続するルータは、レベル 2 のルータであり、別のエリアに直接接続されていないルータは、レベル 1 のルータです。

エリア ID :IS-IS ルータにおいては、このエリア アドレスはインターフェイスではなくルータ全体に関連付けられています。1 台のルータは、最大 3 つのエリア アドレスを持つことができます。IS-IS ルータでは、単一アドレス(Network Entry Title(NET))によって、エリア ID とシステム ID の両方が定義されます。

エリア間 TE :トラフィック エンジニアリング LSP の複数のエリアにまたがる機能。

シスコ エクスプレス フォワーディング :高度なレイヤ 3 IP スイッチング テクノロジー。シスコ エクスプレス フォワーディングによって、インターネットや、Web ベースのアプリケーションまたは対話型セッションが集中的に使用されるネットワークなどの、大規模でダイナミックなトラフィック パターンを持つネットワークのパフォーマンスおよびスケーラビリティが最適化されます。シスコ エクスプレス フォワーディングでは、プレフィクスベースの IP 宛先スイッチングの判定を行うために、Forwarding Information Base(FIB; 転送情報ベース)を使用します。FIB の概念は、ルーティング テーブルまたは情報ベースの概念と似ています。ネットワーク内でルーティングまたはトポロジが変更されると、IP ルーティング テーブルがアップデートされ、これらの変更が FIB に反映されます。FIB は、IP ルーティング テーブル内の情報に基づいて、ネクストホップ アドレス情報を管理します。

自律システム :共通管理で共通のルーティング方針が共有される、ネットワークの集合。自律システムは、エリアごとに細分化されます。

スタティック ルーティング :スタティック ルートとは、ネットワーク管理者により事前にプログラミングされた固定パスです。スタティック ルートは、ルーティング プロトコルを使用できません。また、ルーティング アップデート メッセージの受信後に自己アップデートすることもできません。このため、スタティック ルートは手動でアップデートする必要があります。

テールエンド :トンネルのダウンストリーム受信エンド。トラフィック エンジニアリング LSP の終端となるルータです。

トラフィック エンジニアリング :ネットワーク上で、標準的なルーティング方法が使用された場合に選択されるパスとは異なるパスを経由してトラフィックがルーティングされるようにするために使用する技術やプロセス。

トンネル :2 つのピア間(2 台のルータ間など)のセキュアな通信パス。トラフィック エンジニアリング トンネルは、トラフィック エンジニアリングに使用されるラベル スイッチド トンネルです。このようなトンネルは、通常のレイヤ 3 ルーティングとは異なる方法で設定されます。レイヤ 3 ルーティングの場合にトンネルで使用されるパスとは異なるパスにトラフィックを転送するために使用されます。

プロセス ID :デバイス内部の異なるプロセスを区別します。OSPF プロセス ID は、任意の正の整数にできます。この ID は、それ自身が設定されているルータの外部では意味を持ちません。

ヘッドエンド :トンネルのアップストリーム(送信側)エンド。トラフィック エンジニアリング LSP の起点となり、その LSP を管理するルータ。

仮想リンク :通常、各エリアはエリア 0 に直接接続されています。あるエリアがエリア 0 から 1 エリア分離れたエリアに接続されるとき、仮想リンクが接続に使用されます。

マスク :どのアドレス部分がネットワークまたはサブネットを参照し、どの部分がホストを参照しているかを記述するために使用されるビット組み合せ。

ルータ ID :パケットを発信するルータを他のすべてのルータと一意に区別するために使用できる ID。たとえば、ルータのインターフェイスの 1 つの IP アドレスです。

レベル 1 ルータ :他のエリアに直接接続されたルータ。これらのルータは、バックボーン内にありません。MPLS は、バックグラウンドで実行されません。これらのルータは、内部ルータとも呼ばれます。

レベル 2 ルータ :2 つのエリアを接続するルータ。これらのルータでは、MPLS をバックグラウンドで実行できます。

ロード バランシング :ルータが帯域幅を効率的に使用するように、同じ宛先への複数のパスの間でトラフィックを分散すること。ロード バランシングを行うと、ネットワーク セグメントの使用が増加するため、効率的なネットワーク帯域幅が増加します。