マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS トラフィック エンジニアリング - DiffServ 対応(DS-TE)
MPLS トラフィック エンジニアリング - DiffServ 対応(DS-TE)
発行日;2012/01/30 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS トラフィック エンジニアリング - DiffServ 対応(DS-TE)

背景および概要

利点

関連機能およびテクノロジー

関連資料

サポートされる規格

前提条件

設定作業

従来のコマンドから IETF 標準コマンドへ

ip rsvp bandwidth コマンド

tunnel mpls traffic-eng bandwidth コマンド

mpls traffic-eng ds-te コマンド

IETF 標準へのネットワークの移行

DS-TE トンネルの設定

レベル 1:デバイスの設定

レベル 2:物理インターフェイスの設定

レベル 3:トンネル インターフェイスの設定

設定の確認

設定例

トンネル ヘッド

ミッドポイント デバイス

テールエンド デバイス

保証帯域幅サービスの設定

保証帯域幅サービスの例

送信先プレフィクスが 1 つの場合の例

トンネル ヘッド-1 の設定

トンネル ヘッド-2 の設定

トンネル ミッドポイントの設定(ミッドポイント-1)

トンネル ミッドポイントの設定(ミッドポイント-2)

トンネル テールの設定

多数の送信先プレフィクスが存在する場合の例

トンネル ヘッド-1 の設定

トンネル ヘッド-2 の設定

トンネル ミッドポイントの設定(ミッドポイント-1)

トンネル ミッドポイントの設定(ミッドポイント-2)

トンネル テールの設定

コマンド リファレンス

用語集

MPLS トラフィック エンジニアリング - DiffServ 対応(DS-TE)

このマニュアルでは、Multiprotocol Label Switching Traffic Engineering(MPLS TE; マルチプロトコル ラベル スイッチング トラフィック エンジニアリング)を DiffServ 対応にするための拡張機能について説明します。具体的には、Constraint-Based Routing(CBR; コンストレイントベース ルーティング)用として各リンクで予約可能な帯域幅を少なくとも 2 つの帯域幅プール(グローバル プール(BC0 とも呼ばれる)とサブプール(BC1 とも呼ばれる))を通して管理できるようになりました。サブプールは、リンク帯域幅のごく一部に制限できます。サブプール帯域幅を使用するトンネルを MPLS Quality of Service(QoS; サービス品質)メカニズムと組み合せて使用すると、ネットワーク全体でエンドツーエンドの保証帯域幅サービスが提供されます。

Cisco IOS Release 12.2(33)SRB 以降、Cisco DS-TE の初回作成後に開発された IETF 標準に準拠するように DS-TE が拡張されています。現在は、ネットワーク上で DS-TE の従来のバージョンと IETF バージョンの両方を実行できます。新しいリリースには下位互換性があります。

機能の履歴

リリース
変更点
12.0(11) ST

DS-TE 機能が導入されました。

12.0(14) ST

Cisco シリーズ 7500(VIP) プラットフォームに対するサポートが追加されました。

IS-IS 内部ゲートウェイ プロトコルに対するサポートが追加されました。

12.0(14) ST-1

多数の送信先プレフィクスを対象とした保証帯域幅サービス(たとえば、自律システムまたは BGP コミュニティを対象とした保証帯域幅サービス)に対するサポートが追加されました。

12.0(22)S

この機能は、Cisco IOS Release 12.0(22)S に実装されました。

12.2(14)S

この機能は、Cisco IOS Release 12.2(14)S に統合されました。

12.2(18)S

この機能は、Cisco IOS Release 12.2(18)S に実装されました。

12.2(18)SXD

この機能は、Cisco IOS Release 12.2(18)SXD に実装されました。

12.2(28)SB

この機能は、Cisco IOS Release 12.2(28)SB に実装されました。

12.2(33)SRB

この機能は、DS-TE の新しい IETF 標準機能(RFC 3270、4124、4125、および 4127 に規定)を含めるように拡張されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。

このマニュアルは次の項で構成されています。

「背景および概要」

「サポートされる規格」

「前提条件」

「設定作業」

「設定例」

「コマンド リファレンス」

「用語集」

背景および概要

MPLS トラフィック エンジニアリングを使用すると、IP トラフィックの Constraint-Based Routing(CBR; コンストレイントベース ルーティング)が可能になります。CBR によって満たされる制約の 1 つに、選択されたパスにおける必要な帯域幅のアベイラビリティがあります。DiffServ 対応トラフィック エンジニアリングにより MPLS トラフィック エンジニアリングが拡張され、「保証」トラフィックのコンストレイントベース ルーティングを実行できるようになります。この処理では、通常のトラフィックで CBR によって満たされる制約よりも限定的な帯域幅制約が満たされます。より限定的な帯域幅は サブプール と呼ばれ、通常の TE トンネル帯域幅は グローバル プール と呼ばれます(サブプールはグローバル プールの一部です。新しい IETF 標準では、グローバル プールは BC0 と呼ばれ、サブプールは BC1 と呼ばれます。これらは、最終的に利用可能な 8 つのクラス タイプの 2 つです)。より限定的な帯域幅制約を満たすことができるため、結果として、保証トラフィックの遅延、ジッタ、または損失に関して、より高いサービス品質パフォーマンスを実現できます。

たとえば、DS-TE を使用すると、ネットワークにおいて、すべてのリンクで保証トラフィック(音声など)のリンク容量の 40%(または割り当てられた任意のパーセンテージ)を超えないように、トラフィックがルーティングされるようにできます。通常のトラフィックでは、最大でリンク容量の 100% に達することがあります。また、すべてのリンクで、QoS メカニズムを使用して、保証トラフィックが通常のトラフィックとは別にキューイングされるようにしてある場合は、保証トラフィックと通常のトラフィックに個別の「オーバーブッキング」率を強制できます。実際には、保証トラフィックに対してオーバーブッキングを一切強制しないようにすることも、アンダーブッキングを強制することすら可能になります。これにより、通常のトラフィックに対しては大幅なオーバーブッキングを強制し続けたまま、保証トラフィックに対してはエンドツーエンドで非常に高い QoS を実現できるようになります。

また、任意のリンクに対して保証トラフィックの最大パーセンテージを強制できるため、ネットワーク管理者は、オーバーエンジニアリングや予測最短パス ルーティング動作に頼ることなく、エンドツーエンドの QoS パフォーマンス パラメータを直接制御できます。このことは、リアルタイム音声、仮想 IP 専用線、帯域幅トレーディングなど、非常に高い QoS 要件を持つアプリケーションの転送に不可欠です。これは、ネットワークのすべての場所において、オーバーエンジニアリングを想定できるわけではないためです。

DS-TE の新しい IETF 標準機能により、制約付きの帯域幅を 2 つの異なるモデル(「マトリョーシカ モデル」と「最大割り当てモデル」)に割り当てる手段が拡張されます。次に、これらのモデルの相違点を示します。

表 1 帯域幅制約モデルの機能

モデル
帯域幅効率を向上
クラス タイプ間での分離を実現
QoS の低下を防止
プリエンプションが使用されていない場合
プリエンプションが使用されている場合
premium クラス タイプの場合
他のすべてのクラス タイプの場合
最大割り当て

あり

あり

あり

あり

なし

マトリョーシカ

あり

なし

あり

あり

あり

したがって、実際には、ネットワーク管理者は次のように使い分けることがあります。

最大割り当てモデル:プリエンプションを使用しないですべてのクラス タイプ間での分離を実現する必要があり、かつ、premium クラス以外のクラス タイプの QoS がある程度低下しても許容される場合に使用します。

マトリョーシカ モデル:すべてのクラス タイプの QoS の低下を防止する必要があり、プリエンプションを適用できる場合に使用します。

DS-TE には OSPF(Open Shortest Path First)ルーティング プロトコルの拡張を伴います。これにより、各プリエンプション レベルで 使用可能なグローバル プール帯域幅 以外に、各プリエンプション レベルで 使用可能なサブプール(クラス タイプ)帯域幅がアドバタイズされるようになります。また、DS-TE では、このより複雑なアドバタイズ情報をパス計算中に考慮するように、コンストレイントベース ルーティングを変更します。

IETF 標準機能(Cisco IOS Release 12.2(33)SRB 以降)が追加されたことによって、ネットワークでは 3 つの異なる組み合せ、つまり「モード」で DS-TE を実行できます。これにより、ネットワークを IETF 標準フォーマットに移行するとき、進行中のトラフィック サービスが低下しないようにできます。次に、これら 3 つの状況、つまりモードの概要を示します。

1. 最初、つまり「従来」(IETF 標準以前)のモード 。これは、シスコが数年前に導入した DS-TE の形式をすでに稼動させているネットワークを表します。このようなネットワークでは、新しい Release 12.2(33)SRB およびそれ以降のリリースを使用する場合でも、この従来のモードを引き続き稼動させることができます。

2. 「移行」、つまり組み合せモード 。従来の DS-TE をすでに実行しており、IETF 標準にアップグレードするネットワークでは、最初にルータを移行モードに設定する必要があります。これにより、トンネルを切断しないで、DS-TE の稼動を継続できます。移行モードのルータは、従来の形式の場合と同様に、引き続き IGP およびトンネル シグナリングを生成しますが、TE クラス マッピングを追加し、従来のフォーマットと新しい IETF 標準フォーマットの両方のアドバタイズメントを受け入れるようになります。

3. 「リベラル IETF」モード 。すでに移行モードで稼動しているネットワークは、ルータをこの柔軟(したがって「リベラル」)な組み合せに再設定することによって、IETF フォーマットに移行できます。それ以降、ルータは新しい IETF 標準に従って IGP アドバタイズメントおよびトンネル シグナリングを生成しますが、引き続き従来のフォーマットおよび新しい IETF フォーマットのアドバタイズメントを受け入れることができます。

表 2 に、3 つのモード間の相違点の概要を示します。

表 2 DS-TE モードの動作の概要

TE クラス マッピング
を使用
生成
処理
モード
IGP
アドバタイズメント
RSVP-TE
シグナリング
IGP
アドバタイズメント
RSVP-TE
シグナリング
従来

なし

従来

従来

従来 1

従来

移行

あり

従来

従来

従来および IETF

従来および IETF

リベラル IETF

あり

IETF

従来および IETF

従来および IETF

従来および IETF

 
1 従来のモードは IGP の観点から受け入れる内容に関してリベラルになることはできません。これは、従来のモードでは TE クラス マッピングを使用しないため、サブプールのサブ TLV が存在しない場合に、IETF 準拠の方法で「未予約帯域幅」を解釈できないためです。

利点

DiffServ 対応トラフィック エンジニアリングを使用すると、サービス プロバイダーは、トラフィックの個別のサブセット(たとえば、音声トラフィックとデータ トラフィック)に対して、アドミッション制御とルート計算を個別に実行できます。

このため、DS-TE を他の IOS 機能(QoS など)と組み合せることによって、サービス プロバイダーは次のことを行うことができます。

プロビジョニングされた QoS ではなく、 シグナリングされた QoS に基づいて、エンド カスタマー用の QoS サービスを開発する。

オーバープロビジョニングを行うことなく、高収益をもたらす「厳格なコミットメントの」QoS サービスを構築する。

仮想 IP 専用線、レイヤ 2 サービス エミュレーション、およびポイントツーポイントの保証帯域幅サービス(音声トランキングを含む)を提供する。

MPLS によって提供されるスケーラビリティ プロパティを利用する。

関連機能およびテクノロジー

DS-TE 機能は、OSPF、IS-IS、RSVP(Resource reSerVation Protocol; リソース予約プロトコル)、QoS、および MPLS トラフィック エンジニアリングに関連します。次の項に、これらの全機能に関するシスコのマニュアルのリストを示します。

関連資料

ここでは、MPLS トラフィック エンジニアリング - DiffServ 対応(DS-TE)機能に関する関連資料について説明します。

 

サポートされる規格

従来(IETF 標準以前)のバージョンの DiffServ 対応 MPLS トラフィック エンジニアリングは、次の 2 つのマニュアルに記載されている説明に準拠します。

Requirements for Support of Diff-Serv-aware MPLS Traffic Engineering 』( 著者: F.Le Faucheur、T.Nadeau、A.Chiu、W.Townsend、D.Skalecki、および M.Tatham)

Protocol Extensions for Support of Diff-Serv-aware MPLS Traffic Engineering 』( 著者: F.Le Faucheur、T.Nadeau、J.Boyle、K.Kompella、W.Townsend、および D.Skalecki)

DiffServ 対応 MPLS トラフィック エンジニアリング用の IETF 標準については、次の 4 つのマニュアルで説明されています。

Multi-Protocol Label Switching (MPLS) Support of Differentiated Services 』( 著者: F.Le Faucheur、L.Wu、B.Davie、P.Vaananen、R.Krishnan、P.Cheval、および J.Heinanen)(RFC 3270)

Protocol Extensions for Support of Diffserv-aware MPLS Traffic Engineering 』( 編集者: F.Le Faucheur)(RFC 4124)

Russian Dolls Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering 』( 編集者: F.Le Faucheur)(RFC 4127)

Maximum Allocation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering 』( 著者: F.Le Faucheur および W.Lai)(RFC 4125)

IETF 標準で定義されている「クラス タイプ」の新しい概念は、DS-TE の最初のバージョンに実装されていた「帯域幅プール」の旧概念に対応します。同様に、DS-TE の最初のバージョンに実装されていた 2 つの帯域幅プール(グローバル プールとサブプール)は、IETF 標準の新しいクラス タイプの 2 つ(それぞれクラス タイプ 0 とクラス タイプ 1)に対応します。

前提条件

DiffServ 対応トラフィック エンジニアリングに基づく保証帯域幅サービスをサポートするには、ネットワークで次の Cisco IOS 機能がサポートされている必要があります。

MPLS

IP Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)

OSPF または ISIS

RSVP-TE

QoS

設定作業

ここでは、DiffServ 対応トラフィック エンジニアリング機能を実装する、つまりサブプール (IETF 標準では BC1 と呼ばれる) に対して帯域幅を予約するトンネルを確立するために必要な最小限のコマンド セットについて説明します。

後述の「設定例」 設定例 )では、実際の状況の中でこれらと同じコマンドを示し、これらを QoS コマンドと組み合せることによって保証帯域幅サービスを構築する方法について説明しています。

従来のコマンドから IETF 標準コマンドへ

最初の DS-TE コマンドは、MPLS トラフィック エンジニアリングを設定するために当時使用されていた既存のコマンド セットを基準にして開発されました。そのとき DS-TE を作成するために導入された唯一の違いは、次の 2 つのコマンドの拡張です。

ip rsvp bandwidth は、すべてのリンクでサブプールのサイズを設定できるように拡張されました。

tunnel mpls traffic-eng bandwidth は、TE トンネルでサブプールに対して帯域幅を予約できるように拡張されました。

ip rsvp bandwidth コマンド

初期の MPLS コマンドは次のようなものでした。

ip rsvp bandwidth x y

ここで、x は使用可能な唯一のプールのサイズ、y は(トラフィック エンジニアリングでは無視される)単一トラフィック フローのサイズです。

そのあと、DS-TE の最初の実装を作成するために、コマンドは次のように変更されました。

ip rsvp bandwidth x y sub-pool z

ここで、x はグローバル プールのサイズ、z はサブプールのサイズです。

IETF 標準バージョンの DS-TE を追加することによって、コマンドはさらに拡張され、次のようになりました。

ip rsvp bandwidth x y [ [rdm x {subpool z | bc1 z}] | [mam bc0 x bc1 z]]

ここで、x はグローバル プール(現在は bc0 と呼ばれる)のサイズ、z はサブプール(現在は bc1 とも呼ばれる)のサイズです。

「マトリョーシカ」(キーワード rdm で指定)および「最大割り当て」( mam )の 2 つの帯域幅制約モデルも使用可能になりました。前者のモデルではすべてのクラス タイプ(帯域幅プール)間で帯域幅を高度に共有でき、後者のモデルでは特に premium クラス タイプを保護します(IETF 標準により、LSP ごとに 1 つのサブプールを実装する代わりに、1 つの LSP 内に 7 つのサブプールをさらに実装することが可能になります)。

tunnel mpls traffic-eng bandwidth コマンド

DS-TE 以前のトラフィック エンジニアリング コマンドは次のようなものでした。

tunnel mpls traffic-eng bandwidth b

ここで、b は対象のトンネルで必要になる帯域幅の量です。

したがって、最初の DS-TE では、トンネルの帯域幅をどのプール(グローバルまたはサブ)から得るかを指定していました。次のように入力すると、

tunnel mpls traffic-eng bandwidth sub-pool b

トンネルではサブプールから帯域幅が使用されるようになります。または、次のように入力すると、

tunnel mpls traffic-eng bandwidth b

トンネルではグローバル プールから帯域幅が使用されるようになります(デフォルト)。

IETF 標準バージョンの DS-TE を追加することによって、コマンドは拡張され、次のようになりました。

tunnel mpls traffic-eng bandwidth [sub-pool|class-type 1] b

ここで、 sub-pool class-type 1 ではどちらも、同じ小さな帯域幅プール(現在はクラス タイプ 1 と呼ばれる)を指定します。2 つのキーワードは互いに切り替えて使用できます。

mpls traffic-eng ds-te コマンド

IETF 標準により、2 つの新しいコマンドが導入されています。1 つは、次のように帯域幅制約モデルを指定するものです。

mpls traffic-eng ds-te bc-model [rdm | mam]
 

もう 1 つは、次のように DS-TE モードを選択するものです。

mpls traffic-eng ds-te mode [migration|ietf]
 

(帯域幅制約モデルと DS-TE モードの概念については、 帯域幅制約モデルの機能 で説明されています)

1 つめのコマンドでは、帯域幅制約の Russian Dolls Model( rdm ; マトリョーシカ モデル)と最大割り当てモデル( mam )のいずれかを選択できます。

2 つめのコマンドでは、トンネルの動作を妨げることなく、従来の DS-TE トンネルから IETF 標準にネットワークを移行できます。このことを行うには、最初に( migration キーワードを使用して)ルータを移行モードにし、次に( ietf キーワードを使用して)リベラル IETF モードにします。

IETF 標準へのネットワークの移行

IETF 標準以前の従来のソフトウェアを使用して DS-TE トンネルをすでに稼動させているネットワークは、DS-TE サービスを中断しないで、IETF 標準に切り替えることができます。このことを行うには、次の手順を実行します。

1. ネットワーク内の各ルータに Cisco IOS Release 12.2(33)SRB(またはそれ以降のリリース)をインストールします。このとき、進行中のネットワーク トラフィックの中断を防止するシスコの In Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)手順を使用して、一度に 1 ルータずつ段階的に処理します(インストール後、ネットワーク内の DS-TE トンネルは、IETF 標準以前のフォーマットを使用して引き続き動作します)。

2. ネットワーク内の各ルータ(一度に 1 ルータずつ)にグローバル コンフィギュレーション コマンド mpls traffic-eng ds-te mode migration を入力します。これにより、ルータが IETF フォーマットの IGP アドバタイズメントおよび RSVP-TE シグナリングを受信できるようになります。ただし、ルータはこれら 2 つの機能の標準以前のフォーマットを引き続き生成および受信します。

3. ネットワーク内のすべてのルータが移行モードでの動作を開始したら、各ルータ(一度に 1 ルータずつ)にグローバル コンフィギュレーション コマンド mpls traffic-eng ds-te mode ietf を入力します。これにより、ルータは、トンネルの動作を妨げることなく、IETF 準拠のパス シグナリングを使用して TE トンネルを更新するようになります。また、このモードでは、ルータは IETF 標準フォーマットの IGP アドバタイズメントを生成します。

DS-TE トンネルの設定

サブプール(BC1)トラフィック エンジニアリング トンネルを確立するには、次の 3 つのレベルで設定を入力する必要があります。

デバイス レベル(ルータまたはスイッチ ルータ)

物理インターフェイス

トンネル インターフェイス

最初の 2 つのレベルでは、トラフィック エンジニアリングをアクティブにします。3 つめのレベル(トンネル インターフェイス)では、サブプール トンネルを確立します。したがって、3 つすべてのレベルを設定する必要があるのは、トンネル ヘッドエンド デバイスだけです。トンネルのミッドポイントおよびテールでは、最初の 2 つのレベルを設定するだけで十分です。

後述の各表で、各コマンドについて簡潔に説明しています。コマンドの詳細を確認するには、Command Lookup Tool( http://www.cisco.com/cgi-bin/Support/Cmdlookup/home.pl )に目的のコマンドを入力してください(ログインが要求されたら、Cisco.com アカウントのユーザ名とパスワードを使用してください)。

レベル 1:デバイスの設定

このレベルでは、デバイス(ルータまたはスイッチ ルータ)に対して、加速パケット転送(シスコ エクスプレス フォワーディングまたは CEF と呼ばれる)、MultiProtocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)、トラフィック エンジニアリング トンネリング、帯域幅制約モデル、および OSPF または IS-IS ルーティング アルゴリズム(Open Shortest Path First または Intermediate System to Intermediate System)のいずれかを使用するように指示します。このレベルはグローバル コンフィギュレーション モードと呼ばれます。これは、特定のインターフェイスまたはルーティング インスタンスではなく、デバイス全体にグローバルに設定が適用されるためです。

次のコマンドを入力します。

コマンド
目的

ステップ 1

Router(config)# ip cef distributed

CEF をイネーブルにします。これにより、デバイスを通過するパケットのフローが加速されます。

ステップ 2

Router(config)# mpls traffic-eng tunnels

MPLS、具体的にはそのトラフィック エンジニアリング トンネル機能をイネーブルにします。

ステップ 3

Router(config)# mpls traffic-eng ds-te bc-model [rdm | mam ]

帯域幅制約モデルを指定します( 帯域幅制約モデルの機能 を参照)。

ステップ 4

Router(config)# router ospf
 
 
[または]
Router(config)# router isis
 

IP 用の OSPF ルーティング プロセスを呼び出し、デバイスをルータ コンフィギュレーション モードにします。ステップ 10 および 11 に進みます。

 

または、このコマンドで IS-IS ルーティング プロセスを呼び出し、ステップ 5 に進むこともできます。

ステップ 5

Router (config-router)# net network-entity-title

ルーティング プロセスの IS-IS Network Entity Title(NET)を指定します。

ステップ 6

Router (config-router)# metric-style wide

ルータで IS-IS の新スタイルの Type, Length, Value(TLV; タイプ、長さ、値)オブジェクトを生成して受け入れるようにします。

ステップ 7

Router (config-router)# is-type level- n

独自のエリア、つまり「IS-IS レベル」内の宛先について学習するようにルータを設定します。

ステップ 8

Router (config-router)# mpls traffic-eng level- n

ルータが MPLS トラフィック エンジニアリングのリンク情報をフラッディングする IS-IS レベルを指定します(前の手順と同じレベルにする必要があります)。

ステップ 9

Router (config-router)# passive-interface loopback0

ループバック インターフェイスで IS-IS を実際に実行することなく、そのインターフェイスの IP アドレスをアドバタイズするように IS-IS に指示します。ステップ 10 に進みます。ただし、ステップ 11 は OSPF に関するものであるため、実行しないでください。

ステップ 10

Router(config-router)# mpls traffic-eng router-id loopback0

トラフィック エンジニアリング ルータ識別子が、 loopback0 インターフェイスに関連付けられている IP アドレスになるように指定します。

ステップ 11

Router(config-router)# mpls traffic-eng area num

特定の OSPF エリアに対して MPLS トラフィック エンジニアリングをオンにします。

レベル 2:物理インターフェイスの設定

デバイスの設定後、トンネルが通過するそのデバイスにインターフェイスを設定する必要があります。このことを行うには、最初にルータをインターフェイス コンフィギュレーション モードにします。

次に、Resource Reservation Protocol(RSVP; リソース予約プロトコル)をイネーブルにします。このプロトコルは、トラフィック エンジニアリング トンネルに対してシグナリング(設定)を行い、トンネル パスに沿ったデバイスに対して、そのトンネルを通過するトラフィック用に一定量の帯域幅を予約するように指示するために使用されます。このコマンドでは、 サブプール(BC1) の最大サイズも設定します。

最後に、この物理インターフェイスで MPLS トラフィック エンジニアリング トンネル機能をイネーブルにします。また、IS-IS ルーティング プロトコルを利用する場合は、同様にイネーブルにします。

これらの作業を実行するには、次のコマンドを入力します。

コマンド
目的

ステップ 1

Router(config)# interface interface-id

設定をインターフェイス レベルに移動し、後続のコンフィギュレーション コマンドを、 interface-id で識別された特定のインターフェイスに指定します。

ステップ 2

Router(config-if)# ip rsvp bandwidth [ interface-kbps ] [ single-flow-kbps ][[ rdm kbps {[ subpool kbps ]|[ bc1 subpool ]}]|[ mam max-reservable-bw kbps bc0 kbps bc1 kbps ]]

 

このインターフェイスで RSVP をイネーブルにし、使用する帯域幅制約モデル( 帯域幅制約モデルの機能 を参照)を指定し、RSVP がこのインターフェイスで予約できる帯域幅の量を制限します。このインターフェイス上のすべてのトンネルで使用される帯域幅の合計は、 interface-kbps を超えることはできません。

ステップ 3

Router(config-if)# mpls traffic-eng tunnels

このインターフェイスで MPLS トラフィック エンジニアリング トンネル機能をイネーブルにします。

ステップ 4

Router(config-if)# ip router isis

このインターフェイスで IS-IS ルーティング プロトコルをイネーブルにします。OSPF に対する設定では、このコマンドを入力しないでください。

レベル 3:トンネル インターフェイスの設定

ここでは、トンネル自体の一連のアトリビュートを作成します。これらのアトリビュートは「トンネル インターフェイス」に設定されます(上記で設定したばかりの物理インターフェイスと混同しないでください)。

次のコマンドを入力します。

コマンド
目的

ステップ 1

Router(config)# interface tunnel1

トンネル インターフェイス(この例では tunnel1 )を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# tunnel destination A.B.C.D

トンネル テール デバイスの IP アドレスを指定します。

ステップ 3

Router(config-if)# tunnel mode mpls traffic-eng

トンネルのカプセル化モードを MPLS トラフィック エンジニアリングに設定します。

ステップ 4

Router(config-if)# tunnel mpls traffic-eng bandwidth { sub-pool | class-type1 } bandwid th

トンネルの帯域幅を設定し、それをサブプール(そのキーワードまたは IETF 標準キーワード class-type1 を使用した場合)またはグローバル プール(両方のキーワードを省略した場合)のいずれかに割り当てます。

ステップ 5

Router(config-if)# tunnel mpls traffic-eng priority

システムでプリエンプションの対象とする既存のトンネルを決定するときに使用するプライオリティを設定します。

ステップ 6

Router(config-if)# tunnel mpls traffic-eng path-option

トンネルで使用するパス(ホップ)を設定します。ユーザは、明示パスを入力するか(ホップの IP アドレスを指定できます)、ダイナミック パスを指定できます(ルータが最良のホップのセットを割り出します)。

設定の確認

入力した設定全体を表示するには、EXEC コマンド show running-config を使用します。出力が表示されたら、その内容が正しいかどうかを確認します。

1 つのトンネル の設定 を確認するには、 show interfaces tunnel に続けてトンネル インターフェイス番号を入力します。また、そのトンネルの RSVP 帯域幅とフローを確認するには、 show ip rsvp interface に続けて物理インターフェイスの名前または番号を入力します。

次に、上記 2 つのコマンドによって表示される情報の例を示します(次の出力で使用されている各フィールドの説明を確認するには、Command Lookup Tool( http://www.cisco.com/cgi-bin/Support/Cmdlookup/home.pl )に show interfaces tunnel または show ip rsvp interface を入力します。ログインが要求されたら、Cisco.com アカウントのユーザ名とパスワードを使用してください)。

Router#show interfaces tunnel 4
Tunnel4 is up, line protocol is down
Hardware is Routing Tunnel
MTU 1500 bytes, BW 9 Kbit, DLY 500000 usec, rely 255/255, load 1/255
Encapsulation TUNNEL, loopback not set, keepalive set (10 sec)
Tunnel source 0.0.0.0, destination 0.0.0.0
Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
Last input never, output never, output hang never
Last clearing of “show interface” counters never
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
Five minute input rate 0 bits/sec, 0 packets/sec
Five minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets, 0 restarts
 
Router#show ip rsvp interface pos4/0
interface allocated i/f max flow max sub max
PO4/0 300K 466500K 466500K 0M

 

設定したルータ上の すべてのトンネルをまとめて 表示するには、 show mpls traffic-eng tunnels brief を入力します。トンネルが適切に機能している場合は、次のような情報が表示されます。

Router#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 3029 seconds
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
GSR1_t0 192.168.1.13 - SR3/0 up/up
GSR1_t1 192.168.1.13 - SR3/0 up/up
GSR1_t2 192.168.1.13 - PO4/0 up/up
Displayed 3 (of 3) heads, 0 (of 0) midpoints, 0 (of 0) tails

 

1 つまたは複数のトンネルが適切に機能していない場合は、代わりに次のような情報が表示されます(次の例では、右端のカラムに示されているように、トンネル t0 および t1 がダウンしています)。

Router#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 2279 seconds
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
GSR1_t0 192.168.1.13 - SR3/0 up/down
GSR1_t1 192.168.1.13 - SR3/0 up/down
GSR1_t2 192.168.1.13 - PO4/0 up/up
Displayed 3 (of 3) heads, 0 (of 0) midpoints, 0 (of 0) tails
 

トンネルがダウンしている 理由 を調べるには、同じコマンドにキーワード name を追加し、キーワード brief を省略してから、トンネルの名前を挿入します。例を示します。

Router#show mpls traffic-eng tunnels name GSR1_t0
Name:GSR1_t0 (Tunnel0) Destination:192.168.1.13
Status:
Admin:up Oper:down Path: not valid Signalling:connected
 

この例のように、パスが not valid と表示されている場合は、 show mpls traffic-eng topology コマンドを使用して、ルータが必要なアップデートを受信しているかどうかを確認します。

また、次の show コマンドのいずれかを使用して、関連するネットワーク、ルータ、またはインターフェイスの特定の側面を検査できます。

表示する情報
使用するコマンド
レベル
項目

ネットワーク

アドバタイズされた帯域幅割り当て情報

show mpls traffic-eng link-management advertisements

トンネル パスに沿ったプリエンプション

debug mpls traffic-eng link-management preemption

すべてのヘッド ルータ上の使用可能 TE リンク帯域幅

show mpls traffic-eng topology 用語集 を参照)。

ルータ

対象のルータによって現在シグナリングされているすべてのトンネルのステータス

show mpls traffic-eng link-management admission-control

ミッドポイント ルータ上に設定されているトンネル

show mpls traffic-eng link-management summary

物理インターフェイス

現在の帯域幅プールに関する詳細情報

show mpls traffic-eng link-management bandwidth-allocation [ interface-name ]

TE RSVP ブックキーピング

show mpls traffic-eng link-management interfaces

1 つのインターフェイスの設定全体

show run interface

設定例


) 次の 25 ページでは、IETF 標準以前の従来のモードにおける DS-TE の例を示します。これらの例は簡単にアップデートできます。その場合、新しいデバイス レベル コマンド mpls traffic-eng ds-te bc-model を挿入し(適切な使用方法については、Router(config)# mpls traffic-eng ds-te bc-model [rdm | mam ] のステップ 3 を参照してください)、変更した 2 つのコマンド内でアップデート後の構文を適用します(物理インターフェイス レベルでの適用方法については Router(config-if)# ip rsvp bandwidth [interface-kbps] [single-flow-kbps][[rdm kbps{[subpool kbps]|[bc1 subpool]}]|[mam max-reservable-bw kbps bc0 kbps bc1 kbps]] のステップ 2(ip rsvp bandwidth)、トンネル インターフェイス レベルでの適用方法については Router(config-if)# tunnel mpls traffic-eng bandwidth {sub-pool|class-type1} bandwidth のステップ 4(tunnel mpls traffic-eng bandwidth)をそれぞれ参照してください)。


ここでは、最初に、サブプール トンネルを作成するために必要な DS-TE 設定を示します。次に、エンドツーエンドの保証帯域幅サービスを構築するためのより包括的な設計(サービス品質の設定も含む)を示します。

図 1 に示すように、トンネルの設定には少なくとも 3 つのデバイス(トンネル ヘッド、ミッドポイント、およびテール)が関係します。これらの各デバイスでは、トラフィックの入力および出力用に 1 つまたは 2 つのネットワーク インターフェイスを設定する必要があります。

図 1 トンネル トポロジの例

トンネル ヘッド

デバイス レベルで、次のように入力します。

router-1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 
router-1(config)# ip cef distributed
router-1(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-1(config)# router isis
router ospf 100
router-1(config-router)# net 49.0000.1000.0000.0010.00
redistribute connected
router-1(config-router)# metric-style wide
network 10.1.1.0 0.0.0.255 area 0
router-1(config-router)# is-type level-1
network 22.1.1.1 0.0.0.0 area 0
router-1(config-router)# mpls traffic-eng level-1
mpls traffic-eng area 0
router-1(config-router)# passive-interface Loopback0
 

(ここで、共通のコマンド セットを再開します)

router-1(config-router)# mpls traffic-eng router-id Loopback0
router-1(config-router)# exit
 
router-1(config)# interface Loopback0

 

仮想インターフェイス レベルで、次のように入力します。

router-1(config-if)# ip address 22.1.1.1 255.255.255.255
router-1(config-if)# no ip directed-broadcast
router-1(config-if)# exit

 

デバイス レベルで、次のように入力します。

router-1(config)# interface POS2/0/0

 

物理インターフェイス レベル(出力)で、次のように入力します。

router-1(config-if)# ip address 10.1.1.1 255.255.255.0
router-1(config-if)# mpls traffic-eng tunnels
router-1(config-if)# ip rsvp bandwidth 130000 130000 sub-pool 80000
[and if using IS-IS instead of OSPF]:
router-1(config-if)# ip router isis
[and in all cases]:
router-1(config-if)# exit

 

デバイス レベルで、次のように入力します。

router-1(config)# interface Tunnel1

 

トンネル インターフェイス レベルで、次のように入力します。

router-1(config-if)# bandwidth 110000
router-1(config-if)# ip unnumbered Loopback0
router-1(config-if)# tunnel destination 24.1.1.1
router-1(config-if)# tunnel mode mpls traffic-eng
router-1(config-if)# tunnel mpls traffic-eng priority 0 0
router-1(config-if)# tunnel mpls traffic-eng bandwidth sub-pool 30000
router-1(config-if)# tunnel mpls traffic-eng path-option 1 dynamic
router-1(config-if)# exit
router-1(config)#

 

ミッドポイント デバイス

デバイス レベルで、次のように入力します。

router-2# configure terminal
router-2(config)# ip cef distributed
router-2(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-2(config)# router isis
router ospf 100
router-2(config-router)# net 49.0000.1000.0000.0012.00
redistribute connected
router-2(config-router)# metric-style wide
network 11.1.1.0 0.0.0.255 area 0
router-2(config-router)# is-type level-1
network 12.1.1.0 0.0.0.255 area 0
router-2(config-router)# mpls traffic-eng level-1
network 25.1.1.1 0.0.0.0 area 0
router-2(config-router)# passive-interface Loopback0
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開します)

router-2(config-router)# mpls traffic-eng router-id Loopback0
router-2(config-router)# exit
 
router-2(config)# interface Loopback0

 

仮想インターフェイス レベルで、次のように入力します。

router-2(config-if)# ip address 25.1.1.1 255.255.255.255
router-2(config-if)# no ip directed-broadcast
router-2(config-if)# exit

 

デバイス レベルで、次のように入力します。
router-1(config)# interface POS4/0
router-1(config-if)# ip address 11.1.1.2 255.255.255.0
router-1(config-if)# mpls traffic-eng tunnels
router-1(config-if)# ip rsvp bandwidth 130000 130000 sub-pool 80000
 

(OSPF の代わりに IS-IS を使用する場合)

router-1(config-if)# ip router isis
[and in all cases]:
router-1(config-if)# exit
 
デバイス レベルで、次のように入力します。
router-1(config)# interface POS4/1
router-1(config-if)# ip address 12.1.1.2 255.255.255.0
router-1(config-if)# mpls traffic-eng tunnels
router-1(config-if)# ip rsvp bandwidth 130000 130000 sub-pool 80000
 

(OSPF の代わりに IS-IS を使用する場合)

router-1(config-if)# ip router isis
[and in all cases]:
router-1(config-if)# exit

 

ミッドポイント デバイスでのトンネル インターフェイスの設定、ネットワーク インターフェイスだけの設定、およびデバイスのグローバルな設定はないことに注意してください。

テールエンド デバイス

デバイス レベルで、次のように入力します。

router-3# configure terminal
router-3(config)# ip cef distributed
router-3(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-3(config)# router isis
router ospf 100
router-3(config-router)# net 49.0000.1000.0000.0013.00
redistribute connected
router-3(config-router)# metric-style wide
network 12.1.1.0 0.0.0.255 area 0
router-3(config-router)# is-type level-1
network 24.1.1.1 0.0.0.0 area 0
router-3(config-router)# mpls traffic-eng level-1
mpls traffic-eng area 0
router-3(config-router)# passive-interface Loopback0
 

(ここで、共通のコマンド セットを再開します)

router-3(config-router)# mpls traffic-eng router-id Loopback0
router-3(config-router)# exit
 
router-3(config)# interface Loopback0

 

仮想インターフェイス レベルで、次のように入力します。

router-3(config-if)# ip address 24.1.1.1 255.255.255.255
router-3(config-if)# no ip directed-broadcast
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit

 

デバイス レベルで、次のように入力します。
router-1(config)# interface POS4/0
router-1(config-if)# ip address 12.1.1.3 255.255.255.0
router-1(config-if)# mpls traffic-eng tunnels
router-1(config-if)# ip rsvp bandwidth 130000 130000 sub-pool 80000
 

(OSPF の代わりに IS-IS を使用する場合)

router-1(config-if)# ip router isis
[and in all cases]:
router-1(config-if)# exit

保証帯域幅サービスの設定

2 つの帯域幅プールを設定すると、次のことが可能になります。

厳格な帯域幅保証または遅延保証を必要とするトラフィックを伝送するトンネル用に、一方のプールであるサブプールを使用する。

ディファレンシエーテッド サービスだけを必要とするトラフィックを伝送するトンネル用に、もう一方のプールであるグローバル プールを使用する。

厳格な保証を必要とするトラフィック用に個別のプールを使用すると、このようなトラフィックを特定のリンクで許可する量を制限できます。多くの場合、厳格な QoS 保証を実現できるのは、保証トラフィックの量が合計リンク帯域幅の一部に制限されている場合だけです。

他のトラフィック(ベストエフォート型のトラフィックまたは DiffServ トラフィック)用に個別のプールを使用すると、このようなトラフィックを特定のリンクで許可する量を個別に制限できます。このようにすると、ベストエフォート型のトラフィックまたは DiffServ トラフィックでリンクをいっぱいにすることができ、その結果としてこれらのリンクの使用率が高まるため便利です。

DS-TE サブプール トンネルを使用した厳格な QoS 保証の実現

次のすべての作業を実行すると、サブプール帯域幅を使用するトンネルで、より厳格な要件を満たすことができるようになります。

1. 厳格な保証トラフィックで排他的に使用されるキューを選択します(DiffServ 用語では、Per-Hop Behavior(PHB)を選択します)。このキューを「GB キュー」と呼びます。

遅延/ジッタ保証が要求される場合は、DiffServ Expedited Forwarding キュー(EF PHB)が使用されます。Cisco 7500(VIP) では、これは「プライオリティ」キューです。キューの帯域幅は、少なくともサブプールの帯域幅と等しくなるように設定する必要があります。

帯域幅保証だけが要求される場合は、DiffServ Assured Forwarding PHB(AF PHB)が使用されます。Cisco 7500(VIP) では、既存の Class-Based Weighted Fair Queuing(CBWFQ; クラスベース WFQ)キューのいずれかを使用します。

2. サブプール トンネルを介して送信される保証トラフィックが すべてのトンネル ホップの発信インターフェイスで GB キューに入れられ、他のトラフィックはこのキューに入れられないようにします。

このことを行うには、トンネルに入るトラフィックを MPLS EXP ビット フィールドの固有の値でマーク付けし、このようにマーク付けしたトラフィックだけを GB キューにステアリングします。

3. この GB キューがオーバーサブスクライブされないようにします。つまり、GB キューで処理できる量のトラフィックだけがサブプール トンネルに送信されるようにします。

このことを行うには、保証トラフィックがサブプール トンネルに入る前に、そのトラフィックをレート制限します。サブプール トンネルに入るすべてのトラフィックの集約レートは、サブプール トンネルの帯域幅容量以下にする必要があります。超過トラフィックはドロップするか(遅延/ジッタ保証の場合)、優先廃棄用に別のマークを付けることができます(帯域幅保証の場合)。

4. GB キューに入れられるトラフィックの量が、対応する発信リンクの合計帯域幅に対する適切なパーセンテージに制限されるようにします。使用する正確なパーセンテージは、ネットワークの累積遅延に関係するいくつかの要因によって決まります。この要因には、QoS パフォーマンス目標、トンネル ホップの合計数、トンネル パスに含まれるリンク数、入力トラフィックのバースト性などがあります。

このことを行うには、各発信リンクのサブプール帯域幅を合計リンク帯域幅に対する適切なパーセンテージに設定します(つまり、 ip rsvp bandwidth コマンドの z パラメータを調整します)。

DS-TE グローバル プール トンネルを使用したディファレンシエーテッド サービスの実現

グローバル プール帯域幅を使用するトンネルは、ベストエフォート型のトラフィックに加え、他のいくつかのクラスのトラフィックを伝送するように設定できます。次のすべての作業を実行すると、各クラスのトラフィックでディファレンシエーテッド サービスを受信できるようになります。

1. トラフィック クラスごとに個別のキュー(個別の DiffServ PHB)を選択します。たとえば、3 つのクラス(gold、silver、および bronze)が存在する場合、3 つのキュー(DiffServ AF2、AF3、および AF4)が必要です。

2. MPLS EXP ビット フィールドの固有の値を使用してトラフィックの各クラスをマーク付けします(たとえば、gold = 4、silver = 5、bronze = 6)。

3. Gold とマーク付けされたパケットは gold キューに入れられ、Silver とマーク付けされたパケットは silver キューに入れられるようにします。その他も同様です。トンネル帯域幅は、すべてのサービス クラスにおける集約トラフィックの予測値に基づいて設定されます。

特定のリンクでサポートする DiffServ トンネル トラフィックの量を制御するには、該当するリンクのグローバル プールのサイズを調整します。

同一ネットワークでの厳格保証およびディファレンシエーテッド サービスの実現

DS-TE を使用すると、サブプール トンネルおよびグローバル プール トンネルのコンストレイントベース ルーティングを同時に実行できるため、特定のネットワーク内で厳格保証と DiffServ を同時にサポートできます。

保証帯域幅サービスの例

多くのトポロジで保証帯域幅サービスを適用できますが、ここでは 2 つの例だけを示します。これらの例は、可能性の範囲の点で正反対です。

最初の例では、保証帯域幅トンネルはその宛先によって簡単に指定できます。したがって、転送基準は 1 つの送信先プレフィクスになります。

2 つめの例では、保証帯域幅トラフィックの最終宛先は多数存在することがあり、送信先プレフィクス数もダイナミックに変更されます。したがって、転送基準は Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ポリシーによって指定されます。

送信先プレフィクスが 1 つの場合の例

図 2 に、保証帯域幅サービスの宛先が 1 つのプレフィクスによって指定される場合のトポロジを示します。プレフィクスは、サイト D(音声ゲートウェイなど、ここではプレフィクス 26.1.1.1)またはサブネット(Web ファームの場所など、ここではプレフィクス 26.1.1.0 の「Province」)のいずれかです。次の 3 つのサービスが提供されます。

サイト A からのトラフィック(インターフェイス FE4/1/0 に着信するすべてのトラフィックとして定義):ホスト 26.1.1.1 を宛先とし、低損失、低遅延、および低ジッタの 8 Mbps の保証帯域幅を持つ。

サイト B からのトラフィック(インターフェイス FE4/1/1 に着信するすべてのトラフィックとして定義):サブネット 26.1.1.0 を宛先とし、低損失の 32 Mbps の保証帯域幅を持つ。

サイト C からのトラフィック(インターフェイス FE2/1/0 に着信するすべてのトラフィックとして定義):低損失の 30 Mbps の保証帯域幅を持つ。

図 2 1 つの送信先プレフィクスに対する保証帯域幅サービスを実現する場合のトポロジの例

これら 3 つのサービスは、次の 2 つのサブプール トンネルを通過します。

ヘッド-1 ルータ(23.1.1.1)からルータ-4 テールまで

ヘッド-2 ルータ(22.1.1.1)からルータ-4 テールまで

ヘッドは異なりますが、両方のトンネルで同じテール ルータが使用されています(図 2 では、1 つのミッドポイント ルータが両方のトンネルで共有されています。実際には、より多くのミッドポイントが存在する場合があります)。

この例の POS インターフェイスはすべて OC3 で、容量は 155 Mbps です。

トンネル ヘッド-1 の設定

最初に、2 つの帯域幅プールとサブプール トンネルを確立するコマンドを再び使用します(この「設定例」の項の前半部分を参照)。次に、サブプール トンネルでエンドツーエンドのサービスを保証する QoS コマンドを示します(7500 ルータでは、Modular QoS CLI が使用されます)。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-1(config)# ip cef distributed
router-1(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-1(config)# router isis
router ospf 100
router-1(config-router)# net 49.0000.1000.0000.0010.00
redistribute connected
router-1(config-router)# metric-style wide
network 10.1.1.0 0.0.0.255 area 0
router-1(config-router)# is-type level-1
network 23.1.1.1 0.0.0.0 area 0
router-1(config-router)# mpls traffic-eng level-1
mpls traffic-eng area 0
router-1(config-router)# passive-interface Loopback0
 

(ここで、共通のコマンド セットを再開します)

router-1(config-router)# mpls traffic-eng router-id Loopback0
router-1(config-router)# exit
 

仮想インターフェイスを作成します。

router-1(config)# interface Loopback0
router-1(config-if)# ip address 23.1.1.1 255.255.255.255
router-1(config-if)# no ip directed-broadcast
router-1(config-if)# exit
 

発信物理インターフェイスで、次のように入力します。

router-1(config)# interface pos4/0
router-1(config-if)# ip address 10.1.1.1 255.0.0.0
router-1(config-if)# mpls traffic-eng tunnels
router-1(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-1(config-if)# ip router isis
[and in all cases}:
router-1(config-if)# exit
 

トンネル インターフェイスで、次のように入力します。

router-1(config)# interface Tunnel1
router-1(config-if)# bandwidth 110000
router-1(config-if)# ip unnumbered Loopback0
router-1(config-if)# tunnel destination 27.1.1.1
router-1(config-if)# tunnel mode mpls traffic-eng
router-1(config-if)# tunnel mpls traffic-eng priority 0 0
router-1(config-if)# tunnel mpls traffic-eng bandwidth sub-pool 40000
router-1(config-if)# tunnel mpls traffic-eng path-option 1 dynamic
 

ホスト 26.1.1.1 およびサブネット 26.1.1.0 を宛先としたパケットがサブプール トンネルに送信されるようにするために、スタティック ルートを作成します。デバイス レベルで、次のように入力します。

router-1(config)# ip route 26.1.1.0 255.255.255.0 Tunnel1
router-1(config)# exit
 

また、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)からこのトンネルに他のトラフィックが送信されないようにするために、自動ルート アナウンスをディセーブルにします。

router-1(config)# no tunnel mpls traffic-eng autoroute announce
 

サイト A からサイト D へのサービスの場合

着信物理インターフェイス(FE4/1/0)で、次のように入力します。

1. グローバル コンフィギュレーション モードで、ACL 100 と一致するトラフィックのクラス 「sla-1-class」を作成します。

class-map match-all sla-1-class
match access-group 100
 

2. 26.1.1.1 を宛先としたすべてのパケットを参照する ACL 100 を作成します。

access-list 100 permit ip any host 26.1.1.1
 

3. 「sla-1-input-policy」という名前のポリシーを作成します。このポリシーの内容は次のとおりです。

a. クラス「sla-1-class」のパケットは、次のようにレート制限されます。

- ビット レート 800 万ビット/秒

- 標準バースト 100 万バイト

- 最大バースト 200 万バイト

b. このレートに準拠するパケットは、MPLS EXP ビット 5 でマーク付けされてから転送されます。

c. このレートを超過するパケットはドロップされます。

d. 他のすべてのパケットは、EXP ビット 0 でマーク付けされてから転送されます。

policy-map sla-1-input-policy
class sla-1-class
police 8000000 1000000 2000000 conform-action set-mpls-exp-transmit 5 \ exceed-action drop
class class-default
set-mpls-exp-transmit 0
 

4. ポリシーは、インターフェイス FE4/1/0 に入るパケットに適用されます。

interface FastEthernet4/1/0
service-policy input sla-1-input-policy
 

サイト B からサブネット「Province」へのサービスの場合

着信物理インターフェイス(FE4/1/1)で、次のように入力します。

1. グローバル コンフィギュレーション モードで、ACL 120 と一致するトラフィックのクラス 「sla-2-class」を作成します。

class-map match-all sla-2-class
match access-group 120
 

2. サブネット 26.1.1.0 を宛先としたすべてのパケットを参照する ACL 120 を作成します。

access-list 120 permit ip any 26.1.1.0 0.0.0.255
 

3. 「sla-2-input-policy」という名前のポリシーを作成します。このポリシーの内容は次のとおりです。

a. クラス「sla-2-class」のパケットは、次のようにレート制限されます。

- ビット レート 3200 万ビット/秒

- 標準バースト 100 万バイト

- 最大バースト 200 万バイト

b. このレートに準拠するパケットは、MPLS EXP ビット 5 でマーク付けされてから転送されます。

c. このレートを超過するパケットはドロップされます。

d. 他のすべてのパケットは、EXP ビット 0 でマーク付けされてから転送されます。

policy-map sla-2-input-policy
class sla-2-class
police 32000000 1000000 2000000 conform-action set-mpls-exp-transmit 5 \ exceed-action drop
class class-default
set-mpls-exp-transmit 0
 

4. ポリシーは、インターフェイス FE4/1/1 に入るパケットに適用されます。

interface FastEthernet4/1/1
service-policy input sla-2-input-policy

両方のサービスの場合

発信インターフェイス(POS4/0)を次のように設定します。

1. グローバル コンフィギュレーション モードで、EXP ビット 5 と一致するトラフィックのクラス 「exp-5-traffic」を作成します。

class-map match-all exp-5-traffic
match mpls experimental 5
 

2. 「output-interface-policy」という名前のポリシーを作成します。このポリシーに従って、クラス 「exp-5-traffic」のパケットはプライオリティ キューに入れられます(62 キロビット/秒にレート制限されます)。

policy-map output-interface-policy
class exp-5-traffic
priority 32
 

3. ポリシーは、インターフェイス POS4/0 から出るパケットに適用されます。

interface POS4/0
service-policy output output-interface-policy
 

上記の設定行の結果として、インターフェイス FE4/1/0 を介してヘッド-1 ルータに入り、ホスト 26.1.1.1 を宛先としたパケット、およびインターフェイス FE4/1/1 を介してルータに入り、サブネット 26.1.1.0 を宛先としたパケットの MPLS EXP ビットは 5 に設定されます。(すべてのインターフェイスで)ルータに入る他のパケットではこの値は使用されていないものと仮定します(このことを仮定できない場合は、他の設定を追加して、このようなパケットをすべて別の EXP 値でマーク付けする必要があります)。EXP ビット 5 でマーク付けされたパケットは、インターフェイス POS4/0 を介してルータから出るとき、プライオリティ キューに入れられます。


) FE4/1/0 または FE4/1/1 を介してルータに入り、POS4/0 から出るパケットは、IP パケットとして入り、MPLS パケットとして出ます。


トンネル ヘッド-2 の設定

最初に、2 つの帯域幅プールとサブプール トンネルを確立するコマンドを再び使用します(この「設定例」の項の前半部分を参照)。次に、サブプール トンネルでエンドツーエンドのサービスを保証する QoS コマンドを示します。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-2(config)# ip cef distributed
router-2(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-2(config)# router isis
router ospf 100
router-2(config-router)# net 49.0000.1000.0000.0011.00
redistribute connected
router-2(config-router)# metric-style wide
network 11.1.1.0 0.0.0.255 area 0
router-2(config-router)# is-type level-1
network 22.1.1.1 0.0.0.0 area 0
router-2(config-router)# mpls traffic-eng level-1
mpls traffic-eng area 0
router-2(config-router)# passive-interface Loopback0
 

(ここで、共通のコマンド セットを再開します)

router-2(config-router)# mpls traffic-eng router-id Loopback0
router-2(config-router)# exit
 

仮想インターフェイスを作成します。

router-2(config)# interface Loopback0
router-2(config-if)# ip address 22.1.1.1 255.255.255.255
router-2(config-if)# no ip directed broadcast
router-2(config-if)# exit
 

発信物理インターフェイスで、次のように入力します。

router-2(config)# interface pos0/0
router-2(config-if)# ip address 11.1.1.1 255.0.0.0
router-2(config-if)# mpls traffic-eng tunnels
router-2(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-2(config-if)# ip router isis
[and in all cases]:
router-2(config-if)# exit
 

トンネル インターフェイスで、次のように入力します。

router-2(config)# interface Tunnel2
router-2(config-if)# ip unnumbered Loopback0
router-2(config-if)# tunnel destination 27.1.1.1
router-2(config-if)# tunnel mode mpls traffic-eng
router-2(config-if)# tunnel mpls traffic-eng priority 0 0
router-2(config-if)# tunnel mpls traffic-eng bandwidth sub-pool 30000
router-2(config-if)# tunnel mpls traffic-eng path-option 1 dynamic
router-2(config-if)# exit
 

次に、サブネット 26.1.1.0 を宛先としたパケットがサブプール トンネルに送信されるようにするために、デバイス レベルでスタティック ルートを作成します。

router-2(config)# ip route 26.1.1.0 255.255.255.0 Tunnel2
router-2(config)# exit
 

最後に、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)からこのトンネルに他のトラフィックが送信されないようにするために、自動ルート アナウンスをディセーブルにします。

router-2(config)# no tunnel mpls traffic-eng autoroute announce
 

サイト C からサブネット「Province」へのサービスの場合

着信物理インターフェイス(FE2/1/0)で、次のように入力します。

1. グローバル コンフィギュレーション モードで、ACL 130 と一致するトラフィックのクラス 「sla-3-class」を作成します。

class-map match-all sla-3-class
match access-group 130
 

2. サブネット 26.1.1.0 を宛先としたすべてのパケットを参照する ACL 130 を作成します。

access-list 130 permit ip any 26.1.1.0 0.0.0.255
 

3. 「sla-3-input-policy」という名前のポリシーを作成します。このポリシーの内容は次のとおりです。

a. クラス「sla-3-class」のパケットは、次のようにレート制限されます。

- ビット レート 3000 万ビット/秒

- 標準バースト 100 万バイト

- 最大バースト 200 万バイト

b. このレートに準拠するパケットは、MPLS EXP ビット 5 でマーク付けされてから転送されます。

c. このレートを超過するパケットはドロップされます。

d. 他のすべてのパケットは、EXP ビット 0 でマーク付けされてから転送されます。

policy-map sla-3-input-policy
class sla-3-class
police 30000000 1000000 2000000 conform-action set-mpls-exp-transmit 5 \ exceed-action drop
class class-default
set-mpls-exp-transmit 0
 

4. ポリシーは、インターフェイス FE2/1/0 に入るパケットに適用されます。

interface FastEthernet2/1/0
service-policy input sla-3-input-policy
 

発信インターフェイス POS0/0 を次のように設定します。

1. グローバル コンフィギュレーション モードで、EXP ビット 5 と一致するトラフィックのクラス 「exp-5-traffic」を作成します。

class-map match-all exp-5-traffic
match mpls experimental 5
 

2. 「output-interface-policy」という名前のポリシーを作成します。このポリシーに従って、クラス 「exp-5-traffic」のパケットはプライオリティ キューに入れられます(32 キロビット/秒にレート制限されます)。

policy-map output-interface-policy
class exp-5-traffic
priority 32
 

3. ポリシーは、インターフェイス POS0/0 から出るパケットに適用されます。

interface POS0/0
service-policy output output-interface-policy

 

上記のすべての設定行の結果として、インターフェイス FE2/1/0 を介してヘッド-2 ルータに入り、サブネット 26.1.1.0 を宛先としたパケットの IP precedence フィールドは 5 に設定されます。(すべてのインターフェイスで)このルータに入る他のパケットではこの precedence は使用されていないものと仮定します(このことを仮定できない場合は、他の設定を追加して、このようなパケットをすべて別の precedence 値でマーク付けする必要があります)。precedence 5 でマーク付けされたパケットは、インターフェイス POS0/0 を介してこのルータから出るとき、プライオリティ キューに入れられます。


) FE2/1/0 を介してルータに入り、POS0/0 を介してルータから出るパケットは、IP パケットとして入り、MPLS パケットとして出ます。


トンネル ミッドポイントの設定(ミッドポイント-1)

ミッドポイント ルータの 4 つのインターフェイスはすべて、ヘッド ルータの発信インターフェイスと同じように設定します(ただし、個々のインターフェイスの ID を除きます)。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-3(config)# ip cef distributed
router-3(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-3(config)# router isis
router ospf 100
router-3(config-router)# net 49.0000.2400.0000.0011.00
redistribute connected
router-3(config-router)# metric-style wide
network 10.1.1.0 0.0.0.255 area 0
router-3(config-router)# is-type level-1
network 11.1.1.0 0.0.0.255 area 0
router-3(config-router)# mpls traffic-eng level-1
network 24.1.1.1 0.0.0.0 area 0
router-3(config-router)# passive-interface Loopback0
network 12.1.1.0 0.0.0.255 area 0
router-3(config-router)#
network 13.1.1.0 0.0.0.255 area 0
router-3(config-router)#
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開します)

router-3(config-router)# mpls traffic-eng router-id Loopback0
router-3(config-router)# exit
 

仮想インターフェイスを作成します。

router-3(config)# interface Loopback0
router-3(config-if)# ip address 24.1.1.1 255.255.255.255
router-3(config-if)# exit
 

物理インターフェイス レベル(入力)で、次のように入力します。

router-3(config)# interface pos2/1
router-3(config-if)# ip address 10.1.1.2 255.0.0.0
router-3(config-if)# mpls traffic-eng tunnels
router-3(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit
 
router-3(config)# interface pos1/1
router-3(config-if)# ip address 11.1.1.2 255.0.0.0
router-3(config-if)# mpls traffic-eng tunnels
router-3(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit
 

物理インターフェイス レベル(出力)で、次のように入力します。

router-3(config)# interface pos3/1
router-3(config-if)# ip address 12.1.1.1 255.0.0.0
router-3(config-if)# mpls traffic-eng tunnels
router-3(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit
 
router-3(config)# interface pos4/1
router-3(config-if)# ip address 13.1.1.1 255.0.0.0
router-3(config-if)# mpls traffic-eng tunnels
router-3(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit
 

トンネル ミッドポイントの設定(ミッドポイント-2)

ミッドポイント ルータのインターフェイスは、両方とも、ヘッド ルータの発信インターフェイスと同じように設定します(ただし、個々のインターフェイスの ID を除きます)。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-5(config)# ip cef distributed
router-5(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-5(config)# router isis
router ospf 100
router-5(config-router)# net 49.2500.1000.0000.0012.00
redistribute connected
router-5(config-router)# metric-style wide
network 13.1.1.0 0.0.0.255 area 0
router-5(config-router)# is-type level-1
network 14.1.1.0 0.0.0.255 area 0
router-5(config-router)# mpls traffic-eng level-1
network 25.1.1.1 0.0.0.0 area 0
router-5(config-router)# passive-interface Loopback0
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開します)

router-5(config-router)# mpls traffic-eng router-id Loopback0
router-5(config-router)# exit
 

仮想インターフェイスを作成します。

router-5(config)# interface Loopback0
router-5(config-if)# ip address 25.1.1.1 255.255.255.255
router-5(config-if)# exit
 

物理インターフェイス レベル(入力)で、次のように入力します。

router-5(config)# interface pos1/1
router-5(config-if)# ip address 13.1.1.2 255.0.0.0
router-5(config-if)# mpls traffic-eng tunnels
router-5(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-5(config-if)# ip router isis
[and in all cases]:
router-5(config-if)# exit
 

物理インターフェイス レベル(出力)で、次のように入力します。

router-5(config)# interface pos2/1
router-5(config-if)# ip address 14.1.1.1 255.0.0.0
router-5(config-if)# mpls traffic-eng tunnels
router-5(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-5(config-if)# ip router isis
[and in all cases]:
router-5(config-if)# exit
 

トンネル テールの設定

テール ルータの着信インターフェイスは、ミッドポイント ルータの着信インターフェイスと同じように設定します(ただし、特定の各インターフェイスの ID を除きます)。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-4(config)# ip cef distributed
router-4(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-4(config)# router isis
router ospf 100
router-4(config-router)# net 49.0000.2700.0000.0000.00
redistribute connected
router-4(config-router)# metric-style wide
network 12.1.1.0 0.0.0.255 area 0
router-4(config-router)# is-type level-1
network 14.1.1.0 0.0.0.255 area 0
router-4(config-router)# mpls traffic-eng level-1
network 27.1.1.1 0.0.0.0 area 0
router-4(config-router)# passive-interface Loopback0
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開します)

router-4(config-router)# mpls traffic-eng router-id Loopback0
router-4(config-router)# exit
 

仮想インターフェイスを作成します。

router-4(config)# interface Loopback0
router-4(config-if)# ip address 27.1.1.1 255.255.255.255
router-4(config-if)# exit
 

物理インターフェイス(入力)で、次のように入力します。

router-4(config)# interface pos2/1
router-4(config-if)# ip address 12.1.1.2 255.0.0.0
router-4(config-if)# mpls traffic-eng tunnels
router-4(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-4(config-if)# ip router isis
[and in all cases]:
router-4(config-if)# exit
 
router-4(config)# interface pos2/2
router-4(config-if)# ip address 14.1.1.2 255.0.0.0
router-4(config-if)# mpls traffic-eng tunnels
router-4(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-4(config-if)# ip router isis
[and in all cases]:
router-4(config-if)# exit
 

トンネルはテールで終端するため(トンネルにはテール ルータの発信インターフェイスは含まれないため)、発信 QoS 設定は使用されません。

多数の送信先プレフィクスが存在する場合の例

図 3 に、保証帯域幅サービスの宛先が一連のプレフィクスである場合のトポロジを示します。通常、これらのプレフィクスには、同じ Autonomous System(AS; 自律システム)に属していることや、同じ AS で中継されることなど、いくつかの共通のプロパティがあります。ダウンストリーム自律システム内のルート フラップが原因で個々のプレフィクスがダイナミックに変更される可能性がありますが、プレフィクスの共通のプロパティは変更されません。送信先プレフィクス セットをアドレス指定するポリシーは、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を通して強制されます。詳細については、次のマニュアルを参照してください。

Cisco IOS Quality of Service Solutions Configuration Guide 』(Release 12.1)の「Configuring QoS Policy Propagation via Border Gateway Protocol」(http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_c/qcprt1/qcdprop.htm)

Cisco IOS IP and IP Routing Configuration Guide 』(Release 12.1)の「Configuring BGP」(http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c/ipcprt2/1cdbgp.htm)

Cisco IOS IP and IP Routing Command Reference 』(Release 12.1)の「BGP Commands」(http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_r/iprprt2/1rdbgp.htm)

Cisco IOS Quality of Service Solutions Command Reference 』(Release 12.1)の「BGP-Policy Command」(http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_r/qrdcmd1.htm
#xtocid89313)

この例では、次の 3 つの保証帯域幅サービスが提供されます。これらの各サービスは、7500 または 12000 エッジ デバイスを通過します。

AS5 を宛先としてサイト A から発信されるトラフィック(インターフェイス FE4/1/0 に着信するすべてのトラフィックとして定義)とサイト C から発信されるトラフィック(インターフェイス FE2/1 に着信するすべてのトラフィックとして定義)。

サイト A および C から発信され、AS5 を宛先ではなく中継点として使用するトラフィック(図では、中継トラフィックは AS6 および AS7 に伝送されます)。

サイト A および C から発信され、特定の BGP コミュニティ アトリビュート(100:1)でアドバタイズされるプレフィクスを宛先としたトラフィック。この例では、自律システム #3、#5、および #8 には、BGP コミュニティによってアトリビュート 100:1 が割り当てられています。

図 3 多くの送信先プレフィクスに対する保証帯域幅サービスを実現する場合のトポロジの例

保証帯域幅サービスの適用性は、上記の 3 種類の複数宛先シナリオに限定されません。このマニュアルでは、考えられるすべてのシナリオに関する説明は省略しています。これら 3 つは、考えられる広範な展開の代表として選定されたものです。

保証帯域幅サービスは、次の 2 つのサブプール トンネルを通過します。

ヘッド-1 ルータ(23.1.1.1)からテールまで

ヘッド-2 ルータ(22.1.1.1)から同じテールまで

また、同じ宛先にベストエフォート型のトラフィックを伝送するように、各ヘッドエンドからグローバル プール トンネルが設定されています。4 台のルータでは、ヘッド、およびミッドポイントからの経路が異なりますが、4 台すべてのルータで同じテール ルータが使用されています(実際には、ここに示す 2 つだけでなく、より多くのミッドポイントが存在します)。

この例の POS インターフェイスはすべて OC3 で、容量は 155 Mbps です。

複数宛先の保証帯域幅サービスの設定には次の作業を伴います。

a. サブプール MPLS-TE トンネルの構築

b. DiffServ QoS の設定

c. BGP による QoS ポリシー伝達の設定(QPPB)

d. トンネルへのトラフィックのマッピング

これらの作業はすべて次の例に含まれています。

トンネル ヘッド-1 の設定

最初に、サブプール トンネルを確立するコマンド(前半の P.設定例 で示したコマンド)を再び使用します。また、ここでは、グローバル プール トンネルも設定します。さらに、サブプール トンネルでエンドツーエンドのサービスを保証する QoS および BGP コマンドを示します(7500(VIP) ルータでは、Modular QoS CLI が使用されます)。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-1(config)# ip cef distributed
router-1(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-1(config)# router isis
router ospf 100
router-1(config-router)# net 49.0000.1000.0000.0010.00
redistribute connected
router-1(config-router)# metric-style wide
network 10.1.1.0 0.0.0.255 area 0
router-1(config-router)# is-type level-1
network 23.1.1.1 0.0.0.0 area 0
router-1(config-router)# mpls traffic-eng level-1
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開します)

router-1(config-router)# mpls traffic-eng router-id Loopback0
router-1(config-router)# exit
 

仮想インターフェイスを作成します。

router-1(config)# interface Loopback0
router-1(config-if)# ip address 23.1.1.1 255.255.255.255
router-1(config-if)# exit
 

発信物理インターフェイスで、次のように入力します。

router-1(config)# interface pos4/0
router-1(config-if)# ip address 10.1.1.1 255.0.0.0
router-1(config-if)# mpls traffic-eng tunnels
router-1(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-1(config-if)# ip router isis
[and in all cases]:
router-1(config-if)# exit
 

1 つめのトンネル インターフェイスで、サブプール トンネルを作成します。

router-1(config)# interface Tunnel1
router-1(config-if)# ip unnumbered Loopback0
router-1(config-if)# tunnel destination 27.1.1.1
router-1(config-if)# tunnel mode mpls traffic-eng
router-1(config-if)# tunnel mpls traffic-eng priority 0 0
router-1(config-if)# tunnel mpls traffic-eng bandwidth sub-pool 40000
router-1(config-if)# tunnel mpls traffic-eng path-option 1 explicit name gbs-path1
router-1(config-if)# exit
 

別のトンネル インターフェイスで、グローバル プール トンネルを作成します。

router-1(config)# interface Tunnel2
router-1(config-if)# ip unnumbered Loopback0
router-1(config-if)# tunnel destination 27.1.1.1
router-1(config-if)# tunnel mode mpls traffic-eng
router-1(config-if)# tunnel mpls traffic-eng priority 0 0
router-1(config-if)# tunnel mpls traffic-eng bandwidth 80000
router-1(config-if)# tunnel mpls traffic-eng path-option 1 explicit name \ best-effort-path1
router-1(config-if)# exit
 

この例では、ダイナミック パスではなく明示パスを使用して、ベストエフォート型のトラフィックおよび保証帯域幅トラフィックが別々のパスで伝送されるようにしています。

デバイス レベルで、次のように入力します。

router-1(config)# ip explicit-path name gbs-path1
router-1(config-ip-expl-path)# next-address 24.1.1.1
router-1(config-ip-expl-path)# next-address 27.1.1.1
router-1(config-ip-expl-path)# exit
router-1(config)# ip explicit-path name best-effort-path1
router-1(config-ip-expl-path)# next-address 24.1.1.1
router-1(config-ip-expl-path)# next-address 25.1.1.1
router-1(config-ip-expl-path)# next-address 27.1.1.1
router-1(config-ip-expl-path)# exit
 

自動ルートは使用されていないことに注意してください。自動ルートを使用すると、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)からこれらのトンネルに他のトラフィックが送信される可能性があるためです。

DiffServ QoS の設定

着信物理インターフェイス(図 3 では FE4/1/0)では、受信されるパケットは次のようにレート制限されます。

a. ビット レート 30 Mbps

b. 標準バースト 1 MB

c. 最大バースト 2 MB

qos-group 6 にマッピングされ、レート制限に準拠するパケットは、EXP 値 5 および BGP 宛先コミュニティ ストリングでマーク付けされてから転送されます。準拠しないパケットはドロップされます(超過アクション)。

router-1(config)# interface FastEthernet4/1/0
router-1(config-if)# rate-limit input qos-group 6 30000000 1000000 2000000 \ conform-action set-mpls-exp-transmit 5 exceed-action drop
router-1(config-if)# bgp-policy destination ip-qos-map
router-1(config-if)# exit
 

デバイス レベルで、MPLS EXP ビットが 5 に設定されたトラフィックのクラス「exp5-class」を作成します。

router-1(config)# class-map match-all exp5-class
router-1(config-cmap)# match mpls experimental 5
router-1(config-cmap)# exit
 

「exp5-class」のプライオリティ キューを作成するポリシーを作成します。

router-1(config)# policy-map core-out-policy
router-1(config-pmap)# class exp5-class
router-1(config-pmap-c)# priority 100000
router-1(config-pmap-c)# exit
router-1(config-pmap)# class class-default
router-1(config-pmap-c)# bandwidth 55000
router-1(config-pmap-c)# exit
router-1(config-pmap)# exit
 

ポリシーは、発信インターフェイス POS4/0 から出るパケットに適用されます。

router-1(config)# interface POS4/0
router-1(config-if)# service-policy output core-out-policy
 

BGP による QoS ポリシー伝達の設定

すべての GB サービスの場合

BGP で、プレフィクスを qos-group にマッピングする(結び付ける)テーブル マップを作成します。デバイス レベルで、次のように入力します。

router-1(config)# ip bgp-community new-format
router-1(config)# router bgp 2
router-1(config-router)# no synchronization
router-1(config-router)# table-map set-qos-group
router-1(config-router)# bgp log-neighbor-changes
router-1(config-router)# neighbor 27.1.1.1 remote-as 2
router-1(config-router)# neighbor 27.1.1.1 update-source Loopback0
router-1(config-router)# no auto-summary
router-1(config-router)# exit

AS5 を宛先とした GB サービスの場合

このサービス用に個別のルート マップを作成します。これには、29.1.1.1 と一致するパケットのネクストホップの設定が含まれます。このため、これらのパケットは、トンネル #1(保証帯域幅サービス トンネル)にマッピングされます。デバイス レベルで、次のように入力します。

router-1(config)# route-map set-qos-group permit 10
router-1(config-route-map)# match as-path 100
router-1(config-route-map)# set ip qos-group 6
router-1(config-route-map)# set ip next-hop 29.1.1.1
router-1(config-route-map)# exit
router-1(config)# ip as-path access-list 100 permit ^5$

AS5 で中継される GB サービスの場合

このサービス用に個別のルート マップを作成します。そのトラフィックは AS6 および AS7 に伝送されます。

デバイス レベルで、次のように入力します。

router-1(config)# route-map set-qos-group permit 10
router-1(config-route-map)# match as-path 101
router-1(config-route-map)# set ip qos-group 6
router-1(config-route-map)# set ip next-hop 29.1.1.1
router-1(config-route-map)# exit
router-1(config)# ip as-path access-list 101 permit _5_

コミュニティ 100:1 を宛先とした GB サービスの場合

コミュニティ値が 100:1 のプレフィクスを宛先としたすべてのトラフィック用に個別のルート マップを作成します。このトラフィックは AS3、AS5、および AS8 に伝送されます。

デバイス レベルで、次のように入力します。

router-1(config)# route-map set-qos-group permit 10
router-1(config-route-map)# match community 20
router-1(config-route-map)# set ip qos-group 6
router-1(config-route-map)# set ip next-hop 29.1.1.1
router-1(config-route-map)# exit
router-1(config)# ip community-list 20 permit 100:1

トンネルへのトラフィックのマッピング

すべての保証帯域幅トラフィックをトンネル #1 にマッピングします。

router-1(config)# ip route 29.1.1.1 255.255.255.255 Tunnel1
 

ベストエフォート型のすべてのトラフィックをトンネル #2 にマッピングします。

router-1(config)# ip route 30.1.1.1 255.255.255.255 Tunnel2

 

トンネル ヘッド-2 の設定

ヘッド-1 デバイスおよびインターフェイスと同様に、次のヘッド-2 設定では、最初にサブプール トンネルを確立するコマンド(前半の P.設定例 で示したコマンド)を使用し、次にグローバル プール トンネルも設定します。そのあと、サブプール トンネルでエンドツーエンドのサービスを保証する QoS および BGP コマンドを示します(これは 7500(VIP) ルータであるため、Modular QoS CLI が使用されます)。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-2(config)# ip cef distributed
router-2(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-2(config)# router isis
router ospf 100
router-2(config-router)# net 49.0000.1000.0000.0011.00
redistribute connected
router-2(config-router)# metric-style wide
network 11.1.1.0 0.0.0.255 area 0
router-2(config-router)# is-type level-1
network 22.1.1.1 0.0.0.0 area 0
router-2(config-router)# mpls traffic-eng level-1
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開します)

router-2(config-router)# mpls traffic-eng router-id Loopback0
router-2(config-router)# exit
 

仮想インターフェイスを作成します。

router-2(config)# interface Loopback0
router-2(config-if)# ip address 22.1.1.1 255.255.255.255
router-2(config-if)# exit
 

発信物理インターフェイスで、次のように入力します。

router-2(config)# interface pos0/0
router-2(config-if)# ip address 11.1.1.1 255.0.0.0
router-2(config-if)# mpls traffic-eng tunnels
router-2(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 60000
[and if using IS-IS instead of OSPF]:
router-2(config-if)# ip router isis
[and in all cases]:
router-2(config-if)# exit
 

1 つめのトンネル インターフェイスで、サブプール トンネルを作成します。

router-2(config)# interface Tunnel3
router-2(config-if)# ip unnumbered Loopback0
router-2(config-if)# tunnel destination 27.1.1.1
router-2(config-if)# tunnel mode mpls traffic-eng
router-2(config-if)# tunnel mpls traffic-eng priority 0 0
router-2(config-if)# tunnel mpls traffic-eng bandwidth sub-pool 30000
router-2(config-if)# tunnel mpls traffic-eng path-option 1 explicit name gbs-path2
router-2(config-if)# exit
 

別のトンネル インターフェイスで、グローバル プール トンネルを作成します。

router-2(config)# interface Tunnel4
router-2(config-if)# ip unnumbered Loopback0
router-2(config-if)# tunnel destination 27.1.1.1
router-2(config-if)# tunnel mode mpls traffic-eng
router-2(config-if)# tunnel mpls traffic-eng priority 0 0
router-2(config-if)# tunnel mpls traffic-eng bandwidth 70000
router-2(config-if)# tunnel mpls traffic-eng path-option 1 explicit name \ best-effort-path2
router-2(config-if)# exit
 

この例では、ダイナミック パスではなく明示パスを使用して、ベストエフォート型のトラフィックおよび保証帯域幅トラフィックが別々のパスで伝送されるようにしています。

デバイス レベルで、次のように入力します。

router-2(config)# ip explicit-path name gbs-path2
router-2(config-ip-expl-path)# next-address 24.1.1.1
router-2(config-ip-expl-path)# next-address 27.1.1.1
router-2(config-ip-expl-path)# exit
router-2(config)# ip explicit-path name best-effort-path2
router-2(config-ip-expl-path)# next-address 24.1.1.1
router-2(config-ip-expl-path)# next-address 25.1.1.1
router-2(config-ip-expl-path)# next-address 27.1.1.1
router-2(config-ip-expl-path)# exit
 

自動ルートは使用されていないことに注意してください。自動ルートを使用すると、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)からこれらのトンネルに他のトラフィックが送信される可能性があるためです。

DiffServ QoS の設定

着信物理インターフェイス(図 3 では FE2/1)では、受信されるパケットは次のようにレート制限されます。

a. ビット レート 30 Mbps

b. 標準バースト 1 MB

c. 最大バースト 2 MB

qos-group 6 にマッピングされ、レート制限に準拠するパケットは、EXP 値 5 および BGP 宛先コミュニティ ストリングでマーク付けされてから転送されます。準拠しないパケットはドロップされます(超過アクション)。

router-2(config)# interface FastEthernet2/1
router-2(config-if)# rate-limit input qos-group 6 30000000 1000000 2000000 \ conform-action set-mpls-exp-transmit 5 exceed-action drop
router-2(config-if)# bgp-policy destination ip-qos-map
router-1(config-if)# exit
 

デバイス レベルで、MPLS EXP ビットが 5 に設定されたトラフィックのクラス「exp5-class」を作成します。

router-2(config)# class-map match-all exp5-class
router-2(config-cmap)# match mpls experimental 5
router-2(config-cmap)# exit
 

「exp5-class」のプライオリティ キューを作成するポリシーを作成します。

router-2(config)# policy-map core-out-policy
router-2(config-pmap)# class exp5-class
router-2(config-pmap-c)# priority 100000
router-2(config-pmap-c)# exit
router-2(config-pmap)# class class-default
router-2(config-pmap-c)# bandwidth 55000
router-2(config-pmap-c)# exit
router-2(config-pmap)# exit
 

ポリシーは、インターフェイス POS0/0 から出るパケットに適用されます。

interface POS0/0
service-policy output core-out-policy

 

上記のすべての設定行の結果として、インターフェイス FE2/1 を介してヘッド-2 ルータに入り、AS5 または BGP コミュニティ 100:1 を宛先とするか、AS5 で中継されるパケットの EXP フィールドは 5 に設定されます。(すべてのインターフェイスで)このルータに入る他のパケットではこの EXP ビット値は使用されていないものと仮定します(このことを仮定できない場合は、他の設定を追加して、このようなパケットをすべて別の EXP 値でマーク付けする必要があります)。EXP 値 5 でマーク付けされたパケットは、インターフェイス POS0/0 を介してこのルータから出るとき、プライオリティ キューに入れられます。


) FE2/1 を介してルータに入り、POS0/0 を介してルータから出るパケットは、IP パケットとして入り、MPLS パケットとして出ます。


BGP による QoS ポリシー伝達の設定

すべての GB サービスの場合

BGP で、プレフィクスを qos-group にマッピングする(結び付ける)テーブル マップを作成します。デバイス レベルで、次のように入力します。

router-2(config)# ip bgp-community new-format
router-2(config)# router bgp 2
router-2(config-router)# no synchronization
router-2(config-router)# table-map set-qos-group
router-2(config-router)# bgp log-neighbor-changes
router-2(config-router)# neighbor 27.1.1.1 remote-as 2
router-2(config-router)# neighbor 27.1.1.1 update-source Loopback0
router-2(config-router)# no auto-summary
router-2(config-router)# exit

AS5 を宛先とした GB サービスの場合

このサービス用に個別のルート マップを作成します。これには、29.1.1.1 と一致するパケットのネクストホップの設定が含まれています。このため、これらのパケットは、トンネル #3(保証帯域幅サービス トンネル)にマッピングされます。デバイス レベルで、次のように入力します。

router-2(config)# route-map set-qos-group permit 10
router-2(config-route-map)# match as-path 100
router-2(config-route-map)# set ip qos-group 6
router-2(config-route-map)# set ip next-hop 29.1.1.1
router-2(config-route-map)# exit
router-2(config)# ip as-path access-list 100 permit ^5$

AS5 で中継される GB サービスの場合

このサービス用に個別のルート マップを作成します。そのトラフィックは AS6 および AS7 に伝送されます。

デバイス レベルで、次のように入力します。

router-2(config)# route-map set-qos-group permit 10
router-2(config-route-map)# match as-path 101
router-2(config-route-map)# set ip qos-group 6
router-2(config-route-map)# set ip next-hop 29.1.1.1
router-2(config-route-map)# exit
router-2(config)# ip as-path access-list 101 permit _5_

コミュニティ 100:1 を宛先とした GB サービスの場合

コミュニティ値が 100:1 のプレフィクスを宛先としたすべてのトラフィック用に個別のルート マップを作成します。このトラフィックは AS3、AS5、および AS8 に伝送されます。

デバイス レベルで、次のように入力します。

router-2(config)# route-map set-qos-group permit 10
router-2(config-route-map)# match community 20
router-2(config-route-map)# set ip qos-group 6
router-2(config-route-map)# set ip next-hop 29.1.1.1
router-2(config-route-map)# exit
router-2(config)# ip community-list 20 permit 100:1

トンネルへのトラフィックのマッピング

すべての保証帯域幅トラフィックをトンネル #3 にマッピングします。

router-2(config)# ip route 29.1.1.1 255.255.255.255 Tunnel3
 

ベストエフォート型のすべてのトラフィックをトンネル #4 にマッピングします。

router-2(config)# ip route 30.1.1.1 255.255.255.255 Tunnel4

トンネル ミッドポイントの設定(ミッドポイント-1)

ミッドポイント ルータの 4 つのインターフェイスは、すべて、ヘッド ルータの発信インターフェイスとほぼ同じように設定します。ここでは、この自律システム内のすべてのミッドポイント ルータが、今後および現在設定済みのサブプールおよびグローバル プール トンネルを介して伝送できるようにします。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-3(config)# ip cef distributed
router-3(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-3(config)# router isis
router ospf 100
router-3(config-router)# net 49.0000.2400.0000.0011.00
redistribute connected
router-3(config-router)# metric-style wide
network 10.1.1.0 0.0.0.255 area 0
router-3(config-router)# is-type level-1
network 11.1.1.0 0.0.0.255 area 0
router-3(config-router)# mpls traffic-eng level-1
network 24.1.1.1 0.0.0.0 area 0
router-3(config-router)#
network 12.1.1.0 0.0.0.255 area 0
router-3(config-router)#
network 13.1.1.0 0.0.0.255 area 0
router-3(config-router)#
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開します)

router-3(config-router)# mpls traffic-eng router-id Loopback0
router-3(config-router)# exit
 

仮想インターフェイスを作成します。

router-3(config)# interface Loopback0
router-3(config-if)# ip address 24.1.1.1 255.255.255.255
router-3(config-if)# exit
 

物理インターフェイス レベル(入力)で、次のように入力します。

router-3(config)# interface pos2/1
router-3(config-if)# ip address 10.1.1.2 255.0.0.0
router-3(config-if)# mpls traffic-eng tunnels
router-3(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 70000
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit
 
router-3(config)# interface pos1/1
router-3(config-if)# ip address 11.1.1.2 255.0.0.0
router-3(config-if)# mpls traffic-eng tunnels
router-3(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 70000
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit
 

2 つのサブプール トンネルが現在出口として経由している物理インターフェイス レベル(出力)で、次のように入力します。

router-3(config)# interface pos3/1
router-3(config-if)# ip address 12.1.1.1 255.0.0.0
router-3(config-if)# mpls traffic-eng tunnels
router-3(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 70000
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit
 

2 つのグローバル プール トンネルが現在出口として経由している物理インターフェイス レベル(出力)で、次のように入力します。

router-3(config)# interface pos4/1
router-3(config-if)# ip address 13.1.1.1 255.0.0.0
router-3(config-if)# mpls traffic-eng tunnels
router-3(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 70000
[and if using IS-IS instead of OSPF]:
router-3(config-if)# ip router isis
[and in all cases]:
router-3(config-if)# exit

トンネル ミッドポイントの設定(ミッドポイント-2)

このミッドポイント ルータのインターフェイスは、両方とも、ミッドポイント-1 ルータの発信インターフェイスと同じように設定します。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-5(config)# ip cef distributed
router-5(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します)

router-5(config)# router isis
router ospf 100
router-5(config-router)# net 49.2500.1000.0000.0012.00
redistribute connected
router-5(config-router)# metric-style wide
network 13.1.1.0 0.0.0.255 area 0
router-5(config-router)# is-type level-1
network 14.1.1.0 0.0.0.255 area 0
router-5(config-router)# mpls traffic-eng level-1
network 25.1.1.1 0.0.0.0 area 0
router-5(config-router)#
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開します)

router-5(config-router)# mpls traffic-eng router-id Loopback0
router-5(config-router)# exit
 

仮想インターフェイスを作成します。

router-5(config)# interface Loopback0
router-5(config-if)# ip address 25.1.1.1 255.255.255.255
router-5(config-if)# exit
 

物理インターフェイス レベル(入力)で、次のように入力します。

router-5(config)# interface pos1/1
router-5(config-if)# ip address 13.1.1.2 255.0.0.0
router-5(config-if)# mpls traffic-eng tunnels
router-5(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 70000
[and if using IS-IS instead of OSPF]:
router-5(config-if)# ip router isis
[and in all cases]:
router-5(config-if)# exit
 

物理インターフェイス レベル(出力)で、次のように入力します。

router-5(config)# interface pos2/1
router-5(config-if)# ip address 14.1.1.1 255.0.0.0
router-5(config-if)# mpls traffic-eng tunnels
router-5(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 70000
[and if using IS-IS instead of OSPF]:
router-5(config-if)# ip router isis
[and in all cases]:
router-5(config-if)# exit
 

 

トンネル テールの設定

テール ルータの着信インターフェイスは、ミッドポイント ルータの発信インターフェイスとほぼ同じように設定します。

プールおよびトンネルの設定

デバイス レベルで、次のように入力します。

router-4(config)# ip cef distributed
router-4(config)# mpls traffic-eng tunnels

(ここで、左側の IS-IS コマンドまたは右側の OSPF コマンドのいずれかを使用します。OSPF の場合、2 つの新しいループバック インターフェイス(この例では 29.1.1.1 および 30.1.1.1)をアドバタイズする必要があります。これらは、このページの次の QoS ポリシー伝達に関する項で定義しています)

router-4(config)# router isis
router ospf 100
router-4(config-router)# net 49.0000.2700.0000.0000.00
redistribute connected
router-4(config-router)# metric-style wide
network 12.1.1.0 0.0.0.255 area 0
router-4(config-router)# is-type level-1
network 14.1.1.0 0.0.0.255 area 0
router-4(config-router)# mpls traffic-eng level-1
network 27.1.1.1 0.0.0.0 area 0
router-4(config-router)#
network 29.1.1.1 0.0.0.0 area 0
router-4(config-router)#
network 30.1.1.1 0.0.0.0 area 0
router-4(config-router)#
mpls traffic-eng area 0

(ここで、共通のコマンド セットを再開し、2 つの追加のループバック インターフェイスを慎重に含めます)

router-4(config-router)# mpls traffic-eng router-id Loopback0
router-4(config-router)# mpls traffic-eng router-id Loopback1
router-4(config-router)# mpls traffic-eng router-id Loopback2
router-4(config-router)# exit
 

仮想インターフェイスを作成します。

router-4(config)# interface Loopback0
router-4(config-if)# ip address 27.1.1.1 255.255.255.255
router-4(config-if)# exit
 

物理インターフェイス(入力)で、次のように入力します。

router-4(config)# interface pos2/1
router-4(config-if)# ip address 12.1.1.2 255.0.0.0
router-4(config-if)# mpls traffic-eng tunnels
router-4(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 70000
[and if using IS-IS instead of OSPF]:
router-4(config-if)# ip router isis
[and in all cases]:
router-4(config-if)# exit
 
router-4(config)# interface pos2/2
router-4(config-if)# ip address 14.1.1.2 255.0.0.0
router-4(config-if)# mpls traffic-eng tunnels
router-4(config-if)# ip rsvp bandwidth 140000 140000 sub-pool 70000
[and if using IS-IS instead of OSPF]:
router-4(config-if)# ip router isis
[and in all cases]:
router-4(config-if)# exit
 

QoS ポリシー伝達の設定

テール デバイスでは、ここで終端するサービス クラスごとに個別の仮想ループバック IP アドレスを設定する必要があります。ヘッドエンド ルータでは、トラフィックを適切なトンネルにマッピングするために、これらのアドレスが必要です。現在の例では、同じテール デバイスで 4 つのトンネルが終端しますが、これらが表しているサービス クラスは 2 つだけです。このため、追加のループバック アドレスは 2 つだけ必要となります。

2 つの仮想インターフェイスを作成します。

router-4(config)# interface Loopback1
router-4(config-if)# ip address 29.1.1.1 255.255.255.255
[and if using IS-IS instead of OSPF]:
router-4(config-if)# ip router isis
[and in all cases]:
router-4(config-if)# exit
router-4(config)# interface Loopback2
router-4(config-if)# ip address 30.1.1.1 255.255.255.255
[and if using IS-IS instead of OSPF]:
router-4(config-if)# ip router isis
[and in all cases]:
router-4(config-if)# exit
 

デバイス レベルで、コミュニティを各トンネル ヘッドに送信するように BGP を設定します。

router-4(config)# ip bgp-community new-format
router-4(config)# router bgp 2
router-4(config-router)# neighbor 23.1.1.1 send-community
router-4(config-router)# neighbor 22.1.1.1 send-community
router-4(config-router)# exit
 

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『 Cisco IOS Master Command List 』にアクセスしてください。

ip rsvp bandwidth

mpls traffic-eng ds-te bc-model

mpls traffic-eng ds-te mode

show mpls traffic-eng topology

tunnel mpls traffic-eng bandwidth

用語集

ここでは、すぐには理解しにくい略語および用語を定義しています。

AS :Autonomous System(自律システム)。共通の管理下にあり、共通のルーティング方針を共有し、固有の 16 ビット数値(インターネット割り当て番号局によって割り当てられる)で識別されるネットワークの集まりです。

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。主要なドメイン間ルーティング プロトコルです。これは RFC 1163 で定義されています。バージョン 4 では、ルート集約メカニズムを使用して、ルーティング テーブルのサイズが削減されます。

CBR :Constraint Based Routing(コンストレイントベース ルーティング)。ラベル スイッチド パス アトリビュートと現在のネットワーク リソース制限を同時に満たすトラフィック パスの計算です。

CEF :Cisco Express Forwarding(シスコ エクスプレス フォワーディング)。ルート参照情報を 1 つのルート キャッシュではなく複数のデータ構造に分けて保存することにより、ルータ内のパケットの転送を短時間で行うための手段。

CLI :Command Line Interface(コマンドライン インターフェイス)。ルータを設定および管理するためのシスコのインターフェイスです。

DS-TE :DiffServ-aware Traffic Engineering(DiffServ 対応トラフィック エンジニアリング)。各リンクに 2 つの帯域幅プール( グローバル プール サブプール )を設定するための機能です。サブプール帯域幅を使用する MPLS トラフィック エンジニアリング トンネルは、サービス品質メカニズムを使用してネットワーク上でエンドツーエンドの保証帯域幅サービスを実現するように設定できます。同時に、グローバル プールを使用するトンネルでは、DiffServ トラフィックを伝送できます。

GB キュー :Guaranteed Bandwidth(保証帯域幅)キュー。厳格な保証トラフィックで排他的に使用される Per-Hop Behavior(PHB)です。遅延/ジッタ保証が要求される場合は、DiffServ Expedited Forwarding キュー(EF PHB)が使用されます。帯域幅保証だけが要求される場合は、DiffServ Assured Forwarding PHB(AF PHB)が使用されます。

IGP :Interior Gateway Protocol(内部ゲートウェイ プロトコル)。自律システム内でのルーティング情報の交換に使用されるインターネット プロトコル。一般的なインターネット IGP の例として、IGRP、OSPF、および RIP を挙げることができます。

Label Switched Path(LSP; ラベル スイッチド パス)トンネル :パケットの伝送にラベル スイッチングが使用される、2 台のルータ間に設定された接続。

IS-IS :Intermediate System-to-Intermediate System。DECnet Phase V ルーティングに基づいたリンクステート階層型ルーティング プロトコルです。これにより、ノードは、単一のメトリックに基づいてルーティング情報を交換して、ネットワーク トポロジを決定します。

LCAC :Link-level(per-hop)Call Admission Control(リンクレベル(ホップ単位)のコール アドミッション制御)。

LSP :Label-Switched Path(ラベル スイッチド パス)(上記を参照)。
別用語として Link-State Packet(リンクステート パケット):リンクステート プロトコルで使用されるブロードキャスト パケット。このパケットには、ネイバーおよびパス コストに関する情報が含まれます。LSP は、受信側ルータでルーティング テーブルを維持するために使用されます。Link-State Advertisement(LSA; リンクステート アドバタイズメント)とも呼ばれます。

MPLS :Multi-Protocol Label Switching(マルチプロトコル ラベル スイッチング)(旧称タグ スイッチング)。レイヤ 3 ルーティングではなく、主にレイヤ 2 スイッチングを使用してパケットを送信する方式です。Forwarding Equivalence Class の概念を使用して、MPLS クラウドへの入力でパケットに短い固定長のラベルを割り当てます。MPLS ドメイン内では、元のパケット ヘッダーにほとんど頼ることなく、ラベルに基づいて転送判断が行われます。

MPLS TE :MPLS Traffic Engineering(MPLS トラフィック エンジニアリング)(以前は「RRR」、またはリソース予約ルーティングと呼ばれていました)。ラベル スイッチングを使用してトラフィック パフォーマンスを向上させるとともに、ネットワーク リソースが効率的に使用されるようにします。

OSPF :Open Shortest Path First。IS-IS プロトコルから派生したリンクステート階層型 IGP ルーティング アルゴリズムです。OSPF 機能には、最小コストによるルーティング、マルチパスのルーティング、およびロード バランシングが含まれます。

RSVP :Resource reSerVation Protocol(リソース予約プロトコル)。カスタマーが(インターネット サービスを確保するために)要求をシグナリングする際に使用する IETF プロトコルです。これにより、カスタマーはそのネットワーク部分を経由してデータを伝送することを許可されます。

TE :Traffic Engineering(トラフィック エンジニアリング)。トラフィックのパフォーマンスとネットワーク リソース利用の両方を同時に最適化することを目的としてインターネット トラフィックを測定、モデル化、および制御するために科学的な原理と技術を適用することを指します。

グローバル プール :MPLS トラフィック エンジニアリング リンクに割り当てられた合計帯域幅。

サブプール :MPLS トラフィック エンジニアリング リンクにおける、より限定的な帯域幅。サブプールは、リンクの全体的なグローバル プール帯域幅の一部です。

フラッディング :スイッチおよびブリッジで使用されるトラフィック伝送手法。インターフェイスで受信されたトラフィックは、そのデバイスのすべてのインターフェイス(最初に情報を受信したインターフェイスを除く)を介して送信されます。


) この用語集に記載されていない用語については、『Internetworking Terms and Acronyms』を参照してください。