マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS トラフィック エンジニアリング - 自動 トンネル メッシュ グループ
MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ
発行日;2012/01/30 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ

機能情報の確認

この章の構成

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの前提条件

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの制約事項

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループに関する情報

自動トンネル メッシュ グループの説明および利点

メッシュ トンネル インターフェイスのアクセス リスト

自動トンネル テンプレート インターフェイス

メッシュ グループ情報の OSPF フラッディング

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの設定方法

TE トンネル LSP の設定

自動トンネル メッシュ グループのグローバルなイネーブル化

名前を使用したアクセス リストの作成

自動トンネル テンプレート インターフェイスの作成

メッシュ トンネル インターフェイス番号の範囲の指定

トンネルに関する設定情報の表示

自動トンネル メッシュ ネットワークの監視

トラブルシューティングのヒント

自動トンネル メッシュ グループの IGP フラッディングの設定

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの設定例

TE トンネル LSP のメッシュの設定:例

自動トンネル メッシュ グループのグローバルなイネーブル化:例

名前を使用したアクセス リストの作成:例

自動トンネル テンプレート インターフェイスの作成:例

メッシュ トンネル インターフェイス番号の範囲の指定:例

自動トンネル メッシュ グループの IGP フラッディングの設定:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

用語集

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ機能を使用すると、ネットワーク管理者はいくつかの Command-Line Interface(CLI; コマンドライン インターフェイス)コマンドを使用して Traffic Engineering(TE; トラフィック エンジニアリング)Label Switched Path(LSP; ラベル スイッチド パス)を設定できます。

エッジ TE Label Switch Router(LSR; ラベル スイッチ ルータ)がコア LSR によって接続されているネットワーク トポロジでは、MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ機能により Provider Edge(PE; プロバイダー エッジ)ルータ間の TE LSP のメッシュが自動的に構成されます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

この章の構成

「MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの前提条件」

「MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの制約事項」

「MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループに関する情報」

「MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの設定方法」

「MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの設定例」

「その他の関連資料」

「MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの機能情報」

「用語集」

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの前提条件

MPLS TE に関する知識が必要です。「その他の関連資料」を参照してください。

自動トンネルの設定方法を決定してください(つまり、テンプレート インターフェイスに含めるトンネル コマンドを識別してください)。

メッシュ トンネル インターフェイス用として予約するアドレスのブロックを識別してください。

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの制約事項

メッシュ グループでは、エリア間トンネルはサポートされていません。これは、これらのトンネルの宛先がローカル エリア TE データベースに存在しないためです。

自動トンネル メッシュ グループ TE トンネルを介してトラフィックをルーティングするようにスタティック ルートを設定することはできません。トンネルの選択には自動ルートだけを使用する必要があります。

Intermediate System-to-System(IS-IS)では、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)によるメッシュ グループ情報の配布はサポートされていません。IS-IS の場合、Access Control List(ACL; アクセス コントロール リスト)だけを使用できます。

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループに関する情報

自動トンネル メッシュ グループを設定するには、次の概念を理解する必要があります。

「自動トンネル メッシュ グループの説明および利点」

「メッシュ トンネル インターフェイスのアクセス リスト」

「自動トンネル テンプレート インターフェイス」

「メッシュ グループ情報の OSPF フラッディング」

自動トンネル メッシュ グループの説明および利点

自動トンネル メッシュ グループ(メッシュ グループと呼ぶ)は、ネットワーク内のエッジ LSR 間の一連の接続です。次の 2 種類のメッシュ グループがあります。

完全:すべてのエッジ LSR が接続されます。各 PE ルータには、他の各 PE ルータへのトンネルがあります。

部分:一部のエッジ LSR はトンネルによって相互に接続されません。

エッジ TE LSR がコア LSR によって接続されているネットワーク トポロジでは、MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ機能により PE ルータ間の TE LSP のメッシュが自動的に構成されます。

最初に、最小限のコンフィギュレーション コマンドを使用して、既存の各 TE LSR をメッシュのメンバに設定する必要があります。ネットワークが拡大した場合(つまり、1 つまたは複数の TE LSR が PE ルータとしてネットワークに追加された場合)、そのメッシュの既存の TE LSR メンバを再設定する必要はありません。

メッシュ グループには、次の利点があります。

ネットワークの初期設定が最小限に抑えられます。メッシュごとに 1 つのテンプレート インターフェイスを設定します。必要に応じて、そのテンプレート インターフェイスがすべてのメッシュ トンネル インターフェイスに伝播されます。

今後のネットワークの拡大に伴って必要になる設定が最小限に抑えられます。この機能を使用すると、新しい PE ルータがネットワークに追加されたときに、完全メッシュの TE LSP を確立するように既存の各 TE LSR を再設定する必要がなくなります。

既存のルータで新しい PE ルータに対して TE LSP を設定できます。

PE ルータ間の TE LSP のメッシュを自動的に構成できます。

メッシュ トンネル インターフェイスのアクセス リスト

アクセス リストでは、メッシュ トンネル インターフェイスの宛先アドレスを決定します。これは、関連する IP アドレスのブロックを事前に割り当てる場合に役立ちます。そのアドレス ブロックを使用して、完全メッシュまたは部分メッシュの TE トンネル LSP が確立される PE ルータを制御できます。アクセス リストでは、学習され、TE トポロジ データベースに格納されるアドレスの一致だけが許可されます。

たとえば、すべての 10.1.1.1 IP アドレスと一致するアクセス リストを作成できます。アクセス リスト付きのテンプレートを設定すると、そのテンプレートによって、アクセス リスト内の宛先と一致する、TE トポロジ データベース内の宛先へのメッシュ トンネル インターフェイスが作成されます。

TE トポロジ データベースが更新されたとき(たとえば、新しい TE LSR が Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)に挿入されたとき)、常に宛先アドレスが IGP 内の各ルータの TE トポロジ データベースに格納されます。更新が行われるたびに、メッシュ グループ機能により、データベース内の宛先アドレスと、すべてのテンプレート インターフェイスに関連付けられているアクセス リスト内の IP アドレスが比較されます。一致が見つかった場合、メッシュ グループ機能によりトンネルの宛先 IP アドレスへのメッシュ トンネル インターフェイスが確立されます。

自動トンネル テンプレート インターフェイス

自動トンネル テンプレート インターフェイスは論理エンティティです。つまり、特定のトンネル インターフェイスに結合されていないトンネル インターフェイスの設定です。これは、必要に応じてダイナミックに適用できます。

メッシュ トンネル インターフェイスは、作成、ダイナミックな設定(たとえば、テンプレート インターフェイスの適用またはクローン作成による)、使用、および解放(不要になったとき)が順番に行われるトンネル インターフェイスです。

メッシュ トンネル インターフェイスはその設定情報をテンプレートから取得します。ただし、トンネルの宛先アドレスについては例外で、アクセス リストと一致する TE トポロジ データベースまたは IGP メッシュ グループ アドバタイズメントから取得されます。

テンプレート インターフェイスでは、コマンドをメッシュ グループごとに 1 回入力できます。これらのコマンドでは、メッシュ トンネル インターフェイスの作成方法を指定します。ネットワークに新しいルータが追加されるたびに、新しいメッシュ トンネル インターフェイスが作成されます。インターフェイスの設定はテンプレートから複製されます。各メッシュ トンネル インターフェイスには、テンプレート インターフェイスに設定されているパス制約と他のパラメータが同様に適用されます。異なるのはトンネルの宛先アドレスだけです。

メッシュ グループ情報の OSPF フラッディング

OSPF でメッシュ グループ情報をアドバタイズまたはフラッディングできるようにするには、OSPF でメッシュ グループを設定し、そのメッシュ グループを自動テンプレート インターフェイスに追加する必要があります。設定が完全な場合、OSPF はメッシュ グループ ID をすべての LSR にアドバタイズします。MPLS TE LSP は、各メッシュ グループ内のエッジ LSR を自動的に接続します。設定の詳細については、「自動トンネル メッシュ グループの IGP フラッディングの設定」を参照してください。

OSPF は、OSPF エリアのメッシュ グループ ID をアドバタイズできます。OSPF は、Cisco IOS 12.0(29)S、12.2(33)SRA、12.2(33)SXH、および 12.4(20)T リリースの MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ機能で唯一サポートされている IGP です。

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの設定方法

ここでは、次の各手順について説明します。

「TE トンネル LSP の設定」(必須)

「メッシュ トンネル インターフェイス番号の範囲の指定」(任意)

「トンネルに関する設定情報の表示」(任意)

「自動トンネル メッシュ ネットワークの監視」(必須)

「自動トンネル メッシュ グループの IGP フラッディングの設定」(任意)

TE トンネル LSP の設定

TE トンネル LSP のメッシュを設定するには、ネットワーク内の各 PE ルータで次の作業を実行します。

「自動トンネル メッシュ グループのグローバルなイネーブル化」

「名前を使用したアクセス リストの作成」

「自動トンネル テンプレート インターフェイスの作成」


) これらの作業は任意の順序で実行できます。


自動トンネル メッシュ グループのグローバルなイネーブル化

自動トンネル メッシュ グループをグローバルにイネーブルにするには、次の作業を実行します。この作業は、ネットワークで自動トンネル メッシュ グループに含めるすべての PE ルータで実行します。

手順の概要

1. enable

2. configure terminal

3. mpls traffic-eng auto-tunnel mesh

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls traffic-eng auto-tunnel mesh

 

Router(config)# mpls traffic-eng auto-tunnel mesh

自動トンネル メッシュ グループをグローバルにイネーブルにします。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

名前を使用したアクセス リストの作成

名前を使用してアクセス リストを作成するには、次の作業を実行します。

アクセス リストでは、メッシュ トンネル インターフェイスの宛先アドレスを決定します。アクセス リストを使用して、完全メッシュまたは部分メッシュの TE トンネル LSP が確立される PE ルータを制御できます。アクセス リストでは、学習され、TE トポロジ データベースに格納されるアドレスの一致だけが許可されます。

手順の概要

1. enable

2. configure terminal

3. ip access-list { standard | extended } access-list-name

4. permit source [ source-wildcard ]

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip access-list { standard | extended } access-list-name

 

Router(config)# ip access-list standard a1

名前を使用して IP アクセス リストを定義し、標準の名前付きアクセス リスト コンフィギュレーション モードを開始します。

standard キーワードでは、標準 IP アクセス リストを指定します。

extended キーワードでは、拡張 IP アクセス リストを指定します。

access-list-name 引数は、アクセス リストの名前です。名前にスペースまたは引用符を含めることはできません。また、名前の先頭は英文字にする必要があります。これにより、番号付きアクセス リストとの混同が防止されます。

ステップ 4

permit source [ source-wildcard ]

 

Router(config-std-nacl)# permit 10.0.0.0 0.255.255.255

名前付き IP アクセス リストでパケットを許可する条件を設定します。

source 引数は、パケットの送信元のネットワークまたはホストの番号です。送信元を指定する場合、代わりに次の 3 つの方法を使用できます。

4 つの部分で構成されるドット付き 10 進表記の 32 ビット数量を使用する。

any キーワードを source および source-wildcard の値 0.0.0.0 255.255.255.255 の省略形として使用する。

host 送信元を source および source-wildcard の値 source 0.0.0.0 の省略形として使用する。

source-wildcard 引数は、送信元に適用するワイルドカード ビットです。送信元ワイルドカードを指定する場合、代わりに次の 3 つの方法を使用できます。

4 つの部分で構成されるドット付き 10 進表記の 32 ビット数量を使用する。無視するビット位置には 1 を入力します。

any キーワードを source および source-wildcard の値 0.0.0.0 255.255.255.255 の省略形として使用する。

host 送信元を source および source-wildcard の値 source 0.0.0.0 の省略形として使用する。

ステップ 5

end

 

Router(config-std-nacl)# end

終了して、特権 EXEC モードに戻ります。

自動トンネル テンプレート インターフェイスの作成

自動トンネル テンプレート インターフェイスを作成するには、次の作業を実行します。これにより、ネットワークの初期設定が最小限に抑えられます。メッシュごとに 1 つのテンプレート インターフェイスを設定します。必要に応じて、そのテンプレート インターフェイスがすべてのメッシュ トンネル インターフェイスに伝播されます。


) 次のコマンドを使用して、最小限の設定を作成できます。


手順の概要

1. enable

2. configure terminal

3. interface auto-template interface-num

4. ip unnumbered interface - type interface-number

5. tunnel mode { aurp | cayman | dvmrp | eon | gre | ipip | iptalk | mpls | nos }

6. tunnel mpls traffic-eng autoroute announce

7. tunnel mpls traffic-eng priority setup-priority [ hold-priority ]

8. tunnel mpls traffic-eng auto-bw [ collect-bw ] [ frequency seconds ] [ max-bw kbps ] [ min-bw kbps ]

9. tunnel mpls traffic-eng path-option number { dynamic | explicit { name path-name | path-number }} [ lockdown ]

10. tunnel destination access-list num

11. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface auto-template interface-num

 

Router(config)# interface auto-template 1

テンプレート インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

interface-num 引数は、インターフェイス番号です。有効な値は 1 ~ 25 です。

ステップ 4

ip unnumbered interface-type interface-number

 

Router(config-if)# ip unnumbered Loopback 0

インターフェイスに IP アドレスを明示的に割り当てなくても、インターフェイスで IP 処理をイネーブルにします。

type 引数および number 引数では、ルータに IP アドレスが割り当てられている別のインターフェイスのタイプと番号を指定します。番号付けされていない別のインターフェイスは指定できません。

ステップ 5

tunnel mode { aurp | cayman | dvmrp | eon | gre | ipip | iptalk | mpls | nos }

 

Router(config-if)# tunnel mode mpls

トンネル インターフェイスのカプセル化モードを設定します。

ステップ 6

tunnel mpls traffic-eng autoroute announce

 

Router(config-if)# tunnel mpls traffic-eng autoroute announce

IGP が拡張 Shortest Path First(SPF)計算でトンネル(トンネルがアップしている場合)を使用するように指定します。

ステップ 7

tunnel mpls traffic-eng priority setup-priority [ hold-priority ]

 

Router(config-if)# tunnel mpls traffic-eng priority 1 1

MPLS TE トンネルの設定および予約プライオリティを設定します。

setup-priority 引数は、このトンネルに対して LSP がシグナリングされるときに使用されるプライオリティであり、プリエンプション処理の対象にできる既存のトンネルを決定します。有効な値は 0 ~ 7 であり、数字が小さいほどプライオリティが高いことを示します。したがって、設定プライオリティが 0 の LSP は、プライオリティが 0 以外のどの LSP よりも優先的に取得されます。

hold-priority 引数は、このトンネルの LSP に関連付けられているプライオリティであり、シグナリングされる他の LSP によってプリエンプション処理が行われる必要があるかどうかを決定します。有効な値は 0 ~ 7 です。番号が低いほど、プライオリティが高くなります。

ステップ 8

tunnel mpls traffic-eng auto-bw [ collect-bw ] [ frequency seconds ] [ max-bw kbps ] [ min-bw kbps ]

 

Router(config-if)# tunnel mpls traffic-eng auto-bw

自動帯域幅調整の対象、およびトンネルの帯域幅を調整する方法を制御する対象としてトンネルを設定します。

collect-bw キーワードでは、トンネルの出力レート情報を収集し、トンネルの帯域幅は調整しません。

frequency seconds のキーワードと引数のペアは、帯域幅調整の間隔です。指定できる間隔は 300 ~ 604800 秒です。グローバル コンフィギュレーション モードで mpls traffic-eng auto-bw コマンドによって指定した出力レート サンプリング間隔よりも低い値を指定しないでください。

max-bw kbps のキーワードと引数のペアは、このトンネルの最大自動帯域幅(kbps 単位)です。指定できる値は 0 ~ 4294967295 です。

min-bw kbps のキーワードと引数のペアは、このトンネルの最小自動帯域幅(kbps 単位)です。指定できる値は 0 ~ 4294967295 です。

ステップ 9

tunnel mpls traffic-eng path-option number { dynamic | explicit { name path-name | path-number }} [ lockdown ]

 

Router(config-if)# tunnel mpls traffic-eng path-option 1 dynamic

MPLS TE トンネルのパス オプションを設定します。

number 引数は、パス オプションの番号です。複数のパス オプションが設定されている場合、低い番号のオプションが優先されます。

dynamic キーワードでは、LSP のパスがダイナミックに計算されるように指定します。

explicit キーワードでは、LSP のパスが IP 明示パスになるように指定します。

name path-name のキーワードと引数のペアは、トンネルがこのオプションで使用する IP 明示パスのパス名です。

path-number 引数は、トンネルがこのオプションで使用する IP 明示パスのパス番号です。

lockdown キーワードでは、LSP を再最適化できないように指定します。

ステップ 10

tunnel destination access-list num

 

Router(config-if)# tunnel destination access-list 1

メッシュ トンネル インターフェイス宛先アドレスを取得するためにテンプレート インターフェイスで使用されるアクセス リストを指定します。

num 引数は、アクセス リストの番号です。

ステップ 11

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

メッシュ トンネル インターフェイス番号の範囲の指定

メッシュ トンネル インターフェイス番号の範囲を指定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls traffic-eng auto-tunnel mesh tunnel-num min num max num

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls traffic-eng auto-tunnel mesh tunnel-num min num max num

 

Router(config)# mpls traffic-eng auto-tunnel mesh tunnel-num min 1000 max 2000

メッシュ トンネル インターフェイス番号の範囲を指定します。

min num のキーワードと引数のペアでは、メッシュ トンネル インターフェイス番号の範囲の開始番号を指定します。有効な値は 1 ~ 65535 です。

max num のキーワードと引数のペアでは、メッシュ トンネル インターフェイス番号の範囲の終了番号を指定します。有効な値は 1 ~ 65535 です。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

トンネルに関する設定情報の表示

トンネル インターフェイスやメッシュ トンネル設定などのトンネル設定情報を表示するには、次の作業を実行します。

手順の概要

1. enable

2. show running interface auto-template num

3. show interface tunnel num configuration

4. exit

手順の詳細


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。プロンプトが表示されたらパスワードを入力します。例を示します。

Router> enable
Router#
 

ステップ 2 show running interface auto-template num

このコマンドを使用して、トンネル インターフェイスのインターフェイス コンフィギュレーション情報を表示します。例を示します。

Router# show running interface auto-template 1
 
interface auto-template1
ip unnumbered Loopback0
no ip directed-broadcast
no keepalive
tunnel destination access-list 1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 dynamic
 

この出力は、自動トンネル テンプレート インターフェイス auto-template1 ではアクセス リスト(access-list 1)を使用してメッシュ トンネル インターフェイスの宛先アドレスが決定されることを示しています。

ステップ 3 show interface tunnel num configuration

このコマンドを使用して、メッシュ トンネル インターフェイスの設定を表示します。例を示します。

Router# show interface tunnel 5 configuration
 
interface tunnel 5
ip unnumbered Loopback0
no ip directed-broadcast
no keepalive
tunnel destination access-list 1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 dynamic
 

ステップ 4 exit

このコマンドを使用して、ユーザ EXEC モードに戻ります。例を示します。

Router# exit
Router>
 


 

自動トンネル メッシュ ネットワークの監視

自動トンネル メッシュ ネットワークを監視するには、次の作業を実行します。

手順の概要

1. enable

2. show mpls traffic-eng tunnels property auto-tunnel mesh [ brief ]

3. show mpls traffic-eng auto-tunnel mesh

4. exit

手順の詳細


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。プロンプトが表示されたらパスワードを入力します。例を示します。

Router> enable
Router#
 

ステップ 2 show mpls traffic-eng tunnels property auto-tunnel mesh [ brief ]

このコマンドを使用して、メッシュ トンネル インターフェイスを監視します。このコマンドでは、 show mpls traffic-eng tunnels コマンドの出力にメッシュ トンネル インターフェイスだけを表示するように制限します。例を示します。

Router# show mpls traffic-eng tunnels property auto-tunnel mesh brief
 
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 491 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: disabled
TUNNEL NAME DESTINATION UP IF DOWN IF
STATE/PROT
router_t64336 10.2.2.2 - Se2/0
up/up
router_t64337 10.3.3.3 - Se2/0
up/up
Displayed 2 (of 2) heads, 0 (of 0) midpoints, 0 (of 0) tails
 

ステップ 3 show mpls traffic-eng auto-tunnel mesh

このコマンドを使用して、各自動テンプレート インターフェイスのメッシュ トンネル インターフェイスのクローン、およびメッシュ トンネル インターフェイス番号の現在の範囲を表示します。例を示します。

Router# show mpls traffic-eng auto-tunnel mesh
 
Auto-Template1:
 
Using access-list 1 to clone the following tunnel interfaces:
 
Destination Interface
----------- ---------
10.2.2.2 Tunnel64336
10.3.3.3 Tunnel64337
 
Mesh tunnel interface numbers: min 64336 max 65337
 

ステップ 4 exit

このコマンドを使用して、ユーザ EXEC モードに戻ります。例を示します。

Router# exit
Router>
 


 

トラブルシューティングのヒント

メッシュ トンネル インターフェイスは直接設定できます。ただし、それらを手動で削除することはできません。また、手動設定は永続的なものではありません。テンプレートが変更されたり、メッシュ トンネル インターフェイスが削除され、再作成されたりした場合、設定は上書きされます。メッシュ トンネル インターフェイスを手動で削除しようとすると、エラー メッセージが表示されます。

指定した IP アドレスを宛先としたトンネルに関する情報を表示するには、 show mpls traffic-eng tunnels destination address コマンドを入力します。

メッシュ トンネル インターフェイスに関する情報を表示するには、 show mpls traffic-eng tunnels property auto-tunnel mesh コマンドを入力します。

自動トンネル メッシュ グループの IGP フラッディングの設定

自動トンネル メッシュ グループの IGP フラッディングを設定するには、次の作業を実行します。この作業では、メッシュ グループ メンバを識別し、メッシュ グループ ID をすべての LSR にアドバタイズするように OSPF ベースの検出を設定します。

手順の概要

1. enable

2. configure terminal

3. mpls traffic-eng auto-tunnel mesh

4. router ospf process-id

5. mpls traffic-eng mesh-group mesh-group-id interface - type interface-number area area-id

6. exit

7. 他の LSR に対してステップ 4 および 5 を繰り返し、それらが属するメッシュ グループ番号をアドバタイズします。

8. interface auto-template interface-num

9. tunnel destination mesh-group mesh-group-id

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls traffic-eng auto-tunnel mesh

 

Router(config)# mpls traffic-eng auto-tunnel mesh

自動トンネル メッシュ グループをグローバルにイネーブルにします。

ステップ 4

router ospf process-id

 

Router(config)# router ospf 100

ルータ コンフィギュレーション モードを開始し、OSPF ルーティング プロセスを設定します。

process-id 引数は、OSPF ルーティング プロセスの内部で使用される識別パラメータです。ローカルで割り当てられ、任意の正の整数を使用できます。OSPF ルーティング プロセスごとに固有の値が割り当てられます。

ステップ 5

mpls traffic-eng mesh-group mesh-group-id interface-type interface-number area area-id

 

Router(config-router)# mpls traffic-eng mesh-group 10 loopback 0 area 100

LSR の自動トンネル メッシュ グループ番号をアドバタイズします。

mesh-group-id は、特定のメッシュ グループを識別する番号です。

interface - type 引数および interface- number 引数では、インターフェイスのタイプと番号を指定します。

area area-id のキーワードと引数のペアでは、エリアを識別します。

ステップ 6

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

他の LSR に対してステップ 4 および 5 を繰り返し、それらが属するメッシュ グループ番号をアドバタイズします。

--

ステップ 8

interface auto-template interface-num

 

Router(config)# interface auto-template 1

テンプレート インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

interface-num 引数では、インターフェイス番号を識別します。有効な値は 1 ~ 25 です。

ステップ 9

tunnel destination mesh-group mesh-group-id

 

Router(config-if)# tunnel destination mesh-group 10

テンプレート インターフェイスですべてのメッシュ グループ メンバのトンネルのシグナリングに使用されるメッシュ グループを指定します。

mesh-group-id は、特定のメッシュ グループを識別する番号です。

ステップ 10

end

 

Router(config-if)# end

終了して、特権 EXEC モードに戻ります。

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの設定例

ここでは、次の設定例を示します。

「TE トンネル LSP のメッシュの設定:例」

「メッシュ トンネル インターフェイス番号の範囲の指定:例」

「自動トンネル メッシュ グループの IGP フラッディングの設定:例」

TE トンネル LSP のメッシュの設定:例

ここでは、TE トンネル LSP のメッシュの設定に関する次の設定例を示します。

「自動トンネル メッシュ グループのグローバルなイネーブル化:例」

「名前を使用したアクセス リストの作成:例」

「自動トンネル テンプレート インターフェイスの作成:例」

自動トンネル メッシュ グループのグローバルなイネーブル化:例

次に、自動トンネル メッシュ グループをグローバルにイネーブルにする例を示します。

configure terminal
!
 
mpls traffic-eng auto-tunnel mesh
end

名前を使用したアクセス リストの作成:例

次に、名前を使用してアクセス リストを作成し、メッシュ トンネル インターフェイスの宛先アドレスを決定する例を示します。

configure terminal
!
ip access-list standard a1
permit 10.0.0.0 0.255.255.255
end
 

この例では、アクセス リスト a1 と一致する TE トポロジ データベース内の IP アドレスにより、その宛先アドレスを持つメッシュ トンネル インターフェイスが作成されています。

自動トンネル テンプレート インターフェイスの作成:例

次に、自動トンネル テンプレート インターフェイスを作成する例を示します。次の例では、一般的な TE コマンド セットを使用して、自動トンネル テンプレートが作成および設定されています。テンプレートから作成されたメッシュ グループは、アクセス リスト a1 と一致する宛先アドレスを持つメッシュ トンネル インターフェイスで構成されます。


) 次の例は、一般的な設定を示しています。


configure terminal
!
interface auto-template 1
ip unnumbered Loopback0
tunnel mode mpls
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng auto-bw
tunnel mpls traffic-eng path-option 1 dynamic
tunnel destination access-list a1
end

メッシュ トンネル インターフェイス番号の範囲の指定:例

次の例では、最も低いメッシュ トンネル インターフェイス番号が 1000 であり、最も高いメッシュ トンネル インターフェイス番号が 2000 です。

configure terminal
!
mpls traffic-eng auto-tunnel mesh tunnel-num min 1000 max 2000
end

自動トンネル メッシュ グループの IGP フラッディングの設定:例

次の例では、OSPF は、メッシュ グループ 10 のルータ メンバシップをアドバタイズするように設定されています。

configure terminal
!
mpls traffic-eng auto-tunnel mesh
router ospf 100
mpls traffic-eng mesh-group 10 loopback 0 area 100
exit
!
interface auto-template 1
tunnel destination mesh-group 10
end

その他の関連資料

ここでは、MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ機能に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS トラフィック エンジニアリング コマンドの説明

『Cisco IOS Multiprotocol Label Switching Command Reference』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループの機能情報

機能名
リリース
機能情報

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ

12.0(27)S
12.0(29)S
12.2(33)SRA
12.2(33)SXH
12.4(20)T
12.2(33)SRE

MPLS トラフィック エンジニアリング - 自動トンネル メッシュ グループ機能を使用すると、ネットワーク管理者は TE LSP を設定できます。

この機能は、Cisco IOS Release 12.2(27)S で導入されました。

この機能は、Cisco IOS Release 12.0(29)S で自動トンネル メッシュ グループの Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)フラッディングを含めるように更新されました。

この機能は、Cisco IOS Release 12.2(33)SRA で統合されました。

サポートは、Cisco IOS Release 12.2(33)SXH で追加されました。

この機能は、Cisco IOS Release 12.4(20)T で統合されました。

この機能は、Cisco IOS Release 12.2(33)SRE で統合されました。自動トンネル メッシュ グループを使用するルータには、Stateful Switchover(SSO; ステートフル スイッチオーバー)冗長性を設定できます。

用語集

CE ルータ :Customer Edge(カスタマー エッジ)ルータ。カスタマー ネットワークの一部であり、Provider Edge(PE; プロバイダー エッジ)ルータへのインターフェイスとなるルータ。

Label Switched Path(LSP; ラベル スイッチド パス)トンネル :パケットの伝送にラベル スイッチングが使用される、2 台のルータ間に設定された接続。

LSP :Label Switched Path(ラベル スイッチド パス)。ラベル付きパケットが複数のホップを介して通過するパス。このパスは、入力 LSR から開始し、出力 LSR で終了します。

LSR :Label Switch Router(ラベル スイッチ ルータ)。パケットにカプセル化されたラベルの値に基づいてパケットを転送するレイヤ 3 ルータ。

P ルータ :プロバイダー コア ルータ。

PE ルータ :Provider Edge(プロバイダー エッジ)ルータ。サービス プロバイダーのネットワークのエッジにある、Customer Edge(CE; カスタマー エッジ)ルータへのインターフェイスとなるルータ。

エッジ ルータ :ネットワークのエッジにある、パケットを受信して伝送するルータ。このルータでは、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークの境界を定義できます。

カスタマー ネットワーク :エンド カスタマーの制御下にあるネットワーク。カスタマー ネットワークでは、プライベート アドレスを使用できます。カスタマー ネットワークは、論理上、互いに独立しており、サービス プロバイダーのネットワークから切り離されています。

テールエンド :トンネルのダウンストリーム受信エンド。

トラフィック エンジニアリング :ネットワーク上で、標準的なルーティング方法が使用された場合に選択されるパスとは異なるパスを経由してトラフィックがルーティングされるようにするために使用する技術やプロセス。

トンネル :2 つのピア間(2 台のルータ間など)のセキュアな通信パス。トラフィック エンジニアリング トンネルは、トラフィック エンジニアリングに使用されるラベル スイッチド トンネルです。このようなトンネルは、通常のレイヤ 3 ルーティング以外の手段を使用して設定されます。

ヘッドエンド :トンネルの発信元となる Label Switch Router(LSR; ラベル スイッチ ルータ)。トンネルの「ヘッド」、つまりトンネル インターフェイスもこの LSR に存在します。

メッシュ グループ :Traffic Engineering(TE; トラフィック エンジニアリング)Label Switched Path(LSP; ラベル スイッチド パス)の完全または部分ネットワークのメンバである一連の Label Switch Router(LSR; ラベル スイッチ ルータ)。

ラベル :スイッチング ノードに対してデータの転送方法(パケット)を指示する短い固定長のデータ構造。

ルータ :1 つまたは複数のメトリックを使用して、ネットワーク トラフィックを転送する最適なパスを決定するネットワーク レイヤ デバイス。ルータは、ネットワーク レイヤ情報に基づいて、ネットワーク間でパケットを転送します。