マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS トラフィック エンジニアリング (TE)- TE トンネルの自動帯域幅調整
MPLS トラフィック エンジニアリング(TE)- TE トンネルの自動帯域幅調整
発行日;2012/01/30 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS トラフィック エンジニアリング(TE)- TE トンネルの自動帯域幅調整

機能情報の確認

この章の構成

MPLS TE - TE トンネルの自動帯域幅調整の前提条件

MPLS TE - TE トンネルの自動帯域幅調整の制約事項

MPLS TE - TE トンネルの自動帯域幅調整に関する情報

MPLS TE - TE トンネルの自動帯域幅調整の概要

MPLS TE - TE トンネルの自動帯域幅調整の利点

MPLS TE - TE トンネルの自動帯域幅調整の設定方法

トラフィック エンジニアリング トンネルをサポートするためのデバイスの設定

MPLS トラフィック エンジニアリング用の IS-IS または OSPF の設定

MPLS トラフィック エンジニアリング用の IS-IS の設定

MPLS トラフィック エンジニアリング用の OSPF の設定

トンネルが通過する各リンクの帯域幅の設定

MPLS トラフィック エンジニアリング トンネルの設定

トラブルシューティングのヒント

プラットフォームでの自動帯域幅調整のイネーブル化

トンネルの自動帯域幅調整のイネーブル化

トンネルの平均出力レートの計算間隔の設定

自動帯域幅設定の確認

MPLS TE - TE トンネルの自動帯域幅調整の設定例

MPLS トラフィック エンジニアリングの自動帯域幅の設定:例

自動帯域幅の対象とするトンネルの設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS TE - TE トンネルの自動帯域幅調整に関する機能情報

MPLS トラフィック エンジニアリング(TE)- TE トンネルの自動帯域幅調整

MPLS Traffic Engineering(TE; トラフィック エンジニアリング)- TE トンネルの自動帯域幅調整機能を使用すると、測定されたトラフィック負荷に基づいて、トラフィック エンジニアリング トンネルに対する帯域幅割り当てを自動的に調整できます。実行コンフィギュレーションで設定されている帯域幅は、自動帯域幅の動作により変更されます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「MPLS TE - TE トンネルの自動帯域幅調整に関する機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

MPLS TE - TE トンネルの自動帯域幅調整の前提条件

ネットワークで次のものがサポートされている必要があります。

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Traffic Engineering(TE; トラフィック エンジニアリング)トンネル

シスコ エクスプレス フォワーディング

Intermediate System-to-Intermediate System(IS-IS)または Open Shortest Path First(OSPF)

MPLS TE は、インターフェイスおよびトンネルに設定する必要があります。

MPLS TE - TE トンネルの自動帯域幅調整の制約事項

自動帯域幅調整機能は、各トンネルに対して個別にイネーブルにされ、それぞれ対象のトンネルを処理します。つまり、このような各トンネルの帯域幅は、そのトンネルに対して設定されている調整頻度、および最後の調整以降にサンプリングされた出力レートに従って調整され、他のトンネルに対する今までの調整や保留中の調整には関係しません。

新しい Label Switched Path(LSP; ラベル スイッチド パス)を計算するとき、その LSP が稼動しないためにトンネルがダウンした場合、設定された帯域幅は保存されません。ルータがリロードされると、最後に保存された自動帯域幅の値が使用されます。

論理 Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネル インターフェイスには MPLS TE を設定できません。

MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。

MPLS TE - TE トンネルの自動帯域幅調整に関する情報

MPLS TE - TE トンネルの自動帯域幅調整機能を設定する前に、次のことを理解する必要があります。

「MPLS TE - TE トンネルの自動帯域幅調整の概要」

「MPLS TE - TE トンネルの自動帯域幅調整の利点」

MPLS TE - TE トンネルの自動帯域幅調整の概要

トラフィック エンジニアリングの自動帯域幅では、自動帯域幅調整の対象としてマークされている各トンネルの平均出力レートがサンプリングされます。この機能では、マーク付けされた各トンネルに対して、トンネルの割り当て済み帯域幅が最後の調整以降のトンネルの最大サンプルになるように定期的に(たとえば、1 日に 1 回)調整します。

トンネルの帯域幅が調整される頻度および可能な調整範囲は、トンネルごとに設定できます。さらに、サンプリングの間隔、および平均出力レートを取得するためにトンネルのトラフィックを平均する間隔は、ユーザがトンネルごとに設定できます。

MPLS TE - TE トンネルの自動帯域幅調整の利点

自動帯域幅機能を使用すると、MPLS TE トンネルの帯域幅を設定および監視できます。トンネルに対して自動帯域幅が設定されている場合、TE によりトンネルの帯域幅が自動的に調整されます。

MPLS TE - TE トンネルの自動帯域幅調整の設定方法

ここでは、MPLS TE の TE トンネルの自動帯域幅調整を設定する次の作業について説明します。

「トラフィック エンジニアリング トンネルをサポートするためのデバイスの設定」(必須)

「MPLS トラフィック エンジニアリング用の IS-IS または OSPF の設定」(必須)

「トンネルが通過する各リンクの帯域幅の設定」(必須)

「トンネルが通過する各リンクの帯域幅の設定」(必須)

「プラットフォームでの自動帯域幅調整のイネーブル化」(必須)

「トンネルの自動帯域幅調整のイネーブル化」(必須)

「トンネルの平均出力レートの計算間隔の設定」(任意)

「自動帯域幅設定の確認」(任意)

トラフィック エンジニアリング トンネルをサポートするためのデバイスの設定

TE トンネルをサポートするようにデバイスを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip cef distributed

4. mpls traffic-eng tunnels

5. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef distributed

 

Router(config)# ip cef distributed

分散シスコ エクスプレス フォワーディング動作をイネーブルにします。

ステップ 4

mpls traffic-eng tunnels

 

Router(config)# mpls traffic-eng tunnels

デバイスで MPLS トラフィック エンジニアリング トンネル機能をイネーブルにします。

ステップ 5

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

MPLS トラフィック エンジニアリング用の IS-IS または OSPF の設定

MPLS TE 用に IS-IS または OSPF を設定するには、次の作業のいずれかを実行します。

「MPLS トラフィック エンジニアリング用の IS-IS の設定」(任意)

「MPLS トラフィック エンジニアリング用の OSPF の設定」(任意)

MPLS トラフィック エンジニアリング用の IS-IS の設定

MPLS TE 用に IS-IS を設定するには、次の作業を実行します。


) MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。


手順の概要

1. enable

2. configure terminal

3. router isis

4. mpls traffic-eng level-1

5. mpls traffic-eng router-id loopback0

6. metric-style wide

7. exit

8. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router isis

 

Router(config)# router isis

IS-IS ルーティングをイネーブルにし、IP 用の IS-IS プロセスを指定して、ルータ コンフィギュレーション モードを開始します。

ステップ 4

mpls traffic-eng level-1

 

Router(config-router)# mpls traffic-eng level-1

IS-IS レベル 1 で MPLS TE をオンにします。

ステップ 5

mpls traffic-eng router-id loopback0

 

Router(config-router)# mpls traffic-eng router-id loopback0

ノードの TE ルータ識別子が、インターフェイス loopback0 に関連付けられている IP アドレスになるように指定します。

ステップ 6

metric-style wide

 

Router(config-router)# metric-style wide

新スタイルの Type, Length, Value(TLV; タイプ、長さ、値)オブジェクトだけを生成して受け入れるようにルータを設定します。

ステップ 7

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

MPLS トラフィック エンジニアリング用の OSPF の設定

MPLS TE 用に OSPF を設定するには、次の作業を実行します。


) MPLS トラフィック エンジニアリングでは、単一の IGP プロセスまたはインスタンスだけがサポートされています。複数の IGP プロセスまたはインスタンスはサポートされておらず、MPLS トラフィック エンジニアリングを複数の IGP プロセスまたはインスタンスで設定することはできません。


手順の概要

1. enable

2. configure terminal

3. router ospf process-id

4. mpls traffic-eng area number

5. mpls traffic-eng router-id loopback0

6. exit

7. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id

 

Router(config)# router ospf 200

IP 用の OSPF ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

process-id 引数の値は、OSPF ルーティング プロセスの内部で使用される識別パラメータです。ローカルで割り当てられ、任意の正の整数を使用できます。OSPF ルーティング プロセスごとに固有の値を割り当てます。

ステップ 4

mpls traffic-eng area number

 

Router(config-router)# mpls traffic-eng area 0

指定した OSPF エリアに対して MPLS TE をオンにします。

ステップ 5

mpls traffic-eng router-id loopback0

 

Router(config-router)# mpls traffic-eng router-id loopback0

ノードの TE ルータ識別子が、インターフェイス loopback0 に関連付けられている IP アドレスになるように指定します。

ステップ 6

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

トンネルが通過する各リンクの帯域幅の設定

トンネルが通過する各リンクの帯域幅を設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. mpls traffic-eng tunnels

5. ip rsvp bandwidth [ interface-kbps ] [ single-flow-kbps ] [ sub-pool kbps ]

6. exit

7. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet 0/0/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

mpls traffic-eng tunnels

 

Router(config-if)# mpls traffic-eng tunnels

インターフェイスで MPLS TE トンネルをイネーブルにします。

ステップ 5

ip rsvp bandwidth [ interface-kbps ] [ single-flow-kbps ] [ sub-pool kbps ]

 

Router(config-if)# ip rsvp bandwidth 1000 100

インターフェイスで IP 用の Resource Reservation Protocol(RSVP; リソース予約プロトコル)をイネーブルにします。

interface-kbps 引数では、RSVP フローによって割り当てられる可能性のある帯域幅の最大量(kbps 単位)を指定します。値の範囲は 1 ~ 10000000 です。

single-flow-kbps 引数は、単一フローに割り当てられる可能性のある帯域幅の最大量(kbps 単位)です。値の範囲は 1 ~ 10000000 です。

ステップ 6

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

MPLS トラフィック エンジニアリング トンネルの設定

MPLS TE トンネルを設定するには、次の作業を実行します。MPLS TE トンネルには 2 つのパス設定オプションがあります。2 つのパスとは、優先的な明示パスとバックアップ ダイナミック パスです。

(注) 設定は、TE ヘッドエンド ノードだけに適用されます。設定は、ネットワーク内のすべてのノードおよびインターフェイスに適用されます。

手順の概要

1. enable

2. configure terminal

3. interface tunnel number

4. ip unnumbered interface-type interface-number

5. tunnel destination ip-address

6. tunnel mode mpls traffic-eng

7. tunnel mpls traffic-eng bandwidth bandwidth

8. tunnel mpls traffic-eng path-option [ protect ] preference-number { dynamic | explicit | { name path-name | path-number}} [ lockdown ]

9. exit

10. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel number

 

Router(config)# interface tunnel 1

トンネル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip unnumbered interface-type interface-number

 

Router(config-if)# ip unnumbered loopback 0

このトンネル インターフェイスに、インターフェイス Loopback0 の IP アドレスと同じ IP アドレスを割り当てます。

MPLS TE トンネル インターフェイスは単一方向リンクを表すため、番号なしにする必要があります。

(注) このコマンドは、Lookback0 が IP アドレスとともに設定されるまでは有効になりません。

ステップ 5

tunnel destination ip-address

 

Router(config-if)# tunnel destination 10.3.3.3

トンネルの宛先を指定します。

宛先は、宛先デバイスの MPLS TE ルータ ID にする必要があります。

ステップ 6

tunnel mode mpls traffic-eng

 

Router(config-if)# tunnel mode mpls traffic-eng

トンネルのカプセル化モードを MPLS TE に設定します。

ステップ 7

tunnel mpls traffic-eng bandwidth bandwidth

 

Router(config-if)# tunnel mpls traffic-eng bandwidth 250

MPLS TE トンネルの帯域幅を設定します。

bandwidth 引数は、MPLS TE トンネルに設定された帯域幅(キロビット/秒単位)です。値の範囲は 1 ~ 4294967295 です。デフォルト値は 0 です。

トンネルに自動帯域幅が設定されている場合、 tunnel mpls traffic-eng bandwidth コマンドでトンネルの初期帯域幅を設定します。この初期帯域幅は、自動帯域幅メカニズムによって調整されます。

コマンドで設定した場合、自動帯域幅調整の最小量はこれら 2 つの設定値の小さい方になります。

ステップ 8

tunnel mpls traffic-eng path-option [protect] preference-number {dynamic | explicit | {name path-name | path-number}} [lockdown]

 

Router(config-if)# tunnel mpls traffic-eng path-option 10 explicit avoid-protected-link

指定した IP 明示パス、または TE トポロジ データベースからダイナミックに計算されたパスを使用するようにトンネルを設定します。

明示パスが現在使用可能でない場合は、ダイナミック パスが使用されます。

ステップ 9

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 10

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

tunnel mpls traffic-eng auto-bw コマンドは、前のコマンドよりも優先されます。したがって、トンネルに複数のオプションを指定する場合は、単一の tunnel mpls traffic-eng auto-bw コマンドにそれらすべてを指定する必要があります。

プラットフォームでの自動帯域幅調整のイネーブル化

プラットフォームで自動帯域幅調整をイネーブルにし、帯域幅調整の対象として設定されているトンネルの出力レートのサンプリングを開始するには、次の作業を実行します。

(注) この作業は、TE ヘッドエンド ルータだけに適用されます。設定は、ローカルに設定されているすべての TE ヘッドエンド インターフェイスに適用されます。

手順の概要

1. enable

2. configure terminal

3. mpls traffic-eng auto-bw timers [ frequency seconds ]

4. no mpls traffic-eng auto-bw timers

5. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls traffic-eng auto-bw timers [ frequency seconds ]

 

Router(config)# mpls traffic-eng auto-bw timers frequency 300

プラットフォームで自動帯域幅調整をイネーブルにし、自動帯域幅調整の対象として設定されているトンネルの出力レートのサンプリングを開始します。

frequency キーワードでは、自動帯域幅の対象として設定されている各トンネルの出力レートのサンプリング間隔(秒単位)を指定します。値の範囲は 1 ~ 604800 です。推奨値は 300 です。

ステップ 4

no mpls traffic-eng auto-bw timers

 

Router(config)# no mpls traffic-eng auto-bw timers

(任意)プラットフォームで自動帯域幅調整をディセーブルにします。

トンネルの出力レート サンプリングと帯域幅調整を終了するには、コマンドの no 形式を使用します。また、コマンドの no 形式を使用すると、各トンネルに設定されている帯域幅が元に戻ります。この場合、設定されている帯域幅は次のように判別されます。

実行コンフィギュレーションがスタートアップ コンフィギュレーションに書き込まれたあと、トンネルの帯域幅が tunnel mpls traffic-eng bandwidth コマンドで明示的に設定された場合、設定されている帯域幅はそのコマンドで指定された帯域幅になります。

それ以外の場合、設定されている帯域幅はスタートアップ コンフィギュレーションでトンネルに指定された帯域幅になります。

ステップ 5

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

トンネルの自動帯域幅調整のイネーブル化

トンネルの自動帯域幅調整をイネーブルにし、トンネルに適用される自動帯域幅調整の範囲を制約するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface tunnel number

4. tunnel mpls traffic-eng auto-bw [collect-bw] [frequency seconds ] [ adjustment-threshold percent ] [ overflow-limit number overflow-threshold percent ] [ max-bw kbps ] [ min-bw kbps ]

5. exit

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel number

 

Router(config)# interface tunnel 1

トンネル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

tunnel mpls traffic-eng auto-bw [collect-bw] [frequency seconds ] [ adjustment-threshold percent ] [ overflow-limit number overflow-threshold percent ] [ max-bw kbps ] [ min-bw kbps ]

 

Router(config-if)# tunnel mpls traffic-eng auto-bw max-bw 2000 min-bw 1000

トンネルの自動帯域幅調整をイネーブルにし、トンネルの帯域幅を調整する方法を制御します。

ステップ 5

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

トンネルの平均出力レートの計算間隔の設定

MPLS TE トンネルの平均出力レートの計算間隔を指定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface tunnel number

4. load-interval seconds

5. exit

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel number

 

Router(config)# interface tunnel 1

トンネル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

load-interval seconds

 

Router(config-if)# load-interval 90

インターフェイスの入力レートおよび出力レートを平均化する間隔を設定します。

seconds 引数は、データを使用して負荷の統計を計算する期間です。値は 30 の倍数であり、30 ~ 600(30、60、90、120 など)です。デフォルト値は 300 です。

ステップ 5

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

exit

 

Router(config)# exit

終了して、特権 EXEC モードに戻ります。

自動帯域幅設定の確認

自動帯域幅設定を確認するには、次の作業を実行します。

手順の概要

1. show mpls traffic-eng tunnels

2. show running-config

手順の詳細

ステップ 1 show mpls traffic-eng tunnels

このコマンドを使用して、機能がイネーブルになっているトンネルの自動帯域幅情報を含め、トンネルに関する情報を表示します。例を示します。

Router# show mpls traffic-eng tunnels
 
Name:tagsw4500-9_t1 (Tunnel1) Destination:10.0.0.4
Status:
Admin:up Oper:up Path:valid Signalling:connected
path option 1, type explicit pbr_south (Basis for Setup, path weight 30)
path option 2, type dynamic
Config Parameters:
Bandwidth:13 kbps (Global) Priority:7 7 Affinity:0x0/0xFFFF
AutoRoute: disabled LockDown:disabled Loadshare:13 bw-based
auto-bw:(300/265) 53 Bandwidth Requested: 13
Adjustment threshold: 5%
Overflow Limit: 4 Overflow Threshold: 25%
Overflow Threshold Crossed: 1
Sample Missed: 1 Samples Collected: 1
Active Path Option Parameters:
State: dynamic path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled
InLabel : -
OutLabel : Serial3/0, 18
RSVP Signalling Info:
Src 10.0.0.1, Dst 10.0.0.4, Tun_Id 2, Tun_Instance 2
RSVP Path Info:
My Address: 10.105.0.1
Explicit Route: 10.105.0.2 104.105.0.1 10.0.0.4
Record Route: NONE
Tspec: ave rate=13 kbits, burst=1000 bytes, peak rate=13 kbits
Record Route: NONE
Tspec: ave rate=13 kbits, burst=1000 bytes, peak rate=13 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=13 kbits, burst=1000 bytes, peak rate=13 kbits
Shortest Unconstrained Path Info:
Path Weight: 128 (TE)
Explicit Route: 10.105.0.2 104.105.0.1 10.0.0.4
History:
Tunnel:
Time since created: 7 minutes, 56 seconds
Time since path change: 7 minutes, 18 seconds
Number of LSP IDs (Tun_Instances) used: 2
Number of Auto-bw Adjustment resize requests: 1
Time since last Auto-bw Adjustment resize request: 1 minutes, 7 seconds
Number of Auto-bw Overflow resize requests: 1
Time since last Auto-bw Overflow resize request: 52 seconds
Current LSP:
Uptime: 52 seconds
Selection: reoptimization
Prior LSP:
ID: path option 1 [1]
Removal Trigger: configuration changed

 

コマンドの出力の意味は次のとおりです。

auto-bw 行は、トンネルに対して自動帯域幅調整がイネーブルになっていることを示します。

300 は、帯域幅調整の間隔(秒単位)です。

265 は、次の帯域幅調整が開始されるまでの残存時間(秒単位)です。

53 は、最後の帯域幅調整以降の最大帯域幅サンプルです。

13 は、最後の帯域幅調整、およびトンネルに対して現在要求されている帯域幅です。

調整しきい値は 5% です。

オーバーフロー制限は 4 です。

オーバーフローしきい値は 25% です。

オーバーフローの超過は 1 です。

 

ステップ 2 show running-config

このコマンドを使用して、 tunnel mpls traffic-eng auto bw コマンドが予期したとおりかどうかを確認します。例を示します。

Router# show running-config
.
.
.
interface tunnel1
ip unnumbered loopback 0
tunnel destination 192.168.17.17 255.255.255.0
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng bandwidth 1500
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 dynamic

tunnel mpls traffic-eng auto bw max-bw 2000 min-bw 1000 !Enable automatic bandwidth

.
.
.
 

show running-config コマンドの出力例は、 tunnel mpls traffic-eng bandwidth 1500 コマンドの値 1500 が調整後に変更されることを示しています。

 


 

MPLS TE - TE トンネルの自動帯域幅調整の設定例

図 1 に、MPLS トポロジの例を示します。ここでは、ルータ 1 を送信元とする MPLS TE トンネルの自動帯域幅調整を設定し、トンネル 1 に対して自動帯域幅調整をイネーブルにする場合の設定例を示します。

図 1 MPLS トラフィック エンジニアリング トンネルの設定例

 

ここでは、図 1 に基づく次の設定例を示します。

「MPLS トラフィック エンジニアリングの自動帯域幅の設定:例」

「自動帯域幅の対象とするトンネルの設定:例」

これらの例では、必要な RSVP や Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)(IS-IS または OSPF)の設定など、MPLS TE に必要な一部の設定が省略されています。これらの例の目的は、自動帯域幅調整の設定を示すことであるためです。

MPLS トラフィック エンジニアリングの自動帯域幅の設定:例

次に、 mpls traffic-eng auto-bw timers コマンドを使用して、ルータ 1 に対して自動帯域幅調整をイネーブルにする例を示します。このコマンドでは、自動帯域幅調整の対象として設定されているトンネルの出力レートを 10 分間隔でサンプリングするように指定しています。

configure terminal
!
ip cef distributed
mpls traffic-eng tunnels
mpls traffic-eng auto-bw timers frequency 600 !Enable automatic bandwidth adjustment
interface loopback 0
ip address 192.168.11.11 255.255.255.0

自動帯域幅の対象とするトンネルの設定:例

次に、 tunnel mpls traffic-eng auto-bw コマンドを使用して、トンネル 1 に対して自動帯域幅調整をイネーブルにする例を示します。このコマンドでは、最大許容帯域幅を 2000 kbps、最小許容帯域幅を 1000 kbps に指定し、デフォルトの自動帯域幅調整頻度(1 日に 1 回)が使用されるように指定しています。

interface tunnel1
ip unnumbered loopback 0
tunnel destination 192.168.17.17
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng bandwidth 1500
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 dynamic
tunnel mpls traffic-eng auto-bw max-bw 2000 min-bw 1000 !Enable automatic bandwidth
!adjustment for Tunnel1

その他の参考資料

ここでは、MPLS トラフィック エンジニアリング - TE トンネルの自動帯域幅調整機能に関する関連資料について説明します。

関連資料

関連項目
参照先

IS-IS および OSPF コマンド

『Cisco IOS IP Routing Protocols Command Reference』

MPLS コマンド

『Cisco IOS Multiprotocol Label Switching Command Reference』

サービス品質ソリューションのコマンド

『Cisco IOS Quality of Service Solutions Command Reference』

サービス品質ソリューションの設定

『Quality of Service Overview』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

MPLS トラフィック エンジニアリング MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された規格はありません。また既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

MPLS TE - TE トンネルの自動帯域幅調整に関する機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS TE - TE トンネルの自動帯域幅調整に関する機能情報

機能名
リリース
機能情報

MPLS Traffic Engineering(TE; トラフィック エンジニアリング)- TE トンネルの自動帯域幅調整

Release 12.2(33)SRE

MPLS Traffic Engineering(TE; トラフィック エンジニアリング)- TE トンネルの自動帯域幅調整機能を使用すると、測定されたトラフィック負荷に基づいて、トラフィック エンジニアリング トンネルに対する帯域幅割り当てを自動的に調整できます。実行コンフィギュレーションで設定されている帯域幅は、自動帯域幅の動作により変更されます。

自動帯域幅調整しきい値およびオーバーフローしきい値をサポートするために、次のコマンドが導入または変更されました。 mpls traffic-eng lsp attributes show mpls traffic-eng tunnels 、および tunnel mpls traffic-eng auto-bw