マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS マルチ VRF(VRF-Lite)
MPLS マルチ VRF(VRF-Lite)
発行日;2012/01/31 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS マルチ VRF(VRF-Lite)

この章の構成

MPLS マルチ VRF の前提条件

MPLS マルチ VRF に関する制約事項

MPLS マルチ VRF に関する情報

MPLS マルチ VRF 機能のしくみ

MPLS マルチ VRF 機能を使用してネットワークでパケットが転送されるしくみ

MPLS マルチ VRF の設定方法

VRF の設定

制約事項

VRF のデフォルト設定

ルーティング プロトコルとしての BGP の設定(推奨)

PE から CE への MPLS 転送およびシグナリングで BGP を使用する場合の設定(推奨)

BGP 以外のルーティング プロトコルの設定

制約事項

PE から CE への MPLS 転送およびシグナリングで LDP を使用する場合の設定

MPLS マルチ VRF の設定例

PE ルータでの MPLS マルチ VRF の設定:例

CE ルータでの MPLS マルチ VRF の設定

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

MPLS マルチ VRF の機能情報

MPLS マルチ VRF(VRF-Lite)

MPLS マルチ VRF 機能を使用すると、同じ Customer Edge(CE; カスタマー エッジ)ルータ内でルーティングおよび転送テーブルの複数のインスタンスを設定および維持できます。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「MPLS マルチ VRF の機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

MPLS マルチ VRF の前提条件

ネットワークのコアおよびプロバイダー エッジ ルータは、MPLS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)動作用に構成する必要があります。

MPLS マルチ VRF に関する制約事項

MPLS マルチ VRF 機能を設定できるのは、レイヤ 3 インターフェイスだけです。

MPLS マルチ VRF 機能は、Interior Gateway Routing Protocol(IGRP)でも IS-IS でもサポートされていません。

特定のルータの特定の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスのラベル配布は、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)または Label Distribution Protocol(LDP; ラベル配布プロトコル)のいずれかで処理できます。ただし、両方のプロトコルで同時に処理することはできません。

マルチキャストは、MPLS マルチ VRF 機能が設定されているレイヤ 3 インターフェイスでは動作しません。

MPLS マルチ VRF に関する情報

サブスクリプションベースの Cisco IOS コンテンツ フィルタリングを設定するには、次の概念を理解する必要があります。

「MPLS マルチ VRF 機能のしくみ」

「MPLS マルチ VRF 機能を使用してネットワークでパケットが転送されるしくみ」

MPLS マルチ VRF 機能のしくみ

MPLS マルチ VRF 機能を使用すると、サービス プロバイダーは複数の VPN をサポートして、IP アドレスを複数の VPN にオーバーラップできるようになります。MPLS マルチ VRF 機能では、入力インターフェイスを使用して複数の異なる VPN のルートを区別し、1 つまたは複数のレイヤ 3 インターフェイスを各 VRF に関連付けることによって仮想パケット転送テーブルを作成します。VRF のインターフェイスは、イーサネット ポートなどの物理インターフェイスか、または VLAN Switched Virtual Interface(SVI; スイッチ仮想インターフェイス)などの論理インターフェイスになります。ただし、レイヤ 3 インターフェイスは、どの時点においても複数の VRF に属することはできません。マルチ VRF 機能により、オペレータは CE ルータ上で複数のルーティング ドメインをサポートできます。各ルーティング ドメインでは、独自のセットのインターフェイスと独自のセットのルーティングおよび転送テーブルが使用されます。MPLS マルチ VRF 機能を使用すると、Label Switched Path(LSP; ラベル スイッチド パス)を CE とその CE がサポートしている各ルーティング ドメインに拡張できます。

MPLS マルチ VRF 機能は、次のように動作します。

各 CE ルータは、サイトのローカル ルートを Provider Edge(PE; プロバイダー エッジ)ルータにアドバタイズし、その PE ルータからリモート VPN ルートを学習します。

PE ルータは、スタティック ルーティングまたはルーティング プロトコル(BGP、RIPv1、RIPv2 など)を使用することによって、ルーティング情報を CE ルータと交換します。

PE ルータは、LDP または BGP を介して MPLS ラベル情報を CE ルータと交換します。

PE ルータは、直接接続されている VPN の VPN ルートだけを維持する必要があり、サービス プロバイダーのすべての VPN ルートを維持する必要はありません。各 PE ルータは、直接接続されている各サイトの VRF を維持します。すべてのサイトが同じ VPN に参加している場合、PE ルータ上の複数のインターフェイスを 1 つの VRF に関連付けることができます。各 VPN は、指定した VRF にマッピングされます。CE ルータからローカル VPN ルートを学習すると、PE ルータは Internal BGP(iBGP; 内部 BGP)を介して VPN ルーティング情報を他の PE ルータと交換します。

MPLS マルチ VRF 機能を使用した場合、複数のカスタマーが 1 つの CE ルータを共有でき、CE ルータと PE ルータ間では 1 つの物理リンクだけが使用されます。共有 CE ルータは、カスタマーごとに別個の VRF テーブルを維持し、カスタマーの独自のルーティング テーブルに基づいて各カスタマーのパケットをルーティングします。MPLS マルチ VRF 機能により、PE ルータの限定機能が CE ルータにまで拡張され、個別の VRF テーブルの維持を通して、VPN のプライバシーとセキュリティをブランチ オフィスにまで拡張できるようになります。

図 1 に、各 CE ルータが 2 つの CE ルータであるかのように動作する場合の設定を示します。MPLS マルチ VRF 機能はレイヤ 3 機能であるため、VRF に関連付けられている各インターフェイスはレイヤ 3 インターフェイスにする必要があります。

図 1 各 CE ルータが複数の仮想 CE ルータとして動作する場合

MPLS マルチ VRF 機能を使用してネットワークでパケットが転送されるしくみ

ここでは、図 1 に示した MPLS マルチ VRF CE 対応ネットワークでのパケット転送プロセスについて説明します。

CE は、VPN からパケットを受信すると、入力インターフェイスに基づいてルーティング テーブルを検索します。ルートが見つかると、CE はそのルートについて PE から受信した MPLS ラベルを適用し、パケットを PE に転送します。

入力 PE は、CE からのパケットを受信すると、着信ラベルをそれに対応するラベル スタックと交換し、それを MPLS ネットワークに送信します。

出力 PE は、ネットワークからのパケットを受信すると、VPN ラベルをそのルートについて CE から以前に受信したラベルと交換し、それを CE に転送します。

CE は、出力 PE からのパケットを受信すると、パケット上の着信ラベルを使用してパケットを正しい VPN に転送します。

マルチ VRF を設定するには、VRF テーブルを作成し、その VRF に関連付けられているレイヤ 3 インターフェイスを指定します。次に、VPN 内、および CE と PE 間にルーティング プロトコルを設定します。BGP は、VPN ルーティング情報をプロバイダーのバックボーン上に配布するのに最適なルーティング プロトコルです。その理由の詳細については、「MPLS マルチ VRF の設定方法」を参照してください。

マルチ VRF ネットワークには、次の 3 つの主要コンポーネントがあります。

VPN ルート ターゲット コミュニティ :VPN コミュニティの他のすべてのメンバのリストです。各 VPN コミュニティ メンバに VPN ルート ターゲットを設定する必要があります。

VPN コミュニティ PE ルータのマルチプロトコル BGP ピアリング :VPN コミュニティのすべてのメンバに VRF の到達可能情報を伝播します。VPN コミュニティ内のすべての PE ルータに BGP ピアリングを設定する必要があります。

VPN 転送 :VPN サービス プロバイダー ネットワーク上の VPN コミュニティ メンバ間ですべてのトラフィックを転送します。

MPLS マルチ VRF の設定方法

ここでは、次の各手順について説明します。

「VRF の設定」(必須)

「ルーティング プロトコルとしての BGP の設定(推奨)」(必須)

「PE から CE への MPLS 転送およびシグナリングで BGP を使用する場合の設定(推奨)」(必須)

「BGP 以外のルーティング プロトコルの設定」(必須)

「PE から CE への MPLS 転送およびシグナリングで LDP を使用する場合の設定」(必須)

BGP がルーティング プロトコルとして使用されている場合、PE ルータと CE ルータ間の MPLS ラベル交換にもその BGP を使用できます。一方、OSPF、EIGRP、RIP、またはスタティック ルーティングが使用されている場合、ラベルのシグナリングには LDP を使用する必要があります。

MPLS マルチ VRF 機能を設定するには、VRF テーブルを作成し、その VRF に関連付けられているレイヤ 3 インターフェイスを指定します。次に、VPN 内、および CE ルータと PE ルータ間にルーティング プロトコルを設定します。

マルチ VRF ネットワークには、次の 3 つの主要コンポーネントがあります。

VPN ルート ターゲット コミュニティ:VPN コミュニティの他のすべてのメンバのリストです。各 VPN コミュニティ メンバに VPN ルート ターゲットを設定する必要があります。

VPN コミュニティ PE ルータのマルチプロトコル BGP ピアリング:VPN コミュニティのすべてのメンバに VRF の到達可能情報を伝播します。VPN コミュニティ内のすべての PE ルータに BGP ピアリングを設定する必要があります。

VPN 転送:VPN サービス プロバイダー ネットワーク上の VPN コミュニティ メンバ間ですべてのトラフィックを転送します。

ネットワークに MPLS マルチ VRF 機能を設定するときには、次の点を考慮してください。

MPLS マルチ VRF 機能を設定したルータは複数のカスタマーによって共有され、各カスタマーはそれぞれ独自のルーティング テーブルを使用します。

各カスタマーはそれぞれ異なる VRF テーブルを使用するため、同じ IP アドレスを再利用できます。複数の異なる VPN で IP アドレスをオーバーラップできます。

MPLS マルチ VRF 機能により、複数のカスタマーが PE ルータと CE ルータ間の同じ物理リンクを共有できるようになります。複数の VLAN があるトランク ポートは、パケットをカスタマーごとに分類します。各カスタマーがそれぞれ独自の VLAN を持ちます。

PE ルータでは、MPLS マルチ VRF 機能を使用する場合と複数の CE ルータを使用する場合に違いはありません。たとえば、図 2 では、4 つの仮想レイヤ 3 インターフェイスが MPLS マルチ VRF CE ルータに接続されています。

MPLS マルチ VRF 機能は、パケット スイッチング レートには影響しません。

VRF の設定

PE ルータと CE ルータの両方に VRF を設定します。

制約事項

MPLS マルチ VRF 機能と同じレイヤ 3 インターフェイスにマルチキャストを同時に設定することはできません。

VRF のデフォルト設定

VRF が設定されていない場合、ルータのデフォルト設定は次のようになります。

VRF は定義されていません。

インポート マップ、エクスポート マップ、またはルート マップは定義されていません。

VRF の最大ルート数は存在しません。

インターフェイスにはグローバル ルーティング テーブルだけが存在します。

手順の概要

1. enable

2. configure terminal

3. ip routing

4. ip vrf vrf-name

5. rd route-distinguisher

6. route-target { export | import | both } route-target-ext-community

7. import map route-map

8. exit

9. interface interface-id

10. ip vrf forwarding vrf-name

11. show ip vrf

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip routing

 

Router(config)# ip routing

IP ルーティングをイネーブルにします。

ステップ 4

ip vrf vrf-name

 

Router(config)# ip vrf v1

VRF 名を指定し、VRF コンフィギュレーション モードを開始します。

ステップ 5

rd route-distinguisher

 

Router(config-vrf)# rd 100:1

ルート識別子を指定して VRF テーブルを作成します。

自律システム番号および任意の数(xxx:y)、または IP アドレスおよび任意の数(A.B.C.D:y)のいずれかを入力します。

ステップ 6

route-target {export | import | both} route-target-ext-community

 

Router(config-vrf)# route-target export 100:1

指定した VRF のインポート、エクスポート、またはインポートとエクスポートのルート ターゲット コミュニティのリストを作成します。

自律システム番号および任意の数(xxx:y)、または IP アドレスおよび任意の数(A.B.C.D:y)のいずれかを入力します。

(注) このコマンドは、BGP が稼動している場合にだけ有効です。

ステップ 7

import map route-map

 

Router(config-vrf)# import map importmap1

(任意)ルート マップを VRF に関連付けます。

ステップ 8

exit

 

Router(config-vrf)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface interface-id

 

Router(config)# interface fastethernet3/0.10

VRF に関連付けるレイヤ 3 インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

有効なインターフェイスは、ルーテッド ポートまたは SVI です。

ステップ 10

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding v1

VRF をレイヤ 3 インターフェイスに関連付けます。

ステップ 11

show ip vrf

 

Router# show ip vrf

VRF の設定を表示します。

ルーティング プロトコルとしての BGP の設定(推奨)

ほとんどのルーティング プロトコルを CE ルータと PE ルータ間で使用できます。ただし、次のような理由から External BGP(eBGP; 外部 BGP)の使用を推奨しています。

BGP は、多数の CE ルータと通信するのに複数のアルゴリズムを必要としません。

BGP は、異なる管理下で実行されるシステム間でルーティング情報を渡すように設計されています。

BGP を使用すると、CE ルータにルートのアトリビュートを容易に渡すことができます。

BGP がルーティング プロトコルとして使用されている場合、PE ルータと CE ルータ間の MPLS ラベル交換の処理にもその BGP を使用できます。一方、OSPF、EIGRP、RIP、またはスタティック ルーティングが使用されている場合、ラベルのシグナリングには LDP を使用する必要があります。

BGP PE から CE へのルーティング セッションを設定するには、CE ルータと PE ルータで次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. network ip-address mask network-mask

5. redistribute ospf process-id match internal

6. network ip-address area area-id

7. address-family ipv4 vrf vrf-name

8. neighbor { ip- address | peer-group-name } remote-as as-number

9. neighbor address activate

手順の詳細

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 
Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 100

他の BGP ルータに渡された自律システム番号で BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

network ip-address mask network-mask
 
Router (config-router) # network 10.0.0.0 mask 255.255.255.0

BGP を使用してアナウンスするネットワークおよびマスクを指定します。

ステップ 5

redistribute ospf process-id match internal

 

Router (config-router) # redistribute ospf 2 match internal

OSPF 内部ルートを再配布するようにルータを設定します。

ステップ 6

network ip-address area area-id
 
Router (config-router) # network 10.0.0.0 255.255.255.0 area 0

OSPF が稼動しているネットワーク アドレスとマスク、およびそのネットワーク アドレスのエリア ID を識別します。

ステップ 7

address-family ipv4 vrf vrf-name
 

Router (config-router) # address-family ipv4 vrf v12

次の 2 つのコマンドに関連付ける VRF インスタンスの名前を識別し、VRF アドレス ファミリ モードを開始します。

ステップ 8

neighbor {ip- address | peer-group-name } remote-as as-number
 

Router (config-router-af) # neighbor 10.0.0.3 remote-as 100

このルータの BGP ネイバー テーブルにネイバーのアドレス(またはピア グループ名)とネイバーの自律システム番号を通知します。

ステップ 9

neighbor address activate

 

Router (config-router-af) # neighbor 10.0.0.3 activate

IPv4 アドレス ファミリ ネイバーのアドバタイズメントをアクティブにします。

PE から CE への MPLS 転送およびシグナリングで BGP を使用する場合の設定(推奨)

BGP が PE ルータと CE ルータ間のルーティングに使用されている場合、CE ルータと PE ルータの両方の VRF インターフェイスでラベルをシグナリングするように BGP を設定します。シグナリングは、ルータ コンフィギュレーション レベルでグローバルにイネーブルにし、さらにインターフェイスごとにイネーブルにする必要があります。

ルータ コンフィギュレーション レベルでは、 neighbor send-label コマンドを使用して、BGP を介した MPLS ラベルのシグナリングをイネーブルにします。

インターフェイス レベルでは、 mpls bgp forwarding コマンドを使用して、PE から CE への eBGP セッションに使用されるインターフェイスで MPLS 転送をイネーブルにします。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. address-family ipv4 vrf vrf-name

5. neighbor address send-label

6. neighbor address activate

7. end

8. configure terminal

9. interface interface-id

10. mpls bgp forwarding

手順の詳細

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 100

他の BGP ルータに渡された自律システム番号で BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv4 vrf vrf-name
 

Router (config-router) # address-family ipv4 vrf v12

次の 2 つのコマンドに関連付ける VRF インスタンスの名前を識別し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 5

neighbor address send-label
 

Router (config-router-af) # neighbor 10.0.0.3 remote-as 100

BGP を使用して IPv4 ルートとともに MPLS ラベルをピア ルータに配布できるようにルータを設定します。

このコマンドの発行時に BGP セッションが稼動している場合、BGP セッションを再起動するまでコマンドは有効になりません。

ステップ 6

neighbor address activate
 

Router (config-router-af) # neighbor 10.0.0.3 activate

IPv4 アドレス ファミリ ネイバーのアドバタイズメントをアクティブにします。

ステップ 7

end

 

Router (config-router-af) # end

特権 EXEC モードに戻ります。

ステップ 8

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 9

interface interface-id

 

Router(config)# interface fastethernet3/0.10

BGP セッションに使用するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

有効なインターフェイスは、ルーテッド ポートまたは SVI です。

ステップ 10

mpls bgp forwarding

 

Router(config-if)# mpls bgp forwarding

インターフェイスで MPLS 転送をイネーブルにします。

BGP 以外のルーティング プロトコルの設定

RIP、EIGRP、OSPF、またはスタティック ルーティングを使用できます。この設定では OSPF が使用されていますが、プロセスは他のプロトコルと同じです。OSPF、EIGRP、RIP、またはスタティック ルーティングが使用されている場合、ラベルのシグナリングには LDP を使用する必要があります。

OSPF を PE ルータと CE ルータ間のルーティング プロトコルとして使用する場合、ルータ コンフィギュレーション モードで capability vrf-lite コマンドを発行します。詳細については、『 OSPF Support for Multi-VRF in CE Routers 』を参照してください。

制約事項

OSPF、EIGRP、RIP、またはスタティック ルーティングが使用されている場合、ラベルのシグナリングには LDP を使用する必要があります。

MPLS マルチ VRF 機能は、IGRP でも IS-IS でもサポートされていません。

MPLS マルチ VRF 機能が設定されているレイヤ 3 インターフェイスにマルチキャストを同時に設定することはできません。

手順の概要

1. enable

2. configure terminal

3. router ospf process-id [ vrf vrf-name ]

4. log-adjacency-changes

5. redistribute bgp autonomous-system-number subnets

6. network ip-address subnet-mask area area-id

7. show ip ospf

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id [ vrf vpn-name ]

 

Router(config)# router ospf 100 vrf v1

OSPF ルーティングをイネーブルにし、VRF テーブルを指定して、ルータ コンフィギュレーション モードを開始します。

ステップ 4

log-adjacency-changes

 

Router(config-router)# log-adjacency-changes

(任意)隣接状態の変更をログに記録します。

これがデフォルトの状態です。

ステップ 5

redistribute bgp autonomous-system-number subnets

 

Router(config-router)# redistribute bgp 800 subnets

BGP ネットワークから OSPF ネットワークに情報を再配布するようにルータを設定します。

ステップ 6

network ip-address subnet-mask area area-id

 

Router(config-router)# network 10.0.0.0 255.255.255.0 area 0

OSPF が稼動しているネットワーク アドレスとマスク、およびそのネットワーク アドレスのエリア ID を指定します。

ステップ 7

show ip ospf

 

Router# show ip ospf

OSPF ルーティング プロセスに関する情報を表示します。

PE から CE への MPLS 転送およびシグナリングで LDP を使用する場合の設定

OSPF、EIGRP、RIP、またはスタティック ルーティングが使用されている場合、ラベルのシグナリングには LDP を使用する必要があります。

手順の概要

1. enable

2. configure terminal

3. interface interface-id

4. mpls ip

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface interface-id

 

Router(config)# interface fastethernet3/0.10

VRF に関連付けられているインターフェイスのインターフェイス コンフィギュレーション モードを開始します。有効なインターフェイスは、ルーテッド ポートまたは SVI です。

ステップ 4

mpls ip

 

Router(config-if)# mpls ip

このインターフェイス用に通常ルーティングされるパスに沿って IPv4 パケットの MPLS 転送が行われるようにします。

MPLS マルチ VRF の設定例

ここでは、次の例について説明します。

「PE ルータでの MPLS マルチ VRF の設定:例」

「CE ルータでの MPLS マルチ VRF の設定」

図 2 MPLS マルチ VRF の設定例

PE ルータでの MPLS マルチ VRF の設定:例

VRF の設定

configure terminal
ip vrf v1
rd 100:1
route-target export 100:1
route-target import 100:1
exit
ip vrf v2
rd 100:2
route-target export 100:2
route-target import 100:2
exit

PE から CE への接続でルーティングとラベル交換の両方に BGP を使用する場合の設定

router bgp 100
address-family ipv4 vrf v2
neighbor 10.0.0.8 remote-as 800
neighbor 10.0.0.8 activate
neighbor 10.0.0.8 send-label
exit
address-family ipv4 vrf vl
neighbor 10.0.0.8 remote-as 800
neighbor 10.0.0.8 activate
neighbor 10.0.0.8 send-label
end
 
configure terminal
interface fastethernet3/0.10
ip vrf forwarding v1
ip address 10.0.0.3 255.255.255.0
mpls bgp forwarding
exit
interface fastethernet3/0.20
ip vrf forwarding v2
ip address 10.0.0.3 255.255.255.0
mpls bgp forwarding
exit

PE から CE への接続でルーティングには OSPF を使用し、ラベル交換には LDP を使用する場合の設定

router ospf 100 vrf v1
network 10.0.0.0 255.255.255.0 area 0
exit
router ospf 101 vrf v2
network 10.0.0.0 255.255.255.0 area 0
exit
interface fastethernet3/0.10
ip vrf forwarding v1
ip address 10.0.0.3 255.255.255.0
mpls ip
exit
interface fastethernet3/0.20
ip vrf forwarding v2
ip address 10.0.0.3 255.255.255.0
mpls ip
exit

CE ルータでの MPLS マルチ VRF の設定

VRF の設定

configure terminal
ip routing
ip vrf v11
rd 800:1
route-target export 800:1
route-target import 800:1
exit
ip vrf v12
rd 800:2
route-target export 800:2
route-target import 800:2
exit

CE ルータの VPN 接続の設定

interface fastethernet3/8
ip vrf forwarding v11
ip address 10.0.0.8 255.255.255.0
exit
interface fastethernet3/11
ip vrf forwarding v12
ip address 10.0.0.8 255.255.255.0
exit
router ospf 1 vrf v11
network 10.0.0.0 255.255.255.0 area 0
network 10.0.0.0 255.255.255.0 area 0
exit
router ospf 2 vrf v12
network 10.0.0.0 255.255.255.0 area 0
network 10.0.0.0 255.255.255.0 area 0
exit

) BGP が PE ルータと CE ルータ間のルーティングに使用されている場合、次の例に示すコマンドを使用して、PE ルータからの BGP 学習ルートを OSPF に再配布できます。


router ospf 1 vrf v11
redistribute bgp 800 subnets
exit
router ospf 2 vrf v12
redistribute bgp 800 subnets
exit

PE から CE への接続でルーティングとラベル交換の両方に BGP を使用する場合の設定

router bgp 800
address-family ipv4 vrf v12
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-label
redistribute ospf 2 match internal
exit
address-family ipv4 vrf vl1
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-label
redistribute ospf 1 match internal
end
 
interface fastethernet3/0.10
ip vrf forwarding v11
ip address 10.0.0.8 255.255.255.0
mpls bgp forwarding
exit
interface fastethernet3/0.20
ip vrf forwarding v12
ip address 10.0.0.8 255.255.255.0
mpls bgp forwarding
exit

PE から CE への接続でルーティングには OSPF を使用し、ラベル交換には LDP を使用する場合の設定

router ospf 1 vrf v11
network 10.0.0.0 255.255.255.0 area 0
exit
router ospf 2 vrf v12
network 10.0.0.0 255.255.255.0 area 0
exit
 
interface fastethernet3/0.10
ip vrf forwarding v11
ip address 10.0.0.3 255.255.255.0
mpls ip
exit
interface fastethernet3/0.20
ip vrf forwarding v12
ip address 10.0.0.3 255.255.255.0
mpls ip
exit

その他の関連資料

ここでは、MPLS マルチ VRF 機能に関する関連資料について説明します。

関連資料

関連項目
参照先

マルチ VRF を使用する OSPF

OSPF Support for Multi-VRF in CE Routers

規格

規格
タイトル

該当なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

該当なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

この機能では、新しいコマンドや変更されたコマンドは使用されません。

MPLS マルチ VRF の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS マルチ VRF の機能情報

機能名
リリース
機能情報

MPLS マルチ VRF

12.1(11)EA1
12.1(20)EW
12.2(4)T
12.2(8)YN
12.2(18)SXD
12.2(25)EWA
12.2(28)SB

MPLS マルチ VRF 機能を使用すると、同じ CE ルータ内でルーティングおよび転送テーブルの複数のインスタンスを設定および維持できます。

マルチ VRF 機能は、Cisco IOS Release 12.1(11)EA1 で導入されました。

この機能が 12.1(20)EW リリースに統合されました。

この機能が 12.2(4)T リリースに統合されました。

この機能が 12.2(8)YN リリースに統合されました。

この機能が 12.2(18)SXD リリースに統合されました。

この機能が 12.2(25)EWA リリースに統合されました。

マルチプロトコル ラベル スイッチングのサポートが Cisco IOS Release 12.2(28)SB に追加されました。