マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS VPN トラフィックのロード シェア リング
MPLS VPN トラフィックのロード シェアリング
発行日;2012/02/01 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS VPN トラフィックのロード シェアリング

機能情報の確認

この章の構成

MPLS VPN トラフィックのロード シェアリングに関する前提条件

MPLS VPN トラフィックのロード シェアリングに関する制限

MPLS VPN トラフィックのロード シェアリングに関する情報

BGP マルチパス オプションを使用したロード シェアリング

内部 BGP マルチパス ロード シェアリング

eBGP および iBGP の BGP マルチパス

eBGP マルチパス ロード シェアリング

直接接続ループバック ピアリングを使用したロード シェアリング

ロード シェアリングを設定する方法

eBGP および iBGP の BGP マルチパス ロード シェアリングの設定

制約事項

eBGP および iBGP の BGP マルチパス ロード シェアリングの確認

MPLS VPN Inter-AS での eBGP マルチパス ロード シェアリングの設定

制約事項

MPLS VPN Carrier Supporting Carrier での eBGP マルチパス ロード シェアリングの設定

CSC-PE ルータでの eBGP マルチパス ロード シェアリングの設定

CSC-CE ルータでの eBGP マルチパス ロード シェアリングの設定

VPN-IPv4 アドレスを交換する ASBR を使用した MPLS VPN Inter-AS の直接接続ループバック ピアリングの設定

直接接続 ASBR のループバック インターフェイス アドレスの設定

eBGP ネイバー ループバックへの /32 スタティック ルートの設定

接続ループバック インターフェイスでの転送の設定

ループバック間の eBGP セッションの設定

ループバック間でロード シェアリングが発生することの確認

IPv4 のルートおよびアドレスを交換する ASBR を使用した MPLS VPN Inter-AS の直接接続ループバック ピアリングの設定

直接接続 ASBR のループバック インターフェイス アドレスの設定

eBGP ネイバー ループバックへの /32 スタティック ルートの設定

接続ループバック インターフェイスでの転送の設定

ループバック間の eBGP セッションの設定

ループバック間でロード シェアリングが発生することの確認

MPLS VPN Carrier Supporting Carrier での直接接続ループバック ピアリングの設定

CSC-PE ルータでのループバック インターフェイス アドレスの設定

CSC-CE ルータでのループバック インターフェイス アドレスの設定

CSC-PE ルータでの eBGP ネイバー ループバックへの /32 スタティック ルートの設定

CSC-CE ルータでの eBGP ネイバー ループバックへの /32 スタティック ルートの設定

CSC-CE ループバックに接続する CSC-PE インターフェイスでの転送の設定

CSC-PE ループバックに接続する CSC-CE インターフェイスでの転送の設定

CSC-PE ルータと CSC-CE ループバック間での eBGP セッションの設定

CSC-CE ルータと CSC-PE ループバック間での eBGP セッションの設定

ループバック間でロード シェアリングが発生することの確認

MPLS VPN トラフィックのロード シェアリングの設定例

マルチパスとして eBGP パスまたは iBGP パスを選択するためのルータの設定:例

ASBR から別の ASBR のループバック アドレスに至る /32 スタティック ルートの設定:例

ASBR を接続するインターフェイスでの BGP/MPLS 転送の設定:例

ASBR での VPNv4 セッションの設定:例

指定のネットワークの VPN NLRI の確認:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

MPLS VPN トラフィックのロード シェアリングに関する機能情報

MPLS VPN トラフィックのロード シェアリング

ロード シェアリングでは、個々のルータが過負荷状態にならないように、トラフィックを分散します。Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)ネットワークでは、次の方法でロード シェアリングを実現できます。

BGP マルチパス オプション

直接接続ループバック ピアリング

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「MPLS VPN トラフィックのロード シェアリングに関する機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

MPLS VPN トラフィックのロード シェアリングに関する前提条件

ロード シェアリングを設定する前に、(MPLS VPN Carrier Supporting Carrier や MPLS VPN 相互自律システムを含めた)MPLS VPN ネットワークが正しく設定されて機能していることを確認してください。MPLS VPN については、「関連資料」を参照してください。

MPLS VPN トラフィックのロード シェアリングに関する制限

MPLS または MPLS VPN 環境でスタティック ルートを設定する場合は、 ip route コマンドおよび ip route vrf コマンドの一部のバリエーションがサポートされません。Tag Forwarding Information Base(TFIB; タグ転送情報ベース)がサポートされている Cisco IOS リリース、特に 12.nT、12.nM、および 12.0S では、これらのコマンドのバリエーションはサポートされていません。プレフィクスが通過する再帰ルートがいったん失われて再び現れる場合、TFIB はプレフィクスを解決できません。ただし、MPLS Forwarding Infrastructure(MFI)をサポートする Cisco IOS リリース、特に Cisco IOS Release 12.2(25)S 以降のリリースでは、これらのコマンド バリエーションがサポートされています。スタティック ルートを設定するときは、次の注意事項に従ってください。

MPLS 環境でサポートされるスタティック ルート

MPLS 環境でスタティック ルートを設定する場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface next-hop-address

MPLS 環境でスタティック ルートを設定し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングを設定する場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 next-hop1
ip route destination-prefix mask interface2 next-hop2

TFIB を使用する MPLS 環境でサポートされないスタティック ルート

MPLS 環境でスタティック ルートを設定する場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop-address

MPLS VPN 環境でスタティック ルートを設定し、2 つのパスでネクストホップに到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop-address

MPLS VPN 環境でスタティック ルートを設定し、2 つのネクストホップで宛先に到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop1
ip route destination-prefix mask next-hop2

スタティック ルートを指定するときは、interface 引数および next-hop 引数を使用します。

MPLS VPN 環境でサポートされるスタティック ルート

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップとインターフェイスが同じ Virtual Routing and Forwarding(VRF)インスタンスに関連付けられている場合は、次の ip route vrf コマンドがサポートされます。

ip route vrf vrf-name destination-prefix mask next-hop-address

ip route vrf vrf-name destination-prefix mask interface next-hop-address

ip route vrf vrf-name destination-prefix mask interface1 next-hop1
ip route vrf vrf-name destination-prefix mask interface2 next-hop2

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがグローバル ルーティング テーブルの MPLS クラウドのグローバル テーブルに存在する場合は、次の ip route vrf コマンドがサポートされます。たとえば、ネクストホップがインターネット ゲートウェイを指している場合は、次のコマンドがサポートされます。

ip route vrf vrf-name destination-prefix mask next-hop-address global

ip route vrf vrf-name destination-prefix mask interface next-hop-address
(このコマンドは、ネクストホップおよびインターフェイスがコアにある場合にサポートされます)

MPLS VPN 環境でスタティック ルートを設定し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 next-hop1
ip route destination-prefix mask interface2 next-hop2

TFIB を使用する MPLS VPN 環境でサポートされないスタティック ルート

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがコア内の MPLS クラウドのグローバル テーブルに存在し、2 つのパスでネクストホップに到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route vrf destination-prefix mask next-hop-address global

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがコア内の MPLS クラウドのグローバル テーブルに存在し、2 つのネクストホップで宛先に到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route vrf destination-prefix mask next-hop1 global
ip route vrf destination-prefix mask next-hop2 global

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップおよびインターフェイスが同じ VRF にある場合は、次の ip route vrf コマンドがサポートされません。

ip route vrf vrf-name destination-prefix mask next-hop1
ip route vrf vrf-name destination-prefix mask next-hop2

ネクストホップが CE ルータ上のグローバル テーブルに存在する MPLS VPN 環境でサポートされるスタティック ルート

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップが Customer Edge(CE; カスタマー エッジ)側のグローバル テーブルにある場合は、次の ip route vrf コマンドがサポートされます。たとえば、EBGP マルチホップの場合と同様に、宛先プレフィクスが CE ルータのループバック アドレスである場合は、次のコマンドがサポートされます。

ip route vrf vrf-name destination-prefix mask interface next-hop-address

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップが CE 側のグローバル テーブルに存在し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 nexthop1
ip route destination-prefix mask interface2 nexthop2

MPLS VPN トラフィックのロード シェアリングに関する情報

ロード シェアリング機能を設定するには、次の概念を理解しておく必要があります。

「BGP マルチパス オプションを使用したロード シェアリング」

「直接接続ループバック ピアリングを使用したロード シェアリング」

BGP マルチパス オプションを使用したロード シェアリング

さまざまな Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)マルチパス オプションがあります。これらのオプションを使用すると、BGP を使用する MPLS VPN にロード シェアリングを設定できます。

iBGP マルチパス レベルでトラフィックをロード シェアリングするには、ルータ コンフィギュレーション モードで neighbor send-label コマンドを使用して BGP ラベリングを設定することを推奨します。iBGP マルチパス機能を設定するとき、neighbor send-label コマンド機能を使用するためのリマインダとして次のメッセージが表示されます。

WARNING: Using iBGP multipath feature with LDP or TE based LSPs towards the BGP nexthop, paths taken by forwarding may not be as expected. Please consider configuring BGP labeling (RFC 3107) for proper forwarding behavior.
 

ここでは、BGP マルチパス オプションについて説明します。

「内部 BGP マルチパス ロード シェアリング」

「eBGP および iBGP の BGP マルチパス」

「eBGP マルチパス ロード シェアリング」

内部 BGP マルチパス ロード シェアリング

ローカル ポリシーが設定されていない BGP スピーキング ルータが、Internal BGP(iBGP; 内部 BGP)から同じ宛先の Network Layer Reachability Information(NLRI; ネットワーク レイヤ到達可能性情報)を複数受信すると、ルータは最良パスとして 1 つの iBGP パスを選択します。その後、最良パスはルータの IP ルーティング テーブルにインストールされます。iBGP マルチパス機能を使用すると、BGP スピーキング ルータが宛先への最良パスとして複数の iBGP パスを選択できます。その後、最良パスはルータの IP ルーティング テーブルにインストールされます。iBGP マルチパス ロード シェアリングをイネーブルにするには、ルータ コンフィギュレーション モードで maximum-paths ibgp コマンドを発行します。iBGP マルチパス ロード シェアリングの詳細については、『 Configuring BGP 』を参照してください。

eBGP および iBGP の BGP マルチパス

MPLS VPN 機能で eBGP と iBGP の両方に対する BGP マルチパス ロード シェアリングを導入すると、External BGP(eBGP; 外部 BGP)パスと iBGP パスにトラフィックを分散するように、マルチホーム自律システムおよび Provider Edge(PE; プロバイダー エッジ)ルータを設定できます。

BGP は、( maximum-paths コマンドを使用して設定した)最大許容数までパスをインストールします。BGP は、最良パス アルゴリズムを使用して、最良パスとして 1 つのマルチパスを選択し、その最良パスを Routing Information Base(RIB; ルーティング情報ベース)に挿入し、最良パスを BGP ピアにアドバタイズします。それ以外のマルチパスも RIB に挿入できますが、最良パスとして選択されるのは 1 つのパスだけです。

シスコ エクスプレス フォワーディングは、マルチパスを使用して、パケット単位または送信元/宛先ペア単位でロード バランシングを実行します。ロード シェアリング機能をイネーブルにするには、MPLS VPN でルータを設定します。MPLS VPN には、eBGP パスと iBGP パスの両方をインポートする VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスを含めます。VRF ごとにマルチパスの数を設定できます。


) この機能は、既存の発信ルーティング ポリシーの設定パラメータ内で動作します。


BGP を使用した MPLS ネットワークでの eBGP および iBGP マルチパス ロード シェアリング

図 1 に、BGP を使用するMPLS サービス プロバイダー ネットワークを示します。この BGP によって、PE1 および PE2 に 2 つのリモート ネットワークが接続されています。PE1 と PE2 は両方とも VPNv4 ユニキャスト iBGP ピアリング用に設定されています。ネットワーク 2 は、PE1 および PE2 に接続されているマルチホーム ネットワークです。また、ネットワーク 2 には、ネットワーク 1 とのエクストラネット VPN サービスを設定しています。ネットワーク 1 とネットワーク 2 は、両方とも、PE ルータによる eBGP ピアリング用に設定されています。

図 1 BGP を使用したサービス プロバイダー MPLS ネットワーク

iBGP パスと eBGP パスの両方をマルチパスとして選択し、ネットワーク 1 の VRF にインポートできるように、PE1 を設定できます。シスコ エクスプレス フォワーディングは、マルチパスを使用して、ロード バランシングを実行します。次のようにトラフィックを分散します。

ネットワーク 2 から PE1 および PE2 に送信される IP トラフィックを IP トラフィックとして eBGP パスに送信します。

PE1 から PE2 に送信される IP トラフィックを MPLS トラフィックとして iBGP パスに送信します。

eBGP パスに送信される MPLS トラフィックを IP トラフィックとして送信します。

ネットワーク 2 からプレフィクスがアドバタイズされると、Route Distinguisher(RD; ルート識別子)21 および RD22 を経由して PE1 に届きます。

RD21 を経由するアドバタイズメントは、IP パケットで伝送されます。

RD22 を経由するアドバタイズメントは、MPLS パケットで伝送されます。

どちらのパスも、VRF1 のマルチパスとして選択し、VRF1 RIB に挿入できます。

ルート リフレクタを使用した eBGP および iBGP マルチパス ロード シェアリング

図 2 に、3 つの PE ルータと 1 つのルート リフレクタが含まれているトポロジを示します。いずれも、iBGP ピアリング用に設定されています。PE2 および PE3 はそれぞれ、均等プリファレンス eBGP パスを PE1 にアドバタイズします。デフォルトでは、ルート リフレクタはパスを 1 つだけ選択し、PE1 にアドバタイズします。

図 2 ルート リフレクタを配置したトポロジ

ルート リフレクタ経由で PE1 への均等プリファレンス パスをすべてアドバタイズするには、各 VRF にそれぞれ異なる RD を設定する必要があります。ルート リフレクタが受信する各プレフィクスはそれぞれ個別に認識されて、PE1 にアドバタイズされます。

eBGP マルチパス ロード シェアリング

ルータがネイバー自律システムから 1 つのプレフィクスに対して同じ eBGP パスを 2 つ学習したときは、最良パスとしてルート ID の小さい方を選択します。この最良パスは、IP ルーティング テーブルにインストールされます。eBGP マルチパスをイネーブルにすると、ネイバー自律システムから eBGP パスが学習されたときに、最良パスが 1 つ選択されるのではなく、複数のパスが IP ルーティング テーブルにインストールされます。

パケット スイッチング中、複数のパス間ではスイッチング モードに応じてパケット単位または宛先単位のロード シェアリングが実行されます。 maximum-paths ルータ コンフィギュレーション コマンドが、許容されるパスの数を制御します。デフォルトでは、BGP は IP ルーティング テーブルへのパスを 1 つだけインストールします。

直接接続ループバック ピアリングを使用したロード シェアリング

この機能を MPLS VPN Inter-AS および MPLS VPN Carrier Supporting Carrier(CSC)ネットワークで使用すると、複数のリンクで接続されている隣接 Label Switching Router(LSR; ラベル スイッチング ルータ)間でトラフィックをロード シェアリングできます。LSR は、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)のペアか、または CSC-PE と CSC-CE で構成されます。

直接接続ループバック ピアリングを使用すると、IGP レベルでロード シェアリングを実行できるため、LSR 間に複数の BGP セッションは不要です。BGP 以外の隣接 LSR の間に他のラベル配布メカニズムは不要です。

直接接続ループバック ピアリングを使用すると、次のようにトラフィックをロード シェアリングできます。

LSR のループバック アドレスを使用して、BGP セッションが確立されます。

接続リンクで MPLS がイネーブルになります。

隣接 LSR のループバック アドレスへの複数のスタティック ルートにより、IGP ロード シェアリングが可能になります。

隣接 LSR のループバック アドレスへの出ラベルは、暗黙的ヌル ラベルであり、LSR から推測されます。

隣接 LSR のループバック アドレスで IGP ロード シェアリングがイネーブルになるため、BGP セッションで学習される(さらにループバックに再帰する)プレフィクス宛てのトラフィックがロード シェアリングされます。

ロード シェアリングを設定する方法

ここでは、次の各手順について説明します。

「eBGP および iBGP の BGP マルチパス ロード シェアリングの設定」(必須)

「eBGP および iBGP の BGP マルチパス ロード シェアリングの確認」(任意)

「MPLS VPN Inter-AS での eBGP マルチパス ロード シェアリングの設定」(必須)

「MPLS VPN Carrier Supporting Carrier での eBGP マルチパス ロード シェアリングの設定」(必須)

「VPN-IPv4 アドレスを交換する ASBR を使用した MPLS VPN Inter-AS の直接接続ループバック ピアリングの設定」(必須)

「IPv4 のルートおよびアドレスを交換する ASBR を使用した MPLS VPN Inter-AS の直接接続ループバック ピアリングの設定」(必須)

「MPLS VPN Carrier Supporting Carrier での直接接続ループバック ピアリングの設定」(必須)

eBGP および iBGP の BGP マルチパス ロード シェアリングの設定

ここでは、ロード シェアリングの制約事項を示します。

制約事項

eBGP および iBGP の BGP マルチパスの設定は、基本的な MPLS レイヤ 3 VPN だけを対象とします。MPLS VPN Inter-AS および MPLS VPN Carrier Supporting Carrier では、このマルチパス設定がサポートされていません。

複数の iBGP パスがルーティング テーブルにインストールされている場合、ルート リフレクタがパスのいずれか 1 つだけ(1 つのネクストホップ)をアドバタイズします。ルータがルート リフレクタの背後にある場合、各 VRF に異なる RD を設定しないかぎり、マルチホーム サイトに接続されているどのルータもアドバタイズされません。

iBGP パスが複数ある BGP プレフィクスを IP ルーティング テーブルに登録するには、追加のメモリが必要です。使用可能なメモリ容量が少ないルータでは、特にルータでインターネット ルーティング テーブル全体を伝送するときには、この機能を使用しないことを推奨します。

マルチパス ロード シェアリングに対応する iBGP ルートおよび eBGP ルートを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. maximum-paths eibgp number-of-paths

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 1

ルータ コンフィギュレーション モードを開始し、BGP ルーティング プロセスを実行するようにルータを設定します。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vrf1

標準 IPv4 アドレス プレフィクスを使用する BGP などのルーティング セッションを設定するために、アドレス ファミリ コンフィギュレーション モードを開始します。

キーワードを指定する必要があります。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

maximum-paths eibgp number-of-paths

 

Router(config-router-af)# maximum-paths eibgp 6

ルーティング テーブルにインストールできる並列 iBGP ルートおよび eBGP ルートの数を設定します。

eBGP および iBGP の BGP マルチパス ロード シェアリングの確認

マルチパス ロード シェアリングに対応する iBGP ルートおよび eBGP ルートの設定を確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ rib-failure ] [ ip-prefix/length [ longer-prefixes ]] [ network-address [ mask ] [ longer-prefixes ]] [ cidr-only ] [ community ] [ community-list ] [ dampened-paths ] [ filter-list ] [ flap-statistics] [ inconsistent-as ] [ neighbors ] [ paths [ line ]] [ peer-group ] [ quote-regexp ] [ regexp ] [ summary ] [ labels ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

(任意)特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ rib-failure ] [ ip-prefix/length [ longer-prefixes ]] [ network-address [ mask ] [ longer-prefixes ]] [ cidr-only ] [ community ] [ community-list ] [ dampened-paths ] [ filter-list ] [ flap-statistics ] [ inconsistent-as ] [ neighbors ] [ paths [ line ]] [ peer-group ] [ quote-regexp ] [ regexp ] [ summary ] [ labels ]

 

Router# show ip bgp vpnv4 all

MPLS VPN 内の特定のネットワークのアトリビュートおよびマルチパスを表示します。

キーワードまたは引数を 1 つ以上入力します。

MPLS VPN Inter-AS での eBGP マルチパス ロード シェアリングの設定

MPLS VPN 相互自律システムの eBGP マルチパスを設定するには、ASBR でこの作業を実行します。これにより、ASBR が IPv4 ルートおよび MPLS ラベルを交換できるようになります。

制約事項

ASBR が VPNv4 ルートを交換する MPLS VPN Inter-AS では、eBGP マルチパスがサポートされません。

手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. neighbor { ip-address | peer-group-name } remote-as as-number

5. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

6. maximum paths number-paths

7. neighbor { ip-address | peer-group-name } activate

8. neighbor ip-address send-label

9. exit-address-family

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータでルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.0.0.1 remote-as 200

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 5

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4

標準 IPv4 アドレス プレフィクスを使用する BGP などのルーティング セッションを設定するために、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 6

maximum-paths number-paths

 

Router(config-router-af)# maximum-paths 2

(任意)IP ルーティング プロトコルがサポートできる並列ルートの最大数を制御します。

number-paths 引数には、IP ルーティング プロトコルがルーティング テーブルにインストールする並列ルートの最大数を指定します。

ステップ 7

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.0.0.1 activate

ネイバー ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 8

neighbor ip-address send - label

 

Router(config-router-af)# neighbor 10.0.0.1 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数では、ネイバー ルータの IP アドレスを指定します。

ステップ 9

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 10

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

MPLS VPN Carrier Supporting Carrier での eBGP マルチパス ロード シェアリングの設定

ここでは、次の各手順について説明します。

「CSC-PE ルータでの eBGP マルチパス ロード シェアリングの設定」

「CSC-CE ルータでの eBGP マルチパス ロード シェアリングの設定」

CSC-PE ルータでの eBGP マルチパス ロード シェアリングの設定

MPLS ラベルとともに BGP ルートを配布する CSC-PE ルータに、eBGP マルチパス ロード シェアリングを設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. maximum paths number-paths

6. neighbor { ip-address | peer-group-name } remote-as as-number

7. neighbor { ip-address | peer-group-name } activate

8. neighbor ip-address as-override

9. neighbor ip-address send-label

10. exit-address-family

11. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 
Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vpn1

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

maximum-paths number-paths

 

Router(config-router-af)# maximum-paths 2

(任意)IP ルーティング プロトコルがサポートできる並列ルートの最大数を制御します。

CSC-PE ルータでは、アドレス ファミリ コンフィギュレーション モードでこのコマンドがイネーブルになります。

number-paths 引数には、IP ルーティング プロトコルがルーティング テーブルにインストールする並列ルートの最大数を指定します。

ステップ 6

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router-af)# neighbor 10.0.0.1 remote-as 200

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 7

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.0.0.1 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 8

neighbor ip-address as-override

 

Router(config-router-af)# neighbor 10.0.0.1 as-override

サイトの Autonomous System Number(ASN; 自律システム番号)をプロバイダーの ASN で上書きするように PE ルータを設定します。

ip-address 引数には、指定した ASN で上書きされるルータの IP アドレスを指定します。

ステップ 9

neighbor ip-address send-label

 

Router(config-router-af)# neighbor 10.0.0.1 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数では、ネイバー ルータの IP アドレスを指定します。

ステップ 10

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 11

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

CSC-CE ルータでの eBGP マルチパス ロード シェアリングの設定

CSC-CE ルータに eBGP マルチパス ロード シェアリングを設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. maximum paths number-paths

5. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

6. redistribute protocol

7. neighbor { ip-address | peer-group-name } remote-as as-number

8. neighbor { ip-address | peer-group-name } activate

9. neighbor ip-address send-label

10. exit-address-family

11. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number
 
Router(config)# router bgp 200

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

maximum-paths number-paths

 
Router(config-router)# maximum-paths 2

(任意)IP ルーティング プロトコルがサポートできる並列ルートの最大数を制御します。

CSC-CE ルータでは、ルータ コンフィギュレーション モードでこのコマンドが発行されます。

number-paths 引数には、IP ルーティング プロトコルがルーティング テーブルにインストールする並列ルートの最大数を指定します。

ステップ 5

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 6

redistribute protocol

 

Router(config-router-af)# redistribute static

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

protocol 引数には、ルートの再配布元となるソース プロトコルを指定します。その値は次のキーワードのいずれかになります: bgp connected egp igrp isis mobile ospf rip 、および static [ ip ]。

static [ ip ] キーワードを使用すると、IP スタティック ルートが再配布されます。

キーワードは、スタティック ルートを System-to-Intermediate System(IS-IS)に再配布するときに使用します。

connected キーワードは、IP がインターフェイスでイネーブルな場合に自動的に確立されるルートを示します。

Open Shortest Path First(OSPF)や IS-IS などのルーティング プロトコルの場合、これらのルートは自律システムに対して外部として再配布されます。

ステップ 7

neighbor { ip-address | peer-group-name } remote-as as-number
 
Router(config-router-af)# neighbor 10.0.0.2 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 8

neighbor { ip-address | peer-group-name } activate
 
Router(config-router-af)# neighbor 10.0.0.2 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 9

neighbor ip-address send-label
 
Router(config-router-af)# neighbor 10.0.0.2 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数では、ネイバー ルータの IP アドレスを指定します。

ステップ 10

exit-address-family
 
Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 11

end
 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

VPN-IPv4 アドレスを交換する ASBR を使用した MPLS VPN Inter-AS の直接接続ループバック ピアリングの設定

ここでは、直接接続 ASBR のループバック インターフェイスのピアリングを設定するために必要な次の作業について説明します。

「直接接続 ASBR のループバック インターフェイス アドレスの設定」(必須)

「eBGP ネイバー ループバックへの /32 スタティック ルートの設定」(必須)

「接続ループバック インターフェイスでの転送の設定」(必須)

「ループバック間の eBGP セッションの設定」(必須)

「ループバック間でロード シェアリングが発生することの確認」(任意)

図 3 に、直接接続 ASBR1 および ASBR2 のループバック設定を示します。この設定は、次に説明する作業で例として使用します。

図 3 直接接続 ASBR1 および ASBR2 のループバック インターフェイス コンフィギュレーション

 

直接接続 ASBR のループバック インターフェイス アドレスの設定

直接接続 ASBR のループバック インターフェイス アドレスを設定するには、この作業を実行します。


) 直接接続 ASBR ごとにループバック アドレスを設定する必要があります。つまり、図 3 の例では、ASBR1 と ASBR2 のそれぞれにループバック アドレスを設定します。


手順の概要

1. enable

2. configure terminal

3. interface loopback interface-number

4. ip address ip-address mask [ secondary ]

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface loopback interface- number

 

Router(config)# interface loopback 0

常に稼動するインターフェイスをエミュレートするソフトウェア専用仮想インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

interface-number 引数は、作成または設定するループバック インターフェイスの数です。作成できるループバック インターフェイスの数に制限はありません。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.10.10.10 255.255.255.255

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ip-address 引数は、IP アドレスです。

mask 引数は、関連付けられた IP サブネットのマスクです。

secondary キーワードは、設定されるアドレスがセカンダリ IP アドレスであることを指定する場合に使用します。このキーワードを省略すると、設定されるアドレスはプライマリ IP アドレスになります。

ステップ 5

end

 

Router(config-if)# end

終了して、特権 EXEC モードに戻ります。

eBGP ネイバー ループバックへの /32 スタティック ルートの設定

eBGP ネイバー ループバックへの /32 スタティック ルートを設定するには、この作業を実行します。


) 直接接続 ASBR ごとに /32 スタティック ルートを設定する必要があります。


手順の概要

1. enable

2. configure terminal

3. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}
[ distance ] [ name ] [ permanent ] [ tag tag ]

4. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ] [ name ] [ permanent ] [ tag tag ]

 

Router(config)# ip route 10.20.20.20 255.255.255.255 Ethernet 1/0 172.16.0.1

スタティック ルートを確立します。

prefix 引数は、宛先の IP ルート プレフィクスです。

mask 引数は、宛先のプレフィクス マスクです。

ip-address 引数は、指定したネットワークに到達するのに使用できるネクストホップの IP アドレスです。

interface-type 引数および interface-number 引数は、ネットワーク インターフェイス タイプおよびインターフェイス番号です。

distance 引数は管理ディスタンスです。

name 引数は、指定したルートに名前を適用します。

permanent キーワードは、インターフェイスがシャットダウンした場合でも、ルートを削除しないことを指定します。

tag tag キーワードおよび引数には、ルート マップを使用した再配布を制御するための「照合」値として使用できるタグ値を指定します。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

接続ループバック インターフェイスでの転送の設定

接続ループバック インターフェイスに転送を設定するには、この作業を実行します。

この作業を実行するには、ループバック間にセッションを確立する必要があります。「eBGP ネイバー ループバックへの /32 スタティック ルートの設定」の作業では、イーサネット 1/0 およびイーサネット 0/0 が接続インターフェイスです。

手順の概要

1. enable

2. configure terminal

3. interface type slot / port

4. mpls bgp forwarding

5. exit

6. もう 1 つの接続インターフェイス(イーサネット 0/0)に対して、ステップ 3 および 4 を繰り返します。

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type slot/port

 

Router(config)# interface ethernet 1/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数は、設定するインターフェイスのタイプです。

slot 引数はスロット番号です。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

/ port 引数はポート番号です。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

ステップ 4

mpls bgp forwarding

 

Router(config-if)# mpls bgp forwarding

接続インターフェイスに MPLS 転送をイネーブルにするように BGP を設定します。

ステップ 5

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

もう 1 つの接続インターフェイス(イーサネット 0/0)に対して、ステップ 3 および 4 を繰り返します。

--

ステップ 7

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

ループバック間の eBGP セッションの設定

ループバック間の eBGP セッションを設定するには、この作業を実行します。


) 直接接続 ASBR ごとにループバック間の eBGP セッションを設定する必要があります。


手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default route-target filter

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } disable-connected-check

7. neighbor { ip-address | ipv6-address | peer-group-name } update-source
interface-type interface-number

8. address-family vpnv4 [ unicast ]

9. neighbor { ip-address | peer-group-name | ipv6-address } activate

10. neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

11. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 
Router(config)# router bgp 200

BGP ルーティング プロセスを設定します。

as-number は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。

ステップ 4

no bgp default route-target filter

 

Router(config)# no bgp default route-target filter

BGP ルート ターゲット フィルタリングをディセーブルにし、ルータ コンフィギュレーション モードを開始します。

受信したすべての BGP VPN-IPv4 ルートがルータによって受け入れられます。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.20.20.20 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数は、ネイバーの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

as-number 引数は、ネイバーが属する自律システムです。

ステップ 6

neighbor { ip-address | peer-group-name } disable-connected-check

 

Router(config-router)# neighbor 10.20.20.20 disable-connected-check

ループバック間のピアリングを許可します。

ip-address 引数は、ネイバーの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

ステップ 7

neighbor { ip-address | ipv6-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 10.20.20.20 update-source Loopback 0

 

TCP 接続の動作インターフェイスを使用できるよう BGP セッションを許可します。

ip-address 引数は、BGP スピーキング ネイバーの IPv4 アドレスです。

ipv6-address 引数は、BGP スピーキング ネイバーの IPv6 アドレスです。

この引数は RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

peer-group-name 引数は、BGP ピア グループの名前です。

interface-type 引数はインターフェイス タイプです。

interface-number 引数はインターフェイス番号です。

ステップ 8

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

 

BGP、Routing Information Protocol(RIP)、スタティックなルーティングなどのルーティング プロトコルを設定するためにアドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードは、ユニキャスト プレフィクスを指定します。

ステップ 9

neighbor { ip-address | peer-group-name | ipv6-address } activate

 

Router(config-router-af)# neighbor 10.20.20.20 activate

BGP ネイバーとの情報交換をイネーブルにします。

ip-address 引数は、ネイバー ルータの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

ipv6-address 引数は、BGP スピーキング ネイバーの IPv6 アドレスです。

(注) この引数は RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

ステップ 10

neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

 

Router(config-router-af)# neighbor 10.20.20.20 send-community extended

コミュニティ アトリビュートを BGP ネイバーに送信する必要があることを指定します。

ip-address 引数は、ネイバー ルータの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

both キーワードは、標準コミュニティと拡張コミュニティの両方を送信することを指定します。

standard キーワードは、標準コミュニティだけを送信することを指定します。

extended キーワードは、拡張コミュニティだけを送信することを指定します。

ステップ 11

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

ループバック間でロード シェアリングが発生することの確認

ループバック間でロード シェアリングが発生することを確認するには、この作業を実行します。ネイバー ルートの MPLS Label Forwarding Information Base(LFIB; ラベル転送情報ベース)に、使用可能なパスおよびインターフェイスを登録する必要があります。

手順の概要

1. enable

2. show mpls forwarding - table [ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

3. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

(任意)特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show mpls forwarding-table [ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

 

Router# show mpls forwarding-table

MPLS LFIB の内容を表示します。

必要に応じて任意のキーワードまたは引数を入力します。

ステップ 3

disable

 

Router# disable

終了して、ユーザ EXEC モードに戻ります。

IPv4 のルートおよびアドレスを交換する ASBR を使用した MPLS VPN Inter-AS の直接接続ループバック ピアリングの設定

ここでは、直接接続 ASBR のループバック インターフェイスのピアリングを設定して、相互自律システム ネットワークにロード シェアリングを実現する方法について説明します。

「直接接続 ASBR のループバック インターフェイス アドレスの設定」(必須)

「eBGP ネイバー ループバックへの /32 スタティック ルートの設定」(必須)

「接続ループバック インターフェイスでの転送の設定」(必須)

「ループバック間の eBGP セッションの設定」(必須)

「ループバック間でロード シェアリングが発生することの確認」(任意)

図 4 に、直接接続 ASBR1 および ASBR2 のループバック設定を示します。この設定は、次に説明する作業で例として使用します。

図 4 直接接続 ASBR1 および ASBR2 のループバック インターフェイス コンフィギュレーション

 

直接接続 ASBR のループバック インターフェイス アドレスの設定

ループバック インターフェイス アドレスを設定するには、この作業を実行します。


) 直接接続 ASBR ごとにループバック アドレスを設定する必要があります。つまり、図 4 の例では、ASBR1 と ASBR2 のそれぞれにループバック アドレスを設定します。


手順の概要

1. enable

2. configure terminal

3. interface loopback interface-number

4. ip address ip-address mask [ secondary ]

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface loopback interface - number

 

Router(config)# interface loopback 0

常に稼動するインターフェイスをエミュレートするソフトウェア専用仮想インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

interface-number 引数は、作成または設定するループバック インターフェイスの数です。作成できるループバック インターフェイスの数に制限はありません。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.10.10.10 255.255.255.255

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ip-address 引数は、IP アドレスです。

mask 引数は、関連付けられた IP サブネットのマスクです。

secondary キーワードは、設定されるアドレスがセカンダリ IP アドレスであることを指定する場合に使用します。このキーワードを省略すると、設定されるアドレスはプライマリ IP アドレスになります。

ステップ 5

end

 

Router(config-if)# end

終了して、特権 EXEC モードに戻ります。

eBGP ネイバー ループバックへの /32 スタティック ルートの設定

eBGP ネイバー ループバックへの /32 スタティック ルートを設定するには、この作業を実行します。


) 直接接続 ASBR ごとに /32 スタティック ルートを設定する必要があります。


手順の概要

1. enable

2. configure terminal

3. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}
[ distance ] [ name ] [ permanent ] [ tag tag ]

4. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ] [ name ] [ permanent ] [ tag tag ]

 

Router(config)# ip route 10.20.20.20 255.255.255.255 Ethernet 1/0 172.16.0.1

スタティック ルートを確立します。

prefix 引数は、宛先の IP ルート プレフィクスです。

mask 引数は、宛先のプレフィクス マスクです。

ip-address 引数は、指定したネットワークに到達するのに使用できるネクストホップの IP アドレスです。

interface-type 引数および interface-number 引数は、ネットワーク インターフェイス タイプおよびインターフェイス番号です。

distance 引数は管理ディスタンスです。

name 引数は、指定したルートに名前を適用します。

permanent キーワードは、インターフェイスがシャットダウンした場合でも、ルートを削除しないことを指定します。

tag tag キーワードおよび引数には、ルート マップを使用した再配布を制御するための「照合」値として使用できるタグ値を指定します。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

接続ループバック インターフェイスでの転送の設定

接続ループバック インターフェイスに転送を設定するには、この作業を実行します。

この作業を実行するには、ループバック間にセッションを確立する必要があります。「eBGP ネイバー ループバックへの /32 スタティック ルートの設定」の作業では、イーサネット 1/0 およびイーサネット 0/0 が接続インターフェイスです。

手順の概要

1. enable

2. configure terminal

3. interface type slot / port

4. mpls bgp forwarding

5. exit

6. もう 1 つの接続インターフェイス(イーサネット 0/0)に対して、ステップ 3 および 4 を繰り返します。

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type slot / port

 

Router(config)# interface ethernet 1/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数は、設定するインターフェイスのタイプです。

slot 引数はスロット番号です。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

/ port 引数はポート番号です。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

ステップ 4

mpls bgp forwarding

 

Router(config-if)# mpls bgp forwarding

接続インターフェイスに MPLS 転送をイネーブルにするように BGP を設定します。

ステップ 5

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

もう 1 つの接続インターフェイス(イーサネット 0/0)に対して、ステップ 3 および 4 を繰り返します。

--

ステップ 7

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

ループバック間の eBGP セッションの設定

ループバック間の eBGP セッションを設定するには、次の作業を実行します。


) 直接接続 ASBR ごとにループバック間の eBGP セッションを設定する必要があります。


手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } disable-connected-check

7. neighbor { ip-address | ipv6-address | peer-group-name } update-source
interface-type interface-number

8. address-family ipv4 [ unicast ] vrf vrf-name

9. neighbor { ip-address | peer-group-name | ipv6-address } activate

10. neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

11. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 
Router(config)# router bgp 200

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。

ステップ 4

bgp log-neighbor-changes

 

Router(config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.20.20.20 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数は、ネイバーの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

as-number 引数は、ネイバーが属する自律システムの番号です。

ステップ 6

neighbor { ip-address | peer-group-name } disable-connected-check

 

Router(config-router)# neighbor 10.20.20.20 disable-connected-check

ループバック間のピアリングを許可します。

ip-address 引数は、ネイバーの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

ステップ 7

neighbor { ip-address | ipv6-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 10.20.20.20 update-source Loopback 0

 

TCP 接続の動作インターフェイスを使用できるよう BGP セッションを許可します。

ip-address 引数は、BGP スピーキング ネイバーの IPv4 アドレスです。

ipv6-address 引数は、BGP スピーキング ネイバーの IPv6 アドレスです。

(注) この引数は RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

peer-group-name 引数は、BGP ピア グループの名前です。

interface-type 引数はインターフェイス タイプです。

interface-number 引数はインターフェイス番号です。

ステップ 8

address-family ipv4 [ unicast ] vrf vrf-name

 

Router(config-router)# address-family ipv4

 

BGP、Routing Information Protocol(RIP)、スタティックなルーティングなどのルーティング プロトコルを設定するためにアドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードは、ユニキャスト プレフィクスを指定します。

vrf vrf-name キーワードおよび引数には、サブモード コマンドに関連付ける VPN Routing/Forwarding(VRF; VPN ルーティング/転送)インスタンスの名前を指定します。

ステップ 9

neighbor { ip-address | peer-group-name | ipv6-address } activate

 

Router(config-router-af)# neighbor 10.20.20.20 activate

BGP ネイバーとの情報交換をイネーブルにします。

ip-address 引数は、ネイバー ルータの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

ipv6-address 引数は、BGP スピーキング ネイバーの IPv6 アドレスです。

(注) この引数は RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

ステップ 10

neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

 

Router(config-router-af)# neighbor 10.20.20.20 send-community extended

コミュニティ アトリビュートを BGP ネイバーに送信する必要があることを指定します。

ip-address 引数は、ネイバー ルータの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

both キーワードは、標準コミュニティと拡張コミュニティの両方を送信することを指定します。

standard キーワードは、標準コミュニティだけを送信することを指定します。

extended キーワードは、拡張コミュニティだけを送信することを指定します。

ステップ 11

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

ループバック間でロード シェアリングが発生することの確認

ループバック間にロード シェアリングが発生するようにするには、ネイバー ルートの MPLS LFIB に、使用可能なパスおよびインターフェイスを登録します。

手順の概要

1. enable

2. show mpls forwarding - table [ network { mask | length } | labels label [ -label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

3. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show mpls forwarding-table [ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

 

Router# show mpls forwarding-table

MPLS LFIB の内容を表示します。

必要に応じてキーワードまたは引数を入力します。

ステップ 3

disable

 

Router# disable

終了して、ユーザ EXEC モードに戻ります。

MPLS VPN Carrier Supporting Carrier での直接接続ループバック ピアリングの設定

ここでは、直接接続 CSC-PE ルータおよび CSC-CE ルータのループバック インターフェイスのピアリングを実現して、CSC トラフィックのロード バランシングを行う方法について説明します。

「CSC-PE ルータでのループバック インターフェイス アドレスの設定」(必須)

「CSC-CE ルータでのループバック インターフェイス アドレスの設定」(必須)

「CSC-PE ルータでの eBGP ネイバー ループバックへの /32 スタティック ルートの設定」(必須)

「CSC-CE ルータでの eBGP ネイバー ループバックへの /32 スタティック ルートの設定」(必須)

「CSC-CE ループバックに接続する CSC-PE インターフェイスでの転送の設定」(必須)

「CSC-PE ループバックに接続する CSC-CE インターフェイスでの転送の設定」(必須)

「CSC-PE ルータと CSC-CE ループバック間での eBGP セッションの設定」(必須)

「CSC-CE ルータと CSC-PE ループバック間での eBGP セッションの設定」(必須)

「ループバック間でロード シェアリングが発生することの確認」(任意)

図 5 に、直接接続 CSC-PE ルータおよび CSC-CE ルータのループバック設定を示します。この設定は、次に説明する作業で例として使用します。

図 5 直接接続 CSC-PE ルータおよび CSC-CE ルータのループバック インターフェイス コンフィギュレーション

 

制約事項

直接接続ループバック ピアリングを使用したロード シェアリングは、LDP および IGP を使用してルートおよび MPLS ラベルを配布する CSC ネットワークには適用されません。

CSC-PE ルータでのループバック インターフェイス アドレスの設定

CSC-PE ルータでループバック インターフェイス アドレスを設定するには、この作業を実行します。


) CSC-PE ルータでループバック インターフェイス アドレスを設定するには、VRF をイネーブルにする必要があります。CSC-CE ルータ ループバック インターフェイスでは、VRF をイネーブルにする必要がありません。


手順の概要

1. enable

2. configure terminal

3. interface loopback interface - number

4. ip vrf forwarding vrf-name

5. ip address ip-address mask [ secondary ]

6. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface loopback interface - number

 

Router(config)# interface loopback 0

常に稼動するインターフェイスをエミュレートするソフトウェア専用仮想インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

interface-number 引数は、作成または設定するループバック インターフェイスの数です。作成できるループバック インターフェイスの数に制限はありません。

ステップ 4

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding vpn1

指定したインターフェイスまたはサブインターフェイスに VRF を関連付けます。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 5

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.20.20.20 255.255.255.255

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ip-address 引数は、IP アドレスです。

mask 引数は、関連付けられた IP サブネットのマスクです。

secondary キーワードは、設定されるアドレスがセカンダリ IP アドレスであることを指定する場合に使用します。このキーワードを省略すると、設定されるアドレスはプライマリ IP アドレスになります。

ステップ 6

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

CSC-CE ルータでのループバック インターフェイス アドレスの設定

CSC-CE ルータのループバック インターフェイス アドレスを設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface loopback interface-number

4. ip address ip-address mask [ secondary ]

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface loopback interface- number

 

Router(config)# interface loopback 0

常に稼動するインターフェイスをエミュレートするソフトウェア専用仮想インターフェイスを設定します。

interface-number 引数は、作成または設定するループバック インターフェイスの数です。作成できるループバック インターフェイスの数に制限はありません。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.10.10.10 255.255.255.255

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ip-address 引数は、IP アドレスです。

mask 引数は、関連付けられた IP サブネットのマスクです。

secondary キーワードは、設定されるアドレスがセカンダリ IP アドレスであることを指定する場合に使用します。このキーワードを省略すると、設定されるアドレスはプライマリ IP アドレスになります。

ステップ 5

end

 

Router(config-if)# end

終了して、特権 EXEC モードに戻ります。

CSC-PE ルータでの eBGP ネイバー ループバックへの /32 スタティック ルートの設定

CSC-PE ルータで eBGP ネイバー ループバックへの /32 スタティック ルートを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip route vrf vrf-name prefix mask { ip-address | interface-type interface-number [ ip-address ]}
[ global ] [ distance ] [ name ] [ permanent ] [ tag tag ]

4. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip route vrf vrf-name prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ global ] [ distance ] [ name ] [ permanent ] [ tag tag ]

 

Router(config)# ip route vrf vpn1 10.10.10.10 255.255.255.255 Ethernet 1/0 172.16.0.2

 

VRF のスタティック ルートを確立します。

vrf-name 引数は、スタティック ルートの VRF の名前です。

prefix 引数は、宛先の IP ルート プレフィクスです。

mask 引数は、宛先のプレフィクス マスクです。

ip-address 引数は、宛先ネットワークに到達するのに使用できるネクストホップの IP アドレスです。

interface-type 引数および interface-number 引数は、ネットワーク インターフェイス タイプおよびインターフェイス番号です。

global キーワードは、指定されたネクストホップ アドレスが非 VRF ルーティング テーブルに登録されていることを指定します。

distance 引数は管理ディスタンスです。

name 引数は、指定したルートに名前を適用します。

permanent キーワードは、インターフェイスがシャットダウンした場合でも、ルートを削除しないことを指定します。

tag tag キーワードおよび引数には、ルート マップを使用した再配布を制御するための「照合」値として使用できるタグ値を指定します。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

CSC-CE ルータでの eBGP ネイバー ループバックへの /32 スタティック ルートの設定

CSC-CE ルータで eBGP ネイバー ループバックへの /32 スタティック ルートを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}
[ distance ] [ name ] [ permanent ] [ tag tag ]

4. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ] [ name ] [ permanent ] [ tag tag ]

 

Router(config)# ip route 10.20.20.20 255.255.255.255 Ethernet 1/0 172.16.0.1

 

スタティック ルートを確立します。

prefix 引数は、宛先の IP ルート プレフィクスです。

mask 引数は、宛先のプレフィクス マスクです。

ip-address 引数は、宛先ネットワークに到達するのに使用できるネクストホップの IP アドレスです。

interface-type 引数および interface-number 引数は、ネットワーク インターフェイス タイプおよびインターフェイス番号です。

distance 引数は管理ディスタンスです。

name 引数は、指定したルートに名前を適用します。

permanent キーワードは、インターフェイスがシャットダウンした場合でも、ルートを削除しないことを指定します。

tag tag キーワードおよび引数には、ルート マップを使用した再配布を制御するための「照合」値として使用できるタグ値を指定します。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

CSC-CE ループバックに接続する CSC-PE インターフェイスでの転送の設定

CSC-CE ループバックに接続する CSC-PE インターフェイスで転送を設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type slot / port

4. ip vrf forwarding vrf-name

5. ip address ip-address mask [ secondary ]

6. mpls bgp forwarding

7. exit

8. もう 1 つの接続インターフェイス(イーサネット 0/0)に対して、ステップ 3 ~ 6 を繰り返します。

9. end

DETAILED STEPS--CSC-PE

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type slot / port

 

Router(config)# interface ethernet 1/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数は、設定するインターフェイスのタイプです。

slot 引数はスロット番号です。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

/ port 引数はポート番号です。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

ステップ 4

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding vpn1

VRF をインターフェイスまたはサブインターフェイスに関連付けます。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 5

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 172.16.0.1 255.255.255.255

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ip-address 引数は、IP アドレスです。

mask 引数は、関連付けられた IP サブネットのマスクです。

secondary キーワードは、設定されるアドレスがセカンダリ IP アドレスであることを指定する場合に使用します。このキーワードを省略すると、設定されるアドレスはプライマリ IP アドレスになります。

ステップ 6

mpls bgp forwarding

 

Router(config-if)# mpls bgp forwarding

接続インターフェイスに MPLS 転送をイネーブルにするように BGP を設定します。

ステップ 7

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

もう 1 つの接続インターフェイス(イーサネット 0/0)に対して、ステップ 3 ~ 6 を繰り返します。

--

ステップ 9

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

CSC-PE ループバックに接続する CSC-CE インターフェイスでの転送の設定

CSC-PE ループバックに接続する CSC-CE インターフェイスで転送を設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type slot / port

4. mpls bgp forwarding

5. exit

6. もう 1 つの接続インターフェイス(イーサネット 0/0)に対して、ステップ 3 および 4 を繰り返します。

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type slot / port

 

Router(config)# interface ethernet 1/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数は、設定するインターフェイスのタイプです。

slot 引数はスロット番号です。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

/ port 引数はポート番号です。スロットおよびポート情報については、該当するハードウェア マニュアルを参照してください。

ステップ 4

mpls bgp forwarding

 

Router(config-if)# mpls bgp forwarding

接続インターフェイスに MPLS 転送をイネーブルにするように BGP を設定します。

ステップ 5

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

もう 1 つの接続インターフェイス(イーサネット 0/0)に対して、ステップ 3 および 4 を繰り返します。

--

ステップ 7

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

CSC-PE ルータと CSC-CE ループバック間での eBGP セッションの設定

CSC-PE ルータと CSC-CE ループバック間に eBGP セッションを設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } disable-connected-check

7. neighbor { ip-address | ipv6-address | peer-group-name } update-source
interface-type interface-number

8. address-family ipv4 [ unicast ] vrf vrf-name

9. ip vrf forwarding vrf-name

10. neighbor { ip-address | peer-group-name | ipv6-address } activate

11. neighbor ip-address send-label

12. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 
Router(config)# router bgp 200

BGP ルーティング プロセスを設定します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。

ステップ 4

bgp log-neighbor-changes

 

Router(config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.10.10.10 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数は、ネイバーの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

as-number 引数は、ネイバーが属する自律システムです。

ステップ 6

neighbor { ip-address | peer-group-name } disable-connected-check

 

Router(config-router)# neighbor 10.10.10.10 disable-connected-check

ループバック間のピアリングを許可します。

ip-address 引数は、ネイバーの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

ステップ 7

neighbor { ip-address | ipv6-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 10.10.10.10 update-source Loopback 0

 

TCP 接続の動作インターフェイスを使用できるよう BGP セッションを許可します。

ip-address 引数は、BGP スピーキング ネイバーの IPv4 アドレスです。

ipv6-address 引数は、BGP スピーキング ネイバーの IPv6 アドレスです。

この引数は RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

peer-group-name 引数は、BGP ピア グループの名前です。

interface-type 引数はインターフェイス タイプです。

interface-number 引数はインターフェイス番号です。

ステップ 8

address-family ipv4 [ unicast ] vrf vrf-name

 

Router(config-router)# address-family ipv4 vrf vpn1

 

BGP、Routing Information Protocol(RIP)、スタティックなルーティングなどのルーティング プロトコルを設定するためにアドレス ファミリ コンフィギュレーション モードを開始します。

ipv4 キーワードは、標準 IPv4 アドレス プレフィクスを伝送するセッションを設定します。

unicast キーワードは、ユニキャスト プレフィクスを指定します。

vrf vrf-name キーワードおよび引数には、サブモード コマンドに関連付ける VRF の名前を指定します。

ステップ 9

ip vrf forwarding vrf-name

 

Router(config-router-af)# ip vrf forwarding vpn1

VRF をインターフェイスまたはサブインターフェイスに関連付けます。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 10

neighbor { ip-address | peer-group-name | ipv6-address } activate

 

Router(config-router-af)# neighbor 10.10.10.10 activate

BGP ネイバーとの情報交換をイネーブルにします。

ip-address 引数は、ネイバー ルータの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

ipv6-address 引数は、BGP スピーキング ネイバーの IPv6 アドレスです。

(注) この引数は RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

ステップ 11

neighbor ip-address send-label

 

Router(config-router-af)# neighbor 10.10.10.10 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数は、ネイバー ルータの IP アドレスです。

ステップ 12

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

CSC-CE ルータと CSC-PE ループバック間での eBGP セッションの設定

CSC-CE ルータと CSC-PE ループバック間に eBGP セッションを設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } disable-connected-check

7. neighbor { ip-address | ipv6-address | peer-group-name } update-source
interface-type interface-number

8. address-family ipv4 [ unicast ] [ vrf vrf-name ]

9. neighbor { ip-address | peer-group-name | ipv6-address } activate

10. neighbor ip-address send-label

11. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 
Router(config)# router bgp 200

BGP ルーティング プロセスを設定します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。

ステップ 4

bgp log-neighbor-changes

 

Router(config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.20.20.20 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数は、ネイバーの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

as-number 引数は、ネイバーが属する自律システムです。

ステップ 6

neighbor { ip-address | peer-group-name } disable-connected-check

 

Router(config-router)# neighbor 10.20.20.20 disable-connected-check

ループバック間のピアリングを許可します。

ip-address 引数は、ネイバーの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

ステップ 7

neighbor { ip-address | ipv6-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 10.20.20.20 update-source Loopback 0

 

TCP 接続の動作インターフェイスを使用できるよう BGP セッションを許可します。

ip-address 引数は、BGP スピーキング ネイバーの IPv4 アドレスです。

ipv6-address 引数は、BGP スピーキング ネイバーの IPv6 アドレスです。

この引数は RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

peer-group-name 引数は、BGP ピア グループの名前です。

interface-type 引数はインターフェイス タイプです。

interface-number 引数はインターフェイス番号です。

ステップ 8

address-family ipv4 [ unicast ] [ vrf vrf-name ]

 

Router(config-router)# address-family ipv4

 

BGP、RIP、スタティックなルーティングなどのルーティング プロトコルを設定するためにアドレス ファミリ コンフィギュレーション モードを開始します。

ipv4 キーワードは、標準 IPv4 アドレス プレフィクスを伝送するセッションを設定します。

unicast キーワードは、ユニキャスト プレフィクスを指定します。

vrf vrf-name キーワードおよび引数には、サブモード コマンドに関連付ける VRF の名前を指定します。

ステップ 9

neighbor { ip-address | peer-group-name | ipv6-address } activate

 

Router(config-router-af)# neighbor 10.20.20.20 activate

BGP ネイバーとの情報交換をイネーブルにします。

ip-address 引数は、ネイバー ルータの IP アドレスです。

peer-group-name 引数は、BGP ピア グループの名前です。

ipv6-address 引数は、BGP スピーキング ネイバーの IPv6 アドレスです。

(注) この引数は RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

ステップ 10

neighbor ip-address send-label

 

Router(config-router-af)# neighbor 10.20.20.20 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数は、ネイバー ルータの IP アドレスです。

ステップ 11

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

ループバック間でロード シェアリングが発生することの確認

ループバック間にロード シェアリングが発生するようにするには、ネイバー ルートの MPLS LFIB に、使用可能なパスおよびインターフェイスを登録します。

手順の概要

1. enable

2. show mpls forwarding - table [ vrf vrf-name ] [{ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

3. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show mpls forwarding-table [ vrf vrf-name ] [{ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

 

Router# show mpls forwarding-table

MPLS LFIB の内容を表示します。

ステップ 3

disable

 

Router# disable

終了して、ユーザ EXEC モードに戻ります。

MPLS VPN トラフィックのロード シェアリングの設定例

ここでは、次のような MPLS VPN トラフィックのロード シェアリングの設定例を示します。

「マルチパスとして eBGP パスまたは iBGP パスを選択するためのルータの設定:例」

「ASBR から別の ASBR のループバック アドレスに至る /32 スタティック ルートの設定:例」

「ASBR を接続するインターフェイスでの BGP/MPLS 転送の設定:例」

「ASBR での VPNv4 セッションの設定:例」

「指定のネットワークの VPN NLRI の確認:例」

マルチパスとして eBGP パスまたは iBGP パスを選択するためのルータの設定:例

次の例では、マルチパスとして 6 個の eBGP パスまたは iBGP パスを選択するように、アドレス ファミリ コンフィギュレーション モードでルータを設定します。

Router(config)# router bgp 100
Router(config-router)# address-family ipv4 vrf try
Router(config-router-af)# maximum-paths eibgp 6
Router(config-router-af)# end

ASBR から別の ASBR のループバック アドレスに至る /32 スタティック ルートの設定:例

次の例では、ASBR1 から ASBR2 のループバック アドレスに至る /32 スタティック ルートを設定します。

Router# configure terminal
Router(config)# ip route 10.20.20.20 255.255.255 e1/0 168.192.0.1
Router(config)# ip route 10.20.20.20 255.255.255 e0/0 168.192.2.1
 

次の例では、ASBR2 から ASBR1 のループバック アドレスに至る /32 スタティック ルートを設定します。

Router# configure terminal
Router(config)# ip route vrf vpn1 10.10.10.10 255.255.255 e1/0 168.192.0.2
Router(config)# ip route vrf vpn1 10.10.10.10 255.255.255 e0/0 168.192.2.2

ASBR を接続するインターフェイスでの BGP/MPLS 転送の設定:例

次の例では、ASBR2 と ASBR1 を接続するインターフェイスで BGP/MPLS 転送を設定します。

Router# configure terminal
Router(config)# interface ethernet 1/0
Router(config-if)# ip vrf forwarding vpn1
Router(config-if)# ip address 168.192.0.1 255.255.255.255
Router(config-if)# mpls bgp forwarding
Router(config-if)# exit
Router(config)# interface ethernet 0/0
Router(config-if)# ip vrf forwarding vpn1
Router(config-if)# ip address 168.192.2.1 255.255.255.255
Router(config-if)# mpls bgp forwarding
Router(config-if)# exit

ASBR での VPNv4 セッションの設定:例

次の例では、ASBR2 で VPNv4 セッションを設定します。

Router# configure terminal
Router(config)# router bgp 200
Router(config-router)# bgp log-neighbor-changes
Router(config-router)# neighbor 10.10.10.10 remote-as 100
Router(config-router)# neighbor 10.10.10.10 disable-connected-check
Router(config-router)# neighbor 10.10.10.10 update-source Loopback0
!
Router(config-router)# address-family vpnv4
Router(config-router-af)# neighbor 10.10.10.10 activate
Router(config-router-af)# neighbor 10.10.10.10 send-community extended
Router(config-router-af)# end

指定のネットワークの VPN NLRI の確認:例

show ip bgp vpnv4 コマンドに all キーワードを入力した場合、指定のネットワークの VPN Network Layer Reachability Information(NLRI; ネットワーク レイヤ到達可能性情報)に関する情報がすべて出力に表示されます。

Router# show ip bgp vpnv4 all 10.22.22.0
 
BGP routing table entry for 10:1:22.22.22.0/24, version 19
Paths:(5 available, best #5)
Multipath: eiBGP
Advertised to non peer-group peers:
10.0.0.2 10.0.0.3 10.0.0.4 10.0.0.5
22
10.0.0.2 (metric 20) from 10.0.0.4 (10.0.0.4)
Origin IGP, metric 0, localpref 100, valid, internal, multipath
Extended Community:0x0:0:0 RT:100:1 0x0:0:0
Originator:10.0.0.2, Cluster list:10.0.0.4
22
10.0.0.2 (metric 20) from 10.0.0.5 (10.0.0.5)
Origin IGP, metric 0, localpref 100, valid, internal, multipath
Extended Community:0x0:0:0 RT:100:1 0x0:0:0
Originator:10.0.0.2, Cluster list:10.0.0.5
22
10.0.0.2 (metric 20) from 10.0.0.2 (10.0.0.2)
Origin IGP, metric 0, localpref 100, valid, internal, multipath
Extended Community:RT:100:1 0x0:0:0
22
10.0.0.2 (metric 20) from 10.0.0.3 (10.0.0.3)
Origin IGP, metric 0, localpref 100, valid, internal, multipath
Extended Community:0x0:0:0 RT:100:1 0x0:0:0
Originator:10.0.0.2, Cluster list:10.0.0.3
22
10.1.1.12 from 10.1.1.12 (10.22.22.12)
Origin IGP, metric 0, localpref 100, valid, external, multipath, best
Extended Community:RT:100:1

その他の関連資料

ここでは、MPLS VPN に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS

Cisco IOS Multiprotocol Label Switching Configuration Guide, Release 15.0 MPLS VPN Carrier Supporting Carrier with BGP

BGP

Cisco IOS IP Routing: BGP Configuration Guide, Release 15.0 Configuring BGP

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1164

『Application of the Border Gateway Protocol in the Internet』

RFC 1171

『A Border Gateway Protocol 4』

RFC 1700

『Assigned Numbers』

RFC 1966

『BGP Route Reflection: An Alternative to Full Mesh IBGP』

RFC 2283

『Multiprotocol Extensions for BGP-4』

RFC 2373

『IP Version 6 Addressing Architecture』

RFC 2547

『BGP/MPLS VPNs』

RFC 2842

『Capabilities Advertisement with BGP-4』

RFC 2858

『Multiprotocol Extensions for BGP-4』

RFC 3107

『Carrying Label Information in BGP-4』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

この機能では、新しいコマンドや変更されたコマンドは使用されません。

MPLS VPN トラフィックのロード シェアリングに関する機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS VPN トラフィックのロード シェアリングに関する機能情報

機能名
リリース
機能設定情報

MPLS VPN:Inter-AS および CSC VPN のロード バランシング サポート

12.0(29)S
12.4(20)T

この機能を使用すると、MPLS VPN Inter-AS および MPLS VPN CSC ネットワークが、複数のリンクで接続されている隣接 LSR 間のトラフィックをロード シェアできます。LSR は、ASBR のペアまたは CSC-PE と CSC-CE にすることができます。直接接続ループバック ピアリングを使用すると、IGP レベルでロード シェアリングを実行できるため、LSR 間に複数の BGP セッションは不要です。BGP 以外の隣接 LSR の間に他のラベル配布メカニズムは不要です。

この機能に関する詳細については、次の各項を参照してください。

「直接接続ループバック ピアリングを使用したロード シェアリング」

「VPN-IPv4 アドレスを交換する ASBR を使用した MPLS VPN Inter-AS の直接接続ループバック ピアリングの設定」

MPLS VPN での eBGP と iBGP の両方に対する BGP マルチパス ロード シェアリング

12.2(4)T
12.2(14)S
12.0(24)S

この機能を使用すると、External BGP(eBGP; 外部 BGP)パスと Internal BGP(iBGP; 内部 BGP)パスの両方にトラフィックを分散するように、マルチホーム自律システムおよび PE ルータを設定できます。

この機能に関する詳細については、次の各項を参照してください。

「eBGP および iBGP の BGP マルチパス」

「eBGP および iBGP の BGP マルチパス ロード シェアリングの設定」

iBGP マルチパス ロード シェアリング

12.2(2)T
12.2(14)S

この機能を使用すると、BGP スピーキング ルータが宛先への最良パスとして複数の iBGP パスを選択できます。

この機能に関する詳細については、次の項を参照してください。

「内部 BGP マルチパス ロード シェアリング」

eBGP マルチパス

12.0(27)S

この機能により、ネイバー Autonomous System(AS; 自律システム)から eBGP パスが学習されたときに、最良パスが 1 つ選択されるのではなく、複数のパスが IP ルーティング テーブルにインストールされます。

この機能に関する詳細については、次の各項を参照してください。

「eBGP マルチパス ロード シェアリング」

「MPLS VPN Inter-AS での eBGP マルチパス ロード シェアリングの設定」

「MPLS VPN Carrier Supporting Carrier での eBGP マルチパス ロード シェアリングの設定」