マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV
MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV
発行日;2012/01/31 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV

機能情報の確認

この章の構成

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の前提条件

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の制約事項

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV に関する情報

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の機能

MPLS LSP ping の動作

MPLS LSP Traceroute の動作

MPLS LSP ping および MPLS LSP Traceroute を使用した MPLS ネットワーク管理

Any Transport over MPLS 仮想回線接続

AToM VCCV シグナリング

AToM VCCV スイッチング タイプの選択

LSP ping または LSP traceroute を処理するルータから提供される情報

IP では MPLS エコー要求パケットは転送されない

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の設定方法

MPLS LSP と ping または traceroute 実装間の互換性のイネーブル化

MPLS LSP ping と MPLS LSP Traceroute を使用した FEC の検証

MPLS LSP ping と MPLS LSP Traceroute を使用した LDP IPv4 FEC の検証

MPLS LSP ping と MPLS LSP Traceroute を使用したレイヤ 2 FEC の検証

DSCP を使用した、エコー応答における特定のサービス クラスの要求

MPLS エコー要求に対する応答ルータの応答方法の制御

MPLS LSP ping と LSP Traceroute のエコー要求応答の応答モード

MPLS LSP ping および LSP Traceroute コマンド オプション使用時のループの回避

MPLS LSP ping を使用したループの検出

MPLS LSP traceroute を使用したループの検出

LSP の切断の検出

暗黙的ヌルとタグ付けされたパケットの追跡

非タグ付きパケットの追跡

パケットを送信できない原因の特定

IPv4 LDP LSP でロード バランシングがイネーブルになっている場合の LSP 切断の検出

エコー パケットがルータから発信されるときに経由するインターフェイスの指定

パケット伝送のペーシング

エコー要求の request-dsmap を使用した、中継ルータに対するダウンストリーム情報の問い合せ

ルータに対する DSMAP の問い合せ

中継ルータによるターゲット FEC スタックの検証の要求

LSP ping のイネーブル化による、非タグ付きインターフェイスを起因とする LSP 切断の検出

ピアにアドバタイズされた AToM VCCV 機能やピアから受信した AToM VCCV 機能の表示

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の設定例

MPLS LSP と ping または traceroute 実装間の互換性のイネーブル化:例

MPLS LSP ping と MPLS LSP traceroute を使用した FEC の検証:例

MPLS LSP ping と MPLS LSP traceroute を使用した LDP IPv4 FEC の検証:例

MPLS LSP ping を使用したレイヤ 2 FEC の検証:例

DSCP を使用した、エコー応答における特定のサービス クラスの要求:例

MPLS エコー要求に対する応答ルータの応答方法の制御:例

MPLS LSP ping および LSP Traceroute コマンド オプション使用時のループの回避:例

MPLS LSP ping で発生する可能性があるループ:例

MPLS LSP Traceroute で発生する可能性があるループ:例

LSP の切断の検出:例

LSP ping または traceroute を使用したトラブルシューティング:例

LSP での MTU ディスカバリ:例

暗黙的ヌルとタグ付けされたパケットの追跡:例

非タグ付きパケットの追跡:例

パケットを送信できない原因の特定:例

IPv4 LSP でロード バランシングがイネーブルになっている場合の LSP 切断の検出:例

エコー パケットがルータから発信されるときに経由するインターフェイスの指定:例

パケット伝送のペーシング:例

中継ルータに対するダウンストリーム情報の問い合せ:例

ルータに対する DSMAP の問い合せ:例

中継ルータによるターゲット FEC スタックの検証の要求:例

LSP ping のイネーブル化による、非タグ付きインターフェイスを起因とする LSP 切断の検出:例

ピアにアドバタイズされた AToM VCCV 機能やピアから受信した AToM VCCV 機能の表示:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の機能情報

用語集

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV 機能を使用すると、サービス プロバイダーは Label Switched Path(LSP; ラベル スイッチド パス)を監視したり、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)フォワーディングの問題を迅速に隔離したりできます。

この機能には、次の機能が含まれます。

MPLS LSP ping。IPv4 Label Distribution Protocol(LDP; ラベル配布プロトコル)のプレフィクス、Resource Reservation Protocol(RSVP; リソース予約プロトコル)Traffic Engineering(TE; トラフィック エンジニアリング)、および Any Transport over MPLS(AToM)Forward Equivalence Class(FEC)の LSP 接続をテストします。

MPLS LSP traceroute。IPv4 LDP プレフィクスと RSVP TE プレフィクスの LSP をトレースします。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の前提条件

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV 機能を使用する前に、次のことを行う必要があります。

MPLS ネットワークの基本動作を決定する。例を示します。

予想される MPLS Experimental(EXP)の処理。

LSP の予想される最大サイズ パケットまたは Maximum Transmission Unit(MTU; 最大伝送ユニット)。

トポロジ、予想されるラベル スイッチド パス、および LSP におけるリンクの数。ロード バランシング用のパスなど、ラベル スイッチド パケットのパスをトレースします。

MPLS と MPLS アプリケーションの使用方法を理解する。次のことを理解する必要があります。

LDP の設定方法

AToM の概念

ラベル スイッチング、フォワーディング、およびロード バランシングについて理解する。

ping mpls コマンドまたは trace mpls コマンドを使用する前に、ネットワーク内のすべての受信側ルータが認識できる形式で MPLS エコー パケットを符号化およびデコードするようにルータが設定されていることを確認する必要があります。

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の制約事項

MPLS LSP traceroute を使用して、AToM パケットがたどるパスをトレースすることはできません。MPLS LSP traceroute は AToM ではサポートされません(MPLS LSP ping は AToM でサポートされます)。ただし、MPLS LSP traceroute を使用して、AToM によって使用される Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)LSP をトラブルシューティングすることはできます。

MPLS LSP ping を使用して、MPLS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)を検証またはトレースすることはできません。

MPLS LSP traceroute を使用して、Time-to-Live(TTL; 存続可能時間)隠蔽を使用する LSP をトラブルシューティングすることはできません。

MPLS は、宛先単位およびパケット単位の(ラウンド ロビン)ロード バランシングをサポートします。パケット単位のロード バランシングが有効になっている場合は、MPLS LSP traceroute を使用しないでください。中継ルータの LSP traceroute は、直接接続されている上流のルータから前に送信されたエコー応答内の情報に対する整合性検査を実行するためです。ラウンド ロビンが使用されている場合、エコー要求パケットがたどるパスを制御するときに、誘導されるパケットの TTL を指定ルータで期限切れにすることはできません。そのため、LSP traceroute の実行中に整合性検査が失敗し、整合性検査エラーの戻りコードが返されることがあります。

プラットフォームでは、MPLS エコー要求パケットに応答できるように、LSP ping と traceroute がサポートされている必要があります。

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV 機能がパス全体でイネーブルになっていなければ、要求がパスのいずれかのノードで失敗した場合に応答を取得できません。

ネットワーク内に異なるドラフト バージョンを組み合せて実装する場合は、特定の制限があります。ドラフトのバージョンは、シスコの実装と互換性がある必要があります。LSP ping ドラフトの作成方法により、Type Length Value(TLV; タイプ、長さ、値)形式が変更になったため、十分なバージョン情報がなければ、旧バージョンは新バージョンと互換性がない可能性があります。シスコは、特定のバージョンを想定して、設定によって送信側ルータと応答ルータによるエコー パケットの符号化やデコードを可能にすることにより、実装におけるこの点を補完しようとしています。

MPLS LSP traceroute を使用する場合は、ネットワークで TTL 隠蔽を使用しないでください。

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV に関する情報

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV 機能を使用する前に、次の概念を理解する必要があります。

「MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の機能」

「MPLS LSP ping の動作」

「MPLS LSP Traceroute の動作」

「MPLS LSP ping および MPLS LSP Traceroute を使用した MPLS ネットワーク管理」

「Any Transport over MPLS 仮想回線接続」

「IP では MPLS エコー要求パケットは転送されない」

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の機能

Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)の ping と traceroute は、多くの場合、フォワーディング エラーが発生したときに根本原因を診断するために使用されます。ただし、LSP エラーの特定にはあまり適していません。LSP 切断が発生しても、ICMP パケットは IP 経由で宛先に転送できるためです。

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV 機能は、次の理由で LSP 切断の特定に適しています。

MPLS エコー要求パケットは、IP 経由で転送できません。これは、IP TTL が 1 に設定され、宛先 IP アドレス フィールドは 127/8 アドレスに設定されるためです。

チェック対象の FEC は、ICMP の場合のように宛先 IP アドレス フィールドに格納されません。

MPLS エコー要求と応答のパケットは、LSP をテストします。下流のルータでは、次の 2 つの方法でパケットを受信できます。

以前は Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)のインターネット ドラフト『Detecting MPLS Data Plane Failures』(draft-ietf-mpls-lsp-ping-03.txt)に基づいていた MPLS エコー要求とエコー応答のシスコの実装

このマニュアルで説明する、IETF RFC 4379『 Detecting Multi-Protocol Label Switched (MPLS) Data Plane Failures 』に基づく機能

エコー要求の出力インターフェイス制御

エコー要求のトラフィック ペーシング

エコー要求のスタック末尾の明示的ヌル ラベル シム

エコー要求の request-dsmap 機能

Request-fec チェック

深度制限の報告

MPLS LSP ping の動作

MPLS LSP ping では、MPLS エコー要求パケットとエコー応答パケットを使用して LSP を検証します。MPLS LSP ping を使用すると、 ping mpls コマンドで適切なキーワードと引数を使用することによって、IPv4 LDP、AToM、および IPv4 RSVP FEC を検証できます。

MPLS エコー要求パケットは、検証対象の LSP に関連付けられた適切なラベル スタックを使用してターゲット ルータに送信されます。ラベル スタックを使用すると、パケットは LSP 自体を介して転送されます。

MPLS エコー要求パケットの宛先 IP アドレスは、ラベル スタックの選択に使用されるアドレスとは異なります。宛先 IP アドレスは、127. x . y . z /8 アドレスとして定義されます。127. x . y . z /8 アドレスを使用すると、LSP が切断された場合に IP パケットが宛先に IP スイッチングされるのを防ぐことができます。

MPLS エコー応答は、MPLS エコー要求に応じて送信されます。応答は IP パケットとして送信され、IP、MPLS、または両方のスイッチング タイプの組み合せを使用して転送されます。MPLS エコー応答パケットの送信元アドレスは、エコー応答を生成するルータから取得されたアドレスです。宛先アドレスは、MPLS エコー要求パケットを発信したルータの送信元アドレスです。

MPLS エコー応答の宛先ポートは、エコー要求の送信元ポートに設定されます。

図 1 に、MPLS LSP ping のエコー要求とエコー応答のパスを示します。

図 1 MPLS LSP ping のエコー要求とエコー応答のパス

 

LSR1 で LSR6 の FEC に対する MPLS LSP ping 要求を開始すると、 表 1 に示すような結果になります。

 

表 1 図 1 に基づく MPLS LSP ping の例

手順
ルータ
アクション

1.

LSR1

ターゲット ルータ LSR6 の FEC に対する MPLS LSP ping 要求を開始し、MPLS エコー要求を LSR2 に送信します。

2.

LSR2

MPLS エコー要求パケットを受信し、中継ルータ LSR3 と LSR4 を経由して最後から 2 番めのルータ LSR5 に転送します。

3.

LSR5

MPLS エコー要求を受信し、MPLS ラベルをポップしてパケットを IP パケットとして LSR6 に転送します。

4.

LSR6

IP パケットを受信し、MPLS エコー要求を処理して、代替ルート経由で MPLS エコー応答を LSR1 に送信します。

5.

LSR7 ~ LSR10

MPLS エコー応答を受信し、送信元ルータ LSR1 に転送します。

6.

LSR1

MPLS エコー要求に対する MPLS エコー応答を受信します。

MPLS LSP Traceroute の動作

MPLS LSP traceroute では、MPLS エコー要求パケットとエコー応答パケットを使用して LSP を検証します。MPLS LSP traceroute を使用すると、 trace mpls コマンドで適切なキーワードと引数を使用することによって、IPv4 LDP と IPv4 RSVP FEC を検証できます。

MPLS LSP Traceroute 機能では、TTL 設定を使用して LSP の TTL を強制的に期限切れにします。MPLS LSP Traceroute は、MPLS エコー要求の TTL 値を徐々に増やして(TTL = 1、2、3、4)、連続した各ホップのダウンストリーム マッピングを検出します。LSP traceroute の成否は、TTL = 1 のラベル付きパケットの受信時に MPLS エコー要求を処理する中継ルータに依存します。Cisco ルータでは、TTL が期限切れになると、パケットが処理のために Route Processor(RP; ルート プロセッサ)に送信されます。中継ルータは、TTL が期限切れになった MPLS パケットに応じて、中継ホップに関する情報を含む MPLS エコー応答を返します。

MPLS エコー応答の宛先ポートは、エコー要求の送信元ポートに設定されます。


) ルータがトラフィック エンジニアリング トンネルを通過する IPV4 FEC をトレースすると、中間ルータは、中間ルータで LDP が実行されていない場合に U(到達不能)を返すことがあります。


図 2 に、LSR1 から LSR4 までの LSP の MPLS LSP traceroute 例を示します。

図 2 MPLS LSP Traceroute の例

 

LSR1 から LSR4 の FEC に対する LSP traceroute を入力すると、 表 2 に示すような結果になります。

 

表 2 図 2 に基づく MPLS LSP Traceroute の例

手順
ルータ
MPLS パケット タイプと説明
ルータのアクション(受信または送信)

1.

LSR1

MPLS エコー要求:ターゲット FEC は LSR4 とダウンストリーム マッピングを指す

ラベル スタックの TTL を 1 に設定する

要求を LSR2 に送信する

2.

LSR2

MPLS エコー応答

TTL = 1 のパケットを受信する

User Datagram Protocol(UDP; ユーザ データグラム プロトコル)パケットを MPLS エコー要求として処理する

ダウンストリーム マッピングを検索し、着信ラベルに基づいて独自のダウンストリーム マッピングを付加して LSR1 に応答する

3.

LSR1

MPLS エコー要求:ターゲット FEC は同じで、LSR2 からのエコー応答で受信したダウンストリーム マッピングを含む

ラベル スタックの TTL を 2 に設定する

要求を LSR2 に送信する

4.

LSR2

MPLS エコー要求

TTL = 2 のパケットを受信する

TTL を減らす

エコー要求を LSR3 に転送する

5.

LSR3

MPLS 応答パケット

TTL = 1 のパケットを受信する

UDP パケットを MPLS エコー要求として処理する

ダウンストリーム マッピングを検索し、着信ラベルに基づいて独自のダウンストリーム マッピングを付加して LSR1 に応答する

6.

LSR1

MPLS エコー要求:ターゲットの FEC は同じで、LSR3 からのエコー応答で受信したダウンストリーム マッピングを含む

パケットの TTL を 3 に設定する

要求を LSR2 に送信する

7.

LSR2

MPLS エコー要求

TTL = 3 のパケットを受信する

TTL を減らす

エコー要求を LSR3 に転送する

8.

LSR3

MPLS エコー要求

TTL = 2 のパケットを受信する

TTL を減らす

エコー要求を LSR4 に転送する

9.

LSR4

MPLS エコー応答

TTL = 1 のパケットを受信する

UDP パケットを MPLS エコー要求として処理する

ダウンストリーム マッピングを検索し、ルータがターゲット FEC の出力ルータであることも確認する

LSR1 に応答する

MPLS LSP ping および MPLS LSP Traceroute を使用した MPLS ネットワーク管理

MPLS ネットワークを管理するには、LSP を監視して MPLS 転送の問題を迅速に隔離できる必要があります。そのためには、LSP の動作を評価したり、LSP によるユーザ トラフィックの伝送の失敗を検出したりする方法が必要です。

MPLS LSP ping を使用すると、IPv4 LDP プレフィクス宛てのパケットの転送に使用される LSP や AToM PW FEC を確認できます。MPLS LSP traceroute を使用すると、IPv4 LDP プレフィクス宛てのパケットの伝送に使用される LSP をトレースできます。

MPLS エコー要求は、検証する LSP 経由で送信されます。TTL の期限切れまたは LSP の切断が発生すると、中継ルータはエコー要求を目的の宛先に到達する前に処理します。ルータは説明的な応答コードを含む MPLS エコー応答をエコー要求の送信元に返します。

成功したエコー要求は LSP の出口で処理されます。エコー応答は IP パス、MPLS パス、または両方のパスの組み合せを経由してエコー要求の送信元に返送されます。

Any Transport over MPLS 仮想回線接続

AToM Virtual Circuit Connection Verification(VCCV; 仮想回線接続性検証)を使用すると、送信元の Provider Edge(PE; プロバイダー エッジ)ルータから AToM PW の帯域内で制御パケットを送信できます。伝送は宛先 PE ルータで代行受信され、Customer Edge(CE; カスタマー エッジ)ルータには転送されません。この機能により、MPLS LSP ping を使用して AToM Virtual Circuit(VC; 仮想回線)の PW セクションをテストできます。

LSP ping を使用すると、FEC 128 または FEC 129 による AToM VC のセットアップを検証できます。FEC 128 ベースの AToM VC をセットアップするには、シグナリングに LDP を使用するか、2 つのエンドポイントでシグナリング コンポーネントを使用しないで静的な擬似回線設定を使用します。Cisco IOS では、MPLS ping の発行中、FEC 128 と FEC 129 の静的な擬似回線は区別されず、同じコマンドが使用されます。

AToM VCCV は次のコンポーネントで構成されます。

VC ラベルのシグナリング中に AToM VCCV 機能がアドバタイズされるシグナリング対象のコンポーネント

AToM VC ペイロードが制御パケットとして処理されるスイッチング コンポーネント

AToM VCCV シグナリング

AToM VC セットアップの手順の 1 つは、AToM VC エンドポイント間での VC ラベルと AToM VCCV 機能のシグナリングまたは通信です。各エンドポイントの AToM VCCV ディスポジション機能を通信するために、ルータは IETF インターネット ドラフト『 Pseudo Wire (PW) Virtual Circuit Connection Verification (VCCV) 』(draft-ieft-pwe3-vccv-01)で定義されているオプション パラメータを使用します。

AToM VCCV ディスポジション機能は、次のように分類されます。

アプリケーション:MPLS LSP ping と ICMP ping は、パケットを制御用に AToM PW の帯域内で送信するために AToM VCCV によってサポートされるアプリケーションです。

スイッチング モード:AToM VCCV で制御トラフィックとデータ トラフィックを区別するために使用されるスイッチング モードとして、タイプ 1 とタイプ 2 があります。

表 3 に、AToM VCCV のタイプ 1 とタイプ 2 のスイッチング モードを示します。

 

表 3 タイプ 1 とタイプ 2 の AToM VCCV スイッチング モード

スイッチング モード
説明

タイプ 1

AToM 制御ワードの Protocol ID(PID; プロトコル ID)フィールドを使用して、AToM VCCV パケットを識別します。

タイプ 2

VC ラベルの上の MPLS ルータ アラート ラベルを使用して、AToM VCCV パケットを識別します。

AToM VCCV スイッチング タイプの選択

Cisco ルータでは、AToM VC 制御チャネルを介して MPLS LSP ping パケットを送信するときに、使用可能な場合は常にタイプ 1 スイッチングを使用します。タイプ 2 スイッチングは、AToM 制御ワードをサポートまたは解釈しない VC タイプと実装に対応します。

表 4 に、AToM VC によってアドバタイズされる AToM VCCV スイッチング モードと選択されるスイッチング モードを示します。

 

表 4 AToM VC によってアドバタイズおよび選択される AToM VCCV スイッチング モード

アドバタイズされるタイプ
選択されるタイプ

AToM VCCV はサポートされない

--

タイプ 1 AToM VCCV スイッチング

タイプ 1 AToM VCCV スイッチング

タイプ 2 AToM VCCV スイッチング

タイプ 2 AToM VCCV スイッチング

タイプ 1 およびタイプ 2 AToM VCCV スイッチング

タイプ 1 AToM VCCV スイッチング

AToM VC は、AToM VCCV ディスポジション機能を両方向、つまり送信元ルータ(PE1)から宛先ルータ(PE2)へ、PE2 から PE1 へアドバタイズします。

2 つのエンドポイントの AToM VCCV 機能が異なる場合、AToM VC は異なるスイッチング タイプを使用することがあります。PE1 がタイプ 1 およびタイプ 2 AToM VCCV スイッチングをサポートし、PE2 がタイプ 2 AToM VCCV スイッチングだけをサポートしている場合は、次の 2 とおりの結果になります。

PE1 から PE2 に送信された LSP ping パケットは、タイプ 2 スイッチングでカプセル化される。

PE2 から PE1 に送信された LSP ping パケットは、タイプ 1 スイッチングを使用する。

ピアにアドバタイズされた AToM VCCV 機能やピアから受信した AToM VCCV 機能を確認するには、PE ルータで show mpls l2transport binding コマンドを入力します。

LSP ping または LSP traceroute を処理するルータから提供される情報

表 5 に、LSP ping または LSP traceroute パケットを処理するルータから、要求の成否について送信者に返される文字を示します。

ping mpls コマンドで verbose キーワードを入力して、MPLS LSP ping 動作の戻りコードを表示することもできます。

 

表 5 エコー応答の戻りコード

出力コード
エコーの戻りコード
意味

x

0

戻りコードはない。

M

1

不正なエコー要求。

m

2

サポートされていない TLV。

!

3

成功。

F

4

FEC マッピングはない。

D

5

DS マップのミスマッチ。

I

6

不明なアップストリーム インターフェイス インデックス。

U

7

予約済み。

L

8

ラベル付けされた出力インターフェイス。

B

9

ラベル付けされていない出力インターフェイス。

f

10

FEC のミスマッチ。

N

11

ラベル エントリはない。

P

12

受信インターフェイスのラベル プロトコルがない。

p

13

LSP の終了が不完全。

X

unknown

未定義の戻りコード。


) エコーの戻りコード 6 と 7 は、バージョン 3(draft-ieft-mpls-ping-03)でだけ受け入れられます。


IP では MPLS エコー要求パケットは転送されない

LSP ping 中に送信された MPLS エコー要求パケットは、IP によって転送されません。MPLS エコー要求パケットの IP ヘッダーの宛先アドレス フィールドは 127. x.y.z /8 アドレスです。ルータは 127. x.y.z /8 アドレスを使用したパケットを転送しません。127. x.y.z /8 アドレスは、ローカル ホストのアドレスに対応します。

127. x . y . z アドレスを UDP パケットの宛先アドレスとして使用することが重要です。これは、中継ルータが LSP のラベル スイッチングを行わない場合、MPLS エコー要求パケットは、このアドレスをターゲット ルータにすることができないためです。127. x . y . z アドレスを使用すると、LSP の切断を検出できます。中継ルータでは、次のことが発生します。

中継ルータで LSP の切断が発生した場合、MPLS エコー パケットは転送されず、ルータによって使用されます。

LSP が切断されていない場合、MPLS エコー パケットはターゲット ルータに到達し、LSP の終点で処理されます。

図 3 に、中継ルータが LSP でパケットのラベル スイッチングに失敗した場合の MPLS エコー要求と応答のパスを示します。

図 3 中継ルータがパケットのラベル スイッチングに失敗した場合のパス


) AToM ペイロードは IP パケットではない可能性があるため、ペイロードには中継ルータで使用可能なフォワーディング情報が格納されません。MPLS VPN パケットは IP パケットですが、MPLS ネットワークのエンドポイントの Virtual Routing and Forwarding(VRF)インスタンスには宛先 IP アドレスだけが重要であるため、MPLS VPN パケットには中継ルータで使用可能なフォワーディング情報が格納されません。


MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の設定方法

ここでは、次の作業について説明します。

「MPLS LSP と ping または traceroute 実装間の互換性のイネーブル化」(必須)

「MPLS LSP ping と MPLS LSP Traceroute を使用した FEC の検証」(必須)

「DSCP を使用した、エコー応答における特定のサービス クラスの要求」(任意)

「MPLS エコー要求に対する応答ルータの応答方法の制御」(任意)

「MPLS LSP ping および LSP Traceroute コマンド オプション使用時のループの回避」(任意)

「LSP の切断の検出」(任意)

MPLS LSP と ping または traceroute 実装間の互換性のイネーブル化

バージョン 3(draft-ietf-mpls-ping-03)よりもあとの LSP ping ドラフトでは、多数の TLV 形式の変更が行われていますが、ドラフトのバージョン同士が必ずしも相互運用するとはかぎりません。

新しいシスコの実装がドラフト バージョン 3 のシスコの実装やシスコ以外の実装と相互運用できるようにするには、グローバル コンフィギュレーション モードを使用して、エコー パケットをドラフト バージョン 3 の実装によって認識される形式でデコードします。

特に設定がなければ、シスコの実装では、IETF の実装がベースにしているバージョンを想定して、エコー要求の符号化とデコードを行います。

TLV バージョンの問題によって発生するエラーが応答側ルータから報告されないようにするには、コア内のすべてのルータを設定する必要があります。同じドラフト バージョンで MPLS エコー パケットを符号化およびデコードしてください。たとえば、ネットワークで RFC 4379(シスコ バージョン 4)の実装が実行され、1 つのルータがバージョン 3(シスコ リビジョン 3)にだけ対応している場合は、ネットワーク内のすべてのルータをリビジョン 3 モードで動作するように設定します。

MPLS エコー要求とエコー応答のシスコの実装は、IETF RFC 4379 に基づいています。この RFC よりもあとの IEFT ドラフト(ドラフト 3、4、5、6、および 7)では、TLV 形式に相違があります。エコー パケットでは、ある TLV 形式と別の TLV 形式を区別できないため、これらの相違を識別できません。これにより、Cisco IOS 12.0(27)S1 リリースと 12.0(27)S2 リリースにおける MPLS LSP Ping/Traceroute の実装およびその後の Cisco IOS リリースにおける MPLS ping または traceroute の実装間の互換性に制限があります。これらのリリース間の相互運用を可能にするために、 ping mpls コマンドと trace mpls コマンドに revision キーワードが追加されました。 revision キーワードを使用すると、Cisco IOS リリースは既存のドラフトの変更と今後の IETF LSP ping ドラフト バージョンからの変更に対応できるようになります。


) revision オプションの代わりに、mpls oam グローバル コンフィギュレーション コマンドを使用することを推奨します。



) cisco.com ではリビジョン 2 をサポートするイメージを入手できません。TLV の符号化とデコードのモードを設定する場合は、バージョン 3 以降をサポートするイメージだけを使用することを推奨します。MPLS マルチパス LSP traceroute を使用するには、シスコ リビジョン 4 以降が必要です。


シスコのベンダー拡張

シスコ バージョン 3(draft-ietf-mpls-ping-03.txt)の実装では、ignore-if-not-understood TLV スペースにベンダー拡張 TLV が定義されています。これは次の目的で使用されます。

TLV バージョンを追跡する機能を提供する。

試験的な応答 TOS 機能を提供する。

最初の機能は、エコー パケットの符号化とデコードの動作を設定するために、グローバル コンフィギュレーション コマンドよりも前に定義されました。設定されたデコード動作は、エコー パケット内の TLV バージョン情報によって上書きされます。グローバル コンフィギュレーション機能の導入後、TLV バージョンにこの TLV を使用する必要はなくなりました。

2 番めの機能は、応答 DSCP を制御します。ドラフト バージョン 8 では、応答 TOS TLV が定義されているため、応答 DSCP を使用する必要はなくなりました。

エコー パケットのデフォルト動作をカスタマイズして MPLS LSP と ping または traceroute 実装間の互換性をイネーブルにするには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls oam

4. echo revision { 3 | 4 }

5. echo vendor-extension

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls oam

 

Router(config)# mpls oam

エコー パケットのデフォルト動作をカスタマイズするために、MPLS OAM コンフィギュレーション モードを開始します。

ステップ 4

echo revision { 3 | 4 }

 

Router(config-mpls)# echo revision 4

エコー パケットのデフォルト値のリビジョン番号を指定します。

3:draft-ietf-mpls-ping-03(リビジョン 2)

4:RFC 4379 準拠(デフォルト)

ステップ 5

echo vendor-extension

 

Router(config-mpls)# echo vendor-extension

エコー パケットで TLV のシスコ独自の拡張を送信します。

ステップ 6

exit

 

Router(config-mpls)# exit

グローバル コンフィギュレーション モードに戻ります。

MPLS LSP ping と MPLS LSP Traceroute を使用した FEC の検証

LSP はラベルで構成されています。ルータは、LDP、AToM、またはその他の MPLS アプリケーションを使用してラベルを認識します。MPLS LSP ping または traceroute を使用して、特定の FEC のトラフィックを転送するために使用される LSP を検証できます。

ここでは、次の作業について説明します。

「MPLS LSP ping と MPLS LSP Traceroute を使用した LDP IPv4 FEC の検証」

「MPLS LSP ping と MPLS LSP Traceroute を使用したレイヤ 2 FEC の検証」

MPLS LSP ping と MPLS LSP Traceroute を使用した LDP IPv4 FEC の検証

ルータが LDP によってアドバタイズされた IPv4 FEC プレフィクスの MPLS パケットを転送できるようにするには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls ipv4 destination-address / destination-mask-length [ repeat count ] [ exp exp-bits ] [ verbose ]

または

trace mpls ipv4 destination-address / destination-mask-length

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls ipv4 destination-address / destination-mask-length [ repeat count ] [ exp exp-bits ] [ verbose ]

または

trace mpls ipv4 destination-address / destination-mask-length

 

Router# ping mpls ipv4 10.131.191.252/32 exp 5 repeat 5 verbose

 

または

 

Router# trace mpls ipv4 10.131.191.252/32

検証する LDP IPv4 プレフィクスの FEC を選択します。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

MPLS LSP ping と MPLS LSP Traceroute を使用したレイヤ 2 FEC の検証

ルータが LDP によってアドバタイズされたレイヤ 2 FEC プレフィクスの MPLS パケットを転送できるようにするには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls pseudowire ipv4-address vc-id vc-id

3. exit

手順の詳細

 

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls pseudowire ipv4-address vc-id vc-id

 

 

Router# ping mpls pseudowire 10.131.191.252 vc-id 333

検証するレイヤ 2 FEC を選択します。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

DSCP を使用した、エコー応答における特定のサービス クラスの要求

Cisco IOS Release 12.2(27)SXE では、応答 Differentiated Services Code Point(DSCP; DiffServ コード ポイント)オプションが追加されました。このオプションを使用すると、エコー応答における特定の Class of Service(CoS; サービス クラス)を要求できます。

応答 DSCP オプションは、IETF draft-ietf-mpls-lsp-ping-03.txt の試験モードでサポートされます。シスコは、応答 TOS TLV を使用するのではなく、応答 DSCP オプションのベンダー固有の拡張を実装しました。応答 TOS TLV は、RFC 4379 の reply dscp コマンドと同じ目的を果たします。このドラフトは、応答 DSCP を制御するための標準化された方法を示します。


) ドラフト バージョン 8 よりも前のバージョンでは、シスコは応答 DSCP オプションをシスコのベンダー拡張 TLV を使用した試験的な機能として実装しました。ルータがドラフト バージョン 3 の実装の MPLS エコー パケットを符号化するように設定されている場合は、ドラフト バージョン 8 で定義された応答 TOS TLV の代わりに、シスコのベンダー拡張 TLV が使用されます。


DSCP を使用してエコー応答における特定の CoS を要求するには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask-length | pseudowire ipv4-address vc-id vc-id } [ reply dscp dscp-value ]

または

trace mpls ipv4 destination-address / destination-mask-length [ reply dscp dscp-value ]

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask-length | pseudowire ipv4-address vc-id vc-id } [ reply dscp dscp-value ]

 

または

trace mpls ipv4 destination-address / destination-mask-length [ reply dscp dscp-value ]

 

Router# ping mpls ipv4 10.131.191.252/32 reply dscp 50

 

または

 

Router# trace mpls ipv4 10.131.191.252/32 reply dscp 50

エコー応答の DSCP 値を制御します。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

MPLS エコー要求に対する応答ルータの応答方法の制御

MPLS エコー要求に対する応答ルータの応答方法を制御するには、「MPLS LSP ping と LSP Traceroute のエコー要求応答の応答モード」を参照してください。

MPLS LSP ping と LSP Traceroute のエコー要求応答の応答モード

応答モードは、 ping mpls コマンドまたは trace mpls コマンドによって送信された MPLS エコー要求に対する応答ルータの応答方法を制御します。エコー要求パケットには、次の 2 つの応答モードがあります。

ipv4:IPv4 UDP パケットで応答する(デフォルト)。

router-alert:ルータ アラートを含む IPv4 UDP パケットで応答する。


) ipv4 および router-alert 応答モードを互いに組み合せて使用すると、false negative を防ぐことができます。ipv4 モードで応答を受信できない場合は、router-alert 応答モードでテストを送信すると役に立ちます。両方のモードで失敗する場合は、リターン パスに何か問題があります。唯一考えられる問題は、応答 TOS が正しく設定されていないことです。


ipv4 応答モード

IPv4 パケットは、LSP の完全性を定期的にポーリングする場合に、 ping mpls コマンドまたは trace mpls コマンドで使用される最も一般的な応答モードです。このオプションは、パケットが IP ホップと MPLS ホップのいずれを通過して MPLS エコー要求の送信元に到達するかを明示的に制御するものではありません。 reply mode ipv4 キーワードを使用した場合に、送信元(ヘッドエンド)ルータが MPLS エコー要求に対する応答を受信できないときは、 reply mode router-alert キーワードを使用します。

router-alert 応答モード

router-alert 応答モードを使用すると、ルータ アラート オプションが IP ヘッダーに追加されます。IP ヘッダーに IP ルータ アラート オプションを含む IP パケット、または最も外側のラベルとしてルータ アラート ラベルを含む MPLS パケットがルータに到達すると、ルータはパケットを処理するために Route Processor(RP; ルート プロセッサ)レベルにパント(リダイレクト)します。これにより、Cisco ルータはパケットが宛先に戻るときに各中間ホップでパケットを処理します。ハードウェアとラインカード フォワーディングの不整合は回避されます。router-alert 応答モードは、応答がホップバイホップで移動するため、IPv4 モードよりもコストがかかります。処理速度も遅いため、送信元が応答を受信するまで比較的長い時間がかかります。

表 6 に、IP ルータ アラート オプションを含む IP パケットと MPLS パケットがルータ スイッチング パス プロセスによって処理される方法を示します。

 

表 6 パス プロセスによる IP および MPLS ルータ アラート パケットの処理

着信パケット
通常のスイッチング アクション
プロセス スイッチング アクション
発信パケット

IP パケット:IP ヘッダーにルータ アラート オプションが含まれる

IP ヘッダーにルータ アラート オプションが含まれていると、パケットはプロセス スイッチング パスにパントされる。

パケットをそのまま転送する。

IP パケット:IP ヘッダーにルータ アラート オプションが含まれる

パケットをそのまま転送する。

MPLS パケット

MPLS パケット:最も外側のラベルにルータ アラートが含まれる

ルータ アラート ラベルが最も外側のラベルである場合、パケットはプロセス スイッチング パスにパントされる。

最も外側のルータ アラート ラベルを削除し、パケットを IP パケットとして転送する。

IP パケット:IP ヘッダーにルータ アラート オプションが含まれる

最も外側のルータ アラート ラベルを保持し、MPLS パケットを転送する。

MPLS パケット:最も外側のラベルにルータ アラートが含まれる

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask-length | pseudowire ipv4-address vc-id vc-id } reply mode { ipv4 | router-alert }

または

trace mpls ipv4 destination-address / destination-mask reply mode { ipv4 | router-alert }

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask-length | pseudowire ipv4-address vc-id vc-id } reply mode { ipv4 | router-alert }

 

または

trace mpls ipv4 destination-address / destination-mask reply mode { ipv4 | router-alert }

 

Router# ping mpls ipv4 10.131.191.252/32 reply mode ipv4

 

または

Router# trace mpls ipv4 10.131.191.252/32 reply mode router-alert

MPLS LSP 接続をチェックします。

または

パケットが宛先に転送されるときに実際にたどる MPLS LSP ルートを検出します。

キーワードを入力する必要があります。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

MPLS LSP ping および LSP Traceroute コマンド オプション使用時のループの回避

MPLS Embedded Management の相互作用機能である LSP Ping for LDP 機能オプションを使用すると、ループが発生します。 ping mpls コマンドと trace mpls コマンドで発生する可能性があるループについては、次の項を参照してください。

「MPLS LSP ping を使用したループの検出」

「MPLS LSP traceroute を使用したループの検出」

MPLS LSP ping を使用したループの検出

MPLS LSP ping 機能を使用すると、UDP 宛先アドレス範囲、繰り返しオプション、またはスイープ オプションを使用した場合に、ループが発生する可能性があります。

MPLS LSP ping を使用してループを検出するには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask [ destination address-start address-end increment ] | [ pseudowire ipv4-address vc-id vc-id address-end increment ] } [ repeat count ] [ sweep minimum maximum size-i ncrement ]

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask [ destination address-start address-end increment ] |[ pseudowire ipv4-address vc-id vc-id address-end increment ]} [ repeat count ] [ sweep minimum maximum size-i ncrement ]

 

Router# ping mpls ipv4 10.131.159.251/32 destination 127.0.0.1 127.0.0.2 1 repeat 2 sweep 1450 1475 25

MPLS LSP 接続をチェックします。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

MPLS LSP traceroute を使用したループの検出

MPLS LSP Traceroute 機能を使用すると、UDP 宛先アドレス範囲オプションと存続可能時間オプションを使用した場合に、ループが発生する可能性があります。

デフォルトでは、最大 TTL は 30 に設定されます。したがって、traceroute のターゲットに到達しない場合は(LSP に問題がある場合に発生する可能性があります)、traceroute の出力に 30 行のエントリが含まれることがあります。LSP に問題が発生した場合は、エントリが重複する可能性があります。トレースが最後に到達するポイントのルータ アドレスは、出力が 30 行になるまで繰り返されます。重複したエントリは無視できます。

手順の概要

1. enable

2. trace mpls ipv4 destination-address / destination-mask [ destination address-start address-end address-increment ] [ ttl maximum-time-to-live ]

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

trace mpls ipv4 destination-address / destination-mask [ destination address-start address-end address increment ] [ ttl maximum-time-to-live ]

 

Router# trace mpls ipv4 10.131.159.251/32 destination 127.0.0.1 127.0.0.3 1 ttl 5

パケットが宛先に転送されるときにたどる MPLS LSP ルートを検出します。例は、ループがどのように発生するかを示しています。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

LSP の切断の検出

ネットワークで MPLS パケットの転送に問題が発生した場合は、LSP が切断されている場所を特定できます。ここでは、LSP での MTU ディスカバリについて説明します。

最後から 2 番めのホップの非タグ付き出力インターフェイスは、LSP 経由の IP パケットの転送に影響しません。これは、転送判断が最後から 2 番めのホップで着信ラベルを使用して行われるためです。ただし、非タグ付き出力インターフェイスを使用すると、AToM と MPLS VPN のトラフィックが最後から 2 番めのホップでドロップされます。

MPLS LSP ping の実行中、MPLS エコー要求パケットは IP パケット アトリビュートが「do not fragment」に設定された状態で送信されます。つまり、パケットの IP ヘッダーに Don't Fragment(DF)ビットが設定されます。これにより、MPLS エコー要求を使用して、フラグメンテーションなしでパケットが LSP を通過できるようにするための MTU をテストできます。

図 4 に、LDP によってアドバタイズされたラベルで構成されている 1 つの LSP(PE1 から PE2 まで)のサンプル ネットワークを示します。

図 4 LSP のサンプル ネットワーク:LDP によってアドバタイズされたラベル

MPLS Traceroute 機能を使用して LSP をトレースすることによって、各ホップの Maximum Receive Unit(MRU; 最大受信ユニット)を確認できます。MRU は、LSP 経由で転送できる、ラベル付けされたパケットの最大サイズです。

ここでは、次の作業について説明します。

「暗黙的ヌルとタグ付けされたパケットの追跡」

「非タグ付きパケットの追跡」

「パケットを送信できない原因の特定」

「IPv4 LDP LSP でロード バランシングがイネーブルになっている場合の LSP 切断の検出」

「エコー パケットがルータから発信されるときに経由するインターフェイスの指定」

「パケット伝送のペーシング」

「エコー要求の request-dsmap を使用した、中継ルータに対するダウンストリーム情報の問い合せ」

「ルータに対する DSMAP の問い合せ」

「中継ルータによるターゲット FEC スタックの検証の要求」

「LSP ping のイネーブル化による、非タグ付きインターフェイスを起因とする LSP 切断の検出」

「ピアにアドバタイズされた AToM VCCV 機能やピアから受信した AToM VCCV 機能の表示」

暗黙的ヌルとタグ付けされたパケットの追跡

暗黙的ヌルとタグ付けされたパケットを追跡するには、次の手順を実行します。

手順の概要

1. enable

2. trace mpls ipv4 destination-address / destination-mask

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

trace mpls ipv4 destination-address / destination-mask

 

Router# trace mpls ipv4 10.131.159.252/32

パケットが宛先に転送されるときに実際にたどる MPLS LSP ルートを検出します。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

非タグ付きパケットの追跡

非タグ付きパケットを追跡するには、次の手順を実行します。

手順の概要

1. enable

2. show mpls forwarding-table destination-address / destination-mask

3. show mpls ldp discovery

4. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show mpls forwarding-table destination-address/destination-mask

 

Router# show mpls forwarding-table 10.131.159.252/32

MPLS Label Forwarding Information Base(LFIB; ラベル転送情報ベース)のコンテンツを表示し、LDP が正しく設定されているかどうかを示します。

ステップ 3

show mpls ldp discovery

 

Router# show mpls ldp discovery

LDP ディスカバリ プロセスのステータスを表示し、LDP が正しく設定されているかどうかを示します。

ステップ 4

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

パケットを送信できない原因の特定

Q 戻りコードは、パケットを送信できなかったことを意味します。この問題は、処理メモリの不足が原因である場合がありますが、コマンド ラインで入力された FEC 情報に一致する LSP が見つからなかったために発生した可能性があります。

LSP のパスの問題を修正できるように、パケットが転送されなかった原因を特定する必要があります。そのためには、Routing Information Base(RIB; ルーティング情報ベース)、Forwarding Information Base(FIB; 転送情報ベース)、Label Information Base(LIB; ラベル情報ベース)、および MPLS LFIB を調べます。これらのルーティングまたはフォワーディング ベースに FEC のエントリがない場合は、戻りコードが Q になります。

パケットを送信できなった原因を特定するには、次の手順を実行します。

手順の概要

1. enable

2. show ip route [ip-address [ mask ]]

3. show mpls forwarding-table [ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]]

4. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip route [ip-address [ mask ]]

 

Router# show ip route 10.0.0.1

ルーティング テーブルの現在のステータスを表示します。

MPLS エコー応答が Q を返すと、ルーティング情報データベースでトラブルシューティングが実行されます。

ステップ 3

show mpls forwarding-table [ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]]

 

Router# show mpls forwarding-table 10.0.0.1/32

MPLS LFIB のコンテンツを表示します。MPLS エコー応答が Q を返すと、ラベル情報データベースと MPLS 転送情報データベースでトラブルシューティングが実行されます。

ステップ 4

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

IPv4 LDP LSP でロード バランシングがイネーブルになっている場合の LSP 切断の検出

ICMP ping または trace は、送信元ルータからターゲット ルータまでの 1 本のパスをたどります。送信元ルータからの IP パケットのラウンド ロビン ロード バランシングでは、ターゲット IP アドレスへのさまざまな出力パスを検出します。

MPLS ping と traceroute の場合、ネットワークにターゲット ルータへの複数のパスが存在するときに、Cisco ルータはロード バランシングに IP ヘッダー内の送信元アドレスと宛先アドレスを使用します。MPLS のシスコの実装では、IP ペイロードの宛先アドレスをチェックしてロード バランシングを実行する場合があります(チェックのタイプはプラットフォームによって異なります)。

IPv4 LDP LSP でロード バランシングがイネーブルになっている場合に LSP の切断を検出するには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls ipv4 destination-address / destination-mask-length [ destination address-start address-end increment ]

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls ipv4 destination-address / destination-mask-length [ destination address-start address-end increment ]

 

Router# ping mpls ipv4 10.131.159.251/32 destination 127.0.0.1/8

ロード バランシングのパスをチェックします。

127 .z.y.x /8 宛先アドレスを入力します。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

エコー パケットがルータから発信されるときに経由するインターフェイスの指定

エコー パケットがルータから発信されるときに経由するインターフェイスを指定するには、次の手順を実行します。

エコー要求の出力インターフェイス制御

エコー パケットがルータから発信されるときに経由するインターフェイスを制御できます。パス出力情報は、LSP ping と traceroute への入力として使用されます。

エコー要求の出力インターフェイス制御機能を使用すると、LSP の詳細なデバッグや評価を行うパスをエコー パケットが通過することを強制できます。この機能は、PE ルータが MPLS クラウドに接続し、切断されたリンクがある場合に役立ちます。特定のリンクを介してトラフィックを誘導できます。この機能は、ネットワークの問題のトラブルシューティングにも役立ちます。

エコー要求の出力インターフェイスを指定するには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } [ output interface tx-interface ]

または

trace mpls ipv4 destination-address / destination-mask [ output interface tx-interface ]

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } [ output interface tx-interface ]

または

trace mpls ipv4 destination-address / destination-mask [ output interface tx-interface ]

 

Router# ping mpls ipv4 10.131.159.251/32 output interface ethernet0/0

または

Router# trace mpls ipv4 10.131.159.251/32 output interface ethernet0/0

MPLS LSP 接続をチェックします。

または

パケットが宛先に転送されるときに実際にたどる MPLS LSP ルートを検出します。

キーワードを指定する必要があります。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

パケット伝送のペーシング

エコー要求のトラフィック ペーシングを使用すると、受信側ルータがパケットをドロップしないように、パケット伝送をペーシングできます。エコー要求のトラフィック ペーシングを実行するには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } [ interval ms ]

または

trace mpls ipv4 destination-address / destination-mask

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } [ interval ms ]

 

または

trace mpls ipv4 destination-address / destination-mask

 

Router# ping mpls ipv4 10.131.159.251/32 interval 2

 

または

 

Router# trace mpls ipv4 10.131.159.251/32

MPLS LSP 接続をチェックします。

または

パケットが宛先に転送されるときにたどる MPLS LSP ルートを検出します。

キーワードを指定する必要があります。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

エコー要求の request-dsmap を使用した、中継ルータに対するダウンストリーム情報の問い合せ

エコー要求の request-dsmap のトラブルシューティング機能を TTL フラグと組み合せて使用すると、中継ルータに選択的に問い合せることができます。エラーがある場合は、以前の各エラーに対して lsp traceroute コマンドを入力する必要はありません。失敗したホップにだけ集中できます。

ダウンストリーム マッピングのフラグ フィールドの request-dsmap フラグと非準拠ルータの追跡方法を指定する手順によって、ワイルドカード Downstream Map(DSMAP; ダウンストリーム マップ)で任意に MPLS エコー要求パケットの Time-to-Live(TTL; 存続可能時間)を期限切れにすることができます。

ラベルのないエコー要求の DSMAP を受信した場合、送信元に検証する DSMAP がなかったことを意味します。エコー要求の DSMAP TLV のダウンストリーム ルータ ID フィールドが ALLROUTERs アドレス(224.0.0.2)に設定され、ラベルがない場合、送信元ルータは任意に中継ルータに対して DSMAP 情報を問い合せることができます。

ping mpls コマンドを使用すると、トラブルシューティングやダウンストリーム ルータに対する DSMAP の問い合せのために、ワイルドカード DSMAP を使用して中継ルータの MPLS エコー要求の TTL を期限切れにすることができます。デフォルトでは、DSMAP には IPv4 ビットマップ ハッシュキーがあります。ハッシュキー 0(なし)を選択することもできます。 ping mpls コマンドの目的は、送信元ルータが中継ルータのエコー要求の TTL を選択的に期限切れにして、中継ルータにダウンストリーム情報を問い合せることができるようにすることです。マルチパス(ハッシュキー)タイプも選択できるようにすると、送信元ルータは、マルチパス LSP traceroute の場合と同様に、中継ルータに対してロード バランシング情報を問い合せることができます。このとき、送信元ルータと各エコー要求の TTL が期限切れになるルータ間を通過するすべての後続ノードに問い合せる必要はありません。エコー要求は、TTL 設定と組み合せて使用します。これは、エコー要求に使用した LSP の出口にエコー要求が到達しても、応答ルータは DSMAP を返さないためです。

エラーがある場合に失敗したホップにだけ集中できるように、中継ルータにダウンストリーム情報を問い合せるには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } [ dsmap [ hashkey { none | ipv4 bitmap bitmap-size }]]

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } [ dsmap [ hashkey { none | ipv4 bitmap bitmap-size }]]

 

Router# ping mpls ipv4 10.161.251/32 dsmap hashkey ipv4 bitmap 16

MPLS LSP 接続をチェックします。

キーワードを指定する必要があります。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

ルータに対する DSMAP の問い合せ

ルータは、ソフトウェアまたはハードウェアのフォワーディング レイヤに DSMAP TLV で返す必要がある深度制限を問い合せることができます。フォワーディングによって値が提供されない場合、デフォルトは 255 です。

深度制限を確認するには、 ping mpls コマンドで dsmap キーワードと ttl キーワードを指定します。中継ルータは、DSMAP についての問い合せを受けます。深度制限は、エコー応答の DSMAP とともに返されます。値が 0 の場合、IP ヘッダーはロード バランシングに使用されています。別の値の場合、IP ヘッダーはその数のラベルまでロード バランスを行います。

ルータに DSMAP を問い合せるには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } ttl time-to-live dsmap

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } ttl time-to-live dsmap

 

Router# ping mpls ipv4 10.131.159.252/32 ttl 1 dsmap

MPLS LSP 接続をチェックします。

キーワードを指定する必要があります。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

中継ルータによるターゲット FEC スタックの検証の要求

MPLS エコー要求は、特定の LSP をテストします。テスト対象の LSP は、FEC スタックで識別されます。

中継ルータにターゲット FEC スタックの検証を要求するには、送信元ルータから ping mpls コマンドと trace mpls コマンドに flags fec キーワードを入力して V フラグを設定します。デフォルトでは、エコー要求パケットは V フラグが 0 に設定されて送信されます。

中継ルータにターゲット FEC スタックの検証を要求するには、次の手順を実行します。

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } flags fec

または

trace mpls ipv4 destination-address / destination-mask flags fec

3. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } flags fec

 

または

trace mpls ipv4 destination-address / destination-mask flags fec

 

Router# ping mpls ipv4 10.131.159.252/32 flags fec

 

または

 

Router# trace mpls ipv4 10.131.159.252/32 flags fec

MPLS LSP 接続をチェックします。

または

パケットが宛先に転送されるときに実際にたどる MPLS LSP ルートを検出します。

キーワードを入力する必要があります。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

LSP ping のイネーブル化による、非タグ付きインターフェイスを起因とする LSP 切断の検出

IPv4 FEC を伝送する LSP の MPLS LSP ping と traceroute では、ラベルが要求されていない場合でも、明示的ヌル ラベルを MPLS ラベル スタックに強制的に追加できます。これにより、LSP ping で非タグ付きインターフェイスを起因とする LSP の切断を検出できます。LSP ping は、LSP が MPLS トラフィックを送信できない場合は LSP が動作していると報告しません。

明示的ヌル ラベルが MPLS ラベル スタックに追加されるのは、MPLS エコー要求パケットが LSP ping の宛先に直接接続されている非タグ付きインターフェイスから転送された場合、または MPLS エコー要求パケットの IP TTL 値が 1 に設定されている場合です。

lsp ping コマンドを入力すると、LSP が IP トラフィックを伝送できるかどうかがテストされます。最後から 2 番めのホップの非タグ付き出力インターフェイスで発生したエラーは検出されません。明示的ヌル シムを使用すると、LSP の MPLS トラフィック伝送能力をテストできます。

LSP ping をイネーブルにして、非タグ付きインターフェイスを起因とする LSP の切断を検出するには、次の手順に示すように、 ping mpls コマンドまたは trace mpls コマンドで force-explicit-null キーワードを指定します。

手順の概要

1. enable

2. ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } force-explicit-null

または

trace mpls ipv4 destination-address / destination-mask force-explicit-null

3. exit

手順の詳細

 

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping mpls { ipv4 destination-address / destination-mask | pseudowire ipv4-address vc-id vc-id } force-explicit-null

 

または

trace mpls ipv4 destination-address / destination-mask force-explicit-null

 

Router# ping mpls ipv4 10.131.191.252/32 force-explicit null

 

または

 

Router# trace mpls ipv4 10.131.191.252/32 force-explicit-null

MPLS LSP 接続をチェックします。

または

パケットが宛先に転送されるときに実際にたどる MPLS LSP ルートを検出します。

キーワードを入力する必要があります。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

ピアにアドバタイズされた AToM VCCV 機能やピアから受信した AToM VCCV 機能の表示

ピアにアドバタイズされた AToM VCCV 機能やピアから受信した AToM VCCV 機能を表示するには、次の手順を実行します。

手順の概要

1. enable

2. show mpls l2transport binding

3. exit

手順の詳細

 

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show mpls l2transport binding

 

Router# show mpls l2transport binding

VC ラベルのバインディング情報を表示します。

ステップ 3

exit

 

Router# exit

ユーザ EXEC モードに戻ります。

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の設定例

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV 機能の例は、図 5 に示すサンプル トポロジに基づいています。

図 5 設定例のサンプル トポロジ

 

ここでは、次の設定例を示します。

「MPLS LSP と ping または traceroute 実装間の互換性のイネーブル化:例」

「MPLS LSP ping と MPLS LSP traceroute を使用した FEC の検証:例」

「DSCP を使用した、エコー応答における特定のサービス クラスの要求:例」

「MPLS エコー要求に対する応答ルータの応答方法の制御:例」

「MPLS LSP ping および LSP Traceroute コマンド オプション使用時のループの回避:例」

「LSP の切断の検出:例」

「ピアにアドバタイズされた AToM VCCV 機能やピアから受信した AToM VCCV 機能の表示:例」

MPLS LSP と ping または traceroute 実装間の互換性のイネーブル化:例

次に、RFC 4379 の解釈がシスコとは異なるベンダー実装と相互運用するように MPLS マルチパス LSP traceroute を設定する例を示します。

configure terminal
!
mpls oam
echo revision 4
no echo vendor-extension
exit
 

デフォルトのエコー リビジョン番号は 4 です。これは IEFT ドラフト 11 に対応します。

MPLS LSP ping と MPLS LSP traceroute を使用した FEC の検証:例

ここでは、次手順について説明します。

「MPLS LSP ping と MPLS LSP traceroute を使用した LDP IPv4 FEC の検証:例」

「MPLS LSP ping を使用したレイヤ 2 FEC の検証:例」

MPLS LSP ping と MPLS LSP traceroute を使用した LDP IPv4 FEC の検証:例

次に、 ping mpls コマンドを使用して IPv4 LDP LSP の接続をテストする例を示します。

Router# ping mpls ipv4 10.131.191.252/32 repeat 5 exp 5 verbose
 
Sending 5, 100-byte MPLS Echos to 10.131.191.252, timeout is 2 seconds:
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
! 10.131.191.230, return code 3
! 10.131.191.230, return code 3
! 10.131.191.230, return code 3
! 10.131.191.230, return code 3
! 10.131.191.230, return code 3
 
Success rate is 100 percent (5/5), round-trip min/avg/max = 100/10

MPLS LSP ping を使用したレイヤ 2 FEC の検証:例

次に、レイヤ 2 FEC を検証する例を示します。

Router# ping mpls pseudowire 10.10.10.15 108 vc-id 333
 
Sending 5, 100-byte MPLS Echos to 10.10.10.15,
timeout is 2 seconds, send interval is 0 msec:
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/32/40 ms PE-802#

DSCP を使用した、エコー応答における特定のサービス クラスの要求:例

次に、DSCP を使用してエコー応答における特定の CoS を要求する例を示します。

Router# ping mpls ipv4 10.131.159.252/32 reply dscp 50
 
<0-63> Differentiated services codepoint value
af11 Match packets with AF11 dscp (001010)
af12 Match packets with AF12 dscp (001100)
af13 Match packets with AF13 dscp (001110)
af21 Match packets with AF21 dscp (010010)
af22 Match packets with AF22 dscp (010100)
af23 Match packets with AF23 dscp (010110)
af31 Match packets with AF31 dscp (011010)
af32 Match packets with AF32 dscp (011100)
af33 Match packets with AF33 dscp (011110)
af41 Match packets with AF41 dscp (100010)
af42 Match packets with AF42 dscp (100100)
af43 Match packets with AF43 dscp (100110)
cs1 Match packets with CS1(precedence 1) dscp (001000)
cs2 Match packets with CS2(precedence 2) dscp (010000)
cs3 Match packets with CS3(precedence 3) dscp (011000)
cs4 Match packets with CS4(precedence 4) dscp (100000)
cs5 Match packets with CS5(precedence 5) dscp (101000)
cs6 Match packets with CS6(precedence 6) dscp (110000)
cs7 Match packets with CS7(precedence 7) dscp (111000)
default Match packets with default dscp (000000)
ef Match packets with EF dscp (101110)

MPLS エコー要求に対する応答ルータの応答方法の制御:例

次に、ipv4 応答モードを使用して MPLS LSP 接続をチェックする例を示します。

Router# ping mpls ipv4 10.131.191.252/32 reply mode ipv4

MPLS LSP ping および LSP Traceroute コマンド オプション使用時のループの回避:例

ここでは、次の例について説明します。

「MPLS LSP ping で発生する可能性があるループ:例」

「MPLS LSP Traceroute で発生する可能性があるループ:例」

MPLS LSP ping で発生する可能性があるループ:例

次の ping mpls コマンドを使用した場合のループの動作例を次に示します。

Router# ping mpls ipv4 10.131.159.251/32 destination 127.0.0.1 127.0.0.2 1 repeat 2
sweep 1450 1475 25

 

Sending 2, [1450..1500]-byte MPLS Echos to 10.131.159.251/32,

timeout is 2 seconds, send interval is 0 msec:

 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0

 

Type escape sequence to abort.

Destination address 127.0.0.1

!

!

Destination address 127.0.0.2

!

!

Destination address 127.0.0.1

!

!

Destination address 127.0.0.2

!

!

ping mpls コマンドは、終了アドレスに到達するまで、各宛先アドレスについて、パケット サイズの範囲ごとに送信されます。この例では、宛先アドレス 127.0.0.5 に到達するまでループは同じように続行されます。シーケンスは、数が repeat count キーワードと引数で指定した値に到達するまで続行されます。この例では、リピート回数は 2 です。MPLS LSP ping のループ シーケンスは次のようになります。

repeat = 1
destination address 1 (address-start)
for (size from sweep minimum to maximum, counting by size-increment)
send an lsp ping
 
destination address 2 (address-start + address-increment)
for (size from sweep minimum to maximum, counting by size-increment)
send an lsp ping
 
destination address 3 (address-start + address-increment + address-increment)
for (size from sweep minimum to maximum, counting by size-increment)
send an lsp ping
.
.
.
until destination address = address-end
 
.
.
.
until repeat = count 2

MPLS LSP Traceroute で発生する可能性があるループ:例

次の trace mpls コマンドを使用した場合のループの発生例を次に示します。

Router# trace mpls ipv4 10.131.159.251/32 destination 127.0.0.1 127.0.0.3 1 ttl 5
 
Tracing MPLS Label Switched Path to 10.131.159.251/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
Destination address 127.0.0.1
0 10.131.191.230 MRU 1500 [Labels: 19 Exp: 0]
R 1 10.131.159.226 MRU 1504 [implicit-null] 40 ms
! 2 10.131.159.225 40 ms
Destination address 127.0.0.2
0 10.131.191.230 MRU 1500 [Labels: 19 Exp: 0]
R 1 10.131.159.226 MRU 1504 [implicit-null] 40 ms
! 2 10.131.159.225 40 ms
Destination address 127.0.0.3
0 10.131.191.230 MRU 1500 [Labels: 19 Exp: 0]
R 1 10.131.159.226 MRU 1504 [implicit-null] 40 ms
! 2 10.131.159.225 48 ms
 

mpls trace コマンドは、宛先の end-address 引数で指定されたアドレスに到達するまで、各宛先アドレスについて、1 から最大 TTL( ttl maximum-time-to-live キーワードと引数)までの TTL ごとに送信されます。この例では、最大 TTL は 5 で、終了宛先アドレスは 127.0.0.3 です。MPLS LSP traceroute のループ シーケンスは次のようになります。

destination address 1 (address-start)
for (ttl from 1 to maximum-time-to-live)
send an lsp trace
 
destination address 2 (address-start + address-increment)
for (ttl from 1 to 5)
send an lsp trace
 
destination address 3 (address-start + address-increment + address-increment)
for (ttl from 1 to maximum-time-to-live)
send an lsp trace
.
.
.
until destination address = 4

 

次に、トレース中に IP アドレスが 10.6.1.6 のルータで LSP の問題が発生した場合の例を示します。

Router# traceroute mpls ipv4 10.6.7.4/32
 
Tracing MPLS Label Switched Path to 10.6.7.4/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.6.1.14 MRU 4470 [Labels: 22 Exp: 0]
R 1 10.6.1.5 MRU 4470 [Labels: 21 Exp: 0] 2 ms
R 2 10.6.1.6 4 ms <------ Router address repeated for 2nd to 30th TTL.
R 3 10.6.1.6 1 ms
R 4 10.6.1.6 1 ms
R 5 10.6.1.6 3 ms
R 6 10.6.1.6 4 ms
R 7 10.6.1.6 1 ms
R 8 10.6.1.6 2 ms
R 9 10.6.1.6 3 ms
R 10 10.6.1.6 4 ms
R 11 10.6.1.6 1 ms
R 12 10.6.1.6 2 ms
R 13 10.6.1.6 4 ms
R 14 10.6.1.6 5 ms
R 15 10.6.1.6 2 ms
R 16 10.6.1.6 3 ms
R 17 10.6.1.6 4 ms
R 18 10.6.1.6 2 ms
R 19 10.6.1.6 3 ms
R 20 10.6.1.6 4 ms
R 21 10.6.1.6 1 ms
R 22 10.6.1.6 2 ms
R 23 10.6.1.6 3 ms
R 24 10.6.1.6 4 ms
R 25 10.6.1.6 1 ms
R 26 10.6.1.6 3 ms
R 27 10.6.1.6 4 ms
R 28 10.6.1.6 1 ms
R 29 10.6.1.6 2 ms
R 30 10.6.1.6 3 ms <------ TTL 30.
 

ネットワーク内の最大ホップ数がわかっている場合は、 trace mpls ttl maximum-time-to-live コマンドを使用して、TTL を小さい値に設定できます。次の例では、上記の例と同じ traceroute コマンドを使用していますが、TTL が 5 に設定されています。

Router# traceroute mpls ipv4 10.6.7.4/32 ttl 5
 
Tracing MPLS Label Switched Path to 10.6.7.4/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.6.1.14 MRU 4470 [Labels: 22 Exp: 0]
R 1 10.6.1.5 MRU 4474 [No Label] 3 ms
R 2 10.6.1.6 4 ms <------ Router address repeated for 2nd to 5th TTL.
R 3 10.6.1.6 1 ms
R 4 10.6.1.6 3 ms
R 5 10.6.1.6 4 ms

LSP の切断の検出:例

ここでは、次の例について説明します。

「LSP ping または traceroute を使用したトラブルシューティング:例」

「LSP での MTU ディスカバリ:例」

「暗黙的ヌルとタグ付けされたパケットの追跡:例」

「非タグ付きパケットの追跡:例」

「パケットを送信できない原因の特定:例」

「IPv4 LSP でロード バランシングがイネーブルになっている場合の LSP 切断の検出:例」

「エコー パケットがルータから発信されるときに経由するインターフェイスの指定:例」

「パケット伝送のペーシング:例」

「中継ルータに対するダウンストリーム情報の問い合せ:例」

「ルータに対する DSMAP の問い合せ:例」

「中継ルータによるターゲット FEC スタックの検証の要求:例」

「LSP ping のイネーブル化による、非タグ付きインターフェイスを起因とする LSP 切断の検出:例」

LSP ping または traceroute を使用したトラブルシューティング:例

ICMP の ping コマンドと trace コマンドは、多くの場合、エラーの根本原因の診断に使用されます。LSP が切断されている場合、パケットは IP フォワーディングによってターゲット ルータに到達することがあるため、ICMP の ping と traceroute 機能は、MPLS 転送の問題の検出では信頼性がありません。MPLS LSP ping または traceroute と AToM VCCV 機能は、この診断とトラブルシューティングの機能を MPLS ネットワークに拡張し、IP と MPLS の転送テーブル間の不整合(ある場合)、MPLS 制御とデータ プレーンにおける不整合、および応答パスの問題を処理します。

図 6 に、LDP LSP のサンプル トポロジを示します。

図 6 LDP LSP のサンプル トポロジ

 

この項の内容は、次のとおりです。

「サンプル トポロジの設定」

「LSP が正しく設定されているかどうかの確認」

「LSP の切断の検出」

サンプル トポロジの設定

以降の項では、トラブルシューティング例のサンプル トポロジの設定を示します(図 6 を参照)。6 つのサンプル ルータ設定があります。

ルータ CE1 の設定

次に、CE1 ルータの設定を示します。

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1
!
boot-start-marker
boot-end-marker
!
enable password lab
!
clock timezone EST -5
ip subnet-zero
!
!
!
interface Loopback0
ip address 10.131.191.253 255.255.255.255
no ip directed-broadcast
no clns route-cache
!
!
interface Ethernet2/0
no ip address
no ip directed-broadcast
no keepalive
no cdp enable
no clns route-cache
!
interface Ethernet2/0.1
encapsulation dot1Q 1000
ip address 10.0.0.1 255.255.255.0
no ip directed-broadcast
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
end

ルータ PE1 の設定

次に、PE1 ルータの設定を示します。

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
logging snmp-authfail
enable password lab
!
clock timezone EST -5
ip subnet-zero
ip cef
no ip domain-lookup
!
mpls ldp discovery targeted-hello accept
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.131.191.252 255.255.255.255
no clns route-cache
!
interface Ethernet0/0
ip address 10.131.191.230 255.255.255.252
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/0
ip address 10.131.159.246 255.255.255.252
shutdown
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet2/0
no ip address
no cdp enable
no clns route-cache
!
interface Ethernet2/0.1
encapsulation dot1Q 1000
xconnect 10.131.159.252 333 encapsulation mpls
!
!
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 10.131.159.244 0.0.0.3 area 0
network 10.131.191.228 0.0.0.3 area 0
network 10.131.191.232 0.0.0.3 area 0
network 10.131.191.252 0.0.0.0 area 0
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
!
end

ルータ P1 の設定

次に、P1 ルータの設定を示します。

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P1
!
boot-start-marker
boot-end-marker
!
logging snmp-authfail
enable password lab
!
clock timezone EST -5
ip subnet-zero
ip cef
no ip domain-lookup
!
!
mpls ldp discovery targeted-hello accept
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
!
!
 
no clns route-cache
!
interface Loopback0
ip address 10.131.191.251 255.255.255.255
no clns route-cache
!
interface Ethernet0/0
ip address 10.131.191.229 255.255.255.252
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/0
ip address 10.131.159.226 255.255.255.252
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/1
ip address 10.131.159.222 255.255.255.252
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
!
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 10.131.159.220 0.0.0.3 area 0
network 10.131.159.224 0.0.0.3 area 0
network 10.131.191.228 0.0.0.3 area 0
network 10.131.191.251 0.0.0.0 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
end

ルータ P2 の設定

次に、P2 ルータの設定を示します。

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P2
!
boot-start-marker
boot-end-marker
!
enable password lab
!
clock timezone EST -5
ip subnet-zero
ip cef
no ip domain-lookup
!
mpls ldp discovery targeted-hello accept
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.131.159.251 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/0
ip address 10.131.159.229 255.255.255.252
no ip directed-broadcast
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet0/1
ip address 10.131.159.233 255.255.255.252
no ip directed-broadcast
ip rsvp signalling dscp 0
!
interface Ethernet1/0
ip address 10.131.159.225 255.255.255.252
no ip directed-broadcast
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/1
ip address 10.131.159.221 255.255.255.252
no ip directed-broadcast
ip rsvp signalling dscp 0
!
!
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 10.131.159.220 0.0.0.3 area 0
network 10.131.159.224 0.0.0.3 area 0
network 10.131.159.228 0.0.0.3 area 0
network 10.131.159.232 0.0.0.3 area 0
network 10.131.159.251 0.0.0.0 area 0
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
end

ルータ PE2 の設定

次に、PE2 ルータの設定を示します。

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
logging snmp-authfail
enable password lab
!
clock timezone EST -5
ip subnet-zero
ip cef
no ip domain-lookup
!
mpls ldp discovery targeted-hello accept
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.131.159.252 255.255.255.255
no clns route-cache
!
interface Ethernet0/0
ip address 10.131.159.230 255.255.255.252
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet0/1
ip address 10.131.159.234 255.255.255.252
no clns route-cache
ip rsvp bandwidth 1500 1500
ip rsvp signalling dscp 0
!
interface Ethernet1/0
ip address 10.131.159.245 255.255.255.252
mpls ip
no clns route-cache
!
interface Ethernet3/0
no ip address
no cdp enable
no clns route-cache
!
interface Ethernet3/0.1
encapsulation dot1Q 1000
no snmp trap link-status
no cdp enable
xconnect 10.131.191.252 333 encapsulation mpls
!
!
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 10.131.122.0 0.0.0.3 area 0
network 10.131.159.228 0.0.0.3 area 0
network 10.131.159.232 0.0.0.3 area 0
network 10.131.159.236 0.0.0.3 area 0
network 10.131.159.244 0.0.0.3 area 0
network 10.131.159.252 0.0.0.0 area 0
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
!
end

ルータ CE2 の設定

次に、CE2 ルータの設定を示します。

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2
!
boot-start-marker
boot-end-marker
!
enable password lab
!
clock timezone EST -5
ip subnet-zero
ip cef
no ip domain-lookup
!
!
interface Loopback0
ip address 10.131.159.253 255.255.255.255
no ip directed-broadcast
no clns route-cache
!
interface Ethernet3/0
no ip address
no ip directed-broadcast
no keepalive
no cdp enable
no clns route-cache
!
interface Ethernet3/0.1
encapsulation dot1Q 1000
ip address 10.0.0.2 255.255.255.0
no ip directed-broadcast
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
end

LSP が正しく設定されているかどうかの確認

この項の show コマンドの出力を使用して、LSP が正しく設定されているかどうかを確認します。

show mpls forwarding-table コマンドは、トンネル 1 が MPLS 転送テーブルにあることを示しています。

PE1# show mpls forwarding-table 10.131.159.252
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
22 18 [T] 10.131.159.252/32 0 Tu1 point2point
 
 
[T] Forwarding through a TSP tunnel.
View additional tagging info with the 'detail' option
 

PE 1 で発行された trace mpls コマンドは、最も外側のラベルが 16 でスタック末尾のラベルが 18 であるパケットが PE1 から PE2 に転送されることを確認します。

PE1# trace mpls ipv4 10.131.159.252/32
 
Tracing MPLS Label Switched Path to 10.131.159.252/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.191.252 MRU 1496 [Labels: 16/18 Exp: 0/0] L 1 10.131.191.229
MRU 1508 [Labels: 18 Exp: 0] 0 ms L 2 10.131.159.225
MRU 1504 [Labels: implicit-null Exp: 0] 0 ms ! 3 10.131.159.234 20 ms
PE1#
 

感嘆符(!)で示されているように、PE2 に対する MPLS LSP Traceroute は成功しています。

LSP の切断の検出

この項のコマンドの出力を使用して、LSP の切断を検出します。

次の show mpls ldp discovery コマンドの出力に示されているように、ルータ PE1 と P2 の間に LDP ターゲット セッションが確立されています。

PE1# show mpls ldp discovery
 
Local LDP Identifier:
10.131.191.252:0
Discovery Sources:
Interfaces:
Ethernet0/0 (ldp): xmit/recv
LDP Id: 10.131.191.251:0
Tunnel1 (ldp): Targeted -> 10.131.159.251
Targeted Hellos:
10.131.191.252 -> 10.131.159.252 (ldp): active/passive, xmit/recv
LDP Id: 10.131.159.252:0
10.131.191.252 -> 10.131.159.251 (ldp): active, xmit/recv
LDP Id: 10.131.159.251:0
 

P2 ルータで、次のコマンドをグローバル コンフィギュレーション モードで入力します。

P2(config)# no mpls ldp discovery targeted-hello accept
 

LDP 設定の変更により、TE トンネルのヘッドエンドとテールエンド間のターゲット LDP セッションがダウンします。P2 で学習された IPv4 プレフィクスのラベルは、PE1 にアドバタイズされません。したがって、P2 から到達可能なすべての IP プレフィクスには、PE1 から MPLS ではなく IP を経由する場合にだけ到達可能です。つまり、PE1 のトンネル 1 を経由したそれらのプレフィクス宛てのパケットは、P2 で IP スイッチングされます(これは望ましくありません)。

次の show mpls ldp discovery コマンドは、LDP ターゲット セッションがダウンしていることを示しています。

PE1# show mpls ldp discovery
 
Local LDP Identifier:
10.131.191.252:0
Discovery Sources:
Interfaces:
Ethernet0/0 (ldp): xmit/recv
LDP Id: 10.131.191.251:0
Tunnel1 (ldp): Targeted -> 10.131.159.251
Targeted Hellos:
10.131.191.252 -> 10.131.159.252 (ldp): active/passive, xmit/recv
LDP Id: 10.131.159.252:0
10.131.191.252 -> 10.131.159.251 (ldp): active, xmit
 

PE1 ルータで show mpls forwarding-table コマンドを入力します。次の表示は、LDP 設定が変更された結果、発信パケットが非タグ付きになったことを示しています。

PE1# show mpls forwarding-table 10.131.159.252
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
22 Untagged[T] 10.131.159.252/32 0 Tu1 point2point
 
 
[T] Forwarding through a TSP tunnel.
View additional tagging info with the 'detail' option
 
 

PE1 ルータで ping mpls コマンドを入力すると、次のように表示されます。

PE1# ping mpls ipv4 10.131.159.252/32 repeat 1
 
Sending 1, 100-byte MPLS Echos to 10.131.159.252/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
R
Success rate is 0 percent (0/1)
 

ping mpls コマンドは失敗しています。R は、MPLS エコー応答の送信元にルーティング エントリがあり、MPLS FEC がないことを示します。 ping mpls コマンドで verbose キーワードを入力すると、MPLS LSP エコー応答の送信元アドレスと戻りコードが表示されます。応答ルータに対する telnet とフォワーディングやラベルのテーブルの検査によって、切断が発生した場所を特定できる必要があります。切断は上流のルータで発生する可能性があるため、隣接する上流のルータも調べる必要があります。

PE1# ping mpls ipv4 10.131.159.252/32 repeat 1 verbose
 
Sending 1, 100-byte MPLS Echos to 10.131.159.252/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
R 10.131.159.225, return code 6
 
Success rate is 0 percent (0/1)
 

または、LSP traceroute コマンドを使用して、切断の原因となったルータを特定します。次の例では、TTL の後続の値が 2 よりも大きい場合、同じルータ(10.131.159.225)が応答し続けます。これは、TTL にかかわらず、MPLS エコー要求はそのルータによって処理され続けることを意味します。ラベル スタックの検査によって、P1 が最後のラベルをポップし、パケットを IP パケットとして P2 に転送することがわかります。これは、パケットが P2 によって処理され続ける理由を説明するものです。MPLS エコー要求パケットは、IP ヘッダーの宛先アドレスを使用して転送できません。これは、アドレスが 127/8 アドレスに設定されているためです。

PE1# trace mpls ipv4 10.131.159.252/32 ttl 5
 
Tracing MPLS Label Switched Path to 10.131.159.252/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.191.230 MRU 1496 [Labels: 22/19 Exp: 0/0]
R 1 10.131.159.226 MRU 1500 [Labels: 19 Exp: 0] 40 ms
R 2 10.131.159.229 MRU 1504 [implicit-null] 28 ms
! 3 10.131.159.230 40 ms
pe1#

LSP での MTU ディスカバリ:例

次の例は、LSP が LDP によって作成されたラベルで構成されている場合に trace mpls コマンドを実行した結果を示しています。

PE1# trace mpls ipv4 10.131.159.252/32
 
Tracing MPLS Label Switched Path to 10.131.159.252/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.191.230 MRU 1496 [Labels: 22/19 Exp: 0/0]
R 1 10.131.159.226 MRU 1500 [Labels: 19 Exp: 0] 40 ms
R 2 10.131.159.229 MRU 1504 [implicit-null] 28 ms
! 3 10.131.159.230 40 ms
pe1#
 

show mpls forwarding detail コマンドを使用すると、各ホップの LSP の MRU を確認できます。

PE1# show mpls forwarding 10.131.159.252 detail
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
22 19 10.131.159.252/32 0 Tu1 point2point
MAC/Encaps=14/22, MRU=1496, Tag Stack{22 19}, via Et0/0
AABBCC009700AABBCC0098008847 0001600000013000
No output feature configured
 

LSP に収容されるエコー要求の大きさを確認するには, まず show interface interface-name コマンドを使用して、IP MTU のサイズを計算します。

PE1# show interface e0/0
 
Ethernet0/0 is up, line protocol is up
Hardware is Lance, address is aabb.cc00.9800 (bia aabb.cc00.9800)
Internet address is 10.131.191.230/30
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:01, output hang never
Last clearing of “show interface” counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
377795 packets input, 33969220 bytes, 0 no buffer
Received 231137 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
441772 packets output, 40401350 bytes, 0 underruns
0 output errors, 0 collisions, 10 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 

show interface interface-name の例では、IP MTU は 1500 バイトです。MTU の数値からラベル スタックに対応するバイト数を引きます。 show mpls forwarding コマンドの出力は、タグ スタックが 1 つのラベル(21)で構成されていることを示しています。したがって、LSP で送信できる最も大きい MPLS エコーパケット要求は、1500 - (2 x 4) = 1492 になります。

次の mpls ping コマンドを使用して、これを検証できます。

PE1# ping mpls ipv4 10.131.159.252/32 sweep 1492 1500 1 repeat 1
 
Sending 1, [1492..1500]-byte MPLS Echos to 10.131.159.252/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
!QQQQQQQQ
Success rate is 11 percent (1/9), round-trip min/avg/max = 40/40/40 ms
 

このコマンドでは、サイズ範囲が 1492 ~ 1500 バイトのエコー パケットが宛先アドレスに送信されます。感嘆符(!)で示されているように、1492 バイトのパケットだけが正常に送信されています。バイト サイズが 1493 ~ 1500 のパケットは、Q で示されているように、送信元で抑制されました。

指定サイズのペイロードをテストできるように、MPLS エコー要求をパディングできます。パディング TLV は、MPLS エコー要求を使用して LSP でサポート可能な MTU を検出する場合に役立ちます。MTU ディスカバリは、フラグメント化できない非 IP ペイロードを含む AToM のようなアプリケーションにはきわめて重要です。

暗黙的ヌルとタグ付けされたパケットの追跡:例

次の例では、トンネル 1 はシャットダウンされ、LDP ラベルで構成された LSP だけが確立されます。暗黙的ヌルは、P2 ルータと PE2 ルータの間でアドバタイズされます。PE1 ルータで MPLS LSP traceroute コマンドを入力すると、次のように出力され、パケットが暗黙的ヌル ラベル付きで P2 から PE2 に転送されることが示されます。アドレス 10.131.159.229 は、PE2 ルータに対する P2 のイーサネット 0/0 出力インターフェイス用に設定されています。

PE1# trace mpls ipv4 10.131.159.252/32
 
Tracing MPLS Label Switched Path to 10.131.159.252/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.191.230 MRU 1496 [Labels: 22/19 Exp: 0/0]
R 1 10.131.159.226 MRU 1500 [Labels: 19 Exp: 0] 40 ms
R 2 10.131.159.229 MRU 1504 [implicit-null] 28 ms
! 3 10.131.159.230 40 ms
pe1#

非タグ付きパケットの追跡:例

非タグ付きの例は、MPLS VPN の問題の原因となる可能性がある IGP LSP に有効な設定です。

P2 ルータで発行された show mpls forwarding-table コマンドと show mpls ldp discovery コマンドは、LDP が正しく設定されていることを示しています。

P2# show mpls forwarding-table 10.131.159.252
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
19 Pop tag 10.131.159.252/32 0 Et0/0 10.131.159.230
 
P2# show mpls ldp discovery
 
Local LDP Identifier:
10.131.159.251:0
Discovery Sources:
Interfaces:
Ethernet0/0 (ldp): xmit/recv
LDP Id: 10.131.159.252:0
Ethernet1/0 (ldp): xmit/recv
LDP Id: 10.131.191.251:0
 

show mpls ldp discovery コマンドの出力は、PE2 を P2 に接続するイーサネット インターフェイス 0/0 がパケットを送受信していることを示しています。

イーサネット インターフェイス 0/0 に対して no mpls ip コマンドを入力した場合、P2 ルータと PE2 ルータ間の LDP セッションは確立されません。PE ルータで入力した show mpls ldp discovery コマンドは、PE2 との MPLS LDP セッションがダウンしていることを示しています。

P2# show mpls ldp discovery
 
Local LDP Identifier:
10.131.159.251:0
Discovery Sources:
Interfaces:
Ethernet0/0 (ldp): xmit
Ethernet1/0 (ldp): xmit/recv
LDP Id: 10.131.191.251:0
 

PE2 との MPLS LDP セッションがダウンすると、 show mpls forwarding-table コマンドで示されるように、10.131.159.252 への LSP が非タグ付きになります。

P2# show mpls forwarding-table 10.131.159.252/32
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
19 Untagged 10.131.159.252/32 864 Et0/0 10.131.159.230
 

非タグ付きの例では、次に示すように、MPLS LSP traceroute の応答に No Label のタグが付いたパケットが含まれます。P2 から PE2 への出力インターフェイス(この例ではイーサネット 0/0)に対して mpls ip コマンドを入力して、インターフェイス P2 から PE2 への MPLS LSP セッションを再確立する必要があります。

PE1# trace mpls ipv4 10.131.159.252/32
 
Tracing MPLS Label Switched Path to 10.131.159.252/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.191.230 MRU 1500 [Labels: 20 Exp: 0]
R 1 10.131.159.226 MRU 1500 [Labels: 19 Exp: 0] 80 ms
R 2 10.131.159.229 MRU 1504 [No Label] 28 ms <----No MPLS session from P2 to PE2.
! 3 10.131.159.230 40 ms

パケットを送信できない原因の特定:例

次に、MPLS エコー要求が送信されない場合の ping mpls コマンドの例を示します。返された Q によって、伝送エラーが示されています。

PE1# ping mpls ipv4 10.0.0.1/32
 
Sending 5, 100-byte MPLS Echos to 10.0.0.1/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
QQQQQ
Success rate is 0 percent (0/5)
 

次の show mpls forwarding-table コマンドと show ip route コマンドは、IPv4 アドレス(10.0.0.1)が LFIB または RIB ルーティング テーブルにないことを示しています。したがって、MPLS エコー要求は送信されません。

PE1# show mpls forwarding-table 10.0.0.1
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
 
PE1# show ip route 10.0.0.1
 
% Subnet not in table

IPv4 LSP でロード バランシングがイネーブルになっている場合の LSP 切断の検出:例

次の例では、宛先が同じパスが複数あります。これらの例の出力は、送信元ルータとターゲット ルータ間でロード バランシングが行われていることを示しています。

PE1 ルータのイーサネット インターフェイス 1/0 を動作させるには、PE1 ルータで次のコマンドを入力します。

PE1# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
 
PE1(config)# interface ethernet 1/0
 
PE1(config-if)# no shutdown
 
PE1(config-if)# end
 
*Dec 31 19:14:10.034: %LINK-3-UPDOWN: Interface Ethernet1/0, changed state to up
*Dec 31 19:14:11.054: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet1/0,
changed state to upend
PE1#
*Dec 31 19:14:12.574: %SYS-5-CONFIG_I: Configured from console by console
*Dec 31 19:14:19.334: %OSPF-5-ADJCHG: Process 1, Nbr 10.131.159.252 on Ethernet1/0
from LOADING to FULL, Loading Done
PE1#
 

次の show mpls forwarding-table コマンドは、プレフィクス 10.131.159.251/32 の発信インターフェイスとネクスト ホップを表示します。

PE1# show mpls forwarding-table 10.131.159.251/32
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
21 19 10.131.159.251/32 0 Et0/0 10.131.191.229
20 10.131.159.251/32 0 Et1/0 10.131.159.245
 

宛先 UDP アドレスが 127.0.0.1 の 10.131.159.251/32 に対する次の ping mpls コマンドは、選択したパスのパス インデックスが 0 であることを示しています。

Router# ping mpls ipv4 10.131.159.251/32 destination 127.0.0.1/32
 
Sending 1, 100-byte MPLS Echos to 10.131.159.251/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 40/40/40 ms
PE1#
*Dec 29 20:42:40.638: LSPV: Echo Request sent on IPV4 LSP, load_index 2,
pathindex 0, size 100
*Dec 29 20:42:40.638: 46 00 00 64 00 00 40 00 FF 11 9D 03 0A 83 BF FC
*Dec 29 20:42:40.638: 7F 00 00 01 94 04 00 00 0D AF 0D AF 00 4C 14 70
*Dec 29 20:42:40.638: 00 01 00 00 01 02 00 00 1A 00 00 1C 00 00 00 01
*Dec 29 20:42:40.638: C3 9B 10 40 A3 6C 08 D4 00 00 00 00 00 00 00 00
*Dec 29 20:42:40.638: 00 01 00 09 00 01 00 05 0A 83 9F FB 20 00 03 00
*Dec 29 20:42:40.638: 13 01 AB CD AB CD AB CD AB CD AB CD AB CD AB CD
*Dec 29 20:42:40.638: AB CD AB CD
*Dec 29 20:42:40.678: LSPV: Echo packet received: src 10.131.159.225,
dst 10.131.191.252, size 74
*Dec 29 20:42:40.678: AA BB CC 00 98 01 AA BB CC 00 FC 01 08 00 45 C0
*Dec 29 20:42:40.678: 00 3C 32 D6 00 00 FD 11 15 37 0A 83 9F E1 0A 83
*Dec 29 20:42:40.678: BF FC 0D AF 0D AF 00 28 D1 85 00 01 00 00 02 02
*Dec 29 20:42:40.678: 03 00 1A 00 00 1C 00 00 00 01 C3 9B 10 40 A3 6C
*Dec 29 20:42:40.678: 08 D4 C3 9B 10 40 66 F5 C3 C8
 

宛先 UDP アドレスが 127.0.0.3 の 10.131.159.251/32 に対する次の ping mpls コマンドは、選択したパスのパス インデックスが 1 であることを示しています。

PE1# ping mpls ipv4 10.131.159.251/32 destination 127.0.0.3/32
 
Sending 1, 100-byte MPLS Echos to 10.131.159.251/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 40/40/40 ms
PE1#
*Dec 29 20:43:09.518: LSPV: Echo Request sent on IPV4 LSP, load_index 13,
pathindex 1, size 100
*Dec 29 20:43:09.518: 46 00 00 64 00 00 40 00 FF 11 9D 01 0A 83 BF FC
*Dec 29 20:43:09.518: 7F 00 00 03 94 04 00 00 0D AF 0D AF 00 4C 88 58
*Dec 29 20:43:09.518: 00 01 00 00 01 02 00 00 38 00 00 1D 00 00 00 01
*Dec 29 20:43:09.518: C3 9B 10 5D 84 B3 95 84 00 00 00 00 00 00 00 00
*Dec 29 20:43:09.518: 00 01 00 09 00 01 00 05 0A 83 9F FB 20 00 03 00
*Dec 29 20:43:09.518: 13 01 AB CD AB CD AB CD AB CD AB CD AB CD AB CD
*Dec 29 20:43:09.518: AB CD AB CD
*Dec 29 20:43:09.558: LSPV: Echo packet received: src 10.131.159.229,
dst 10.131.191.252, size 74
*Dec 29 20:43:09.558: AA BB CC 00 98 01 AA BB CC 00 FC 01 08 00 45 C0
*Dec 29 20:43:09.558: 00 3C 32 E9 00 00 FD 11 15 20 0A 83 9F E5 0A 83
*Dec 29 20:43:09.558: BF FC 0D AF 0D AF 00 28 D7 57 00 01 00 00 02 02
*Dec 29 20:43:09.558: 03 00 38 00 00 1D 00 00 00 01 C3 9B 10 5D 84 B3
*Dec 29 20:43:09.558: 95 84 C3 9B 10 5D 48 3D 50 78
 

選択された実際のパスを確認するには、 packet キーワードと data キーワードを指定して debug mpls lspv コマンドを入力します。


) ロード バランシング アルゴリズムは、IP ヘッダーの送信元アドレスと宛先アドレスに基づくハッシュによって、パケットを使用可能な出力パスに均一に分散しようとします。destination キーワードに address-startaddress-end、および address-increment 引数を指定しても、期待どおりの結果が得られない場合があります。


エコー パケットがルータから発信されるときに経由するインターフェイスの指定:例

次に、上流のルータからロード バランシングをテストする例を示します。

Router# ping mpls ipv4 10.131.161.251/32 ttl 1 repeat 1 dsmap hashkey ipv4 bitmap 8
 
Sending 1, 100-byte MPLS Echos to 10.131.161.251/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
L
Echo Reply received from 10.131.131.2
DSMAP 0, DS Router Addr 10.131.141.130, DS Intf Addr 10.131.141.130
Depth Limit 0, MRU 1500 [Labels: 54 Exp: 0]
Multipath Addresses:
127.0.0.3 127.0.0.5 127.0.0.7 127.0.0.8
DSMAP 1, DS Router Addr 10.131.141.2, DS Intf Addr 10.131.141.2
Depth Limit 0, MRU 1500 [Labels: 40 Exp: 0]
Multipath Addresses:
127.0.0.1 127.0.0.2 127.0.0.4 127.0.0.6
 

次に、エコー応答の送信元アドレスが 2 ホップ離れていると判断し、アップストリームにアドバタイズされた rx ラベルをチェックして、中継ルータが適切な結果を報告したことを検証する例を示します。

Success rate is 0 percent (0/1)
 
Router# trace mpls ipv4 10.131.161.251/32 destination 127.0.0.6 ttl 2
 
Tracing MPLS Label Switched Path to 10.131.161.251/32, timeout is 2 seconds
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.131.1 10.131.131.2 MRU 1500 [Labels: 37 Exp: 0]
L 1 10.131.131.2 10.131.141.2 MRU 1500 [Labels: 40 Exp: 0] 0 ms, ret code 8
L 2 10.131.141.2 10.131.150.2 MRU 1504 [Labels: implicit-null Exp: 0] 0 ms, ret code 8
Router#
Router# telnet 10.131.141.2
Trying 10.131.141.2 ... Open
 
User Access Verification
 
Password:
Router> en
 
The following example shows how the output interface keyword forces an LSP traceroute out Ethernet interface 0/0:
 
Router# show mpls forwarding-table 10.131.159.251
 
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
20 19 10.131.159.251/32 0 Et1/0 10.131.159.245
18 10.131.159.251/32 0 Et0/0 10.131.191.229
 
Router# trace mpls ipv4 10.131.159.251/32
 
Tracing MPLS Label Switched Path to 10.131.159.251/32, timeout is 2 seconds
 
Type escape sequence to abort.
0 10.131.159.246 MRU 1500 [Labels: 19 Exp: 0]
L 1 10.131.159.245 MRU 1504 [Labels: implicit-null Exp: 0] 4 ms
! 2 10.131.159.229 20 ms
 
Router# trace mpls ipv4 10.131.159.251/32 output-interface ethernet0/0
 
Tracing MPLS Label Switched Path to 10.131.159.251/32, timeout is 2 seconds
 
Type escape sequence to abort.
0 10.131.191.230 MRU 1500 [Labels: 18 Exp: 0]
L 1 10.131.191.229 MRU 1504 [Labels: implicit-null Exp: 0] 0 ms
! 2 10.131.159.225 1 ms

パケット伝送のペーシング:例

次に、パケットの伝送ペースの例を示します。

Router# ping mpls ipv4 10.5.5.5/32 interval 100
 
Sending 5, 100-byte MPLS Echos to 10.5.5.5/32,
timeout is 2 seconds, send interval is 100 msec:
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/36 ms PE-802

中継ルータに対するダウンストリーム情報の問い合せ:例

次に、2 本の出力パスを持つルータに問い合せた場合のサンプル出力を示します。

Router# ping mpls ipv4 10.161.251/32 ttl 4 repeat 1 dsmap hashkey ipv4 bitmap 16
 
Sending 1, 100-byte MPLS Echos to 10.131.161.251/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
L
Echo Reply received from 10.131.131.2
DSMAP 0, DS Router Addr 10.131.141.130, DS Intf Addr 10.131.141.130
Depth Limit 0, MRU 1500 [Labels: 54 Exp: 0]
Multipath Addresses:
127.0.0.3 127.0.0.6 127.0.0.9 127.0.0.10
127.0.0.12 127.0.0.13 127.0.0.14 127.0.0.15
127.0.0.16
 
DSMAP 1, DS Router Addr 10.131.141.2, DS Intf Addr 10.131.141.2
Depth Limit 0, MRU 1500 [Labels: 40 Exp: 0]
Multipath Addresses:
127.0.0.1 127.0.0.2 127.0.0.4 127.0.0.5
127.0.0.7 127.0.0.8 127.0.0.11
 
Success rate is 0 percent (0/1)
 

マルチパス アドレスにより、パケットは出力ラベル スタックを使用してルータに中継されます。出力パスの本数の確認には ping mpls コマンドが有用ですが、ルータが 2 ホップ以上離れている場合は、ルータでこれらのアドレスを使用して問い合せ対象のルータにパケットを中継できるとはかぎりません。このような状況になるのは、IP ヘッダーの宛先アドレスが変更されたために、送信元ルータと応答ルータの間にあるルータによって、パケットが異なる方法でロード バランシングされることがあるためです。ロード バランシングは、IP ヘッダーの送信元アドレスの影響を受けます。次に、上流のルータからのロード バランシング報告をテストする例を示します。

Router# ping mpls ipv4 10.131.161.251/32 ttl 1 repeat 1 dsmap hashkey ipv4 bitmap 8
 
Sending 1, 100-byte MPLS Echos to 10.131.161.251/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
L
Echo Reply received from 10.131.131.2
DSMAP 0, DS Router Addr 10.131.141.130, DS Intf Addr 10.131.141.130
Depth Limit 0, MRU 1500 [Labels: 54 Exp: 0]
Multipath Addresses:
127.0.0.3 127.0.0.5 127.0.0.7 127.0.0.8
DSMAP 1, DS Router Addr 10.131.141.2, DS Intf Addr 10.131.141.2
Depth Limit 0, MRU 1500 [Labels: 40 Exp: 0]
Multipath Addresses:
127.0.0.1 127.0.0.2 127.0.0.4 127.0.0.6
 

中継ルータが適切な結果を報告したことを検証するには、エコー応答の送信元アドレスが 2 ホップ離れていると判断し、アップストリームにアドバタイズされた rx ラベルをチェックします。次に、出力例を示します。

 
Success rate is 0 percent (0/1)
 
Router# trace mpls ipv4 10.131.161.251/32 destination 127.0.0.6 ttl 2
 
Tracing MPLS Label Switched Path to 10.131.161.251/32, timeout is 2 seconds
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.131.1 10.131.131.2 MRU 1500 [Labels: 37 Exp: 0]
L 1 10.131.131.2 10.131.141.2 MRU 1500 [Labels: 40 Exp: 0] 0 ms, ret code 8
L 2 10.131.141.2 10.131.150.2 MRU 1504 [Labels: implicit-null Exp: 0] 0 ms, ret code 8
Router#
Router# telnet 10.131.141.2
Trying 10.131.141.2 ... Open
 
User Access Verification
 
Password:
Router> en
 
Router# show mpls forwarding-table 10.131.161.251
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
40 Pop tag 10.131.161.251/32 268 Et1/0 10.131.150.2
Router#

ルータに対する DSMAP の問い合せ:例

次に、ソフトウェアとハードウェアのフォワーディング レイヤに DSMAP TLV で返す必要がある深度制限を問い合せる例を示します。

Router# ping mpls ipv4 10.131.159.252/32 ttl 1 dsmap
 
Sending 1, 100-byte MPLS Echos to 10.131.159.252/32,
timeout is 2 seconds, send interval is 0 msec:
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
L
Echo Reply received from 10.131.191.229
DSMAP 0, DS Router Addr 10.131.159.225, DS Intf Addr 10.131.159.225
Depth Limit 0, MRU 1508 [Labels: 18 Exp: 0]
Multipath Addresses:
127.0.0.1 127.0.0.2 127.0.0.3 127.0.0.4
127.0.0.5 127.0.0.6 127.0.0.7 127.0.0.8
127.0.0.9 127.0.0.10 127.0.0.11 127.0.0.12
127.0.0.13 127.0.0.14 127.0.0.15 127.0.0.16
127.0.0.17 127.0.0.18 127.0.0.19 127.0.0.20
127.0.0.21 127.0.0.22 127.0.0.23 127.0.0.24
127.0.0.25 127.0.0.26 127.0.0.27 127.0.0.28
127.0.0.29 127.0.0.30 127.0.0.31 127.0.0.32
Success rate is 0 percent (0/1)

中継ルータによるターゲット FEC スタックの検証の要求:例

次に、中継ルータで、テスト対象の LSP を識別するターゲット FEC スタックを検証する例を示します。

Router# trace mpls ipv4 10.5.5.5/32 flags fec
 
Tracing MPLS Label Switched Path to 10.5.5.5/32, timeout is 2 seconds
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.2.3.2 10.2.3.3 MRU 1500 [Labels: 19 Exp: 0] L 1 10.2.3.3 10.3.4.4 MRU 1500 [Labels: 19 Exp: 0] 40 ms, ret code 8 L 2 10.3.4.4 10.4.5.5 MRU 1504 [Labels: implicit-null Exp: 0] 32 ms, ret code 8 ! 3 10.4.5.5 40 ms, ret code 3
Router# ping mpls ipv4 10.5.5.5/32
Sending 5, 100-byte MPLS Echos to 10.5.5.5/32
timeout is 2 seconds, send interval is 0 msec:
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
! size 100, reply addr 10.4.5.5, return code 3
! size 100, reply addr 10.4.5.5, return code 3
! size 100, reply addr 10.4.5.5, return code 3
! size 100, reply addr 10.4.5.5, return code 3
! size 100, reply addr 10.4.5.5, return code 3
 
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

LSP ping のイネーブル化による、非タグ付きインターフェイスを起因とする LSP 切断の検出:例

次に、明示的ヌル ラベル シムがある場合に、ラベル スタックの最後に追加されるラベルの例を示します。

Router# trace mpls ipv4 10.131.159.252/32 force-explicit-null
 
Tracing MPLS Label Switched Path to 10.131.159.252/32, timeout is 2 seconds
 
Codes:
'!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.191.252 MRU 1492 [Labels: 16/18/explicit-null Exp: 0/0/0]
L 1 10.131.191.229 MRU 1508 [Labels: 18/explicit-null Exp: 0/0] 0 ms
L 2 10.131.159.225 MRU 1508 [Labels: explicit-null Exp: 0] 0 ms
! 3 10.131.159.234 4 ms
 

次に、明示的ヌル ラベル シムがない場合のコマンド出力例を示します。

Router# trace mpls ipv4 10.131.159.252/32
 
Tracing MPLS Label Switched Path to 10.131.159.252/32, timeout is 2 seconds
 
Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
0 10.131.191.252 MRU 1496 [Labels: 16/18 Exp: 0/0]
L 1 10.131.191.229 MRU 1508 [Labels: 18 Exp: 0] 4 ms
L 2 10.131.159.225 MRU 1504 [Labels: implicit-null Exp: 0] 4 ms
! 3 10.131.159.234 4 ms

ピアにアドバタイズされた AToM VCCV 機能やピアから受信した AToM VCCV 機能の表示:例

次に、ルータ PE1 が AToM VCCV タイプ 1 とタイプ 2 の両方のスイッチング機能をアドバタイズし、リモート ルータ PE2 がタイプ 2 のスイッチング機能だけをアドバタイズする例を示します。

Router# show mpls l2transport binding
 
Destination Address: 10.131.191.252, VC ID: 333
Local Label: 16
Cbit: 1, VC Type: Ethernet, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV Capabilities: Type 1, Type 2 <----- Locally advertised VCCV capabilities
Remote Label: 19
Cbit: 1, VC Type: Ethernet, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV Capabilities: Type 2 <-----Remotely advertised VCCV capabilities

その他の関連資料

ここでは、MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV 機能に関する関連資料について説明します。

関連資料

 

関連項目
参照先

IP ping および IP traceroute コマンドの使用例

『Understanding the Ping and Traceroute Commands』

MPLS LDP の設定および検証作業

『MPLS Label Distribution Protocol (LDP) Overview』

AToM の設定および検証作業

『Any Transport over MPLS』

スイッチング サービス コマンド

『Cisco IOS Multiprotocol Label Switching Command Reference』

Virtual Private LAN Service(VPLS)ドメインに対して追加または削除される PE ルータの自動検出

『Information About VPLS Autodiscovery: BGP Based』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに対する MIB を特定してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用してください。

debug mpls lspv

echo

mpls oam

ping mpls

show mpls oam echo statistics

trace mpls

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の機能情報

表 7 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。この表に示されているのは、Cisco IOS Release 12.0(27)S、Cisco IOS Release 12.4(6)T、または 12.3(33)SXI 以降のリリースで導入または変更された機能だけです。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 7 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 7 MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV の機能情報

機能名
リリース
機能情報

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV

12.0(27)S
12.2(18)SXE
12.4(6)T
12.2(28)SB
12.0(32)SY
12.4(11)T
12.2(31)SB2
12.2(33)SRB
12.2(33)SXH
12.3(33)SXI

MPLS LSP Ping/Traceroute for LDP/TE および LSP Ping for VCCV 機能を使用すると、サービス プロバイダーはラベル スイッチド パスを監視したり、MPLS 転送の問題を迅速に隔離したりできます。

この機能は、Cisco IOS Release 12.0(27)S で導入されました。 ping mpls コマンドと trace mpls コマンドが導入されました。

この機能は、Cisco IOS Release 12.2(18)SXE に組み込まれました。 ping mpls コマンドと trace mpls コマンドが変更されました

Cisco IOS Release 12.4(6)T では、 mpls oam コマンドが導入され、 trace mpls コマンドが変更されました。

この機能は、Cisco IOS Release 12.2(28)SB に統合されました。

この機能は、Cisco IOS Release 12.0(32)SY に組み込まれました。 show mpls oam echo statistics コマンドが追加されました。

この機能は、Cisco IOS Release 12.4(11)T に組み込まれました。AToM Virtual Circuit Connection Verification(VCCV; 仮想回線接続性検証)がサポートされています。 mpls oam ping mpls 、および trace mpls の各コマンドが変更されました。

この機能は、Cisco IOS Release 12.2(31)SB2 に組み込まれました。

Cisco IOS Release 12.2(33)SRB に FEC 129 のサポートが追加されました。

この機能は、Cisco IOS Release 12.2(33)SXH に統合されました。

この機能は、Cisco IOS Release 12.2(33)SXI に統合されました。

用語集

FEC :Forward Equivalence Class。転送のために同等に処理できるパケットのセット。したがって、1 つのラベルへのバインディングに適しています。たとえば、1 つのアドレス プレフィクス宛てのパケットのセットやフロー内のパケットなどがあります。

ICMP :Internet Control Message Protocol(インターネット制御メッセージ プロトコル)。エラーを報告し、IP パケット処理に関連するその他の情報を提供するネットワーク層インターネット プロトコル。RFC 792 に記載されています。

LFIB :Label Forwarding Information Base(ラベル転送情報ベース)。宛先と着信ラベルが発信インターフェイスとラベルに関連付けられているデータ構造およびフォワーディング管理手段。

localhost :ホスト ルータ(デバイス)を表す名前。localhost は、予約済みのループバック IP アドレス(127.0.0.1)を使用します。

LSP :Label Switched Path(ラベル スイッチド パス)。MPLS がパケットを転送する 2 つのルータ間の接続。

LSPV :Label Switched Path Verification。LSP ping のサブプロセス。MPLS エコー要求と応答を符号化およびデコードします。また、MPLS エコー要求と応答を送受信するために、IP、MPLS、および AToM スイッチングとやり取りします。MPLS エコー要求の発信元ルータでは、LSPV によって、エコー応答が受信されていない未処理のエコー要求のデータベースが保持されます。

MPLS ルータ アラート ラベル :MPLS ラベル 1。ルータ アラート ラベルを含む MPLS パケットは、処理のためにルータによって Route Processor(RP; ルート プロセッサ)の処理レベルにリダイレクトされます。これにより、これらのパケットはハードウェア ルーティング テーブルにおけるフォワーディング エラーを回避できます。

MRU :Maximum Receive Unit(最大受信ユニット)。LSP を介して転送できる、ラベル付きパケットの最大サイズ(バイト単位)。

MTU :Maximum Transmission Unit(最大伝送ユニット)。特定のインターフェイスが送受信できる最大パケット サイズ(バイト単位)。

PW :pseudowire(擬似回線)。パケット スイッチド ネットワークを介して、エミュレートされた回線の重要な要素を、ある Provider Edge(PE; プロバイダー エッジ)ルータから別の PE ルータに伝送するトンネルの形式。

RP :Route Processor(ルート プロセッサ)。Cisco 7000 シリーズ ルータのプロセッサ モジュール。CPU、システム ソフトウェア、およびルータで使用されるほとんどのメモリ コンポーネントが含まれます。スーパーバイザ プロセッサと呼ばれることもあります。

RSVP :Resource Reservation Protocol(リソース予約プロトコル)。IP ネットワークのリソースの予約をサポートするプロトコル。IP エンド システムで実行されているアプリケーションは、RSVP を使用して、受信するパケット ストリームの特性(帯域幅、ジッタ、最大バーストなど)を他のノードに示すことができます。RSVP は IPv6 に依存します。リソース予約設定プロトコルとも呼ばれます。

TLV :Type, Length, Value(タイプ、長さ、値)。シスコ検出プロトコル アドレスに含まれる情報のブロックです。

TTL 隠蔽 :存続可能時間は、設定可能なパラメータで、パケットが宛先に到達するまでに通過するホップの最大数を示します。

UDP :User Datagram Protocol(ユーザ データグラム プロトコル)。TCP/IP プロトコル スタックにおけるコネクションレス型トランスポート レイヤ プロトコル。UDP は、確認応答や配信保証を行わずにデータグラムを交換する単純なプロトコルです。そのため、エラー処理と再伝送を他のプロトコルで処理する必要があります。UDP は RFC 768 で定義されています。

パント :ルータ アラートを含むパケットを処理のためにライン カードまたはインターフェイスから Route Processor(RP; ルート プロセッサ)のレベル処理にリダイレクトします。

フラグメンテーション :元のパケット サイズをサポートできないネットワーク メディアを介してパケットを送信するときに、パケットを小さい単位に分割するプロセス。

フロー :1 組のホスト間、または 1 組のホスト上にある 1 組のトランスポート プロトコル ポート間で転送されるパケットのセット。たとえば、同じ送信元アドレス、送信元ポート、宛先アドレス、および宛先ポートを持つパケットは、フローと見なされることがあります。

フローは、ネットワークの 2 つのエンドポイント間で(たとえば、ある LAN ステーションから別の LAN ステーションへ)転送されるデータのストリームでもあります。複数のフローを 1 つの回線で送信できます。