マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS ラベル配布プロトコル(LDP)
MPLS ラベル配布プロトコル(LDP)
発行日;2012/01/30 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS ラベル配布プロトコル(LDP)

この章の構成

MPLS LDP の前提条件

MPLS LDP に関する情報

MPLS LDP の概要

MPLS LDP 機能の概要

LDP および TDP のサポート

LDP セッションの概要

直接接続されている MPLS LDP セッション

直接接続されていない MPLS LDP セッション

LDP ラベル バインディング、ラベル スペース、および LDP ID の概要

MPLS LDP の設定方法

直接接続されている LDP セッションのイネーブル化

直接接続されていない MPLS LDP セッションの確立

前提条件

設定の保存:MPLS/タグ スイッチング コマンド

LDP ルータ ID の指定

前提条件

MPLS LDP の明示的ヌルを使用した QoS 設定の保持

MD5 認証による LDP ピア間のデータの保護

MPLS LDP の設定例

直接接続されている MPLS LDP セッションの設定:例

直接接続されていない MPLS LDP セッションの確立:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

MPLS ラベル配布プロトコルの機能情報

MPLS ラベル配布プロトコル(LDP)

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Label Distribution Protocol(LDP; ラベル配布プロトコル)を使用すると、MPLS ネットワーク内のピア Label Switch Router(LSR; ラベル スイッチ ルータ)は、MPLS ネットワークでのホップバイホップ転送をサポートするためのラベル バインディング情報を交換できます。この章では、MPLS LDP に関連する概念と、ネットワークでの MPLS LDP の設定方法について説明します。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「MPLS ラベル配布プロトコルの機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

MPLS LDP の前提条件

ルータ上でラベル スイッチングを行うには、そのルータで Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)をイネーブルにする必要があります。

MPLS LDP に関する情報

MPLS LDP を設定するには、次の概念を理解する必要があります。

「MPLS LDP の概要」

「MPLS LDP 機能の概要」

「LDP および TDP のサポート」

「LDP セッションの概要」

「LDP ラベル バインディング、ラベル スペース、および LDP ID の概要」

MPLS LDP の概要

MPLS LDP を使用すると、LSR はラベル プレフィクス バインディング情報を要求し、ネットワーク内のピア ルータに配布したり解放したりできます。また、LSR は潜在的なピアを検出し、ラベル バインディング情報を交換するためにそれらのピアとの LDP セッションを確立できます。

MPLS LDP を使用すると、ある LSR は自身が行ったラベル バインディングを別の LSR に通知できます。1 組のルータは LDP パラメータを通信すると、Label Switched Path(LSP; ラベル スイッチド パス)を確立します。MPLS LDP を使用すると、LSR は、通常ルーティングされるパスに沿ってラベルを配布して MPLS 転送に対応できます。このラベル配布方法は、ホップバイホップ転送とも呼ばれます。IP 転送では、パケットがルータに到達すると、そのルータは IP ヘッダー内の宛先アドレスを確認し、ルート検索を実行してパケットをネクストホップに転送します。MPLS 転送では、パケットがルータに到達すると、そのルータは着信ラベルを確認し、テーブル内のラベルを検索してパケットをネクストホップに転送します。MPLS LDP は、MPLS VPN などのホップバイホップ転送を必要とするアプリケーションに役立ちます。

MPLS LDP 機能の概要

Cisco MPLS LDP は、MPS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)などの MPLS 対応アプリケーションのビルディング ブロックを提供します。

LDP は、基になる Interior Gateway Protocol(IGP)ルーティング プロトコルによって選択されたルートにラベルを割り当てることにより、MPLS ネットワークにおけるホップバイホップ(つまりダイナミック ラベル)配布の標準の方式を提供します。その結果得られるラベル付きパスは Label Switch Path(LSP; ラベル スイッチ パス)と呼ばれ、MPLS バックボーン上でラベル トラフィックを特定の宛先に転送します。サービス プロバイダーはこれらの機能を使用して、MPLS ベースの IP VPN と IP+ATM サービスをマルチベンダー MPLS ネットワークに実装できます。

LDP および TDP のサポート

LDP は、Tag Distribution Protocol(TDP; タグ配布プロトコル)に代わるものです。Cisco IOS リリースにおける LDP と TDP のサポートの詳細については、 表 1 を参照してください。

TDP を使用するルータ上のイメージをアップグレードする場合は、十分注意してください。新しいイメージをロードするときに、TDP セッションが確立されていることを確認してください。確認するには、グローバル コンフィギュレーション コマンド mpls label protocol tdp を発行します。新しいイメージをロードする前に、このコマンドを発行してスタートアップ コンフィギュレーションに保存します。または、新しいイメージのロード後すぐにコマンドを入力し、実行コンフィギュレーションを保存することもできます。

 

表 1 LDP および TDP のサポート

トレインとリリース
LDP/TDP のサポート

12.0S Train

TDP はデフォルトでイネーブルになっています。

Cisco IOS Release 12.0(29)S 以前のリリース:TDP は LDP 機能でサポートされます。

Cisco IOS Release 12.0(30)S 以降のリリース:TDP は LDP 機能でサポートされません。

12.2S、SB、および SR Train

LDP はデフォルトでイネーブルになっています。

Cisco IOS Release 12.2(25)S 以前のリリース:TDP は LDP 機能でサポートされます。

Cisco IOS Release 12.2(27)SBA、12.2(27)SRA、12.2(27)SRB 以降のリリース:TDP は LDP 機能でサポートされません。

12.T/Mainline Train

Cisco IOS Release 12.3(14)T 以前のリリース:TDP はデフォルトでイネーブルになっています。

Cisco IOS Release 12.4 および 12.4T 以降のリリース:LDP はデフォルトでイネーブルになっています。

Cisco IOS Release 12.3(11)T 以前のリリース:TDP は LDP 機能でサポートされます。

Cisco IOS Release 12.3(14)T 以降のリリース:TDP は LDP 機能でサポートされません。

LDP セッションの概要

MPLS LDP をイネーブルにすると、LSR はメッセージを送信して、LDP セッションを作成できる他の LSR を探そうとします。ここでは、直接接続されている LDP セッションと直接接続されていない LDP セッションの違いについて説明します。

直接接続されている MPLS LDP セッション

LSR がそのネイバーから 1 つめのホップである場合、LSR はネイバーに直接接続されています。LSR は、LDP リンク Hello メッセージを User Datagram Protocol(UDP; ユーザ データグラム プロトコル)パケットとしてサブネット上のすべてのルータに送信します(マルチキャスト)。ネイバー LSR がリンクの Hello メッセージに応答すると、2 つのルータは LDP セッションを確立できます。これを基本ディスカバリと呼びます。

ルータ間の LDP セッションを開始するために、ルータはアクティブ ロールを担当するルータとパッシブ ロールを担当するルータを決定します。アクティブ ロールを担当するルータは、LDP TCP 接続セッションを確立し、LDP セッション パラメータのネゴシエーションを開始します。ロールを決定するために、2 つのルータはトランスポート アドレスを比較します。高い方の IP アドレスを持つルータがアクティブ ロールを担当し、セッションを確立します。

LDP TCP 接続セッションが確立されると、LSR は、使用するラベル配布方法などのセッション パラメータをネゴシエーションします。次の 2 つの方法を使用できます。

ダウンストリーム未承諾:LSR は、要求されなくてもラベル マッピングをピアにアドバタイズします。

ダウンストリームオンデマンド:LSR は、ピアから要求された場合だけラベル マッピングをピアにアドバタイズします。

LDP セッションの作成については、「直接接続されている LDP セッションのイネーブル化」を参照してください。

直接接続されていない MPLS LDP セッション

LSR がネイバーから 2 つめ以降のホップである場合、LSR はそのネイバーに直接接続されていません。LSR は、これらの直接接続されていないネイバーに対し、ターゲット Hello メッセージを UDP パケットとして、特にその LSR に宛てられたユニキャスト メッセージとして送信します。直接接続されていない LSR が Hello メッセージに応答すると、2 つのルータは LDP セッションの確立を開始します。これを拡張ディスカバリと呼びます。

MPLS LDP ターゲット セッションは、直接接続されていないルータ間のラベル配布セッションです。MPLS トラフィック エンジニアリング トンネル インターフェイスを作成する場合、トンネルのヘッドエンドとテールエンドのルータ間にラベル配布セッションを確立する必要があります。直接接続されていない MPLS LDP セッションを確立するには、ターゲット Hello メッセージの伝送をイネーブルにします。

Traffic Engineering(TE; トラフィック エンジニアリング)トンネルに対する mpls ip の設定や Any Transport over MPLS(AToM)Virtual Circuit(VC; 仮想回線)の設定など、他のターゲット セッション確立方法が適用されない場合は、 mpls ldp neighbor targeted コマンドを使用してターゲット セッションを設定できます。たとえば、MPLS ラベル転送のコンバージェンス時間が問題になっている場合は、このコマンドを使用して、直接接続されている MPLS Label Switch Router(LSR; ラベル スイッチ ルータ)間のターゲット セッションを作成できます。

mpls ldp neighbor targeted コマンドを使用すると、ネイバー LSR を直接接続しているリンクがダウンした場合に、それらの LSR のラベル コンバージェンス時間を短縮できます。ネイバー LSR 間のリンクがアップ状態の場合、リンクとターゲット Hello によって LDP セッションが保持されます。ネイバー LSR 間のリンクがダウンすると、ターゲット Hello によってセッションが保持され、LSR は相互のルータから学習したラベルを保持できます。LSR を直接接続するリンクがアップ状態に戻ると、LSR はただちに転送に使用するラベルを再インストールします。このとき、LDP セッションを再確立したり、ラベルを交換したりする必要はありません。

2 つの直接接続されていないネイバー間でのターゲット Hello メッセージの交換は、次のようにいくつかの方法で行われます。

ルータ 1 は、応答要求を伝送するターゲット Hello メッセージをルータ 2 に送信します。ルータ 2 は、設定で許可されている場合、応答としてターゲット Hello メッセージを送信します。この場合、ルータ 1 はアクティブと見なされ、ルータ 2 はパッシブと見なされます。

ルータ 1 とルータ 2 は、両方ともターゲット Hello メッセージを相互に送信します。両方のルータはアクティブと見なされます。相互のルータから送信されたターゲット Hello メッセージの要求に応答するように設定されている場合、両方または一方がパッシブと見なされるか、またはどちらもパッシブと見なされないことがあります。

LSR のデフォルトの動作では、ターゲット Hello メッセージを送信する他の LSR からの要求を無視します。 mpls ldp discovery targeted-hello accept コマンドを発行して、ターゲット Hello メッセージの要求に応答するように LSR を設定できます。

アクティブな LSR は、ターゲット セッションに使用するプロトコルを要求します。パッシブな LSR は、受信したターゲット Hello メッセージのプロトコルを使用します。

MPLS LDP ターゲット セッションの作成の詳細については、「直接接続されていない MPLS LDP セッションの確立」を参照してください。

LDP ラベル バインディング、ラベル スペース、および LDP ID の概要

LDP ラベル バインディングは、送信先プレフィクスとラベル間のアソシエーションです。ラベル バインディングで使用されるラベルは、ラベル スペースと呼ばれる一連のラベルから割り当てられます。

LDP では、次の 2 つのタイプのラベル スペースがサポートされています。

インターフェイス固有:インターフェイス固有のラベル スペースは、ラベルにインターフェイス リソースを使用します。たとえば、Label-Controlled ATM(LC-ATM; ラベル制御 ATM)インターフェイスは、ラベルに Virtual Path Identifier/Virtual Circuit Identifier(VPI/VCI; 仮想パス識別子/仮想チャネル識別子)を使用します。設定によって、LDP プラットフォームでサポートされるインターフェイス固有のラベル スペースの数は、ゼロ、1 つ、または複数です。

プラットフォーム全体:LDP プラットフォームでは、1 つのプラットフォーム全体のラベル スペースがサポートされます。プラットフォーム全体のラベル スペースは、同じラベルを共有できるインターフェイスによって使用されます。シスコのプラットフォームでは、LC-ATM を除くすべてのインターフェイス タイプでプラットフォーム全体のラベル スペースが使用されます。

LDP では、LDP Identifier(LDP ID)と呼ばれる 6 バイトを使用してラベル スペースに名前を付けます。LDP ID は、次のコンポーネントで構成されます。

最初の 4 バイトは、LPD ルータ ID と呼ばれ、ラベル スペースを所有する LSR を識別します。

最後の 2 バイトは、ローカル ラベル スペース ID と呼ばれ、LSR 内のラベル スペースを識別します。プラットフォーム全体のラベル スペースでは、LDP ID の最後の 2 バイトは両方とも常に 0 です。

LDP ID は次の形式になります。

<LDP ルータ ID> : <ローカル ラベル スペース ID>

次に、LPD ID の例を示します。

172.16.0.0:0

192.168.0.0:3

mpls ldp router-id コマンドを実行しない場合、LDP ルータ ID はルータによって次のように決定されます。

1. ルータは、すべての動作インターフェイスの IP アドレスを調べます。

2. これらの IP アドレスにループバック インターフェイス アドレスが含まれている場合、ルータは最大のループバック アドレスを LDP ルータ ID として選択します。

3. それ以外の場合、ルータは動作インターフェイスに関連する最大の IP アドレスを LDP ルータ ID として選択します。

LDP ルータ ID の通常(デフォルト)の決定方法では、特定の状況で使用できないルータ ID が選択される場合があります。たとえば、ルータはルーティング プロトコルがネイバー ルータにアドバタイズできない IP アドレスを LDP ルータ ID として選択する場合があります。 mpls ldp router-id コマンドを使用すると、インターフェイスの IP アドレスを LDP ルータ ID として指定できます。IP アドレスを LDP ルータ ID として使用できるように、指定したインターフェイスが動作中であることを確認します。

force キーワードを指定せずに mpls ldp router-id コマンドを発行すると、ルータは次回 LDP ルータ ID の選択が必要になった場合に(通常は、次回インターフェイスがシャットダウンされた場合、またはアドレスが設定された場合に)、指定されたインターフェイスの IP アドレスを選択します(インターフェイスが動作中の場合)。

force キーワードを指定して mpls ldp router-id コマンドを発行した場合、 mpls ldp router-id コマンドの効果は、指定されたインターフェイスの現在の状態によって異なります。

インターフェイスがアップ状態(動作中)の場合、およびインターフェイスの IP アドレスが現在 LDP ルータ ID ではない場合、LDP ルータ ID は、そのインターフェイスの IP アドレスに変わります。LDP ルータ ID のこの強制的な変更によって、既存の LDP セッションが切断され、LDP セッションを通じて学習されたラベル バインディングが解放されます。また、バインディングに関連付けられていた MPLS 転送アクティビティが中断されます。

mpls ldp router-id interface force コマンドを発行したときにインターフェイスがダウンしている(動作していない)場合、インターフェイスがアップ状態に移行すると、LDP ルータ ID はそのインターフェイスの IP アドレスに変更されます。LDP ルータ ID のこの強制的な変更によって、既存の LDP セッションが切断され、LDP セッションを通じて学習されたラベル バインディングが解放されます。また、バインディングに関連付けられていた MPLS 転送アクティビティが中断されます。

MPLS LDP の設定方法

ここでは、次の各手順について説明します。

「直接接続されている LDP セッションのイネーブル化」(必須)

「直接接続されていない MPLS LDP セッションの確立」(任意)

「設定の保存:MPLS/タグ スイッチング コマンド」(任意)

「LDP ルータ ID の指定」(任意)

「MPLS LDP の明示的ヌルを使用した QoS 設定の保持」(任意)

「MD5 認証による LDP ピア間のデータの保護」(任意)

直接接続されている LDP セッションのイネーブル化

この手順では、直接接続されている 2 つのルータ間の MPLS LDP セッションを設定する方法について説明します。

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol { ldp | tdp | both }

5. interface type number

6. mpls ip

7. exit

8. exit

9. show mpls interfaces [ interface ] [ detail ]

10. show mpls ldp discovery [ all | vrf vpn-name ] [ detail ]

11. show mpls ldp neighbor [[ vrf vpn-name ] [ address | interface ] [ detail ] | [ all ]]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip
 
Router(config)# mpls ip

MPLS ホップバイホップ転送をグローバルに設定します。

mpls ip コマンドはデフォルトでイネーブルになってるため、このコマンドを指定する必要はありません。

MPLS 転送をグローバルにイネーブルにした場合、MPLS 転送はルータ インターフェイス上ではイネーブルになりません。MPLS 転送は、インターフェイスとルータに対してイネーブルにする必要があります。

ステップ 4

mpls label protocol {ldp | tdp | both}
 
Router(config)# mpls label protocol ldp

すべてのインターフェイスに対して LDP の使用を設定します。LDP がデフォルトです。

すべてのインターフェイスをグローバルに LDP に設定した場合は、インターフェイス コンフィギュレーション モードでコマンドを指定し、 tdp または both キーワードで特定のインターフェイスを上書きできます。

ステップ 5

Router(config)# interface type number
 
Router(config)# interface ethernet3/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

mpls ip
 
Router(config-if)# mpls ip

インターフェイスに対して MPLS ホップバイホップ転送を設定します。

MPLS 転送は、インターフェイスとルータに対してイネーブルにする必要があります。

ステップ 7

exit
 
Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 8

exit
 
Router(config)# exit

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 9

show mpls interfaces [ interface ] [ detail ]
 
Router# show mpls interfaces

LDP、TDP または両方を使用するようにインターフェイスが設定されていることを確認します。

ステップ 10

show mpls ldp discovery [ all | vrf vpn-name ] [ detail ]
 
Router# show mpls ldp discovery

インターフェイスがアップ状態でディスカバリ Hello メッセージを送信することを確認します。

ステップ 11

show mpls ldp neighbor [[ vrf vpn-name ] [ address | interface ] [ detail ] | [ all ]]
 
Router# show mpls ldp neighbor

LDP セッションのステータスを表示します。

次の show mpls interfaces コマンドは、インターフェイスのイーサネット 1/0 と 1/1 が LDP を使用するように設定されていることを確認します。

Router# show mpls interfaces
 
Interface IP Tunnel BGP Static Operational
Ethernet3/0 Yes (ldp) No No No Yes
Ethernet3/1 Yes No No No Yes
 

次の show mpls ldp discovery コマンドは、インターフェイスがアップ状態で、TDP Hello メッセージではなく、LDP ディスカバリ Hello メッセージを送信することを確認します。

Router# show mpls ldp discovery
 
Local LDP Identifier:
172.16.12.1:0
Discovery Sources:
Interfaces:
Ethernet3/0 (ldp): xmit
 

次に、ルータ間の LDP セッションが正常に確立された例を示します。

Router# show mpls ldp neighbor
 
Peer LDP Ident: 10.1.1.2:0; Local LDP Ident 10.1.1.1:0
TCP connection: 10.1.1.2.18 - 10.1.1.1.66
State: Oper; Msgs sent/rcvd: 12/11; Downstream
Up time: 00:00:10
LDP discovery sources:
FastEthernet1/0, Src IP addr: 10.20.10.2
Addresses bound to peer LDP Ident:
10.1.1.2 10.20.20.1 10.20.10.2
 

直接接続されている LDP セッションの設定例については、「直接接続されている MPLS LDP セッションの設定:例」を参照してください。

直接接続されていない MPLS LDP セッションの確立

ここでは、直接接続されていない MPLS LDP セッションを設定する方法について説明します。これにより、直接接続されていないルータ間の LDP セッションを確立できます。

前提条件

MPLS には CEF が必要です。

mpls ldp discovery targeted-hello accept コマンドを使用して、トンネルの両端にあるルータをアクティブに設定するか、または一方のルータをパッシブにできるようにする必要があります。

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol { ldp | tdp | both }

5. interface tunnel number

6. tunnel destination ip-address

7. mpls ip

8. exit

9. exit

10. show mpls ldp discovery [ all | vrf vpn-name ] [ detail ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip
 
Router(config)# mpls ip

MPLS ホップバイホップ転送をグローバルに設定します。

mpls ip コマンドはデフォルトでイネーブルになってるため、このコマンドを指定する必要はありません。

MPLS 転送をグローバルにイネーブルにした場合、MPLS 転送はルータ インターフェイス上ではイネーブルになりません。MPLS 転送は、インターフェイスとルータに対してイネーブルにする必要があります。

ステップ 4

mpls label protocol {ldp | tdp | both}
 
Router(config)# mpls label protocol ldp

すべてのインターフェイスに対して LDP の使用を設定します。LDP がデフォルトです。

すべてのインターフェイスをグローバルに LDP に設定した場合は、インターフェイス コンフィギュレーション モードでコマンドを指定し、 tdp または both キーワードで特定のインターフェイスを上書きできます。

ステップ 5

interface tunnelnumber
 
Router(config)# interface tunnel1

トンネル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

tunnel destination ip-address
 
Router(config-if)# tunnel destination 172.16.1.1

トンネル インターフェイスに IP アドレスを割り当てます。

ステップ 7

mpls ip
 
Router(config-if)# mpls ip

インターフェイスに対して MPLS ホップバイホップ転送を設定します。

MPLS 転送は、インターフェイスとルータに対してイネーブルにする必要があります。

ステップ 8

exit
 
Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 9

exit
 
Router(config)# exit

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 10

show mpls ldp discovery [ all | vrf vpn-name ] [ detail ]
 
Router# show mpls ldp discovery

インターフェイスがアップ状態でディスカバリ Hello メッセージを送信することを確認します。

次に、直接接続されていない LDP セッションに対する show mpls ldp discovery コマンドの出力例を示します。

Router# show mpls ldp discovery
 
Local LDP Identifier:
172.16.0.0:0
Discovery Sources:
Interfaces:
POS2/0 (ldp): xmit/recv
LDP Id: 172.31.255.255:0
Tunnel1 (ldp): Targeted -> 192.168.255.255
Targeted Hellos:
172.16.0.0 -> 192.168.255.255 (ldp): active, xmit/recv
LDP Id: 192.168.255.255:0
172.16.0.0 -> 192.168.0.0 (tdp): passive, xmit/recv
TDP Id: 192.168.0.0:0
 

このコマンド出力は、次のことを示しています。

ローカル LSR(172.16.0.0)は、インターフェイス POS2/0 で LDP リンク Hello メッセージを送信し、ネイバー 172.31.255.255 を検出しました。

ローカル LSR は、インターフェイス Tunnel1 に関連付けられている LDP ターゲット Hello メッセージをターゲット 192.168.255.255 に送信しました。LSR は、LDP を使用するように設定されています。

ローカル LSR は 192.168.255.255 のターゲット ディスカバリ アクティビティに対してアクティブです。これは、LSR が 192.168.255.255 に送信するターゲット Hello メッセージによって応答要求が伝送されることを意味します。ローカル LSR は、直接接続されていない LSR 192.168.255.255 との LDP セッションを持つように設定されています。

ローカル LSR は、次のいずれかの理由により、192.168.255.255 のディスカバリ アクティビティからパッシブではありません。

192.168.255.255 から受信するターゲット Hello メッセージは、応答要求を伝送しません。

ローカル LSR は、そのような要求に応答するように設定されていません。

ローカル LSR は、TDP 有向型 Hello メッセージをターゲット LSR 192.168.0.0 に送信しました。この LSR は、ターゲット LSR 192.168.0.0 から受信した Hello メッセージが TDP有向型 Hello メッセージであったため、TDP を使用します。

ローカル LSR は、LSR 192.168.0.0 のディスカバリ アクティビティでパッシブです。これは、LSR 192.168.0.0 から受信する有向型 Hello メッセージが応答要求を伝送し、ローカル LSR が mpls ldp discovery targeted-hello accept コマンドで LSR 192.168.0.0 からのそのような要求に応答するように設定されていることを意味します。

ローカル LSR は LSR 192.168.0.0 のディスカバリ アクティビティでアクティブではありません。これは、LSR 192.168.0.0 との LDP セッションを必要とするアプリケーションがローカル LSR 上で設定されていないためです。

LDP ターゲット セッションの設定例については、「直接接続されていない MPLS LDP セッションの確立:例」を参照してください。

設定の保存:MPLS/タグ スイッチング コマンド

Cisco IOS ソフトウェア 12.4(2)T よりも前のリリースでは、一部の MPLS コマンドにタグ スイッチング バージョンと MPLS バージョンの両方がありました。たとえば、2 つのコマンド tag-switching ip mpls ip は同じものでした。下位互換性をサポートするために、タグ スイッチング形式のコマンドが保存済みの設定に書き込まれました。

Cisco IOS Release 12.4(2)T からは、MPLS 形式のコマンドが保存済みの設定に書き込まれます。

次に、タグ スイッチング形式と MPLS 形式の両方がある次のコマンドを使用して、ATM インターフェイスを設定する例を示します。

Router(config)# interface ATM3/0
Router(config-if)# ip unnumbered Loopback0
router(config-if)# tag-switching ip
Router(config-if)# mpls label protocol ldp
 

これらのコマンドを入力し、この設定を保存するか、 show running コマンドを使用して実行コンフィギュレーションを表示した場合、保存または表示されるコマンドは次のようになります。

interface ATM3/0
ip unnumbered Loopback0
mpls ip
mpls label protocol ldp
 

LDP ルータ ID の指定

mpls ldp router-id コマンドを使用すると、インターフェイスの IP アドレスを LDP ルータ ID として設定できます。

次の手順では、LDP ルータ ID を決定する通常のプロセスについて説明します。

1. ルータは、すべての動作インターフェイスのすべての IP アドレスを考慮します。

2. これらのアドレスにループバック インターフェイス アドレスが含まれている場合、ルータは最大のループバック アドレスを選択します。ループバック アドレスの状態は変わらないため、ループバック アドレスを設定すると、ルータに安定した LDP ID を確保できます。ただし、各ルータでループバック インターフェイスと IP アドレスを設定する必要はありません。

次のような場合、ループバック IP アドレスは、ローカル LDP ID のルータ ID になりません。

ループバック インターフェイスが明示的にシャットダウンされた場合

mpls ldp router-id コマンドによって、別のインターフェイスを LDP ルータ ID として使用するように指定された場合

ループバック インターフェイスを使用する場合は、ループバック インターフェイスの IP アドレスが /32 ネットワーク マスクで設定されていることを確認します。さらに、使用中のルーティング プロトコルが対応する /32 ネットワークをアドバタイズするように設定されていることを確認します。

3. それ以外の場合、ルータは最大のインターフェイス アドレスを選択します。

ルータは、特定の状況で使用できないルータ ID を選択する場合があります。たとえば、ルータは、ルーティング プロトコルがネイバー ルータにアドバタイズできない IP アドレスを選択する場合があります。

ルータは、次回 LDP ルータ ID の選択が必要になったときにルータ ID を実装します。コマンドの効果は、次回 LDP ルータ ID の選択が必要になるときまで反映されません。通常、これは次回インターフェイスがシャットダウンされるか、またはアドレスの設定が解除されるときです。

mpls ldp router-id コマンドで force キーワードを使用した場合、ルータ ID はすぐに有効になります。ただし、ルータ ID の実装は、指定したインターフェイスの現在の状態に応じて、次のように異なります。

インターフェイスがアップ状態(動作中)の場合、およびその IP アドレスが現在 LDP ルータ ID ではない場合、LDP ルータ ID は、強制的にそのインターフェイスの IP アドレスに変更されます。LDP ルータ ID のこの強制的な変更によって、既存の LDP セッションが切断され、LDP セッションを通じて学習されたラベル バインディングが解放されます。また、バインディングに関連付けられていた MPLS 転送アクティビティが中断されます。

インターフェイスがダウンしている場合、インターフェイスがアップ状態に移行すると、LDP ルータ ID は、強制的にそのインターフェイスの IP アドレスに変更されます。LDP ルータ ID のこの強制的な変更によって、既存の LDP セッションが切断され、LDP セッションを通じて学習されたラベル バインディングが解放されます。また、バインディングに関連付けられていた MPLS 転送アクティビティが中断されます。

前提条件

指定したインターフェイスを LDP ルータ ID として割り当てる前に、そのインターフェイスが動作中であることを確認します。

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol { ldp | tdp | both }

5. mpls ldp router-id interface [ force ]

6. exit

7. show mpls ldp discovery [ all | detail | vrf vpn-name ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip
 
Router(config)# mpls ip

MPLS ホップバイホップ転送をグローバルに設定します。

mpls ip コマンドはデフォルトでイネーブルになってるため、このコマンドを指定する必要はありません。

MPLS 転送をグローバルにイネーブルにした場合、MPLS 転送はルータ インターフェイス上ではイネーブルになりません。MPLS 転送は、インターフェイスとルータに対してイネーブルにする必要があります。

ステップ 4

mpls label protocol { ldp | tdp | both }
 
Router(config)# mpls label protocol ldp

すべてのインターフェイスに対して LDP の使用を設定します。LDP がデフォルトです。

すべてのインターフェイスをグローバルに LDP に設定した場合は、インターフェイス コンフィギュレーション モードでコマンドを指定し、 tdp または both キーワードで特定のインターフェイスを上書きできます。

ステップ 5

mpls ldp router-id interface [ force ]
 
Router(config)# mpls ldp router-id pos2/0/0

LDP ルータ ID を決定するための優先インターフェイスを指定します。

ステップ 6

exit
 
Router(config)# exit

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 7

show mpls ldp discovery [ all | detail | vrf vpn-name ]
 
Router# show mpls ldp discovery

ローカル ルータの LDP ID を表示します。

次に、インターフェイス pos2/0/0 を LDP ルータ ID として割り当てる例を示します。

Router> enable
Router# configure terminal
Router(config)# mpls ip
Router(config)# mpls label protocol ldp
Router(config)# mpls ldp router-id pos2/0/0 force
 

次に、LDP ルータ ID(10.15.15.15)を表示する例を示します。

Router# show mpls ldp discovery
 
Local LDP Identifier:
10.15.15.15:0
Discovery Sources:
Interfaces:
Ethernet4 (ldp): xmit/recv
LDP Id: 10.14.14.14:0

MPLS LDP の明示的ヌルを使用した QoS 設定の保持

通常、LDP は、直接接続されているルータに対して暗黙的ヌル ラベルをアドバタイズします。暗黙的ヌル ラベルがアドバタイズされると、最後から 2 番めの Label Switched Router(LSR; ラベル スイッチド ルータ)はパケットから MPLS ヘッダーを削除します。この場合、最後から 2 番めの LSR と最後の LSR は、MPLS ヘッダーが削除される前にパケットによって伝送された Quality of Service(QoS; サービス品質)値にアクセスできません。QoS 値を保持するには、明示的ヌル ラベル(ゼロのラベル値)をアドバタイズするように LSR を設定できます。最後から 2 番めのホップの LSR は、IP パケットを転送する代わりに、MPLS パケットにヌル ラベルを付加して転送します。


) 最後から 2 番めのホップが少なくとも 2 つのラベルを含むラベル スタックが付加された MPLS パケットを受信し、最後から 2 番めのホップのポッピングが実行される場合、明示的ヌル ラベルは必要ありません。この場合は、最後から 2 番めの LSR と最後の LSR に必要な QoS 値を内部ラベルで伝送して、その QoS ポリシーを実装できます。


mpls ldp explicit-null コマンドを発行すると、直接接続されているプレフィクスに対して、暗黙的ヌルの代わりに明示的ヌルがアドバタイズされます。

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol { ldp | tdp | both }

5. interface type number

6. mpls ip

7. exit

8. mpls ldp explicit-null [ for prefix-acl | to peer-acl | for prefix-acl to peer-acl ]

9. exit

10. show mpls forwarding-table [ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vpn-name ] [ detail ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip
 
Router(config)# mpls ip

MPLS ホップバイホップ転送をグローバルに設定します。

mpls ip コマンドはデフォルトでイネーブルになってるため、このコマンドを指定する必要はありません。

MPLS 転送をグローバルにイネーブルにした場合、MPLS 転送はルータ インターフェイス上ではイネーブルになりません。MPLS 転送は、インターフェイスとルータに対してイネーブルにする必要があります。

ステップ 4

mpls label protocol { ldp | tdp | both }
 
Router(config)# mpls label protocol ldp

すべてのインターフェイスに対して LDP の使用を設定します。LDP がデフォルトです。

すべてのインターフェイスをグローバルに LDP に設定した場合は、インターフェイス コンフィギュレーション モードでコマンドを指定し、 tdp または both キーワードで特定のインターフェイスを上書きできます。

ステップ 5

interface type number
 
Router(config)# interface atm2/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

mpls ip
 
Router(config-if)# mpls ip

インターフェイスに対して MPLS ホップバイホップ転送を設定します。

MPLS 転送は、インターフェイスとルータに対してイネーブルにする必要があります。

ステップ 7

exit
 
Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

mpls ldp explicit-null [ for prefix-acl | to peer-acl | for prefix-acl to peer-acl ]
 
Router(config)# mpls ldp explicit-null

通常は暗黙的ヌル ラベルをアドバタイズする状況で、明示的ヌル ラベルをアドバタイズします。

ステップ 9

exit
 
Router(config)# exit

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 10

show mpls forwarding-table [ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vpn-name ] [ detail ]
 
Router# show mpls forwarding-table

MPLS パケットが明示的ヌル ラベル(値 0)付きで転送されることを確認します。

出力 LSR で明示的ヌルをイネーブルにすると、その LSR は明示的ヌル ラベルをすべての隣接 MPLS ルータにアドバタイズします。

Router# configure terminal
Router(config)# mpls ldp explicit-null
 

隣接ルータで show mpls forwarding-table コマンドを発行した場合、出力では、MPLS パケットが明示的ヌル ラベル(値 0)付きで転送されることが示されます。次の例で、2 番めの列は、以前は「Pop label」とマークされていたエントリの送信ラベルが 0 になっていることを示しています。

Router# show mpls forwarding-table
 
Local Outgoing Prefix Bytes label Outgoing Next Hop
label label or VC or Tunnel Id switched interface
19 Pop tag 10.12.12.12/32 0 Fa2/1/0 172.16.0.1
22 0 10.14.14.14/32 0 Fa2/0/0 192.168.0.2
23 0 172.24.24.24/32 0 Fa2/0/0 192.168.0.2
24 0 192.168.0.0/8 0 Fa2/0/0 192.168.0.2
25 0 10.15.15.15/32 0 Fa2/0/0 192.168.0.2
26 0 172.16.0.0/8 0 Fa2/0/0 192.168.0.2
27 25 10.16.16.16/32 0 Fa2/0/0 192.168.0.22
28 0 10.34.34.34/32 0 Fa2/0/0 192.168.0.2
 

明示的ヌルをイネーブルにし、標準の Access Control List(ACL; アクセス コントロール リスト)とともに for キーワードを指定した場合、すべての隣接 MPLS ルータのテーブルが変更され、アクセス リストで指定されたエントリの明示的ヌル ラベルだけが交換されます。次の例では、10.24.24.24/32 エントリを含むアクセス リストが作成されます。明示的ヌルが設定され、アクセス リストが指定されています。

Router# configure terminal
Router(config)# mpls label protocol ldp
Router(config)# access-list 24 permit host 10.24.24.24
Router(config)# mpls ldp explicit-null for 24
 

隣接ルータで show mpls forwarding-table コマンドを発行すると、出力では、指定されたアドレス(172.24.24.24/32)の送信ラベルだけが Pop ラベルから 0 に変わることが示されます。他のすべての Pop ラベルの送信ラベルは、変わりません。

Router# show mpls forwarding-table
 
Local Outgoing Prefix Bytes label Outgoing Next Hop
label label or VC or Tunnel Id switched interface
19 Pop tag 10.12.12.12/32 0 Fa2/1/0 172.16.0.1
22 0 10.14.14.14/32 0 Fa2/0/0 192.168.0.2
23 0 172.24.24.24/32 0 Fa2/0/0 192.168.0.2
24 0 192.168.0.0/8 0 Fa2/0/0 192.168.0.2
25 0 10.15.15.15/32 0 Fa2/0/0 192.168.0.2
26 0 172.16.0.0/8 0 Fa2/0/0 192.168.0.2
27 25 10.16.16.16/32 0 Fa2/0/0 192.168.0.22
28 0 10.34.34.34/32 0 Fa2/0/0 192.168.0.2
 
 

明示的ヌルをイネーブルにし、 to キーワードとアクセス リストを指定すると、明示的ヌル ラベルをアクセス リストで指定した隣接ルータだけにアドバタイズできます。明示的ヌルを特定のルータにアドバタイズするには、アクセス リストでそのルータの LDP ID を指定する必要があります。

次の例では、アクセス リストに隣接 MPLS ルータの LDP ID である 10.15.15.15/32 エントリが含まれています。明示的ヌルが設定されたルータは、その隣接ルータだけに明示的ヌル ラベルをアドバタイズします。

Router# show mpls ldp discovery
 
Local LDP Identifier:
10.15.15.15:0
Discovery Sources:
Interfaces:
Ethernet4 (ldp): xmit/recv
TDP Id: 10.14.14.14:0
 
Router# configure terminal
Router(config)# mpls label protocol ldp
Router(config)# access-list 15 permit host 10.15.15.15
Router(config)# mpls ldp explicit-null to 15
 

show mpls forwarding-table コマンドを発行すると、出力には、明示的ヌル ラベルがアクセス リストで指定されたルータだけにアドバタイズされることが示されます。

Router# show mpls forwarding-table
 
Local Outgoing Prefix Bytes label Outgoing Next Hop
label label or VC or Tunnel Id switched interface
19 Pop tag 10.12.12.12/32 0 Fa2/1/0 172.16.0.1
22 0 10.14.14.14/32 0 Fa2/0/0 192.168.0.2
23 0 172.24.24.24/32 0 Fa2/0/0 192.168.0.2
24 0 192.168.0.0/8 0 Fa2/0/0 192.168.0.2
25 0 10.15.15.15/32 0 Fa2/0/0 192.168.0.2
26 0 172.16.0.0/8 0 Fa2/0/0 192.168.0.2
27 25 10.16.16.16/32 0 Fa2/0/0 192.168.0.22
28 0 10.34.34.34/32 0 Fa2/0/0 192.168.0.2
 

for キーワードと to キーワードの両方を使用して明示的ヌルをイネーブルにすると、明示的ヌル ラベル付きでアドバタイズするルートとこれらの明示的ヌル ラベルのアドバタイズ先の隣接ルータを指定できます。

Router# show access 15
 
Standard IP access list 15
permit 10.15.15.15 (7 matches)
 
Router# show access 24
 
Standard IP access list 24
permit 10.24.24.24 (11 matches)
 
Router# configure terminal
Router(config)# mpls label protocol ldp
Router(config)# mpls ldp explicit-null for 24 to 15
 

47K-60-4 というルータで show mpls forwarding-table コマンドを発行した場合、出力では、10.24.24.24/32 に対する明示的ヌル ラベルを受信することが示されます。

 
Router# show mpls forwarding-table
 
Local Outgoing Prefix Bytes label Outgoing Next Hop
label label or VC or Tunnel Id switched interface
17 0 <--- 10.24.24.24/32 0 Et4 172.16.0.1
20 Pop tag 172.16.0.0/8 0 Et4 172.16.0.1
21 20 10.12.12.12/32 0 Et4 172.16.0.1
22 16 10.0.0.0/8 0 Et4 172.16.0.1
23 21 10.13.13.13/32 0 Et4 172.16.0.1
25 Pop tag 10.14.14.14/32 0 Et4 172.16.0.1
27 Pop tag 192.168.0.0/8 0 Et4 172.16.0.1
28 25 10.16.16.16/32 0 Et4 172.16.0.1
29 Pop tag 192.168.34.34/32 0 Et4 172.16.0.1
 

MD5 認証による LDP ピア間のデータの保護

2 つの LDP ピア間の認証をイネーブルにして、ピア間の TCP 接続で送信された各セグメントを確認できます。両方の LDP ピアで同じパスワードを使用して認証を設定する必要があります。そうしなければ、ピア セッションは確立されません。

認証では、Message Digest 5(MD5)アルゴリズムを使用して、通信の整合性の確認とメッセージ発信者の認証を行います。

認証をイネーブルにするには、 password キーワードを指定して mpls ldp neighbor コマンドを発行します。これにより、ルータは TCP 接続で送信されるすべてのセグメントについて MD5 ダイジェストを生成し、TCP 接続から受信したすべてのセグメントの MD5 ダイジェストをチェックします。

LDP ネイバーのパスワードを設定すると、ルータは既存の LDP セッションを切断し、ネイバーとの新しいセッションを確立します。

ルータにネイバーのパスワードが設定され、そのネイバー ルータにパスワードが設定されていない場合、これらの 2 つのルータが LDP セッションを確立しようとすると、パスワードが設定されているルータのコンソールに、次のようなメッセージが表示されます。この場合、LDP セッションは確立されません。

%TCP-6-BADAUTH: No MD5 digest from [peer's IP address](11003) to [local router's IP address](646)

同様に、2 つのルータに設定されているパスワードが異なる場合、次のようなメッセージがコンソールに表示されます。この場合、LDP セッションは確立されません。

%TCP-6-BADAUTH: Invalid MD5 digest from [peer's IP address](11004) to [local router's IP address](646)

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol { ldp | tdp | both }

5. mpls ldp neighbor [ vrf vpn-name ] ip-address [ password [ 0-7 ] password-string ]

6. show mpls ldp neighbor [[ vrf vpn-name ] [ address | interface ] [ detail ] | [ all ]]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip
 
Router(config)# mpls ip

MPLS ホップバイホップ転送をグローバルに設定します。

mpls ip コマンドはデフォルトでイネーブルになってるため、このコマンドを指定する必要はありません。

MPLS 転送をグローバルにイネーブルにした場合、MPLS 転送はルータ インターフェイス上ではイネーブルになりません。MPLS 転送は、インターフェイスとルータに対してイネーブルにする必要があります。

ステップ 4

mpls label protocol { ldp | tdp | both }
 
Router(config)# mpls label protocol ldp

すべてのインターフェイスに対して LDP の使用を設定します。LDP がデフォルトです。

すべてのインターフェイスをグローバルに LDP に設定した場合は、インターフェイス コンフィギュレーション モードでコマンドを指定し、 tdp または both キーワードで特定のインターフェイスを上書きできます。

ステップ 5

mpls ldp neighbor [ vrf vpn-name ] ip-address [ password [ 0-7 ] password-string ]
 
Router(config)# mpls ldp neighbor 172.27.0.15 password onethirty9

2 つの LDP ピア間の認証を指定します。

ステップ 6

exit
 
Router(config)# exit

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 7

show mpls ldp neighbor [[ vrf vpn-name ] [ address | interface ] [ detail ] | [ all ]]
 
Router# show mpls ldp neighbor detail

LDP セッションのステータスを表示します。

両方の LDP ピアにパスワードが設定されており、それらのパスワードが一致する場合は、 show mpls ldp neighbor コマンドを発行すると、LDP セッションが正常に確立されたことが表示されます。

次に、ルータにパスワード cisco を設定する例を示します。

Router> enable

Router# configure terminal

Router(config)# mpls ip
Router(config)# mpls label protocol ldp
Router(config)# mpls ldp neighbor 10.1.1.1 password cisco
Router(config)# exit
 

次に、ルータ間の LDP セッションが正常に確立された例を示します。

Router# show mpls ldp neighbor
 
Peer LDP Ident: 10.1.1.2:0; Local LDP Ident 10.1.1.1:0
TCP connection: 10.1.1.2.11118 - 10.1.1.1.646
State: Oper; Msgs sent/rcvd: 12/11; Downstream
Up time: 00:00:10
LDP discovery sources:
FastEthernet1/0, Src IP addr: 10.20.10.2
Addresses bound to peer LDP Ident:
10.1.1.2 10.20.20.1 10.20.10.2
 

次の show mpls ldp neighbor detail コマンドは、MD5(太字で表示)が LDP セッションに使用されていることを示しています。

Router# show mpls ldp neighbor 10.0.0.21 detail
 
Peer LDP Ident: 10.0.0.21:0; Local LDP Ident 10.0.0.22:0
TCP connection: 10.0.0.21.646 - 10.0.0.22.14709; MD5 on
State: Oper; Msgs sent/rcvd: 1020/1019; Downstream; Last TIB rev sent 2034
Up time: 00:00:39; UID: 3; Peer Id 1;
LDP discovery sources:
FastEthernet1/1; Src IP addr: 172.16.1.1
holdtime: 15000 ms, hello interval: 5000 ms
Addresses bound to peer LDP Ident:
10.0.0.21 10.0.38.28 10.88.88.2 172.16.0.1
172.16.1.1
Peer holdtime: 180000 ms; KA interval: 60000 ms; Peer state: estab

MPLS LDP の設定例

ここでは、次の設定例を示します。

「直接接続されている MPLS LDP セッションの設定:例」

「直接接続されていない MPLS LDP セッションの確立:例」

直接接続されている MPLS LDP セッションの設定:例

図 1 に、直接接続されている LDP セッションを設定するためのサンプル ネットワークを示します。

この例では、次のように設定します。

ルータ 1 とルータ 2 の間およびルータ 1 とルータ 3 の間の POS リンクに MPLS ホップバイホップ転送を設定する。

ルータ 1 とルータ 2 の間のラベル配布に LDP を設定する。

ルータ 1 とルータ 3 の間のラベル配布に TDP を設定する。

LDP ルータ ID として使用できる各 LSR のループバック インターフェイスと IP アドレスを設定する。

図 1 MPLS LDP の設定

 


) 次の設定例は、図 1 に示すサンプル ネットワーク内のルータ 1、ルータ 2、およびルータ 3 に対する LDP の設定に関連するコマンドだけを示しています。


ルータ 1 設定

ip cef distributed !Assumes R1 supports distributed CEF
interface Loopback0 !Loopback interface for LDP ID.
ip address 172.16.0.11 255.255.255.255
!
interface POS3/0/0
ip address 10.0.0.44 255.0.0.0
mpls ip !Enable hop-by-hop MPLS forwarding
mpls label protocol ldp !Use LDP for this interface
!
interface POS3/0/1
ip address 192.168.0.44 255.0.0.0
mpls ip !Enable hop-by-hop MPLS forwarding
mpls label protocol tdp !Use TDP for this interface

ルータ 2 設定

ip cef distributed !Assumes R2 supports distributed CEF
!
interface Loopback0 !Loopback interface for LDP ID.
ip address 172.16.0.22 255.255.255.255
!
interface POS2/0/0
ip address 10.0.0.33 255.0.0.0
mpls ip !Enable hop-by-hop MPLS forwarding
mpls label protocol ldp !Use LDP for this interface

ルータ 3 設定

ip cef !Assumes R3 does not support dCEF
!
interface Loopback0 !Loopback interface for LDP ID.
ip address 172.16.0.33 255.255.255.255
!
interface POS1/0
ip address 192.168.0.55 255.0.0.0
mpls ip !Enable hop-by-hop MPLS forwarding
mpls label protocol tdp !Use tDP for this interface
 

ルータ 1 の LDP 設定では、インターフェイス コンフィギュレーション モードで mpls label protocol ldp コマンドを使用しています。これは、一部のインターフェイスでは LDP が使用され、他のインターフェイスでは TDP が使用されているためです。ルータ 1 を設定する別の方法では、グローバル コンフィギュレーション モードで mpls label protocol ldp コマンドを使用して LDP をインターフェイスのデフォルト プロトコルとして設定し、インターフェイス コンフィギュレーション モードで mpls label protocol tdp コマンドを使用してルータ 3 への POS3/0/1 リンクに TDP を設定します。この別の方法によるルータ 1 の設定例を次に示します。

ルータ 1 設定

ip cef distributed !Assumes R1 supports dCEF
mpls label protocol ldp !Use LDP for the default protocol
!
interface Loopback0 !Loopback interface for LDP ID.
ip address 172.16.0.11 255.255.255.255
interface POS3/0/0
ip address 10.0.0.44 255.0.0.0
mpls ip !Enable hop-by-hop MPLS forwarding
!Use LDP (configured i/f default)
interface POS3/0/1
ip address 192.168.0.44 255.0.0.0
mpls ip !Enable hop-by-hop MPLS forwarding
mpls label protocol tdp !Use TDP for this interface
 

ルータ 2 の設定でも、インターフェイス コンフィギュレーション モードで mpls label protocol ldp コマンドを使用します。すべてのインターフェイスに LDP を指定するには、グローバル コンフィギュレーション モードで mpls label protocol ldp コマンドを使用し、インターフェイスの mpls label protocol コマンドを使用しません。

インターフェイスに対して mpls ip コマンドを設定すると、そのインターフェイスに対するディスカバリ Hello メッセージが送信されます。

直接接続されていない MPLS LDP セッションの確立:例

次に、図 2 に示すサンプル ネットワークを使用して、MPLS LDP の直接接続されていないセッションのプラットフォームを設定する例を示します。このサンプル ネットワーク内のルータ 1、4、5、および 6 は、相互に直接接続されていません。

図 2 ターゲット セッションの LDP を設定するためのサンプル ネットワーク

 

この設定例では、次のことを示します。

ルータ 1 と 4 の間のターゲット セッションで LDP を使用する。ルータ 1 と 4 はともにアクティブである。

ルータ 1 と 6 の間のターゲット セッションで LDP を使用する。ルータ 1 はアクティブ、ルータ 6 はパッシブである。

ルータ 1 と 5 の間のターゲット セッションで TDP を使用する。ルータ 5 はアクティブである。

これらの例では、直接接続されていないセッションのアクティブ エンドが MPLS トラフィック エンジニアリング トンネルなどのトンネル インターフェイスに関連付けられていることを前提としています。LDP ターゲット セッションの設定に関連するコマンドだけが示されています。ターゲット セッションを開始するアプリケーションの設定は示されていません。

ルータ 1 設定

トンネル インターフェイス Tunnel14 と Tunnel16 で、これらのインターフェイスに関連付けられたターゲット セッションに LDP が指定されています。ルータ 5 のターゲット セッションには TDP が必要です。グローバル コンフィギュレーション モードで mpls label protocol ldp コマンドを発行すると、Tunnel14 と Tunnel16 から設定の一部として LDP を明示的に指定する必要がなくなります。

ip cef distributed !Router1 supports distributed CEF
 
mpls label protocol ldp !Use LDP as default for all interfaces
 
interface Loopback0 !Loopback interface for LDP ID.
ip address 10.25.0.11 255.255.255.255
 
interface Tunnel14 !Tunnel to Router 4 requiring label distribution
tunnel destination 10.11.0.4 !Tunnel endpoint is Router 4
mpls ip !Enable hop-by-hop forwarding on the interface
 
interface Tunnel15 !Tunnel to Router 5 requiring label distribution
tunnel destination 10.11.0.5 !Tunnel endpoint is Router 5
mpls label protocol tdp !Use TDP for session with Router 5
mpls ip !Enable hop-by-hop forwarding on the interface
 
 
interface Tunnel16 !Tunnel to Router 6 requiring label distribution
tunnel destination 10.11.0.6 !Tunnel endpoint is Router 6
mpls ip !Enable hop-by-hop forwarding on the interface

ルータ 4 設定

グローバル コンフィギュレーション モードで mpls label protocol ldp コマンドを発行すると、ルータ 1 との Tunnel41 ターゲット セッションの設定の一部として LDP を明示的に指定する必要がなくなります。

ip cef distributed !Router 4 supports distributed CEF
 
mpls label protocol ldp !Use LDP as default for all interfaces
 
interface Loopback0 !Loopback interface for LDP ID.
ip address 10.25.0.44 255.255.255.255
 
interface Tunnel41 !Tunnel to Router 1 requiring label distribution
tunnel destination 10.11.0.1 !Tunnel endpoint is Router 1
mpls ip !Enable hop-by-hop forwarding on the interface
 

ルータ 5 設定

ルータ 5 では、すべてのターゲット セッションに TDP を使用する必要があります。したがって、その設定に mpls label protocol tdp コマンドが含まれています。

ip cef !Router 5 supports CEF
 
mpls label protocol tdp !Use TDP as default for all interfaces
 
interface Loopback0 !Loopback interface for LDP ID.
ip address 10.25.0.55 255.255.255.255
 
interface Tunnel51 !Tunnel to Router 1 requiring label distribution
tunnel destination 10.11.0.1 !Tunnel endpoint is Router 1
mpls ip !Enable hop-by-hop forwarding on the interface
 

ルータ 6 設定

デフォルトでは、ルータをターゲット セッションのパッシブ ネイバーにすることはできません。したがって、ルータ 1、ルータ 4、およびルータ 5 はターゲット セッションのアクティブ ネイバーです。 mpls ldp discovery targeted-hello accept コマンドを発行すると、ルータ 6 をルータ 1 とのターゲット セッションのパッシブ ターゲットにすることができます。ルータ 6 をターゲット セッションのアクティブ ネイバーにすることもできますが、この例には、そのような設定は含まれていません。

ip cef distributed !Router 6 supports distributed CEF
 
interface Loopback0 !Loopback interface for LDP ID.
ip address 10.25.0.66 255.255.255.255
 
mpls ldp discovery targeted-hellos accept from LDP_SOURCES
!Respond to requests for targeted hellos
!from sources permitted by acl LDP_SOURCES
 
ip access-list standard LDP_SOURCES !Define acl for targeted hello sources.
permit 10.11.0.1 !Accept targeted hello request from Router 1.
deny any !Deny requests from other sources.

その他の関連資料

ここでは、MPLS LDP に関する関連資料について説明します。

関連資料

関連項目
参照先

指定した IGP インスタンスに関連付けられている各インターフェイス上で LDP を設定する。

『MPLS LDP Autoconfiguration』

IGP パスをスイッチングに使用する前に LDP が完全に確立されていることを確認する。

『MPLS LDP-IGP Synchronization』

LSR がピア LSR から受け入れるラベル バインディングを ACL で制御できるようにする。

『MPLS LDP Inbound Label Binding Filtering』

Cisco IOS におけるラベル スイッチング機能について標準の SNMP ベースのネットワーク管理を実行できるようにする。

『MPLS Label Distribution Protocol MIB Version 8 Upgrade』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

MPLS ラベル配布プロトコル MIB(draft-ietf-mpls-ldp-mib-08.txt)

SNMP-VACM-MIB
SNMP 用 View-based Access Control Model(ACM)MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、テクニカル ティップス、ツールへのリンクなど、技術的なコンテンツを検索可能な形で大量に提供しています。Cisco.com 登録ユーザの場合は、次のページからログインしてさらに多くのコンテンツにアクセスできます。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mo/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『Cisco IOS master commands list』にアクセスしてください。

mpls label protocol (グローバル コンフィギュレーション)

mpls ldp router-id

MPLS ラベル配布プロトコルの機能情報

表 2 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


表 2 MPLS ラベル配布プロトコルの機能情報の概要

機能名
リリース
機能情報

MPLS ラベル配布プロトコル

12.0(10)ST
12.0(14)ST
12.1(2)T
12.1(8a)E
12.2(2)T
12.2(4)T
12.2(8)T
12.0(21)ST
12.0(22)S
12.0(23)S
12.2(13)T
12.4(3)
12.4(5)

この機能は、Cisco IOS Release 12.0(10)ST で導入され、Cisco ルータとスイッチでの使用に備えて実装された新しい一連の Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)CLI コマンドが組み込まれました。このリリースの CLI コマンドには、MPLS のコマンド構文と用語が反映されたため、Tag Distribution Protocol(TDP; タグ配布プロトコル)を使用したネットワークから Label Distribution Protocol(LDP; ラベル配布プロトコル)を使用したネットワークへの正しい移行が容易になります。

Cisco IOS Release 12.0(14)ST では、いくつかの新しい MPLS CLI コマンドが導入され、特定の既存のコマンドにおける新しい vrf vpn-name パラメータによって MPLS VPN のサポートが追加されました。その他のコマンドも、関連付けられた prefix-access-list 引数が Cisco IOS ソフトウェアによって矛盾なく解釈されるように変更されました。

この機能は、Cisco IOS 12.1(2)T でこのリリースに統合されました。また、 debug mpls atm-ldp api debug mpls atm-ldp routes 、および debug mpls atm-ldp states コマンドが変更されました。

この機能は、Cisco IOS Release 12.1(8a)E に統合されました。

この機能は、Cisco IOS Release 12.2(2)T に統合されました。

Cisco IOS Release 12.2(4)T では、Cisco MGX RPM-PR カードが装備された Cisco MGX 8850 および MGX 8950 スイッチのサポートが追加され、 show mpls atm-ldp bindings コマンドと show mpls ip binding コマンドにおける VPI 範囲が 4095 に変更されました。

Cisco IOS Release 12.2(8)T では、 debug mpls atm-ldp failure コマンドが導入されました。

Cisco IOS Release 12.0(21)ST では、 mpls ldp neighbor implicit-withdraw コマンドが導入されました。

この機能は、Cisco IOS Release 12.0(22)S に統合されました。 mpls ldp neighbor targeted-session コマンドと、 mpls ldp advertise-labels コマンドの interface キーワードが追加されました。

この機能は、Cisco IOS Release 12.0(23)S に統合されました。 mpls ldp discovery コマンドの holdtime キーワードと interval キーワードのデフォルト値が変更されました。

この機能は、Cisco IOS Release 12.2(13)T に統合されました。

Cisco IOS Release 12.4(3) では、デフォルトの MPLS ラベル配布プロトコルが TDP から LDP に変更されました。詳細については、「LDP および TDP のサポート」を参照してください。 mpls label protocol コマンドでプロトコルが明示的に設定されていない場合は、LDP がデフォルトのラベル配布プロトコルになります。詳細については、 mpls label protocol (グローバル コンフィギュレーション)コマンドを参照してください。

また、Cisco IOS Release 12.4(3) では、LDP コンフィギュレーション コマンドは、タグ スイッチング形式ではなく MPLS 形式のコマンドを使用して保存されます。以前は、下位互換性を確保するために、コマンドはタグ スイッチング形式のコマンドを使用して保存されていました。詳細については、「設定の保存:MPLS/タグ スイッチング コマンド」を参照してください。

Cisco IOS Release 12.4(5) では、 mpls ldp router-id コマンドに vrf vrf-name キーワードと引数のペアが追加され、LDP ルータ ID をデフォルト以外の VRF に関連付けることができます。

Copyright © 1999-2011, シスコシステムズ合同会社.
All rights reserved.