マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード
MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード
発行日;2012/01/31 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード

この章の構成

MPLS LDP MIB バージョン 8 アップグレードの前提条件

MPLS LDP MIB バージョン 8 アップグレードの制約事項

MPLS LDP MIB バージョン 8 アップグレードに関する情報

MPLS LDP MIB バージョン 8 アップグレードの機能設計

MPLS LDP MIB のバージョン 8 における機能拡張

MPLS LDP MIB バージョン 8 アップグレードの利点

MPLS LDP MIB バージョン 8 アップグレードの MPLS LDP MIB 要素の説明

LDP エンティティ

LDP セッションとピア

LDP Hello 隣接

MPLS LDP MIB バージョン 8 アップグレードにおける MPLS LDP MIB 通知を生成するイベント

MPLS LDP MIB バージョン 8 アップグレードの MIB テーブル

mplsLdpEntityTable

mplsLdpEntityConfGenLRTable

mplsLdpEntityAtmParmsTable

mplsLdpEntityConfAtmLRTable

mplsLdpEntityStatsTable

mplsLdpPeerTable

mplsLdpHelloAdjacencyTable

mplsLdpSessionTable

mplsLdpAtmSesTable

mplsLdpSesStatsTable

MPLS LDP MIB バージョン 8 アップグレードにおける VPN コンテキスト

SNMP コンテキスト

VPN 対応 LDP MIB セッション

VPN 対応 LDP MIB の通知

MPLS LDP MIB バージョン 8 アップグレードの設定方法

SNMP エージェントのイネーブル化

シスコ エクスプレス フォワーディングのイネーブル化

MPLS のグローバルなイネーブル化

LDP のグローバルなイネーブル化

インターフェイス上の MPLS のイネーブル化

インターフェイス上の LDP のイネーブル化

VPN 対応 LDP MIB の設定

VPN の SNMP サポートの設定

VPN の SNMP コンテキストの設定

この次の手順

SNMPv1 または SNMPv2 への SNMP VPN コンテキストの関連付け

MPLS LDP MIB バージョン 8 アップグレードの確認

MPLS LDP MIB バージョン 8 アップグレードの設定例

MPLS LDP MIB バージョン 8 アップグレードの例

SNMPv1 または SNMPv2 の VPN 対応 SNMP コンテキストの設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

用語集

MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード

MPLS Label Distribution Protocol(LDP; ラベル配布プロトコル)MIB バージョン 8 アップグレード機能は、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)ドラフト バージョン 8 をサポートするように LDP MIB を拡張します。


) Cisco IOS Release 12.2(33)SRB と Cisco IOS Release 12.2(33)SB では、この MIB が廃止され、MPLS-LDP-STD-MIB(RFC 3815)に置き換えられました。この 2 つのリリースおよび以降のイメージでは、SNMP サーバ除外/包含コマンド向けに、MIB 全体を名前 mplsLdpMIB で参照できます。ルータで他の MIB オブジェクト名を参照する必要がある場合は、MPLS-LDP-MIB::<table_entry_name> によって参照する必要があります。


MLPS ラベル配布プロトコル MIB バージョン 8 アップグレード機能の履歴

リリース
変更点

12.0(11)ST

この機能は、Cisco 7200、Cisco 7500、および Cisco 12000 シリーズ ルータにおける MPLS LDP MIB 用の SNMP エージェント サポートを提供するために導入されました。

12.2(2)T

この機能は、Cisco 7200 および Cisco 7500 シリーズ ルータにおける MPLS LDP MIB 用の SNMP エージェント サポートを提供するためにこのリリースに追加されました。

12.0(21)ST

この機能は、Cisco 7200、Cisco 7500、および Cisco 12000 シリーズ インターネット ルータにおける MPLS LDP MIB 用の SNMP エージェントと LDP 通知のサポートを提供するためにこのリリースに追加されました。

12.0(22)S

この機能(バージョン 1)は、Cisco IOS Release 12.0(22)S に統合されました。

12.0(24)S

この機能は、Cisco IOS Release 12.0(24)S でバージョン 8 にアップグレードされました。

12.0(27)S

MPLS VPN - VPN 対応 LDP MIB 機能のサポートが追加されました。

12.2(18)S

この機能は、Cisco IOS Release 12.2(18)S に統合されました。

12.2(33)SRA

この機能は、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

この機能は、Cisco IOS Release 12.2(33)SXH に統合されました。

12.2(33)SRB

この MIB は廃止され、MPLS-LDP-STD-MIB(RVC 3815)に置き換えられました。

12.2(33)SB

この MIB は廃止され、MPLS-LDP-STD-MIB(RVC 3815)に置き換えられました。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

プラットフォームのサポートと Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

この章の構成

「MPLS LDP MIB バージョン 8 アップグレードの前提条件」

「MPLS LDP MIB バージョン 8 アップグレードの制約事項」

「MPLS LDP MIB バージョン 8 アップグレードに関する情報」

「MPLS LDP MIB バージョン 8 アップグレードの MPLS LDP MIB 要素の説明」

「MPLS LDP MIB バージョン 8 アップグレードにおける MPLS LDP MIB 通知を生成するイベント」

「MPLS LDP MIB バージョン 8 アップグレードの MIB テーブル」

「MPLS LDP MIB バージョン 8 アップグレードにおける VPN コンテキスト」

「MPLS LDP MIB バージョン 8 アップグレードの設定方法」

「MPLS LDP MIB バージョン 8 アップグレードの設定例」

「その他の参考資料」

「コマンド リファレンス」

「用語集」

MPLS LDP MIB バージョン 8 アップグレードの前提条件

Label Switch Router(LSR; ラベル スイッチ ルータ)で Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)がインストールされ、イネーブルになっている。

LSR で Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)がイネーブルになっている。

LSR で LDP がイネーブルになっている。

MPLS LDP MIB バージョン 8 アップグレードの制約事項

MPLS LDP MIB のこの実装では、MIB オブジェクトに対するアクセス権が Read-Only(RO; 読み取り専用)に制限されます。ただし、SNMP エージェントによる書き込みが可能になるように拡張された MIB オブジェクト mplsLdpSessionUpDownTrapEnable を除きます。

このオブジェクトの値を true に設定すると、LSR で mplsLdpSessionUp 通知と mplsLdpSessionDown 通知の両方がイネーブルになります。逆に、このオブジェクトの値を false に設定すると、これらの両方の通知がディセーブルになります。

通知イベントについては、「MPLS LDP MIB バージョン 8 アップグレードにおける MPLS LDP MIB 通知を生成するイベント」を参照してください。

ほとんどの MPLS LDP MIB オブジェクトは、LDP ピアのディスカバリ(hello)プロセス、および以降の LDP ピア間 LDP セッションのパラメータや確立のネゴシエーション中に自動的に設定されます。

次のテーブルは、この機能では実装されていません。

mplsLdpEntityFrParmsTable

mplsLdpEntityConfFrLRTable

mplsLdpFrameRelaySesTable

mplsFecTable

mplsLdpSesInLabelMapTable

mplsXCsFecsTable

mplsLdpSesPeerAddrTable

MPLS LDP MIB バージョン 8 アップグレードに関する情報

MPLS LDP MIB バージョン 8 アップグレードを設定するには、次の概念を理解する必要があります。

「MPLS LDP MIB バージョン 8 アップグレードの機能設計」

「MPLS LDP MIB のバージョン 8 における機能拡張」

「MPLS LDP MIB バージョン 8 アップグレードの利点」

MPLS LDP MIB バージョン 8 アップグレードの機能設計

MPLS は、パケット転送テクノロジーであり、パケットでラベルと呼ばれる短い固定長の値を使用して、Label Switch Router(LSR; ラベル スイッチ ルータ)による MPLS ネットワークでのパケット転送のネクスト ホップを指定します。

MPLS の基本原則として、MPLS ネットワーク内の LSR は、パケット転送動作に使用されるラベルの定義に同意する必要があります。ラベルの同意は、LDP で定義されている手順によって MPLS ネットワークで行われます。

LDP 動作はディスカバリ(hello)プロセスで始まります。そのプロセスの間に、LDP エンティティ(ローカル LSR)はネットワーク内の連携する LDP ピアを探し、LSR とピア間で基本動作手順をネゴシエーションします。このディスカバリ プロセスによってピアが認識および識別されると、Hello 隣接が確立されます。これは、ローカル LSR とその LDP ピア間でラベル バインディング情報が交換されるコンテキストを表します。その後、LDP によって、2 つの LSR 間にアクティブな LDP セッションが確立され、ラベル バインディング情報が交換されます。このプロセスが MPLS ネットワーク内のすべての LSR に関して完了すると、通信ネットワーク デバイス間のエンドツーエンドのパケット伝送経路を構成する Label Switched Path(LSP; ラベル スイッチド パス)が確立されます。

LSR は、LDP によってラベル バインディング情報を収集し、MPLS ネットワーク内の他の LSR に配布したり解放したりできます。これにより、ネットワーク内のパケットを正常に経路選択されたパスに沿ってホップバイホップで転送できるようになります。

MPLS LDP MIB は、Cisco IOS ソフトウェアにおけるラベル スイッチング機能について標準の SNMP ベースのネットワーク管理を実行できるようにするために実装されました。この機能を使用するには、ネットワーク内の指定した Network Management Station(NMS; ネットワーク管理ステーション)で SNMP エージェント コードを実行する必要があります。NMS は、MPLS LDP MIB 内のネットワーク管理オブジェクトとのユーザ対話手段として機能します。

SNMP エージェント コードは、Cisco IOS ソフトウェアと互換性のある階層構造を持ち、MPLS LDP MIB 内のオブジェクト、さらに Cisco IOS ソフトウェアによってサポートされる豊富なラベル スイッチング機能とのネットワーク管理インターフェイスを提供します。

SNMP エージェントを使用すると、標準の SNMP GET 操作を使用して MPLS LDP MIB オブジェクトにアクセスし、それらのオブジェクトを使用してさまざまなネットワーク管理作業を実行できます。MPLS LDP MIB 内のすべてのオブジェクトは、IETF ドラフト MIB( draft-ietf-mpls-ldp-mib-08.txt )の規定に従っています。このドラフト MIB では、ネットワーク管理オブジェクトが構造化および標準化された形式で定義されています。このドラフト MIB は発展しており、まもなく標準規格になると予想されます。それに応じて、MPLS LDP MIB は、この IETF ドキュメントの発展に追随する形で実装されます。

ただし、IETF ドラフト MIB および対応する Cisco IOS 機能の実装には若干の違いがあります。そのため、MPLS LDP MIB オブジェクトと Cisco IOS の内部データ構造の間で多少の変換が必要になります。このような変換は、SNMP エージェントによって行われます。SNMP エージェントは、NMS ワークステーションでプライオリティの低いプロセスとしてバックグラウンドで実行されます。

豊富な Cisco IOS ラベル スイッチング機能によって、WAN で伝送された大量のトラフィックについて統合型の管理が可能になります。これらの機能はレイヤ 3 ネットワーク サービスに統合され、インターネット サービス プロバイダーのバックボーンを通過する大量のトラフィックの ルーティング が最適化されます。同時に、リンクやノードの障害に対するネットワークの耐性が確保されます。

Cisco IOS Release 12.0(11)ST 以降のリリースでは、次の MPLS LDP MIB 関連の機能がサポートされています。

Tag Distribution Protocol(TDP; タグ配布プロトコル)

LDP セッションのステータスの変更を知らせるイベント通知メッセージの生成と送信

既存の SNMP CLI コマンドの機能拡張による、イベント通知メッセージのイネーブル化とディセーブル化

ネットワーク管理を目的とした Cisco IOS イベント通知メッセージの送信先となる稼動環境内の NMS ワークステーションの名前または IP アドレスの指定

NMS の NVRAM へのイベント通知メッセージに関連する設定の保管

MPLS LDP MIB の構造は、Abstract Syntax Notation One(ASN.1; 抽象構文記法 1)に準拠しているため、高度に構造化された理想的なネットワーク管理オブジェクトのデータベースが形成されます。

標準の SNMP アプリケーションを使用すると、標準の SNMP GET および GETNEXT 操作によって MPLS LDP MIB から情報を取得し、表示できます。


) 実装の時点では、MPLS LDP MIB に Internet Assigned Numbers Authority(IANA; インターネット割り当て番号局)Experimental Object Identifier(OID; オブジェクト ID)が割り当てられていなかったため、シスコは、次のようにして ciscoExperimental OID 番号に基づいて MIB を実装しました。

ciscoExperimental
1.3.6.1.4.1.9.10
mplsLdpMIB
1.3.6.1.4.1.9.10.65

MPLS LDP MIB に IANA Experimental OID 番号が割り当てられた場合、シスコは ciscoExperimental OID に基づく MIB 内のすべてのオブジェクトを、IANA Experimental OID に基づくオブジェクトに置き換えます。


MPLS LDP MIB のバージョン 8 における機能拡張

MPLS LDP MIB のバージョン 8 には、次の機能拡張が含まれています。

TDP のサポート

アップグレードされたオブジェクト

セッション数ベースではなくなった新しいインデックス

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)での複数の SNMP コンテキスト サポート

MPLS LDP MIB バージョン 8 アップグレードの利点

TDP と LDP をサポートする。

MPLS ネットワーク内のピア デバイス間の LDP セッションを確立する。

次のような LDP エンティティの動作に関連する MIB パラメータを取得する。

既知の LDP ディスカバリ ポート

Maximum Transmission Unit(MTU; 最大伝送ユニット)

提示されるキープアライブ タイマー間隔

ループ検出

セッション確立しきい値

ラベルの形成に使用される Virtual Path Identifier/Virtual Channel Identifier(VPI/VCI; 仮想パス識別子/仮想チャネル識別子)ペアの範囲

エラー カウンタ( 表 5 )などの LDP 動作に関連する統計情報を収集する。

hello 隣接の残り時間を監視する。

次のような LDP ピアの特性とステータスを監視する。

LDP ピアのインターネットワーク レイヤ アドレス

LDP ピアのループ検出

LDP ピアのデフォルト MTU

LDP ピアがキープアライブ インターバルの値として提示する秒数

次のような LDP セッションの特性とステータスを監視する。

エラー カウンタ( 表 10 )の表示

LDP セッションによって使用される LDP バージョンの特定

LDP セッションの残りのキープアライブ保留時間の確認

LDP セッションの状態の確認(セッションがアクティブかどうか)

プラットフォーム全体のセッションとインターフェイス固有のセッションのラベル範囲( 表 2 )の表示

ATM パラメータ( 表 3 )の表示

MPLS LDP MIB バージョン 8 アップグレードの MPLS LDP MIB 要素の説明

MPLS LDP MIB に関連する LDP 動作には、次の機能要素が関与します。

LDP エンティティ:ラベル スペースの交換を目的とした LDP インスタンスに関連します。潜在的なセッションを表します。

LDP ピア:リモート LDP エンティティ(つまり、非ローカル LSR)を意味します。

LDP セッション:ローカル LSR とリモート LDP ピア間のアクティブな LDP プロセスを意味します。

Hello 隣接:MPLS ネットワーク内の 2 つの LSR の状態を相互に隣接している(つまり、LDP ピアである)と確認する LDP ディスカバリ プロセスの結果を意味します。ネイバーが検出されると、そのネイバーが hello 隣接になります。hello 隣接との LDP セッションを確立できます。セッションが確立されたら、LSR 間でラベル バインディングを交換できます。

これらの MPLS LDP MIB 要素については、以降の各見出しで簡単に説明します。

実際には、MPLS LDP MIB は、データベース内の各種 MIB オブジェクトへのリアルタイム アクセスをサポートするネットワーク管理データベースを提供します。このデータベースには、ネットワークにおける MPLS LDP 動作の現在の状態が反映されます。このネットワーク管理情報データベースにアクセスするには、MPLS LDP 稼動環境で NMS から標準の SNMP コマンドを使用します。

MPLS LDP MIB は、次のネットワーク管理アクティビティをサポートします。

LDP 動作に関連する MPLS LDP MIB パラメータの取得

LDP ピアの特性とステータスの監視

LDP ピア間の LDP セッション ステータスの監視

ネットワークにおける Hello 隣接の監視

LDP セッションに関する統計情報の収集

LDP エンティティ

LDP エンティティは、mplsLdpEntityLdpId mplsLdpEntityIndex(図 1 を参照)で構成される LDP ID によって一意に識別されます。

mplsLdpEntityLdpId は、ローカル LSR ID(4 オクテット)とラベル スペース ID(2 オクテット)で構成されます。ラベル スペース ID は、LSR 内で使用可能な特定のラベル スペースを識別します。

mplsLdpEntityIndex は、ピアのアクティブな hello 隣接の IP アドレス(ピア LSR に割り当てられた IP アドレスの 32 ビット表現)で構成されます。

mplsldpEntityProtocolVersion は、mplsLdpEntityTable のサンプル オブジェクトです。

図 1 は、次のインデックスを示しています。

mplsLdpEntityLdpId = 10.10.10.10.0.0

LSR ID = 10.10.10.10

ラベル スペース ID = 0.0

mplsLdpEntityLdpId、つまり LDP ID は、LSR ID とラベル スペース ID で構成されています。

ピアのアクティブな hello 隣接の IP アドレス、つまり mplsLdpEntityIndex = 3232235777(ピアのアクティブな hello 隣接に割り当てられた IP アドレスの 32 ビット表現)

図 1 LDP エンティティのサンプル インデックス

LDP エンティティは、LDP ピアとのセッションの可能性があるラベル スペースを表します。LDP エンティティは、hello 隣接が LDP ピアから hello メッセージを受信すると設定されます。

図 2 では、ルータ A に 2 つのリモート ピア(ルータ B と C)との潜在的なセッションがあります。mplsLdpEntityLdpId は 10.10.10.10.0.0、ルータ B の IP アドレス 192.168.1.1 の 32 ビット表現である、ピアのアクティブな hello 隣接の IP アドレス(mplsLdpEntityIndex)は 3232235777 です。

図 2 LDP エンティティ

LDP セッションとピア

LDP セッションは、ラベル スペースを配布する目的で、ローカル エンティティとリモート ピアの間に存在します。LDP ピアと LDP セッションの間には、常に 1 対 1 の対応関係があります。1 つの LDP セッションは、1 つの LDP ピアとの 1 つ以上のネットワーク リンクで通信する LDP インスタンスです。

LDP では、次のタイプのセッションがサポートされています。

インターフェイス固有:インターフェイス固有のセッションでは、ラベル スペースの配布にインターフェイス リソースを使用します。たとえば、各 Label-Controlled ATM(LC-ATM; ラベル制御 ATM)インターフェイスでは、ラベル スペースの配布に独自の VPI/VCI を使用します。設定によって、LDP プラットフォームでサポートされるインターフェイス固有のセッションの数は、ゼロ、1 つ、または複数です。各 LC-ATM インターフェイスには、独自のインターフェイス固有のラベル スペースとゼロ以外のラベル スペース ID があります。

プラットフォーム全体:LDP プラットフォームでは、1 つのプラットフォーム全体のセッションがサポートされます。プラットフォーム全体のセッションは、同じグローバル ラベル スペースを共有できるすべてのインターフェイスによって使用されます。シスコのプラットフォームでは、LC-ATM を除くすべてのインターフェイス タイプでプラットフォーム全体のセッションが使用され、ラベル スペース ID はゼロです。

2 つのピア間にセッションが確立されると、インデックスが同じであるため、mplsLdpPeerTable と mplsLdpSessionTable にエントリが作成されます。

図 3 では、ルータ A に 2 つのリモート ピア(ルータ B と C)があります。ルータ A には、ルータ B との 2 つのシリアル インターフェイスで構成される 1 つのプラットフォーム全体のセッションおよびルータ C とのプラットフォーム全体のセッションがあります。また、ルータ B との 2 つのインターフェイス固有セッションもあります。

図 3 LDP セッション

図 4 に、図 3 の mplsLdpPeerTable と mplsLdpSessionTable に対応するエントリを示します。

図 4 では、mplsLdpSesState はルータ A 上の mplsLdpSessionTable のサンプル オブジェクトです。4 つの mplsLdpSesState サンプル オブジェクトが上から下へ示されています。最初のオブジェクトは、2 つのシリアル インターフェイスに関連付けられたプラットフォーム全体のセッションを表しています。次の 2 つのオブジェクトは、ルータ A と B 上にある LC-ATM インターフェイスのインターフェイス固有のセッションを表しています。これらのインターフェイス固有のセッションには、ゼロ以外のピア ラベル スペース ID が割り当てられています。最後のオブジェクトは、次のピア、ルータ C とのプラットフォーム全体のセッションを表しています。

インデックスは、mplsLdpEntityTable のエントリに基づいています。mplsLdpEntityTable のインデックスで始まり、次の値が付加されます。

ピア LDP ID = 10.11.11.11.0.0

ピア LDP ID は、ピア LSR ID(4 オクテット)とピア ラベル スペース ID(2 オクテット)で構成されます。

ピア LSR ID = 10.11.11.11

ピア ラベル スペース ID = 0.0

ピア ラベル スペース ID は、LSR 内で使用可能な特定のピア ラベル スペースを識別します。

図 4 LDP セッションのサンプル インデックス

LDP Hello 隣接

LDP hello 隣接は、ルータとそのピア間のネットワーク リンクです。LDP hello 隣接によって、2 つの隣接ピアはラベル バインディング情報を交換できます。

LDP が実行されるリンクごとに LDP hello 隣接が存在します。ルータとそのピア間のセッション(プラットフォーム全体のセッションなど)に複数のリンクがある場合は、常に複数の LDP hello 隣接が存在します。

hello 隣接は、現在セッションに関わっている場合はアクティブと見なされ、関わっていない場合は非アクティブと見なされます。

ターゲット hello 隣接は、そのピアに直接接続されず、ピアとの間のホップ数に制限がありません。リンク hello 隣接は、2 つのルータ間で直接接続されます。

図 5 では、ルータ A に 2 つのリモート ピア(ルータ B と C)があります。ルータ A には、ルータ B との 3 つのシリアル インターフェイスで構成されるプラットフォーム全体のセッションがあり、そのうち 1 つのシリアル インターフェイスがアクティブです。また、ルータ C とのプラットフォーム全体の(ターゲット)セッションもあります。

図 5 Hello 隣接

図 6 に、mplsLdpHelloAdjacencyTable のエントリを示します。上から下へ 4 つの mplsLdpHelloAdjHoldTime サンプル オブジェクトがあります。これらのオブジェクトは、図 5 に示す 2 つのプラットフォーム全体のセッションと 4 つのシリアルリンクを表しています。

インデックスは、mplsLdpSessionTable に基づいています。mplsLdpHelloAdjIndex によって 1 つのセッション内に異なるリンクが列挙される場合、アクティブ リンクは mplsLdpHelloAdjIndex = 1 です。

図 6 LDP Hello 隣接のサンプル インデックス

MPLS LDP MIB バージョン 8 アップグレードにおける MPLS LDP MIB 通知を生成するイベント

snmp-server enable traps mpls ldp コマンドを発行して MPLS LDP MIB 通知機能をイネーブルにすると、通知メッセージが生成され、ネットワーク内の指定した NMS に送信されます。これにより、Cisco IOS 内で特定のイベントが発生したことが通知されます。

LDP ステータスの移行とイベント通知に関与する MPLS LDP MIB オブジェクトは次のとおりです。

mplsLdpSessionUp:このメッセージは、LDP エンティティ(ローカル LSR)によって別の LDP エンティティ(ネットワーク内の隣接 LDP ピア)との LDP セッションが確立されると生成されます。

mplsLdpSessionDown:このメッセージは、ローカル LSR とその隣接 LDP ピア間の LDP セッションが終了すると生成されます。

mplsLdpPathVectorLimitMismatch:このメッセージは、ローカル LSR によって、その隣接ピアである LSR との LDP セッションが確立され、2 つの LSR でパス ベクトル制限が異なる場合に生成されます。

パス ベクトル制限の値の範囲は 0 ~ 255 です。値が 0 の場合、ループ検出はオフです。0 以外の 255 までの値の場合、ループ検出はオンで、さらにネットワーク内のループ状態が検知されるまでに LDP メッセージが通過できるホップの最大数が示されます。

ネットワーク内のすべての LDP 対応ルータに同じパス ベクトル制限を設定することを推奨します。mplsLdpPathVectorLimitMismatch オブジェクトが MPLS LDP MIB に存在するは、LDP 動作に関わっている 2 つのルータのパス ベクトル制限が異なる場合に NMS に警告メッセージを送信するためです。


) この通知が生成されるのは、配布方式がダウンストリームオンデマンドである場合だけです。


mplsLdpFailedInitSessionThresholdExceeded:このメッセージは、ローカル LSR と隣接 LDP ピアが、それらの間に LDP セッションを確立しようとして失敗し、その試行回数が指定数を超えた場合に生成されます。デフォルトの試行回数は 8 回です。このデフォルト値は実装されており、変更できません。

デバイス間の何らかの非互換により、ローカル LSR と LDP ピア間の LDP セッションの確立に 8 回失敗すると、この通知メッセージが生成されます。Cisco ルータは複数のプラットフォームで同じ機能をサポートします。

したがって、Cisco LSR 間で最も発生する可能性が高い非互換は、それぞれの ATM VPI/VCI ラベル範囲のミスマッチです。

たとえば、LSR に有効なラベルの範囲を指定し、その範囲が隣接 LDP ピアの範囲と重ならない場合、ルータは LDP ピアとの LDP セッションを 8 回確立しようとします。その後、mplsLdpFailedInitSessionThresholdExceeded 通知が生成され、情報メッセージとして NMS に送信されます。

ラベル範囲が重ならない LSR は、8 回のリトライしきい値を超えても、それらの LSR 間の LDP セッションを確立しようとし続けます。

そのような場合、LDP しきい値超過通知によって、ネットワーク内に注意すべき状態があることがネットワーク管理者に知らされます。

RFC 3036『 LDP Specification 』に、MPLS ネットワーク内の Cisco ルータやその他の LSR 間に存在する可能性がある非互換について詳しく記載されています。

このような非互換の例を次に示します。

LDP セッションを確立しようとする LSR 間で、ATM VPI/VCI 範囲が重ならない(前述のとおり)、またはフレーム リレー DLCI 範囲が重ならない。

ラベル配布方式がサポートされていない。

Protocol Data Unit(PDU; プロトコル データ ユニット)サイズが異なる。

LDP 機能のサポートのタイプが異なる。

MPLS LDP MIB バージョン 8 アップグレードの MIB テーブル

MPLS LDP MIB のバージョン 8 には、次のテーブルが含まれています。

mplsLdpEntityTable( 表 1 ):すべてのアクティブな LDP hello 隣接のエントリが格納されます。非アクティブな hello 隣接は、このテーブルではなく mplsLdpHelloAdjacencyTable に表示されます。このテーブルのインデックスは、インターフェイスのローカル LDP ID とピアのアクティブな hello 隣接の IP アドレスに基づいて作成されます(図 1 を参照)。

このテーブルにセッションではなくアクティブな hello 隣接を表示するメリットは、LDP セッションがアクティブでない(確立できない)場合でも、アクティブな hello 隣接が存在できることです。IETF MPLS-LDP MIB の以前の実装では、セッションをこのテーブルのエントリとして使用していました。これは適切な方法ではありませんでした。セッションがダウンすると、エージェント コードがセッションにアクセスできなくなるため、エンティティ テーブル内のエントリが完全に失われるからです。この結果、MIB は失敗した LDP セッションに関する情報を提供できませんでした。

誘導隣接もこのテーブルに表示されます。ただし、誘導セッションが失敗すると隣接が失われるため、これらのエントリは、管理上(adminStatus)および動作上(operStatus)常にアップ状態になります。基礎となるインターフェイスが動作上ダウンした場合などは隣接が削除されるため、非誘導隣接は MIB から失われることがあります。

mplsLdpEntityConfGenLRTable( 表 2 ):グローバル ラベル スペース内にあるすべての LDP 対応インターフェイスのエントリが格納されます(シスコでは、これは LC-ATM を除くすべてのインターフェイスに適用されます。LC-ATM エンティティは、代わりに mplsLdpEntityConfAtmLRTable に表示されます)。インデックスは、2 つのインデックス(mplsLdpEntityConfGenLRMin と mplsLdpEntityConfGenLRMax)が追加されていることを除き、mplsLdpEntityTable の場合と同じです。これらの追加インデックスを使用すると、複数のラベル範囲を定義できます。ただし、現在の Cisco IOS 実装では、グローバル ラベル範囲は 1 つしか許可されません。

mplsLdpEntityAtmParmsTable( 表 3 ):すべての LDP 対応 LC-ATM インターフェイスのエントリが格納されます。このテーブルのインデックスは mplsLdpEntityTable の場合と同じですが、LC-ATM インターフェイスだけが表示されます。

mplsLdpEntityConfAtmLRTable( 表 4 ):すべての LDP 対応 LC-ATM インターフェイスのエントリが格納されます。インデックスは、2 つのインデックス(mplsLdpEntityConfAtmLRMinVpi と mplsLdpEntityConfAtmLRMinVci)が追加されていることを除き、mplsLdpEntityTable の場合と同じです。これらの追加インデックスを使用すると、複数のラベル範囲を定義できます。ただし、現在の Cisco IOS 実装では、ラベル範囲は LC-ATM インターフェイスごとに 1 つしか許可されません。

mplsLdpEntityStatsTable( 表 5 ):mplsLdpEntityTable を拡張し、GET 操作と GETNEXT 操作の実行でまったく同じインデックスを共有します。このテーブルには、エンティティの追加統計情報が表示されます。

mplsLdpPeerTable( 表 6 ):すべてのピア セッションのエントリが格納されます。このテーブルのインデックスは、セッションのローカル LDP ID、ピアのアクティブな hello 隣接の IP アドレス、およびピアの LDP ID に基づいて作成されます(図 4 を参照)。

mplsLdpHelloAdjacencyTable( 表 7 ):すべての hello 隣接のエントリが格納されます。このテーブルのインデックスは、関連付けられたセッションのローカル LDP ID、ピアのアクティブな hello 隣接の IP アドレス、ピアの LDP ID、および隣接のリスト位置に設定された任意のインデックスに基づいて作成されます(図 6 を参照)。

mplsLdpSessionTable( 表 8 ):mplsLdpPeerTable を拡張し、GET 操作と GETNEXT 操作の実行で同じインデックスを共有します。このテーブルにはすべてのセッションが表示されます。

mplsLdpAtmSesTable( 表 9 ):LC-ATM セッションのエントリが格納されます。インデックスは、2 つのインデックス(mplsLdpSesAtmLRLowerBoundVpi と mplsLdpSesAtmLRLowerBoundVci)が追加されていることを除き、mplsLdpPeerTable の場合と同じです。これらの追加インデックスを使用すると、複数のラベル範囲を定義できます。ただし、現在の Cisco IOS 実装では、ラベル範囲は LC-ATM インターフェイスごとに 1 つしか許可されません。

mplsLdpSesStatsTable( 表 10 ):mplsLdpPeerTable を拡張し、GET 操作と GETNEXT 操作の実行でまったく同じインデックスを共有します。このテーブルには、セッションの追加統計情報が表示されます。

mplsLdpEntityTable

表 1 に、mplsLdpEntityTable のオブジェクトとその説明を示します。

 

表 1 mplsLdpEntityTable のオブジェクトと説明

オブジェクト
説明

mplsLdpEntityEntry

2 つのピア間の潜在的なセッションである LDP エンティティを表します。

mplsLdpEntityLdpId

LDP ID(アクセス不能)は、ローカル LSR ID(4 オクテット)とラベル スペース ID(2 オクテット)で構成されます。

mplsLdpEntityIndex

この行を一意に識別するセカンダリ インデックス。ピアのアクティブな hello 隣接の IP アドレス(LSR に割り当てられた IP アドレスの 32 ビット表現)で構成されます(アクセス不能)。

mplsLdpEntityProtocolVersion

セッション初期化メッセージで使用される LDP プロトコルのバージョン番号。

mplsLdpEntityAdminStatus

この LDP エンティティの管理ステータスは常にアップです。hello 隣接で障害が発生した場合、このエンティティは mplsLdpEntityTable から失われます。

mplsLdpEntityOperStatus

この LDP エンティティの動作ステータス。値は、unknown(0)、enabled(1)、disabled(2) のいずれかです。

mplsLdpEntityTcpDscPort

LDP または TDP の TCP ディスカバリ ポート。デフォルト値は 646(LDP)です。

mplsLdpEntityUdpDscPort

LDP または TDP の UDP ディスカバリ ポート。デフォルト値は 646(LDP)です。

mplsLdpEntityMaxPduLength

初期化メッセージの共通セッション パラメータで送信される最大 PDU 長。

mplsLdpEntityKeepAliveHoldTimer

この LDP エンティティについて提示されるキープアライブ保留時間である 2 オクテットの値。

mplsLdpEntityHelloHoldTimer

この LDP エンティティについて提示される hello 保留時間である 2 オクテットの値。

mplsLdpEntityInitSesThreshold

このエンティティとそのピアが初期化メッセージの無限シーケンスに関わっている場合の通知のしきい値。

デフォルト値は 8 で、SNMP でも CLI でも変更できません。

mplsLdpEntityLabelDistMethod

特定の LDP セッションに指定されたラベル配布方法。値は、downstreamOnDemand(1) と downstreamUnsolicited(2) です。

mplsLdpEntityLabelRetentionMode

LC-ATM に conservative(1) を使用するか、またはその他のすべてのインターフェイスに liberal(2) を使用するように設定できます。

mplsLdpEntityPVLMisTrapEnable

mplsLdpPVLMismatch トラップが生成されるかどうかを示します。

値が enabled(1) の場合、トラップは生成されます。値が disabled(2) の場合、トラップは生成されません。デフォルトは disabled(2) です。

(注) mplsLdpPVLMismatch トラップが生成されるのは、mplsLdpEntityLabelDistMethod が downstreamOnDemand(1) の場合だけです。

mplsLdpEntityPVL

このオブジェクトの値が 0 の場合、パス ベクトルのループ検出はディセーブルになっています。値がゼロ(0)より大きい場合、パス ベクトルのループ検出はイネーブルになっており、その値がパス ベクトル制限になります。

(注) mplsLdpEntityPVL オブジェクトがゼロ(0)以外になるのは、mplsLdpEntityLabelDistMethod が downstreamOnDemand(1) の場合だけです。

mplsLdpEntityHopCountLimit

このオブジェクトの値が 0 の場合、ホップ カウンタを使用したループ検出はディセーブルになっています。

値がゼロ(0)より大きい場合、ホップ カウンタを使用したループ検出はイネーブルになっており、このオブジェクトによって、このエンティティのホップ カウントの最大許容値が指定されます。

(注) mplsLdpEntityHopCountLimit オブジェクトがゼロ(0)以外になるのは、mplsLdpEntityLabelDistMethod が downstreamOnDemand(1) の場合だけです。

mplsLdpEntityTargPeer

この LDP エンティティでターゲット隣接が使用されている場合、このオブジェクトは true(1) に設定されます。デフォルト値は false(2) です。

mplsLdpEntityTargPeerAddrType

拡張ディスカバリに使用されるインターネットワーク レイヤ アドレスのタイプ。このオブジェクトは、mplsLdpEntityTargPeerAddr の値の解釈方法を示します。

mplsLdpEntityTargPeerAddr

ターゲット隣接に使用されるインターネットワーク レイヤ アドレスの値。

mplsLdpEntityOptionalParameters

LDP 初期化メッセージのオプション パラメータを指定します。値が generic(1) の場合、このエンティティに関連付けられた LDP 初期化メッセージでオプション パラメータは送信されません。

LC-ATM では、atmParameters(2) を使用して、mplsLdpEntityAtmParmsTable の行がこのエントリに対応することを指定します。

(注) フレーム リレー パラメータはサポートされません。

mplsLdpEntityDiscontinuityTime

このエンティティのカウンタが 1 つ以上中断した場合、最後に中断したときの sysUpTime の値。関連するカウンタは、このエンティティに関連付けられた、mplsLdpEntityStatsTable に含まれている Counter32 または Counter64 オブジェクトの特定のインスタンスです。ローカル管理サブシステムを最後に再初期化してから中断が発生しなかった場合、このオブジェクトには値 0 が格納されます。

mplsLdpEntityStorType

このエントリのストレージ タイプは読み取り専用の実装であり、常に volatile です。

mplsLdpEntityRowStatus

このオブジェクトは読み取り専用の実装であり、常に active です。

mplsLdpEntityConfGenLRTable

表 2 に、mplsLdpEntityConfGenLRTable のオブジェクトとその説明を示します。

 

表 2 mplsLdpEntityConfGenLRTable のオブジェクトと説明

オブジェクト
説明

mplsLdpEntityConfGenLREntry

LDP Entity Configurable Generic Label Range Table 内の行。このテーブルの 1 つのエントリには、ラベルの 1 つの範囲に関する情報が格納されます。範囲は、上限(VPI/VCI ペア)と下限(VPI/VCI ペア)で定義されます。

現在の実装では、エンティティごとに 1 つのラベル範囲がサポートされています。

mplsLdpEntityConfGenLRMin

この範囲に設定されている最小ラベル(アクセス不能)。

mplsLdpEntityConfGenLRMax

この範囲に設定されている最大ラベル(アクセス不能)。

mplsLdpEntityConfGenIfIndxOrZero

この値は、プラットフォーム全体のエンティティの SNMP IF-MIB インデックスを表します。アクティブな hello 隣接がターゲットの場合、この値は 0 です。

mplsLdpEntityConfGenLRStorType

このエントリのストレージ タイプは読み取り専用の実装であり、常に volatile です。

mplsLdpEntityConfGenLRRowStatus

このオブジェクトは読み取り専用の実装であり、常に active です。

mplsLdpEntityAtmParmsTable

表 3 に、mplsLdpEntityAtmParmsTable のオブジェクトとその説明を示します。

 

表 3 mplsLdpEntityAtmParmsTable のオブジェクトと説明

オブジェクト
説明

mplsLdpEntityAtmParmsEntry

この LDP エンティティの ATM パラメータと ATM 情報を表します。

mplsLdpEntityAtmIfIndxOrZero

この値は、インターフェイス固有の LC-ATM エンティティの SNMP IF-MIB インデックスを表します。

mplsLdpEntityAtmMergeCap

このエンティティのマージ機能を表します。

mplsLdpEntityAtmLRComponents

初期化メッセージのラベル範囲コンポーネントの数。このエントリに対応する mplsLdpEntityConfAtmLRTable 内のエントリ数も表します。

mplsLdpEntityAtmVcDirectionality

このオブジェクトの値が bidirectional(0) の場合、特定の VPI 内の特定の VCI が両方向のラベルとして相互に独立して使用されます。

このオブジェクトの値が unidirectional(1) の場合、VPI 内の特定の VCI は一方向を指定します。

mplsLdpEntityAtmLsrConnectivity

ATM VP によってピア LSR を間接的に接続できるため、VPI 値はエンドポイント上で異なる場合があります。そのため、ラベルを VCI フィールド内で完全に符号化する必要があります。

値は direct(1)(デフォルト)と indirect(2) です。

mplsLdpEntityDefaultControlVpi

非 MPLS 接続のデフォルトの VPI 値。

mplsLdpEntityDefaultControlVci

非 MPLS 接続のデフォルトの VCI 値。

mplsLdpEntityUnlabTrafVpi

ラベル付けされていないトラフィックをサポートする VCC の VPI 値。この非 MPLS 接続は、ラベル付けされていない(IP)パケットの伝送に使用されます。

mplsLdpEntityUnlabTrafVci

ラベル付けされていないトラフィックをサポートする VCC の VCI 値。この非 MPLS 接続は、ラベル付けされていない(IP)パケットの伝送に使用されます。

mplsLdpEntityAtmStorType

このエントリのストレージ タイプは読み取り専用の実装であり、常に volatile です。

mplsLdpEntityAtmRowStatus

このオブジェクトは読み取り専用の実装であり、常に active です。

mplsLdpEntityConfAtmLRTable

表 4 に、mplsLdpEntityConfAtmLRTable のオブジェクトとその説明を示します。

 

表 4 mplsLdpEntityConfAtmLRTable のオブジェクトと説明

オブジェクト
説明

mplsLdpEntityConfAtmLREntry

LDP Entity Configurable ATM Label Range Table 内の行。このテーブルの 1 つのエントリには、ラベルの 1 つの範囲に関する情報が格納されます。範囲は、上限(VPI/VCI ペア)と下限(VPI/VCI ペア)で定義されます。これは、初期化メッセージで使用されるのと同じデータです。このラベル範囲はピアのラベル範囲と重なっている必要があります。

mplsLdpEntityConfAtmLRMinVpi

この範囲に設定されている最小 VPI 番号(アクセス不能)。

mplsLdpEntityConfAtmLRMinVci

この範囲に設定されている最小 VCI 番号(アクセス不能)。

mplsLdpEntityConfAtmLRMaxVpi

この範囲に設定されている最大 VPI 番号(アクセス不能)。

mplsLdpEntityConfAtmLRMaxVci

この範囲に設定されている最大 VCI 番号(アクセス不能)。

mplsLdpEntityConfAtmLRStorType

このエントリのストレージ タイプは読み取り専用の実装であり、常に volatile です。

mplsLdpEntityConfAtmLRRowStatus

このオブジェクトは読み取り専用の実装であり、常に active です。

mplsLdpEntityStatsTable

表 5 に、mplsLdpEntityStatsTable のオブジェクトとその説明を示します。

 

表 5 mplsLdpEntityStatsTable のオブジェクトと説明

オブジェクト
説明

mplsLdpEntityStatsEntry

これらのエントリは、各エントリの追加情報を提供することによって mplsLdpEntityTable を拡張します。

mplsLdpAttemptedSessions

この機能ではサポートされていません。

mplsLdpSesRejectedNoHelloErrors

この LDP エンティティによって拒否されたセッション、または送受信された no hello エラー通知メッセージのカウント。

mplsLdpSesRejectedAdErrors

この LDP エンティティによって拒否されたセッション、または送受信されたパラメータ アドバタイズメント モード エラー通知メッセージのカウント。

mplsLdpSesRejectedMaxPduErrors

この LDP エンティティによって拒否されたセッション、または送受信されたパラメータ最大 PDU 長エラー通知メッセージのカウント。

mplsLdpSesRejectedLRErrors

この LDP エンティティによって拒否されたセッション、または送受信されたパラメータ ラベル範囲通知メッセージのカウント。

mplsLdpBadLdpIdentifierErrors

この LDP エンティティに関連付けられているセッションによって検出された不正 LDP ID 重大エラー数のカウント。

mplsLdpBadPduLengthErrors

この LDP エンティティに関連付けられているセッションによって検出された不正 PDU 長重大エラー数のカウント。

mplsLdpBadMessageLengthErrors

この LDP エンティティに関連付けられているセッションによって検出された不正メッセージ長重大エラー数のカウント。

mplsLdpBadTlvLengthErrors

この LDP エンティティに関連付けられているセッションによって検出された不正 Type-Length-Value(TLV)長重大エラー数のカウント。

mplsLdpMalformedTlvValueErrors

この LDP エンティティに関連付けられているセッションによって検出された不正 TLV 値重大エラー数のカウント。

mplsLdpKeepAliveTimerExpErrors

この LDP エンティティに関連付けられているセッションによって検出されたセッション キープアライブ タイマー期限切れエラー数のカウント。

mplsLdpShutdownNotifReceived

この LDP エンティティに関連付けられているセッションについて受信したシャットダウン通知数のカウント。

mplsLdpShutdownNotifSent

この LDP エンティティに関連付けられているセッションについて送信されたシャットダウン通知数のカウント。

mplsLdpPeerTable

表 6 に、mplsLdpPeerTable のオブジェクトとその説明を示します。

 

表 6 mplsLdpPeerTable のオブジェクトと説明

オブジェクト
説明

mplsLdpPeerEntry

セッションに関連する単一ピアの情報(アクセス不能)。

(注) このテーブルは、mplsLdpSessionTable によって拡張されます。

mplsLdpPeerLdpId

この LDP ピアの LDP ID(アクセス不能)は、ピア LSR ID(4 オクテット)とピア ラベル スペース ID(2 オクテット)で構成されます。

mplsLdpPeerLabelDistMethod

特定の LDP セッションのラベル配布方法。値は、downstreamOnDemand(1) と downstreamUnsolicited(2) です。

mplsLdpPeerLoopDetectionForPV

パス ベクトルに基づくループ検出が、このピアでディセーブルまたはイネーブルのいずれになっているかを示します。

ダウンストリーム未承諾配布(mplsLdpPeerLabelDistMethod が downstreamUnsolicited(2))の場合、このオブジェクトの値は常に disabled(0) になり、ループ検出はディセーブルになります。

ダウンストリームオンデマンド配布(mplsLdpPeerLabelDistMethod が downstreamOnDemand(1))の場合、パス ベクトルに基づくループ検出がイネーブルになっていれば、このオブジェクトの値は enabled(1) になります。

mplsLdpPeerPVL

このエントリの mplsLdpPeerLoopDetectionForPV の値が enabled(1) の場合、このオブジェクトは、このピアのパス ベクトル制限を表します。

このエントリの mplsLdpPeerLoopDetectionForPV の値が disabled(0) の場合、この値は 0 になります。

mplsLdpHelloAdjacencyTable

表 7 に、mplsLdpHelloAdjacencyTable のオブジェクトとその説明を示します。

 

表 7 mplsLdpHelloAdjacencyTable のオブジェクトと説明

オブジェクト
説明

mplsLdpHelloAdjacencyEntry

各行が 1 つの LDP hello 隣接を表します。LDP セッションは、1 つ以上の hello 隣接を持つことができます(アクセス不能)。

mplsLdpHelloAdjIndex

この特定の隣接の識別名(アクセス不能)。アクティブな hello 隣接の mplsLdpHelloAdjIndex は 1 になります。

mplsLdpHelloAdjHoldTimeRem

この hello 隣接の残り時間。この間隔は、この hello 隣接に対応する次の hello 隣接を受信すると変わります。

mplsLdpHelloAdjType

この隣接は、このオブジェクトの値が link(1) である場合のリンク hello の結果です。それ以外の場合、この隣接は、ターゲット hello の結果であり、値は targeted(2) になります。

mplsLdpSessionTable

表 8 に、mplsLdpSessionTable のオブジェクトとその説明を示します。

 

表 8 mplsLdpSessionTable のオブジェクトと説明

オブジェクト
説明

mplsLdpSessionEntry

このテーブルのエントリは、LDP エンティティと LDP ピア間の単一セッションに関する情報を表します。行内の情報は読み取り専用です。このテーブルは、mplsLdpPeerTable を拡張します。

mplsLdpSesState

セッションの現在の状態。すべての状態は、セッション ネゴシエーション動作の LDP または TDP ステート マシンに基づいています。

状態は次のとおりです。

nonexistent(1)

initialized(2)

openrec(3)

opensent(4)

operational(5)

mplsLdpSesProtocolVersion

このセッションが使用している LDP プロトコルのバージョン。これは、セッションの初期化中にネゴシエーションされた LDP プロトコルのバージョンです。

mplsLdpSesKeepAliveHoldTimeRem

このセッションの残りのキープアライブ保留時間。

mplsLdpSesMaxPduLen

このセッションの LDP PDU の最大許容長。この値は、セッションの初期化中にネゴシエーションされた可能性があります。

mplsLdpSesDiscontinuityTime

このセッションのカウンタが 1 つ以上中断した場合、最後に中断したときの sysUpTime の値。関連するカウンタは、このセッションに関連付けられた、mplsLdpSesStatsTable に含まれている Counter32 または Counter64 オブジェクトの特定のインスタンスです。

このオブジェクトの初期値は、このテーブルにエントリが作成されたときの sysUpTime の値です。

mplsLdpAtmSesTable

表 9 に、mplsLdpAtmSesTable のオブジェクトとその説明を示します。

 

表 9 mplsLdpAtmSesTable のオブジェクトと説明

オブジェクト
説明

mplsLdpAtmSesEntry

このテーブルのエントリは、LDP エンティティと LDP ピア間の単一のラベル範囲共通部分に関する情報を現します(アクセス不能)。

mplsLdpAtmSesLRLowerBoundVpi

この範囲の最小 VPI 番号(アクセス不能)。

mplsLdpAtmSesLRLowerBoundVci

この範囲の最小 VCI 番号(アクセス不能)。

mplsLdpAtmSesLRUpperBoundVpi

この範囲の最大 VPI 番号(読み取り専用)。

mplsLdpAtmSesLRUpperBoundVci

この範囲の最大 VCI 番号(読み取り専用)。

mplsLdpSesStatsTable

表 10 に、mplsLdpSesStatsTable のオブジェクトとその説明を示します。

 

表 10 mplsLdpSesStatsTable のオブジェクトと説明

オブジェクト
説明

mplsLdpSesStatsEntry

このテーブルのエントリは、LDP エンティティと LDP ピア間の単一セッションに関する統計情報を表します。このテーブルは、mplsLdpPeerTable を拡張します。

mplsLdpSesStatsUnkMesTypeErrors

このオブジェクトは、このセッション中に検出された不明なメッセージ タイプ エラー数のカウントです。

mplsLdpSesStatsUnkTlvErrors

このオブジェクトは、このセッション中に検出された不明な TLV エラー数のカウントです。

MPLS LDP MIB バージョン 8 アップグレードにおける VPN コンテキスト

MPLS Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)4 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)環境では、各 VPN に個別の LDP プロセスを作成できます。これらのプロセスとその関連データを LDP コンテキストと呼びます。各コンテキストは、他のすべてのコンテキストとは独立しており、そのコンテキスト固有のデータだけが含まれています。

Cisco IOS Release 12.0(11)ST 以降のリリースには、LDP MIB による VPN コンテキスト情報の取得を可能にする VPN 対応 LDP MIB 機能が含まれています。この機能により、MPLS VPN ごとに異なるコンテキストのサポートが追加されます。MIB のユーザは、特定の MPLS VPN の MPLS LDP プロセスを表示できます。VPN 対応 LDP MIB 機能によって、IETF MPLS-LDP MIB の構文が変わることはありません。テーブル内のエントリの数とタイプが変わります。

IETF MPLS-LDP MIB は、同時に 1 つのコンテキストだけの情報を表示できます。SMNP セキュリティ名を使用して、グローバル コンテキストまたは MPLS VPN コンテキストを指定できます。

次の項では、VPN 対応 LDP MIB 機能に関連する内容について説明します。

「SNMP コンテキスト」

「VPN 対応 LDP MIB セッション」

「VPN 対応 LDP MIB の通知」

SNMP コンテキスト

VPN ユーザは、SNMP コンテキストを使用すると、MIB データに安全にアクセスできます。VPN がコンテキストに関連付けられている場合、その VPN 固有の MIB データはそのコンテキスト内にあります。VPN をコンテキストに関連付けると、サービス プロバイダーは複数の VPN を含むネットワークを管理できます。コンテキストを作成して VPN に関連付けることにより、サービス プロバイダーは、ある VPN のユーザが同じネットワーク デバイス上で他の VPN のユーザに関する情報にアクセスするのを防ぐことができます。

VPN 対応 SNMP を使用するには、VPN 環境で動作している SNMP マネージャと SNMP エージェント エンティティが SNMP セキュリティ名と VPN 名の間のマッピングに同意する必要があります。このマッピングは、異なる VPN の SNMP データに異なるコンテキストを使用して作成されます。これは、SNMP View-based Access Control Model MIB(SNMP-VACM-MIB)の設定を通じて行われます。SNMP-VACM-MIB にビューを設定して、セキュリティ名を持つ VPN 上のユーザに、その VPN だけのコンテキスト内で制限されたオブジェクト スペースにアクセスすることを許可できます。

SNMP 要求メッセージがセキュリティおよびアクセス コントロールの 3 つのフェーズを通過すると、VPN コンテキスト内でオブジェクト値が付加された応答メッセージが返送されます。

最初のセキュリティ フェーズは、ユーザ名の認証です。このフェーズの間に、ユーザは SNMP アクセスを許可されます。

2 つめのフェーズはアクセス コントロールです。このフェーズの間に、ユーザは要求した SNMP コンテキスト内のグループ オブジェクトへの SNMP アクセスを許可されます。

3 つめのフェーズでは、ユーザはテーブル エントリの特定のインスタンスにアクセスできます。このフェーズでは、SNMP コンテキスト名に基づいて完全な取得を行うことができます。

IP アクセス リストを設定し、SNMP コミュニティ ストリングに関連付けることができます。この機能を使用すると、VRF インスタンスと SNMP コミュニティ ストリング間のアソシエーションを設定できます。VRF インスタンスが SNMP コミュニティ ストリングに関連付けられている場合、SNMP は、特定のコミュニティ ストリングの着信要求を、設定されている VRF から受信した場合だけ処理します。着信パケットに含まれているコミュニティ ストリングに VRF が関連付けられていない場合は、VRF 以外のインターフェイス経由で着信した場合だけパケットを処理します。

VRF のミスマッチによりドロップされた SNMP パケットの認証トラップをイネーブルまたはディセーブルにすることもできます。デフォルトでは、SNMP 認証トラップをイネーブルすると、VRF 認証トラップもイネーブルになります。

VPN 対応 LDP MIB セッション

Cisco IOS Release 12.0(11)ST よりも前のリリースでは、MPLS LDP MIB に対する SNMP クエリーによって返されるのはグローバル セッションに関する情報だけでした。VPN コンテキストの LDP セッションに関する情報は返されませんでした。IETF MPLS LDP MIB はグローバル ルーティング テーブルから情報を取得しましたが、VPN ごとのルーティング データが格納された VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスから情報を取得しませんでした。MPLS LDP MIB はグローバル コンテキスト内の LDP プロセスだけを参照し、他のすべてのセッションを無視しました。VRF に対するクエリーによって情報は返されませんでした。VPN コンテキスト内の LDP プロセスは表示できます。

図 7 に、VPN 対応 LDP MIB 機能が実装される前の MPLS LDP セッションを含むサンプル MPLS VPN ネットワークを示します。

図 7 VPN 対応 LDP MIB 機能よりも前の MPLS LDP セッションの設定

 

この Cisco IOS リリースよりも前の MIB ウォークでは、グローバル セッションの情報だけが表示されました。

この Cisco IOS リリースの VPN 対応 LDP MIB 機能拡張により、IETF MPLS-LDP-MIB に対する SNMP クエリーでグローバル コンテキストと VPN コンテキストの両方がサポートされます。この機能を使用すると、VRF とコア(グローバル コンテキスト)に対する LDP クエリーを入力できます。クエリーは、異なる VPN からの LDP セッションを区別できます。VPN の LDP セッション情報は、その VPN のコンテキストに保存されます。したがって、ある VPN からの情報を別の VPN のユーザが使用することはできません。LDP MIB に対する VPN 対応アップデートによって、Carrier Supporting Carrier(CSC)ネットワークで動作している LDP プロセスを表示することもできます。

MPLS VPN では、サービス Provider Edge(PE; プロバイダー エッジ)ルータに複数の VPN の VRF とグローバル ルーティング テーブルを含めることができます。同じデバイス上の VPN ごとに個別の LDP プロセスを設定するには、各 VPN に一意の securityName、contextName、および View-based Access Control Model(VACM)ビューを設定する必要があります。VPN の securityName は、IETF MPLS LDP MIB に対して設定する必要があります。

図 8 に、VPN 対応 LDP MIB 機能を使用したサンプル MPLS VPN ネットワークの LDP セッションを示します。

図 8 VPN 対応 LDP MIB 機能を使用した MPLS LDP セッション

 

VPN 対応 LDP MIB 機能を使用すると、MPLS VPN LDP セッションまたはグローバル LDP セッションに対して MIB クエリーまたは MIB ウォークを実行できます。


) 特定の VPN の LDP セッション情報を確認するには、show mpls ldp neighbor vrf vpn-name detail コマンドを使用します。


VPN 対応 LDP MIB の通知

Cisco IOS Release 12.0(11)ST よりも前のリリースでは、MPLS LDP セッションのすべての通知メッセージは、ネットワーク内の指定された同じ Network Management Station(NMS; ネットワーク管理ステーション)に送信されました。通知をイネーブルにするには、 snmp-server enable traps mpls ldp コマンドが使用されました。

図 9 に、VPN 対応 LDP MIB 機能が実装される前の LDP 通知の送信を示します。

図 9 VPN 対応 LDP MIB 機能よりも前の LDP 通知の送信

 

VPN 対応 LDP MIB 機能では、VPN の複数の LDP コンテキストに対する LDP 通知がサポートされます。LDP 通知は、コア(グローバル コンテキスト)および異なる VPN に対して生成できます。LDP コンテキストごとに異なる NMS ホストに通知を送信できます。特定の VRF に関連付けられた LDP 通知は、その VRF に指定された NMS に送信されます。LDP グローバル通知は、グローバル トラップを受信するように設定された NMS に送信されます。

VPN 対応 LDP MIB 機能の LDP コンテキスト通知をイネーブルにするには、SNMP オブジェクト mplsLdpSessionsUpDownEnable(グローバル LDP コンテキストの場合だけ)または次の拡張グローバル コンフィギュレーション コマンドを使用します。

グローバル コンテキストの LDP 通知をイネーブルにするには、次のコマンドを使用します。

PE-Router(config)# snmp-server host host-address traps community mpls-ldp
 
PE-Router(config)# snmp-server enable traps mpls ldp
 

VPN コンテキストの LDP 通知をイネーブルにするには、次のコマンドを使用します。

PE-Router(config)# snmp-server host host-address vrf vrf-name version {v1|v2c|v3}
community community-string udp-port upd-port mpls-ldp
 
PE-Router(config)# snmp-server enable traps mpls ldp
 

図 10 に、VPN 対応 LDP MIB 機能を使用した LDP 通知を示します。

図 10 VPN 対応 LDP MIB 機能を使用した LDP 通知

 

MPLS LDP MIB バージョン 8 アップグレードの設定方法

ここでは、次の各手順について説明します。

「SNMP エージェントのイネーブル化」(必須)

「シスコ エクスプレス フォワーディングのイネーブル化」(必須)

「MPLS のグローバルなイネーブル化」(必須)

「LDP のグローバルなイネーブル化」(必須)

「インターフェイス上の MPLS のイネーブル化」(必須)

「インターフェイス上の LDP のイネーブル化」(必須)

「VPN 対応 LDP MIB の設定」(必須)

「MPLS LDP MIB バージョン 8 アップグレードの確認」(任意)

SNMP エージェントのイネーブル化

SNMP エージェントをイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. show running-config

3. configure terminal

4. snmp-server community string [ view view-name ] [ ro ] [ number ]

5. end

6. write memory

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show running-config

 

Router# show running-config

ルータの実行コンフィギュレーションを表示して、デバイス上で SNMP エージェントがすでに実行中かどうかを判断します。

SNMP 情報が表示されない場合は、次のステップに進みます。

SNMP 情報が表示された場合は、必要に応じて情報を修正したり変更したりできます。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

snmp-server community string [ view view-name ] [ ro ] [ number ]

 

Router(config)# snmp-server community public ro

MPLS LDP MIB に対して Read-Only(RO; 読み取り専用)のコミュニティ ストリングを設定します。

string 引数は、パスワードのように機能し、MPLS ネットワーク内の Label Switching Router(LSR; ラベル スイッチング ルータ)上の SNMP 機能へのアクセスを許可します。

省略可能な ro キーワードでは、MPLS LDP MIB 内のオブジェクトへの読み取り専用(ro)アクセスを設定します。

ステップ 5

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

ステップ 6

write memory

 

Router# write memory

変更した SNMP 設定をルータの NVRAM に書き込み、SNMP 設定を永続的に保存します。

シスコ エクスプレス フォワーディングのイネーブル化

シスコ エクスプレス フォワーディングまたは分散シスコ エクスプレス フォワーディングをイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip cef distributed

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef distributed

 

Router(config)# ip cef distributed

分散シスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

MPLS のグローバルなイネーブル化

MPLS をグローバルにイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip
 

Router(config)# mpls ip

プラットフォーム用に通常ルーティングされるパスに沿って IPv4 パケットの MPLS 転送が行われるようにします。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

LDP のグローバルなイネーブル化

LDP をグローバルにイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls label protocol { ldp | tdp }

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls label protocol { ldp | tdp }

 

Router(config)# mpls label protocol ldp

プラットフォームのデフォルトのラベル配布プロトコルを指定します。

ステップ 4

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

インターフェイス上の MPLS のイネーブル化

インターフェイス上の MPLS をイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface [ type number ]

4. mpls ip

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface [ type number ]

 

Router(config)# interface Ethernet 1

インターフェイス コンフィギュレーション モードを開始します。

type number 引数には、設定するインターフェイスを指定します。

ステップ 4

mpls ip

 

Router(config-if)# mpls ip

特定のインターフェイス用に通常ルーティングされるパスに沿って IPv4 パケットの MPLS 転送が行われるようにします。

ステップ 5

end

 

Router(config-if)# end

終了して、特権 EXEC モードに戻ります。

インターフェイス上の LDP のイネーブル化

インターフェイス上の LDP をイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface [ type number ]

4. mpls label protocol { ldp | tdp | both }

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface [ type number ]

 

Router(config)# interface Ethernet 1

インターフェイス コンフィギュレーション モードを開始します。

type number 引数には、設定するインターフェイスを指定します。

ステップ 4

mpls label protocol { ldp | tdp | both }

 

Router(config-if)# mpls label protocol ldp

指定したインターフェイスで使用するラベル配布プロトコルを指定します。

ステップ 5

end

 

Router(config-if)# end

終了して、特権 EXEC モードに戻ります。

VPN 対応 LDP MIB の設定

VPN 対応 LDP MIB を設定するには、次の作業を実行します。

「VPN の SNMP サポートの設定」

「VPN の SNMP コンテキストの設定」

「SNMPv1 または SNMPv2 への SNMP VPN コンテキストの関連付け」

VPN の SNMP サポートの設定

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)またはリモート VPN の SNMP サポートを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. snmp-server host host-address [ traps | informs ] [ version { 1 | 2c | 3 [ auth | noauth | priv ]}]
community-string [ udp-port port ] [ notification-type ] [ vrf vrf-name ]

4. snmp-server engineID remote ip-address [ udp-port udp-port-number ] [ vrf vrf-name ]
engineid-string

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

snmp-server host host-address [ traps | informs ] [ version { 1 | 2c | 3 [ auth | noauth | priv ]}] community-string [ udp-port port ] [ notification-type ] [ vrf vrf-name ]

 
Router(config)# snmp-server host example.com vrf trap-vrf

SNMP 通知動作の受信者を指定し、SNMP 通知の送信に使用する Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンス テーブルを指定します。

ステップ 4

snmp-server engineID remote ip-address [ udp-port udp-port-number ] [ vrf vrf-name ] engineid-string

 
Router(config)# snmp-server engineID remote 172.16.20.3 vrf traps-vrf 80000009030000B064EFE100

ルータ上のリモート SNMP エンジンの名前を設定します。

ステップ 5

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

この次の手順

「VPN の SNMP コンテキストの設定」に進みます。

VPN の SNMP コンテキストの設定

VPN の SNMP コンテキストを設定するには、次の作業を実行します。これにより、VPN の一意の SNMP コンテキストを設定して、VPN の LDP セッション情報にアクセスできるようになります。

SNMP コンテキスト

VPN ユーザは、SNMP コンテキストを使用すると、MIB データに安全にアクセスできます。VPN がコンテキストに関連付けられている場合、その VPN 固有の MIB データはそのコンテキスト内にあります。VPN をコンテキストに関連付けると、サービス プロバイダーは複数の VPN を含むネットワークを管理できます。コンテキストを作成して VPN に関連付けることにより、サービス プロバイダーは、ある VPN のユーザが同じネットワーク デバイス上で他の VPN のユーザに関する情報にアクセスするのを防ぐことができます。

VPN ルート識別子

Route Distinguisher(RD; ルート識別子)によって、VPN のルーティングおよび転送テーブルが作成されます。Cisco IOS は、RD をカスタマーの IPv4 プレフィクスの先頭に追加して、それらのプレフィクスをグローバルに一意である VPN-IPv4 プレフィクスに変更します。

RD は、自律システム番号と任意の番号で構成される Autonomous System Number(ASN; 自律システム番号)相対 RD、または IP アドレスと任意の番号で構成される IP アドレス相対 RD のいずれかです。RD は、次のいずれかの形式で入力できます。

16 ビット ASN:101:3 などの 32 ビット数値

32 ビット IP アドレス:192.168.122.15:1 などの 16 ビット数値

手順の概要

1. enable

2. configure terminal

3. snmp-server context context-name

4. ip vrf vrf-name

5. rd route-distinguisher

6. context context-name

7. route-target { import | export | both } route-target-ext-community

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

snmp-server context context-name
 

Router(config)# snmp-server context context1

SNMP コンテキストを作成し、その名前を指定します。

ステップ 4

ip vrf vrf-name

 

Router(config)# ip vrf vrf1

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; VPN ルーティングおよび転送)テーブルを設定し、VRF コンフィギュレーション モードを開始します。

ステップ 5

rd route-distinguisher
 

Router(config-vrf)# rd 100:120

VPN ルート識別子を作成します。

ステップ 6

context context-name
 

Router(config-vrf)# context context1

SNMP コンテキストを特定の VRF に関連付けます。

ステップ 7

route-target { import | export | both } route-target-ext-community
 

Router(config-vrf)# route-target export 100:1000

(任意)VRF 用の route-target 拡張コミュニティを作成します。

ステップ 8

end

 

Router(config)# end

終了して、特権 EXEC モードに戻ります。

SNMPv1 または SNMPv2 への SNMP VPN コンテキストの関連付け

SNMP VPN コンテキストを SNMPv1 または SNMPv2 に関連付けるには、次の作業を実行します。これにより、SNMPv1 または SNMPv2 を使用して VPN の LDP セッション情報にアクセスできます。

SNMPv1 または SNMPv2 セキュリティ

SNMPv1 と SNMPv2 は、SNMPv3 ほど安全ではありません。SNMP バージョン 1 と 2 では、プレーン テキスト コミュニティを使用し、SNMP バージョン 3 で実行される認証やセキュリティ チェックを実行しません。

SNMP バージョン 1 または SNMP バージョン 2 を使用するときに VPN 対応 LDP MIB 機能を設定するには、コミュニティ名を VPN に関連付ける必要があります。関連付けると、SNMP は、特定のコミュニティ ストリングの着信要求を、設定されている VRF から受信した場合だけ処理します。着信パケットに含まれているコミュニティ ストリングに VRF が関連付けられていない場合は、VRF 以外のインターフェイス経由で着信した場合だけパケットを処理します。このプロセスによって、VPN 外のユーザがクリア テキスト コミュニティ ストリングを使用して VPN データを問い合わせるのを防ぐことができます。ただし、これは SNMPv3 を使用する場合ほど安全ではありません。

手順の概要

1. enable

2. configure terminal

3. snmp-server user username group-name [ remote host [ udp-port port ]] { v1 | v2c | v3 [ encrypted ]
[ auth { md5 | sha } auth-password ]} [ access access-list ]

4. snmp-server group group-name { v1 | v2c | v3 { auth | noauth | priv }} [ context context-name ]
[ read readview ] [ write writeview ] [ notify notifyview ] [ access access-list ]

5. snmp-server view view-name oid-tree { included | excluded }

6. snmp-server enable traps [ notification-type ]

7. snmp-server host host-address [ traps | informs ] [ version { 1 | 2c | 3 [ auth | noauth | priv ]}]
community-string [ udp-port port ] [ notification-type ] [ vrf vrf-name ]

8. snmp mib community-map community-name [ context context-name ] [ engineid engine-id ]
[ security-name security-name ] target-list vpn-list-name

9. snmp mib target list vpn - list-name { vrf vrf-name | host ip-address }

10. no snmp-server trap authentication vrf

11. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

snmp-server user username group-name [ remote host [ udp-port port ]] { v1 | v2c | v3 [ encrypted ] [ auth { md5 | sha } auth-password ]} [ access access-list ]

 

Router(config)# snmp-server user customer1 group1 v1

SNMP グループの新しいユーザを設定します。

ステップ 4

snmp-server group group-name { v1 | v2c | v3 { auth | noauth | priv }} [ context context-name ] [ read readview ] [ write writeview ] [ notify notifyview ] [ access access-list]

 

Router(config)# snmp-server group group1 v1 context context1 read view1 write view1 notify view1

新しい SNMP グループ、または SNMP ユーザを SNMP ビューにマッピングするテーブルを設定します。

context context-name キーワードと引数を使用して、指定した SNMP グループを設定されている SNMP コンテキストに関連付けます。

ステップ 5

snmp-server view view-name oid-tree { included | excluded }

 

Router(config)# snmp-server view view1 ipForward included

ビュー エントリを作成または更新します。

ステップ 6

snmp-server enable traps [ notification-type ]

 

Router(config)# snmp-server enable traps

システムで使用できるすべての SNMP 通知(トラップまたは応答要求)をイネーブルにします。

ステップ 7

snmp-server host host-address [ traps | informs ] [ version { 1 | 2c | 3 [ auth | noauth | priv ]}] community-string [ udp-port port ] [ notification-type ] [ vrf vrf-name ]

 

Router(config)# snmp-server host 10.0.0.1 vrf customer1 public udp-port 7002

SNMP 通知動作の受信者を指定します。

ステップ 8

snmp mib community-map community-name [ context context-name ] [ engineid engine-id ] [ security-name security-name ] target-list vpn-list-name

 

Router(config)# snmp mib community-maps community1 context context1 target-list commAVpn

SNMP コミュニティを SNMP コンテキスト、エンジン ID、またはセキュリティ名にマッピングします。

ステップ 9

snmp mib target list vpn-list-name { vrf vrf-name | host ip-address }

 

Router(config)# snmp mib target list commAVpn vrf vrf1

SNMP コミュニティに関連付けるターゲット VRF とホストのリストを作成します。

ステップ 10

no snmp-server trap authentication vrf

 

Router(config)# no snmp-server trap authentication vrf

(任意)VRF インターフェイスで受信したパケットについて生成されるすべての SNMP 認証通知(トラップまたは応答要求)をディセーブルにします。

このコマンドを使用して、関連付けられているコミュニティが正しくない VRF インターフェイス上のパケットに対する認証トラップだけをディセーブルにします。

ステップ 11

exit

 

Router(config) exit

終了して、特権 EXEC モードに戻ります。

MPLS LDP MIB バージョン 8 アップグレードの確認

MPLS LDP MIB バージョン 8 アップグレードが機能していることを確認するには、SNMP 管理ツールを使用して MIB ウォークを実行します。

MPLS LDP MIB バージョン 8 アップグレードの設定例

ここでは、次の設定例について説明します。

「MPLS LDP MIB バージョン 8 アップグレードの例」

「SNMPv1 または SNMPv2 の VPN 対応 SNMP コンテキストの設定:例」

MPLS LDP MIB バージョン 8 アップグレードの例

次に、ホスト NMS 上で SNMP エージェントをイネーブルにする例を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
 
Router(config)# snmp-server community

 

次に、ホスト NMS 上の SNMPv1 と SNMPv2C をイネーブルにする例を示します。設定では、コミュニティ ストリング public を使用して、SNMP エージェントが読み取り専用アクセス権を持つすべての MPLS LDP MIB オブジェクトにアクセスすることを許可しています。

Router(config)# snmp-server community public

 

次に、comaccess コミュニティ ストリングを指定するアクセス リスト 4 のメンバに、すべての MPLS LDP MIB オブジェクトへの読み取り専用アクセスを許可する例を示します。その他の SNMP エージェントは MPLS LDP MIB オブジェクトにアクセスできません。

Router(config)# snmp-server community comaccess ro 4

 

次に、LDP をグローバルにイネーブルにしてからインターフェイスに対してイネーブルにする例を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
 
Router(config)# mpls label protocol ldp
 
Router(config)# interface Ethernet1
 
Router(config-if)# mpls label protocol ldp
 
Router(config-if)# end
 

SNMPv1 または SNMPv2 の VPN 対応 SNMP コンテキストの設定:例

次に、SNMPv1 または SNMPv2 を使用して MPLS LDP MIB バージョン 8 の VPN 対応 SNMP コンテキストを設定する例を示します。

snmp-server context A
snmp-server context B
 
ip vrf CustomerA
rd 100:110
context A
route-target export 100:1000
route-target import 100:1000
!
 
ip vrf CustomerB
rd 100:120
context B
route-target export 100:2000
route-target import 100:2000
!
 
interface Ethernet3/1
description Belongs to VPN A
ip vrf forwarding CustomerA
ip address 10.0.0.0 255.255.0.0
 
interface Ethernet3/2
description Belongs to VPN B
ip vrf forwarding CustomerB
ip address 10.0.0.1 255.255.0.0
 
snmp-server user commA grp1A v1
snmp-server user commA grp2A v2c
snmp-server user commB grp1B v1
snmp-server user commB grp2B v2c
 
snmp-server group grp1A v1 context A read viewA write viewA notify viewA
snmp-server group grp1B v1 context B read viewB write viewB notify viewB
 
snmp-server view viewA ipForward included
snmp-server view viewA ciscoPingMIB included
snmp-server view viewB ipForward included
snmp-server view viewB ciscoPingMIB included
 
snmp-server enable traps
snmp-server host 10.0.0.3 vrf CustomerA commA udp-port 7002
snmp-server host 10.0.0.4 vrf CustomerB commB udp-port 7002
 
snmp mib community-map commA context A target-list commAvpn
! Configures source address validation
snmp mib community-map commB context B target-list commBvpn
! Configures source address validation
snmp mib target list commAvpn vrf CustomerA
! Configures a list of VRFs or from which community commA is valid
snmp mib target list commBvpn vrf CustomerB
! Configures a list of VRFs or from which community commB is valid
 

その他の参考資料

ここでは、MPLS LDP MIB バージョン 8 アップグレード機能に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS LDP の設定作業

『MPLS Label Distribution Protocol (LDP)』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

MPLS ラベル配布プロトコル MIB(draft-ietf-mpls-ldp-mib-08.txt)

SNMP-VACM-MIB
SNMP 用 View-based Access Control Model(ACM)MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2233

MPLS LDP MIB をサポートする LDP 実装は、RFC 2026 第 10 項の規定に完全に準拠しています。その規定では、宛先ベースのルーティング プロトコルで決定された、通常ルーティングされるパスに沿った MPLS 転送を実行するネットワーク デバイスに LDP の実装を推奨しています。

『Interfaces MIB』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『 Cisco IOS Master Command List 』にアクセスしてください。

context

show mpls ldp neighbor

snmp mib community-map

snmp mib target list

snmp-server community

snmp-server context

snmp-server enable traps(MPLS)

snmp-server group

snmp-server host

snmp-server trap authentication vrf

用語集

ATM Asynchronous Transfer Mode(非同期転送モード)。セルリレーの国際規格であり、このモードでは、複数のサービス タイプ(音声、ビデオ、データなど)が固定長(53 バイト)のセルで伝送されます。セルを固定長にすることで、セル処理をハードウェアで実行できるため、中継遅延が短縮されます。ATM は、E3、SONET、T3 などの高速送信メディアを活用する設計になっています。

LDP :Label Distribution Protocol(ラベル配布プロトコル)。MPLS のホップバイホップ転送およびラベルとネットワーク プレフィクス間のバインディングの配布をサポートするプロトコル。このプロトコルのシスコ独自のバージョンは、Tag Distribution Protocol(TDP; タグ配布プロトコル)です。

LSP :Label Switched Path(ラベル スイッチド パス)。ラベル スイッチング技術がパケット転送に使用される、2 つの Label Switching Router(LSR; ラベル スイッチング ルータ)間の設定済み接続。このパスは、MPLS ネットワークを介した特定のパスでもあります。

LSR :Label Switch Router(ラベル スイッチ ルータ)。ネイティブなレイヤ 3 パケットを転送できる Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ノード。LSR は、パケットに付加されたラベルの値に基づいてパケットを転送します。

MIB :Management Information Base(管理情報ベース)。Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)などのネットワーク管理プロトコルにより使用および管理される、ネットワーク管理情報のデータベース。MIB オブジェクトの値を変更または検索するには、通常はネットワーク管理システムを介して、SNMP コマンドを使用します。MIB オブジェクトはツリー構造であり、ツリーにはパブリック(標準)ブランチとプライベート(独自)ブランチを含みます。

MPLS :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)。ラベルを使用して IP トラフィックを転送するスイッチング方式。このラベルによって、ネットワーク内のルータおよびスイッチが、事前に確立された IP ルーティング情報に基づくパケットの転送先を指示されます。

MPLS ラベル配布 :Label Switched Path(LSP; ラベル スイッチド パス)トンネルのルーティングを行うための、コンストレイントベース ルーティング アルゴリズム。

NMS :Network Management Station(ネットワーク管理ステーション)。ネットワーク管理者がネットワーク内の他のデバイスとの通信に使用する、十分に装備された強力なコンピュータ(通常はエンジニアリング ワークステーション)。NMS は通常、ネットワーク リソースの管理、統計の収集、さまざまなネットワーク管理タスクと設定タスクの実行のために使用されます。SNMP のコンテキストでは、NMS は、管理対象デバイスの SNMP エージェントに対する SNMP クエリーを実行して、情報を取得または変更します。

RSVP :Resource Reservation Protocol(リソース予約プロトコル)。IP ネットワークのリソースの予約をサポートするプロトコル。IP エンド システムで実行されているアプリケーションは、RSVP を使用して、帯域幅、ジッタ、最大バーストなどの項目を指定することにより、受信するパケット ストリームの特性を他のノードに示すことができます。

RTR :Response Time Reporter。応答時間とアベイラビリティを測定することによってネットワーク パフォーマンス、ネットワーク リソース、およびアプリケーションを監視できるツール。

SNMP :Simple Network Management Protocol(簡易ネットワーク管理プロトコル)。TCP/IP ネットワークでほぼ独占的に使用されているネットワーク管理プロトコル。SNMP を使用すると、ネットワーク デバイスの監視と制御、設定の管理、統計の収集、パフォーマンスの監視、およびネットワーク セキュリティの確保が可能になります。

SNMP コミュニティ :インテリジェントなネットワーク デバイスによる SNMP 要求の検証を可能にする認証方式。

SNMPv2c :簡易ネットワーク管理プロトコルのバージョン 2c。SNMPv2c では、集中型および分散型のネットワーク管理方式がサポートされ、Structure of Management Information(SMI; 管理情報構造)、プロトコル動作、管理アーキテクチャ、およびセキュリティが改善されています。

SNMPv3 :簡易ネットワーク管理プロトコルのバージョン 3。ネットワーク管理用の相互運用可能な標準ベースのプロトコル。SNMPv3 は、ネットワーク経由のパケットの認証と暗号化を組み合せることによって、デバイスへのセキュア アクセスを実現します。

TDP :Tag Distribution Protocol(タグ配布プロトコル)。パケットの転送に使用されるタグ(アドレス)をネゴシエーションするために、MPLS 対応ルータによって使用される標準プロトコル。「LDP」も参照してください。

TLV :Type-Length-Value。さまざまなアトリビュートを伝送するために、いくつかのルーティング プロトコルで使用されるメカニズム。TLV を使用するプロトコルの例として、Cisco Discovery Protocol(CDP; シスコ検出プロトコル)、Label Discovery Protocol(LDP)、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)などがあります。BGP は、TLV を使用して、Network Layer Reachability Information(NLRI; ネットワーク レイヤ到達可能性情報)、Multiple Exit Discriminator(MED)、ローカル プリファレンスなどのアトリビュートを伝送します。

VCC :Virtual Channel Connection(仮想チャネル接続)。ATM ネットワーク内の 2 つのエンドポイント間でデータを伝送する、Virtual Channel Link(VCL; 仮想チャネル リンク)で構成された論理回線。仮想回線接続と呼ばれることもあります。

VCI :Virtual Channel Identifier(仮想チャネル識別子)。ATM セルのヘッダーにある 16 ビットのフィールド。VCI は、Virtual Path Identifier(VPI; 仮想パス識別子)とともに、セルがその最終的な宛先に到達するまで一連の ATM スイッチを通過するときの次のネットワーク Virtual Channel Link(VCL; 仮想チャネル リンク)を識別するために使用されます。

VCL :Virtual Channel Link(仮想チャネル リンク)。ATM ネットワーク内の 2 つの隣接スイッチ間に存在する論理接続。

VPI :Virtual Path Identifier(仮想パス識別子)。ATM セルのヘッダーにある 8 ビットのフィールド。VPI は、Virtual Channel Identifier(VCI; 仮想チャネル識別子)とともに、セルがその最終的な宛先に到達するまで一連の ATM スイッチを通過するときの次のネットワーク Virtual Channel Link(VCL; 仮想チャネル リンク)を識別するために使用されます。

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。トンネリングを使用することにより、パブリック TCP/IP ネットワーク経由でも IP トラフィックをセキュアに転送できるネットワーク。

VRF :VPN Routing and Forwarding(VPN ルーティングおよび転送)インスタンス。VRF は、IP ルーティング テーブル、取得された転送テーブル、その転送テーブルを使用する一連のインターフェイス、転送テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。一般に、VRF には、PE ルータに付加されるカスタマー VPN サイトが定義されたルーティング情報が格納されています。

応答要求 :従来のトラップ通知メッセージよりも信頼性の高い通知メッセージのタイプ。信頼性が高いのは、応答要求メッセージ通知には確認応答が必要ですが、トラップ通知には必要ないためです。

ダウンストリームオンデマンド配布 :ラベル配布方式。ダウンストリーム Label Switch Router(LSR; ラベル スイッチ ルータ)は、アップストリーム LSR によって要求された場合だけバインディングをアップストリームに送信します。

ダウンストリーム未承諾配布 :ラベル配布方式。ダウンストリーム Label Switch Router(LSR; ラベル スイッチ ルータ)がネイバー アップストリーム LSR との新しいバインディングを確立する必要がある場合に、ラベルが分散されます。たとえば、エッジ LSR は、別のサブネットとの新しいインターフェイスをイネーブルにする場合があります。その場合、LSR は、このネットワークに到達するためのバインディングをアップストリーム ルータにアナウンスします。

通知 :Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)エージェントによってネットワーク管理ステーション、コンソール、または端末に送信されるメッセージ。これにより、重大なネットワーク イベントが発生したことが示されます。「トラップ」も参照してください。

トラップ :SNMP エージェントによってネットワーク管理ステーション、コンソール、または端末に送信されるメッセージ。これにより、重大なネットワーク イベントが発生したことが示されます。トラップ(通知)は応答要求よりも信頼性が低くなります。トラップの受信者が受信の確認応答を送信しないので、トラップが受信されたかどうかをトラップの送信者が判断できないためです。「通知」も参照してください。

ラベル :スイッチング ノードに対してデータの転送方法(パケットまたはセル)を指示する短い固定長のデータ ID。

ラベル配布 :通常ルーティングされるパスに沿ったホップバイホップ転送をサポートするために、Label Switch Router(LSR; ラベル スイッチ ルータ)によって、ラベル バインディング情報の交換に使用される技術およびプロセス。