マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS LDP グレースフル リスタート
MPLS LDP グレースフル リスタート
発行日;2012/01/31 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS LDP グレースフル リスタート

この章の構成

MPLS LDP グレースフル リスタートに関する情報

MPLS LDP グレースフル リスタートの動作

MPLS LDP グレースフル リスタートをサポートしていることをルート プロセッサがアドバタイズする方法

ルート プロセッサに LDP グレースフル リスタートがない場合の動作

MPLS LDP グレースフル リスタートの設定方法

MPLS LDP グレースフル リスタートの設定

制約事項

設定の確認

MPLS LDP グレースフル リスタートの設定例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

MPLS LDP グレースフル リスタート

ルータに Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Label Distribution Protocol(LDP; ラベル配布プロトコル)Graceful Restart(GR; グレースフル リスタート)が設定されている場合、ルータは MPLS LDP Stateful Switchover/Nonstop Forwarding(SSO/NSF; ステートフル スイッチオーバー/ノンストップ フォワーディング)サポートとグレースフル リスタートが備えられたネイバー ルータがサービスの中断から正常に回復するのを支援します。この Cisco IOS リリースでは、MPLS LDP GR は厳格にヘルパー モードで機能します。これは、MPLS SSO/NSF および GR がイネーブルになっている他のルータの回復の支援だけを行えることを意味します。LDP GR が備えられたルータで障害が発生すると、そのルータのピア ルータではルータの回復を支援できません。

注:

MPLS LDP SSO/NSF サポートおよびグレースフル リスタートは、Cisco IOS Release 12.2(25)S でサポートされています。簡略化のために、このマニュアルではこの機能を LDP SSO/NSF と呼びます。

このマニュアルで説明している MPLS LDP GR 機能はヘルパー モードを指しています。

MPLS LDP SSO/NSF 対応のルータのピアであるルータ上で MPLS LDP GR をイネーブルにした場合、SSO/NSF 対応のルータでは、それらのルータ間の LDP セッションが中断したときにそのフォワーディング ステートを維持できます。SSO/NSF 対応のルータが回復している間、ピア ルータは古い情報を使用してパケットを転送します。これにより、SSO/NSF 対応のルータでは、より迅速に動作状態になることができます。

MPLS LDP グレースフル リスタートの機能の履歴

リリース
変更点

12.0(29)S

(ヘルパー モードに)MPLS LDP グレースフル リスタート機能が導入されました。

12.3(14)T

この機能は、Cisco IOS Release 12.3(14)T に統合されました。

12.2(33)SRA

この機能は、Cisco IOS Release 12.2(33)SRA に統合されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。

MPLS LDP グレースフル リスタートに関する情報

MPLS LDP GR を設定するには、次の概念を理解する必要があります。

「MPLS LDP グレースフル リスタートの動作」

「MPLS LDP グレースフル リスタートをサポートしていることをルート プロセッサがアドバタイズする方法」

「ルート プロセッサに LDP グレースフル リスタートがない場合の動作」

MPLS LDP グレースフル リスタートの動作

MPLS LDP GR は、厳格なヘルパー モードで動作します。つまり、MPLS LDP SSO/NSF を備えた隣接ルート プロセッサが、MPLS フォワーディング ステートを維持したまま、サービスの中断から回復するのを支援します。サービスの中断は、TCP や UDP イベント、またはルート プロセッサのステートフル スイッチオーバーが原因で発生する可能性があります。ネイバー ルータが新しいセッションを確立すると、LDP バインディングおよび MPLS フォワーディング ステートが回復します。

図 1 に示すトポロジでは、次の要素が設定されています。

LDP セッションが、ルータ 1 とルータ 2 の間、およびルータ 2 とルータ 3 の間で確立されています。

ルータ 2 には MPLS LDP SSO/NSF が設定されています。ルータ 1 および 3 には MPLS LDP GR が設定されています。

Label Switched Path(LSP; ラベル スイッチド パス)が、ルータ 1 とルータ 3 の間に確立されています。

図 1 LDP グレースフル リスタートを使用したネットワークの例

 

次のプロセスは、LDP GR が設定されているルータ 1 および 3 が、LDP SSO/NSF が設定されているルータ 2 がサービスの中断から回復するのをどのように支援するかを示しています。

1. ルータ 1 によって、ルータ 2 のサービスの中断が検出されます(ルータ 3 でも、このプロセスで同じアクションが実行されます)。

2. ルータ 1 は、ルータ 2 からのすべてのラベル バインディングを古いものとしてマークしますが、MPLS 転送には引き続きバインディングを使用します。

ルータ 1 によってルータ 2 との LDP セッションが再確立されますが、古いラベル バインディングは保持されます。 graceful-restart キーワードを指定して show mpls ldp neighbor コマンドを発行すると、コマンド出力には回復中の LDP セッションが表示されます。

3. 両方のルータがラベル バインディング情報を再アドバタイズします。セッションの再確立後にルータ 1 がルータ 2 からラベルを再び学習すると、古いフラグが削除されます。 show mpls forwarding-table コマンドでは、ローカル ラベル、発信ラベルまたは VC、プレフィクス、ラベル スイッチド バイト、発信インターフェイス、ネクストホップなど、MPLS 転送テーブル内の情報が表示されます。

さまざまなグレースフル リスタート タイマーを設定できます。詳細については、次のコマンドを参照してください。

mpls ldp graceful-restart timers neighbor-liveness

mpls ldp graceful-restart timers max-recovery

MPLS LDP グレースフル リスタートをサポートしていることをルート プロセッサがアドバタイズする方法

MPLS LDP GR を実行するように設定されたルート プロセッサは、LDP 初期化メッセージ内に Fault Tolerant(FT; フォルト トレラント)Type Length Value(TLV; タイプ、長さ、および値)を含めます。ルート プロセッサは、LDP 初期化メッセージをネイバーに送信して、LDP セッションを確立します。

FT セッション TLV には、次の情報が含まれます。

Learn from Network(L)フラグが 1 に設定されます。これは、ルート プロセッサが MPLS LDP GR を実行するように設定されていることを示します。

Reconnect Timeout フィールドは、LDP セッションが失われた場合にネイバーが再接続を待機する時間(ミリ秒単位)を示します。このリリースでは、タイマーは 0 に設定されます。これは、ローカル ルータに障害が発生した場合に、そのピアがルータの回復を待機する必要がないことを示します。タイマー設定は、ローカル ルータがヘルパー モードで動作していることを示します。

Recovery Time フィールドは、回復中にネイバーが MPLS フォワーディング ステートを保持する必要のある時間(ミリ秒単位)を示します。コントロール プレーンの再起動の前にネイバーが MPLS フォワーディング ステートを保持しなかった場合、ネイバーは回復時間を 0 に設定します。

ルート プロセッサに LDP グレースフル リスタートがない場合の動作

2 つのルート プロセッサが LDP セッションを確立し、一方のルート プロセッサで MPLS LDP GR が設定されていない場合、2 つのルート プロセッサは正常な LDP セッションを作成しますが、MPLS LDP GR を実行する能力はありません。両方のルート プロセッサで MPLS LDP GR を設定する必要があります。

MPLS LDP グレースフル リスタートの設定方法

ここでは、次の各手順について説明します。

「MPLS LDP グレースフル リスタートの設定」(必須)

「設定の確認」(任意)

MPLS LDP グレースフル リスタートの設定

サービスの中断時に LDP セッションを保持するには、すべてのルート プロセッサで MPLS LDP GR をイネーブルにする必要があります。

MPLS LDP GR がグローバルにイネーブルになります。MPLS LDP GR をイネーブルにしても、既存の LDP セッションには影響しません。確立された新しい LDP セッションは、MPLS LDP GR を実行できます。

制約事項

MPLS LDP GR は、厳格なヘルパー モードでサポートされています。

Tag Distribution Protocol(TDP; タグ配布プロトコル)セッションはサポートされていません。LDP セッションだけがサポートされています。

MPLS LDP GR は、Label-Controlled ATM(LC-ATM; ラベル制御 ATM)インターフェイス上では設定できません。

MPLS LDP SSO/NSF は、IOS Release 12.2(25)S でサポートされます。このリリースではサポートされません。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. mpls ldp graceful-restart

5. interface type slot/port

6. mpls ip

7. mpls label protocol {ldp | tdp | both}

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distributed ]

 

Router(config)# ip cef distributed

Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)をイネーブルにします。

ステップ 4

mpls ldp graceful-restart
 
Router(config)# mpls ldp graceful-restart

サービスの中断時に LDP バインディングおよび MPLS フォワーディング ステートを保護するように、ルータをイネーブルにします。

ステップ 5

interface type slot/port
 
Router(config)# interface pos 3/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

mpls ip
 

Router(config-if)# mpls ip

インターフェイスに対して MPLS ホップバイホップ転送を設定します。

ステップ 7

mpls label protocol { ldp | tdp | both }
 

Router(config-if)# mpls label protocol ldp

インターフェイスに対して LDP の使用を設定します。LDP を使用する必要があります。


) グローバル コンフィギュレーション モードで mpls label protocol ldp コマンドを発行することもできます。これにより、MPLS 用に設定されたすべてのインターフェイスで LDP がイネーブルになります。


設定の確認

次のコマンドは、MPLS LDP GR が正常に設定されていることを確認するのに役立ちます。

show mpls ldp neighbor graceful-restart キーワードを指定)

LDP セッションのグレースフル リスタート情報を表示します。

show mpls ldp graceful-restart

グレースフル リスタート セッションおよびセッション パラメータを表示します。

MPLS LDP グレースフル リスタートの設定例

図 2 に、ルータ 1 で MPLS LDP GR がイネーブルになっていて、ルータ 2 および 3 で MPLS LDP SSO/NSF がイネーブルになっている設定を示します。この設定例では、ルータ 1 によってルータ 2 との LDP セッションが作成されます。ルータ 1 は、ルータ 2 を使用したトラフィック エンジニアリング トンネルを介してルータ 3 とのターゲット セッションも作成します。


) MPLS LDP SSO/NSF は、Cisco IOS Release 12.2(25)S でサポートされます。このリリースではサポートされません。


図 2 MPLS LDP グレースフル リスタートの設定例

LDP GR が設定されたルータ 1:

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz
!
ip subnet-zero
ip cef
mpls label range 16 10000 static 10001 1048575
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 20.20.20.20 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Tunnel1
ip unnumbered Loopback0
no ip directed-broadcast
mpls label protocol ldp
mpls ip
tunnel destination 19.19.19.19
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 500
tunnel mpls traffic-eng path-option 1 dynamic
!
interface ATM5/1/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/1/0.5 point-to-point
ip address 12.0.0.2 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
pvc 6/100
encapsulation aal5snap
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth 1000
!
router ospf 100
log-adjacency-changes
redistribute connected
network 12.0.0.0 0.255.255.255 area 100
network 20.20.20.20 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 100

LDP SSO/NSF が設定されたルータ 2:

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz
!
redundancy
mode sso
!
ip cef
no ip domain-lookup
mpls label range 17 10000 static 10001 1048575
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
no mpls advertise-labels
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 17.17.17.17 255.255.255.255
no ip directed-broadcast
!
interface ATM4/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM4/0/0.5 point-to-point
ip address 12.0.0.1 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
pvc 6/100
encapsulation aal5snap
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth 1000
!
interface POS5/1/0
ip address 11.0.0.1 255.0.0.0
no ip directed-broadcast
encapsulation ppp
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
no peer neighbor-route
clock source internal
ip rsvp bandwidth 1000
!
router ospf 100
log-adjacency-changes
redistribute connected
nsf enforce global
network 11.0.0.0 0.255.255.255 area 100
network 12.0.0.0 0.255.255.255 area 100
network 17.17.17.17 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 100
!
ip classless

LDP SSO/NSF が設定されたルータ 3:

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz
!
redundancy
mode sso
!
ip subnet-zero
ip cef
!
no ip finger
no ip domain-lookup
mpls label protocol ldp
mpls ldp neighbor 11.11.11.11 targeted ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp discovery directed-hello interval 12
mpls ldp discovery directed-hello holdtime 130
mpls ldp discovery directed-hello accept
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 19.19.19.19 255.255.255.255
no ip directed-broadcast
!
interface POS1/0
ip address 11.0.0.2 255.0.0.0
no ip directed-broadcast
encapsulation ppp
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
no peer neighbor-route
clock source internal
ip rsvp bandwidth 1000
!
router ospf 100
log-adjacency-changes
redistribute connected
nsf enforce global
network 11.0.0.0 0.255.255.255 area 100
network 19.19.19.19 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 100
!
ip classless

その他の参考資料

ここでは、MPLS LDP GR に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS ラベル配布プロトコル

『MPLS Label Distribution Protocol (LDP)』

規格

規格
タイトル

なし

--

MIB

MIB1
MIB リンク

MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

1.サポートされている MIB がすべて記載されているわけではありません。

RFC

RFC2
タイトル

RFC 3036

『LDP Specification』

RFC 3478

『Graceful Restart Mechanism for Label Distribution』

2.サポートされている RFC がすべて記載されているわけではありません。

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポートおよびドキュメンテーション Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『 Cisco IOS Master Command List 』にアクセスしてください。

debug mpls ldp graceful-restart

mpls ldp graceful-restart

mpls ldp graceful-restart timers max-recovery

mpls ldp graceful-restart timers neighbor-liveness

show mpls ip binding

show mpls ldp bindings

show mpls ldp graceful-restart

show mpls ldp neighbor