マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
NSF/SSO - MPLS LDP および LDP グレース フル リスタート
NSF/SSO - MPLS LDP および LDP グレースフル リスタート
発行日;2012/01/31 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

NSF/SSO - MPLS LDP および LDP グレースフル リスタート

目次

NSF/SSO - MPLS LDP および LDP グレースフル リスタートの前提条件

NSF/SSO - MPLS LDP および LDP グレースフル リスタートに関する制約事項

NSF/SSO - MPLS LDP および LDP グレースフル リスタートに関する情報

NSF/SSO - MPLS LDP および LDP グレースフル リスタートの動作方法

LDP リスタートおよび LDP セッション リセット中の動作

ルート プロセッサが NSF/SSO - MPLS LDP および LDP グレースフル リスタートをサポートしていることをアドバタイズする方法

ルート プロセッサに LDP グレースフル リスタートが設定されていない場合の動作

チェックポインティング

トラブルシューティングのヒント

NSF/SSO - MPLS LDP および LDP グレースフル リスタートの設定方法および使用方法

MPLS LDP グレースフル リスタートの設定

前提条件

設定の確認

の設定例

NSF/SSO - MPLS LDP および LDP グレースフル リスタートの設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

NSF/SSO - MPLS LDP および LDP グレースフル リスタートに関する機能情報

NSF/SSO - MPLS LDP および LDP グレースフル リスタート

ステートフル スイッチオーバー機能を備えた Cisco ノンストップ フォワーディングにより、ネットワーク プロセッサ ハードウェアまたはソフトウェアで障害が発生している間でも、パケット転送を継続できます。冗長システムでは、プライマリ プロセッサで重大な障害が発生している間、セカンダリ プロセッサにより、コントロール プレーン サービスが回復されます。SSO は、プライマリ プロセッサとセカンダリ プロセッサの間でネットワーク ステート情報を同期します。

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Label Distribution Protocol(LDP; ラベル配布プロトコル)は、SSO、NSF、およびグレースフル リスタートを使用して、ルート プロセッサが、MPLS フォワーディング ステートを失うことなく、コントロール プレーン サービス(特に LDP コンポーネント)の中断から回復できるようにします。LDP NSF は、直接接続されているピアと直接接続されていないピアの間の LDP セッション(ターゲット セッション)を処理します。


) このマニュアルでは、NSF/SSO - MPLS LDP および LDP グレースフル リスタート機能を、短縮して LDP NSF と呼びます。


この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。 このモジュールに記載されている機能に関するドキュメントへのリンク、および各機能がサポートされているリリースに関するリストについては、「NSF/SSO - MPLS LDP および LDP グレースフル リスタートに関する機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

NSF/SSO - MPLS LDP および LDP グレースフル リスタートの前提条件

サポートされているハードウェアの詳細については、ご使用のプラットフォームのリリース ノートを参照してください。

MPLS High Availability(HA; ハイ アベイラビリティ)では、ネイバー ネットワーキング デバイスが NSF 認識デバイスである必要があります。

LDP NSF を実行するには、ルート プロセッサに SSO が設定されている必要があります。詳細については、「 Stateful Switchover 」の機能の章を参照してください。

Provider(P; プロバイダー)ルータ、Provider Edge(PE; プロバイダー エッジ)ルータ、および Customer Edge(CE; カスタマー エッジ)ルータの間で実行されるルーティング プロトコルに対して、ノンストップ フォワーディングをイネーブルにする必要があります。ルーティング プロトコルを以下に示します。

Border Gateway Protocol(BGP)

Open Shortest Path First(OSPF)

Intermediate System-to-Intermediate System(IS-IS)

詳細については、「 Cisco Nonstop Forwarding 」の機能の章を参照してください。

NSF/SSO - MPLS LDP および LDP グレースフル リスタートに関する制約事項

LDP NSF には、次の制約事項があります。

Tag Distribution Protocol(TDP; タグ配布プロトコル)セッションはサポートされていません。LDP セッションだけがサポートされています。

LDP NSF は、Label-Controlled ATM(LC-ATM; ラベル制御 ATM)インターフェイス上では設定できません。

NSF/SSO - MPLS LDP および LDP グレースフル リスタートに関する情報

LDP NSF を設定するには、次の概念を理解する必要があります。

「NSF/SSO - MPLS LDP および LDP グレースフル リスタートの動作方法」

「ルート プロセッサが NSF/SSO - MPLS LDP および LDP グレースフル リスタートをサポートしていることをアドバタイズする方法」

「チェックポインティング」

NSF/SSO - MPLS LDP および LDP グレースフル リスタートの動作方法

LDP NSF により、ルート プロセッサは、MPLS フォワーディング ステートを失うことなく、サービスの中断から回復できます。LDP NSF は、次の状況で動作します。

LDP リスタート LDP リスタートは、SSO イベントにより、すべての LDP ネイバーとの LDP 通信が中断されたあとに実行されます。ルート プロセッサに LDP NSF が設定されている場合、バックアップ ルート プロセッサが MPLS フォワーディング ステートを保持し、LDP ネイバーとの通信を再確立します。次に、ルート プロセッサにより、MPLS フォワーディング ステートが回復されます。

LDP セッションのリセット LDP セッションのリセットは、SSO イベント以外の原因により個々の LDP セッションが中断されたあとに実行されます。LDP セッションは、TCP または UDP の通信問題が原因で中断される場合があります。ルート プロセッサに MPLS LDP NSF サポートおよびグレースフル リスタートが設定されている場合、ルート プロセッサは、新しいセッションを、前に中断されたセッションに関連付けます。新しいセッションが確立されると、LDP バインディングおよび MPLS フォワーディング ステートが回復されます。

LSR で SSO イベントが発生した場合、その LSR は LDP リスタートを実行します。隣接する LSR は、LDP セッションのリセットを実行します。

LDP のリスタートおよびリセットの詳細については、次の項を参照してください。

LDP リスタートおよび LDP セッション リセット中の動作

図 1 に示すトポロジでは、次の要素が設定されています。

LDP セッションが、ルータ 1 とルータ 2 の間、およびルータ 2 とルータ 3 の間で確立されています。

Label Switched Path(LSP; ラベル スイッチド パス)が、ルータ 1 とルータ 3 の間に確立されています。

ルータには LDP NSF が設定されています。

図 1 LDP グレースフル リスタートを使用したネットワークの例

次のプロセスは、ルータの 1 つで障害が発生した場合に、LDP がどのように回復するかを示しています。

1. ルータ 2 でルート プロセッサに障害が発生すると、ルータ間の通信が中断されます。

2. ルータ 1 とルータ 3 は、ルータ 2 からのすべてのラベル バインディングを stale とマークし、一方で MPLS フォワーディングのためにそのバインディングを引き続き使用します。

3. ルータ 1 とルータ 3 は、ルータ 2 との LDP セッションを再確立しようとします。

4. ルータ 2 は、そのすべてのフォワーディング エントリをリスタートし、stale とマークします。 show mpls ldp graceful-restart コマンドを発行すると、コマンド出力には次の行が含まれます。

LDP is restarting gracefully.
 

5. ルータ 1 とルータ 3 は、ルータ 2 との LDP セッションを再確立しますが、stale ラベル バインディングを保持します。 graceful-restart キーワードを指定して show mpls ldp neighbor コマンドを発行すると、コマンド出力には回復中の LDP セッションが表示されます。

6. 3 つすべてのルータが、それぞれのラベル バインディング情報を再アドバタイズします。セッションが確立されたあと、ラベルが再学習され、stale フラグが削除されます。 show mpls forwarding-table コマンドでは、ローカル ラベル、発信ラベルまたは VC、プレフィクス、ラベル スイッチド バイト、発信インターフェイス、ネクストホップなど、MPLS 転送テーブル内の情報が表示されます。

各種タイマー設定することで、ルータの再起動前に、LDP セッションが再確立されるのを待機する時間を制限できます。詳細については、次のコマンドを参照してください。

mpls ldp graceful-restart timers forwarding-holding

mpls ldp graceful-restart timers max-recovery

mpls ldp graceful-restart timers neighbor-liveness

ルート プロセッサが NSF/SSO - MPLS LDP および LDP グレースフル リスタートをサポートしていることをアドバタイズする方法

LDP NSF を実行するように設定されたルート プロセッサは、LDP 初期化メッセージ内に Fault Tolerant(FT; フォルト トレラント)Type Length Value(TLV; タイプ、長さ、値)を含めます。ルート プロセッサは、LDP 初期化メッセージをネイバーに送信して、LDP セッションを確立します。

FT セッション TLV には、次の情報が含まれます。

Learn from Network(L)フラグが 1 に設定されます。これは、ルート プロセッサが LDP グレースフル リスタートを実行するように設定されていることを示します。

Reconnect Timeout フィールドは、LDP セッションが失われた場合にネイバーが再接続を待機する時間(ミリ秒単位)を示します。このフィールドは 120 秒に設定され、再設定できません。

Recovery Time フィールドは、回復中にネイバーが MPLS フォワーディング ステートを保持する必要のある時間(ミリ秒単位)を示します。コントロール プレーンの再起動の前にネイバーが MPLS フォワーディング ステートを保持しなかった場合、ネイバーは回復時間を 0 に設定します。

ルート プロセッサに LDP グレースフル リスタートが設定されていない場合の動作

MPLS LDP グレースフル リスタートが設定されていないルート プロセッサが、LDP グレースフル リスタートが設定されているルート プロセッサと LDP セッションを確立しようとすると、次のエラーが発生します。

1. MPLS LDP グレースフル リスタートが設定されているルート プロセッサは、FT セッション TLV 値を含む初期化メッセージを、MPLS LDP グレースフル リスタートが設定されていないルート プロセッサに送信します。

2. MPLS LDP グレースフル リスタートが設定されていないルート プロセッサは、LDP 初期化メッセージを受け取ると、FT セッション TLV を廃棄します。

3. 2 つのルート プロセッサは通常の LDP セッションを作成しますが、MPLS LDP グレースフル リスタートは実行できません。

サービスの中断時に LDP セッションを保持するには、すべてのルート プロセッサで MPLS LDP グレースフル リスタートをイネーブルにする必要があります。

チェックポインティング

チェックポインティングは、アクティブ ルート プロセッサからバックアップ ルート プロセッサにステート情報をコピーする機能です。これにより、バックアップ ルート プロセッサは最新情報を入手できます。アクティブ ルート プロセッサで障害が発生した場合、バックアップ ルート プロセッサが処理を引き継ぎます。

LDP NSF 機能では、チェックポインティング機能により、アクティブ ルート プロセッサの LDP ローカル ラベル バインディングがバックアップ ルート プロセッサにコピーされます。ルーティングの変更の結果としてローカル ラベル バインディングが変更されると、アクティブ ルート プロセッサはバックアップ ルート プロセッサに更新を送信します。


) BGP により割り当てられるローカル ラベル バインディング、およびヌル ローカル ラベル バインディングは、チェックポインティング操作には関係しません。


チェックポインティング機能は、デフォルトではイネーブルになっています。

チェックポインティング データを表示するには、アクティブ ルート プロセッサに対し show mpls ldp graceful-restart コマンドを発行します。

アクティブ ルート プロセッサとバックアップ ルート プロセッサが、ローカル ラベル バインディングの同一コピーを所有していることを確認するには、アクティブ ルート プロセッサおよびバックアップ ルート プロセッサに対し、 detail キーワードを指定した show mpls ldp bindings コマンドを発行します。このコマンドにより、保存されているローカル ラベル バインディングが表示されます。アクティブ ルート プロセッサとバックアップ ルート プロセッサは、同一のローカル ラベル バインディングを所有している必要があります。

トラブルシューティングのヒント

debug mpls ldp graceful-restart コマンドを使用すると、MPLS LDP チェックポイント イベントおよびエラーの表示をイネーブルにできます。

NSF/SSO - MPLS LDP および LDP グレースフル リスタートの設定方法および使用方法

「MPLS LDP グレースフル リスタートの設定」(必須)

「設定の確認」(任意)

MPLS LDP グレースフル リスタートの設定

MPLS LDP Graceful Restart(GR; グレースフル リスタート)はグローバルにイネーブルになります。LDP GR をイネーブルにしても、既存の LDP セッションには影響しません。LDP GR は、機能がグローバルにイネーブルにされたあとに確立される新しいセッションに対してイネーブルです。

前提条件

ルート プロセッサは SSO で設定する必要があります。詳細については、「 Stateful Switchover 」の機能の章を参照してください。

P、PE、ルータ、および CE ルータの間で実行されるルーティング プロトコルに対して、ノンストップ フォワーディングをイネーブルにする必要があります。詳細については、「 Cisco Nonstop Forwarding 」の機能の章を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. mpls ldp graceful-restart

5. interface type slot / port

6. mpls ip

7. mpls label protocol { ldp | tdp | both }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distributed ]

 

Router(config)# ip cef distributed

Cisco 7500 シリーズ ルータで分散シスコ エクスプレス フォワーディングをイネーブルにします。シスコ エクスプレス フォワーディング情報をライン カードに配布します。

(注) Cisco 10000 シリーズ ルータでは、IP シスコ エクスプレス フォワーディングはデフォルトでオンになっており、ディセーブルにできません。

ステップ 4

mpls ldp graceful-restart

 
Router (config)# mpls ldp graceful-restart

サービスの中断時に LDP バインディングおよび MPLS フォワーディング ステートを保護するように、ルータをイネーブルにします。

ステップ 5

interface type slot / port

 
Router(config)# interface pos 3/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

mpls ip

 

Router(config-if)# mpls ip

インターフェイスに対して MPLS ホップバイホップ転送を設定します。

ステップ 7

mpls label protocol { ldp | tdp | both }

 

Router(config-if)# mpls label protocol ldp

インターフェイスに対して LDP の使用を設定します。LDP を使用する必要があります。グローバル コンフィギュレーション モードで mpls label protocol ldp コマンドを発行することもできます。これにより、MPLS 用に設定されたすべてのインターフェイスで LDP がイネーブルになります。

設定の確認

MPLS LDP グレースフル リスタートが正しく設定されていることを確認するには、次の手順を使用します。

手順の概要

1. show mpls ldp graceful-restart

2. show mpls ldp neighbor graceful restart

3. show mpls ldp checkpoint

手順の詳細


ステップ 1 show mpls ldp graceful-restart

このコマンドの出力には、グレースフル リスタート セッションおよびセッション パラメータが表示されます。

Router# show mpls ldp graceful-restart
 
LDP Graceful Restart is enabled
Neighbor Liveness Timer: 5 seconds
Max Recovery Time: 200 seconds
Down Neighbor Database (0 records):
Graceful Restart-enabled Sessions:
VRF default:
 
Peer LDP Ident: 10.18.18.18:0, State: estab
Peer LDP Ident: 10.17.17.17:0, State: estab
 

ステップ 2 show mpls ldp neighbor graceful restart

このコマンドの出力には、LDP セッションのグレースフル リスタート情報が表示されます。

Router# show mpls ldp neighbor graceful-restart
 
Peer LDP Ident: 10.20.20.20:0; Local LDP Ident 10.17.17.17:0
TCP connection: 10.20.20.20.16510 - 10.17.17.17.646
State: Oper; Msgs sent/rcvd: 8/18; Downstream
Up time: 00:04:39
Graceful Restart enabled; Peer reconnect time (msecs): 120000
Peer LDP Ident: 10.19.19.19:0; Local LDP Ident 10.17.17.17:0
TCP connection: 10.19.19.19.11007 - 10.17.17.17.646
State: Oper; Msgs sent/rcvd: 8/38; Downstream
Up time: 00:04:30
Graceful Restart enabled; Peer reconnect time (msecs): 120000
 

ステップ 3 show mpls ldp checkpoint

このコマンドの出力には、チェックポイント情報の概要が表示されます。

Router# show mpls ldp checkpoint
 
Checkpoint status: dynamic-sync
Checkpoint resend timer: not running
5 local bindings in add-skipped
9 local bindings in added
1 of 15+ local bindings in none

LDP NSF の設定例

ここでは、次の例について説明します。

「NSF/SSO - MPLS LDP および LDP グレースフル リスタートの設定:例」

NSF/SSO - MPLS LDP および LDP グレースフル リスタートの設定:例

次の設定例は、LDP NSF 機能が設定された 3 つのルータを示しています(図 2を参照)。この設定例では、ルータ 1 がルータ 2 との LDP セッションを作成します。またルータ 1 は、ルータ 2 を使用して、TE トンネルを通じてルータ 3 とのターゲット セッションを作成します。

図 2 MPLS LDP:NSF/SSO サポートおよびグレースフル リスタートの設定例

ルータ 1:Cisco 7500 シリーズ

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz
 
redundancy
mode sso
ip subnet-zero
ip cef
mpls label range 16 10000 static 10001 1048575
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 172.20.20.20 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Tunnel1
ip unnumbered Loopback0
no ip directed-broadcast
mpls label protocol ldp
mpls ip
tunnel destination 10.19.19.19
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 500
tunnel mpls traffic-eng path-option 1 dynamic
!
interface ATM5/1/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/1/0.5 point-to-point
ip address 172.17.0.2 255.255.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
pvc 6/100
encapsulation aal5snap
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth 1000
!
router ospf 100
log-adjacency-changes
redistribute connected
nsf enforce global
network 172.17.0.0 0.255.255.255 area 100
network 172.20.20.20 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 100

ルータ 2:Cisco 7500 シリーズ

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz
 
redundancy
mode sso
!
ip cef
no ip domain-lookup
mpls label range 17 10000 static 10001 1048575
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
no mpls advertise-labels
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 172.18.17.17 255.255.255.255
no ip directed-broadcast
!
interface ATM4/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM4/0/0.5 point-to-point
ip address 172.17.0.1 255.255.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
pvc 6/100
encapsulation aal5snap
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth 1000
!
interface POS5/1/0
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
encapsulation ppp
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
no peer neighbor-route
clock source internal
ip rsvp bandwidth 1000
!
router ospf 100
log-adjacency-changes
nsf enforce global
redistribute connected
network 10.0.0.0 0.255.255.255 area 100
network 172.17.0.0 0.255.255.255 area 100
network 172.18.17.17 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 100
!
ip classless

ルータ 3:Cisco 7500 シリーズ

boot system slot0:rsp-pv-mz
hw-module slot 2 image slot0:rsp-pv-mz
hw-module slot 3 image slot0:rsp-pv-mz
 
redundancy
mode sso
!
ip subnet-zero
ip cef
!
no ip finger
no ip domain-lookup
mpls label protocol ldp
mpls ldp neighbor 10.11.11.11 targeted ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp discovery directed-hello interval 12
mpls ldp discovery directed-hello holdtime 130
mpls ldp discovery directed-hello accept
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 172.19.19.19 255.255.255.255
no ip directed-broadcast
!
interface POS1/0
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
encapsulation ppp
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
no peer neighbor-route
clock source internal
ip rsvp bandwidth 1000
!
router ospf 100
log-adjacency-changes
nsf enforce global
redistribute connected
network 10.0.0.0 0.255.255.255 area 100
network 172.19.19.19 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 100
!
ip classless
 

ルータ 1:Cisco 10000 シリーズ

boot system flash:c10k2-p11-mz
 
redundancy
mode sso
ip subnet-zero
ip cef
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 172.20.20.20 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface ATM5/1/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/1/0.5 point-to-point
ip address 172.18.0.2 255.255.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
pvc 6/100
encapsulation aal5snap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
redistribute connected
nsf enforce global
network 172.18.0.0 0.255.255.255 area 100
network 172.20.20.20 0.0.0.0 area 100

ルータ 2:Cisco 10000 シリーズ

boot system flash:c10k2-p11-mz
 
redundancy
mode sso
!
ip cef
no ip domain-lookup
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 172.17.17.17 255.255.255.255
no ip directed-broadcast
!
interface ATM4/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM4/0/0.5 point-to-point
ip address 172.18.0.1 255.255.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
pvc 6/100
encapsulation aal5snap
mpls label protocol ldp
mpls ip
!
interface POS5/1/0
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
encapsulation ppp
mpls label protocol ldp
mpls ip
no peer neighbor-route
clock source internal
!
router ospf 100
log-adjacency-changes
nsf enforce global
redistribute connected
network 10.0.0.0 0.255.255.255 area 100
network 172.18.0.0 0.255.255.255 area 100
network 172.17.17.17 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
!
ip classless

ルータ 3:Cisco 10000 シリーズ

boot system flash:c10k2-p11-mz
 
redundancy
mode sso
!
ip subnet-zero
ip cef
!
no ip finger
no ip domain-lookup
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 172.19.19.19 255.255.255.255
no ip directed-broadcast
!
interface POS1/0
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
encapsulation ppp
mpls label protocol ldp
mpls ip
no peer neighbor-route
clock source internal
!
router ospf 100
log-adjacency-changes
nsf enforce global
redistribute connected
network 10.0.0.0 0.255.255.255 area 100
network 172.19.19.19 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
!
ip classless

その他の参考資料

次の項では、NSF/SSO - MPLS LDP および LDP グレースフル リスタート機能に関する関連資料について説明します。

関連資料

関連項目
参照先

ステートフル スイッチオーバー

『Stateful Switchover』

MPLS ラベル配布プロトコル

MPLS Label Distribution Protocol (LDP)

Cisco ノンストップ フォワーディング

Cisco Nonstop Forwarding

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 3478

『Graceful Restart Mechanism for Label Distribution』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。サービス契約が有効で、ログイン ID またはパスワードを取得していない場合は、Cisco.com でまず登録手続きを行ってください。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にあるコマンド検索ツールを使用するか、または『 Cisco IOS Master Command List 』を参照してください。

debug mpls ldp graceful-restart

mpls label protocol(グローバル コンフィギュレーション)

mpls ldp graceful-restart

mpls ldp graceful-restart timers forwarding-holding

mpls ldp graceful-restart timers max-recovery

mpls ldp graceful-restart timers neighbor-liveness

show mpls ip binding

show mpls ldp bindings

show mpls ldp checkpoint

show mpls ldp graceful-restart

show mpls ldp neighbor

NSF/SSO - MPLS LDP および LDP グレースフル リスタートに関する機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 NSF/SSO - MPLS LDP および LDP グレースフル リスタートに関する機能情報

機能名
リリース
機能情報

NSF/SSO - MPLS LDP および LDP グレースフル リスタート

12.2(25)S
12.2(28)SB
12.2(33)SRA
12.2(33)SXH

LDP NSF により、ルート プロセッサは、MPLS フォワーディング ステートを失うことなく、サービスの中断から回復できます。

この機能は、12.2(25)S で Cisco 7500 シリーズ ルータに導入されました。

この機能は、12.2(28)SB で Cisco IOS Release 12.2(28)SB に統合され、Cisco 10000 シリーズ ルータで実装されました。

この機能は、12.2(33)SRA で Cisco IOS Release 12.2(33)SRA に統合されました。

この機能は、12.2(33)SXH で Cisco IOS Release 12.2(33)SXH に統合されました。