マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
L2VPN 擬似回線スイッチング
L2VPN 擬似回線スイッチング
発行日;2012/01/30 | 英語版ドキュメント(2011/07/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

L2VPN 擬似回線スイッチング

機能情報の確認

目次

の前提条件

に関する制約事項

について

の機能

集約ポイントでのパケットの操作方法

の設定方法

前提条件

制約事項

の設定例

Inter-AS 設定での :例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

L2VPN 擬似回線スイッチング

この章では、Interautonomous System(Inter-AS; 相互自律システム)の境界線、または 2 つの異なる Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークをまたいで、Layer 2 Virtual Private Network(L2VPN; レイヤ 2 バーチャル プライベート ネットワーク)擬似回線を拡張する L2VPN 擬似回線スイッチングの設定方法を説明します。この機能は、ATM および Time-Division Multiplexing(TDM; 時分割多重)Attachment Circuit(AC; 接続回線)、およびイーサネット AC をサポートします。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「L2VPN 擬似回線スイッチングの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

L2VPN 擬似回線スイッチングの前提条件

Cisco 12000 シリーズ ルータでは、Any Transport over MPLS(AToM)に対応した L2VPN 擬似回線スイッチング機能は次のエンジンでサポートされています。

E2

E3

E4+

E5

E6

この機能をサポートしていないエンジンでは、パケットはソフトウェアに送信され、スロー パス経由で転送されます。


) エンジン E1 と E4 は、スロー パスでも L2VPN 擬似回線スイッチングをサポートしていません。


L2VPN 擬似回線スイッチングに関する制約事項

L2VPN 擬似回線スイッチングは、AToM でサポートされています。

スタティックなオンボックス プロビジョニングだけがサポートされます。

AToM パケットのシーケンス番号は L2VPN 擬似回線スイッチングでは処理されません。この機能は連続するデータを、透過的優先順位付けと呼ばれる処理、xconnect パケット パス経由でそのまま渡します。エンドポイントの Provider Edge(PE; プロバイダー エッジ)から Customer Edge(CE; カスタマー エッジ)への接続は、この順序付けを強制します。

隣接するネクストホップ PE ルータを ping できます。エンドツーエンド Label Switched Path(LSP; ラベル スイッチド パス)の ping はサポートされていません。

L2VPN 擬似回線スイッチングがイネーブルにされているルータでは、IP またはイーサネット インターワーキングを設定しないでください。代わりに、ネットワークのエッジ PE にあるルータでインターワーキングを設定します。

コントロール ワード ネゴシエーションの結果は一致する必要があります。いずれかのセグメントがコントロール ワードのネゴシエーションを行わない場合、このコントロール ワードは両方のセグメントでディセーブルになります。

AToM グレースフル リスタートは、個々の擬似回線セグメントで個別にネゴシエーションされます。2 つの AToM PE ルータの間で、Label Distribution Protocol(LDP; ラベル配布プロトコル)セッションが一時的に途切れた場合でも、パケットのフローは継続します。

擬似回線単位の Quality of Service(QoS)はサポートされていません。Traffic Engineering(TE; トラフィック エンジニアリング)トンネルの選択はサポートされています。

接続回線インターワーキングはサポートされていません。

L2VPN 擬似回線スイッチングについて

L2VPN 擬似回線スイッチング機能を設定するには、次の概念を理解しておく必要があります。

「L2VPN 擬似回線スイッチングの機能」

「L2VPN 擬似回線スイッチング集約ポイントでのパケットの操作方法」

L2VPN 擬似回線スイッチングの機能

L2VPN 擬似回線スイッチングでは、図 1、および図 2 に示すとおり、ユーザは 2 つの異なる MPLS ネットワーク、または Inter-AS 境界をまたいで L2VPN 擬似回線を拡張することができます。

L2VPN 擬似回線スイッチングは、複数の近接する擬似回線セグメントを接続して、エンドツーエンドのマルチホップ擬似回線を形成します。このエンドツーエンド擬似回線は、単一のポイントツーポイント擬似回線として機能します。

図 2 に示すとおり、L2VPN 擬似回線スイッチングにより、Inter-AS 境界線をまたいで、エッジ PE ルータの IP アドレスを秘密にしておくことができるようになります。Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)の IP アドレスを使用して、これらを Pseudowire Aggregation(PE-agg)ルータとして扱うことができます。ASBR は 2 つのドメインにある擬似回線を結合します。

また、L2VPN 擬似回線スイッチングにより、エンドツーエンド サービスを管理するために、さまざまな管理ドメインやプロビジョニング ドメインを維持することもできるようになります。管理責任は、これらのネットワークの境界線で PE-agg ルータによりはっきりと線引きされます。

図 1 Intra-AS トポロジの L2VPN 擬似回線スイッチング

 

図 2 Inter-AS トポロジの L2VPN 擬似回線スイッチング

L2VPN 擬似回線スイッチング集約ポイントでのパケットの操作方法

2 つの AToM 擬似回線間での AToM パケットの切り替えは、MPLS パケットの切り替えと同じです。MPLS 切り替えデータ パスは、2 つの AToM 擬似回線の間で AToM パケットを切り替えます。ただし、次のような例外もあります。

パケット内の受信 VC ラベルは、発信 Virtual Circuit(VC; 仮想回線)ラベルで置き換えられます。新しい Internal Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)ラベルとレイヤ 2 カプセル化が追加されます。

受信 VC ラベルの Time-to-Live(TTL; 存続可能時間)フィールドの値が 1 つ減らされ、発信 VC ラベル TTL フィールドにコピーされます。

受信 VC ラベルの EXP 値が、発信 VC ラベルの EXP フィールドにコピーされます。

発信 VC ラベル内の発信 VC ラベルの「Bottom of Stack」S ビットが 1 に設定されます。

AToM コントロール ワード処理が L2VPN 擬似回線スイッチング集約ポイントで行われません。シーケンス番号は検証されません。LSP ping には、ルータ アラート ラベルを使用します。LSP ping パケットの判断に、コントロール ワード インスペクションを要求してはいけません。

L2VPN 擬似回線スイッチングの設定方法

個々の PE-agg ルータで L2VPN 擬似回線スイッチングを設定するには、次の手順を実行します。

前提条件

この手順は、基本的な AToM L2VPN がすでに設定されていることを前提にしています。この手順では、MPLS バックボーン経由でレイヤ 2 パケットをトランスポートする基本的な AToM L2VPN の設定方法は説明しません。基本設定の詳細については、『 Any Transport over MPLS 』を参照してください。

相互自律の設定で使用するために、ASBR では、ラベル付きインターフェイスが必要です。

制約事項

この設定では、 l2 vfi コマンド入力後の neighbor コマンドは 2 個に制限されます。

手順の概要

1. enable

2. configure terminal

3. l2 vfi name point-to-point

4. neighbor ip-address vcid [ encapsulation mpls | pw-class pw-class-name ]

5. exit

6. exit

7. show mpls l2transport vc [ vcid [ vc-id | vc-id-min vc-id-max ]] [ interface name [ local-circuit-id ]] [ destination ip-address | name ] [ detail ]

8. show vfi [ vfi-name ]

9. ping [ protocol ] [ tag ] { host-name | system-address }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

l2 vfi name point-to-point

 

Router(config)# l2 vfi atomtunnel point-to-point

ポイントツーポイント レイヤ 2 Virtual Forwarding Interface(VFI)を作成し、VFI コンフィギュレーション モードを開始します。

ステップ 4

neighbor ip-address vcid [ encapsulation mpls | pw-class pw-class-name]

 

Router(config-vfi)# neighbor 10.0.0.1 100 pw-class mpls

エミュレートされる VC を設定します。

リモート ルータの IP アドレスと VC ID を指定します。

また、エミュレートされた VC で使用する擬似回線クラスを指定します。

コマンドは 2 つのみです。

ステップ 5

exit

 

Router(config-vfi)# exit

VFI コンフィギュレーション モードを終了します。

ステップ 6

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 7s

show mpls l2transport vc [ vcid [ vc-id | vc-id-min vc-id-max ]] [ interface name [ local-circuit-id ]] [ destination ip-address | name ] [ detail ]
 
Router# show mpls l2transport vc

L2VPN 擬似回線スイッチング セッションが確立されたことを検証します。

ステップ 8

show vfi [ vfi-name ]
 
Router# show vfi atomtunnel

ポイントツーポイント VFI が確立されたことを検証します。

ステップ 9

ping [ protocol ] [ tag ] { host-name | system-address }
 
Router# ping 10.1.1.1

CE ルータから発行した場合は、エンドツーエンドの接続を検証します。

次に、 show mpls l2transport vc コマンドからの出力例を示します。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ----- ----
MPLS PW 10.0.1.1:100 10.0.1.1 100 UP
MPLS PW 10.0.1.1:100 10.0.1.1 100 UP
 

次は、 show vfi コマンドからの出力例を示します。

Router# show vfi
 
VFI name: test, type: point-to-point
Neighbors connected via pseudowires:
Router ID Pseudowire ID
10.0.1.1 100
10.0.1.1 100

L2VPN 擬似回線スイッチングの設定例

ここでは、次の設定例について説明します。

「Inter-AS 設定での L2VPN 擬似回線スイッチング:例」

Inter-AS 設定での L2VPN 擬似回線スイッチング:例

2 つの PE-agg ルータが L2VPN 擬似回線スイッチングを使って設定されているため、2 つの異なる自律システムで L2VPN パケットを渡すことができます。この設定例を 図 3 に示します。

図 3 相互自律システムでの L2VPN 擬似回線スイッチング

PE-agg-1
PE-agg-2

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname [pe-agg1]

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$Q0Bb$32sIU82pHRgyddWaeB4zs/

!

ip subnet-zero

ip cef

no ip domain-lookup

mpls label protocol ldp

pseudowire-class SW-PW

encapsulation mpls

!

l2 vfi PW-SWITCH-1 point-to-point

neighbor 172.17.255.3 100 pw-class SW-PW

neighbor 172.16.255.1 16 pw-class SW-PW

!

interface Loopback0

ip address 172.16.255.3 255.255.255.255

no ip directed-broadcast

!

interface Serial0/0

ip address 172.16.0.6 255.255.255.252

no ip directed-broadcast

mpls ip

!

interface Serial1/0

ip address 192.168.0.1 255.255.255.252

no ip directed-broadcast

mpls bgp forwarding

!

router ospf 16

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0

!

router bgp 65016

no synchronization

bgp log-neighbor-changes

network 172.16.255.3 mask 255.255.255.255

neighbor 192.168.0.2 remote-as 65017

neighbor 192.168.0.2 send-label

no auto-summary

!

ip classless

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

no cns aaa enable

end

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname [pe-agg2]

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$32jd$zQRfxXzjstr4llV9DcWf7/

!

ip subnet-zero

ip cef

no ip domain-lookup

mpls label protocol ldp

pseudowire-class SW-PW

encapsulation mpls

!

l2 vfi PW-SWITCH-1 point-to-point

neighbor 172.16.255.3 100 pw-class SW-PW

neighbor 172.17.255.1 17 pw-class SW-PW

!

interface Loopback0

ip address 172.17.255.3 255.255.255.255

no ip directed-broadcast

!

interface Serial0/0

ip address 172.17.0.6 255.255.255.252

no ip directed-broadcast

mpls ip

!

interface Serial1/0

ip address 192.168.0.2 255.255.255.252

no ip directed-broadcast

mpls bgp forwarding

!

router ospf 17

log-adjacency-changes

network 172.17.0.0 0.0.255.255 area 0

!

router bgp 65017

no synchronization

bgp log-neighbor-changes

network 172.17.255.3 mask 255.255.255.255

neighbor 192.168.0.1 remote-as 65016

neighbor 192.168.0.1 send-label

no auto-summary

!

ip classless

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

no cns aaa enable

end

A-P1
B-P1

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname [a-p1]

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$eiUn$rTMnZiYnJxtMTpO0NKpQQ/

!

ip subnet-zero

ip cef

no ip domain-lookup

mpls label protocol ldp

!

interface Loopback0

ip address 172.16.255.2 255.255.255.255

no ip directed-broadcast

!

interface Serial0/0

ip address 172.16.0.5 255.255.255.252

no ip directed-broadcast

mpls ip

!

interface Serial1/0

ip address 172.16.0.2 255.255.255.252

no ip directed-broadcast

mpls ip

!

router ospf 16

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0

!

ip classless

!

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

no cns aaa enable

end

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname [b-p1]

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$svU/$2JmJZ/5gxlW4nVXVniIJe1

!

ip subnet-zero

ip cef

no ip domain-lookup

mpls label protocol ldp

!

interface Loopback0

ip address 172.17.255.2 255.255.255.255

no ip directed-broadcast

!

interface Serial0/0

ip address 172.17.0.5 255.255.255.252

no ip directed-broadcast

mpls ip

!

interface Serial1/0

ip address 172.17.0.2 255.255.255.252

no ip directed-broadcast

mpls ip

!

router ospf 17

log-adjacency-changes

network 172.17.0.0 0.0.255.255 area 0

!

ip classless

!

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

no cns aaa enable

end

PE1
PE2

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname [pe1]

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$9z8F$2A1/YLc6NB6d.WLQXF0Bz1

!

ip subnet-zero

ip cef

no ip domain-lookup

mpls label protocol ldp

pseudowire-class ETH-PW

encapsulation mpls

!

interface Loopback0

ip address 172.16.255.1 255.255.255.255

no ip directed-broadcast

!

interface Ethernet0/0

no ip address

no ip directed-broadcast

no cdp enable

xconnect 172.16.255.3 16 pw-class ETH-PW

!

interface Serial1/0

ip address 172.16.0.1 255.255.255.252

no ip directed-broadcast

mpls ip

!

router ospf 16

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0

!

ip classless

!

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

no cns aaa enable

end

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname [pe2]

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$rT.V$8Z6Dy/r8/eaRdx2TR/O5r/

!

ip subnet-zero

ip cef

no ip domain-lookup

mpls label protocol ldp

pseudowire-class ETH-PW

encapsulation mpls

!

interface Loopback0

ip address 172.17.255.1 255.255.255.255

no ip directed-broadcast

!

interface Ethernet0/0

no ip address

no ip directed-broadcast

no cdp enable

xconnect 172.17.255.3 17 pw-class ETH-PW

!

interface Serial1/0

ip address 172.17.0.1 255.255.255.252

no ip directed-broadcast

mpls ip

!

router ospf 17

log-adjacency-changes

network 172.17.0.0 0.0.255.255 area 0

!

ip classless

!

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

no cns aaa enable

end

CE1
CE2

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname [ce1]

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$o9N6$LSrxHufTn0vjCY0nW8hQX.

!

ip subnet-zero

ip cef

no ip domain-lookup

!

interface Ethernet0/0

ip address 10.0.0.1 255.255.255.252

no ip directed-broadcast

!

ip classless

!

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

no cns aaa enable

end

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname [ce2]

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$YHo6$LQ4z5PdrF5B9dnL75Xvvm1

!

ip subnet-zero

ip cef

no ip domain-lookup

!

interface Ethernet0/0

ip address 10.0.0.2 255.255.255.252

no ip directed-broadcast

!

ip classless

!

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

no cns aaa enable

end

その他の参考資料

ここでは、L2VPN 擬似回線スイッチング に関する関連資料について説明します。

関連資料

関連項目
参照先

Any Transport over MPLS

『Any Transport over MPLS』

擬似回線冗長性

『L2VPN Pseudowire Redundancy』

AToM のハイ アベイラビリティ

『AToM Graceful Restart』

L2VPN インターワーキング

『L2VPN Interworking』

レイヤ 2 ローカル スイッチング

『Layer 2 Local Switching』

PWE3 MIB

『Pseudowire Emulation Edge-to-Edge MIBs for Ethernet and Frame Relay Services』

パケット シーケンス

『Any Transport over MPLS (AToM) Sequencing Support』

規格

規格
タイトル

draft-ietf-pwe3-control-protocol-14.txt

『Pseudowire Setup and Maintenance using LDP』

draft-martini-pwe3-pw-switching-01.txt

『Pseudo Wire Switching』

MIB

MIB
MIB リンク

CISCO-IETF-PW-MIB

CISCO-IETF-PW-MPLS-MIB

CISCO-IETF-PW-ENET-MIB

CISCO-IETF-PW-FR-MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

L2VPN 擬似回線スイッチングの機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(28)SB、12.2(33)SRB 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 L2VPN 擬似回線スイッチング の機能情報

機能名
リリース
機能情報

L2VPN 擬似回線スイッチング

12.0(31)S
12.2(28)SB
12.2(33)SRB
12.2(33)SRD2 12.2(33)SRE

この機能は、Interautonomous System(Inter-AS; 相互自律システム)の境界線、または 2 つの異なる MPLS ネットワークをまたいで、L2VPN 擬似回線を拡張する L2VPN 擬似回線スイッチングを設定します。

Cisco IOS Release 12.2(28)SB では、Cisco 7200 および 7301 シリーズ ルータのサポートが追加されました。

ATM and TDM AC のサポートは、12.2(33)SRD2 で追加されました。

次のコマンドが導入または変更されました。 l2 vfi point-to-point neighbor (L2VPN 擬似回線切り替え)、 show vfi