マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
L2VPN インターワーキング
L2VPN インターワーキング
発行日;2012/01/30 | 英語版ドキュメント(2011/11/23 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

L2VPN インターワーキング

機能情報の確認

この章の構成

L2VPN インターワーキングの前提条件

L2VPN インターワーキングの制約事項

全般的な制約事項

Cisco 7600 シリーズ ルータの制約事項

Cisco 12000 シリーズ ルータの制約事項

ATM AAL5 インターワーキングの制約事項

イーサネット/VLAN インターワーキングの制約事項

の制約事項

フレーム リレー インターワーキングの制約事項

PPP インターワーキングの制約事項

L2VPN インターワーキングに関する情報

L2VPN インターワーキングの概要

L2VPN インターワーキング モード

イーサネット(ブリッジ型)インターワーキング

IP(ルーテッド)インターワーキング

VLAN インターワーキング

L2VPN インターワーキング:サポート マトリクス

PPP の L2VPN インターワーキング用のスタティック IP アドレス

L2VPN インターワーキングの設定方法

L2VPN インターワーキングの設定

L2VPN インターワーキングの設定確認

の設定

制約事項

前提条件

L2VPN インターワーキングの設定例

Ethernet to VLAN over L2TPV3(ブリッジ型):例

Ethernet to VLAN over AToM(ブリッジ型):例

Frame Relay to VLAN over L2TPV3(ルーテッド):例

Frame Relay to VLAN over AToM(ルーテッド):例

Frame Relay to ATM AAL5 over AToM(ルーテッド):例

VLAN to ATM AAL5 over AToM(ブリッジ型):例

Frame Relay to PPP over L2TPv3(ルーテッド):例

Frame Relay to PPP over AToM(ルーテッド):例

Ethernet/VLAN to PPP over AToM(ルーテッド):例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

L2VPN インターワーキングの機能情報

L2VPN インターワーキング

Layer 2 Virtual Private Network(L2VPN; レイヤ 2 バーチャル プライベート ネットワーク)インターワーキングを使用すると、異種接続回線を接続できます。この章では、次の L2VPN インターワーキング機能の設定方法について説明します。

Ethernet/VLAN to ATM AAL5 インターワーキング

Ethernet/VLAN to Frame Relay インターワーキング

Ethernet/VLAN to PPP インターワーキング

Ethernet to VLAN インターワーキング

Frame Relay to ATM AAL5 インターワーキング

Frame Relay to PPP インターワーキング

Ethernet/VLAN to ATM Virtual Channel Identifier(VPI; 仮想チャネル識別子)および Ethernet/VLAN to ATM Virtual Channel Identifier(VCI; 仮想チャネル識別子)インターワーキング

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「L2VPN インターワーキングの機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、Cisco Catalyst OS ソフトウェア イメージ、および Cisco IOS XE ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

L2VPN インターワーキングの前提条件

ルータで L2VPN インターワーキングを設定する前に、次のことを行っておく必要があります。

シスコ エクスプレス フォワーディングをイネーブルにする必要があります。

Cisco 12000 シリーズ インターネット ルータでは、IP Services Engine(ISE; IP サービス エンジン/エンジン 3)またはエンジン 5 インターフェイス上で L2VPN インターワーキング用に Layer 2 Tunnel Protocol version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)を設定する前に、ライン カード上で L2VPN 機能バンドルもイネーブルにする必要があります。

機能バンドルをイネーブルにするには、次のようにグローバル コンフィギュレーション モードで hw-module slot np mode feature コマンドを入力します。

Router# configure terminal
Router(config)# hw-module slot slot-number np mode feature

L2VPN インターワーキングの制約事項

次の各項では、L2VPN インターワーキングの制約事項を示します。

「全般的な制約事項」

「Cisco 7600 シリーズ ルータの制約事項」

「Cisco 12000 シリーズ ルータの制約事項」

「ATM AAL5 インターワーキングの制約事項」

「イーサネット/VLAN インターワーキングの制約事項」

「L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプションの制約事項」

「フレーム リレー インターワーキングの制約事項」

「PPP インターワーキングの制約事項」

全般的な制約事項

ここでは、L2VPN インターワーキングに適用される全般的な制約事項を示します。プラットフォーム固有またはデバイス固有のその他の制約事項は、以降の項で示します。

Provider Edge(PE; プロバイダー エッジ)ルータ上のインターワーキング タイプは、ピア PE ルータ上のインターワーキング タイプと一致する必要があります。

L2VPN インターワーキングでは、次の Quality of Service(QoS; サービス品質)機能がサポートされます。

トンネル ヘッダーのスタティック IP Type of Service(ToS; タイプ オブ サービス)または Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Experimental Bit(EXP; 検出ビット)設定

トンネル ヘッダーの IP ToS リフレクション(Layer 2 Tunnel Protocol Version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)のみ)

フレーム リレー ポリシング

フレーム リレー Data-Link Connection Identifier(DLCI; データリンク接続識別子)ベースの輻輳管理(Cisco 7500/Versatile Interface Processor(VIP))

VLAN 優先順位ビットから MPLS EXP ビットへの 1 対 1 マッピング

ATM AAL5 VC モードだけがサポートされます。ATM VP およびポート モードはサポートされません。

Cisco 7600 シリーズ ルータの制約事項

Cisco 7600 シリーズ ルータでは、次のライン カードがサポートされます。 表 1 に、インターワーキング リンクの WAN(ATM、フレーム リレー、または PPP)側でサポートされるライン カードを示します。 表 2 に、インターワーキング リンクのイーサネット側でサポートされるライン カードを示します。Cisco 7600 ルータでサポートされる共有ポート アダプタとライン カードの詳細については、次のマニュアルを参照してください。

『Cisco 7600 Series Routers Documentation Roadmap』

『Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers』

表 1 Cisco 7600 シリーズ ルータ:WAN 側でサポートされるライン カード

インターワーキング タイプ
コア方向ライン カード
カスタマーエッジ ライン カード

イーサネット(ブリッジ型)
(ATM およびフレーム リレー)

任意

EflexWAN
SIP-200
SIP-400

IP(ルーテッド)
(ATM、フレーム リレー、および PPP)

任意

EflexWAN
SIP-200

表 2 Cisco 7600 シリーズ ルータ:イーサネット側でサポートされるライン カード

インターワーキング タイプ
Ethernet over MPLS モード
コア方向ライン カード
カスタマーエッジ ライン カード

イーサネット(ブリッジ型)

Policy Feature Card(PFC; ポリシー フィーチャ カード)ベース

任意(Optical Services Module(OSM; オプティカル サービス モジュール)と ES40 を除く)

Catalyst LAN
SIP-600

イーサネット(ブリッジ型)

Switched Virtual Interface(SVI; スイッチ仮想インターフェイス)ベース

EflexWAN
ES20
ES+40
SIP-200
SIP-400
SIP-600

Catalyst LAN
EflexWAN(MPB あり)
ES20
ES+40
SIP-200(MPB あり)
SIP-400(MPB あり)
SIP-600

イーサネット(ブリッジ型)

スケーラブル(E-MPB あり)

任意(OSM を除く)

ES20
SIP-600 および SIP-400(Gigabit Ethernet(GE; ギガビット イーサネット)SPA あり)

IP(ルーテッド)

PFC ベース

Catalyst LAN
SIP-600

注: Cisco IOS Release 12.2(33)SRD では、PFC ベース モードはルーテッド インターワーキングでサポートされません。SVI、スケーラブル、または Ethernet Virtual Connection(EVC; イーサネット仮想接続)ベースの Ethernet over MPLS(EoMPLS)を代わりに使用してください。

Catalyst LAN
SIP-600

注: Cisco IOS Release 12.2(33)SRD では、PFC ベース モードはルーテッド インターワーキングでサポートされません。SVI、スケーラブル、または EVC ベース EoMPLS を代わりに使用してください。

IP(ルーテッド)

SVI ベース

任意(Catalyst LAN と OSM を除く)

Catalyst LAN
EflexWAN(MPB あり)
ES20
SIP-200(MPB あり)
SIP-400(MPB あり)
SIP-600

Cisco 7600 シリーズ ルータと L2VPN インターワーキングには、次の制約事項が適用されます。

OAM エミュレーションは、SIP-200、SIP-400、および Flexwan2 ライン カード上の L2VPN インターワーキングでは不要です。

Cisco 7600 シリーズ ルータでは、Cisco IOS Release 12.2(33)SRE から導入された L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能がサポートされます。この機能には、次の制約事項があります。

PFC ベースの EoMPLS はサポートされません。

スケーラブルおよび SVI ベース EoMPLS は、SIP-400 ライン カードでサポートされます。

Cisco 7600 シリーズ ルータでは、L2VPN Interworking over L2TPv3 はサポートされません。

Cisco 7600 シリーズ ルータでは、次のインターワーキング タイプだけがサポートされます。

Ethernet/VLAN to Frame Relay(IP およびイーサネット モード)

Ethernet/VLAN to ATM AAL5SNAP(IP およびイーサネット モード)

Ethernet/VLAN to PPP(IP のみ)

Ethernet to VLAN インターワーキング

Cisco 7600 シリーズ ルータでは、次のインターワーキング タイプはサポートされません。

Ethernet/VLAN to ATM AAL5MUX

Frame Relay to PPP インターワーキング

Frame Relay to ATM AAL5 インターワーキング

インターワーキング リンクの両側に、同じカプセル化とインターワーキング タイプが設定されている必要があります。

イーサネット カプセル化を使用する場合は、イーサネット(ブリッジ型)インターワーキング タイプを使用する必要があります。イーサネット カプセル化を使用していない場合は、Routed Bridge Encapsulation(RBE; ルーテッド ブリッジ カプセル化)などのブリッジング メカニズムを使用できます。

IP カプセル化(ATM やフレーム リレーなど)を使用する場合は、IP(ルーテッド)インターワーキング タイプを使用する必要があります。PE ルータは、アドレスの学習と解決のためにプロセスをネゴシエーションします。

擬似回線の各側の接続回線で同じ MTU サイズを使用する必要があります。

PFC ベース EoMPLS は、ES40 ライン カードでサポートされません。SVI および EVC/スケーラブル EoMPLS が代替オプションです。

Cisco IOS Release 12.2(33)SRD およびそれ以降のリリースでは、PFC ベース EoMPLS はルーテッド/IP インターワーキングでサポートされません。代替のルーテッド/IP インターワーキング オプションは、SVI と EVC、またはスケーラブル EoMPLS です。ただし、PFC ベース EoMPLS は、イーサネット/ブリッジ型インターワーキングと like-to-like over AToM でサポートされます。

Cisco 12000 シリーズ ルータの制約事項

Cisco 12000 シリーズ ルータでのハードウェア要件の詳細については、『 Cross-Platform Release Notes for Cisco IOS Release 12.0S 』を参照してください。

Cisco 12000 シリーズ ルータでの QOS サポートについては、『 Any Transport over MPLS (AToM): Layer 2 QoS (Quality of Service) for the Cisco 12000 Series Router 』を参照してください。

Frame Relay to PPP および High-Level Data Link Control インターワーキングの場合

Cisco 12000 シリーズ インターネット ルータでは、Cisco IOS Release 12.0(32)S よりも前の Cisco IOS リリースで PPP および High-level Data-Links Control(HDLC; 高レベル データ リンク制御)転送タイプを使用した L2VPN インターワーキングはサポートされません。

Cisco IOS Release 12.0(32)S およびそれ以降のリリースでは、Cisco 12000 シリーズ インターネット ルータは、次の Shared Port Adapter(SPA; 共有ポート アダプタ)でだけ Frame Relay over MPLS および PPP と HDLC over MPLS の L2VPN インターワーキングをサポートします。

ISE/エンジン 3 SPA:

SPA-2XCT3/DS0(2 ポート チャネライズド T3 to DS0)

SPA-4XCT3/DS0(4 ポート チャネライズド T3 to DS0)

エンジン 5 SPA:

SPA-1XCHSTM1/OC-3(1 ポート チャネライズド STM-1c/OC-3c to DS0)

SPA-8XCHT1/E1(8 ポート チャネライズド T1/E1)

SPA-2XOC-48-POS/RPR(2 ポート OC-48/STM16 POS/RPR)

SPA-OC-192POS-LR(1 ポート OC-192/STM64 POS/RPR)

SPA-OC-192POS-XFP(1 ポート OC-192/STM64 POS/RPR)

L2VPN Interworking over L2TPv3

Cisco 12000 シリーズ インターネット ルータでは、L2TPv3 に対してイーサネット(ブリッジ型)インターワーキングはサポートされません。IP(ルーテッド)インターワーキングだけがサポートされます。

IP(ルーテッド)インターワーキングは、( sequencing コマンドを使用して)データ シーケンス用に設定された L2TPv3 擬似回線ではサポートされません。

Cisco IOS Release 12.0(32)SY およびそれ以降のリリースでは、Cisco 12000 シリーズ インターネット ルータは、次のように、ISE およびエンジン 5 ライン カード上で IP モードの L2TPv3 トンネルを介した L2VPN インターワーキングをサポートします。

L2TPv3 トンネリング用に設定された ISE インターフェイスでは、次のレイヤ 2 カプセル化がサポートされます。

ATM Adaptation Layer Type-5(AAL5; ATM アダプテーション レイヤ タイプ 5)

イーサネット

802.1q(VLAN)

フレーム リレー DLCI

L2TPv3 トンネリング用に設定されたエンジン 5 インターフェイスでは、次のレイヤ 2 カプセル化がサポートされます。

イーサネット

802.1q(VLAN)

フレーム リレー DLCI

詳細については、『 Layer 2 Tunnel Protocol Version 3 』を参照してください。

エンジン 5 イーサネット SPA 上の L2TPv3 インターワーキングでサポートされるフレーム形式は、Ether タイプ 0x0800 値がインターネット プロトコル ペイロードおよび(任意で)802.1q VLAN として設定されたイーサネット バージョン 2(イーサネット II とも呼ばれる)だけです。他のイーサネット フレーム形式のイーサネット パケットはドロップされます。

リモート イーサネット ポート シャットダウンのサポート

Cisco リモート イーサネット ポート シャットダウン機能(リモート リンク エラー後のデータ損失の可能性を最小化します)は、次のエンジン 5 イーサネット SPA でだけサポートされます。

SPA-8XFE(8 ポート ファスト イーサネット)

SPA-2X1GE(2 ポート ギガビット イーサネット)

SPA-5X1GE(5 ポート ギガビット イーサネット)

SPA-10X1GE(10 ポート ギガビット イーサネット)

SPA-1X10GE(1 ポート 10 ギガビット イーサネット)

この機能の詳細については、『 Any Transport over MPLS (AToM): Remote Ethernet Port Shutdown 』を参照してください。

エンジン 5 ライン カード上の L2VPN Any-to-Any インターワーキング

表 3 に、MPLS または L2TPv3 で接続回線を介して接続されているエンジン 3 およびエンジン 5 SPA インターフェイス上の L2VPN インターワーキングに対してサポートされる転送タイプの各種組み合せを示します。

 

表 3 L2VPN インターワーキングでサポートされるエンジン 3 およびエンジン 5 ライン カード/SPA

接続回線 1(AC1)
接続回線 2(AC2)
インターワーキング モード
AC1 エンジン タイプとライン カード/SPA
AC2 エンジン タイプとライン カード/SPA

フレーム リレー

フレーム リレー

IP

エンジン 5
POS およびチャネライズド

エンジン 3
ATM ライン カード

フレーム リレー

ATM

イーサネット

エンジン 5
POS およびチャネライズド

エンジン 3
ATM ライン カード

フレーム リレー

ATM

IP

エンジン 5
POS およびチャネライズド

エンジン 3
ATM ライン カード

フレーム リレー

イーサネット

イーサネット

エンジン 5
POS およびチャネライズド

エンジン 5
ギガビット イーサネット

フレーム リレー

イーサネット

IP

エンジン 5
POS およびチャネライズド

エンジン 5
ギガビット イーサネット

フレーム リレー

VLAN

イーサネット

エンジン 5
POS およびチャネライズド

エンジン 5
ギガビット イーサネット

フレーム リレー

VLAN

IP

エンジン 5
POS およびチャネライズド

エンジン 5
ギガビット イーサネット

イーサネット

イーサネット

イーサネット

エンジン 5
ギガビット イーサネット

エンジン 5
ギガビット イーサネット

イーサネット

イーサネット

IP

エンジン 5
ギガビット イーサネット

エンジン 5
ギガビット イーサネット

イーサネット

VLAN

イーサネット

エンジン 5
ギガビット イーサネット

エンジン 5
ギガビット イーサネット

イーサネット

VLAN

IP

エンジン 5
ギガビット イーサネット

エンジン 5
ギガビット イーサネット

ATM

イーサネット

イーサネット

エンジン 3
ATM ライン カード

エンジン 5
ギガビット イーサネット

ATM

イーサネット

IP

エンジン 3
ATM ライン カード

エンジン 5
ギガビット イーサネット

Cisco 12000 シリーズ エンジン 3 ライン カードでは、Network Layer Protocol ID(NLPID; ネットワーク層プロトコル ID)カプセル化はルーテッド モードでサポートされません。また、NLPID と AAL5MUX はどちらもブリッジ モードでサポートされません。

Cisco 12000 シリーズ インターネット ルータでは、L2TPv3 に対してイーサネット(ブリッジ型)インターワーキングはサポートされません。

L2VPN インターワーキング設定では、 encapsulation l2tpv3 コマンドを使用して擬似回線に L2TPv3 トンネル カプセル化を設定したあとは、 interworking ethernet コマンドを入力できません。

Cisco 12000 シリーズ インターネット ルータ上のイーサネット SPA では、L2TPv3 インターワーキングでサポートされるフレーム形式は、Ether タイプ 0x0800 値がインターネット プロトコル ペイロードおよび(任意で)802.1q VLAN として設定されたイーサネット バージョン 2(イーサネット II とも呼ばれる)だけです。

他のイーサネット フレーム形式のイーサネット パケットはドロップされます。

ATM AAL5 インターワーキングの制約事項

ATM AAL5 インターワーキングには、次の制約事項が適用されます。

Switched Virtual Circuit(SVC; 相手先選択接続)はサポートされません。

Inverse Address Resolution Protocol(ARP; アドレス解決プロトコル)は IP インターワーキングでサポートされません。

Customer Edge(CE; カスタマー エッジ)ルータでは、ポイントツーポイント サブインターフェイスまたはスタティック マップを使用する必要があります。

AAL5MUX および AAL5SNAP カプセル化はどちらもサポートされます。AAL5MUX の場合、変換は不要です。

Ethernet End-to-End over ATM シナリオでは、次の変換がサポートされます。

LAN Frame Check Sequence(FCS; フレーム チェック シーケンス)のないイーサネット(AAAA030080C200070000)

スパニング ツリー(AAAA030080c2000E)

その他はすべてドロップされます。

IP over ATM シナリオでは、IPv4(AAAA030000000800)変換がサポートされます。その他はすべてドロップされます。

L2VPN インターワーキングの Operation, Administration, and Management(OAM; 操作、管理、メンテナンス)エミュレーションは、like-to-like と同じです。エンドツーエンド F5 ループバック セルは、PE ルータでループバックされます。擬似回線がダウンしている場合は、F5 エンドツーエンド セグメント Alarm Indication Signal(AIS; アラーム表示信号)/Remote Defect Identification(RDI; リモート検出識別)が PE ルータから CE ルータに送信されます。

Interim Local Management Interface(ILMI; 暫定ローカル管理インターフェイス)では、Virtual Circuit(VC; 仮想回線)と Permanent Virtual Circuit(PVC; 相手先固定接続)を管理できます。

ILMI 管理をイネーブルにするには、PE ルータの ATM インターフェイスで ILMI PVC 0/16 を設定します。PVC がプロビジョニングまたは削除されている場合は、ilmiVCCChange トラップが CE ルータに送信されます。

User-Network Interface(UNI; ユーザ ネットワーク インターフェイス)のユーザ側だけがサポートされます。UNI のネットワーク側はサポートされません。

イーサネット/VLAN インターワーキングの制約事項

イーサネット/VLAN インターワーキングには、次の制約事項が適用されます。

VLAN to Ethernet インターワーキング、VLAN to Frame Relay(ルーテッド)、またはイーサネット(ブリッジ型)を使用した ATM インターワーキングを設定する場合、CE ルータから VLAN タグ付きフレームを受信するイーサネット側の PE ルータでは VLAN タグが削除されます。逆方向では、PE ルータはフレームを CE ルータに送信する前にフレームに VLAN タグを追加します。

interworking vlan コマンドで L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能をイネーブルにした場合は、VLAN ID がイーサネット フレームの一部として含まれます。詳細については、「VLAN インターワーキング」を参照してください。)

VLAN からフレーム リレーへのブリッジ型インターワーキングでは、フレーム リレー PE ルータによって、受信したイーサネット トラフィックから VLAN タグが取り除かれます。

Cisco 10720 インターネット ルータでは、L2TPv3 上でだけ Ethernet to VLAN インターワーキング イーサネットがサポートされます。

RAW イーサネット ポートまたは VLAN トランクのイーサネット インターワーキングはサポートされません。トラフィック ストリームは、トラフィックが転送タイプ間で送信される場合には分離されません。

ルータ モードでは、イーサネット PE ルータに CE ルータを 1 台だけ接続できます。

接続回線と擬似回線の間には 1 対 1 関係が必要です。ポイントツーマルチポイントまたはマルチポイントツーポイント設定はサポートされません。

イーサネットから非イーサネットへの設定では、CE ルータにポイントツーポイント オペレーションのルーティング プロトコルを設定します。

IP インターワーキング モードでは、IPv4(0800)変換がサポートされます。PE ルータは ARP(0806)パケットをキャプチャし、独自の MAC アドレス(プロキシ ARP)で応答します。その他はすべてドロップされます。

イーサネットまたは VLAN には、2 台の IP デバイス(PE ルータと CE ルータ)だけが含まれている必要があります。PE ルータはプロキシ ARP を実行し、受信したすべての ARP 要求に応答します。したがって、イーサネットまたは VLAN セグメントには 1 台の CE ルータと 1 台の PE ルータだけが存在する必要があります。

CE ルータでスタティック ルーティングが実行されている場合は、次の作業を実行できます。

PE ルータは、CE ルータの MAC アドレスを学習してトラフィックを CE ルータに正しく転送する必要があります。イーサネット PE ルータは、Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)Router Discovery Protocol(RDP; ルータ ディスカバリ プロトコル)請求メッセージを、送信元 IP アドレスをゼロとして送信します。イーサネット CE ルータは、この請求メッセージに応答します。ICMP RDP 請求メッセージに応答するように Cisco CE ルータのイーサネットまたは VLAN インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで ip irdp コマンドを発行します。CE ルータを設定しない場合は、CE ルータによってトラフィックが PE ルータに送信されるまでトラフィックがドロップされます。

CE ルータのルータ ディスカバリ プロトコルの実行をディセーブルにするには、インターフェイス モードで ip irdp maxadvertinterval 0 コマンドを発行します。

この制約事項は、Catalyst スイッチを CE ルータとしてイーサネットと VLAN 間のインターワーキングを設定する場合に適用されます。スパニング ツリー プロトコルは、イーサネット インターワーキングに対してサポートされます。イーサネット ポートと VLAN 間のイーサネット インターワーキングでは、VLAN 1 でだけスパニング ツリー プロトコルがサポートされます。VLAN 1 を非ネイティブ VLAN として設定します。

イーサネット PE ルータ上のインターワーキング設定を変更する場合は、隣接する CE ルータ上の ARP エントリをクリアして、新しい MAC アドレスを学習できるようにします。そうしないと、トラフィックがドロップされることがあります。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプションの制約事項

次の制約事項は、VLAN ID をイーサネット フレームの一部として含められるようにする L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能に適用されます。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能は次のリリースでサポートされます。

Cisco Catalyst 3750 Metro スイッチ用 Cisco IOS Release 12.2(52)SE

Cisco 7600 シリーズ ルータ用 Cisco IOS Release 12.2(33)SRE

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプションは、L2TPv3 ではサポートされません。この機能は AToM でだけ設定できます。

PE ルータ上のインターフェイスが VLAN インターフェイスの場合は、PE ルータで必ずしも interworking vlan コマンドを指定する必要はありません。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能は、次の接続回線の組み合せでだけ動作します。

Ethernet to Ethernet

Ethernet to VLAN

VLAN to VLAN

PE ルータにインターワーキング タイプを指定した場合は、そのインターワーキング タイプが適用される必要があります。インターワーキング タイプは両方の PE ルータで一致する必要があります。そうでないと、VC は互換性のない状態になり、ダウン状態のままになることがあります。Attachment Circuit(AC; 接続回線)が VLAN の場合、PE ルータでは Label Distribution Protocol(LDP; ラベル配布プロトコル)を使用して VC タイプをネゴシエーション(自動検知)できます。

たとえば、PE1 と PE2 の両方でイーサネット インターフェイスを使用し、VLAN インターワーキングは PE1 でだけ指定されているとします。PE2 にはインターワーキング タイプが設定されておらず、インターワーキング タイプを自動検知できません。その結果、VC がダウン状態のままになる非互換状態が発生します。

一方、PE1 でイーサネット インターフェイスが使用され、VLAN インターワーキングがイネーブルになっていて(これにより VLAN が VC タイプとして適用されます)、PE2 で VLAN インターフェイスが使用され、インターワーキングがイネーブルになっていない場合(これにより、PE2 ではイーサネットがデフォルトの VC タイプとして使用されます)、PE2 ではインターワーキング タイプを自動検知およびネゴシエーションし、VLAN を VC タイプとして選択できます。

表 4 に、ネゴシエーション後の AC タイプ、インターワーキング オプション、および VC タイプの概要を示します

表 4 イーサネットおよび VLAN インターワーキング タイプのネゴシエーション

PE1 AC
タイプ
インターワーキング オプション
PE2 AC タイプ
インターワーキング オプション
ネゴシエーション後の VC タイプ

イーサネット

none

イーサネット

none

イーサネット

Vlan

none

イーサネット

none

イーサネット

イーサネット

none

Vlan

none

イーサネット

Vlan

none

Vlan

none

イーサネット

イーサネット

Vlan

イーサネット

none

互換性なし

Vlan

Vlan

イーサネット

none

互換性なし

イーサネット

Vlan

Vlan

none

Vlan

Vlan

Vlan

Vlan

none

Vlan

イーサネット

none

イーサネット

Vlan

互換性なし

Vlan

none

イーサネット

Vlan

Vlan

イーサネット

none

Vlan

Vlan

互換性なし

Vlan

none

Vlan

Vlan

Vlan

イーサネット

Vlan

イーサネット

Vlan

Vlan

Vlan

Vlan

イーサネット

Vlan

Vlan

イーサネット

Vlan

Vlan

Vlan

Vlan

Vlan

Vlan

Vlan

Vlan

Vlan

フレーム リレー インターワーキングの制約事項

フレーム リレー インターワーキングには、次の制約事項が適用されます。

接続回線の Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズは、MPLS を介して接続する場合に一致している必要があります。デフォルトでは、フレーム リレー DLCI に関連付けられている MTU サイズはインターフェイス MTU です。これにより、たとえば PoS インターフェイス(デフォルトの MTU は 4470 バイト)上の一部の DLCI をイーサネットまたは VLAN(デフォルトの MTU は 1500 バイト)に接続し、同じ PoS インターフェイス上の他の DLCI を ATM(デフォルトの MTU は 4470 バイト)に接続する場合などに、問題が発生する場合があります。すべてのインターフェイス MTU が最小公分母(この場合は 1500 バイト)に削減されることを回避するには、 mtu コマンドを使用して個々の DLCI の MTU を指定します。

DLCI モードだけがサポートされます。ポート モードはサポートされません。

DCE または Network-to-Network Interface(NNI; ネットワーク間インターフェイス)を使用するようにフレーム リレー スイッチングを設定します。DTE モードでは、Local Management Interface(LMI; ローカル管理インターフェイス)プロセスでステータスはレポートされません。Frame Relay over MPLS 回線がダウンし、PE ルータが DTE モードの場合、CE ルータにはディセーブルになっている回線が通知されません。DCE または NNI を設定するには、グローバル コンフィギュレーション モードで frame-relay switching コマンドを設定する必要があります。

フレーム リレー ポリシングは Cisco 7500 シリーズ ルータ上に分散されません。フレーム リレー ポリシングをイネーブルにした場合は、トラフィックがルート スイッチ プロセッサに送信されて処理されます。

IP インターワーキングでは Inverse ARP がサポートされません。CE ルータでは、ポイントツーポイント サブインターフェイスまたはスタティック マップを使用する必要があります。

PE ルータでは、CE から受信した Cisco カプセル化と
Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)カプセル化の両方の変換が自動的にサポートされますが、CE ルータへの送信時には IETF にだけ変換されます。Cisco CE ルータは、Cisco カプセル化を送信するように設定されている場合でも受信した IETF カプセル化を処理できるため、このことは Cisco CE ルータでは問題になりません。

イーサネット インターワーキングでは、次の変換がサポートされます。

LAN FCS のないイーサネット(0300800080C20007 または 6558)

スパニング ツリー(0300800080C2000E または 4242)

他のすべての変換はドロップされます。

IP インターワーキングでは、IPv4(03CC または 0800)変換がサポートされます。他のすべての変換はドロップされます。

PVC ステータス シグナリングは like-to-like の場合と同じように動作します。PE ルータでは、擬似回線のアベイラビリティに基づいて PVC ステータスが CE ルータにレポートされます。PE ルータによって検出された PVC ステータスも、擬似回線に反映されます。フレーム リレーを ATM に接続する場合は、LMI to OAM インターワーキングがサポートされます。

PPP インターワーキングの制約事項

PPP インターワーキングには、次の制約事項が適用されます。

PPP セッションと擬似回線の間には 1 対 1 関係が必要です。擬似回線上での複数の PPP セッションの多重化はサポートされません。

PPP セッションとフレーム リレー DLCI の間には 1 対 1 関係が必要です。各フレーム リレー PVC には 1 つの PPP セッションだけが存在する必要があります。

IP(IPv4(0021))インターワーキングだけがサポートされます。Link Control Protocol(LCP; リンク コントロール プロトコル)パケットと Internet Protocol Control Protocol(IPCP; インターネット プロトコル制御プロトコル)パケットは PE ルータで終了します。その他はすべてドロップされます。

擬似回線上に IP インターワーキングが設定されている場合は、PE ルータでプロキシ IPCP が自動的にイネーブルになります。

デフォルトでは、PE ルータは CE ルータがリモート CE ルータの IP アドレスを認識していると想定します。

Password Authentication Protocol(PAP; パスワード認証プロトコル)と Challenge-Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)認証がサポートされます。

L2VPN インターワーキングに関する情報

次の各項では、L2VPN インターワーキングの概要を説明します。

「L2VPN インターワーキングの概要」

「L2VPN インターワーキング モード」

「L2VPN インターワーキング:サポート マトリクス」

「PPP の L2VPN インターワーキング用のスタティック IP アドレス」

L2VPN インターワーキングの概要

MPLS および IP を介したレイヤ 2 トランスポートは、Ethernet-to-Ethernet や PPP-to-PPP などの like-to-like 接続回線に対してすでに存在します。L2VPN インターワーキングは、異種接続回線を接続できるようにすることにより、この機能に基づいて構築されます。インターワーキング機能によって、異なるレイヤ 2 カプセル化間の変換が容易になります。図 1 は、ATM とフレーム リレー パケットが MPLS クラウドを通過するレイヤ 2 インターワーキングの例です。

図 1 ATM to Frame Relay インターワーキングの例

L2VPN インターワーキング機能では、MPLS および L2TPv3 上でイーサネット、802.1Q(VLAN)、フレーム リレー、ATM AAL5、および PPP 接続回線がサポートされます。like-to-like の機能と制約事項が L2VPN インターワーキングにも適用されます。

L2VPN インターワーキング モード

L2VPN インターワーキングは、イーサネット(「ブリッジ型」)モード、IP(「ルーテッド」)、またはイーサネット VLAN モードで動作します。擬似回線クラス コンフィギュレーション モードで interworking { ethernet | ip |vlan } コマンドを発行することにより、モードを指定します。

イーサネット(ブリッジ型)インターワーキング

ethernet キーワードを指定すると、イーサネット フレームが接続回線から抽出され、擬似回線に送信されます。イーサネット エンドツーエンド送信が想定されます。イーサネットでない接続回線フレームはドロップされます。VLAN の場合は、VLAN タグが削除され、非タグ付きイーサネット フレームが残されます。

イーサネット インターワーキングは、ブリッジ型インターワーキングとも呼ばれます。イーサネット フレームは、擬似回線を介してブリッジされます。CE ルータは、イーサネットをネイティブにブリッジするか、Bridge Virtual Interface(BVI; ブリッジ仮想インターフェイス)や RBE などのブリッジ型カプセル化モデルを使用してルーティングできます。PE ルータは、イーサネット like-to-like モードで動作します。

このモードは、次のサービスを提供するために使用されます。

LAN サービス:たとえば、一部のサイトに Service Provider(SP; サービス プロバイダー)ネットワークへのイーサネット接続があり、他のサイトに ATM 接続がある、複数のサイトがある企業などです。企業はすべてのサイトへの LAN 接続を必要とします。この場合、1 つのサイトのイーサネットまたは VLAN からのトラフィックを IP/MPLS ネットワーク経由で送信し、別のサイトの ATM VC 上のブリッジ型トラフィックとしてカプセル化できます。

接続サービス:たとえば、ブロードキャスト リンクと非ブロードキャスト リンクに互換性のないプロシージャがある、Internal Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)ルーティング プロトコルを実行している異なるサイトがある企業などです。企業には、サイト間で Open Shortest Path First(OSPF)や Intermediate System to Intermediate System(IS-IS)などの IGP を実行している複数のサイトがあります。このシナリオでは、一部のプロシージャ(ルート アドバタイズメントや代表ルータなど)は基礎となるレイヤ 2 プロトコルに依存し、ポイントツーポイント ATM 接続とブロードキャスト イーサネット接続とで異なります。したがって、ATM 上でのブリッジ型カプセル化を使用して、IGP を実行している CE ルータ間の同種イーサネット接続を実現できます。

IP(ルーテッド)インターワーキング

ip キーワードを指定すると、IP パケットが接続回線から抽出され、擬似回線に送信されます。IPv4 パケットを含まない接続回線フレームはドロップされます。

IP インターワーキングは、ルーテッド インターワーキングとも呼ばれます。CE ルータでは、CE ルータと PE ルータ間のリンク上で IP がカプセル化されます。新しい VC タイプを使用して、MPLS と L2TPv3 の IP 擬似回線に通知します。擬似回線上でのレイヤ 2 カプセル化と IP カプセル化の間の変換が必要です。アドレス解決とルーティング プロトコル操作は、異なるレイヤ 2 カプセル化では異なる方法で処理されるため、特別な考慮が必要です。

このモードを使用して、サイトへのレイヤ 2 接続にかかわらず、これらのサイト間に IP 接続を提供します。本質的にはポイントツーポイントであり、サービス プロバイダーはカスタマーのルーティング情報を保持しないため、レイヤ 3 VPN とは異なります。

アドレス解決は、カプセル化に依存します。

イーサネットは ARP を使用する。

フレーム リレーと ATM は Inverse ARP を使用する。

PPP は IPCP を使用する。

したがって、アドレス解決は PE ルータで終了する必要があります。エンドツーエンドのアドレス解決はサポートされません。ルーティング プロトコルは、ブロードキャストとポイントツーポイント メディアでは異なる動作をします。イーサネットの場合、CE ルータでスタティック ルーティングを使用するか、イーサネット側をポイントツーポイント ネットワークとして扱うようにルーティング プロトコルを設定する必要があります。

VLAN インターワーキング

vlan キーワードを指定すると、VLAN ID をイーサネット フレームの一部として含めることができます。Cisco IOS Release 12.2(52)SE では、イーサネット(ブリッジ型)インターワーキングにイーサネット VLAN を使用するように Catalyst 3750 Metro スイッチを設定できます。擬似回線クラス コンフィギュレーション モードで interworking vlan コマンドを発行することにより、イーサネット VLAN(タイプ 4)を指定できます。これにより、VLAN ID をイーサネット フレームの一部として含めることができます。Cisco IOS Release 12.2(52)SE よりも前のリリースでは、VLAN カプセル化を実現する唯一の方法は、イーサネット VLAN インターフェイス/サブインターフェイスを通じて CE ルータを PE ルータに接続することでした。

L2VPN インターワーキング:サポート マトリクス

表 5 に、サポートされる L2VPN インターワーキング機能を示します。

表 5 L2VPN インターワーキングでサポートされる機能

機能
MPLS または L2TPv3 サポート
IP またはイーサネット サポート

Ethernet/VLAN to ATM AAL5

MPLS
L2TPv3(12000 シリーズのみ)

IP
イーサネット

Ethernet/VLAN to Frame Relay

MPLS
L2TPv3

IP
イーサネット

Ethernet/VLAN to PPP

MPLS

IP

Ethernet to VLAN

MPLS
L2TPv3

IP
イーサネット1

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション

MPLS

イーサネット VLAN

Frame Relay to ATM AAL5

MPLS
L2TPv3(12000 シリーズのみ)

IP

Frame Relay to Ethernet または VLAN

MPLS
L2TPv3

IP
イーサネット

Frame Relay to PPP

MPLS
L2TPv3

IP

注: Cisco 12000 シリーズのインターネット ルータ上では、次のようになります。

イーサネット(ブリッジ型)インターワーキングは L2TPv3 に対してサポートされません。

IP(ルーテッド)インターワーキングは、( sequencing コマンドを使用して)データ シーケンス用に設定された L2TPv3 擬似回線ではサポートされません。

1.L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプションでは、VLAN インターワーキングもサポートできます。詳細については、「VLAN インターワーキング」を参照してください。

PPP の L2VPN インターワーキング用のスタティック IP アドレス

PE ルータが PPP 用のローカル CE ルータでアドレス解決を実行する必要がある場合は、PE ルータにリモート CE ルータの IP アドレスを設定できます。PE ルータの xconnect PPP インターフェイス上で、リモート CE ルータの IP アドレスを指定して ppp ipcp address proxy コマンドを発行します。次に、設定例を示します。

pseudowire-class ip-interworking
encapsulation mpls
interworking ip
 
interface Serial2/0
encapsulation ppp
xconnect 10.0.0.2 200 pw-class ip-interworking
ppp ipcp address proxy 10.65.32.14
 

ローカル CE ルータでアドレス解決を実行する場合は、 peer default ip address コマンドを使用して、ローカル CE ルータ上にリモート CE ルータの IP アドレスを設定することもできます。

L2VPN インターワーキングの設定方法

ここでは、L2VPN インターワーキングを設定するために実行できる作業について説明します。

「L2VPN インターワーキングの設定」(必須)

「L2VPN インターワーキングの設定確認」(任意)

「L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプションの設定」(任意)

L2VPN インターワーキングの設定

L2VPN インターワーキングを使用すると、異種接続回線を接続できます。L2VPN インターワーキング機能を設定するには、擬似回線を構成するコマンドのリストに interworking コマンドを追加する必要があります。L2VPN インターワーキングの擬似回線を設定する手順については、この項で説明します。全体的な AToM または L2TPv3 設定の一部として、 interworking コマンドを使用します。AToM または L2TPv3 を設定する具体的な手順については、次のマニュアルを参照してください。

『Layer 2 Tunnel Protocol Version 3』

『Any Transport over MPLS』

手順の概要

1. enable

2. configure terminal

3. hw-module slot slot-number np mode feature

4. pseudowire-class name

5. encapsulation { mpls | l2tpv3 }

6. interworking { ethernet | ip | vlan }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hw-module slot slot-number np mode feature
 

Router(config)# hw-module slot 3 np mode feature

(任意)Cisco 12000 シリーズ ルータで L2VPN インターワーキング機能をイネーブルにします。

コマンドを入力して、ライン カードで L2VPN 機能バンドルをイネーブルにする必要があります。

ステップ 4

pseudowire-class name

 

Router(config)# pseudowire-class class1

指定する名前で擬似回線クラスを確立し、擬似回線クラス コンフィギュレーション モードを開始します。

ステップ 5

encapsulation { mpls | l2tpv3 }

 

Router(config-pw)# encapsulation mpls

トンネリング カプセル化を指定します。これは mpls または l2tpv3 です。

ステップ 6

interworking { ethernet | ip } | vlan }

 

Router(config-pw)# interworking ip

擬似回線のタイプと、その回線を流れるトラフィックのタイプを指定します。

コマンドを入力できません。

L2VPN インターワーキングの設定確認

L2VPN インターワーキング設定を確認するには、次のコマンドを使用します。

手順の概要

1. enable

2. show l2tun session all

3. show arp

4. ping

5. show l2tun session interworking

6. show mpls l2transport vc detail

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたらパスワードを入力します。

ステップ 2 show l2tun session all(L2TPv3 のみ)

L2TPv3 では、PE ルータで show l2tun session all コマンドを使用して、L2VPN インターワーキング設定を確認できます。

次の例では、インターワーキング タイプを太字で示しています。

PE1
PE2

Router# show l2tun session all

 

Session Information Total tunnels 1 sessions 1

 

Session id 15736 is up, tunnel id 35411

Call serial number is 4035100045

Remote tunnel name is PE2

Internet address is 10.9.9.9

Session is L2TP signalled

Session state is established, time since change 1d22h

16 Packets sent, 16 received

1518 Bytes sent, 1230 received

Receive packets dropped:

out-of-order: 0

total: 0

Send packets dropped:

exceeded session MTU: 0

total: 0

Session vcid is 123

Session Layer 2 circuit, type is Ethernet, name is FastEthernet1/1/0

Circuit state is UP

Remote session id is 26570, remote tunnel id 46882

DF bit off, ToS reflect disabled, ToS value 0, TTL value 255

No session cookie information available

FS cached header information:

encap size = 24 bytes

00000000 00000000 00000000 00000000

00000000 00000000

Sequencing is off

Router# show l2tun session all

 

Session Information Total tunnels 1 sessions 1

 

Session id 26570 is up, tunnel id 46882

Call serial number is 4035100045

Remote tunnel name is PE1

Internet address is 10.8.8.8

Session is L2TP signalled

Session state is established, time since change 1d22h

16 Packets sent, 16 received

1230 Bytes sent, 1230 received

Receive packets dropped:

out-of-order: 0

total: 0

Send packets dropped:

exceeded session MTU: 0

total: 0

Session vcid is 123

Session Layer 2 circuit, type is Ethernet Vlan, name is FastEthernet2/0.1:10

Circuit state is UP, interworking type is Ethernet

Remote session id is 15736, remote tunnel id 35411

DF bit off, ToS reflect disabled, ToS value 0, TTL value 255

No session cookie information available

FS cached header information:

encap size = 24 bytes

00000000 00000000 00000000 00000000

00000000 00000000

Sequencing is off

 

ステップ 3 show arp

CE ルータ間で show arp コマンドを発行して、データが送信されていることを確認できます。

Router# show arp
 
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.1.1.5 134 0005.0032.0854 ARPA FastEthernet0/0
Internet 10.1.1.7 - 0005.0032.0000 ARPA FastEthernet0/0
 

ステップ 4 ping

CE ルータ間で ping コマンドを発行して、データが送信されていることを確認できます。

Router# ping 10.1.1.5
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

ステップ 5 show l2tun session interworking(L2TPv3 のみ)

L2TPv3 では、 show l2tun session interworking コマンドを使用して、インターワーキング タイプが正しく設定されていることを確認できます。インターワーキング変換を実行している PE ルータ上でコマンドを入力します。

例 1 では、PE ルータによって RAW イーサネット変換が実行されます。コマンド出力には、インターワーキング タイプがダッシュ(-)付きで表示されます。

例 2 では、PE ルータによってイーサネット VLAN 変換が実行されます。コマンド出力には、インターワーキング タイプが ETH として表示されます。

例 1 RAW イーサネット変換のコマンド出力

Router# show l2tun session interworking
 
Session Information Total tunnels 1 sessions 1
 
LocID TunID Peer-address Type IWrk Username, Intf/Vcid, Circuit
15736 35411 10.9.9.9 ETH - 123, Fa1/1/0

例 2 イーサネット VLAN 変換のコマンド出力

Router# show l2tun session interworking
 
Session Information Total tunnels 1 sessions 1
 
LocID TunID Peer-address Type IWrk Username, Intf/Vcid, Circuit
26570 46882 10.8.8.8 VLAN ETH 123, Fa2/0.1:10
 

ステップ 6 show mpls l2transport vc detail(AToM のみ)

AToM 設定は、 show mpls l2transport vc detail コマンドを使用して確認できます。次の例では、インターワーキング タイプを太字で示しています。

PE1
PE2

Router# show mpls l2transport vc detail

 

Local interface: Fa1/1/0 up, line protocol up, Ethernet up

Destination address: 10.9.9.9, VC ID: 123, VC status: up

Preferred path: not configured

Default path: active

Tunnel label: 17, next hop 10.1.1.3

Output interface: Fa4/0/0, imposed label stack {17 20}

Create time: 01:43:50, last status change time: 01:43:33

Signaling protocol: LDP, peer 10.9.9.9:0 up

MPLS VC labels: local 16, remote 20

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 15, send 4184

byte totals: receive 1830, send 309248

packet drops: receive 0, send 0

Router# show mpls l2transport vc detail

 

Local interface: Fa2/0.3 up, line protocol up, Eth VLAN 10 up

MPLS VC type is Ethernet, interworking type is Ethernet

Destination address: 10.8.8.8, VC ID: 123, VC status: up

Preferred path: not configured

Default path: active

Tunnel label: 16, next hop 10.1.1.3

Output interface: Fa6/0, imposed label stack {16 16}

Create time: 00:00:26, last status change time: 00:00:06

Signaling protocol: LDP, peer 10.8.8.8:0 up

MPLS VC labels: local 20, remote 16

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 5, send 0

byte totals: receive 340, send 0

packet drops: receive 0, send 0

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプションの設定

擬似回線クラス コンフィギュレーション モードで interworking vlan コマンドを発行することにより、イーサネット VLAN(タイプ 4)を指定できます。これにより、VLAN ID をイーサネット フレームの一部として含めることができます。Cisco IOS Release 12.2(52)SE および Cisco IOS Release 12.2(33)SRE よりも前のリリースでは、VLAN カプセル化を実現する唯一の方法は、イーサネット リンクを通じて CE ルータを PE ルータに接続することでした。

制約事項

Cisco IOS Release 12.2(52)SE および Cisco IOS Release 12.2(33)SRE では、 encapsulation コマンドで mpls キーワードだけがサポートされます。 l2tpv3 キーワードはサポートされません。 interworking コマンドでは、 ethernet および vlan キーワードだけがサポートされます。 ip キーワードはサポートされません。

前提条件

AToM の設定の詳細な手順については、『 Any Transport over MPLS 』を参照してください。

手順の概要

1. enable

2. configure terminal

3. pseudowire-class name

4. encapsulation { mpls | l2tpv3 }

5. interworking { ethernet | ip | vlan }

6. end

7. show mpls l2transport vc [ vcid vc-id | vcid vc-id-min vc-id-max ] [ interface type number [ local-circuit-id ]] [ destination ip-address | name ] [ detail ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class name

 

Router(config)# pseudowire-class class1

指定する名前で擬似回線クラスを確立し、擬似回線クラス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation { mpls | l2tpv3 }

 

Router(config-pw)# encapsulation mpls

トンネリング カプセル化を指定します。これは mpls または l2tpv3 です。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能の場合は、MPLS カプセル化だけがサポートされます。

ステップ 5

interworking { ethernet | ip | vlan }

 

Router(config-pw)# interworking vlan

擬似回線のタイプと、その回線を流れるトラフィックのタイプを指定します。

L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能の場合は、 vlan キーワードを指定します。

ステップ 6

end

 

Router(config-pw)# end

擬似回線クラス コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 7

show mpls l2transport vc [ vcid vc-id | vcid vc-id-min vc-id-max ] [ interface type number [ local-circuit-id ]] [ destination ip-address | name ] [ detail ]

 

Router# show mpls l2transport vc detail

AToM VC に関する情報を表示します。

インターフェイス上の擬似回線が VC タイプと異なる場合は、インターワーキング タイプが show mpls l2transport vc detail コマンドの出力に表示されます。次の例では、擬似回線がイーサネット ポートに設定され、VLAN インターワーキングが擬似回線クラスに設定されます。関連する出力は太字で示されています。

PE1# show mpls l2 vc 34 detail
 
Local interface: Et0/1 up, line protocol up, Ethernet up
MPLS VC type is Ethernet, interworking type is Eth VLAN
Destination address: 10.1.1.2, VC ID: 34, VC status: down
Output interface: if-?(0), imposed label stack {}
Preferred path: not configured
Default path: no route
No adjacency
Create time: 00:00:13, last status change time: 00:00:13
Signaling protocol: LDP, peer unknown
Targeted Hello: 10.1.1.1(LDP Id) -> 10.1.1.2
Status TLV support (local/remote) : enabled/None (no remote binding)
LDP route watch : enabled
Label/status state machine : local standby, AC-ready, LnuRnd
Last local dataplane status rcvd: No fault
Last local SSS circuit status rcvd: No fault
Last local SSS circuit status sent: Not sent
Last local LDP TLV status sent: None
Last remote LDP TLV status rcvd: None (no remote binding)
Last remote LDP ADJ status rcvd: None (no remote binding)
MPLS VC labels: local 2003, remote unassigned
Group ID: local 0, remote unknown
MTU: local 1500, remote unknown
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0

L2VPN インターワーキングの設定例

次の各項では、L2VPN インターワーキングの例を示します。

「Ethernet to VLAN over L2TPV3(ブリッジ型):例」

「Ethernet to VLAN over AToM(ブリッジ型):例」

「Frame Relay to VLAN over L2TPV3(ルーテッド):例」

「Frame Relay to VLAN over AToM(ルーテッド):例」

「Frame Relay to ATM AAL5 over AToM(ルーテッド):例」

「VLAN to ATM AAL5 over AToM(ブリッジ型):例」

「Frame Relay to PPP over L2TPv3(ルーテッド):例」

「Frame Relay to PPP over AToM(ルーテッド):例」

「Ethernet/VLAN to PPP over AToM(ルーテッド):例」

「その他の関連資料」

Ethernet to VLAN over L2TPV3(ブリッジ型):例

次の例は、Ethernet to VLAN over L2TPv3 の設定を示しています。

PE1
PE2

ip cef

!

l2tp-class interworking-class

authentication

hostname PE1

password 0 lab

!

pseudowire-class inter-ether-vlan

encapsulation l2tpv3

interworking ethernet

protocol l2tpv3 interworking-class

ip local interface Loopback0

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface FastEthernet1/0

xconnect 10.9.9.9 1 pw-class inter-ether-vlan

ip cef

!

l2tp-class interworking-class

authentication

hostname PE2

password 0 lab

!

pseudowire-class inter-ether-vlan

encapsulation l2tpv3

interworking ethernet

protocol l2tpv3 interworking-class

ip local interface Loopback0

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

!

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.3

encapsulation dot1Q 10

xconnect 10.8.8.8 1 pw-class inter-ether-vlan

Ethernet to VLAN over AToM(ブリッジ型):例

次の例は、Ethernet to VLAN over AToM の設定を示しています。

PE1
PE2

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom-eth-iw

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface FastEthernet1/0.1

encapsulation dot1q 100

xconnect 10.9.9.9 123 pw-class atom-eth-iw

 

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom

encapsulation mpls

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

!

interface FastEthernet0/0

no ip address

!

interface FastEthernet1/0

xconnect 10.9.9.9 123 pw-class atom

 

Frame Relay to VLAN over L2TPV3(ルーテッド):例

次の例は、Frame Relay to VLAN over L2TPv3 の設定を示しています。

PE1
PE2

configure terminal

ip cef

frame-relay switching

!

!

interface loopback 0

ip address 10.8.8.8 255.255.255.255

no shutdown

!

pseudowire-class ip

encapsulation l2tpv3

interworking ip

ip local interface loopback0

!

interface POS1/0

encapsulation frame-relay

clock source internal

logging event dlci-status-change

no shutdown

no fair-queue

!

connect fr-vlan POS1/0 206 l2transport

xconnect 10.9.9.9 6 pw-class ip

!

router ospf 10

network 10.0.0.2 0.0.0.0 area 0

network 10.8.8.8 0.0.0.0 area 0

configure terminal

ip routing

ip cef

frame-relay switching

!

interface loopback 0

ip address 10.9.9.9 255.255.255.255

no shutdown

!

pseudowire-class ip

encapsulation l2tpv3

interworking ip

ip local interface loopback0

!

interface FastEthernet1/0/1

speed 10

no shutdown

!

interface FastEthernet1/0/1.6

encapsulation dot1Q 6

xconnect 10.8.8.8 6 pw-class ip

no shutdown

!

router ospf 10

network 10.0.0.2 0.0.0.0 area 0

network 10.9.9.9 0.0.0.0 area 0

Frame Relay to VLAN over AToM(ルーテッド):例

次の例は、Frame Relay to VLAN over AToM の設定を示しています。

 

PE1
PE2

configure terminal

ip cef

frame-relay switching

!

mpls label protocol ldp

mpls ldp router-id loopback0

mpls ip

!

pseudowire-class atom

encapsulation mpls

interworking ip

!

interface loopback 0

ip address 10.8.8.8 255.255.255.255

no shutdown

!

connect fr-vlan POS1/0 206 l2transport

xconnect 10.9.9.9 6 pw-class atom

configure terminal

ip routing

ip cef

frame-relay switching

!

mpls label protocol ldp

mpls ldp router-id loopback0

mpls ip

!

pseudowire-class atom

encapsulation mpls

interworking ip

!

interface loopback 0

ip address 10.9.9.9 255.255.255.255

no shutdown

!

interface FastEthernet1/0/1.6

encapsulation dot1Q 6

xconnect 10.8.8.8 6 pw-class atom

no shutdown

Frame Relay to ATM AAL5 over AToM(ルーテッド):例


) Frame Relay to ATM AAL5 は、IP モードの AToM でだけ使用可能です。


次の例は、Frame Relay to ATM AAL5 over AToM の設定を示しています。

PE1
PE2

ip cef

frame-relay switching

mpls ip

mpls label protocol ldp

mpls ldp router-id loopback0 force

pseudowire-class fratmip

encapsulation mpls

interworking ip

interface Loopback0

ip address 10.33.33.33 255.255.255.255

interface serial 2/0

encapsulation frame-relay ietf

frame-relay intf-type dce

connect fr-eth serial 2/0 100 l2transport

xconnect 10.22.22.22 333 pw-class fratmip

interface POS1/0

ip address 10.1.7.3 255.255.255.0

crc 32

clock source internal

mpls ip

mpls label protocol ldp

router ospf 10

passive-interface Loopback0

network 10.33.33.33 0.0.0.0 area 10

network 10.1.7.0 0.0.0.255 area 10

ip cef

mpls ip

mpls label protocol ldp

mpls ldp router-id loopback0 force

pseudowire-class fratmip

encapsulation mpls

interworking ip

interface Loopback0

ip address 10.22.22.22 255.255.255.255

interface ATM 2/0

pvc 0/203 l2transport

encapsulation aa5snap

xconnect 10.33.33.33 333 pw-class fratmip

interface POS1/0

ip address 10.1.1.2 255.255.255.0

crc 32

clock source internal

mpls ip

mpls label protocol ldp

router ospf 10

passive-interface Loopback0

network 10.22.22.22 0.0.0.0 area 10

network 10.1.1.0 0.0.0.255 area 10

 

VLAN to ATM AAL5 over AToM(ブリッジ型):例

次の例は、VLAN to ATM AAL5 over AToM の設定を示しています。

PE1
PE2

ip cef

!

mpls ip

mpls label protocol ldp

mpls ldp router-id Loopback0

!

pseudowire-class inter-ether

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface ATM1/0.1 point-to-point

pvc 0/100 l2transport

encapsulation aal5snap

xconnect 10.9.9.9 123 pw-class inter-ether

!

interface FastEthernet1/0

xconnect 10.9.9.9 1 pw-class inter-ether

!

router ospf 10

log-adjacency-changes

network 10.8.8.8 0.0.0.0 area 0

network 10.1.1.1 0.0.0.0 area 0

ip cef

!

mpls ip

mpls label protocol ldp

mpls ldp router-id Loopback0

!

pseudowire-class inter-ether

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

!

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.1

encapsulation dot1Q 10

xconnect 10.8.8.8 123 pw-class inter-ether

!

router ospf 10

log-adjacency-changes

network 10.9.9.9 0.0.0.0 area 0

network 10.1.1.2 0.0.0.0 area 0

Frame Relay to PPP over L2TPv3(ルーテッド):例

次の例は、Frame Relay to PPP over L2TPv3 の設定を示しています。

PE1
PE2

ip cef

ip routing

!

!

!

pseudowire-class ppp-fr

encapsulation l2tpv3

interworking ip

ip local interface Loopback0

!

interface Loopback0

ip address 10.1.1.1 255.255.255.255

!

interface FastEthernet1/0/0

ip address 10.16.1.1 255.255.255.0

!

interface Serial3/0/0

no ip address

encapsulation ppp

ppp authentication chap

!

ip route 10.0.0.0 255.0.0.0 10.16.1.2

!

xconnect 10.2.2.2 1 pw-class ppp-fr

ppp ipcp address proxy 10.65.32.14

 

ip cef

ip routing

!

frame-relay switching

!

pseudowire-class ppp-fr

encapsulation l2tpv3

interworking ip

ip local interface Loopback0

!

interface Loopback0

ip address 10.2.2.2 255.255.255.255

!

interface FastEthernet1/0/0

ip address 10.16.2.1 255.255.255.0

!

interface Serial3/0/0

no ip address

encapsulation frame-relay

frame-relay intf-type dce

!

ip route 10.0.0.0 255.0.0.0 10.16.2.2

!

connect ppp-fr Serial3/0/0 100 l2transport

xconnect 10.1.1.1 100 pw-class ppp-fr

Frame Relay to PPP over AToM(ルーテッド):例

次の例は、Frame Relay to PPP over AToM の設定を示しています。

PE1
PE2

ip cef

ip routing

mpls label protocol ldp

mpls ldp router-id loopback0 force

!

!

!

pseudowire-class ppp-fr

encapsulation mpls

interworking ip

ip local interface Loopback0

!

interface Loopback0

ip address 10.1.1.1 255.255.255.255

!

interface FastEthernet1/0/0

ip address 10.16.1.1 255.255.255.0

mpls ip

label protocol ldp

!

interface Serial3/0/0

no ip address

encapsulation ppp

ppp authentication chap

xconnect 10.2.2.2 1 pw-class ppp-fr

ppp ipcp address proxy 10.65.32.14

!

ip route 10.0.0.0 255.0.0.0 10.16.1.2

 

ip cef

ip routing

mpls label protocol ldp

mpls ldp router-id loopback0 force

!

frame-relay switching

!

pseudowire-class ppp-fr

encapsulation mpls

interworking ip

ip local interface Loopback0

!

interface Loopback0

ip address 10.2.2.2 255.255.255.255

!

interface FastEthernet1/0/0

ip address 10.16.2.1 255.255.255.0

mpls ip

mpls label protocol ldp

!

interface Serial3/0/0

no ip address

encapsulation frame-relay

frame-relay intf-type dce

!

ip route 10.0.0.0 255.0.0.0 10.16.2.2

!

connect ppp-fr Serial3/0/0 100 l2transport

xconnect 10.1.1.1 100 pw-class ppp-fr

Ethernet/VLAN to PPP over AToM(ルーテッド):例

次の例は、Ethernet VLAN to PPP over AToM の設定を示しています。

PE1
PE2

configure terminal

mpls label protocol ldp

mpls ldp router-id Loopback0

mpls ip

!

pseudowire-class ppp-ether

encapsulation mpls

interworking ip

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

no shutdown

!

interface POS2/0/1

no ip address

encapsulation ppp

no peer default ip address

ppp ipcp address proxy 10.10.10.1

xconnect 10.9.9.9 300 pw-class ppp-ether

no shutdown

 

 

configure terminal

mpls label protocol ldp

mpls ldp router-id Loopback0

mpls ip

!

pseudowire-class ppp-ether

encapsulation mpls

interworking ip

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

no shutdown

!

interface vlan300

mtu 4470

no ip address

xconnect 10.8.8.8 300 pw-class ppp-ether

no shutdown

!

interface GigabitEthernet6/2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 300

switchport mode trunk

no shutdown

その他の関連資料

ここでは、L2VPN インターワーキング機能に関する関連資料について説明します。

関連資料

関連項目
参照先

レイヤ 2 トンネル プロトコル バージョン 3

『Layer 2 Tunnel Protocol Version 3』

Any Transport over MPLS

『Any Transport over MPLS』

Cisco 12000 シリーズ ルータのハードウェア サポート

Cross-Platform Release Notes for Cisco IOS Release 12.0S』

Cisco 7600 シリーズ ルータのハードウェア サポート

『Cisco 7600 Series Routers Documentation Roadmap』

『Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers』

Cisco 3270 シリーズ ルータのハードウェア サポート

『Cisco IOS Software Releases 12.2SE Release Notes』

規格

規格
タイトル

draft-ietf-l2tpext-l2tp-base-03.txt

『Layer Two Tunneling Protocol (Version 3) 'L2TPv3'』

draft-martini-l2circuit-trans-mpls-09.txt

『Transport of Layer 2 Frames Over MPLS』

draft-ietf-pwe3-frame-relay-03.txt

『Encapsulation Methods for Transport of Frame Relay over MPLS Networks』

draft-martini-l2circuit-encap-mpls-04.txt

『Encapsulation Methods for Transport of Layer 2 Frames Over IP and MPLS Networks』

draft-ietf-pwe3-ethernet-encap-08.txt

『Encapsulation Methods for Transport of Ethernet over MPLS Networks』

draft-ietf-pwe3-hdlc-ppp-encap-mpls-03.txt

『Encapsulation Methods for Transport of PPP/HDLC over MPLS Networks』

draft-ietf-ppvpn-l2vpn-00.txt

『An Architecture for L2VPNs』

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

L2VPN インターワーキングの機能情報

表 6 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 6 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 6 L2VPN インターワーキングの機能情報

機能名
リリース
機能情報

L2VPN インターワーキング

12.0(26)S
12.0(30)S
12.0(32)S
12.0(32)SY
12.2(33)SRA
12.4(11)T
12.2(33)SXH
12.2(33)SRD
12.2(52)SE
12.2(33)SRE

この機能を使用すると、異種接続回線を接続できます。インターワーキング機能によって、異なるレイヤ 2 カプセル化間の変換が容易になります。

この機能は、Cisco IOS Release 12.0(26)S で導入されました。

Cisco IOS Release 12.0(30)S では、Cisco 12000 シリーズ インターネット ルータに対するサポートが追加されました。

Cisco IOS Release 12.0(32)S では、Cisco 12000 シリーズ ルータのエンジン 5 ライン カード(SIP-401、SIP-501、SIP-600、および SIP-601)に、次の 4 つの転送タイプのサポートが追加されました。

Ethernet/VLAN to Frame Relay インターワーキング

Ethernet/VLAN to ATM AAL5 インターワーキング

Ethernet to VLAN インターワーキング

Frame Relay to ATM AAL5 インターワーキング

Cisco 12000 シリーズ インターネット ルータでは、L2TPv3 トンネリング用に設定されている IP Services Engine(ISE; IP サービス エンジン)とエンジン 5 ライン カードのサポートが追加されました(『 Layer 2 Tunnel Protocol Version 3 』を参照)。

Cisco IOS Release 12.2(33)SRA では、Cisco 7600 シリーズ ルータのサポートが追加されました。

Cisco IOS Release 12.4(11)T では、次の転送タイプのサポートが追加されました。

Ethernet to VLAN インターワーキング

Ethernet/VLAN to Frame Relay インターワーキング

この機能は、Cisco IOS Release 12.2(33)SXH に統合されました。

Cisco IOS Release 12.2(33)SRD では、Cisco 7600 シリーズ ルータに対して SIP-400 上のルーテッドおよびブリッジ型インターワーキングのサポートが追加されました。

Cisco IOS Release 12.2(52)SE では、Cisco 3750 Metro スイッチに対して L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能が追加されました。

Cisco IOS Release 12.2(33)SRE では、Cisco 7600 シリーズ ルータに対して L2VPN インターワーキング:AToM の VLAN イネーブル/ディセーブル オプション機能が追加されました。

コマンド interworking が導入または変更されました。