マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
ATM および TDM アクセス回線用のホットス タンバイ擬似回線サポート
ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート
発行日;2012/01/30 | 英語版ドキュメント(2011/10/28 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート

機能情報の確認

目次

の前提条件

に関する制約事項

について

機能の動作

サポートされる転送タイプ

の設定方法

擬似回線クラスの設定

の設定

前提条件

設定の確認

の設定例

CEM 回線での の設定:例

ATM 回線での の設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能は、次の方法で L2VPN 擬似回線冗長性機能を拡張します。

バックアップ擬似回線へのより高速なフェールオーバー

フェールオーバー中の少ないトラフィック損失

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能を使用すると、バックアップ擬似回線を「ホットスタンバイ」ステートにして、プライマリ擬似回線で障害が発生した場合に即時に引き継ぎを行えるようにできます。ここでは、この機能の概念と設定作業について説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの前提条件

この機能では、レイヤ 2 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)の設定方法を理解している必要があります。この情報については、次のマニュアルを参照してください。

『Any Transport over MPLS』

『L2VPN Interworking』

『L2VPN Pseudowire Redundancy』

Cisco 7600 シリーズ ルータでのこの機能の設定については、次のマニュアルを参照してください。

『Cisco 7600 Series Router SIP, SSC, and SPA Software Configuration Guide』

『Cisco 7600 IOS Software Configuration Guide, Release 15.1S』

『Configuring the CEoP and Channelized ATM SPAs』

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能でネットワークの障害を迅速に検出するには、次のメカニズムを設定することをお勧めします。

Label-Switched Path(LSP; ラベル スイッチド パス)Ping/Traceroute および Any Transport over MPLS Virtual Circuit Connection Verification(AToM VCCV; AToM 仮想回線接続検証)

Local Management Interface(LMI; ローカル管理インターフェイス)

Operation, Administration, and Maintenance(OAM; 保守運用管理)

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートに関する制約事項

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートは、L2TPv3 ではサポートされません。MPLS L2VPN だけがサポートされています。

複数のバックアップ擬似回線はサポートされません。

MPLS 擬似回線上で、異なる擬似回線カプセル化タイプはサポートされません。

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートを L2VPN インターワーキングと同時に使用する場合は、プライマリ擬似回線とバックアップ擬似回線のインターワーキング方式が同じである必要があります。TDM アクセス回線では、インターワーキングはサポートされません。

ダイナミック擬似回線だけがサポートされます。

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートについて

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能を設定する前に、次の概念を理解する必要があります。

「ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート 機能の動作」

「サポートされる転送タイプ」

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート 機能の動作

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能は、障害を検出し、サービスの中断を最小限に抑えながら処理することによって、L2VPN 擬似回線のアベイラビリティを向上させます。

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能を使用すると、バックアップ擬似回線を「ホットスタンバイ」ステートにして、プライマリ擬似回線で障害が発生した場合に即時に引き継ぎを行えるようにできます。L2VPN 擬似回線冗長性機能により、バックアップ擬似回線も(ただしコールド ステートで)設定できます。L2VPN 擬似回線冗長性機能を使用すると、プライマリ擬似回線で障害が発生した場合に、バックアップ擬似回線が引き継ぐのに時間がかかり、トラフィックの損失が生じます。

ネットワークで L2VPN 擬似回線冗長性を設定した場合に、Cisco IOS Release 15.1(1)S にアップグレードするときは、ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートを実行するために他のコマンドを追加する必要はありません。バックアップ擬似回線は自動的にホットスタンバイ ステートになります。

サポートされる転送タイプ

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能では、次の転送タイプがサポートされます。

ATM

VC モードでの ATM AAL5

VC モードでの ATM Packed Cell Relay

VP モードでの ATM

VP モードでの ATM Packed Cell Relay

ポート モードでの ATM

ポート モードでの ATM Packed Cell Relay

Time Division Multiplexing(TDM; 時分割多重)

Structure-Agnostic TDM over Packet(SAToP)

Circuit Emulation Services over PSN(CESoPSN)

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート の設定方法

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能を使用すると、プライマリ擬似回線で障害が発生した場合に備えて、バックアップ擬似回線を設定できます。プライマリ擬似回線で障害が発生すると、PE ルータによって、バックアップ擬似回線への切り替えが即時に行われます。

ここでは、ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能を設定する方法について説明します。

「擬似回線クラスの設定」(必須)

「ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定」(必須)

「ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート設定の確認」(任意)

擬似回線クラスの設定

PE ルータの設定によって、PE ルータ間でレイヤ 2 フレームを正常に転送できるかどうかが決まります。ルータ間に擬似回線と呼ばれる接続を設定します。

擬似回線クラス コンフィギュレーション グループには、トンネリング メカニズムの特性を指定します。指定する内容は次のとおりです。

カプセル化タイプ

制御プロトコル

ペイロード固有のオプション

AToM VC が正しく動作するには、擬似回線クラスの一部として encapsulation mpls コマンドを指定する必要があります。 encapsulation mpls コマンドを xconnect コマンドの一部として指定しなかった場合は、次のエラーが表示されます。

% Incomplete command.
 

擬似回線クラスを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. pseudowire-class name

4. encapsulation mpls

5. interworking { ethernet | ip }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class name

 

Router(config)# pseudowire-class atom

指定した名前で擬似回線クラスを作成します。擬似回線クラス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation mpls

 

Router(config-pw-class)# encapsulation mpls

トンネリングのカプセル化を指定します。AToM の場合、カプセル化タイプは mpls です。

ステップ 5

interworking { ethernet | ip }

 

Router(config-pw-class)# interworking ip

(任意)異なるレイヤ 2 カプセル化間の変換をイネーブルにします。

ステップ 6

end

 

Router(config-pw-class)# end

グローバル コンフィギュレーション モードに戻ります。

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能を設定するには、次の手順を実行します。

前提条件

xconnect コマンドの設定は転送タイプごとに少しずつ異なります。

他の転送タイプの xconnect コマンドを設定するには、『 Any Transport over MPLS 』を参照してください。

Circuit Emulation(CEM; 回線エミュレーション)擬似回線を設定するには、『 Configuring the CEoP and Channelized ATM SPAs 』を参照してください。

手順の概要

1. enable

2. configure terminal

3. interface atm number

4. pvc [ name ] vpi/vci l2transport

5. xconnect peer-router-id vcid { encapsulation mpls | pw-class pw-class-name }

6. backup peer peer-router-ip-addr vcid [ pw-class pw-class-name ]

7. backup delay enable-delay { disable-delay | never }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm number

 

Router(config)# interface atm4/1/0

ATM インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

pvc [ name ] vpi/vci l2transport

 

Router(config-if)# pvc 1/100 l2transport

ATM PVC に名前を割り当てるかまたは名前を作成し、L2transport PVC コンフィギュレーション モードを開始します。

ステップ 5

xconnect peer-router-id vcid { encapsulation mpls | pw-class pw-class-name}

 

Router(config-if-atm-l2trans-pvc)# xconnect 10.0.0.1 123 pw-class atom

接続回線を擬似回線 VC にバインドします。

ステップ 6

backup peer peer-router-ip-addr vcid [ pw-class pw-class-name ]

 

Router(config-if-atm-l2trans-pvc)# backup peer 10.0.0.3 125 pw-class atom

擬似回線 VC に冗長ピアを指定します。

擬似回線クラス名は、擬似回線クラスを作成したときに指定した名前と一致する必要があります。ただし、 backup peer コマンドでは、プライマリ xconnect コマンドで使用した名前の擬似回線クラスとは異なる擬似回線クラスを使用できます。

ステップ 7

backup delay e nable-delay { disable-delay | never }

 

Router(config-if-atm-l2trans-pvc)# backup delay 5 never

プライマリ擬似回線 VC が停止したあと、バックアップ擬似回線 VC が引き継ぐまでの待機時間(秒単位)を指定します。値の範囲は 0 ~ 180 です。

プライマリ擬似回線がアクティブになったあと、バックアップ擬似回線 VC を引き継ぐまでのプライマリ擬似回線の待機時間を指定します。値の範囲は 0 ~ 180 秒です。 never キーワード を指定すると、プライマリ擬似回線 VC はバックアップ擬似回線 VC を引き継ぎません。

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート設定の確認

バックアップ擬似回線がホットスタンバイ サポート用にプロビジョニングされていることを確認する場合は、次のコマンドを使用します。

手順の概要

1. show atm acircuit

2. show atm pvc

3. show cem acircuit

4. show cem acircuit detail

手順の詳細


ステップ 1 show atm acircuit

次の例に示すように、 show atm acircuit コマンドの出力で同じ vpi または vci について 2 つのエントリが表示される場合は、バックアップ擬似回線は正しくプロビジョニングされています。

Router# show atm acircuit
 
Interface VPI VCI AC Id Switch Segment St Flg Prov
--------- --- --- -- -- ------- -------- -- --- ----
ATM2/1/0.2 11 111 ATA5 1 2003 4007 2 0 Y
ATM2/1/0.2 11 111 ATA5 1 1002 3006 2 0 Y
 

ステップ 2 show atm pvc

次の例に太字で示すように、 show atm pvc コマンドの出力に「Red Prov: Yes」が含まれている場合は、バックアップ擬似回線 は正しくプロビジョニングされています。

Router# show atm pvc 1/1010
 
Interworking Method: like to like
AC Type: ATM AAL5, Circuit Id: 2, AC State: UP, Prov: YES
Switch Hdl: 0x1005, Segment hdl: 0x4011
Red Switch Hdl: 0x3007, Red Segment hdl: 0x6010, Red Prov: YES
AC Hdl: 0x7200000F, AC Peer Hdl: 0x5D000012, Flg:0, Platform Idx:10
 
Status: UP
 

ステップ 3 show cem acircuit

次の例に太字で示すように、 show cem acircuit コマンドの出力に「Redundancy Member Prov: Yes」が含まれていない場合は、バックアップ擬似回線 は正しくプロビジョニングされています。

Router# show cem acircuit
 
CEM Int. ID Flags Swhdl Seghdl Ckttype Provisioned
----------------------------------------------------------------
CEM3/0/0 1 0 B00E 201E 19 Yes
Redundancy Switch hdl: 0xC00F Redundancy Segment hdl: 0x401F Redundancy Member Prov: Yes
 

ステップ 4 show cem acircuit detail

次の例に太字で示すように、 show cem acircuit detail コマンドの出力に「Redundancy Member Prov: Yes」が含まれていない場合は、バックアップ擬似回線 は正しくプロビジョニングされています。

Router# show cem acircuit detail
 
CEM3/0/0 Cemid 1
PW Ckt_type: 19 Aie hdl: EE00000B Peer aie hdl: 0x2000000C
Switch hdl: 0xB00E Segment hdl: 0x201E Redundancy Switch hdl: 0x1000 Redundancy Segment hdl: 0x4002 Redundancy Member Prov: Yes
 


 

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート の設定例

図 1 に、ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定を示します。ここでは、バックアップ擬似回線は同じ PE ルータ上にあります。

図 1 ホットスタンバイの擬似回線トポロジ

 

図 1 に示されている設定は、次の例で使用されます。

「CEM 回線での ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定:例」

「ATM 回線での ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定:例」

CEM 回線での ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定:例

表 1 CEM 回線での ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定:例

PE1
PE2
interface Loopback0
ip address 10.4.4.4 255.255.255.255
!
Controller E1 9/2/0
clock source internal
cem-group 0 timeslots 1-4
!
pseudowire-class atom
encapsulation mpls
!
interface CEM9/2/0
no ip address
class int cesopsn_1
cem 0
xconnect 10.2.2.2 5000 pw-class atom
backup peer 10.2.2.2 5005 pw-class atom
backup delay 0 5
 
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
Controller E1 2/2/0
clock source internal
cem-group 0 timeslots 1-4 <<<<<< Primary
cem-group 5 timeslots 21-24<<<<< Backup
!
interface CEM2/2/0
no ip address
class int cesopsn_1
cem 0<<<<<<<<<< Primary
service-policy input cem_exp_6
xconnect 10.4.4.4 5000 encapsulation mpls
!
cem 5<<<<<<<<<< Backup
xconnect 10.4.4.4 5005 encapsulation mpls
 

ATM 回線での ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定:例

表 2 ATM 回線での ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの設定:例

PE1
PE2
interface Loopback0
ip address 10.44.44.44 255.255.255.255
!
interface POS3/3/0
ip address 10.4.4.4 255.255.255.0
mpls ip
!
interface ATM4/1/0
no ip address
no atm enable-ilmi-trap
pvc 1/100 l2transport
xconnect 10.22.22.22 1 encapsulation mpls
backup peer 10.22.22.22 2
 
interface Loopback0
ip address 10.22.22.22 255.255.255.255
!
interface POS3/3/0
ip address 10.4.4.1 255.255.255.0
mpls ip
!
interface ATM4/1/0
no ip address
no atm enable-ilmi-trap
pvc 1/100 l2transport
xconnect 10.44.44.44 1 encapsulation mpls
!
pvc 1/200 l2transport
xconnect 10.44.44.44 2 encapsulation mpls

その他の参考資料

ここでは、ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能に関する関連資料について説明します。

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

MPLS コマンド

Cisco IOS Multiprotocol Label Switching Command Reference

7600 シリーズ ルータ上の L2VPN

Cisco 7600 Series Router SIP, SSC, and SPA Software Configuration Guide

Cisco 7600 IOS Software Configuration Guide, Release 15.1S

Configuring the CEoP and Channelized ATM SPAs

Circuit Emulation Services over Packet Switched Network(CESoPSN)モードおよび Structure-Agnostic TDM over Packet(SAToP)モード

Overview of the CEoP and Channelized ATM SPAs

CEM 擬似回線の設定

Configuring the CEoP and Channelized ATM SPAs

Circuit Emulation(CEM; 回線エミュレーション)擬似回線での擬似回線冗長性の設定

Configuring the CEoP and Channelized ATM SPAs

L2VPN 擬似回線

Any Transport over MPLS

L2VPN Interworking』

L2VPN Pseudowire Redundancy』

L2VPN の NSF/SSO

NSF/SSO - Any Transport over MPLS and AToM Graceful Restart

L2VPN の ping および traceroute

MPLS LSP Ping/Traceroute for LDP/TE, and LSP Ping for VCCV

規格

規格
タイトル

draft-muley-pwe3-redundancy

『Pseudowire Redundancy』

draft-ietf-pwe3-iccp- xx .txt

『Inter-Chassis Communication Protocol for L2VPN PE Redundancy』

MIB

MIB
MIB リンク

CISCO-IETF-PW-ATM-MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 5085

『Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for Pseudowires』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの機能情報

表 3 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 3 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 3 ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートの機能情報

機能名
リリース
機能情報

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート

15.1(1)S

ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート機能を使用すると、バックアップ擬似回線を「ホットスタンバイ」ステートにして、プライマリ擬似回線で障害が発生した場合に即時に引き継ぎを行えるようにできます。

15.1(1)S では、この機能は Cisco 7600 で導入されました。

この機能に関する詳細については、次の各項を参照してください。

「ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポートについて」

「ATM および TDM アクセス回線用のホットスタンバイ擬似回線サポート の設定方法」

追加または変更されたコマンドはありません。