マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
MPLS EM - MPLS VPN MIB RFC 4382 Upgrade
MPLS EM - MPLS VPN MIB RFC 4382 Upgrade
発行日;2012/01/31 | 英語版ドキュメント(2011/07/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

MPLS EM - MPLS VPN MIB RFC 4382 Upgrade

目次

の前提条件

に関する制約事項

について

MPLS レイヤ 3 VPN の概要

MPLS-L3VPN-STD-MIB の利点

でサポートされている機能

でサポートされるオブジェクト

のスカラ オブジェクト

MIB テーブル

VRF コンフィギュレーション テーブル(mplsL3VpnVrfTable)

VPN インターフェイス コンフィギュレーション テーブル(mplsL3VpnIfConfTable)

VRF ルート ターゲット テーブル(mplsL3VpnVrfRTTable)

VRF セキュリティ テーブル(mplsL3VpnVrfSecTable)

VRF パフォーマンス テーブル(mplsL3VpnVrfPerfTable)

VRF ルーティング テーブル(mplsL3VpnVrfRteTable)

通知イベント

の SNMP 通知の仕様

ネットワーク管理ステーションでの 通知の表示

IPv6 VPN over MPLS の サポート

IPv6 VPN over MPLS での テーブルとオブジェクトのサポート

IPv6 VPNs over MPLS の 通知サポート

IPv6 アドレス ファミリ VRF ルート制限への最大ルートの設定について

データ セキュリティ

および の主要な相違点

オブジェクトのグローバルな名前変更

および スカラ オブジェクトの相違点

および テーブル オブジェクトの相違点

でサポートされていないテーブル

および 通知の相違点

の設定方法

SNMP コミュニティの設定

MPLS レイヤ3 VPN SNMP 通知をホストに送信するためのルータの設定

MPLS レイヤ3 VPN SNMP 通知のしきい値の設定

MPLS VPN 通知しきい値の SNMP 制御の設定

MPLS EM - MPLS VPN MIB RFC4382 アップグレードの設定例

SNMP コミュニティの設定:例

MPLS レイヤ3 VPN SNMP トラップを送信するためのルータの設定:例

MPLS レイヤ3 VPN SNMP 通知のしきい値の設定:例

MPLS レイヤ3 VPN 通知しきい値の SNMP 制御の設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

の機能情報

用語集

MPLS EM - MPLS VPN MIB RFC 4382 Upgrade

MPLS EM - MPLS VPN MIB RFC 4382 Upgrade 機能のドキュメントでは、RFC 4382『 MPLS/BGP Layer 3 Virtual Private Network (VPN) Management Information Base 』に基づいて Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)レイヤ 3 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)をサポートする MPLS-L3VPN-STD-MIB を説明します。また、RFC 4382 と、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)ドラフト バージョン 3(draft-ieft-ppvpn-mpls-vpn-mib-03.txt)に基づく MPLS-VPN-MIB の相違点を説明します。さらに、MPLS-L3VPN-STD-MIB(RFC 4382)を実装するために必要な変更点についても説明します。MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB は、Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)を使用して、Cisco IOS ソフトウェアで MPLS VPN 機能を管理するインターフェイスを提供します。

Cisco IOS MPLS Embedded Management(EM)は、Fault, Configuration, Accounting, Performance, and Security(FCAPS; 障害、設定、アカウンティング、パフォーマンス、セキュリティ)モデルに従った MPLS ベースのネットワークの開発、操作、アドミニストレーション、および管理を容易にする標準と付加価値サービスのセットです。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールに記載されている機能に関するドキュメントへのリンク、および各機能がサポートされているリリースに関するリストについては、「MPLS EM - MPLS VPN MIB RFC 4382 Upgradeの機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

MPLS EM - MPLS VPN MIB RFC 4382 Upgradeの前提条件

MPLS-L3VPN-STD-MIB エージェントの前提条件は次のとおりです。

SNMP が、Label Switch Router(LSR; ラベル スイッチング ルータ)にインストールされてイネーブルになっている。

LSR で MPLS がイネーブルになっている。

Multiprotocol Border Gateway Protocol(MP-BGP; マルチプロトコル ボーダー ゲートウェイ プロトコル)が、LSR でイネーブルになっている。

LSR でシスコ エクスプレス フォワーディングがイネーブルになっています。

Label Distribution Protocol(LDP; ラベル配布プロトコル)パスまたはトラフィック エンジニアリング トンネリング(RFC 3812)は、Provider Edge(PE; プロバイダー エッジ)ルータと Customer Edge(CE; カスタマー エッジ)ルータ間で設定されます。

MPLS EM - MPLS VPN MIB RFC 4382 Upgradeに関する制約事項

次は Cisco IOS Release 12.2(33)SRC および 12.2(33)SB ではサポートされていません。

トラップ関連のオブジェクトである mplsL3VpnNotificationEnable を除き、SNMP SET コマンドを使用した MIB の設定はサポートされません。

MPLS EM - MPLS VPN MIB RFC 4382 Upgradeについて

このセクションには次のトピックがあります。

「MPLS レイヤ 3 VPN の概要」

「MPLS-L3VPN-STD-MIB の利点」

「MPLS-L3VPN-STD-MIB でサポートされている機能」

「MPLS-L3VPN-STD-MIB でサポートされるオブジェクト」

「MPLS-L3VPN-STD-MIB のスカラ オブジェクト」

「MPLS-L3VPN-STD-MIB MIB テーブル」

「MPLS-L3VPN-STD-MIB 通知イベント」

「IPv6 VPN over MPLS の MPLS-L3VPN-STD-MIB サポート」

「MPLS-L3VPN-STD-MIB データ セキュリティ」

「MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB の主要な相違点」

MPLS レイヤ 3 VPN の概要

MPLS レイヤ 3 VPN テクノロジーを使用すると、サービス プロバイダーはセキュリティおよびサービスをプライベート ネットワークと同じレベルに維持したパブリック ネットワークにカスタマーのリモート オフィスを直接接続するイントラネットおよびエクストラネット VPN サービスを提供できます。各 VPN は、1 つ以上の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスに関連付けられています。ルータに定義されている VPN ごとに VRF が作成されます。VRF には、MPLS レイヤ 3 VPN を管理および監視するために必要な情報のほとんどが含まれています。具体的には、IP ルーティング テーブル、取得されたシスコ エクスプレス フォワーディング テーブル、転送テーブルを使用する一連のインターフェイス、およびルーティング テーブルに格納されている情報を制御するための一連のルールおよびルーティング プロトコル パラメータです。

MPLS-L3VPN-STD-MIB の利点

MPLS-L3VPN-STD-MIB を使用すると、VRF 情報の他に、VRF に含まれているインターフェイス、および他の設定とモニタリング情報にアクセスできます。

MPLS-L3VPN-STD-MIB には次の利点があります。

標準ベースの SNMP インターフェイスにより、重要な MPLS VPN イベントに関する情報を取得できる。

MPLS VPN の管理および監視に VRF 情報を利用できる。

インターフェイス MIB とともに、VRF に割り当てられたインターフェイスに関する情報も利用できる。

ルータのすべての VRF に関するパフォーマンス統計情報を利用できる。

MPLS VPN 対応インターフェイスの動作ステータスが大きく変更された場合、注意を喚起する通知を生成し、キューに入れることができる。ネットワーク管理者が評価し、対策を講じることができるように、指定の Network Management System(NMS; ネットワーク管理システム)に通知メッセージを転送できる。

VPN ルーティング テーブルが容量の限度に近づくか超えたとき、警告を通知できる。

VRF 対応インターフェイスで不正なラベルを受信した場合に、警告を通知できる。このようなラベルを受信した場合は、設定に誤りがあるか、またはセキュリティ違反が試みられた可能性があります。

MPLS-L3VPN-STD-MIB でサポートされている機能

MPLS-L3VPN-STD-MIB では SNMP エージェント コードが動作するため、標準化された SNMP ベースの方法を使用して、Cisco IOS ソフトウェアで MPLS VPN を管理できます。

MPLS-L3VPN-STD-MIB は RFC 4382『 MPLS/BGP Layer 3 Virtual Private Network (VPN) Management Information Base 』に基づいています。この仕様には、MPLS VPN イベントをサポートする機能を説明したオブジェクトが規定されています。

MPLS-L3VPN-STD-MIB では、次の操作を実行できます。

ルータで MPLS VPN のルーティング情報および転送情報を収集する。

VRF ルーティング テーブル内の情報を表示する。

重要な MPLS VPN イベントが発生したときに、変更を伝える通知メッセージを送信する。

既存の SNMP Command-line Interface(CLI; コマンドライン インターフェイス)コマンドの拡張機能を使用して、MPLS VPN イベントに関する通知メッセージをイネーブル、ディセーブル、および設定する。

通知メッセージの送信先となる稼動環境の NMS の IP アドレスを指定する。

通知設定を不揮発性メモリに書き込む。

RFC 4382 と Cisco IOS ソフトウェアに実装している MPLS VPN にはわずかに異なる部分があるため、MPLS-L3VPN-STD-MIB と Cisco IOS ソフトウェアの内部データ構造との間でいくつかの軽微な変換が必要となります。このような変換は、SNMP エージェント コードによって実行されます。また、SNMP エージェントはロー プライオリティのプロセスとして動作し、Cisco IOS ソフトウェアへの管理インターフェイスとなります。SNMP が動作しても、デバイスの通常の機能へのオーバーヘッドはわずかです。

すべての MPLS-L3VPN-STD-MIB オブジェクトは RFC 4382 に基づいています。このため、Cisco 固有の SNMP アプリケーションを使用することなく、MPLS-L3VPN-STD-MIB に関する機能および操作をサポートできます。

MPLS-L3VPN-STD-MIB でサポートされるオブジェクト

MPLS-L3VPN-STD-MIB には、Cisco IOS ソフトウェアで読み取り専用の SNMP を使用して MPLS VPN 機能を管理するためのテーブルとオブジェクト定義が数多く含まれています。MPLS-L3VPN-STD-MIB は、Abstract Syntax Notation One(ASN.1; 抽象構文記法 1)に準拠し、これにより、理想的な MPLS VPN データベースが提供されます。

標準の SNMP ネットワーク管理アプリケーションを使用すると、GET 操作で MPLS-L3VPN-STD-MIB から情報を取得して表示できます。また、GETNEXT 操作で MIB データベース内の情報を走査して表示することもできます。

MPLS-L3VPN-STD-MIB テーブルおよびオブジェクトについては、以降の項で簡単に説明します。

「MPLS-L3VPN-STD-MIB のスカラ オブジェクト」

「MPLS-L3VPN-STD-MIB MIB テーブル」

「MPLS-L3VPN-STD-MIB 通知イベント」

図 1 に、簡単な MPLS VPN 設定を示します。この設定には、(VPN1 と VPN2 のラベルが付いた)カスタマー MPLS VPN が 2 つ含まれています。また、(PE1 と PE2 のラベルが付いた)Provider Edge(PE; プロバイダー エッジ)ルータ 2 台と、P のラベルが付いたプロバイダー コア ルータ 1 台で構成されている簡単なプロバイダー ネットワークも含まれています。図 1 に、次の設定例を示します。

VRF 名:VPN1 および VPN2

VRF に関連付けられたインターフェイス:Et1、Et2、および At3/0

ルーティング プロトコル:Open Shortest Path First(OSPF)、Routing Information Protocol(RIP)、Interior Border Gateway Protocol(IBGP; 内部ボーダー ゲートウェイ プロトコル)

VPN1 に関連付けられたルート:10.1.0.0、10.2.0.0、および 10.3.0.0

VPN2 に関連付けられたルート:172.16.1.0 および 172.16.2.0

プロバイダー ネットワークに関連付けられたルート:192.168.1.0、192.168.2.0、および 192.168.3.0

この設定を使用して、MPLS-L3VPN-STD-MIB が監視および管理する MPLS VPN イベントについて説明します。

図 1 MPLS レイヤ 3 VPN の設定例

 

IPv6 VPN over MPLS(6VPE)の設定については、『 Cisco IOS IPv6 Configuration Guide 』の「Implementing IPv6 VPN over MPLS (6VPE)」の章を参照してください。

MPLS-L3VPN-STD-MIB のスカラ オブジェクト

MPLS-L3VPN-STD-MIB では、複数のスカラ オブジェクトを定義します。 表 1 で、Cisco IOS Release 12.2(33)SRC および Release 12.2(33)SB に実装されているスカラ オブジェクトを説明します。

 

表 1 MPLS-L3VPN-STD-MIB のスカラ オブジェクト

MIB オブジェクト
説明

mplsL3VpnConfiguredVrfs

ルータに設定された VRF の数。最近削除されたものも含まれています。

mplsL3VpnActiveVrfs

ルータでアクティブな VRF の数。アップ状態である 1 つ以上のインターフェイスにアクティブな VRF が割り当てられます。

mplsL3VpnConnectedInterfaces

VRF に割り当てられたインターフェイスの総数。

mplsL3VpnNotificationEnable

MPLS-L3VPN-STD-MIB 通知をイネーブルまたはディセーブルにするオブジェクト。

このオブジェクトを true に設定すると、MPLS-L3VPN-STD-MIB に定義されているすべての通知がイネーブルになります。

このオブジェクトを false に設定すると、MIB に定義されているすべての通知がディセーブルになります。これがデフォルトです。

これは、書き込み可能な数少ないオブジェクトの 1 つです。

mplsL3VpnVrfConfMaxPossRts

このルータが格納できるルートの数。システムで使用可能なメモリ容量に基づくため、この値は特定できません。このため、このオブジェクトはゼロ(0)に設定されます。

mplsL3VpnVrfConfRteMxThrshTime

最大ルート数に達したあとに、ルートを引き続き追加しようとした場合に、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知が送信される秒単位の間隔。

デフォルト値は 0 です。値が 0 の場合、ルート数がしきい値より下回り、ルート数が再度しきい値を超えようとしないかぎり、MIB エージェントは二度と通知を送信しません。

次のコンフィギュレーション コマンドを使用して、最大しきい値の通知が送信されるまでの秒数を指定できます。

Router(config)# snmp mib mpls vpn max-threshold seconds
 

mplsL3VpnIllLblRcvThrsh

この数を超える不正なラベルを受信すると、mplsNumVrfSecIllglLblThrshExcd 通知が生成されます。デフォルト値は 0 です。

次のコンフィギュレーション コマンドを使用して、通知を生成する不正なラベルの数を設定できます。

Router(config)# snmp mib mpls vpn illegal-label number
 

VRF コンフィギュレーション テーブル(mplsL3VpnVrfTable)

VRF コンフィギュレーション テーブル(mplsL3VpnVrfTable)のエントリは、ルータに設定されている VRF インスタンスを表します。この中には、最近削除された VRF も含まれています。このテーブルの情報は、 show vrf detail コマンドの出力にも表示されます。

各 VRF は、それぞれの VRF 名(mplsL3VpnVrfName)で参照されます。

表 2 に、VRF コンフィギュレーション テーブル(mplsL3VpnVrfTable)でサポートされている MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクトのリストを示します。

 

表 2 VRF コンフィギュレーション テーブル:MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクト

MIB オブジェクト
MPLS レイヤ 3 VPN 情報

mplsL3VpnVrfName

この VRF に関連付けられた名前。このオブジェクトがテーブルのインデックスとして使用される場合、最初のオクテットは文字列の長さで、後続のオクテットは各文字の ASCII コードとなります。たとえば、「vpn1」は 4.118.112.110.49 と表されます。

VRF 名は VPN ID と同じにできます。VRF 名が VPN ID と同じである場合、VRF 名は mplsL3VpnVrfVpnId MIB オブジェクトの値と同じである必要があります。同じ VPN に参加する VRF をサポートするすべてのサイトで、VRF に同じ命名規則と同じ VPN ID を使用することを推奨します。

mplsL3VpnVrfVpnId

RFC 2685 に基づく VPN 識別番号。VPN ID を指定しない場合、値は空白の文字列です。

mplsL3VpnVrfDescription

VRF の説明。これは、VRF コンフィギュレーション モードの description コマンドで指定されます。

Router(config)# vrf definition vrf-name
Router(config-vrf)# description vrf-description
 
コマンドを使用すると、IPv4 アドレス ファミリ VRF だけを設定できます。

mplsL3VpnVrfRD

この VRF のルート識別子。これは、VRF コンフィギュレーション モードの rd コマンドで指定されます。

Router(config)# vrf definition vrf-name
Router(config-vrf)# rd route-distinguisher
 
コマンドを使用すると、IPv4 アドレス ファミリ VRF だけを設定できます。

mplsL3VpnVrfCreationTime

この VRF エントリが作成されたときの sysUpTime の値。

mplsL3VpnVrfOperStatus

この VRF の動作ステータス。VRF に関連付けられた少なくとも 1 つのインターフェイスがアップであると、VRF はアップ(1)となります。次の場合には、VRF はダウン(2)となります。

ifOperStatus がアップ(1)となっているインターフェイスがない。

この VRF に関連付けられたインターフェイスがない。

mplsL3VpnVrfActiveInterfaces

この VRF に割り当てられたインターフェイスのうち、アップしているインターフェイスの数。

mplsL3VpnVrfAssociatedInterfaces

動作ステータスとは関係なく、この VRF に割り当てられたインターフェイスの数。

mplsL3VpnVrfConfMidRteThresh

中間しきい値。VRF ルートの数がこのしきい値を超えた場合、mplsL3VpnVrfRouteMidThreshExceeded 通知が送信されます(通知がイネーブルで、かつ設定されている場合)。この値は、VRF アドレス ファミリ コンフィギュレーション モードで、次のように maximum routes limit { warn-threshold | warn-only } コマンドを使用して、最大値に占める割合として設定できます。

たとえば、次の maximum routes コマンドは、VRF vpn1 の IPv4 アドレス ファミリの警告しきい値を、最大ルートしきい値の 50 % に設定します。

Router(config)# vrf definition vpn1
Router(config-vrf)# address-family ipv4
Router(config-vrf-af)# maximum routes 1000 50
 

また、vpn1 に IPv6 アドレス ファミリも設定されている場合、次の maximum routes コマンドは、IPv6 アドレス ファミリの警告しきい値を、最大ルートしきい値の 50 % に設定します。

Router(config)# vrf definition vpn1
Router(config-vrf)# address-family 1pv6
Router(config-vrf-af)# maximum routes 2000 50
 
コマンドを使用すると、IPv4 アドレス ファミリ VRF だけを設定できます。

IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、このしきい値は警告しきい値の集約になります。この例では、集約された警告しきい値は 1500 ルート [(ipv4 = 500)+(ipv6 = 1000)] です。両方のアドレス ファミリがそれぞれの警告しきい値に達しないかぎり、mplsL3VpnVrfRouteMidThreshExceeded 通知は送信されません。VRF にアドレス ファミリが 1 つだけ存在する場合、その 1 つのアドレス ファミリの警告しきい値に達すると、mplsL3VpnVrfRouteMidThreshExceeded 通知は送信されます。

次のコマンドでは、1000 ルートの中間しきい値を設定しています。このしきい値を超えると、mplsL3VrfRouteMidThreshExceeded 通知が送信されます。ただし、このコマンドでは最大ルートしきい値を設定していないため、引き続きルートを追加できます。

Router(config-vrf-if)# maximum routes 1000 warn-only
 

mplsL3VpnVrfRouteMidThreshExceeded 通知の詳細については、「MPLS-L3VPN-STD-MIB 通知イベント」を参照してください。

mplsL3VpnVrfConfHighRteThresh

最大ルートしきい値。VRF ルートの数がこのしきい値を超えた場合、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知が送信されます(通知がイネーブルで、かつ設定されている場合)。この値は、VRF アドレス ファミリ コンフィギュレーション モードで、次のように maximum routes limit { warn-threshold | warn-only } コマンドを使用して設定できます。

Router(config)# vrf definition vpn2
Router(config-vrf)# address-family ipv4
Router(config-vrf-af)# maximum routes 1000 75
 
Router(config)# vrf definition vpn2
Router(config-vrf)# address-family ipv6
Router(config-vrf-af)# maximum routes 2000 75
 
コマンドを使用すると、IPv4 アドレス ファミリ VRF だけを設定できます。

IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、このしきい値は最大しきい値の集約になります。この例では、集約された最大ルートしきい値は 3000 [(ipv4 = 1000)+(ipv6 = 2000)] です。両方のアドレス ファミリがそれぞれの最大ルートしきい値に達しないかぎり、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知は送信されません。VRF にアドレス ファミリが 1 つだけ存在する場合、その 1 つのアドレス ファミリの最大ルートしきい値に達すると、mplsL3VpnVrfRouteMaxThreshExceeded 通知は送信されます。最大ルートしきい値にすでに達しているアドレス ファミリには、ルートは追加されません。

mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知の詳細については、「MPLS-L3VPN-STD-MIB 通知イベント」を参照してください。

mplsL3VpnVrfConfMaxRoutes

この値は、mplsL3VpnVrfConfHighRteThresh と同じです。

mplsL3VpnVrfConfLastChanged

VRF の設定が変更されたとき、または VRF からインターフェイスが割り当てられたか、割り当てられなかったときの sysUpTime の値。

(注) このオブジェクトは、このテーブルの値が変更されたときにだけ更新されます。

mplsL3VpnVrfConfRowStatus

テーブルの行のステータス。このオブジェクトは通常「active (1)」になりますが、VRF が最近削除された場合には「notInService(2)」になることもあります。

mplsL3VpnVrfConfAdminStatus

VRF の動作ステータス。有効値は次のとおりです。

up (1):少なくとも 1 つのインターフェイスが管理用に起動していて、VRF はパケットを渡す準備ができています。

down (2):すべてのインターフェイスは管理用にダウしているため、VRF はパケットを渡すことができません。

mplsL3VpnVrfConfStorageType

VRF エントリのストレージ タイプ。このオブジェクトは常に「volatile (2)」の値を返します。

VPN インターフェイス コンフィギュレーション テーブル(mplsL3VpnIfConfTable)

Cisco IOS ソフトウェアでは、VRF は 1 つの MPLS レイヤ 3 VPN に関連付けられます。1 つの VRF に 0 個以上のインターフェイスを関連付けることができます。VRF は、MIB II(IFMIB)のインターフェイス グループの ifTable に定義されているインターフェイスを使用します。IFMIB には、インターフェイスを管理するためのオブジェクトが定義されています。この MIB の ifTable には、ネットワーク内の各インターフェイスに関する情報が登録されています。mplsL3VpnIfConfTable は、mplsL3VpnVrfTable の VRF を ifTable の転送インターフェイスに関連付けます。図 2 に、ifTable および mplsL3VpnIfConfTable に定義されている VRF とインターフェイスとの関係を示します。

図 2 VRF、インターフェイス MIB、および mplsL3VpnIfConfTable

 

VPN インターフェイス コンフィギュレーション テーブル(mplsL3VpnIfConfTable)のエントリは、各 VRF に割り当てられるインターフェイスを表します。このテーブルの情報は、 show vrf コマンドの出力にも表示されます。

mplsL3VpnIfConfTable には、インターフェイスをどのように VRF に割り当てるかが記載されています。LSR は、MPLS レイヤ 3 VPN に対応できるインターフェイスごとに、このテーブルにエントリを作成します。

mplsL3VpnIfConfTable のインデックスは、次のように作成されます。

mplsL3VpnVrfName:VRF 名

mplsL3VpnIfConfIndex:VRF に割り当てられたインターフェイスのインターフェイス MIB からの ifIndex と同じ識別子

表 3 に、VPN インターフェイス コンフィギュレーション テーブル(mplsL3VpnIfConfTable)でサポートされている MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクトのリストを示します。

 

表 3 VPN インターフェイス コンフィギュレーション テーブル:MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクト

MIB オブジェクト
MPLS レイヤ 3 VPN 情報

mplsL3VpnIfConfIndex

VRF に割り当てられているこのインターフェイスのインターフェイス MIB ifIndex を提供します。

mplsL3VpnIfVpnClassification

このインターフェイスが提供している VPN のタイプを指定します。Carrier Supporting Carrier(CSC)(1)、企業(2)、InterProvider(3)のいずれかになります。

このインターフェイスで MPLS がディセーブルである場合には企業(2)に設定され、MPLS がイネーブルになっている場合には Carrier Supporting Carrier(1)に設定されます。

mplsL3VpnIfVpnRouteDistProtocol

このインターフェイス上で、PE から CE へのリンク間でルートを再配布するために使用されるルート配布プロトコルを示します。値は、none(0)、BGP(1)、OSPF(2)、RIP(3)、Intermediate System-Intermediate System(IS-IS)(4)、static(5)、other (6)です。複数のプロトコルを同時にイネーブルにできます。

Cisco IOS ソフトウェアでは、インターフェイス単位ではなく VRF 単位でルータ プロセスが定義され、再配布されます。このため、同じ VRF に割り当てられたすべてのインターフェイスで、このオブジェクトの値が同じものになります。

mplsL3VpnIfConfStorageType

VPN インターフェイス エントリのストレージ タイプを示します。このオブジェクトのデフォルト値は「volatile (2)」です。

mplsL3VpnIfConfRowStatus

指定したインターフェイスと VRF を関連付けるテーブル内の行のステータスを提供します。このオブジェクトは通常「active (1)」になりますが、VRF が最近削除された場合には「notInService(2)」になることもあります。

VRF ルート ターゲット テーブル(mplsL3VpnVrfRTTable)

VRF ルート ターゲット テーブル(mplsL3VpnVrfRTTable)には、特定の VRF に対して定義されているルート ターゲット コミュニティが登録されます。MPLS レイヤ 3 VPN インスタンスをサポートする VRF 用に設定されたターゲットごとに、LSR がこのテーブルにエントリを作成します。

VPN ルーティング情報の配布は、BGP 拡張コミュニティによって実装される VPN ルート ターゲット コミュニティを使用して制御されます。VPN ルーティング情報の配布は、次のように機能します。

CE ルータから学習した VPN ルートが BGP に注入されると、VPN ルート ターゲット拡張コミュニティ アトリビュートのリストが、そのルートに関連付けられます。通常、ルート ターゲット コミュニティ値のリストは、ルートの学習元の VRF に関連付けられているルート ターゲットのエクスポート リストから設定されます。

ルート ターゲット拡張コミュニティのインポート リストは、各 VRF に関連付けられています。インポート リストには、ルートが VRF にインポートされるために、ルートに設定されている必要のある、ルート ターゲット拡張コミュニティ アトリビュートが定義されています。たとえば、ある特定の VRF のインポート リストにルート ターゲット コミュニティ A、B、および C が含まれている場合、これらのルート ターゲット拡張コミュニティ A、B、または C のいずれかを伝送するすべての VPN ルートが VRF にインポートされます。

図 3 に、設定例および設定と mplsL3VpnVrfRTTable との関係を示します。各 PE ルータにルート ターゲット テーブルが存在します。設定例には、Route Distinguisher(RD; ルート識別子)が 100:1、100:2、および 100:3 のルータが示されています。図 3 には RD が 100:4 および 100:5 のルータは示されていませんが、PE2 のルート ターゲットおよび mplsL3VpnVrfRTTable には含まれています。

図 3 設定例および mplsL3VpnVrfRTTable

 

mplsL3VpnVrfRTTable には、各 VRF のインポート ルート ターゲットおよびエクスポート ルート ターゲットが登録されています。次の機能によって、テーブルにインデックスが作成されます。

mplsL3VpnVrfName:VRF 名

mplsL3VpnVrfRTIndex:ルート ターゲット エントリ識別子

mplsL3VpnVrfRTType:エントリがインポート ルート ターゲット、エクスポート ルート ターゲット、またはその両方に定義されているかを指定する値。

表 4 に、VRF ルート ターゲット テーブル(mplsL3VpnVrfRTTable)でサポートされている MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクトのリストを示します。

 

表 4 VRF ルート ターゲット テーブル:MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクト

MIB オブジェクト
MPLS レイヤ 3 VPN 情報

mplsL3VpnVrfRTIndex

テーブル内での各ルート ターゲットの位置を定義する値。

mplsL3VpnVrfRTType

ルート ターゲット配布タイプ:インポート(1)、エクスポート(2)、両方(3)。

mplsL3VpnVrfRT

ルート ターゲット配布ポリシー。このターゲットのルート識別子を決定します。

mplsL3VpnVrfRTDescr

このオブジェクトには、ルート ターゲットが宣言されているアドレス ファミリを示す文字列が含まれています。ルート ターゲットが IPv4 アドレス ファミリで宣言されている場合、このオブジェクトの値は AF_IPv4 です。ルート ターゲットが IPv6 アドレス ファミリアドレス ファミリで宣言されている場合、このオブジェクトの値は AF_IPv6 です。

mplsL3VpnVrfRTRowStatus

テーブルの行のステータス。このオブジェクトは通常「active (1)」になりますが、VRF が最近削除された場合には「notInService(2)」になることもあります。

mplsL3VpnVrfRTStorageType

VPN ルート ターゲット エントリのストレージ タイプ。このオブジェクトのデフォルト値は「volatile (2)」です。

VRF セキュリティ テーブル(mplsL3VpnVrfSecTable)

VRF セキュリティ テーブル(mplsL3VpnVrfSecTable)には、VRF ごとにセキュリティに関する説明が登録されています。LSR は、MPLS レイヤ 3 VPN に対応できる VRF ごとに、このテーブルにエントリを作成します。

mplsL3VpnVrfSecTable は mplsL3VpnVrfTable を強化したもので、同じインデックスが作成されています。

表 5 に、VRF セキュリティ テーブル(mplsL3VpnVrfSecTable)でサポートされている MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクトのリストを示します。

 

表 5 VRF セキュリティ テーブル :MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクト

MIB オブジェクト
MPLS レイヤ 3 情報

mplsL3VpnVrfSecIllegalLblVltns

VRF インターフェイスで不正に受信したラベルの数。このオブジェクトでは、不正なラベルだけがカウントされます。このため、このオブジェクトは、MPLS 対応(Carrier Supporting Carrier(CSC)状況)の VRF インターフェイスにだけ適用されます。

ラベルが有効なラベル範囲を上回るか下回るか、ラベルがグローバル ラベル転送テーブルにないか、または誤った VRF(受信インターフェイスのテーブル ID と適切な VRF ラベル転送テーブルにあるテーブル ID とが一致しない)でラベルが受信されるたびに、このカウンタが増分されます。

(注) 管理システムの再初期化時や、mplsL3VpnVrfSecDiscontinuityTime オブジェクトの値で示されているときに、中断が発生する場合があります。

mplsL3VpnVrfSecDiscontinuityTime

このエントリのカウンタが最後に 1 つ以上中断したときの sysUpTime の値。スイッチオーバーにより中断が発生します。ローカル管理システムを最後に再初期化してから中断が発生しなかった場合、このオブジェクトには値 0 が格納されます。

VRF パフォーマンス テーブル(mplsL3VpnVrfPerfTable)

VRF パフォーマンス テーブル(mplsL3VpnVrfPerfTable)には、各 VRF の統計パフォーマンス情報が登録されています。LSR は、MPLS レイヤ 3 VPN に対応できる VRF ごとに、このテーブルにエントリを作成します。

mplsL3VpnVrfPerfTable は mplsL3VpnVrfTable を強化したもので、同じインデックスが作成されています。

表 6 に、VRF パフォーマンス テーブル(mplsL3VpnVrfPerfTable)でサポートされている MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクトのリストを示します。

 

表 6 VRF パフォーマンス テーブル:MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクト

MIB オブジェクト
MPLS レイヤ 3 VPN 情報

mplsL3VpnVrfPerfRoutesAdded

このカウンタの値は、最後の中断からこの VRF に追加されたルートの数です。管理システムの再初期化時(スイッチオーバーなど)や、mplsL3VpnVrfPerfDiscTime オブジェクトの値で示されているときに、中断が発生する場合があります。

IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、このカウンタの値は、VRF に追加された IPv4 と IPv6 のルーティング テーブルからのルート数の合計です。

mplsL3VpnVrfPerfRoutesDeleted

このカウンタの値は、この VRF から削除されたルートの数です。

(注) 管理システムの再初期化時や、mplsL3VpnVrfPerfDiscTime オブジェクトの値で示されているときに、中断が発生する場合があります。

IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、このカウンタの値は、VRF から削除された IPv4 と IPv6 のルーティング テーブルからのルート数の合計です。

mplsL3VpnVrfPerfCurrNumRoutes

この VRF 内に現在定義されているルートの数。

IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、ルートの数は、VRF に定義されている IPv4 と IPv6 アドレス ファミリのルート数の合計です。

mplsL3VpnVrfPerfRoutesDropped

このオブジェクトはサポートされません。カウンタは常に値 0 を返します。

mplsL3VpnVrfPerfDiscTime

このエントリのカウンタが 1 つ以上中断したときの sysUpTime の値。スイッチオーバーにより中断が発生します。ローカル管理サブシステムを最後に再初期化してから中断が発生しなかった場合、このオブジェクトには値 0 が格納されます。

VRF ルーティング テーブル(mplsL3VpnVrfRteTable)

VRF ルーティング テーブル(mplsL3VpnVrfRteTable)には、各 MPLS レイヤ 3 VPN VRF のインターフェイス ルーティング テーブル単位の情報が登録されています。

このテーブルで利用できる情報は、IPv4 ルートの場合、 show ip route vrf vrf-name コマンドで表示でき、IPv6 ルートの場合、 show ipv6 route vrff vrf-name コマンドで表示できます。

たとえば、図 1 の PE1 の場合、 show ip route vrf vpn1 コマンドを使用すると、次のような結果が表示されます。

Router# show ip route vrf vpn1
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
!
Gateway of last resort is not set
!
10.0.0.0/32 is subnetted, 3 subnets
B 10.3.0.0 [200/0] via 192.168.2.1, 04:36:33
C 10.1.0.0/16 is directly connected, Ethernet1
C 10.2.0.0/16 [200/0] directly connected Ethernet2, 04:36:33
 

show ip route vrf vpn2 コマンドを実行すると、次のような結果が得られます。

Router# show ip route vrf vpn2
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
!
Gateway of last resort is not set
!
172.16.0.0/32 is subnetted, 2 subnets
B 172.16.2.0 [200/0] via 192.168.2.1, 04:36:33
C 172.16.1.0 is directly connected, ATM 3/0
 

次に、 show ipv6 route vrf コマンドで表示される、vrf3 という名前の VRF に関連する IPv6 出力例を示します。

Router# show ipv6 route vrf vrf3
 
IPv6 Routing Table vrf3 - 6 entries
 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 
C 2001:8::/64 [0/0]
via ::, FastEthernet0/0
L 2001:8::3/128 [0/0]
via ::, FastEthernet0/0
B 2002:8::/64 [200/0]
via ::FFFF:192.168.1.4,
B 2010::/64 [20/1]
via 2001:8::1,
C 2012::/64 [0/0]
via ::, Loopback1
L 2012::1/128 [0/0]
via ::, Loopback1
 

図 4 に、ルーティング テーブル、VRF、および mplsL3VpnVrfRteTable の関係を示します。 show ip route vrf vrf-name コマンドを使用して、VPN1 および VPN2 ルート テーブルに関する情報を表示できます。IPv4 ルートのグローバル ルート テーブルは、IP-FORWARD-MIB の ipCidrRouteTable と同じです。 show ip route コマンドを使用して、グローバル ルート テーブルに関する情報を表示できます。

図 4 IPv4 ルート テーブル、VRF、および mplsL3VpnVrfRteTable

 

show ipv6 route vrf { vrf-name | vrf-number } コマンドを使用して、IPv6 ルート テーブルに関する情報を表示できます。IPv6 ルートのグローバル ルート テーブルは、IP-FORWARD-MIB の inetCidrRouteTable と同じです。 show ipv6 route コマンドを使用して、グローバル ルート テーブルに関する情報を表示できます。

図 5 に、マルチプロトコル VRF を示します。このマルチプロトコル VRF では、vrf1 という VRF が IPv6 と IPv4 の両方のルートでイネーブルであり、2 つのインターフェイス(IF1、IF2)、2 つのテーブルのセット(IPv4 RIB と FIB、IPv6 RIB と FIB)、共通ポリシーまたは個別のポリシーのセットに関連付けられています。

図 5 マルチプロトコル VRF

 

LSR が、設定されるルートごとに mplsL3VpnVrfRteTable にエントリを作成します。MPLS レイヤ 3 VPN に対応できる特定の VRF のコンテキスト内で、ダイナミックまたはスタティックに作成します。

mplsL3VpnVrfRteTable のインデックスが次のように作成されます。

mplsL3VpnVrfName:VRF ルーティング コンテキストを提供する VRF 名

mplsL3VpnVrfRteInetCidrDestType:宛先アドレス タイプ(IPv4 または IPv6)

mplsL3VpnVrfRteInetCidrDest:宛先の IPv4 または IPv6 アドレス

mplsL3VpnVrfRteInetCidrPfxLen:IP 宛先アドレスのプレフィクス長。

mplsL3VpnVrfRteInetCidrPolicy:同じ宛先への複数のパスを識別するインデックス

mplsL3VpnVrfRteInetCidrNHopType:ネクスト ホップ IP アドレスのアドレス タイプ(IPv4 または IPv6)

mplsL3VpnVrfRteInetCidrNextHop:ルート エントリごとのネクスト ホップの IP アドレス

表 7 に、VRF ルーティング テーブル(mplsL3VpnVrfRteTable)でサポートされている MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクトのリストを示します。このテーブルは、VRF 固有のルートを表します。グローバル ルーティング テーブルは、IP-FORWARD-MIB の ipCidrRouteTable(IPv4 ルート)または inetCidrRouteTable(IPv6 ルート)です。

 

表 7 VRF ルーティング テーブル:MPLS レイヤ 3 VPN 情報と、それに関連する MIB オブジェクト

MIB オブジェクト
MPLS レイヤ 3 VPN 情報

mplsL3VpnVrfRteInetCidrDestType

IP 宛先アドレスのアドレス タイプ。このオブジェクトの値は、ipv4 (1) または ipv6 (2) です。

mplsL3VpnVrfRteInetCidrDest

このルートに対して定義されている宛先 IP アドレス。このアドレスのタイプは、mplsL3VpnVrfRteInetCidrDestType オブジェクトの値によって決定されます。

インデックス オブジェクト mplsL3VpnVrfRteInetCidrDest および mplsL3VpnVrfRteInetCidrPfxLen の値は一致している必要があります。

mplsL3VpnVrfRteInetCidrPfxLen

宛先アドレスのプレフィクス長(mplsL3VpnVrfRteInetCidrDest)。

インデックス オブジェクト mplsL3VpnVrfRteInetCidrDest および mplsL3VpnVrfRteInetCidrPfxLen の値は一致している必要があります。

mplsL3VpnVrfRteInetCidrPolicy

同じ宛先への複数のパスを識別するために使用されるインデックス。デフォルト値は、(0 0) です。

mplsL3VpnVrfRteInetCidrNHopType

ネクストホップ IP アドレスのアドレス タイプ。このオブジェクトの値は、unknown (0)、ipv4 (1)、ipv6 (2)、ipv6z (4) のいずれかです。リモートではないルートでは、値を unknown (0) に設定します。

mplsL3VpnVrfRteInetCidrNextHop

このルートに対して定義されているネクストホップ IP アドレス。このアドレスのタイプは、mplsL3VpnVrfRteInetCidrNHopType オブジェクトによって決定されます。

mplsL3VpnVrfRteInetCidrIfIndex

このルートの転送に使用されるインターフェイスのインターフェイス MIB ifIndex。ルートにインターフェイスが定義されていない場合には、オブジェクトは 0 になります。

mplsL3VpnVrfRteInetCidrType

ルートのタイプ。値 local (3) はネクスト ホップが最後の宛先であるルートを示します。値 remote (4) はネクスト ホップが最後の宛先でないルートを示します。

mplsL3VpnVrfRteInetCidrProto

このルートを VRF に追加したルーティング プロトコル。

mplsL3VpnVrfRteInetCidrAge

このルートが最後に更新されてから経過した秒数。

mplsL3VpnVrfRteInetCidrNextHopAS

このルートのネクストホップの自律システム番号。このオブジェクトはサポートされず、常に 0 になります。

mplsL3VpnVrfRteInetCidrMetric1

このルートに使用されるプライマリ ルーティング メトリック。

mplsL3VpnVrfRteInetCidrMetric2
mplsL3VpnVrfRteInetCidrMetric3
mplsL3VpnVrfRteInetCidrMetric4
mplsL3VpnVrfRteInetCidrMetric5

このルートに使用される代替ルーティング メトリック。これらのオブジェクトは、Cisco Interior Gateway Routing Protocol(IGRP)プロトコルおよび Cisco Enhanced Interior Gateway Routing Protocol(EIGRP)プロトコルの場合にだけサポートされます。これらのオブジェクトによって、ルートに使用される帯域幅メトリックが表示されます。それ以外の場合、これらの値は -1 に設定されます。

mplsL3VpnVrfRteXCPointet

このオブジェクトはサポートされません。これは空白の文字列を返します。

VRF ルート テーブル エントリに関連付けられているエントリの相互接続インデックスは、MPLS-LSR-STD-MIB の MPLS 相互接続テーブル(mplsXCTable)にあります。

mplsL3VpnVrfRteInetCidrStatus

行のステータス。このオブジェクトは通常「active (1)」になりますが、VRF が最近削除された場合には「notInService (2)」になることもあります。行のステータスが active (1) の場合、行のエントリは変更できません。

MPLS-L3VPN-STD-MIB 通知イベント

MPLS-L3VPN-STD-MIB の次の通知がサポートされています。

mplsL3VpnVrfUp:この通知は VRF が起動していることを示します。この通知は、VRF に関連付けられているすべてのインターフェイスがダウン状態にある中で、その内の 1 つのインターフェイスが起動したときに生成され、NMS に送信されます。

mplsL3VpnVrfDown:この通知は VRF がダウンしていることを示します。この通知は、VRF に関連付けられている 1 つ以外のインターフェイスがすでにすべてダウン状態にある中で、VRF に関連付けられている最後のインターフェイスがダウンしたときに生成され、NMS に送信されます。

mplsL3VpnVrfRouteMidThreshExceeded:この通知は、中間しきい値または警告しきい値である mplsL3VpnVrfMidRouteThreshold を超えると生成されて送信されます。このしきい値は、次のコマンドを使用して CLI で設定できます。

Router(config)# vrf definition vrf-name
Router(config-vrf)# address-family {ipv4 |ipv6}
Router(config-vrf-af)# maximum routes limit warn-threshold [% of max)
 

warn-threshold 引数は、 limit 引数に指定した最大ルートの割合となります。また、次のコマンドで中間しきい値を設定することもできます。 limit 引数には、警告しきい値を指定します。

Router(config-vrf-af)# maximum routes limit warn-only
 

この通知は、しきい値を超えたときにだけ NMS に送信されます。(警告しきい値と最大しきい値との比較については、図 6 を参照してください)。ルートの数がこのしきい値を下回り、再度しきい値を超えるたびに、通知が NMS に送信されます。

If IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、このしきい値は警告しきい値の集約になります。2 つめのアドレス ファミリがその警告しきい値に達しないかぎり、mplsL3VpnVrfRouteMidThreshExceeded 通知は送信されません。

mplsL3VpnVrfNumVrfRouteMaxThreshExceeded:mplsL3VpnVrfMaxRouteThreshold オブジェクトで示されている最大ルート数がすでに含まれている VRF でルートを作成しようとすると、この通知が生成されて送信されます。最大ルート数は、 maximum routes コマンドの limit 引数で定義されます。

Router(config)# vrf definition vrf-name
Router(config-vrf)# address-family {ipv4 |ipv6}
Router(config-vrf-af)# maximum routes limit warn-threshold [% of max]
 

最大しきい値を超えようとすると、トラップ通知が NMS に送信されます。ルートの数が最大しきい値を下回り、再度最大しきい値に達した場合や、mplsL3VpnVrfConfRteMxThrshTime の値がゼロ以外の場合に間隔が経過した場合、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知がもう 1 つ送信されます(この通知のしくみを示す例、および最大しきい値と警告しきい値の比較については、図 6 を参照してください)。

最大ルート数を超えてルートを追加しようとすると、SNMP は通知を 1 通送信します。ルート数が最大ルート数を下回り、その制限を超えてルートを追加しようとないかぎり、他の通知は送信されません。

ただし、0 以外の値(0 はデフォルト)を指定して snmp mib mpls vpn max-threshold time コマンドを設定した場合に、別のルートを追加しようとすると、間隔が経過したあとに SNMP は通知の送信を繰り返します。

If IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、このしきい値は最大しきい値の集約になります。2 つめのアドレス ファミリが最大ルートしきい値に達しないかぎり、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知は送信されません。最大ルートしきい値にすでに達しているアドレス ファミリには、ルートは追加されません。


) IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にあり、いずれかのアドレス ファミリに最大しきい値が設定されていない場合、最大しきい値の通知は送信されません。


mplsL3VpnNumVrfSecIllglLblThrshExcd:この通知は、mplsL3VpnVrfSecIllegalLblVltns 値で示されている、VRF インターフェイスで受信した不正なラベルの数が、mplsL3VpnIllLblRcvThrsh 値を超えた場合に生成されて送信されます。このしきい値は、値 0 で定義されています。このため、VRF で初めて不正なラベルを受信すると、通知が送信されます。ラベルが有効なラベル範囲内にない場合、ラベルが Label Forwarding Information Base(LFIB; ラベル転送情報ベース)に登録されていない場合、またはメッセージのテーブル ID が LFIB にあるラベルのテーブル ID に一致しない場合、ラベルは不正であると見なされます。

MplsL3VpnNumVrfRouteMaxThreshCleared:VRF でのルート数が最大ルート数を超えようとしたものの、その後最大ルート数を下回ると、生成されて送信されます。最大ルート数がすでに含まれている VRF でルートを作成しようとすると、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知が送信されます(イネーブルの場合)。ルート数が制限値を下回るように、VRF からルートを削除すると、MplsL3VpnNumVrfRouteMaxThreshCleared 通知が送信されます。VRF からすべてのルートをクリアするには、IPv4 ルートでは clear ip route vrf コマンドを使用し、IPv6 ルートでは clear ipv6 route vrf コマンドを使用します(MplsL3VpnNumVrfRouteMaxThreshCleared 通知がいつ送信されるかについては、図 6 を参照してください)。

図 6 警告しきい値と最大しきい値の比較

 

NMS に送信される MPLS-L3VPN-STD-MIB 通知を設定する Cisco IOS CLI コマンドの詳細については、「MPLS EM - MPLS VPN MIB RFC 4382 Upgrade の設定方法」を参照してください。

MPLS-L3VPN-STD-MIB の SNMP 通知の仕様

SNMPv1 通知では、各 MPLS レイヤ 3 VPN 通知に汎用タイプの ID と、通知タイプを識別するための企業固有タイプ ID が含まれます。

すべての VPN 通知に対する汎用タイプは、SNMP に対して定義されている汎用通知タイプの 1 つではないため、「企業固有」です。

企業固有タイプは次のように識別されます。

mplsL3VpnVrfUp は 1

mplsL3VpnVrfDown は 2

mplsL3VpnVrfRouteMidThreshExceeded は 3

mplsL3VpnVrfNumVrfRouteMaxThreshExceeded は 4

mplsL3VpnNumVrfSecIllglLblThrshExcd は 5

mplsL3VpnNumVrfRouteMaxThreshCleared は 6

SNMPv2 では、通知タイプは通知メッセージ内に含まれている SnmpTrapOID 変数バインド(オブジェクト ID(OID)タイプと値で構成されている変数バインド)で識別されます。

VRF のアップ/ダウン通知には、 mplsL3VpnIfConfRowStatus 変数と mplsL3VpnVrfOperStatus 変数が含まれています。これらの変数は、それぞれ SNMP 行ステータスと動作ステータスを示します。

中間しきい値通知には、mplsL3VpnVrfVConfMidRteThresh 変数と、VRF 内の現在のルート数を示す mplsL3VpnVrfPerfCurrNumRoutes 変数が含まれています。

最大しきい値通知には、mplsL3VpnVrfVConfHighRteThresh 変数と、VRF 内の現在のルート数を示す mplsL3VpnVrfPerfCurrNumRoute s 変数が含まれています。

不正なラベル通知には、VPN 内の現在の不正なラベル数を保持する mplsL3VpnVrfSecIllegalLblVltns 変数が含まれています。

クリアされた最大しきい値通知には、mplsL3VpnVrfConfHighRteThresh 変数と、VRF 内の現在のルート数を示す mplsL3VpnVrfPerfCurrNumRoutes 変数が含まれています。

ネットワーク管理ステーションでの MPLS-L3VPN-STD-MIB 通知の表示

MPLS-L3VPN-STD-MIB 通知がイネーブルになっている場合( snmp-server enable traps mpls rfc vpn コマンドを参照)、Cisco IOS ソフトウェア内の特定の MPLS VPN イベントに関連する通知メッセージが生成されて、ネットワーク内の指定された NMS に送信されます。SNMPv1 または SNMPv2 通知をサポートするユーティリティはいずれも、通知メッセージを受信できます。

MPLS-L3VPN-STD-MIB 通知メッセージを監視するには、SNMP 通知を表示するユーティリティをサポートしている NMS にログインし、表示ユーティリティを起動します。

IPv6 VPN over MPLS の MPLS-L3VPN-STD-MIB サポート

次の各項では、MPLS-L3VPN-STD-MIB が IPv6 VPN over MPLS(6VPE)をサポートする方法について説明します。

「IPv6 VPN over MPLS での MPLS-L3VPN-STD-MIB テーブルとオブジェクトのサポート」

「IPv6 VPNs over MPLS の MPLS-L3VPN-STD-MIB 通知サポート」

「IPv6 アドレス ファミリ VRF ルート制限への最大ルートの設定について」

IPv6 VPN over MPLS での MPLS-L3VPN-STD-MIB テーブルとオブジェクトのサポート

MPLS-L3VPN-STD-MIB は、MIB オブジェクトを入力するための情報を RIB ルーティング テーブルから取得します。MPLS-L3VPN-STD-MIB で MPLS を介した IPv6 ルートをサポートするには、MIB は VRF の IPv6 と IPv4 の両方の RIB ルーティング テーブルにアクセスする必要があります。

表 8 に、アドレス ファミリで指定されているか、ルーティング テーブル情報が必要な MIB テーブルとオブジェクトを、MPLS-L3VPN-STD-MIB でサポートする方法を示します。

 

表 8 MIB テーブルとオブジェクトのアドレス ファミリの MPLS-L3VPN-STD-MIB サポート

MIB テーブルとオブジェクト
MPLS-L3VPN-STD-MIB サポート

VRF ルート ターゲット テーブル(mplsL3VpnVrfRTTable)

このテーブルは VRF に指定したルート ターゲットのリストを示します。IPv6 VPN over MPLS では、ルート ターゲットは各アドレス ファミリに指定できます。

MPLS-L3VPN-STD-MIB は IPv4 のすべてのルート ターゲットを取得し、次に IPv6 に指定したすべてのルート ターゲットを取得します。

mplsL3VpnVrfRTDescr オブジェクトは、特定のルート ターゲットが IPv4 または IPv6 アドレス ファミリのに定義されているかどうかを示します。

VRF コンフィギュレーション テーブル(mplsL3VpnVrfTable)、mplsL3VpnVrfConfMidRteThresh、mplsL3VpnVrfConfHighRteThresh、mplsL3VpnVrfConfMaxRoutes

Cisco IOS CLI を使用すると、アドレス ファミリ単位で最大しきい値および中間しきい値を設定できます。

IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが存在する場合、MPLS-L3VPN-STD-MIB はこれらの設定の集約値(最大 int32 値を超過しない)を表示します。最大ルート数の制限が 1 つのアドレス ファミリに設定されていて、もう一方のアドレス ファミリには設定されていない場合、集約値は最大 int32(4,294,967,295)です。

VRF にアドレス ファミリ コンフィギュレーションが 1 つだけ存在する場合、MPLS-L3VPN-STD-MIB はその 1 つのアドレス ファミリに設定されている値を表示します。 MPLS-L3VPN-STD-MIB が通知をサポートする方法の詳細については、「ネットワーク管理ステーションでの MPLS-L3VPN-STD-MIB 通知の表示」および「IPv6 VPNs over MPLS の MPLS-L3VPN-STD-MIB 通知サポート」を参照してください。

VRF パフォーマンス テーブル(mplsL3VpnVrfPerfTable)、mplsL3VpnVrfPerfRoutesAdded、mplsL3VpnVrfPerfRoutesDeleted、mplsL3VpnVrfPerfCurrNumRoutes、mplsL3VpnVrfPerfRoutesDropped

MPLS-L3VPN-STD-MIB は、IPv4 からのルーティング テーブル情報と IPv6 からのルーティング テーブル情報を取得し、値を追加し、各 VRF パフォーマンス テーブル オブジェクトの累積カウントを提供します。

VRF ルーティング テーブル(mplsL3VpnVrfRteTable)

このテーブルには、この VRF に関連するルートのリストを示します。

MPLS-L3VPN-STD-MIB は、VRF の IPv4 ルート テーブルおよび IPv6 ルート テーブルの両方から、すべてのルートを取得する必要があります。

VPN インターフェイス コンフィギュレーション テーブル(mplsL3VpnIfConfTable)、mplsL3VpnIfVpnRouteDistProtocol

これは、VRF が定義されているインターフェイスのプロトコルを示すビット マスクです。MPLS-L3VPN-STD-MIB はプロトコルと設定するビットを検索するために、IPv4 アドレス ファミリおよび IPv6 アドレス ファミリの両方からルート テーブルを取得する必要があります。

この MPLS-L3VPN-STD-MIB 情報は、VRF 内の IPv4 コンフィギュレーションと IPv6 コンフィギュレーションの結合です。

IPv6 VPNs over MPLS の MPLS-L3VPN-STD-MIB 通知サポート

ここでは、MPLS-L3VPN-STD-MIB が mplsL3VpnVrfRouteMidThreshExceeded、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded、mplsL3VpnNumVrfRouteMaxThreshCleared の各通知を処理する方法を説明します。

ルート数がしきい値に達したあとに新しいルートを追加しようとすると、中間しきい値(mplsL3VpnVrfRouteMidThreshExceeded)および最大しきい値(mplsL3VpnVrfNumVrfRouteMaxThreshExceeded)の最大ルート数超過の通知が、ルート テーブルによってトリガーされます。IPv6 と IPv4 の両方で MIB がサポートされることにより、VRF には 2 つの個別のルート テーブルが存在する場合があります。最大しきい値または中間しきい値を設定している場合、これらのしきい値を超えると、MPLS-L3VPN-STD-MIB は NMS に通知を送信します。

MPLS-L3VPN-STD-MIB は、アドレス ファミリ コンフィギュレーションに基づいて、最大しきい値と中間しきい値を管理します。Cisco IOS Release 12.2(33)SRC および 12.2(33)SB では、MPLS-L3VPN-STD-MIB は、IPv4 と IPv6 の最大しきい値と中間しきい値の集約に基づいて、通知(またはトラップ)をトリガーします。


) Cisco IOS Release 12.2(33)SRC には、IPv6 アドレス ファミリ用に maximum コマンドが導入されています。


MPLS-L3VPN-STD-MIB は、次のシナリオで説明されているとおりに集約しきい値を管理します。

シナリオ 1:アドレス ファミリが 1 つ設定されている(IPv4 または IPv6)。このアドレス ファミリには、最大しきい値と中間しきい値の設定が含まれている。

集約最大しきい値はアドレス ファミリ固有の最大ルート値と同一。

集約中間しきい値はアドレス ファミリ固有の中間ルート値と同一。

ルート数がそのアドレス ファミリに設定されている最大しきい値に達すると、アドレス ファミリ ルートはルーティング テーブルへの追加を停止する。通知またはトラップは、次のルート追加の試行で送信される。

シナリオ 2:IPv4 と IPv6 の両方のアドレス ファミリが設定されている。両方には最大しきい値と中間しきい値の設定が含まれている。

集約最大しきい値は、IPv4 と IPv6 の最大しきい値の合計と同一(上限は 4,294,967,295 の最大値に設定)。

集約中間しきい値は、IPv4 と IPv6 の中間しきい値の合計と同一。両方のアドレス ファミリが中間しきい値の制限に達した場合にのみ、通知が送信される。

ルート数が各アドレス ファミリの最大しきい値に達すると、アドレス ファミリ ルートはルーティング テーブルへの追加を停止する。IPv6 と IPv4 の両方のルートが最大しきい値に達するまで、通知またはトラップは送信されない。

シナリオ 3:IPv4 と IPv6 の両方のアドレス ファミリが設定されている。そのいずれかにのみ、最大および中間のルートしきい値の設定が含まれている。

集約最大しきい値は最大しきい値と同一(4,294,967,295)。

集約中間しきい値は最大しきい値と同一(4,294,967,295)。

最大しきい値設定が含まれるアドレス ファミリの最大しきい値にルート数が達すると、アドレス ファミリ ルートはそのアドレス ファミリのルーティング テーブルへの追加を停止する。ただし、通知またはトラップは送信されない。


) 1 つのアドレス ファミリ VRF に最大および中間のしきい値(シナリオ 1)を設定し、最大しきい値を設定せずに、他のアドレス ファミリ コンフィギュレーションを VRF にあとで追加する場合(シナリオ 3)、しきい値に達しても元のアドレス ファミリに対する最大しきい値通知は送信されなくなりますが、このアドレス ファミリのルーティング テーブルにルートは追加されなくなります。


IPv6 アドレス ファミリ VRF ルート制限への最大ルートの設定について

IPv6 アドレス ファミリに最大ルートを設定する前に、次の情報を理解する必要があります。

maximum routes コマンドは、指定した VRF のアドレス ファミリ コンフィギュレーション モードを開始します( address-family ipv6 または address-family ipv4 コマンド)。

VRF の IPv6 ルーティング テーブルの現在のルート数を下回るように最大ルート数を設定しようとすると、この CLI コマンドは拒否されます。IPv6 ルーティング テーブルのサイズを小さくすることはできません。

警告のみのしきい値を設定する場合、コマンドは受け入れられますが、ルート制限は強制されません。この条件は IPv4 にも当てはまります。

ルーティング テーブルがルート制限を超えると、 show ipv6 route vrf コマンドからの出力には、RIB がオーバーフローしたことを示すエラー メッセージが表示されます。

ルート数が制限を下回っても、ルーティング テーブルがオーバーフロー状態から自動的に復旧しない場合は、 clear ipv6 route vrf コマンドを入力する必要があります。このコマンドにより、ルーティング テーブルが強制的に消去されて再度入力されます。

再入力が正常に実行されると、エラー状態はクリアされます。自動または手動による消去と再入力が正常に実行されない場合、 show ipv6 route vrf コマンド出力には、エラー メッセージが引き続き表示されます。

Cisco IOS Release 12.2(1st)SRC および 12.2(33)SB では、IPv4 と IPv6 の両方のルーティング テーブルが VRF で設定されている場合、ルートの最大、中間、警告に対して MPLS-L3VPN-STD-MIB で生成された通知、およびしきい値がクリアされたオブジェクトに対して生成された通知は、IPv4 と IPv6 のルート制限およびルート カウントの集約です。

MPLS-L3VPN-STD-MIB データ セキュリティ

MPLS-L3VPN-STD-MIB データ セキュリティを確保するための、ネットワークを運用するオペレータおよびお客様の要件は次のとおりです。

ネットワークを運用するオペレータは、セキュリティをおろそかにすることなく、VRF 対応 MPLS-L3VPN-STD-MIB にすべてのデータをポーリングする必要があります。ネットワークを管理するオペレータは、利用可能なすべてのデータを 1 つの SNMP ウォークにポーリングする必要があります。

VRF を NMS から管理するお客様は、お客様が責任を持つ VRF でのみデータをポーリングする必要があります。お客様の VRF 情報はその特定のお客様にだけ表示される必要があります。次の設定例では、VRF vrf1 に関連付けられているお客様は VRF vrf1 情報だけを閲覧でき、VRF vrf2 に関連付けられているお客様は VRF vrf2 情報だけを閲覧できます。

ネットワーク オペレータは、Access Control List(ACL; アクセス コントロール リスト)が含まれる snmp-server community コマンドを入力して、すべてのデータが 1 つの SNMP ウォークでアクセスできることと、お客様のルータからはそのデータにアクセスできないことを確認できます。たとえば、オペレータは、 snmp-server community any-community-name rw access-list acl-number のグローバル コンフィギュレーション コマンドを入力できます。 acl-number 引数を設定すると、PE ネットワークからの要求を許可できます。これにより、カスタマー側のルータは、指定したコミュニティ ストリングを使用するデータにはアクセスできません。

お客様の VRF 情報のセキュリティが確保されていることを確認するために、お客様の VRF 固有の SNMP コンテキストを設定できます。たとえば、次の設定例では、両方とも同じ PE に接続されている、VRF vrf1 に関連付けられているお客様と VRF vrf2 に関連付けられているお客様は、それぞれの VRF に関連する情報にだけアクセスでき、それ以外の情報にはアクセスできません。

!
vrf definition vrf1
rd 100:110
!
address-family ipv4
route-target export 100:1000
route-target import 100:1000
exit-address-family
!
vrf definition vrf2
rd 100:120
!
address-family ipv4
route-target export 100:2000
route-target import 100:2000
exit-address-family
!
interface Ethernet3/1
description Belongs to VPN vrf1
vrf forwarding vrf1
ip address 10.20.1.20 255.255.0.0
!
interface Ethernet3/2
description Belongs to vrf2
vrf forwarding vrf2
ip address 10.30.1.10 255.255.0.0
!
access-list 10 permit 10.20.1.21
access-list 10 deny any
access-list 20 permit 10.30.1.11
access-list 20 deny any
!
snmp-server view vrf1View mplsL3VpnMIB.*.*.*.*.*.3.114.101.100 included
snmp-server view vrf2View mplsL3VpnMIB.*.*.*.*.*.5.103.114.101.101.110 included
!
snmp-server community vrf1Comm view vrf1View rw 10
snmp-server community vrf2Comm view vrf2View rw 20
!

snmp-server view コマンドには、OID を指定した mplsL3VpnMIB が含まれています。形式は mplsL3VpnMIB.*.*.*.*.*.length-of-vrf-name.vrf-name-converted-to-octet-character-representation-
of-the-name のようになります。次に例を示します。

VRF vrf1 は 3.114.101.100 として表される。

VRF vrf2 は 5.103.114.101.101.110 として表される。


 


注意 SNMP 要求が PE ルータに入らないようにファイアウォールで保護されていないかぎり、snmp-server community community-name rw コマンドは入力しないでください。コミュニティ ストリングは保護されておらず、任意のネットワークからあらゆるデータをポーリングできます。

MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB の主要な相違点

RFC 4382 に基づく MPLS-L3VPN-STD-MIB は、MPLS-VPN-MIB のドラフト バージョン 3(draft-ieft-ppvpn-mpls-vpn-mib-03.txt)と同じ基本機能を提供します。これらは両方とも、SNMP を使用して MPLS レイヤ 3 VPN のインターフェイスを提供します。

Cisco IOS Release 12.2(33)SRC への MPLS-L3VPN-STD-MIB(RFC 4382)の実装後、MPLS-VPN-MIB のサポートは、一定の共存期間を経て完全に終了します。この共存期間に MPLS-L3VPN-STD-MIB への移行を実行できます。MPLS-L3VPN-STD-MIB および MPLS-VPN-MIB には異なるルート OID が付けられるため、両方の MIB は同じイメージ内に共存できます。

次の各項では、MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB の主要な相違点を説明します。

「MPLS-L3VPN-STD-MIB オブジェクトのグローバルな名前変更」

「MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB スカラ オブジェクトの相違点」

「MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB テーブル オブジェクトの相違点」

「MPLS-L3VPN-STD-MIB でサポートされていないテーブル」

「MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB 通知の相違点」

MPLS-L3VPN-STD-MIB オブジェクトのグローバルな名前変更

MPLS-L3VPN-STD-MIB では、すべてのオブジェクトの名前が mplsVpn name (MPLS-VPN-MIB オブジェクト名)から mplsL3Vpn name に変更されました。たとえば、VRF コンフィギュレーション テーブル名は mplsVpnVrfTable から mplsL3VpnVrfTable に変更されました。

次の各項では、グローバルな名前変更の規則に則さない名前変更が行われた、MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を説明します。

MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB スカラ オブジェクトの相違点

表 9 に、各スカラ オブジェクトの MPLS-VPN-MIB オブジェクトと MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を示します。

 

表 9 MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB スカラ オブジェクト

MPLS-VPN-MIB オブジェクト
MPLS-L3VPN-STD-MIB オブジェクト
相違点

mplsVpnVrfConfMaxPossibleRoutes

mplsL3VpnVrfConfMaxPossRts

オブジェクト名変更。

--

mplsL3VpnVrfConfRteMxThrshTime

新規オブジェクト。

--

mplsL3VpIllLblRcvThrsh

新規オブジェクト。

MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB テーブル オブジェクトの相違点

次の表では、各テーブルの MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を示します。

VRF コンフィギュレーション テーブル(mplsL3VpnVrfTable)

表 10 に、VRF コンフィギュレーション テーブル(mplsL3VpnVrfTable、旧称 mplsVpnVrfTable)の MPLS-VPN-MIB オブジェクトと MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を示します。

 

表 10 VRF コンフィギュレーション テーブル:MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB オブジェクトの相違点

MPLS-VPN-MIB オブジェクト
MPLS-L3VPN-STD-MIB オブジェクト
相違点

--

mplsL3VpnVrfVpnId

新規オブジェクト。

mplsVpnVrfRouteDistinguisher

mplsL3VpnVrfRD

オブジェクト名変更。

mplsVpnVrfConfMidRouteThreshold

mplsL3VpnVrfConfMidRteThresh

オブジェクト名変更。

mplsVpnVrfConfHighRouteThreshold

mplsL3VpnVrfConfHighRteThresh

オブジェクト名変更。

--

mplsL3VpnVrfConfAdminStatus

新規オブジェクト。

VPN インターフェイス コンフィギュレーション テーブル(mplsL3VpnIfConfTable)

表 11 に、VPN インターフェイス コンフィギュレーション テーブル(mplsL3VpnIfConfTable、旧称 mplsVpnInterfaceConfTable)の MPLS-VPN-MIB オブジェクトと MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を示します。

 

表 11 VPN インターフェイス コンフィギュレーション テーブル:MPLS-VPN-MIB およびMPLS-L3VPN-STD-MIB オブジェクトの相違点

MPLS-VPN-MIB オブジェクト
MPLS-L3VPN-STD-MIB オブジェクト
相違点

mplsVpnInterfaceConfTable

mplsL3VpnIfConfTable

テーブル名変更。

mplsVpnInterfaceConfIndex

mplsL3VpnIfConfIndex

オブジェクト名変更。

mplsVpnInterfaceLabelEdgeType

--

オブジェクト削除。

mplsVpnInterfaceVpnClassification

mplsL3VpnIfVpnClassification

オブジェクト名変更。

mplsVpnInterfaceVPNRouteDistProtocol

mplsL3VpnIfVpnRouteDist Protocol

オブジェクト名変更。

mplsVpnInterfaceConfStorageType

mplsL3VpnIfConfStorageType

オブジェクト名変更。

mplsVpnInterfaceConfRowStatus

mplsL3VpnIfConfRowStatus

オブジェクト名変更。

VRF ルート ターゲット テーブル(mplsL3VpnVrfRTTable)

表 12 に、VRF ルート ターゲット テーブル(mplsL3VpnVrfRTTable、旧称 mplsVpnVrfRouteTargetTable)の MPLS-VPN-MIB オブジェクトおよび MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を示します。

 

表 12 VRF ルート ターゲット テーブル:MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB オブジェクトの相違点

MPLS-VPN-MIB オブジェクト
MPLS-L3VPN-STD-MIB オブジェクト
相違点

mplsVpnVrfRouteTargetTable

mplsL3VpnVrfRTTable

テーブル名変更。

mplsVpnVrfRouteTargetIndex

mplsL3VpnVrfRTIndex

オブジェクト名変更。

mplsVpnVrfRouteTargetType

mplsL3VpnVrfRTType

オブジェクト名変更。

mplsVpnVrfRouteTarget

mplsL3VpnVrfRT

オブジェクト名変更。

mplsVpnVrfRouteTargetDescr

mplsL3VpnVrfRTDescr

オブジェクト名変更。

mplsVpnVrfRouteTargetRowStatus

mplsL3VpnVrfRTRowStatus

オブジェクト名変更。

--

mplsL3VpnVrfRTStorageType

新規オブジェクト。

VRF セキュリティ テーブル(mplsL3VpnVrfSecTable)

表 13 に、VRF セキュリティ テーブル(mplsL3VpnVrfSecTable、旧称 mplsVpnVrfSectTable)の MPLS-VPN-MIB オブジェクトおよび MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を示します。

 

表 13 VRF セキュリティ テーブル:MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB オブジェクトの相違点

MPLS-VPN-MIB オブジェクト
MPLS-L3VPN-STD-MIB オブジェクト
相違点

mplsVpnVrfSecIllegalLabelViolations

mplsL3VpnVrfSecIllegalLblVtns

オブジェクト名変更。

mplsVpnVrfSecIllegalLabelRcvThresh

--

オブジェクト削除。

--

mplsL3VpnVrfSecDiscontinuityTime

新規オブジェクト。

VRF パフォーマンス テーブル(mplsL3VpnVrfPerfTable)

表 14 に、VRF パフォーマンス テーブル(mplsL3VpnVrfPerfTable、旧称 mplsVpnVrfPerfTable)の MPLS-VPN-MIB オブジェクトおよび MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を示します。

 

表 14 VRF パフォーマンス テーブル:MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB オブジェクトの相違点

MPLS-VPN-MIB オブジェクト
MPLS-L3VPN-STD-MIB オブジェクト
相違点

--

mplsL3VpnVrfPerfRoutesDropped

新規オブジェクト。

--

mplsL3VpnVrfPerfDiscTime

新規オブジェクト。

VRF ルーティング テーブル(mplsL3VpnVrfRteTable)

表 14 に、VRF ルーティング テーブル(mplsL3VpnVrfRteTable、旧称 mplsVpnVrfRouteTable)の MPLS-VPN-MIB オブジェクトおよび MPLS-L3VPN-STD-MIB オブジェクトの主要な相違点を示します。

VRF ルーティング テーブルのインデックスも変更されています。

MPLS-VPN-MIB インデックス:mplsVpnVrfName、mplsVpnVrfRouteDest、mplsVpnVrfRouteMask、mplsVpnVrfRouteTos、mplsVpnVrfRouteNextHop

MPLS-L3VPN-STD-MIB インデックス:mplsL3VpnVrfName、mplsL3VpnVrfRteInetCidrDestType、mplsL3VpnVrfRteInetCidrDest、mplsL3VpnVrfRteInetCidrPfxLen、mplsL3VpnVrfRteInetCidrPolicy、mplsL3VpnVrfRteInetCidrNHopType、mplsL3VpnVrfRteInetCidrNextHop

 

表 15 VRF ルーティング テーブル:MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB オブジェクトの相違点

MPLS-VPN-MIB オブジェクト
MPLS-L3VPN-STD-MIB オブジェクト
相違点

mplsVpnVrfRouteTable

mplsL3VpnVrfRteTable

テーブル名変更。

mplsVpnVrfRouteDest

mplsL3VpnVrfRteInetCidrDest

オブジェクト名変更。

mplsVpnVrfRouteDestAddrType

mplsL3VpnVrfRteInetCidrDestType

オブジェクト名変更。

mplsVpnVrfRouteMask

--

オブジェクト削除。

mplsVpnVrfRouteMaskAddrType

--

オブジェクト削除。

--

mplsL3VpnVrfRteInetCidrPfxLen

新規オブジェクト。

mplsVpnVrfRouteTos

--

オブジェクト削除。

--

mplsL3VpnVrfRteInetCidrPolicy

新規オブジェクト。

mplsVpnVrfRouteNextHop

mplsL3VpnVrfRteInetCidrNextHop

オブジェクト名変更。

mplsVpnVrfRouteNextHopAddrType

mplsL3VpnVrfRteInetCidrNHopType

オブジェクト名変更。

mplsVpnVrfRouteIfIndex

mplsL3VpnVrfRteInetCidrIfIndex

オブジェクト名変更。

mplsVpnVrfRouteType

mplsL3VpnVrfRteInetCidrType

オブジェクト名変更。

mplsVpnVrfRouteProto

mplsL3VpnVrfRteInetCidrProto

オブジェクト名変更。

mplsVpnVrfRouteAge

mplsL3VpnVrfRteInetCidrAge

オブジェクト名変更。

mplsVpnVrfRouteInfo

--

オブジェクト削除。

mplsVpnVrfRouteNextHopAS

mplsL3VpnVrfRteInetCidrNextHopAS

オブジェクト名変更。

mplsVpnVrfRouteMetric1

mplsL3VpnVrfRteInetCidrMetric1

オブジェクト名変更。

mplsVpnVrfRouteMetric2

mplsL3VpnVrfRteInetCidrMetric2

オブジェクト名変更。

mplsVpnVrfRouteMetric3

mplsL3VpnVrfRteInetCidrMetric3

オブジェクト名変更。

mplsVpnVrfRouteMetric4

mplsL3VpnVrfRteInetCidrMetric4

オブジェクト名変更。

mplsVpnVrfRouteMetric5

mplsL3VpnVrfRteInetCidrMetric5

オブジェクト名変更。

--

mplsL3VpnVrfRteXCPointer

新規オブジェクト。

mplsVpnVrfRouteStatus

mplsL3VpnVrfRteInetCidrStatus

オブジェクト名変更。

mplsVpnVrfRouteStorageType

--

オブジェクト削除。

MPLS-L3VPN-STD-MIB でサポートされていないテーブル

MPLS-VPN-MIB の次のテーブルは、MPLS-L3VPN-STD-MIB(RFC 4382)では削除されました。

BGP ネイバー アドレス テーブル(mplsVpnVrfBgpNbrAddrTable)

BGP ネイバー プレフィクス テーブル(mplsVpnVrfBgpNeighborPrefixTable)

MPLS-VPN-MIB の Cisco IOS 実装では、mplsVpnVrfBgpNeighborPrefixTable はサポートされていませんでした。

Definitions of Managed Objects for BGP-4 』(RFC 4273)に基づく Cisco-BGP4-MIB では、BGP に関連する情報を提供します。

MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB 通知の相違点

表 16 に、MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB 通知の主要な相違点を示します。

 

表 16 MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB 通知の相違点

MPLS-VPN-MIB 通知
MPLS-L3VPN-STD-MIB 通知
相違点

mplsVpnVrfIfUp

--

通知の削除。

mplsVpnVrfIfDown

--

通知の削除。

--

mplsL3VpnVrfUp

新規通知。

--

mplsL3VpnVrfDown

新規通知。

mplsNumVrfRouteMidThresExceeded

mplsL3VpnVrfRouteMidThreshExceeded

返されるオブジェクトの変更。通知名の変更。

mplsNumVrfRouteMaxThreshExceeded

mplsL3VpnVRFNumVrfRouteMaxThreshExceeded

返されるオブジェクトの変更。通知名の変更。

mplsNumVrfSecIllegalLabelThreshExceeded

mplsL3VpnNumVrfSecIllglLblThrshExcd

返されるオブジェクトの変更。通知名の変更。

cMplsNumVrfRouteMaxThreshCleared
(CISCO-IETF-PPVPN-MPLS-VPN-MIB から)

mplsL3VpnNumVrfRouteMaxThreshCleared

通知名変更。

MPLS EM - MPLS VPN MIB RFC 4382 Upgrade の設定方法

ここでは、MPLS EM - MPLS VPN MIB RFC 4382 Upgrade 機能を設定する作業について説明します。MPLS EM - MPLS VPN MIB RFC 4382 Upgrade 機能には MPLS-L3VPN-STD-MIB が導入されています。

SNMP を使用して MPLS レイヤ 3 VPN を監視および管理するようにルータを設定するには、次の作業を実行します。

「SNMP コミュニティの設定」(必須)

「MPLS レイヤ 3 VPN SNMP 通知をホストに送信するためのルータの設定」(任意)

「MPLS レイヤ 3 VPN SNMP 通知のしきい値の設定」(任意)

「MPLS レイヤ 3 VPN 通知しきい値の SNMP 制御の設定:例」(任意)

SNMP コミュニティの設定

デフォルトでは、MPLS-L3VPN-STD-MIB の SNMP エージェントはディセーブルになっているため、SNMP を使用してネットワーク上で MPLS レイヤ 3 VPN を監視および管理するには、これをイネーブルにする必要があります。

SNMP コミュニティ ストリングでは、SNMP マネージャと SNMP エージェントとの関係を定義します。コミュニティ文字列は、ルータ上のエージェントへのアクセスを制御するパスワードのように機能します。

SNMP コミュニティを設定するには、次の作業を実行します。

手順の概要

1. enable

2. show running-config

3. configure terminal

4. snmp-server community string [ view view-name ] [ ro | rw ] [ acl - number ]

5. do copy running-config startup-config

6. exit

7. show running-config | include [ option ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show running-config

 

Router# show running-config

実行コンフィギュレーションを表示して、SNMP エージェントがすでに動作しているかどうかを判断します。

SNMP 情報が表示されない場合は、次のステップに進みます。

SNMP の情報が表示された場合は、情報を修正するか、または必要に応じて情報を変更できます。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

snmp-server community string [ view view-name ] [ ro | rw ] [ acl - number ]

 

Router(config)# snmp-server community comaccess ro

SNMP プロトコルへのアクセスを許可するように、コミュニティ アクセス ストリングを設定します。

string 引数はパスワードのように機能し、SNMP プロトコルへのアクセスを許可します。

view view-name キーワードと引数のペアには、以前に定義されたビューの名前を指定します。ビューには、コミュニティで使用できるオブジェクトが定義されています。

ro キーワードは、読み取り専用アクセスであることを指定します。許可された管理ステーションは MIB オブジェクトだけを取得できます。

rw キーワードは、読み取り/書き込みアクセスであることを指定します。MIB オブジェクトの取得と変更の両方を実行できるのは、許可された管理ステーションです。

acl-number 引数は、1 ~ 99 の整数で、コミュニティ ストリングを使用した SNMP エージェントへのアクセスが許可される IP アドレスのアクセス リストを指定します。

ステップ 5

do copy running-config startup-config

 

Router(config)# do copy running-config startup-config

変更された設定をスタートアップ コンフィギュレーション ファイルとして NVRAM に保存します。

do コマンドを使用すると、コンフィギュレーション モードで EXEC レベルのコマンドを実行できます。

ステップ 6

exit

 

Router(config)# exit

特権 EXEC モードに戻ります。

ステップ 7

show running-config | include [ option ]

 

Router# show-running config | include snmp-server

(任意)ルータ上の現在の設定情報、特定のインターフェイスの情報、またはマップクラス情報を表示します。

show running-config コマンドを使用すると、snmp-server 文が出力に表示されることを確認できます。

MPLS レイヤ 3 VPN SNMP 通知をホストに送信するためのルータの設定

MPLS レイヤ 3 VPN SNMP 通知またはトラップをホストに送信するようにルータを設定するには、この作業を実行します。

snmp-server host コマンドは、通知を受信するホストを指定します。 snmp-server enable traps コマンドでは、指定した通知のトラップ生成メカニズムをグローバルにイネーブルにします。

ホストで通知を受信するには、そのホストに snmp-server host コマンドを設定し、一般的には snmp-server enable traps コマンドを使用して通知をグローバルにイネーブルにする必要があります。


snmp-server host コマンド自体を使用して community-string 引数を設定できますが、snmp-server community コマンドを使用してこのストリングを定義してから snmp-server host コマンドを使用することを推奨します。


手順の概要

1. enable

2. configure terminal

3. snmp-server host host-addr [ traps | informs ] [ version { 1 | 2c | 3 [ auth | noauth | priv ]}] community-string [ udp-port port ] [ notification-type ] [ vrf vrf-name ]

4. snmp-server enable traps mpls rfc vpn [ illegal-label ] [ max-thresh-cleared] [ max-threshold ] [ mid-threshold ] [ vrf-down ] [ vrf-up ]

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

snmp-server host host-addr [ traps | informs ] [ version { 1 | 2c | 3 [ auth | noauth | priv ]}] community-string [ udp-port port ] [ notification-type ] [ vrf vrf-name ]

 

Router(config)# snmp-server host 172.20.2.160 traps comaccess mpls-vpn

SNMP 通知動作の指定

host-addr 引数には、ホスト(ターゲット受信者)の名前またはインターネット アドレスを指定します。

traps キーワードを指定すると、このホストに SNMP トラップが送信されます。これがデフォルトです。

informs キーワードを指定すると、このホストに SNMP 応答要求が送信されます。

version キーワードには、トラップの送信に使用する SNMP のバージョンを指定します。最も安全なモデルはバージョン 3 です。このバージョンでは、 priv キーワードを使用してパケットを暗号化できるためです。 version キーワードを使用する場合は、次のいずれかを指定する必要があります。

1 :SNMPv1。このオプションは、informs とともに使用することはできません。

2c :SNMPv2C。

3 :SNMPv3。 version 3 キーワードのあとに、 auth noauth priv の 3 つのオプション キーワードを指定できます。

community-string 引数は、通知動作で送信される、パスワードに似たコミュニティ ストリングです。

udp-port port キーワードと引数のペアには、使用するホストの User Datagram Protocol(UDP; ユーザ データグラム プロトコル)ポートを指定します。デフォルト値は 162 です。

notification-type 引数には、ホストに送信する通知のタイプを指定します。タイプが指定されていない場合は、すべての通知が送信されます。

vrf vrf-name キーワードと引数のペアには、SNMP 通知の送信に使用する VRF テーブルを指定します。

ステップ 4

snmp-server enable traps mpls rfc vpn [ illegal-label ] [ max-thresh-cleared ]
[ max-threshold ] [ mid-threshold ] [ vrf-down ] [ vrf-up ]

 

Router(config)# snmp-server enable traps mpls rfc vpn vrf-down vrf-up

ルータで MPLS レイヤ 3 VPN 固有の SNMP 通知(トラップと応答要求)を送信できるようにします。

illegal-label キーワードを指定すると、VRF インターフェイスで不正なラベルを受信した場合に通知が送信されようになります。ラベルが有効な範囲内にないか、LFIB に登録されていないか、または LFIB にあるラベルのテーブル ID に一致しない場合、ラベルは不正であると見なされます。

max-thresh-cleared キーワードを指定すると、ルート数が最大ルート数を超えようとしたあとで制限値を下回った場合に、通知が送信されるようになります。

(注) VRF に IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションがある場合の通知の詳細については、「IPv6 VPNs over MPLS の MPLS-L3VPN-STD-MIB 通知サポート」を参照してください。

max-threshold キーワードを指定すると、ルートを作成しようとしたものの、最大ルート数に達したために作成できなかった場合に、通知が送信されるようになります。ルートの数が最大しきい値を下回り、再度最大しきい値に達すると、 mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知がもう 1 つ送信されます。最大しきい値は、VRF コンフィギュレーション モードの maximum routes コマンドによって決まります。

(注) IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合の、最大しきい値通知の詳細については、「IPv6 VPNs over MPLS の MPLS-L3VPN-STD-MIB 通知サポート」を参照してください。

mid-threshold キーワードを指定すると、作成したルートの数が警告しきい値を超えた場合に、警告の通知が送信されるようになります。この警告は、警告しきい値を超えたときにだけ送信されます。

(注) IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合の、最大しきい値通知の詳細については、「IPv6 VPNs over MPLS の MPLS-L3VPN-STD-MIB 通知サポート」を参照してください。

vrf-down キーワードを指定すると、VRF の最後のインターフェイスが起動状態からダウン状態になったときに、通知が送信されるようになります。

vrf-up キーワードを指定すると、VRF のすべてのインターフェイスがダウン状態にある中で、その内の 1 つの VRF インターフェイスが起動状態になったときに、通知が送信されるようになります。

ステップ 5

end

 

Router(config)# end

(任意)終了して、特権 EXEC モードに戻ります。

MPLS レイヤ 3 VPN SNMP 通知のしきい値の設定

MPLS レイヤ 3 VPN SNMP 通知に次のしきい値を設定するには、次の作業を実行します。

中間しきい値(警告)を超えると、mplsL3VpnVrfRouteMidThreshExceeded 通知イベントが生成されて送信されます。CLI でこのしきい値を設定するには、VRF コンフィギュレーション モードで maximum routes コマンドを使用します。この通知は、しきい値を超えたときにだけ NMS に送信されます。ルートの数がこのしきい値を下回り、再度しきい値を超えるたびに、通知が NMS に送信されます

IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、このしきい値は警告しきい値の集約になります。2 つめのアドレス ファミリがその警告しきい値に達しないかぎり、mplsL3VpnVrfRouteMidThreshExceeded 通知は送信されません。

VRF コンフィギュレーション モードの maximum routes コマンドで定義したとおりに最大ルート数がすでに含まれている VRF でルートを作成しようとすると、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知イベントが生成されて送信されます。最大しきい値を超えようとすると、トラップ通知が NMS に送信されます。ルートの数が最大しきい値を下回り、再度最大しきい値に達すると、 mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知がもう 1 つ送信されます。

IPv6 と IPv4 の両方のアドレス ファミリ コンフィギュレーションが VRF にある場合、このしきい値は最大しきい値の集約になります。2 つめのアドレス ファミリが最大ルートしきい値に達しないかぎり、mplsL3VpnVrfNumVrfRouteMaxThreshExceeded 通知は送信されません。最大ルートしきい値にすでに達しているアドレス ファミリには、ルートは追加されません。

この通知のしくみを示す例、および最大しきい値と警告しきい値の比較については、図 6 を参照してください。

手順の概要

1. enable

2. configure terminal

3. vrf definition vrf-name

4. address-family { ipv4 | ipv6 }

5. maximum routes limit warn-threshold
または
maximum routes limit warn-only

6. exit-address-family

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vrf definition vrf-name

 

Router(config)# vrf definition vpn1

VRF ルーティング テーブルを設定し、VRF コンフィギュレーション モードを開始します。

vrf-name 引数には、VRF に割り当てられている名前を指定します。

ステップ 4

address-family { ipv4 | ipv6 }

 

Router(config-vrf) address-family ipv4

VRF アドレス ファミリ コンフィギュレーション モードを開始します。

ipv4 キーワードは、IPv4 VPN のアドレス ファミリを指定します。

ipv6 キーワードは、IPv6 VPN のアドレス ファミリを指定します。

ステップ 5

maximum routes limit warn-threshold

 

Router(config-vrf-af)# maximum routes 10000 80

または

maximum routes limit warn-only

 

Router(config-vrf-af)# maximum routes 10000 warn-only

 

PE ルータにインポートされるルートの数が多くなりすぎないように、VRF の最大ルート数を制限します。

limit 引数には、VRF で許可されるルートの最大数を指定します。範囲は 1 ~ 4,294,967,295 です。

warn - threshold 引数は、 warn-threshold 引数に設定されたルートの数に達すると警告を生成し、 limit 引数に設定された最大数を超えるルートを拒否します。警告しきい値は、 limit 引数に指定された最大ルート数に占める割合を 1 ~ 100 で示した値となります。

warn-only キーワードを指定すると、VRF に許可された最大ルート数が制限しきい値を超えたときに、システム メッセージ ロギング(syslog)エラー メッセージが発行されるようになります。ただし、引き続きルートを追加できます。

ステップ 6

exit-address-family

 

Router(config-vrf-af)# exit-address-family

VRF アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 7

end

 

Router(config-vrf)# end

(任意)終了して、特権 EXEC モードに戻ります。

MPLS VPN 通知しきい値の SNMP 制御の設定

MPLS VPN 通知しきい値に次の SNMP 制御を設定するには、次の作業を実行します。

mplsL3VpnVrfConfRteMxThrshTime は、最大ルート超過通知(mplsL3VpnVrfNumVrfRouteMaxThreshExceeded)が、最大値を超えてから(または達してから)再度発行される間隔、および最初の通知が送信されてから再度発行される間隔です。この間隔を CLI で設定するには、グローバル コンフィギュレーション モードで snmp mib mpls vpn max-threshold seconds コマンドを使用します。最大ルート値を超えたことを知らせる最初の通知以外の通知を受信する場合は、このコマンドを設定します。

VRF の不正なラベル違反の数が、mplsL3VpnIllLblRcvThrsh スカラで示されている数を超えた場合に、mplsL3VpnNumVrfSecIllglLblThrshExcd 通知が生成されて送信されます。グローバル コンフィギュレーション モードで snmp mib mpls vpn illegal-label number コマンドを使用すると、mplsL3VpnNumVrfSecIllglLblThrshExcd 通知を生成する不正なラベルの数を CLI で設定できます。mplsL3VpnNumVrfSecIllglLblThrshExcd 通知を受け取る前に、特定数の不正なラベルの違反を許可する場合は、このコマンドを設定します。

手順の概要

1. enable

2. configure terminal

3. snmp mib mpls vpn max-threshold seconds

4. snmp mib mpls vpn illegal-label number

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

snmp mib mpls vpn max-threshold seconds

 

Router(config)# snmp mib mpls vpn max-threshold 3600

MPLS VPN 通知しきい値の SNMP 制御を設定します。

max-threshold キーワードは、MPLS VPN 最大しきい値超過通知を制御します。

seconds 引数は、SNMP が最大しきい値通知を再送するまでの秒単位の時間です。有効範囲は 0 ~ 4,294,967,295 です。デフォルト値は 0 です。

ステップ 4

snmp mib mpls vpn illegal-label number

 

Router(config)# snmp mib mpls vpn illegal-label 10

MPLS VPN 通知しきい値の簡単な SNMP 制御を設定します。

illegal-label キーワードは、MPLS VPN の不正なラベルのしきい値の超過通知を制御します。

number 引数は、SNMP が不正なラベルのしきい値通知を送信するまでに許可される不正なラベル数です。有効範囲は 1 ~ 4,294,967,295 です。デフォルト値は 0 です。

ステップ 5

end

 

Router(config)# end

特権 EXEC モードに戻ります。

MPLS EM - MPLS VPN MIB RFC 4382 アップグレードの設定例

ここでは、MPLS EM - MPLS VPN MIB RFC 4382 Upgrade機能の設定例を示します。

「SNMP コミュニティの設定:例」

「MPLS レイヤ 3 VPN SNMP トラップを送信するためのルータの設定:例」

「MPLS レイヤ 3 VPN SNMP 通知のしきい値の設定:例」

「MPLS レイヤ 3 VPN 通知しきい値の SNMP 制御の設定:例」

SNMP コミュニティの設定:例

次に、簡単な SNMP コミュニティ グループをイネーブルにする例を示します。この設定では、SNMP クライアントがコミュニティ ストリング comaccess を使用して読み取り専用アクセス権ですべての MPLS-L3VPN-STD-MIB オブジェクトにアクセスすることを許可しています。

configure terminal
!
snmp-server community comaccess ro
 

次のコマンドを使用して、MPLS EM - MPLS VPN MIB RFC 4382 Upgrade 機能に対して、SNMP マスター エージェントがイネーブルになっていることを確認します。

Router# show running-config | include snmp-server

 

Building configuration...
....
snmp-server community comaccess RO
....

) 「snmp-server」という文がない場合は、ルータで SNMP がイネーブルになっていません。


MPLS レイヤ 3 VPN SNMP トラップを送信するためのルータの設定:例

次に、VRF がアップ状態またはダウン状態に移行した場合に、ルータがコミュニティ ストリング comaccess を使用して MPLS レイヤ 3 VPN 通知をホスト 172.20.2.160 に送信する例を示します。

configure terminal
!
snmp-server host 172.20.2.160 traps comaccess mpls-vpn
snmp-server enable traps mpls rfc vpn vrf-down vrf-up

MPLS レイヤ 3 VPN SNMP 通知のしきい値の設定:例

次に、ルータ上の vpn1 という VRF に最大しきい値として 10,000 ルート、警告しきい値として最大しきい値の 80 % をそれぞれ設定する例を示します。

configure terminal
!
vrf definition vpn1
address-family ipv4
maximum routes 10000 80
exit address-family
end
 

次に、ルータ上の vpn2 という VRF に警告しきい値として 10,000 ルートを設定する例を示します。エラー メッセージが表示されますが、このコマンドでは最大ルートしきい値を設定していないため、引き続きルートを追加できます。

configure terminal
!
vrf definition vpn2
address-family ipv4
maximum routes 10000 warn-only
exit address-family
end

MPLS レイヤ 3 VPN 通知しきい値の SNMP 制御の設定:例

次に、MPLS レイヤ 3 VPN 通知しきい値の SNMP 制御を設定する方法の例を示します。

この例では、最初の通知が送信されたあとも引き続きルート追加が試行される場合、2 時間(7200 秒)の間隔で、最大しきい値超過通知が再送されるように設定します。

configure terminal
!
snmp mib mpls vpn max-threshold 7200
end
 

最大ルート超過通知を再送する間隔を設定しない場合、最大しきい値を超えたときに、SNMP は最大しきい値通知を一度だけ送信します。

次の例では、SNMP が不正なラベルのしきい値超過通知を送信するまでに VRF で許可される不正なラベルの数は 5 と設定されています。

configure terminal
!
snmp mib mpls vpn illegal-label 5
end
 

不正なラベルのしきい値を設定しない場合、不正なラベルが最初に発生したときに、SNMP は不正なラベル通知を送信します。

その他の参考資料

ここでは、MPLS EM - MPLS VPN MIB RFC 4382 Upgrade機能に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS レイヤ 3 VPN の設定作業と情報

『Cisco IOS Multiprotocol Label Switching Configuration Guide』

IPv6 VPN over MPLS の設定作業と情報

Cisco IOS IPv6 Configuration Library 』の「 Implementing IPv6 VPN over MPLS (6VPE) 」の章

Cisco IPv6 に関連するコマンドの説明

『Cisco IOS IPv6 Command Reference』

他の MPLS レイヤ 3 VPN 機能の説明とリンク

『Cisco IOS Multiprotocol Label Switching Configuration Guide』

MPLS レイヤ 3 VPN に関連するコマンドの説明

『Cisco IOS Multiprotocol Label Switching Command Reference』

規格

規格
タイトル

http://www.rfc-editor.org/rfc/rfc2578.txt

『Structure of Management Information Version 2 (SMIv2)』

MIB

MIB
MIB リンク

MPLS-L3VPN-STD-MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2578

『Structure of Management Information Version 2 (SMIv2)』

RFC 2685

『Virtual Private Networks Identifier』

RFC 2863

『The Interfaces Group MIB』

RFC 3031

『Multiprotocol Label Switching Architecture』

RFC 3410

『Introduction and Applicability Statements for the Internet-Standard Management Framework』

RFC 3413

『Simple Network Management Protocol (SNMP) Applications』

RFC 3813

『Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB)』

RFC 4001

『Textual Conventions for Internet Network Addresses』

RFC 4273

『Definitions of Managed Objects for BGP-4』

RFC 4364

『BGP/MPLS IP Virtual Private Networks (VPNs)』

RFC 4382

『MPLS/BGP Layer 3 Virtual Private Network (VPN) Management Information Base』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にあるコマンド検索ツールを使用するか、または『 Cisco IOS Master Command List 』を参照してください。

maximum routes

snmp mib mpls vpn

snmp-server enable traps mpls rfc vpn

MPLS EM - MPLS VPN MIB RFC 4382 Upgradeの機能情報

表 17 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 17 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 17 MPLS EM - MPLS VPN MIB RFC 4382 Upgrade の機能情報

機能名
リリース
機能情報

MPLS EM - MPLS VPN MIB RFC 4382 Upgrade

12.2(33)SRC
12.2(33)SB

MPLS EM - MPLS VPN MIB RFC 4382 Upgrade 機能ドキュメントは、RFC 4382『 MPLS/BGP Virtual Private Network (VPN) Management Information Base 』に基づく Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Networks(VPN; バーチャル プライベート ネットワーク)をサポートする MIB を説明します。また、RFC 4382 と、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)ドラフト バージョン 3(draft-ieft-ppvpn-mpls-vpn-mib-03.txt)に基づく MPLS-VPN-MIB の相違点、および MPLS-L3VPN-STD-MIB(RFC 4382)を実装するために必要な変更点を説明します。MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB は、Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)を使用して、Cisco IOS ソフトウェアで MPLS VPN 機能を管理するインターフェイスを提供します。

Cisco IOS MPLS Embedded Management(EM)は、Fault, Configuration, Accounting, Performance, and Security(FCAPS; 障害、設定、アカウンティング、パフォーマンス、セキュリティ)モデルに従った MPLS ベースのネットワークの開発、操作、アドミニストレーション、および管理を容易にする標準と付加価値サービスのセットです。

12.2(33)SRC では、この機能が Cisco 7600 シリーズ ルータに導入されました。

12.2(33)SB では、この機能は Cisco 10000 Performance Routing Engine 2(PRE-2)および PRE-3 上の Cisco 10000 シリーズ ルータに実装されていました。

この機能に関する詳細については、次の各項を参照してください。

「MPLS レイヤ 3 VPN の概要」

「MPLS-L3VPN-STD-MIB の利点」

「MPLS-L3VPN-STD-MIB でサポートされている機能」「MPLS-L3VPN-STD-MIB でサポートされるオブジェクト」

「MPLS-L3VPN-STD-MIB のスカラ オブジェクト」

「MPLS-L3VPN-STD-MIB MIB テーブル」

「MPLS-L3VPN-STD-MIB 通知イベント」

「IPv6 VPN over MPLS の MPLS-L3VPN-STD-MIB サポート」

「MPLS-L3VPN-STD-MIB データ セキュリティ」

「MPLS-VPN-MIB および MPLS-L3VPN-STD-MIB の主要な相違点」

「SNMP コミュニティの設定」

「MPLS レイヤ 3 VPN SNMP 通知をホストに送信するためのルータの設定」

「MPLS レイヤ 3 VPN SNMP 通知のしきい値の設定」

次のコマンドが導入または変更されました。 maximum routes snmp mib mpls vpn snmp-server enable traps mpls rfc vpn

用語集

6VPE ルータ :IPv4 ベースの MPLS コアを介して、BGP-MPLS IPv6 VPN サービスを提供するプロバイダー エッジ ルータ。これは、6PE の概念をコア方向のインターフェイスに実装する IPv6 VPN PE、デュアル スタック ルータです。

ASN.1 :Abstract Syntax Notation One(抽象構文記法 1)。特定のコンピュータ構造および表現技法に依存しないデータ タイプ。ISO International Standard 8824 に記述されています。

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。別々の自律システムに属するルータ間でのルーティング情報交換に使用する外部ボーダー ゲートウェイ プロトコル。BGP は TCP を使用します。TCP は信頼性の高いプロトコルであるため、BGP ではデータ パケットのドロップまたはフラグメント化の問題が発生しません。

BGP プレフィクス :BGP を使用したルート アナウンス。プレフィクスは、パケットが通過する必要があるネットワークを示す自律システム番号のパスと、ルーティングされる IP ブロックで構成されます。BGP プレフィクスは、701 1239 42 206.24.14.0/24 のようになります(/24 の部分は、CIDR マスクと呼ばれます)。/24 は、このブロックのネットマスクに左側から 1 が 24 個存在することを示します。/24 は、ナチュラル マスク 255.255.255.0 に対応します。

CE ルータ :Customer Edge(カスタマー エッジ)ルータ。VPN プロバイダーと VPN カスタマーの境界にあり、カスタマーに属するルータ。

CIDR :Classless Interdomain Routing(クラスレス ドメイン間ルーティング)。BGP4 でサポートされ、ルート集約に基づく技術。CIDR を使用すると、ルータはルートをグループ化して、コア ルータによって伝送されるルーティング情報の量を減らすことができます。グループ外のネットワークからは、複数の IP ネットワークが 1 つの大きなエンティティに見えます。CIDR では、IP アドレスとそのサブネット マスクは、ピリオドで区切った 4 オクテットとして記述され、そのあとにスラッシュとサブネット マスクを表す 2 桁の数字が続きます。

IETF :Internet Engineering Task Force(インターネット技術特別調査委員会)。インターネットの規格を策定している 80 を超えるワーキング グループで構成される委員会。IETF は、ISOC の援助を受けて活動しています。「ISOC」 も参照してください

ISOC :Internet Society(インターネット学会)。1992 年に設立された国際的な非営利団体。インターネットの発展と利用の整備を行っています。さらに、ISOC は、IAB などの他のインターネット関連団体に権限を委任しています。ISOC の本部は米国バージニア州レストンにあります。

ラベル :スイッチング ノードに対してデータの転送方法(パケットまたはセル)を指示する短い固定長のデータ構造。

LDP :Label Distribution Protocol(ラベル配布プロトコル)。パケットの転送に使用されるラベル(アドレス)のネゴシエーションで使用される MPLS 対応ルータ間の標準プロトコル。

LFIB :Label Forwarding Information Base(ラベル転送情報ベース)。シスコのラベル スイッチング システムにおける、着信タグと送信タグ(ラベル)、およびラベル付けに適した関連する対応パケットに関する情報を保存するためのデータ構造。

LSR :Label Switch Router(ラベル スイッチ ルータ)。各パケット内にカプセル化されている固定長ラベルの値に基づいて MPLS パケットを転送するデバイス。

MIB :Management Information Base(管理情報ベース)。SNMP や CMIP などのネットワーク管理プロトコルにより使用および管理されるネットワーク管理情報のデータベース。MIB オブジェクトの値は、SNMP コマンドまたは CMIP コマンドを使用して変更および取得できます。これらのコマンドは通常、GUI のネットワーク管理システムから実行します。MIB オブジェクトはツリー構造であり、ツリーにはパブリック(標準)ブランチとプライベート(独自)ブランチを含みます。

MPLS :Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)。ネットワークを介してパケット(フレーム)を転送する方式。ネットワークのエッジにあるルータがラベルをパケット(フレーム)に適用できるようにします。ネットワーク コア内の ATM スイッチまたは既存のルータは、最小限のルックアップ オーバーヘッドでラベルに従ってパケットを切り替えることができます。

MPLS インターフェイス :MPLS トラフィックがイネーブルになっているインターフェイス。

MPLS VPN :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)Virtual Private Network(バーチャル プライベート ネットワーク)。レイヤ 3 バックボーンを使用して、パブリック インフラストラクチャを介してプライベート ネットワーク サービスを提供する、IP ネットワーク インフラストラクチャ。Cisco IOS ネットワークで MPLS VPN を使用すると、スケーラブルなレイヤ 3 VPN バックボーン サービス(アプリケーション、データ ホスティング ネットワーク コマース、テレフォニー サービスなど)を展開および管理する機能をビジネス上のカスタマーに提供できます。

MPLS VPN ソリューションでは、MPLS VPN は、共通の「バックボーン」ネットワークによって接続された一連のプロバイダー エッジ ルータであり、2 つ以上のカスタマー サイト間のプライベート IP 相互接続を特定のカスタマーに提供します。各 VPN には一連のプロビジョニング テンプレートとポリシーがあり、VPN は複数の Provider Administrative Domain(PAD; プロバイダー管理ドメイン)にまたがることができます。

NMS :Network Management System(ネットワーク管理システム)。ネットワーク管理者がネットワーク内の他のデバイスとの通信に使用する、十分に装備された強力なコンピュータ(通常はエンジニアリング ワークステーション)。NMS は通常、ネットワーク リソースの管理、統計の収集、さまざまなネットワーク管理タスクと設定タスクの実行のために使用されます。

PE ルータ :Provider Edge(プロバイダー エッジ)ルータ。VPN プロバイダーと VPN カスタマーの境界にあり、プロバイダーに属するルータ。

QoS :Quality Of Service。伝送システムのパフォーマンスの測定。伝送システムの伝送品質およびサービス アベイラビリティが反映されます。

RIB :Routing Information Base(ルーティング情報ベース)。ルーティング テーブルとも呼ばれます。

RT :Route Target(ルート ターゲット)。ルータのグループ、およびそのグループの各ルータにある転送テーブルのサブセットを識別する拡張コミュニティ アトリビュート。転送テーブルは、ルータによって保持され、その拡張コミュニティ アトリビュートを伝送する BGP ルートを格納できます。RT は 64 ビット値で、Cisco IOS ソフトウェアは VRF でのルート更新のためにこの値を使用してルートを区別します。

SNMP :Simple Network Management Protocol(簡易ネットワーク管理プロトコル)。TCP/IP ネットワークでほぼ独占的に使用されているネットワーク管理プロトコル。SNMP では、ネットワーク デバイスを監視および制御し、設定、統計情報収集、パフォーマンス、およびセキュリティを管理できます。「SNMP2」 も参照してください

SNMP2 :SNMP バージョン 2。一般的なネットワーク管理プロトコルのバージョン 2。SNMP2 では、集中型および分散型のネットワーク管理方式がサポートされ、Structure of Management Information(SMI; 管理情報構造)、プロトコル動作、管理アーキテクチャ、およびセキュリティが改善されています。「SNMP」 も参照してください

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。管理ポリシー セットにより、共有バックボーン ネットワーク上で相互に通信可能なサイトのグループ。VPN は、1 つまたは複数の物理ネットワークでリソースを共有するセキュアな IP ベースのネットワークです。VPN には地理的に分散したサイトが含まれており、共有バックボーン上で安全に通信できるようになっています。「MPLS VPN」 も参照してください

VPN ID :RFC 2685 に基づいて VPN を識別するメカニズム。VPN ID は、Organizational Unique Identifier(OUI; 組織固有識別子)、IEEE Registration Authority によって割り当てられた 3 オクテットの 16 進数、および会社内で VPN を識別する 4 オクテットの 16 進数である VPN インデックスで構成されます。

VRF :VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンス。VRF は、IP ルーティング テーブル、取得された転送テーブル、その転送テーブルを使用する一連のインターフェイス、転送テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。一般に、VRF には、PE ルータに付加されるカスタマー VPN サイトが定義されたルーティング情報が格納されています。

応答要求 :従来のトラップ通知メッセージよりも信頼性の高い通知メッセージのタイプ。信頼性が高いのは、応答要求メッセージ通知には確認応答が必要ですが、トラップ通知には必要ないためです。

コミュニティ :SNMP における、同じ管理ドメイン内の管理対象デバイスと NMS の論理グループ。

コミュニティ ストリング :パスワードとして機能するテキスト文字列。管理対象ステーションと SNMP エージェントを含むルータとの間で送信されるメッセージの認証に使用されます。コミュニティ ストリングは、マネージャとクライアント間のすべてのパケットで送信されます。コミュニティ名とも呼ばれます。

コミュニティ名 :「コミュニティ ストリング」 を参照してください

シスコ エクスプレス フォワーディング :高度なレイヤ 3 IP スイッチング テクノロジー。シスコ エクスプレス フォワーディングによって、大規模でダイナミックなトラフィック パターンを持つネットワークのパフォーマンスおよびスケーラビリティが最適化されます。

自律システム :同じルーティング プロトコルを共有し、同じシステム管理者の管理下にあるネットワークの集合。

通知 :SNMP エージェントによってネットワーク管理ステーション、コンソール、または端末に送信されるメッセージ。これにより、Cisco IOS ソフトウェア内で重大なイベントが発生したことが示されます。「トラップ」 も参照してください

トラップ :SNMP エージェントによってネットワーク管理ステーション、コンソール、または端末に送信されるメッセージ。これにより、重大なイベントが発生したことが示されます。受信者はトラップの受信時に確認応答を送信しないため、トラップ(通知)は応答要求よりも信頼性が低くなります。送信者は、トラップが受信されたかどうかを判断できません。「通知」 も参照してください。