マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
BGP を使用する MPLS VPN Carrier Supporting Carrier
BGP を使用する MPLS VPN Carrier Supporting Carrier
発行日;2012/02/01 | 英語版ドキュメント(2012/01/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

BGP を使用する MPLS VPN Carrier Supporting Carrier

機能情報の確認

この章の構成

BGP を使用する MPLS VPN CSC の前提条件

BGP を使用する MPLS VPN CSC の制約事項

BGP を使用する MPLS VPN CSC の概要

MPLS VPN CSC の概要

MPLS VPN CSC の実装の利点

BGP を使用する MPLS VPN CSC の実装の利点

BGP を使用する MPLS VPN CSC の設定オプション

カスタマー キャリアが IP コアを使用する ISP である場合

カスタマー キャリアが VPN サービスを使用または使用しない MPLS サービス プロバイダーである場合

BGP を使用する MPLS VPN CSC の設定方法

Carrier Supporting Carrier トポロジの識別

バックボーン キャリア コアの設定

前提条件

CSC コアにおける IP 接続と LDP 設定の確認

CSC-PE ルータの VRF の設定

バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定

CSC-PE ルータと CSC-CE ルータの設定

CSC-PE ルータの設定

CSC-CE ルータの設定

CSC-PE ルータのラベルの確認

CSC-CE ルータでのラベルの確認

カスタマー キャリア ネットワークの設定

前提条件

カスタマー キャリアでの IP 接続の確認

ルート リフレクタとしてのカスタマー キャリア コア ルータの設定

階層型 VPN のカスタマー サイトの設定

階層型 VPN の PE ルータでの VPN の定義

階層型 VPN の PE ルータでの BGP ルーティング セッションの設定

階層型 VPN の各 PE ルータでのラベルの確認

階層型 VPN の CE ルータの設定

カスタマー サイトでの IP 接続の確認

BGP を使用する MPLS VPN CSC の設定例

バックボーン キャリア コアの設定:例

CSC コアにおける IP 接続と LDP 設定の確認:例

CSC-PE ルータの VRF の設定:例

バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定:例

CSC-PE ルータと CSC-CE ルータ間のリンクの設定:例

CSC-PE ルータの設定:例

CSC-CE ルータの設定:例

CSC-PE ルータのラベルの確認:例

CSC-CE ルータのラベルの確認:例

カスタマー キャリア ネットワークの設定:例

カスタマー キャリアでの IP 接続の確認:例

ルート リフレクタとしてのカスタマー キャリア コア ルータの設定:例

階層型 VPN のカスタマー サイトの設定:例

階層型 VPN の PE ルータの設定:例

階層型 VPN の各 PE ルータでのラベルの確認:例

階層型 VPN の CE ルータの設定:例

カスタマー サイトでの IP 接続の確認:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

BGP を使用する MPLS VPN CSC の機能情報

用語集

BGP を使用する MPLS VPN Carrier Supporting Carrier

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Carrier Supporting Carrier(CSC)を使用すると、MPLS VPN ベースのサービス プロバイダーは、そのバックボーン ネットワークのセグメントを他のサービス プロバイダーが使用できるようにすることができます。この章では、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を使用してルートおよび MPLS ラベルを配布する MPLS VPN CSC ネットワークの設定方法について説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「BGP を使用する MPLS VPN CSC の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

BGP を使用する MPLS VPN CSC の前提条件

エンドツーエンド(CE から CE へのルータ)の ping が機能するように MPLS VPN を設定できる必要があります。そのためには、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)、MPLS Label Distribution Protocol(LDP; ラベル配布プロトコル)、および Multiprotocol Border Gateway Protocol(MP-BGP; マルチプロトコル ボーダー ゲートウェイ プロトコル)の設定方法を理解している必要があります。

CSC-PE ルータおよび CSC-CE ルータが、BGP ラベル配布をサポートするイメージを実行できる必要があります。実行できない場合は、これらのルータ間で External BGP(EBGP; 外部 BGP)を実行できません。カスタマー キャリアとバックボーンキャリア間の接続を確認します。EBGP ベースのラベル配布は、MPLS をカスタマー キャリアとバックボーンキャリア間でイネーブルにするために、これらのリンク上で設定されています。

BGP を使用する MPLS VPN CSC の制約事項

Provider Edge(PE; プロバイダー エッジ)ルータ上で、ラベルを使用する BGP または LDP のいずれかのインターフェイスを設定できます。両方のタイプのラベル配布を同じインターフェイス上でイネーブルにすることはできません。プロトコルを別のプロトコルに切り替える場合は、別のプロトコルをイネーブルにする前に、すべてのインターフェイス上の既存のプロトコルをディセーブルにする必要があります。

この機能では、次の機能はサポートされていません。

CSC-PE ルータと CSC-CE ルータ間の EBGP マルチホップ

EIBGP マルチパス ロード シェアリング

複数の BGP スピーカーを接続する物理インターフェイスは、シスコ エクスプレス フォワーディングまたは分散シスコ エクスプレス フォワーディングと MPLS をサポートしている必要があります。

BGP を使用する MPLS VPN CSC の概要

MPLS VPN CSC を設定する前に、次の概念を理解しておく必要があります。

「MPLS VPN CSC の概要」

「MPLS VPN CSC の実装の利点」

「BGP を使用する MPLS VPN CSC の実装の利点」

「BGP を使用する MPLS VPN CSC の設定オプション」

MPLS VPN CSC の概要

Carrier Supporting Carrier により、サービス プロバイダーは、そのバックボーン ネットワークのセグメントを別のサービス プロバイダーが使用できるようにすることができます。別のプロバイダーにバックボーン ネットワークのセグメントを提供するサービス プロバイダーは、バックボーン キャリアと呼ばれます。バックボーン ネットワークのセグメントを使用するサービス プロバイダーは、カスタマー キャリアと呼ばれます。

バックボーン キャリアは、Border Gateway Protocol および Multiprotocol Label Switching(BGP/MPLS; ボーダー ゲートウェイ プロトコル/マルチプロトコル ラベル スイッチング)VPN サービスを提供します。カスタマー キャリアは、次のいずれかになります。

Internet Service Provider(ISP; インターネット サービス プロバイダー)

BGP/MPLS VPN サービス プロバイダー

MPLS VPN CSC の実装の利点

MPLS VPN CSC ネットワークは、バックボーン キャリアであるサービス プロバイダー、およびカスタマー キャリアに対して次の利点をもたらします。

バックボーン キャリアにとっての利点

バックボーン キャリアは、多数のカスタマー キャリアに対応し、そのバックボーンにカスタマー キャリアがアクセスできるようにします。バックボーン キャリアは、それぞれのカスタマー キャリア用に個別のバックボーンを作成および維持する必要はありません。1 つのバックボーン ネットワークを使用して複数のカスタマー キャリアをサポートすると、バックボーン キャリアの VPN 動作が簡略化されます。バックボーン キャリアは、一貫した方法を使用して、バックボーン ネットワークを管理および維持します。この方法は、個々のバックボーンを維持するよりも安価かつ効率的でもあります。

MPLS VPN Carrier Supporting Carrier 機能は、スケーラブルです。Carrier Supporting Carrier では、帯域幅および接続の変化するニーズに合わせて VPN を変更できます。この機能は、予定外の成長や変更に対応できます。Carrier Supporting Carrier 機能により、同じネットワーク上で何千もの VPN をセットアップでき、サービス プロバイダーは VPN サービスとインターネット サービスの両方を提供できます。

MPLS VPN Carrier Supporting Carrier 機能は、柔軟なソリューションです。バックボーン キャリアは、多くのタイプのカスタマー キャリアに対応できます。バックボーン キャリアは、ISP であるカスタマー キャリアおよび VPN サービス プロバイダーであるカスタマー キャリアのいずれかまたは両方を受け入れることができます。バックボーン キャリアは、セキュリティおよびさまざまな帯域幅を必要とするカスタマー キャリアに対応できます。

カスタマー キャリアにとっての利点

MPLS VPN Carrier Supporting Carrier 機能により、カスタマー キャリアでは、独自のバックボーンを設定、運用、および維持する必要がなくなります。カスタマー キャリアは、バックボーン キャリアのバックボーン ネットワークを使用しますが、ネットワークのメンテナンスと運用はバックボーン キャリアが担当します。

バックボーン キャリアが提供する VPN サービスを使用するカスタマー キャリアには、フレーム リレーまたは ATM ベースの VPN が提供するのと同じレベルのセキュリティがもたらされます。また、カスタマー キャリアは VPN で IPSec を使用することにより、より高いレベルのセキュリティを確保できます。これは、バックボーン キャリアにとっては完全に透過的です。

カスタマー キャリアは、任意のリンク レイヤ テクノロジー(SONET、DSL、フレーム リレーなど)を使用して、CE ルータを PE ルータに接続し、PE ルータを P ルータに接続します。MPLS VPN Carrier Supporting Carrier 機能は、リンク レイヤとは独立しています。CE ルータと PE ルータは IP を使用して通信し、バックボーン キャリアは MPLS を使用します。

カスタマー キャリアは、任意のアドレッシング方式を使用でき、バックボーン キャリアによるサポートを引き続き受けることができます。カスタマーのアドレス空間およびルーティング情報は、他のカスタマー キャリアまたはバックボーン プロバイダーのアドレス空間およびルーティング情報とは独立しています。

BGP を使用する MPLS VPN CSC の実装の利点

BGP をイネーブルにするように CSC ネットワークを設定して、バックボーン キャリア PE ルータとカスタマー キャリア CE ルータ間のルートおよび MPLS ラベルを複数パスを使用して転送できます。BGP を使用して IPv4 ルートと MPLS ラベル ルートを配布する利点を次に示します。

BGP は、VPN Routing/Forwarding(VRF; VPN ルーティング/転送)インスタンス テーブルでの IGP および LDP の代わりになります。BGP を使用して、ルートおよび MPLS ラベルを配布できます。2 つではなく単一のプロトコルを使用すると、設定およびトラブルシューティングが簡単になります。

BGP は、2 つの ISP を接続する場合の優先ルーティング プロトコルです。主な理由は、そのルーティング ポリシーと拡張性です。ISP では、通常、2 つのプロバイダー間で BGP を使用します。この機能を使用すると、これらの ISP は BGP を使用できます。

BGP を使用する MPLS VPN CSC の設定オプション

バックボーン キャリアは、BGP サービスと MPLS VPN サービスを提供します。カスタマー キャリアは、次のいずれかになります。

「カスタマー キャリアが IP コアを使用する ISP である場合」

「カスタマー キャリアが VPN サービスを使用または使用しない MPLS サービス プロバイダーである場合」

ここでは、バックボーン キャリアおよびカスタマー キャリアが、IPv4 ルートと MPLS ラベルを配布する方法について説明します。

カスタマー キャリアが IP コアを使用する ISP である場合

図 1 に、カスタマー キャリアが ISP であるネットワーク設定を示します。このカスタマー キャリアには 2 つのサイトがあり、それぞれが Point of Presence(POP)です。カスタマー キャリアは、バックボーン キャリアによって提供される VPN サービスを使用してこれらのサイトを接続します。バックボーン キャリアは MPLS を使用します。ISP サイトは IP を使用します。

図 1 カスタマー キャリアが ISP であるネットワーク

CE ルータと PE ルータ間のリンクでは、EBGP を使用して、IPv4 ルートと MPLS ラベルを配布します。これらのリンク間では、PE ルータはマルチプロトコル IBGP を使用して、VPNv4 ルートを配布します。


) Cisco ルータ以外のルータが CSC-PE または CSC-CE として使用される場合、そのルータで IPv4 BGP ラベル配布(RFC 3107)がサポートされている必要があります。サポートされていない場合は、ラベルを使用する EBGP をルータ間で実行できません。


カスタマー キャリアが VPN サービスを使用または使用しない MPLS サービス プロバイダーである場合

図 2 に、バックボーン キャリアとカスタマー キャリアが BGP/MPLS VPN サービス プロバイダーであるネットワーク設定を示します。これは、階層型 VPN と呼ばれています。カスタマー キャリアには 2 つのサイトがあります。バックボーン キャリアとカスタマー キャリアは両方とも、それぞれのネットワークで MPLS を使用します。

図 2 カスタマー キャリアが MPLS VPN サービス プロバイダーであるネットワーク

 

この設定では、カスタマー キャリアは、そのネットワークを次のいずれかの方法で設定できます。

カスタマー キャリアは、そのコア ネットワークで IGP および LDP を実行できます。この場合、カスタマー キャリアの CSC-CE1 ルータは、バックボーン キャリアの CSC-PE1 ルータから学習した EBGP ルートを IGP に再配布します。

カスタマー キャリア システムの CSC-CE1 ルータは、PE1 ルータとの間で IPv4 およびラベル IBGP セッションを実行できます。

BGP を使用する MPLS VPN CSC の設定方法

ここでは、次の作業について説明します。

「Carrier Supporting Carrier トポロジの識別」(必須)

「バックボーン キャリア コアの設定」(必須)

「CSC-PE ルータと CSC-CE ルータの設定」(必須)

「カスタマー キャリア ネットワークの設定」(必須)

「階層型 VPN のカスタマー サイトの設定」(必須)

Carrier Supporting Carrier トポロジの識別

BGP を使用して MPLS VPN CSC を設定する前に、バックボーン キャリアとカスタマー キャリアの両方のトポロジを識別する必要があります。

階層型 VPN の場合、MPLS VPN ネットワークのカスタマー キャリアは、カスタマーに対して MPLS VPN サービスを提供します。この場合、カスタマー キャリアのタイプ、およびカスタマー キャリアのトポロジを識別する必要があります。階層型 VPN では、追加の設定手順が必要となります。この設定手順については、設定の項で説明します。


) 複数のインターフェイスを使用して、複数の CSC-CE ルータを同じ PE に接続したり、単一の CSC-CE ルータを複数の CSC-PE に接続したりすることにより、CSC トポロジでの冗長性および複数パス サポートを提供できます。


Carrier Supporting Carrier トポロジを識別するには、次の作業を実行します。

手順の概要

1. カスタマー キャリアのタイプ、ISP、または MPLS VPN サービス プロバイダーを識別します。

2. (階層型 VPN の場合だけ)CE ルータを識別します。

3. (階層型 VPN の場合だけ)カスタマー キャリアのコア ルータの設定を識別します。

4. カスタマー キャリア エッジ(CSC-CE)ルータを識別します。

5. バックボーン キャリア ルータ設定を識別します。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

カスタマー キャリアのタイプ、ISP、または MPLS VPN サービス プロバイダーを識別します。

Carrier Supporting Carrier ネットワークの設定に関する要件を設定します。

ISP の場合、カスタマー サイトの設定は必要ありません。

MPLS VPN サービス プロバイダーの場合、カスタマー サイトを設定する必要があるだけでなく、「階層型 VPN の場合だけ」に必要となる作業や手順もあります。

ステップ 2

(階層型 VPN の場合だけ)CE ルータを識別します。

CE から PE への接続の設定に関する要件を設定します。

ステップ 3

(階層型 VPN の場合だけ)カスタマー キャリアのコア ルータの設定を識別します。

コア(P)ルータ間、およびコア(P)ルータとエッジ ルータ(PE ルータと CSC-CE ルータ)間の接続設定に関する要件を設定します。

ステップ 4

カスタマー キャリア エッジ(CSC-CE)ルータを識別します。

CSC-CE から CSC-PE への接続の設定に関する要件を設定します。

ステップ 5

バックボーン キャリア ルータ設定を識別します。

CSC コア ルータ間、および CSC コア ルータとエッジ ルータ(CSC-CE ルータと CSC-PE ルータ)間の接続設定に関する要件を設定します。

この次の手順

「バックボーン キャリア コアの設定」で説明しているように、Carrier Supporting Carrier ネットワークをセットアップします。

バックボーン キャリア コアの設定

バックボーン キャリア コアの設定では、CSC コア ルータと CSC-PE ルータの接続およびルーティング機能をセットアップする必要があります。

CSC コア(バックボーン キャリア)を設定および確認するには、次の作業を実行します。

「CSC コアにおける IP 接続と LDP 設定の確認」(任意)

「CSC-PE ルータの VRF の設定」(必須)

「バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定」(必須)

前提条件

バックボーン キャリア コアを設定する前に、CSC コア ルータ上で次のプロトコルを設定します。

IGP ルーティング プロトコル:BGP、OSPF、IS-IS、EIGRP、スタティックなど。

Label Distribution Protocol(LDP; ラベル配布プロトコル)。詳細については、『 How to Configure MPLS LDP 』を参照してください。

CSC コアにおける IP 接続と LDP 設定の確認

CSC コアにおける IP 接続と LDP 設定を確認するには、次の作業を実行します。

手順の概要

1. enable

2. ping [ protocol ] { host - name | system - address }

3. trace [ protocol ] [ destination ]

4. show mpls forwarding - table [ vrf vrf-name ] [{ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

5. show mpls ldp discovery [ vrf vrf-name | all ]

6. show mpls ldp neighbor [[ vrf vrf-name ] [ address | interface ] [ detail ] | all ]

7. show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

8. show mpls interfaces [[ vrf vrf-name ] [ interface ] [ detail ] | all ]

9. show ip route

10. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping [ protocol ] { host-name | system-address }

 

Router# ping ip 10.1.0.0

(任意)AppleTalk、CLNS、IP、Novell、Apollo、VINES、DECnet、または XNS ネットワークでの基本的なネットワーク接続を診断します。

ping ip コマンドを使用して、CSC コア ルータから別の CSC コア ルータへの接続を確認します。

ステップ 3

trace [ protocol ] [ destination ]

 

Router# trace ip 10.2.0.0

(任意)パケットがその宛先に送信されるときに実際に取るルートを検出します。

trace コマンドを使用して、パケットがその最終的な宛先に到達するまでに通過するパスを確認します。 trace コマンドは、2 つのルータが通信できない場合に問題のある箇所を分離するのに役立ちます。

ステップ 4

show mpls forwarding-table [ vrf vrf-name ] [{ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

 

Router# show mpls forwarding-table

(任意)MPLS Label Forwarding Information Base(LFIB; ラベル転送情報ベース)の内容を表示します。

show mpls forwarding-table コマンドを使用して、MPLS パケットが転送されていることを確認します。

ステップ 5

show mpls ldp discovery [ vrf vrf-name | all ]

 

Router# show mpls ldp discovery

(任意)LDP ディスカバリ プロセスのステータスを表示します。

show mpls ldp discovery コマンドを使用して、LDP が CSC コアで動作していることを確認します。

ステップ 6

show mpls ldp neighbor [[ vrf vrf-name ] [ address | interface ] [ detail ] | all ]

 

Router# show mpls ldp neighbor

(任意)LDP セッションのステータスを表示します。

show mpls ldp neighbor コマンドを使用して、CSC コアにおける LDP 設定を確認します。

ステップ 7

show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

 

Router# show ip cef

(任意)Forwarding Information Base(FIB; 転送情報ベース)のエントリを表示します。

show ip cef コマンドを使用して、転送テーブル(プレフィクス、ネクスト ホップ、およびインターフェイス)を確認します。

ステップ 8

show mpls interfaces [[ vrf vrf-name ] [ interface ] [ detail ] | all ]

 

Router# show mpls interfaces

(任意)ラベル スイッチングに設定されている 1 つ以上のインターフェイスまたはすべてのインターフェイスに関する情報を表示します。

show mpls interfaces コマンドを使用して、LDP を使用するようにインターフェイスが設定されていることを確認します。

ステップ 9

show ip route

 

Router# show ip route

(任意)IP ルーティング テーブルのエントリを表示します。

show ip route コマンドを使用して、ホスト IP アドレス、ネクストホップ、インターフェイスなどを含む、ルーティング テーブル全体を表示します。

ステップ 10

disable

 

Router# disable

(任意)特権 EXEC モードに戻ります。

トラブルシューティングのヒント

ping コマンドと trace コマンドを使用して、コアにおける MPLS 接続の詳細を確認します。さらに show コマンドを使用して、有用なトラブルシューティング情報を入手することもできます。

CSC-PE ルータの VRF の設定

VPN Routing/Forwarding(VRF; VPN ルーティング/転送)インスタンスをバックボーン キャリア エッジ(CSC-PE)ルータに設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target { import | export | both } route-target-ext-community

6. import map route-map

7. exit

8. interface type number

9. ip vrf forwarding vrf-name

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf vpn1

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 100:1

ルーティング テーブルと転送テーブルを作成します。

route-distinguisher 引数によって、8 バイトの値が IPv4 プレフィクスに追加され、VPN IPv4 プレフィクスが作成されます。RD は、次のいずれかの形式で入力できます。

16 ビットの AS 番号:32 ビットの番号。101:3 など。

32 ビットの IP アドレス:16 ビットの番号。192.168.122.15:1 など。

ステップ 5

route-target { import | export | both } route-target-ext-community

 

Router(config-vrf)# route-target import 100:1

VRF 用の route-target 拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ターゲット VPN 拡張コミュニティとの間でルーティング情報がインポートまたはエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ アトリビュートが、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 6

import map route-map

 

Router(config-vrf)# import map vpn1-route-map

(任意)VRF のインポート ルート マップを作成します。

route-map 引数には、VRF のインポート ルート マップとして使用されるルート マップを指定します。

ステップ 7

exit

 

Router(config-vrf)# exit

(任意)終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface type number

 

Router(config)# interface Ethernet5/0

設定するインターフェイスを指定します。

type 引数には、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 9

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding vpn1

指定したインターフェイスまたはサブインターフェイスに VRF を関連付けます。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 10

end

 

Router(config-if)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show ip vrf detail コマンドを入力し、MPLS VPN が稼動しており、適切なインターフェイスに関連付けられていることを確認します。

バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定

バックボーン キャリアで Multiprotocol BGP(MP-BGP; マルチプロトコル BGP)接続を設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. no bgp default ipv4-unicast

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } update-source interface-type

7. address-family vpnv4 [ unicast ]

8. neighbor { ip-address | peer-group-name } send-community extended

9. neighbor { ip-address | peer-group-name } activate

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as - number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

(任意)IPv4 ユニキャスト アドレス ファミリをすべてのネイバーでディセーブルにします。

ネイバーを MPLS ルートだけに使用している場合は、 bgp default-unicast コマンドを no 形式で使用します。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.5.5.5 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } update-source interface-type

 

Router(config-router)# neighbor 10.2.0.0 update-source loopback0

BGP セッションで、TCP 接続の特定の動作インターフェイスを使用できるようになります。

ip-address 引数には、BGP スピーキング ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

interface-type 引数には、ソースとして使用するインターフェイスを指定します。

ステップ 7

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

省略可能な unicast キーワードは、VPNv4 ユニキャスト アドレス プレフィクスを指定する場合に使用します。

ステップ 8

neighbor { ip-address | peer-group-name } send-community extended

 

Router(config-router-af)# neighbor 10.0.0.1 send-community extended

コミュニティ アトリビュートを BGP ネイバーに送信する必要があることを指定します。

ip-address 引数には、BGP スピーキング ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 9

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.4.0.0 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 10

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show ip bgp neighbor コマンドを入力して、ネイバーが稼動中であることを確認できます。このコマンドが成功しなかった場合は、 debug ip bgp x.x.x.x events コマンドを入力します。ここで、 x.x.x.x はネイバーの IP アドレスです。

CSC-PE ルータと CSC-CE ルータの設定

BGP を使用してルートと MPLS ラベルを配布する MPLS VPN CSC ネットワークの CSC-PE ルータとキャリア CSC-CE ルータとの間のリンクを設定および確認するには、次の作業を実行します。

「CSC-PE ルータの設定」(必須)

「CSC-CE ルータの設定」(必須)

「CSC-PE ルータのラベルの確認」(任意)

「CSC-CE ルータでのラベルの確認」(任意)

図 3 に、CSC-PE ルータと CSC-CE ルータ間を直接接続するインターフェイスによるピアリングの設定を示します。この設定は、次に説明する作業で例として使用します。

図 3 CSC-PE ルータと CSC-CE ルータ間を直接接続するインターフェイスによるピアリングの設定

 

CSC-PE ルータの設定

CSC-PE ルータを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } activate

7. neighbor ip-address as-override

8. neighbor ip-address send-label

9. exit-address-family

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 
Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vpn1

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router-af)# neighbor 10.0.0.1 remote-as 200

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.0.0.2 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

neighbor ip-address as-override

 

Router(config-router-af)# neighbor 10.0.0.2 as-override

サイトの Autonomous System Number(ASN; 自律システム番号)をプロバイダーの ASN で上書きするように PE ルータを設定します。

ip-address 引数には、指定した ASN で上書きされるルータの IP アドレスを指定します。

ステップ 8

neighbor ip-address send-label

 

Router(config-router-af)# neighbor 10.0.0.2 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数では、ネイバー ルータの IP アドレスを指定します。

ステップ 9

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 10

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show ip bgp neighbor コマンドを入力して、ネイバーが稼動中であることを確認します。コマンド出力で、ネイバーの各機能の下に次の行が表示されていることを確認してください。

IPv4 MPLS Label capability:advertised and received

CSC-CE ルータの設定

CSC-CE ルータを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. redistribute protocol

6. neighbor { ip-address | peer-group-name } remote-as as-number

7. neighbor { ip-address | peer-group-name } activate

8. neighbor ip-address send-label

9. exit-address-family

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number
 
Router(config)# router bgp 200

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

redistribute protocol

 

Router(config-router-af)# redistribute static

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

protocol 引数には、ルートの再配布元となるソース プロトコルを指定します。次のいずれかのキーワードを指定できます。 bgp egp igrp isis ospf mobile static [ ip ]、 connected 、および rip

static [ ip ] キーワードを使用すると、IP スタティック ルートが再配布されます。省略可能な ip キーワードは、スタティック ルートを IS-IS に再配布する場合に使用します。

connected キーワードは、IP がインターフェイスでイネーブルな場合に自動的に確立されるルートを示します。OSPF や IS-IS などのルーティング プロトコルの場合、これらのルートは自律システムに対して外部として再配布されます。

ステップ 6

neighbor { ip-address | peer-group-name } remote-as as-number
 
Router(config-router-af)# neighbor 10.5.0.2 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 7

neighbor { ip-address | peer-group-name } activate
 
Router(config-router-af)# neighbor 10.3.0.2 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 8

neighbor ip-address send-label
 
Router(config-router-af)# neighbor 10.0.0.2 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数では、ネイバー ルータの IP アドレスを指定します。

ステップ 9

exit-address-family
 
Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 10

end
 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

CSC-PE ルータのラベルの確認

CSC-PE ルータのラベルを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

3. show mpls interfaces [ all ]

4. show ip route vrf vrf-name [ prefix ]

5. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

6. show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

7. show mpls forwarding - table [ vrf vrf-name ] [{ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

8. traceroute vrf [ vrf-name ] ip-address

9. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

 

Router# show ip bgp vpnv4 all summary

(任意)BGP テーブルの VPN アドレス情報を表示します。

show ip bgp vpnv4 all summary コマンドを使用して、BGP セッションが CSC-PE ルータと CSC-CE ルータ間で稼動中であることを確認します。State/PfxRcd カラムのデータをチェックして、各セッション時にプレフィクスが学習されていることを確認します。

ステップ 3

show mpls interfaces [ all ]

 

Router# show mpls interfaces all

(任意)ラベル スイッチングに設定されている 1 つ以上のインターフェイスに関する情報を表示します。

show mpls interfaces all コマンドを使用して、MPLS インターフェイスが稼動中であることを確認します。また、LDP 対応インターフェイスに、LDP が稼動中であることが示されていることを確認します。EBGP によってラベルが配布されるため、VRF では LDP がオフになっていることを確認してください。

ステップ 4

show ip route vrf vrf-name [ prefix ]

 

Router# show ip route vrf vpn1 10.5.5.5

(任意)VRF に関連付けられている IP ルーティング テーブルを表示します。

show ip route vrf コマンドを使用して、PE ルータのプレフィクスが CSC-PE ルータのルーティング テーブルに存在することを確認します。

(注) CSC-PE と CSC-CE 間に複数パスを設定している場合は、CSC-CE から学習した同じ宛先への複数ルートが、対応する VRF ルーティング テーブルにインストールされていることを確認します。

ステップ 5

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

 

Router# show ip bgp vpnv4 vrf vpn1 labels

(任意)BGP テーブルの VPN アドレス情報を表示します。

show ip bgp vpnv4 vrf vrf-name labels コマンドを使用して、カスタマー キャリア MPLS サービス プロバイダー ネットワークのプレフィクスが BGP テーブルに存在し、適切なラベルが付けられていることを確認します。

(注) CSC-PE と CSC-CE 間に複数パスを設定している場合は、CSC-CE から学習した同じ宛先への複数のラベルが、対応する VRF ルーティング テーブルにインストールされていることを確認します。

ステップ 6

show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

 

Router# show ip cef vrf vpn1 10.1.0.0 detail

(任意)Forwarding Information Base(FIB; 転送情報ベース)のエントリを表示するか、または FIB のサマリーを表示します。

show ip cef vrf コマンドと show ip cef vrf detail コマンドを使用して、PE ルータのプレフィクスが CEF テーブルに存在することを確認します。

ステップ 7

show mpls forwarding-table [ vrf vrf-name ] [{ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

 

Router# show mpls forwarding-table vrf vpn1 10.1.0.0 detail

(任意)MPLS Forwarding Information Base(LFIB; ラベル転送情報ベース)の内容を表示します。

vrf キーワード、および vrf キーワードと detail キーワードの両方を指定した show mpls forwarding-table コマンドを使用して、ローカル カスタマー MPLS VPN サービス プロバイダーにおける PE ルータのプレフィクスが LFIB 内にあることを確認します。

(注) CSC-PE と CSC-CE 間に複数パスを設定している場合は、CSC-CE から学習したのと同じ宛先のラベルが、対応する VRF テーブルにインストールされていることを確認します。

ステップ 8

traceroute vrf [ vrf-name ] ip-address

 

Router# traceroute vrf vpn2 10.2.0.0

パケットがその宛先に到達するまでにネットワークを通過するルートを表示します。

traceroute vrf コマンドを使用して、PE から宛先 CE ルータへのデータ パスおよびトランスポート ラベルを確認します。

コマンドに関するマニュアルを参照してください。

(注) CSC-PE と CSC-CE 間に複数パスを設定している場合は、CSC-CE から学習した同じ宛先への複数ルートが、対応する VRF テーブルにインストールされていることを確認します。

ステップ 9

disable

 

Router# disable

(任意)終了して、ユーザ EXEC モードに戻ります。

CSC-CE ルータでのラベルの確認

CSC-CE ルータでラベルを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip bgp summary

3. show ip route [ address ]

4. show mpls ldp bindings [ network { mask | length }]

5. show ip cef [ network [ mask ]] [l onger-prefixes ] [ detail ]

6. show mpls forwarding - table [ vrf vrf-name ] [{ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

7. show ip bgp labels

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip bgp summary

 

Router# show ip bgp summary

(任意)すべての BGP 接続のステータスを表示します。

show ip bgp summary コマンドを使用して、BGP セッションが CSC-CE ルータ上で稼動中であることを確認します。

ステップ 3

show ip route [ address ]

 

Router# show ip route 10.1.0.0

(任意)IP ルーティング テーブルのエントリを表示します。

show ip route コマンドを使用して、ローカルおよびリモートの PE ルータのループバック アドレスがルーティング テーブルに存在することを確認します。

(注) CSC-PE と CSC-CE 間に複数パスを設定している場合は、CSC-CE から学習した同じ宛先への複数ルートが、対応する VRF テーブルにインストールされていることを確認します。

ステップ 4

show mpls ldp bindings [ network { mask | length }]

 

Router# show mpls ldp bindings 10.2.0.0 255.255.255.255

(任意)Label Information Base(LIB; ラベル情報ベース)の内容を表示します。

show mpls ldp bindings コマンドを使用して、ローカル PE ルータのプレフィクスが MPLS LDP バインディングに存在することを確認します。

ステップ 5

show ip cef [ network [ mask ]] [ longer-prefixes ] [ detail ]

 

Router# show ip cef 10.5.0.0 detail

(任意)Forwarding Information Base(FIB; 転送情報ベース)のエントリまたは FIB のサマリーを表示します。

show ip cef コマンドと show ip cef detail コマンドを使用して、ローカルおよびリモートの PE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

(注) CSC-PE と CSC-CE 間に複数パスを設定している場合は、CSC-CE から学習した同じ宛先への複数のルートとラベルが、対応する VRF テーブルにインストールされていることを確認します。

ステップ 6

show mpls forwarding-table [ vrf vrf-name ] [{ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

 

Router# show mpls forwarding-table 10.2.0.0 detail

(任意)MPLS LFIB の内容を表示します。

show mpls forwarding-table コマンドと show mpls forwarding-table detail コマンドを使用して、ローカルおよびリモートの PE ルータのプレフィクスが、MPLS 転送テーブルに存在することを確認します。

(注) CSC-PE と CSC-CE 間に複数パスを設定している場合は、CSC-CE から学習した同じ宛先への複数のルートとラベルが、対応する VRF ルーティング テーブルにインストールされていることを確認します。

ステップ 7

show ip bgp labels

 

Router# show ip bgp labels

(任意)EBGP ルート テーブルの MPLS ラベルに関する情報を表示します。

show ip bgp labels コマンドを使用して、BGP ルーティング テーブルに、カスタマー キャリア MPLS VPN サービス プロバイダー ネットワークのプレフィクスのラベルが含まれていることを確認します。

カスタマー キャリア ネットワークの設定

カスタマー キャリア ネットワークを設定および確認するには、次の作業を実行します。手順を実行するには、カスタマー キャリア コア(P)ルータおよびカスタマー キャリア エッジ(PE)ルータに対して接続およびルーティング機能をセットアップする必要があります。

「カスタマー キャリアでの IP 接続の確認」(任意)

「ルート リフレクタとしてのカスタマー キャリア コア ルータの設定」(任意)

前提条件

BGP を使用してルートと MPLS ラベルを配布する MPLS VPN CSC ネットワークを設定する前に、カスタマー キャリア ルータで次のことを設定する必要があります。

IGP ルーティング プロトコル:BGP、OSPF、IS-IS、EIGRP、スタティックなど。詳細については、『 Configuring a Basic BGP Network 』、『 Configuring OSPF 』、『 Configuring a Basic IS-IS Network 』、および『 Configuring EIGRP 』を参照してください。

PE ルータ上での MPLS VPN 機能(階層型 VPN の場合だけ)。

P ルータおよび PE ルータでの Label Distribution Protocol(LDP; ラベル配布プロトコル)(階層型 VPN の場合だけ)。詳細については、『 How to Configure MPLS LDP 』を参照してください。


) この項の作業を実行する前に、上のリストの項目を設定する必要があります。


カスタマー キャリアでの IP 接続の確認

カスタマー キャリアでの IP 接続を確認するには、次の作業を実行します。

手順の概要

1. enable

2. ping [ protocol ] { host-name | system-address }

3. trace [ protocol ] [ destination ]

4. show ip route

5. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping [ protocol ] { host-name | system - address }

 

Router# ping ip 10.2.0.0

AppleTalk、CLNS、IP、Novell、Apollo、VINES、DECnet、または XNS ネットワークでの基本的なネットワーク接続を診断します。

ping コマンドを使用して、カスタマー キャリア コア ルータから別のカスタマー キャリア コア ルータへの接続を確認します。

ステップ 3

trace [ protocol ] [ destination ]

 

Router# trace ip 10.1.0.0

パケットがその宛先に送信されるときに実際に取るルートを検出します。

trace コマンドを使用して、パケットがその最終的な宛先に到達するまでに通過するパスを確認します。 trace コマンドは、2 つのルータが通信できない場合に問題のある箇所を分離するのに役立ちます。

ステップ 4

show ip route

 

Router# show ip route

IP ルーティング テーブルのエントリを表示します。

show ip route コマンドを使用して、ホスト IP アドレス、ネクストホップ、インターフェイスなどを含む、ルーティング テーブル全体を表示します。

ステップ 5

disable

 

Router# disable

ユーザ モードに戻ります。

ルート リフレクタとしてのカスタマー キャリア コア ルータの設定

カスタマー キャリア コア(P)ルータをマルチプロトコル BGP プレフィクスのルート リフレクタとして設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. neighbor { ip-address | peer-group-name } remote-as as-number

5. address-family vpnv4 [ unicast ]

6. neighbor { ip-address | peer-group-name } activate

7. neighbor ip-address route-reflector-client

8. exit-address-family

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 200

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にラベルを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.1.1.1 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 5

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

省略可能な unicast キーワードは、VPNv4 ユニキャスト アドレス プレフィクスを指定する場合に使用します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.1.1.1 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

neighbor ip-address route-reflector-client

 

Router(config-router-af)# neighbor 10.1.1.1 route-reflector-client

ルータを BGP ルート リフレクタとして設定し、指定したネイバーをそのクライアントとして設定します。

ip-address 引数には、クライアントとして識別される BGP ネイバーの IP アドレスを指定します。

ステップ 8

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 9

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

デフォルトでは、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用して定義したネイバーが、ユニキャスト アドレス プレフィクスだけを交換します。ネイバーが、マルチキャストや VPNv4 などの他のアドレス プレフィクス タイプを交換できるようにするには、上で示しているように、アドレス ファミリ コンフィギュレーション モードで neighbor activate コマンドを使用して、ネイバーをアクティブにする必要もあります。

neighbor route-reflector-client コマンドを使用してルータ コンフィギュレーション モードで定義したルート リフレクタおよびクライアント(ネイバーまたは内部 BGP ピア グループ)では、デフォルトで、これらのクライアントへの、またはこれらのクライアントからのユニキャスト アドレス プレフィクスが反映されます。ルート リフレクタおよびクライアントで、マルチキャストなどの他のアドレス ファミリのプレフィクスを反映できるようにするには、上で示しているように、 neighbor route-reflector-client コマンドを使用して、アドレス ファミリ コンフィギュレーション モードでリフレクタおよびクライアントを定義します。

階層型 VPN のカスタマー サイトの設定


) この項は、BGP を使用してルートおよび MPLS ラベルを配布するカスタマー キャリア ネットワークだけに適用されます。


階層型 VPN のカスタマー サイトを設定および確認するには、次の作業を実行します。

「階層型 VPN の PE ルータでの VPN の定義」(必須)

「階層型 VPN の PE ルータでの BGP ルーティング セッションの設定」(必須)

「階層型 VPN の各 PE ルータでのラベルの確認」(任意)

「階層型 VPN の CE ルータの設定」(必須)

「カスタマー サイトでの IP 接続の確認」(任意)


) この項は、階層型 VPN だけに適用されます。


階層型 VPN の PE ルータでの VPN の定義

PE ルータで VPN を定義するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target { import | export | both } route-target-ext-community

6. import map route-map

7. ip vrf forwarding vrf-name

8. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf vpn2

VRF ルーティング テーブルとシスコ エクスプレス フォワーディング テーブルを作成し、VRF コンフィギュレーション モードを開始します。

vrf-name 引数は、VRF に割り当てられた名前です。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 200:1

VRF のルーティング テーブルと転送テーブルを作成します。

route-distinguisher 引数によって、8 バイトの値が IPv4 プレフィクスに追加され、VPN IPv4 プレフィクスが作成されます。

ステップ 5

route-target { import | export | both } route-target-ext-community

 

Router(config-vrf)# route-target export 200:1

VRF 用の route-target 拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ターゲット VPN 拡張コミュニティとの間でルーティング情報がインポートまたはエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ アトリビュートが、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 6

import map route-map

 

Router(config-vrf)# import map map23

VRF のインポート ルート マップを作成します。

route-map 引数には、VRF のインポート ルート マップとして使用されるルート マップを指定します。

ステップ 7

ip vrf forwarding vrf-name

 

Router(config-vrf)# ip vrf forwarding vpn2

VPN VRF インスタンスをインターフェイスまたはサブインターフェイスに関連付けます。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 8

exit

 

Router(config-vrf)# exit

グローバル コンフィギュレーション モードに戻ります。

階層型 VPN の PE ルータでの BGP ルーティング セッションの設定

PE ルータで PE から CE へのルータ通信の BGP ルーティング セッションを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. neighbor { ip address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } activate

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 200

BGP プロセスを実行するようにルータを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 multicast

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

neighbor { ip-address | peer-group-name } remote - as as-number

 

Router(config-router-af)# neighbor 10.5.5.5 remote-as 300

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as - number 引数には、ネイバーが属している自律システムを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.1.0.0 activate

ネイバー ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

階層型 VPN の各 PE ルータでのラベルの確認

階層型 VPN の各 PE ルータでラベルを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip route vrf vrf-name [ prefix ]

3. show mpls forwarding-table [ vrf vrf-name ] [ prefix ] [ detail ]

4. show ip cef [ network [ mask [ longer-prefix ]]] [ detail ]

5. show ip cef vrf vrf-name [ ip-prefix ]

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip route vrf vrf-name [ prefix ]

 

Router# show ip route vrf vpn2 10.5.5.5

(任意)VRF に関連付けられている IP ルーティング テーブルを表示します。

show ip route vrf コマンドを使用して、ローカルおよびリモートの CE ルータのループバック アドレスが、PE ルータのルーティング テーブルに存在することを確認します。

ステップ 3

show mpls forwarding-table [ vrf vrf-name ] [ prefix ] [ detail ]

 

Router# show mpls forwarding-table vrf vpn2 10.1.0.0

(任意)LFIB の内容を表示します。

show mpls forwarding-table コマンドを使用して、ローカルおよびリモートの CE ルータのプレフィクスが、MPLS 転送テーブルに存在し、指定したプレフィクスが非タグ付きであることを確認します。

ステップ 4

show ip cef [ network [ mask [ longer-prefix ]]] [ detail ]

 

Router# show ip cef 10.2.0.0

(任意)IP アドレス情報に基づく FIB 内に特定のエントリが表示されます。

show ip cef コマンドを使用して、ローカルおよびリモートの PE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

ステップ 5

show ip cef vrf vrf-name [ ip-prefix ]

 
Router# show ip cef vrf vpn2 10.3.0.0

(任意)VRF に関連付けられているシスコ エクスプレス フォワーディング テーブルを表示します。

show ip cef vrf コマンドを使用して、リモート CE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

ステップ 6

exit

 

Router# exit

(任意)終了して、ユーザ EXEC モードに戻ります。

階層型 VPN の CE ルータの設定

階層型 VPN の CE ルータを設定するには、次の作業を実行します。この設定は、階層型トポロジではない MPLS VPN の場合の設定と同じです。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. interface type number

5. ip address ip-address mask [ secondary ]

6. exit

7. router bgp as - number

8. redistribute protocol

9. neighbor { ip-address | peer-group-name } remote-as as-number

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distributed ]

 

Router(config)# ip cef distributed

ルート プロセッサ カードでシスコ エクスプレス フォワーディングをイネーブルにします。

distributed キーワードを使用すると、分散シスコ エクスプレス フォワーディング動作がイネーブルになります。シスコ エクスプレス フォワーディング情報は、複数のラインカードに分散されます。ラインカードによって、エクスプレス フォワーディングが実行されます。

キーワードは必須です。

ステップ 4

interface type number

 

Router(config)# interface loopback 0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

ループバック インターフェイスは、常に稼動状態にあるインターフェイスをエミュレートするソフトウェア専用インターフェイスを示します。これは、すべてのプラットフォームでサポートされている仮想インターフェイスです。

number 引数は、作成または設定するループバック インターフェイスの数です。作成可能なループバック インターフェイスの数に制限はありません。

ステップ 5

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.8.0.0 255.255.255.255

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ip-address 引数は、IP アドレスです。

mask 引数は、関連付けられた IP サブネットのマスクです。

secondary キーワードは、設定されるアドレスがセカンダリ IP アドレスであることを指定する場合に使用します。このキーワードを省略すると、設定されるアドレスはプライマリ IP アドレスになります。

ステップ 6

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

router bgp as - number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 8

redistribute protocol

 

Router(config-router)# redistribute connected

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

protocol 引数には、ルートの再配布元となるソース プロトコルを指定します。次のいずれかのキーワードを指定できます。 bgp connected egp igrp isis mobile ospf static [ ip ]、または rip

connected キーワードは、IP がインターフェイスでイネーブルな場合に自動的に確立されるルートを示します。Open Shortest Path First(OSPF)や IS-IS などのルーティング プロトコルの場合、これらのルートは自律システムに対して外部として再配布されます。

ステップ 9

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.8.0.0 remote-as 100

リモート自律システムでのネイバーの IP アドレスを、ローカル ルータのマルチプロトコル BGP ネイバー テーブルに追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 10

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

カスタマー サイトでの IP 接続の確認

カスタマー サイトでの IP 接続を確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip route [ ip-address [ mask ] [ longer-prefixes ] | protocol [ process-id ] | list [ access-list-number | access-list-name ] | static download ]

3. ping [ protocol ] { host-name | system - address }

4. trace [ protocol ] [ destination ]

5. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip route [ ip-address [ mask ] [ longer-prefixes ] | protocol [ process-id ] | list [ access-list-number | access-list-name ] | static download ]

 

Router# show ip route 10.5.5.5

(任意)ルーティング テーブルの現在の状態を表示します。

show ip route ip-address コマンドを使用して、PE ルータを介して学習したリモート CE ルータのループバック アドレスが、ローカル CE ルータのルーティング テーブルに存在することを確認します。

ステップ 3

ping [ protocol ] { host-name | system - address }

 

Router# ping 10.5.5.5

Apollo、AppleTalk、Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)、DECnet、IP、Novell IPX、VINES、または XNS ネットワーク上で基本的なネットワーク接続を診断します。

ping コマンドを使用して、カスタマー サイトのルータ間の接続を確認します。

ステップ 4

trace [ protocol ] [ destination ]

 

Router# trace ip 10.5.5.5

パケットがその宛先に送信されるときに実際に取るルートを検出します。

trace コマンドを使用して、カスタマー サイトのパケットのパスを追跡します。

デフォルト以外のパラメータを使用し、拡張 trace テストを呼び出すには、宛先の引数を指定せずに trace コマンドを入力します。ダイアログに従って手順を実行し、目的のパラメータを選択します。

ステップ 5

disable

 

Router# disable

(任意)終了して、ユーザ EXEC モードに戻ります。

BGP を使用する MPLS VPN CSC の設定例

BGP を使用する MPLS VPN CSC の設定例には、次の設定が含まれます。

「バックボーン キャリア コアの設定:例」

「CSC-PE ルータと CSC-CE ルータ間のリンクの設定:例」

「カスタマー キャリア ネットワークの設定:例」

「階層型 VPN のカスタマー サイトの設定:例」

図 4 に、IPv4 ルートと MPLS ラベルを交換するためのサンプル CSC トポロジを示します。この図は、IPv4 ルートおよび MPLS ラベルを交換するために Carrier Supporting Carrier ルータを設定および確認する場合の参照として使用します。

図 4 IPv4 ルートと MPLS ラベルを交換するためのサンプル CSC トポロジ

 

表 1 では、図 4 で示しているサンプル設定について説明します。

 

表 1 図 4 に示しているサンプル設定の説明

ルータ
説明

CE1 および CE2

エンド カスタマーに属しています。CE1 ルータと CE2 ルータは、PE ルータから学習したルートを交換します。

エンド カスタマーは、カスタマー キャリアから VPN サービスを購入します。

PE1 および PE2

MPLS VPN サービスを提供するように設定された、カスタマー キャリア ネットワークの一部です。PE1 および PE2 は、VPNv4 IBGP セッションを使用してピアリングして、MPLS VPN ネットワークを形成します。

CSC-CE1 おおび CSC-CE2

カスタマー キャリア ネットワークの一部です。CSC-CE1 ルータと CSC-CE2 ルータは、MPLS ラベルとともに IPv4 BGP アップデートを交換し、IGP(この例では OSPF)との間で PE ループバック アドレスを再配布します。

カスタマー キャリアは、バックボーン キャリアから Carrier Supporting Carrier VPN サービスを購入します。

CSC-PE1 および CSC-PE2

Carrier Supporting Carrier VPN サービスを提供するように設定された、バックボーン キャリアのネットワークの一部です。CSC-PE1 および CSC-PE2 は、VPNv4 IP BGP セッションを使用してピアリングして、MPLS VPN ネットワークを形成します。VRF では、CSC-PE1 と CSC-PE2 は、CSC-CE ルータを使用してピアリングします。CSC-CE ルータは、IPv4 EBGP セッションを使用して、ルートとともに MPLS ラベルを伝送するように設定されています。

バックボーン キャリア コアの設定:例

この項に含まれている、バックボーン キャリア コアの設定例および確認例は、次のとおりです。

「CSC コアにおける IP 接続と LDP 設定の確認:例」

「CSC-PE ルータの VRF の設定:例」

「バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定:例」

CSC コアにおける IP 接続と LDP 設定の確認:例

CSC-CE1 で次のコマンドを入力して、CSC-PE2 が CSC-PE1 から到達可能であることを確認します。

Router# ping 10.5.5.5
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
 

CSC-CE1 で次のコマンドを入力して、CSC-PE1 から CSC-PE2 へのパスを確認します。

Router# trace 10.5.5.5
 
Type escape sequence to abort.
Tracing the route to 10.5.5.5
 
1 10.5.5.5 0 msec 0 msec *
 

次に示すように、CSC-PE ルータ プレフィクスが、MPLS 転送テーブルに存在することを確認します。

Router# show mpls forwarding-table
 
Local Outgoing Prefix or Bytes tag Outgoing Next Hop
tag tag or VC Tunnel Id switched interface
16 2/nn dd.dd.dd.dd/32 0 AT2/1/0.1 point2point
17 16 bb.bb.bb.bb/32[V] 30204 Et1/0 pp.0.0.1
21 Pop tag cc.cc.cc.cc/32[V] 0 Et1/0 pp.0.0.1
22 Pop tag nn.0.0.0/8[V] 570 Et1/0 pp.0.0.1
23 Aggregate pp.0.0.0/8[V] 0
2 2/nn gg.gg.gg.gg/32[V] 0 AT3/0.1 point2point
8 2/nn hh.hh.hh.hh/32[V] 15452 AT3/0.1 point2point
29 2/nn qq.0.0.0/8[V] 0 AT3/0.1 point2point
30 2/nn ss.0.0.0/8[V] 0 AT3/0.1 point2point
 

次に示すように、コアでの LDP ディスカバリ プロセスのステータスを確認します。

Router# show mpls ldp discovery
 
Local LDP Identifier:
ee.ee.ee.ee:0
Discovery Sources:
Interfaces:
ATM2/1/0.1 (ldp): xmit/recv
TDP Id: dd.dd.dd.dd:1
 

次に示すように、コアでの LDP セッションのステータスを確認します。

Router# show mpls ldp neighbor
 
Peer LDP Ident: dd.dd.dd.dd:1; Local LDP Ident ee.ee.ee.ee:1
TCP connection: dd.dd.dd.dd.646 - ee.ee.ee.ee.11007
State: Oper; Msgs sent/rcvd: 20/21; Downstream on demand
Up time: 00:14:56
LDP discovery sources:
ATM2/1/0.1, Src IP addr: dd.dd.dd.dd
 
 

次に示すように、転送テーブル(プレフィクス、ネクストホップ、およびインターフェイス)を確認します。

Router# show ip cef
 
Prefix Next Hop Interface
0.0.0.0/0 drop Null0 (default route handler entry)
0.0.0.0/32 receive
dd.dd.dd.dd/32 dd.dd.dd.dd ATM2/1/0.1
ee.ee.ee.ee/32 receive
224.0.0.0/4 drop
224.0.0.0/24 receive
255.255.255.255/32 receive
 

「CSC-CE ルータのラベルの確認:例」も参照してください。


 

次に示すように、LDP を使用するようにインターフェイスが設定されていることを確認します。

Router# show mpls interfaces

 
Interface IP Tunnel Operational
Ethernet0/1 Yes (ldp) No Yes
 

ホスト IP アドレス、ネクストホップ、インターフェイスなどを含む、ルーティング テーブル全体を表示します。

Router# show ip route

 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
 
Gateway of last resort is not set
 
 
dd.0.0.0/32 is subnetted, 1 subnets
O dd.dd.dd.dd [110/7] via dd.dd.dd.dd, 00:16:42, ATM2/1/0.1
ee.0.0.0/32 is subnetted, 1 subnets
C ee.ee.ee.ee is directly connected, Loopback0

CSC-PE ルータの VRF の設定:例

次に、CSC-PE ルータの VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスを設定する例を示します。

ip cef distributed
 
ip vrf vpn1
rd 100:1
route target both 100:1
!

バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定:例

次に、バックボーン キャリアにおける VPN 接続の Multiprotocol BGP(MP-BGP; マルチプロトコル BGP)を設定する例を示します。

ip cef distributed
 
ip vrf vpn1
rd 100:1
route target both 100:1
 
hostname csc-pe1
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
timers bgp 10 30
neighbor ee.ee.ee.ee remote-as 100
neighbor ee.ee.ee.ee update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee send-community extended
bgp dampening 30
exit-address-family
!
router bgp 100
. . .
! (BGP IPv4 to CSC-CE router from CSC-PE router)
!
address-family ipv4 vrf vpn1
neighbor ss.0.0.2 remote-as 200
neighbor ss.0.0.2 activate
neighbor ss.0.0.2 as-override
neighbor ss.0.0.2 advertisement-interval 5
neighbor ss.0.0.2 send-label
no auto-summary
no synchronization
bgp dampening 30
exit-address-family
!

CSC-PE ルータと CSC-CE ルータ間のリンクの設定:例

ここでは、次の例について説明します。

「CSC-PE ルータの設定:例」

「CSC-CE ルータの設定:例」

「CSC-PE ルータのラベルの確認:例」

「CSC-CE ルータのラベルの確認:例」

CSC-PE ルータの設定:例

次に、CSC-PE ルータを設定する例を示します。

ip cef
!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
mpls label protocol ldp
!
interface Loopback0
ip address dd.dd.dd.dd 255.255.255.255
!
interface Ethernet3/1
ip vrf forwarding vpn1
ip address pp.0.0.2 255.0.0.0
!
interface ATM0/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM0/1/0.1 mpls
ip unnumbered Loopback0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
router ospf 100
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
passive-interface Ethernet3/1
network dd.dd.dd.dd 0.0.0.0 area 100
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
timers bgp 10 30
neighbor ee.ee.ee.ee remote-as 100
neighbor ee.ee.ee.ee update-source Loopback0
!
address-family vpnv4 !VPNv4 session with CSC-PE2
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee send-community extended
bgp dampening 30
exit-address-family
!
address-family ipv4 vrf vpn1
neighbor pp.0.0.1 remote-as 200
neighbor pp.0.0.1 activate
neighbor pp.0.0.1 as-override
neighbor pp.0.0.1 advertisement-interval 5
neighbor pp.0.0.1 send-label
no auto-summary
no synchronization
bgp dampening 30
exit-address-family

CSC-CE ルータの設定:例

次に、CSC-CE ルータを設定する例を示します。

ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address cc.cc.cc.cc 255.255.255.255
!
interface Ethernet3/0
ip address pp.0.0.1 255.0.0.0
!
interface Ethernet4/0
ip address nn.0.0.2 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets !Exchange routes
redistribute bgp 200 metric 3 subnets !learned from PE1
passive-interface ATM1/0
passive-interface Ethernet3/0
network cc.cc.cc.cc 0.0.0.0 area 200
network nn.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
timers bgp 10 30
neighbor pp.0.0.2 remote-as 100
neighbor pp.0.0.2 update-source Ethernet3/0
no auto-summary
!
address-family ipv4
redistribute connected
redistribute ospf 200 metric 4 match internal
neighbor pp.0.0.2 activate
neighbor pp.0.0.2 send-label
no auto-summary
no synchronization
bgp dampening 30
exit-address-family

CSC-PE ルータのラベルの確認:例

次に、CSC-PE ルータの設定を確認する例を示します。

BGP セッションが、CSC-PE ルータと CSC-CE ルータ間で稼動中であることを確認します。State/PfxRcd カラムのデータをチェックして、各セッション時にプレフィクスが学習されていることを確認します。

Router# show ip bgp vpnv4 all summary
 
BBGP router identifier 10.5.5.5, local AS number 100
BGP table version is 52, main routing table version 52
12 network entries and 13 paths using 2232 bytes of memory
6 BGP path attribute entries using 336 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Dampening enabled. 0 history paths, 0 dampened paths
BGP activity 16/4 prefixes, 27/14 paths, scan interval 5 secs
 
 
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.5.5.5 4 100 7685 7686 52 0 0 21:17:04 6
10.0.0.2 4 200 7676 7678 52 0 0 21:16:43 7
 
 

MPLS インターフェイスが稼動中であることを確認します。また、LDP 対応インターフェイスで、LDP が稼動中であることが示されていることを確認します。EBGP によってラベルが配布されるため、VRF では LDP がオフになっています。

Router# show mpls interfaces all
 
Interface IP Tunnel Operational
GigabitEthernet6/0 Yes (ldp) No Yes
 
VRF vpn1:
Ethernet3/1 No No Yes
 

次のように、ローカル PE ルータのプレフィクスが、CSC-PE ルータのルーティング テーブルに存在することを確認します。

Router# show ip route vrf vpn2 10.5.5.5
 
Routing entry for 10.5.5.5/32
Known via "bgp 100", distance 20, metric 4
Tag 200, type external
Last update from pp.0.0.2 21:28:39 ago
Routing Descriptor Blocks:
* pp.0.0.2, from pp.0.0.2, 21:28:39 ago
Route metric is 4, traffic share count is 1
AS Hops 1, BGP network version 0
 

次のように、リモート PE ルータのプレフィクスが、CSC-PE ルータのルーティング テーブルに存在することを確認します。

Router# show ip route vrf vpn2 10.5.5.5
 
Routing entry for 10.5.5.5/32
Known via "bgp 100", distance 200, metric 4
Tag 200, type internal
Last update from 10.1.0.0 21:27:39 ago
Routing Descriptor Blocks:
* 10.1.0.0 (Default-IP-Routing-Table), from 10.1.0.0, 21:27:39 ago
Route metric is 4, traffic share count is 1
AS Hops 1, BGP network version 0
 

カスタマー キャリア MPLS VPN サービス プロバイダー ネットワークのプレフィクスが、BGP テーブルに存在し、適切なラベルを持っていることを確認します。

Router# show ip bgp vpnv4 vrf vpn2 labels
 
Network Next Hop In label/Out label
Route Distinguisher: 100:1 (vpn1)
cc.cc.cc.cc/32 pp.0.0.2 22/imp-null
bb.bb.bb.bb/32 pp.0.0.2 27/20
hh.hh.hh.hh/32 ee.ee.ee.ee 34/35
gg.gg.gg.gg/32 ee.ee.ee.ee 30/30
nn.0.0.0 pp.0.0.2 23/imp-null
ss.0.0.0 ee.ee.ee.ee 33/34
pp.0.0.0 pp.0.0.2 25/aggregate(vpn1)
 

次のように、ローカル カスタマー キャリア MPLS VPN サービス プロバイダーの PE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

Router# show ip cef vrf vpn2 10.1.0.0
 
10.1.0.0/32, version 19, cached adjacency pp.0.0.2
0 packets, 0 bytes
tag information set
local tag: 27
fast tag rewrite with Et3/1, pp.0.0.2, tags imposed {20}
via pp.0.0.2, 0 dependencies, recursive
next hop pp.0.0.2, Ethernet3/1 via pp.0.0.2/32
valid cached adjacency
tag rewrite with Et3/1, pp.0.0.2, tags imposed {20}
 
Router# show ip cef vrf vpn2 10.1.0.0 detail
 
10.1.0.0/32, version 19, cached adjacency pp.0.0.2
0 packets, 0 bytes
tag information set
local tag: 27
fast tag rewrite with Et3/1, pp.0.0.2, tags imposed {20}
via pp.0.0.2, 0 dependencies, recursive
next hop pp.0.0.2, Ethernet3/1 via pp.0.0.2/32
valid cached adjacency
tag rewrite with Et3/1, pp.0.0.2, tags imposed {20}
 

次のように、ローカル カスタマー キャリア MPLS VPN サービス プロバイダーの PE ルータのプレフィクスが、MPLS 転送テーブルに存在することを確認します。

Router# show mpls forwarding-table vrf vpn2 10.1.0.0
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
27 20 10.1.0.0/32[V] 958048 Et3/1 pp.0.0.2
 
Router# show mpls forwarding-table vrf vpn2 10.1.0.0 detail
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
27 20 10.1.0.0/32[V] 958125 Et3/1 pp.0.0.2
MAC/Encaps=14/18, MTU=1500, Tag Stack{20}
00B04A74A05400B0C26E10558847 00014000
VPN route: vpn1
No output feature configured
Per-packet load-sharing, slots: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
 

次のように、リモート カスタマー キャリア MPLS VPN サービス プロバイダーの PE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

Router# show ip cef vrf vpn2 10.3.0.0
 
10.3.0.0/32, version 25, cached adjacency rr.0.0.2
0 packets, 0 bytes
tag information set
local tag: 34
fast tag rewrite with Gi6/0, rr.0.0.2, tags imposed {35}
via ee.ee.ee.ee, 0 dependencies, recursive
next hop rr.0.0.2, GigabitEthernet6/0 via ee.ee.ee.ee/32
valid cached adjacency
tag rewrite with Gi6/0, rr.0.0.2, tags imposed {35}
 
Router# show ip cef vrf vpn2 10.3.0.0 detail
 
hh.hh.hh.hh/32, version 25, cached adjacency rr.0.0.2
0 packets, 0 bytes
tag information set
local tag: 34
fast tag rewrite with Gi6/0, rr.0.0.2, tags imposed {35}
via ee.ee.ee.ee, 0 dependencies, recursive
next hop rr.0.0.2, GigabitEthernet6/0 via ee.ee.ee.ee/32
valid cached adjacency
tag rewrite with Gi6/0, rr.0.0.2, tags imposed {35}
 

次のように、リモート カスタマー キャリア MPLS VPN サービス プロバイダーの PE ルータのプレフィクスが、MPLS 転送テーブルに存在することを確認します。

Router# show mpls forwarding-table vrf vpn2 10.3.0.0
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
34 35 hh.hh.hh.hh/32[V] 139034 Gi6/0 rr.0.0.2
 
 
Router# show mpls forwarding-table vrf vpn2 10.3.0.0 detail
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
34 35 hh.hh.hh.hh/32[V] 139034 Gi6/0 rr.0.0.2
MAC/Encaps=14/18, MTU=1500, Tag Stack{35}
00B0C26E447000B0C26E10A88847 00023000
VPN route: vpn1
No output feature configured
Per-packet load-sharing, slots: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

CSC-CE ルータのラベルの確認:例

次に、CSC-CE ルータの設定を確認する例を示します。

次のように、BGP セッションが稼動中であることを確認します。

Router# show ip bgp summary
 
BGP router identifier cc.cc.cc.cc, local AS number 200
BGP table version is 35, main routing table version 35
14 network entries and 14 paths using 2030 bytes of memory
3 BGP path attribute entries using 168 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Dampening enabled. 1 history paths, 0 dampened paths
BGP activity 17/67 prefixes, 29/15 paths, scan interval 60 secs
 
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
pp.0.0.1 4 100 7615 7613 35 0 0 21:06:19 5
 

次のように、ローカル PE ルータのループバック アドレスがルーティング テーブルに存在すること確認します。

Router# show ip route 10.1.0.0
 
Routing entry for 10.1.0.0/32
Known via "ospf 200", distance 110, metric 101, type intra area
Redistributing via bgp 200
Advertised by bgp 200 metric 4 match internal
Last update from nn.0.0.1 on Ethernet4/0, 00:34:08 ago
Routing Descriptor Blocks:
* nn.0.0.1, from bb.bb.bb.bb, 00:34:08 ago, via Ethernet4/0
Route metric is 101, traffic share count is 1
 

次のように、リモート PE ルータのループバック アドレスが、ルーティング テーブルに存在すること確認します。

Router# show ip route 10.5.5.5
 
Routing entry for 10.5.5.5/32
Known via "bgp 200", distance 20, metric 0
Tag 100, type external
Redistributing via ospf 200
Advertised by ospf 200 metric 3 subnets
Last update from pp.0.0.1 00:45:16 ago
Routing Descriptor Blocks:
* pp.0.0.1, from pp.0.0.1, 00:45:16 ago
Route metric is 0, traffic share count is 1
AS Hops 2, BGP network version 0
 

次のように、ローカル PE ルータのプレフィクスが、MPLS LDP バインディングに存在することを確認します。

Router# show mpls ldp bindings 10.1.0.0 255.255.255.255
 
tib entry: 10.1.0.0/32, rev 20
local binding: tag: 20
remote binding: tsr: 10.1.0.0:0, tag: imp-null
 

次のように、ローカル PE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

Router# show ip cef 10.1.0.0
 
10.1.0.0/32, version 46, cached adjacency nn.0.0.1
0 packets, 0 bytes
tag information set
local tag: 20
via nn.0.0.1, Ethernet4/0, 0 dependencies
next hop nn.0.0.1, Ethernet4/0
unresolved
valid cached adjacency
tag rewrite with Et4/0, nn.0.0.1, tags imposed {}
 

次のように、ローカル PE ルータのプレフィクスが、MPLS 転送テーブルに存在することを確認します。

Router# show mpls forwarding-table 10.1.0.0
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
20 Pop tag bb.bb.bb.bb/32 893397 Et4/0 nn.0.0.1
 
Router# show mpls forwarding-table 10.1.0.0 detail
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
20 Pop tag bb.bb.bb.bb/32 893524 Et4/0 nn.0.0.1
MAC/Encaps=14/14, MTU=1504, Tag Stack{}
00074F83685400B04A74A0708847
No output feature configured
Per-packet load-sharing, slots: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
 

次のように、BGP ルーティング テーブルに、カスタマー キャリア MPLS VPN サービス プロバイダー ネットワークのプレフィクスのラベルが含まれていることを確認します。

Router# show ip bgp labels
 
Network Next Hop In Label/Out Label
cc.cc.cc.cc/32 0.0.0.0 imp-null/exp-null
bb.bb.bb.bb/32 nn.0.0.1 20/exp-null
hh.hh.hh.hh/32 pp.0.0.1 26/34
gg.gg.gg.gg/32 pp.0.0.1 23/30
nn.0.0.0 0.0.0.0 imp-null/exp-null
ss.0.0.0 pp.0.0.1 25/33
pp.0.0.0 0.0.0.0 imp-null/exp-null
pp.0.0.1/32 0.0.0.0 16/exp-null
 

次のように、リモート PE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

Router# show ip cef 10.5.5.5
 
10.5.5.5/32, version 54, cached adjacency pp.0.0.1
0 packets, 0 bytes
tag information set
local tag: 26
fast tag rewrite with Et3/0, pp.0.0.1, tags imposed {34}
via pp.0.0.1, 0 dependencies, recursive
next hop pp.0.0.1, Ethernet3/0 via pp.0.0.1/32
valid cached adjacency
tag rewrite with Et3/0, pp.0.0.1, tags imposed {34}
 

次のように、リモート PE ルータのプレフィクスが、MPLS 転送テーブルに存在することを確認します。

Router# show mpls forwarding-table 10.5.5.5
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
26 34 hh.hh.hh.hh/32 81786 Et3/0 pp.0.0.1
 
Router# show mpls forwarding-table 10.5.5.5 detail
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
26 34 hh.hh.hh.hh/32 81863 Et3/0 pp.0.0.1
MAC/Encaps=14/18, MTU=1500, Tag Stack{34}
00B0C26E105500B04A74A0548847 00022000
No output feature configured
Per-packet load-sharing, slots: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

カスタマー キャリア ネットワークの設定:例

この項のカスタマー キャリアの設定例と確認例には、次の設定と確認が含まれます。

「カスタマー キャリアでの IP 接続の確認:例」

「ルート リフレクタとしてのカスタマー キャリア コア ルータの設定:例」

カスタマー キャリアでの IP 接続の確認:例

次のコマンドを入力して、カスタマー キャリア コア ルータから別のカスタマー キャリア コア ルータ(CE1 から CE2)への接続を確認します。

Router# ping 10.2.0.0
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to jj.jj.jj.jj, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
 
 

次のように、パケットが、最終的な宛先(CE1 から CE2)に到達するまでに通過するパスを確認します。

Router# trace 10.2.0.0
 
Type escape sequence to abort.
Tracing the route to 10.2.0.0
 
1 mm.0.0.2 0 msec 0 msec 4 msec
2 nn.0.0.2 [MPLS: Labels 20/21 Exp 0] 8 msec 8 msec 12 msec
3 pp.0.0.2 [MPLS: Labels 28/21 Exp 0] 8 msec 8 msec 12 msec
4 ss.0.0.1 [MPLS: Labels 17/21 Exp 0] 8 msec 8 msec 12 msec
5 ss.0.0.2 [MPLS: Labels 16/21 Exp 0] 8 msec 8 msec 12 msec
6 tt.0.0.1 [AS 200] [MPLS: Label 21 Exp 0] 8 msec 8 msec 8 msec
7 tt.0.0.2 [AS 200] 8 msec 4 msec *
 

次のように、パケットが、最終的な宛先(CE2 から CE1)に到達するまでに通過するパスを確認します。

Router# trace 10.1.0.0
 
Type escape sequence to abort.
Tracing the route to 10.1.0.0
 
 
1 tt.0.0.1 0 msec 0 msec 0 msec
2 qq.0.0.2 [MPLS: Labels 18/21 Exp 0] 8 msec 12 msec 12 msec
3 ss.0.0.1 [MPLS: Labels 28/21 Exp 0] 8 msec 8 msec 8 msec
4 pp.0.0.2 [MPLS: Labels 17/21 Exp 0] 12 msec 8 msec 8 msec
5 pp.0.0.1 [MPLS: Labels 16/21 Exp 0] 12 msec 12 msec 8 msec
6 mm.0.0.2 [AS 200] [MPLS: Label 21 Exp 0] 12 msec 8 msec 12 msec
7 mm.0.0.1 [AS 200] 4 msec 4 msec *

ルート リフレクタとしてのカスタマー キャリア コア ルータの設定:例

次に、アドレス ファミリを使用して、内部 BGP ピア 10.1.1.1 をユニキャスト プレフィクスとマルチキャスト プレフィクスの両方のルート リフレクタ クライアントとして設定する例を示します。

router bgp 200
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 route-reflector-client
 
router bgp 100
address-family vpnv4
neighbor xx.xx.xx.xx activate
neighbor xx.xx.xx.xx route-reflector-client
! xx.xx.xx,xx is a PE router
neighbor xx.xx.xx.xx send-community extended
exit address-family
! You need to configure your peer BGP neighbor.

階層型 VPN のカスタマー サイトの設定:例

ここでは、カスタマー サイトに関する次の設定例および確認例について説明します。

「階層型 VPN の PE ルータの設定:例」

「階層型 VPN の各 PE ルータでのラベルの確認:例」

「階層型 VPN の CE ルータの設定:例」

「カスタマー サイトでの IP 接続の確認:例」

階層型 VPN の PE ルータの設定:例

次に、PE ルータを設定する例を示します。

ip cef
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
mpls label protocol ldp
!
interface Loopback0
ip address bb.bb.bb.bb 255.255.255.255
!
interface Ethernet3/0
ip address nn.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
interface Ethernet3/3
ip vrf forwarding vpn2
ip address mm.0.0.2 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
!
router ospf 200
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
passive-interface Ethernet3/3
network bb.bb.bb.bb 0.0.0.0 area 200
network nn.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
timers bgp 10 30
neighbor hh.hh.hh.hh remote-as 200
neighbor hh.hh.hh.hh update-source Loopback0
!
address-family vpnv4 !VPNv4 session with PE2
neighbor hh.hh.hh.hh activate
neighbor hh.hh.hh.hh send-community extended
bgp dampening 30
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor mm.0.0.1 remote-as 300
neighbor mm.0.0.1 activate
neighbor mm.0.0.1 as-override
neighbor mm.0.0.1 advertisement-interval 5
no auto-summary
no synchronization
bgp dampening 30
exit-address-family

階層型 VPN の各 PE ルータでのラベルの確認:例

次に、階層型 VPN での PE ルータの設定を確認する例を示します。

次のように、ローカル CE ルータのループバック アドレスが、PE1 ルータのルーティング テーブルに存在することを確認します。

Router# show ip route vrf vpn2 10.2.2.2
 
Routing entry for 10.2.2.2/32
Known via "bgp 200", distance 20, metric 0
Tag 300, type external
Last update from mm.0.0.2 20:36:59 ago
Routing Descriptor Blocks:
* mm.0.0.2, from mm.0.0.2, 20:36:59 ago
Route metric is 0, traffic share count is 1
AS Hops 1, BGP network version 0
 

次のように、ローカル CE ルータのプレフィクスが、MPLS 転送テーブルに存在し、プレフィクスが非タグ付きであることを確認します。

Router# show mpls forwarding-table vrf vpn2 10.2.2.2
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
23 Untagged aa.aa.aa.aa/32[V] 0 Et3/3 mm.0.0.2
 

次のように、リモート PE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

Router# show ip cef 10.5.5.5
 
10.5.5.5/32, version 31, cached adjacency nn.0.0.2
0 packets, 0 bytes
tag information set
local tag: 31
fast tag rewrite with Et3/0, nn.0.0.2, tags imposed {26}
via nn.0.0.2, Ethernet3/0, 2 dependencies
next hop nn.0.0.2, Ethernet3/0
unresolved
valid cached adjacency
tag rewrite with Et3/0, nn.0.0.2, tags imposed {26}
 

次のように、リモート CE ルータのループバック アドレスが、ルーティング テーブルに存在すること確認します。

Router# show ip route vrf vpn2 10.2.0.0
 
Routing entry for 10.2.0.0/32
Known via "bgp 200", distance 200, metric 0
Tag 300, type internal
Last update from hh.hh.hh.hh 20:38:49 ago
Routing Descriptor Blocks:
* hh.hh.hh.hh (Default-IP-Routing-Table), from hh.hh.hh.hh, 20:38:49 ago
Route metric is 0, traffic share count is 1
AS Hops 1, BGP network version 0
 

次のように、リモート CE ルータのプレフィクスが MPLS 転送テーブルに存在すること、および発信インターフェイスが存在することを確認します。

Router# show mpls forwarding-table vrf vpn2 10.2.0.0
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
None 26 jj.jj.jj.jj/32 0 Et3/0 nn.0.0.2
 

次のように、リモート CE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

Router# show ip cef vrf vpn2 10.2.0.0
 
10.2.0.0/32, version 12, cached adjacency nn.0.0.2
0 packets, 0 bytes
tag information set
local tag: VPN route head
fast tag rewrite with Et3/0, nn.0.0.2, tags imposed {26 32}
via hh.hh.hh.hh, 0 dependencies, recursive
next hop nn.0.0.2, Ethernet3/0 via hh.hh.hh.hh/32
valid cached adjacency
tag rewrite with Et3/0, nn.0.0.2, tags imposed {26 32}
 

次のように、ローカル PE ルータのプレフィクスが、シスコ エクスプレス フォワーディング テーブルに存在することを確認します。

Router# show ip cef 10.1.0.0
 
10.1.0.0/32, version 9, connected, receive
tag information set
local tag: implicit-null

階層型 VPN の CE ルータの設定:例

次に、CE を設定する例を示します。

ip cef distributed
interface Loopback0
ip address 10.3.0.0 255.255.255.255
!
interface FastEthernet0/3/3
ip address mm.0.0.1 255.0.0.0
!
router bgp 300
no synchronization
bgp log-neighbor-changes
timers bgp 10 30
redistribute connected !Redistributing routes into BGP
neighbor mm.0.0.2 remote-as 200 !to send to PE1
neighbor mm.0.0.2 advertisement-interval 5
no auto-summary

カスタマー サイトでの IP 接続の確認:例

次に、カスタマー サイトで IP 接続を確認する例を示します。

次のように、PE ルータから学習した、リモート CE ルータのループバック アドレスが、ローカル ルータのルーティング テーブルに存在することを確認します。

Router# show ip route 10.2.0.0
 
Routing entry for 10.2.0.0/32
Known via "bgp 300", distance 20, metric 0
Tag 200, type external
Redistributing via ospf 300
Advertised by ospf 300 subnets
Last update from mm.0.0.1 20:29:35 ago
Routing Descriptor Blocks:
* mm.0.0.1, from mm.0.0.1, 20:29:35 ago
Route metric is 0, traffic share count is 1
AS Hops 2

その他の関連資料

ここでは、MPLS VPN に関する情報について説明します。

関連資料

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1164

『Application of the Border Gateway Protocol in the Internet』

RFC 1171

『A Border Gateway Protocol 4』

RFC 1700

『Assigned Numbers』

RFC 1966

『BGP Route Reflection: An Alternative to Full Mesh IBGP』

RFC 2283

『Multiprotocol Extensions for BGP-4』

RFC 2547

BGP/MPLS VPNs

RFC 2842

『Capabilities Advertisement with BGP-4』

RFC 2858

『Multiprotocol Extensions for BGP-4』

RFC 3107

『Carrying Label Information in BGP-4』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

この機能では、新しいコマンドや変更されたコマンドは使用されません。

BGP を使用する MPLS VPN CSC の機能情報

表 2 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 2 BGP を使用する MPLS VPN CSC の機能情報

機能名
リリース
機能情報

MPLS VPN--Carrier Supporting Carrier--IPv4 BGP ラベル配布

12.0(21)ST
12.0(22)S
12.0(23)S
12.2(13)T
12.0(24)S
12.2(14)S
12.0(27)S
12.0(29)S

この機能を使用すると、BGP を使用してルートおよび MPLS ラベルを転送する MPLS VPN CSC ネットワークを作成できます。

この機能は、12.0(21)ST で初めて導入されました。

この機能は、12.0(22)S で統合されました。

この機能は、12.0(23)S で統合されました。

この機能は、12.2(13)T で統合されました。

この機能は、12.0(24)S で統合されました。

この機能は、12.2(14)S で統合されました。

この機能は、12.0(27)S で統合されました。

この機能は、12.0(29)S で統合されました。

用語集

ASBR:Autonomous System Boundary Router(自律システム境界ルータ)。自律システムを別の自律システムに接続するルータ。

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。個別のルーティング ポリシーが含まれた個別のルーティング ドメイン(自律システム)間のループフリー ルーティングを提供するように設計されたドメイン間ルーティング プロトコル。

CE ルータ :Customer Edge(カスタマー エッジ)ルータ。カスタマー ネットワークの一部であり、Provider Edge(PE; プロバイダー エッジ)ルータへのインターフェイスとなるルータ。このマニュアルでは、CE ルータはカスタマー キャリア ネットワークのエッジにあります。

LDP :Label Distribution Protocol(ラベル配布プロトコル)。パケットの転送に使用されるラベル(アドレス)をネゴシエーションするための、MPLS 対応ルータ間の標準プロトコル。

MPLS :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)。ラベルを使用して IP トラフィックを転送するスイッチング方式。このラベルによって、ネットワーク内のルータおよびスイッチが、事前に確立された IP ルーティング情報に基づくパケットの転送先を指示されます。

PE ルータ :Provider Edge(プロバイダー エッジ)ルータ。サービス プロバイダーのネットワークのエッジにある、CE ルータへのインターフェイスとなるルータ。

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。トンネリングを使用することにより、パブリック TCP/IP ネットワーク経由でも IP トラフィックをセキュアに転送できるネットワーク。

エッジ ルータ :ネットワークのエッジにあるルータ。MPLS ネットワークの境界を定義します。パケットを送受信します。エッジ ラベル スイッチ ルータおよびラベル エッジ ルータとも呼ばれます。