マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
AToM スタティック擬似回線プロビジョニング
AToM スタティック擬似回線プロビジョニング
発行日;2012/01/30 | 英語版ドキュメント(2011/07/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

AToM スタティック擬似回線プロビジョニング

機能情報の確認

目次

AToM スタティック擬似回線プロビジョニングの制約事項

AToM スタティック擬似回線プロビジョニングに関する情報

擬似回線プロビジョニング

スタティックにプロビジョニングされた擬似回線の利点

AToM スタティック擬似回線のプロビジョニング方法

AToM スタティック擬似回線のプロビジョニング

AToM スタティック擬似回線設定の確認

AToM スタティック擬似回線プロビジョニングの設定例

AToM 擬似回線のプロビジョニング:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

AToM スタティック擬似回線プロビジョニングの機能情報

AToM スタティック擬似回線プロビジョニング

AToM スタティック擬似回線プロビジョニング機能を使用すると、指示制御接続を使用せずに、Any Transport over Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)(AToM)スタティック擬似回線をプロビジョニングできます。指示制御プロトコルを使用しないか、使用できない環境では、この機能により、Cisco IOS Command-Line Interface(CLI; コマンドライン インターフェイス)でスタティックに擬似回線パラメータをプロビジョニングできます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「AToM スタティック擬似回線プロビジョニングの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

AToM スタティック擬似回線プロビジョニングの制約事項

次のパラメータは、擬似回線で指示制御プロトコル メッセージを使用して交換されますが、Cisco IOS Release 12.33(SRB) で導入された AToM スタティック擬似回線プロビジョニング機能を使用して変更できません。代わりに、ソフトウェアによってデフォルトが事前に設定されます。

接続の両方の終端で障害検出、分離、および検証に使用される Virtual Circuit Connectivity Verification(VCCV; 仮想回線接続性検証)オプションは、次のように設定されます。

制御チャネル タイプ 1 が制御ワードを設定します。

制御チャネル タイプ 2 が MPLS ルータ アラート ラベルを設定します。

接続性検証タイプ 2 が Label Switched Path(LSP; ラベル スイッチド パス) ping コマンドを設定します。

Cisco IOS Release 12.2(33)SRE では、スタティック擬似回線のセル パッキングに対するサポートが追加されました。この機能には、次の制約事項があります。

両方の Provider-Edge(PE; プロバイダー エッジ)ルータが、Cisco IOS Release 12.2(33)SRE を実行する必要があり、パッキングできるセルの最大数は、各 PE ルータで同じ値に設定する必要があります。

Ethernet over MPLS の仮想回線タイプの自動検知はサポートされません。

さらに、スタティック擬似回線では次の機能はサポートされません。

pseudowire-class コマンドでシーケンス機能によって設定されるシーケンス番号の再同期化は、サポートされません。これは、Label Distribution Protocol(LDP; ラベル配布プロトコル)ソフトウェアが「LDP Label Release or Withdraw」メッセージを送信したあとで、続けて「Label Request or Mapping」メッセージを送信し、スタティック擬似回線で LDP を使用しない場合に、シーケンス番号の再同期化が行われるためです。

リモートおよびローカル ラベルなどのスタティック擬似回線パラメータの設定を可能にするモードを開始するために neighbor コマンドの拡張が必要であるため、トンネル ステッチはサポートされません。トンネル スイッチ ポイントは、異なるスタティック ラベル コマンドを使用して設定できることに注意してください。トンネル スイッチ ポイントは制御ワードを処理しませんが、ラベル交換が行われます。

ピア プロバイダー エッジ ルータ間で指示制御プロトコルを使用する必要があるため、擬似回線冗長性はサポートされません。

AToM スタティック擬似回線プロビジョニングに関する情報

AToM スタティック擬似回線をプロビジョニングするには、次の概念を理解しておく必要があります。

「擬似回線プロビジョニング」

「スタティックにプロビジョニングされた擬似回線の利点」

擬似回線プロビジョニング

AToM スタティック擬似回線プロビジョニング機能を使用すると、指示制御プロトコルを使用できない場合に、スタティック擬似回線を設定できます。ほとんどの場合、擬似回線は、これらの接続に必要なさまざまなパラメータを交換するために、LDP や、Resource Reservation Protocol over Traffic-Engineered Tunnel(RSVP-TE)などの別の指示制御プロトコルを使用してダイナミックにプロビジョニングされます。

AToM スタティック擬似回線プロビジョニング機能はプラットフォームに依存しませんが、Cisco 7600 シリーズ ルータだけでテストされています。

スタティックにプロビジョニングされた擬似回線の利点

この機能を使用すると、指示制御接続を使用せずに、AToM ラベル スイッチングのスタティック擬似回線をプロビジョニングできます。この機能には、トンネル ラベルと擬似回線ラベルのスタティック プロビジョニングも組み込まれています。

AToM スタティック擬似回線のプロビジョニング方法

ここでは、次の手順について説明します。

「AToM スタティック擬似回線のプロビジョニング」

「AToM スタティック擬似回線設定の確認」

AToM スタティック擬似回線のプロビジョニング

この設定作業では、 xconnect イーサネット インターフェイス コンフィギュレーション コマンドでオプションを使用してスタティック接続を指定して、 mpls コマンドを xconnect モードで使用して次の擬似回線パラメータをスタティックに設定します。

ローカルおよびリモートの擬似回線ラベルを設定します。

MPLS 制御ワードの送信をイネーブルまたはディセーブルにします。

手順の概要

1. enable

2. configure terminal

3. interface ethernet-type interface-number

4. xconnect peer-ip-address vcid encapsulation mpls manual pw-class class-name

5. mpls label local-pseudowire-label remote-pseudowire-label

6. [ no ] mpls control-word

7. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface ethernet-type interface-number
 

Router(config)# interface Ethernet 1/0

特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

xconnect peer-ip-address vcid encapsulation mpls manual pw-class class-name
 

Router(config-if)# xconnect 10.131.191.252 100 encapsulation mpls manual pw-class mpls

スタティック AToM 擬似回線を設定して、ローカルおよびリモートの擬似回線ラベルを設定する xconnect コンフィギュレーション モードを開始します。

ステップ 5

mpls label local-pseudowire-label remote-pseudowire-label
 

Router(config-if-xconn)# mpls label 100 150

ローカルおよびリモートの擬似回線ラベルを設定します。

ラベルは、 mpls label range コマンドを使用して設定されたスタティック ラベル範囲内にある未使用のスタティック ラベルである必要があります。

mpls label コマンドを使用すると、入力したラベルの有効性がチェックされ、有効でない場合はエラー メッセージが表示されます。 remote-pseudowire-label 引数に指定されたラベルは、ピア PE のローカル擬似回線ラベルの値でなければなりません。

ステップ 6

[ no ] mpls control-word
 

Router(config-if-xconn)# no mpls control-word

MPLS 制御ワードが送信されるかどうかを設定します。

このコマンドは、フレーム リレー Data-Link Connection Identifier(DLCI; データリンク接続識別子)接続回線および ATM Adaptation Layer 5(AAL5; ATM アダプテーション レイヤ 5)接続回線に対して設定する必要があります。その他の接続回線では、制御ワードはデフォルトで含まれています。

制御ワードの包含をイネーブルにする場合、回線が正しく動作するように、接続の両端でイネーブルにする必要があります。

制御ワードの包含は、 no mpls control-word コマンドを使用して明示的にディセーブルにできます。

ステップ 7

exit
 

Router(config-if-xconn)# exit

コンフィギュレーション モードを終了します。

目的のコンフィギュレーション モードに到達するまで、ルータ プロンプトで exit コマンドを入力し続けます。

AToM スタティック擬似回線設定の確認

AToM スタティック擬似回線設定を確認するには、 show running-config EXEC コマンドを使用します。AToM スタティック擬似回線が正しくプロビジョニングされたことを確認するには、次の手順の説明に従って、 show mpls l2transport vc detail ping mpls pseudowire EXEC コマンドを使用します。

手順の概要

1. show mpls l2transport vc detail

2. ping mpls pseudowire ipv4-address vc-id vc-id

手順の詳細


ステップ 1 show mpls l2transport vc detail

非スタティック擬似回線設定では、このコマンドを使用すると、MPLS ラベルの送信に使用されるプロトコルのタイプ(LDP など)がリストされます。スタティック擬似回線設定では、シグナリング プロトコル フィールドの値は Manual でなければなりません。次に出力例を示します。

Router# show mpls l2transport vc detail
 
Local interface: Et1/0 up, line protocol up, Ethernet up
Destination address: 10.0.1.1, VC ID: 200, VC status: up
Output interface: Et3/0, imposed label stack {17}
Preferred path: not configured
Default path:
Next hop: 10.0.0.2
Create time: 00:27:27, last status change time: 00:27:24
Signaling protocol: Manual
MPLS VC labels: local 17, remote 17
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 193, send 193
byte totals: receive 19728, send 23554
packet drops: receive 0, send 0
 

ステップ 2 ping mpls pseudowire ipv4-address vc-id vc-id

スタティック擬似回線にパラメータの指示制御プロトコル交換がないため、接続の両方の終端を正しく設定する必要があります。ラベルまたは制御ワード オプションの不一致を検出する方法の 1 つは、設定作業の一環として MPLS 擬似回線 LSP ping コマンドを送信してから、問題が検出された場合は接続を再設定することです。 ping コマンドが宛先に正常に送信されると、感嘆符(!)が表示されます。コマンドの使用と出力の例は次のとおりです。

Router# ping mpls pseudowire 10.7.1.2 vc-id 1001
 
Sending 5, 100-byte MPLS Echos to 10.7.1.2,
timeout is 2 seconds, send interval is 0 msec:

 

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'X' - unknown return code, 'x' - return code 0
 
Type escape sequence to abort.
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms


 

AToM スタティック擬似回線プロビジョニングの設定例

ここでは、次の例について説明します。

「AToM 擬似回線のプロビジョニング:例」

AToM 擬似回線のプロビジョニング:例

次に、2 つの PE(PE1 と PE2)間の AToM スタティック擬似回線接続のコンフィギュレーション コマンドの例を示します。

AToM スタティック擬似回線をプロビジョニングする前に、 mpls label range static コマンドを使用してスタティック ラベル範囲を設定する必要があります。

Router# configure terminal
Router(config)# mpls label range 200 16000 static 16 199
% Label range changes will take effect at the next reload.

 

mpls ip コマンドは、PE1 と PE2 の両方のコア方向のインターフェイスでも設定する必要があります(指示制御プロトコルでシグナルされた擬似回線でも行われます)。次に、設定例を示します。

Router(config)# interface Ethernet 0/0
Router(config-if)# description Backbone interface
Router(config-if)# ip address 10.0.0.1 255.255.255.0
Router(config-if)# mpls ip
Router(config-if)# exit

 

次に、PE1 の AToM スタティック擬似回線の設定例を示します。

Router(config)# interface Ethernet 1/0
Router(config-if)# no ip address
Router(config-if)# xconnect 10.131.191.251 100 encapsulation mpls manual pw-class mpls
Router(config-if-xconn)# mpls label 100 150
Router(config-if-xconn)# exit

 

次に、PE2 の AToM スタティック擬似回線の設定例を示します。

Router(config)# interface Ethernet 1/0
Router(config-if)# no ip address
Router(config-if)# xconnect 10.132.192.252 100 encapsulation mpls manual pw-class mpls
Router(config-if-xconn)# mpls label 150 100
Router(config-if-xconn)# exit

 

この機能を使用すると、 mpls static binding ipv4 vrf コマンドを使用して、トンネル ラベルをスタティックに設定することもできます。これは、トンネルと擬似回線をプロビジョニングするために指示制御プロトコルを使用する必要がないことを意味します。スタティック ラベルと mpls static binding ipv4 vrf コマンドの詳細については、『 MPLS Static Labels 』の機能の章と『 Cisco IOS Multiprotocol Label Switching Command Reference』を参照してください。

その他の参考資料

ここでは、AToM スタティック擬似回線プロビジョニング機能の関連資料について説明します。

関連資料

関連項目
参照先

Cisco IOS コマンド

Cisco IOS Master Commands List, All Releases

MPLS コマンド

Cisco IOS Multiprotocol Label Switching Command Reference

擬似回線クラスの設定

Any Transport over MPLS

MPLS および xconnect コマンド

Cisco IOS Multiprotocol Label Switching Command Reference

スタティック ラベルおよび mpls static binding ipv4 vrf コマンド

Cisco IOS Multiprotocol Label Switching Configuration Guide 』の項「 MPLS Static Labels

規格

規格
タイトル

IETF draft-ietf-pwe3-vccv-12.txt

Pseudo Wire Virtual Circuit Connectivity Verification (VCCV)

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3036

LDP Specification

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

AToM スタティック擬似回線プロビジョニングの機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 AToM スタティック擬似回線プロビジョニングの機能情報

機能名
リリース
機能情報

AToM スタティック擬似回線プロビジョニング

12.2(33)SRB
12.2(33)SRE

この機能を使用すると、指示制御プロトコル接続を使用せずに、AToM スタティック擬似回線をプロビジョニングできます。

AToM スタティック擬似回線機能はプラットフォームに依存しませんが、Cisco IOS Release 12.33(SRB) の Cisco 7600 シリーズ ルータだけでテストされています。

Cisco IOS Release 12.2(33)SRE では、スタティック PW でのセル パッキングに対する L2VPN サポート機能が追加されました。

この機能により、コマンド cell-packing mpls control-word mpls label show mpls l2transport vc xconnect が導入または変更されました。