マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE
NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE
発行日;2012/01/31 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE

機能情報の確認

目次

の前提条件

に関する制約事項

について

機能をサポートするエレメント

MPLS VPN 6vPE および 6PE での BGP グレースフル リスタートの機能

再起動中の BGP グレースフル リスタートによるプレフィクス情報の保存方法

MPLS VPN 6vPE および 6PE の ISSU サポート

MPLS VPN 6VPE および 6PE の NSF/SSO サポート

MPLS VPN 設定の BGP グレースフル リスタート サポート

基本的な 6VPE セットアップのグレースフル リスタート サポート

Carrier Supporting Carrier および相互自律システム セットアップの 6VPE でのグレースフル リスタート

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE がサポートされていないルータでの動作

の設定方法

基本的な MPLS 6VPE および 6PE の NSF/SSO の設定

前提条件

MPLS VPN 6VPE および 6PE の NSF/SSO および ISSU サポートの確認

の設定例

基本的な 6VPE セットアップの NSF/SSO の設定:例

基本的な 6VPE セットアップでの PE1 設定

基本的な 6PE セットアップの NSF/SSO の設定:例

基本的な 6PE セットアップでの PE1 設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

用語集

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE

このマニュアルでは、Cisco IOS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)IPv6 Provider Edge(6VPE; プロバイダー エッジ)ルータ over Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)および Cisco IOS IPv6 Provider Edge(6PE; プロバイダー エッジ)ルータ over Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)での Nonstop Forwarding(NSF; ノンストップ フォワーディング)、Stateful Switchover(SSO; ステートフル スイッチオーバー)および In Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)サポートの設定について説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「NSF/SSO および ISSU - MPLS VPN 6VPE および 6PEの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE の前提条件

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能を利用するには、次のものがサポートされている必要があります。

IPv6 NSF

IPv6 シスコ エクスプレス フォワーディング

Label Distribution Protocol(LDP; ラベル配布プロトコル)グレースフル リスタート

LDP グレースフル リスタートは、LDP が MPLS コアで使用されるプロトコルの場合にイネーブルにする必要があります。

Provider(P; プロバイダー)ルータ、PE ルータおよび Customer Edge(CE; カスタマー エッジ)ルータ間で実行する次のルーティング プロトコルで NSF をイネーブルにする必要があります。

Border Gateway Protocol(BGP)

スタティック ルート

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能をイネーブルにするには、サポートされている MPLS VPN ネットワーク設定が必要です。「 Configuring MPLS Layer 3 VPNs 」、「 Implementing IPv6 over MPLS」および「 Implementing IPv6 VPN over MPLS 」の章の設定情報を参照してください。

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PEに関する制約事項

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能には、次の制約事項があります。

Tag Distribution Protocol(TDP; タグ配布プロトコル)セッションはサポートされていません。LDP セッションだけがサポートされています。

MPLS VPN 6VPE および 6PE Carrier Supporting Carrier(CSC)VPN は BGP だけをサポートします。LDP を使用する CSC 設定はサポートされません。

Cisco IOS Release 12.2(33)SRE の 6VPE および 6PE では、BGP およびスタティック ルートだけがサポートされます。

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PEについて

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE機能を設定するには、次の概念を理解しておく必要があります。

「NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能をサポートするエレメント」

「MPLS VPN 6vPE および 6PE での BGP グレースフル リスタートの機能」\

「再起動中の BGP グレースフル リスタートによるプレフィクス情報の保存方法」

「MPLS VPN 6vPE および 6PE の ISSU サポート」

「MPLS VPN 6VPE および 6PE の NSF/SSO サポート」

「MPLS VPN 設定の BGP グレースフル リスタート サポート」

「NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE がサポートされていないルータでの動作」

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能をサポートするエレメント

Cisco IOS VPN 6vPE および 6PE 機能の NSF/SSO および ISSU 機能をサポートするメジャー エレメントは次のとおりです。

MPLS VPN:NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能をイネーブルにするには、サポートされる MPLS VPN ネットワークを設定する必要があります。

BGP グレースフル リスタート:BGP グレースフル リスタート機能は、グレースフル リスタート機能のネゴシエーション、フォワーディング保存ステートの交換およびセッション再起動後のアドバタイズメントの調整を行います。MPLS VPN は、BGP と相互作用することで、Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routingu and Fowarding(VRF; VPN ルーティングおよび転送)ルートおよびラベルを交換します。

IPv6 NSF:IPv6 NSF サポートは、チェックポイントされたシスコ エクスプレス フォワーディング隣接を使用したスイッチオーバー中での IPv6 キャッシュ リビルドをイネーブルにします。

CEF/MFI:シスコ エクスプレス フォワーディングおよび MPLS Forwarding Infrastructure は、Route Processor(RP; ルート プロセッサ)スイッチオーバー間でフォワーディング エントリおよびローカル ラベルを維持します。

MPLS VPN 6vPE および 6PE での BGP グレースフル リスタートの機能

IPv6 および VPNv6 の BGP グレースフル リスタートの動作は、本質的に IPv4 および VPNv4 のグレースフル リスタートの動作と同じです。唯一の違いは、IPv6 および VPNv6 アドレス ファミリのサポートが追加されたことです。

BGP グレースフル リスタートを設定すると、BGP は、グレースフル リスタート機能を含み、アドレス ファミリ、つまり、IPv4/VPNv4 および IPv6/VPNv6 アドレス ファミリの保存ステートをネゴシエートします。

両方の BGP ピアは、グレースフル リスタート タイマーで一致する必要があります。これは、 bgp graceful-restart restart-timer seconds コマンドで設定できます。BGP セッションが確立され、初期アップデートの送信が終了すると、各 BGP ピアは、end-of-Routing Information Base(RIB; ルーティング情報ベース)マーカーを送信します。

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能は、RFC 4724『 Graceful Restart Mechanism for BGP 』および「 Cisco Nonstop Forwarding 」の機能の章で定義されているメカニズムを使用します。

再起動中の BGP グレースフル リスタートによるプレフィクス情報の保存方法

BGP グレースフル リスタートが可能なルータの接続が切断されると、リスタート ルータで次のことが行われます。

1. ルータは、他のルータとの BGP セッションを確立して、グレースフル リスタート可能な他のルータから BGP ルートを再学習します。リスタート ルータは、ネイバー ルータからアップデートを受信するまで待機します。ネイバー ルータはアップデートの送信を完了したことを示す end-of-RIB マーカーを送信すると、リスタート ルータは、その独自のアップデートの送信を開始します。

2. リスタート ルータは、各プレフィクスの MPLS Forwarding Infrastructure(MFI)データベースからラベルを受信します。ルータは、ラベルを検出すると、ラベルをネイバー ルータにアドバタイズします。ルータは、ラベルを検出しない場合、データベースから新しいラベルを割り当て、アドバタイズします。

3. リスタート ルータは、使用されなくなったエントリのタイマーの有効期限が切れると、使用されなくなったプレフィクスを削除します。

BGP グレースフル リスタートが可能なピア ルータがリスタート ルータを検出すると、次のことを行います。

1. ピア ルータは、すべてのルーティング アップデートをリスタート ルータに送信します。アップデートの送信を完了すると、ピア ルータは、end-of RIB マーカーをリスタート ルータに送信します。

2. ピア ルータは、リスタート ルータから学習した BGP ルートをすぐにはその BGP ルーティング テーブルから削除しません。リスタート ルータからプレフィクスを学習する場合、ピアは、新しいプレフィクスおよびラベル情報が古い情報と一致する場合、使用されなくなったルートをリフレッシュします。

MPLS VPN 6vPE および 6PE の ISSU サポート

Cisco IOS Release 12.2(33)SRE およびそれ以降のリリースでは、ISSU は、MPLS VPN 6vPE および 6PE をサポートします。Cisco IOS ISSU プロセスを使用すると、パケット転送を継続しながら Cisco IOS ソフトウェアをアップグレードまたは変更できます。ほとんどのネットワークでは、予定されているソフトウェア アップグレードがダウンタイムの大きな原因になっています。ISSU を使用すると、パケット転送を続行しながら Cisco IOS ソフトウェアを修正できるため、ネットワークの可用性が向上し、予定されているソフトウェア アップグレードによるダウンタイムを短縮することができます。

MPLS 6vPE および 6PE の ISSU サポートは、プラットフォームの 6vPE および 6PE NFS/SSO 機能に依存して、フォワーディング プレーンで中断を最小限に抑えます。

ISSU の詳細については、『 Cisco IOS In Service Software Upgrade Process 』を参照してください。

MPLS VPN 6VPE および 6PE の NSF/SSO サポート

Cisco IOS Release 12.2(33)SRE およびそれ以降のリリースでは、NFS/SSO は、MPLS VPN 6vPE および 6PE をサポートします。

6VPE および 6PE の NSF/SSO は、次の設定をサポートします。

IPv4 および VPNv4 共存での NSF/SSO

MPLS コア テクノロジーを介したベーシック 6VPE および 6PE

BGP マルチパス設定

6VPE の NSF/SSO は、次の設定をサポートします。

VRF ごとのラベル設定

オプション B および C を含む、InterAutonomous System(Inter-AS; 相互自律システム)トポロジ

IPv6 + ラベルが PE Customer Edge(CE; カスタマー エッジ)リンクで設定されている場合、CSC

SSO 機能は、ステートフル プロトコルおよびアプリケーション情報を保守するため、ユーザ セッション情報は、スイッチオーバー中に保守され、ラインカードは、引き続き、セッションを損失することなくネットワーク トラフィックを転送します。これにより、ネットワーク アベイラビリティが改善されます。SSO は、スタンバイ RP を初期化および設定して、ステート情報を同期化します。これにより、ルーティング プロトコルのコンバージェンスに必要な時間を短縮できます。ネットワークの安定性は、ネットワーク内のルータで障害が発生してルーティング テーブルが消失したときに作成されるルート フラップ数を減らすことで改善できます。

RP スイッチオーバーが発生すると、フォワーディング情報は、MFI およびシスコ エクスプレス フォワーディングによりライン カードとスタンバイ RP の両方で保存されます。VPNv6 プレフィクスおよびローカル ラベル マッピングは、フォワーディング データベースに保存されます。スタンバイ RP が新しいアクティブ RP になると、6PE および 6vPE トラフィックは、中断を最小限に抑えて、引き続き転送されます。

BGP セッションが新しいアクティブ RP で再起動する場合、新しいアクティブ RP には、以前のプレフィクスまたはラベルに関するステート情報はありません。新しいアクティブ RP は、そのピアから VPNv6 プレフィクスを再学習する必要があります。新しいアクティブ RP が VPNv6 プレフィクスを学習する場合、最初に稼動するときと同様に新しいローカル ラベルを取得しようとします。MFI データベースに、プレフィクスのローカル ラベルの保存コピーがある場合、MFI データベースは、そのローカル ラベルを BGP に提供します。これにより、BGP は、同じローカル ラベルを保守するようになります。MFI データベースにプレフィクスの保存ローカル ラベルがない場合、MFI は新しいラベルを割り当てます。

MPLS VPN 設定の BGP グレースフル リスタート サポート

ここでは、基本的な 6VPE セットアップおよび CSC の設定と相互自律システム セットアップの BGP グレースフル リスタート サポートについて説明します。

「基本的な 6VPE セットアップのグレースフル リスタート サポート」

「Carrier Supporting Carrier および相互自律システム セットアップの 6VPE でのグレースフル リスタート」

基本的な 6VPE セットアップのグレースフル リスタート サポート

PE から CE external BGP(eBGP; 外部 BGP)の場合、グレースフル リスタート機能は、IPv6 アドレス ファミリでサポートされます。PE からコアの Route Reflector(RR; ルータ リフレクタ)がある、またはない PE interior BGP(iBGP; 内部 BGP)セッションの場合、BGP グレースフル リスタート機能は、VPNv6 アドレス ファミリをサポートします。

PE ルータがリセットされると、接続される CE ルータは、PE ルータから受信した IPv6 プレフィクスを保持し、これらのプレフィクスを古いものとしてマークします。eBGP セッションが指定再起動時間内に再確立されない場合、またはセッションは再確立されたが、再起動またはフォワーディング ステート ビットが設定されない場合、CE ルータは、使用されなくなった IPv6 ルートを削除します。eBGP セッションが指定再起動時間内に再確立され、フォワーディングおよび再起動ビットの両方が設定された場合、CE ルータは、PE ルータからアップデートを受信したときに IPv6 ルートから使用されなくなったステートを削除します。CE ルータが end-of-RIB マーカーを受信すると、使用されなくなった残りの情報がある場合、これを削除します。

リスタート PE ルータは、iBGP ピアおよび eBGP ピアを含むすべての BGP 対応ピアから end-of-RIB マーカーを待機します。すべての BGP 対応ピアから end-of-RIB マーカーを受信した場合だけ、PE ルータは、最適なパスを計算して、初期アップデートを送信します。

Carrier Supporting Carrier および相互自律システム セットアップの 6VPE でのグレースフル リスタート

ルート保存に関して基本的な 6VPE セットアップに適用されるものと同じグレースフル リスタート機能が、CSC および Inter-AS セットアップに適用されます。IPv6 または VPNv6 ルートおよびラベルは、スイッチオーバー間で保存されます。

CSC 設定では、送信ラベルが CSC-PE および CSC-CE eBGP 接続間で設定されると、いずれかのピアの再起動時に、ラベルが IPv6 BGP ルートとともに保存されます。

Inter-AS オプション B およびオプション C セットアップでは、VPNv6 ルートおよびラベルは、VPNv6 ピアが再起動するときに、Autonomous System Border Router(ASBR; 自律システム境界ルータ)またはルート リフレクタに保存されます。

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE がサポートされていないルータでの動作

ルータが NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能をサポートしていない場合、プレフィクスおよびラベル情報は保存されません。スイッチオーバー後、BGP は、再起動し、すべてのルートを再学習して、ラベルをフォワーディング データベースにインストールする必要があります。これにより、いくつかのネットワーク トラフィックが損失することがあります。

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE の設定方法

MPLS 6VPE および 6PE の NSF/SSO を設定するには、次の作業を実行します。

「基本的な MPLS 6VPE および 6PE の NSF/SSO の設定」(必須)

「MPLS VPN 6VPE および 6PE の NSF/SSO および ISSU サポートの確認」(任意)

ISSU の設定方法については、「 Cisco IOS In Service Software Upgrade Process 」の章を参照してください。

基本的な MPLS 6VPE および 6PE の NSF/SSO の設定

基本的な MPLS 6VPE および 6PE の NSF/SSO を設定するには、次の作業を実行します。


bgp graceful-restart コマンドを使用すると、使用可能なすべてのアドレス ファミリで BGP グレースフル リスタートを設定できます。


前提条件

ルート プロセッサは SSO で設定する必要があります。詳細については、『 Stateful Switchover 』を参照してください。

コアで LDP を使用する場合、MPLS LDP:NSF/SSO サポートおよびグレースフル リスタート機能をイネーブルにする必要があります。詳細については、『 NSF/SSO-MPLS LDP and MPLS LDP Graceful Restart 』を参照してください。

P、PE および CE ルータ間で稼動するルーティング プロトコルでノンストップ フォワーディングをイネーブルにする必要があります。CE ルータおよび PE ルータ間のルーティング プロトコルは、スタティックおよび BGP です。詳細については、『 Cisco Nonstop Forwarding 』を参照してください。

NSF/SSO - MPLS VPN 機能をイネーブルにするには、サポートされている MPLS VPN ネットワーク設定が必要です。「 Configuring MPLS Layer 3 VPNs 」、「 Implementing IPv6 over MPLS」および「 Implementing IPv6 VPN over MPLS 」の設定情報を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip cef distributed

4. ipv6 unicast-routing

5. ipv6 cef distributed

6. redundancy

7. mode sso

8. exit

9. router bgp autonomous-system-number

10. bgp graceful-restart [ restart-time seconds ]

11. bgp graceful-restart stalepath-time seconds

12. bgp graceful-restart

13. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef distributed

 

Router(config)# ip cef distributed

分散シスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 4

ipv6 unicast-routing

 

Router(config)# ipv6 unicast-routing

IPv6 ユニキャスト データグラムの転送をイネーブルにします。

ステップ 5

ipv6 cef distributed

 

Router(config)# ipv6 cef distributed

IPv6 での分散シスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 6

redundancy

 

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 7

mode sso

 

Router(red-config)# mode sso

冗長コンフィギュレーション モードを SSO に設定します。

ステップ 8

exit

 

Router(red-config)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

router bgp autonomous-system-number

 

Router(config)# router bgp 1000

ルータ コンフィギュレーション モードを開始し、BGP ルーティング プロセスを設定します。

autonomous-system-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号です。番号は 1 ~ 65535 の範囲の整数です。

ステップ 10

bgp graceful-restart restart-time seconds

 

Router(config-router)# bgp graceful-restart restart-time 180

すべての BGP ネイバーで BGP グレースフル リスタート タイマー機能をグローバルでイネーブルにします。

restart-time seconds キーワードおよび引数は、再起動イベントが発生してからグレースフル リスタート対応ネイバーが通常動作に戻るまでローカル ルータが待機する最大時間を設定します。 seconds 引数のデフォルト値は 120 です。指定できる値の範囲は、1 ~ 3600 です。

ステップ 11

bgp graceful-restart stalepath-time seconds

 

Router(config-router)# bgp graceful-restart stalepath-time 420

すべての BGP ネイバーで BGP グレースフル リスタートの使用されなくなったパスのタイマー機能をグローバルでイネーブルにします。

stalepath-time seconds キーワードおよび引数は、ローカル ルータがリスタート ピアの使用されなくなったパスを保持する最大時間を設定します。このタイマーが期限切れになると、使用されなくなったすべてのパスが削除されます。 seconds 引数のデフォルト値は 360 です。指定できる値の範囲は、1 ~ 3600 です。

ステップ 12

bgp graceful-restart

 

Router(config-router)# bgp graceful-restart

すべての BGP ネイバーで BGP グレースフル リスタート機能をグローバルでイネーブルにします。

ステップ 13

end

 

Router(config-router)# end

特権 EXEC モードに戻ります。

MPLS VPN 6VPE および 6PE の NSF/SSO および ISSU サポートの確認

6VPE および 6PE の NSF/SSO および ISSU サポートを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip bgp neighbor

3. show ip bgp vpnv6 unicast vrf vrf-name

4. show ip bgp ipv6 unicast

5. show mpls forwarding

6. show ipv6 cef vrf -name

手順の詳細


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。次に例を示します。

Router> enable
Router#
 

ステップ 2 show ip bgp neighbor

このコマンドを使用して、IPv6 アドレス ファミリおよび VPNv6 アドレス ファミリ エントリが保存されることを確認します。次に例を示します。

Router# show ip bgp neighbor
 
BGP neighbor is 10.2.2.2, remote AS 100, internal link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:02:42
Last read 00:00:36, last write 00:00:36, hold time is 180, keepalive
.
.
.
Neighbor capabilities:
.
.
.
Graceful Restart Capability: advertised and received
Remote Restart timer is 120 seconds
Address families advertised by peer:
IPv6 Unicast (was preserved), VPNv6 Unicast (was preserved)
 

ピアが再起動した場合だけ、出力の Graceful Restart Capability セクションに「IPv6 Unicast (was preserved), VPNv6 Unicast (was preserved)」と表示されます。

ステップ 3 show ip bgp vpnv6 unicast vrf vrf-name

このコマンドを使用して、使用されなくなったことを示すマークがスイッチオーバー中に VPNv6 エントリに付けられることを確認します。次に例を示します。

Router# show ip bgp vpnv6 unicast vrf vpn1
 
BGP table version is 10, local router ID is 10.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf vpn1)
S>iA::1/128 ::FFFF:10.2.2.2 0 100 0 200 ?
*> A::5/128 A::4:5:5 0 0 200 ?
S>iA::1:2:0/112 ::FFFF:10.2.2.2 0 100 0 ?
* A::4:5:0/112 A::4:5:5 0 0 200 ?
 

ステップ 4 show ip bgp ipv6 unicast

このコマンドを使用して、使用されなくなったことを示すマークがスイッチオーバー中に VPNv6 エントリに付けられることを確認します。次に例を示します。

Router# show ip bgp ipv6 unicast
 
BGP table version is 9, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*> A::1/128 :: 0 32768 ?
S A::1:2:0/112 A::1:2:2 0 0 100 ?
*> :: 0 32768 ?
S> A::4:5:0/112 A::1:2:2 0 100 ?
Router#
 

ステップ 5 show mpls forwarding

このコマンドを使用して、IPv6 および VPNv6 プレフィクスの保存されるフォワーディング エントリを表示します。この例は、CSC 設定の PE ルータの出力例です。コマンドをアクティブおよびスタンバイ ルータで入力します。アクティブ ルータの出力例とスタンバイ ルータの出力例を比較します。次の例は、アクティブ ルータの出力例です。

Router# show mpls forwarding
 
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
18 Pop Label 10.3.3.3/32 0 Et1/0 10.2.3.3
19 Pop Label 10.3.4.0/24 0 Et1/0 10.2.3.3
20 17 10.4.4.4/32 0 Et1/0 10.2.3.3
21 Pop Label 10.1.2.1/32[V] 0 Et0/0 10.1.2.1
22 Pop Label A::1:2:0/112[V] 0 aggregate/vpn1
23 Pop Label A::1:2:1/128[V] 0 Et0/0 A::1:2:1
24 Pop Label 10.1.2.0/24[V] 0 aggregate/vpn1
25 Pop Label A::1:2:2/128[V] 0 aggregate/vpn1
26 18 A::1/128[V] 0 Et0/0
FE80::A8BB:CCFF:FE03:2101
27 26 10.4.5.5/32[V] 0 Et1/0 10.2.3.3
28 25 10.4.5.0/24[V] 0 Et1/0 10.2.3.3
29 22 A::4:5:5/128[V] 0 Et1/0 10.2.3.3
30 21 A::4:5:0/112[V] 0 Et1/0 10.2.3.3
31 23 A::4:5:4/128[V] 0 Et1/0 10.2.3.3
32 24 A::5/128[V] 0 Et1/0 10.2.3.3
33 Pop Label 10.1.2.2/32[V] 0 aggregate/vpn1
34 Pop Label 10.1.1.1/32[V] 0 Et0/0 10.1.2.1
35 27 10.4.5.4/32[V] 0 Et1/0 10.2.3.3
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
36 28 10.5.5.5/32[V] 0 Et1/0 10.2.3.3
 

次の例は、スタンバイ ルータの出力例です。

Standby-Router# show mpls forwarding
 
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
18 Pop Label 10.3.3.3/32 0 Et1/0 10.2.3.3
19 Pop Label 10.3.4.0/24 0 Et1/0 10.2.3.3
20 17 10.4.4.4/32 0 Et1/0 10.2.3.3
21 Pop Label 10.1.2.1/32[V] 0 Et0/0 10.1.2.1
22 Pop Label A::1:2:0/112[V] 0 aggregate/vpn1
23 Pop Label A::1:2:1/128[V] 0 Et0/0 A::1:2:1
24 Pop Label 10.1.2.0/24[V] 0 aggregate/vpn1
25 Pop Label A::1:2:2/128[V] 0 aggregate/vpn1
26 18 A::1/128[V] 0 Et0/0
FE80::A8BB:CCFF:FE03:2101
27 26 10.4.5.5/32[V] 0 Et1/0 10.2.3.3
28 25 10.4.5.0/24[V] 0 Et1/0 10.2.3.3
29 22 A::4:5:5/128[V] 0 Et1/0 10.2.3.3
30 21 A::4:5:0/112[V] 0 Et1/0 10.2.3.3
31 23 A::4:5:4/128[V] 0 Et1/0 10.2.3.3
32 24 A::5/128[V] 0 Et1/0 10.2.3.3
33 Pop Label 10.1.2.2/32[V] 0 aggregate/vpn1
34 Pop Label 10.1.1.1/32[V] 0 Et0/0 10.1.2.1
35 27 10.4.5.4/32[V] 0 Et1/0 10.2.3.3
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
36 28 10.5.5.5/32[V] 0 Et1/0 10.2.3.3
 

ステップ 6 show ipv6 cef vrf vrf-name

このコマンドを使用して、IPv6 および VPNv6 プレフィクスの保存されるフォワーディング エントリを表示します。この例は、CSC 設定の PE ルータの出力例です。コマンドをアクティブおよびスタンバイ ルータで入力します。アクティブ ルータの出力例とスタンバイ ルータの出力例を比較します。次の例は、アクティブ ルータの出力例です。

Router# show ipv6 cef vrf vrf1
 
::/0
no route
::/127
discard
A::1/128
nexthop FE80::A8BB:CCFF:FE03:2101 Ethernet0/0 label 18
A::5/128
nexthop 10.2.3.3 Ethernet1/0 label 17 24
A::1:2:0/112
attached to Ethernet0/0
A::1:2:1/128
attached to Ethernet0/0
A::1:2:2/128
receive for Ethernet0/0
A::4:5:0/112
nexthop 10.2.3.3 Ethernet1/0 label 17 21
A::4:5:4/128
nexthop 10.2.3.3 Ethernet1/0 label 17 23
A::4:5:5/128
nexthop 10.2.3.3 Ethernet1/0 label 17 22
FE80::/10
 

次の例は、スタンバイ ルータの出力例です。

Standby-Router# show ipv6 cef vrf vrf1
 
::/0
no route
::/127
discard
A::1/128
nexthop FE80::A8BB:CCFF:FE03:2101 Ethernet0/0 label 18
A::5/128
nexthop 10.2.3.3 Ethernet1/0 label 17 24
A::1:2:0/112
attached to Ethernet0/0
A::1:2:1/128
attached to Ethernet0/0
A::1:2:2/128
receive for Ethernet0/0
A::4:5:0/112
nexthop 10.2.3.3 Ethernet1/0 label 17 21
A::4:5:4/128
nexthop 10.2.3.3 Ethernet1/0 label 17 23
A::4:5:5/128
nexthop 10.2.3.3 Ethernet1/0 label 17 22
FE80::/10
 


 

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE の設定例

ここでは、PE1 ルータの次の設定例について説明します。

「基本的な 6VPE セットアップの NSF/SSO の設定:例」

「基本的な 6PE セットアップの NSF/SSO の設定:例」

基本的な 6VPE セットアップの NSF/SSO の設定:例

ここでは、基本的な 6VPE セットアップの NSF/SSO の設定を示します。図 1 に、基本的な 6VPE ネットワーク設定の例を示します。

図 1 基本的な 6VPE ネットワーク設定の例

 

基本的な 6VPE セットアップでの PE1 設定

次に、VPNv6 および VPNv6 アドレス ファミリを含む基本的な 6VPE セットアップでの PE1 ルータ(図 1 を参照)の設定例を示します。

vrf definition vpn1
rd 1:1
route-target export 1:1
route-target import 1:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
ip cef distributed
!
ipv6 unicast-routing
ipv6 cef distributed
mpls ldp graceful-restart ! <==+ Command to configure LDP Graceful Restart
mpls label protocol ldp
redundancy
mode sso
interface Loopback0
ip address 10.2.2.2 255.255.255.255
ipv6 address A::2/128
!
interface Ethernet0/0
vrf forwarding vpn1
ip address 10.1.2.2 255.255.255.0
ipv6 address A::1:2:2/112
!interface Ethernet1/0
ip address 10.2.3.2 255.255.255.0
mpls label protocol ldp
mpls ip
!router ospf 10
log-adjacency-changes
nsf
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
bgp graceful-restart restart-time 120 ! <=== This command,
bgp graceful-restart stalepath-time 360 ! <=== this command, and
bgp graceful-restart ! <=== this command configures NFS/SSO for a 6VPE router.
neighbor 10.4.4.4 remote-as 100
neighbor 10.4.4.4 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.4.4.4 activate
neighbor 10.4.4.4 send-community extended
exit-address-family
!
address-family vpnv6
neighbor 10.4.4.4 activate
neighbor 10.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
no synchronization
redistribute connected
redistribute static
neighbor 10.1.2.1 remote-as 200
neighbor 10.1.2.1 update-source Ethernet0/0
neighbor 10.1.2.1 activate
exit-address-family
!
address-family ipv6 vrf vpn1
redistribute connected
redistribute static
no synchronization
neighbor A::1:2:1 remote-as 200
neighbor A::1:2:1 update-source Ethernet0/0
neighbor A::1:2:1 activate
exit-address-family

基本的な 6PE セットアップの NSF/SSO の設定:例

ここでは、基本的な 6PE セットアップの NSF/SSO の設定を示します。図 2 に、基本的な 6PE ネットワーク設定の例を示します。

図 2 基本的な 6PE ネットワーク設定の例

 

基本的な 6PE セットアップでの PE1 設定

次に、基本的な 6PE セットアップの PE1 ルータ(図 2 を参照)の設定例を示します。

ip cef distributed
!
ipv6 unicast-routing
ipv6 cef distributed
mpls ldp graceful-restart ! <=== Command to configure LDP Graceful Restart
mpls label protocol ldp
redundancy
mode sso
 
interface Loopback0
ip address 10.11.11.1 255.255.255.255
ipv6 address BEEF:11::1/64
interface Ethernet0/0
ip address 10.50.1.2 255.255.255.0
ipv6 address 4000::72B/64
ipv6 address 8008::72B/64
!
interface Ethernet1/0
ip address 10.40.1.2 255.255.255.0
mpls ip
!
router ospf
nsf
network 0.0.0.0 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
bgp graceful-restart restart-time 120 ! <=== This command,
bgp graceful-restart stalepath-time 360 ! <=== this command, and
bgp graceful-restart ! <=== this command configures NFS/SSO for a 6PE router.
neighbor 8008::72A remote-as 200
neighbor 10.10.10.1 remote-as 100
neighbor 10.10.10.1 update-source Loopback0
!
address-family ipv4
no synchronization
redistribute connected
no neighbor 8008::72A activate
neighbor 10.10.10.1 activate
no auto-summary
exit-address-family
!
address-family ipv6
redistribute connected
no synchronization
neighbor 8008::72A activate
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-label
exit-address-family

その他の参考資料

ここでは、NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE機能に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS VPN の NFS/SSO に関する情報

NSF/SSO - MPLS VPN

Cisco ノンストップ フォワーディングに関する情報および設定作業

『Cisco Nonstop Forwarding』

MPLS VPN に関する情報および設定作業

『Configuring MPLS Layer 3 VPNs』

6VPE over MPLS に関する情報および設定作業

『Implementing IPv6 VPN over MPLS』

6PE over MPLS に関する情報および設定作業

『Implementing IPv6 over MPLS』

ISSU に関する情報および設定作業

『Cisco IOS In Service Software Upgrade Process』

SSO に関する情報および設定作業

Stateful Switchover

MPLS LDP NSF/SSO およびグレースフル リスタートに関する情報および設定作業

『NSF/SSO-MPLS LDP and MPLS LDP Graceful Restart』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

NSF/SSO および ISSU - MPLS VPN 6VPE および 6PEの機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE の機能情報

機能名
リリース
機能情報

ISSU - MPLS VPN 6VPE および 6PE ISSU サポート

12.2(33)SRE

12.2(33)XNE

この機能は、Cisco IOS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)IPv6 Provider Edge(6VPE; VPN IPv6 プロバイダー エッジ)ルータ over Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)および Cisco IOS IPv6 Provider Edge(6PE; IPv6 プロバイダー エッジ)ルータ over MPLS に In Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)サポートを提供します。

12.2(33)SRE では、この機能が Cisco 7600 シリーズ ルータで追加されました。

この機能に関する詳細については、次の各項を参照してください。

「NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能をサポートするエレメント」

「MPLS VPN 6vPE および 6PE の ISSU サポート」

この機能で導入される新しいコマンドまたは変更されたコマンドはありません。

SSO - MPLS VPN 6VPE および 6PE SSO サポート

12.2(33)SRE

12.2(33)XNE

この機能は、Cisco IOS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)IPv6 Provider Edge(6VPE; VPN IPv6 プロバイダー エッジ)ルータ over Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)および Cisco IOS IPv6 Provider Edge(6PE; IPv6 プロバイダー エッジ)ルータ over MPLS に Stateful Switchover(SSO; ステートフル スイッチオーバー)サポートを提供します。

12.2(33)SRE では、この機能が Cisco 7600 シリーズ ルータで追加されました。

この機能に関する詳細については、次の各項を参照してください。

「NSF/SSO および ISSU - MPLS VPN 6VPE および 6PE 機能をサポートするエレメント」

「MPLS VPN 6vPE および 6PE での BGP グレースフル リスタートの機能」

「再起動中の BGP グレースフル リスタートによるプレフィクス情報の保存方法」

「MPLS VPN 6VPE および 6PE の NSF/SSO サポート」

「MPLS VPN 設定の BGP グレースフル リスタート サポート」

この機能で導入される新しいコマンドまたは変更されたコマンドはありません。

用語集

6PE ルータ :IPv6 Provider Edge(PE; プロバイダー エッジ)ルータ。Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ベース メカニズムを実行して、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)対応 IPv4 クラウドを介して IPv6 アイランドを相互接続するルータ。

6VPE ルータ :Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)IPv6 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)サービスを IPv4 ベース MPLS コアに提供するプロバイダー エッジ ルータ。これは、6PE の概念をコア フェーシング インターフェイスで実装する IPv6 VPN Provider Edge(PE; プロバイダー エッジ)、デュアル スタック ルータです。

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。グローバル インターネット向けドメイン間ルーティング プロトコル。exterior Border Gateway Protocol(eBGP; 外部ボーダー ゲートウェイ プロトコル)は、異なる自律システム間での通信を行います。interior Border Gateway Protocol(iBGP; 内部ボーダー ゲートウェイ プロトコル)は、単一の自律システム内のルータ間での通信を行います。

CE ルータ :Customer Edge(カスタマー エッジ)ルータ。カスタマー ネットワークの一部であり、Provider Edge(PE; プロバイダー エッジ)ルータへのインターフェイスとなるルータ。

シスコ エクスプレス フォワーディング :高度なレイヤ 3 IP スイッチング テクノロジー。あらゆる種類のネットワークのネットワーク パフォーマンスおよびスケーラビリティを最適化します。

eBGP :external Border Gateway Protocol(外部ボーダー ゲートウェイ プロトコル)。

グレースフル リスタート :ノード障害の発生後に RP の再起動を補助するプロセス。

iBGP :interior Border Gateway Protocol(内部ボーダー ゲートウェイ プロトコル)。

ISSU :In Service Software Upgrade(インサービス ソフトウェア アップグレード)。サービスを中断せずにソフトウェアをアップグレードすること。

LDP :Label Distribution Protocol(ラベル配布プロトコル)。パケットの転送に使用するラベル(アドレス)をネゴシエーションする Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)対応ルータ間の標準プロトコル。

MPLS :Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)。ラベルを使用して IP トラフィックを転送するスイッチング方式です。このラベルによって、ネットワーク内のルータおよびスイッチが、事前に確立された IP ルーティング情報に基づくパケットの転送先を指示されます。

NSF :Nonstop Forwarding(ノンストップ フォワーディング)。機能停止状態からの回復処理を行っているルータに対してトラフィックの転送を継続するルータの機能。また、障害からの回復中であるルータは、自身に送信されたトラフィックをピアによって正しく転送することができます。

PE ルータ :Provider Edge(プロバイダー エッジ)ルータ。PE ルータは、サービス プロバイダー ネットワークへのエントリ ポイントです。PE ルータは通常、ネットワークのエッジに展開され、サービス プロバイダーによって管理されます。PE ルータは、CE ネットワーキングに対する PE 内での EIGRP と BGP 間の再配布ポイントです。

RIB :Routing Information Base(ルーティング情報ベース)。ルーティング テーブルとも呼ばれます。

SSO :Stateful Switchover(ステートフル スイッチオーバー)。SSO とは、アプリケーションや機能が、定義されているステートをアクティブ RP とスタンバイ RP との間で維持できる Cisco IOS ソフトウェアの実装を指しています。スイッチオーバーが発生しても、転送処理とセッションが維持されます。NSF と SSO を組み合わせると、RP に障害が発生してもネットワークに影響がおよぶことがありません。

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。ネットワーク間のトラフィックを暗号化することにより、パブリック TCP/IP ネットワーク経由でも IP トラフィックをセキュアに転送できます。VPN では、トンネリングが使用され、すべての情報が IP レベルで暗号化されます。

VRF :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VPN ルーティングおよび転送)インスタンス。VRF は、IP ルーティング テーブル、取得されたルーティング テーブル、フォワーディング テーブルを使用するインターフェイスのセットで構成されます。また、VRF には、Provider Edge(PE; プロバイダー エッジ)ルータに接続されるカスタマー VPN サイトを定義するルールおよびルーティング情報のセットが含まれます。

Copyright © 2009-2011, シスコシステムズ合同会社.
All rights reserved.